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Welcome to Easy Grade Pro from Orbis Software. With Easy Grade Pro you can

create an electronic gradebook which, like a paper gradebook, can be used to store

student information for all of your classes and subjects. Better than a paper

gradebook, an Easy Grade Pro gradebook provides an abundance of tools to save

you time, provides you with a wealth of information, and allows you to generate

professional internet and paper reports.

What’s New in Version 3.6
•  New ways to produce student reports for password-protected internet viewing.

•  New HTML reports for attaching to your email to parents and students.

•  Compatibility with EGP Clipboard, the Palm OS companion to Easy Grade Pro.

•  Color coding of scores and attendance marks.

•  Score categories can have unique grade scales for greater grading flexibility.

•  Curving of the overall grade using percentage offsets.

•  New tool bar tools: Export, Import, Internet, Palm Setup and Show Colors.

•  Easy combining of multiple gradebooks for printing of multi-teacher reports.

•  Importing can now be used to update existing student rosters.

•  Automatic selection of student comments based on user-defined selection rules.

•  New ways to combine term grades.

System Requirements
Easy Grade Pro 3.6 requires Windows 95+ or Mac OS 7.0+, a color monitor with

256+ colors with at least 640x480 resolution, a CD-ROM drive (to install the

software), a hard disk drive with 4 MB of free space, and a minimum of 16 MB of

RAM (or 8 MB of RAM for Macintosh 680x0-based computers).

Getting Started1
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Installing Easy Grade Pro
For Macintosh:
1  Insert the installation CD. The icon of the CD will appear on the Desktop.

2  Double-click the icon of the CD. In the window that appears, double-click the

Easy Grade Pro 3.6 Installer icon and follow the steps. Eject and store the disk.

3  Start Easy Grade Pro by double-clicking on the Easy Grade Pro™ 3.6 icon in the

Easy Grade Pro folder created during installation.

For Windows:
1  Insert the installation CD and follow the instructions that appear automatically.

If nothing appears, choose Run from the Start menu, type D:\setup.exe and press

enter. Use the drive letter for your CD-ROM drive in place of D. Eject and store

the disk.

2  Start Easy Grade Pro by clicking on Start in the corner of the screen, choosing

Programs, and then choosing Easy Grade Pro.

FAQ: How do I install Easy Grade Pro to a computer without a CD-ROM drive?
The Easy Grade Pro CD has a folder titled Floppy Disk Folder with instructions and files

for making a floppy disk installer. To find this folder, insert the CD. On a Macintosh

computer, the folder is easy to find. On a Windows computer, when you insert the CD,

the installer software may start automatically. Cancel the installation. Then right-click

on the icon of the CD and choose Explore. You’ll see the folder with instructions and files

for making your own floppy disk installer for Easy Grade Pro.

FAQ: Can Easy Grade Pro be networked? (site license versions only)
Easy Grade Pro can be run from a computer’s hard drive or from a networked server.

Because servers are generally slower and less reliable than the hard drives attached

directly to computers, we recommend that you install Easy Grade Pro directly to each

computer.

Easy Grade Pro for Macintosh can be installed to a server using the standard installation

instructions. Easy Grade Pro for Windows can also be installed to a server but you will

need to copy certain registry entries (at HKEY_LOCAL_MACHINE, SOFTWARE

\\Microsoft\\Windows \\CurrentVersion\\Uninstall\\Easy Grade Pro) to each worksta-

tion before the program can be used.
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Registering Easy Grade Pro
The first time you use Easy Grade Pro, a registration window will automatically

appear. Carefully type the registration number found on the License/Installation

card. Be sure to include the dashes. Click OK. Then type the registration name

(school name for a site license or teacher name for a single-user license) and click

OK. Be careful when entering the registration name because it will appear near

the top of all reports.

How to Use this Manual
If you are a busy educator with little time to spare, be sure to take advantage of

this user manual. Its descriptions, step-by-step instructions and illustrations will

save you lots of time and help ensure that you set up your gradebook properly in

the beginning.

Some parts of this manual should be read by all Easy Grade Pro users. Other parts

can be skipped except by those with certain needs. The rest of this chapter out-

lines the manual with suggestions on use.

Chapters 1-2: Getting Started
If you are new to Easy Grade Pro, be sure to thoroughly investigate the first two

chapters. The last section of this chapter explains how to quickly get answers to

questions while you are using the program. Chapter 2, Tutorial: Four Short

Lessons, should not be missed; by spending time going through its short lessons,

you’ll quickly discover how you can use Easy Grade Pro with your classes and

students.

Chapters 3-5: Starting Your Own Gradebook
When you are ready to start your own gradebook, chapters three through six are

essential. Chapter 3, Gradebooks and Classes, explains how to create gradebook

and add classes. Chapter 4, Setting Options, describes the variety of options that

will allow you to get Easy Grade Pro to match your grading style. In Chapter 5,

Students and Assignments, you'll learn how to add and work with these key

elements.

Chapters 6-7: The Charts
Before you start entering scores, be sure to look at Chapter 6, Using the Score

Chart because it describes a variety of ways to quickly enter scores. It explains
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how to add notes to scores, how to adjust scores by dropping, using extra credit,

etc., and how to customize the display of the score chart to meet your needs. If

you will be working with attendance, seats or student record data (i.e. phone

numbers), check out Chapter 7, Using the Other Charts for explanations and

suggestions about the three other charts available to you.

Chapter 8: The Most Important Chapter
If you only read one chapter, it should be Chapter 8, Making and Managing

Backups. Computers fail; security can be compromised. It is essential that you

follow a fail-safe plan for protecting your important student data.

Chapters 9-16: The Other Chapters
There are eight additional chapters that you may find very helpful. If you plan to

use Easy Grade Pro at more than one location, take a look at Chapter 9, Working

at Home and School. When a term is coming to an end and a new term is begin-

ning, be sure to read Chapter 10, Working with Terms. To learn how to utilize

powerful summaries, check calculations, and enter notes and comments, examine

Chapter 11, Using Summaries.

Most likely you’ll benefit from Chapter 12, Printing Reports. It explains how to

utilize Easy Grade Pro’s nineteen reports. If you’d like to publish your student

reports to the internet or email reports to parents, be sure to read Chapter 13,

Internet Reports and Chapter 14, Email Reports.

Chapter 15, Porting, includes technical information on transferring data between

your gradebook and other files.

If you have a question about using Easy Grade Pro, be sure to take a look at

Chapter 16, Technical Support. It includes a list of some of the most frequently

asked questions of our technical support staff and where to find the answers. It

also includes information on contacting Orbis Software in case your question is

not answered somewhere in the manual.

FAQ: What is an FAQ?
Throughout this manual, you’ll find special FAQ sections like this one. These highlight

the most frequently asked questions that we have received from Easy Grade Pro users

over the years. Read these sections! You’ll likely find answers to at least some of your

questions.
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Getting Help within Easy Grade Pro
In addition to this manual, help is available within the Easy Grade Pro software in

the form of balloon help, status bar help and a context-sensitive help window.

Balloon Help (Macintosh only)
Balloons are short descriptions that appear and disappear as the mouse arrow is

moved around in a window. Easy Grade Pro has balloons for most objects.

To turn balloon help on, click the Balloon Help tool  found in nearly every

window. Then point to the object of interest to view the description. To turn

balloon help off, click the tool again.

There are descriptive balloons for objects in nearly every window. Note the Balloon Help tool on the
right side of the tool bar.

FAQ: How do I turn off the balloons?
Although the descriptive balloons can be very helpful, they can quickly get in the way.

Once you’ve gotten the information you needed, promptly click the Balloon Help tool

 to turn off the balloons.

Status Bar Help (Windows only)
The status bar is a region at the bottom of the main gradebook window. It

provides information about the item currently pointed to by the mouse arrow. To

turn the status bar on, choose Show Status Bar from the Help menu. When an

object is pointed to with the mouse arrow, text will appear (like the text shown

below). To turn this help off, select the menu item again.

The status bar can display information about most objects in the main window.
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Help Window
To get detailed explanations and step-by-step instructions, use the Easy Grade Pro

Help window. To open this window, click the Help tool  found in most

windows. Easy Grade Pro will display information based on the window in which

the tool is clicked.

The Help window has two views: Index and Contents. The Contents view displays

information on a single topic while the Index view contains a list of topics.

        

The Contents (left) and Index (right) views.

•  To switch between the Contents and Index views, click the View button in the

lower-left corner.

•  To view adjacent topics, click the << and >> buttons.

•  To search for a specific topic, use the Find and Again buttons. Searching works

in both views.

•  Windows: To resize the Help window, press and drag the lower-right corner.



Tutorial:
Four Short Lessons2

The lessons in this chapter will introduce you to the structure, tools and options

found in Easy Grade Pro. The time spent here will almost certainly save you as

much and more time later. The word to remember is explore; these lessons are

meant to be springboards for your own exploration of Easy Grade Pro.

Lesson 1: Moving around in a Gradebook
1  Open the gradebook named Demo Gradebook. To do this on a Macintosh

computer, double-click on the icon titled Demo Gradebook found inside the Easy

Grade Pro Folder. On a Windows computer, click on Start in the corner of your

screen, point to Programs, point to Easy Grade Pro and click Demo Gradebook.
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You should be viewing the gradebook of a fictitious sixth grade teacher, Ms.

Demo, who teaches reading, math, language arts and science. She also teaches

science to the students in the other sixth grade class. The other sixth grade teacher

teaches Social Studies to both groups. Ms. Demo is currently in the second

quarter of the school year and you are viewing the score chart for the class

Quarter 2: Reading. Notice the name of this class on the tool bar.

The Class menu on the tool bar indicates that the class being viewed is Quarter 2: Reading. This
menu can be used to switch to any class in any term of a gradebook.

2  Press on the Class menu on the tool bar to switch to Quarter 2: Math. Notice

that Ms. Demo's math class has most of the same students as her reading class but

the assignments are different.

3  Use the Class menu to move to Quarter 2:Science-1 and then to Quarter

2:Science-2. Recall that Ms. Demo teaches science to both sixth grade classes. The

science classes have the same assignments but different students. To save time, Ms.

Demo enters assignments into just one science class and then copies them to the

other class. You’ll have a chance to do this in Lesson 2.

4  Move to the Social Studies class to view a class imported from the other sixth

grade teacher's gradebook. Notice that the students are the same but other items

are different because this class was created by the other sixth grade teacher.

Although Ms. Demo does not teach this class, she wants to keep track of her

students’ performance in all classes and wants to include their Social Studies

grades in the progress reports sent to parents and posted on her website. So,

periodically, she imports the entire Social Studies class from her associate's Easy

Grade Pro gradebook using a floppy disk or her school’s network.

5  Switch back to Quarter 2: Reading. Now, click on the Attend. tab above the

Class menu to switch to the attendance chart. Make sure that you are viewing

Quarter 2: Reading. Notice that the new chart displays dates and attendance

marks. Ms. Demo takes attendance in just one class, Reading, because it is the first

class of her day. She could, if she wanted to, take attendance in any or all classes.
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6  A class actually has five different charts: score, attendance, seating, student and

assignment. Although Ms. Demo spends most of her time using the Score chart,

she does use the others on occasion. Use the tabs above the Class menu to switch

to each of the five charts. In the student and assignment charts, be sure to use the

scroll bars so that you can view all the different columns.

7  Each class in a gradebook can have its own students, assignments and configu-

ration of the charts. Before moving on to Lesson 2, take a few moments to use the

Class menu, the Prior Class  and Next Class  tools, and chart tabs to

examine the rest of Ms. Demo’s gradebook. Remember, explore!

Lesson 2: Adding Assignments and Scores
The most time consuming task in the grading process is that of adding assign-

ments and scores. Easy Grade Pro provides many tools to make this task easy and

fast. In this lesson, you'll be introduced to some of these tools. To begin this

lesson, the Demo Gradebook must be open and the score chart must be visible.

1  Using the Class menu, move to Quarter 2: Science-1. You'll know that you are in

this class when its title is visible on the tool bar. Be sure you are viewing the score

chart. If necessary, click the Score tab or choose Score from the Chart menu.

2  To prepare for the entering of scores, click the small triangle below-left of the

first tab so that the triangle points downwards. The triangle (circled below) shows

and hides a row of grades and special scores. (Note: if the tool bar is visible

instead of the tool palette, this triangle will not be available. In this case, choose

Show Tool Bar from the Edit menu.)

Click on the triangle (circled above) to show the row of grades and special scores below the tools.

3  Click the Add Assignment button visible after the last assignment or choose Add

Assignment from the Tool menu. After clicking, the Records window will open to

an empty assignment record.
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The Records window is used to add assignments, students and classes to a gradebook.

4  In the Name field, type Star Lab.

5  Press tab to move to the Max. Score field. Type 25.

6  Press tab to move to the Points field. Type 100. For a detailed explanation of

maximum score and points, see FAQ: What are maximum score and points? How

should I set them? on page 57.

7  Set the due date of the assignment by clicking on the calendar. The date is used

by Easy Grade Pro when sorting, using filters to show or hide certain assignments

and when producing graphs.

8  Press on the Category menu and select Classwork. The category is used when

sorting assignments, in filters, graphs, summaries, reports and in grading if you

have category weighting turned on. You can view, edit and create score categories

in the Class Options window but you’ll see this later.

9  Click the Done button. You should be viewing the score chart again. The first

score cell under the new assignment's title should have the flashing cursor in it. If

not, click on the first empty box under the Star Lab assignment.

10  Now it's time to enter scores. Just to make things interesting, you'll enter scores

in several different ways. Follow the directions below to enter the first four scores.

If you make a mistake, simply click on the score cell with the error and try again.

Student #1: Type the number 25 and press enter.

Student #2: Click on the B grade on the tool bar. Do not press the enter key
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because the next cell is automatically selected after clicking. You can set up the

grades that appear on the tool bar. In fact, you can have a different set of grades

for each student and for each category.

Student #3: Press the letter m. This enters a score of mi for missing. You can

customize up to thirty special scores and give them any meaning you wish. Notice

that the score turns red. Ms. Demo has set things up so that all failing scores are

displayed in red.

Student #4: Type the number 25. Do not press enter. Now click the Fill Down tool

 on the tool bar. Notice that 25 is repeated all the way down.

11  Click the Undo tool  on the tool bar or choose Undo from the Edit menu

to prepare for the next step. Notice that the score of 25 is removed from the

students. Undo is nearly always available to reverse the last action.

12  Select the seven blank score cells by pressing on the first and dragging to the

last. Release the mouse. The seven score cells should be highlighted as shown

below.

A

B

Press on A and drag down to B to highlight the score cells.

13  Click on the A+ grade on the tool bar. A score of 25 is entered for each student.

Try clicking on other grades and special scores on the tool bar.

Recall that Ms. Demo teaches two science classes and both have the same assign-

ments. It is easy to copy assignments from one class to another. In the next few

steps, you'll do just that.

14  Using the Class menu on the tool bar, move to Quarter 2: Science-2.
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15  Click on the Copy Class Data tool  or choose Copy->Assignments... from

the Tool menu. The Copy Class Data window will open. The Copy window can be

used to copy assignments, students, options and other class data. It can copy

several items together and copy them to several classes at the same time.

16  First click on the Assign. tab at the top. In the top-left list, click on Quarter 2:

Science-1. In the bottom-left list, click on Quarter 2: Science-2. In the right-hand

list, click on Star Lab. Finally, click Copy. The assignment will be copied from

Science-1 to Science-2. After the window closes, the first score cell for the new

assignment will be selected, ready for you to enter scores.

The rest of this lesson will focus on entering scores for the copied assignment.

You'll use a very powerful tool that allows you to easily enter scores from a mixed

stack of papers. Since you don't actually have the student papers, you'll simply

pretend.

17  Click on the Find tool  on the tool bar or choose Find from the Tool

menu. The Find window will open.
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18  Select Use Continuous Search Mode. Then click Exit -- you must close the Find

window. The continuous search mode causes Easy Grade Pro to return to the Find

window after every score is entered. This means that whenever the enter key is

pressed, or whenever a grade is clicked on the tool bar, the Find window will

reopen automatically.

19  In the score chart, select the first score cell for the Star Lab assignment. This

score cell is for Kelly Armstrong.

20  You will be pretending to enter scores directly from student papers. Follow

these steps:

Paper #1: In Kelly Armstrong's score cell, type 25 and press enter. The Find

window will reopen.

Paper #2: The next paper belongs to Josef Talbo. In the Find window, type the

letter T and notice that Easy Grade Pro completes it with ‘Talbo, Josef ’. Press enter.

Now click Sat on the tool bar. The Find window reopens.

Paper #3: Tad Nguyen earned a 20. Type an N in the Find window and press enter.

Type a 20 and press enter again.

Paper #4: Justin Bronin earned an 18. Type the letter B and notice that Easy Grade

Pro completes it with ‘Benjamin, Atunde’. Type the letter R and notice that Easy

Grade Pro completes it with ‘Bronin, Justin’. Press enter. Type his score.

Go ahead and finish the remaining scores on your own -- just make them up!

When you are done, be sure to deselect the Use Continuous Search Mode box so

the Find window will stop reappearing.

Lesson 3: Options and Tools
This lesson, which has been divided into five short parts, will guide you in an

exploration of some of the options and tools within a gradebook. To begin this

lesson, the Demo Gradebook must be open.

Part A: Gradebook Options and Class Options
Easy Grade Pro offers an abundance of options to accommodate your personal

style. Some options, such as font and font size, affect the entire gradebook and are

called Gradebook Options. But many options apply only to a single class; these
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are called Class Options and include items like grade scales, categories, weighting,

calendars, colors and more. In this section, you’ll view both types of options.

Don’t forget to utilize the Help tool(s) to gain additional information about the

options.

1  Select Gradebook Options from the Edit menu and explore all tabs. Click Done.

2  Select Class Options from the Edit menu and explore all tabs. Click Done.

Part B: Adding a New Data Column
You have many ways to configure the charts so that they best suit your needs. In

the score chart, for example, special columns can be added which show class rank,

points, or nearly any other data about your students. The next few steps will show

you how to do add special columns.

1  Switch to the score chart view of Quarter 2: Reading. Above the column of

student names, press on the 11 of 11 Students title (shown on the next page).
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Press here

2  From the menu that appears, choose Add NEW Column (first item). A new

column will appear to the immediate right. It will also be titled 11 of 11 Students.

3  Press on the new column’s title and choose Main Grades->Class Rank. The

title and content of the column will change to display the rank for each student.

4  To resize the new column, move the mouse so that the arrow is over the line to

the right of the Class Rank title. Press and drag the line to the left or right.

Press here

5  To relocate the new column, press on any cell below the title. The cursor will

change to a hand. Drag the column left or right to the new position and let go.

6  Press on any student’s name. The cursor will change to a hand but you won’t

be able to drag the column left or right. However, you can drag the student’s row

up or down to a new row position. Try moving students to new rows. This also

works on assignments: press on an assignment’s title and drag left or right to

move the assignment to a new location.

Add up to eight data columns in both the score and attendance charts. Resize

and relocate them. Go ahead and explore.

Part C: Using Filters
Easy Grade Pro allows you to configure the charts so that they display just the

students, assignments, scores or attendance dates that you would like to see. In

this section, you will explore ways to do this.
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1  Switch to the score chart and explore the four filter menus (circled below).

2  Switch to the other charts (except seating); find and explore the filter menus.

 Press on the four menus (circled) to filter students and assignments and to set the display
of scores.

Part D: Setting the Display of Seats and Furniture
The seating chart allows you to place seats and furniture nearly anywhere. It also

allows you to change the shape, size, rotation and color of these items. Use the

Chart menu or tabs to switch to the seating chart. Then try these:

•  Move a single item by dragging it.

•  Swap two seats by dragging one to another. (The upper-left corners must be

aligned.)

•  Select more than one item by clicking while holding down the shift key or by

dragging a rectangle around the seats.

•  Drag a group of selected items.

•  Double-click on a seat to open the Seat Options window. Try different settings.

•  Double-click on a piece of furniture to open the Furniture Options window. Try

different settings.
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Part E: Other Tools and Windows
Many special windows can be opened by double-clicking, right-clicking and

control-clicking in different regions of the charts. Try these suggestions for

opening special windows in the score chart:

•  Double-click on a row number or column number to open the Summaries

window for that item.

•  Double-click on any student or assignment name to open the Records window.

•  Double-click on any score cell to open the Score Note window.

•  Single-click in the small box to the left of the first score for any student to open

the Lock/Curve Grade window.

•  Right-click (Windows) or control-click (Macintosh) on student names and

assignment names.

Lesson 4: Working with Reports
In this lesson, you will be taken through the steps of selecting a report, its range

and options. Then, instead of printing the report, you will preview the report on

screen. The Demo Gradebook should be open. You can be in any class.

1  Click the Print tool  on the tool bar or choose Print from the File menu.

The Print Reports window will open. Notice that there are three tabs with differ-

ent reports listed under each for a total of nineteen reports.

2  Click the Student tab, select the Single-class Progress item and click Next. After

clicking, the Report Options window will open. The Report Options window

allows you to set options for the report and then preview or print the report.

There is a different Report Options window for each report.
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3  The upper half of the Report Options window allows you to select the students

to receive reports. The lower half allows you to select the items to be included in

each report. Click the set buttons to open windows where additional options can

be set. Click the Page/Print Setup button to set options based on your printer. To

get a description of an option, click on the Help tool . Set the range and

options as desired.

4  Click the Preview button to open the Print Preview window. This window has

two views: fit-in-screen and full-size. The fit-in-screen view shows the entire page.

The cursor is a magnifying glass. By clicking once on any part of the page, the

view automatically switches to the full-size view. In the full-size view the cursor
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becomes a hand. By pressing the mouse button, the page can be grabbed and

dragged about. Double-clicking causes the view to change to the original view.

The Zoom button can also be used to toggle between the two views.

With the Windows version of Easy Grade Pro, you can right-click anyplace on a

page to choose from different zoom levels.

The Print Preview window.

5  Click the Done button to close the Print Preview window.

6  Change any options in the Report Options window, then preview again to see

how the report has changed.

7  Click the Cancel button in the Report Options window.

8  All the reports have options which allow much customization. Several reports

(charts, graphs) can be printed in color. Repeat the steps in this lesson for some of
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the other reports. Remember, explore!

This is the end of Lesson 4 and the end of this tutorial. You can quit Easy Grade

Pro by choosing Quit/Exit from the File menu. By the way, the changes that you

made during these lessons have been automatically saved. With Easy Grade Pro,

changes are always automatically saved.
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Classes3

This chapter is for you if you if you are ready to begin using Easy Grade Pro to

manage your student data. It will take you through the steps of creating a

gradebook, adding classes and a few other basic gradebook tasks.

Starting a New Gradebook
You’re likely to need only a single Easy Grade Pro gradebook at a time. Since a

gradebook can hold up to 250 classes in up to ten terms you might want to use a

single gradebook for an entire school year because it saves time and minimizes the

duplication of efforts. However, a gradebook can become large; if you intend to

use a floppy disk or email to transfer your gradebook between computers, you

may want to create a new gradebook for each major term. Don’t do this, however,

if the student grades in one term must be combined with the grades in another.

To start a new gradebook:
1  Start Easy Grade Pro. On a Macintosh, do this by double-clicking on the Easy

Grade Pro 3.6 icon in the Easy Grade Pro folder. On a Windows computer, do this

by clicking on Start, choosing Programs, and then choosing Easy Grade Pro. If a

gradebook opens, choose Close from the File menu. A small window will appear

(shown below).
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FAQ: Why does a gradebook open when I choose Easy Grade Pro from the Start menu?
With the Windows version of Easy Grade Pro, the last opened gradebook is automatically

reopened whenever you choose Easy Grade Pro from the Start menu. This feature can

save you time but, if you need to start a new gradebook or switch to a different grade-

book, be sure to choose Close from the File menu to close the current gradebook.

2  Click the Create a New Gradebook button. The standard Save window will open

where you can name and choose a location for your new gradebook.

3  In the Save window, type the name of your new gradebook. What name should

you give it? We recommend that you use your last name and the year (or term)

such as Smith 2003-4 or Smith Winter Term 2003.

4  Choose the location for your gradebook. We recommend that you save it to

your computer’s Desktop because 1) you’ll have ready access to it, 2) you’ll be able

to open it easily by double-clicking its icon, and 3) the Desktop is a reliable place

to store an important file since it is part of your computer’s hard drive.

Do not save your gradebook to a floppy disk or some other type of removable

media -- these are among the least reliable and slowest places. And, unless di-

rected to do so by your school or unless you are a mobile teacher, don’t save your

gradebook to a server because it is likely slower and less reliable than the hard

drive attached to your computer.

5  Click the Save button. Easy Grade Pro will create an empty gradebook and open

the gradebook’s window.

FAQ: Easy Grade Pro saves automatically. What does this mean?
Like many programs that deal with large amounts of data, Easy Grade Pro automatically

saves your changes while you work. When you switch classes, switch charts, choose most

menu commands or even pause for a few moments, you trigger Easy Grade Pro’s save

feature, causing it to write changes to your gradebook file.

In Easy Grade Pro’s File menu, there is no Save command; you never manually save your

work. However, there is a Save Copy command and, when you close a gradebook, there is

a prompt for saving a copy. It is highly recommended that you make copies of your

gradebook but keep in mind that these are copies -- they should never be used unless

something happens to make your original gradebook unusable.
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Adding Classes to a Gradebook
In Easy Grade Pro, a class is a collection of students and their data for a single

subject in a single term. A subject might be Reading, Math, Physics I or Art

History. A term might be Quarter 1, Semester 2 or even Final Exam.

It is generally best to have a one-to-one correspondence between the classes that

you teach and the classes in your gradebook. If you teach five subjects this term,

you probably should have five classes in the current term of your gradebook. If

you teach multiple sections of the same class (i.e. three sections of Earth Science),

there generally is no benefit to combining the sections into a single class. Easy

Grade Pro makes it easy to switch from one class to another and to copy assign-

ments and options from one class to others. By keeping your classes separate, you

will be able to view summaries of each making it easy to make comparisons. If

you are an elementary teacher with multiple reading (or math) groups from your

main group of students, you can choose to have all groups in a single class or

break them into separate classes. Easy Grade Pro can handle either setup well.

If you have just created a new gradebook, one without classes, a window will

automatically appear (shown below) directing you to add classes.

Obviously, a gradebook without classes is not very usable so it is a good idea to

click the Add Classes button. Here are some general guidelines about adding

classes to a gradebook:

•  Add a class to the gradebook for each class you teach in your current term only.

•  Do not add classes for future terms; it is best to add them later.

•  If you are an elementary teacher and specialists teach some subjects to your

students and you wish to include grades from the specialists in your reports to

parents, do not add the classes now. They can be easily created when you import

from the specialists’ gradebooks.
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To add a class:
1  If your gradebook has no classes, click the Add Classes button. Otherwise,

choose Add Class from the Tool menu. In either case, the Records window will

open (shown below) to an empty class record.

2  Type the name of the class in the Class/Subject Name field and press tab. Be

sure to use a unique name for the class. Examples include Math, Reading, En-

glish(1), English(2), etc. Do not include a term name with the name of the class.

3  (Optional) Edit the Class Weight and press tab. It’s not likely that you’ll ever

need to change the class weight. It is used only in the multi-class progress report

and the multi-class gradesheet report when a student’s weighted average for

several classes is calculated. In most cases it should be left at 1.00. If you have a

class that is worth half of a normal class, set the class weight to 0.50 and so on.

4  Edit the Term Labels in the column on the left so that they match the term

labels used by your school. You can use First 6 Weeks, Quarter 1, Semester 2, etc. If

you will give a final exam that must be weighted, then you must add the final

exam as a term. Changes made to these labels will apply to all classes so you won’t

have to change them again in the gradebook.

5  Select the current term for the class by clicking in the box to the right of your

current term’s label. A check or ‘x’ will appear. You must select at least one term

and you may select more. We recommend that you select your current term only.

Later on, when you are ready to begin the next term, you can add a new term.



29CHAPTER 3: Gradebooks and Classes

6  (Optional) Edit the Custom Labels and enter Custom Data. These eight custom

fields are very important to some users of Easy Grade Pro but are not used by

most. They are used to hold course number, section number, teacher name and

other course-specific data. These values are critical if you will be importing your

student rosters from school administration software and exporting grades. These

are also used when uploading internet reports to Edline or Basmati. Generally,

you won’t use them unless your school instructs you to do so.

7  (Optional) To add more classes, click the Next Class button. Then repeat steps 2

through 6.

8  Click Done to close the Records window. To switch to the different classes, use

the Class menu or the Prior Class  and Next Class  tools.

Managing the Classes in your Gradebook
You can add, delete and rename your classes. You can sort them into any order.

Terms can be added to classes and terms can be renamed. This section explains

how to perform these basic tasks.

To add a class:
To add a new class, follow the steps found on the prior page. Note: if you need to

add a new term to an existing class, see To add a term to an existing class on the

next page.

To delete a class:
1  Choose Delete->Class from the Tool menu. The Delete Records window will

open with a list of all the classes in the gradebook.

2  Select the class or classes to delete from the list. Press on the blue arrow to select

or deselect all items in the list.

3  Click the Delete button.

To rename a class:
1  Use the Class menu to switch to the class.

2  Choose Records from the Chart menu or click the Records tool .

3  Select the Classes tab.

4  Edit the name of the class and click Done.
To sort or reorder your classes:
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1  Choose Sort Classes from the View menu. The Sort Classes window will open.

2  Press on classes and drag them to the desired locations in the list. Use the

sample class menu at the top of the window to view the effects of your changes.

3  Click Done.

To add a term to an existing class:
We recommend that you wait until right before the start of the new term before

adding a term to a class.

1  Use the Class menu to switch to the class.

2  From the Tool menu, choose Term Tools->Start New Term. Easy Grade Pro will

automatically put a check or ‘x’ for the appropriate term in the Records window

for the class. It will then switch to the new term and automatically copy the

students to it from the prior term. Be sure to take a look at Working with Terms on

page 89 for a thorough discussion of this topic.

To rename a term:

1  Choose Records from the Chart menu or click the Records tool .

2  Select the Classes tab.

3  Edit the name of the term. This change applies to all classes in a gradebook.
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Easy Grade Pro attempts to accommodate your grading style by providing options

on two levels: class as well as gradebook. Class options apply to a single class in

one term. Gradebook options apply to all classes. Since getting Easy Grade Pro to

match your style is so important, this chapter should not be missed!

About Class Options
Each class within your gradebook has its own grading scales, score categories,

special scores, attendance categories and other options. Together, these are known

as class options because they are stored with the class and are unique to it.

A class does not have options until you view it for the first time; Easy Grade Pro

will automatically copy options into it from another class, either from a prior-

term class or from an adjacent one. If there is no ‘other’ class because it’s your first

one, Easy Grade Pro will copy from a built-in set and display a message letting

you know what it has done. Since the built-in set is unlikely to match your style,

you’ll want to edit it as soon as possible, ideally before you view other classes.

To view or edit the options, choose Class Options from the Edit menu or click the

Class Options tool . In the window that opens, you’ll find a series of tabs, one

for each type of option. There is a section in this chapter for the options found

under each tab except for the Term tab, which is covered in Chapter 10.

Keep in mind that the changes you make to the options will have no effect on

other existing classes in your gradebook. This allows you to have options that vary

from class to class and term to term. However, since you’ll likely have some

options that you’ll want the same in all classes, be sure to read the section Copying

Class Options to other Classes on page 42.
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Class Options: Grade Scale
A grade scale is used to convert the percent on an assignment, a category average

and the overall average to some meaningful label called a grade. For example, it

may be used to convert a 98% to an A+.

A scale consists of one or more grades with a minimum or cutoff percent for each.

Grades can be letters (A,B,C), words (Outstanding, Satisfactory) or numbers

(4.00, 3.00). A class may have multiple grade scales. Each student is assigned the

first grade scale but you can have different scales for different students. You can

even assign scales to score categories in case you wish a category of assignments to

always use a certain scale.

To edit scale options:
1  Open the Class Options window to the Scale view.

2  To view or edit a scale, first click on its row number. The grades and minimum

percents will appear in the list to the right.

3  To create a new scale, click the New button. Type the name of the scale and then

type the grades and minimum percents in the list to the right. The minimum

percents must be in descending order and the last percent must be 0. Use the

small blue arrows to insert or delete a row anywhere in a scale.

4  To duplicate or delete a scale, first click on its row number. Then click the

appropriate button below the list.

5  The first grade scale in the list is the most important one because it is initially
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assigned to all students. To move a scale to the top position, press on its row

number and drag.

6  To assign a scale to a student (other than the first scale), exit from the Class

Options window and choose Students from the Chart menu. In the Grade Scale

column, select a scale for the student.

7  To assign a scale to a score category (other than the student’s scale), click the

Category tab in the Class Options window and make your selection from the pop

up menu after the category’s name.

FAQ: What is grade-clicking? How does it work?
Easy Grade Pro allows you to enter scores by clicking on grade buttons in a process known

as grade-clicking. You can also enter scores by typing grades if the ‘Allow typing of

Grades and Special Scores’ option is on in the Gradebook Options window.

What score does a student get when an A+ or C+ is clicked or typed? The score is based

on the grade-click value of the grade. The grade-click value for the top grade is always

100%. For other grades, it is the average percent for the grade. If an A+ is the top grade,

the student will get a score that is equivalent to 100%. If a C+ ranges from 76% to 80%,

the student will get a score that is equivalent to 78%.

Grade-click values are automatically set and editing is usually unnecessary. To edit them,

click the blue arrow above the scroll bar on the right in the Scale view of the Class

Options window.

FAQ: How do I set up my 5-point (or some other point) grading system? (Part 1)
The simplest way to do this is to set the maximum score on assignments to five and type

the numbers one through five as scores into score cells.

Before you do this, be sure you understand how this will affect student percents: since a

score of 1 out of 5 is a 20%, 2 out of 5 is a 40%, etc., students may have assignment and

overall percents that are much lower than what is typically considered acceptable. To

compensate for this, you can create a grade scale that looks something like this: +5

(90%), +4 (70%), +3 (50%), +2 (30%), +1 (10%) and +0 (0%). You will almost

certainly want to hide percents in reports so you don’t get questions from parents like

“My daughter has a 49% and this is OK?”. You might be wondering why we added the

‘+’ before each grade -- this is so you can tell the difference between the number five and

the grade of five onscreen and in reports -- grades and numbers are not the same!.
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The biggest drawback of this method is that, once set up, you must use it for every

assignment in the class. Since a grade scale applies to a student, you don’t want a

situation in which a 50% is good on one assignment (grade of +3) but bad on another

(grade of F). This topic is addressed again in Part 2 on page 37.

Class Options: Rounding
Rounding options include whole numbers, tenths and hundredths, and are used

whenever percents are calculated. As an example, suppose a student has earned

89.638%. After rounding, the number displayed will be 90% for ones rounding,

89.6% for tenths rounding and 89.64% for hundredths. Ones rounding results in

cleaner looking numbers. Hundredths rounding results in greater accuracy. For

many teachers, tenths rounding offers a good compromise. Rounding can be

edited only in the Rounding view of the Class Options window.

Class Options: Score Category
Whenever you add an assignment to a class, a score category must be selected.

Categories are used in graphs, summary charts, filters and reports. They help

provide useful information about a student’s performance. They can also affect a

student’s overall grade if the weighted-categories option is turned on. A class can

have up to fifteen score categories.
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To edit category options:
1  Open the Class Options window to the Category view.

2  View and edit the category names. Since each class has its own set of options,

you can use subject-specific names such as Lab Activity.

3  Turn on category weighting (click the Yes button) if you want your categories to

have a certain proportional effect on overall grades. Enter percents in the Weights

column so that their sum is 100%. To learn how category weighting affects

calculations, refer to FAQ: How a Student’s Overall Grade is Calculated on page 66.

If you turn on category weighting, do not set up a single category just for extra

credit. See FAQ: I’ve added an extra credit assignment but student grades haven’t

changed. Why? on page 70 for an explanation of this.

4  If you would like to use a special grade scale for all assignments in a certain

category, select it from the last column. As an example, you can have a category

named Effort that uses a +1, +2, +3 grade scale. Easy Grade Pro will use the

category’s assigned grade scale in the score chart, in assignment graphs and in

reports. Grade scales are created in the Scale view of the Class Options window.

Class Options: Score Footnote
Score footnotes are short comments that can be attached to scores to provide

additional meaning. They can be included adjacent to scores in printed reports.

Footnote text can be edited in the Footnote view of the Class Options window.

For more information, see Adding Footnotes and Notes to Scores on page 67.



CHAPTER 4: Setting Options36

Class Options: Special Score
Special scores are scores that can be used in place of numeric scores to provide

special meaning. Easy Grade Pro provides a variety of special scores that you can

use, modify and delete. In addition, you can create your own.

Here is a list of some of the most used special scores with suggestions for use:

•  ex, short for excused, is for an assignment that has not been submitted and not

required of the student, perhaps due to a late enrollment or other special circum-

stance. It has no value and does not affect the overall grade.

•  cr, short for credit, is for an assignment that has been submitted but is not to be

graded. It has no value and does not affect the overall grade.

•  ab, short for absent, is for an assignment not submitted due to an absence. It has

a value of 0%. It implies that the assignment can and should be submitted for a

new grade. This score causes the assignment to appear in missing work reports.

•  mi, short for missing, is for an assignment not submitted and for which no valid

excuse exists. It has a value of 0%. Teacher policy determines how this grade can

be changed. This score causes the assignment to appear in missing work reports.

•  inc, short for incomplete, is for an assignment that has been submitted but must

be redone or completed. It has a value of 0%. It implies that the assignment can

and should be completed for a new grade. This score causes the assignment to

appear in missing work reports.
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To edit special score options:
1  Open the Class Options window to the Score view.

2  In the Score Names column, put the name to be used as a key in reports.

3  In the Code column, put the text that will be used as the score. To avoid confu-

sion, we strongly recommend that you not use numbers unless you include other

symbols. For example, consider using ‘+1’ instead of ‘1’.

4  Optionally, you can include a single Shortcut key that, when pressed, enters the

code into a score cell. If used, it must be unique in the list.

5  The Value% of a special score should be blank or between 0 and 100%. If you

leave this blank, the special score will have no affect on a student’s grade.

6  If you would like the score to be picked up when a missing work report is

printed or when a missing work filter is used, be sure to set the Missing attribute.

For information of using special scores, refer to the section Entering Scores

starting on page 61.

FAQ: How do I enter a check mark (÷) as a special score?
Easy Grade Pro allows you to use nearly any font on your computer that includes the

alphabet, numbers and punctuation. On Macintosh computers, most fonts that have

these characters also have a check mark. Simply type option-v to get it. On Windows

computers, the check mark is only found in specialty symbol fonts that are not suitable for

use in Easy Grade Pro because they do not include alphabetic and numeric characters.

FAQ: How do I set up my 5-point (or some other point) grading system? (Part 2)
(This is a continuation of a FAQ started on page 33).

Because of the tremendous range of percents that occurs when the maximum score on an

assignment is as low as 5 (i.e. 1/5 = 20%, 2/5 = 40%, 3/5=60%, 4/5=80%, 5/5=100%),

the use of special scores instead of numbers may be a better way to set up a 5-point

system. Your special scores could be +5 (100%), +4 (90%), +3 (80%), +2 (70%) and +1

(60%). If you were to enter a +5 as a score, the student would receive 100% of the

maximum score; for a +4, the student would receive 80% and so on.

This use of special scores has advantages over the use of true numbers: 1) the range of

percents is more typical, 2) you don’t have to use a modified grade scale, 3) percents can
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be displayed in reports if you choose, and 4) you don’t have to use a maximum score of 5

on every assignment -- use whatever you want on any assignment!

Create your special scores in the Score view of the Class Options window. Put the ‘+5’

and other scores in the Code column. Be sure to add the ‘+’ or some other symbol to

minimize confusion with true numeric scores. Put the percents in the Value% column. Be

sure to create a shortcut for each to make data entry of your special scores very fast.

Class Options: Attendance Category
Any class can be used for recording student attendance marks. If you are an

elementary teacher, you may find it best to use your first class of the day for

recording attendance; when you print multi-class progress reports, Easy Grade

Pro will automatically find and use the right class when printing the attendance

chart portion of the report. If you are a secondary teacher, you can record atten-

dance in every class.

To record attendance marks in a class, attendance categories and a term calendar

must be set up. (Setting up a calendar is discussed in the next section). You can set

up to fifteen attendance categories. An attendance category has four attributes.

The category, such as Excused Absence, is the full name of the category. The master

category, such as, Absent, names the major grouping that the category belongs to.

The code, such as AE, is the one- or two-character mark that is entered in an

attendance cell. The value is used when calculating totals and should be 1.00 for

full-day marks, 0.50 for half-day, etc. Easy Grade Pro will calculate totals for all of

your categories and master categories.
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To edit attendance category options:
1  Open the Class Options window to the Attendance view.

2  To edit the list of Master Categories, first press and hold on any row in the

Master Category column. From the menu that pops up, choose Edit this Menu. In

the window that appears, edit the list of master categories.

3  For each of your attendance categories, select the Master Category and enter the

category, code and value.

Once you start using your attendance codes, it is important that you don’t change

their order or meaning and that you don’t delete items that are in use.

Class Options: Calendar
Calendar options are used to set the days of the week, the starting and ending

dates and no-school days. These only need to be set if you plan to use the class for

recording attendance marks.

In Easy Grade Pro, a class is an entity within a single term only; the calendar that

you set up should reflect this. If you use Easy Grade Pro’s Term options to com-

bine student data across terms, you will be able to obtain attendance totals for

multiple terms. This is explained in Chapter 10, Working with Terms.

To edit calendar options:
1  Open the Class Options window to the Calendar view.

2  Set the days of the week that the class meets. If your class meets on varying
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days, be sure to select any day that the class might meet. Once you begin recording

student attendance marks, the days of the week cannot be changed.

3  Set the first day of the term by clicking on the date in the first calendar. Once

you begin recording attendance marks, the first day of the term can’t be changed.

4  Set the last day of the term and the no-school days on the other calendars.

These can be changed at any time.

Class Options: Seat Format
If you plan to use the seating chart for a class, you can set the size, shape, name

format and attendance formats for all of the seats in the Class Options window.

Additional options, such as color and rotation, can be set for individual seats but

must be set in the actual seating chart.

To edit seat options:
1  Open the Class Options window to the Seat view.

2  To change the shape, drag the box in the lower-right corner of the sample seat.

3  To change the name and attendance formats of the seats, use the buttons and

menus on the right.

To set options for individual seats:
1  Choose Seating from the Chart menu.

2  Double-click on a seat to open the seat’s format window.

3  Change the rotation, color and locked status as desired. Locking a seat prevents

the seat from being moved or being affected by sorting.
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Class Options: Color
Color options allow you to set the background and grid colors used in a class to

make it easier to identify the class. You can also color-code scores and attendance

marks to emphasize certain ones. Score and attendance colors can be turned on

and off using the Show Colors tool  and using the Show Colors item in the

View menu.

To edit color options:
1  Open the Class Options window to the Color view.

2  Use the Grid Color and Background Color buttons to open a window where

you can choose new colors.

3  Use the Score Colors and Attendance Colors tabs to switch between setting

colors for the score chart and for the attendance chart. You may set colors for both

charts.

4  Use the Select colors based on menu to choose the basis for color selection.

5  Use the six pop up menus and six buttons in the bottom half of the window to

select specific colors for scores and attendance marks.

FAQ: How do I change the row and column highlight color?
On a Macintosh, use the Color or Appearance control panel. On a Windows computer,

the highlight color is the inverse of the background color and can’t be directly changed.



CHAPTER 4: Setting Options42

Copying Class Options to other Classes
One of the most important features in Easy Grade Pro is the ability to copy some

or all of your class options from one class to others using the Copy Class Data

window. This can save you lots of time and help you ensure that your options are

consistent across classes and terms.

To copy class options from one class to others:
1  Choose Copy->Class Options from the Tool menu or click the Copy Class Data

tool  and select the Options tab.

2  In the upper-left list, select the class to copy from.

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select

the class that is selected in the upper list.

4  Select the options you wish to copy in the list on the right. Use the blue arrow

button to select or deselect all list items.

5  Check all of your settings to ensure that you are copying the right options to the

right classes.

6  Click the Copy button.

About Gradebook Options
Gradebook Options are settings that affect your entire gradebook. You can set the

font, the order of first and last names, passwords, types of warnings and whether

you want to be able to directly type grades or special score shortcuts. You can
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create reusable text items for notes and reports, customize the labels used in

student reports and even set up your gradebook to be used with EGP Clipboard,

the Palm OS companion to Easy Grade Pro.

To view or edit these options, choose Gradebook Options from the Edit menu. In

the window that opens, you’ll find a series of tabs, one for each option group. The

remaining sections in this chapter describe the options found under each tab.

Gradebook Options: Display
Use display options to set the font and other items that affect display throughout

your gradebook.

To edit display options:
1  Open the Gradebook Options window to the Display view.

2  To change the font or font size, use the Font and Size menus.

3  By default, the entire row and column are highlighted whenever a cell is selected

in a chart. To modify this behavior, use the Highlight menu.

4  To set the order of first and last names in the charts and in reports, use the

Show Students menu. Note: this does not affect the display in the seating chart;

use the Seat view of the Class Options window instead.

5  Use the Show Grades menu to set the display of grades in the Overall column of

the score chart to percents only, grades only or both. This does not affect the
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display of grades in a student’s progress report; use the Grades menu in the

Report Options window instead.

6  An  can appear after a student’s name in the score chart if the student has any

scores that count has missing. Use the Show  for missing work button to turn this

option on or off.

Gradebook Options: General
Use general options to control the behavior of typing, warnings, scrolling, the
movement of palettes and compression.

To edit general behavior options:
1  Open the Gradebook Options window to the General view.

2  Choose between the Allow typing of Special Score Shortcuts and the Allow typing

of Grades and Special Scores options. The first item allows you to type a shortcut

like a and have Easy Grade Pro automatically enter an ab and jump down to the

next cell. Special scores and their shortcuts are set in the Score view of the Class

Options window. The second item allows you to directly type an A+, A or ab --

any grade or special score.

3  To receive a warning any time a non-blank score or attendance mark has been

changed, turn on the Give warning when a score is changed option. This can help
minimize accidental changes.

4  To receive a warning when the score you type exceeds the maximum set for the
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assignment, turn on the Give warning when a score exceeds the maximum option.
This can help minimize mistyped scores. Only a single warning is given on an
assignment in case you are entering a series of scores with extra credit.

5  The Scroll to top when the last score is entered option makes it easier to enter
scores from a paper gradebook. When a score is entered for the last student, Easy
Grade Pro scrolls up to the first student on the next assignment. This option can
get in the way if you are entering a series of scores for the last student; in this case,
use the left or right arrow key after entering each score to prevent the automatic
scrolling.

6  If you want the column that you are working on to be as close as possible to the
column of student names, turn on the Scroll to left when a cell is selected option. If
this option is on and you select a cell in any chart, the column will be instantly
scrolled to the left-most position. Use the left and right arrow keys to select cells
in adjacent columns.

7  Easy Grade Pro has two floating tool palettes available for your use: the tool
palette and mini-summary. Both can be shown or hidden from the Edit menu. If
you would like these windows to automatically move to the upper-left corner in
the score and attendance charts and move to the bottom in the other charts, turn
on the Palettes: automatically position based on chart option. Since the floating
window will likely cover data in some of the charts, you may want to turn on the
Palettes: hide in Seating, Student and Assign. charts option.

8  If your gradebook is large and you want to email or use a floppy disk to transfer
it to another computer on a regular basis, you may wish to turn on the Compres-
sion: always ON option to keep your gradebook as small as possible. There is a
speed penalty when this option is on. You can also compress your gradebook at
any time by choosing Compress from the File menu.

Gradebook Options: Security
Use security options to set your teacher and TA passwords, backup preferences
and TA access privileges.

To edit security options:
1  Open the Gradebook Options window to the Security view.

2  Use the Set Teacher Password button to open a window where the teacher
password can be entered or changed. This password is used to gain full access to a
gradebook.
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3  To have your gradebook automatically lock whenever it is closed, turn on
Password protect: when Lock, Close or Quit option. To have your gradebook lock

only when you choose Lock from the File menu or select the Lock tool , turn

on the Password protect: when Lock only option.

FAQ: I don’t remember the password. How do I get back in?
If you are unable to get into your gradebook, call Orbis Software for help. If you are a

registered single-user license holder or if you are the contact person for a school that holds

a registered site license, you will be given a special one-day password that will allow you

to open the gradebook and set a new password. See the appendix for phone number and

times in which this support is available.

4  By default, Easy Grade Pro will prompt you to make a backup of your grade-
book whenever you close it. Keep in mind that Easy Grade Pro automatically saves
all of your work; the backup prompt is primarily for making a copy of your
gradebook for archival purposes. Use the When Close or Quit... options to change
the standard behavior. For important information on making backups, see
Chapter 8, Making and Managing Backups.

5  If you will have an assistant help enter student data, use the Set TA Password

button to set a password that allows limited access to your gradebook. The TA or

teacher assistant mode is designed to allow someone other than the teacher to

enter student data, while protecting the gradebook and the privacy rights of

students. When the TA mode is on, many student data fields are grayed and access

to menus and tools is limited. Use the Allow TA to items to control the level of
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access. Options include entering data into charts, switching charts, switching

classes, adding assignments, copying data to other classes and printing reports.

To turn on the TA mode, choose TA Mode from the File menu or select the TA

Mode tool . To turn off the TA mode, choose TA Mode as before. The pass-

word window will appear and the teacher password must be typed to regain full

access. It is suggested that, before turning on the TA mode, you use assignment

and calendar filters to hide all columns except for those to receive data from the

TA. See pages 75 and 78 for help with showing and hiding assignments and dates.

Gradebook Options: Clipboard Text
Use clipboard text options to create and store sentences and paragraphs that can

be used and reused in score notes, summary notes and student reports. There is

no limit to the number of clipboard text items and each has a 32,000 keystroke

limit. Numerous variables can be added to the text; Easy Grade Pro completes the

variables with student data at the time the text is printed or pasted into notes. A

50,000-word dictionary is available to help ensure that your text is error-free.

To edit clipboard text options:
1  Open the Gradebook Options window to the Clipboard Text view.

2  To edit an item, first select it in the left list. The full text will appear to the right.

3  To create a new item, select the list item titled NEW ITEM. Then type the text.

4  To delete or duplicate an item, press on the small blue arrow above the list.



CHAPTER 4: Setting Options48

5  Use the four menus below the text to add text variables. Variables are automati-

cally filled in with the specified student or other data at the time the text is pasted

into a note or printed in a report. You may need to put a space before and after

each variable to ensure proper spacing when Easy Grade Pro later substitutes the

variable with student data.

6  Click the Spell button to bring up the Spell Check window.

Gradebook Options: Report Labels
Report Label options allow you to change the titles and labels used in student

reports. Easy Grade Pro has labels in three different languages (English, French

and Spanish) and each can be customized. You can even create labels for a fourth

language of your choice.

To edit report labels options:
1  Open the Gradebook Options window to the Report Labels view.

2  Use the Language menu to set the language you wish to customize. Select the

last menu item to add your own language or to add an alternate set of labels.

3  Edit any of the labels. The built-in label will be used unless you enter your own.

4  By default, Easy Grade Pro assigns English to every student. To assign a different

language, choose Student from the Chart menu. Edit the items in the column

labeled Language.
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Gradebook Options: Palm Setup
EGP Clipboard, the Palm OS companion to Easy Grade Pro, can be used to record

student scores, attendance and notes. For information about obtaining EGP

Clipboard software, contact Orbis Software or view www.orbissoft.com.

To set up palm setup options:

1  Choose Palm Setup from the File menu or click the Palm Setup tool .

2  Select Turn on syncing for this gradebook. If a different gradebook is already set

up for syncing, a warning window will appear because only one gradebook can be

set up for syncing at a time. Do not turn on syncing for a new gradebook if there

are unsynced gradebook changes on the handheld. Sync the data first!

3  (Optional) Click the Reset User button. EGP Clipboard uses the Handheld User

name displayed in the window to match the gradebook with the right handheld

when syncing. If the name is blank, it will be filled in automatically during the

first sync. Do not reset the user if there are unsynced gradebook changes on the

handheld.

4  From the list, select the classes to be copied to the handheld. You may select up

to sixteen classes from one term. If a selected class has no students, it will be

ignored. You may change your selection of classes at any time; EGP Clipboard will

sync the changes in your handheld before switching to your new class selections.

Don’t select unneeded classes: each adds roughly five seconds to the sync time.
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5  Choose the students to be copied to the handheld. You can choose to include all

students, displayed students (based on the items in the View menu) or students

with missing or blank scores. Withdrawn students are never copied. The students

that appear on the handheld can actually change each time you sync. If your

selection results in no students to be copied, the class will be ignored and not

appear on the handheld.

6  (Optional) Select the Include Assignments box and choose the assignments to

be copied to the handheld. You can choose to include all assignments, displayed

assignments (based on the items in the View menu) or assignments with missing

or blank scores. The assignments that appear on the handheld can change every

time you sync based on your setting. To minimize sync time, only include assign-

ments needed until the next sync.

7  (Optional) Select the Include Attendance box. If you want to record attendance

on the handheld, be sure to set a calendar for the class in the Class Options

window before syncing. Calendars cannot be set on the handheld. To minimize

sync time, only set calendars in classes for which attendance data will be recorded.

FAQ: How do I switch the classes in EGP Clipboard to my new term?

Choose Palm Setup from the File menu or click the Palm Setup tool . From the list,

deselect the classes in the old term. Then select the classes in your new term that you’d like

to have appear in EGP Clipboard. Keep in mind that you may change your selection of

classes at any time; EGP Clipboard will sync the changes in your handheld before

switching to your new class selections.
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A Class Without Students
Whenever you view a class that has no students, a window will appear (shown

below) requesting that you choose how students are to be added to the class.

Whenever possible, click the Copy Students from the PRIOR TERM button because

the students will appear without any more effort on your part and will be identi-

cal in both classes. The Copy Students from another Class button should be your

second choice. This is explained in the section Copying Students to other Classes on

page 59. If you have access to another Easy Grade Pro gradebook or a text file with

the students, you can click the Import from another file button. Importing students

is explained in Chapter 15, Porting. Only select the Type Student Names button if

it is your only option. This is explained next.

Adding Students to a Class by Typing
1  Open the Records window to the first empty student record. There are four

ways to do this: 1) click the Type Student Names button (shown above); 2) choose

Add Student from the Tool menu; 3) click the large Add Student button found in

the charts; or 4) click the Add Student tool  on the tool bar.
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2  Type the Last name and press tab. Type the First name and press tab. Notice

that after both names are typed, the Next Student >> button that leads to the next

record becomes framed. Any framed button can be selected by pressing the enter

key. After the names have been entered, you can move to the next student by

pressing this key. Be careful: if you press enter intending to move down to the next

field in this record, you will actually move to the next student’s record. If this

happens, click the << button.

3  (Optional) Enter the ID and press tab. The small button to the right of the ID

number field opens a window where automatic ID numbers can be set.

4  (Optional) Set the student’s gender. Gender is used in filters that show and hide

certain students and in clipboard text when Easy Grade Pro must choose the

proper pronoun when generating text.

5  (Optional) Edit the student’s status. You may choose between Active, WD

(grayed) and WD (hidden). WD is an abbreviation for withdrawn.

6  (Optional) Edit the student’s grade scale. Grade scales are edited in the Class

Options window.

7  (Optional) Edit the student’s report language. This option affects the titles and

labels used in progress and missing work reports. Report labels can be edited in

the Gradebook Options window.

8  (Optional) Enter a password. The password is used to gain access to Easy Grade

Pro's HTML Multi- and Single-class Website reports. It is not used with any other

internet reports. Additionally, the password is used as a filter when creating these
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reports: only students with passwords will have reports created. The case of the

password is not important but it must consists of numbers and letters only. No

spaces are allowed. It must be at least six but no more than twenty-four characters

in length.

9  (Optional) Edit the Custom Labels and Custom Data fields. There are twelve

custom data fields. You can set the labels of these fields as well as enter any kind of

information. You might include phone number, parent name, address (to be used

in mailing labels), reading group, etc.

10  Press enter or click Next Student to move to the next student or click Done.

Copying Students to other Classes
One of the most important features in Easy Grade Pro is the ability to copy one or

more students from one class to others using the Copy Class Data window. This

can save you lots of time and help ensure that your student record data are

consistent across classes and terms.

To copy students from one class to others:
1  Choose Copy->Students from the Tool menu or click the Copy Class Data tool

 and select the Students tab.

2  In the upper-left list, select the class to copy from.

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select

the class that is selected in the upper list.
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4  Select the students you wish to copy in the list on the right. Use the blue arrow

button to select or deselect all list items.

5  Check all of your settings to ensure that you are copying the right students to

the right classes.

6  Click the Copy button.

Managing your Students
You can change the names or other data in student records. You can change order,

delete, withdraw and transfer your students. This section explains how to perform

these basic tasks.

To change a student’s name or other record data:
1  Open the record by double-clicking on the student's name in any chart except

the seating chart.

2  Edit the name or other data. Click Done.

3  Repeat these steps for each class in which the student data should be changed.

To change the order of your students, do one of the following:
•  Press on a student’s name in the score, attendance or student chart and drag up

or down.

•  Choose Sort Students from the View menu. You can sort by name, ID, score on a

selected assignment and by a variety of other keys.

•  Click the Sort tool  to sort by name. In the seating chart this tool sorts

randomly.

To delete a single student:
1  Click on the student’s row number (to the left of the name) in one of the charts.

2  Click the Delete tool  or press the delete key.

3  Repeat these steps for each class in which the student is to be deleted.

To delete multiple students:
1  Choose Delete Student from the Tool menu.

2  Select the students in the list. Click the Delete button.

3  Repeat these steps for each class in which the student are to be deleted.
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To withdraw a student:
1  Open the student’s record by double-clicking on the student's name in the

score, attendance or student chart.

2  Use the Status menu to select either WD (grayed) or WD (hidden) and click

Done. If you choose WD (grayed), the student will remain visible in the charts but

will appeared grayed and the data will not be editable. The letters WD are ap-

pended to the name of the withdrawn student. If you choose WD (hidden), the

student will be removed from all charts but will remain in the Records window.

3  Repeat these steps for each class in which the student is to be withdrawn.

A student whose status is WD (grayed) appears in gray in the charts.

FAQ: How do I reshow a student once the status has been set to WD (hidden)?
To show a student whose status has been set to WD (hidden), choose Records from the

Chart menu and select the Students tab. Use the Record pop up menu in the right corner

to switch to the student’s record. Use the Status menu to change the status to Active or

WD (grayed).

To transfer a student when classes match:
If the two classes match exactly (assignment order, assignment settings, calendar

settings, score footnotes, etc.), it is easy to transfer a student using copy and paste.

This method is preferred because it transfers all student data (scores, attendance

data, notes, comments, etc.).

1  Select the student’s row number (to the left of the name) in one of the charts.

2  Choose Copy from the Edit menu.

3  Switch to the class the student is transferring to. If this class is in another

gradebook, be sure you don’t quit Easy Grade Pro. Rather, choose Close from the

File menu and then open the other gradebook.

4  Select the row number where you want to insert the student.

5  Choose Paste from the Edit menu.

To transfer a student when classes do not match:
Transferring a student is more difficult when the classes don’t match. If possible,

print out scores and attendance charts and retype the data into the proper col-

umns. If this is not be possible you may want to add a new assignment column
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used solely to give the student a transfer grade. Use an assignment name like

Tommy’s Transfer Grade. Set the assignment’s maximum score to 100. Set the

assignment’s points value to the sum of all the points currently in the class. This

will ensure that the student’s transfer grade has the same weight as all the assign-

ments currently in the class. Set the assignment’s progress report option to Include

if student has score. In the score cell for this student, enter the transfer percent. If

you use category weighting in the class, you may need to follow these steps for

each of the categories.

Adding Assignments
Assignments can be added to a class by typing, by copying from another class or

by importing from a class in another gradebook. This section explains how to add

assignments by typing.

1  Open the Records window to the first empty assignment record. There are three

ways to do this: 1) select Add Assignment from the Tool menu, 2) click the large

Add Assignment button in the score or assignment charts or 3) click the Add

Assignment tool .

2  Type the assignment Name and press tab.

3  Type the assignment’s Maximum Score and press tab. Type the assignment’s

Points. Ignore these fields if the assignment is being used for extra credit or is a

nongraded item. For a thorough discussion of Maximum Score and Points, be

sure to take a look at the FAQs on the next page.
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FAQ: What are maximum score and points? How should I set them?
By definition, an assignment’s maximum score is the score that is worth 100%. It’s the

score that is given when everything is correct (ignoring extra credit). Perhaps you like to

score papers using percents (scores between 0 and 100). In this case, as a percents-

grader, you should keep the maximum score at 100. Perhaps you count the number of

problems the student has correct to get the score. In this case, as a problems-grader, you

should set the maximum score to the total number of problems. Perhaps you apply

differing amounts of points to problems based on difficulty and then sum the points the

student has earned to get the score. In this case, as a points-grader, you should set the

maximum score to the number of points possible on the assignment.

Easy Grade Pro uses the maximum score to do one thing only: calculate a student’s

percent on the assignment. If a student’s score is 15 and the maximum score is 20, Easy

Grade Pro calculates (15/20) x 100 and gets 75%. Notice that the maximum score has

nothing to do with the value of an assignment. A student can have a 15 out of 20 on a

small assignment as well as on a huge semester project. How is one assignment given

more value than another? It is done through the use of assignment points!

By definition, an assignment’s points is the number of points to be earned when a

student’s score is equal to the maximum score. Using the example above in which the

student’s score is 15 out of 20, the student will get 75% of whatever value is set for points.

The student will receive 15 points if there are 20 points possible, 75 points if there are 100

points possible, 150 if there are 200 points possible and so on.

So, how should you set an assignment’s points? The answer depends on your grading

style. If you are a points-grader, you should use the same number for maximum score

and points. When you do this, the student’s score, whatever it is, will be equal to the

number of points earned. If you are a percents-grader or a problems-grader, simply

keep the points set at 100 for a typical assignment, 200 for an assignment worth double,

50 for an assignment worth half and so on. Be sure to see FAQ: How is a student’s

overall grade calculated? on page 66.

FAQ: If I use category weighting, does it matter how I set assignment points?
If you use category weighting (i.e. Quiz 30%, Homework 50%, Final Exam 20%) and

you want all assignments in a category to have the same value, simply set points on all of

them to 100, or to 10 or to anything -- as long as they are all the same. However, if you

want one assignment to be worth more than another assignment in the same category,

then follow the guidelines in the prior FAQ.
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4  Select the assignment's due date. The calendar is initially set to the current date.

If the date showing is not the current date, the computer's clock may be improp-

erly set or its clock battery may be dead.

5  Select the assignment's category. The category is used in summaries, reports

and in grading (if categories are weighted). To edit your categories, choose Class

Options from the Edit menu and select the Category tab.

6  Select the Special Status option. Special status options include the following:

•  Normal. No special action is taken.

•  Extra credit. Any score entered for a student will increase the number of points

the student has earned without increasing the number of points possible. In other

words, the student’s average will go up. Students without scores are unaffected.

•  Can be dropped. Easy Grade Pro will drop this assignment for a student if, by

dropping it, the student's overall percent is improved more than by dropping any

other assignment that can be dropped. A letter d is drawn next to a dropped score.

•  Not for grade. The assignment will not be included when determining grades. It

can be used for recording items such as whether a progress report has been

returned. It can also be used to temporarily turn off a group of assignments so

that they do not influence the overall grades.

•  (-)Negative Points. A score entered for a student will decrease the number of

points the student has earned without decreasing the number of points possible,

causing the average to go down. Students without scores are unaffected.

7  Select the Display Scores option. Use this to set whether the scores will appear

as scores, percents or grades in the score chart. A pop up menu in the score chart

(see page 73) can override this setting.

8  Select the Progress Report option. Progress report options include the following

items:

•  Include Assignment. The assignment will be included on every progress report

whether the student has a score or not.

•  Include if Student has Score. The assignment will be included only if the student

has a score. This option allows you to add columns to your score chart that only

apply to one or some students. It also allows you to enter assignments in advance

and prevent them from appearing too soon in progress reports.

•  Exclude Assignment. The assignment will not be included in any progress report.
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9  (Optional) Enter text in the Note field. Text could include the assignment

objective or purpose. It can also be used in conjunction with custom filters to

allow you to show or hide the assignment based on any criteria that you choose.

10  Select Next Assignment >> to move to the next assignment or select Done.

FAQ: Why are the dates wrong on the calendars and in the charts?
This problem indicates that the computer’s clock is not set properly or the clock’s battery

is dead. Use the computer’s Date and Time control panel to set the clock. Refer to your

computer’s user manual for help in replacing a dead clock battery.

Copying Assignments to other Classes
If you teach more than one section of a subject, be sure to use the Copy Class

Data tool to copy your assignments from one class to others. This can save you

lots of time and help ensure that your assignments are consistent across classes.

To copy assignments from one class to others:
1  Choose Copy->Assignments from the Tool menu or click the Copy Class Data

tool  and select the Assign. tab.

2  In the upper-left list, select the class to copy from.

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select

the class that is selected in the upper list.

4  Select the assignments you wish to copy in the list on the right. Use the blue
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arrow button to select or deselect all list items.

5  Check all of your settings to ensure that you are copying the right assignments

to the right classes.

6  Click the Copy button.

Managing your Assignments
You can change the name or other data in an assignment’s record. You can change

the order or delete your assignments. This section explains how to perform these

basic tasks.

To change an assignment’s name or other record data:
1  Open the assignment’s record by double-clicking on the assignment's name in

the score or assignment chart.

2  Edit the name or other data. Click Done.

To change the order of your assignments, do one of the following:
•  Press on an assignment’s name in the score or assignment chart and drag to the

new location.

•  Choose Sort Assignments from the View menu. You can sort by name, date, and

category.

To delete a single assignment:
1  In the score chart, click the assignment’s column number.

2  Click the Delete tool  or press the delete key.

To delete multiple assignments:
1  Choose Delete Assignment from the Tool menu.

2  Select the assignments to be deleted in the list. Click the Delete button.
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The posting and manipulation of student scores and notes can be tedious and

time-consuming. This chapter explains Easy Grade Pro numerous tools to make

the tasks both fast and easy.

Entering Scores
This section describes a variety of ways to enter scores.

To enter scores by typing:
1  Select the score cell.

2  Enter any number from zero through 999.9.

3  Press enter, return or one of the arrow keys.

To repeat a score:
1  Select the score cell other than the first cell in a column.

2  Press the ‘=’ key.

To delete one or more scores:
1  Select the scores. To select multiple scores, press on the first and drag to the last.

2  Press the delete key.

To move a group of scores:
Use these steps if you have entered a group of scores into the wrong cells, perhaps

offset by a single row or column.

1  Select the first score cell in the group and drag to the last.

2  Choose Cut from the Edit menu.

3  Select the first cell where the scores should go.

4  Choose Paste from the Edit menu.
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To enter a special score (i.e. mi ) using its shortcut (i.e. m):
1  Make sure that the typing mode is set to Allow typing of Special Score Shortcuts.

This can be set using the typing mode menu on the tool bar (see the illustration

below) or in the General view of the Gradebook Options window.

2  Select a score cell.

3  Type the shortcut key. Do not press enter or return; Easy Grade Pro will auto-

matically advance to the next cell.

A

B

Use the grade click menu (A) to show or hide the row of grades and special scores. Use the typing
mode menu (B) to switch between typing shortcuts and typing of grades and special scores.

To enter special scores and grades by typing:
1  Make sure that the typing mode is set to Allow typing of Grades and Special

Scores. This can be set using the typing mode menu on the tool bar (see the

illustration above) or in the General view of the Gradebook Options window.

2  Select a score cell.

3  Type the full text of the grade or special score.

4  Press enter or return.

To enter special scores and grades by grade-clicking:
1  Make sure that the row of grades is visible on the tool bar (see the illustration

above). Alternately, you may use the tool palette. To make the tool palette visible,

choose Show Tool Palette from the Edit menu.

2  Select one or more score cells. To select multiple cells, press on the first and

drag to the last.

3  Click on the grade or special score on the tool bar or palette.

For additional information on working with grades and special scores, see Class

Options: Grade Scale on page 32, FAQ: What is grade-clicking? How does it work?

on page 33, Class Options: Special Score on page 36, and To display scores as raw

scores, percents or grades on page 73.
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To fill down a score:
To fill down means to copy a score from a starting cell downwards to the last row.

It is typically used when most of the scores on an assignment are the same. If

there are a few scores that are different, they can be changed after filling down.

1  Select a score cell.

2  If the cell is blank, type the score but do not press enter.

3  Select the Fill Down tool  or choose Fill Down from the Tool menu.

To fill across a score:
To fill across means to copy a grade from a starting cell across to the last column.

It is normally used on a transferring student to apply the transfer grade to all

assignments given prior to the transfer. Note that the grade, not the score, is filled

across. Each assignment may have a different score but each will have the same

grade value. An assignment whose special status is Not for grade is ignored during

filling across.

1  Select a score cell.

2  If the cell is blank, type the score but do not press enter.

3  Select the Fill Across tool  or choose Fill Across from the Tool menu. If this

tool is not visible, press on any tool or empty tool location and hold the mouse

down for at least a second. From the menu that pops up, choose the tool.

To enter scores directly from student papers:
By using Easy Grade Pro’s Find tool, it is easy to enter scores directly from student

papers -- even if the papers consist of an unsorted mixture of assignments, classes

and students. Here’s how:

1  Open the Find window by clicking the Find tool  or by choosing Find from

the Tool menu.
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2  Choose by Name from the Search menu and select Use Continuous Search Mode.

By selecting the continuous search mode, Easy Grade Pro will reopen this window

after each score is entered.

3  (Optional) If the stack of papers includes several classes, select Search all

current-term classes. If this is selected, Easy Grade Pro will search other classes if

the student cannot be found in the current class. If you have the same student in

multiple classes, you may wish to search using some other search field that you’ve

set up for this purpose.

4  Click Exit. The window will close. You are now ready to begin entering scores.

5  Select the score cell for the first paper. Enter the score and press enter. The Find

window will reopen.

6  Enter a few letters of the name from the next paper. Easy Grade Pro will at-

tempt to complete the student’s name for you.

7  Click Find or press enter. Easy Grade Pro will find the student and select the

score cell in the same column as before. If the wrong student is selected, edit the

search text and click the Find Again tool , choose Find Again from the Tool

menu or simply press enter twice to find to the next match. If the selected cell is in

the wrong assignment column, use the arrow key to switch columns.

8  When you are done, deselect Continuous Search Mode and click Exit. The

window will close and remain closed.

FAQ: How does Easy Grade Pro treat blank score cells? How can I easily set all blanks to a certain score?
In Easy Grade Pro, a blank score has no value and is completely ignored when calcula-

tions are made. This allows you to add assignments in advance without affecting

calculations. It also allows you to add assignments that are not meant for all students. If

you set an assignment’s Progress Report option to Include if Student has Score, the

assignment won’t even appear in a report until the student has a score. The Show Blanks

filter can be used from the View menu to hide all scores except those that are blank. Don’t

think that you’ll have to spend a lot of time filling in all the blanks with zeros; the

Change Scores tool  can easily change all blanks (or just some blanks) to zeros (or

something else) with just a few clicks. (See the next section.)
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To convert blank cells to a certain score:
Using the Change Scores tool, you can change scores of one type, such as blank, to

another score, such as mi. You can choose to change scores on all assignments,

displayed assignments or just selected ones.

1  (Optional) If you want to change scores on some, but not all assignments, select

the assignments (by pressing on the column number and dragging left or right) or

use a filter in the View menu to show just certain assignments.

2  Select the Change Scores tool  or choose Change Scores from the Tool

menu. If this tool is not visible, press on any tool or empty tool location and hold

the mouse down for at least a second. From the menu that pops up, choose the

tool.

3  Use the first menu to select the score to change. If you select Text Score--> from

the menu, be sure to type a numeric score.

4  Use the second menu to select the new score. As before, if you select the last

item in the menu, be sure to type a numeric score.

5  Select the range of assignments to be included. If you choose All displayed

assignments, any assignments hidden by filters will not be affected. Choose

Selected assignments ONLY if you selected at least one assignment column before

opening the window.

6  (Optional) If you would like ungraded assignments to be included, select the

Include “Not for Grade” item. The “Not for Grade” attribute is set in the record

window for an assignment.

7  Click the Change button.
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FAQ: How is a student’s overall grade calculated?
Understanding the math behind the calculations of a student’s overall grade can help you

use Easy Grade Pro more effectively. It can also help you explain a student’s grades when

asked by an inquisitive parent or student. Two examples will be used to explain the

process and both use the following five sample assignments:

Points Earned

Assignment Data Student Data

Name Max. Score Points Score %

Quiz 1
Quiz 2
Hwk 1
Hwk 2
extra credit 

10
15

8
12
---

100
100

50
50
---

6.5
12

8
9
2

65%
80%

100%
75%

---

65
80
50

37.5
2

Let’s take a close look at this chart. The student is being graded on two quizzes, two

homework assignments and one extra credit homework. On Quiz 1, the teacher set

maximum score to 10 and points to 100. The student’s score is 6.5. Easy Grade Pro first

calculates percent: (6.5/10)x100 = 65%. It then calculates points earned: 65% of 100

points possible = 65. Take a moment to examine the numbers for the other assignments.

Example 1: When Category Weighting is Off
When category weighting is off, Easy Grade Pro calculates an overall grade by summing

the points earned and dividing by the total points possible. Here’s how it does it:

1. Sum the points earned (last column): 65 + 80 + 50 + 37.5 + 2 = 234.5

2. Sum the points possible (Points column): 100 + 100 + 50 + 50 = 300

3. Divide points earned by points possible to get the overall percent: 234.5/300 = 78.17%

Example 2: When Category Weighting is On
In this example, the Quiz category is weighted 30% and Homework is weighted 50%. A

third category, Final Exam, is weighted 20% but is not yet being used. When category

weighting is used, Easy Grade Pro goes through the calculations in Example 1 for each

category. Then it combines the categories using the category weights to calculate the

overall percent. It works properly even though not all categories are being used.

Quiz Homework

1. Sum the points earned (last column): 65 + 80  = 145 50 + 37.5 + 2 = 89.5

2. Sum the points possible: 100 + 100 = 200 50 + 50 = 100

3. Divide to get the category percent: 145/200 = 72.5% 89.5/100 = 89.5%

4. Combine the categories percents using their weights to get the

overall percent: ((72.5% x 30%) + (89.5% x 50%)) / (30%+50%) = 83.125%
For a related topic, see FAQ: How can I check the calculations for one of my students? on page 94.
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Adding Footnotes and Notes to Scores
A footnote is a short, numbered, predefined note that can be quickly added to one

or more scores. It is used to provide additional meaning about the score. Foot-

notes can be viewed and edited in the Class Options window, Footnote view.

In the score chart, a footnote appears as a small number between one and seven in

the lower-left corner of the score cell. However, in a progress report, the full text

of the footnote appears with the score.

A B

A footnote number appears in the lower-left corner of a score cell (A) but the full text appears with
the score in a progress report (B).

To attach a footnote to a score, do one of the following:
•  Right-click (Windows) or control-click (Macintosh) on the cell and select the

footnote from a contextual menu that pops up. To delete a footnote, choose the

first item in the menu.

•  Double-click the score to open the Score Note window and select a footnote. To

delete a footnote, select the first list item.

•  Select the score and press option and a number from 1 through 7. Press option-

0 to delete a footnote. (Macintosh only.)

•  Select one or more score cells and click on a footnote in the Mini-summary

palette. If the palette is not visible, choose Show Mini-sum. from the Edit menu.

Press on the menu on the palette to display the list of footnotes. Select the first list

item to delete a footnote.

The Mini-summary window can be used to attach footnotes to scores.

In addition to score footnotes, you may attach unique and lengthy notes to scores.

You may even use notes instead of scores for special situations. The section that

follows explains how to attach notes to scores.
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To attach a note to a score:
1  Double-click on a student’s score cell or select the score cell and click the Open

Score Note tool . The Score Note window will open.

The Score Note window allows you to attach a unique, lengthy note to a score. The sample Score Cell
in the upper-left corner shows how the note alters the appearance of the score cell.

2  Use the Format menu to select one of the following:

•  Note is for teacher; footnote is for student. The footnote but not the note will

appear in a student’s progress report.

•  Note is for student. The note will appear in a student report. A footnote is not

allowed.

•  Note is for student in place of score. The note will appear in a student report in

place of a score. A footnote is not allowed.

3  Type the note or use the Clipboard tool  to paste in a note created in the

Clipboard Text view of the Gradebook Options window. See Gradebook Options:
Clipboard Text on page 47 for additional information on Clipboard text.

The sample Score Cell in the upper-left corner shows how the note alters the

appearance of the score cell. If you add a note using the first or second formats, a

small, black box appears in the upper-right corner of the cell. A footnote number

may appear in the lower-left corner. If you choose the third format, a picture of a

notebook covers the score cell indicating that a score is not allowed.
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4  (Optional) To check the spelling of the note, click the Spell button.

5  (Optional) To add a note for a different student or assignment, use the menus

and buttons at the top and bottom.

6  Click Done.

Adjusting Grades: Dropping, Extra Credit, Curving and Locking
You can raise and lower student grades by dropping scores, adding extra credit,

curving assignments and curving /locking overall grades. This section explains

how to perform these tasks.

To drop the most damaging score for each student:
1  Choose Assignment from the Chart menu.

2  In the Status column, choose Can be Dropped for one or more assignments.

Only assignments with this setting will be eligible for dropping.

3  Choose Score from the Chart menu.

Easy Grade Pro will regrade each student and drop the score that results in the

greatest improvement in the student’s overall grade. If there are two assignments

that cause the same improvement, Easy Grade Pro will drop the first. Surprisingly,

the score that is dropped is often not the lowest score because it may have too

little point value or be in a category with little weight.

When a score is dropped, a small letter d is drawn in the upper-left corner of the

score cell. As new scores are entered, the d may move about, disappear and

reappear.

FAQ: How can I drop more than one score for each student?
Because Easy Grade Pro drops scores in real time (as scores are entered) in a way that

ensures the student’s grade is improved the most, it can only drop one score automati-

cally. However, it is possible to have more than one score dropped using the Change

Scores tool. First make sure that you have at least two assignments with status of Can be

Dropped. Then choose Change Scores from the Tool menu. In the Change Scores window,

set the first menu to Dropped Score and the second menu to ‘dr’. Click Change. The small

letter ‘d’ will be replaced by the ‘dr’ and a new automatic drop calculation is made. Be

sure to note that ‘dr’ is a special score that has no value and will replace the numeric

score.
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To add extra credit, do one of the following:
•  Increase the score on any normal assignment.

•  Add a new assignment and set its status to Extra Credit. To view how extra

credit is affecting a student’s grade, see FAQ: How can I check the calculations for

one of my students? on page 94.

FAQ: I’ve added an extra credit assignment but student grades haven’t changed. Why?
This problem can occur if you are using category weighting and have a category with

extra credit assignments only. By definition, extra credit increases the number of points

earned without increasing the number of points possible. So, in your extra credit category,

a student may have 50 points of extra credit out of 0 points possible... no computer can

do this kind of math! One solution is to move the extra credit assignments to a category

with points possible. Another solution is to turn off category weighting. For more

information, see FAQ: How is a student’s overall grade calculated? on page 66.

To curve an assignment:
1  Select the assignment by clicking on its title in the score chart.

2  Choose Curve Assign. from the Tool menu or select the Curve tool . The

Curve window will open.

3  From the Curve menu, choose Create New Curve. The New Curve window will

open (shown below). Note: if you have already created a curve, you can select it

instead and skip this step.

Each row in the New Curve window corresponds to a vertical bar, or step, in the

main Curve window (shown on the next page). These bars have grade labels, such
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as A, B or C and percentage values such as 100%, 85% or 75%. Note that the

grade labels do not directly relate to grades in your grade scales -- they are merely

convenient labels for the vertical bars. The percentage values are more important:

they are used to calculate new scores for your students.

4  Decide how many steps you want in your curve. Then type the step labels in the

Grades in Curve column and the percentage values in the Value of Grades column.

Click the Create button.

5  From the Interval menu, choose the desired score interval for the graph. The

interval affects curving because all the scores in an interval are curved as a group.

6  From the Size menu, choose the desired screen width for each interval. The size

does not affect curving -- only the readability of the graph.

7  Change the distribution of grades by dragging the vertical bars left and right or

by clicking the two Shift buttons. The students to the immediate right of a bar will

get a score based on the percentage value of the bar.

8  (Optional) To show the true percent or the curved percent of any grade bar,

press on the grade label at the top of the bar. A menu will appear with options. To

see the names of students and curved percents, click on any box in the graph.

9  Click the Curve button. A new assignment column will be added to the score

chart immediately after the original assignment with scores based on the percents

in the curve scale. The original assignment will be set to Not for Grade status and

Exclude from progress reports. If desired, it can be deleted but may be kept as a

record of the original scores and can be used to re-curve the assignment later.
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To lock or curve the overall grade:
1  Choose Lock/Curve Grade from the Tool menu or click the small square after

the student's grade in the score chart. The Lock/Curve Grade window will open.

2  To lock a grade, type the new percent in the Locked/Curve% column. Typically,

this is something that is only done at the end of a term because, once a grade is

locked, it does not change even when scores are added. To change the grade scale,

press in the Grade and Scale column and choose the new scale.

3  To curve a grade, type a '+' or a '-' and the offset percent in the Locked/Curve%

column (i.e. '+5.0' or '-5.0'). The student’s grade is adjusted by the offset amount

every time it is calculated.

4  To unlock a grade or to remove a curve offset, select the percent and press the

delete key.

5  Click Done. A small +/- symbol is drawn in the score chart for a student with a

curved grade. A small padlock is drawn for a locked grade.

A small +/- symbol is drawn for a student with a curved grade. A small padlock is drawn for a locked
grade.
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Customizing the Display of your Data
You can customize the display of data in the score chart in a variety of ways.

Scores can be displayed as raw scores, percents and grades; the assignment title

region can be resized; special columns can be added with many types of data;

students, assignments and scores can be filtered so that only the items you want to

see are visible. This section explains how to customize the score chart to meet

your unique and changing needs.

To display scores as raw scores, percents or grades:
An assignment’s display of scores can be set in its record window. To override this

setting so that the scores on all assignments are displayed as raw scores, percents

or grades, use the small menu next to the intersection of the first student row and

the first assignment column shown below.

A

Press on this menu (A) to set the display of scores to raw scores, percents or grades.

To resize the assignment title region:
If your assignments’ titles are long, you can give them more room in the score

chart. If the titles are consistently short, you can take away some space so that

more student rows can be shown on your screen. To resize the column height,

press and drag the thick, horizontal line below the assignment titles up or down.

A

To resize the column height, press on the thick line below the assignment titles (A) and drag up or
down.
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To add a column to display points earned, term grades, attendance totals, special
student record information, class rank, etc.:
1  Press on the column title above the column of student names (or an adjacent

column) and, from the menu that pops up, choose Add NEW Column. A new

column with student names will appear. Note: this menu item will become

disabled if the eight-column limit has been reached.

2  Press on the new column’s title to bring up the menu again, but, this time,

choose the desired content for the column.

3  To resize the column, press on the vertical line to the right of the title and drag

left or right.

4  To move the column to a new location, press on any data beneath the column’s

title and drag left or right. Note: this does not work with the column of student

names. To move this column, drag the other columns around it.

5  To delete a column, press on the column title and choose Delete THIS Column.

A B C

To add a column or to change its content, press on the column’s title (A). To resize a column, press on
the vertical line to the right of the title (B) and drag. To move a column, press on a data cell and drag.

To show just one student or a subset of students:
•  To show only a single student, choose the student from the pop up menu

immediately above the first row number in the score chart. This enters the show

one mode in which the vertical scroll bar scrolls the students one at a time draw-

ing each in the first row. The Find tool allows you to find any student and still
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never have more than one student visible.

• To show or hide selected students, press on a student’s row number. Drag up or

down to select multiple rows. Then choose Show Selected or Hide Selected from

the View menu.

•  Choose Show All from the View menu to return to the normal view.

To show just one assignment or a subset of assignments:
•  To show a single assignment, choose the assignment from the pop up menu to

the left of the first assignment’s column number.

•  To show assignments in a single category, choose the category from the pop up

menu to the left of the first assignment’s column number.

• To show or hide selected assignments, press on an assignment’s column number.

Drag left or right to select multiple columns. Then choose Show Selected or Hide

Selected from the View menu.

•  Choose Show All from the View menu to return to the normal view.

To show missing work, failing students, blank scores, absent students, the top
10, improvers, decliners or other special groups:
Choose one of the custom filters from the View menu or from the pop up menu

immediately above the vertical scroll bar. The next section explains how to edit

the custom filters and how to create your own.

Creating Custom Filters
You can create filters to show just the students, assignments and scores you want

to see. Filters can be used in all charts but the seating chart. Before creating your

own filter, you should study the built-in filters to see how they were set up. To do

so, choose Edit filters from the View menu. In the window that appears, select a

filter and click the Edit button.

To create your own filter:

1  Open the Filters window using the Filters tool  or by choosing Edit Filters

from the View menu.

2  Click the New Filter button. The New Filter window will open.
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3  Enter a name in the Filter Name field. It will be placed in the View and Custom

Filters menus.

4  (Optional) Use the Keyboard menu to select a unique key to be used to activate

your filter.

5  Your filter may contain individual filters for students, assignments and scores.

Use the tabs to switch between these three parts. Under each tab, enter up to four

rules. The rules can be connected using and and or found in the small menus to

the left. And connects two rules so that they must both be met while or allows

either rule to be sufficient. Each rule consists of a subject and a condition that are

selected using menus. Depending on the type of condition, the rule may or may

not have an object that must be completed by typing letters or words into a text

field. Case is not important.

6  Be sure to test your filter; you may find that it needs refinement to work

properly. Note: filters have no effect on students whose status is WD (hidden).

FAQ: I have a group of students (or just one student) with unique assignments. How can I create a filter
to show just this group and its assignments?
The first step is to come up with a code for this group, such as RED. Choose Assignment

from the Chart menu and put the code into the Note field of each assignment’s record.

Choose Student from the Chart menu and put the code into one of the twelve custom

fields of each student’s record. Now, create a filter that shows students with the code in

the custom field and that shows assignments with the code in the Note field. If you have

multiple groups of students and assignments in your class, you can create a filter for each

group.
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Although the score chart is the most comprehensive of the five charts, the atten-

dance, seating, student and assignment charts share many of its tools and offer a

variety of new ones to help you manage your student data. This chapter describes

the unique features of these charts. Be sure to refer to Chapter 6, Using the Score

Chart for explanations of tools shared by the charts. To view any chart, use the

items in the Chart menu.

The Attendance Chart
The attendance chart allows you to record attendance data for a single term.
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To use the attendance chart:
•  Attendance and calendar options must be set before using the attendance chart.

Color options may also be set for your attendance categories. Refer to Chapter 4,

Setting Options for help with this.

•  Each column of the chart represents a single date in the calendar for the class.

Column numbers indicate the day numbers into the term. No-school days are

grayed and cannot be selected.

•  To filter the dates displayed in the chart, use the menu to the left of the first

column number. You can choose between showing all days, the current day,

current week, current month or a selected range of dates. If the current day, week

or month is selected, the actual dates will automatically change at the right times.

•  To quickly hide all dates but one, click on the date. When only one date is

visible, use the horizontal scroll bar to scroll through all dates while keeping only

a single date visible at a time. To return to the normal view, click the date again.

•  To resize the space for the date titles, press and drag the thick, horizontal line

below the titles up or down.

•  Be sure to display the attendance codes on the tool bar or tool palette. This lets

you know what marks can be typed and allows you to enter marks by clicking. To

display these codes, press on the small triangle to the left of the class menu.

Click on the triangle (circled above) to show the row of attendance marks..

•  To add a note to an attendance mark, double-click on a cell to open the student

note view of the Summaries window. You may find it helpful to press on the

Clipboard tool in this window and choose • Attendance Note ([Date: MO/DY/

YEAR]). This text will be pasted into the text field with the actual date.

•  Attendance can be exported over you school’s network. Refer to the section

Exporting Attendance on page 133 for information on this.

•  To print the attendance chart, choose Print from the File menu. Under the
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Chart tab, select and print the Attendance Chart report.

•  To combine attendance data from multiple terms, refer to Chapter 10, Working

with Terms.

The Seating Chart
You can set up a seating chart to match your classroom, furniture included. Once

set up, attendance can be taken directly from the chart.

To set up a seating chart:
•  To set the shape, size, name format and attendance format of all seats in a class,

use the Seat options in the Class Options window. Refer to page 40 for help.

•  The first time the seating chart is viewed for a class, Easy Grade Pro places the

first 128 students into seats using a built-in arrangement.

•  To move any seat, press and drag it to the desired location. To move a group of

seats, first select the seats by clicking on each while holding down the shift key or

drag a rectangle that encloses or touches the seats. To move the group, press on

one and drag. To deselect all selected seats, click on any empty place.

•  To swap two students, drag the first seat on top of the other. If one seat is
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rotated and the other is not, be sure to drag the upper-left corner of the first seat

to the upper-left corner of the second. Swapping also works on groups of seats.

•  To set the color, rotation or locked status of an individual seat, double-click on

the seat.  A seat that is locked cannot be moved or sorted.

•  To sort your students into the seats, choose Sort Seats from the View menu and

select one of the patterns. To randomize your students, click the Sort tool  or

choose Randomly from the View menu.

•  To add furniture, choose Add Furniture from the Tool menu or click the Add

Furniture tool . If this tool is not visible, press on any tool or empty tool

location and hold the mouse down for at least a second. From the menu that pops

up, choose the tool.

•  To change the size of a piece of furniture, drag the small rectangle in the lower

corner. To set the format, rotation or name, double-click on the item. The Furni-

ture Options window will open.

•  Furniture can be copied and pasted using Copy and Paste in the Edit menu. To

delete an item, select it and click the Delete tool  or press the delete key.

•  The structure of a seating chart and its furniture can be copied to and from

other classes. Choose Copy Seats from the Tool menu and follow the prompts.

When furniture is copied from one class to another, it always replaces any furni-

ture that the class may already have.

•  To print the seating chart, choose Print from the File menu. Under the Chart

tab, select and print the Seating Chart report.

To take attendance using the seating chart:
•  Attendance and calendar options must be set before using the attendance chart.

Refer to Chapter 4, Setting Options for help with this.

•  The current date, if it is within the calendar for the class, will be displayed in the

lower-left corner of the window. Use the Set, ‘+’ and ‘-’ buttons to switch to other

dates. If the date is not the current date, it will be grayed. Attendance can be taken

on any day in the calendar.
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•  To record attendance, press on the menu in the seat and select a mark, or select

one or more seats and click on an attendance code on the tool bar or palette.

•  Attendance can be exported over you school’s network. Refer to the section

Exporting Attendance on page 133 for information on this.

FAQ: How can I easily see who was absent on a certain day when entering scores in my score chart?
There are two built-in filters to help with this. Select Show Absent from the View menu.

All students will be hidden except for those absent on the selected date. Perhaps you can

then enter a score of ‘ab’ for the first student and use the Fill Down tool for the rest. To

reverse the display of students, select Hide Absent from the View menu. Note: since your

attendance codes may be different from those used by these filters, you may need to edit

the filters. See Creating Custom Filters on page 75 for help with this.

The Student and Assignment Charts
The student and assignment charts have a lot in common with the Records

window: both display virtually the same information. While the Records window

displays one record at a time, the charts can display all records together making

them easier to view and manipulate. The charts also offer a variety of tools not

available in the Records window such as fill down, copy, paste, find and filters.
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To use the student and assignment charts:
•  The columns in these charts correspond to the fields in the Records window.

•  Data can be entered into any cell except in the first column with names. Many

of the fields bring up menus when selected.

•  To change the order of the columns, press on a column’s title and drag the

column left or right to the desired location.

•  To change the width of a column, move the cursor until it is over the vertical

line to the right of a column title. Press on the line and drag the line to the desired

location.

•  To view the record for any row, double-click on the row.

•  To rename any of the twelve custom field columns in the student chart, double-

click on the row and edit the Custom Labels.

•  As with the score chart, you can use filters, dragging of rows, find, fill down, and

cut, copy and paste on rows and columns.

•  The last six columns of the student chart can be used to enter comment num-

bers. Although it is easier to enter student comments in the Summaries window,

the student chart can be used to view and edit groups of comments.

FAQ: I understand how Easy Grade Pro calculates but the overall grade seems wrong. What should I do?
The very first thing to do is to choose Assignment from the Chart menu and check out the

settings for your assignments. Check the Max. Score and Points columns and, if you use

category weighting, check the Category column. Perhaps you have Points set to 1000

when you intended 100 or have some other unintended setting that is throwing off the

calculations. If this doesn’t solve the problem, check out FAQ: How is a student’s overall

grade calculated? on page 66, FAQ: How can I check the calculations for one of my

students? on page 94 and FAQ: What are maximum score and points? How should I set

them? on page 57.



Making and
Managing Backups8

Why you Should have a Backup Plan
Anyone who has used a computer for long knows that computers are susceptible

to all sorts of problems: software conflicts, corrupted memory, damaged floppy

disks, network glitches, hardware breakdowns, user errors and more. Problems

may be inevitable but the quick and stress-free recovery from problems can only

be guaranteed if there is a good backup plan in place and it is followed without

exception.

Many computer users maintain only a single backup copy. This is risky behavior!

If the backup is stored on the same computer as the original, both files could be

lost if the hard drive crashes or the computer is stolen. Even if the backup is

stored apart from the original, there could be problems if the backup was made

after an undetected problem occurred.

If you have responsibility for reporting student data to others, there will be times

during the year in which you must have access to your Easy Grade Pro data.

Imagine a problem occurring during one of those times... if you follow a good

backup plan, the solution will be painless!

In the next section, we present a plan for making and managing backups of your

gradebook data. You are strongly encouraged to follow this plan or some other

comprehensive plan for securing your gradebook data.

A Three-part Plan for Securing your Student Data
For greatest security it is best to make backups of your student data in different

ways and at different locations. Here is a three-part plan that might work for you:
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•  Part 1: Daily Backups. Create a folder on your computer’s hard drive, server or

convenient volume. Make a copy of your gradebook every day to the folder. Use

the name of the day of the week for your backup (Monday, Tuesday, etc.) and let

one day’s backup replace the backup from the prior week.

•  Part 2: Weekly Archived Backups. Get a box of floppy disks or other removable

media. Once a week, save a copy of your gradebook to a disk and store it at a

different site. Do not erase a backup until after the school year has ended.

•  Part 3: Biweekly Reports. Print score and attendance chart reports for each

current class on a biweekly basis. Store these away from your archived backups.

How to Make a Backup
1  By default, Easy Grade Pro prompts you to make a backup copy whenever you

close or quit. When this happens, click the Yes button. Alternately, you can choose

Save Copy from the File menu or select the Save Copy tool .

2  In the window that opens, set the name of the backup. The default backup

name is Copy of ‘gradebook name’ (on Windows) or ‘gradebook name’ copy (on

Macintosh). If you are following Part 1 in the three-part plan outline above, name

the backup for the day of the week.

3  Set the location for the backup to a folder created for backups or some other
location set aside for your backups.

4  Click the Save button.

FAQ: My gradebook’s name is ‘Copy of copy of...’. What is going on?
Many programs prompt you to save your changes when you quit. However, with Easy

Grade Pro, since all changes are saved automatically, it prompts you to make a backup

copy of your gradebook and suggests a name of ‘Copy of gradebook name’ (Windows). If

you have a gradebook with a ‘Copy of copy of...’ in its name, it means you are opening

and using your backup copies instead of your main gradebook. A backup copy of a

gradebook is like an insurance policy -- it’s something that you hope you never have to

use. Don’t get your gradebook and its backup copies confused, and don’t work on a

backup of your gradebook unless there is a good reason. For more information on this, see

FAQ: Easy Grade Pro saves automatically. What does this mean? on page 26.
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and School9

If you would like to use your Easy Grade Pro gradebook on computers at both

school and home, this chapter is for you. It explains how to transfer your grade-

book from one computer to another using email or a floppy disk, even if the

computers are of different platforms (Macintosh and Windows).

Using an Easy Grade Pro gradebook at two locations is similar to using a paper

gradebook at two locations: in both cases, you have to move the gradebook back

and forth. There is, however, a fundamental difference that can cause problems if

you’re not careful. When transferring an Easy Grade Pro gradebook using email

or a disk, you’ll be leaving behind a copy so that both computers have identical

gradebooks at first. Once you make changes to one of the gradebooks, it becomes

your current one turning the other into nothing more than a recent backup. Be

careful to work only with the current gradebook and to transfer it before working

at a different location. Otherwise, you may find yourself with two gradebooks in

which neither is current forcing you to retype data into one of them.

You may be tempted to use your gradebook directly from a floppy disk to avoid

this problem. Don’t do this! Floppy disks are too unreliable to be trusted with

such important data.

Getting Started
1  Make sure that you have Easy Grade Pro installed on both computers and that

they have the same version number (i.e. v3.6.1). To find the version, choose About

Easy Grade Pro from the Apple (Macintosh) or Help (Windows) menu.

2  If your gradebook is on a Windows computer, we recommend that you move it

to the Desktop or some other convenient location so that you’ll have easy access to
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it. To move it, press on its icon and drag. If you don’t know where your

gradebook’s icon is, try looking at this path: C:\Program Files\Orbis

Software\Easy Grade Pro. Its name ends with ‘.egp’.

3  If you’ll be transferring the gradebook from a Macintosh, you may have to

rename it so that it ends with an ‘.egp’ (i.e. My Gradebook.egp). Rename it if 1) you

will be transferring it to a Windows computer or 2) you will be transferring it to

another Macintosh using email.

4  If you’ll be transferring the gradebook to a Macintosh, you may have to set the

receiving computer’s File Exchange control panel so it identifies a file with ‘.egp’ as

an Easy Grade Pro gradebook. Do this if 1) you will be transferring it from a

Windows computer or 2) you will be transferring it from another Macintosh

using email. To set this, open the File (or PC ) Exchange Control Panel and click

the Add button. In the window that opens, type egp into the Extensions field and

select Easy Grade Pro 3.6 from the list.

A
B

Click the Add button in the File Exchange control panel (A). In the Add Mapping window
(B), type ‘egp’ and select Easy Grade Pro 3.6 from the list.

5  (Optional) If your gradebook file is large, you may want to compress it to

minimize emailing time or to enable it to fit on a floppy disk. To compress a

gradebook, open it in Easy Grade Pro and choose Compress from the File menu.
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Using Email to Transfer a Gradebook
1  Start your email program. Create a new email and address it to an account

accessible from the other computer. Click the Attach button or choose Attach

from the appropriate menu. Navigate to your gradebook and select it.

2  If both of your computers are Macintosh and if your email program allows you

to set the encoding method, set it to BinHex or some other Macintosh-friendly

method. This can help minimize problems.

3  Send your email.

4  On the receiving computer, start your email program and find the attached

gradebook. Select it, choose Save and save the gradebook to the Desktop or to a

folder set up for your gradebook. Quit your email program.

5  To start your gradebook, find its icon on the Desktop or in the folder and

double-click on it. This will ensure that you are opening the right gradebook. If

this doesn’t work, start Easy Grade Pro directly. If the wrong gradebook opens,

choose Close from the File menu. Then click the Open an Existing Gradebook

button and open the gradebook. Make sure you are using the right gradebook!

Using a Floppy Disk to Transfer a Gradebook
1  Insert a floppy disk it into the computer. If you will be transferring the grade-

book to a Windows computer, make sure that you are using a PC-formatted

floppy disk even if the gradebook is being transferred from a Macintosh.

2  To ensure that the floppy disk is in good shape, we recommend that you

occasionally reformat it. Windows:  Right-click on the A-drive icon and choose

Format. Macintosh: Select the icon of the floppy disk and choose Erase Disk from

the Special menu; if you will be transferring the gradebook to a Windows com-

puter, be sure to format the disk using a PC/DOS format.

3  Copy the gradebook to the floppy disk. Windows:  Right-click on the

gradebook’s icon and choose Copy. Right-click on the A-drive icon and choose

Paste. Macintosh: Drag the gradebook’s icon to the icon of the floppy disk.

4  Eject the floppy disk and insert it into the other computer’s drive.

5  Copy the gradebook from the floppy disk. Windows:  Double-click on the A-
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drive’s icon to open a window to the floppy disk. Right-click on the gradebook’s

icon and choose Copy. Right-click on the folder on the hard drive to receive the

gradebook or right-click on an empty place on the Desktop and choose Paste.

Macintosh: Double-click on the icon of the floppy disk. Drag the icon of the

gradebook to the folder on the hard drive to receive the gradebook. Do not drag

the gradebook to the Desktop because the Desktop belongs to all disks, including

the floppy disk.

6  Eject the floppy disk.

7  To start your gradebook, double-click on its icon. This will ensure that you are

opening the right gradebook. If this doesn’t work, start Easy Grade Pro directly. If

the wrong gradebook opens, choose Close from the File menu. Then click the

Open an Existing Gradebook button and open the gradebook. Make sure you are

using the right gradebook!

FAQ: Why am I getting disk error messages when copying to and from floppy disks?
Floppy disks are prone to a variety of problems, especially when used with two or more

computers. At the first sign of trouble, toss the floppy disk and get a new one.

Working Cross Platform
Easy Grade Pro 3.6 for Macintosh and for Windows can share gradebooks easily

and seamlessly but there are a few platform-specific differences that you should be

aware of as follows:

•  Different characters are found in fonts. Some characters on the Macintosh, such

as the check mark, are not available in Windows and vice versa.

•  Menu item terminology, keyboard keys and highlight colors have some plat-

form-specific differences.

•  Easy Grade Pro for Macintosh saves all Page Setup (orientation, paper type,

scaling, etc.) options. Easy Grade Pro for Windows does not; you will need to reset

any non-default page setup options each time you print.

•  Macintosh printers typically allow scaling. Since fewer Windows printers offer

this, Easy Grade Pro for Windows allows smaller typefaces in reports and allows

right-clicking in the print preview window to select from multiple zoom levels.

•  Easy Grade Pro for Windows offers status bar help and automatic reopening of

the last gradebook. Easy Grade Pro for Macintosh offers balloon help.
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If you teach a class that continues with the same students from one term to the

next, then this chapter is for you. It explains the simple process of starting a new

term for an existing class in your gradebook. It also explains the more complex

process of combining student grades and attendance data from classes in different

terms to produce multi-term totals.

If you need to add a new class to your gradebook -- new meaning a class with new

students or new course-section numbers -- you don’t need this chapter. Instead,

take a look at the section To add a class on page 28.

Starting a New Term
Although you can start a new term at any time, we recommend that you wait until

the end of a term to do so. This will help minimize the number of changes that

may need to be made to your roster, seating chart and options in the new term.

To start a new term for a class:
1  Switch to the class.

2  From the Tool menu, choose Term Tools->Start New Term. Easy Grade Pro will

automatically put a check or x for the appropriate term in the Records window for

the class. It will then switch to the new term and copy the students to it.

3  To set the calendar or edit other class options, click the View/Edit Class Options

button in the window that automatically appears.

To edit the term label for a term:

1  Choose Records from the Chart menu or click the Records tool .

2  Select the Classes tab.

3  Edit the name of the term. This change applies to all classes in a gradebook.
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To add the Prior Term  and Next Term  buttons to the tool bar:

These tools can make it easier to switch back and forth between terms.

1  Press on any tool or empty tool location and hold the mouse down for at least a

second. From the menu that pops up, choose the Prior Term tool.

2  Repeat the process to add the Next Term tool.

3  To relocate any tool, press and drag (quickly) the tool to the desired location.

Combining Terms (Class Options: Term)
At any time, you can combine your students’ grade and attendance data from two

or more terms to produce multi-term totals. Once combined, you can view

summaries and print reports that include the totals and individual term data.

To set or edit term options:
1  Switch to a class in your current term.

2  Choose Term Tools->Combine Terms from the Tool menu. The Term view of

the Class Options window will open (shown above).

3  You must decide to combine your term data using weights or points. Select

weights if you want each term to have a set value. Don’t use this method unless

you are at or near the end of the current term because temporary grade distor-

tions can occur when the current term has only a few assignments. Select points if

you want the terms to be combined by summing all the points that a student has

earned.  This option is not available if any of the classes being combined uses
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category weighting.

4  Choose to match the students across classes by ID or name. Each student’s ID

number or name must be completely identical in all terms.

5  Carefully select the prior-term classes by pressing on one or more menus below

the name of the current class. When selecting classes, you must choose between

combining the term or the overall grade. In most cases, you should choose Term.

However, if one of the classes you are combining has term options set in it, you

may want to choose Overall instead.

Here is an example to explain the difference between Term and Overall. Let’s say

your gradebook has five terms as follows: Quarter 1, Quarter 2, Quarter 3, Quar-

ter 4 and Year. In the Quarter 2 class, you combine Term grades from Quarters 1

and 2. In the Quarter 4 class, you combine Term grades from Quarters 3 and 4. In

the Year class, you could combine Term grades from Quarters 1, 2, 3 and 4 but you

could, instead, combine Overall grades from Quarters 2 and 4.

6  If you have selected Combine grades using weights, enter the term weights in the

Weights column. They must sum to 100%.

7  Click Done. Easy Grade Pro will go to each of the prior-term classes and try to

match the students. Whenever a match is found, the student’s points, grade and

attendance totals for that term are copied to and combined with the current class.

A window will appear listing any students that could not be found in prior terms.

Questions about Combining Terms
What do I do when a student didn’t match when combining terms but should have?
In most cases, the problem occurs because the student’s name or ID number in

the prior-term class is different. Correct this and then, from the current-term

class, choose Term Tools->Recombine Terms from the Tool menu. Easy Grade Pro

will start the process over and, again, let you know who hasn’t matched.

How often do I need to combine terms? How do I recombine terms?
Generally, you will combine terms only once for a class. However, if you make any

changes to grades or attendance data in any of the prior term classes, you must

recombine the terms to copy the updated data into your current term. To recombine

the data, choose Term Tools->Recombine Terms from the Tool menu.
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How do I un-combine terms?
You may occasionally want to combine terms just long enough to print certain

reports. To later un-combine terms, choose Term Tools->Combine Terms from

the Tools menu. Press on each prior term class listed in this window and choose

None in the menu that appears. When you exit from this window, your class will

be un-combined.

How is a class changed by using combine term options?
After combining, the Overall grades and attendance totals found in charts, in

summaries and in reports reflect all combined terms. Many reports and summa-

ries will display multi-term data automatically or as an option. In the score and

attendance charts, special columns can be added to display data from individual

terms. (See page 74 for information on adding special data columns.)

FAQ: I’ve combined terms but the prior-term grades or attendance data in reports are wrong. How do I
fix this?
This problem occurs if you change grades or attendance marks in a prior-term class after

you’ve combined its data with your current-term class. To fix this, choose Term Tools-

>Recombine Terms from the Tool menu. This will copy the changed data to your current-

term class.

FAQ: I need to print reports that show grades from multiple terms but I don’t want the grades to be
combined to form a multi-term overall grade. What do I do?
 Choose Term Tools->Combine Terms from the Tool menu. In the Term view of the Class

Options window, combine your terms using weights, but set the term weights to 100% for

the current term class and 0% for all the prior-term classes.

FAQ: I have to include a weighted final exam. What do I do?
When a final exam must be weighted with one or more other terms, the final exam

should be treated in the same way as the other terms. As an example, you might set up

your terms in the Records window as follows: Semester 1, Semester 2 and Final Exam.

Your Final Exam will actually be a separate class within your gradebook. From within

the Final Exam Class, you might set the combine term options as follows: Semester 1 -

40%, Semester 2 - 40% and Final Exam - 20%. The overall grades will be found in the

Final Exam class.



Using Summaries11
Easy Grade Pro provides two powerful tools for analysis of student performance:

the Summaries window and the Mini-Summary window. This chapter explains

how to utilize these windows.

Using the Summaries Window
The Summaries window can be a tremendous aid in your efforts to identify and

meet the needs of your students. Its eleven views with graphs, charts, calendars,

notes and comments can help you understand your students’ strengths, weak-

nesses and changes in performance over time.

To open the Summaries window, do one of the following:
•  Select Summaries from the Chart menu.

•  Click the Summaries tool . To view the summary of a specific student or

assignment, select the item first and then click this tool.

•  Double-click a row or column number in any chart (except the seating chart).

•  Right-click (Windows) or control-click (Macintosh) on a student or assignment

name and choose View Summary from the menu that pops up.

Use the tabs at the top of the window to switch between the different views. Use

the menus and buttons below to switch students, classes and assignments.

Student Summaries
There are five student views in the Summaries window. These are described next.

  Student Graph. This view displays a line graph of student performance in
different categories over time. To print the graph, print a student progress report

with the Summary Graph option on.
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  Student Grades. This view displays a complete breakdown of student perfor-
mance with scores, points, percents and grades by assignment, category, term and

overall. This view can be very helpful as the FAQ that follows describes.

FAQ: How can I check the calculations for one of my students?
The Summaries window can help you check all the calculations that go into computing

the overall grade for a student. To open this window, double-click on the student’s row

number and click on the percent tab to view the Student Grades view. To print the data,

print a student progress report with the Grade Summary Chart and Assignment Chart

options on. To include Points, click the Set button after each option and turn on Points.

For a related topic, see FAQ: How is a student’s overall grade calculated? on page 66.
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  Student Attendance. This view displays calendars with attendance codes and a
list of attendance totals by category and term. To print the graph, turn on the

Attendance Summary Graph option in a student’s progress report.

  Student Notes. This view allows you to enter notes to document events and

summarize performance. Type the note or use the Clipboard tool  to paste in

a note created in the Clipboard Text view of the Gradebook Options window. See
Gradebook Options: Clipboard Text on page 47 for additional information. To spell

check the note, click the Spell button. To print the note, turn on the Summary

Notes option in a student’s progress report or print the Student Notes report.
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  Student Comments. Use this view to apply comments to students for progress

reports and grade export files. There are two lists in this view: the upper list

displays the comments that have been applied to a student and the lower list

displays the available comments.

To edit the list of comments:
To sort or edit the comments, press on the blue pop up menu above the lower list.

To insert the student’s first name into a comment, use the ^ symbol. An addi-

tional item in the menu allows you to create a plug-in of the list to make it easy to

distribute it to others. For additional information, see Using Plug-ins on page 138.

To change the order of comments, press on a comment number and drag.

To apply and remove comments:
To apply a comment, click the item in the lower list. Up to six comments can be

applied. To remove a comment, click the comment’s number in the upper list. Use

the small menu above the upper list to erase comments, copy comments from the

prior term or copy comments to all students in the class.

To have comments automatically selected:
To automatically apply up to six comments, click the Auto-Select button. Easy

Grade Pro will select the comments and add them to the upper list. Be sure to

check them to ensure that the comments are appropriate. If necessary, click a

comment number to remove it from the list. To set the rules for the automatic

selection of comments, use the small menu above the upper list and choose Edit
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Auto-select comments. The Auto-select Comments window will open where the

rules for the automatic selection can be entered. There are six tabs and, under

each, you can set up to four rules and assign a comment to each rule. While

designing your rules, keep in mind that Easy Grade Pro will select a comment

based on the first rule that is true for a student.

Class Summaries
There are four class views in the Summaries window as follows:

  Class Graph. This view displays a bar graph of overall grades. To see the
students that a bar represents, press on the bar; a list of students will appear. To

print the graphs, print the Class Graphs report.
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  Class Grades. This view displays a complete list of students with overall
points, percents and grades for a class. The list is ranked from highest to lowest

average and provides some statistical information at the bottom. To print the list,

print the Class Summary report.

  Class Attendance. This view displays student attendance totals by category and
term. Use the View menu to set the attendance category to be displayed. To print

the list, print the Attendance Summary report.
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  Class Notes. This view allows you to enter notes to document general events
in the class. These notes are for your eyes only. Type the note or use the Clipboard

tool  to paste in a note created in the Clipboard Text view of the Gradebook

Options window. See Gradebook Options: Clipboard Text on page 47 for additional
information. To spell check the note, click the Spell button. To print the note,

print the Class Notes report.

Assignment Summaries
There are two assignment views in the Summaries window as follows:

  Assignment Graph. This view, like the Class Graph view, displays a bar graph
of grades on an assignment. To see the students that a bar represents, press on the

bar; a list of students will appear. To print the graphs, print the Assignment

Graphs report.

  Assignment Grades. This view, like the Class Grades view, displays a list of
students with points, percents and grades for the assignment. The list is ranked

from highest to lowest average and provides some statistical information at the

bottom. To print the list, print the Assignment Summary report.
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Using the Mini-Summary Window
The Mini-Summary window can display graphs and lists while you are working in

any of the five charts. It can also be used to attach footnotes to scores and show

score notes in the score chart.

To make the summary window visible, choose Show Mini-Summary from the

Edit menu. Select the item again to hide it. The small menu in the upper-left

corner of the window can be used to switch between the seven views. These

include Class Graph, Assignment Graph, Student Graph, Student Grades, Student

Attendance, Score Footnotes and Score Notes.

B

C D

E F

G

A

The views of the Mini-Summary include: A) Class Graph, B) Assignment Graph, C)
Student Graph, D) Student Grades, E) Student Attendance, F) Score Footnotes and G)
Score Text.
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Easy Grade Pro offers nineteen comprehensive reports. Regardless of the report,

you’ll follow the same steps when printing: select the report, set options, preview

and then print. This chapter begins by explaining this process in general. It then

describes each of the reports.

Using the Print Windows
1  Choose Print from the File menu or click the Print tool . The Print Reports

window will open.

2  Select the appropriate tab, Student, Chart or Other, based on the report that you

would like to print.

3  Enter the teacher or school name at the bottom of the window. This name will

appear near the top of each report.

4  To customize the labels used in Student reports, click the Labels button. For

more information, see Gradebook Options: Report Labels on page 48.
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5  Select a report and click Next. The Report Options window will open where

options for the report can be set. Each report has its own Report Options window.

To get a description of an option, click on the Help tool .

6  Use the buttons in the upper half to select the range of reports. Use the items in

the lower half to set options for the reports.

FAQ: How can I maximize the columns on each page?
To maximize the number of columns that will fit on a page, use the Page/Print Setup

options to set the orientation to landscape view (sideways) and the scale to between 60%

and 80%. If your printer doesn’t support scaling, set the font size to a small value.

7  To preview the reports, click the Preview button. Previewing a report before

printing is a good way to learn how certain options affect a report and helps

ensure that a report fits on a page in the desired manner.

The preview window has two views: fit-in-screen and full-size. The fit-in-screen

view shows the entire page and the cursor is a magnifying glass. By clicking on

any part of the page, the view switches to the full-size view and the cursor be-

comes a hand. By pressing the mouse button, the page can be dragged about.

Double-clicking causes the view to change to the original view. The Zoom button

can also be used to toggle between the two views. Your can right-click anyplace on

a page to choose from different zoom levels (Windows only).
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8  Select Print or ePrint. Select Print to print paper reports. The Print window for
your type of printer will open where you can set some final print options and
begin printing. Select ePrint if you want to save each page as a file to be used in a
graphics or presentation program. Each report page will be saved as a separate file
in PICT format (Macintosh) or BMP format (Windows). Be sure to create a new
folder to hold all the files.

FAQ: How to I print multiple reports per sheet of paper?
Many printers today allow you to choose the number of pages to be printed on each sheet

of paper. They do this by shrinking each page the correct amount and placing the pages at

different locations on the paper. These options are known as layout options and can be

found in the print window that appears after you click the Print button.

FAQ: How do I change the teacher or school name that appears on reports?
Site license version: The school’s name is entered into the program when it is first used. It

can only be changed by reinstalling the program. The teacher’s name can be changed in

the Print Reports window. Single-user license version: The teacher’s name is entered into

the program when it is first used. It can only be changed by reinstalling the program. The

school’s name can be changed in the Print Reports window. Note: it is safe to reinstall

Easy Grade Pro without losing any data as long as your gradebook is not named Demo

Gradebook or Demo.egp.
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Student Reports: Multi- and Single-class Progress
Use the multi-class and single-class progress reports to report student informa-

tion to parents, students and for student folders. The multi-class progress report

includes information about a student in multiple classes or subjects; the single-

class report includes information on a single class only.

         

Major Report Options:
• To customize the labels used in a student report, click the Labels button in the

main Print Reports window.

• Grades menu. Use this menu to set the display of grades throughout the report

as percents only, grades only or both.

• Custom Student title. To include a title with up to four lines of custom student

data (i.e. class rank, overall grade, phone number), select this item. Click the set

button to select the items. If you include an overall grade in a multi-class report,

Easy Grade Pro calculates a weighted average based on the class weights in the

Classes view of the Records window.

• Intro & Postscript Text. To include a message, signature line, explanation or other

text at the top and bottom of each report, select this item. To view or edit the text,

click the set button.

• Grade Summary Chart. To include a chart with overall, category and other data

from the Student Grades view of the Summaries window, select this item. To set

the content of the chart, click the set button.

• Assignment Chart. To include a chart with assignment data, select this item. To
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control which assignments and data are included, click the set button. If you

choose to include Displayed assignments only, be sure to use items in the main

View menu to display the desired items before starting the print process.

• Summary Graph. Select this to include the line graph from the Student Graph

view of the Summaries window. To set the lines and colors, click the set button.

• Attendance Summary. Select this to include the data from the Student Atten-

dance view of the Summaries window. You can include a chart, calendars and a

list of attendance dates. To set options for this summary, click the set button.

• Summary Notes. To include the notes from the Student Notes view of the Sum-

maries window, select this item.

• Comments. To include the comments from the Student Comments view of the

Summaries window, select this item. Select w/Class Name to include the name of

the class at the beginning of each comment. (multi-class only)

• Blank Comment Lines. Select this to include blank lines for handwritten com-

ments for the teacher or parents. Be sure to set the number of lines.

• Selected Classes Only (multi-class only). To limit the classes in a report, select this

item. If not selected, Easy Grade Pro will use the first eighteen occurrences of a

student in current-term classes. To select the classes, click the set button.

• Match by... (multi-class only). Use this item to choose how students are matched

in the different classes.

• Students> ?? < ?? (single-class only). Use this item to exclude reports except for

students whose overall grades fall within the percents in the boxes. One use of this

option is to print reports only for students who are at risk of failing.

FAQ: How can I get a progress report to fit on a single sheet of paper?
One way to shorten a progress report is to limit the number of assignments that are

included. There are two common ways to do this: 1) in the options window for a progress

report, click the set button after the Assignment Chart option, choose Assignments on or

after-> from the Include menu and set a date on the calendar; 2) in the score chart, use

items in the View menu to hide some of the assignments; in the options window for a

progress report, click the set button after the Assignment Chart option and choose

Displayed Assignments Only from the Include menu.

FAQ: Some assignments are not showing up in progress reports. How do I fix this?
From the Chart menu, choose Assignment. Find the column labeled Progress Report.

Make sure you don’t have this field set to Exclude on assignments to be included.



CHAPTER 12: Printing Reports106

FAQ: Why are classes missing on a student’s multi-class progress report? Why am I getting two different
multi-class progress reports for a student, each with different classes?
The student’s name or ID number is different in the different class(es). Correct the name

or ID number and print again.

FAQ: How do I remove the Overall column in a multi-class progress report?
If you have combined two or more terms, the multi-class progress report automatically

includes columns for each term and for the overall grade. If you want to include indi-

vidual term grades but not the overall column, combine your terms using weights of 0%

for each prior term class and 100% for the current term class. Also, do not curve or lock

the overall grade for any student in any current term class. Under these conditions, Easy

Grade Pro will automatically omit the Overall column.

FAQ: How can I use the multi-class progress report as a report card for multiple teachers’ grades?
First create a master gradebook that contains gradebooks from multiple teachers. To do

so, start a new gradebook. When a window appears stating that the gradebook has no

classes, click the Import button (or choose Import from the File menu). Under the Built-

in Formats tab, select Combine Gradebooks and click Next. In the window that appears,

select one of the gradebooks and click Open. In a matter of seconds, all classes in the other

gradebook will be imported in the master gradebook. Continue using the Combine

Gradebooks format until all gradebooks have been imported. Print reports. It is impor-

tant that the students’ names or ID numbers are identical in all teachers’ gradebooks.

Note: there is a 250 class limit for a gradebook which means that you can typically

combine up to ten gradebooks.

FAQ: How do I show points in a progress report?
In the options window for a progress report, click the set button after the Grade Summary

Chart option and turn on Points Earned. Click the set button after the Assignment Chart

option and turn on Points Earned.

FAQ: How can I use a progress report as a missing work report? ...as an attendance report?
In the options window for a progress report, turn on the Assignment Chart item, click the

set button after this item and choose Missing Assignments Only from the Include menu.

For an attendance report, turn on the Attendance Summary item, click the set button

after this item to select the desired attendance items. Click the Labels button in the main

Print Reports window to change the title of the report.
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Student Reports: Missing Work
Use the student missing work report to print a list of assignments for which a

student has scores that count as missing. See Class Options: Special Score on page

36 for information on scores that counts as missing. Keep in mind that blank

scores do not count as missing. To change blank score to scores that count as

missing, see To convert blank cells to a certain score on page 65.

           

Major Report Options:
• To customize the labels used in a student report, click the Labels button in the

main Print Reports window.

• Style. Select single class if a student’s report should include missing work for one

class only. Select multi-class if a student’s report should include missing work

from all current-term classes.

• Custom Student title. To include a title with up to four lines of custom student

data (i.e. class rank, overall grade, phone number), select this item. Click the set

button to set the items.

• Intro & Postscript Text. To include a message, signature line, explanation or other

text at the top and bottom of each report, select this item. To view or edit the text,

click the set button.

• Include ALL students. To print a report for every student, whether the student

has missing work or not, select this item.

• Include only if on or after date. To filter out older missing assignments, select this

item and set a cutoff date on the calendar to filter out older assignments.
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FAQ: Many reports allow me to choose ‘Displayed Only’ for students, assignments or dates. What does
this mean and how do I use this option?
Easy Grade Pro allows you to show and hide students, assignments and dates in the

onscreen score, attendance, student and assignment charts using items in the View menu

and special pop up menus in the charts.

When you print certain reports, you have the option of including all students, assign-

ments and dates or just the ones ‘displayed’ in the onscreen charts. For more information

on this topic, see the section Customizing the Display of your Data on pages 73-75.

Chart Reports: Score Chart
The score chart report mirrors the onscreen score chart. It can be used for storing

grade information, for recording grades on paper and as a wall poster for display-

ing grades. Options in the report allow you to sort students in different ways and

display them by name or ID. You can add blank columns and rows. You can

include column statistics, a key for footnotes and print the scores in color.

If the report is to be used for recording grades, set the Assignments option to

Include none, and turn on Include x blank columns at right. To use it as a poster, set

the Students option to ID only and the Sort option to by ID or Randomly. To

minimize the paper used, see FAQ: How can I maximize the columns on each page?

on page 102.
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Chart Reports: Attendance Chart
The attendance chart report mirrors the onscreen attendance chart. It can be used

for storing attendance information and for recording attendance data on paper.

Options in the report allow you to control which students and dates are included.

You can include a key for codes and print the codes in color. To minimize the

paper used, see FAQ: How can I maximize the columns on each page? on page 102.

    

Chart Reports: Seating Chart
The seating chart report mirrors the onscreen seating chart. In can be used for

reference and for recording attendance. Options in the report allow you to frame

each page, include furniture and print in color. To ensure that your chart fits on a

single sheet, use the Page/Print Setup options to set the orientation and the scale.

If your printer doesn’t support scaling, set the font size to a value so that the

report fills but does not exceed the page.
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Chart Reports: Student and Assignment Charts
These reports mirror the onscreen student and assignment charts. They can be

used for archiving record information and for creating specialty reports for book

numbers, phone number, addresses, etc. Options allow you to set the content of

the columns and to set a title for the report. To set the order and content of the

columns, turn on Use Custom Column Options and click the set button. To mini-

mize the paper used, see FAQ: How can I maximize the columns on each page? on

page 102.

    

Other Reports: Assignment and Class Graph
The assignment and class graph reports allow you to print the bar graphs that

appear in the Summaries window. You can include different statistics and choose

to have the graphs printed in color. Easy Grade Pro will automatically include as

many graphs per page as will fit. If your printer allows it, use the Page/Print Setup

options to set orientation to landscape view and scale to about 75% for six graphs

per page and to 150% for a graph that fills the page.
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Other Reports: Assignment Summary
The assignment summary report allows you to print ranked lists of student grades

on one or more assignments. It mirrors the Assignment Grades view of the

Summaries window. It can be used as a poster for displaying grades on an assign-

ment. You can sort students in different ways, display them by name or ID and

can include a variety of statistics. To use it as a poster, set the Students option to

ID only and the Sort option to by ID or Randomly.

          

Other Reports: Attendance Summary
The attendance summary report includes a chart of student attendance totals

broken down by category and term. It mirrors the Class Attendance view of the

Summaries window. It can be used for reporting attendance information. You can

include a key to your attendance codes. To set the order and attendance codes of

the columns, turn on Use Custom Column Options and click the set button.
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Other Reports: Class Summary
The class summary report includes a chart of overall, term and category grades. It

mirrors the Class Grades view of the Summaries window. It can be used for

reporting grade information and as a poster. You can include points, percents and

grades. To set the content of the columns, turn on Use Custom Column Options
and click the set button. To use it as a poster, set the Students option to ID only
and the Sort option to by ID or Randomly. To minimize the paper used, see FAQ:

How can I maximize the columns on each page? on page 102.

    

Other Reports: Class Missing Work
The class missing work report includes a list of missing work in one or more

classes. The missing work can be grouped by student or assignment. Although it is

meant for the teacher, it can be used as a poster or cut up and given to students.

For additional information, see Student Reports: Missing Work on page 107.
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Other Reports: Class Roster
The class roster report includes a chart with student names and blank columns. It

can be used to hand-enter grade and other information. Columns can be normal

width (like the score chart) or half-width (like the attendance chart). Columns

will be printed to fit the page. To include blank column titles, turn on Include

room for custom titles. To have Easy Grade Pro print custom column titles, click

the set button, type the titles and turn on the Use the custom titles above option.

    

Other Reports: Labels
Use the Labels report to print mailing, file folder and other labels. You can use

most popular Avery® labels for laser and ink jet printers. Each label can include

up to three lines with student name, grade and record information. You can

center or left justify the text and set it to all capitals. In case your sheet of labels is

missing the first set, you can begin printing at an offset. As with the single-class

progress report, you can specify a grade range to include only certain students.
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Other Reports: Multi-class Gradesheet
Use the multi-class gradesheet report to produce a chart with overall or term

grades from several classes. Elementary teachers can use this report to list all

subject grades for all students. Secondary teachers can use this report to produce a

single list of students and grades from multiple classes. Since students can be

displayed by ID and can be sorted in a variety of ways, this report can be used as a

poster. You can choose to have the report display individual term grades or overall

grades. A term grade is the grade for a single term. If term options have not been

set in the Class Options window, then the overall grade and the term are the same.

This report can include a combined class average, which is the weighted average

of all the grades that appear in the report for a student. (The weight used for each

class can be edited in the Classes view of the Records window). You can sort by

the combined class grade to produce a ranked list of students across multiple

subjects or classes.

You can match students in the different classes by name or ID number. If a

student’s name or ID doesn’t match, the student will appear more than once in

the report.

    

Other Reports: Class Notes and Student Notes
The class notes and student notes reports allow you to print the notes in the Class

Notes and Student Notes views of the Summaries window. Optionally, the student

notes report can include the notes found in the Score Notes window.
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Internet Report Options
Easy Grade Pro offers different ways to securely post student reports on the

internet: HTML, Edline and Basmati. Each is very different and has its own set of

features as the chart below illustrates.

HTML Edline Basmati

 Web 
Server

For

To 
upload 

Security

School or district web 
server running NT/ 2000, 
Linux, Unix, or OSX.

Secure server provided 
and maintained by Edline.

School or district web 
server or web space 
provided by any ISP.

Individuals, schools. Schools and districts.

Teacher creates a folder of 
reports using Easy Grade 
Pro and uploads it to the 
web server using an ftp 
program.

Easy one-click uploading 
of reports directly from 
Easy Grade Pro using Mac 
OS 8.6+ or Win95+.

Teacher creates a report 
file using Easy Grade Pro 
and uploads it to the 
server using a web 
browser.

Schools and districts.

Password protection. Encryption of uploaded 
reports. Secure web site. 
Passwords for school 
personnel, students and 
parents. 

Password protection. 
Single password for 
access to grades from 
multiple teachers.

Other Free. Can work with 
existing school or 
personal web pages. Must 
add link to main 
password page.

Monthy fee. Full-
featured, service for 
posting grades and any 
school/class info. Email 
option.

Free. Can work with 
existing school web pages. 
Allows easy viewing of 
reports from multiple 
teachers.

Report 
View
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Using HTML Reports
HTML Reports are for individual teachers and schools that want a free way to

post student reports for viewing on the internet. If a teacher doesn’t have access to

a school or district web server, web space provided by an ISP can be used as long

as the space provided is at least 4 MB.

HTML Reports offer security through the use of JavaScript 1.1 and frames.

Netscape Navigator 3.0+, Internet Explorer 4.0+ and America Online are capable

of viewing student HTML reports as long as frames and JavaScript have not been

turned off in the browser’s preferences window. The majority of browsers in use

at the time of printing are capable of viewing the reports.

It is best to view HTML reports using a computer that is not shared by others in a

public environment because the browser history stored by web browsers may

allow access to reports previously viewed. This risk can be substantially reduced if

the browser history is turned off.

To set up HTML Reports with password security:
1  Choose Student from the Chart menu and enter passwords in the Password

column. Not only are passwords used to gain access to reports on the internet,

they are used as filters when creating reports: students without passwords are

skipped. Passwords must consist of letters and numbers only and must be be-

tween six and twenty-four characters in length. They are not case sensitive.

2  Select Internet from the File menu or use the Internet tool  to open the

Internet Reports window.

3  Enter the name of the school or your name in the field at the bottom of the

window. This name is used in the title area of the reports.

4  Select the HTML tab and select either Multi-class or Single-class Website

Reports. Click Next. Select Multi-Class Website Reports if you have the same

students in multiple classes or subjects and wish to produce reports that include

all subjects. Otherwise, select Single-class Website Reports. After clicking, the

Report Options window will appear.
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5  Set the desired options in the Report Options window. Many of the options

found in this window are identical to those found in the window for the printed

progress reports. See Student Reports: Multi- and Single-class Progress on page 104

for an explanation of these options.

There are some special options as follows:

•  Main Page Options. The main page is a password page where the viewer must

choose a class, enter a name and password. Optionally, it can include a message

from the teacher and the teacher’s email address. To include a message, select the

Include Main Page Text option. Then click the set button and enter the text. The

text might include a greeting, directions, or a request to sign up and send a

password. If you would like parents to be able to click on a button in order to

send you email, enter your email address in the Email field.

•  HTML Options. Click this to open a window where the style and colors used in

the tables of the report can be set.

•  Label Options. Click this to open the Gradebook Options window so that the

labels used in the report can be edited.

•  Use Custom Student Title. For security, it is strongly recommended that you turn

on this option and click the set button. In the Custom Student Title Options

window (shown on next page), set Line 1 to ID only or turn on the Exclude ‘Line

1’ from Internet reports. This causes any reference to the student to be omitted.
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6  Click the Create button.

Follow the prompt to create a folder on your desktop. Give the folder an exact

name such as ‘teacher name’ Grades. Perhaps your school will provide you with a

name. Easy Grade Pro will automatically create the main page, named index.html,

other special files as well as a folder with reports for each class. You must use the

same folder name every time you create reports so that the link to your

index.html does not break.

7  Quit Easy Grade Pro and view the reports using your web browser. Although

there is no way to preview the HTML reports within Easy Grade Pro, it is easy to

view them using your web browser before you upload them to the web server.

Find the folder you created, open it and double-click on the index.html page. If it

doesn’t open, first open your web browser, choose Open from the File menu, then

navigate to the index.html page and open it. If there is an element in the main

page or in the reports that you would like to change, delete the folder and start

over.

8  Use a file transfer protocol (ftp) program to upload the folder to your web

server. Your school may provide you with the instructions and software necessary

to complete this step. For security, be sure to delete the folder from your com-

puter when done with the transfer.

9  Using a web design program, provide a link from you school’s web page or a

personal web page to the index.html page within your folder of grade reports. You

will need a web design program to set up the link. Your school may provide you

with the instructions and software necessary to complete this step or it may be

done for you.
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Using Edline
Edline provides a complete Internet platform that serves as your school’s website

or as a companion website. It allows one-click uploading of student reports

directly from Easy Grade Pro making it the easiest way to regularly upload

reports. For information view www.edline.com or call 1-800-491-0010. Once your

Edline account has been set up and your school’s classes and students have been

defined, you’ll be able to begin uploading student reports.

To upload reports:
1  Your school will provide you with a unique Class ID for each class you teach.

These may be imported into your gradebook directly from school administration

software or you may need to manually enter them. The Class ID will be entered

into one of the fields in the Records window for each class you teach. To open this

window, choose Records from the Chart menu or click the Records tool  and

select the Classes tab. If you must manually enter a Class ID, enter it in the first

field under the Custom Data title.

2  Every student must have a unique ID number that identifies him or her in

Edline. When you post reports from your gradebook, Edline uses the student ID

to determine which student or parents should be allowed to see the report. Your

school will provide you with a unique Student ID for each student. These may be

imported into your gradebook directly from school administration software or

you may need to manually enter them. The Student ID can be entered into the

Student ID field in the Records window or it can be entered directly into the

Student chart (choose Student from the Chart menu).
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3  Select Internet from the File menu or use the Internet tool  to open the

Internet Reports window.

4  Enter the name of the school or your name in the field at the bottom of the

window. This name is used in the title area of the reports.

5  Select the Edline tab and select a report from the list. Select the Multi-Class

Edline Reports if you have the same students in multiple classes or subjects and

wish to produce reports that include all subjects. Otherwise, select the Single-class

Edline Reports. Click Next. The Report Options window will open.

6  Set the desired options. Many of the options found in this window are identical

to those found in the window for the printed progress reports. See Student

Reports: Multi- and Single-class Progress on page 104 for an explanation of these

options. There are some special options as follows:

•  For the Multi-class Report, you must enter the Class ID given to you by your

school. It is critical that you use the correct value. You must also enter a Class

Title, such as Ms. Demo’s 6th Grade.

•  For the Single-class Report, you must select from a menu the field in the Records

window that is holding the Class ID.

•  The Report/Folder Name is the name of the folder to hold the reports on Edline
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and is visible to viewers. You can use one or more folders for different reports

such as Quarter 1 Reports, Quarter 2 Reports, Final Reports, Missing Work Reports,

November Grades, etc. If you want to upload reports that replace older reports for

your student, use the same name for the folder. If you want to upload reports that

do not replace older reports, use a new name.

•  HTML Options. Click this to open a window where the style and colors used in

the tables of the report can be set.

•  Label Options. Click this to open the Gradebook Options window so that the

labels used in the report can be edited.

7  Click the Upload button. If you are not using an always on connection to the

internet, be sure to connect before clicking Upload. Easy Grade Pro will open

your web browser to the Edline server and send the reports. During the process

you will be prompted to enter your Edline screen name and password.

8  View one or more reports. To view the reports, go to the home page for any

class whose reports you uploaded. Click on the name of the report folder in the

Contents box. You will see a list of reports. The title of each report is the student's

name. To view an individual report, click on a student's name. You, as the teacher,

will see all the reports. When students and parents click on the folder, they will

only see their own reports.
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Using Basmati
Basmati is open-source software that can run on your school or district’s Linux,

Unix, Windows NT/2000 or Mac OS X web server. Software and documentation

are free and are available for downloading at http://www.sourceforge.net. (Search

for Basmati.) Parents and students can use a single password to view grades from

all classes and teachers. Once your school or district has set up the software on its

server, you can use Easy Grade Pro to generate a single grade file with information

on all of your students and classes and upload it to the server using your browser.

To set up Basmati reports:
1  Ensure that each class in your gradebook has a Course Code and other values.

Every class must have a unique course code that identifies it in Basmati. Option-

ally, it may also have a section number and period. These codes may be imported

into your gradebook directly from school administration software or you may

need to manually enter them into fields in the Records window for each class you

teach. To open this window, choose Records from the Chart menu or click the

Records tool . Then select the Classes tab. Typically, the Course Code will be

in the first field under the Custom Data title (shown below) and the others below

it. Follow the instructions provided by your school.

2  Ensure that each student has a Student ID. Every student must have a unique ID

number that identifies him or her in Basmati. These IDs may be imported into

your gradebook directly from school administration software or you may need to

manually enter them. The Student ID can be entered into the Student ID field in

the Records window, under the Students tab or can be entered directly into the
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Student chart. Choose Student from the Chart menu to view this chart.

3  Select Internet from the File menu or use the Internet tool  to open the

Internet Reports window. Select the Other tab and select Basmati from the list.

Click Next. After clicking, the Basmati Options window will appear.

4  Set the desired Basmati options using these guidelines:

•  Include Students in. Use this to set the classes to be included.

•  Course#. Set this to the appropriate custom field in the Records window. This

field is required.

•  Section# and Period#. Set these to omit or to the appropriate custom fields in the

Records window.

•  Students and Assigns. Use these to set which students and assignments are to be

included. Use these in conjunction with the filters found in the View menu.

•  Teacher. Put your name in this field.

•  Email. Put your email in this field. This field is required.

•  TchrID. Put your password in this field for access to Basmati. This field is

required.

•  Phone. Put your school phone# in this field.

•  Control. Leave this field blank unless instructed to use it.

5  Click Create and save the Basmati.txt file to the desktop of your computer or

some other location.

6  Quit Easy Grade Pro.



CHAPTER 13: Internet Reports124

7  Upload the Basmati.txt file using your web browser. Using your browser, access

your school’s Basmati Faculty page. After logging in, click the Submit File button.

Then click the Browse button (shown below). Find and select the Basmati.txt file

your created with Easy Grade Pro. Then click the Submit File to Basmati button.

For security, be sure to delete the Basmati.txt file when done uploading.
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Using Easy Grade Pro’s HTML reporting features, it is easy to create a folder of

student reports for each of your classes. These reports can be attached to your

email messages and viewed by parents and students using their web browsers.

This chapter explains how.

Creating the Reports
1  Select Internet from the File menu or use the Internet tool  to open the

Internet Reports window.

2  Enter the name of the school or your name in the field at the bottom of the

window. This name is used in the title area of the reports.

3  Select the HTML tab and select either Multi-class or Single-class Email Reports.

Click Next. Select Multi-Class Email Reports if you have the same students in

multiple classes or subjects and wish to produce reports that include all subjects.

Otherwise, select Single-class Email Reports. After clicking, the Report Options

window will appear with a variety of options.

4  Set the desired options in the Report Options window. Many of the options

found in this window are identical to those found in the window for the printed

progress reports. See Student Reports: Multi- and Single-class Progress on page 104

for an explanation of these options.

There are some special options as follows:

•  HTML Options. Click this to open a window where the style and colors used in

the tables of the report can be set.

•  Label Options. Click this to open the Gradebook Options window so that the
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labels used in the reports can be edited.

•  Use Custom Student Title. For security, it is strongly recommended that you turn

on this option and click the set button. In the Custom Student Title Options

window, set Line 1 to ID only or turn on the Exclude ‘Line 1’ from Internet reports.

This causes any reference to the student to be omitted.

5  Click the Create button. Follow the prompt to create a folder on your desktop.

You may wish to name it Email Reports. Easy Grade Pro will create a folder inside

it with student reports for each class.

6  Quit Easy Grade Pro and view the reports using your web browser. Although

there is no way to preview the HTML reports within Easy Grade Pro, it is easy to

view them using your web browser before you email them. Find the folder you

created, open it and double-click on any report page. If it doesn’t open, open your

web browser, choose Open from the File menu, then navigate to the report and

open it.

Emailing a Report
1  Using a email program, write an email to the parent or student. You may wish

to write a set of instructions for opening the attached report. Save the set of

instructions so that it can be reused. The instructions might include something

like this.

“Please find the grade report attached to this email. You may be able to view the report by

double-clicking on the report’s name. Otherwise, save it to the Desktop of your computer.

Then start your web browser, choose Open from the File menu and open the report.”

2  Attach the report to your email message. With many email programs you can

simply drag the report file into the message window. If this doesn’t work, use the

Attach tool of the email program to attach the report.
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Porting refers to the transfer of data to and from your gradebook. To import

means to copy data from another file to your gradebook. To export means to

create a new file that holds data from your gradebook. This chapter explains the

many ways you can port data.

Importing
Typically, importing is used to bring student names and other student record

information into a gradebook, but it can also be used to import options, scores

and more. You can import from Easy Grade Pro gradebooks and text files.

To import:

1  Select Import from the File menu or use the Import tool  to open the

Import window. The Import window has two tabs. Under the first, you’ll find the

built-in formats. Under the second you’ll find user-defined and other editable

formats. A format specifies the fields and structure of the data to be imported.
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2  (Optional) If the format that you need is not present, you can create one by first

clicking the Other Formats tab and then clicking the New Format button. For

help in creating a format, refer to the section Creating Formats for Importing and

Exporting on page 131.

3  Select a format, click Next.  The formats include:

•  Import from an EGP Gradebook. Use this format to copy students, options,

assignments, a whole class, etc. from another Easy Grade Pro gradebook. The

Import Gradebook window will appear where you can select the items to be

imported.

•  “Easy Import” of Students. Use this format to import students from most tab-

separated or comma separated text files. Many database and spreadsheet pro-

grams use this format when creating text files. The Easy Import window will open

where you can identify the fields in a record from the file. You must identify the

first and last names but all other fields are optional. You must also name the

format so that it can be added to the Import window where it can be reused

directly.

•  “Easy Import” of Scores. Use this format to import scores from most tab-

separated or comma separated text files. The records may be in any order as long

as each contains a score and an ID number (or student name) to be used for

matching. The Easy Import window will open where you must identify the score

and the ID number (or student name) fields.

•  Import Summary Comments. Use this format to import a list of summary

comments from a text file. This will replace the list in the Student Comments view

of the Summaries window.

•  Combine Gradebooks. Use this format to combine one or more gradebooks

from other teachers into a single master gradebook to be used for the printing of

multi-class progress reports or other reports. Note: there is a 250 class limit for a

gradebook which means that you can typically combine up to ten gradebooks.

•  Other Formats. The formats that appear under the Other Formats tab can only

be used to import students and student record data from text files. There is a

small blue arrow above the list of formats which allows you to duplicate a format

or create a plug-in of a format. A plug-in is a small file that makes it easy to
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distribute a format to other Easy Grade Pro users. See Using Plug-ins on page 138

for additional information.

4  For some formats, the Import Preview window will appear so that you can

verify the data and select the records (students) to be imported. Be sure to check

that the data in the columns properly match the column titles. If they match, click

the Import Selected Records button. If a selected student has the same ID number

as a student currently in the class, the import data will be used to update the

student’s record information. The student will not be duplicated in the class.

Exporting
Exporting is typically used to transfer student grade data to a program used to

print report cards, but it can also be used to transfer all kinds of student informa-

tion to word processor, spreadsheet or database software to take advantage of the

unique tools of these programs. When exporting, you can create two types of files:

Easy Grade Pro gradebooks and text files. Text is a standard file format that many

programs use for transferring data to other programs.

To export:

1  Select Export from the File menu or use the Export tool  to open the

Export window. The Export window (shown on the next page) has two tabs.

Under the first tab, you’ll find export formats that are built-in. Under the second

tab you’ll find user-defined and other editable formats. A format is used to specify

the fields of the data to be exported.
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2  (Optional) If the format that you need is not present, you can create one by first

clicking the Other Formats tab and then clicking the New Format button. For

help in creating a format, refer to the section Creating Formats for Importing and

Exporting on page 131.

3  Select the classes to be exported from the list on the left. Select  the students to

be exported using the menu below the list.

4  Select a format and click Next.  What happens after clicking depends on the

selected format. The formats include:

•  Export One Class. Use this format to create a new gradebook with a single class.

This can be used to create a file with data to be imported into another gradebook.

•  Export Gradebook Template. Use this format to create a new gradebook that

has only the settings from the gradebook options, class options, comments

windows. The template can be used by others when starting their gradebooks.

•  Export Attendance. This format is usually not selected directly because it is

automatically used whenever the Export Attendance tool is selected from the tool

bar. For help, refer to the section Exporting Attendance on page 133.

•  Export Report Card Data. This format can be used to export student grade data

to database software that prints custom report cards. This is explained in detail in

the section Using the Report Card Data Format on page 136.

•  Export Summary Comments. Use this format to create a text file of the list of

comments found in the Summaries window.
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•  Other Formats. The formats that appear under the Other Formats tab can only

be used to export student data to text files. There is a small blue arrow above the

list of formats which allows you to duplicate or create a plug-in of a format. A

plug-in is a small file that makes it easy to distribute a format to other Easy Grade

Pro users. See Using Plug-ins on page 138 for additional information.

5  If the Export Preview window appears, verify the data and click the Export

button.

FAQ: Can Easy Grade Pro import student rosters from my school’s school administration software and
can it export grade data back to it?
In many cases the answer is ‘Yes’. If your school administration software can produce a

roster file for a class in text format and if it can read a grade file for a class in text format,

the standard version of Easy Grade Pro can probably share data with it. You, or someone

at your school with the proper knowledge and expertise may have to create import and

export formats within Easy Grade Pro. Plug-ins can be used to distribute the formats to

other users. For help, see Creating Formats for Importing or Exporting on page 131 and

Using Plug-ins on page 138. In some cases, custom versions of Easy Grade Pro are

required. Contact Orbis Software for availability and pricing for custom versions.

Creating Formats for Importing or Exporting
If you wish to import or export student data with spreadsheet, database, school

administration and other software, you may need to create an porting format.

This section explains how to create formats that appear under the Other Formats

tab in the Import and Export windows.

Creating formats requires a certain amount of knowledge of file formats and

ASCII codes. In addition, it requires 100% accuracy or else unpredictable results

may occur. Proceed with caution!

By default, Easy Grade Pro separates fields (pieces of data) using tabs (ASCII 9)

and separates records using a CR (carriage return, ASCII 13). Many word process-

ing, spreadsheet and consumer database program also use this format when

porting. In the PC world, many programs use a CR/LF (carriage return/line feed,

ASCII 13/10) combination instead of a CR. You may need to modify a format to

include a CR/LF. For help with this, see FAQ: How do I set the record delimiter to

the CR/LF used by most Windows programs? on page 133.



CHAPTER 15: Porting132

If you will be porting to or from school administration software, things can be

much more difficult because these programs tend to use custom formats. For

example, some files may use fixed-length fields (instead of variable length fields)

that are left or right justified, with special fill characters and no delimiters except

at the end of a record. In many but not all cases, formats can be created in Easy

Grade Pro to work with school administrative software.

To create a format:
1  From the Import or Export window, select the Other Formats tab. Then click

the New button. The New Format window will open. On the left side of this

window is a list of fields that are available for use in the format.

2  To add a field to your format, select it in the list on the left and click the Copy

button. The field is copied to the format list on the right. If a field is in the wrong

position in the format list, press on it and drag it to the new location.  A format is

limited to thirty fields per record.

3  (Optional) Select the Quotes button. Set this item if the data has (if importing)

or should have (if exporting) quotation marks around each field. Under many

circumstances, Easy Grade Pro will remove quotation marks automatically during

importing.

4  (Optional) To customize a field, select it and click the Edit button. Easy Grade

Pro automatically uses a tab-delimited format in which each field is variable in

length and is followed by a tab (ASCII 9) for most fields and a CR (ASCII 13) for

the last field in a record. To change this formatting, or to make a field required

(for export formats), select the field in the list on the right and click the Edit
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button. A small window will open with options for changing the format of a field.

Only those with sufficient knowledge of file formats should attempt to make

changes in this window. Any field that has been customized will have an asterisk

appended to its name in the list.

If you set the Field Data Required item in an export format, Easy Grade Pro will

block exporting until all required data are complete.

FAQ: How do I set the record delimiter to the CR/LF  used by most Windows programs?
By default, Easy Grade Pro adds a CR (ASCII 13) to the end of a record. If your format

requires a CR/LF (ASCII 13/10) combination, follow these steps:

a)  Change the delimiter of the last field to CR (ASCII 13). To do this, select the last field

and click the Edit button. In the window that opens, change the delimiter to CR.

b)  Add a Blank Field to the format. To do this, select Blank Field (the last field) in the

list on the left and click the Copy button.

c)  Change the delimiter of the Blank Field to LF (ASCII 10). To do this, select the field

and click the Edit button. In the window that opens, change the delimiter to LF.

5  Name the format in the text field at the top of the window and click Done. The

name will appear under the Other Formats tab in the Import or Export window.

Exporting Attendance
Easy Grade Pro allows you to export attendance over a network in just a few steps.

To prepare for the exporting of attendance:
Careful preparations are required before exporting can begin. These are listed

next.
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•  Attendance Folder. A folder must be set up on a shared volume to hold the daily

attendance export files. The pathname (name of folder, enclosing folders and

volume) must not change once exporting has begun. The volume should be

automatically mounted on each teacher’s computer.

•  Attendance Categories. Each teacher’s gradebook must have the school’s

attendance categories and codes. Although these can be set by each teacher using

the Class Options window, it is suggested that a gradebook template be set up and

made available to teachers.

•  Export Attendance Format. Easy Grade Pro has a built-in export format for

attendance. This format has the name Export Attendance and can be found under

the Built-in Formats tab of the Export window. It has the following fields:

Field 1 Selected Date

Field 2 ID

Field 3 Last Name, First

Field 4 Selected Day’s Attendance

If desired, you can create your own custom format. See the section Creating

Formats for Importing and Exporting on page 131 for help. In order for Easy Grade

Pro to use your format, it must be named Export Attendance. It is best to include

the format in a gradebook template.

•  Calendar Settings. Attendance data cannot be recorded until calendar options

have been set in the Class Options window.

•  Export Attendance Tool. The Export Attendance tool  is used to start the

export process. It must be placed on either the tool bar or tool palette. To add the

tool, press and hold on any occupied or unoccupied tool location. Select the

Export Attendance tool from the menu that appears. It is best to include this

setting in the gradebook template.

•  Gradebook Template. A gradebook template can be used to ensure that all

teachers’ gradebooks have the same settings. It also minimizes the work that

teachers must do. First create a gradebook with the right settings. Then create a

template of the gradebook. Refer to the section Exporting starting on page 129 for

help. Teachers should create their gradebooks directly from the template.
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To export attendance:
Before you can export attendance, your gradebook must have the correct atten-

dance categories and export format. The Export Attendance Tool must be on the

tool bar or tool palette and the volume to receive your attendance data must be

mounted on your computer. You must know the name to use for your export file

and the location in which it is to be saved. Be sure to enter your attendance data

in the attendance chart or seating chart first. Then follow these steps:

1  Click the Export Attendance tool. A small calendar will appear (shown below).

This calendar will automatically display the current date but you may change this

by clicking on another date. Click OK.

2   Easy Grade Pro will gather the attendance data for the selected date and present

it in the Export Preview window (shown below). This window is used to verify the

attendance data. Note that only students with attendance marks appear. Even if

the preview window is empty, it is important to export so that a file is created

indicating that attendance has been sent. Click the Export Records button.
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3   If this is the first time that you are exporting attendance from the gradebook,

the standard Save dialog window will open allowing you to name and save the

export file. Use the unique name given to you. The location to save the file should

be the attendance folder set up on a shared volume. Easy Grade Pro will remem-

ber the name and location and use them automatically in the future.

If you saved the file using the wrong name or location, you must reset Easy Grade

Pro. To do this, click the Export Records button in the Export Preview window

while holding down the option (Macintosh) or Ctrl (Windows) key. You will be

able to reset the name and location.

Using the Report Card Data Format
This section explains the Report Card Data export format found in the Export

window of Easy Grade Pro. This format can be used to export student data to a

general-purpose database program so that custom report cards can be printed.

The Report Card Data format consists of 157 fields (listed to the right). Virtually

every piece of data about a student is included (other than individual attendance

marks and assignment scores). Even the text found in the Summaries window is

included. This format results in a tab-delimited text file.

In most cases, this format cannot be used with the expensive, out-of-the-box

school administration programs. Such programs have very specific data format-

ting requirements and lack the flexibility to handle the data in the 157 fields.

Rather, this format is to be used with general-purpose database programs, ones

that offer rich sets of tools for importing, sorting, searching, data manipulation

and form creation. These powerful programs are relatively inexpensive and are

available for both Macintosh and Windows computers. However, using one of

these programs to create a well-designed database requires much skill and time.

This task is best left to experts.

Once set up, it can be fast and easy to print your school’s report cards using data

from files created using Easy Grade Pro’s Report Card Data format.
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1 Last Name, First
2 Last Name
3 First Name
4 ID
5 Gender
6 Status
7 Grade Scale
8 Language
9 Student Custom 1

10 Student Custom 2
11 Student Custom 3
12 Student Custom 4
13 Student Custom 5
14 Student Custom 6
15 Student Custom 7
16 Student Custom 8
17 Student Custom 9
18 Student Custom 10
19 Student Custom 11
20 Student Custom 12
21 Class Name
22 Class Weight
23 Class Custom 1
24 Class Custom 2
25 Class Custom 3
26 Class Custom 4
27 Class Custom 5
28 Class Custom 6
29 Class Custom 7
30 Class Custom 8
31 Overall Points
32 Overall %
33 Overall Grade
34 Class Rank
35 Class Average %
36 Class Average Grade
37 Current Term Points
38 Current Term %
39 Current Term Grade
40 Category 1 Points
41 Category 1 %
42 Category 1 Grade
43 Category 2 Points
44 Category 2 %
45 Category 2 Grade
46 Category 3 Points
47 Category 3 %
48 Category 3 Grade
49 Category 4 Points
50 Category 4 %
51 Category 4 Grade
52 Category 5 Points
53 Category 5 %

54 Category 5 Grade
55 Category 6 Points
56 Category 6 %
57 Category 6 Grade
58 Category 7 Points
59 Category 7 %
60 Category 7 Grade
61 Category 8 Points
62 Category 8 %
63 Category 8 Grade
64 Category 9 Points
65 Category 9 %
66 Category 9 Grade
67 Category 10 Points
68 Category 10 %
69 Category 10 Grade
70 Category 11 Points
71 Category 11 %
72 Category 11 Grade
73 Category 12 Points
74 Category 12 %
75 Category 12 Grade
76 Category 13 Points
77 Category 13 %
78 Category 13 Grade
79 Category 14 Points
80 Category 14 %
81 Category 14 Grade
82 Category 15 Points
83 Category 15 %
84 Category 15 Grade
85 #Missing Assignments
86 Completed Work Points
87 Completed Work %
88 Completed Work Grade
89 Term 1 Points
90 Term 1 %
91 Term 1 Grade
92 Term 2 Points
93 Term 2 %
94 Term 2 Grade
95 Term 3 Points
96 Term 3 %
97 Term 3 Grade
98 Term 4 Points
99 Term 4 %

100 Term 4 Grade
101 Term 5 Points
102 Term 5 %
103 Term 5 Grade
104 Term 6 Points
105 Term 6 %
106 Term 6 Grade

107 Term 7 Points
108 Term 7 %
109 Term 7 Grade
110 Term 8 Points
111 Term 8 %
112 Term 8 Grade
113 Term 9 Points
114 Term 9 %
115 Term 9 Grade
116 Term 10 Points
117 Term 10 %
118 Term 10 Grade
119 Master Attendance 1
120 Master Attendance 2
121 Master Attendance 3
122 Master Attendance 4
123 Master Attendance 5
124 Master Attendance 6
125 Master Attendance 7
126 Master Attendance 8
127 Master Attendance 9
128 Master Attendance 10
129 Attendance 1
130 Attendance 2
131 Attendance 3
132 Attendance 4
133 Attendance 5
134 Attendance 6
135 Attendance 7
136 Attendance 8
137 Attendance 9
138 Attendance 10
139 Attendance 11
140 Attendance 12
141 Attendance 13
142 Attendance 14
143 Attendance 15
144 Today's Date (short)
145 Comment 1 (number)
146 Comment 2 (number)
147 Comment 3 (number)
148 Comment 4 (number)
149 Comment 5 (number)
150 Comment 6 (number)
151 Comment 1 (text)
152 Comment 2 (text)
153 Comment 3 (text)
154 Comment 4 (text)
155 Comment 5 (text)
156 Comment 6 (text)
157 Student Summary Note
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Using Plug-ins
Plug-ins are small files created using Easy Grade Pro that can be used to distribute

import formats, export formats and summary comments to other Easy Grade Pro

users.

To create a plug-in of an import or export format:
Choose Import or Export from the File menu, click the Other Formats tab and

select the desired format from the list. Press on the small blue arrow above the list

and choose Save Item as Plug-in from the menu that appears. Then name and save

the plug-in.

To create a plug-in of the list of comments in the Summaries window:
Choose Summaries from the Chart menu, click the Students tab on the left and

the Comments (balloon) tab on the right. Press on the small blue arrow above the

lower list and choose Save Comments as Plug-in from the menu that appears.

Then name and save the plug-in.

To distribute a plug-in file:
Plug-in files should be placed in the same folder as the Easy Grade Pro application

or should be placed in a folder titled Plug-ins found in the same folder as the Easy

Grade Pro application. Whenever a person opens an Easy Grade Pro gradebook

using version 3.5.6 or higher, Easy Grade Pro scans the plug-ins and transfers

their contents to the gradebook.

Be careful with plug-ins. A plug-in with comments will prevent the user from

making lasting changes to comments in the Summary window. If the user makes

changes to comments, the next time the gradebook is opened, the changes will be

erased and replaced with what is found in the comments plug-in.

To remove a plug-in:
Drag the file out of the Plug-ins folder and out of the Easy Grade Pro folder. Note:

this does not remove the contents of a plug-in from a gradebook if the contents

have already been read into the gradebook.



Technical Support

This chapter includes the most frequently asked technical questions about Easy

Grade Pro and where to find the answers. If you can’t find your question in this

section, at the end you’ll find email and phone information for contacting techni-

cal support at Orbis Software.

FAQs: Frequently Asked Questions

Chapter 1: Getting Started
•  How do I install Easy Grade Pro to a computer without a CD-ROM drive? (page 6)

•  Can Easy Grade Pro be networked? (page 6)

•  How do I turn off the balloons? (page 9)

Chapter 3: Gradebooks and Classes
•  Why does a gradebook open when I choose Easy Grade Pro from the Start menu?

(page 26)

•  Easy Grade Pro saves automatically. What does this mean? (page 26)

Chapter 4: Setting Options
•  What is grade-clicking? How does it work? (page 33)

•  How do I set up my 5-point (or some other point) grading system? (Part 1) (page 33)

•  How do I enter a check mark as a special score? (page 37)

•  How do I set up my 5-point (or some other point) grading system? (Part 2) (page 37)

•  How do I change the highlight color? (page 41)

•  I don’t remember the password. How do I get back in? (page 46)

•  How do I switch the classes in EGP Clipboard to my new term? (page 50)

Chapter 5: Students and Assignments
•  How do I reshow a student once the status has been set to WD (hidden)? (page 55)

16
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•  What are maximum score and points? How should I set them? (page 57)

•  If I use category weighting, does it matter how I set assignment points? (page 57)

•  Why are the dates wrong in the calendars and in the charts? (page 59)

Chapter 6: Using the Score Chart
•  How does Easy Grade Pro treat blank score  cells? How can I easily set all blanks to a

certain score? (page 64)

•  How is a student’s overall grade calculated? (page 66)

•  How can I drop more than one score for each student? (page 69)

•  I’ve added an extra credit assignment but student grades haven’t changed. Why?

(page 70)

•  I have a group of students (or just one student) with unique assignments. How can I

create a filter to show just this group and its assignments? (page 76)

Chapter 7: Using the Other Charts
•  How  can I easily see who was absent on a certain day when entering scores in my score

chart? (page 81)

•  I understand how Easy Grade Pro calculates but the overall grade seems wrong. What

should I do? (page 82)

Chapter 8: Making and Managing Backups
•  My gradebook’s name is ‘Copy of copy of...’. What is going on? (page 84)

Chapter 9: Working at Home and School
•  Why am I getting disk error messages when copying to and from floppy disks? (page 88)

Chapter 10: Working with Terms
•  I’ve combined terms but the prior-term grades or attendance data in reports are wrong.

How do I fix this? (page 92)

•  I need to print reports that show grades from multiple terms but I don’t want the grades

to be combined to form a multi-term overall grade. What do I do? (page 92)

•  I have to include a weighted final exam. What do I do? (page 92)

Chapter 11: Using Summaries
•  How can I check the calculations for one of my students? (page 94)

Chapter 12: Printing Reports
•  How can I maximize the columns on each page? (page 102)

•  How to I print multiple reports per sheet of paper? (page 103)
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•  How do I change the teacher or school name that appears on reports? (page 103)

•  How can I get a progress report to fit on a single sheet of paper? (page 105)

•  Some assignments are not showing up in progress reports. How to I fix this? (page 105)

•  Why are classes missing on a student’s multi-class progress report? Why am I getting two

different multi-class progress reports for a student, each with different classes? (page 106)

•  How do I remove the Overall column in a multi-class progress report? (page 106)

•  How can I use the multi-class progress report as a report card for multiple teachers’

grades? (page 106)

•  How do I show points in a progress report? (page 106)

•  How can I use a progress report as a missing work report? ...as an attendance report?

(page 106)

•  Many reports allow me to choose ‘Displayed Only’ for  students, assignments or dates.

What does this mean and how do I use this option? (page 108)

Chapter 15: Porting
•  Can Easy Grade Pro import student rosters from my school’s school administration

software and can it export grade data back to it? (page 131)

•  How do I set the record delimiter to the CR/LF  used by most Windows programs?

(page 133)

Contacting Orbis Software for Technical Support
Orbis Software provides free technical support to registered users. Before you

contact us, please be sure that you have read the FAQs above and you’ve searched

this manual. Be sure to have the following information: your registration number,

the version number of Easy Grade Pro (i.e. 3.6.1), your operating system (i.e.

Win98, Mac OS 9.0.4) and a clear description of the problem. If calling for

technical support, you are strongly encouraged to be at your computer.

Address: P.O. BOX 73745, Puyallup, WA 98373

Phone: (253) 848-6899 (Pacific Time)

Fax: (253) 848-6505 (fax only

Web: www.orbissoft.com or www.easygradepro.com

Support: support@orbissoft.com

Sales: sales@orbissoft.com
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Index
Symbols

5-point grading system  33, 37

A

ab (absent)  36
add

assignments  56
classes  27, 28, 29
students  51
term  89

Add Assignment tool  56
Add Furniture tool  80
Add Student tool  51
assignment chart  81

printing  110
assignments

add  56
Can be dropped  58
category  58
change name  60
chart  81
copying  59
date  58
delete  60
Extra Credit  58
managing  60
maximum score  57
Negative Points  58
Not for grade  58
points  57
progress report option  58
resizing title region  73
show one  75
sort  60
Status  58
summaries  99

attendance
master categories  38
options  38
summary  95, 98

attendance chart  77
printing  109

automatic save  26

B

backups
making  83
options  46
three-part plan  83

Balloon Help tool  9
Basmati  115, 122
blank scores  64

C

calculating grades  66, 82, 94
calendar

options  39
wrong date  59

Can be dropped  58
category options  34
category weighting  34, 66

and assignment points  57
Change Scores tool  65
chart

assignment  81
attendance  77
score  61
seating  79
student  81

check mark  37
Class Options  31

attendance category  38
calendar  39
color  41
copying to other classes  42
grade scale  32
rounding  34
score category  34
score footnote  35
seat format  40
special score  36

Class Options tool  31
class rank, showing  74
class roster report  113
Class Weight  28
Class/Subject Name  28
classes  25

add  27, 29
add term  30
Class Weight  28

Class/Subject Name  28
Custom Labels  29
delete  29
managing  29
notes  99
rename  29
sort  30
summaries  97
Term Labels  28
without students  51

clipboard text options  47
Clipboard tool  68, 95, 99
color options  41
Combine Gradebooks  128
combining terms  90
comments  96

importing  128
plug-ins  138

compression  45
Copy Class Data tool  16, 42, 53, 59
Copy of copy of...  84
copying

assignments  60
options  42
students  53

cr (credit)  36
CR/LF  131, 133
curving  69, 70, 72
Custom Labels  29, 53

D

delete
assignment  60
class  29
score  61
student  54

Delete tool  54, 60, 80
display options  43
dropping  58, 69

E

Easy Import of Scores  128
Easy Import of Students  128
Edline  115, 119
email

gradebook  87
reports  125
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English  48
ex (excused)  36
Export Attendance  130, 133
Export Attendance tool  134
Export Gradebook Template  130
Export One Class  130
Export Report Card Data  130, 136
Export Summary Comments  130
exporting  129

creating formats  131
plug-ins  138

extra credit  58, 69, 70

F

FAQ
definition  8
list  139

fill across  63
Fill Across tool  63
fill down  63
Fill Down tool  15, 63
filters, custom  75
Filters tool  75
final exam (weighted)  92
Find tool  16, 63
floppy disk

error messages  88
transferring gradebook  87
using gradebook from  26

font, font size  43
footnotes

applying to scores  67
options  35

French  48

G

gender  52
general options  44
grade scale

assign to student  52
options  32

grade-clicking  33
gradebook

new  25
Gradebook Options  42

clipboard text  47
display  43
general  44

Palm setup  49
report labels  48
security  45

gradebooks  25
automatic open  26
automatic save  26
floppy disk  26
location  26
working cross platform  85

grades
calculating  66, 82, 94
display  43, 73
entering  62
grade-clicking  62
summaries  94, 98

graphs
assignment  99
class  97
student  93

H

help  9
Balloon Help  9
Help window  10
status bar  9
tutorial  11

Help tool  10, 22, 102
highlighting, rows and columns  43
HTML  115, 116

passwords  116

I

ID number  52
Import from an EGP Gradebook  128
Import Summary Comments  128
Import tool  127
importing  127

creating formats  131
plug-ins  138

inc (incomplete)  36
installation

CD-ROM  6
floppy disk  6

internet  115
Basmati  115, 122
comparison chart  115
Edline  115, 119

email  125
HTML  115, 116

Internet tool  116, 120, 123

L

labels  113
languages  48

assign to student  52
License Agreement  2
Lock tool  46
locking  72
locking grades  69

M

M (symbol in charts)  44
maximum score  57
mi (missing)  36
Mini-summary  67, 100
missing, scores that count as  37
missing work report  107, 112
multi-class gradesheet  114

N

Negative Points  58
networking  6
Next Term tool  90
Not for grade  58

O

options. See Class
Options; Gradebook Options

P

palettes, options  45
Palm setup options  49
Palm Setup tool  49, 50
password

forgot  46
options  46
student  52, 116
TA  46
teacher  45

plug-ins  138
points  57
porting. See exporting; importing
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previewing reports  102
Print tool  21, 101
printing  101

assignment chart  110
assignment graph  110
assignment summary  111
attendance chart  109
attendance summary  111
changing school/teacher name  103
class graph  110
class missing work  112
class notes  114
class roster  113
class summary  112
displayed only option  108
labels  113
maximizing columns  102
multi-class gradesheet  114
multiple reports per sheet  103
preview  102
score chart  108
seating chart  109
student chart  110
student missing work  107, 112
student notes  114
student progress reports  104

Prior Term tool  90
progress reports  104

R

recombine terms  92
Records tool  29, 30, 89, 119, 122
registration  7
rename class  29
repeating  61
report label options  48
reports. See printing
rounding options  34

S

Save Copy tool  84
score category options  34
score chart  61

printing  108
score footnote options  35
Score Note tool  68
scores

blank  64
changing scores  65
curving  69, 70, 72
deleting  61
display columns  74
dropping  69
enter grades  62
enter special scores  62
entering from papers  63
extra credit  69, 70
fill across  63
fill down  63
footnotes  67
grade-clicking  62
locking  69, 72
moving  61
notes  67
repeating  61
typing  61

scrolling  45
seat format options  40
seating chart  79

printing  109
security options  45
Show Colors tool  41
Software License Agreement  2
sort

assignments  60
classes  30
students  54

Sort tool  54, 80
Spanish  48
special scores

entering  62
options  36

student chart  81
printing  110

students
add  51
change name  54
comments  96
copying  53
Custom Data  53
delete  54
gender  52
ID number  52
managing  54
order of name  43
report language  52

show one  74
sort  54
summaries  93
summary note  95
transfer  55
withdrawing  55
withdrawn  52

summaries  93. See also printing
assignment  99
class  97
Mini-summary  100
student  93

Summaries tool  93
system requirements  5

T

TA Mode tool  47
technical

support  139
term

combining grades, attendance  90
displaying term grades  74
recombine  92
rename  30
starting new  89
un-combine  92
weighting final exam  92

Term Labels  28
transfer student  55
typing

grades  44
scores  61
shortcuts  44
special scores  44

U

Undo tool  15

W

warnings  44
WD (withdrawn)  52

reshow student  55
web. See internet
weighting categories  34


