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INSTRUCTOR SETUP:

Materials:

♦ After Effects 5 Instructor Manual with disk of accompanying files
♦ After Effects 5 User Manual (1 copy per user)
♦ Job Aid (1 copy per user)

Equipment::

♦ Electronic Classroom
♦ PC or Macintosh workstations (1 per user) After Effects 5 installed
♦ Instructor PC or Mac workstation with After Effects 5 installed
♦ Overhead projector connected to instructor workstation

Setup:

♦ Session length is approximately 2 hours

♦ Instructor should be familiar with all aspects/components of this After Effects 5 module

♦ Check that all computers and equipment are functioning properly

♦ Turn on and test projector

♦ Have users sit at their own computer

♦ Copy the Practice Media files from the disk onto the desktop of each workstation,
including the Instructor workstation.  Copy the Flash demo file to the Instructor
workstation

♦ The Instructor Manual is set up so that you can see the corresponding User Manual page
next to it.  To make copies of the User Manual for the participants of the workshop, print
out the PDF version from http://mll.arizona.edu/workshops.shtml?tutorialpdfs

♦ When teaching this module, make sure you demonstrate steps and ideas for the
users FIRST.  Do not allow them to follow along on their own while you are
demonstrating; they will have the opportunity to practice steps on their own after.
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LECTURETTE 1: WHY AFTER EFFECTS?

Instructor Note: At this time, pass out the User Manual to the students.   Indicate that the students are
Not to do anything on the computer besides the indicated tasks at the indicated times.  Remind them
that they are to watch you first as you demonstrate any steps, then they will practice on their own.

AfterEffects creates stand alone movies.  With so many programs out there that create stand alone
movies to choose from, how can we help a user pick the best one to fit their needs?

AfterEffects is an advanced motion graphics and visual effects program.  The final outcome of
AfterEffects is a movie file such as a QuickTime movie.  Because of this it is necessary to distin-
guish AfterEffects from digital video editing software.  AfterEffects does not edit video, but rather
takes video clips and creates special effects and/or adds movement to the clip- along with sound
files, still images, text, etc.

Final Cut Pro is a professional quality digital video editing program.  Final Cut Pro offers some
effects, but has relatively few options when compared to AfterEffects.

Macromedia Flash also has the ability to create web sites and movies that can be published to the
web using a separate FTP program or burned to a CD as a projector of the movie.  The advantages of
Flash is the ability of increased interactivity and animation.   Flash movies can be very small in size
and can be placed in Dreamweaver along with other information on a web page.  Flash is the choice if
interactivity and advanced animations are important to you or your web site.

Macromedia Director can also be used like a Flash movie as an interactive web site, but is mostly
useful if creating stand alone projectors for movies, interactive games, and animations on CDs, web
sites, and Kiosks.

Footage file:  is any sound, movie or picture file (such as .aif, .mov or .tif) that After Effects supports.

Object:  is a footage file that has been placed into the Composition and Timeline windows.

Layer:  Objects are placed in a stacking order, each one on a layer, in the Composition and Timeline
windows.

Manipulate:  To manipulate an object is to apply any transform, mask or effect to it; objects are
manipulated over time.

Transforms:  are used to change an object’s position, scale, opacity and/or rotation within the compo-
sition and over time.

Masks:  are created to block out and/or reveal portions of the composition. They are an outline, that
modifies a layer's alpha channel. Use a mask when you want to draw areas of transparency in After
Effects. A mask belongs to a specific layer, but each After Effects layer can contain multiple masks.

Effects:  are another, more advanced way to manipulate objects.

A movie file (ex. a QuickTime file) will be the final outcome of using After Effects.

LECTURETTE 2: ESSENTIAL TERMS AND CONCEPTS

Instructor Note: Take a moment to let the class read through the following terms and then discuss.
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LECTURETTE 3: EXPLORING THE INTERFACE

Instructor Note:  Open the AfterEffects interface and create a new composition while explaining settings and
then point to the interface windows while you name them.

The interface consists of three main windows: the Project window, the Composition window, and the
Timeline window.  In addition there are palettes: tools, info, time controls, and audio.   AfterEffects
defaults to a blank project.  We then open a new blank composition.

Project Window

Composition
Window

Timeline
Window

Tool Palette

Info Palette

Time Controls/
Audio Palettes

If the palettes are not open, you can open them by selecting Tools, Info, Time Controls, or Audio
from WINDOW option on the Menu Bar.  If there is a check mark by the name, then the palette is
open but possibly is hidden by another window.

Steps:

1. Create a new composition window by
selecting Composition > New
Composition. The Composition
Settings window will appear.

2. Name the composition in the Com-
position Name box.

3. Set the Preset (i.e. frame size) to
720 x 480 and NTSC DV, 720 x 480.

EXERCISE 1: EXPLORING THE INTERFACE

Instructor Note: Remember to demonstrate the steps to the users first.  After you have demonstrated, allow
them to repeat the steps on their own.
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4. Set the Pixel Aspect Ratio to D1/DV NTSC

5. Set Resolution to Full.

6. Set Frame Rate to 29.97 frames per second.

7. Set Duration to the expected duration of your project (i.e. Hours : Minutes : Seconds :
Frames). This can be changed later if necessary.

8. Click OK.

Instructor Note:  After the class have repeated these steps on their own, pass out the Job Aid.  Indicate to
the class that for most users, these specifications (other than composition name and duration) will be as
specified here in these steps and are included on this Job Aid.
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As you work with compositions, you also use three other types of windows: Footage windows,
Layer windows, and Effect Controls windows.

Footage Windows: are useful for viewing and evaluating footage items in their original form.
Layer Windows: To view a layer's original source independently of other layers or to trim footage,
you can open a Layer window.
Effects Control Windows: As you work with effects, you use the Effect Controls window to modify
and animate the effects.

LECTURETTE 4: THE INTERFACE IN DEPTH

In a project, you work with footage items using primarily three windows: the Project window, which lists
all the source footage items you import; the Composition window, which displays images as they
relate in space; and the Timeline window, which displays compositions and animation events in terms
of time. Add footage items to a composition by dragging them from the Project window into either the
Composition window or the Timeline window.

Each Composition window has a corresponding Timeline window. When you edit a composition in a
Composition window, After Effects automatically displays the corresponding Timeline window, and vice
versa.

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first, then allow them to practice on their own.

A

B C

D

A. Source Footage B. Project Window C. Composition Window D. Timeline Window
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EXERCISE 2: IMPORTING FILES

Preparing Media
Copy the footage files you will be using from their source (ex. Zip disk, CD-ROM, etc.) to a new folder
on the computer’s hard drive. For the best quality, be sure that all image files (moving and still) are
created and saved at the largest size they will be in the After Effects composition. Images scaled
beyond 100% will lose visual quality.

Once imported, the footage files will automatically appear in the Project window.

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first, then allow them to practice the steps on their own.

This section will introduce the concept of keyframing, which is vital to compositing within
AfterEffects.

First, assume that to animate still images, one must specify some kind of changes in values over
time (such as position). Knowing that, we must create a keyframe to specify these value changes.

1. A keyframe marks the point in time (in the Timeline window) where one specifies a value for a
layer property (for instance, its position).
2. Animation of any kind requires at least two keyframes (i.e. an initial value and a final value).
Change begins at the first keyframe and continues until it reaches the second keyframe.
3. Given two or more keyframes, AfterEffects interpolates transition frames (the frames between
the keyframes) automatically.
4. You will be setting keyframes in the Timeline window for each desired property (ex. position,
scale, etc.) of every object you wish to animate.

(continued)

LECTURETTE 5:  KEYFRAMING

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first, then allow them to practice on their own.

Steps:

1. Click File > Import > File.  A location window will
appear

2. Locate and select the footage file you wish to
import

3. Click Import.  For this workshop, the folder on the
hard drive is called AEWorkshop.  Import the files in
this folder

Note: If importing more than one file: choose Multiple
Files option.  A location window will appear.  Locate and
select the footage files you wish to import onto the
computer, one at a time.
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Instructor Note:  Open the file, keyframes.swf.  Flash 5 player should open.  Read the dialogue on the left
side aloud to the group, giving time for comprehension of each part.  When ready, click "NEXT" to go on.
If needed, click "BACK" to go back one page at a time. Instruct the group to watch the screen as you go
through the Flash movie, following along in their User Manuals if desired.

Instructor Note:  After you have finished with the above, ask the following questions to the users for
review.  Refer to the last frame of the Flash movie (keyframes.swf) to point out the corresponding informa-
tion.

These are the basic principles of keyframes and how to use them. Though this is only a model created for
this lesson, the principles can be directly applied to After Effects, or any program that uses keyframes.

Questions for Review:

Q:  What is done to create a first keyframe for a particular object?
A:  The object is placed in its first position in the Composition window.

Q:  What represents the keyframe in this model?
A:  The blue triangle.

Q:  What does the vertical red bar in the timeline represent?
A:  The current-time marker.

Q:  Describe the two steps necessary to create the second keyframe.
A:  Move the current-time marker to the desired time of the second keyframe, then place
the object in the desired position of the second keyframe.

Q:  How are the frames between keyframes calculated?
A:  After Effects interpolates them automatically.
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This demonstration will show how to place objects into the Timeline window and set the initial
values for transform properties.

EXERCISE 3: COMPOSITING

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first (i.e. do not let them follow along), then allow them to practice the steps
on their own.

Steps:

1. Drag the footage files that you will be using from the Project window to the Timeline window.
They will appear as a list of objects once moved.

Most transform properties’ values can be changed either by setting a numeric value or by using the
appropriate tool from the Tools window.  Both options will be necessary depending on the circum-
stances.

2. Expand properties of item by pressing on the triangle and then expanding the Transform option as
well.

3. Set a numeric value for any transform property by doing one of the following:

♦ Click and hold on the blue number to the right of the property. While holding down the
mouse button, you will be able to increase or decrease the property’s value by scrolling
right or left, respectively.

♦ Set both position and scale, using the selection tool. For position, click the center of
the object in the Composition Window and drag to the desired position. For scale, click
and drag the handles at the corners or sides of the object.

♦ Set the rotation property by using its tool. Select the rotation tool  in the Tools window. In
the Composition window, click on the desired object. Then rotate the object using the
handles.

This is how to place objects in the Timeline window and set the initial transform property values. As we
will see later in the sections on setting numeric values for masks, effects and keyframes, all property
values are set in basically the same way.

Instructor Note:  As you allow the users to practice these steps on their own, instruct them to each try
adjusting the following transform properties by using the appropriate tool (from the Tools window), setting
the numeric values or BOTH if applicable.  POSITION, SCALE, ROTATION, OPACITY.
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This demonstration will cover how to create masks and set their initial values.

When part of a layer is transparent, that transparency information is stored in the layer's alpha chan-
nel.  If the alpha channel of a layer doesn't meet your requirements, you can use any combination of
masks, (mattes and keying also) to display or hide different parts of a layer.

Steps:

1. Select the layer in the Timeline window that you wish to add a mask to.

2. Click Layer > Mask > New Mask. A new mask named "Mask 1" will appear under the
Masks section.

3. Click on the triangle to the left of "Mask 1" to reveal the mask’s properties. You will see
Mask Shape, Mask Feather, Mask Opacity, and Mask Expansion.

Mask Shape controls the shape and size of the mask.
Mask Feather dithers the edges of the mask (for less noticeable edges).
Mask Opacity controls the transparency of the mask.
Mask Expansion scales the mask.

4. Change the Mask Opacity to 41%

5. Change Mask Feather to 5 pixels

EXERCISE 4: MASKING

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first (i.e. do not let them follow along), then allow them to practice the steps
on their own.  For this exercise,

To adjust the values of any of the four
mask properties, click on the numbers
or words to the right of the property’s
name and enter a value or click, hold
and scroll (the same way transform
properties are adjusted).

The tools from the Tools window (used
on the transform properties) can also be
used to manipulate masks such as
moving the position of the mask using
the Selection Tool.
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Instructor Note:  Remember to demonstrate first, then allow the users to complete on their own, following
the steps in their User Manuals.

EXERCISE 5: EFFECTS

LECTURETTE 6:  EFFECTS

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first, then allow them to practice on their own.

When you apply an effect to a layer, the Effect Controls window opens; the effect is listed there.
Each layer to which you apply effects appears on its own tab in the Effect Controls window. The
effect is also listed in the Effects section under the layer name in the Timeline window.

 If you apply additional effects to the layer, they are listed under the first effect in the Timeline
window. Effects are rendered in order from top to bottom in this list. You change the order in which
effects are rendered by dragging the effect name to a new position in the list.

All effects and their various property values are created and set in basically the same ways.  All
effects included in After Effects are listed and described in on-line Help. You can print any Help topic
at any time.  For detailed information about an effect's controls, and specific procedures on certain
effects, see the AfterEffects product section on Adobe's Web site.

Steps:

1. Select the layer in the Timeline
window that you wish to add an effect
to.

2. Select the desired effect(s) by going to
Effect at the top of the screen. For
example, click Effect > Blur & Sharpen
> Directional Blur.  The Effect Con-
trols window will appear.

3. In the Effect Controls window, adjust
the values (in this example, Direction
and Blur Length) as desired. The
values can also be set in the Timeline
window by changing the numeric value
to the right of the property (the same
ways as described before for transform
and mask properties).

Instructor Note:  As the Users repeat these steps, instruct each participant to try adding a Motion Blur to
their desired layer.  Then let them choose an additional effect of their choice from the effects list, notice its
specific properties, and try adjusting those properties.  Have them discuss the different effects they
discovered with the participants next to them, the properties involved with that effect and how adjusting those
properties’ values changes the layer.
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♦ adding a mask
♦ setting its shape to an oval, its feather to 5 pixels, its opacity to 50%
♦ adding an effect (Image Control > Tint)
♦ setting Map White to a Red color
♦ adding an additional effect of their choice and changing those settings

Repeat this with multiple effects (if necessary) so everyone has a turn.

Instructor Note:  Have a series of people come up to the projection screen-equipped computer and
demonstrate these skills, one person per item on this list (or combine tasks if only a few participants are
present).

REVIEW MASKING AND EFFECTS

LECTURETTE 7:  SET KEYFRAMES AND SAVE WORK

Instructor Note:  Remember to demonstrate key items and concepts on the overhead.  Also, remember to
go over any steps for the users first, then allow them to practice on their own.  For this example, you will use a
new layer and animating position as your example.

This demonstration will show how to set keyframes to animate objects and also briefly cover the
importance of saving your work often. Please observe for now, we will have a chance to practice in a
moment.

Set keyframes to animate objects:

Activate the time-vary stopwatch (circled)
for the layer you wish to animate. Do this by
clicking on the stopwatch-shaped icon located
to the left of the layer property (ex. to the left of position)

When the time-vary stopwatch is activated,
a keyframe (circled) will be appear wherever
the current-time marker (red line) is currently located.

To add an additional keyframe, place the
current-time marker in a new position and
set the property’s value any of the ways
discussed before (i.e. setting a property’s
initial value). Another keyframe automatically
appears and another diamond will appear
along the timeline once a new keyframe
has been set.

To remove a keyframe, highlight the keyframe by clicking on it once, then press the delete key.

To remove all keyframes for a given layer property, deactivate the time-vary stopwatch by clicking
on it.  If you accidentally get rid of your keyframes this way, choose Edit > Undo.

To show the animation between the keyframes press play on the Time Controls Palette or press the
spacebar with the Current Time Marker at the beginning point of the animation.
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Be sure to save your work often. It is also advisable to save various versions of your work as you
progress. This way, if a mistake is made and then saved, an older version can be recalled. Saving
options are found under the File menu.

When saving work to removable media (ex. Zip disk, CD-R or CD-RW), be sure to copy the AfterEffects
project file as well as all source media (i.e. footage files). The file After Effects creates when you save
only keeps track of the manipulations you make to your media. The media is only referenced from the
original image, movie and sound files.

Instructor Note:  You do not have to demonstrate these steps first, as you already went over them in the last
lecturette.  Just allow the users to complete on their own.

EXERCISE 6: SET KEYFRAMES AND SAVE WORK

Steps:

1. Add a keyframe by activating the time-vary stopwatch for a particular property, placing
the cursor on a new point in time and changing the property’s value.

2. Remove a keyframe by highlighting it and pressing delete and replace it in another
location on Timeline.

3. Deactivate the time-vary stopwatch to remove all keyframes for a particular layer, then
Undo.

4. Save the project to the hard drive by going to File > Save As. . .

♦ open a new layer and activate the time-vary stopwatch on the computer
♦ add a keyframe for a property and change its value
♦ add another keyframe for the same property and change its value
♦ demonstrate the animation created by the two keyframes.
♦ delete all the keyframes in the layer by deactivating the time-vary stopwatch

Instructor Note:  Have a series of people come up to the projection screen-equipped computer and
demonstrate these skills, one person per item on this list (or combine tasks if only a few participants are
present).

REVIEW SETTING KEYFRAMES
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Instructor Note:  Remember to demonstrate the steps on the overhead first, then allow the users to
complete on their own, following the steps in their User Manuals.

EXERCISE 7: EXPORT FROM AFTER EFFECTS

This demonstration will show how to export a QuickTime video file from AfterEffects. Please observe for
now, you will have a chance to practice in a moment.

Steps:

1. Click Composition > Add To Render
Queue. The Render Queue window will
appear.

2. The composition you have been creating will
be highlighted in black in the Render Queue
window.   Click the triangle to the right of
Render Settings: and select Best Settings.

3. Double click on Output Module to bring up
the Output Module Settings window. Set
Format to QuickTime Movie.

4. Make sure the Video Output box is
checked.

5. Under Video Output, click Format Options.
The Compressor Settings window will appear.

6. For Compressor, select None and Millions
of Colors+.  Set the Quality slider to Best.

7. Click OK.

8. If your composition does not have audio,
make sure the Audio Output box is not
checked. If your composition does have
audio, place a check in the Audio Output
box.

9. Click on Format Options. The Sound Settings window will appear.  Select the following
values:

♦ Compressor: None
♦ Rate: 44.100
♦ Size: 16 bit
♦ Use: Mono or Stereo (*depends on your specific audio source)

Click OK

10. Click OK to close the Output Module Settings window.



 

File name: AfterEffect5_Instructor.pmd
Last modified: 05/24/02

Copyright Arizona Board of Regents, 2002
University of Arizona

16 AFTER EFFECTS 5: Instructor Manual

11. Click on Not Yet Specified to the
right of Output To: to set your file’s
saving destination and name. The
Output Movie To: window will appear.

12. Name the movie file and select an
output destination on the hard
drive.

13. Click Save.

14. Click Render to begin rendering your composition into a movie file. When finished, the
movie will appear as a file in the location you saved it to.

This is the detailed procedure for exporting an After Effects project as a full-resolution, "best quality"
QuickTime movie file. It is not recommended that you compress your video within AfterEffects, but rather
use Media Cleaner.

Instructions and settings for creating a full-resolution QuickTime are found in the Job Aid, again it is not
advised to compress the QuickTime using AfterEffects rather first Save the high-resolution movie and
then compress in Media Cleaner.

At this time you should be able to import files into AfterEffects,  set the original settings, animate
files using keyframes, save and export the composited project as a QuickTime.

Are there any questions before we move on to the Criterion Test?

FINAL REVIEW
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Instructor Note:  Instruct the students to turn to the last page of their User’s Manuals.  Inform the
students they have 20 minutes to complete the Criterion Test.  At the end of the time allowed, check
the students’ final products to ensure they have passed successfully. Answers are noted in italics.

CRITERION TEST:
20 min

Write the answers to the following questions:

1. What is After Effects used for?
Compositing,  Motion Graphics, Video Effects

2. What is a footage file?
Any sound, movie or picture file (such as .aif, .mov or .tif) that After Effects supports

3. What is an object?
Any footage file that has been placed into the Composition and Timeline windows

4. What are the four primary Transform properties?
Position, Scale, Rotation and Opacity

5. What are masks used for?
blocking out and/or revealing portions of the composition

6. How are effect properties set compared to Masks or Transforms?
The same way

7. What will the final product of After Effects be?
A movie file (QuickTime)

8. Which of the following lab clients should use After Effects?
A. Someone wanting to digitize and edit video
B. Someone wanting to create an interactive web page containing video
C. Someone wanting to animate titles and audio into a video

Complete the following tasks. Have the instructor verify that the task was successfully completed before
moving to the next task:

1. Open After Effects 5.
2. Create a new composition and set the correct initial values.

(Check against Instructor Manual)
3. Import footage files from the “AE5 Module Media” folder on the desktop into the Project window of

After Effects.
(Check that Project window contains all footage files)
Show the instructor what you have done before proceeding.

Write the answers to the following questions about keyframing:

1. What is a keyframe used for?
To control various property’s values over time

2. What information is contained in a keyframe?
The value of the property and the point in time

3. How many keyframes must be set to animate objects?
At least two

4. How are the frames between keyframes calculated?
After Effects interpolates them


