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NB 900 GPS Quick Guide V2.0

1. Introduction

NB 900 GPS is a simple and yet powerful software. It operates on Windows 7, Vista, and XP. If
the software has been successfully installed, you may read workout history, track logs, and paths
from GPS watch in just a few clicks. Communication between watch and PC is done through the
dedicate USB clip cable. It comes together with the GPS watch. If you require 3D satellite map
viewing of track logs and paths, you need to install Google Earth (GE) separately. GE is free from
Google. You can download it from this link:

http://earth.google.com/download-earth.html

It is recommended to download GE and install GE before using NB 900 GPS. Please make sure

that you have the USB clip cable and GPS watch ready with you when you use NB 900 GPS.

1.1 Features:

[ Support multi users that share a single or multiple watches
[ Show multiple workout graphs in one screen

[ Show workout path in Google map

[ Interactive logged track transfer to GE

[ Easy path editing in embedded Google Map environment
[ Easy to use workout history hierarchy

[ Tracks or paths can be transfer to friends electronically. So that they can follow and share

your wonderful experience.
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An panorama view of NB 900 GPS workout log together with Google Earth

1.2 Create User and Login to NB 900 GPS

If you use NB 900 GPS for the first time, you will see the following screen:

’Lugin @

Data Path

C:\ProgramData\NB 800 GPS\wuser .
Reset to default

User

Remove user

If you want to change the database location other than the default one, you may do that in the

"Data Path" box.

Page 2 /27

www.newbalance-watch.com




new balance _g Gp51

The user database is empty after the first time installation. You have to create new user(s) now. If
you have more than users you can add as many as you want here. Just click the "Add" button

and give it a name in the "User Name" box.

Add User ==

Mew user

User name

Cancel

If you forgot to add the 2" or more users, you still can do that afterward in the User menu. As

you have finished adding users select the user you want to play with, then click "Login" button.
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2. Operating Instructions

NB 900 GPS Screen Layout
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Speed (km/h)

Show Lap Details

lkem Data

Start Time
Total workout time

23:.06:02
00:14:56
No. of laps 3
Total distance (km) 2.014
Pace Avg. (min/km) 0724
Avg. Speed (km'h) 8.1 8

01 2 3 4 5 6 7T & %1011 12 13 14 15
Smoothing data

Ready MB 900 GP5v2.0.11 Watch

Summary information of workout Select X-axis data

The main screen is divided into 5 sections:
l. Menu bar

Il. Calendar

I1l.  Workout history

Ic. summary of selected workout

e Map view

¢l. Graphical views of the logged data

Workout History
ﬁ The workout history without GPS log
# The workout history with GPS log
You can click the workout history with # icon on the left hand side to launch the Google

Earth. The Google Earth setting can be set in the menu (Setting>QOption)
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Note :
There is no effect when you click the workout history with ﬁ on the left hand side. Google

Earth will NOT be launched since there is no GPS data in file.

Workout History Remark
You can make a short note for a workout. It is limited to 64 characters long. This remark is

saved in the selected workout file.

Report
Click the "Report” button to generate the daily, weekly, monthly and yearly report. Statistics of

distance, speed/pace, heart rate, and calorie are provided in this summary report.

Activities

Workouts can be classified and stored into different activity categories such as running, cycling,

hiking, etc. NB 900 GPS creates the <default> activity after installation. All workouts are placed

into this activity unless it is changed manually. The <default> activity can neither be deleted nor

removed. You are free to create and manage your own activities with the following buttons:

a. Click "+" button to add a new activity. You may add as many activities as you want provided
that the hard disk storage is sufficient.

b. Click "-" button to delete current selected activity. Be aware that all the track logs under this
activity will be removed at the same time. If you want to keep part of the workouts you must
move them to other activity deliberately.

c. Click "a=b" button to rename current selected activity.

To select a different activity, click the combo box next to "Activity” and select the desire activity
from the given list. All data downloaded from watch will be stored into this activity afterward. To
move a workout to a different activity, right click the workout, a popup menu will be displayed

and select "Move to activity”. The following dialog will be shown. (e.g. Running and hiking

activities were previously added)

Mowe @

Select destination activity

=

Hiking

Select an activity and press "Move” button to confirm.
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Google Map
Workout path will be shown in Map area if selected workout has GPS data.
Note :

Internet connection is required for showing Google Map.

Graphical Views

Finger touch mode is used when the button is checked. Normal HR mode is used
L] I. when the button is unchecked.

Graphical data will be shown when the button is checked.

,-__.i‘"i-- To add or remove charts

rCharts @

Available Selected charts

Altitude Speed

Distance
Heart rate

Pace Cancel

There are 5 data types (Speed, Heart Rate , Altitude, Distance and Pace). You can

plot all of them against time / distance.

Note:

The first item in "Selected charts” will be plotted in major Y-axis.

% Zoom all
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Zoom area

Step 1: Place the cursor at the beginning of the area you would like to select.

Step 2: Hold down the "left mouse button” and move the mouse (drag) over the area you want
to select.

Step 3: Release the mouse button

Step 4: Then, the selected area is zoomed.

Selected area for zooming

. Speed (kmih) \
G0 /"

40

20

Zoom Previous

Clicking right mouse button will zoom previous area
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Panning

- Speed (kim/hj
o VM

4an Effective
panning area

PN A

] 2 10 194+ 20

Step 1: Place the cursor in the pan area
Step 2: Hold down the "left mouse button” and move the mouse (drag) over the area you want
to move.

Step 3: Release the mouse button

Note:

The panning function is disabled when the chart is in zoom all status.
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2.1 File

You can issue IMPORT, EXPORT workout log functions here. All workout logs are stored in a
directory specified by the Data Location path. Data Location path can be modified in
Setting 2 Options menu. There are 2 types of files in the database. One has file extension .ss
and the other .tkl. A .tkl file contains workout with GPS track log. A .ss file contains workout
without GPS log. Files names are derived by its date and time stamp. For example if a
workout was logged at 20:26:08 on Jan 7, 2010 with GPS data. The corresponding file name
should be "20100107202608.tkl" after it has been transferred into PC.

211 IMPORT function reads a WORKOUT file and places it into the database of the
current user. In order to save the file to proper location in the database. The file
name should follow the naming convention described above.

21.2 EXPORT function saves the selected WORKOUT in either NB 900 GPS format
(.tkl) or several other file formats supported by some popular softwares. NB 900
GPS can export :

.kml | supported by Google Earth

.gpx - GPX (the GPS eXchange Format) is a light-weight XML data format for the
interchange of GPS data (waypoints, routes, and tracks) between applications and
web services on the Internet.

.nmea [The National Marine Electronics Association (NMEA) has developed a
specification that defines the interface between various pieces of marine
electronic equipment. The standard permits marine electronics to send
information to computers and to other marine equipment. Most GPS devices
support NMEA file format.

.pth { The select workout track is converted to a PATH. It can be loaded to the
watch for navigation directly. You have to define either maximum number of
waypoints (N) or the distance between 2 waypoints (D). Change one setting will
affect the other. Maximum number of waypoint is limited to 99. The whole track is
divided into N-1 equal distance segment. Waypoint is created at the end of each
segment. The newly created PATH is stored in the Path Library folder.

.Ccsv - A comma-separated values (CSV) file is used for storage of data structured
in a table of lists form, where each associated item in a group is in association with
others also separated by the commas of its set. Each line in the CSV file
corresponds to a row in the table. Within a line, fields are separated by commas,
each field belonging to one table column. You may import .csv file into Excel

spreadsheet directly.
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2.2 View—>Refresh
Re-read WORKOUT history and update hierarchical tree

2.3 User

2.3 User->Add
Create new database structure for a new user
2.3.2 User->Switch user

Log-in to a different user.

2.4 Data Transfer

2.41 Data Transfer > Receive watch data
Before you activate this function please make sure that USB cable has been
plugged into PC and the clip has been attached to the watch correctly and
securely. Once everything is fine, data transmission will be complete in a couple of

minutes.
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Browsing around workout information in NB 900 GPS is simple. Imported items are placed in
the Workout History tree. It is arranged in a tree fashion hierarchy in order. New tree nodes
are created automatically after new workout data has been read from watch or imported
from a file. Just select or click the activity as you are interested in the History section, then
associated summary information will be shown in the Summary section. If track log is
available, track data can be viewed from GE immediately. Meanwhile 3 selected graphical
charts are plotted on the left. Each chart can be customized to specific workout data. A
button attached at top left corner of each chart is dedicated for this purpose. Kick and pick
the desired type of data to be plotted in the y-axis of this chart. The selection box at the
bottom right corner depicts the x-axis to be either TIME or DISTANCE. The calendar
provides a shortcut for searching for workouts which are far away from current workout

item.

Selecting the "Smoothing data” check box, moving average filter is applied. Short-term

fluctuations will be smoothed out.
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2.4.2 Data Transfer 2 A-GPS (Optional)
AGPS, stands for Assisted GPS, is a method which accelerates the time required for GPS
module to "fix" onto Global Positioning Satellites, thus aiding the GPS receiver to perform

a faster positioning calculation when under a weak signal environment.

A-GPS data is storing in a server. NB 900 GPS will download A-GPS data from the server
and transfer to the watch. The validity period of A-GPS data is 7 days.

Note :

Internet connection is required for A-GPS function

Please refer to section 2.6.5 for A-GPS smart update.
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2.5 Path-> Path Manager

2.5.1 Path Manager

NB 900 GPS watch has 10 individual paths (or routes). A path has maximum 99 waypoints.
Paths can be created by the embedded Google Maps (GMAP) path editor. Paths can also be
read from the watch after they have been created manually. Or they can be created by GE
and import to here. Please refer to the detail instruction of Add->Path section in GE.

There are 3 major sections in Path Manager: Current Paths, Path Library, and embedded

GMAP path editor.

Path library Current Paths

Path Manager

Path library m Current path Import I Del. I Close

waypoint

kem Path Description tem Path Description

2 - 0
3 0
4 0
5 0
Path editor Mews path Save path Export to GE
Distance - Delete a waypoint | Delete all waypoints |
| Map | Satellite
S X :
/: ;\ 'I \I.I 1t.
s i i
E Asia
[ @b 5
‘\ Morth Europe
l[U] An'u?\:rica
- Atfantic
L_:J Oeean
i Africa
South i
" T America " T
1 ol Irdian ! e
Australia ! Lecarn Chiean Australia i LA
i i
i i
_‘F'_I
e |
Antarctica s oillze
Press F2 to edit k
GMAP Path Editor
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a. Path Library Section

User can store unlimited number of paths in the path library. Path in library can be edited

and transfer to current path section by pressing button | == | and then upload to the

watch. Workout track can be transformed to path and placed in path library in the
File=>Export>select .pth or right click workout history and hit "Save to Path Library”

menu

b. Current Path Section
This is a temporary buffer storage for the 10 paths read and write to watch. All 10 paths
are transferred to and from watch at the same time. Reading path from watch overwrites

existing content in the buffer. If you want to keep a copy for later use, you have to copy

it to the Path Library using the | == | button. Similarly paths in Library can be brought

to Current Path by clicking| == |button. Path name can be edited. Select a desire path,

then either push F2 key or click the | =P | button. Path name is limited to 32 characters

long.
@ —PC Send paths from watch to PC
pc_,@ Send paths from PC to watch
1t 4 Change the order of selected path in Current Path section
import Import a .kml file generated by Google Earth (Please refer to
- section 2.5.2)
OR
Import a .pth file generated by NB 900 GPS
Del. Delete current selected path
a—b Rename current selected path
< Copy a selected path in Current Path section to Path Library
Export to GE Open selected path with Google Earth

c. Path Editor Section
As you select a path, disregard it is from Current Path or Library, it is plotted graphically
in GMAP. Waypoints are shown with place mark. Waypoint name is displayed when
mouse cursor is put on waypoint marker. Name can be edited by double clicking the
marker. Waypoint name is limited to 10 characters long.
To create a new path from scratch, press "New Path” button, path editor will load Google
MAPS as below:
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Path Manager @
Path library Current path Import I Dl I Close

tem Path De=scription tem Path Description waypoint

Path editor Mew path

Distance : |3.828 km / 2.378 mi

e =

&
&

=

Borough

4395'&

H BFIIMAX =
- Young Vic =
e = G ]

Walerloo
The Westminster,
Collection

College Ministry Dicke 5 L
i} T 4 L of Sl RE g dats 82012 Goonks- rms of Lse
Wictoria Tower s of Sound oG Map dats"@2012 ,.Ig Terms of U

Press F2 to edit

1. Press map control to pan in four directions, and to zoom-in and zoom-out.
Left-click mouse button to place a placemark. The green placemark is the active
placemark. "Delete a waypoint” button deletes the active placemark.

2. After you have created a path, press button "Save path”. You are prompted to enter
a path description. You can select the save location either "Path Library” or "Current

Path"” . Then press "Save & Exit" button to finish
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Path

tem Name

Waypt1
Waypt02
Waypt03
Waypto4
Wayptls
Waypt0s
Waypt07
Waypt0d
Waypt0g

=T == T B S I L

Path Description

Save location

Lengitude

-0.1241970
-0.1187338
-0.1188755
-0.1156998
-0.1090908
-0.0965595
-0.0885773
-0.0871181
-0.0934598

Save

Latitude

51.5008890
51.5007821
51.5039878
51.5069795
51.5082617
51.5079946
51.5063918
£1.5005433
£1.5108258

@ Path Libary

® Current Path

and exit

Cancel

Path Editor Street View Function
Street view is supported in many countries. Please refer to the following link

http:/amaps-samples.googdlecode.com/svn/trunk/streetview_landing/streetview-map.html

1. Drag the Pegman [E[] to your desire location
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Delete a waypoint |

Delete all waypoints
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L

Atna

% ]
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2. The street view is available in roads with a blue boarder. Then drop the[m]

Delete all waypoints

= =] =

UM =]

a T QL
o Ly >

ROV W 4

Satellite :

3. Street view image will be shown

Distance - |3_828 km / 2.378 mi Delete a waypoint Delete all waypoints
N
A Westminster Bridge Road, Lambeth

Address is approximate

<&y
&,

Rotation control

y

Westminster Bridge Road * . Westminster Bridg ‘ Road

Google

© 2011 Google - Terms of Use

4. D rag the ring in rotation control to rotate the view. And slide zoom control to change the

zoom factor of image.

5. To exit street view, press X
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2.5.2 Create a path using Google Earth
Open Google Earth and select menu "Add->Path"”

b. Left-click mouse button to add new waypoints to the path as the Add->Path dialog is
opened.

c. Right click the newly created PATH under the Temporary Places in the middle of the

sidebar then saves it as a .kml file as shown in the picture below.

= Google Earth

Google Earth - New Path

Name: Disney Tour -

| Description | Styte, Color | View | Alimds |

Lines

Color: [ Width: 40 2] Opacity: (1008 ¢

L

Imagety Date: Feb Eyealt 462m

= Google Earth
Eile Edit YWiew Tools Add Help
* Search

| FlyTo | Find Businesses | Diractions |

Flytoe.g,, 3725'19.1'M, 1220506"W

Snapshot View

Froperties

I » Lavers

Now you can import this path to NB 900 GPS’s Path Manager by clicking the Import button
and browse for the path (.kml) file created by Google Earth.
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2.6 Setting 2 Watch Configuration

2.6.1 Setting & Watch Configuration - View Setting

The Watch offers 5 activity profile (Running, Cycling, Hiking, Sailing and User by default).
Each profile has 3 views with 3 data lines each. Users may create any combination that and
review their performance easily. Profile setting can be done in watch. Or it can be

manipulated in PC more easily. Transfer profiles to and from PC only takes a few seconds.

Watch configuration

View zetting | Uzer data |

(5]
.

Profile Load

CuStm'zE Runfing Rename
MRURNING | cvong f

'JC]."'IE Hiking Save selected

Hikiﬁ9 Sy Save all

User

Data view 1 Data view 2

|Di3tance v| |Lap Number v| |A|titud&

| Pace Avg. - | | Heart rate Current - | |Tim& of Day

|W|:|rk|:|utTime v| |LapTime v| |L“.al|:|rie

Reset to default |

Read zetting from watch Write zetting to watch

Press "Write setting to watch” button writes all Workout Views to the watch. Reset View
settings to factory default by pressing "Reset to default” button. Please note that watch’s
workout Views are downloaded at the same time when workout data is being transferred to

PC.

Activity profile name (max. 10 characters) can be modified by pressing "Rename” button.
Profile name editing cannot be done in watch. Activity view setting is saved to an .ACT file in
the ActivityLib folder under the user’s own directory eg. "c:\program files\NB 900
GPS\user\John\ActivityLib". They can be reloaded by clicking "Load" button and then to
transfer to the watch later. That means your are not only limited to 5 activity profiles. You

can customize any activity profile, store it in PC, and retrieve to watch as you wish.
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2.6.2 Setting » Watch Configuration 2 User Data

Watch configuration @

“View setting User data | unit |

E=N

Cancel

Birthday 1/ 111880 [G~

Weight 70

Read setfting from watch Write setting to watch

User’s gender, birthday and weight can be set here

2.6.3 Setting » Watch Configuration 2 Unit

Watch configuration @

Wiew setfting | Userdata  Unit

Cancel

Distance / Speed [Ekm, kmih

Weight | kg

Time format |24h -

Read setting from watch Write setting to watch

In "unit” tab, measuring units and time format are set here.
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2.6.4 Setting =2 Watch Firmware update (Optional)
The watch firmware will be released from time to time. Press "Check now" button will

check if latest watch firmware is available.

o )

Watch firrmware update @

Check for update

NB 900 GPS will compare the watch firmware version and the latest version in the
server. If a new watch firmware is available. Press "Yes"” button to download it and

update to the watch.

Note :
All the data will be ERASED during watch firmware updating process.

’Message @ﬁ

Anew watch firmware (1.20.19) is available !

Mote :
The firmware update will ERASE ALL workout and paths in your watch.

Do you want to proceed ?

Connect the USB clip cable and press "OK" button.
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Watch firrmware update @

o

f . \ Please connect USE clip cable between watch and PC and then press
OK button,

QK l | Cancel

After the watch firmware has been downloaded to the watch, the updating process is

done by the watch itself. You cannot access the watch until the connection icon

o= appears on the watch again.

r -

Watch firmware update @

Watch firmware is updating. Please wait about a
minute to complete the process.
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2.6.5 Setting 2 Option

[ Option @
Diata transfer
& Receive workout history ONLY
@ Receive workout history and paths

Auto-clear memory
B Awuto-clear workout history after data transfer

B Eui-cieer path: aiher daita trans ey

Data Path

cProgramDatahME 900 GPS\user -

Google earth setting

@ Single-click launch & Double-click launch @ Disable

B Show seiting dialog

Route line width

Min. 2pt. distance

Show lap information
B Show split markers

B Show data points

Language

English (English) - B Smart update

a. Receive workout history only

Both workout history and paths are stored in watch’s memory. Select "Receive workout
history only”, the workout history will be downloaded from watch to PC. But paths stored
in watch WILL NOT be transfer at the same time. User can separated upload or download
paths in Path->Path Manager.

b. Receive workout history and paths

Select "Receive workout history and paths”, the workout history and paths will be

downloaded from watch to PC at the same time.
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C. Auto-clear memory
If this option is activated, workout history in watch will be cleared after data transfer of

has complete.

d. Database location
NB 900 GPS maintains users’ workout history databases and paths in a particular
subdirectory. This is the root directory of NB 900 GPS’s database. Every user has its own
subdirectory under the root directory. Workout files are arranged under the user
subdirectories in chronological manner. Name of a user subdirectory is the same as the
user’s login name. The whole database or data of individual users can be backup by

copying the corresponding directory to another backup location.

e. Google Earth Setting
NB 900 GPS allows users to launch Google Earth by either single-click or double-click
mouse button. If "Disable” option is selected, it will NOT launch Google Earth.
When the option "Show setting dialog” is checked, the setting dialog will be shown when

you launch Google Earth.

f. Language
User can change the language of NB 900 GPS. Press "Save & Exit" button to confirm

g. A-GPS Smart update
A-GPS data from the server automatically and transfer to the watch if smart update

option is checked.

When smart update process is completed the following message will be shown:

a-GPs ==

Drata transfer is completed

-

OK

h. Run on system startup
It is suggested that this option and smart update option should be checked. When you

connect clip cable to PC for battery charging, A-GPS data is transferred automatically.
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2.7 Close & Exit NB 900 GPS

Press @ close button, NB 900 GPS will be minimized to the system tray. (The system
tray is located in the Windows Taskbar, usually at the bottom right corner next to the

clock.)
To bring NB 900 GPS from the system tray, click the NB 900 GPS icon.

Customize...

To exit NB 900 GPS application, select menu "File &> Exit".
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Troubleshooting and FAQ

1. Why does it show "Open virtual COM port error” / "No virtual COM port is found” when

| receive watch data?

Solution
a. Please check if the USB driver is installed or not.
For XP, select "Control Panel->System->Hardware->Device Manager". Expand "Ports”

For Win7, select "Control Panel"->Device Manager”
If the icon next to "Silicon Labs CP210x USB to UART Bridge" has a cross #or

exclamation mark, the driver is not installed correctly. When the driver is installed

properly, it will show as follows:
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b. Please make sure USB clip cable has been plugged into PC and the clip has been
attached to the watch correctly and securely.

c. Make sure ONLY ONE "NB 900 GPS" software is running. Do not run many copies of "NB
900 GPS" software in a PC.

2. Why does it show "Error in communicating with watch !I" when | receive watch data?

Solution :
a. Please make sure that USB clip cable has been plugged into PC and the clip has been
attached to the watch correctly and securely. Once connected USB clip cable between

watch and PC, "Connected icon” will be shown on watch screen.

g

3. Why does it show "Cannot find Google Earth in your system !" when | click the workout
history with GPS data ##?
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Solution :
a. Google Earth is not included in the installation file. Please download it from

http://earth.google.com/download-earth.html

After Google Earth is installed, the NB 900 GPS software will launch Google Earth when
you click workout history with GPS data .

4. Why does it not call Google Earth when | click the workout history ?

Solution :

a. Please make sure clicking the workout history with GPS log (there is a # icon on the left
hand side of the workout history). Clicking the workout history with ﬁ icon will not
launch Google Earth since there is no GPS log in the history file.

b. Make sure Google Earth is installed in your system and work properly.

c. Check the setting in the menu (Setting->_Option)

@ Single-click launch @ Double-click launch @ Di=able

Make sure "Disable” option is not selected. If "Disable” setting is selected, Google Earth
will not be launched by NB 900 GPS software even Google Earth is installed in your

system.
5. Why does it show nothing when | click a path in "Path Manager” ?
Solution :

a. Please check internet connection. NB 900 GPS needs the internet connection to reach

Google Map web site.
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