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Version Control 

Version Date Notes Written By Approved By 

1.0.0 11/10/2012 First Edition MW CB, KC 

1.0.2 09/01/2013 Release Edition MW  

2.0.0 13/06/2013 Version 2 Functionality, Windows 8 MW  

3.0.0 21/08/2013 Version 3 Functionality MW KC 

4.0.0 10/12/2013 Version 4 Functionality, JSON Conversion MW  

4.0.1 01/05/2014 SEO Meta tags, Image Alt Tags MW  

5.0.0 23/01/2015 Version 5 new features, Responsive 

checkout support 

MW  

6.0.0 02/10/2015 Rebranded MW  

 

Prerequisites 

• A Shopify web store has already been registered and is configured with a payment gateway. 

For further information please see the Shopify – Getting Started guide. 

• Microsoft Dynamics RMS Version 2 is installed and configured with a valid SQL database 

• RMSify has been installed to Shopify, downloaded to the RMS system, and installed and 

configured with the RMS database. For more information see the RMSify – Installation 

Guide 

• It is assumed the reader has some knowledge of RMS and how it works. This is not designed 

to be an RMS user manual. 

• It is assumed some basic knowledge of Shopify has been learned. For further help see 

http://www.shopify.com 

• Support for RMSify is provided only for installation, configuration and synchronisation of 

RMSify by email only: support@k3retail.com. If you would like K3 Retail to provide support 

for RMS and/or Shopify, please contact +44 1675 463032 or email coleshill@k3retail.com 

• Support does not ever cover themes, search engine optimisation, or web marketing tips 

System Requirements 

• .NET Framework 2.0 

• 1gb RAM (2gb Recommended) 

• User must have windows administrator privileges 

• Windows XP SP3+, Windows Vista Business, Windows 7 Pro or Windows 8 Pro, Windows 10 
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1. Introduction 

RMSify is an add-in developed and supported by Retail Technology Ltd, and is designed to provide a 

full integration between Microsoft Dynamics RMS, and the popular eCommerce platform, Shopify. 

The add-in must be installed through the Shopify App Store, and you must have a valid Shopify 

account in order to install it. It’s easily found by searching for “RMSify” at http://apps.shopify.com 

The software itself is a single installer which can be used anywhere in the RMS estate. There are no 

different installers for Headquarters, Store or POS as there are with other integrated solutions. It’s 

one simple package which can be installed wherever you need to run it. The package consists of 2 

components. 

• RMSify Sync – This is the application which synchronises your product data between RMS 

and Shopify, and is also where all settings are configured. RMSify Sync can either 

synchronise data from RMS to Shopify, or the other way round – from Shopify into RMS. This 

can be run on a Store Operations database or a Headquarters database and it will 

automatically detect which it is and behave accordingly. This is usually operated from a 

“Back office” computer. 

 

• RMSify Web Orders – This is the application which runs on the till and allows the process of 

Shopify Web Orders through the RMS POS interface. It retrieves outstanding orders from 

Shopify to allow a “Picking List” to be printed to your receipt printer. Once picked, it imports 

the order as a standard POS transaction and allows you to tender the transaction as per 

RMS. It then notifies Shopify that the order has been shipped. It can only be launched 

through a Custom POS Button and therefore can only be run on an RMS Point of Sale. 

As already discussed, RMSify can be used in Store Operations and Headquarters, or a combination of 

both. Here are the supported topologies which you can deploy RMSify to. 

• Standard Headquarters – This scenario is when product data is synchronising from the 

Headquarters database. All web orders must be processed through an RMS POS, and you 

must choose which store is going to be used to process your web orders. You can optionally 

choose which “on hand” figures you want to use in Shopify – Either the quantities from the 

store you selected as your web store or the total of “on hand” quantities from all of your 

stores. In this scenario, it is not possible to run Sync and Web Orders on the same physical 

computer.  

 

• Store Only Headquarters – This scenario is when your store is part of an RMS Headquarters 

chain, but product data and web orders are all processed through a single store as part of 

that chain. This is not recommended, as any product data amended at store level is liable to 

be overwritten by an RMS Headquarters Worksheet. In this scenario, only local store 

inventory data is used for your Shopify inventory levels.  

 

• Single Store – This scenario is when you have only one RMS store. Both RMSify Sync and 

RMSify Web Orders run from the single store database.   
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1.1. Login 

Upon launching RMSify, you will be presented with a Login screen as shown below. 

 

The RMSify Login makes use of the usernames and passwords you already use in RMS.  

If it is installed to a Headquarters database, you would log in using the credentials used for 

Headquarters Manager. The Headquarters user must have “Administrator Rights” to be able to use 

the application on a Headquarters database. 

If it is installed to a Store Operations database, you can use the credentials you enter to access Store 

Operations Manager or Point of Sale. The user must have “Manager Rights” in order to run the 

application for a Store Operations database 

If you do not want to be prompted to log in each time you run the application, check the Do not ask 

me to log in again box. 
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2. Overview 

RMSify can be launched from the Start Menu through Start > All Programs > Retail Technology Ltd > 

RMSify, or if you are using the standard RMS addins path, it will be accessible through Utilities > 

Addins > RMSify  in Store Operations or Headquarters Manager. 

These will always launch the main RMSify application, which is known as RMSify Sync and is shown 

below.  

 

Additionally, there is an application called RMSify Web Orders, and can only be opened through a 

“Custom POS Button” on the POS. This button is automatically created upon the launch of RMSify 

Sync. This is shown below.  
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2.1. Menus  

The menus allow you to access various tools and functions within the application. 

File > Database Settings This will let you switch between RMS databases 

File > Exit   This will exit the application 

Options > Settings  This will take you to the settings screen to configure the software 

Options > Backup Database This will backup the database the application is using 

Options > Require Login This will toggle if you are required to log in to the app or not 

Updates > Check For Updates This will update the software to the latest version 

Tools > Scheduled Stock Up… This will allow you to schedule an automatic stock quantity update 

Tools > Multiple Web Stores This is where you configure RMSify to update multiple web stores 

Tools > Web Item Filter  This is where you can filter what items get published to the web 

Tools > Custom Fields  This is where you define custom fields to extend your database 

Tools > Quick Editor  This is where you make quick wholesale changes to your database 

Tools > Print Logs  This will print the log from the user interface to help troubleshoot 

Tools > Delete All Custom… This will delete all custom collections from your Shopify store 

Tools > Delete All Images This will delete all images from your Shopify store 

Help > About   This will tell you the software’s current version number 

Help > Read Manual  This will open this user guide (PDF Reader required) 

Help > Send Logs  This is used by K3 support if we need to troubleshoot the software 

Help > Support Forum  This is a link to our support forum to get free help with the software 
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2.2. Status 

The status bar shows you the current sync status of the application.  

 

When Idle (As above) or complete,  you can Sync data. 

Whilst data syncing is in progress, you will see a progress bar for each section of the sync that it has 

to perform. Each of these are detailed later in the user guide. 
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2.3. Log 

The log section of the screen shows you useful information about the sync process, allowing you to 

see exactly what is happening during data synchronisation. 

 

If you double click an error in the log, it will show you the full details of the error, which can often be 

much more helpful when deducing the cause of the issue or warning. 

 

If you need to send these log files to K3 for analysis, then use the Help > Send Logs menu. 
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2.4. Sync Section 

This area lists the different Shopify fields which RMS can sync with. These make use of the field 

mappings which are defined in the configuration. At any time you can see what field is mapped to it 

by hovering the pointer over the field name. 
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2.5. To Shopify 

This column allows you to pick which fields you want to update in Shopify when you press the Sync 

button. It will only update fields in Shopify which have a check in the box. 

 

Cells which are shaded out are “required” fields that you can not toggle, so will always synchronise 

with Shopify. 
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2.6. From Shopify 

This column allows you to synchronise data back from Shopify into RMS when you press the sync 

button. It is designed so that you can make the most of Shopify’s WYSIWYG editor and apply rich 

formatting to your product description and product pages. 

 

Cells which are shaded out are “required” fields that you can not toggle, so will always synchronise 

with Shopify. 
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2.7. Sync Buttons 

When one of the relevant Sync buttons is pressed, data will be syncronised between RMS and 

Shopify in the direction that you choose. Only fields which have a check in the box will be 

synchronised. 

 

They  will only synchronise new or changed data.  
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2.8. Go To Webstore 

This button takes you directly to the administration area of your Shopify web store. You will still 

need to log in using your registered username and password. 

 

If you are using the Multiple Web Stores feature, the button will take you to the administration page 

of the webstore selected in the Sync drop down box. 
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2.9. Choose Web Store 

If you are using the Multiple Web Stores feature, then the Sync screen has a drop down box listing 

the web stores you have configured.  

 

Pressing the Sync button will sync data for the web store selected in this box only. 
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2.10. Web Orders  

This section lists all of the web orders which have been downloaded to RMS and are awaiting picking 

and processing. With an order selected you can perform a task with the buttons at the bottom of the 

screen.  

 

Order Name  The Shopify order name downloaded (Usually an order number) 

Order Date  The date the order was created on Shopify 

RMS Customer Name The name of the RMS customer that the order is for 

Shopify Billing Name The name of the customer downloaded from Shopify 

Order Value  The total value of the order (Including shipping) 

Status   If the order has been picked or not 

Risk   If the order is at risk of being fraudulent it will show a yellow icon 

The RMS Customer and Shopify Billing Name can be different. The Shopify Billing Name is 

the name of the customer as entered into the web order. When downloading web orders, 

it associates the order with the RMS customer which has a matching Account Number or 

Email Address. 

Any cashier which needs to process web orders must have the permission to alter tax 

status in their RMS cashier rights. For more information about this, please contact your 

RMS support partner. 
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2.11. Get Web Orders 

Pressing this button will retrieve all “Open” web orders in your Shopify web store, where a payment 

has either been “Authorised” or “Captured”. 

 

The application will automatically connect to Shopify and download orders when the Web Orders 

button is pressed in the POS, so there is no need to click the Web Orders button and then 

immediately click the Get Web Orders button. 

Additionally, once Web Orders has been opened the first time in the day, it will check for Web 

Orders automatically for you in the background, every 5 minutes. If it finds an order, it will tell you. 

 

If you restart your computer, you will need to click the Web Orders button again the first time to 

restart the automatic web order download process again. 

If you are using the Multiple Web Stores feature, pressing this button will retrieve orders from all 

web stores which this store has been configured to process orders for. For more information, please 

see section 4.9. 
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2.12. Print Pick List 

Pressing this button with a web order selected in the list will print a picking list to the OPOS printer 

defined for the installed register. This can then be used by the cashier to go and find the products 

they need to dispatch. 

 

If the user wants to print the picking list to a Windows Printer instead, simply check the Windows 

Printer box and choose the printer they want to print to. 

 

Once the button has been pressed, the Status colum of the Web Orders list will change to say 

“Picking” to indicate that someone is already picking the goods. 
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2.13. Complete Order  

Pressing the Complete Order button will load the Web Order you have selected into the POS 

transaction screen. 

 

RMSify does not actually complete the order in Shopify until it has been tendered through 

the POS against the defined Web Tender.  
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3. Configuration 

All configuration is completed through the Sync application. This is the application that is launched 

when you select Start > All Programs > Retail Technology Ltd > RMSify. Alternatively, it can be 

launched from Headquarters or Store Operations Manager through the menu Utilities > Addins > 

RMSify. 

Initial configuration is performed through the installation wizard which is takes you through the 

same configuration screens described below, but in a more structured way. The wizard only appears 

on first launch. 

There are rules as to where you can edit the configuration, and these work in line with the 

supported topologies described in the Introduction. 

Standard Headquarters – All configuration is performed in the Headquarters database. 

Changes to the configuration are transmitted to the processing store through a Worksheet 

51. You will not be able to open the Sync application at the processing store. 

Store Only Headquarters – Once the wizard is run and you have told it you are syncing from 

the processing store, all configuration will need to be performed at the processing store. If 

you want to change back to a Standard Headquarters topology, you launch the application at 

Headquarters and make the change there. 

Single Store – The configuration can be run on any computer which has RMSify installed. 

To access the configuration settings, click Options > Settings from the RMSify menus. 

 

 

Any machine which is going to run the Web Orders tool MUST have the Sync application 

launched once before the Web Orders “Custom POS Button” will work. 

Any change made in RMSify in a Headquarters database will be automatically transmitted 

to stores through a Worksheet 51.  
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3.1. HQ 

The HQ tab is only visible when you are in a Headquarters environment of any kind. Changes made 

in this tab are transmitted to stores automatically using a Worksheet 51. 

 

3.1.1. Sync Data 

This section allows you to configure where Shopify will sync its data from within RMS.  

You can either synchronise data from the Headquarters database, which is recommended and the 

default setting. 

 

Alternatively you can synchronise product data from a Store Operations database within your HQ 

estate. If you choose to sync from Store Operations, you must uncheck the Use Headquarters 

product data box, and then choose which RMS store you will be using to sync data from as shown 

below.  

 

In this scenario, RMSify Sync will only open (And therefore synchronise data) from the store you 

select in this box. 
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If you choose to synchronise from a Store database, you must be aware that the product 

data is at risk of being overwritten by Worksheets originating from Headquarters. When 

changing these settings, RMSify will warn you as shown below 

 

3.1.2. Web Store 

When using a Standard Headquarters environment, RMSify needs to know at which store you will be 

processing your Web Orders. You can choose the store using the drop down box here. 

 

You will only be able to launch the Web Orders on the store which is selected here. 

3.1.3. Resend Settings 

In the event that a new store is added to the HQ chain, or a new store database is exported to an 

existing store, you will need to use the Resend Settings button. Just choose the store from the drop 

down and press Resend Settings. 
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3.2. Shopify API 

The Shopify API tab is where you configure which Shopify Web Store your RMS database will 

synchronise with. 

 

Enter the Shopify Store URL (You must use the Shopify Subdomain you registered with here – 

you.myshopify.com) along with your RMSify Key.  

Your RMSify Key is your activation code, and you will have been emailed it during the installation 

process. If you don’t have it, please contact K3 Retail. 

When you have entered these details you can press Test Connection.  

Provided the Shopify Store has installed RMSify through the Shopify App Store then it will retrieve all 

of the store information it needs to know automatically. 
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3.3. Shopify Settings 

This tab is read only, and displays the store information retrieved from your Shopify store. It gets this 

information from the preferences you set up in Shopify, and changes need to be made there if 

something isn’t right on this screen. 
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3.4. Tender Settings 

This tab allows you to configure which Tender your cashiers will use to process web sales payments. 

When processing Web orders, RMSify will only notify Shopify that an order is completed if this 

tender is selected at the point of sale. We recommend having a dedicated tender type for web sales. 

 

In the initial wizard it is possible to automatically create a web tender for you. 
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3.5. Product Field Mappings 

We understand that everyone’s RMS database is different, and they want different data to be 

displayed in their web store. The product Field Mappings allows you to choose what data in RMS 

gets uploaded to which field in Shopify. 

 

RMSify can store a mapping for Standard items, and a separate mapping for Matrix items, as they 

can both be very different. You can use the drop down boxes to choose which RMS field gets used 

for the relevant Shopify field by item type. 

RMSify does not support Assembly or Lot Matrix items. 

There are two types of field which RMSify refers to. Strings (Textual information used for things like 

Descriptions, Product Type etc) and Currency (Numeric information used for pricing) and the field 

mappings use one of these two lists.  

Strings Currency 

<None> Cost Price 

Description Retail Price 

Extended Description Price Level A 

Sub Description 1 Price Level B 

Sub Description 2 Price Level C 

Sub Description 3 MSRP 

Dimension 1 Sale Price 

Dimension 2 Replacement Cost 

Dimension 3 

Barcode 

Department 

Category 

Supplier 

Notes 

Bin Location 
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More information on these fields and exactly where this data can be found in the RMS data structure 

can be found in Appendix C but if you are familiar with RMS Item properties these should all be 

straight forward. 

RMSify will also allow you to create Custom Fields in your RMS database which gives your RMS 

database unlimited flexibility when it comes to data mapping to Shopify. Please see Section 3.9 for 

more details. 

For further information on the fields available within Shopify, see our Shopify – Getting Started 

guide. 

RMSify makes use of the Custom Captions table for Sub Description 1, 2 and 3. If you 

wanted to rename them in this table, the caption would be reflected throughout RMSify. 

3.5.1. SKU 

The SKU field is the link between the RMS item and the Shopify item. This mapping cannot be 

changed – This will always be the RMS Item Lookup Code 

3.5.2. Product Title 

The Product Title field is the items name. It will appear in your stores catalog and in the title bar of 

the browser.  

 

By default this looks at the Item or Matrix Description, but it is common to make use of one of the 

Sub Description fields as a “Web Title” field, as you can be flexible with the product title without 

affecting other RMS users. 

3.5.3. Description 

The Description is the long product description which is designed to provide more information to the 

shopper. The first few lines may also appear in google search results.  
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Typically in RMS this is the Extended Description which is the default setting, though the Notes field 

is also long enough to hold this lengthy description. 

3.5.4. Product Type 

Product Type is how Shopify primarily group/categorise products. The product type is the core of the 

navigation through the default product catalogue. 

  

This is the RMS Category by default though it is common to utilise one of the Sub Description fields 

or even Bin Location to manage a more web friendly product type. 

3.5.5. Product Vendor 

Product Vendor is another way of grouping products in Shopify. Also known as Brand or Supplier, by 

default RMSify will use the (Primary) Supplier. 
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If required you can utilise one of the Sub Description fields or even Bin Location to manage a more 

web friendly Brand/Vendor name. 

3.5.6. Selling Price 

This field is the price that your customers will pay when ordering through the web. You can utilise 

any of the price fields at your disposal in RMS to map into your Shopify Selling Price. Often retailers 

will use a Price Level to maintain a different (And often more competitive) price for their web store 

compared with their bricks and mortar store. 

If you are making use of the Automatic RMS Sale Pricing rule then the selling price 

mapping will be over-ridden with RMS Sale Price when within the selected date range (See 

3.7.6) 

3.5.7. Weight 

The Weight of your products can be used by Shopify to automatically calculate the cost of shipping. 

In RMS there is only one relevant field for Weight and it is mapped to this by default, however you 

can make use of a Custom Field to store your item weights provided it is of type “Float”. 

RMSify assumes the value in the Weight box is in Kilograms: 1.2 would represent 1.2 

kilograms.   

Shopify stores the value in Grams. So RMSify multiplies this value by 1000 to store it in 

Shopify, leaving the weight in RMS in tact. Shopify can then be set to display the weight 

values in KG or LBS, and this is handled by the Shopify user interface. 

3.5.8. Compare At Price 

The Compare At Price can be used in different ways, and can depend on how the theme has been 

designed. It could be that it is used to display a “Was” price if the product is currently on sale. It 

could display the “In store” price, or it could show the “Competitor Price”. Its entirely up to your 

theme and/or designer. 

RMSify will typically use this as a “Was” price. You can choose a related currency field to map to this, 

and there is no mapping defined by default.  
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RMSify can automatically manage the Compare At Price if you want it to take effect when you are 

running a sale in RMS. See section 3.7.6 (Automatic RMS Sale Pricing) for details on how it works. 
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3.5.9. Variant 1, 2 and 3 

For products that come in different dimensions, like fashion products in colours and sizes, where 

RMS uses “Dimensions” Shopify uses “Variants”. Just like RMS, you can have a product with up to 

three Variants, and these are mapped together in the same way as any other field type. 

 

 

By default, RMSify maps Variant 1 with Dimension 1, Variant 2 with Dimension 2 and Variant 3 with 

Dimension 3.  

Typically a retailer may want to utilise a more web friendly colour name or size definition. This can 

be done by utilising one of the other fields, such as Sub Descriptions or Bin Location. If you want to 

change the mappings though, it will need to resync your whole Shopify store. RMSify will warn you 

before you make the change 

 

This means you need to delete all Matrix products from your Shopify store and start a new Sync to 

reload the store with the right combination of variants. 
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3.5.10. Tags 

Tags are a flexible and easy way to add further levels of categorisation to your products. Shopify can 

use them for Navigation and when creating “Smart Collections”. They are a comma separated list of 

values which you might want to group your products by and are freely editable. For more 

information on them, see the Shopify documentation. 

 

By default, there is no mapping defined for them. Typically you would need a long field as they can 

contain quite a lot of text and it might be worth mapping this to the Notes field in RMS. 

3.5.11. Picture 

With any web store, the Picture literally tells a thousand words and is the first thing a customer will 

look at. RMS only has one picture field, so its not possible to map the picture to a different field.  

Standard items in RMS can only hold one picture, and this will be syncronised to Shopify as the 

“Featured” image. This means it should always be the best image and the one you want to appear in 

the product catalog. 

 

However you can upload further pictures in the Shopify back end – as many as you like. RMSify will 

set the picture you have in RMS as the “Featured” image for your products. 

 

If you are using an RMS Matrix product you can assign a different picture to each component item. 

By default, these images will be uploaded to the whole matrix/shopify product. If you wish to link 
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these images to the specific Shopify variants, make sure you have enabled the “Use Variant Images” 

rule (Section 3.7.7) 

If you change an image for a product in RMS (Or remove an image) then this does not get 

removed from Shopify. Because the data is removed from RMS, there is no way to tell 

Shopify what to remove, so you will have to remove the image manually from the Shopify 

back end. 

3.5.12. Picture Alt Text 

Although the Picture tells a thousand word, Google and other search engines do not know what it is 

a picture of. Search engines use Alt tags which is a textual representation of what the image is. You 

will see it on your website if you hover the mouse over an image. 

 

I addition to Google’s interpretation of the image, Alt tags can also be used by Themes and 

Templates in order to more dynamically display images. Such a use may be if you wanted to show 

different colour images depending on the variant selected on your website. You would need to refer 

to your theme/apps documentation to see how you might make use of such a feature. 

3.5.13. Collection  

Shopify has the ability to define “Custom Collections”. These are groups of products and are 

essentially a way to add further categorisation to the products available on your web store. 

Collections can be used as ways to define your web store navigation, or perhaps display “People who 

bought this product may also like…”. 

 

In Shopify you can have a single product in as many collections as you like. But RMSify can only 

assign it in one. The default mapping is from the RMS Department, but you can of course use any 

other available field if you wish to. 
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3.5.14. Barcode 

In Shopify  you have the ability to associate a “Barcode” to a SKU. You can also map an RMS data 

field (Typically this would be the ItemLookupCode) to this data in Shopify. 
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3.6. Customer Field Mappings 

Customer Relationship Management is a critical area of eCommerce. Not only do you want to attract 

new customers, but you also want to manage and communicate with your existing customer more 

effectively. RMSify’s integration between RMS and Shopify can help with that. 

When downloading Web Orders, the customer information comes with them. There are a number of 

straightforward mappings which sync directly “Out of the box” such as the name, address, email etc. 

But there is some additional information which Shopify can provide you may also want to import 

with your web orders. This data can be mapped in this screen. 

 

RMSify can use the RMS Custom Text fields for Customer data. If you are already using them for 

something then it is likely that they will appear here. 

If you wish to map some customer data you must choose a field to map it into and check the “Use” 

box. You can then assign it a caption, and choose which Shopify field you want to populate it with, 

like the example below. 

Shopify offers the following “mappable” fields. 

Latitude  The global latitude of the customers billing address 

Longitudue  The global longitude of the customers billing address 

Country Code  The country code of the customers billing address 

Province Code  The province code of the customers billing address 

Accepts Marketing Whether the customer has checked the “marketing” option in the checkout 

Tags   Any tags which are associated with the customer 

These fields, although typically only populated through the order, can be managed through the 

Customers tab in the Shopify back end. 
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3.7. Rules 

Shopify has a number of features which can be utilised for products on an individual basis which 

RMS simply isn’t designed to do. In order to make RMSify a simple and effective solution, we have 

implemented these rules, which apply to all products in the database. 

 

3.7.1. Track Inventory 

Shopify has an option available for each product, that allows you to choose if Shopify is going to 

track how many it has in stock for your products.  

 

RMSify will use the “Track Inventory” rule to assign the rule you define to all products that it 

synchronises to Shopify. If the box is checked (As per the below example) then each product will 

have inventory tracked. The quantities themselves will also be uploaded from RMS. 

 

Alternatively, you can choose not to track inventory levels by unchecking the box. This means that 

no matter what your actual stock position is in RMS, the product will continue to be on sale in your 

web store. 

If the RMS item is a “Non Inventory” item, it will always be uploaded as “Not Tracked 

Inventory”  
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3.7.2. Out of Stock 

Working hand in hand with the Track Inventory rule, Shopify also allows you to choose how you 

want a product to behave when your quantities reach zero. You can choose to deny purchases (It 

will display an out of stock message) or continue selling it. 

 

As with the Track Inventory rule, the setting you choose will apply to all products you upload from 

RMS. 

 

If the “Track Inventory” rule is disabled, this setting will not be configurable.  

 

3.7.3. Use Inventory Levels 

When you are in a Headquarters database you have your stock located across all of your stores. As 

RMSify can upload stock quantities to Shopify, it needs to know which stock is available to it. 

You can choose to upload the total available quantity from all stores in your Headquarters chain 

using the “All Stores” option. 

 

Alternatively, you can set it to only include stock from the store which is defined as the “Web Store” 

in 3.1.2. 

 

Regardless of which is chosen, RMSify will only upload stock quantities for Available stock. It will not 

upload any committed quantities, which means your web store will show a true reflection on your 

stock availability. 

3.7.4. Charge Taxes 

Shopify uses a “Destination based” taxation system. You must define the tax rate your customer 

must pay dependent on the delivery location, and also if your prices include tax or not. This is 

configured in your Shopify back end Preferences > Regions and Taxes, and you can see our  Shopify 

– Getting Started guide for more information. 
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From a product perspective, the only thing Shopify needs to know is if the product being sold online 

should attract sales tax, or not. In order to cater for all posibilities in RMS, we defined the following 

rules to be applied during sync.. 

 

All Items All items uploaded will be marked as taxable 

No Items All items uploaded will be marked as NOT taxable 

Sales Tax > 0 Only Items which have a tax percentage more than 0% will be marked as taxable 

You are responsible for ensuring your store adheres to local tax rules and laws, not K3 

Retail.  

 

3.7.5. Require Shipping Address 

There is an option in Shopify which checks that when purchasing a product it requires a shipping 

address to be defined or not. 

 

It may be that some products can be delivered electronically so a Shipping address is not required. 

Generally if you are operating an RMS bricks and mortar store (or more) then a shipping address will 

be required for all purchases. 

 

This is the default setting and is fine to be left this way for most integrations. 

3.7.5. Automatic RMS Sale Pricing 

RMS has a very useful sale pricing system. You can define a sale price for a product, along with the 

date range which it is on sale for. RMSify can use this functionality if the rule is enabled and work 
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with the Shopify Selling Price (3.5.6) and Compare At Price (3.5.8) to automatically make your 

products use the new sale price. 

 

If the rule is enabled, for each product it will check to see if today (9th October 2012) falls within the 

sale date period defined in RMS. 

 

If a product is on sale when the Sync button is pressed, it will upload the RMS Sale Price to be the 

Shopify Selling Price, and upload the Mapped Selling Price to be the Shopify Compare At Price. 

  

When the product is no longer on sale, when the Sync button is pressed again it will remove the 

Compare At Price and set the Selling Price to be the Mapped Selling Price. 

3.7.6. Split Matrix by Dimension 1 

For Matrix products there are typically two ways the products can be displayed. Either, you have a 

single product with all of the Dimension 1 attributes being selectable, or you have an individual 

product for each Dimension 1 variation. 

This is common in shoes and apparel, as the product listing on the site will display each colour 

individually giving the consumer a greater visibility over your product. And example is shown below.  

In RMS you can see the product has 2 dimension 1 (Colour) attributes 
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With the setting disabled, it keeps the Matrix item together, and lists each Dimension 1 as a variant 

of the same product and contains pictures for the whole product. 

 

 

 

With the setting enabled however, it will create a Shopify product for the Black, and a Shopify 

product for the brown. So they will be listed independently and allow them to have their own set of 

pictures, descriptions etc. 

 

 

If you change the status of this setting after the products are already in Shopify, you will need to 

delete your products first and then resynchronise in order for the changes to take effect. You are 

warned of this when toggling the setting. 
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3.7.7. Use Variant Images 

A recent update to Shopify is the support of “Variant Images”. That is, you can assign individual 

images to individual products of certain colours and sizes. This is shown in the screenshot below. 

 

If the “Use Variant Images” box is checked it will assign the image attached to the individual 

standard item in RMS to that specific related variant in Shopify. 

 

3.7.8. Bypass Shopify Fulfilment 

RMSify, as part of its POS Web orders function, will notify Shopify when it has completed a web 

order, and mark it as “Fulfilled” on Shopify, automatically notifying the customer that the goods are 

on their way. 

If the “Bypass Shopify Fulfilment” box is checked, RMSify will complete the order in RMS, but it will 

NOT then complete the order on Shopify. 
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This feature is designed to allow you to compelte the order in RMS and correct your on-premise 

stock, whilst perhaps using a third party fulfilment provider or system. 

3.7.9. Bypass Tracking Number 

RMSify, as part of the POS Web orders function, will ask you to enter a Tracking Number for the 

goods being fulfilled. 

 

If you want to bypass this as you do not use this sort of service, then the settings box can be 

checked. 

 

3.7.10. Create Out Of Stock Variants 

By default, RMSify will always create every vriant you have created in RMS that is enabled as a web 

item. 

This option will not create any variants for which you have no stock. 

3.7.11. Rule Overrides 

The rules described through this section apply to all products. However, there are occasions when 

you may not want them to apply all of your merchandise. For example, if you sell a few perpetually 

replenished products, such as Pet Food. To counter this, it is possible to override the “Track 

Inventory” (3.7.1), “Out of Stock” (3.7.2), “Charge Taxes” (3.7.3) and “Require Shipping 

Address”(3.7.4) rules. 

By overriding the rules, you then will need to use Quick Editor (Section 6) to choose the behaviour 

during the sync process. 

If you want to override a rule, create a “Custom Field” (3.9) with one of the following names. 

• TrackInventory (Overrides rule 3.7.1) 

• AllowOutOfStockPurchases (Overrides rule 3.7.2) 

• ChargeTaxes (Overrides rule 3.7.3) 

• Require Shipping Address (Overrides rule 3.7.4) 
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The “Field Type” can be ignored, as these become Boolean (Checkboxes) regardless of the option 

you choose. 

 

 

These fields can then be managed in Quick Editor (Section 6) 
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3.8. Web Order Receipt 

RMSify has its own RMS Receipt Template, which is installed into RMS automatically for you. You can 

use this on either of your receipt printers defined in the register settings. It uses standard RMS 

receipt XML which means you or your support partner can fully customise it to look and feel exactly 

how you want. It can be found in Database > Registers > Receipt Formats 

 

You can view the properties of this receipt template in the same way as any other RMS template. 

Click the Properties button, and then click the Properties button next to “Sales”. 

 

It contains all of your standard settings and the same things you’d expect to find in an RMS receipt 

template. Some additional settings have been provided which are geared around your web store. 
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Webstore Name The name of your webstore as you want it to appear in the 

header section 

Webstore URL  Your Shopify webstore address 

Webstore Email The email address you want customers to send 

correspondence to 

Webstore Receipt Caption The name of your receipt. E.G. “Receipt”, “Invoice”, 

“Packing Note” 

RMS Transaction Number Caption What you want the RMS Transaction number to be known 

as. This will be different from your Shopify order number 

RMS Customer Number Caption What you want the RMS Customer Number caption to be 

RMS Cashier Caption What you want the Cashier name to be listed as on the 

receipt 

RMS Reference Caption This is the field RMSify uses as the Shopify Order number, 

but you can caption it something else if you like 

RMS Comment Caption This allows you to caption the notes section with something 

more customised. 

 

These are highlighted in the diagram below. 

 

 

The receipt template can be assigned to any RMS register to either receipt printer 1 or 2. You can 

configure this in Database > Registers > Register List. 
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Click the Properties button for the regiter you are using as your Webstore POS. You can choose to 

use this receipt template either as printer 1 or printer 2 by selecting the tab at the top of the screen.. 

 

Receipt Printing - You can choose to either “Print receipts automatically after each transaction” 

which is useful if this is a dedicated Web POS, or “Print receipts only after asking a cashier”, which is 

more suited to a POS which is also in use in a bricks and mortar store. 

Printer Type – RMSify’s receipt template will only work with a Windows printer. It is assumed this is 

already installed on the computer.  

Windows Device Name – This is the name of the printer as it is listed in Windows Printers control 

panel. For the example below, I would enter “hp LaserJet 4250” as the device name 

 

Journal receipts from this printer – If you want the RMS Journal to keep a record of the printed 

RMSify receipts, check the box. This is recommended. 

Receipt Format – Use the magnifier icon to choose the RMSify receipt format. 

Click OK to save your changes. You must restart the POS application in order for the changes to take 

effect. 

For further assistance with register settings and receipt formats, please consult your 

certified RMS partner.  
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3.9. Custom Fields 

In RMS, you are limit in resepect to where you can store your data. There are only so many fields you 

can make use of to use your “Web Friendly” details. For example, you may not want to use the RMS 

“Extended Description” as your web description, but there are no other fields which will allow you to 

do this. RMS is also limited by the number of pictures you can attach to a product. 

RMSify now allows you to add custom data fields to give you an unlimited amount of space, giving 

you freedom and flexibility to maintain different data for RMS and Shopify if you so desire – 

including the ability to attach unlimited pictures to your RMS products. This data can be managed in 

RMSify’s Quick Editor (See Section 6) 

Additionally, Shopify allows you to make use of “Meta Fields”. These are the equivilent of Custom 

Fields in RMS, and the data you upload to Shopify Meta Fields is available to be accessed through 

your theme. 

In order to manage these custom fields use the Tools > Custom Fields menu option. 

 

You can then choose the RMS fields tab, if you want to add custom fields to RMS, or Shopify Meta 

Fields tab if you want to create those instead. 

RMSify will simply create the Meta Field and assign the data you map to the meta field. In 

order to make use of this data in a theme or another app you will need to seek consult the 

theme designer or app developer as appropriate, or for more customised use, a 

development partner. 

A “Checkbox” type of custom field is only created for “Rule Overrides”. Please see section 

3.7.10 for details about this. 
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3.9.1. RMS Fields 

In order to Add a custom RMS field, click the RMS Fields tab on the Custom Fields screen, which you 

can access through the Tools > Custom Fields menu.  

The screen displays the different custom fields already configured and their types – though you see a 

blank screen if you have no custom fields configured. 

 

To create a new custom field, press the Add button. You then need to name the field as something 

you will recognise and is relevant, and choose what data type it is. 

 

Short Text Suitable for alphanumeric information, shorter than 255 characters, like a Collection 

Long Text Suitable for much longer text, like a Web Description  

Number Suitable for numbers without decimal points 

Money  Suitable for currencies, such as a Web Price 

Picture  Allows you to browse to Pictures to attach more than RMS allows to your items 

Date  Allows you to enter a date field 

Float  Suitable for numbers with decimal points like weights 

Short Text fields also have their own tabs in the Web Item Filter.  

When you add a custom Picture field, you get an additional option to choose which field will contain 

that picture’s Alt Text. You can leave it blank if you wish, or choose an available field. You can use 

RMS fields, Custom Fields or Nitrosell fields. 

Once you have added a custom field, it immediately becomes available for you to map to Shopify in 

your Product Field Mappings. For more information on this, please see section 3.5. 

If you wish to remove a custom field, simply select it and press the Remove button. 
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Removing a custom field will permanently delete any data which was contained in that 

custom field. So if you believe you may want to use that data at a later date, please make 

a backup. 

Please see Section 6 “Quick Editor” for instructions on how you can quickly and easily 

modify all of your RMS item data, including populating and modifying the data in your 

custom fields. 

3.9.2. Shopify Meta Fields 

In order to add a Shopify Meta Field, click the relevant tab on Custom Fields screen, which you can 

access through the Tools > Custom Fields menu. 

The screen displays the Meta Fields you already have configured in your RMS database, though this 

screen may be blank if you’ve not used this feature before. 

 

Any Meta Fields you already have in Shopify will not appear here. If you want to map data 

to existing Shopify meta Fields, you will need to configure them in RMSify with the same 

parameters with which they are already configured in Shopify. 
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To create a new Shopify Meta Field, simply press the Add button. You can then enter the necessary 

parameters into the form. 

 

For further information on how to configure these Meta Fields, you will need to consult the Shopify 

documentation. http://www.shopify.co.uk/technology/3032322-new-feature-metafields 

If you want to manage your SEO fields in Shopify from within RMSify, you will need to create 2 Meta 

Fields containing the following parameters which are case sensitive. 

Description Namespace Key Type 

SEO Title global title_tag String 

SEO Description global description_tag String 

 

If you are using the Google Shopping app, which is developed by Shopify, you need to create 4 Meta 

Fields containing the following parameters which are case sensitive. 

Description Namespace Key Type 

Manufacturer Part Number global MPN String 

Age Group google age_group String 

Gender google gender String 

Google Product Type google google_product_type String 

 

The Google Shopping app is not supported by K3 Retail. RMSify simply enables data to be 

uploaded to the fields that the app uses from the RMS database. For information about 

and to install the Google Shopping app, plese see https://apps.shopify.com/google-

shopping 

When a Meta Field has been created, it then becomes available in the Product Field Mappings 

screen, for you to choose an RMS field whose data you want to be uploaded to that Meta Field. For 
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more information on Product Field Mappings, please see section 3.5

 

Once the field has been mapped, it then appears on the Sync screen which you can then check to 

use when syncing data. For more information on the Synchronisation screen, please see section 4. 

 

If you have checked the “Apply Metafields to Variants” check box, all meta field data will also be 

applied to each of that products Variant meta fields too. 

 

To delete a Meta Field, simply click the Remove button. 

Removing a Meta Field does not delete any mapped data in RMS and does not remove the 

Meta Field or its data from Shopify. 

RMSify does not support individual variant/meta field mappings. 
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4. Synchronisation  

Synchronising your products with Shopify is a key part of maintaining an effective multi-channel 

retail solution. RMSify can synchronise product data in two directions, either To Shopify from RMS, 

or From Shopify into RMS. These procedures are detailed in this section of the User Guide. 

Synchronisation occurs from within the RMSify Sync application. This can be launched through Start 

> All Programs > Retail Technology Ltd > RMSify. Alternatively it can be launched from 

Headquarters or Store Operations Manager in the Utilities > Add-ins menu. 

 

If you ever close the application you will find it running in the Systray near the clock. You can also 

access it through right-clicking and choosing Restore. 

 

By default, RMSify synchronises all items which are enabled as “Web items” in RMS. However, this 

can be further configured using the Web Item Filter to choose a more specific range of products to 

be uploaded on the web. See section 4.10 for more details. 

Unchecking the “Item available on website” setting will NOT delete the product from 

Shopify. See section 4.6. for details.  

RMSify ignores the “Item inactive” flag for a product.  

 



RMSify | User Guide 

 

 

Page 54 of 107  Version 6.0.0 

 

4.1. Status Bar 

The Status bar shows you the current status of the synchronisation application. They are colour 

coded so you can tell which ones are good messages, and which are bad.  

A red status bar means something has failed – this is usually the connection to Shopify. 

Orange means that the Sync application is negotiating a connection with Shopify. 

Green means that synchronisation is happening. 

The below shows that RMSify has successfully connected to Shopify. 

 

When synchronising variants for a product it tells you which number it is on from the total variants 

within that product. 

 

When its synchronising Images it will show you this 

 

The same is true for the synchronisation of Collections. 
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4.2. Log 

During the synchronisation in either direction, the Log section gives you some really useful 

information as to what is going on with the sync you are attempting. 

 

There are 3 types of log message, indicated by the icon. 

Success: This indicates that something has happened successfully. For example, a 

product has been successfully uploaded, or a product has been updated for. 

 

Warning: This informational message alerts you that something has changed which 

you need to be aware of, or something has been uploaded that you need to consider 

as it may not be right. An example of this might be a product which has been 

uploaded with a Zero price, or informing you that one of the synchronisation rules 

have changed. 

Error: This means something during the synchronisation has failed. Usually, these 

errors will tell you what the fault is so you can correct them. This may be that it was 

unable to connect to Shopify, or perhaps that an image failed to upload due to it 

already being in use for another product. 

If you double click the log message, it will give you some useful information about it, or simply give 

you the full message which might not be visible in the log screen. It also tells you the date and time 

that the log occurred. 
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In the above example, we can see it has informed the user that the a product exists in Shopify, but 

has no mathing SKU/ItemLookupCode in the RMS database. 
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4.3. To Shopify 

Synchronising data to Shopify is very simple. All you need to do is press the Sync button in the 

column marked “To Shopify” 

 

This will connect to Shopify and start comparing the data you have in Shopify with the data you have 

in RMS. Where it finds a difference between RMS and Shopify and the item has been modified since 

the last synchronisation, it will update Shopify with the data that is in RMS. 

If you are using the Multiple Web Stores feature, then you must make sure you have selected the 

store you want to Sync to using the drop down box. For more information on this, see section 4.9. 

RMSify will only update fields which have their boxes checked on the sync screen. For example, if 

you know you have only made changes to the Mapped Description field, uncheck all other boxes and 

it will not synchronise that data. 
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If at any stage you are unsure what the “Field To Sync” is mapped to in RMS, you can hover you 

mouse over the field name and the tool tip text will explain it to you, rather than having to go into 

the settings. 

 

Shopify requires that Product Title, Product Type and Product Vendor are always included 

in synchronisation so cannot be deselected.  

When you alter a products Collection, either through amending it in RMS or re-mapping to 

a different field, RMSify will create/attach it to the new collection, but retain the link to 

the old collection. This would need to be removed manually. 

RMSify uses the Last Updated field in RMS. It will only synchronise data where the last 

updated date/time is more recent than the date/time of the last synchronisation.  
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4.4. From Shopify  

There are occasions when you may have edited information in Shopify that you actually want to 

import back into RMS. Typically, this would be when you have edited your products description or 

title, making use of the excellent rich text formatting WYSIWYG editor in the Shopify back end, to let 

you enhance your product listings. 

Without syncronising those changes back to RMS means that the next time you sync data to Shopify, 

your changes will be overwritten. RMSify will sync data into the Mapped field which you have 

configured. 

Syncing data back into RMS from Shopify works the same way as from RMS into Shopify. Click the 

Sync button in the “From Shopify” column. 

 

If you do not want to synchronise one of the available fields, simply uncheck its box. In the example 

below, it will import the Description back to RMS, but not the Product Title. 

 

If you are using the Multiple Web Stores feature, then you must make sure you have selected the 

store you want to Sync from using the drop down box. For more information on this, see section 4.9. 
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If at any stage you are unsure what the “Field To Sync” is mapped to in RMS, you can hover you 

mouse over the field name and the tool tip text will explain it to you, rather than having to go into 

the settings. 
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4.5. Images 

If you choose to (By checking the box in the Sync fields list), RMSify will synchronise images assigned 

in RMS into Shopify. The image must be located in the images folder defined in Store Operations. 

The general rule of thumb is, if you can see it in Store Operations Manager in the Item Properties, 

RMSify will upload it. If RMSify is installed to the pictures must be stored in the defined 

Headquarters picture folder. 

 

The application converts the image into a format which Shopify can understand and display 

correctly. RMSify does not alter your original images, and these are left alone in the images folder. 

If you are using Matrix products, it is possible to have a different image for each component 

item/individual SKU. In the example above it shows the image pajamas.jpg. This is a component 

item from the “Infant Pajamas” Matrix Item in RMS. 
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In the image below it shows a different component item, looking at a different picture.  

 

As RMSify handles Matrix items and converts them to Shopify “Variant Products” then both of these 

images (And any other images which are associated in component items for that matrix) will be 

uploaded into the same Shopify product. 

 

RMSify will assign the first image it uploads for the matrix as being the “Featured” image. If you want 

to alter this you need to do so through the Shopify back end. 

Unfortunately, there is no link between the component items and the images themselves, you can’t 

link a specific colour variant to a specific image directly. It is possible, with the aid of a third party 

app (Search the Shopify App Store for “Variant Images”) but that is outside the scope of this user 

guide and the application. 

Images MUST be unique per product. If you have the same image linked to two products in RMS, 

then RMSify will error whilst uploading the second image, because Shopify can only link one image 

file name to one product. 

If you change or delete an image for a product , then unfortunately Shopify will retain the linked 

image for the product. You will have to remove the picture from the Shopify back end manually to 

stop it showing on your web store. 
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Unlike in standard RMS, RMSify allows you to assign more than one image per item. Firstly, you 

would need to create a Custom Field (See section 3.9), and then you would then need to assign the 

pictures to the products using Quick Editor (See section 6). RMSify will always upload all pictures 

attached to custom picture fields. It will however, only assign the RMS picture as the “Featured” 

image. 
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4.6. Product Visibility 

Shopify makes use of a Product Visibility attribute, which allows you to choose if the selected 

product is visible to customers on the web or not. 

 

When you synchronise a new product to Shopify, it will automatically mark the item as Visible.  

If you were to uncheck the “Item is available on website box” in RMS, rather than deleting the 

product from Shopify, it will simply mark it as hidden. You will be able to see when this has occurred 

in the Log. 

 

This is important, because if you are approaching your SKU limit, simply removing the “Web Item” 

flag in RMS will not make a difference. You will need to physically delete them from the Shopify back 

end. 

If you want to re-publish the hidden item, you can simply check the “Web Item” flag in RMS and it 

will mark the product as published again. 

Shopify does not maintain it’s visibility attribute at Variant level. This means that you 

cannot set a certain colour as Hidden. In order to achieve this, if you unmark all items of a 

particular as web items, RMSify will delete that variant from Shopify. 
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4.7. Stock Update 

If you are tracking your inventory or stock levels with your Shopify store (Please see the Rules 

section for details) you need to synchronise the data on a regular basis. We advise you schedule the 

stock to be updated automatically (See 4.7) however you can update it manually at any time by 

right-clicking the RMSify icon in the bottom right hand corner by the clock, and clicking “Update 

Stock Quantities” 

 

If you are using the Multiple Web Stores feature, it will update the stock quantities for each defined 

web store, one at a time. For more information on the Multiple Web Stores feature, see section 4.9. 
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4.8. Scheduled Stock Update 

In order to maintain accurate stock levels, its important that these are updated as frequently as 

possible and appropriate for your business. RMSify can perform this task for you automatically. Click 

Tools  followed by Scheduled Stock Update. RMSify uses a Windows Scheduled Task to do this 

 

You can choose whether or not you want to make use of this feature through the Enable check box. 

Checked means it will run, unchecked means it will not. 

You can choose how often it is repeated too. By default it is selected as Daily, which means it will run 

the stock update at midnight every day. If you were to choose a different option, it would run every 

n minutes throughout the day. 

If you are using the Multiple Web Stores feature, it will update the stock quantities for each defined 

web store, one at a time. For more information on the Multiple Web Stores feature, see section 4.9. 

If you wish to set up more advanced settings, you can edit the properties of the relevant Windows 

Scheduled Task.  

K3 Retail do not support the execution and advanced configuration of scheduled tasks as 

this is a core windows feature. For more help in configuring a scheduled task please 

contact your support partner. 
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4.9. Multiple Web Stores 

RMSify will allow you to operate as many Shopify webstores as you wish to, right from the same 

RMS database. By utilising the Web item Filter functionality (See section 4.10) you can additionally 

tailor each web store to carry different products. 

RMSify will download orders from all of your Shopify stores, and will notify the relevant web store 

when an order from that store has been fulfilled. 

In an HQ environment, you can even configure which Physical store processes orders from which 

Web store.  

To configure your Multiple Web Stores, click the Tools > Multiple Web Stores menu. 

 

 

RMSify is charged and operates on a per Web store basis. You must have undertaken the 

RMSify installation process through the Shopify App Store for each web store you want to 

synchronise with prior to continuing the process. 

 

The data you require for this configuration is the same as you do to configure the main web store. 

See section 3 for full details on these, however a summary is listed below. 

Store Name The name of the web store you are adding. Is is only used internally to 

identify the store in the syncronisation screen. 

Store URL  The Shopify URL of the web store you are configuring 

RMSify Key The RMSisy key you were emailed as part of the installation process through 

the Shopify App Store 

Use Stock From Store In an HQ environment you can choose where the inventory quantities on 

your website will be taken from. Either single store (Which will be the store 



RMSify | User Guide 

 

 

Page 68 of 107  Version 6.0.0 

 

you process the orders in) or All Stores. This option is not configurable in a 

Single Store environment. 

Sync Data Store In an HQ environment you can choose where the product data will be 

uploaded from. Either single store (Which will be the store you process the 

orders in) or All Stores. Typically this will always be HQ, but please see 

section 3.1.1 for full details. This option is not configurable in a Single Store 

environment. 

Order Processing Store In an HQ environment you must choose the RMS store which will process 

the orders for this web store. Only the store selected here will be able to 

process the web orders for this web store. This option is not configurable in 

a Single Store environment. 

Selling Price You can choose an alternative selling price for each web store. Choose the 

price field you want to use. 

Compare At Price You can choose an alternative selling price for each web store. Choose the 

price field you want to use. 

4.9.1. Add a Web Store 

Clicking the Add button along the bottom will create a new record in the table for you to enter 

configuration details for your new web store. 

 

Fill in all of the relevant details for your web store and pres the Test Connection button to check 

they have been entered correctly.  

 

When you have finished you can press the Save button. Note, you will not be able to save the details  

unless all web stores have had a successful test connection made. 
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4.9.2. Editing a Web Store 

If you want to make changes to a web store, such as changing the Order Processing Store or Store 

Name, simply make the changes and press the Save button.   

 

4.9.3. Delete a Web Store 

To delete a web store, simply click on the web store name you want to delete and press the Delete 

button. 

 

It will prompt you to make sure you are sure you know you are deleting the store.  

RMSify does not delete your Shopify account, any data from your Shopify store, nor does it 

perform a Shopify uninstallation of the app from the selected web store.  

4.9.4. Synchronising Product Data 

When you are using Multiple Web Stores, your synchronisation screen will have a drop down menu 

which lists your web stores. When you press the Sync buttons, RMSify will sync data only for the 

Web Store that is selected here. 

 

4.9.5. Stock Update 

When choosing to Update Stock Quantities from the right click menu, RMSify will update 

stock/inventory levels for all web stores. 

4.9.6. Scheduled Stock Update 

The scheduled stock update feature will always update inventory levels for all stores. 
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4.9.7. Processing Web Orders 

Only the store defined as the “Order Processing Store” will be able to download the orders for a 

given web store, and obviously you must have installed the RMSify application to that system to 

process them. 

When the order is download it keeps an internal record of which web store it came from and this is 

not visible to the user. When the order is completed and committed, it then notifies the relevant 

web store to close the order and complete the customer notification processes. 

4.9.8. Go To Webstore 

The “Go To Webstore” button will take you to the admin page of the webstore chosen on the Sync 

screen.  
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4.10. Web Item Filter 

By default, the only way that RMS can determine what items are on the web is through the “Item is 

available on the website” check box in the item properties. RMSify makes use of this “Web Item 

Flag” by default and will only ever put products online that have that flag enabled. 

However, RMSify can now further refine the products on the web using the Web item Filter. It is 

perfect for customers who want to sell different products through different Shopify Web Stores. 

Typically, this may be that a retailer wants to sell just a certain brand of product through one web 

store, with the rest of them through another. 

It can be accessed through the Tools > Web Item Filter menu in the Sync application. 

 

This launches the Web item Filter interface. 

 

Using the features of this screen you can cumulatively build your Web Item Filter. When 

synchronising your products to your Shopify store(s), it will only synchronise products which meet 

the fitler defined here. 

By default, all web stores use only the “Web item” identifier, and this is a fundamental 

requirement. Therefore that field is not able to be removed as a filter option. 

1 2 

3 

4 
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4.11.1. Web Stores 

The store you choose on the left represents the filter that you are modifying.  

 

You can assign completely different filters for each web store you operate. 

4.11.2. Filter Tabs 

The Filter Tabs represent a field in RMS that you can filter your data by. For example, if you were to 

choose the Supplier tab, it means you are filtering web items based upon who supplies the products. 

 

The filters work on a Do Not Use/Use basis. On the left hand side is the list of paramters you don’t 

want included in your filter. The right hand side shows parameters you do want to use. 

You can toggle the positioning of the parameters using the Use and Do Not Use buttons. 

 

To make things nice and easy for large lists, you can use a “Use Like” and “Don’t Use Like”, and it 

uses an asterisk wildcard filter as part of that feature too. 
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The filters are completely cumulative, and you can filter using as many tabs as you wish. For 

example, if you then wanted to additionally filter by Department, simply click the Department tab to 

continue building your filter. 

 

Further more, the filters are “Reactive”. That is, when you click an additional filter tab, it will only 

show you parameters that also meet the filter which has been built up so far. 

4.11.3. Filter Script 

The filter script box shows you a quick overview of the filters you have applied, saving you from 

clicking each individual tab to wor out what is filtered and what isn’t. 

 

4.11.4. Buttons 

When you are happy with the filter you have created/modified, you can press Save. If you want to 

reset the filter to defaults and start over, click the Clear button. 
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4.11. Tools 

4.11.1. Scheduled Stock Update 

Please see section 4.7. 

4.11.2. Multiple Web Stores 

Please see section 4.9. 

4.11.3. Web Item Filter 

Please see section 4.10. 

4.11.4. Custom Fields 

Please see section 3.9. 

4.11.5. Quick Editor 

Please see section 6. 

4.11.6. Print Logs 

When you are synchronising data, the log screen can give you some useful information when you 

have issues. This tool prints out the log from the user interface to the windows printer you choose, 

to help you troubleshoot and fix the synchronisation issues. 

4.11.7. Delete All Custom Collections 

During the staging process you will be synchronising a lot of data and seeing how it gets uploaded. 

This can create numerous Custom Collections in Shopify. In order to keep these tidy, prior to going 

live, you should do a clean sync. This involves first deleting the custom collections. 

 

This will orphan all products from these collections. We would recommend if you are performing this 

task, to also delete all of your products from Shopify and re-synchronise afterwards. Take note of the 

warning: Deleting custom collections may affect your Navigation if your Menus rely on them. 

4.11.8. Delete All Images 

Deleting all products from Shopify doesn’t always delete all of the images associated with them, nor 

the link between the RMS image and the Shopify Image. This tool is designed to do this for you and 

should be run before deleting all products. 
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This will not delete the images from RMS or the RMS database. 
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5. Web Orders  

With your products online you can start trading. As orders start coming through Shopify you will 

need to start processing them through the POS. You can see the orders at any stage through the 

Shopify back end. For more information about the Shopify order processing screens, please see our 

Shopify – Getting Started guide. 

 

Web Orders placed through your web store must be processed at the POS. In order for them to be 

processed at the POS, you must have launched the RMSify Sync application on the POS computer at 

least once. This will install the Custom POS Button and integration with RMS. If it has been installed 

successfully you will have a button on the right hand side which will launch the Web Orders 

application. 

 

Pressing the button will launch the Web orders screen. 
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The application will automatically connect to Shopify and download orders when the Web Orders 

button is pressed in the POS. 

 

Additionally, once Web Orders has been opened the first time in the day, it will check for Web 

Orders automatically for you in the background, every 5 minutes. If it finds an order, it will tell you. 

 

If you restart your computer, you will need to click the Web Orders button again the first time to 

restart the automatic web order download process again. 

If you are using the Multiple Web Stores feature, pressing this button will retrieve orders from all 

web stores which this store has been configured to process orders for. For more information, please 

see section 4.9. 

If you do not have the custom POS buttons on the right hand side, these can be switched 

on in RMS through the screen properties (Ctrl + F6). For more information contact your 

RMS partner. 

If you are in a Headquarters environment, running Web orders will only work at the store 

you have configured to be your “Web Store”. See section 3.1 for details.  
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5.1. Get Web Orders  

If configured in the Shopify back end, you will receive an email notification when an order has been 

placed on your website. When one arrives you should press the Get Web Orders button to 

automatically download the orders into your RMS database.  If you wanted to update this list 

manually, you can do so with the Get Web Orders button. 

 

Pressing the button will contact Shopify and download all “Open” orders which have not been 

already downloaded into RMS, and have a payment status of “Authorised” or “Captured”. 

Any orders which Shopify have flagged as having a “risk” will be shown on the web orders screen 

with the yellow exclamation icon. 

 

If you double click the icon, it will tell you why Shopify thingks this order is risky. It is up to the 

retailer or cashier to determine if they want to proceed with the processing and fulfilment of this 

order or not. You can see more details about this order in your Shopify Administration pages. 

 

If you are using the Multiple Web Stores feature, pressing this button will retrieve orders from all 

web stores which this store has been configured to process orders for. For more information, please 

see section 4.9. 
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The Get Web Orders process will also close any orders which have been downloaded to RMS, but 

processed through the Shopify back end instead of through the POS. 

From this list you can  either Print a Pick List, or Complete the Order. 

RMSify does not support partial order downloads at this time.  

Any cashier which needs to process web orders must have the permission to alter tax 

status in their RMS cashier rights. For more information about this, please contact your 

RMS support partner. 
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5.2. Customers 

When you download web orders, it will automatically create the customers in RMS for you, if they 

don’t already exist. It checks if they exist based upon their Shopify account number, or email 

address. If it finds a match, it associates the web order with that customer, otherwise, it creates a 

new one. 

 

If you have a field mapping defined for additional information to be retrieved from Shopify, it will 

map it to the relevent field. See section 3.6 for details. These are displayed in the “Additional” tab in 

RMS. 
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RMSify will also create and associate a shipping address to the customer, in case it is different from 

the billing address.  

 

When the sale is completed it will lodge the sale against the customer record as if it were any other 

RMS transaction, which means it can be reported against and audited on for marketing purposes. 

RMSify respects the “New customers default as global customers” setting. If this box is 

checked then the customers will be Global. If it is not checked, they will remain as local 

customers. 
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5.3. Print Picking List  

Pressing this button with a web order selected in the list will print a picking list to the OPOS printer 

defined for the installed register. This can then be used by the cashier to go and find the products 

they need to dispatch. 

 

 

If you want to instead print it to a Windows printer, you can check the relevant box and choose the 

printer you want to print it to. 

 

Once the button has been pressed, the Status column of the Web Orders list will change to say 

“Picking” to indicate that someone is already picking the goods. 

The Picking List will also print any additional comments which the customer entered into their 

Shopify order, so it is useful to print this every time, just in case there are special instructions. 

OPOS printing on 64bit architectures may work in some instances, but is not supported at 

this time.   
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5.4. Complete Orders 

When you have picked the products listed in the order from the Picking List you have printed (Or at 

least the products which are available, you can press the Complete Order button. This will load the 

RMS POS transaction screen with the details of the order. 

 

It loads all products that were ordered online into the RMS transaction screen. In addition, it adds a 

Shipping item.  
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5.4.1 Order Discounts 

If the customer entered a Shopify discount code as part of their web order, then you will be 

presented with a screen which will let you choose which product(s) you wish to apply this discount 

to. 

 

By default, it selects the first product in the list. However, the discounted product can be changed, 

or even be applied to multiple products by checking the relevant boxes 

 

When the order is added to the transaction screen, it then correctly calculates the right total order 

value and applies the discount appropriately. 
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5.4.2. Sales Tax 

 

This section is only relevant if your RMS system is set to be Tax-Exclusive. 

 

Shopify and RMS are both very different when it comes to calculating sales taxes. Shopify uses sales 

taxes which are destination based, but you can choose whether or not these taxes are already 

included in your product prices or not. The same is true for shipping. 

 

When you are processing your Web Orders, if it comes across a scenario where the destination 

based tax is applicable in your Shopify order, RMSify will look for an appropriate tax rate in RMS. If it 

can’t find it, it will need to create it for you. 

 

If you press No you will not be able to complete the web order. If you press Yes, you will need to 

restart the POS for it to activate the new tax rate. 

 

The order will then be processed as normal  
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5.4.3. Shipping 

Due to the radical differences between RMS and Shopify’s billing mechanisms, there is no direct 

integration between RMS and Shopify’s shipping providers. RMSify does not make use of RMS 

Shipping functionality at all.  

Instead, RMSify automatically creates an item in RMS with the Item Lookup Code of 

“WEBSHIPPING”, meaning you can filter your reports to include/export this item as required. It is a 

Non-Inventory item. 

 

When an order is loaded to RMS, RMSify will add this “WEBSHIPPING” item to the transaction. The 

price it shows in the POS screen will reflect the shipping charge which Shopify has calculated based 

upon the shipping rules you have defined in the Shopify back end. 
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5.4.4. Process Order 

Processing the whole order is as simple as tendering the transaction. Once the order is loaded into 

the POS transaction screen, all the prices will match what were listed on the Website. 

 

When you tender the transaction, you MUST do so solely against the Web Tender which is defined in 

the tender settings (3.4). Failure to do so will result in the transaction not getting marked as Closed 

in Shopify, and payment will not be captured from the customer. 
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If for whatever reason the order cannot be completely fulfilled, you can remove the lines from the 

transaction screen which are unable to be met. For partial orders, RMSify will always close the order 

regardless of if all the items are fulfilled or not. Multiple deliveries for the same order are not 

supported. 

The payment is captured for the value of the goods actually processed, so if an item cannot be 

fulfilled, the payment taken by Shopify to your payment gateway is adjusted accordingly. 

If you are using the Multiple Web Stores feature, then Shopify will obviously fulfil the order through 

the web store that the order came in on, and it works this out for you automatically. For more 

details on this feature, see section 4.9. 

5.4.5. Tracking Number 

Prior to the Web Order being finalised, RMSify will ask you what the shipping number is for the 

dispatch you will be sending to the customer. If you know the shipping number you can enter it here, 

if you don’t then you can leave it blank. 

 

The Shopify order fulfilment emails can then be configured to include a link to your shipping 

providers tracking system, and include the tracking number in the email as part of that too. You can 

modify this in the Shopify Email templates 

5.4.6. Customer Notifications 

Once the web order is tendered through the POS, Shopify fulfils the items and closes the order. At 

this point, the customer receives some notifications to let them know how their order has been 

dispatched. 
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6. Quick Editor 

Quick Editor is a data editing tool which lets you make quick changes on both a small and large scale 

in an excel style grid interface. Quick Edit 

It also allows you populate and edit data in your custom fields (See section 3.9 for instructions on 

how to create these), and is a really easy way to manage your webstore data. 

To open Quick Editor, use the Tools > Quick Editor menu.  

Quick Editor can make wholesale changes to your database. Before making such changes 

we recommend backing up your database. 

 

 

1 2 
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6.1. Filter 

 

The filter is designed to let you narrow down the products you want to examine/edit. You can use as 

few or as many filters as you like as they are cumulative. Simply use the drop down boxes and check 

boxes to narrow down your selection. 

Supplier  Will return items which are supplied by the selected supplier 

Department  Will return items which are assigned to the selected department 

Category  Will return items which are assigned to the selected category 

Season   Will return items which are assigned to the selected season  

Web Items  Will return items that are members of the selected Web Item Filter (4.10) 

Search String  Will return all items where it finds the given text in the description 

Exclude Inactive Will exclude any items marked “Inactive” in RMS 

Show Items With Stock Will only show items if there is a positive on hand quantity for the product 

Show … Items On Sale Will only show items with a current Sale Start Date/End Date 

Show … Disc Applied Will only show items where they are a member of an RMS discount 

When you have chosen your filter option, press the Apply Filter button. To clear your filter and start 

over, press the Clear Filter button. 

As Quick Editor can consume a lot of system resources on larger databases, you must 

choose a filter of some kind in order to show some data. If you are happy to accept there 

are performance issues, you can simply enter * into the search string box to return all 

items. This is at your own risk. 
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6.2. Data Grid 

This is the main area where the data is displayed. It will be blank unless you have applied a filter. 

There are two types of column. The read only columns are Green and Yellow, and the editable 

columns are White. You can see information on data editing the white columns in section 6.4. 

 

The columns being shown can be resized, and these sizes are remembered for the next time they are 

opened. 

You can manipulate which columns are shown, and in which order, in section 6.3. 
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6.3. Columns to Display 

The data grid can be manipulated to look however you want it (Except for the Read Only columns. 

This is performed on the left hand side. However, if you want to change the filter you can switch the 

panel back to the filter screen by pressing Please choose a filter. 

 

The list of columns shows all fields available in RMS including any custom fields which you have 

added (Section 3.9). In order to see them in the data grid, simply check the box for the field you 

want to see, and uncheck the box for data you don’t. 

You can also change the sequence of the columns by selecting the field in the list and pressing either 

Move Up Order or Move Down Order. 

Any changes you make to the columns to display take effect when you press Refresh Grid. 
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6.4. Data Editing 

In quick editor there are many ways to edit and manipulate your data. 

6.4.1. Enter Data Manually 

The most simplistic method is to click on a field and edit it by typing in new values. The way to do 

this varies depending on the type of field you are editing. 

Long Text For a long text field, Quick Editor will show an expanded text box to give you more 

visibility over what you are typing 

 

Short Text For a shorter text field, simply enter/edit a value in the box. 

 

Number Numeric fields work the same way as short text boxes, but restrict you only to 

numeric values. 

 

Date Date fields let you pick a date using a small calendar 
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Money Money/currency fields will automatically format the numbers you enter as a 

monetary value with currency symbol. Just type in or modify the price 

 

Picture Double clicking a Picture field will elt you browse to a picture file. Quick Editor will 

also automatically copy the picture file itself to the Pictures folder (When you press 

Save) as this is where it needs to be to upload to Shopify. 

 

Picker In a field where you are limited to the values you can enter, you’ll get a drop down 

box to pick the option you need. 
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6.4.2. Apply To A Range 

When you have modified (Or not!) a piece of data in Quick Editor, you can apply the change to a 

range of cells in the same column. 

First, click the cell you want as the “Source” and drag it up or down the column to select the range. 

 

Then press the F12 key. It has copied the content across the rest of the selected cells. 

 

Alternatively, if you want to paste the data to a range of cells which aren’t joined to the source, you 

can use copy and paste. Click the cell you want as the “Source” and press Ctrl+C on the keyboard. 

This puts the cell contents in the clipboard. 

 

Select the cells you want to paste the data into 
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And press Ctrl+V on the keyboard to Paste it in. 

 

6.4.3. Apply to Matrix/Dimension1/Column 

If you don’t want to use click and drag functions as mentioned above, you can apply the changes to 

an entire Matrix, an entire matrix/Dimension 1 Combination, or the Entire Column. 

Simply click and edit the data you want to change and press Enter. 

Then reselect the cell and click one of the options from the button bar at the top of the screen. 

 

Apply to Matrix This function is only active if the item selected is a member of a 

Matrix. It will apply the value in the selected cell to all items which 

are also a member of the same matrix. 

Apply to Matrix/Dimension1 This function is also  only active if the item selected is a member of a 

Matrix. It will apply the value in the selected cell to all items which 

are also a member of the same matrix and also share the same 

Dimension 1 attribute. 

Apply to Entire Column This will apply the data to every item in the selected filter. So prior 

to using this, ensure that only the items you want to update are 

filtered correctly! 

These options are also available if you Right Click the cell you have selected. 
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6.4.4. Apply Formula 

When you are editing Number or Money fields, a function becomes available in the Right-Click menu 

called Apply Formula.  

 

This function will let you perform a calculation on the field which you can also apply to the whole 

Matrix, Dimension or Column. The key thing to remember is that the end result of the formula gets 

applied to the column you have selected. In the example above, this will be Web Price. 

 

You firstly choose a Base Field. This is the starting point of your formula. This could be the same 

column you have selected. 

Then you choose an Operation. Which will be to either add, subtract, multiply or divide that base 

field. 

Then you choose if you want to perform the operation by a Percentage or a fixed Value. 

Then you enter that Percentage or Value in the Value box. 

The example below will take the Price field and will reduce it by 10%. 

 

So if Price = £100.00, then the Web Price will become £90.00 

The next example will take the Cost Price field and add £20 to it 
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So if Cost Price = £50.00, web price will become £70.00. 

You could even (If you choose to) perform an exact copy of the column using the below example. So 

you would take the Price field and add £0 to it 

 

So if Price = £100.00, then Web price=£100.00. This would give you a starting point to make 

adjustments to your prices without affecting yourRMS prices. 

You can also choose to apply the formula to the Matrix, Dimension, or Entire Column in the same 

way as you could in section 6.4.3. 

 

And you can also choose if you want to round up or down to the nearest whole £/$. And if you do 

then you could deduct a number of pence. 

 

The example below will round DOWN to the nearest £ and then deduct 5 pence. 

 

So if the price was £100, it would subtract 10% and round down (If applicable) to the nearest whole 

pound and then deduct 5 pence. The end result in the Web price would be £89.95 

The rounding options are not available if the field is a custom field of type “Float”. 

You can then press the Apply button to perform the calculations. 
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6.4.5. Text Functions 

When you are editing Text fields, a function becomes available in the Right-Click menu called Text 

Functions.  

 

This feature lets you Find and Replace, Prefix, Suffix and Overwrite text data in a column, with either 

data from another field, or a text string you decide to enter. You can then perform the function on 

the Matrix, Dimension or the Entire Column. The net result will be applied to the column you right-

clicked to access the function. 

 

Find and Replace 

Find and Replace will search for the value you enter in the box, and replace it with the value 

selected/entered in the options. 

In the example below, it would look for the word “CLA” and replace it with the word “Clarks” 
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In that instance it would replace all instances of CLA, wherever it appears in the column. 

If you wanted to only replace data where the field was EXACTLY CLA (And there was no other data in 

the field) use the “Exact Match” check box. 

 

However, if I wanted to use the data in an existing field I could instead automatically the data from 

there by choosing the field as the replacement value. In the example below it will still look for “CLA” 

but instead it will replace it with it’s “Vendor” name. 

 

Insert Before 

Insert Before will prefix the field you have selected with the value/field chosen, including a space. 

In the example below, it will prefix the Web Size “5” with the word “UK ”. 

 

And the result is “UK 5”, is it includes a space. 

 

I could also if necessary choose a field name to Insert Before. The example below will change web 

size “5” to “Clarks 5”, as the Vendor name is Clarks. 
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Insert After 

The Insert After function behaves in a similar way to “Insert Before, but appends the end of the field 

instead (Including a prefixing space). 

In the example below, it would suffix the Web Size “5” with the word “ UK”. 

 

So the end result is “5 UK” 

 

Or you could, like the example below, suffix it with an existing field. The example below would suffix 

the Web Size “5” with the Vendor “Clarks” 
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Overwrite 

The overwrite function will replace the entire contents of the field you selected with the value/field 

you choose. This function is particularly useful as a “Copy” function, as you can quickly replicate the 

contents of one column into another. 

The example below will overwrite the “Web Size” field with the contents from the “Dim 2” field. 

 

And the result is as follows. 

 

Alternatively the example below will set the “Web Size” field to be “One Size” 
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The result is as follows. 

 

6.5. Save 

Changes are not commited to the database until you click the Save button. This means you can work 

away on your data without committing any changes to your database. However, if you choose not to 

save data and you force quit the application or it crashes, you will lose such changes. 

So we recommend making a backup prior to using Quick Editor, and then saving data regularly to 

prevent you from losing your work. 

If you are using Headquarters, when you try to exit Quick Editor it will offer to create the relevant 

worksheets for you. Quick Editor is clever and only create the appropriate worksheet styles for the 

products which you modified. If you want to create these worksheets you can press Yes. 

 

 

Once created, you will then be asked if you want to Approve them. If you are happy to approve them 

then you can press Yes.  
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Appendix A: Link Directory 

RMSify Support – support@k3retail.com 

Support for the RMSify software. 

Shopify Wiki - http://wiki.shopify.com/Main_Page 

Full documentation on Shopify from start to finish. Includes theme design and development in a 

language any designer can understand. 

Shopify Support - http://support.shopify.com 

If you need help with any aspect of Shopify, then this is their knowledgebase and support ticketing 

website. Registration is required 

Shopify Experts - http://experts.shopify.com 

This is where the Shopify Experts advertise their services. If you’re looking for a designer this should 

be the first place to come. 

Shopify Job Board - http://forums.shopify.com/categories/11 

If you’re looking to hire someone for a custom theme for example, you may want to post an advert 

here. Registration required. 

Shopify Forum - http://forums.shopify.com 

The Shopify Forum allows you to post and interact with other Shopify users, share knowledge and 

experience and get help. 
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Appendix B: Payment Gateways 

Shopify supports the following payment gateways. You will need to sign up an account and obtain 

the relevant details needed for Shopify. The details required won’t be available in Shopify until you 

choose your gateway. 

This list also states if the provider has a test mode available or not. 

Please note: Merely signing up for these accounts may not be enough. To get full instructions on the 

steps required to use the provider with Shopify, choose the provider in the Checkout and Payment 

section of your Shopify Admin. It tells you what you need to do for that provider. 

List correct as of 2nd February 2012 

United Kingdom: 

Cardstream – http://www.cardstream.com (Test Mode) 

Chronopay - http://www.chronopay.com 

Datacash – http://www.datacash.com (Test Mode) 

DirectEBanking - http://www.directebanking.com  

Iridium - http://www.iridiumcorp.co.uk 

Nochex - http://www.nochex.com 

Paymentexpress - http://www.paymentexpress.com 

PSLPayment – http://www.paymentsolutionsltd.com 

Realex - http://www.realexpayments.com 

Sagepay - http://www.sagepay.com (Test Mode) 

Sagepay Form - http://www.sagepay.com 

Worldpay (Direct) - http://www.worldpay.com (Test Mode) 

Other: 

Authorise.net - http://reseller.authorize.net/application/?id=5555050 (Test Mode) 

Barclays ePDQ - http://www.barclaycard.co.uk/business/accepting-payments/epdq-mpi 

Beanstream - http://www.beanstream.com 

Braintree - http://www.braintreepaymentsolutions.com 

Cybersource - http://www.cybersource.com/ (Test Mode) 

Direcpay - http://www.timesofmoney.com/direcpay/jsp/home.jsp 

E-xact - http://www.e-xact.com 

EFSNet - http://www.concordefsnet.com (Test Mode) 

Elavon MyVirtualMerchant - http://www.elavon.com 

ePay - http://epay.dk 

ePaymentPlans - https://www.epaymentplans.com 

eWay - http://www.eway.com.au 

FirstData US - http://www.firstdata.com (Test Mode) 

Garanti Sanal POS - https://sanalposweb.garanti.com.tr 

GestPay - https://www.sella.it/index.jsp 

HiTrust - http://www.hitrust.com.hk 

InspireCommerce - http://www.inspiregateway.com 
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Instapay - http://www.instapayllc.com 

Merchant eSolutions - http://www.merchante-solutions.com 

MerchantWARE by Merchant Warehouse - http://merchantwarehouse.com/merchantware 

Modern Payments - http://www.modpay.com 

Moneris - http://www.moneris.com 

Moneybookers - http://www.moneybookers.com 

Nelix Transax - https://www.nelixtransax.com 

NetBilling - http://www.netbilling.com 

NetRegistry - http://www.netregistry.com.au 

Ogone Directlink - http://www.ogone.com/en/Solutions/Payment%20Processing/DirectLink.aspx 

PayboxDirect - http://www.paybox.com 

PayJunction - http://www.payjunction.com 

Paypal Payflow Pro – http://www.paypal.com 

PaySecure - http://www.commsecure.com.au/paysecure.shtml 

Plugn’pay - http://www.plugnpay.com 

Psigate - http://www.psigate.com 

Quickbooks Merchant Services - http://payments.intuit.com (Test Mode) 

Quickpay - http://quickpay.dk 

Sage Payment Solutions - http://www.sagepayments.com 

SecurePay - http://www.securepay.com 

SecurePay (Australia) - http://securepay.com.au (Test Mode) 

SecurePayTech - http://www.securepaytech.com 

SkipJack - http://www.skipjack.com (Test Mode) 

Stripe - https://stripe.com 

TransFirst - http://transfirst.com 

Trust Commerce - http://www.trustcommerce.com 

USA ePay - http://www.usaepay.com 

Valitor - http://valitor.is 

Verifi - http://www.verifi.com 

Viaklix - http://www.viaklix.com (Test Mode) 

Wirecard - http://www.wirecard.com 

Worldpay (Offsite) - http://www.worldpay.com (Test Mode) 

 

 

 

 

 

 


