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General Information 
 

1. Introduction 

DNA is a fundamental unit of any organism, which makes it the most intriguing and exciting option 

available for construction of nanostructure. Due to its specificity of the base pairing, it weaves itself 

in to the target structures at nano level. DNA origami [1] is a simple method used to construct 

complex two-dimensional (2D) and three-dimensional (3D) structures by DNA self-assembly [2]. 

However, conducting random experiments for constructing such structures is exhaustive and 

expensive, hence, there is need to develop the software for such nanoscale construction. DNA Pen 

is one such tool for creation of two dimensional DNA nanostructures which employs the idea of 

DNA Bricks [3] [4]. Desired shapes are created on the molecular canvas and the respective 

sequences required for the building of the shapes is generated as output. It generates error free 

DNA sequence with the error correction and stability modules [5]. By the designing of the 

structures, visualizing the structure, the software increase the efficiency and productivity of the nano 

scale construction  

2. Overview 

DNA Pen has been primarily developed to facilitate the construction of nanostructures by DNA 

Brick. The software encourages the users to first visualize the structures, draw them accordingly on a 

virtual sheet and then generates the required DNA strand sequence. By this we not only achieve 

automation but also minimize the need for repetitive experimentation for developing one structure.  

The reduction in exhaustion is because of two processes that the software undertakes. The software 

is able to give infinite number of DNA strand sequences for the same shape. It allows user to 

choose to variety of DNA strands for the experiments. 

3. Product Scope 

This software provides the user with: 

 Visualization and list of DNA strand sequences for DNA Bricks of different dimensions. 

 Visualization and list of DNA Brick sequences for 2D structures drawn on a free-hand draw 

grid.  

 Visualization and list of DNA strand sequences for 2D structures drawn on a digital grid. 

(Each cell in the grid represents one tile of DNA Brick) 

 DNA Pen checks for the thermal stability of the DNA strand sequences generated. Also it 

makes sure that there are no possibilities for any kind of secondary structures being formed. 

The strings then go through a refined process to ensure that they satisfy the constraints for 

error-correcting codes. 
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4. Product Perspective 

This product’s main aim is to make the process of making the computerization and computation 

of DNA Origami structure user friendly. 

System Summary 
Operating Systems – Windows 7, Mac OS X 

This software requires the system to have specifications similar to: - 2.4 GHz Core 2 Duo, 

100 MB Hard Disk, 2GB Random Access Memory and Basic peripherals like keyboard, mouse etc. 

Getting Started 
 

Once you have successfully installed the software, open DNA pen by double clicking on the 

icon available on your desktop screen, a window with four menu options on the menu bar will 

appear. The dialogue box generating the random tips will appear that will guide the user about 

the software utility. It includes the button for creating the new project. User can click on this 

button or can select the option “Create a new project” from the file menu. This will open the 

dialogue box that will ask to enter the name of the project. Once user specifies the name, select 

the path to save the project at specific location and click on “create” button. Once you save the 

project folder at specified location, this folder consists of all the output files of your project. The 

main features that the software provides the user with and which are spanned across these four 

options on the menu bar are:- 

 Work on Free-hand Molecular Canvas 

 Work on Digitized Molecular Canvas 

 Save Detailed DNA Data 

 Save DNA Sequence 

 Save PDF 

 Create Latex file 

 View Draw Image 

 Edit Dimension 

 Estimator 

 Capture Canvas Screenshot 

 Clear  

 Social Media 
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1. Free Hand Molecular Canvas  

This option is available under the tools menu of the menu bar. When the user clicks on “Tools -

> Free Hand Molecular Canvas”, the display area on the DNA Pen’s home window where 

user can draw the 2D structure he wants to create. Using this molecular canvas is very easy; a 

simple mechanism is to be followed. The user has to click and drag the mouse simultaneously on 

the canvas in accordance with the shape that he wants to create. It works just like drawing tool 

Paint, where you can draw any shape. If you want erase some you can select Erase   button on 

right hand top corner of the screen. To again start drawing select Pen mode by Pen button next 

to erase button. Figure 1 is the example of the hindi letter “OM” created on the free hand 

molecular canvas. User can draw any free hand shape he wishes to built at nano scale on this 

free hand molecular canvas. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1 Free Hand Molecular Canvas 

 

2. Digitized Molecular Canvas 

This option is available under the tools menu of the menu bar. When the user clicks on the 

“Tools-> Digitized Molecular Canvas”, the display area on the DNA Pen’s home window 

would be filled up with a gridded canvas. Here the canvas would be filled with cells which are 

bigger in size as compared to the cells available in Free Hand Molecular Canvas. The user simply 

needs to click on the cell that he wants to be a part of his structure. The cell gets highlighted as 

the user clicks on it. Figure 2 is the example of the nano shape of Cross designed on the 

Eraser 

mode 
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digitized canvas.  There is an undo option available in the tools which enable the user to undo 

the designed once built. Also by clicking twice on the cell it will de-highlight the cell. 

 

 

Figure 2: Digitized Molecular Canvas 

 

3. Save Detailed DNA Data 

This option is available under the File menu of the menu bar. When the user clicks on “File -> 

Save Detailed DNA Data”, DNA Pen checks whether the user has created a design on either 

of the two molecular canvases available. The software saves an excel file which contains an 

ordered list of the DNA strand sequences required to make such a structure experimentally and 

coordinates of the tile used to generate the shape. A pop-up window is generated that confirms 

that file is saved successfully at specified location with the name DNAData_filename.  Figure 3 

shows the way to save the designed shape, which will generate the sequence to for the designed 

shape. 

4. Save DNA Sequence 

This option is available under the File menu of the menu bar. When the user clicks on “File -> 

Save DNA Sequence”, DNA Pen checks whether the user has created a new Brick and 

changed the dimensions from the default values. The software saves an excel file which contains 

an ordered list of the DNA strand sequences used to make the Brick. A pop-up window is 

generated that confirms that file is saved successfully at specified location with the name 

DNAData_filename.  
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Figure 3: Save detailed DNA option generate DNA sequences 

5. Save PDF 

This option includes all the output in one PDF. Once you draw the shape on the canvas, click 

on this option. It will include the barcode number which is unique to all the shapes drawn by the 

user.  This will help to identify the shapes drawn by him uniquely. It will include image of the 

structure designed in the canvas, dimension of the brick and brick image. This all are the output 

in one page which will help user to understand it better. A pop-up window is generated that 

confirms that file is saved successfully at specified location with the name 

FreeGridData_filename (If user had drawn on freehand molecular canvas) and 

DigitizedGridData_filename. 

6. Create Latex File 

This option includes all the latex file  of the DNA sequence and its related information like total 

number of half tile and full tiles and total DNA sequences generated.in one PDF. Once you save 

the DNA sequences, click on this option. This will create the latex folder which include image of 

the shape and PDF that includes all the DNA sequences in well-organized tabular format. All 

are the output in one folder which will help user to understand it better.  

7. View Draw Image 

This option will generate the image of the shape drawn. It will display the tiles arranged in 

specific manner according to the shape drawn on the molecular canvas. This will allow the 
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user to understand how the specific shape gets arranged according the design of the single 

stranded tiles. Figure 4 displays the arrangement of the SST for the shape in figure 3. 

 

 

 

 

 

 

Figure 4 SST arrange in specific manner by view draw image option 

8. Edit Dimensions 

This option is available on the menu bar under the Edit menu. When the user clicks on “Edit -

> Edit Dimensions” a small pop up window opens up where the user can select any 

dimensions from dropdown options. The pop-up has 2 buttons at the bottom of the window, 

the “Save” and the “Cancel” button. The Save button saves the dimensions of the brick 

created and now if the user works on the molecular canvas, the bricks used in the backend 

would be of the dimensions as specified by the user.  Figure 5 shows the dialouge box appear 

when user wish to change the brick dimension.  

9. Estimator 

This option is available on the menu bar under the Tools menu. When the user clicks on 

“Tools-> Estimator” a small pop up window opens up where the user can enter the cost per 

base of DNA. This will give you total cost of the DNA sequences used to generate DNA 

sequences in US dollar (USD). 
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Figure 5 Dimensions for the free grid molecular canvas . 

10. Capture the screenshot 

This will take the screenshot of the canvas. It is available in Tools menu. This will ask user to 

save the screenshot at user choice destination. 

11.   Clear 

This will clear your shapes drawn on the molecular canvas.  

 

12.  Social Media 

This provides links to follow us on the social media websites.  You can follow DNA Pen at 

Facebook, Twitter, Quora and You tube.  

 

Output 

Once you save the draw data, the output generated is in the excel format. The destination place 

which you have selected to save the draw data, contains the excel file. Double click on the file to 

open it. It gives the information about the base sequences required for the shape designed. Also 

it includes the sequences for each domain in the DNA bricks, number of full and half tile for 

each domain and number of stick ends. It generates the coordinates for each base in the 

sequence on the basis of shape constructed on the molecular canvas. Figure 6 show the sample 

output file for the above shape mentioned in the digitized molecular canvas.  This output helps 

the researcher to design the shape with respect to arrangement of bricks DNA and the stick 

ends.  
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Figure 6 Sample DNA detailed output file 

 
Help Menu 

 
 “Help” menu which is very common in any software. There are four options in the Help Menu. 

1. User Manual 

2. Product Demo 

3. Product Feedback 

4. About 

 First option, user manual should open this user manual in the default PDF reader of user’s 

system. 

 Second option product demo will open the homepage of DNA Pen where the demo is 

available. 

 Third option will open the feedback form where you can give feedback for the software. 

 Finally about option recognize the contributors in this project. There is a dialog box that 

opens up as shown below, which contains information like logo of the software, version of 

the software, name of the software, Credits button and URL of the software. On pressing 

“Credits”, it opens a PDF document in user’s default PDF reader. 
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Support and Feedback  

 
Users are requested to contact team at the email: dnapen@guptalab.org for feedback and any other 

issues with the software. Two platform specific installers (Windows and Mac) are available on the 

project home page along with source code with open source license agreement.  
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