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Introduction to Case Study E
Parent topic: 
Tutorial case 
study E 
(Forward and 
inverse 
modelling of 
potential field 
data)

Why are we interested in potential field data as an aid to geological mapping? There 
are generally insufficient geological observations to unambiguously construct the 
boundaries between formations to form a 3D geological map. Observations are 
generally in short supply at depth and relationships between formations may be 
unclear. Variations in potential field response are related to the 3D distribution of 
physical properties. If we can sensibly relate physical properties to the units used in 
the geological map, then the potential field data can provide additional insight into 
the 3D distribution of the mapped units. Potential field data are often readily 
available and uniformly sampled, enhancing the value of these data. 

The purpose of this tutorial is to show functionality available in the 3D GeoModeller 
geophysics modules so that you can apply this powerful technique to your own project. 

In this section:
• Definitions and references
• Interpretation phases
• Overall strategy
• The geological scenario and starting 3D litho-model
• Introduction to litho-constrained inversion of gravity and magnetics
• Physical properties
• Prior geological information
• The need for a close initial 3D geology model
• Strategies for achieving successful inversions of geophysical data
• Inversion analysis flowchart
• Overview of steps for this case study
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Definitions and references
Parent topic: 
Introduction to 
Case Study E

In geophysics, the term forward modelling refers to the process of calculating a 
response given a physical property model. You can carry these calculations out  
relatively quickly and accurately to predict the gravity and magnetic response, given 
a 3D model of density and magnetisation respectively. 

Property optimization is a term used to describe a simple way to improve the 
overall fit of your geology model to any observed geophysics grids you may have. 
Often your rock property knowledge, especially of deeper unit’s is very poor. With this 
technique, you can easily come up with average properties that make a best fit overall 
for each unit. With this, it is much easier to then judge if your geology model is giving 
a reasonable first fit to the geophysics.

Inverse modelling or inversion is the reverse operation to forward modelling, 
attempting to derive a physical property model given a set of observations. With 
potential field data, this is a much more challenging process than forward modelling 
because there is more than one possible solution. To circumvent this characteristic, 
termed non-uniqueness, you can define some preferred characteristics for the 
solution. The inversion program can then find one or more solutions that not only 
reproduce the observations but satisfy your preferences. In this instance, these 
preferences or ‘constraints’ are in the form of the 3D geological map and the physical 
property distributions that you define for each geological formation in the map. 
References

Parent topic: 
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Forward modelling and inversion with 3D GeoModeller (a 3D GeoModeller 
reference manual).

Interpretation phases
Parent topic: 
Introduction to 
Case Study E

The flowchart shows the basic phases for production of an integrated interpretation of 
geological, physical property and geophysical data. Operations that you can carry out 
using 3D GeoModeller are shown in cyan. 

Following acquisition, geological observations are assessed and assigned to categories 
(‘formations’). The mapping module is used to compile boundary and orientation 
information into a 3D map that shows the geometrical arrangement of boundaries 
between the formations. Physical property measurements are assigned to formations, 
and statistical methods are then used to determine the characteristics of these 
properties at the scale of the elements used in the inversion phase. 

Overall strategy 
Parent topic: 
Introduction to 
Case Study E

These tutorials guide you through practical demonstrations beginning with a forward 
modelling exercise and progressing to a litho-constrained, joint inversion of gravity 
and magnetic datasets. 

Put simply (see illustration below), the idea is to begin with a starting 3D geology 
model that honours all geology observations (somewhere in green space). Then, use 
the observed gravity and magnetic data sets to drive an inversion result to deliver 
only 3D geology models which also honour the gravity and magnetic data, i.e., in the 
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overlapping space between red, green and blue 3D GeoModeller uses the principles 
of statistical sampling to drive the inversion process, so the approach can be thought 
of as a Monte Carlo, Markov Chain simulation. For more details see Forward 
modelling and inversion with 3D GeoModeller.

The geological scenario and starting 3D litho-model
Parent topic: 
Introduction to 
Case Study E

Your exploration team has identified what they hope to be a swarm of volcanogenic 
massive sulphide deposits from the initial airborne gravity survey. More detailed 
surveys of gravity and magnetism have been flown in follow-up exploration, revealing 
many anomalies in both the gravity and magnetic signature.

Following image processing enhancements of the potential field data sets, Euler 
methods (automatic depth determination) and multi-scale edge detection analysis 
have been carried out and your exploration geophysicists have singled-out the 
location of one of the largest anomalies. They recommend the team focus on this 
anomaly for higher resolution geological interpretation, prior to planned drilling. 
Their initial assessment of this anomaly is that it appears to reflect the presence of a 
rough granite body, elongated in a north-south orientation, and buried at least 200 m 
below ground surface. 

The setting may be part of a well developed rift, with faulting on the edges of the rift 
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zone, some volcanics associated with these faults, and crustal thinning, where a 
granite intrusive shows as a gravity high, along the axis.

The figure is taken from Peter Gunn’s 1997 paper in the AGSO volume 17 geophysics 
practice manual. Our exploration team's task now is to build a starting 3D geology 
model for the focus area, and adopt some appropriate physical properties for the 
geological formations based on locally accumulated data sets for density and 
magnetic susceptibility, and generic published tables. 

As a starting model, your exploration team propose an elongated granite dome within 
a homogenous host formation (two units in total). Initially the team agrees the slab 
may have dimensions of ~450m (length) x ~150m (width) x ~200 metres (height), and 
is buried 200 metres below the surface.

Introduction to litho-constrained inversion of gravity and magnetics
Parent topic: 
Introduction to 
Case Study E

Because of the non-uniqueness associated with both geological and potential field 
observations, we cannot tell whether the 3D geological map in the current project and 
the estimates of the physical properties are a good approximation of the ‘truth’ or not. 
The most that we can say is that this combination of geometry from the 3D map and 
properties from the supplied distributions, is one of many solutions that would be 
consistent with all of the observations. However, if this combination of inputs 
produces a response that is significantly different to the geophysical observations, we 
can conclude that combination is extremely unlikely to be present. 

The inversion method implemented in 3D GeoModeller begins with linked lithology 
and property models, which we assume to be close to the ‘true’ models. The algorithm 
generates a sequence of linked models that are similar to these starting models by 
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making small random changes to the lithological boundaries and physical properties. 
After each change is made, the likelihood of this combination of models is assessed by 
comparing the predicted potential field response to the supplied observations. The 
proposal is then accepted or rejected.

The algorithm preferentially samples models that have greater likelihood.   It is, 
however, important for you, during the monitoring stage of the inversion, to decide if 
this likelihood equates to reproduction of the observations within a reasonable 
uncertainty envelope. If this is not the case, then you must make changes to one or 
more of the following:
• The starting litho-model
• The physical property distributions assigned to each formation
• The uncertainty levels associated with the geophysical data
You can run another inversion session using the modified inputs. 

At the conclusion of an inversion session, 3D GeoModeller carries out an analysis of 
the ensemble of models that was generated. Although this analysis is restricted to 
models that reproduced the observations to an acceptable degree, there may be many 
millions of models involved. 

We use statistical methods to distil and simplify the information contained within 
these models. It is important to recognise the difference between statistical entities 
such as the ‘most probable model’ from the models that were actually sampled during 
the inversion. The statistics highlight general features of the samples, but do not 
necessarily represent a ‘true’ configuration of lithologies and properties. 

Physical properties
Parent topic: 
Introduction to 
Case Study E

It is unrealistic, given our knowledge of the real world, to assign a single constant 
physical property to each geological formation. It is also well known that the bulk 
properties of rocks vary considerably from those measured in a laboratory, on a small 
scale, or say from a sample gathered in a borehole. We tend to measure the properties 
of the most durable portion of the population and ignore the more friable fraction. 
Every formation shows some degree of heterogeneity. We simulate this in the 
inversions by defining a ‘distribution’ or spread of physical properties for each 
formation. Our convention for recording the spread, is to ask you to define a 
probability distribution function or PDF. In the simplest of cases, this can be a 
Normal population with a mean and standard deviation.  In a forward model, the 
mean is adapted for the single run.

Before spending time on inversion, we recommend you spend some time checking the 
bulk properties. This can be done using a new property optimization method. You 
take your geology model, give your formations a property distribution. You also allow 
a lower bound and an upper bound for each property. These bounds should be 
conceived and constrained by reasonableness. If the results show that some 
properties required to explain the geophysics are consistently at one end of the 
bounds, maybe your model is not as good as it needs to be. 

During an inversion session, 3D GeoModeller selects properties at random from the 
supplied distribution. The algorithm is more likely to retain a selection that improves 
the fit between the observed and predicted geophysical response than one that 
increases the misfit between these two quantities. 

Note that the distributions supplied for each formation are for samples having a 
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volume equal to the volume of the cells used in the models. These cells typically have 
volumes that are many orders of magnitude greater than the volume of drill core or 
hand specimen samples (for example, a model cell 100 x 100 x 50 m in size has a 
volume 1 billion times larger than a sample 100 x 50 x 50 mm in size). 

Much of the local heterogeneity seen in collections of drill core or hand specimen 
measurements is averaged out when considering the variability between samples 
having large volumes. This issue of estimating the variability between samples with 
different volumes is analogous to the problem of estimating the grade for a mine stope 
from assays of drill core samples. The variability in the grades for stopes is always 
much less than the variability observed in small volume samples. 

Unfortunately, it is very difficult to estimate the correct variability (spread of values) 
for specifying in 3D GeoModeller without measurements from a large number of 
samples from many locations within the project area. However, if you have some 
confidence in the volumes of the main units, Property optimization (E2) can help.

Prior geological information
Parent topic: 
Introduction to 
Case Study E

Prior to commencing forward or inverse modelling, methodical investigation of all 
available datasets is crucial to building a realistic starting 3D geology model. 

The following illustration shows progressive investigation of gravity and magnetic 
data via a range of interpretation methods. In combination with all available 
geological observations (surface and sub-surface), completing some or all of these 
methods can provide best-available knowledge for building your starting 3D 
geological model.
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The need for a close initial 3D geology model
Parent topic: 
Introduction to 
Case Study E

Most successful use of the fully constrained lithological inversion method is achieved 
by first creating a starting or reference geology model that is consistent with all of the 
geological observations, and also closely honours the observed geophysics signals for 
most of the study area. This is necessary because the Monte Carlo techniques adopt 
very detailed processes of changing individual properties or geometries, and a close 
starting model will ensure you minimize the time needed to explore probability space 
and maximize your chance of converging quickly to an acceptable mis-fit, allowing 
time to continue on gathering good statistical results. 

Below is a histogram illustration of a non-viable reference model prior to any 
inversion. The left hand population from a forward model of the gravity response is a 
completely different distribution to the observed response. The average starting mis-
fit is more than 200 mGal, and far too much to consider inversion. 

        Left is observed, right is calculated (units in mGal)
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Taking the example case here of having an observed gravity grid and a forward model 
of the gravitational response from your model (above figure), you should immediately 
examine the two grids for a spatial comparison, and also on a statistical basis. In the 
case shown, the likelihood of your starting position migrating to the required 
observed position, while also honouring the known constraints, is very low. 

One extra complication here is the issue of detrending a regional response. What this 
can mean is that your observed grid of geophysics data contains a contribution from a 
much larger and deeper volume than what you are modelling. You can either high 
pass filter your grid to remove a regional or allow geomodeller to detrend the 
observed grid, in an automatic way, thus also removing the regional.

By analogy it is very important to build an initial 3D geology model that is as close as 
possible to the real situation. To check this - forward modelling of the gravity and 
magnetic responses of your initial geology model (using measured or assumed 
physical property values for each geology formation) is strongly recommended. This 
way you can compare the 'predicted' with 'observed' gravity and magnetic responses, 
and manually make changes to your 3D GeoModeller model or changes to the 
assigned physical properties (if these are not known with high-level certainty). 
Forward geophysical modelling, followed by revisions to the geology model (geometry) 
and physical properties (densities and magnetic susceptibilities) may need to be 
repeated  to achieve a close starting model. These are considered to be the gross-scale, 
necessary modifications to complete carefully before embarking on inversion.

Strategies for achieving successful inversions of geophysical data
Parent topic: 
Introduction to 
Case Study E

Overall strategy for building robust 3D geology models—Sequential 
evolution

This section describes a recommended strategy for achieving successful inversions of 
geophysical data directly from 3D geology models.  

Whilst not required to complete all of the following cases in sequential order, the 
following list gives ideal cases, which if carried out and verified separately - gives the 
user the best-possible chance of achieving a desired inversion that will be robust from 
all points of view (good convergence, realistic geology outcomes, tight statistics, etc.).

1 Forward Model, Propose a start model, 
• compute gravity response - [Tutorial E2]
• compute a magnetic response
• compute a seismic section response

2 Property Optimization (Solve for properties using a bounded least-squares fit) - 
[Tutorial E3]

3 Bi-Modal Property Only Inversion (No proposed body, just a proposed density 
contrast)
• A very simple geology model with perhaps just 2 units such as basement and 

an intrusive to see where the blobs form - similar to the deterministic methods
4 Fixed Geology Model Property-Only Inversion (an alternative approach to 

property optimization)
5 Prior Only Inversion (Fixed Properties Geology-Only Inversion) explores only the 

probability space implied by the geological constraints together with the 
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inversion-restrictions set. Does not use any geophysics grids to drive the 
evolution.) [Tutorial E4]
• This is very similar to aspects of what is becoming more popular in regional 

geology studies where attempts are made to characterise the geological 
uncertainty in the map.

Geology and densities can change, but both must follow reasonable statistical 
laws and use gravity to constrain results.
Geology and susceptibilities can change, but both must follow reasonable 
statistical laws and use magnetics assuming induced response only.

6 Joint gravity and magnetics:
• exploring geometry-only;  (0 probability of property change)
• exploring properties-only, ( 100 % probability of property change) 
• exploring both geometry & properties (50/50 chance of either sort of change) 

[Tutorial E5]
7 Joint gravity and magnetics including the possibility of magnetic remanence.
8 Forward modelling of the gravity full tensor response [Tutorial E6]
9 Inversion of observed full tensor gradients with 5 independent observations or 

more, driving the changes.
At all stages, examine the computed geophysical response grids and compare them to 
the observed grids. 

Especially in the early stages, confirm the main features are present. 

Once you have a near starting model, all the inversion methods above will produce 
quite a good fit. 

The statistical analysis of the thousands of equally viable models is the place where 
you will learn more about how good your model is at explaining the geology.
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Inversion analysis flowchart
Parent topic: 
Introduction to 
Case Study E

This flow chart illustrates the way an inversion session progresses. Each pass 
through the central loop is termed an iteration. There are generally many millions of 
iterations in each session. 

At the beginning of an iteration, 3D GeoModeller makes a small change to a 
boundary between different formations, to physical properties, or to both. It assesses 
the suitability of the change against criteria such as whether this has preserved the 
network of interconnections between formations (the ‘topology’ of the model). 

If the change fails the test, 3D GeoModeller rejects it and concludes the iteration. If 
it passes, the forward potential field response of the modified model is calculated. 

3D GeoModeller applies a second set of tests, favouring acceptance of models that 
reduce the misfit between the predicted and observed response.  It does not, however, 
completely exclude the possibility of accepting a change that increased this misfit. 
This important aspect of the algorithm enables us to explore many different model 
configurations. 

If the modified model passes all tests, the changes are accepted. The modified model 
becomes the input for the next iteration. This loop continues until 3D GeoModeller 
has reached the maximum number of iterations specified, or you stop the program. 

This is not a deterministic solver (the misfit does not determine when the solver will 
stop), but rather when the solver has converged to a starting point where all 
subsequent models will fit the data with the same likelihood and from which point, 
statistical records and movies can start to be made capturing the results with equal 
probability of being good answers. There can be millions of equally plausible answers.
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Detailed inversion flowchart
The flowchart below explains 3D GeoModeller inversion workflow in greater detail.
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Overview of steps for this case study
Parent topic: 
Introduction to 
Case Study E

Review the existing geology model (Tutorial E1)
1 To understand the geological scenario and familiarize ourselves with the starting 

geology model, you will load the already-built 3D geological project without 
making any changes. Using the menus for geological editing and viewing, you will 
explore the geological data constraining the model, repeat the model-compute (run 
the 3D interpolators to build surfaces) and visualise 2D and 3D aspects of the 
model and geological pile.

Forward modelling (Tutorial E2)
2 Firstly, associate physical property distributions with each geology formation 

(required for both forward and inverse modelling), 
3 Next, carry out a gravity forward calculation (using a spatial method) to see 

whether the combination of the geological model and the choice of physical 
properties produces a response that broadly corresponds with the measured 
geophysical observations. 

4 Access a results viewer, then also view the geophysical response grids in 2D. 
Manage the colour table and data range clipping to enhance the details.

Property Optimisation (Tutorial E3)
5 If the results of the forward calculation are broadly similar with the measured 

observations, then you can skip property optimisation. 
However, if the predicted response of the ‘starting model’ bears little resemblance 
to the measured geophysics, this violates a fundamental assumption of the 
inversion methodology, and the end results will be meaningless should you not 
optimise the properties in some way (one method is demonstrated here).
An assessment of new mean and standard deviations of rock properties, per 
lithology, that are returned. Adaptation of your improved understanding of rock 
properties prior to inversion.

Prior-only Inversion (Tutorial E4)
6 Perform prior only inversion to see what probability space is implied by the 

geological constraints (“geology tests”) that you are going to set.
In this case, there is no concern here, with the reduction of the calculated misfit 
between predicted and observed geophysics – (no likelihood of the new proposal is  
calculated at each iteration, nor compared with the reference geophysics grids).

Joint magnetic-gravity inversion with stochastics (Tutorial E5)
7 You will supply suitable parameters and carry out the joint litho-constrained 

inversion calculations. The inversion program searches for models that:
• Satisfactorily reproduce the measured geophysical observations,
• Have a physical property distribution close to what you have assigned, and
• Obey the geology tests.

8  Next, you will use a number of tools to visualise and analyse the inversion 
results. These enable:
• Viewing of the misfit evolution curve.
• Running of the super summary statistics, collation & analysis tool, after first 

deciding the “burn-in point” or earliest point of convergence during inversion.
• Loading, directly viewing and accessing the intial, final, and post-

SuperSummaryStats output MeshGrids / results-voxet.
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• Filtering, slicing, combining and computing with the MeshGrids / results-
voxet, as required. For example:

• To create histograms of the mean & standard deviations of rock properties 
from the accepted proposals considering every single voxel / cell - grouped on a 
per-lithology basis (this could either be from the final iteration, or say from all 
accepted proposals between burn-in and the last iteration).

9 Forward calculation of the gravity full tensor response (using a Fast Fourier 
Transform in 3D) - Also, visualisation of the component tensors (Tutorial E6)
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Tutorial E1—Review the existing geology model ‘BuriedGranite’
Parent topic: 
Tutorial case 
study E 
(Forward and 
inverse 
modelling of 
potential field 
data)

In this tutorial:
• E1—Introduction 

• E1 Stage 1__Load and examine the ‘BuriedGranite’ GeoModeller project

• E1 Stage 2__Examine the project meta data

• E1 Stage 3__Re-compute and review the 2D and 3D views of the geology model
E1—Introduction

This simple 3D GeoModeller project / model has already been created for you.

In this tutorial we will explore the existing 3D geology model using menus for  
viewing the project properties, geolgical editing and visualisation without 
making changes to the model.

E1 Stage 1—Load and examine the ‘BuriedGranite’ 3D geology project / model
Parent topic: 
Tutorial E1- 
Review the 
existing geology 
model

E1 Stage 1—Steps
View the pre-created 3D geology project in 3D GeoModeller

1 Launch the 3D GeoModeller software, to reveal the splash screen.

2 From the main menu choose Project > Open OR 

From the Project toolbar choose Open  OR 
Press CTRL+O.

3 Browse to the pre-created 3D GeoModeller project: 
GeoModeller\tutorial\CaseStudyE\TutorialE1\E1Beginning_Project
\TutorialE1\E1Beginning_Project.xml

(where GeoModeller is the location of your 3D GeoModeller installation, for 
example: C:\Geomodeller\Geomodeller, or /home/geomodeller/Geomodeller 
for a LINUX install)

4 View the already-computed 3D geology model as rendered in the 2D viewers.
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5 Examine the main elements of the GeoModeller workspace, labelled above.

• 2D Viewer__contains 2D sections. This tutorial E1 project contains several 
sections: C3 and C2 which are already rendered when the project opens.
• We use 2D sections for storing and/or digitising geological data input, and for 

rendering 2D plots of our 3D model.
• You can also open section: MNT (the “Topographic” or “Map” section). This is  

a special type of “2D section” in that it retains the information of the draped 
grid of the digitial elevation model (DEM) if one has been used to build the 
project. If not, then this section will be a horizontal plane of a specified height, 
as used in this case study (sea level). Check this by moving the mouse over the 
MNT section, and observing the x,y,z mouse-location in the lower left corner of 
the workspace (z is constantly -1.0m in this project).

• Note the topography section (MNT here) defines the rock-air interface of your 
model. Generally we recommend using a DEM to assign the correct 
topographic shape as this allows more accurate mapping of geology on surface.

• 3D Viewer__contains a 3D view of your project, or a wireframe bounding box if 
the model is not yet visualised. At the stage opened (see above) a “Visualise 3D 
Formations and Faults” has not yet been done (we will do this later).

6 Also note the Project Explorer, located to the right of the 2D Toolbar:

• Project Explorer__this has a tree structure containing details about the many 
objects making up your 3D geology model: 
• Formations in the stratigraphic pile, and what data-type the contraints exist 

in (by 2D-data on individual sections; or by 3D data; or by drill holes)
• Faults in the project and what data-type the contraints exist in (by 2D-data 

with the section identified; or by 3D data)
• Sections (names & any associated geo-located images)
• Drillholes (ID and geology intercepts)
• 3D geology (“+” if a 3D model or 3D grid is built / visualised in the 3D Viewer)
• Meshes and grids (“+” if one or more is loaded in the 3D Viewer)
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The image above shows contact / interface data for the tops of 2 formations in our 
model - this is an example of data-type: 2D. They were added to  the section using 
the “pencil/create” tool, from the 2D Toolbar.
7 View the stratigraphic pile for the ‘BuriedGranite’ 3D model.  From the main 

menu choose Geology >  Stratigraphic Pile: Visualise.
• Every aspect of the way the stratigraphic pile is set up will have an impact on the 

way that the interpolators will run, and how the resulting geology shapes and 
lines will be built. We call this “rule-based-modelling”. It is intuitive for geologists 
and geophysicists, and unique to 3D GeoModeller.

8 Next, save the project with a new name in the folder you are using for your own 
tutorial materials. It is important to progressively Save (and Save As), as you 
progress with the exercises.
From the main menu choose Project > Save As OR 

From the Project toolbar choose Save As  OR 
Press CTRL+SHIFT+S.
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E1 Stage 2—Examine the project meta data
Parent topic: 
Tutorial E1  -
Review the 
existing geology 
model

E1 Stage 2—Steps
1 menu choose Project >  Properties
Examine the project meta data. 

For this project the dimensions and Coordinate System are:
• Projection __Local
• Height Datum__Local
• Extents:

Some further comments about the 3D GeoModeller project work space:
• X (East), Y (North) and Z (Elevation, positive upwards) are a standard coordinate 

framework according to a right-hand rule
• X, Y, Z are all in the same units - meters (they cannot be degrees of latitude or 

longitude).
• X and Y would typically be real world projected coordinates but could be a local 

grid (this is the case for the “BuriedGranite” model).
• Z is elevation, and is positive upwards. It also would typically use a real world 

vertical datum such as mean sea level.
• You can (and should) define the Projection (actually a Coordinate System, 

consisting of a Datum and Projection). Geolocation of your project is essential if 
you are to properly create and integrate with geoscientific data from many 
sources.

Minimum Maximum Range
East 0 10,000 10,000
North 0 10,000 10,000
Z-axis -2,000 0 2,000
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• All data must be within the 3D project limits. Data outside of the limits will be 
ignored when importing (a report will be given listing them as excluded).

• Likewise all modelled results - geology lines, polygons and surfaces - reside within 
those limits.

 When you create your own project, make the project dimensions large enough to:
• include all your data
• include a margin above your highest point of your topography
allow sufficient project space at the bottom of the model to cover the entire range of 
modelled geology and geophysical data that you are interested in.

E1 Stage 3—Re-compute and review the 2D and 3D views of the geology model
E1 Stage 3—Steps

Compute the 3D geology

Compute the 3D geology model for the project that we have loaded (to be constrained 
by the geological data and pile we have reviewed).
1 From the Model toolbar, choose Compute  or (press ctrl+M)
In the Compute the Model dialog box:
• Series to interpolate—Select All
• Faults to interpolate—Select All
• Sections to take into account—Select All
• Faults only—Clear (therefore DO compute faults)
• Choose OK
3D GeoModeller computes the model. (Nothing to see yet.) The model is a 
mathematical model—a set of interpolator equations that are computed from the 
geology contacts and orientation data. There is an interpolator equation for each 
series in the stratigraphic pile, and also an equation for each fault.
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View the modelled geology

To see the modelled geology, we need to interrogate the model equations. We can:
• Plot the modelled geology on any section in the model
• Create a new section, and plot the modelled geology on it
• Build the 3D shapes of the modelled geology, and view in the 3D Viewer

2 Select C3 section in the 2D Viewer (click the window & a tick appears in the top 
left corner)

3 From the Model toolbar, choose Plot the model settings  (or press ctrl+D)
In the Plot the model settings dialog box:
• Check all 3:  “Show Fill” and “Show Lines”
• Choose OK

The fill and lines of the modelled geology are plotted on the vertical 2D Section (C3).
4 Repeat these steps and plot the modelled geology on some of the other sections.
5 Save your project
From the main menu choose Project > Save or from the toolbar choose Save  (or 
press ctrl+S)

Explore model plotting options

Experiment with other options in the Plot the model settings dialog box: 
• Check “Show Trend Lines”
• Choose “Apply to All” to render the 3D model on all (open) 2D sections.
• For “Show Trend Lines” or “Show Fill”, select or de-select various combinations of 

formations
• Choose ”Show Trend Lines” in combination with Show Lines &/or Show Fill
• Modify the Plotting resolution from the default u=50, v=50 to, say, 100 x 100

6 Experiment with the three plot buttons in the Model toolbar:
• Model > Plot the model settings (or press ctrl+d)
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• Model > Plot the model on the current section
• Model > Plot the model on all sections

7 Experiment with the Section display parameters:
• Right-click on the background of an active 2D section
• Choose for example C3 > Display parameters
This allows you to toggle between different views which are already rendered.

For example:  Model geology > geology - lines (tick) OR geology - fill (tick)

Explore the 3D Viewer - ‘Build’ the model in 3D
8 From the Model toolbar choose Build 3D Formations and Faults 
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In the Build 3D Formation and Fault Shapes dialog box:

Check Build—Formations

Check Build—Faults

Select Type—Volume

Check Draw Shapes after building

Adjust the Resolution—Render quality to Medium

Choose OK

Use Project Explore to Manage the 3D Viewer - ‘View’ the model in 3D

3D GeoModeller computes the 3D shapes of the geology model as solid ‘volumes’ 
defined by triangle mesh surfaces, which it displays in the 3D Viewer.

Use the Project Explorer (typically on the left-side of your work space) to manage 
the display of modelled objects in the 3D Viewer.
9 Experiemt with change “whole” model appearances
• In the Project Explorer right-click 3D Geology  > and select Hide—to hide the 

entire modelled geology
• In the Project Explorer right-click 3D Geology > and select Show—to show again 

the entire modelled geology
• In the Project Explorer right-click 3D Geology > and select Wireframe—to 

change the displayed 3D volumes to wireframes
• In the Project Explorer right-click 3D Geology > and select Shading—to toggle 

the 3D display of geology, back to shaded
10 Change individual geology units of the model, in the same ways as above:
• In the Project Explorer click the “plus” symbol to expand the list within 3D 

Geology.
• Again, expand the “plus” symbols for each series in the model
11 For the series3 unit, Right-click on Volume: Cover to >Hide from the 3D viewer.
12 For the series2 unit, Right-click on Volume: Host-rock to > Wireframe
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To Show modelled geology polygons (or lines) in the 3D Viewer:
13 Select a 2D section (for example, C3) (ensure a green tick appears top-left).
14 Use the shortcut menu: right-click the background of the 2D viewer, and choose: 

“Show Modelled Geology Polygons in 3D Viewer”.

15 Save your project
From the main menu choose Project > Save

NOTE: Managing the Geological Editor is not the main objective of Tutorial E, and a 
brief overview has only been given here for this reason. 

For further instruction on the Geological Editor functions of 3D GeoModeller, go to 
Tutorial Case Study A, in the Main Menu > Help > Manual & Tutorial (PDF).
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Tutorial E2—Potential field forward calculation
Parent topic: 
Tutorial case 
study E 
(Forward and 
inverse 
modelling of 
potential field 
data)

This tutorial takes the user through a typical sequence of tasks for forward modelling 
of potential field data directly from 3D geology models. 

In this tutorial: 

• E2 __Steps Overview

• E2 Stage 1__Enter physical properties

• E2 Stage 2__Forward calculation

• E2 Stage 3__2D Seismic calculation
E2—Steps overview

1 The first task, whether we are going to carry out forward or inverse modelling, 
will be to associate physical property distributions with each formation. 

2 We then carry out a forward model calculation to see whether the combination of 
the geological model and the choice of physical properties produces a response 
that broadly corresponds with the measured observations. 

You need to perform the following operations on the geophysical observations:
3 3D GeoModeller expects the observations to form a regular grid and to be the 

response observed on a horizontal plane, or a draped surface. 
4 Especially with the spatial forward modelling algorithm, we have added provision 

to reduce any aliasing of the response due to topography effects. If this is 
insufficent, you may wish to reduce aliasing effects, by upward continuing the 
data. For vertical gravity and TMI data types, a terrain clearance of half to one 
vertical cell height, respectively, would be sufficient. 

5 Make adjustments to the geophysical observations to remove the response of 
material that will not be considered during the inversion phase. This process is 
generally called ‘regional removal’. 

6 3D GeoModeller inversion obtains formation and geological boundary 
information from the current project. Enter the parameters that define the 
distributions of properties for each formation into a table in 3D GeoModeller. 

7 Supply a grid containing processed geophysical data for each data type. 
8 Run the forward modelling calculation either for magnetism, gravimetry or both. 
9 When 3D GeoModeller has finished, you can view the observed geophysical 

grids, the calculated grids and the misfits. 
10 In the light of outcomes, you can revise geology boundaries (including adding new 

units) and physical properties and repeat the forward modelling. 
E2 Stage 1—Enter physical properties

• E2__Physical properties__Introduction

• E2__Display physical properties in the geological unit dialog box—Information

• E2__Set single mode mean density properties—Steps

• E2__Set bi-modal mean density properties—Steps
• E2—Finalise density and magnetic susceptibility properties—Steps
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Physical Properties—Introduction
Parent topic: E2 
Stage 1—Enter 
physical 
properties

It is unrealistic, given our knowledge of the real world, to assign a single constant 
physical property to each formation. Every formation shows some degree of 
heterogeneity. We simulate this in the inversions by defining a ‘distribution’ or 
spread of physical properties for each formation. In a forward model, the mean is 
adapted for the single run.

Display physical properties in the geological formation dialog box - Information
1 From the main menu choose Geophysics > Define physical properties. 3D 

GeoModeller displays the Physical properties of geological formation dialog 
box. Some default values are shown as we have not set ‘considered’ values yet.

In each of the five tabs of the dialog box, the top section contains a table of 
physical properties for each formation in the geological pile. Double click within 
the appropriate cell to view or modify the parameters. 
In the lower half of each tab of the dialog box you can set parameters that apply to 
all formations in the model. 
In the Gravity tab, use the Reference density to convert absolute density values 
from the table to relative density for the calculations. The reference density is 
often, but not always, related to the density used for the Bouguer or terrain 
corrections applied to gravity data. The standard density used for this purpose is 
2.67 g/cm3. No changes to be made here yet.
In the Magnetic tab, note that the Total field (nT), Declination and Inclination are 
default values. This is due to a “local” co-ordinate system being set in this project 
(see Main Menu: Project > Properties). A real world co-ordinate system for the 
model would result in appropriate fields being automatically filled here. Just 
provide the date of the observed geophysics survey using the IGRF calculator, and 
these will adjust accordingly. Alternatively, you can manually enter the Total 
field (nT), Declination and Inclination from independent sources. No changes to 
be made here yet.

Set single mode mean magnetic susceptibility properties__Steps
1 In the menu tab for Magnetic > Susceptibility (SI), double-click on the value-field 
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for Cover to display details of the current magnetic susceptibility for Series3 - 
Cover.  Enter/change them to the values below

2 OK to close and save the new Mn and SD values.
Staying in the Magnetics tab, note the 3 fields below the IGRF Calculator where you 
can enter ambient field properties: Total magnetic field, Declination and Inclination. 

Ideally use the IGRF calculator to automatically fill these 3 fields, based on the 
model location known from the Projection System (Project & height datum) of the 
project. (See Project > Properties). 

But as this project uses a Local system - we must enter them manually.
3 The “BuriedGranite” model is fictitious, but nominally located in northern South 

Autralia in WGS 84 zone 54S. Our geophysics surveys were acquired on 1st Jan 
2010. Therefore please enter: 

Series Mean  
Susceptibility

Standard  
Deviation

Statistical  
Law

Percentage of 
Population

3 - Cover 0.00002 0.000001 LogNormal 100

Total magnetic field (nT) Declination (degrees) Inclination (degrees)

56 600 7.6 -62.0
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Note:
• The magnitude of the induced magnetisation is the product of induced 

susceptibility and the magnitude of the ambient field.
• Inclination is positive below the horizontal and declination is positive east of 

true north. 
4 OK to close and save the new values.

Further Information
Settings
• Number of modes 
• Statistical ‘law’ or distribution type 
• Parameters to define the distribution 
• Proportions (if more than 1 mode) 
For each formation and property, you can select the number of modes, the statistical 
law (for each mode if multi-modal), then assign two parameters, Mean value and 
Standard deviation. These define the distribution (for each mode if multi-modal). For 
multi-modal options, you also specify the proportions for each mode. 
• For a Normal distribution, the Mean value and Standard deviation have a 

meaning that is well understood. 
• For a LogNormal distribution, the Mean value is the natural logarithm of the 

mean, and the Standard deviation is the standard deviation of the natural 
logarithm transformed values. 

• For an Equal distribution, the Mean value is the central value and the Standard 
deviation is half the range (in other words, the limits of the distribution are Mean 
value ± Standard deviation). 

• A Poisson distribution is completely defined by the Mean value (in other words, 
the Standard deviation is not required). 

• An Equal Plus distribution is an equal distribution where the Mean value is the 
minimum value and the Standard deviation is the range. 

• An Equal Minus distribution is an equal distribution where the Mean value is the 
maximum value and the Standard deviation is again the range. 

At present, the properties are initialised when performing either a forward or inverse 
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calculation using the mean value. This is the reason for having three different ways of 
defining an equi-probable distribution (that is, where the distribution is defined with 
a ‘mean’ that relates to the central, minimum and maximum values respectively for 
the equal, equal plus and equal minus distributions). 

Supply Density values in units of g/cm3.  

Supply Magnetisation values in SI units. We assume that the magnetisation is 
entirely induced.  3D GeoModeller obtains the orientation from the ambient field 
information. 

1 cgs or emu unit of susceptibility = 4 * π SI units of susceptibility 
magnetisation = susceptibility (κ) * field_intensity (H) 
magnetisation = susceptibility (κ) * induction (B) / μ0 

Hence, if you know the susceptibility ‘susc’ in SI * 10–5, and the ambient field ‘amb’ in 
nT, then the magnetisation is:

(susc * 10–5 * amb * 10–9) 
----------------------------------- 
(4 * π * 10–7) 

Multi-modal options

The multi-modal options enable you to define complex distributions as a random 
mixture of samples from populations that are defined by simple uni-modal 
distributions. 

Specify the proportions for each mode. Since these are constrained to add up to 100%, 
3D GeoModeller automatically assigns the proportion of samples for one of the 
modes based on the proportions specified for the other modes. 

Set bi-model mean density properties__Steps
Parent topic: E2 
Stage 1—Enter 
physical 
properties

Create a bi-modal distribution with 70:30 proportions
1 In the Gravity > Mean density properties dialog box for Host_rock, select Bi-

modal from the Modes option buttons.
Set the parameters as shown in this table:

Components
of series 2

Mean  
Density

Standard  
Deviation

Statistical  
Law

Percentage of 
Population

Host_rock 3.1 0.1 LogNormal 70-component1

Host_rock 2.9 0.2 Normal 30-component2
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2 Set each component in turn. Use the slide bar for the first component, to set 70% 
of the population. The other 30% will automatically assign to the 2nd population.

3 Choose OK. 3D GeoModeller updates property definitions in the table with the 
revised ‘mean’, ‘standard deviation’ and percentage values.

Finalise density and magnetic susceptibility properties—Steps
Even though the first exercise (forward modelling) is for gravity only, we will also 
finalise the magnetic susceptibilities for all 3 geological formations in our model - 
ready for our later joint inversion exercise.
Densities

Magnetic Susceptibilities (we will not be setting Remanent Magnetization)

1 Ensure all of the values in the above tables are entered and then Save

Series Mean  
Value

Standard 
Deviation

Statistical  
Law

Percentage of 
population

Series3-Cover 2.2 0.1 LogNormal 100

Series2-Host_rock 3.1 0.1 LogNormal 70- component1

Series2-Host_rock 2.9 0.2 Normal 30-component2

Series1-Granite 2.8 0.1 LogNormal 100

Series Mean  
Value

Standard 
Deviation

Statistical  
Law

Percentage of 
population

Series3 - Cover 0.00002 0.000001 LogNormal 100

Series2 - Host_rock 0.002 0.0001 LogNormal 100

Series1 - Granite 0.004 0.0002 LogNormal 100
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E2 Stage 2—Forward calculation
We perform a forward model calculation to verify that the combination of a geological 
model and the properties assigned to each formation produces a response that broadly 
corresponds with a set of observations. 

We do this as a prelude to the inversion session because we base interpretation of the 
inversion results on an assumption that the starting model was a reasonable first 
guess for a model that would be consistent with geological, physical property and 
geophysical observations. 

In this section:

• E2__Configure and run a forward calculation__Steps

• E2__Lateral padding of a model—Information

• E2__Summary images of the response for gravity forward calculation__Steps

• E2_Analyse the forward calculation__Steps

Configure and run a forward calculation—Steps
Parent topic: E2 
Stage 2—
Forward 
calculation

1 Select the data type to calculate. 
From the main menu choose Geophysics > 3D Geophysics > Forward wizard. 3D 
GeoModeller displays the forward calculation area of the 3D Geophysics tool.

2 Accept Case 1 and choose Create a new case
3 Choose Gz (vertical gravity) in the Fields to compute area. 

Gz is the vertical component of gravity in mGal (the quantity normally measured 
with ground gravity instruments). TMI is total field magnetic intensity in nT (the 
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quantity normally measured in an aeromagnetic survey). 
Gravity Tensors (and the following 6 separate components; Gxx, etc.) and 
Magnetic Tensors (and the following 9 separate components, Mx, etc.) ... are the 
gravity and magnetic field gradients in the x, y and z directions (correspond to 
east, north and up). See Tutorial E6 for further details and a demonstration 
exercise.
Below is an image of the observed gravity: 10km x 10km -7.6 to 18.8 mGal. Linear 
colour stretch. Contour spacing 1 mGal.

The aim of our forward modelling exercise is to achieve a close fit of the 
gravity response from our current geology model, compared with the 
observed response above. The observed response is the “unknown 
geology” which is our target, and that which we seek to discover during 
the course of this tutorial.
Our investigation is typical of an exploration approach adopting 
geophysical inversion. Our starting geology model begins as a best guess 
at the true sub-surface geology (which in nature is never known with 
complete certainty). As more geological data can be added to the model 
(through drilling, sampling and mapping) - and /or potential field 
geophysics can be interpreted through forward and inverse techniques 
as demonstrated in this tutorial - then the starting geology model will be 
driven toward the reality, and better matches to the observed geophysics 
will be possible.

4 Select Specify an Observed Grid
5 Browse for and load the observed Gz grid file:  

GeoModeller\tutorial\CaseStudyE\ 
TutorialE2\Data\Observed_Ground_Gravity_BuriedGranite.ers 

6 Choose a calculation surface that best describes the same surface as your grid 
of observed responses. Choose Constant elevation = 0 m. This assumes the data 
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was collected on a constant elevation, which is on the zero height datum (eg. sea 
level). This will ignore terrain effects in the response.
• Alternatively you can create a calculation surface which mimics the shape of 

your DEM, but for a set terrain clearance height.
• The final option allows you to load an external “drape grid” that you want your 

model response estimated upon. This is the closest option to being able to 
compare your model response calculations to what might be given to you from 
an airborne geophysics contractor grid.   

7 Choose NEXT.

Supported reference grid formats - Information
The default grid format is ERMapper *.ers format. Beneath the “hood” we use 
the generic Intrepid GridIO drivers, that are capable of auto detecting a range of 
industry standard geophysical grids.
Some formats support multi-band grids, ie there are multiple data fields within 
the same grid. An example of a 4 band geophysics grid would be radiometrics 
data, with bands 1,2,3 for K,Th, U and the fourth band for the Total Count. 
Choose the band that you want to use as an observed grid. Tensor grids are stored 
in 6 bands by Intrepid. 
The *.semi format is a very simple ASCII XY value format that can be used if 
you are having trouble obtaining a standard grid. 
With the Kriging capability within Geomodeller, you can also import gravity point 
data, or an airborne survey magnetic channel and grid the observations, prior to 
this importing step. (see the reference manual)
The extent of the grid of forward calculations is the intersection of the extent of 
the supplied grid and the plan view extent of the current project. The spacing 
between observations in the forward model output is identical to that of the voxet 
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used to calculate the forward response. 
Enter Voxet Properties
1 Verify the number of cells in the X,Y,Z. n=20 for all dimensions; leave these 

defaults.
2 Verify the vertical resolution of 100m, where vertical sampling interval is 

given below. Leave the default value.

The model mesh used for the forward calculations extends from the bottom of the 
voxet model volume in the current project to the level of the mean elevation of the 
surface topography.  This is subject to rounding to the nearest integer multiple of 
the vertical sampling interval.
 3D GeoModeller positions the mesh elements laterally, such that the 
observation locations in the supplied grid coincide in plan view location with the 
centre of each mesh element. 

3 Choose Spatial as the computation method. This is the default method, which is 
now automatically thread-safe. That means it will use more than one CPU on a 
local machine. 
The other option introduced here, is a vertical sub-cell resolution for topography 
modelling in order to reduce vertical aliasing due to honouring steps in the 
vertical resolution of your model. It is recommended to use half the vertical cell 
size as a starting position and it really depends upon how rugged your topography 
is, as to what to do here. 

4 Choose NEXT
Review or edit your lithology properties

NEXT, review (or edit) your rock properties. In this case, we are doing a gravity 
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simulation, so we are just asked to review densities. Leave the set values which 
are derived from the Physical Properties table as entered in the previous section.
Click on each coloured formation in the left hand side of the panel, and the tool 
will show each property as you select the formation. If you wish to change a value, 
double click on the property law, and the editor will appear.
A background or regional density can also be set. Leave the reference density 
and above topo density as the defaults: both 2.67.
 

Parent topic: E2 
Stage 2—
Forward 
calculation

1 Choose NEXT as prompted, to launch a Spatial method forward computation.
Note on the last page you are prompted for the number of CPUs to commit to this 
task. You also have the option for an interactive session or a batch session in the 
background. In this case, the time to compute is small, so interactive is OK. 
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Choose FINISH.

Monitoring the forward calculation - Information
The program discretises the geological model (extracts the lithology at the centre 
of each cell).
To make the forward model calculations tractable, especially as 3D GeoModeller 
uses the forward model calculation many millions of times during inversion, we 
must ‘discretise’ the geological model. This means that we need to convert the 
continuous form of the geological model (created in the mapping module) to a 
mesh or block model form. We assume the lithology at all points within each mesh 
element to be the same as the lithology we calculated (based on the continuous 
geological model) at the centre of the cell. 
3D GeoModeller announces when it has started the re-sampling operations 
required to discretise the model. The time required for these calculations depends 
on the number of elements in the mesh. The time may be only a few seconds for a 
mesh with a few tens of thousands of elements (for example, 40 x 40 x 20 cells) or 
many minutes for a mesh with several million elements (for example, 200 x 200 x 
100 cells). 
3D GeoModeller initialises the appropriate physical property model, density for 
gravity calculations and magnetisation for magnetic calculations using the ‘mean’ 
value for each formation. 
3D GeoModeller announces when the forward calculations are ready to start.
The forward calculation for a typical mesh (for example, 100 x 100 x 50 elements) 
should take no more than a few minutes. 
3D GeoModeller displays the results in the 3D Gravity Forward modelling 
window.

Lateral padding of a model - Information
The illustration below shows a plan-view of padded litho-model arrangement used 
in the forward model response calculation.
Before undertaking forward model calculation using either spatial or FFT 
methods, we pad the model volume by surrounding it with 8 copies of the model. 
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We create these copies by reflecting the model about the vertical sides of the 
model and performing a double reflection to produce the corner tiles. This strategy 
results from the thought that the region adjacent to the volume under 
consideration is most likely occupied by material similar to that of the model 
volume. 3D GeoModeller calculates the forward model response of the entire 
padded model at grid points above the core model volume. 
This simple strategy reduces the need to remove the effect of sources adjacent to 
the model volume.  However, we still need to exclude the response of material 
below the model volume from the observed data before comparing these data with 
the forward model response. 

Summary images of the response for gravity forward calculation
3D GeoModeller displays the images of the response of our gravity forward 
calculation in the Results Explorer window. 

To remove a DC shift or regional trend from your calculated response go to the 
bottom left hand-corner: select a degree from the regional settings available. 
0-Constant is a DC shift, 
1-linear is the simplest regional trend.
2-linear, a more complex regional trend type. 

1 For this case study, select 0-Constant
2 Next select Solve (bottom right hand side).
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3D GeoModeller displays several images and some basic statistics when the forward 
model calculations have been completed. The images are:
• Top Left—the observed grid
• Top Centre—the response of the ‘current model’ that you have calculated
• Top Right—the ‘current misfit’ or difference in response between the response of 

the ‘current’ model and the observed grid. 
• Bottom Left  is the result of choosing a DC shift and asking the tool to solve for a 

best fit degree. The surface is horizontal, so no grid is apparent here. (The solved 
degree is displayed on bottom-bar, in “Regional” field.)

• Bottom Middle is the computed response with the DC shift added.
• Bottom Right is the redone misfit plot, to see if this extra regional has improved 

the misfit to the observed.
Note that the colour scales are typically different for each of the images as they are 
the result of a linear colour mapping between the minimum and maximum values in 
the range for each grid. 
3 Use File > Exit to leave this tool.
All grids are saved in a folder within the GeoModeller project folder called “Case1”. 
4 Use Project > Save.
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You can return at any time later to see these results again, by going to: Geophysics > 
3D Geophysics > Results explorer

The left hand panel provides a data explorer for all the cases you may have created. 
The convention is to use the GREEN arrow to indicate Forward model result cases 
and RED arrows to the left,  to indicate inversion cases. 

Analyse the forward calculation—Steps
Parent topic: E2 
Stage 2—
Forward 
calculation

3D GeoModeller saved the results of the forward gravity calculation in the project 
folder in Case1 > Run1. You can examine the grids in more detail by viewing the files.

Load 2D grids to 2D sections of the geology model
1 Back in the 2D viewer of the main GeoModeller workspace, go to the Explore 

Window.
2 Left-click on the Grids and Meshes item, or from the main menu open the Import 

> grid and mesh > 2D grid.

3 Browse to TutorialE2 > Completed_Project > Case1 > Run1
For this E2 training exercise, the file to load is “calculated_Gravimetry_1.ers”

4 Ensure your 2D section called “MNT” is open and active (green tick will show)
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5 Expand the “+” symbol which has appeared next to Grids and meshes in the 
Explorer until you can select and then right-click on calculated_Gravimetry_1

6 Check the “Field Visualization Manager” 
Also, you can see all available mechanisms for displaying, colour table matching, 
statistical analysis, cross plots, contouring and general manipulation of fields 
within any grid or surface. Special purpose geophysical options are also available 
for micro-seismic analysis.
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7 Check View on section for MNT

The calculated grid of gravity is now geolocated in the 2D map section of the current 
geology model. (Note the “observed_Gravimetry_1” can be loaded in addition:- 
Repeat steps 5, 6, and 7 above). Toggle between different 2D grids on the section: In 
Explore, right-click on the grid name then > Hide all views of this field. 

8 Finally, to see a colour table for the loaded grid Select 
Calculated_Gravimetry_1 in the Explorer tree
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9 Right-cick > Display Colour Table

Remember that interpolated geology boundaries/lines can be switched on/off in this 
view to aid interpretation:- Right-click in the background of the 2D window display 
parameters. (This MTN surface geology section is dominated by the Cover unit hence 
only the fault iso-line is rendered in blue, lower right.)

Next we will view a histogram of the forward modelled gravity grid (2D)
1 In Explorer, choose calculated_Gravimetry_1 below Grids and meshes
2  Right click, and choose Histogram.  (The y axis is in mGal.)
.

You can also examine the completed project folder (to view the grid files directly) 
as stored in your project directory: 
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GeoModeller\tutorial\CaseStudyE\TutorialE2\Completed_project\C
ase1\Run1 
.

3D GeoModeller writes results from the forward model calculation to standard 
ERMapper geophysical grids. 

Load the initial lithology & density 3D voxet, and view histograms
The process of running a forward model requires that a “Case” or initial lithology 
voxet is created at the cell-size defined in Create Forward Case > Voxet Properties 
(See page 34). Other attributes of the initial case are stored in the same voxet, such as 
densities. The voxet files can be viewed directly in Windows, in the path containing 
your tutorial project:  ... TutorialE2\Completed_Project\Case1\run1\initial.vo
1  In Explore, choose Grids and meshes and click right. 
2 Choose import > 3D Grid (Voxels).
3 Browse to: ...  TutorialE2\Completed_Project\Case1\run1\initial.vo 

4 In Explore, an expandable voxet item “Initial” will appear, and will further reveal 

Grid file Description

Observed_Gravimetry_1 A copy of the supplied grid. 3D GeoModeller may 
have resampled the observed grid and trimmed its 
extent if the supplied grid was not wholly within the 
plan view extent of the current project. 

calculated_Gravimetry
_1

Response grid of the starting geology model using 
the density values set in the physical properties 
table.
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two voxet properties: “Lithology” and “Density”.

5 Choose the Lithology field, then right click. 
6 Check the “Field Visualization Manager” and then “View grid in 3D”. 

The voxet appears in the wireframe of the 3D viewer. If the interpolated 3D 
geology model is also in the same space, go to Explore > 3D Geology > hide

7 Now in Explore check initial > Litholgy >Histogram. The 3 units are shown, as 
seen below left

What you see (left) is the volumetric proportions of each geology unit in the 
lithology voxet model, as created as “Case1” during forward gravity modelling.
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1 To see the Density field of the same initial voxet, Repeat Steps 5, 6 and 7. Note 
the spikes in the histogram occur because only mean values of density per 
lithology were used in forward modelling gravity.

.

“Set Clipping Parameters” of the 3D voxet

To slice and interrogate a voxet, you can clip the 3D view in the directions: x, y, and z.
1 First, ensure only one voxet (Density) is in the 3D viewer, by right-clicking: 

+ Initial > Lithology > Hide Field from all views
2 Select the “Set Clipping Parameters” 3D tool on the bottom of the right-hand-side.
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3 Choose Axis Aligned: XZ; Choose Slice XY
4 Use the slider bar on Axis Aligned: XZ to reveal the interior cells of the slice
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E2 Stage 3—2D seismic calculation
The first job is to set a seismic velocity for your geological formations.
1 Do this in the main menu by choosing Geophysics > Define physical properties. 
2 Choose the Seismic tab. Create velocity contrasts between the 3 geology units in 

our model, by entering the values for a log-normal distribution in the table below.
 Enter by clicking on each number field.

3 Now choose Geophysics > 2D geophysics. 
4 At the top, choose section C2, as this will be the vertical section on which to show 

a predicted seismic response.
5 Toggle to the Seismic tab. The “Physical Properties” status is shown as 

Defined.
6 The Time, Space and Frequency sampling parameters allow you to adjust the 

resolution of the predicted response. Change the From Frequency sampling to 
just 2 Hz.

7 At the top, tick Compute Seismic, and 
8 at the bottom, select Compute. 

The following results pop-up shows the section C2 through geology model, 
together with its 2D synthetic seismograph. 

9 Finally, Save as Image. (Example name: “C2-seismic”) in Case 1, Run1.

Geology unit velocity m/s standard deviation m/s % of population

Cover 1200 20 100

Host_rock 1800 20 100

Granite 1500 20 100
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.. 

Discussion

Other features of support for 2D seismic surveys include an importer of seismic 
navigation files that automatically creates GeoModeller sections. 

We enable rapid creation of a 3D geology model in an off-shore continental margin 
setting by: 
• using the 2D seismic picks that are being interpreted in a Time based context, 
• bringing these, plus the lines, into a 3D / Depth based context,
• using the potential field interpolator of GeoModeller to rapidly create 3D bodies 

that fill the whole project volume. 
The gravitational response of a body is easily computed, so that any misfit with 
observed marine gravity data becomes obvious. This then leads to queries for the 
seismic picking team to mull over and perhaps re-think some of the horizon returns.

To do something similar with either Gravity or Magnetic profiles is quite easy. Any 
geophysical database that is line based, and has field observations, can be used to 
create sections down each line, and have its profile tested for a fit with the underlying 
3D geology model.
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Tutorial E3—Potential field rock property optimization
In this section:

• E3__How it works__Information

• E3__Run and monitor the Property Optimisation

The aim is to get your 3D geology model not only to be consistent with all the known 
geology observations, but also to explain main features of regional geophysical 
datasets such as a Free Air gravity or a Total Magnetic Intensity grid.

To achieve this, you need to specify rock properties. If you are confident of your 
geology model and have an observed geophysical grid of observations, then you can 
use property optimization to deduce bulk average rock properties needed to explain 
the observations.

How it works
Spatial discretisation
We provide a technology/algorithm that can give you a bounded least squares optimi-
zation of the property estimates using your model with relative coarse cells in the XY 
and finer ones in the Z direction.  
Response kernel
A response kernel for each lithology is needed for property optimisation. These are 
calculated automatically if you choose the Run Property Optimisation option in 
the forward wizard. Once the response kernels have been calculated, property optimi-
sation is run and a report file is displayed with the optimised property values. Also, to 
be effective, it is best if there are at least 3 lithology units. 
Bounds
Additional to the standard Property Law, such as Normal Distribution with a mean 
value and a Standard Deviation,  you also must provide two extra fields, a LOWER 
and an UPPER bounds. The purpose of these is to constrain the resulting estimates to 
be within bounds which are reasonable. If you find the estimated values are all at one 
end of the bounds or the other, chances are that you do not have a good geology model, 
or an understanding of typical rock properties to go further without doing more inves-
tigations.
Spike rejection

To make sure you use representative values of observed data, a maxAbsoluteObserved 
field is available to ignore outliers.  You may have a genuine very high observed 
reading in your data that would distort the general background properties for a unit, 
so this allows you to limit the influence of an outlier observation.
Solver method

The solver uses a weighted least-squares approach over the whole 3D assembly of 
cells and properties, to best fit the observed data and the response from each 
individual unit, summed by its response kernels.
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Running a property optimization exercise for this case study: “Buried Granite”

THIS TUTORIAL IS UNDER DEVELOPMENT. 
PLEASE CONTACT INTREPID GEOPGHYSICS FOR FURTHER 
INFORMATION, AND TO ASK THE RELEASE DATE FOR TUTORIAL E3
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Tutorial E4—Prior Only Inversion (fixed properties, geology-only 
inversion)
The aim of this tutorial is to walk through a simple, practical example of how to set up a Prior Only 
geophysical inversion designed to improve your knowledge about the geology, geometry and the rock 
properties of your project. The reference manual contains further references and detailed explanations.

E4—Introduction
Parent topic: 
Tutorial case 
study E 
(Forward and 
inverse 
modelling of 
potential field 
data)

Our last main objective before running the joint inversion (which will explore both 
properties and geology space) - is to calibrate the “tightness or looseness” of geological 
boundaries explored during an inversion. This is best done while the properties are 
fixed.

Forward modelling (E2) demonstrated that a reasonably close fit to the observed 
gravity potential field was achieved from our initial 3D geology model. Further 
refinements to the properties was achieved in Tutorial E3 through Property 
Optimization.

We are now reasonably confident of the assigned physical properties of the geological 
units in our 3D model (lets say, through a combination of Property Optimization, and 
because drilling and sampling has provided direct data for densities and magnetic 
susceptibility values). Therefore, we have confidence to soon proceed to a litho-
constrained inversion, but first we need to perform prior-only inversion to see what 
probability space is implied by the geological constraints (“geology tests”) that we are 
going to set.

We are not concerned, in this case, with the reduction of the calculated misfit between 
predicted and observed geophysics – (no likelihood of the new proposal will be 
calculated at each iteration, nor compared with the reference geophysics grids).

E4—Steps overview
1 This simple 3D GeoModeller project has already been created for you. You can 

use the same model/project from Tutorial E2, or Load the Beginning project of 
Tutorial E3, from your installation directory.

2 First, we will set the geological tests which will govern the “tightness or 
looseness” of the exploration of geological boundaries during an inversion.

3 Next, carry out a stochastic simulation calculation. 
4 Finally, evaluate whether our set geological tests result in appropriate variations 

of the 3D geology model.
 In this section:

• E2__Configure and run a fixed-properties gravity inversion including setting the 
geological tests

• E2__Evaluate the extents of the spaces explored between the geological units in 
the 3D geological, during inversion.
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E4 Stage 1—Create a new Case
1 Open the pre-created 3D geology project in 3D GeoModeller

Launch 3D GeoModeller
From the main menu choose Project > Open OR 

From the Project toolbar choose Open  OR 
Press CTRL+O.
Browse to the pre-created 3D GeoModeller project: 
.\tutorial\CaseStudyE\TutorialE4\Beginning_Project\Beginning_P
roject4.xml

2 Choose Geophysics > 3D Geophysics > Inversion Wizard

Steps taken are similar to those in the Tutorial E5 below.

Repeating: E5 Tutorial Stages 1 to 4

The main differences are that 

1. Joint inversion is not necessary to set (single only), as geophysics will not be 
referenced anyway.

2. Stage 3 : Set Probability of a Property-only change to: 0%

3. Geology-changes allowable by the geology-tests (inversion settings) can be viewed 
and assessed in the same way as demonstrated in Tutorial E5.

THIS TUTORIAL IS UNDER DEVELOPMENT. 

PLEASE CONTACT INTREPID GEOPHYSICS FOR FURTHER INFORMATION, 
AND TO ASK THE RELEASE DATE FOR TUTORIAL E4.
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Tutorial E5—Joint Gravity-magnetics litho-constrained inversion
This tutorial is designed to walk you through a simple, practical example of how to set up and run a 
joint gravity-magnetics litho-constrained inversion. Inversion of your 3D geology model is designed to 
improve your knowledge about the geology-geometry and rock properties of your project.

The “Forward modelling and inversion with 3D GeoModeller 2012” Reference Manual contains 
more detailed references and explanations of the methods used in this section.

In this tutorial:

• E5 __Introduction

• E5 __Steps Overview

• E5 Stage 1__Create a new case

• E5 Stage 2__Check rock properties distributions

• E5 Stage 3__Enter geology body constraints and laws for change

• E5 Stage 4__Enter run control parameters

• E5 Stage 5__Monitoring the misfit and computing post burn-in summary statistics

• E5 Stage 6__View the final 2D grids for magnetics and gravity (quality check)

• E5 Stage 7__Statistical results analysis and visualization

• E5 Stage 8__Analyse 2D & 3D composite views of resulting geology-geometry

• E5 Stage 9__Create 3D points of inversion-driven geology (Export Shells - cvs)
E5—Introduction

To set-up and run a litho-constrained inversion. You only need to access the 
Geophysics menu.

The Geophysics menu operations directly access the geological information in the 
current project, including the physical properties tables, so there is only a modest 
amount of additional information to supply in the Inversion wizard.

Some of the pages of the Inversion wizard are similar to the Forward Modelling 
wizard (such as the need to set properties, choose grids, and set the run 
environment). The main differences appear on wizard pages 3 & 4 

E5—Steps overview
1 Set up the new Case and Run number, select observed geophysical datasets.
2 Check associated physical property distributions for each formation. 
3 Set the exploration-bounds on geology boundaries to be explored during inversion.
4 Set iterations, boundary conditions, and the aspects of lithology that will be fixed.
5 Carry out a stochastic simulation - exploring all allowed bounds of the geology, 

gravity and magnetics “data sets”.
6 When 3D GeoModeller has finished, a misfit trend can be analysed to see the 

progression towards converged solutions. You judge this by observing where the 
misfit becomes more or less constant, despite best efforts to perturb the model.

7 For the proportion of the inversion runs where the misfit was constant, begin at 
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the “burn-in point” - request a “Super Summary Stats voxet to be created. This 
included all the results of the valid models of the simulation, but excludes the 
beginning iterations, before burn-in.

8 Next we view the final calculated geophysics grids, the statistically compiled 
geophysical-results voxets, the per-lithology rock property distributions, and  
thresholded surfaces of probability of the geology.

9 In the light of outcomes, you can revise geology boundaries and physical 
properties. 

 

E5 Stage 1—Create a new Case
Open the existing 3D geology project in 3D GeoModeller

1 From the main menu choose Project > Open OR 

From the Project toolbar choose Open  OR 
Press CTRL+O.

Browse to the existing 3D GeoModeller project: 
...\CaseStudyE\TutorialE5\E6Beginning_Project\E5Beginning_Project
.xml

View the 3D model in the 2D and 3D viewers.
2 Choose Geophysics > 3D Geophysics > Inversion Wizard.

The wizard will suggest creating a new Case and a new Run - labelled by the next 
sequentially available name. (Case1 already exists in your directory.)

If you prefer to re-use a previous Case (with an associated discretisation scheme, and 
selected grids) - you can do this (Browsing options to existing Cases will show) and 
GeoModeller will then instead suggest a new sequential Run number for the same 
Case.
3 Choose Next
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4 Now we can choose voxet extents and cell size for the discretisation scheme of 
the Case. For a rapid inversion, accept the defaults.

The defaults are the geology model project space with a relatively coarse voxet/cube 
size. A lesser volume or the same volume can be selected for the x,y,z extents. Cell 
dimensions for x, y and z can each be a different length - but a constant set of cell 
dimensions must apply throughout the voxel model.

The default discretisation scheme suggested  20 x 20 x 20 divisions in each direction. 
This results in the cell dimensions x=500m; y=500m, and z=100m.
5 Now we can decide which geophysical observational grid data type to use (Fields 

to Compute). In this case for a joint inversion, tick both Gz and TMI. 
6 Return the highlight to the first data-type Gz.
7 Click on the Browse and navigate to : 

TutorialE2\Data\Observed_Gravimetry_BuriedGranite.ers
8 > Open
9 Highlight to the second data-type TMI.
10 Click on the Browse and navigate to : 

TutorialE2\Data\Observed_Magnetism_BuriedGranite.ers
11 > Open
Ensure a grid is registered for both Fields (check by toggling between Gz and TMI).
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12 Leave the other options as defaults, and choose NEXT. 
Before leaving this page, note extra options available.
• Detrending the observed gravity grid
• Specifying the elevation surface to calculate the on-going response on - exactly the 

same as for Forward modelling.
• Specifying a vertical sampling interval on the topography surface, to reduce 

aliasing.
• Also note the Indicator: this shows estimated required memory to run the task.]

E5 Stage 2—Check rock properties distributions
This wizard page allows you to check and alter the initial set of rock properties 
distributions for each lithology, in turn.

You can change a Probability Distribution Function (PDF) - for this lithology - by 
double clicking on the text with the law in it. (This is similar to the same page in the 
Forward Wizard.)

At the bottom of the wizard page, you can choose how density / magnetic 
susceptibility will be applied to the initial model. The options are -
• From Law Mean - this is the Default and sets the mean value of each unit to be 

applied to every cell with that lithology.
• From Law Random - this sets the full PDF to be used on startup, to give each 

cell a random sample from the law.
• From voxet (external) - this allows you to supply and set a voxet with customised 

properties already described, prepared externally. Currently, you must take care 
to exactly meet the same project extent and cell size you have specified previously 
in this wizard (Page 2 of the wizard).
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An important point to remember is that each lithology has its own unique property 
change law. So, even if you want to fix the geology-geometry of a model and just do a 
property-change-only inversion, the properties generated are still confined to what is 
allowed within each law. .

1 For GRAVITY, set FromLawRandom
2 For MAGNETIC, set FromLawRandom
3 In the lower field, toggle between the Gravity and Magnetic tabs to check the field 

settings are appropriate for both:

(Check reference density: 2.67 g/cm3; Above-topo density: 2.67 g/cm3; Total Magnetic 
Field: 56,600 nT; Declination 7.6 degrees; Inclination: -62 degrees)
4 choose Next.

E5 Stage 3—Enter geology body constraints and laws for change
The Create Inversion Case - Geological Settings page is for setting controls on 
the style of geology constraints during inversion. Left Hand side “Shared settings” 
deal with controlling the generation of proposals for change in your model. 
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1 Leave the default ticked on: “ Allow Property Change on Fixed Cell(s)”. 
Usually, the fact that a cell has fixed geology should not preclude its properties 
from changing, within the constraints of its property law. 

2 Leave the default ticked on:  “Allow Local Property Difference Check”. This 
option keeps local variations of properties in the immediate neighbourhood to a 
minimum. It is a way of clustering the property across cells. 

3 Leave the default:  Probability of property change only (50%)
Fixing Cells

A cell in your model might have fixed lithologies as you are very confident of the 
geology at that point. Typical reasons and ways to control this are -
• good surface geology map - hold this constant by fixing all surface outcrop geology 

cells.
• borehole logged geology observation at depth - fix any cell that has a borehole 

geology log.
seismic pick on a section - an interpreted point

4 Tick on: “Fix Individual Cells Containing:” 
5 and choose Surface Intersections (tick) from the list of options. 
6 Also select Interpreted below for the provenance of the data in the model.
Scenario: A “good surface map” scenario applies in this case study: We know from 
field maping that “Cover” exists everywhere on surface, although “contact” data 
points for Cover are not actually required on surface to build it that way. (See 
Tutorial E1.) Also, we have confidence in the modelled location of the base of the 
Cover unit due to detailed interpretation of Electromagnetic (EM) survey data which 
was used to constrain the starting geology model.

Probability of property change only (%) [Change Scenario Generation Control]

Case MCMC

For this tutorial, keep the default at: 50/50. For Monte Carlo/Markov Chain (MCMC), 
the natural case is to allow for a 50/50 split between changing model at the lithology 
boundaries, and changing the properties of a unit in any one iteration. 
Property Only Case (Probability of property change only: 100%)

When you feel very confident about your geology model and you already may have got 
bulk physical properties that do a good job of reproducing the observed geophysical 
response from that model, more subtle features may emerge in pockets, if you allow a 
100% probability of property change only run. The reason for this is that a non-
deterministic exploration of probability space will show you the probability of 
coherent property anomalies at depth , within various units. You may also restrict 
which units to explore this way, by setting the Standard Deviation to zero for those 
units you want to exclude from the study. This way, just one or two units are in play.

This approach, which locks-down the geology, could be thought of as a sophisticated 
“Property Optimisation”.
Geology Only Case (Probability of property change only: 0%)

The other extreme is similar to the algorithms used in more traditional gravity/mag 
inversions for solving depth to basement. You hold all the properties constant and 
force geology-boundary changes as the only way to reduce the misfit in the study. 
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Note, however, as the boundary changes, the cell with the new geology must use the 
new property law.

Locking-down the properties, can be thought of as a “Prior-only” run (see Tutorial E4) 
with important differences! Prior Only seeks to calibrate which settings provide 
maximum valid levels of geology-boundary variation (based on your geological 
knowledge and data sets), whilst a Geology-Only approach should only be commenced 
once a close starting model is confirmed, because inversion refers only to geophysics 
to drive solutions within your valid geology envelope (already established).

Setting up geology tests for a litho-constrained inversion
Aim to specify how, and with what constraints, geology units can change.

Without any “litho-constraints” or “geology tests”, inversion can still proceed to an 
apparent conversion / good fit to the geophysics, but the resulting models will 
probably include fragmented geology that bears little relationship to your starting 
model, and are geologically unrealistic. 

In 3D GeoModeller, specifications of certain geometric constraints (“geology tests”) 
are available on a lithology-by-lithology basis, so for instance high-confidence geology 
units can be “locked down” while lower-confidence units can be allowed more freedom 
for the geometry to change. An inversion can therefore be set-up to minimise 
unrealistic geology being created for investigation during inversion – i.e., the geology 
tests limit totally random variations to the initial geology model.

In 3D GeoModeller, five inversion control commands are currently provided in respect 
of varying the geometry of geology units in the initial or reference model. These are: 
Movable, Commonality, Commonality Volume, Shape Ratio and Volume Ratio. From 
previous studies, it has been found that in most cases, Commonality and Shape Ratio 
are the only commands typically required to launch a robust inversion. This tutorial 
demonstration is no exception.

NOTE: You will need to choose each Lithology unit in turn when applying 
the geology tests. A highlight box is drawn around the chosen unit.

Starting from the top right hand side, 3 mechanisms are available per lithology:
• Fix lithology frontier - basically freeze the geometry of this unit (you might 

have good near-surface seismic control of this layer).
• Constraints - to modify the rules for how a lithology unit’s shape and volume is 

confined as it changes with successive proposals. (Note these are the test-settings, 
the test on/off buttons are later in the “RUN” page of the wizard.)

• Always above these lithologies - also known as Preserve Younging Direction. 
Allows/disallows overturning of the younging direction in your geology sequence. 
This requires your geological knowledge, but is often known! (For example, 
“Thrust faulting is absent in our Basin Setting, hence units will always appear in 
depth order as per the stratigraphic pile [missing units allowed]”) - Therefore, it 
does not make sense for the stochastic process to explore other possibilities.
Contents  Help | Top © 2013 BRGM & Desmond Fitzgerald & Associates Pty Ltd  | Back | 



GeoModeller  User Manual Tutorial case study E (Forward and inverse modelling of potential field data) 60
Contents | Help | Top  | Back | 
For this tutorial: 
1 Ensure default unchecked “Fix lithology frontiers” for all 3 units. Because 

none of our geology boundaries are known with certainty. 
2 Constraints (middle 4 sections) - Leave defaults for Cover and Host_rock
• Constraints (middle 4 sections) - For Granite we want to maintain the integrity 

of this proposed 3D intrusive, but need to allow it to shift and expand more than 
the Cover or Host_rock units. These requirements are met by setting: For Granite, 
set Commonality to a Weibull PDF of 0.4 by clicking on the pencil at the right-
hand-side (0.4 equates to 70% similarity with the reference model, that is, more 
freedom than the default of 0.2 which equates to 84% similarity with the reference 
model.)
By definition: Commonality is the extent to which formation-voxels remain ‘in 
common’ with that formation’s voxels in the reference/initial model.
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Viewing/modifying the Weibull PDF is the same as for lithology properties, except 
there is no provision for multi-populations. The PDF’s you choose are appropriate to 
shapes, not properties. The advantage of Weibul is that it is a very conservative PDF. 
The probability of a radical change at any one step is minimized, whereas for a 
Normal distribution, there is always a 50/50 chance of a larger change.
3 For Granite, leave Volume Ratio on the default value of 0.25 (0.25 equates to 75% 

of the volume stays the same as the reference model.)
By definition: Volume Ratio is the extent to which the total volume of a 
formation’s voxels remains the same as the total volume of that formation’s voxels 
in the reference/initial model.

Both of these laws are explained in detail in the Reference Manual (Forward 
modelling and inversion with 3D GeoModeller v2-2012)
4 Choose Next.
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E5 Stage 4—Enter run control parameters
Here you control the specifics of the inversion run: number of iterations, how to 
influence convergence, and switches for geology constraint tests (set but not on yet).

For this tutorial,: 
1 Change the number of Iterations to 500,000
500,000 iterations is enough in this exercise, to get convergence to a uniform misfit 
between the model geophysics responses and the observed geophysics grids. The 
further iterations past the initial convergence (after “Burn-in”) allow for an 
exploration of all the equally probable models that follow. Millions of equally probable 
models, each with a small variation in a property or geology boundary, can explain 
the observed data sets.
2 Tick on “Allow Formation Geometry Tests”
3 Tick on “Allow Commonality Test”. Weighting option to the right: leave default 

as “none”.
4 Tick on “Allow Volume Ratio Test”. Weighting option to the right: change to 

“Local Abundance”.
5 Leave default on: “ Allow Geophysical Misfit Tests”
6 Choose Next
Weighting options are explained in the Reference Manual (forward modelling and 
inversion with 3D GeoModeller 2012)

The advanced options are available for testing and for influencing the speed of the 
solver in the initial convergence stage. For this tutorial, leave Advanced Tuning 
Options unadjusted.
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Execution of Environment Settings
Just prior to running an inversion, you must make a decision about where to run the 
job and how many CPU resources to request to do it.

The default is to use your local machine interactively. You may have more than one 
CPU and an operating system is designed to allow you to continue to work 
interactively, while “number crunching” continues in separate process(es). 
1 Accept the default to run Interactively
2 Accept the default maximum number of cores to run on your computer - this 

prioritises the inversion process.
If you need other processes to current concurrently, choose a lesser number of cores to 
dedicate to the inversion task.
3 Choose Finish

E5 Stage 5—Monitoring the misfit and computing post burn-in summary statistics
Immediately, when running interactively, a progress bar in the form of a current 
misfit vs iterations graph pops-up.

As the inversion gets underway, a pop-up graph shows us a high initial misfit which 
rapid settles lower and then constant. When the 500,000 iterations are complete you 
will be asked if you wish to compute Summary Voxets (also known as “Super 
Summary Statistics”[SSS]) which collates all results in attributed voxets (3D grids) 
for a post-burn-in phase of your choice.
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1 Choose Yes to immediately compute the Summary Voxets.
If you decline the first time, or wish to calculate SSS for a different burn-in point, you 
can return to accepting this request through a misfit screen, by opening:

 Geophysics > 3D Geophysics > Summary Voxets from Inversion

2 Choose a burn-in point of 400,000 and type it in the From box, lower left. 
This is where the misfit becomes more or less constant (at ~1.1), as shown by the 
graph below. Your burn in point may be different if different settings have been 
applied.
Note the mouse is interactive with the misfit plot to display a label.
Setting the burn-in gives the starting iteration for statistical analysis of that 
portion of the inversion corresponding to simulations that are all equally plausible 
(usually, through to and including the last iteration). Burn-in is judged by 
observing where the misfit becomes more or less constant, despite best efforts to 
perturb the model. 

3 Choose OK, to create a summary statistics mesh grid (voxet) for re-compiled 
results and settings captured between 400,000 & 500,000 iterations.

Note that we left the default Threshold at ‘90’. This is a percentage measure of 
geological uncertainty to be recorded in the statistical summary. See E6 - Stage 7 
below, and the Table therein for further details.

When the Summary Voxet calculations are finished, you will see the following pop-up:
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View the list of your joint inversion output files
Here is a summary of the inversion output files which now exits in your project 
directory folder:  Case2 > Run1:

File(s) Description

misfit.csv Numeric record of the misfit evolution (Misfit 
degree for gravity and magnetics as a function of 
iteration number).

effects_Gravimetry_1.ers 2D grid of the computed gravity response from the 
initial iteration of the inversion

final_Gravimetry_1.ers 2D grid of the computed gravity response from the 
final iteration of the inversion

effects_Magnetism_2.ers 2D grid of the computed magnetic response from 
the initial iteration of the inversion

 final_Magnetism_2.ers 2D grid of the computed magnetic response from 
the final iteration of the inversion

initial.vo Initial voxet (3D grid) - 4 attributes: initial 
lithologies; fixed cells; initial densities, initial 
susceptibilities

final.vo Voxet (3D grid) for the state of the model at the 
final iteration - 4 attributes: final lithologies; fixed 
cells; final densities, final susceptibilities

reference.vo The geophysical response kernel voxet model (3D 
grid), discretised at the same cell size as the voxet 
models above.

SummaryStats_400000_50000
0_Threshold_90_super.vo

A summary statistics mesh grid (voxet) for re-
compiled results and settings captured between 
burn-in (400,000) & end of iterations (500,000).

For further details of this key file see E5 Stages 8 
& 9.

Case1_Run1.txt Log of change to the geology model voxet, for 
reconstructing the state of the inversion during 
the evolution. For headings, and further 
information see the Inversion Manual.
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E5 Stage 6__View the final 2D grids for magnetics and gravity (quality check)
The reason for this stage: comparing observed with final geophysics grids is to 
evaluate that inversion drove geometry and rock properties changes to achieve a close 
fit, as expected.
• If the geology tests had been too tight, 
• if the initial geology model was not a good/close-enough fit, 
• if the understanding of rock properties was poor and was not improved by 

property optimisation - 
THEN poor matches between observed and final-computed grid will probably occur.

On the other hand, good agreement between observed and final-computed grids does 
not guarantee that the inversion regime was appropriate or has necessarily given us 
good results. Before concluding this we must also discover and analyse the changes 
that were driven in terms of the property arrays and geology-geometry.

Load the summary final geophysical grids via EXPLORE 
Similar to the Forward Modelling tool (Tutorial E2), Inversion also creates and stores 
summary results which can be viewed by going to: 

Geophysics > 3D Geophysics > Results explorer

The left hand panel provides a data explorer for all the cases you may have created. 
The convention is to use GREEN arrows to indicate Forward model result cases, and 
RED arrows to indicate inversion cases. The other main function available here is the 
ability to delete cases that are of no further interest.
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3D GeoModeller displays several grid images including calculated misfit grids. The 
images are:
• Top Left—the observed grid
• Top Centre—the computed response of the final inversion iteration 
• Top Right—the ‘misfit’ or difference between the ‘observed’ response minus the 

response of the litho- model proposed in the final iteration.
• Bottom Left  is the result of choosing to solve and remove a regional trend. (No de-

trending is applied in this case).
• Bottom Middle is same as Top Middle, in this case.
• Bottom Right is same as Top Right, in this case.
Note that the colour scales are arbitrary and typically different for each of the images 
as they are the result of a linear colour mapping between the minimum and 
maximum values in the range for each grid. 
1 Toggle the Gravity data / Magnetic data menus to show similar summary images 

for Gravity
2 Use File > Exit to leave this tool.
All grids are saved in a folder within the GeoModeller project folder called “Case2”. 

Load the 2D geophysics grids (observed & final) to the 3D geology workspace
1 Ensure your MNT Section is open in the 2D Viewer
2 From the Explore tree, select Grids & Meshes
3 Right-click Import > 2D Grid
4 Browse to: 

CaseStudyE\TutorialE5\E5Beginning_Project\Case2\Run1\final_Gravimetry_
1.ers

5 In the Explore tree, Expand the “+” for final_Gravimetry_1.ers
6 with the grid selected, right-click Field Visualisation Manager
7 Tick MNT versus View on Section

8 Display Colour Table >  OK.  The grid will immediately geo-locate in the MNT 2D 
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Viewer AND display the Colour Table.
[Or, Click on the same grid in Explore, and right-click > Display Colour Table

• Import as many 2D grids as you want to compare by repeating steps 2., 3., 
and 4. above. When loaded they stay in your Explore tree.

• Geo-register the grids and display the colour table by repeating Steps 5. to 8 
above.

• Use Grids and Meshes (right-click) > Hide all Views to refresh your MNT Viewer 
before viewing the next grid. 

9 For Example: Browse to:    
\CaseStudyE\TutorialE5\Data\Observed_Gravimetry_BuriedGranite.ers

Note the resolutions of the two grids are different. A low resolution discretisation 
scheme was selected in the inversion settings (top image) for a fast outcome.
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E5 Stage 7—Statistical results analysis and visualization
Topics covered in this Section E5 Stage 7 include:
• Load the final voxet, and analyse statistical arrays for densities and magnetic 

susceptibilities
• Load the SummaryStats voxet and visualise most-probable geology
• Visualise most probably thresholded geology

Load the final voxet / 3D grid to the 3D geology workspace
1 From the Explore tree, select Grids & Meshes
2 Right-click Import > 3D Grid (Voxels)
3 Browse to and Open “final.vo” in your results directory:
 For example: CaseStudyE\TutorialE5\E5Beginning_Project\Case2\Run1\final.vo
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4 In the Explore tree, a “+” symbols appears next to the Grids and Meshes, expand 
this directory twice to reveal 4 different property fields of this attributed 3D grid: 

5 Select Susceptibility, Right-click > Histogram
6 Use the bottom right-hand-corner tab to Open each lithology in turn. 

(Host_rock; Cover and Granite) ALL is shown in the first view.
7 Select Host_rock, as shown below

.

1 Toggle through each lithology in turn, noting the Mean Magnetic Susceptibility 
and standard deviation for each, and here is a summary of the distributions 
that were recorded in the final iteration of the inversion.

Note - The following table gives an  indication of the expected values:

Note that similar statistics can be analysed in regard to densities/susceptibilties 
derived from the accumulated accepted inversion proposals which occurred between 
burn-in, and the end of iterations (instead use: 
SummaryStats_400000_500000_Threshold_90_super.vo) -  rather than those shown 
here which relate to the last iteration-only (final.vo).

Voxet (3D grid) for the state of the model at the 
final iteration - 4 attributes: 

fixed cells; litholgies; densities, susceptibilities

Lithology Mean Susceptibility Standard deviation

Cover 0.00002 0.000001

Granite 0.004014 0.000233

Host_rock 0.002028 0.000148
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Check the volumetric changes of the granite body in initial vs final inversion models
The final.vo is already loaded in the Explore tree, so now load the “initial.vo” to set 
up a quick comparison in volumetric terms:
1 From the Explore tree, select Grids & Meshes
2 Right-click Import > 3D Grid (Voxels)
3 Browse to and Open “initial.vo” in you results directory:
 ...\CaseStudyE\TutorialE5\E5Beginning_Project\Case2\Run1\initial.vo
4 Select and expand the initial.vo grid in Explore
5 Select the “Lithology field” of the initial.vo grid, and right-click > Histogram

6 Repeat Steps 4. and 5. to also view the histogram for lithology field in final.vo

Key observations:

Granite in: % of litho-model Volmue Change

initial.vo 8.388 2.31 x 1010

final.vo 6.688 1.65 x 1010 lesser volume
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E5 Stage 8 — Analyse 2D & 3D composite views of resulting geology-geometry
1 From the Explore tree, select Grids & Meshes
2 Right-click Import > 3D Grid (Voxels).
3 Browse to, and open “final.vo” in you results directory: 

...\CaseStudyE\TutorialE5\E5Beginning_Project\Case2\Run1\SummaryStats
_400000_500000_Threshold_90_super.vo

4 Select SummaryStats_400000_500000_Threshold_90_super.vo
 

5 In the Explore tree, a “+” symbols appears next to the Grids and Meshes, expand 
this directory twice to reveal 12 different property fields of the attributed 3D grid.

The following table explains each property field of the 3D mesh/grid. We will only be 
analysng and/or visualizing some of them in this tutorial.
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File(s) Description

Change Count The number of times this particular voxel has had 
a change

Entropy Relates the volatility or change-degree of the 
particular voxel throughout inversion in respect of 
geometry changes. Represented as a number from 
0 (low volatility) to 1 (high volatility).

Mean density The mean density as derived from the 
accumulated accepted inversion proposals/models 
which occurred between burn-in and the last 
iterations.

Standard Deviation Density Directly related to the above mean as derived 
through the PDF.

 Mean Susceptibility The mean magnetic susceptibility as derived from 
the accumulated accepted inversion proposals/
models which occurred between burn-in and the 
last iterations.

Standard Deviation 
Susceptibility

Directly related to the above mean as derived 
through the PDF.

Most Probable For each voxel location, this field records the 
lithology-identity that the voxel adopted for the 
majority of the iterations between burn-in and 
the last iterations.

Most Probable Thresholded As above, but rather than “majority” the voxel 
location must have adopted a single lithology-
identity for “equal to or greater than the % 
threshold” number of iterations between burn-in 
and the end of iterations. Otherwise a “zero” is 
recorded instead of a lithology integer. A higher % 
value requested will return a greater level of 
geological certainty per formation, but less of the 
model will be designated to any formation, and 
“zeros of uncertainty” will fall between (creating a 
wide geological boundary). 

Probability_AboveTopography

Probability_Cover For every part of the model space the probability of 
finding “Cover” in any given cell is given between 0 
and 100%. This is usually then displayed in a 
black/grey/white colour scale. 

Probability_Granite For every part of the model space the probability of 
finding “Granite” in any given cell is given 
between 0 and 100%. This is usually then 
displayed in a black/grey/white colour scale. 
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6 From the Explore tree, select the MostProbableThresholded property field

7 Select MostProbableThresholded > right-click > Properties (bottom of list)
8 Change Alias to “Lithology” (type)

9 OK
10 In Explore > MostProbableThresholded, right-click > Edit Colours & Clips

Probability_Host_rock For every part of the model space the probability of 
finding “Host_rock” in any given cell is given 
between 0 and 100%. This is usually then 
displayed in a black/grey/white colour scale. 

File(s) Description
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11 Select a Visibility Clip from 0 to 1.5 to isolate granite (pink); and the zero field 
(white) which represents cells which resided below the threshold of 90% c.l. ) 

12 Apply & Close
13 Next ensure that section C2 is open in the 2D Viewer

14 Again with MostProbableThresholded selected, right-click > Field 
Visualisation Manager

15  Select View on Section “C2”

16 The image below is a 2D rendering of the 3D voxet for MostProbableThresholded 
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geology at 90% confidence limits (an inversion outcome for the granite). This is 
directly compared in the 2D Viewer, with the data which constrained the shape of 
the granite in the initial (starting) model. In accordance with the volume results a 

Visualising the 3D Voxet for MostProbable geology
1 From the Explore tree, select the MostProbable property field.
2 MostProbable > right-click > Properties (bottom of list)
3 Change Alias to “Lithology” (type)
4 OK
5 In Explore > MostProbable, right-click > Edit Colours & Clips
6 Select a Visibility Clip from 0.5 to 1.5 to isolate granite (series 1)
7 again select MostProbable, right-click > Field Visualisation Manager.
8 tick the upper area: View grid in 3D.

9 Post-inversion voxels deemed “Granite” in the MostProbable field of the summary 
statistics voxet are rendered in 3D.
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10 Having done a Model Compute > Visualise 3D Formations & Faults (Tutorial 
E2), a wireframe view can be turned on in Explore

11  3D Geology > Hide (clears the view)
12 3D Geology > Volume: Granite > Appearance > (Display mode) Wireframe 

> Apply > Close

Compute a New Field for viewing granite by post-burn in density distribution
1 In Explore select Meshes and Grids > Hide all Views
2 With SummaryStats_400000_500000_Threshold_90_super.vo selected,
 right-click > Compute new Field 

All fields to be computed must be within the same grid. (Functions such as: “Merge 
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this grid with Another” can assist manipulation)

3 In the Grid Computer type/select:
If “MostProbable” == 1; (THEN) MeanDensity; (OTHERWISE) null - and close the 
bracket.
4 From EXPLORE, select 3D Geology > Hide
5 Give the new field a name, (top right of Calculator): say, 

“GraniteBYDensitycontrast”
6 Evaluate, then Save and exit.
7 From EXPLORE, select: 
SummaryStats_400000_500000_Threshold_90_super.vo >  Hide all Views of this 
mesh/grid
8 From EXPLORE, select the new field “GravityBYDensitycontrast”
9 Right-click > Field Visualisation Manager
10 Select View grid in 3D > OK

11 The View below opens in 3D. 
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1 Aditionally, you can open the colour table: from EXPLORE > Grids and Meshes > 
GranitBYDensitycontrast > Display Colour Table

E5 Stage 9 — Create 3D points of inversion-driven geology (Export Shells - cvs)
A key method for re-importing the post-inversion geology geometry is demonstrated 
in this section. First, we export the “tops” of the MostProbable Geology as a point 
cloud and then re-import them as primary geology constraints (“new granite”).
1 From the Main menu open Geology > Formations: Create or Edit
2 Select a colour and type a name say, “NewGRANITE” No spaces!  > Add

3 Select Yes, Start Stratigraphic Pile editor
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4 Select > New Series

5 Highlight > NEWgranite > Commit > Close > Close 

6 In Explore select Meshes and Grids > Hide all Views
7 With SummaryStats_400000_500000_Threshold_90_super.vo  > 
MostProbable selected, 
8 Right-click and select > Export Surface Shells

9 Choose query type “EQ”
10 Tops only, for cvs output (which can be re-imported into GeoModeller as a cloud of 

contact data points)
11 Choose value type 1 (1=Granite)
12 From the Right-side “ .. “ Browse to the directory of your choice to save the file
13 Name the file say, “Tops_NEWgranite” > OK
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14 Next, from the Main menu Import > 3D Geology interfaces

The WIZARD will lead you through the importation of the points from the .cvs file to 
be assigned to the geology object called “NewGRANITE”

15  Step 1 of 4: Select “Tops_NEWgranite.cvs” > Open.    > Next.

16 Step 2 of 4: Observe 3 separate columns are recognised for x, y and z. > Next
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17 Step 3 of 4: Sorts the columns: Geological Formation=Project; NEWgranite; 
X=A; Y=B; Z=C         > Next 

18 Step4 of 4: Lastly, merge to existing Formation called NewGRANITE (green)
19 >Finish.
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20 A report on the importing of points is given

21 From the Main menu View > 3D Viewer > Show interface data

Select NEWgranite > OK

• The points viewed (below) define the top of the “MostProbable” granite body as an 
outcome of the joint geophysical inversion.
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• They are currently committed to a new geology object (NEWGranite), and 
included in the geological pile.

Re-comuting the 3D granite iso-surface in the model, with post-inversion constraints
• In this step we modify the initial geology model - replacing of the “old” granite 

contact points, with the NEWgranite contact points.
The first step is to add some orientation data for NEWgranite (as a rule, both 
orientation & points data are required to compute a surface)
1 From Main menu, select Model >  Project Data onto Sections in 2D Viewer
2 Select Section C2
3 Select “NEWgranite”
4 Type Maximum Projection distance: “500” > OK
5 With Section C2 active (tick in the top left), select the “Create” tool from the 2D 

toolbar (pencil tool)
6 Guidance for the shape of the NEWgranite is needed on Section C2:
Use the Create tool to click in 2 places, and select > Create Geology Orientation 
data (from the top toolbar Menu)
7 For each of the 3 orientations, check NEWgranite is selected > Create (bottom)
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Guidance is also required for the shape of the NEWgranite surface as described on 
Section C3:
1 Repeat Steps 1 to 7 above for Section C3.
2 New orientation data, in the approximate locations as show below, are 

recommended.

Compute the 3D geology
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Compute the 3D geology model for the project that we have loaded (to be constrained 
by the geological data and pile we have reviewed).
1 From the Model toolbar, choose Compute  or (press ctrl+M)
In the Compute the Model dialog box:
• Series to interpolate—Select ONLY “Series 2” and “NEWgranite Series”
• (Series 3 is Cover. This will automatically generate between series 2 and the 

topographic surface. We DO NOT wish to include Series1-original granite).
• Faults to interpolate—Select All
• Sections to take into account—Select All
• Faults only—Clear (therefore DO compute faults)
2 Choose OK

Explore the 3D Viewer - ‘Build’ the model in 3D
3 From the Model toolbar choose Build 3D Formations and Faults 

In the Build 3D Formation and Fault Shapes dialog box:
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Check Build—Formations

Check Build—Faults

Select Type—Volume

Check Draw Shapes after building

Adjust the Resolution—Render quality to Medium
4 Choose OK
The full model in built in the 3D Viewer, but let’s now reveal the NEW granite

5 From Explore > Expand the +3D Geology
6 Expand +Series3 > Volume: Cover > Hide
7 Expand +Series2 > Volume: Host_rock > Hide

Conclusion: the inversion outcomes for the NEW granite body are now fully 
integrated in the revised geology model.
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Tutorial E6—Forward calculation of full tensor gravity grids
Parent topic: 
Tutorial case 
study E 
(Forward and 
inverse 
modelling of 
potential field 
data)

This tutorial introduces the user to full tensor gravity grids, as a precusor exercise to 
performing inversion with observed full tensor potential field data (the basis of an 
extension Tutorial currently under development).

In this tutorial: 

• E6 __Introduction

• E6 Stage 1__Load the “BuriedGranite” 3D model

• E6 Stage 2__Forward calculation of a gravity full tensor grid

• E6 Stage 3__Visualization of the component tensor grids
E6—Introduction

1 In this tutorial we will forward model a gravity full tensor field directly from our 
3D geology model, using a modified Fourier method. 

2 The result is a 6 band ERMapper BIL grid.
3 We will visualise the full tensor grid by the cube root of its determinant.
4 Next we will visualize in turn, the separate components of the tensor by querying 

each band using a small grid-viewer tool, in GeoModeller.

E6 Stage 1—Load and review the “BuriedGranite” 3D model
1 Continuing on from Tutorial E5, with your current project.
2 OR, from the main GeoModeller menu choose Project > Open OR 

From the Project toolbar choose Open  OR 
Press CTRL+O.

3 Browse to and open the pre-created 3D GeoModeller project: 
GeoModeller\tutorial\CaseStudyE\TutorialE6\E6Beginning_Project
\E6Beginning_Project.xml

(where GeoModeller is the location of your 3D GeoModeller installation, for 
example: C:\Geomodeller\Geomodeller
4 From the main menu choose Geophysics > Define physical properties.

5 Ensure the above values are entered for densities. We will only be creating a 
gravity full tensor grid, so only densities need to be checked.

Note that NEWgranite is a geology object created for the purpose of tutorial E5.

Series Mean  
Density

Standard 
Deviation

Statistical  
Law

Percentage 
of 
population

Series3-Cover 2.2 0.1 LogNormal 100

Series2-component1 3.1 0.1 LogNormal 70

Series2-component2 2.9 0.2 Normal 30

Series3-Granite

& NEWgranite

2.8

2.8

0.1

0.1

LogNormal

LogNormal

100

100
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E6 Stage 2—Forward calculation of a gravity full tensor grid 

Now we will set up and compute a full tensor gravity field (Free Air) directly from the 
3D geology model
1 From the main menu choose Geophysics > 3D Geophysics > Forward wizard. 3D 

GeoModeller displays the forward calculation area of 3D Geophysics tool.
2 Choose Gravity Tensor in the Fields to compute area. All six tensor components 

will automatically select too.

The six separate components of the Gravity Tensors
Gxx : second derivative of the gravity potential purely in the x (east) direction
Gxy or Gyx : second derivative of the gravity potential in the composite directions 
x and y
Gxz or Gzx : second derivative of the gravity potential in the composite directions 
x and z
Gyy : second derivative of the gravity potential purely in the y direction
Gyz or Gzy : second derivative of the gravity potential in the composite directions 
z and y
Gzz : second derivative of the gravity potential purely in the z (depth) direction
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3 Now press NEXT and go to the next page of the wizard. 

Forward Model Parameters

Unlike our previous forward modelling (tutorial E2) we will not browse for/load an 
observed (reference) Gravity Tensor grid. This will be included in the extension 
tutorial currently being prepared.

Choose a calculation surface (The choice is open, since we are not matching the 
metadata of a reference grid)
4 Choose Constant elevation = 0 m. This is the default and assumes the data was 

collected at sea level.
.

• Alternatively you can create a calculation surface which mimics the shape of 
your DEM, but for a set terrain clearance height.

•  The final option allows you to load an external “drape grid” that you want 
your model response estimated upon. This is the closest option to being able to 
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compare your model response calculations to what might be given to you from 
an airborne geophysics contractor grid.   

5 Choose NEXT.
6 Accept the default values for x, y, and z of the Voxet Properties 
7 Select 3D FFT method
8 Set the vertical expansion to 1200%. 
9 Accept all the remaining defaults in the remaining part of this window.

10 Choose NEXT (series:_NEWgranite may also appear in this list)
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11 Density property per lithology can be altered (entries here will dominate the 
settings of those in the Physical Properties table). No changes necessary.

12 As we are creating a Free Air anomaly, the appropriate settings for Reference 
density and Above-topo density are both: zero. Change the values to “0” in this 
window. 

13 Now choose NEXT.
14 Finally, choose the default of Interactive mode.
15 The number of CPU’s available for this computation is displayed. You can accept 

the full availability, or choose to reduce this value, to allow other processes to 
continue (Note: this will result in slower computation times).

16 Choose FINISH

Summary images of the full tensor response for gravity
3D GeoModeller displays the images of the response of our gravity forward 
calculation of the full tensor in the Results Explorer window.

(This Forward Viewer can be returned-to at a later time:

Geophysics > 3D Geophysics > Results Explorer) 
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When the forward model calculations have been completed 3D GeoModeller displays 
several full tensor grid images (by a Cube Root Determinant function) and some basic 
statistics. The images are:
• Top Centre—the response of the ‘current model’ that you have calculated
• Top Right—the ‘current misfit’ (meaningless without an observed grid)
• Bottom Middle is the computed response (no detrending applied).
• Bottom Right is the redone misfit plot (meaningless without an observed grid).
It is not applicable to alter the Region Settings or detrend, as no observed grid is 
available for comparison, in this case.

Note that the colour scales are typically different for each of the images as they are 
the result of a linear colour mapping between the minimum and maximum values in 
the range for each grid. 
1 Use File > Exit to leave this tool.
2 Project > Save.
All grids are saved in a folder within the GeoModeller project folder called “Case3”. 

E6 Stage 3—Visualisation of the component tensor grids 
Viewing one of the tensor component grids requires dynamic re-sampling of the full 
tensor grid.

This is done using Spherical Linear Interpolation (SLERP) along the rows and down 
the columns.

As you zoom into an area of interest, the full tensor is calculated at all points. The 
required component is then passed to the view window.
1 Open Geophysics > Examine Geophysical Grids 
2 Open File > Load Grid Dataset

3 Browse to: 
D:\...\CaseStudyE\TutorialE6\E6Beginning_Project\Case3\Run1\calculated_
GravityTensors_1.ers

4 The computed full tensor gravity grid is visualised (same as the top middle 
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grid of the previous Results Explorer summary figure (above). This visualisation 
is available to us through a Cube Root Determinant function. 

5 Within the small “Intrepid Visualization” window open Grid Display > Tensor 
Query (bottom of the list)

6 Select “XX” > OK  The tensor derivative grid of the gravity potential purely in the 
x direction is displayed. 

7 Now select “YZ” > OK  The tensor derivative grid of the gravity gradient in the 
composite directions z and y is displayed.
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You can slso examine the completed project folder as stored in your project directory: 
GeoModeller\tutorial\CaseStudyE\TutorialE6\Completed_project\Case
3\Run1

Creating a FALCON tensor forward model
The convention for a Falcon tensor grid comes from wishing to preserve the same 6 
band BIL scheme that is used for FTG, while indicating in a systematic way that the 
data is reflecting the duplicate A and B readings of the horizontal tensor gradient 
that is the Falcon’s signature.  The spreadsheet tool in Intrepid has a simple function 
to convert the FTG forward model grid created above, into a form that is compatible 
with an observed Falcon tensor grid. This process must be followed before proceeding 
to any visual comparison of an observed Falcon gridded dataset, and the response 
from your model. The options for visualizing a Falcon tensor grid are also adapted to 
what is available from the measured data.

You will note a number of 2D grids (.ers grid files), 3D grids (.vo voxet files).

Also, as we have used the FFT method (rather than a spatial method), a .task file is 
also present that captures the process used to do the 3D FFT forward model. This is 
typically called vfilt_GravityTensor.task). 

Geomodeller has spawned this separate process as a batch process.
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CONCLUDING NOTE
This tutorial is currently under extension to include demonstration exercises of 
inversion referencing observed full tensor potential field data.
The functionality is in place, and the GUI is fully enabled for this work.

File Description

calculated_GravityTensors_1.ers 2D full tensor grid computed by FFT 
forward modelling (6 bands)

final_GravityTensors.vo Resulting 3D grid - 6 attributes (one for 
each tensor component)

initial.vo Initial 3D grid - 2 attributes (one each for 
Lithology, density)

Observed_GravityTensors_1.ers empty grid, as we did not use a supplied / or 
reference grid

vfilt_GravityTensors.task The FFT process captured ready for batch 
or multi-threading environments 
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