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Preface

This manual is written for users of the Streamer for DOS data acquisition program. It provides all the information required
to successfully operate the software.

What is Streamer for DOS?
Streamer for DOS is a simple yet powerful data acquisition package for the United Electronic Industries WIN-30 range of
analog I/O boards. Streamer for DOS is entirely menu driven. Its capabilities are as follows:

• Data can be acquired from any one of the WIN-30 and WIN-3016 series of analog I/O boards. All gain and speed
versions are supported. Multi-channel data acquisition is fully supported.

• Data is acquired directly to hard disk. The amount of data that can be acquired is limited only by available hard
disk space.

• The acquired data can be displayed in a graphical form. Graphs can show any amount of data, irrespective of the
available memory.

• Data files can be recalled later and the data written out in a number of formats for use in other programs.

Structure of the manual
This manual is written in a tutorial form, and deals with each topic as you are likely to encounter it. There are four
chapters:

• Chapter 1: Quick Start

This chapter is a one-page guide for the advanced user detailing how to immediately sample data.

• Chapter 2: Installation and Configuration.

This chapter guides you through the process of setting up Streamer for DOS to operate on your system and
configuring it to operate with your data acquisition boards.



• Chapter 3: Basic Operations.

This chapter describes how you go about getting data into Streamer for DOS, displaying the data, and other useful
features.

• Chapter 4: Advanced Operations.

This chapter describes the use of digital I/O, saving and recalling of configurations and data files, and gives
information on exporting data from Streamer for DOS to a number of file formats for use in other programs.

What you need to know

This manual assumes:

• That you have a WIN-30 or WIN-3016 series board, and have installed and tested it as described in chapter 1 of
the board’s user manual.

• That you are familiar with the basic measurement capabilities of the WIN-30 or WIN-3016 series board, and
have read chapters 1, 2, 3 and 4 of the user manual.

• That you are familiar with the host PC that you are using, and basic DOS operations.
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Chapter 1

1. Quick Start
This chapter gives a one page quick start procedure for Streamer for DOS. This is intended for users that have experience
of both DOS and data acquisition. The later chapters discuss these steps in more detail

The procedure is as follows:

i. Install Streamer for DOS by running the INSTALL.EXE program on the Streamer for DOS distribution disk.

ii. Change to the directory in which you installed Streamer for DOS and run STREAMER.EXE.

iii. From the Options menu, chose Board..., and select the appropriate options from the resulting dialog box.

iv. From the Analog menu, chose Configure..., and select the parameters of the data acquisition you want to
perform.

v. From the Analog menu select Sample or press F7. A dialog box will be displayed for you to select a file on
disk to sample into.

vi. Press OK. The channels that you selected will be sampled and a dialog box will display all the information
about the sample.
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Chapter 2

2. Installation
This chapter explains how to install Streamer for DOS on your computer, the basics of using the menu system, and how to
setup Streamer for DOS to suit your requirements.

2.1. What you need to do
Prior to acquiring and processing data under Streamer for DOS, you need to perform two steps:

i. Install Streamer for DOS

ii. Configure Streamer for DOS to use your data acquisition board.

2.2. System Requirements

Streamer for DOS requires the following hardware and software:

2.2.1. Computer

IBM 386, 486 or compatible.

2.2.2. Plug-in Board

WIN-30D, WIN-30DA, WIN-30DS, WIN-30DS/4, WIN-30PGL, WIN-30PGH, WIN-3016D, WIN-3016DA, WIN-
3016DS, WIN-3016DS/4, WIN-3016PGL, WIN-3016PGH.
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2.2.3. Operating System

MS-DOS (3.x, 4.x, 5.x, 6.x).

2.2.4. Memory

640K Ram.

2.2.5. Graphics Adapter

IBM Color/Graphics adapter (CGA); color or composite monitor, or

IBM Enhanced Graphics Adapter (EGA); any monitor, or

IBM Video Graphics Adapter (VGA); any monitor, or

IBM 8514; any monitor

2.2.6. Math coprocessor (Optional)

Streamer for DOS will make use of a maths coproccessor (80387), if installed.

2.2.7. Mouse (Optional)

Any mouse (or other pointing device) with a mouse (INT 33) driver can be used. Mouse installation is described in the
next section.

2.3. Installing Streamer for DOS

Streamer for DOS is automatically installed on your hard disk by the installation program. It is not possible to install
Streamer for DOS by copying files from the distribution diskettes.

To start the installation, insert Disk 1 of Streamer for DOS in drive A: and type the following:

A:INSTALL <enter>

The Streamer for DOS executable files will be copied to the selected directory.

2.4. Starting Streamer for DOS

To start Streamer for DOS, simply type:

STRMDOS <enter>

The screen in figure 2.1 will then be displayed.
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Figure 2.1. Streamer for DOS start-up screen.

A welcome message will be displayed on the screen. This message will clear either after a predetermined time, or when
you click the OK button on the dialog.

2.5. Navigating in Streamer for DOS
Streamer for DOS has a menu-driven interface that uses dialogs to display information and let you configure the software.
The interface is DOS-based, but operates in a very similar manner to Microsoft Windows. You can operate Streamer for
DOS with both the mouse and the keyboard.

• The mouse is the recommended input device for operating Streamer for DOS. Menus, direct entry boxes, option
buttons, check boxes and command buttons are selected by clicking the left-hand button of the mouse with the
cursor positioned over the button, check box, menu name etc. To move between the buttons, checkboxes, etc.
using the keyboard press the Tab key to go to the next field and Shift-Tab to go to the previos field.

• Menus may also be opened by simultaneously pressing the Alt key and the highlighted letter of the desired menu.
Menu item selections may then be made by pressing the first letter of the menu option. Once a menu has dropped
down, you can also navigate through the menus using the cursor keys.



6 Installation

2.7. Configuring Streamer for DOS
The first thing to do in Streamer for DOS is to configure the board that you will be using. You need to setup the board --
base address, interrupts, DMA channels, A/D ranges, clock sources, etc. -- to suit your requirements.

When you select Board... from the Options menu the following dialog will be displayed:

Figure 2.2. Board Configuration dialog.

2.8.1. Base Address

The base address is the only setting on the WIN-30 and WIN-3016 series boards that is not configurable via software.
Select the base address at which the board is installed from the drop-down list to configure the board for use with
Streamer for DOS. Note: The factory default is 0x700, and is always a good place to start if you are not sure of the current
configuration of the board.

2.8.2. IRQ Level

The IRQ level is the interrupt number used to communicate with the board. Select a free interrupt from the drop-down list
to configure the IRQ level of the board.
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2.8.3. Primary DMA

The primary DMA channel is used for dual-channel DMA transfers. Select an unused DMA channel from the drop-down
list to set up the first part of the DMA channel settings.

2.8.4. Secondary DMA

The secondary DMA channel is also used for dual-channel DMA transfers. Select an unused DMA channel from the drop-
down list to set up the second part of the DMA channel settings.

2.8.5. Sampling Clock

The sample clock used for timing and control when sampling can be either internally generated by the WIN-30 or
externally generated by the data source. Select whether to use the internal clock with the radio buttons labeled Sampling
Clock from this dialog.

2.8.6. Input Mode

The analog input can be defined as either single-ended or differential. Select the correct option here from the radio buttons
labeled Input Mode.

2.8.7. Analog Input Range

The analog input range can be defined for the analog I/O sub-system by selecting the correct input range with the radio
buttons marked Analog Input Range.

2.9. Quitting Streamer for DOS

There are two ways to leave Streamer for DOS:

• Go to the File menu, then select Exit.

• Press <Alt-X>.
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Chapter 3

3. Basic Operations
This chapter discusses how to configure the analog I/O ports and sample data directly to disk. Graphical viewing of
sampled data is also described. In order to perform these operations you must have installed and configured Streamer for
DOS as described in chapter 2.

3.1. Analog Input Port Configuration

Figure 3.1. Analog Input Configuration dialog
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Before you can sample data, you need to tell Streamer for DOS how to perform the operation; which channels to sample,
at what frequency to sample them, etc. Select Configuration from the Analog menu to display the dialog in figure 3.1:

3.1.1. Sampling Rate

A predefined A/D converter throughput may be selected from the dropdown list or a user defined value entered into the
box provided.

The maximum possible sampling frequency depends on your board, the host PC, and the number of channels being
sampled. If you attempt to sample at too high a rate, an error message will be displayed informing you of the failed sample
attempt.

3.1.2. Sample size

The streamer will sample any amount of data up to the maximum available disk space. Select the size of the file required
here from the dropdown list or enter a custom size. All sizes are in KB (1024 bytes).

3.1.3. Channels to sample

Select the channels to sample from the list box. Use the cursor keys to navigate up and down in the list box, press the
<spacebar> key to toggle on and off the sampling of a channel, and press <insert> and <delete> to toggle all the channels
on and off respectively.

3.1.4. Channel gain

The WIN-30PG and WIN-3016PG series feature software programmable gain. The gain of each of the 16 input channels
can be independently set to either 1, 2, 4 or 8 (WIN-30PGH and WIN-3016PGH), or 1, 10, 100 or 1000 (WIN-30PGL
and WIN-3016PGL). Select the desired gain for the currently highlighted channel from the group of radio buttons labeled
Channel Gain.

3.1.5. Transfer mode

The WIN-30 and WIN-3016 series boards offer a choice of high speed data transfer options to the user. The first of these
options is dual DMA channel “gap-free” operation utilizing bursting DMA transfers. This is useful when running under
simple operating systems, such as DOS. When running Streamer for DOS under more advanced operating systems like
Windows 3.1 and Windows NT it is preferable to use 32-bit Rep String operations as a transfer mode to improve
efficiency. This transfer mode utilises 32-Bit Rep String operations (REP INSD) via the 32-bit ‘phantom register’
available only on 386 and higher class processors, and offers improved efficiency under Windows NT and other 32-bit
DOS extenders.

3.1.6. A/D Capture mode

Either normal or block mode A/D capture may be selected. In normal mode one A/D conversion is performed on each
clock pulse. In block mode, all selected channels are sampled on each clock pulse. For boards which do not support true
simultaneous sampling, the entire block is converted at maximum throughput, so achieving near simultaneous sampling of
all channels. For boards which do support true sumltaneous sampling, selecting block mode enables this. This option is
only applicable when more than one channel has been selected for capture.

3.1.7. Data packing

Data packing can be used to maximize the efficiency of the data acquisition process. When data packing is enabled the
WIN-30 or WIN-3016 series board will store four 12-bit samples in every 6 bytes of data streamed to disk. This is 30%
more efficient than not using data packing, where every 6 bytes contain only 3 samples of 12 bits each.
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3.2. Voltmeter
Often while sampling data it can be useful to quickly see what signals are currently being measured on the analog input
lines. Streamer for DOS has a voltmeter which displays the values present on all of the board A/D channels. Selecting
Voltmeter from the Analog menu will display a dialog similar to the following dialog:

Figure 3.2. Analog Voltmeter dialog

The values being measured may be viewed as actual binary input codes or as scaled voltages. Press the ‘Scaled’ button to
display scaled values. Press the Integer button to view the raw data. Press Close or click in the close box in the top left to
close the dialog. Note: You don't have to close the voltmeter to continue working - you can still select menu options and
use any other of the Streamer for DOS facilities while the voltmeter is displayed.

3.3. Sampling the data
In order to sample the data, press <F7>, or select the Get Input Sample option under the Analog menu. The data will be
sampled and a dialog displayed on the screen containing information about the sample. A typical screen is shown in figure
3.3.
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Figure 3.3. Typical Current File dialog

3.4. Viewing the data
In order to view the data that you have just sampled, click on the View button in the current file dialog or press <Alt-V>.
Streamer for DOS has to summarize the data that was sampled before displaying it because the data files are unlimited in
size and might not fit into physical memory. While summarizing the data a progress bar will inform you of how much of
the data has been summarized. When finished Streamer for DOS will switch to graphics mode, display a set of axes and
plot the summarised data. To toggle the display of a channel on and off, press the number from 0-9 and A-F associated
with that channel. Press the <Grey-+> key to turn on display of all the channels and the <Grey--> key to turn off display of
all the channels. Click on the OK buttons or press <Enter> to end the display of the summarized data.

The data is summarized in two ways:

3.4.1 Minima & Maxima

The data is divided into a number of equal ranges, each representing a discrete time period. Within a range the data values
are examined and the minimum and maximum values are extracted. When displaying the graph a vertical line is drawn
between the minimum and maximum points to create a hi-low graph that indicates the range of values for a given channel.

3.4.2 Average

The data is divided into a number of equal ranges, each representing a discrete time period. Within a range the data values
are examined and the average value is extracted. When displaying the graph the average values for each time period are
plotted to show a summary of the channel’s values.
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Chapter 4

4. Advanced Operations

4.1. Digital Operations

The digital menu allows data to be sent to or read from the digital I/O ports on the selected board. There are three options
available:

4.1.1. Digital I/O Port Configuration

Figure 4.1. Digital Configuration dialog



14 Advanced Operations

Selecting Configuration... from the Digital menu will display the dialog in figure 4.1.

Select a digital port from the list box using the mouse or the cursor keys. The spacebar or the left mosue button will toggle
a digital port between input and output. Use <Ins> or <Del> to toggle all the digital ports to be input or output
respectively.

4.1.2. Digital Input

Any digital port can be used for digital input. Select the port out of the list box and either press <Spacebar> or double-
click with the left mouse button on the port number. Streamer for DOS will display a dialog showing you what the current
value of the digital line requested.

4.1.3. Digital Output

Only digital ports expressly defined as output ports can be used for digital output. Select the port out of the list box and
either press <Spacebar> or double-click with the left mouse button on the port number. Streamer for DOS will display a
dialog prompting you for the value to output form the digital I/O port. Note: this value should be entered in decimal, and
must be between 0 and 255.

4.2. Exporting Data
When a file is open selecting Save As from the File menu will display the following dialog:

Figure 4.3. Save As (Export) dialog
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This dialog gives you the opportunity to save the sampled data in a number of formats for export to other applications.
Type a destination filename into the field labelled Destination Field or click on Browse to display a dialog to help you
selact an output file. Choose the Sample Start and Sample End to export only a certain range of the data, select an output
file format from the radio buttons and choose OK. The data will be saved in one of four distinct data formats to the file of
your choice.

4.2.1 Destination file

Enter the name of the destination file here. Click on the Browse button or press <Alt-B> to display a dialog that will allow
you to select a destination filename.

4.2.2 Sample Start and End

One can limit which portions of the data are exported by entering the starting and ending positions to export between.
Either enter the positions manually or click on the View button (or press <Alt-V>) to display the data graphically. While
viewing the data use the left mouse button to select two points on the graph. Click on the OK button or press the <Enter>
key to accept the range selected.

4.3.3 Output Format

Select the desired format for the exported data.

4.3. Saving and Recalling Configurations
Streamer for DOS can save its entire setup. If you save and then recall a setup, the entire program context, except for the
data, will be restored to what it was.

On start-up, Streamer for DOS looks for a file called DEFAULT.CFG in the current directory. If this is found, the settings
in it are automatically loaded.

In order to save a set-up, proceed as follows :

i. Go the Options menu.

ii. Select the Save... option. The program will prompt for a filename.

iii. Enter the filename, and press <enter> or click on the OK button.

Setups can be loaded by the Load... option in the Options menu, or automatically as described above.

4.4. Environment Settings
Selecting Environment... from the Options menu will display the following dialog:
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Figure 4.3. Environment Settings dialog

4.3.1. Display progress bar

Clear this check box to turn off all visual representation of sample progress when sampling. The progress bar is useful to
determine how much space is left in the file being sampled into, but can impact efficiency if sampling at a very high rate.

4.3.2. Display clock

Streamer for DOS always shows the current system time in the top right corner of the screen. Clear this check box to
disable this display of the current time.

4.3.3. Display memory

Streamer for DOS always shows the amount of free memory in the bottom right corner of the screen Clear this check box
to disable this display of the free memory.

4.3.4. Disable clock

Clear this check box to disable the computer’s internal clock. This can be used for sampling where efficiency is of the
utmost importance and the real-time clock in the PC is decreasing the maximum sample rate.
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4.3.5. Save configuration

By default Streamer for DOS will save its entire configuration when exiting to maintain all the user options selected
during a session. By clearing this check box you can disable this feature. Once disabled, use the procedure described in
section 4.2 to save and load configurations manually.

4.3.6. View mode

In order to graphically view sampled data larger than physical memory Streamer for DOS summarizes the data using on of
two methods. Select the summarizing method you wish to use when viewing data by selecting one of these two radio
buttons.

4.5. Other Useful Features

4.5.1. DOS Prompt

Often you may want to perform DOS file management to set aside enough space on the hard drive to sample into. You do
not need to leave Streamer for DOS to do this - simply select DOS Shell... fom the File menu and you will be placed in
DOS. When ready to return to the streamer, type:

EXIT<enter>

This will place you back in the streamer exactly where you were before going to DOS.


