
LiveProject User Manual 

Page 1 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

LiveProject User Manual 
For all versions of LiveProject. Version 3.1 by KaDonk 

Written for version 3.1.2 of LiveProject Page 1/45 

 



LiveProject User Manual 

Page 2 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

1 Table of Contents 
LiveProject User Manual..................................................................................................................................... 1 

1 Table of Contents ....................................................................................................................................... 2 

2 Support ..................................................................................................................................................... 6 

3 KaDonk Products ........................................................................................................................................ 7 

3.1 How to find your version of LiveProject ................................................................................................... 8 

3.2 Upgrading LiveProject .......................................................................................................................... 8 

3.3 More Help .......................................................................................................................................... 8 

4 Installation................................................................................................................................................. 9 

4.1 MSI Installer ........................................................................................................................................ 9 

4.1.1 Command Line Options for MSI Installer ........................................................................................ 9 

4.2 Microsoft ClickOnce............................................................................................................................. 9 

4.3 Uninstalling LiveProject ......................................................................................................................... 9 

5 Running LiveProject ................................................................................................................................... 11 

5.1 Username and Passwords ................................................................................................................... 11 

5.1.1 Running in Free Viewer Mode..................................................................................................... 12 

6 The Big Picture! ........................................................................................................................................ 13 

7 Getting Started Using LiveProject Now!....................................................................................................... 16 

7.1 View ................................................................................................................................................ 16 

7.1.1 Viewing local files ..................................................................................................................... 16 

7.1.2 Viewing shared project files ....................................................................................................... 17 

7.1.3 Viewing a Bugzilla Database ..................................................................................................... 17 

7.2 Share ............................................................................................................................................... 17 



LiveProject User Manual 

Page 3 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

7.3 Collaborate....................................................................................................................................... 17 

7.3.1 Upload projects and files to LiveProject Server .............................................................................. 18 

7.3.2 Invite Users to Account............................................................................................................... 19 

7.3.3 Suggest Changes on Project ....................................................................................................... 19 

8 Viewers in General................................................................................................................................... 22 

8.1 Common features for Project and Bugzilla viewers ................................................................................. 22 

9 Project Viewers ........................................................................................................................................ 23 

9.1 Using a Project Viewer ....................................................................................................................... 23 

9.2 Project Tree ....................................................................................................................................... 23 

9.3 Project Overview Bar ......................................................................................................................... 24 

9.4 Task Details....................................................................................................................................... 25 

9.5 Context Menu.................................................................................................................................... 25 

9.6 Add new task .................................................................................................................................... 25 

9.7 Edit "Task name" ............................................................................................................................... 26 

9.8 Delete Task ....................................................................................................................................... 26 

9.9 Secure Project ................................................................................................................................... 26 

9.10 Suggestions .................................................................................................................................. 27 

9.11 Reset Sort ..................................................................................................................................... 27 

9.12 Open with MS Project .................................................................................................................... 27 

9.13 Project Details ............................................................................................................................... 27 

9.14 Show Legend ................................................................................................................................ 28 

9.15 Configure LiveProject Colors ........................................................................................................... 28 

9.15.1 Edit Custom Color Rules ............................................................................................................. 29 

9.16 Calendar View.............................................................................................................................. 29 



LiveProject User Manual 

Page 4 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

9.16.1 Fit to window............................................................................................................................ 30 

9.16.2 Task list.................................................................................................................................... 30 

9.16.3 Go to....................................................................................................................................... 31 

9.16.4 Timescale ................................................................................................................................. 31 

9.16.5 Text styles................................................................................................................................. 31 

9.16.6 Bar styles ................................................................................................................................. 31 

9.16.7 Zoom....................................................................................................................................... 31 

9.17 Resources ..................................................................................................................................... 31 

10 Bugzilla Viewers ................................................................................................................................ 33 

10.1 Adding a new Bugzilla Viewer........................................................................................................ 33 

10.2 Using a Bugzilla Viewer ................................................................................................................. 33 

10.3 Create new bug ............................................................................................................................ 34 

10.4 Edit Bug #XYZ............................................................................................................................... 34 

10.5 Launch Bugzilla ............................................................................................................................. 34 

10.6 Configure Viewer .......................................................................................................................... 34 

10.7 Edit Account ................................................................................................................................. 34 

10.8 Select Account .............................................................................................................................. 34 

10.9 Edit Filter ...................................................................................................................................... 34 

10.10 Select Filter ................................................................................................................................... 34 

11 Explore Server ................................................................................................................................... 35 

11.1 Shared files .................................................................................................................................. 36 

11.2 Publish files................................................................................................................................... 36 

11.3 Show Log ..................................................................................................................................... 37 

11.4 Secure Project Settings ................................................................................................................... 38 



LiveProject User Manual 

Page 5 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

12 Manage Project Suggestions ............................................................................................................... 40 

12.1 Reviewing suggestions ................................................................................................................... 41 

12.2 Update Project .............................................................................................................................. 41 

13 Manage Users................................................................................................................................... 42 

13.1 User Status ................................................................................................................................... 42 

13.2 Actions......................................................................................................................................... 42 

13.2.1 Apply Changes......................................................................................................................... 42 

13.2.2 Reset Password ......................................................................................................................... 43 

13.2.3 Delete User............................................................................................................................... 43 

13.3 Rights........................................................................................................................................... 43 

13.3.1 Invite other users ....................................................................................................................... 43 

13.3.2 Edit other users ......................................................................................................................... 43 

13.3.3 Delete other users...................................................................................................................... 43 

13.3.4 Edit own E-mail ......................................................................................................................... 43 

13.3.5 Administrator............................................................................................................................ 43 

14 Index................................................................................................................................................ 44 

 



LiveProject User Manual 

Page 6 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com 

2 Support 
This user manual is written for LiveProject version 3.0  

As new versions of LiveProject are released, some of the functionality described in this manual may change, and new 
functionality will be added.  

Please refer to the following locations for the latest help on your specific version of LiveProject: 

1. At any time in LiveProject, press F1 for context-sensitive help 

2. The LiveProject Help files are published at http://www.kadonk.com/Help 

3. KaDonk provides access to online support forums at http://forum.kadonk.com  

4. E-mail support is provided at support@kadonk.com 

http://www.kadonk.com/Help
http://forum.kadonk.com/
mailto:support@kadonk.com
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3 KaDonk Products 
KaDonk's LiveProject client is available as several solutions: 

• LiveProject Free Viewer (LPFV) 

• LiveProject Premium Viewer (LPPV) 

• LiveProject Team Viewer (LPTV) 

• LiveProject Project Collaboration (LPPC) 

Each LiveProject client solution, starting at the top going down offers more features than the previous.  

LiveProject Free Viewer: This is our basic Project Viewer, which allows you open and view Microsoft Project ® mpp 
project files. It has no expiration, and allows you to view task and resource information, as well as Gantt Charts. 

LiveProject Premium Viewer: This solution offers additional features, such as the ability to encrypt project files, and 
restrict access to certain fields. You can safely distribute your projects to external clients, who can open them using 
LiveProject.  Among other features it also includes Calendar View and Auto-Filtering on columns to enable you to 
quickly find the information you need.  

LiveProject Team Viewer: In addition to the Premium Viewer features, the Team Viewer allows users to login to a 
LiveProject Server account, and open project files and document from shared folders. For users that will not make 
changes to shared projects, this solution is an affordable way to share information with external teams or management. 

LiveProject Project Collaboration: Fully featured, this solution allows you to upload files and projects to the LiveProject 
Server account. It also allows you to make 'suggestions' to project plans (Edit, add and delete tasks), which are 
accepted by the Project Manager. This solution is our most powerful, as each team member can see pending changes 
to project plans, and update the plan 'live' with the latest information. It is available without complicated IT 
deployments; just download LiveProject to the team member's computers, and go. 

Because of the different LiveProject client versions, not all features are available in all versions. To help you navigate 
this manual, each feature will be marked with the abbreviation of each version in which the feature is available. 

In addition to the LiveProject client above versions, KaDonk also offers an in-house server for mission-critical customers: 

• LiveProject Collaboration Server (LPCS) 

Please contact sales@kadonk.com to learn more about our LPCS Solution. 

 

mailto:sales@kadonk.com
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3.1 How to find your version of LiveProject 

After you start LiveProject, select the menu Help > About LiveProject.  

3.2 Upgrading LiveProject 

Any LiveProject installation with a version number of 3.0 or higher is capable of running as any of the LiveProject client 
solutions listed above. You do not need to re-install or download a new version of LiveProject.  

Upgrades can be purchased on the KaDonk Website. When upgrading, you will receive an e-mail with detailed 
information about your purchase. 

LiveProject Free Viewer version 3.0 or later is free only for personal use, students, or non-profit organizations. 
For commercial use, you must upgrade to Premium Viewer, Team Viewer or Project Collaboration. 

3.3 More Help 

If you have any problems not addressed by this manual, we recommend checking out the LiveProject online FAQ, which 
always has the latest information available. You can also browse our website, or use the new 'help' tab inside 
LiveProject (requires an internet connections). 

http://www.kadonk.com/restricted/CreateOrder.aspx?forcelogin=true
http://forum.kadonk.com/index.php?showforum=14
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4 Installation 
LiveProject is installed from this location: 

http://www.kadonk.com/download/  

You have two options for the installation: 

• Using an MSI installer, or 

• Using Microsoft ClickOnce technology 

4.1 MSI Installer 

For some users, or for IT managers that wish to roll out LiveProject to a group of people, the MSI installer is a better 
solution. In a few cases some users have experienced problems with ClickOnce, but been able to install using MSI 
without any problems.  

4.1.1 Command Line Options for MSI Installer 

In addition to the standard MSI command options, this installer has a number of custom parameters to help you out: 

• DISABLEUPDATEUI=1 will remove the update checks from LiveProject allowing you to control updates 
manually. 

• PERMACHINE=1 will make the file associations to be added for all the users on the given machine instead of 
just for the current user. 

• DISABLELOGINPROMPT=1 will disable the initial login prompt shown to the user the first time LiveProject is 
started. 

4.2  Microsoft ClickOnce 

For most users, the first option is the easiest. ClickOnce will install everything needed to run LiveProject, using a 
standard installation procedure.  

4.3 Uninstalling LiveProject 

To uninstall LiveProject from your computer, follow these steps: 

• Open Windows Control panel 

• Select "add or Remove Programs" 

http://www.kadonk.com/download/
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• Find the entry named "LiveProject" and click the "Change/Remove" button 

• Select the option "Remove the application from this computer" and click OK 

On some Windows installations LiveProject installed using ClickOnce will not show up in the program list. In this case, 
LiveProject can be uninstalled by running the following statement in the Windows Start Menu > Run textbox (for Vista 
this is the text box with the text Start Search): 

rundll32.exe dfshim.dll,ShArpMaintain LiveProject.application, Culture=en-US, PublicKeyToken=dc96a37df9fbea78, processorArchitecture=msil 

If you are still experiencing problems, we have created a specific uninstaller that you can download: 

http://liveproject.kadonk.com/download/LiveProjectUninstaller.exe 

If you decide that LiveProject is not right for you, we would like to know why so we can improve. Please let us know 
how we did by sending us an e-mail at support@kadonk.com. 

 

http://liveproject.kadonk.com/download/LiveProjectUninstaller.exe
mailto:support@kadonk.com
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5 Running LiveProject 
Once installed, you can run LiveProject from the windows program menu where it is stored under the folder KaDonk. 

Each time LiveProject launches, it will check if there is a new version available and prompt you to upgrade. We 
recommend that you accept the upgrade each time as it may contain important bug-fixes or new features.  

Note: You can disable automatic update checks from Tools->Options->Updates. 

5.1 Username and Passwords 

 

Figure 1 - Login 

LiveProject Free Viewer and LiveProject Premium Viewer do not require that you enter a username/password.  

LiveProject Team Viewer and Team Collaboration both require that you have an E-mail and Password to use the extra 
features. 

If you are unable to login to LiveProject, first make sure you have a valid license: 

• The person who first signed up for your LiveProject account is the Root Administrator. The Root Administrator 
can invite more users through the "Manager Users" tab of LiveProject. 

• Users that are invited by their manager will receive an e-mail from support@kadonk.com with download 
instructions, as well as their e-mail and temporary password. If your manager has invited you, but you have 
not received this e-mail, please check your SPAM filter and make sure that e-mails from support@kadonk.com 
are allowed through. 

 

mailto:support@kadonk.com
mailto:support@kadonk.com
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If you have your e-mail and password but LiveProject is refusing your login it may be due to your clock. LiveProject 
server has strict rules to minimize the chance of spoofing (hackers). As an effect of this, it will not accept requests from 
the 'future', or requests that are too old. Try setting your clock back a few minutes to ensure it is set exact, and then try 
logging in again. If you version of Windows supports it, you can also choose to synchronize your clock with an Internet 
Time Server, which should completely eliminate the problem. 

Return to the KaDonk webpages for more information on project management and LiveProject in general. 

5.1.1 Running in Free Viewer Mode 

You can run LiveProject as a Free Viewer, by clicking the Skip login – Free Viewer button on the login dialog (See 
Figure 1).  

http://www.kadonk.com/
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6 The Big Picture! 
Before we start explaining Team Features in detail, it's worthwhile to provide a big picture on how LiveProject works. 

When you share documents and projects through LiveProject, they are in fact stored on a central LiveProject Server that 
is typically maintained by KaDonk. This allows al users on your account to see the files that are uploaded, and to view 
or download them. Figure 2 shows an overview of the architecture. 

 

 

Figure 2 - How LiveProject works 

In the corner, a manager uploads a project plan he has been working with locally. His team, which can include 
external partners or remote offices use LiveProject to see the shared project. They can not only view it, but using 
LiveProject Project Collaboration, they can also make suggested changes to the project. These changes are also stored 
on the LiveProject server, and instantly become visible to all the LiveProject Participants. 

 



LiveProject User Manual 

Page 14 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com

When the Manager is ready to review the changes, he uses LiveProject to accept or reject them. Upon completion, 
LiveProject updates his local project plan with all the accepted changes, and then uploads the file to the LiveProject 
Server. When that is complete, the entire team can see the changes to the project plan, including highlights of accepted 
and rejected changes. 

 

Figure 3 - Project Collaboration Flow 

Figure 3 illustrates the cycle of updating the local project file, publishing to the server, and reviewing team members' 
suggestions to the project plan. In day-to-day work, this is all automated by LiveProject. LiveProject automatically asks 
the manager to update, automatically updates viewers on the team members' computers, and automatically notify the 
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manager of pending changes. It even loads and updates the Microsoft Project Plan with a single click, before 
publishing the new file to the server for all to see. 

While Figure 3 may initially look complicated, there are really just a few steps to take from your perspective: 

1. Upload the original file 

2. Open a viewer to see the project, and make suggestions. 

3. Accept and reject changes 

LiveProject automatically shares the suggestions, highlights changes, shows notifications, uploads and checks for new 
versions of the project plan, and shows new versions of the plan for the team without any prompting. 

Using LiveProject provides instant communication for your project; eliminates the need for Microsoft Project installations 
for your team, and keeps everyone informed, organized and on schedule. 
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7 Getting Started Using LiveProject Now! 
While we recommend that you read the entire manual, we know that you are busy and just want to get started. This 
section is for you, and will have you up and running in a few minutes. 

7.1 View 

When you are first viewing your projects you will notice that all tasks have been color coded. To get a complete 
explanation of each color you see, right-click on the project viewer and select Show Legend: 

 

Figure 4 - Colors and symbols used in LiveProject 

Note: Since version 3.1 you can configure these colors, and even make colors conditional on task information. See 
section 9.15. 

7.1.1 Viewing local files 

Products: LPFV, LPPV, LPTV, LPPC 
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To view a Microsoft Project files that is stored on one of your local drives, select from the menu File > Open Project File 
> Open Local Project File. Then select your project file, and LiveProject will open it up in a new project viewer tab. 

 

Figure 5 - File Menu 

7.1.2 Viewing shared project files 

Products: LPTV, LPPC 

To view a Microsoft Project files that is shared on the LiveProject Server, select from the menu File > Open Project File > 
Open Project file from Server. Then select your project file, and LiveProject will open it up in a new project viewer tab. 

7.1.3 Viewing a Bugzilla Database 

Products: LPFV, LPPV, LPTV, LPPC 

To view a Bugzilla Database, select from the menu File > Open Bugzilla Viewer. Then define your Bugzilla account and 
the filtering to use and LiveProject will open a viewer with the selected filter results in a new Bugzilla Viewer tab. 

7.2 Share 

Products: LPTV, LPPC 

To share documents (including project plans) on the LiveProject Server, open the Explorer Server tab. Here you can 
right-click on a blank area to create folders and import files. You can also see folders and files your manager may have 
shared with you. See also page 18. 

Double-clicking on a project plan will open up a new project viewer tab showing the plan. 

7.3 Collaborate 

Products: LPPC 

LiveProject Project Collaboration allows you to collaborate on Microsoft Project MPP Project plans. The changes that are 
made, we call 'suggestions', because they won't enter into the project plan before the manager approved them 
explicitly.  Using LiveProject Project Collaboration you and your team can edit project tasks, add new tasks and even 
delete tasks. Again, note that no changes will be made to the original project plan, until the manager accepts the 
pending suggestions. 
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To get started you need to perform these three steps: 

1. Upload one or more MPP Project Plans to LiveProject Explorer (Page 18) 
2. Invite your team members to join your LiveProject Account (Page 19) 
3. Start making suggestions to your project plans (Page 19) 

Once your team has started making suggestion, you (as a manager) will need to accept or reject the pending 
suggestions: 

• Manage Project Suggestions (page 40) 

7.3.1 Upload projects and files to LiveProject Server 

To use LiveProject Project Collaboration your must first add one or more project files (.mpp project files) to the 
LiveProject Server. 

Adding projects to the server allows you and your team to start collaborating on the projects, making suggestions to the 
plan. 

To add a project file, click on the Explore Server tab in the main window: 

 

Figure 6 - LiveProject Explorer 

This view shows an account with many files and folders. If you just started, your explorer tab is blank. 

To add a project file (or any other type of file or folder), you have two options: 

1. Drag and drop the file directly into the right side of the explorer window. LiveProject will start uploading it to 
the server automatically.  
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2. Right click in the right rise of the explorer window to show the context-sensitive drop-down menu. Select New 
Resource > Import File to add a file or folder.  

LiveProject will show a window with the upload progress. Once all your file uploads have completed, the explorer 
window will update to show your files. 

You can now double-click on an .mpp project file to open a project viewer. 

7.3.2 Invite Users to Account 

Note: You need to be an Administrator or have sufficient rights to invite other users. Each user requires one license on 
the server, and each account has a number of licenses that match their purchase. 

LiveProject Project Collaboration makes it easy to invite more users to your account: 

1. Open the Manage Users tab in the main window  
2. Click on Invite Users from the top left toolbar strip  
3. Enter the e-mail addresses of the users you with to invite. You may separate the users by comma, semicolon, or 

newline.  
4. Click Invite  

LiveProject will send e-mail invitations to the users you have invited. Make sure that e-mails from kadonk.com are 
allowed through your SPAM filters. Otherwise your team may not get invitations to join your account. 

Each e-mail contains the user's temporary password, as well as download instructions for LiveProject. 

Users can be listed as having the following status: 

• PENDING. The user has not yet accepted, received or logged into LiveProject. 

• PERMANENT. Users have successfully logged into LiveProject at least once. 

7.3.3 Suggest Changes on Project 

Collaboration on projects only works on project plans stored on the server, and requires LiveProject Project 
Collaboration. You cannot collaborate on local project files. 

To setup collaboration everyone on your team must: 

• Have LiveProject installed, and invited to your account. 
Inviting someone generates an e-mail that also contains download instructions for LiveProject.  

• Have access to your project file on the LiveProject Server. By default all users has access. 
• Have an open Project Viewer that shows your project plan. 

To open a project viewer for a project plan stored on the LiveProject Server simply double-click on the project 
file in the explorer tab.  
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7.3.3.1 Making Suggestions 

To make suggestions to a project plan, double-click on a task. The task will change color to white, and you can edit the 
task information in what we call 'inline mode': 

 

 

Figure 7 - Making suggestions to a project plan in 'inline' mode 

In this mode you can make changes to the task quickly and easily. The comment field shown here is used for any 
comments that you with to discuss with the manager. Click "Done" when you have completed your edits, and added 
your comments. 

Pressing the Task Information button brings up more detailed information, where you can continue the task editing: 
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Figure 8 - Task Information Window 

Edited fields are highlighted in yellow as shown above.  

When you have completed your edits, the suggested changes are sent to the LiveProject Server. They are also 
highlighted for other users to see. 
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8 Viewers in General 

8.1 Common features for Project and Bugzilla viewers 

A viewer is a window that contains information you want to view. Currently the following types of viewer exist: 

• Project Viewers (Page 23) 
• Bugzilla Viewers (Page 33) 

Viewers have the following things in common: 

• Right-Click anywhere in the viewer to show the drop-down context menu. 
• Each viewer has a menu item called Configure Viewer. It will contain several tabs, depending on the type of 

viewer.  
• Viewers all show a status bar in the top-right corner, indicating the current state of the viewer.  
• You can create a new viewer the Main Window, by using the menu File > Open...  
• Viewers continuously monitor their source data, either locally on the LiveProject server for changes, and update 

themselves automatically.  
• All viewers run in their own tabs/windows. If you exit LiveProject, the location and content of its viewers will 

be stored, and they will re-appear in the same location next time you start LiveProject. Detached viewers can 
be minimized and maximized. The state of the window is remembered when LiveProject shuts down, and 
maintained when LiveProject starts up again  

Whenever you start a viewer we recommend that you leave it open. LiveProject will keep it up-to-date, and load it each 
time LiveProject starts up 
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9 Project Viewers 

 

Figure 9 - LiveProject Free Viewer 

9.1 Using a Project Viewer 

A Project viewer is comprised of three panes: Project Tree on the left side, Project Overview on the top right, Task 
Details on the bottom, and Gantt chart on the right side. Furthermore it has three tabs; Tasks, Calendar and 
Resources. 

9.2 Project Tree 

The Project Tree can be used to select the part of the project plan that is shown in the Project Overview and the Task 
Details. Selecting the top task will show the entire project, while selecting a subproject or a single task will show the 
details and the status of that subproject/task. 

Tip: To quickly hide or show the Project Tree, click on the Hide/Show to the right of the Project Tree at the top of the 
viewer (Figure 10). 
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Figure 10 - Show/Hide Project Tree 

9.3 Project Overview Bar 

The Project Overview shows a view of the selected project, subproject or task. This bar is a quick way to get an 
overview of an entire project at a glance.  

 

Figure 11 - Project Overview Bar 

The bar shows the timeline, which will auto-scale to best fit the duration. It may show days, weeks, months or years 
depending on the space available. 

• The Blue triangle represents current time (now).  
• Green parts of the bar represents completed work  
• Yellow parts of the bar represents not-completed work  
• The black rectangles represents milestones on the project  
• To get more information on the bars and/or milestones, simply right-click on a bar or milestone, and the drop-

down box will tell you the name(s) of milestones, and various other information.  

On Figure 11, you can quickly see that the project is significantly delayed (The green bar does not extend all the way 
to the blue marker). 

Tip: To quickly hide or show the Project Overview, click on the Hide/Show at the top right corner of the viewer. 
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9.4 Task Details 

Task Details shows the tasks in detail for the selected project, subproject, or task and optionally filtered by the selected 
resource (see below). You can also sort tasks by clicking on the desired column header. 

• Double-click on a task to show the Task-Edit window.  
• Tasks are color-coded to provide a quick-overview of their status. Select menu Project > Show Legend to see 

what the colors mean.  
• Right-Click on any task to show the Context Sensitive menu  

9.5 Context Menu 

Most of the actions available when viewing a Project file can be accessed from the context menu: 

 

Figure 12 - Project Viewer Context Menu 

A subset of this functionality can also be found from the Project Menu. 

9.6 Add new task 

Create a new task, which will be sent to the manager for approval as a suggestion to the project. 
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9.7 Edit "Task name" 

Opens the Task Information window, which allows the user to edit the task information. Another way to edit a task is to 
double-click on it in the viewer itself. That will turn on "inline mode" where you can instantly edit the visible fields. 

Note 1: Some tasks are not editable, in which case the OK button will be disabled. The window will still open so you 
can see the details of the task. 

Note 2: Some tasks can only have some fields edited (Such as summary tasks). The other fields are disabled on 
purpose to avoid sending illegal suggestions. 

Note 3: Please be aware that LiveProject depends on Microsoft Project to accept your changes. If the Project is 
configured in such a way that your suggestions are illegal, contact your manager. A good test is to perform your 
suggestions manually in the Microsoft Project directly, and see if the suggestions are acceptable. In case of a conflict, 
please let us know.  

9.8 Delete Task 

When deleting a task, you will be presented with the Delete task window. You can add a comment along with your 
suggestion for deletion. As with all suggestions, delete task suggestion will go to the manager for approval before the 
project is modified. 

 

Figure 13 - Suggest a task for deletion 

9.9 Secure Project 

LiveProject allows the creation and viewing of 'Secure Project Files'. Secure project files are encrypted and access to 
them is protected by a password. Additionally, the manager can configure which Project fields should be visible and 
which ones should be hidden. For example, the manager can choose to hide all cost columns. 

Note: Viewing and creating secure projects requires LiveProject Premium Viewer or above. 
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9.10 Suggestions 

Suggestions are changes to a project made by team members. We call them 'suggestions' because they are not actual 
changes to a project plan, but rather suggestions that are visible to the team while pending manager approval. The 
project plan will never be updates without the manager reviewing pending suggestions and accepting them explicitly. 

While suggestions are pending, they will be show in the project viewer in one color (See the legend for a color chart). 
Once they are accepted or rejects by the manager, they will become part of the project plan, but continue to be 
highlighted for a period of time to indicate they have changed status. 

The following menus provide a way for users to 'clear' these suggestions in various ways. 

• Cancel pending suggestions for "task name" 
This menu item is only visible if the task has any pending changes. In that case, selecting this menu will cancel 
them (if the user has the rights to do so). 

• Clear all completed suggestions 
Clear the coloring for completed suggestions in the task table.  

• Clear completed suggestions for "task name" 
Clear the coloring for completed suggestions for this task only.  

Tip: The length of time a suggestion is highlighted can be changed via the Context Menu Configure Viewer > 
Suggestions. 

9.11 Reset Sort 

Resets the sorting to 'no sorting' or to the sorting defined by the current active filter. 

9.12 Open with MS Project 

Selecting this menu will attempt to launch the Project file in Microsoft Project ®. If you do not have Microsoft Project ® 
installed, this will fail. 

• If you are the Manager of the project, LiveProject will launch the original project file, from the location it was 
published from. If the file cannot be found, you will be asked to re-map it to a local file.  

• If you are not a manager, LiveProject will prompt you for the file to open (Assuming you don't have access to 
the original project at the exact same location as your manager).  

9.13 Project Details 

Open the Project Details window with more information about the Project.  
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9.14 Show Legend 

Open a window with the Legend of the project color codes and Gantt chart information. 

9.15 Configure LiveProject Colors 

Products: LPFPV, LPTV, LPPC 

You can configure the LiveProject colors, and even make them dependent on task information. To get started, select 
Tools > Customize LiveProject Colors from the main menu. 

 

Figure 14 - Edit custom colors 

In this window, you can click on each color to change it.  

At the bottom, you can create custom rules to color your projects. Here are shown two rules; One colors critical tasks, 
and one completed milestones. 
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9.15.1 Edit Custom Color Rules 

Select the "add new custom color rule" to add a new rule: 

 

Figure 15 - Edit Custom Colors Rules 

Here you can specify which fields, and what values that trigger a color. On Figure 15 the Completed Milestone task 
will color tasks green when the milestone field is true, and the complete field is true. 

9.16 Calendar View 

The second tab of the project viewer contains the calendar view (Figure 16). The Calendar view shows how tasks are 
distributed over time, and allows users to get an overview of the project in terms of concurrent work mapped to days. 

Through the Context menu (Mouse Right-Click) a number of options are available: 

• Fit to window 

• Task list 

• Go to 

• Timescale 

• Text styles 

• Bar styles 

• Zoom 
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These options will be explained in the following sections. 

 

 

Figure 16 - Project Calendar View 

You can re-size columns and rows to fit the task lists. Clicking on the two arrow buttons at the top right will scroll the 
calendar back and forth a month at a time. 

9.16.1 Fit to window 

Selecting Fit to Window will automatically re-scale the calendar view to fit to the current window size. Because it is 
possible to drag and resize columns and rows, this is a handy function to quickly get back to default. 

9.16.2 Task list 

Show a full task-list for the date selected. 
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9.16.3 Go to 

Jump to a specific task, or a specific date. 

9.16.4 Timescale 

Configure headings, week preferences, overflow indicators, patterns and colors for the top and bottom rows, and 
shading options for the calendars. 

An 'overflow' is when there are too many tasks on any given date to be fully shown. 

9.16.5 Text styles 

Change the text styles (font styles) on various types of tasks, such as: 

• Non-critical and critical tasks 

• Milestone tasks 

• External Tasks 

• Daily titles 

• … 

9.16.6 Bar styles 

Change bar styles such as type of bar, colors, patterns, shadow and fields on tasks types such as noncritical, critical, 
milestones, summary and more. 

9.16.7 Zoom 

Zooms the calendar to show a specific interval, such as a week, month, 4 weeks, or custom. 

 

9.17 Resources 

The last tab on the project viewer shows the resource table (Figure 17). 

On the resource table is shown a list of all the resources working on this project. Over-allocated resources are shown in 
red, while resources with no work to be done are shown in green. Other resources are shown in yellow. 
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Figure 17 - Resources 
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10 Bugzilla Viewers 

10.1 Adding a new Bugzilla Viewer 

In order to add a new Bugzilla Viewer, you must select a Bugzilla Account, and a Bugzilla Filter. If none is available, 
click on the Manage accounts or Manage Filters buttons to set them up: 

 

Figure 18 - Setting up a new Bugzilla viewer 

10.2 Using a Bugzilla Viewer 

 

Figure 19 - Bugzilla Viewer 

With a Bugzilla Viewer, you may: 

• Double-Click on any entry to launch a detailed view of all fields.  
• Right-Click on any bug to show the Context Sensitive menu, with these specific Bugzilla menu items:  

o Create new bug  
o Edit Bug #  
o Launch Bugzilla  
o Configure Viewer  
o Edit Account  
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o Select Account  
o Edit Filter  
o Select Filter 

A subset of these menu items also can be found on the Bugzilla Menu. 

10.3 Create new bug 

Launches Bugzilla in your browser at the "Enter Bug" page. 

10.4 Edit Bug #XYZ 

Launches Bugzilla in your browser at the bug on which you clicked. 

10.5 Launch Bugzilla 

Launches Bugzilla in your browser at the Bugzilla account homepage you have specified. 

10.6 Configure Viewer 

Configure Viewer 

10.7 Edit Account 

Allows you to edit the Bugzilla account currently used in the viewer. 

10.8 Select Account 

Shows a drop-down list of your configured Bugzilla accounts. By selecting an account, the viewer will reload its data 
using the same filter from the new account. 

10.9 Edit Filter 

Allows you to edit the Bugzilla filter currently used in the viewer. 

10.10 Select Filter 

Shows a drop-down list of your configured Bugzilla filters. By selecting a filter here, the viewer will reload its data using 
the same account but applying the new filter. 

 



LiveProject User Manual 

Page 35 of 45 

© 2008 KaDonk, Inc. 

 
KaDonk Address: 12902 Dorathea Terrace, Poway, CA, 92064, USA 
 Phone: +1 (888) 4-KADONK (452-3665) | WWW.KADONK.COM | E-mail: support@kadonk.com

11 Explore Server 
LiveProject explorer can be started by: 

• From the Main Window  
• Using the System Tray Icon  

Sometimes, LiveProject will prompt you to select a file from the server. For example, it might prompt you when adding a 
project viewer, in which case you also will see the LiveProject Explorer window. When prompted, the full functionality 
of Explorer may not be available. 

 

Figure 20 - Explorer Tab 

The LiveProject Explorer window shows a view of the files and folders stored in your company account on the 
LiveProject Server. 

Note: Some of the following functionality requires that you have sufficient rights to perform the operation. 

• You can drag and drop files into and within the LiveProject Explorer window, directly from your local desktop 
or file system.  

• You can download files and or folders by selecting them in the LiveProject Explorer window and then selecting 
Download from the right-click context menu.  

• You can rename files and folders.  
• You can right-click for a context-sensitive menu, which allows you to:  

o View project files (mpp project files only).  
o Create a new folder via the menu New Resource > Folder  
o Import files via the menu New Resource > Import file  
o Delete and download files  
o View properties for the files  
o Show revision log. See below. 
o Secure Project – allows you convert this resource into a secure project. 
o Secure Project Settings. See below. 
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o Publish files. See below.  
o Copy to an existing shared file.  
o Mangers only functionality: 

 Assign access-rights to folder through the right-click context menu on a folder > Access 
Rights. 

 Select a new manager by right-clicking on a file and selecting Properties, then click the 
Change Manager button. 

 Share a file by right-clicking on a file and selecting Properties, then check the check box 
'Allow file to be edited by others'. This will allow other users to overwrite and update the 
file. 

11.1 Shared files 

Sharing a file allows other users (other than the manager) to overwrite and update the file by right-clicking on a file and 
selecting Copy to <filename> or by drag and dropping a file. The users must still have write privileges for the given 
folder. Only the manager of the file is allowed to change the name or delete the file. 

You can easily spot a shared file by the icon. 

 

Figure 21 – Allow file to be modified by other users 

11.2 Publish files 

Publishing a file involves copying the original file, from its original location, to the LiveProject Server. LiveProject is 
aware of each file's original location, so in Explorer you may select the file and publish it via the context-sensitive right-
click menu.  

Note: LiveProject will monitor local files for changes. If you are a manager of a file and you edit your local copy, 
LiveProject will prompt you to publish it to the LiveProject Server. If you do not publish, no one will be able to see your 
changes. You can publish at any time manually via the explorer window. 

When publishing, LiveProject will also ask you to provide a commit message for this change. This message will be 
associated with this given change into the revision history. 
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Figure 22 - Commit message 

11.3 Show Log 

LiveProject provides automatic version control for files stored on the server. You can see the revision history by clicking 
on the Show Log context menu item for a given resource in the LiveProject Explorer. 

From the revision history you can also choose to download old revision. 
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Figure 23 - Revision history 

11.4 Secure Project Settings 

If the selected resource is a secure project this option can be selected to modify the secure project settings. 
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Figure 24 - Secure project settings 
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12 Manage Project Suggestions 
To manage project suggestions, you can: 

• Use the System Tray Icons  
• Use the Manage Project Suggestions tab from the Main Window  

You will see a window listing the projects you are a manager for with pending suggestions. 

Note: Projects with no suggestions and projects you are not managing are not listed. You also need to be logged in to 
review suggestions.  

 

Figure 25 - Manage Project Suggestions Tab 

In this example, I am a project manager Project Acme.mpp. This project has 1 pending new task, and 2 suggestions to 
existing tasks that I need to review. 

Click in the project you wish to manage to review the suggestions. The bottom part of the window (as shown below) will 
become populated: 
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Figure 26 - Manage Project Suggestions - View suggestions 

12.1 Reviewing suggestions 

At the bottom of this dialog, you can control what to view, and whether to show existing project values, or suggested 
project values.  

The Manage Suggestions buttons allows you to make quick decisions that will affect all pending suggestions. This is 
typically what you will do when approving or rejecting suggestions.  

You can also click on each task individually to show extended information about each suggestion on each field. Using 
this method is slower, but you will be able to accept or reject each field individually. 

12.2 Update Project 

When you have done reviewing the suggestions, click OK to update the project. You must have Microsoft Project 2000, 
2003 or 2007 installed on your machine for this to work. LiveProject will open the local project file, make all the 
changes to the plan that you approved, close the local project file, and prompt you to upload it (Publish it) to the server. 

Once the new project file is published, your entire team will be able to see the new project plan automatically, and 
each decision you made will be highlighted in the plan. 
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13 Manage Users 
To open the Manage Users tab, click the Manage Users tab from the main window  

Note: You can only manage users if you have the rights to do so. 

 

Figure 27 - Manage Users Tab 

13.1 User Status 

A user can be in either of these two states: 

• PENDING 

• PERMANENT 

A user is in PENDING state after first being invited by a manager, and does not reach PERMANENT state until he has 
successfully logged into LiveProject the first time.  

If you invite a user and he remains in PENDING state it could be because the e-mail address was wrong and he never 
got the invitation, or perhaps the e-mail was being caught by a SPAM filter. As a manager, you can always delete 
PENDING users and re-invite them. 

13.2 Actions 

13.2.1 Apply Changes 

Apply the changes made to the users. 
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13.2.2 Reset Password 

Clicking "Reset password" will reset the currently selected user's password! 

1. The password is reset on the LiveProject Server to a random one.  
2. A new e-mail with a new temporary password is sent to the e-mail address of the user.  
3. The user's status is set back to PENDING.  
4. The user will be prompted to change his password on his next login attempt.  

These steps are similar to what happens if the user resets his own password, using his security question and answer. 

13.2.3 Delete User 

Clicking "Delete user" will permanently remove the user from LiveProject. You can of course invite the user again if 
need be, but internally in LiveProject, that will be considered a new user. Use with caution. 

13.3 Rights 

13.3.1 Invite other users 

Users with rights to invite others can invite other users to join LiveProject. This may affect your account, as each 
registered user takes up one license. Usually only managers should be allowed to do this. 

13.3.2 Edit other users 

User can edit other user's information, such as name and e-mail. Usually only managers should be allowed to do this. 

13.3.3 Delete other users 

User can delete other user's accounts. This will free up a license (unless the account was pending, in which case it does 
not occupy a license in the first place). Usually only managers should be allowed to do this. 

13.3.4 Edit own E-mail 

Allow the user to edit his or her e-mail address. This could be prevented for security reasons. 

13.3.5 Administrator 

User is an administrator and is given extended rights within LiveProject in addition to having the rights to invite, edit 
and delete users. For example, an administrator can delete resources belonging to other managers. Only administrators 
can assign other administrators. Please use with care. 
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