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What Is Celtx?

Taken from "Celtx - An Introduction" 

Celtx is the world's first fully integrated software for Pre-Production and collaboration of film, theatre, radio, AV 
and comics. It has all the tools media creators need to bring their stories to life while combining intelligent 
writing and planning tools, storyboarding, and scheduling with internet-friendly technologies. Celtx is available 
as a free download from our website. This open source client software is augmented by Celtx Studios, a set of 
integrated web services delivered by the Celtx server. Together they make Celtx the most complete media pre-
production software program. 
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28.  Glossaries
29.  Past Release Notes
30.  Portable Celtx

This Wiki currently reflects instructions for versions 1.0 +. Not all the information is up to date so some instructions may be 
wrong. If you encounter any issues please feel free to ask questions about using Celtx on our forum. 

The latest version of Celtx is the 2.7 release, issued January 4, 2010. Please bear with us as we continue to update the 
documentation for this latest release. Celtx 2.7 is compatible with Windows XP/Vista /7, Mac OS X, and Linux.

For additional info on v.2.7, head to the new Feature Tours on the Walkthrus and Tutorials page.

Celtx logo

Welcome to Celtx!

This wiki manual is intended to provide our users with everything there is to know about Celtx. The information currently provided reflects the features of the desktop versions 1.0 and 
2.0, and The Celtx Studios. The Manual is written primarily from a Mac perspective, but for the most part all features function similarly to those on Windows. Any obvious differences 
should be included, but if we've missed something... anything at all, please feel free to create a wiki user account and contribute your knowledge, or let us know by contacting us at 
Customer Support and we'll be sure to update. 

Your suggestions and feedback... the good and the bad... are always encouraged. 

THANK YOU for using Celtx!! 

Enjoy! 

The Celtx Crew 

Sheila, Steve, Laurie, Tony, Greg, Chad and Mark 

Introduction 

Welcome to Celtx, the world's first client-server web based application designed for the Pre-Production of film, television, theatre and animation. Celtx helps Creators bring their story 
ideas to life – combining intelligent writing and media planning tools with Internet friendly technologies to create a new, open standards platform for the pre-production of Media. The 
software provides features for generating story ideas, writing narratives as well as properly formatted film scripts, and completing media rich breakdowns of a project that can be saved 
where you want with a standard folder system, and shared with team members to foster Collaboration. 

Celtx is available as a free download from the our website www.celtx.com. This open source client software is augmented by Celtx Studios, a set of integrated web services that are 
delivered by the Celtx server. 
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System Requirements

Celtx v.2.0 (based on Firefox 3.x) 

WINDOWS 

●     75 MB of free disk space 
●     Windows 2000 
●     Windows XP 
●     Windows Server 2003 
●     Windows Vista 

Minimum Hardware 

●     Pentium 233 MHz (Recommended: Pentium 500MHz or greater) 
●     64 MB RAM (Recommended: 128 MB RAM or greater) 
●     52 MB hard drive space 

MAC 

●     75 MB of free disk space 
●     Mac OS X 10.4.x 

Note to MAC Panther (10.3) Users - The latest version of Celtx (v.2.0) is not compatible with the MAC OS X 10.3.0 operating system. On moving Celtx to the new Firefox 3.0 code 
base, we are no longer able to support 10.3 (or earlier) versions of the MAC operating system. 

●     Version 1.0 For Mac OS X 10.3.x users is available for download here. 

Minimum Hardware 

●     Macintosh computer with an Intel x86 or PowerPC G3, G4, or G5 processor 
●     128 MB RAM (Recommended: 256 MB RAM or greater) 
●     200 MB hard drive space 

LINUX 

●     Linux kernel - 2.2.14 or higher with the following libraries or packages: 
❍     glibc 2.3.2 or higher 
❍     XFree86-3.3.6 or higher 
❍     gtk+2.0 or higher 
❍     fontconfig (also known as xft) 
❍     libstdc++5 

●     Gnome (recommended) 
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●     75 MB of free disk space 
●     NOTE: an up to date Linux distribution is recommended 

Minimum Hardware 

●     Intel Pentium II or AMD K6-III+ 233 MHz CPU (Recommended: 500MHz or greater) 
●     64 MB RAM (Recommended: 128 MB RAM or greater) 
●     52 MB hard drive space 

Internet Connection & Networks

If you are experiencing connection or network issues, ensure your network/firewall is not blocking the Celtx server which could be considered a 'non-approved host'. Access to the Celtx 
server is over a SSL connection, so access to an encrypted connection must also be allowed. 

At a minumum, for TypeSet to work you need to allow HTTPS (port 443) access to render.celtx.com. For upload/download (etc.), the client needs HTTPS access to publish.celtx.com. 

If you connect to the internet via proxy, ensure the proxy settings are correct in the client preferences/options. 

The Technology - XUL, RDF, Moz framework. 

Built on top of the award winning Firefox technologies, Celtx is an open source and open standards software application. Celtx is built using Firefox's XUL Mozilla application 
framework. The application uses a semantic web compliant RDF database and XML file formatting. 

As a client-server application Celtx is Internet aware and also provides off-line access. This provides the best of both worlds - giving users desktop client behavior coupled with Server 
based intelligence. Celtx users can access managed web services like enhanced data security, remote file back-ups, and special server features like auto-formatting for PDF printing. As 
a "stand-alone" application. Celtx data is stored on the user's own computer; which means that users can access their Projects while off-line. 

Cross Platform Compatibility 

Celtx is designed to work on all major operating systems - Mac, Linux and Windows. Celtx is available for free download from the Celtx website, under an open source license. 

Features Summary

WRITING TOOLS

Story Development Forms
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Celtx helps you develop your story with preloaded forms for key elements like locations, scenes, props, characters, and 32 other production categories. You can use the forms to 
organize your thoughts and kick-start a media rich storyline that includes sound files, images and video clips. Celtx story development forms are intelligently tied into your script, 
informing the story and each scene with valuable production information. 

Scripts

Celtx includes six dedicated industry standard editors for writing: 

●     Screenplay 
●     Stageplay - International and US standard 
●     AV scripts - including documentaries, music videos and advertising. 
●     Audio Play - including radio plays and podcasts. 
●     Comic Book 
●     Plain Text 

Celtx includes the essential features that writers need to keep their fingers moving - like intuitive formatting, text auto-complete, page breaks, dual column dialog, scene management, 
scratchpad, embedded notes, title page generation, pagination, printing, spellchecker, keyboard shortcuts, find and replace, script importing and exporting, PDF and HTML script 
reports, and collaboration. 

Adapt To

With a single click Adapt To converts any fully formatted script of one type into a fully formatted script of another - for example, a Stageplay to a Screenplay - displaying in an instant 
the multi-media potential of your work. 

TypeSet

TypeSet provides precise automatic formatting of your script to industry and international standards. The Celtx server uses the very powerful LaTex typesetting tool to deliver perfectly 
formatted scripts. Full support is provided for optional formatting features like Mores and Continueds, Scene Numbering and paper size. Encryption technology protects every project 
upload & download between the Celtx Server and the desktop. 

Index Cards

Celtx includes reversible, colour coded Index Cards that are intelligently tied to your script and auto populate with the Scene Headers and first 40 words or so of the scene. You can flip 
the cards to type notes on the back, colour code them to track plot lines, and drag and drop them to reorder scenes. 

Template Engine

If the default setting for a Celtx project doesn't fit your needs, you can create your own new, blank state Template that will only open the documents you want. 

PRE-VISUALIZATION TOOLS

Storyboarding

Take your media project to the next level by adding a storyboard based on your script and adding individual or batch images in to the storyboard. Each storyboard image is accompanied 
with a shot description to help you communicate your creative vision. Rearrange images and sequences within the project to construct your visual narrative. Then when you're ready, 
use the slideshow feature to play the images to help pre-visualize your media project. 
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Media Rich Breakdowns

You can add sound files, video clips, digital photos and scanned documents to your project to create a media intensive breakdown. You can then associate the media with any one of the 
36 production categories, including wardrobe, props, and locations. 

ORGANIZATION TOOLS

Catalogs

Catalogs provide a way for you to organize and view the many production items and research details required in the pre-production stage of any media project. Each Celtx project 
includes a Master Catalog which auto-populates as you breakdown your script, ultimately providing a searchable dashboard view of all your story's elements and production items. 
Additional Sub-Catalogs can be created for specific production categories - like props, characters, and wardrobe. 

External Documents

You can add any document from any application to your project - PDFs, budget spreadsheets, images, and scripts written in other applications - to help stay organized. 

Scheduling, Call Sheets and Shooting Reports

Celtx includes a 'Just In Time' Scheduling feature that lets you manage your projects in real time. Open a schedule based on your script and drag and drop scenes to the calendar to build 
your shooting schedule. Generate customizable Shooting Reports to keep track of the resources you'll need during shooting, including lists of props, actors, and wardrobe items. Create 
Call Sheets to ensure your crew knows where and when to show up for the shoot. 

Inter-Project Document Management

You can also drag and drop documents between projects. Grab a document from one Project Library and drop it in to another Project Library and you're done. 

Toolbox

New for v2.0, you can now customize your Celtx application with a suite of new add-on productivity tools. Customization lets you better tailor Celtx to fit your particular needs. 

Note: Are you interested in developing custom tools for Celtx? Check out our developers page for more information. 

PUBLISHING TOOLS

Celtx Forums

You can publish your work-in-progress or completed scripts for public viewing and peer reviews at the Script Reviews & Collaborations section of the Celtx Forums. Register here first 
to access the forums. 

CELTX STUDIOS

New web-based Celtx Studios integrate with Celtx software to provide a cost-saving and professional way to store, manage, and collaborate on your scripts and projects. 
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Celtx Studios are filled with innovative tools you can use to take your creativity and productivity to new heights. 

Contact Info

The development of Celtx is shaped in part by the valuable feedback provided by our user community. So if you have something to tell us or a question to ask, here's how to get in 
touch: 

●     Send us an email directly to mailto:info@celtx.com. 

●     Write us a letter c/o: 

Greyfirst Corporation, P.O. Box 23126, St. John's, Newfoundland, Canada A1B 4J9 

To learn more about Celtx you can also head to... 

Celtx Forum

To request a new feature, report a bug, or ask a question about Celtx or anything industry related, head to the forums. Community members and Celtx moderators are always quick to 
reply. 

Wiki Manual

For the 'How To's" and details on all Celtx features, stay where you are and have a browse around the Wiki . We encourage users to create an account and contribute your Celtx 
knowledge to this new and in-progress guide. 

Feature Tours

Watch our flash based video walk-thrus, we hope this conceptual approach that makes Celtx easier to use. 

FAQs

The FAQs provide a compiled list of responses to 'frequently asked questions' which may address any outstanding queries you have. 

The Celtx Blog

Visit our blog to keep up to date on news and projects that the Celtx team is involved in. 
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Return to Main Page The first step is to download the Celtx installer from our download page. Celtx is available for Windows, Mac OS X / Universal and Linux, in a variety of different 
languages. Download the OS version and language pack that suits your needs. 

For Windows (XP, NT, 2000, Vista)

Double click the CeltxSetup.exe file and follow the installation wizard. The setup will place a shortcut on your Desktop as well as place Celtx in the Start menu. 

If you get a reported problem with: 

"The application has failed to start because MSVCR71.dll was not found. Restarting the application may fix this problem." 

you need to get the files msvcr71.dll and msvcp71.dll. They can be found at http://www.driverskit.com/dll/msvcr71.dll/2373.html and 
http://www.driverskit.com/dll/msvcp71.dll/2371.html (or search for them on Google). The DLLs go in your C:\Windows\system32 directory. 

As with any software downloaded off the Internet, you should be careful installing files from untrusted sources. For the security conscious, the MD5 checksums should be: 

MD5 (msvcr71.dll) = 86f1895ae8c5e8b17d99ece768a70732 
MD5 (msvcp71.dll) = 561fa2abb31dfa8fab762145f81667c2 

From an earlier version

Upgrading from an earlier version to 0.991 sometimes causes Celtx to not start at all. If this happens to you: 

1.  Remove celtx using Add Remove Programs 
2.  Open C:\Program Files and delete the Celtx folder 
3.  Remove the Greyfirst folder from: 

C:\Documents and Settings\[username]\Application Data 
and 
C:\Documents and Settings\[username]\Local Settings\Application Data 
If you can't find it, you need to 'Show hidden files'. From Windows Explorer, pick Tools | Options... | View | Hidden files and folders | 
Show hidden files and folders 

4.  Clear your browser cache. 
5.  Download 0.991 
6.  Install celtx. 

This will give you a clean install of 0.991. 

Vista

If, when you try to write a script, you cant key in anything, then find the Celtx software icon and: 
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●     right click 
●     select 'Properties' 
●     select 'Security' 
●     press Edit 
●     press Add 
●     enter the name of the user 
●     click the "full control" check box 
●     press Ok 

For Mac OS X / Universal

Double click the Celtx.dmg file to mount the drive to your system. Drag the Celtx icon to your Applications folder to complete the installation. 

For Linux 

You can install Celtx by extracting the downloaded archive into your home folder (e.g. /home/yourusername/bin) and run the application from there. But then only this single user will 
have access to it. 

Otherwise, if you want all users to have access to it, Celtx must be installed and run once as the root user. A typical installation from an administrator account is done as follows: 

(copy - Ctrl+C - and paste - Maj+Ins - the following code lines, one by one, in a Terminal window -Ctrl+Alt+T) 

cd /usr/local 

If you are installing Celtx 1.0, then use this: 

sudo tar zxf /path/to/Celtx.tar.gz 

If you are installing Celtx 2.0, then use this: 

sudo tar xjf /path/to/Celtx.tar.bz2 

(enter your password) 

sudo /usr/local/celtx/celtx 

If you get an error error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory then you need to install a package that contains 
libstdc++.so.5. On Redhat and Ubuntu, this is the compat-libstdc++ package. On Gentoo, it's just called lib-compat. You might be able to install it using yum install 
compat-libstdc++ 

Now any user can run it using /usr/local/celtx/celtx. 

If you're running a 64-bit build, ensure the 32-bit libraries are installed. Just search for the string "ia32" within synaptic. You might have to install the normal "ia32-libs" and also "ia32-
libs-gtk", perhaps more. 
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Note to Eee-PC users 

In order for Celtx to work you have to remove the Scim package: 

sudo apt-get remove xandros-scim 

Alternatively, on more recent 701 EeePC (build starting March 08, thus including all 900), gcin replaces scim: 

sudo apt-get remove xandros-gcin 

sudo apt-get remove gcin 

Celtx v1.0 uses too recent a package (glibc) for the vanilla EeePC Xandros distribution. Unless you want to take the risk to mess up with your OS we advise you to install the previous 
Celtx 0.997: 

cd 

Download it: 

wget http://www.celtx.com/download/Celtx-0997-en-US.tar.gz 

Untar it to your local folder (for instance): 

cd /usr/local 

sudo tar xvf /home/user/Celtx-0997-en-US.tar.gz 

And launch it: 

sudo /usr/local/celtx/celtx 

Next you may be thinking of adding a Celtx icon to the work panel through a program like Easy Mode editor. 

Hyperlinks
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Hyperlinks may not work. Firefox (upon which Celtx is based) primarily supports the GNOME desktop environment, although various Linux distributions include modified forms of 
Firefox with support for KDE. At the moment, Celtx consults the GNOME registry to check what your default browser is. We hope to address this when we have the time. 

Root

If you can only run Celtx as root (not just the first time), you need to delete the following directories: 

●     .greyfirst 
●     .celtx 

Depending on your distro, they will most likely be in one of the following locations: 

●     Your home directory (~) 
●     /tmp 
●     /usr/tmp 
●     /usr/local/celtx 

The small Print

When installing, we'd really appreciate it if you would please take the time to read the small print: 

●     CePL 
Celtx uses the CePL, which is a derivative of Netscape’s Mozilla Public License (MPL)! 

●     Terms of Use 
●     Privacy Policy 

Launching for the first time

To launch Celtx double click the movie clapper icon like the one below. 

Image:Celtx_Clapper_icon.png

 

The application will open and display the Splash Page. 

Installing other dictionaries to the Spell Checker
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Adding new language dictionaries to Celtx is performed through the Toolbox. 

1.  Open Celtx with any project or create a new project. 
2.  Select the menu option 'Tools' then 'Toolbox'. 
3.  Celtx will open a new dialog box. Click 'Get Celtx Tools' at the bottom of this box. This will open the Celtx tools web page. 
4.  Click the link for the desire dictionary language to install. The dictionary will be added to the Toolbox dialog with a note the dictionary will be available after Celtx has been 

restarted. 
5.  Restart Celtx to begin using the new dictionary. 

Direct downloads of dictionary files available below. Installation of dictionaries through Toolbox method listed above is recommended. 

●     Afrikaan (South Africa) 
●     Bulgarian 
●     Catalan 
●     Croation 
●     Czech 
●     Danish 
●     Dutch 
●     English (Australia) 
●     English (Canada) 
●     English (United Kingdom) 
●     English (United States) 
●     English (New Zealand) 
●     France 
●     Faroese 
●     Galician (Spain) 
●     German (Austria) 
●     German (Germany) 
●     German (Switzerland) 
●     Greek 
●     Hebrew 
●     Hungarian 
●     Irish 
●     Interlingua 
●     Italian 
●     Latin 
●     Latvian 
●     Lithuanian 
●     Malay 
●     Maori 
●     Norwegian (Bokmal) 
●     Norwegian (Nynorsk) 
●     Polish 
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●     Portuguese (Brasil) 
●     Portuguese (Portugal) 
●     Romanian 
●     Russian 
●     Russian (Without Ë) 
●     Russian (With Ë) 
●     Spanish (Mexico) 
●     Spanish (Spain) 
●     Slovakian 
●     Slovenian 
●     Swedish 
●     Ukrainian 
●     Welsh 
●     Zulu 

The Splash Page

The Celtx Splash Page

 

The Celtx Splash Page

The Celtx Splash Page is the first screen you are presented with when you launch the application. Its new design allows you to jump right into your work or engage directly with the 
Celtx community through the Community News or the Project of the Week selection. Below is a brief description of the functions found in each of the Splash Page tabs. 

Getting Started-Options Tab
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Start a New Project

Name and Save your Project

●     To start a new project simply select one of the template types under the list of Templates. 
●     custom term papers 
●     You now have the option to start writing your script or add additional items to your project. 

A new project in Celtx (version 0.991)

 

A new project in Celtx (version 0.991)

Customizing Your Project

Preferences / Advanced Add Item Options 

Depending on the nature of your project, there are a number of different Celtx documents that you can add to your project to help flesh it out. 

Select one item or select them all. By default, each Project starts with a Catalog and a Script. 
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Advanced Project Options

Open an Existing Project

To open an existing project single click browse option from the Splash Page. This will launch the Open Project dialog. 

You can also open a Project directly from a Celtx file icon. 

Download a Project

The Celtx server provides a list of projects that are available to you. They could be projects that were uploaded by you as 'private', by other users as 'shared' projects in which the author 
has authorized you as a collaborator in his project. 

To download a project from the Celtx server single click download. This will launch the Download Dialog. 
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The Download Dialog

●     This dialog will prompt you for your Celtx server username and password. 
●     If you don't have one, select Create an Account and follow the instructions provided by the Registration Wizard. 
●     Once this is completed, you'll be presented with your Server Project dialog. 
●     Select the project you want and hit 'Download'. 

Server Project Dialog

 

Server Project Dialog

●     Complete the New Project dialog that appears next. 
●     Name and save the project as desired. 
●     A progress bar then displays showing the download activity. 
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The Progress Bar

 

The Progress Bar

●     Once the bar is completed, you'll get a message that says 'Finished'. Sync completed successfully'. 

Successful Sync Message

 

Successful Sync Message

●     Hit 'Close' 
●     Downloaded project displays in the Script Editor. 

Create an Account / Registration Wizard

To access Celtx web services, you'll need to create a Celtx Account using the Registration Wizard. The account Wizard can be accessed from the Help menu or from the Login dialog. 
Having an account allows you to: 

●     Collaborate with others (Upload / Download as 'Shared') 
●     Make secure backups of your project (Upload as 'Private') 
●     Participate in Project Central (Upload as 'Public') 

Selecting 'Create an Account' will launch the Registration Wizard. 
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Create an Account

 

Create an Account

Community News

The Community News notifier keeps you informed of recent Celtx developments, community updates and industry events. Selection of the Notifier will open any embedded link in your 
default web browser. 

 

The Celtx Notifier

Getting Started - Other Useful Info

Converting Projects from Celtx v. 0.9.5.1
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Follow these steps to Convert your 095 Projects: 

●     1. Open Celtx 
●     2. Select ‘Open Existing Project’ 
●     3. You’ll get an ‘Open file’ dialogue 
●     4. WINDOWS and LINUX users MUST change the file filter located at the bottom of the dialogue from “Celtx 0.9.7 Projects” to “Celtx 0.9.5 Projects” 
●     5. Use the Open file dialogue to locate your 095 Project Folder. 
●     6. Click in to the 095 Project 
●     7. You should see a “project.rdf” file. Highlite it and select ‘Open’. 
●     8. Your 095 Project will be automatically converted to the new data model and open in Celtx 

Note 1: Mac users will not see the file filter in Step 4. You can simply select the 095X project folder, then select the project.rdf file in the folder to convert your project. 

Note 2: Celtx will automatically make a back-up of your 095 Project during the conversion in case you’re not happy with the result and want to revert to 095.] 

If you're not sure about all of this, or have some questions, try out our new video tutorials to get a first hand demonstration of this and many of the other features of the application. 

Reverting Projects from v.097 (+) back to v.095

Users who tried the new version (097 / 0971) and want to switch back to 095 can do so by re-installing 095. You can download 095 at the following links: 

●     Celtx version 0.951 for Windows 
●     Celtx version 0.951 for Mac OS X 

095 Projects

Old Projects that were converted to the new data model using 097 can still be accessed in 095 (Celtx did an automatic back up of the *.rdf file when your project was converted). Follow 
these steps to locate and open your converted project in 095: 

●     Step 1 – Locate the relevant Project Folder 
●     Step 2 – Open the Folder 
●     Step 3 – Rename the file “Project.rdf” to “Project097.rdf’ 
●     Step 4 – Rename the file “Project.rdf.orig” to “Project.rdf” 

Then after re-installing 095 

●     Step 5 – Use Celtx to locate and open your Project per the “Open Existing Project” dialogue 
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097 Projects

New Projects created using 097 are not backwards compatible, so if you did some writing in 097 that you want to access in 095, export the script as a *.txt file using the Export option 
available in 097 under the ‘Script’ menu and then re-import the file once you have 095 re-installed. 

Please feel free to contact us if you experience any trouble reverting back to 095. 

Saving Projects

Projects are initially saved when you create them using the 'New Project' dialog. Through the 'Browse' dialog you have the option to store your projects wherever you choose. 

Save Your Project where you want 

Choose where you want to save your project folder by selecting the Browse button.The Browse button allows you to: 

●     Change the location where the project is saved 
●     Updates the location path in the dialog 
●     Remembers new save location for future projects 

Default Save Locations 

Depending on which operating system(s) you are using, the default save locations for your projects are as follows: 

●     Windows - My Documents 
●     Mac OS X - Documents 
●     Linux - Home directory 

Manual Saves 

To perform a manual save of your work while in an open project, select the 'Save' icon from the Project toolbar or 'Save Project' from the File menu. 

Saving Documents

When working on other Celtx documents (text doc, forms) within a project, the user is prompted with a save dialog when they go to close the document. 
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Saving your Project

 

Saving your Project

Other Save Options for your Script

Other options for saving your script include: 

●     Export as text or HTML files 
●     Generate as PDF 

Copying Projects

We've added in a Copy Project feature which basically serves as 'Save As'. This feature will create a copy of your current project and all its contents. It is located under File -> Copy 
Project and will prompt you to provide a new title once selected. 

Copying of projects can also be handled by your operating system's file dialog. 

To Copy a Project on Mac: 

●     Open your Finder window, navigate to your existing project and select. 
●     From the File menu choose 'Duplicate'. 
●     Re-name, if desired. The duplicate project will maintain the original title and add 'copy' to the name. 
●     Once completed, close the Finder window. 
●     In Celtx, use the Open Project dialog to navigate to the copied project. 

Deleting Projects

Deleting a project is now also handled by your operating system's file dialog. A user will have to manually delete a project by sending it to the trash/recycle bin. 

To Delete a Project on Mac: 
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●     Open your Finder window, navigate to the project you want to delete, and select. 
●     From the File menu choose 'Move to Trash'. 
●     And poof.... gone! 

Return to Main Page 

Writing Your Script

Whether you're writing poetry, song lyrics, a novel or film script, the Celtx Script Editor allows scripts to be created from scratch using the 12 pt Courier font, or imported from other 
word processing programs as plain text files . 

Celtx film scripts adhere to the industry standard format. Scripts can be quickly written in Celtx with the built in format-intelligence. Celtx knows what logically comes next in a 
standard script, Scene heading (slugline) ->Action -> Character -> Dialog... just by using the 'return key' to move from one element to the next. The tab key will quickly switch from 
Character back to Action. See formatting details and shortcuts below. 

The Script Editor interface is comprised of 6 main components: 

●     1. Script Editor Window 
●     2. Script Editor Toolbar 
●     3. Project Navigator 
●     4. Scene Navigator 
●     5. Project Toolbar 
●     6. Media Sidebar 

Below is an image that illustrates the interface when all component features are open and turned on. 
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The Celtx Screenplay Editor

 

The Celtx Screenplay Editor

Customize your Work Space

Each component of the Script Editor can be customized to help optimize your workspace. For example, the interface displays can be re-sized using the small, white disc 'grippies' 
located on the inside borders of the navigator and sidebar panels. Just click your cursor on the grippy and slide it left / right, or up / down accordingly. 

The Sidebar can be turned on or off by selecting the Sidebar icon (located at far right in Editor toolbar) or Script menu->Sidebar. 

The main Project Toolbar can be turned on or off, or the toolbar functions can be customized to display as text, icons, or both by selecting these options from View menu->Toolbars. 

Below is a view of your bare-bones Script Editor: 
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Bare Bones Script Editor

 

Bare Bones Script Editor

Script Editor Toolbar Features

The Script Editor Toolbar
 

The Script Editor Toolbar

Script Formatting - Element dropdown menu
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The Script Element 
Dropdown

 

The Script Element Dropdown

Each of the standard script elements (Scene Heading (slugline), Action, Character, Dialog, Parenthetical (wryly), Transition and Shot) are found in the Script Element dropdown in the 
editor toolbar. Selecting one of these script elements from the drop down will apply the appropriate formating to your text, conforming to the industry script standard. This drop down 
menu is best used for formatting large portions of text. 

If you want to reformat some text, place your cursor in the block of text you wish to change and select the appropriate format element. 

Tab / Enter

The Tab / Enter keys provide shortcuts to formatting your script elements. Refer to the shortcut formatting chart below for details. Note that the elements less used (ie. Transition and 
Shot) have been removed from the element sequence, but can be applied from the element dropdown menu. 

The Tab /Enter functionality is also referenced in the status bar at the bottom of the editor display screen as you type. 

Shift + Tab

If you made a mistake and want to cycle backwards through element selections made previously, select SHIFT + TAB. 

KeyStroke Commands

Ctrl+1: Scene Heading
Ctrl+2: Action
Ctrl+3: Character
Ctrl+4: Dialog
Ctrl+5: Parenthetical
Ctrl+6: Transition
Ctrl+7: Shot
Ctrl+8: Text

Script Editor Formatting Keyboard Shortcuts
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If you type TAB in... You will get to... 

Scene Heading Action 

Action Character 

Character Action 

Dialog Parenthetical 

Parenthetical Dialog 

Transition Action 

Shot Action 

Text Action 

When the current line is NOTblank 

If you type ENTER in... You will get to... 

Scene Heading Action 

Action Action 

Character Dialog 

Dialog Character 

Parenthetical Dialog 

Transition Action 

Shot Action 

Text Text 

When the current line ISblank 

If you type TAB in... You will get to... 

Scene Heading Action 

Action Scene Heading 

Character Action 

Dialog Action 

Parenthetical Dialog 

Transition Action 

Shot Action 

Text Text 
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Script Notes

Script Notes provide a handy commenting system within your script. The notes can be used to ask questions or make comments regarding details about a particular scene, prop, 
character, camera angle, etc. The notes can be added and removed, and are editable and draggable. You can also create a Script with Notes report in the Reports feature. 

To Add a script note 

While in the Editor, click your cursor where you want the note to be inserted in the text Then click on the yellow note in the Editor toolbar. The note displays in the script. 

To Open and add comments: 

Single-click the note to open it. You'll see that each note is date-stamped with the current date. Type in your text. Text space within the note is unlimited so write as much as you like. 

Adding A Script Note

 

Adding A Script Note

To Close: 

Single click inside the note. Once created, clicking on the Note icon in the script will display the contents of the script note. 

Script Note

 

Script Note

To Edit: 
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Open the note, select 'Edit', make your text changes and single click to close. 

To Drag: 

Click your cursor on the note and drag it to the desired position in the script. 

To Remove: 

Remove the note entirely by selecting the script note and pressing the Delete key. 

Bold / Italic / Underline

Font Styles
 

Font Styles

To add the bold, italic and underline styles, simply highlite the text you want to stylize, then select the appropriate icon from the Editor toolbar. 

To view the underline style, be sure to click off the text highlite after the underline icon has been selected. 

Change UPPER/lower case

Change 
Case  

Change Case

To change text characters or words from upper case to lower case and vice versa, highlite the text and select the corresponding icon from the Editor toolbar. 

Find and Replace

Find & Replace is found under the Edit menu and is used to search for specific text within the script window. You then have the option to replace the found text with different text. 

To Find text in the script: 
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Find

 

Find

Find begins from the insertion point of your cursor within the script. Enter the text you are searching for in the 'Find Text' field of the F&R dialog. Click 'Find Next'. If the searched text 
is found, searching will stop and the found text will be selected. If no text is located, a message saying "No matches found" will appear in the dialog. 

To Find the next occurrence of the same text: 

Click 'Find Next' again. 

To Replace the Find text: 

Replace

 

Replace

Enter the text to be used as a replacement for the Find text in the "Replace with" text field. Click Replace (or Replace All). The text that was found will be replaced with the text in the 
'Replace with' text field. 

Replace All: 

Searches the script and replaces all occurrences of the text that is being searched. 

Celtx also provides you with a 'case sensitive' search option. (Matches upper/lower case text.) 
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Multi-Language Spell Checker

The Spell Checker

 

The Spell Checker

Celtx has a multi-language spell checker that is accessible via the Editor toolbar. 

To begin spell-checking, place your cursor at the beginning of the text area you want to check. Select Spellcheck from the Celtx toolbar and a Check Spelling dialog will appear. Any 
misspelled words will show up at the top of the dialog. Spell Check will offer alternate word suggestions, and give you the option to Replace, Replace All, Add Word, Ignore or Ignore 
All. Once all misspelled words are detected, 'Completed spell checking' will appear at the top of the dialog. 

You can add more language dictionaries to the Spellcheck tool by following the instructions here. 

In-line Spell Check / Context Menu

This new feature checks your spelling as you write, underlining any misspelled words in red. Right-clicking on the mispelled word will display a context menu that presents correction 
options: 

●     Alternate word suggestions 
●     No suggestions found 
●     Add to dictionary 
●     Ignore word 

http://wiki.celtx.com/index.php?title=Print_Version_-_English&printable=yes (30 of 87) [7/19/2010 10:46:44 PM]

http://wiki.celtx.com/index.php?title=Image:39SpellCheck.png
http://wiki.celtx.com/index.php?title=Image:39SpellCheck.png
http://wiki.celtx.com/index.php?title=Spell_checker
http://wiki.celtx.com/index.php?title=Installation#Installing_other_dictionaries_to_the_Spell_Checker


Print Version - English - CeltxWiki

Inline Spell Check

 

Inline Spell Check

Remove Markup

Remove 
Markup 

Remove Markup

To erase marked up items (items that have been broken down) in the Editor, highlight the text, then select the eraser icon from the Editor toolbar. The colour markup will be removed 
from the text. Details associated with the markup item will remain in the database. 

Zoom

Zoom
 

Zoom

The Editor's 12 pt Courier font can be viewed at 100% (default), 150%, or 200%. Select the Zoom dropdown menu to select the option you prefer. 

Production Items Sidebar
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The Breakdown Sidebar

 

The Breakdown Sidebar

Other Editor Features

Editor Window 

This is the main display window where you write your script. 
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The Editor Window

 

The Editor Window
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Multiple Projects

In Celtx multiple project windows can be open at one time which allows cut, copy, paste between multiple projects. Mac users can select the Windows menu to see which projects are 
open at once, and have the option to select which project they want to bring to the front of the screen. 

Auto-Complete

Character Autocomplete

 

Character Autocomplete

The Auto-complete function applies to the Character and Scene Heading elements in the Script Editor. It saves you time as you write because it eliminates the need to repeatedly type a 
character name or scene header (ie INT. / EXT., etc.) over and over. Once the first instance of the element has been typed in the script, Auto-complete remembers it and displays a 
dropdown when the first letter of the element is typed in subsequent entries. 

Mores and Continueds

Scene Numbering

Applying Scene Numbers

 

Applying Scene Numbers

Scene numbers can be turned on or off depending on whether you're writing a spec script or shooting script. By default, the Script Editor does not assign scene numbers as you enter or 
revise your script. 

http://wiki.celtx.com/index.php?title=Print_Version_-_English&printable=yes (34 of 87) [7/19/2010 10:46:44 PM]

http://wiki.celtx.com/index.php?title=Image:43-Char-autocomplete.png
http://wiki.celtx.com/index.php?title=Image:43-Char-autocomplete.png
http://wiki.celtx.com/index.php?title=Generating_PDFs#Mores_and_Continueds
http://wiki.celtx.com/index.php?title=Image:Scene-s.png
http://wiki.celtx.com/index.php?title=Image:Scene-s.png


Print Version - English - CeltxWiki

To apply scene numbers to your script, go to File - >Page SetUp. Go to 'Show scene numbers' from the Page and Scene Numbers Dialog and select the placement option - 'left', 'right', 
or 'both' from the dropdown menu. 

To turn scene numbers off, select 'none' 

Pagination

In the Script Editor page numbers can be turned on or off by going to File->Page Setup and ticking the Show page numbers box accordingly. You also have the option to Show page 
number on first page. 

If your version of Celtx doesn't show this option, go to Script->Format Options and check the box for Pagination. Select the function again to turn it off. 

A page counter is located in the bottom right-hand corner of the screen. 

Page Counter

 

Page Counter

Page Breaks

The Script Editor defaults to 54 lines per page and inserts page breaks automatically. Widows and Orphans get pushed to the next page. 

The ScratchPad

The 'ScratchPad' is a small text editor that serves as a holding tank or 'Bone Yard' where you can store loose pieces of draft text, or jot down ideas that come to you while you are 
writing. You can also use the feature to swap out sections of your script to the ScratchPad. 

The Scratchpad is accessible by clicking on the yellow notepad icon at the bottom of the Scene Navigator located on the left-hand side of your screen. The ScratchPad will open at the 
bottom of the Editor window. 

There are many ways to send highlighted text to the ScratchPad: 

●     Any text can be dragged and dropped from the script to the ScratchPad, and vice versa. Just highlight the text, grab with your cursor, and drag to desired position. 
●     Cut and Paste 
●     Alternatively, highlight the text you want to move then right-click your mouse and select "Send to Scratchpad' in the Editor Context Menu. 
●     From the Scene Navigator you can send whole scenes to the Scratchpad by selecting the scene you want, then hit the small yellow icon in the Navigator toolbar. 
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The Scratch Pad

 

The Scratch Pad

Script Editor Context Menu

Editor Context Menu

 

Editor Context Menu

To access the Script Editor's context menu place your cursor in the script and right click your mouse. Context menu options include: 

●     [ Cut / Copy / Paste] 
●     Send to ScratchPad 

Title Page

The Title Page is accessed via the Tiltle Page subtab found at the bottom of the editor windows. 

The Title Page is automatically included when you generate a PDF, and it can be printed off separately by selecting the 'Print' button located on the main toolbar of the Title Page. 
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Editing the Title Page

 

Editing the Title Page

Importing Scripts

Script Import/Export Menu

 

Script Import/Export Menu

Celtx can import plain text scripts generated by other script writing or word processing applications. Once a script is imported into Celtx it can then be further developed, edited and 
then broken down using the Production Breakdown features of Celtx. It is important to ensure that scripts are properly formatted before importing into Celtx, otherwise some manual 
tweaking may be required. Adhere to the instructions below and your import should go smoothly: 

To Import a Script into Celtx... 

●     Open the script / file in the word processor. 
●     Remove any scene numbers. 
●     Remove anything before the first scene (Title Page, Sources, etc). 
●     Ensure the first text is EXT. or INT. (include periods and use uppercase, as shown) 
●     To convert your file to .txt, choose File->Save As and select File Type 'Text Only', or 'Text with Layout'. 
●     Ensure a .txt file is created. (Suggestion: Save it to your desktop for easy retrieval.) 
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●     Open Celtx and select 'Start a New Project' from the splash page OR select File -> New Project from the Menu toolbar. 
●     Complete the New Project dialog as desired being sure to select 'Script' as one of your project items, then hit OK. 
●     Your new project opens, defaulting to script mode in the Editor window. 
●     Select Script->Import Script 
●     From your displayed file directory, navigate to and select the script /.txt file you want to import, then hit 'Open'. 
●     A progress bar appears showing the import activity of your script. 
●     Once the script has loaded, it will appear in the Script Editor window, while each scene is loaded into the Scene Navigator on the LH side of the screen. 

Importing from the Other Guys 

Currently Celtx only imports plain text script files, which can be created with either Final Draft Pro or Movie Magic Screen Writer 2000. 

MS WORD 

When in an open Celtx project, a WORD file can be added as an external file by selecting File menu->Add Item. 

Please note that Celtx does not support MS WORD imports directly. WORD documents often include embedded tags that have a negative affect on Celtx formatting. Therefore, we 
strongly recommend that you do NOT cut and paste text from WORD documents directly into the Celtx editor, nor into text files to be imported into Celtx . 

Importing from Final Daft 

Users of Final Draft will want to save their scripts with the 'Text Only with Layout' found under 'File -> Save As'. 

Importing from Movie Magic Screen Writer 

Users of Movie Magic Screen Writer will want to save their scripts using the 'Formatted ASCII' format found under 'File -> Save As' for Windows. •On a Mac, select 'File -> Save As, 
then select the 'Avid Editor Format' from the file type drop down menu. 

Import to an Existing Script 

Celtx allows you to import additional scenes into your existing script. When you import an additional script, or portion of a script, it will be appended to the end of your existing project 
script. 

Exporting Scripts

Celtx currently supports the export of scripts as a text (.txt) or HTML files. 
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To export a script from Celtx.... 

●     While in script mode of your project, select Script->Export script from the Menu toolbar. 
●     Complete the displayed Export dialog selecting where you want to save your file and in which file format you want to export your script. 
●     Select 'Save'. 

Exporting to Final Draft 

Return to Main Page 

1.  redirect Web Services 

Publishing to Project Central 

The Project Toolbar has the following buttons: 

●     New Project... 
●     Open Project... with an Open Recent dropdown next to it 
●     Save Project 
●     Print 

On the far right hand side there's the 

●     Web Services button 

Below are Mac screenshots of each menu: 

Celtx Menu
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Celtx Menu

 

Celtx Menu

File Menu

File Menu

 

File Menu

●     New Project 
●     Open Project 
●     Open Recent 
●     Save Project 
●     Copy Project 

Similar to a Save As command. 
●     Close Tab 
●     Close Window 

Doesn't prompt for save 
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●     Add Item 
●     Add Folder 
●     Delete Item 

●     Page Setup 
●     Print Preview 

The only way to resume editing after choosing this option is to close the print preview tab (which replaces the editable script tab) and re-opening your script. 
●     Print 

Printing from the file menu is not the ideal option - instead, select Script | Generate PDF... and print that out. Orphan-control on page breaks, and Mores & 
Continueds aren't handled by File | Print... 

●     Open Project Folder 
Pop the contents of your project folder up in the file browser, such as Windows Explorer. 

●     Exit 
Prompts for save if needed 

Edit Menu

Edit Menu

 

Edit Menu

Standard text editor commands: cut, paste, copy, find and replace. 

View Menu
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View Menu

 

View Menu

●     Toolbars 
❍     Icons and Text 
❍     Icons 
❍     Text 
❍     None 

Script Menu

‘Script’ menu is used to access anything to do with the script; as such it only appears when a script tab is selected. 

●     Import Script... 
Only text-format scripts can be imported, but Celtx is reasonably clever about picking out the characters, sluglines and other script elements. 

●     Export Script 
Scripts can be exported as text-format or HTML. 

●     Adapt To 
This option will adapt on document type to another. 

●     Add Characters to Catalog 
Used after importing or pasting a script into the editor. It will parse the new script and add any new Characters to the Master Catalog. 

●     Format Options 
Opens the Format Options dialog where you will find options for paper type, scene numbers, and pagination. 

●     Sidebar 
Opens and Closes the sidebar 

Tools Menu

Tools Menu
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Tools Menu

●     Check Spelling... 
●     Inline Spell Checking 

●     Options... 

Help Menu

Help Menu

 

Help Menu

●     About Celtx 
Version number and contribution credits 

●     Splash Screen 
●     Online Support 
●     Celtx Wiki 

You are here 
●     Video Tutorial 

Requires Internet connection 
●     Report A Bug 

Uses the Celtx Forum 
●     Celtx Account... 

Necessary to Generate PDFs and publish your project to Project Central
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The Project Navigator

 

The Project Navigator

The Project Library Sidebar is the storage place for your Celtx documents and folders. It's located in the upper left-hand side of the interface and is where you navigate to the different 
items contained in your project. 

New folders and new documents, forms, files or scripts can be added or deleted from your project using the 'Three Little Buttons' located in the toolbar at the top. 
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As a handy alternative to the buttons, the Project Nav Context Menu easily allows you to add, delete, open and re-name your documents and folders with a simple right-click of your 
mouse. 

The Project Library also offers drag and drop capability, allowing you to organize and move your files and folders as you like. 

The Project Library can be hidden by grabbing the right hand side of it and resizing it to the left. To restore the Project Library, just drag out the left hand side of Celtx. 

The Three Little Buttons

The Three Little Buttons specifically refer to 'Add a New Item', 'Add a New Folder', and 'Delete'. 

3 Buttons  

3 Buttons

Add a New Item

Add 
Button

 

Add Button

The Add Items Dialog

 

The Add Items Dialog
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Selecting the dark grey + (plus sign) allows you to add any pre-loaded Celtx document, or any other kind of document from any application to your Celtx Project folder – PDFs, 
Spreadsheets, Storyboards, even Scripts written in other applications. Each document will open in its default application where it can be modified and then saved back to the Celtx 
folder. That way you’ll always know that you have the latest version of a particular file in your Celtx Project making it easier to Collaborate with team members. 

Add Multiple Scripts

You can also use this feature to add multiple scripts to your Project, or to split a long script in to several shorter scripts to better facilitate co-writing. If only making a copy of the script, 
just add a new script document to the project, then cut and paste the script into the new script, and make your new changes. 

Add Unlimited versions of any Document

'Add a New Item' allows you to add an unlimited number of versions of any document to your Celtx project, including the pre-loaded Celtx forms (Scene Details, Characters, Actor 
Profiles, Locations, Props and Wardrobe). 

Add a New Folder

Add 
Folder

 

Add Folder

The Add Folder Dialog

 

The Add Folder Dialog

You can also create folders that can be used to organize your documents. Gather together – IN ONE PLACE – all of your project related material. Think of it as your digital three ring 
binder. 

To Add a Folder.... 

●     While in an open project, select the dark grey folder icon from the Project Navigator toolbar. 
●     In the dialog displayed, name your folder in the 'Save As' field. 
●     Select where you want to save your folder within the Project Navigator by selecting the folder dropdown menu. 
●     Hit 'OK' or 'Cancel' 

Delete An Item
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Delete 
Item

 

Delete Item

To Delete an Item.... 

●     In the Project Navigator, select the file / folder you want to delete 
●     Click the light grey 'X' from the Project Navigator toolbar. 
●     A confirmation dialog will appear to make sure you do want to delete that particular item. 
●     If you do want to delete, select 'OK' 
●     If you don't want to delete, select 'Cancel'. 

Project Navigator Context Menu

When in the Project Navigator you can 'Open', 'Rename' 'Add' or 'Delete' any file or folder that you create using the standard right click context menu. (Note: for Mac users with a one 
button mouse, the same context menus are available by holding down the Control button and then clicking on the file or folder.) 

The Project Navigator Context Menu

 

The Project Navigator Context Menu
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The Scene Navigator

The Scene Navigator view provides a top-to-bottom ordering of the scenes based on your script. The scene's Scene Heading and Scene Number are displayed. The toolbar at the top of 
the Scene Navigator lets users move and re-order scenes, copy entire scenes to the Scratchpad, and delete scenes. Any changes made within the Scene Navigator are automatically 
synchronized with the script in the Script Editor. 

The Scene Navigator populates automatically as you write each new scene header in your script. Alternatively, if you import additional scenes to be appended to your existing script, 
they too will be added to the end of the Navigator. 

Moving / Re-Ordering Scenes

●     Scenes can be moved via drag and drop. Select the scene, then drag and insert it in its new position within the Navigator. 
●     Scenes can also be re-ordered using the UP / DOWN arrows. To move a scene up the list, select the scene and press the UP arrow. To move a scene down the list, select the 

scene and press the DOWN arrow. 
●     Move a scene to the ScratchPad by selecting a scene and then selecting the ScratchPad button at the top of the Scene Navigator. A confirmation dialog will appear to confirm 

moving the scene to the ScratchPad. To view the scene in the ScratchPad, select the ScratchPad icon below the Scene Navigator. 

Double-clicking any scene in the Navigator will display that scene at the top of the Script Editor window. 

Adding Scenes

Scenes can be added to your script in a few ways: 

●     As you Write 

As you write in the Script Editor, place your cursor where you want the new scene to appear and choose 'Scene Heading' from the Script Element dropdown menu in the Script 
Editor Toolbar, or apply the keyboard shortcut. 
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●     Importing scenes from another script /version 

Any item imported into Celtx must be in a plain text format. To import scenes from one script to another, have your existing script open in the Editor, then select Script->Import 
Script. Navigate to the desired document and choose Open. When the document opens, the contents will be appended to the end of your existing script in the Editor. 

●     Cut and Paste 

Scenes from one Celtx script (or other plain text script) can be highlighted, Cut (or Copied) and Pasted into another Celtx script. (Please Note: Cutting and Pasting from MS 
WORD documents / scripts into Celtx scripts is NOT recommended.) 
If turned on, scene numbers (found in File->Page Setup) in the Editor and Scene Navigator will be re-ordered accordingly as new scenes are added. 

Deleting Scenes

Scenes can be deleted in the Scene Navigator by selecting the scene, then selecting red 'Delete' button from the Navigator toolbar. Alternately, scenes can also be deleted by right-
clicking the scene context menu and selecting 'delete'. All delete functions are prompted with a confirmation dialog to confirm your decision to delete an item. 

Scene Context Menu

The Scene Nav Context Menu

 

The Scene Nav Context Menu

To access the Scene Context Menu, right-click your mouse while in the Scene Navigator. Select a scene in the Navigator then choose one of the menu options below: 

●     Go To 
●     Send to ScratchPad 
●     Delete 

Known bugs

In version 0.9.9, Celtx occasionally inserts blank or invisible scenes. If these occur on the same line as a real scene heading, they can easily be removed by Sending them to the 
ScrachPad. But if they are embedded within a scene, they can be removed by editing the script-abc.html file (it's not actually called that, but replace the abc with whatever letters match 
your script). Locate the blank scene in the script, and find corresponding point in the html file. When a tag has a value like id="asdfefxxfe", this creates a scene or other database object, 
like a character, prop or whatever. If you find an id value in an unexpected place, remove the id="asdfefxxfe" and the blank scene will be removed without harming other aspects of 
your screenplay.
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The Breakdown Sidebar

 

The Breakdown Sidebar

The Production Items Sidebar allows you to perform departmental breakdowns of your script in Celtx. You highlight text items in the script and assign them to the appropriate 
departments by tagging them. Production breakdowns use industry standard categories like Cast, Extra, Location, Props, Set, Wardrobe, Camera, Lights, Sound etc. 

You can detail your breakdown as much as you like by assigning names, descriptions, images and other media files to your breakdown items. Once your breakdown is complete, you 
can select the Reports icon to generate customized project reports and lists. 

There is a button on the Script Editor Toolbar to show/hide the sidebar, or you can pick Script | Sidebar to toggle its visibility. 

Breakdown Categories
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Categories and Items

 

Categories and Items

Tagging

To create a new entry in the Production Items Sidebar, execute the following steps: 

●     In the editor, select the item to be added by highlighting the word or words describing the item
●     In the Sidebar, select the Category of the item to be added.
●     In the Item window, select <New...>
●     Click the "Tag" button

The new item will now appear in the Item window for the selected Category. You may now enter additional information including a description. 

Item selected and Remove 
Markup button highlighted

 

Item selected and Remove Markup button highlighted

If for whatever reason you decide that you no longer want an item to be tagged, simply select it in the script and click the "Remove Markup" button on the Script Editor Toolbar. 

Adding Media

Another one of the great features of Celtx is that it allows you to better visualize your project by giving you the ability to add image, sound and video files directly to marked up items in 
your script, or to unassociated text, just as reference material. A great feature to have when researching your project. 

Add Media Button

Add Media

 

Add Media

Media can be added to script items that have already been tagged. While in the Sidebar, simply select the 'Add Media' button. A file browser will open to choose the media to assign to 
the item. To remove a media file from the item, select the media thumbnail and then select the 'Remove Media' button. The media file is no longer associated with the breakdown item. 
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The Media Viewer

 

The Media Viewer

Supported Media Formats

Mac

●     Images - .jpg / .png / .gif 
●     Sound - .mp3 / .wav / .au / .mid / .aif 
●     Video - .mpg / .mov / .avi (though not all avi files are created equal, some may not be supported) 

Windows

●     This list is dependent on whether the QT plug-in is installed.The formats that are natively supported (without Quicktime installed) are: 
●     Images - .jpg / .png / .gif 
●     Sound - .au / .aiff / .wma 
●     Video - .wmv 

Removing Media

To remove any media files that were added previously to the Sidebar Media Viewer, simply click on the image, then select 'Remove'. Removing image items from the Sidebar also 
removes them from Breakdown Reports. 

Images button

When an item is selected, the Images button opens a browser on a search page with the Name of the item used to search Google Images. Makes finding images to 'borrow' a breeze. 
Celtx provides many different types of documents and Forms that can be added to a Project. 
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Document types are added through the [[Add Item dialog]]. Celtx provides six (6) different editors, each for writing a specific kind of script. The Add Item dialog can also be used to 
add a Storyboard, Production Schedule, Bookmark, Calendar and any External File. For ease of use, the Add Item dialog also includes two popular Forms used by writers - the Scene 
Details Form and a Character Development Form. 

Forms are used to augment the writing process or to complete a script breakdown. Forms are added through the Catalog. 
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By default, each Celtx Project will include a Script and a [[Catalog]. 

Pick Lists 

Using 'Pick Lists', the pre-loaded forms can be intelligently tied to the script, allowing you to associate locations or props or wardrobe items to specific characters or scenes. The forms 
haven't been hard-wired though so you can add them to your existing project whether you have a script or not. (Please Note: Pick Lists do not apply to Text documents.) 

Customize your Forms 

All the new pre-loaded Celtx forms are HTML templates designed to be customized by the user. If you are so inclined, sample instructions to modify ie. the Character and Scene Detail 
Forms can be found here. 

Adding Items to your Project 

Deleting Items from your Project 

Pre-loaded Celtx Documents

Text Document
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Celtx offers a Plain Text Editor tool that you can use to create whatever kind of text-based document your heart desires, including Outlines, Treatments, Poems, Song Lyrics, Short 
Stories, Letters, or for the truly brave - a Complete Novel. You can drag and drop images into your document as you type, or easily cut and paste text contents to and from other 
Celtx forms and document items, and print off hard copies. 

The Text option can be selected from an existing project's 'Add Item' dialog, or from the dialog presented when creating a new project. 

A Plain Text Document

 

A Plain Text Document

With a little help from your Tab and Enter keys, the Plain Text document supports nested bullets so it can be used to make Outlines. 

Character and Scene Details Forms

We’ve added some new functionality to the Scene Details and Character Forms. Upon selection of these forms from the 'Add Item' dialog, you will see that they offer a ‘Pick List' that 
can be used to quickly associate a form with a relevant Scene or Character element from the script. The pick list populates as you write and add new characters / scenes to the script. 
Note though that we haven’t hardwired the forms so you can add them to your project whether you have a script or not. 

So for instance, from the 'Add Item' Dialog, the Scene Details pick list would appear like this: 
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Adding a Scene Details Form

 

Adding a Scene Details Form

Character Details

●     HTML Form - Description / purpose 
●     Character Name 
●     Full Name 
●     Description 
●     Adding characters 
●     Deleting characters 
●     Dropdown picklists 
●     Media -Adding Media / Deleting Media 

We like to think of this as Character 101. The Character Detail form is used to provide background information for your characters to aid you in the writing process. Also when 
collaborating with others, other users will be able to read your character profiles to get a better sense of how these characters react and behave under different circumstances. 

The Catalog will include a Form for each Character in the script. You can add more Characters to this list using the Add + button in the Catalog toolbar. Once a character is added to the 
Catalog it will also get added to the character auto-complete pop-up that appears each time you write a Character name in the Script. If the character has dialog, it will appear in the 
Character list. 
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Character Details Form

 

Character Details Form

Scene Details

●     HTML Form - Description / purpose 
●     Scene Title 
●     Alternate Scene Title 
●     Description 
●     Media - Adding Media / Removing Media 
●     Dropdowns picklists 
●     Version 0951 Description: 

This is to complement the Character Details tab allowing users to better describe details about a particular scene that may fall outside the scope of the Sceneheader or Action 
description. By filling in these extra details, the writer can give the reader a better sense of the scene, including the goals and mood of a given scene. Using Scene Details is a pretty 
simple process. When the user selects the Scene Details tab, a list of scenes is presented on the left. Select a scene and the Sceneheader will be presented at the top of the details form. 
The user can then fill in the particular details for each scene. This information is saved when the user switches to another scene, or to another tab in the application. 
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A Scene Details Form

 

A Scene Details Form

Schedule / Calendar

You can now keep multiple schedules in a Celtx Project, each of which will now be included in the Collaboration sync, allowing you to share calendars with team members. 

We’ve also switched to Lightning for our Calendar. The Mozilla Lightning Project uses the same code base as the Mozilla Sunbird Project, which was the previous calendar we used, so 
your dates should transfer over nicely. 

Lightning 0.1 Release Notes

Lightning Development Weblog

The Lightning development team keeps a development weblog. It is intended for everyone who is looking for in-depth, up-to-date information about current events in Lightning 
development. 
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A Production Schedule

 

A Production Schedule

Actor Profile Form
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An Actor Form

 

An Actor Form

Location Form
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A Location Form

 

A Location Form

Locations / Google Map feature
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Using Google Maps

 

Using Google Maps

Prop Form

A Props Form
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A Props Form

Wardrobe Form

The Wardrobe Form

 

The Wardrobe Form

Bookmarks
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Adding a Web Bookmark

 

Adding a Web Bookmark

External Files

External Files refer to any kind of existing document created in any other application like PDFs, Spreadsheets, Storyboards, even Scripts written in other applications. These can be 
added to your Celtx folder by choosing the "Add New Document' icon. When the files are selected within the Project Navigator each document will open in its default application where 
it can be modified and then saved back to the Celtx folder. That way you’ll always know that you have the latest version of a particular file in your Celtx Project making it easier to 
Collaborate with team members. 

How to Add an External File

●     While in an open project, select the blue 'Add New Document' icon from the Project Navigator toolbar. 
●     Then in the dialog displayed, click on the 'File' document from 'Select Item'. 
●     Under 'Item Details' select 'Browse' and navigate to the desired file within your local directory and select 'Open'. 
●     The file then attaches to the dialog and it's name appears in the 'Name field'. Here you can change the file's name or leave as is. 
●     Select the 'Folder' dropdown to choose where you want to store your file within the project. Files are stored in 'Project Home' by default. 
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●     Hit 'OK'. 
●     The new file is now added to your project and can be accessed within the Project Navigator. 

Image:ExtForm.png Generate PDF creates a PDF file on your local computer. PDF generation is now found under the TypeSet feature, which is accessed at the bottom of the editor 
window. 

Compared to printing from the file menu, the PDF output is more sophisticated and responsive to your script elements. It looks more professional because it is more in keeping with 
scriptwriting norms for presentation. 

Your computer must be connected to the Internet to generate a PDF. No copy of your script is made when generating a PDF. It runs in memory only, getting converted on the fly, and is 
then routed back to the sender, after which it was like it was never sent as far as the Celtx Server is concerned. 

Generating PDFs

The PDF Generator has been re-implemented using XSL, and LaTeX and is deployed from the Celtx server to easily accommodate all operating systems. This approach allows us to 
offer features listed below which are generated automatically in the PDF if previously added to your script. 

How To Create a PDF

●     While in the Script Editor, select the TypeSet subtab found at the bottom of the editor window.. 
●     Now select the Save PDF button in the TypeSet toolbar. 
●     Next you are presented with a Browse dialog where you can name the PDF and choose where you want to store it. 
●     Select 'Save'. 
●     A progress bar appears indicating the conversion of your script to PDF. 
●     Once the bar disappears your PDF can be accessed from your Save location. 

Nothing happens

If nothing happens after Generating a PDF, check to see that you have Adobe Acrobat Reader installed on your computer. 

Non-Roman languages

Non-Roman languages are currently not supported by PDF generation. The only fallback available is to use File | Print. 

PDF Features

Bold and Italic

To activate bold and italics in the PDF, first apply the functions in the script via the Script Editor Toolbar. 

Scene Numbers
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To activate the scene numbers select your placement option (left/right/both /none) under File->Page Setup, then generate your PDF to view. 

Page Numbers

Page numbers are included in your PDF automatically 

Page Breaks

Sensible pagebreaking that minimizes widows & orphans 

Title Page

The Title Page is included in your PDF automatically. 

Mores and Continueds

The Mores and Continueds features are available for PDF only. While in the Script Editor, they can be accessed from the Formatting Options button on th TypeSet toolbar. Options 
include: 

Mores and Continueds

 

Mores and Continueds

Dialogue Breaks

When dialogue needs to be split between two pages, (MORE) is placed beneath the dialogue at the bottom of the first page. At the top of the next page, the name of the character is 
repeated along with (cont'd). 

If the 'Show dialogue breaks' box isn't ticked, these features will not be displayed or printed. Default is disabled. 

Automatic Character Continueds

If the same character speaks repetitively during a single scene, Celtx automatically places "(cont'd)" after the character's name. This tells the reader that the same character is continuing 
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a speech when it is broken by some action. Default is disabled. 

Scene Breaks

When a scene continues from one page to the next, Celtx will type the Bottom of Page text (CONTINUED) at the bottom of the first page. In addition, the Top of Next Page text 
(CONTINUED:) will appear at the top of the next page along with the scene number that is being continued. 

If the 'Show scene breaks' box isn't ticked, these features will not be displayed or printed. Default is disabled. 

Continued Page Count

Ticking the 'Show continued page count' will add a number after the CONTINUED (i.e. (2), (3), etc.) at the top of each continued page, indicating how many pages are included in the 
same scene. Default is disabled. 

Mac Notes

In Mac OS X, .pdf files can be generated natively without the need for the online script generator. To create a .pdf file in OS X, simply enter a print command and select the "PDF" drop 
down menu and choose "Save as PDF...". The .pdf file will be generated automatically including all visible formatting included in the script. 

However, this PDF will by default lack any of the extras available with a PDF generated by Celtx. For example, pages will break after the 55th line, without any attempt to indicate 
breaks in dialogue or breaks in a scene (your settings for Mores and Continued will be ignored), and the title page will not be included in such a PDF. 

See also

●     Export Script 

External links

●     Forums discuss the considerations for printing a script for submission 

Selecting the Reports subtab found at the bottom of the editor window allows you to generate a customized and printable view of the script breakdown to help plan and organize your 
film project. Create lists of your props, dialogue, characters or needed wardrobe for your project by scene and /or department. Driven by the script, Reports can be generated on the fly 
to slice and dice through the information in your Celtx Project. 

Users can choose whether the Report includes breakdown details or any associated image files. Ticking the 'Display Media' box, will display images as standard thumbnails to make the 
reports easier to read. 

New Reports options allow you to isolate any element of a script. View only dialogue (by a single Character, or multiple Characters) or isolate the Action sequences, or look only at 

Shot directions. You decide whatâ€™s in your Report. You can also now use Reports to view all the Script Notes in one place. These reports can be shared or printed off as hard copies. 

Only items that are tagged in your script will appear in reports. 
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Reports Display

 

Reports Display

Reports Navigator

Head to the Reports Navigator located on the left hand side of the screen to select a report template, then customize it the way you want by selecting the desired items from the Scene 
and Department Category filters (located in the panels at the top). To get a complete breakdown report, select ALL scenes and ALL categories, or break it up and select specific scenes 
and categories by selecting and applying the 'Shift' key. 

Pre-loaded reports include: 

Scene Breakdown

The Scene Breakdown is a report to allow planning of personnel and other items required to produce a scene. 

It prints as at least one page per scene - so can chew up a lot of paper. If your script is not heavily marked up with items (CGI work, camera effects, props, costumes and so on) it can be 
very sparse. 

For a given scene (or all scenes) lists all items for a department (or all departments) that appear in that scene (or all scenes that item appears in). As well as all and single 
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scenes/departments/items, multiple selections can be made - such as scenes 2, 6 and 11. 

If the Display Media box is checked, then associated media will be included in the report (photos, etc). 

Scene Breakdown with Description

Produces a more verbose report than the Scene Breakdown because the Description field of all the items are also shown. 

Dialog

Shows only the dialog for a certain scene (or multiple scenes, including all scenes) for a selected character (or multiple characters, or even all characters). 

This can be used to check for consistency of dialog and speech patterns, or providing an actor with all of the dialog for their character(s) - which can be used for rehearsal or 
memorization, or in animation makes the recording of a single actor's voice a much simpler matter. 

Dialog Report

 

Dialog Report
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Elements

The Elements report is handy when you want to view all instances of a particular formatting element (Action, Character, Dialog, Parenthetical, Transition, Shot ) in a scene or scenes 
(ie. view all the Action lines in scenes 20-30). Or you can customize the report to include a combination of elements (ie. Character and Dialog). Choosing 'ALL' elements will generate a 
report that is exactly the same as the script itself. 

To create an Elements Report.... 

●     While in Script mode select Script->Generate Report or hit the Reports icon in the Project toolbar. 
●     Reports displays with the Reports Navigator located on the LH side. 
●     Select 'Elements' from the Navigator. 
●     Select the scenes to be included from the Scene filter above. 
●     NOTE: To choose more than one item, select the first, then hold down the 'SHIFT' key and make your other selections. 
●     Then choose the Element(s) to be included from the Element filter. 
●     Once your selections are made, they will appear in the Display Window for viewing. 
●     To Print your report, select File->Print. 

Script with Notes

The 'Script with Notes' report lets you see all the notes that have been added to a script in context (i.e. inline as they were added). 

To create a "Script with Notes' Report.... 

●     While in Script mode select Script->Generate Report or hit the Reports icon in the Project Toolbar. 
●     Reports displays with the Reports Navigator located on the left hand side. 
●     Select 'Script with Notes' from the Navigator. 
●     Once you've made your selection, the script will appear with the contents of all notes displayed as they were added, in yellow. 
●     To Print your report, select File->Print. 
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Script with Notes Report

 

Script with Notes Report

A basic Calendar is provided by Celtx. It allows users to create a project calendar and schedule dates and tasks that can be shared with team members (via a WebDav folder). Users can 
create calendars on a per project basis, then filter the calendar view for a particular project, or view all of them to get a sense of upcoming dates and deadlines. 

You can also keep multiple calendars in a Celtx Project, each of which will now be included in the Collaboration sync, allowing you to share calendars with team members when you 
Upload your project to the server. 
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Scheduling Interface

 

Scheduling Interface

Adding a Calendar

Any number of calendars can be added to an open project by first selecting the 'Add Item' icon located in the Project Library Toolbar. Then select 'Calendar' from the Add Item Dialog, 
name it and hit OK. The new calendar will appear at the bottom of the Project Library. Select and double-click to open. 

Deleting a Calendar

In the Project Library, select the schedule you want to remove, then hit the red 'Delete' button located in the Project Library Toolbar. 

Technologies used

We’ve also switched to Lightning for our Calendar. The Mozilla Lightning Project uses the same code base as the Mozilla Sunbird Project, which was the previous calendar we used, so 
your dates should transfer over nicely. 

http://wiki.celtx.com/index.php?title=Print_Version_-_English&printable=yes (72 of 87) [7/19/2010 10:46:44 PM]

http://wiki.celtx.com/index.php?title=Image:Schedule.png
http://wiki.celtx.com/index.php?title=Image:Schedule.png
http://wiki.celtx.com/index.php?title=Add_Item
http://wiki.celtx.com/index.php?title=Project_Library_Toolbar&action=edit
http://wiki.celtx.com/index.php?title=Add_Item_Dialog
http://wiki.celtx.com/index.php?title=Project_Library
http://wiki.celtx.com/index.php?title=Project_Library_Toolbar&action=edit
http://wiki.mozilla.org/Calendar:Lightning
http://www.mozilla.org/projects/calendar/sunbird/


Print Version - English - CeltxWiki

The Lightning development team keeps a development weblog. It is intended for everyone who is looking for in-depth, up-to-date information about current events in Lightning 
development: 

●     Lightning Development Weblog 
●     Lightning 0.1 Release Notes 

See also

●     ScheduleCollaboration 

Celtx added an AV editor in version 0.99.5. Working in conjunction with the Typeset feature, the AV editor provides a simple, screenplay-like editing environment that uses Typeset to 
generate an industry standard two column shot format. 

The writing process is very similar to writing a screenplay, with the <Ret> and <Tab> keys providing easy navigation from one element (eg. Scene Heading) to another (eg. Action). 
You can also use the element drop down menu to change any element. 

 

This is what a script looks like in the editor: 
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And this is the same script after using Typeset: 
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Script Formatting (Film) 

Current Entity
Press Tab Press Enter (Windows) or Return (Mac OS)

Anywhere On Blank Line
Before Text or in 
Middle-of-Line

At End-of-Line

Scene Heading > Action > Action ¶ Scene Heading ¶ Action

Action > Character > Scene Heading ¶ Action ¶ Action

Character > Action > Action ¶ Character ¶ Dialogue

Dialogue > Parenthetical > Action ¶ Dialogue ¶ Character

Parenthetical > Dialogue > Dialogue ¶ Dialogue ¶ Dialogue

Transition > Action > Action ¶ Transition ¶ Scene Heading

Shot > Action > Action ¶ Shot ¶ Action

Text > Action ¶ Text ¶ Text ¶ Text 

●     Note: ">" indicates actions that convert the current element to another type, "¶" indicates that the 
remainder of the current line, if any, will be pushed below the current element, to a new one with 
the indicated formatting. 

●     Also: "Before Text or in Middle-of-Line" and "End-of-Line" commands work when the lines are 
totally blank and when the cursor is in the last position in the line, respecitvely. This does 
withstand automatically-typed characters, such as parentheses in parenthetical elements.

The Editors - Script Elements 

Screenplay

Command Windows Mac OS

Scene Heading Ctrl+1 or Ctrl-
Enter

Command-1

Action Ctrl+2 Command-2

Character Ctrl+3 Command-3

Dialog Ctrl+4 Command-4

Parenthetical Ctrl+5 Command-5

Transition Ctrl+6 Command-6

Shot Ctrl+7 Command-7

Text Ctrl+8 Command-8

http://wiki.celtx.com/index.php?title=Print_Version_-_English&printable=yes (76 of 87) [7/19/2010 10:46:44 PM]

http://wiki.celtx.com/index.php?title=Scene_Heading
http://wiki.celtx.com/index.php?title=Action
http://wiki.celtx.com/index.php?title=Character
http://wiki.celtx.com/index.php?title=Dialogue
http://wiki.celtx.com/index.php?title=Parenthetical
http://wiki.celtx.com/index.php?title=Transition
http://wiki.celtx.com/index.php?title=Shot
http://wiki.celtx.com/index.php?title=Text
http://wiki.celtx.com/index.php?title=Scene_Heading
http://wiki.celtx.com/index.php?title=Action
http://wiki.celtx.com/index.php?title=Character
http://wiki.celtx.com/index.php?title=Dialog
http://wiki.celtx.com/index.php?title=Parenthetical
http://wiki.celtx.com/index.php?title=Transition
http://wiki.celtx.com/index.php?title=Shot
http://wiki.celtx.com/index.php?title=Text


Print Version - English - CeltxWiki

●     Note: See, "notes" below for written 
keyboard command conventions. 

Stage Play

Command Windows Mac OS

Act Ctrl+1 Command-1

Scene Heading Ctrl+2 Command-2

Stage Direction Ctrl+3 Command-3

Character Ctrl+4 Command-4

Dialog Ctrl+5 Command-5

Parenthetical Ctrl+6 Command-6

Transition Ctrl+7 Command-7

Text Ctrl+8 Command-8

●     Note: See, "notes" below for written 
keyboard command conventions. 

Audio Play

Command Windows Mac OS

Scene Heading Ctrl+1 Command-1

Production Note Ctrl+2 Command-2

Character Ctrl+3 Command-3

Dialog Ctrl+4 Command-4

Parenthetical Ctrl+5 Command-5

Sound Ctrl+6 Command-6

Voice Ctrl+7 Command-7

Music Ctrl+8 Command-8

●     Note: See, "notes" below for written 
keyboard command conventions. 
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A/V

Command Windows Mac OS

Scene Heading Ctrl+1 Command-1

Shot Ctrl+2 Command-2

Character Ctrl+3 Command-3

Dialog Ctrl+4 Command-4

Parenthetical Ctrl+5 Command-5

●     Note: See, "notes" below for written 
keyboard command conventions. 

Comic Book

Command Windows Mac OS

Page Ctrl+1 Command-1

Panel Ctrl+2 Command-2

Caption Ctrl+3 Command-3

Character Ctrl+4 Command-4

Balloon Type Ctrl+5 Command-5

Balloon Ctrl+6 Command-6

●     Note: See, "notes" below for written 
keyboard command conventions. 

Page Breaks

To insert a manual page break select the following: 

Command Windows Mac OS

Page Break alt + Enter option + Return

http://wiki.celtx.com/index.php?title=Print_Version_-_English&printable=yes (78 of 87) [7/19/2010 10:46:44 PM]

http://wiki.celtx.com/index.php?title=Scene_Heading
http://wiki.celtx.com/index.php?title=Shot
http://wiki.celtx.com/index.php?title=Character
http://wiki.celtx.com/index.php?title=Dialog
http://wiki.celtx.com/index.php?title=Parenthetical
http://wiki.celtx.com/index.php?title=Page
http://wiki.celtx.com/index.php?title=Panel
http://wiki.celtx.com/index.php?title=Caption
http://wiki.celtx.com/index.php?title=Character
http://wiki.celtx.com/index.php?title=Balloon_Type
http://wiki.celtx.com/index.php?title=Balloon
http://wiki.celtx.com/index.php?title=Page_Break


Print Version - English - CeltxWiki

Options 

Command Windows Mac OS

Select all Ctrl+A Command-A

Cut Ctrl+X Command-X

Copy Ctrl+C Command-C

Paste Ctrl+V Command-V

White Space Shift+Enter Shift-Return

Bold Ctrl+B Command-B

Italics Ctrl+I Command-I

Underline Ctrl+U Command-U

Undo Ctrl+Z Command-Z

Redo Ctrl+Y Command-Y

Find & Replace Ctrl+F Command-F

Find Next Ctrl+G Command-G

Find Previous Shift+Ctrl+G Shift-Command-G

New Project Ctrl+N Command-N

Open Project Ctrl+O Command-O

Save Ctrl+S Command-S

Print Ctrl+P Command-P

Tab Switching Ctrl+tab cmd+option+left/right

●     Note: See, "notes" below for written keyboard command 
conventions. 

Notes 

●     Note: To insert a parenthetical into a block of dialogue, press Shift+Enter, Shift+Enter, Tab (Windows) or Shift+Return, Shift+Return, Tab (Mac OS). 
●     Note: By convention, written keyboard shortcuts in Windows use a "+" and in Mac OS use a "-" to denote that keys are depressed at the same time, rather than in sequence. 

Pressing the "+" or "-" key along with the keyboard shortcut will cause the command not to work. 

See also 

●     Original Forum Post 

This section of useful links and resources was born on the Celtx Forum and compiled as a group effort by our users and staff so that everyone can share 'the knowledge'. Primarily we 
look for links related to screenwriting, filmmaking, theatre, animation, new media, the industries in general, related technology, or really anything you find useful in getting your job 
done... whether you are student, amateur or pro. 
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Like the manual itself, this section is a work in progress with new links being added all the time. So if you have a golden nugget of info that would enhance the collection, please add it 
to the list. (Note: Main topics are in alphabetical order.) 

Filmmaking Resources

●     Australian Film Commission FAQs
●     CyberFilmSchool
●     Film Info
●     Online resources for film pre-productions
●     Proletariatpictures Links
●     studentfilmmakers.com
●     Wikibooks Movie Making Manual
●     Movie_Making_Manual-Linux_in_film_production Linux in film production 

Film Festivals

●     Film Festivals Server 
●     WithoutaBox 

Film Music

●     Film Music on the Web 
●     Music on the Web other links 

Glossaries

●     Movie Terminology Glossary 
●     John August Glossary 
●     John August's Wiki 
●     imdb Glossary 

Production Forms

●     dependentfilms

Movie and TV Resources

●     Free Movies & Documentaries & Cartoons & Music
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●     Greatest Films
●     Internet Movie Database
●     Inside Film Magazine
●     Roger Ebert
●     Rotten Tomatoes
●     Screenplay Europe
●     The Trailer Park
●     TV Party
●     TV To Me
●     Yahoo! Movies

Screenwriting Contests

MovieBytes

Technical Resources

DV Resources

●     DV Creators.net
●     DV Guru
●     DV Information Network
●     DVXUser.com
●     dvcafe - Not a great site, but it has some content. Some links go to books you have to buy, but others are useful articles. It takes some surfing to find the good stuff. 

Mac Related

●     Mac Widgets for Filmmakers

Open Source Software-Industry Related Applications

●     Audacity - An audio editor that does multi-tracking 
●     AviSynth- A "middleman" interface that allows users to process their video with an infinite amount of options. AVISynth uses a scriptable interface so editors can write their 

own preset codes and modify them to their own need every project so they aren't restricted to a GUI. AVISynth includes a VirtualDub interface for easy integration. 
●     Blender - 3D Rendering Tool - 3D modeling/animation
●     Celtx - A comprehensive scriptwriting and pre-production software program for people working in Film, TV, Theatre and New Media.
●     CeltxWiki Manual
●     Celtx Media Blog
●     Cinelerra - Non-linear Editing Suite
●     Cinelerra Tutorial
●     Cinepaint- Image editor used in many films
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●     Flash for Linux - f4l is a free open source Maacromedia flash clone for Linux. 
●     FreeFrame - Plugins for various editors and image editors 
●     Gimp - A good alt to Photoshop 
●     Jahshaka - Real time editing and effects 
●     Kino - Linux editing suite 
●     Open Office 
●     Synfig - A professional quality 2-d animation program. 
●     Virtual Dub - A video capture/processing utility for 32-bit Windows platforms licensed under the GNU General Public License (GPL). 

Theatre Resources

●     New York theatre scene
●     The WWW Virtual Library of Theater and Drama
●     Yahoo Performing Arts

Writing Resources

●     ClicheFinder 
●     David Griffith's Crash Course in Screenwriting (pdf) 
●     Free Range Librarian 
●     Oscar Script Format 
●     Paul Brians' Common Errors in English Usage and Other Good Resources 
●     Resources for Writers 
●     Rhyming Dictionary 
●     Roget's Thesaurus 
●     Screen Story Writing 
●     Screenwriting Expo 
●     Screenwriting Info 
●     Seventh Sanctum 
●     The Slot 
●     Wikipedia Screenwriting Entry 
●     WordPlayer 
●     WritingTreatments.com 
●     SimplyScripts Glossary - Gives a lot of screenwriting terms to help decipher scripts or get across an effect exactly the way you want. 
●     Fiction Factor - GREAT website for writers in general. Lots of topics about making good characters and stories. I suggest you browse this site for whatever interests you! 
●     A Short Story on length discusses appropriate length for speculative scripts. 
●     Screenwriting - quick resource links to everything to do with screenwriting. 

Screenwriter Blogs

●     Complications Ensue 
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●     I Find Your Lack of Faith Disturbing 
●     John August 
●     Kung Fu Monkey 
●     Pianista en un burdel (spanish) 

Scripts

●     Hollywoodlitsales 
●     Drew's Script-o-Rama 
●     Screentalk Biz 
●     ScriptCrawler - A database of scripts to view. Pick your favorite movie, and examine it. 
●     ScriptPimp 
●     SimplyScripts 
●     SoYouWannaSellAScript 

Essential URLs (Useful Links and Resources)

●     File Factory - Great for hosting your PDF generated scripts. Although it's hard to find how to download it for some people. 
●     OhShare - is a great file host! I recommend using them to host your files on the forum rather than File Factory because it's easier for users to figure out how to download the file. 

sitvitrocr 

External Glossary Links 

Screenwriting.info's Glossary 
SimplyScripts' Glossary 

Feel free to contribute to our own glossary of media making terms. 
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●     Aspect ratio of an image is its displayed width divided by its height 

B 

C 

●     Call Sheet - a list of actors required for a day's filming 
●     Casting call 
●     Celtx - The coolest Pre-Production software, EVER!!!! 

D 

E 

F 

G 

H 

I 

●     Intertitle - text for the purposes of placing the scene in time and/or space 

J 

K 

L 

M 

N 

O 
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P 

●     Polish - insignificant changes to a script 
●     Pre-Production - all the work done on a movie prior to filming it 

Q 

R 

●     Rewrite - significant changes to a script 

S 

sides - scenes from the script that actors read for their auditions 

T 

●     Title card - text for the purposes of placing the scene in time and/or space 

U 

V 

Voiceover - Usually abbreviated as VO, an offscreen narration performed by a voice Actor 

W 

X 

Y 

Z 
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Bug Fix 

●     Updated the save process 
●     Improved project recovery after unexpected OS shutdowns. 

Version 2.0.1 updates listed below. Released April 30, 2009 

Bug Fixes 

Launch Bug - Notifier Feeds - The application no longer waits for the Notifier feeds to populate before opening. 

Schedule Prefs - Changes made to the default settings for the Production Schedule now persist after a close. 

Keyboard Beeps (Mac only) - Keyboard short cuts no longer cause a Beep! 

Multiple Openings (Mac only) - Celtx no longer lets multiple instances of the same project from being opened at the same time. 

Install Bug - Profile Upgrade Bug - An install bug that prevented Celtx from launching due to a Profile issue is squashed. 

Form Tab - Closing on Deletion - Deleting an item in a Catalog will automatically close any corresponding open Tab. 

Drag and Drop in Project Library - Improved drop behaviour ensures the item gets placed at the intended target in the Library. 

Editor Cut and Paste Bug - Squashed a cut and paste bug that effected all the editors. 

Install Bug - Missing Windows dll - Fixed an issue affecting Windows users who were missing a dll file. 

Catalog - Print Preview (Windows only) - Print Preview now behaves properly in Catalogs. 

Catalog - File -> Print - 'Print' from the 'File' drop down no longer goes inactive. 

Recent Projects Opening (Mac only) - The 'Recent Projects' list in the toolbar populates properly. 

Auto Parenthetical - The Parenthetical feature now behaves properly across all editors. 

Production Schedule Call Sheet Date Select - A bug has been resolved ensuring Call Sheets display the correct date. 

Index Card Plot Renaming - Deleting the Plot Names no longer causes problems in the Index Cards. 

●     This version supersedes the 2.0.1 Release Notes 
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●     This version was superseded by the 2.5 Release Notes on 2009-November-06 

Portable Celtx is a version of Celtx that utilizes Portable Firefox as codebase. Portable Celtx adds considerable convenience for people who use Celtx on various computers by not 
requiring installation. It can simply run from a USB stick or other portable storage device. 

The project has been hosted by Sourceforge since January 2007. You can see the download statistics from that page. Portable Firefox is available under the Mozilla Public License 1.1 
(MPL 1.1), and Portable Celtx is available under the GNU General Public License version 2 (GPL v2) and the Celtx Public License (CePL). 

As of November 15, 2007, the newest portable version for Windows is 0.996. As of January 11, 2008 the newest Mac OS X version is 0.997 r1.0. These versions are created by Jacob 
Koehler and are based on Portable Firefox and the original Celtx program files. You can download the Mac port from the official project homepage. 

Celtx also runs from a USB flash drive, or any other form of portible media, if you run the standard install, and target it to your device. 

REMEMBER! your portable device MUST be plugged in to do this. 

Additionally, you can run the standard install and copy-paste the Celtx folder in your Program Files folder on your computer to your portable flash drive. Both of these methods are 
"just works" methods and are not truly "portable", meaning that while they will run from your portable device, they leave files on the computer you are using, usually in the AppData or 
Application Data folder. 

Remember: you can also follow the additional steps listed in the Installation article, which deal with missing DLLs and the extra dictionaries. 

External links

●     Portable Celtx Homepage (English) 
●     English Version of Portable Celtx 0.9.8 in the Celtx Forum 
●     Portable Celtx Sourceforge project 
●     Shell script source code 

Announcement of Portable Celtx for Mac OS X 

●     versiontracker.com 
●     macupdate.com 
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