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Graphical Analysis for Windows®

How to Use this Manual

This manual is divided into three main sections: the User’s Manual, the Teacher’s Guide, and the Reference Section.
The User’s Manual includes a quick introduction to the most important features of the program. The Teacher’s Guide
contains suggestions on how this program can be used in the classroom. It also gives information on all the sample files
on the disk. The Reference Section explains al the features and menus of the program in some detail. Refer to the
Reference Section if you have questions about the program.

Some familiarity with the use of Windows and a mouse is assumed in this manual.
If thisisthefirst timeyou are using the Graphical Analysis program, look over the User’s Manual. Refer to the
Built-in help when you want to learn more about other features of the program.

If you want to learn how to install Graphical Analysis on your computer, read “ Getting Started” at the beginning of
the Teacher’s Guide. This section explains how to install the Graphical Analysis for Windows software.

If you have a particular question about program operation, Graphical Analysis for Windows has extensive Built-in
help describing every menu item, every dialog box, and every type of window. To use the Built-in help, highlight the
item of interest and press the <F1> key. Y ou can aso get help when you press the key combination <shift> + <F1>,
move to the item of interest, and click the mouse. The Reference Section of this manual contains answers to specific
guestions.



Graphical Analysis for Windows is a copyrighted program by Vernier Software. The program disk does not have any
copy protection and back-up copies may be made using standard procedures. Purchasers of Graphical Analysis are
permitted to make as many copies of the program as they wish for use within their own high school or college
department. Making copies for any other purpose is prohibited.

Graphical Analysis for Windows was programmed by Mark Topinka and Chris Chamberlin and is copyrighted (©
1995) by Vernier Software. The program was designed by David L. Vernier, Mark Topinka, and Chris Chamberlain.
The Help system was written by Chris Chamberlin, David Gardner, and Rick Sorensen. This manua was written by
David L. Vernier, Rick Sorensen, and David Gardner. It is copyrighted (© 1995) by Vernier Software.

Vernier LabPro is trademarked by Vernier Software and Technology.

Microsoft, Windows, and MS-DOS are registered trademarks of Microsoft Corporation.

Calculator-Based Laboratory, CBL 2, CBL, and TI-GRAPH LINK are trademarks of Texas Instruments, Inc.
Hewlett-Packard, HP, and LaserJet are registered trademarks and DeskJet is a trademark of Hewlett Packard Company.
Macintosh and Apple are registered trademarks of the Apple Computer, Inc.

Turbo Pascal is aregistered trademark of Borland International, Inc.
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Graphical Analysis for Windows®

USER’'S MANUAL

General Description of the Program and Built-in Help

Graphical Analysisfor Windows is a user-friendly program that allows you to easily graph and analyze data. Data may
be manually entered from the keyboard, pasted from the clipboard, or retrieved from afile saved on disk. Y ou can even
import datafrom Texas Instruments T1-73, T1-82, T1-83, TI1-83 Plus, T1-85, TI-86, T1-89, TI1-92 and T1-92 Plus
graphing calculators and LabProd or Calculator-Based Laboratoryd (CBLO, CBL 200) interfaces. Data can be
displayed in spreadsheet form and as a graph. Y ou have several options on the scaling and style of graphs. Powerful
data analysistools are provided, including curve fits, derivatives, tangent lines, integrals, smoothing, FFTs, and
histograms. Graphical Analysis allows you to create new columns that are based on other data, much as you might do
with a spreadsheet program. Since thisis a Windows program, you can easily copy your data and graph to aword
processing or spreadsheet program viathe clipboard. Several sample files are included for your experimentation.

The Graphical Analysis program has been designed with non-overlapping windows. We chose this approach because
overlapping windows often cause confusion. As you create new windows, the screen will be subdivided among al the
windows without overlapping. Y ou can adjust the size of windows by dragging the horizontal and vertical dividers that
separate them. Y ou can set up the screen with up to ten windows open at one time.

In previous versions of Graphical Analysis, the emphasis has been on teaching students to modify their data with
mathematical operations. They would then create and analyze graphs looking for linear relationships. This approach is
still supported in this program and explained in the “ Graphing Modified Data” section of the User’s Guide. In addition,
we have added curve fitting to this version. Students can easily fit a curve to data and quickly test various mathematical
models. Curvefitting is discussed in the “ Automatic Curve Fitting” section of the User’s Guide.

Built-in Help

This manual will give you an introduction to Graphical Analysis for Windows. Much more information about
this program isincluded in the Built-in help. Y ou can access the Built-in help in severa ways:

» Toget abrief description of apart of the screen, move the mouse over that part and read the short message
displayed in the help bar at the bottom of the Graphical Analysis window.

» To obtain help information, simultaneously press the <shift> + <F1> keys. The cursor turnsinto a question
mark. To get help on a button or awindow, click on the object. To get help with a menu option while the
cursor is aquestion mark, click the menu and hold the mouse button down, drag down to the option of
interest and release the mouse. Help information will be displayed for each item you access.

» Toget help on aspecific item or dialog box, press F1 while you are accessing the item.

» A Table of Contents for the Help program is available from the Help menu. To use it, choose Help Contents
from the Help menu. Y ou will be provided with alist of four general help topics. These topics include
Getting Started, How to (perform certain operations), Menus, and Windows. Y ou also have accessto the
Search feature of the Help system. Click on the Search button found in the toolbar of the Help program. A
dialog box will appear from which you can typein akey word. As you type in aword, the search list will
automatically scroll through an alphabetical list of topics.

The Graphical Analysis Program for Windows version is designed to operate on a PC computer running Windows
version 3.1 or Windows 95/98/2000/2000ME/NT 4.0. An MS-DOS® version of this program has been available for
several years. It includes most of the features of the Windows version. It is a menu-driven program and does not
reguire amouse. It works on any PC computer with 640K of memory. If your computer is not capable of running the
Windows version, contact us about exchanging for the MS-DOS version. Macintosh® and Apple® Il versions of
Graphical Analysis are also available.



Graphical Analysis for Windows USER’S MANUAL

Fast Start (If you don’t read manuals)

Many computer users do not believe in manuals. If you are one of them, we offer thisinformation to get you
started with Graphical Analysis.

» Double-click the Graphical Analysisicon.

» Click the OK button in the About box to continue.

* Enter datainto the data table.

» Double-click on the graph to add features to the graph.

» Click on the numbers at the ends of the axes to change the scaling.

» Experiment with the Zoom buttons, the Analyze button, and the Tangent button.

» Click and drag through a section of the graph to use the Integrate and Linear Regression button.

» Choose New Window or Replace Window from the Window menu item to add new windows. Choose
Arrange Windows from the Window menu to rearrange the window layout.

» Try the various menus. Have fun experimenting. If you have questions, check the Built-in help. If all else
fails, remember thereis a manual.

Using the Graphical Analysis Program

Typical Screen

Start up the program by double-clicking on the Graphical Analysisicon. Click the OK button in the About box to
continue. You will be presented with a blank data table and graph. A typical Graphical Analysis screen is shown below.
(The data and graph was taken from the STROBE.DAT file included with this program.) This screen includes three
different windows with a menu and atoolbar at the top. Important features of the window have been identified on this
figure.

Graphical Analysis [ "cAwin_galdecay.dat"]
Menu Bar —»|F
Tool Bar —»
Control Box — Data Table Window ] =] Graph Window - I "ﬁ{mdow
Data Set Titlle — Data Set 1: Data 500 Rate vs. Time Title Bar
i
i b min|
Column Title —
12.000
Cell Being e
Edited {} . « Graph
w300k Window
g o
o
Z 20 Y < Floating Box
& o
=]
100 @
© e, |11 Label Axis
=]
Data Table —] . , e e
20 40 G0 100 120 140
L] Time(min%_//—
=] Text Window -
Data on the decay rate | ] of a radi ive ple taken from a 1941 ki
issue of the "Physical Review." L
-+ Text Window
[+]
Help Bar —j——»

A Typical Graphical Analysis Screen
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As you work with the Graphical Analysis program, you can choose from five types of windows:

e Data Table windows use atable to display datain the same way a spreadsheet does.

e Graph windows plot data on a scatter graph.

«  Histogram windows plot the number of occurrences of the various data values.

e Fast Fourier Transform (FFT) Graph windows plot the frequency components of a column of data.
e Text windows display notes about the data or graphs.

When the program starts, the screen will have a Data Table window on the left and a Graph window on the right. A
small Text window will be displayed in the lower left. Only one window can be active at a time and it will have the
same color or shading as the Graphical Analysis Title Bar. You can make a window active by simply clicking it with
the mouse.

Entering and Editing Data

The first step in using Graphical Analysis is usually entering a table of =] Data Table Window | +]
data. Most data tables will have two “manually entered” columns. The 2.5° Incline: Data
blank data table to the right has been set up so that Time (X-axis) and Time Distance

(s} {cm)

Distance (Y-axis) can be manually entered into the first two columns. To
enter the time and distance data, simply click a cell and start typing.
When you have completed an entry, press the <tab> or <enter> key to
move to the next available blank data cell in the table. For example, after
entering data in the first row, press <tab> to move the cursor to the first
cell in the next row. After each data pair has been entered, the
corresponding data point will be graphed. As you make entries, the
program will check to make sure that you have entered a valid number. If
your entry is not valid, the cell will not be updated.t

o=t oa ko —

The figure to the right shows a completed data table. Editing a cell is |3 Data Table Window 4]
easy. Use the mouse or keyboard to select the cell you want to change. 3.5° Incline: Data
(To move horizontally with the keyboard, use the <tab> or <enter> keys. Time Distance

To move vertically within the data table, use the up or down arrow keys.) (=) (i)
Once the cell is selected, edit the cell by either typing in a new value, or g:ggg gg:ggg
using the left and right arrow keys and the delete keys to change a =700 anonn
limited number of digits in the entry. To accept the changes and 4.200 50,000
automatically adjust the graph, press <enter>, <tab>, or either the up or 4.500 £0.000
down arrow. (The changes will also be accepted if you click another cell 4.900 70.000
with the mouse.)

Qo= ||| | ko —

If you are entering numbers in scientific notation, usethe “E” or “€” key asin the examples below:

To enter this number: Typethis:
35x 104 35E4
24x103 24e3

55x 1012 55E-12

Editing the Axis Labels, Units, and Graph Title

When the program starts, the labels for the horizontal and vertical axes are simply X and Y, and no units are displayed.
To change this, double-click the top cell of either column and enter the new label and unit in the pop-up menu that
appears. Click the OK button to accept the changes. To change thetitle of the graph, click the title of the graph window
and enter anew title in the pop-up box that appears.

1The range of numbers allowed to be entered is-1.7 x 10308 to 1.7 x 10308,
9
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Changing Display Features of a Graph

To change a graph, move the mouse to the graph and click it once to make the graph the active window. Now try
selecting different options from the Graph menu. Selecting a menu item togglesit on or off. If anitemis preceded by a
check mark, theitemison. Hereisalist of the available options:

« Point Protectors (small squares, triangles, etc., that make the data points more visible)
e Error Bars(marksthat can indicate the uncertainty in the data)

¢ Connecting Lines (straight-line segments from point to point)

e Bar Graph (bars extending from the bottom of the graph to the top for each data point)
e Background Grid (a pattern of background dots on the graph)

* Legend (small box matching point protectors, data columns, and data sets)

Changing the Scale of a Graph
In most circumstances, the axis scales of the graph are automatically

Choose which columns to plot:

) AutoScale at 0
3] Volume HaOH O Autoscale

@ Manual Scaiing:

adjusted by the program, but you may want to change them. To change
the scale of a graph, move the mouse to the graph and click either axis

label. A dialog box like the one to the right will appear. ket Limi zz
You have three different choices for the scaling of each axis. If you R

select Manual Scaling, you can enter the minimum and maximum values
to be used on the axis. Enter the appropriate value in each box. If you

| Ok I| Cancel ” Help I

choose Autoscale, the program will automatically calculate a scale for the graph, just fitting all the points on the graph.
If you choose Autoscale at Zero, the program will automatically choose the axis scale, but it will aways include zero
on the axis.2

There is another way to quickly adjust the axis limits from the graph itself. You can change each limit by clicking on
that limit, entering a new value in the small box that appears, and pressing <enter>.

Zooming In on a Graph

You can zoom in on any region of a graph to examine it more carefully. When = ph vs. Volime NaOH
you want to zoom in, click and drag the mouse over the region and click the Zoom N -
In button (3 on the toolbar or choose Zoom In from the Graph menu. The [¢"
program will then adjust the scales of the graph so that only the region included in | N
the rectangle is graphed. For example, a small section of the graph on this graph \ M fffffffffff
has been selected with the mouse. N .
° (1221 VoluLieNaOrzumL) éﬁb : =

After selecting Zoom In, this region is expanded to yield the graph to the right.

@

E

, L ,
22 B 3l

| \
24 6 E
< Volume NaOH {mL) >

2If the numbers to be graphed are all positive, the axis will start with zero. If the numbers to be graphed are all
negative, the graph will end with zero. If both positive and negative numbers are to be graphed, the scale will be
adjusted to include both positive and negative values.

10
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Analysis Tools

Five very useful analysis tools can be found on the toolbar. Those tools are available by clicking any of the following

¥

o 0
buttons. Examine ‘==z, Tangent Line , Integrate I , Regression Line ’ﬁf or Curve Fit "=, (Note that these tools
can aso be found in the Analyze menu.)

The Examine feature of the program will display the values of an individual data point. Click the Examine button on
the toolbar and move the cursor across the graph. A vertical line will be drawn through the data point closest to the
cursor and a box will display the values that correspond to that point.

Graph Window

3500 Pressure vs. Volume

3000 o]
i °
g 2s00F ©

@
g o]
E @
7 o |Press: 1882775 mm HG
@ Yo
o o]
L1500 @ o
o]

g oo,

1000 F ?a

o)
T oo,
SDD 1 1 1 1 1
a 10 14 20 25 30 34
<O Volume (cm) >

Using “Examine Data”

The Examine option works on any graph window. When you are finished examining the data, click the Examine button
or deselect the Examine option from the Analyze menu.

To see the tangent line, click the Tangent Line button and move the mouse across the graph. As you do, atangent line
will be drawn at each data point. A floating box will also display the numeric value of the slope at that point. To turn
off the tangent line, click the Tangent Line button or deselect the Tangent Line option in the Analyze menu. The
number of points used to calculate the slope is controlled in the Preferences option in the File menu.

To determine the integral, click and drag the mouse across the region of interest on the graph, then click the Integral
button. The area under the curve will be shaded and a box will display the numeric results. (Theintegral is calculated
using the trapezoid method.) To remove this information and the shading from the graph, click the small box in the
upper-left corner of the floating box.

The Regression Line button is used to calculate the best-fit line for a selected curve or region of acurve. Tofit a
regression lineto a set of data, click and drag the mouse across the entire graph, then click the Regression Line button.
A best-fit line will be drawn on the graph and a floating box will display the numeric results. To fit aregression line to
only aportion of the data, click and drag the mouse across the area of interest, then click the Regression Line button.
To remove this line and the curve fit information, click the small box in the upper-left corner of the floating box.

Y ou can use the Curve Fit button to fit various mathematical equations to the data. This processis explained in detail
in the “ Automatic Curve Fitting” section of the User’s Manual.

Displaying a Range of the Graph

If you need to determine the difference between two points on a graph, you could examine the data at the two points,
record the point coordinates, and make a calculation. Alternatively, click the Examine button so that it is active. Hold
the left mouse button down and drag it over the region of interest in the graph. A box will appear in the upper-left
corner of the graph from which you can read the changesin the X and Y values. This feature can be helpful in analysis
situations such as determining the amplitude and period of a periodic wave or determining the change in temperature
during an experiment.

11
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Creating a New Column of Data

One of the most useful features of Graphical Analysisis the ability to plot graphs of modified data. Thisis extremely
helpful in looking for the relationship between variables. The section entitled “ Graphing Modified Data’ later in this
User’s Manual has several examples showing the use of this concept.

To create anew column, click the @ button for a calculated column or the E

Hew Column Hame: Hew Column Units:

button for amanually entered column. Alternatively, choose New Column from the

s [ Data menu and choose between a calculated column and a manually entered
Hows Cotum Defnition: column. If you choose a manually entered column, enter the name and units for the

new column and click OK. If you choose to add a calculated column, the pop-up
screen to the left will appear. Enter the name and units for the new column and

move to the New Columns Definition box. Define the new column in this box by
either typing in aformulaor by clicking the various buttons provided. If you choose
[ [ [ [ to type in the formula, you must include the name of any column in double quotes.
0 | [ [ The easiest method is to use the mouse and click the various buttons in the dialog
I | box. These buttons include a calculator keypad with standard mathematical
%%% functions, a button labeled “Columns’ that provides alist of all existing columns

that can be used, and a button labeled “ Other Functions’ that provides alist of
various functions to apply to the columns—functions such as derivative, integral,
smoothing, and absolute value.

To demonstrate this process, consider the example where you have pressure and volume data from an experiment and
it is stored in columns labeled “ pressure” and “volume”. (A sample set of data can be found in the BOY LES.DAT file
included with this program.) In addition to a graph of pressure vs. volume, you might want to graph pressure vs. the
reciprocal of volume. Start by adding a new calculated column to obtain the above New Column dialog box. After
entering “reciprocal volume” for the new column name and “reciprocal mL” for the new column unit, click the New
Column Definition box. Next click the “1” key on the calculator followed by the “divide” key. Click the Columns
button to pull down alist of columns. Choose the “volume” column. The column definition will now read: 1/*volume”.

Click OK to save this new column. The new column will appear in the data table and will be available for graphing by
clicking on any axis label.

Modifying Data and Its Display

To modify a column of data, double-click on the column heading of the data to
be modified. Thiswill bring up the Column Options dialog box from which you "% 0" Options

can change the label, units and definition of the column. The precision of the newhame: [ ]
data can be specified by choosing either decimal places or significant figures T
and entering the number of digits that will be displayed in both the data table )

and graphs. In addition, the point protector symbol, the column color, and the | "o Preesters Coaxoemas

1 alumn Color: HEEEEERENC

size of the error bars can be chosen. Column Col EECOCOEEDO
e ey . . . ing: @ Dec. Places

When the definition button is clicked and the column is a calculated column, || **"*™ & vew.pices ]

the Edit Column Definition dialog box will appear, alowing the definition of Error Bars: 53 percent
the column to be changed. The column will be updated after you redefine the
column.

Definition: Raw Data Column.

| Ok I | Cancel I |Deﬁni‘tiun...| | Help I

Changing What Is Graphed on an Axis

To change which columns are plotted on a graph, simply click on the axislabel. A pop-up menu listing al the columns
in the data table will be displayed. Y ou can choose what you want graphed on the axis from this menu. Any number of
columns can be plotted on the Y -axis, but only one column may be plotted on the X-axis.

12
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Creating a New Graph

To create anew graph, select either of the last two options in the Window menu. Since all windows on the screen are
non-overlapping windows, the New Windows option divides the area held by the currently selected window into two
equal areas. The original window remains and a pop-up menu appears from which you select the style of the new
window. To create a new graph, choose the Graph option. The New Window 100 option adds the new graph by
splitting the current region of the display vertically into non-overlapping windows. The New Window = option
splits the old window horizontally. The new graph will contain no data and blank axes. Click on each axisto select the
variables to be graphed. Changes can be made to this new graph as they were with the first graph. The second graph
can be used to display different columns of data or the same data with different scales and graph styles. Additional
graph windows can be created, but the screen can only have ten windows open at one time.

Multiple Data Sets

As you have seen, Graphical Analysis data are stored in columns Data Table Window
i T+ 2.5° Incline: Dat: 1.0% Incline; Dat:
and rows but data can also be stored in additional data sets. The o fnene: Dats 10 incine: Data
use of different sets of data is a good way to compare various (=) {cm) (=) (L
2.700 20.000 1.900 20.000

experimental results when an experiment is being repeated under
different conditions or for different experiment runs. For
example, the figure to the right shows time and distance data for
aball rolling down aramp in two different runs. The data set on
the left was collected when the ramp was inclined at 2.5° while
the ramp was inclined at 1° for the second data set.

3300 30,000 2.500 30.000
3700 40.000 2.800 40.000
4200 S0.000 3100 S0.000
4500 60.000 3.500 E0.000
4800 70.000 3600 70.000

1
2
3
4
5
-]
il
g
]

Each data set in a Data Table window contains the same set of columns and each can be graphed separately. When
several data sets are combined on a graph, every set has a different shape point protector, a separate point-to-point line,
and separate curve fit lines. Graphing the various data sets on the same graph provides a convenient way to compare
results.

To create a new data window, select New Data Set from the Data menu. The new table will appear in the data table.
Numbers can be entered into these new data set columns as they were in the original data columns. Y ou can control
which data sets appear on a graph by clicking the Y -axis label and checking or unchecking the box for each data set.

Any one Graphical Analysis file can have up to nine data sets. Each data set can have up to twenty columns and as
many as 8000 rows of data.

Renaming Data Sets

Y ou may want to rename the data sets you create so they have meaningful names, such as “Joe’ s data’ or “Run #2,
with 5-gram mass.” The name of the data set appearsin the title of the data set column and it can also appear in the
legend on the graph if you activate the legend option. To rename a data set, double-click the data set name and enter a
new name or modify the existing name that appears in the pop-up dialog box.

Printing Graphs or Data

To print agraph or datatable, select the Print option in the File menu. A pop-up menu displays three options: Data
Table, Selected Display, and Whole Screen. The Data Table option will print the entire data table, including rows not
displayed in the window. This option may produce many pages of paper. The Selected Display option only prints the
active window on the screen. It can be used to print graphs, data tables and other windows. If you select this option for
alarge data table, the entire data table may not appear.

To print agraph, first select the graph by clicking it, then select the Selected Display option. To print the entire screen
including all windows, select the Whole Screen option. If you have a Text window that contains more text than can fit
in the window, a scroll bar will appear on the right hand side of the window. To print all the text, you will need to click
the Text window and select Copy Text from the Edit menu. Paste the text in aword processor and print the text from

the word processor. If you want to quickly print the active window, click the button on the toolbar. Make sure the
correct window is active before you start printing.
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In printing with a network, it is useful to attach an identifying header. To do so, select the Printer Setup option from the
File menu. A pop-up menu will appear. If you check the Name checkbox, you can enter your name and it will appear in
the upper-left corner of the printout. If you check the Date checkbox, the date will appear in the upper-right corner of
the printout.

Transferring Graphs and Data to Other Applications

In many cases, it can be useful to transfer graphs created in Graphical Analysisto another Windows program. For
example, you may want to include the graphsin a report being written with aword processing program. To copy a
graph, make sure the graph window is active and then choose Copy Window from the Edit menu. This places a bitmap
of the graph in the Windows clipboard. If necessary, you can store the graph to afile. Later, you can paste the graph
into another application.

Y ou may also want to transfer data from a Graphical Analysis data table into another application, such asa
spreadsheet. The easiest way to make thistransfer isto copy the data from the Graphical Analysis data table window to
the Windows clipboard. Y ou can then paste it into the other application. If necessary, you can store the data
temporarily in aclipboard file. To copy awhole data table, make sure the data window is active, choose Select All from
the Edit menu, then choose Copy Data Set from the Edit menu. If you want to get only part of adatatable, drag the
cursor across the data table until all the data you want is highlighted, then choose Copy from the Edit menu. Once the
data has been copied to the clipboard, open the new file and paste in the data. Graphical Analysis can aso create text
files that can be opened by other applications. This procedure is explained in the section Saving Information.

Transferring Data from Other Applications

Y ou may also want to transfer data from another application, such as a spreadsheet, into a Graphical Analysis data
table. The easiest way to make this transfer is to copy the data from the other application to the Windows clipboard.
Y ou can then paste it into the Graphical Analysis Data Table.

To copy awhole data table, make sure the data window is active, choose Select All from the Edit menu, then choose
Copy Data Set from the Edit menu. If you want to copy only part of a datatable, drag the cursor across the data table
until al the data you want is highlighted, then choose Copy from the Edit menu. Once the data has been copied to the
clipboard from another application, switch back to the Graphical Analysis program. Click on the first column of the
Graphical Analysis Data Table and then select Paste Data from the Edit Menu or press CTRL+V.

Saving Information

After you have entered, edited, and graphed information, you may want to save it on the disk. Two save commands
appear in the Graphical Analysis File menu: Save and Save As. To save your work back to the original datafile, choose
Save from the File menu. This saves the data and the graphs exactly as you have them set up. If the data have not been
previously saved, you will be asked to enter afile name. When you use the Save As... command, it makes a new file
containing the current data and graph. Save As always alows you to enter a file name and choose alocation for the
new file.

Two file formats can be used when saving the data. These are data (*.DAT) and text (*.TXT). When you save afile as
a*.DAT file, everything about that file including data, text, and graph setupsis saved. This format is the default file
format. Data and graphs are saved quickly in this format using the Save and Save As commands. To save afilein text
format, choose the Save As command in the File menu. Next, pull down the Save As Type list found at the bottom of
the dialog box and select the Text File (*.TXT) option. Files saved in text format can be opened by word processing
and spreadsheet programs. Note, however, that only the datais saved in atext file. Data saved in either format can be
opened by Graphical Analysis.
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Quit
If you want to quit the Graphical Analysis program, choose Quit from the File menu. If you are working with an
unsaved file or have entered new data, you will be asked if you want to save this information on disk before quitting.

Finding a Mathematical Relationship between Variables

An important goal of data analysisis to determine the mathematical relationship between different variables. Graphical
Analysis provides two methods to achieve this goal. One method, described in the following section, involves the
graphing of modified datato find linear relationships. The other method, described later, applies mathematical models
to automatically or manually fit a curve to the data.

Graphing Modified Data

This method of analysisis performed with columns of modified data. This concept is based on the idea that if a graph
produces data along a straight line, then

whatever you whatever you :
— the vertical
graphed on the — | graphed on the X ct:;etlhzlcl)i%z + axis intercept
vertical axis horizontal axis

If the line goes through the point (0, 0) on the graph, then the relationship is even simpler:

whatever you whatever you the s|
graphed on the — | graphed onthe X fehs (IJ_pe
vertical axis horizontal axis ofthe line
In other words, the variables graphed are proportional. Graphical Analysis provides away to experiment with different

graphs and to try to find one that produces a straight line. If you are successful, you have probably found the
relationship between the variables. The examples and graphs below illustrate this idea:

Example 1: Consider the relationship between the
variables X and Y in the upper graph shown to the right.
Clearly, Y is not proportional to X or else the graph of Y
vs. X would be a straight line. Is'Y proportional to X??
Maybe Y is proportional to X*. Perhaps the relationship is
more complicated. You can do some quick checking by
creating a modified data column and plotting a graph of
the modified data. To test whether Y is proportional to X2,
plot a graph of Y vs. X2 If this graph turns out to be a
straight line, then Y is proportional to X2, If this graph is
not a straight line, you can try plotting Y vs. X°. If this
graph is a straight line, then the relationship is that Y is
proportional to X3, Whenever the “straight line graph” is
found, you have determined the relationship between X
and Y. By trying several different graphs with X-axis data
raised to different powers, you can search for the graph

¥ §
X

Graph Window I

Y vs. XA2

5,660 53716

that gives the best straight line. In thisway, you can often find the relationship that best fits the experimental data. The
bottom graph at the right shows that, in this case, Y isindeed proportional to X2.
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Example 2: The top graph on the screen to the right
shows a different kind of relationship. What isit? Clearly
Y decreases as X increases, so you might try an inverse
relationship (Y = 1/X). The middle graph plots Y vs. 1/X
but it is not linear. The bottom graph plots Y vs. X ?and
thisislinear; therefore, Y is proportional to the 1/X 2.

This procedure is summarized below:

e =] =T Graph Window I+
Data Set 1: Data Y vs. X
Row £ v E=]
Hum ¢
T 5200 P | 075 af
56600 072 035 -
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1000 0172 415 [ . . L
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X D
=T Graph Window T
o Y vs. X1
na
-
i
v ; ‘
) 05 17 15 20 15
o X1 o
=T Graph Window T
o Y vs. Xh-2
na
-
i
o, ; , , ,
[ 2 K] 1
X2 o
[Doubie ciick for Data Tabie Options, or click & drag the mouse to select data.

1. Decide on apossible relationship between the two variables. Usually, you can do this by looking at the data table
or by looking at the original graph. Other times, the relationship to test will be suggested by ateacher, lab manual,
etc. Since it does not take very long to produce a graph using Graphical Analysis, do not worry about this choice. If
it does not work out, you can always try another graph.

2. Pull down the Data menu and choose the New Column option. Select Calculated from the pop-up menu that
appears. Enter the appropriate information in the New Column dialog box. (Refer to the Creating a New Column

of Data section for further information.)

3. Clickthe Y-axislabel of agraph to select the appropriate variable to be graphed.
4. Check the graph to see how linear it is. If it seemslinear, determine its slope and intercept. The easiest way to do
thisisto click and drag through the data, then click the Regression Line button. (Refer to the Analysis Tools

section.)

5. If that graph does not seem linear, try a different relationship. Even if the graph you made appearsto be a straight
ling, it isagood ideato try other relationships to verify that they are not aslinear.

Automatic Curve Fitting

=‘ Graphical Analysis hd

File Edit Window Data Analyze Help

Rate vs. Time

Data Tahle

@ o

)
|

7 iy il 3 700 T a0
<2 Time (min) o>

(= Text Window =

Equation: y =M+ B Mean Sar. Err = 2020 [0k koop it

M= 2.7838 B = 297.49 [ create Column i =
ancel

Try Hew Fit
0 Is this fit 0K? Hfyou are satisfied with this fit, press the "0K - Keep Fit" |I
Modify Fit

button. Press "Madify Fit" to edit the parameters in the above equation. Help

Another way to explore the relationship between variables
with this program is to fit mathematical models or curves
to data. Within the program you have two options for
curve fitting: automatic curve fitting and manual curve
fitting. When selecting the automatic curve fitting option,
you choose an appropriate model and the program will
use standard statistical formulas to calculate the
coefficients, constants, and/or exponents of the model.
For example, open the DECAY .DAT file and select the
Automatic Curve Fit option in the Analyze menu. Select
the Linear model from the Stock Functionslist. The
screen to the left will appear. It is obvious that this model
does not provide a good fit to this data. As a matter of
fact, the mean square error of 2020 is very large.

3The Teacher's Guide has more information on how to use Graphical Analysis to find the relationship between

variables.
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Graphical Analysis
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We should try another model. Click the Try New Fit
button and select the Inverse model from the Stock
Functions list. Again, the model does not provide agood
fit. The mean square error, 6280, is even larger. Click the
Try New Fit button and select the Exponential model.

This choice has provided a very good fit with avery small
mean square error, 0.453. If you click the OK - Keep Fit
button, you will return to the main screen.

The graph window will now look like the screen to the
left. The raw datawill be graphed along with the
exponential model. A floating box will be displayed on
the graph. This box will contain the model, the calculated
coefficients, constants, and/or exponents, and the mean
square error.
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Each of the above examples uses one of the stock
equations built into the program. An extremely powerful

feature of the curve fitting options is the ability to enter | ¥~ X215 |
your own custom equation. To do that, select the Perform fit on...

Automatic Curve Fit option from the Analyze menu. The [pata set :Pressure 3] [0 saatr origin
pop-up box to the right will appear with a field labeled

“y="in the top portion of the box. In the examples Stock functions... _

above, you clicked on one of the Stock functions to paste e+ chmnz i L

an equation into the field; however, you can enter any RaEmr Folynomial

equation you want using the variable X and any functions, L Inverse Sqr.

coefficients, constants, or exponents. In the example to A v mmtEe) Erponential

the right, the equation “y = A*x"2+1/x+B” has been Rt (1- expitiex) ) Reverse Exp. *
entered.

If you enter your own equation, the program determines ok || conca || wew |

the curve fit by trial and error. It tries various values,

calculates the mean square error, adjusts the values slightly and repeats the process. Y ou can watch the process as the
program tries different values. Y ou may find it interesting to see how the curve moves gradually to the best possible fit.

Asyou experiment with curve fitting, you might select the reverse exponential, sine, or Gaussian model. These models
do not have single, closed forms. In each case, the best solution is calculated by trial and error. This may take a
considerable amount of time, especially on a slow computer. While the curve fitting calculations are being performed,
you can aso click on any of the coefficients or exponentsto “suggest” a better value. This can speed up the curve
fitting process and, in afew cases, may be necessary to help the curve fitting routine find a solution. Throughout this
process, you will be able to watch the fitted curve as it is modified to fit the data.

Sample Data Files

There are anumber of sample data files on the Graphical Analysis disk that you can open and graph. Try finding the
relationship between the variables for some of them.# Y ou can use the modified data method or the curve fit method to
find the relationship between variables.

4All these sample data files are described in the Teacher’s Guide.
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Other Operations

The previous description of the manual has covered only the essential features of the program. This program has many
other features. Here is a quick summary of other operations you might want to perform. For more information on any
feature of the program, consult the Reference Section of this manual or the Help system built into the program.

Operation:

How to do it:

Create anew data set

Select the New Data Set option from the Data menu.

Resize awindow

When two or more windows appear on the screen, it is possible
to resize them. Move the mouse pointer over the space
between the windows. It will turn into a double-headed arrow
pointing in the directions that the window edge can be moved.
Click and drag the edge of the windows until they are sized as
you want them. Release the mouse.

Swap windows

It isvery easy to swap two windows using the mouse. To do
this, click and drag the title bar of one window into the other.
The mouse pointer will change, notifying you of the swap.
(Note: you can also Choose Arrange Windows from the
Window menu.)

Remove a window

Select Close Window from the Window menu or double-click
the Control box.

Delete data pairs

Select the rows and then choose Delete Data from the Edit
menu.

Delete a column or data set

Click the title of the column or data set and choose Delete
Column or Delete Data Set from the Edit menu.

Sort the data

Select the header of the column by which the datais to be
sorted, then choose Sort Data from the Data menu.

Insert data pairsinto the table

Enter the data at the bottom of the data table, then select the
Sort Data option in the Data menu. Select the appropriate
column to sort by.

Generate numbers automatically for the data table

Select acell in the Data Table and then choose Fill Column
from the Data menu to fill from that cell down.

Change the way the numbers are rounded

Select Column Options from the Data menu.

Cadlculate statistics for a column of data

Click the data table and select Data Table Options from the
Window menu, then check the Show Statistics box in the pop-
up menu that appears.

Interpolate or extrapolate from the regression line or
fitted curve of the data.

Choose Interpolate from the Analyze menu.

Copy thetitle bar and border with a window.

Hold down the <Ctrl> key while selecting the Copy Window
option from the Edit menu.

Load DatafromaTI-73, T1-82, T1-83, TI-83 Plus, TI-
85, T1-86, T1-89, T1-92, or TI-92 Plus graphing
calculator.

Connect the TI-GRAPH LINK cable. Choose Import from
TI Calculator on the File menu. Link the data using the
standard calculator keystrokes.
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Getting Started

Computer Requirements
The Graphical Analysis Program for Windows requires

(a) a386DX or newer computer

(b) Windows 3.1/95/98/2000/2000ME/NT 4.0 operating system

(c) at least 4 MB of RAM

(d) ahard disk with approximately 2MB available for the program and related files

(e) aPC VGA graphics compatible display

(f) amouse or Windows-compatible pointing device

(g) If you want to print graphs or data tables, you need a Windows-compatible printer and a properly installed print
driver. (See the Windows 3.1 manual for this information.)

Loading Graphical Analysis onto Your Hard Drive

Windows Softwar e installation

To install Graphical Analysis on acomputer running Windows 3.1/95/98/2000/2000ME/NT 4.0, follow these steps:
* Place the Graphical Analysis CD in the CD-ROM drive of your computer.

« If you have Autorun enabled, the installation will launch automatically; otherwise choose Settings - Control Panel
from the Start menu. Double click on Add/Remove Programs. Click on the Install button in the resulting dialog box.

* The Graphical Analysisinstaller will launch, and a series of dialog boxes will step you through the installation of the
Graphical Analysis software. Y ou will be given the opportunity to either accept the default directory or enter a
different directory.

Using Graphical Analysis in Science Classes

Students should learn in a science class that graphs are useful tools for determining the relationship between variables.
Usually this concept is discussed in class and examples of various graphs are shown to the students. Later students are
expected to use graphs to analyze lab results. This program may be used to give the students more practice with
graphically analyzing data. A number of sample data files have been included with this program for this purpose.

Y ou can use this program in two ways to see the relationship between two variables: 1) Y ou can analyze the graph by
looking for alinear relationship between two variables. If alinear relationship does not exist, you can perform
calculations on the variables to find alinear relationship. 2) Y ou can use various mathematical models to fit a curve to
the data. Each of these methods is described below.

Using Modified Data to Show the Relationship between Variables

Students can investigate the relationship between variables by performing calculations on data and graphing this
modified data. For most of the mathematical relationships that show up in science, a modified graph may be made to
“linearize” the data. For example, to test for an inverse square relationship between x and y, plot y vs. x2. You can
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quickly see whether the data fit an inverse square relationship by checking whether the modified graph produced isa
straight line. It may be just as educational to show that other modified graphs do not produce straight lines.

When you suspect the relationship to be of the general form: Y = ¢ X", an alternative way to find the relationship
between variablesis to use alog-log graph. Plot the natural log (In) of Y vs. the natural log (In) of X by creating two
new calculated columns of data. Thisis useful because taking the natural log of both sides of the above equation
produces

InNY =1Inc + n(InX).

Thisequationisin the genera formy =M x + B if wetreat In (Y) asy and In (X) as x. Therefore, if In (Y) is graphed
vs. In (X), the result will be a straight line with a slope of n and a y-intercept of In (c) (provided the relationship is of
the general type that we are discussing). Notice that this general type of equation includes many of the important
relationships in science. A In-In graph of an inverse square relationship will produce a straight line with aslope of -2. A
In-Ingraphof Y = X Y2 will produce a straight line with a slope of 0.5. It isinteresting to determine the slope of the
In-In graph line by plotting the graph and including the linear regression line. Y ou and your students can experiment
with several sample fileson this disk (e.g., GALILEO.DAT, DVST.DAT, COULOMB.DAT, TVSH.DAT).

Exponential relationships of theformY = ¢ e arealso important in science and may be studied with the modified
column technique. If the constant k is positive, the equation represents exponential growth (population, compound
interest, a charging capacitor, etc.). If k is negative, the equation represents exponential decay (radioactivity, a
discharging capacitor, etc.). In either case, plot the In of the Y-axis data vs. the X-axis data. Thisis sometimes called a
“semi-log” graph. If you take the log (base €) of both sides of the general exponential equation above you get

InY =1Inc + kXIne
or InY =1Inc + kX .

Thus, if (InY) is plotted vs. X, exponential datawill produce a straight line with a slope equal to k and a y-intercept of
(In ¢). You might want to try this with the data files GRAINS.DAT, POSTAL1.DAT or POSTAL2.DAT. For more
information about the exponential function, see the series of articles by Albert A. Bartlett in The Physics Teacher
beginning in October 1976.

Many other mathematical relationships can be discovered using this technique. Physics teachers often have students
investigate the relationship between the angle of incidence and the angle of refraction for a beam of light striking and
passing into a different medium. Graphical Analysis can be used to plot sini vs. sinr to show Snell's law. The graph on
the left shows some Snell's law data plotted with no modification. The graph on theright isasinr vs. sini graph.
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Snell’s law (angle r vs. anglei) Snell’s law (sin r vs. sin [)

Modeling Data with Equations

Another powerful technique available with this program is the fitting of a mathematical equation to data. The following
three graphs of the Snell’ s law data contain different fitted curves. The first graph shows the data with alinear model
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fitted to the data. The second graph used a quadratic function and the last graph used a sine function. Notice that the
sine function produced the smallest mean squared error.
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Snell's law data fitted with a sine curve

The above fitted curves were made using the Automatic Curve Fitting option in the Analysis menu. Students can easily
experiment with various models to determine a best fit for their data. Of course, it isimportant to realize that the model
isonly as good as the data. For example, in the above experiment, if the angle of incidence were limited to a range of
30 to 50 degrees, alinear model would fit the data.

Y ou can also have students use the Manual Curve Fitting option in the Analysis menu. To use this option, the students
would have to make educated guesses concerning the curve’s coefficients and exponents and it might require more
work to obtain afit. The sample files included on this disk can be used to investigate a variety of mathematical
relationships.

Determining Relationships with Three or More Variables

The previous examples investigated the relationship between two variables. In some case three or more variables many
be involved. Consider the example below where you have temperature, electricity usage, and time. The graph on the
left shows average temperature over time while the graph on right shows electric usage over the same time.
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Each of these variablesis a function of change with time, but is there a relationship between electric usage and
temperature? Since Graphical Analysis allows you to quickly change the variable plotted on each axis, you can easily
plot energy vs. temperature, asin the graph below.
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Student Use During Labs

Graphical Analysis can be very useful for students trying to analyze the results of alab. They can use the program to
search for straight-line graphs or to model equations to the data. Certainly students need to know how to plot a graph
by hand, but after they have demonstrated this ability, they can create and analyze graphs much faster using the
program. The User's Manual is designed to give students enough information to enter data and plot afew graphs
without confusing them with all the other features of the program.

Going Over Lab Results

One way to review arecently completed lab investigation isto use alarge monitor or projection panel to plot atypical
group's data using Graphical Analysis.® In fact, the results of several different lab groups can be entered as separate
data sets. The different results can be compared on the same graph. Using modified graphs or curve fitting features,
you can demonstrate the relationship between variables, discuss problems with the results, and sometimes come up
with meaningful constants from the slopes, intercepts, and areas. The same strategy is useful in going over homework
problems that involve graphing.

Plotting Graphs During “Demonstration Labs”

This program can help you present and analyze data collected during demonstration labs collected in front of the class.
When you finish gathering the data, it is awkward to stop and take extra time to make a graph on a chalkboard or
overhead projector. This program provides a quick method to produce quality, well-labeled graphs on a large monitor
or projection panel.

Graphing Data Collected on Windows Computers

A feature of Graphical Analysisis the ability to graph data collected with Windows computers. Many schools use
Vernier Software programs and hardware to collect data from temperature probes, photogates, pH probes, etc. After
datais collected, use the File menu of the data collection program to save the data as atext file. In Graphical Analysis
for Windows, choose the Open option in the File menu and change file type to *.TXT in the pull down box found in the
bottom of the dialog box. Change to the correct directory and select the appropriate file. The data will then be loaded
into the Graphical Analysis data table window.

® One efficient way to do thisis to have the first few lab groups that complete a lab enter their results into
Graphical Analysis. Have them save their data so you can reload and use it as you discuss the lab.
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Graphing Data Collected with LabProd, CBL 20, and CBLO

The LabPro, CBL 2, and CBL systems provide a method of collecting and analyzing data with T1 Graphing
Calculators. Sometimes, though, you will want to transfer this data to your Windows computer for further analysis or to
print higher quality graphs. Such transfer is possible with this program and a TI-GRAPH LINK O cable (part of the TI-
GRAPH LINK package), which is sold by Vernier Software and other Texas Instruments dealers. This cable connects
the T1 Graphing Calculator to the serial port of your PC computer.

Perform the following steps to import data from the calculator into Graphical Analysis.

e Connect the TI-GRAPH LINK cable between the serial port of your PC computer and TI Graphing Calculator
Link port.

*  With Graphical Analysis running and a blank data table displayed, select the column where you want the data
imported.

e Choose the Import from TI Calculator option in the File menu.

e Onthecalculator, follow the same procedure you would if you were sending (Linking) lists from your calculator to
another calculator.

*  When transferred to Graphical Analysis, the lists will appear in columns of the data table. They will be labeled
with the simple list names from the calculator. If you want to rename them or add units, double-click the column
heading and enter new names on the pop-up menu that appears.

If you have problems importing data from the T1 calculator, perform the following checks.

< |If you have transmission error problems with the calculator, make sure the cable is connected to the correct seria
port on the computer and that you have selected the correct serial port in the Graphical Analysis program. Also
make sure the plug on the GRAPH LINK cable is completely pushed into the calculator link port connection.

e Make sure you select the Import from T1 Calculator... option before you transmit the data from the calculator.

e Check to be sure you are only sending lists to the computer and not matrices, programs, etc.

An interesting variation of this procedure isto import data directly from the CBL unit. This procedure is useful when
using a T1-82 because the T1-82 lists are limited to 99 elements. Y ou can program the T1-82 to collect more than 99
points per channel and then send the data directly from the CBL to the computer. To perform this procedure after the
CBL has collected the data, connect the TI-GRAPH LINK cable between the serial port of your PC computer and the
CBL. Have the Graphical Analysis program open with a blank data table. Select the column where you want the data
imported. Choose the Import from T1 Calculator option in the File menu. With data stored in the CBL, press the <2™>
and <XMIT 85> keys on the CBL. Thefirst data group from the CBL will be sent to Graphical Analysis. Select anew
column in the Graphical Analysis datatable and repeat this process to retrieve additional data groups from the CBL.
Refer to the “ Retrieving Collected Data from the CBL” section of the CBL System Guidebook (p.24) for information on
the order in which data groups are sent from the CBL.

Demonstrating the Shape of Various Mathematical Functions

Y ou can use Graphical Analysis to produce graphs of mathematical functions. For example, open a new datafile by
choosing the New option from the File menu. From the File Menu, choose Preferences and click the “degrees’ radio
button then click OK. Click the“X” label in the data table and use the Fill Column option in the Data menu to create a
sequence of numbers from 0 to 359 with a step of 1. Now, double-click on the column labeled “Y” and click on the
Definition button. If you want to graph a sine function, for example, enter a column name. Press the <Tab> key twice
to move to the Column Definition Box and click the Sine button on the calculator. Next, choose the “ X" column from
the Columns drop-down list. When you click the OK button, the sine of each X valueis shown in the “Y” column and
graphed on the graph. Y ou can change and edit the column definition to show graphs of various functions. The graphs
below show sine and tangent functions.
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Graph Window
Sin{ Angle } vs. Angle
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Using the Derivative Function to Analyze Data

The Derivative function can be used to study the rate of change of a variable. Choose New Column from the Data
menu and create a calculated column. When entering the column formulain the New Column Formula box, choose the
derivative function in the Functions pull-down list. The derivative can then be plotted, just like any other column.
There are many uses for this kind of dataanalysis. For example, if you have several distance figures taken at equal time
intervals, the derivative column becomes a table of velocities. Use this approach to analyze strobe photographs,
videotaped data, or ticker-tape timer data. The example below shows the derivative being used on data from aftitration

experiment to find the maximum rate of change in the pH.

= Graph Window
pH vs. Volume NaOH

<2 Volume NaOH (mL) <>

L L L
0 1] 10 15 20 25 il ]

= Graph Window -
di pH YdV vs. Volume NaQH

&S dipH)dv
£
e

e & -
a ] 10 15 20 25 30 35
<2 Volume NaOH imL) —

Titration Graph (pH vs. mL Added)

Titration Graph (Delta pH/Delta Volume vs. mL Added)

As another example, here are two graphs of data from a strobe photograph of an accelerating object. The first graphis
the raw data, the second one is the derivative of distance with respect to time. The acceleration can be determined from

the dlope of the linear regression line.
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Timing Graph (Delta Distance/Delta Time vs. Time)

25



Graphical Analysis for Windows TEACHER'S MANUAL

Using Data Collected with Other Programs

Because Graphical Analysisis a Windows program, data transfer to other programs is easy. For numeric data, smply
drag across the part of the data table you want and choose Copy Data from the Edit menu. Go to the Program Manager
by simultaneously pressing the <Alt> and <Tab> keys and launching the application into which you want to paste the
data. Go to the appropriate part of the application and choose Paste from its Edit menu. This works with both word
processing and spreadsheet programs. Graphs and other windows can be transferred in the same way. Select the
window you want to copy and choose Copy Window from the Edit menu.

If you need the Graphical Analysis Program datain asimple text file format for any reason, follow the instructions
above using the Notepad application (included with Windows) and paste in the data. Then save the data after choosing
Text as the type of file in the Save dialog box.

Sample Data Files

Several sample datafiles are included on the Graphical Analysis disk. Use them to explore the features of this program.
Later, you may want to use them to demonstrate the use of graphs as tools to find the relationship between variables.

- 3500 PrerVqume - BOY L EDAT

Baoef o v=c* 1lp

gz %, This historical data was gathered by Boyle in studying the relationship

E””” i %o, between the volume and pressure of a gas at a constant temperature. The

81500} e experiment used a“ J/shaped” tube filled with mercury. Reference: Morris

Brow} LTI H. Shamos, Great Experimentsin Physics, 1959. The data was converted
500 ‘ L DBeo to metric units.

|
10 30 35

|
148 20 29
<= Volume (cm) =

COULOMB.DAT

s )
! f=c* 1r2
P Use thisfile to see the relationship between distance and electrical force.
5 Thedatain thisfile are student results (West Starr and Bob Faber, 1978)
g from the Project Physics version of the Coulomb’s law experiment.
&t

0

| . L . I
H 10 14 20 25 a0 35
<> Distance {cm)

DAMP_SHM.DAT

5 Potential-A vs. Time
o 4 Damped Simple Harmonic Motion
g, The datain this file was imported from the MultiPurpose Lab Interface
; Program. A strain gage was attached to horizontal hacksaw blade. The
g hacksaw blade was displaced from the horizontal and allowed to undergo
&t simple harmonic motion.

o DI1 0.2 DIS DI4 [1K:}

<20 Time (s) O

DECAY .DAT

Rate vs. Time

In(d)=c*t

Thisfile contains data showing the decay rate (counts/sec) of a radioactive
sample. The data was taken from a 1941 issue of the Physical Review.

<2 Rate (ctsis) >

20 4

1} 60 g0 1
<= Time (min) >
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DVST.DAT
d=c*t2

This set of dataisthe distance traveled from rest for a glider sliding down
aninclined air track. Three different data sets are included for different
angles of tilt. The data was taken from Project Physics Resource Book, p.
48, 1981.

FFT.DAT
Frequency Analysis

Y ou can use thisfile to show an example of afast Fourier Transform. The
file contains atriangle wave. The corresponding FFT shows the frequency
components of the wave and can be used to determine the component
frequencies.

FREEFALL.DAT

v=c*t

Thisfile contains speed and time data for afreely falling golf ball. The
data came from a high school lab report (Cheryl Duyck and Shelee Moore,

1981). A strobe photograph was taken of the golf ball. The value of the
slope (M) is a measure of the acceleration due to gravity.

GALILEO.DAT
d=c*t2

This data represents the distance traveled from rest for a ball rolling down
an inclined plane. The timing was done using a waterclock in an attempt
to duplicate the work of Galileo. The table was taken from Project
Physics, p. 62, 1970. The data was converted to metric units.

GRAINS.DAT

G =2(X-1)

Thedatain thisfileis based on the old story of the man who was paid 1
grain of wheat on the first day, 2 on the second day, 4 on the third day, 8
on the fourth day, etc. The datais the number of grainsvs. day. Thefileis
intended for demonstrations of the exponential function. A semi-log graph
(Iny vs. x) gives astraight line with a slope of log (base €) of 2. The
intercept is the negative of the same number.
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KEPLER.DAT

2500000 Period vs. Radius

Tzzc* R3

{F2000000 F
g Thisfile consists of data comparing the mean periods and radii of the nine
planets. The datais from PSSC Physics, Fifth Edition, page 97. The radius

units were converted to earth radii. Graphing R3vs. T2 verifies Kepler's

1500000

d {Hour:

1000000 -

erio

=

L=l
o
2
1=}
1=
3
=

T

third law.
¢ 10 70 L 10
{2 Radius (Earth Radii) >
14 Mass Distribution PENNY.DAT
12 Penny M asses

10

Thisfile contains data collected with the Mass Plotter program for MS-
DOS . The mass of each of 100 U.S. pennies was collected. The date
stamped on each penny was noted during the weighing process. A
histogram of the data shows two peaks. Thisis aresult of the U.S. Mint
changing the composition of metalsin the penny after 1982.

Count (%)

g
B
4
2
b

2 24 26 28 an 32 34
Mass (g} (0.010 g / bin}

5 Postal Rtes {19568-1981) POSTAL 1DAT
ot Postal Rates (1958-1982)
z jz This table lists the cost of mailing a one-ounce letter viathe U.S. Postal
j ol Service. The x axisisthe time of each rate increase. The datawas
t o collected by Albert Bartlett (The Physics Teacher, May 1982). For this
] time period, the growth of the postal rate was nearly exponential. The

. ‘ . . graph can lead to some interesting discussion of future rates.
0 <o Timei?ears) = » 0

15 Postal Rtes {1958-1981) POSTAL2.DAT
o Postal Rates (1885-1991)
; j: Thisisthe same data as in the last sample, with the earlier and later years
E b included®. The whole table does not fit asimple exponential curve as well
gl asthe previousfile.
&t

0

L
0 40

1b QID 3
<2 Time (years) >

®The postal increases to $0.22 (in 1983), to $0.25 (in 1988), and to $.029 (in 1991) were added to Dr. Bartlett's
data.
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= Graph Window
Period vs. Diameter {Data Set 1)
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RINGSDAT
T=k*dn

Thisfile contains the period of oscillation of metal rings with different
diameters as they rock back and forth. It was assumed that the equation
for the period was likely to in the form T = k * d", but the value for n was
unknown. Graphing the In-In graph with the regression line included
yields the numerical value of n. The value of k may also be determined
from the fact that the y-intercept of the In-In graph isIn (k). This datafile
consists of two different runs with two different data sets.

SNELL.DAT
sinl =nsinr

Datain this file compares the angle of incidence to the angle of refraction
as abeam of light traveled through air and entered glass. All the angles are
in degrees. This datais from PSSC Physics, Fifth Edition, p. 397.

STROBE.DAT
d=c*t2

A strobe photograph provided the distance and time data for thisfile. The
datawas collected as a nearly-frictionless puck was pulled along a level
table by a constant force. The data table was taken from PSSC Physics,
Fifth Edition, p. 32.

TEMP.DAT
Ti1=c*T2+k

Thisisaplot of temperaturein Celsius vs. temperature in Fahrenheit. The
only two data pairs are the freezing and boiling points of water. Plotting
the (non-modified) graph of these two points and having the program
calculate the statistics of the best-fit line through the two points can be
instructional. The slopeis 9/5 and the intercept is 32°. These are the
numbers used to convert Fahrenheit to Celsius temperatures. The
Interpolate item on the Graph menu can be used with this samplefile for
converting temperature units. Thisidea comes from an article by M.
Bucher and Hugh A. Williamson in the May 1986 issue of The Physics
Teacher.
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14 pH vs.Vqume NaOH TITRATEDAT
Titration
Use thisfile to investigate a sample titration. Take the derivative of pH vs.
volume to determine the equivalence point. Vincent J. Sollimo (Burlington
County College, NJ) provided the data for this graph.
é 10 1‘5 ZIEI 24 3IEI 34
{2 Volume NaOH (mLy >
100 Time vs. Diamet;e;; o TVSDDAT
10 cmbeiht. Tine - 2
o Seabmtn | | 1=V
3 o0 Here the time taken to empty a can of water through holes of different
] diameter is studied. Four different sets of data are included. Each set isfor
E} * adifferent starting height of the water. Data taken from Appendix 2 of the
2 PSSC Lab Guide (Fifth Edition).
% g ZID 2‘5 3a 3‘5 40 45 a0
{2 Diameter (cm) —>
1 Time vs. He_ig_hteﬁ 0 cm hole: Time TVS'_I DAT
o gigmi || t=ervh
3 sl Thisfile contains the time taken to empty the water through aholein a
] can. The can was filled to various heights. Four different sets of dataare
E} T included. Each set is the result of experiments done with a hole of
saf different diameter. Data taken from Appendix 2 of the PSSC Lab Guide
Jege—— (Fifth Edition).
a 10 15 20 25 a0
<3 Height (cm) >
18 Mas vs. Length WIRE.DAT
1ok M=k+c*L
g &l Thisfile contains a set of sample datataken from the article
E 12p “Demonstrating the Role of Mathematicsin Science” by D.W. Turner,
o'0f from the book Best of Physics from Science Teacher’ s Workshop. A pan
naf balance was secretly “weighted.” The students took data on the mass of
06 . . " . " various lengths of wire. They then determine the mass of another length
2 Length om) > (3.12 cm) of the same wire by using their graph.
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General Notes

Statistics
The standard deviation used in statistical calculationsis
2 2
X —nkX
std.dev.= X7 NG
n-1
where Xm= mean
n = number of data points
Thisis sometimes referred to as the sample standard deviation.

The program calculates the “best fit” line using linear regression by the method of least squares. The equations used
are

nif xi ;) -(2xi) 3 ;)

Slope=M =
ope n[ﬁZx ) Zx.)
| (2xF) gz yi)-(2x) E@zwi)
intercept = B =
[ﬁZx) Zx,
Y% ¥~ nm ¥y

correlation coefficient =

532 -nod) {5y -n3)

n|]7)2,
std. dev. of lope=
EQZX. ) Zx.
2E]Zx-2
std. dev. of y -intercept =
o f2ed] ()

where n = number of data pairs
Xm = mean of x-values
Ym = mean of y-values

a)%:—[z(yl B-M D‘I)Z

When Graphical Analysis performs automatic or manual curvefits, it calculates and reports the mean square error
which is

mean square error =

3 (vi-v)

where vy, =they-value of each data point
y," = the y-value of the curve fit
n = number of data points.
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These are fairly standard formulas.” The coefficient of regression is a useful measure of how well the data fit a straight
line, but it should not be overused. Always examine the graph. The coefficient is greatly affected by afew extreme
points.

Smoothing

When smoothing is used in a calculated column, the column data, z, is aweighted average of the number of points
selected by the user to use in smoothing, m.

i=+n

> Wiy -n
Z :I__ni:+n
ZV\/i
i=-n
wi=1+n-fi|, -n=ziz+n
n=int(m2) -1

Modifying Graphical Analysis

If you do not want your students to use certain features of this program, we have provided a method for disabling menu
items or toolbar items. Y ou might use this feature to disable the Automatic Curve Fit option, so that students are
required to use Manual Curve Fit to find afit. To do so, use atext editor (such as Notepad) to load the
STARTUP.DAT file. In the section marked System Settings, add aline like this:

Disable: x,y

where x should be the number of the menu you want disabled, Fileis 1, Edit is 2, etc., and y is the number of the item
in the menu, thefirst item is 1, the second item is 2, etc.. The separator lines in the menus also count asitems. To
disable toolbar buttons, x should be zero, and y should be the number of the button, counting from the left with the first
button being 1. Y ou can disable any number of items. When you are finished editing the file, save it, and reload the
program. Included on the distribution disk is afile called STUDENT.DAT. This data file contains the commands that
will disable the Automatic curve fitting button and menu item. If you would rather your students did not use automatic
curve fitting, rename the STARTUP.DAT file as STARTUP.OLD and rename STUDENT.DAT to STARTUP.DAT.

If you are experienced with aresource editor such as Borland's Resource Workshop, you can make minor changes to
the Graphical Analysis program. These changes could include changing the text of menu items, dialog boxes and help
text, or adding keystroke equivalents for menu items. Only modify a back-up copy of Graphical Analysis. Y ou could
accidentally make changes that make the program unusable.

"Refer to a statistics text for more information; for example, An Introduction to Error Analysis by John R. Taylor,
Oxford University Press, 1982.
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Questions about Graphical Analysis

Graphical Analysisisthe fourth version of a program, first written in 1982 for the Apple 110 . Many of the features of
the program are the result of suggestions made by users of earlier versions of the program. We thank al of them for
their support and suggestions. If you have any problems or questions about this program, or if you are not on our
mailing list, please contact us. We publish a periodic newsletter containing program improvements and new ideas for
using this and other Vernier Software programs.

Vernier Software & Technology
13979 SW Millikan Way
Beaverton, Oregon 97005-2886
Phone (503) 277-2299
FAX (503) 277-2440
WWW.vernier.com
info@vernier.com
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REFERENCE SECTION

Graphical Analysis Menus

File

New

Open...

Import from Tl
Calculator...

Graphical Analyszis [ "untitled.dat" ]

Edit Window Graph Data  Analyze
Hew
Open...
Irnport from TI Calculatar. .

Save
Save az...

Print k
Frinter Setup...

Preferences. ..

E xit
| L I

This option opens up anew blank data window and graph. The data and graph
options will be the same asthe STARTUP.DAT file.

This option can be used to load a previously saved file. Graphical Analysis will
only allow you to have one file open at atime. If you wish to view a previously
saved file or create anew file, you must first close the currently open file. You can
also load files saved with several other programs including: any spreadsheet when
the file was saved astext, Vernier Software MS-DOS applications, ULI Timing
Module, and Graphical Analysis for Macintosh” when the file was exported as text.

This option can be used to import lists stored on your TI-73, TI-82, TI-83, T1-83
Plus, T1-85, T1-86, TI-89, TI-92 or TI-92 Plus calculator. Thisis useful if you have
collected data using the LabProd , CBL 200, or CBLO system and you would like
to analyze the data further or to produce higher quality graphs. Y ou will need the
TI-GRAPH LINK[O cable to use this option. Contact Vernier Software or your
Texas Instruments dealer for information about this product. The procedure for
importing datais the following:

*  Connect the TI-GRAPH LINK cable between a serial port of your computer
and the T1 Graphing Calculator or LabPro/CBL 2/CBL.

e With Graphical Analysisrunning and a blank data table displayed, select the
column where you want the first column of imported data to appear. If more
than one list is transmitted, each list will be placed in the subsequent columns.

*  Choose the Import from TI-Calculator option from the File menu.

»  Onthecaculator, follow the same procedure you would if you were sending
(Linking) lists from your calculator to another calculator.

*  When transferred to Graphical Analysis, the lists will appear in columns of the
data table. They will be labeled with the simple list names from the calculator.
If you want to rename them or add units, double-click the column heading and
enter the new name on the pop-up menu that appears.
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Save

Save As...

Print

Printer Setup...

Preferences...

Exit

Use this option to save all current data sets and graphs together in onefile. This
option will use the current file name and replace the previously saved file with the
new file.

Use this option to save all current data sets and graphs together in anew file. This
option prompts you for afile name. Y ou can also choose the folder and disk where
the file will be stored.

From this option, you can choose to print the Data Table, Selected Display or the
Entire Screen. The Data Table option will print the entire data table including rows
not displayed in the window. This option may produce many pages of paper. The
Selected Display option only prints that portion of awindow displayed on the
screen. |t can be used to print graphs, data tables and other windows. If you select
this option for alarge data table, the entire data table may not appear. To print a
graph, first select the graph by clicking it , then select the Selected Display option.
To print the entire screen including all windows, select the Whole Screen option. If
you have a Text window that contains more text than can fit in the window, a scroll
bar will appear on the right hand side of the window. To print all the text, you will
need to click the Text window and select Copy Text from the Edit menu. Paste the
text in aword processor and print the text from the word processor.

The Printer Setup option is used to include header information to be used in the
print out. You can enter your name and check the box next to your name to print it
as part of the header. Y ou can also select the date as part of the header by checking
the box next to the date. This option is aso used to choose the printer.

This option controls a number of settings saved with each file. The Preferences...
dialog box is shown below. The derivative and smoothing pull-down options control
the number of points used in each calculation for those columns using these
functions. Set the appropriate options according to your preference, then click OK.

= Preferences

ders between windows

Derivatives: [3 | [2]

Smoothing: IZI E

Angles measured in:
@' Radians {:} Degrees

OK |Cance| | Help

Preferences ... Dialog Box

Closes the Graphical Analysis program.
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Edit

Undo...

Copy Window
Cut
Copy Data

Paste Data

Delete Data
Select All

Window

Arrange Windows...

Close Window

“Window” Options...

Analyz

Window Graph Data

Copy Window
Cut

Copy Data
Paste Data
Delete

Select all

The Undo command can usually cancel the most recent action performed on either
the graph or the data. Not al actions can be undone and you will be warned when
some commands or operations cannot be undone.

The currently selected window is copied into the Windows clipboard as a bitmap.
This command is used to cut sections of text and is available only in text windows.

The Copy Data command is used to copy selected regions of a datatable or atext
window to the clipboard. The command will not be accessible until you highlight
the data or text.

This command is used to paste data into a data table or text into a text window. The
use of Cut or Copy, along with Paste, provides a convenient way of moving data
around in the data table.

This option deletes all data from the selected cells.

Use this option to quickly select al the data. This command selects data only, not
column labels and units.

File Edit di Data Analyze

|D’>-H nrrange 00

Close Window
Graph Options...

=
L3

[ITTm

Heplace Window k
New Window [1—00 »
Mew Window LI—-= 3

If more than one window is open, choose this item to bring up a dialog box showing
all of the possible layouts for these windows. Sometimes, so many windows are
open that not all layouts can be shown. In these cases, the basic layouts are shown
and a Rotate button is available allowing you to select other layouts. To choose a
layout, click one of the diagrams and select OK.

Thisitem will close the currently selected window.

Thisitem displays a dialog box containing the options available for the currently
selected window which may be a graph, a datatable or atext box.
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Replace Window

New Windows [1—00

New Windows [1—+E

Graph

Point Protectors

Point Protectors Every

Error Bars

Thisitem will replace the currently selected window with one of the following
windows:

» Graph

» Data Table

* Histogram Graph
» FFT Graph

» Text Window

These windows are discussed in the next section of this manual.

Use this option to split the currently selected window horizontally (as the graphic
suggests) and make the right-hand window one of the five available windows types.

Use this option to split the currently selected window vertically and make the lower
window one of the five available windows types.

Window BTN Data Analyze
= E -/ Point Protectors
Point Protectors Every »
Error Bars
+ Connecting Lines
Bar Graph
Background Grid
Legend

Help

—
o]

W7

Zoom In
Zoom Qut
Auto Scale

X-Axis Options...
Y-Axis Options...
Column Appearance...
More Graph Options...

If this option is activated, each data point will be surrounded by a small
geometrical shape to make it more visible. These point protectors vary in shape
depending on the data set being plotted.

Point protectors generally make the data points easier to see and are especialy
useful if more than one data set is used. If you are plotting alarge number of data
points, you may want to turn off the point protectorsto avoid cluttering the graph,
or at least to limit their number.

Use this option to control how often the point protector is used on the graph.

40 Speed vs. Time

Both horizontal and vertical error bars can
be added to the graph. To control the size
of the bars, double click the column label
for the data of interest. A Column Option
dialog box will appear. Enter the amount of
the error bar and choose whether or not the
error is a percent of the data point.

<5 Speed (mis)
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P
T

=
T

o
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Connecting Lines

Bar Graph

Background Grid

Legend

Zoom In

Zoom Out

Auto Scale

This option will cause a point-to-point line
to be drawn connecting the data points. The
line will be drawn from point to point in the 40 Speed vs. Time
order in which the data appear in the data
table. If the data in the table are not listed
in order by the column graphed on the
horizontal axis, you should sort the data by
using the Sort command on the Data menu.
It more than one s&t of data is being T T ST
graphed, a separate line will be drawn for D Tmets ©

each set.

This option drastically changes the
appearance of the graph by producing a bar
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graph. If you choose this option, you will  |¢,,
probably want to turn off the other options  |£ .-
(except perhaps the grid). The bar graph |Ez
style is not very useful if several data sets g5

o
T

are plotted.

=
=23
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<2 Time(s) c»

This option produces a background grid of
dots on the graph so that it looks more like SRR R R S LR &

graph paper. If you activate thisoption, you  |¢,,
will probably want to use point protectors |£ s
to make the data points distinguishable :@.‘zu
from the grid dots. oier

o L L | I
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A legend helps you identify the data points - Time vs. Diameter

by point protector shape. It is a small table SHocanet T
lising the name of each data set and 1 o . o
showing the point protector shape

associated with it. Use the legend when you
have more than one set of data on a graph.
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Use this option to examine a portion of a graph more closely. Before using Zoom
In, you must select aregion by clicking and dragging through it. Choosing this
option causes the region selected to expand to fill the entire graph. Y ou can repeat
the Zoom In several times. Y ou can undo the most recent Zoom In operation by
choosing Undo Zoom In from the Edit menu. Y ou can restore the graph to amore
standard scale by selecting AutoScale from the Graph menu.

When you use the Zoom Out command, the range of the axes will be increased by
200 %.

Use this option to automatically set the range of the axes so that the data just fitsin
the graph.
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X-Axis Options... This option brings up the following dialog box for the X-axis. Choose the X variable

and select a scaling method for this axis.

= X-Axis Setup

Choose which columns to plot: O AutoScale at 0

® ! @ Hartoscale

) Grains 2} Manual Sealing
Left Limit 0
Right Limit 12

| Ok I| Cancel I| Help I

Y-Axis Options... This option brings up the following dialog box for the Y-axis. Choose the Y variable

and select a scaling method for this axis.

= Y-Axis Setup
Choose which columns to plot: O AutoScale at 0

T aime | @
&

O Manual Scaling

Top Limit 2500

Bottom Limit |7

| Ok I| Cancel I| Help I

Column Appearance... This option brings up the Column Options dialog box which is described under the
Data menu item below.
More Graph Options... The following dialog box appears when you select this option. A variety of graph

options can be set with this box as well options that apply to each data column.

= Graph Options...

D Error Bars

D Connecting Lines
D Bar Graph

D Background Grid
D Legend

| Column Appearance VI

| More X-Axis Options... I Cancel

| More Y-Axis Options... I
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Data

Sort Data

Fill Column...

New Data Set

Clear All Data

idow Graph QiEI&M Analyze Help

Eill Column...
Mew Data Set
Clear All Data

Column Options...
Mew Column 3
Edit Column Definition 3

Use this option to sort the data in ascending order based on any column (except
those cal culated with derivatives or delta functions). This operation can be used to
make it easier in analyzing data. It may be desirable to use the option when you
plan to include a point-to-point line on the graphs. The line drawn between pointsis
always drawn in the order in which the data appearsin the data table. If the data
tableis not in order, the point-to-point line may not be useful.

Sorting by the column used on the horizontal axisis sometimes necessary before
integration can be carried out on the graph.

If the data table includes more than one set of data, the data will be sorted
separately within each set.

The Fill Column option can be used to quickly fill in a datatable when thereisa
simple pattern to the numbers. To use this option, click on the top cell to befilled or
select the column header. Select the Fill Data option in the Data menu. The dialog
box shown below will appear. Specify the starting value, ending value, and

increment.
= Fill Data

Fill Column: Time

Start Value: |0

End value: 10 Cancel

Increment:  |4.000

Increment... Dialog Box

The New Data Set item creates a blank data set, with the same columns as the
previous data sets.

Clear All Data deletes all data stored in all data sets. Thisis different from New
option in the File menu which creates a new file with a blank data set and default
screen layout.
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Column Options...

New Column

Edit Column Definition

Use this option to enter the name and
unit of acolumn, to select a point "Time {s)" Options

protector, and to specify the column How Hame:

color. You can aso control the rounding howtrices ]

of the numbers as they appear in the
datatables, graphs, and statistics. You

Point Protector: - [2J0 4 X ¢ e m 4 &

Olumn Color: .......D
can choose €either to specify the number o EEEOEEOC
of significant digits or to enter the Rounding: 2 Der. Places ]
number of digitsto theright of the e e
decimal point. The allowable rangeis 1 e _Ra Feree
to 9 significant digits or 0to 9 digitsto ’ '
theright of the decimal point. If you o] [ (o] [

have chosen to display error bars, use
this screen to control their display. If
this column is a calculated column, you
can display and edit the definition.

Column Options... Dialog Box

This item is used to create a new column in which the data are either manually-
entered or calculated from a formula. If you choose the manually entered data
column, you will need to type in the label and units of the column. A blank column
will be added to the data set so that you can enter new data.

If you choose the cal culated data column, you will be presented with the following
dialog box. Enter the name and units for the new column and move to the New
Columns Definition box. Define the new column in the box provided by typing or
clicking the various buttons provided. If you type in the name of acolumn in the
definition, it must be enclosed in double quotes. The Columns button is a pull-down
menu listing all existing columns that can be used in defining your new column. The
Other Functions button is a pull-down menu that allows you to choose various
functions to apply to the columns, functions such as derivative, integral, smoothing,
and absolute value. The part of the dialog box that looks like a calculator provides
standard mathematical functions that can also be used in defining the New Column.
Asyou click on the buttons and use the pull-down menus in this dialog box, the new
column definition will be updated.

Hew Column Hame: Hew Column Units:
|Culumn 5 ‘

Hew Column

| |
(o] (D] (5] (g
[other Funstons |
[ (] (] ]

i | e

R [ [ e
MEIEE
=

If the currently selected column is a calculated column, this item can be used to
change the column definition. When this option is selected, the above dia og box
will be displayed.
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Analyze

Tangent Line

Examine...

Interpolate

Statistics

aph Data gUE]Trd

Tangent Line
Examine
Interpolate

Statistics

Hegression

Integral

Manual Curve Fit...
Automatic Curve Fit...
Floating Box Options...

You can use this option to see the tangent line on the data or fitted curve. The
tangent line is only effective on agraph, not FFT graphs or histograms.

This option is useful when you want to read the values from a graph. The check
mark next to the Examine option indicates that it is active.

Graph Window
Speed vs. Time

=
=)

o
n

ﬁsu 7

z ',

E s

3 Time: 0.130
me: 0130 5

£ a0}

{}1.5—

1.0F

=
Sin

0 0.05 o1n 014s 0.20 0.25 0.30 035
<o Timefs) o>

Using “Examine”

This option is used to read values from afitted curve or linear regression line. With
Interpolate on, asmall set of vertical and horizonta lines will follow the curve as
you move the mouse across the graph. The X and Y values for that point on the
curve will be displayed below the floating box.

Graph Window
5 _ Speed vs. Time

|+

Rearession:

<5 Speed (mis)

ik K] 77 3 7 i
<2 Time(s) o

This feature adds statistical information to a graph. When aregion of afigureis
selected, the minimum, maximum, mean, and standard deviation of the selected data
are calculated. A solid horizontal line shows the mean, and dashed lines mark one

standard deviation above and below the mean. A floating box which contains the
statistics is aso added to the graph.
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Regression

Integral

Manual Curve Fit...

Automatic Curve Fit...

Floating Box Options...

Help

Help Contents...

This option causes the “best fit” linear
regression line to be drawn through all I = —

or part of the data. The lineiis calculated 0ot R e
using the method of least squares. If 2.

more than one set isto be plotted, you Z. zof o

will be asked to select a data set. 015k

=)
T

o
Sin

| , L L \ \
0 005 010 014 020 025 030 0.35
<o Timeis) O

This option uses the trapezoid rule to approximate the area under the curve for the
selected data.. The integral is estimated by adding the area of the trapezoids under
the curve as shown here:

—

data points = /

— T
il g

TRAPEZOIDS
USED IN AREA
CALCULATION

horz. axis

Before integrating, you must click and drag a rectangle on the graph to mark the
region over which you want to integrate. The program will then calculate the area
and display the result. The calculation of the integral is affected by the directionin
which you drag the mouse. If you drag the mouse |eft to right the integral is
positive, while dragging the mouse right to left yields a negative integral.

If integration is performed on a graph with more than one data set, you will be
asked to select adata set.

The manual curve fitting option is used to apply a mathematical model to
experimental data. A list of mathematical functions will be displayed including
linear, exponential, polynomial, etc. You will have to enter coefficients, constants,
and exponents for the model. When the model is finalized, the program displays a
curve representing your equation on the graph along with a floating box that
summarizes the curve fitting results.

This option is similar to the Manua Curve Fit option; however, the program
calculates the coefficients, constants, and exponents used in the mathematical
model. Thelist of mathematical functionsincludes linear, exponential, polynomial,
etc. Choose the type of function you want and the program will determine the best
fit. Refer to the Built-in help or the User’s Manual for more information.

This option is used to change the appearance of floating boxes which are associated
with fitted curves, regression lines, integrals, etc.

Analyze
Help Contents...
How to Use Help
Search for Help On...
Hint...

About GA...

Use this option to access atable of contents for the Help system. From there, you
can get information on getting started with Graphical Analysisfor Windows, tips
on performing common tasks, menu descriptions, and descriptions of windows.
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How to Use Help

Search for Help On...

Hint...

About GA

This option is used to access extensive information on the Help functions available
in the Windows environment.

Use this option to search for a specific topic. When you select this option, the
Search dialog box will automatically open. Typein akey word and then click the
“Show Topics’ button or press <enter>. A list of topics then appears at the bottom
of the screen. Select the appropriate topic and click the“Go To” button. Y ou can
also double click the topic for quicker access to the Help.

This option displays abrief hint or tip about Graphical Analysis. These hints
highlight some of the more obscure features of the program which you may find
useful.

If the Display Hints on Startup checkbox is selected, the hint dialog box appears
while the program isfirst loading. Y ou may want to deselect it after you have been
using the software for awhile.

This option provides a pop-up screen with information about this software,
including the version date. At the bottom of the screen you will find a short
description of your computer’s hardware. This includes the type of CPU in the
computer and the amount of remaining free memory.
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Graphical Analysis Windows

Each of the types of the windows used in Graphical Analysis for Windows has its own features and controls.

Graph

This general purpose graph window is used to plot any data column. Y ou can change the
axes by clicking on their labels. The title of the graph can be customized by double-
clicking on it and entering the desired text.

The scales can be changed by clicking on the tick mark labels at either end of the axis.
Type in a new value and the limits of the graph will be changed. For example, on the
sample graph, if you clicked on the top tick mark label on the vertical axis and typed in
“3000", you could change the scale so that it runs from 0 to 3000 Grains.

2500 Grains vs. Time
BiGraing

2000 -

1600

1000+

£ Graing >

a00 -

il h @ 1 L
2 ] & ] 10 12
<o Time (Days) =

The arrows near the graph axis labels provide another way to change what is graphed.
These arrows alow you to scroll the graph by one minor division in the direction chosen
for the respective axis. For example, if you click on the right arrow of the sample graph,
the entire graph would scroll to the left by 0.5 days.

Double-click on the graph if you want to make other
changes to the graph. A dialog box will appear. The top
section of the dialog allows you choose what should
appear on the graph: a grid, lines between data points,
point protectors (and frequency of the symbols), bars,
legend and error bars. The button labeled “Column
Appearance” lets you change the appearance of the data

= Graph Options...
ri

i . Column Appearance W | oK I
points in several ways. You can choose the color used, =

the point protector symbol, the error bar size, or even
the label used for the column. The bottom two buttons
provide ways to adjust what is graphed on each axis and
to change the scale used on each axis.

Help
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Data Table The Data Table window displays columns of raw and calculated data. A datatable can
also contain histogram, FFT, and curve fit data. In the figure below, the data for the
graph shown above are displayed along with a new column defined as the natural log of
Grains. As the mouse moves over the data table, the entire row will be highlighted. If
you have a graph displayed with a data table, a cursor line on the graph will scroll across
the graph along with the highlighted row in the data table. This aso works the other
direction. If the mouse moves over any graph, the row corresponding to the point on the
graph will be highlighted in the data table.

Data Table Window

Data Set 1: Data

Time Grains In{Grains)
{Days)
1.000 1.000 0.000
2.000 2.000 0.693
3.000 4.000 1.356
4.000 5.000 2.079
5.000 16.000 2773
5.000 32.000 3466
7.000 54.000 4.158
5.000 128,000 4.852
9.000 256,000 5.545
10.000 512000 5.238
11.000 1024 .000 5.931
12.000 2045.000 7.B25

1
2
3
4
5
5]
7
g
9

To select the entire data table, click the gray Control box in the top left corner of the
window. An entire data set can be selected by clicking on the data set header. Data
columns can be selected by clicking on the column header. Similarly, entire rows of data
can be selected by clicking the row number.

When you double-click a data table, adialog

box appears showi ng all the columns that Columns visible in data tables:
can be active in the data table. You can use bJ Time +
this to hide columnsin the data table. % G""“?

You can aso display statistics for each
column in the data table by checking the 5
Show Statistics box. The statistics for each [ Show Statistics Help
data set are placed at the bottom of each
column.

Cancel

Bl

The FFT Graph window displays a Fast
FFT Graph Fourier Transform of the data set. An FFT

is a bar graph showing the frequencies that
make up a periodic signal such as sound
waves. For example, if you are given
waveform data from severa different
musical instruments, you can display an
FFT Graph to show that each of the
instruments produces a different set of
frequencies (harmonics). The graph below
shows the frequency components of a 500-
Hz square wave. This example shows the
fundamental frequency of 500 Hz, as well
as the odd harmonics.
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Histogram
Graph

Text

You can double-click the FFT Graph to set
several options. The dialog box displayed
lets you select the column on which to
apply the FFT. You can aso set the
frequency axis scaling and other options of
the FFT calculation and display.

= FFT Setup

Columns to Plot:

Potential-A
) Polential-B

C AutoScale at 0
O A 1

®Manual Scaling!
Left Limit

[
Right Limit

1 of pts

[ Spike Enhancement
[ Show Peak Freq.

0Ok

][ cancet || Hep

A Histogram window displays a bar graph showing the distribution of readings. It is
useful in studying noise levels. Double-click on the Histogram window to change what
data are analyzed on the histogram or to change the bin setting used in the calculation.

You can enter text in a Text window and save it as part of an experiment. Examples
include teacher notes to students, descriptions of where the data came from, questions
for students to answer, and summaries of results. If you add more text than will fit in the
text window, you can use the scroll bar on the right side of the window to access al the

information.

The text window below is taken from the BOYLES.DAT file.

=] Text Window

3

Historical data gathered by Boyle in studying the j

relationship between the volume and pressure of a gas
at a constant temperature. The experiment used a
"Jishaped" tube filled with mercury. Reference: Morris H.
Shamos, "Great Experiments in Physics", 1959, The data

was converted to metric units.

«]
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Program Design Notes

The main portions of this program were written using Borland Pascal for Windows, a powerful Pascal compiler
developed by Borland International, 1800 Green Hills Road, P.O. Box 660001, Scotts Valley, CA 95066-0001.
Graphical Analysis for Windows was programmed by Mark Topinka and Chris Chamberlin. The Built-in help was
written by Chris Chamberlin, David Gardner, and Rick Sorensen.

Questions about Graphical Analysis

If you have any problems or questions about this program, please contact us at:

Vernier Software & Technology
13979 SW Millikan Way
Beaverton, Oregon 97005-2886
Phone (503) 277-2299
FAX (503) 277-2440
WWW.vernier.com
info@vernier.com



Appendix A

Files on the Graphical Analysis CD

GAX.EXE: The executable file for Graphical Analysisfor Windows, compiled with Borland Pascal for Windows.
STARTUP.DAT: The data file used when the program starts. This file sets the window layout, etc.
STUDENT.DAT: Thisisthe same asthe file STARTUP.DAT except that the automatic curve fit features have been

disabled.

Data files have been included on this disk for use with Graphical Analysisfor Windows and have the extension
“* DAT”. Thesefiles are described in the Teacher's Guide.

File Description
BOYLE. DAT Historical data gathered by Boyle in studying the relationship between the
volume and pressure of agas at a constant temperature.
COULOMB. DAT Student results (West Starr and Bob Faber, 1978) from the Project Physics

version of the Coulomb's Law experiment.

DAMP_SHM DAT

This MPLI experiment file shows damped harmonic oscillator data. The
intended use of thisfileisto demonstrate the Manua Curve Fit feature.

DECAY. DAT Data on the decay rate (counts/sec) of aradioactive sample.
DVST. DAT Distance traveled from rest for a glider sliding down an inclined air track.
FFT. DAT Triangle wave and corresponding FFT showing the frequency components.

FREEFALL. DAT

Speed vs. time for afreely falling golf ball. The slope of alinear regression line
isameasure of the accel eration due to gravity.

GALI LEO. DAT Distance traveled from rest for aball rolling down an inclined plane. The
timing was done using awaterclock in an attempt to duplicate the work of
Galileo.

GRAI NS. DAT Thefileisintended for demonstrations of the exponential function. A semi-log
graph (Iny vs. X) gives astraight line with a slope of 2.

KEPLER. DAT Thisfile consists of data on the mean periods and radii of the nine planets. The
radius units were converted to earth radii. Graphing R*3 vs. T2 verifies
Kepler'sthird law.

PENNY. DAT This data file from the Mass Plotter program shows a histogram for the mass of
100 U.S. pennies. A change in the composition of the penny in 1982 is the
cause of the bimodal histogram.

POSTAL. DAT Thistable lists the cost of mailing a one-ounce letter viathe U.S. Postal Service
from 1858-1995.

Rl NGS. DAT The period of oscillation of metal rings of various diameters as they rock back
and forth.

SNELL. DAT This data was collected for abeam of light traveling through air and entering
glass. All of the angles arein degrees.

STROBE. DAT Distance traveled from rest for a nearly-frictionless puck being pulled by a
constant force along alevel table.

TEMP. DAT Thisisaplot of temperaturein Celsius vs. temperature in Fahrenheit.

Tl TRATE. DAT Thisis asample file showing pH vs. mL of base added during atitration

experiment.
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TVSD. DAT

The time taken to empty a can of water through holes of different diameters.
Four different sets of data are included. Each set isfor adifferent starting
height of the water.

TVSH. DAT

The time taken to empty a can of water through a holeis studied. Thecanis
filled to various heights. Four different sets of data are included. Each set isthe
result of experiments done with a hole of different diameter.

VVST. DAT

These data are from aticker-tape experiment in which a cart was accelerated by
aweight hanging over apulley. There are four separate runs (as four separate
data sets) using masses of 50, 100, 150 and 200 g as the weight hanging over
the pulley.

W RE. DAT

A pan balance has been secretly “weighted”. The students took data on the mass
of various lengths of wire. They then determine the mass of another length
(3.12 cm) of the same wire by using their graph.

CBL\ 3PROBES. DAT

CBL data showing temperature, air pressure, and relative humidity as a car
drives from Portland, Oregon to Madras, Oregon over the Cascade range.

CBL\ ACC. DAT

A Low-g Accelerometer in a Toyota Celica (manual shift), going from 0 to 95
km/hr (whichis 26.4 m/s)

CBL\ BALLOON. DAT

Data showing CBL readings during a hot-air balloon ride on 7/25/95 over
Newburg, Oregon.

CBL\ BUNGEE. DAT

Data showing CBL readings during a bungee jump using three Low-g
Accelerometers.

CBL\ DROPZONE. DAT

Low-g Accelerometer data from the Drop Zone at Great America, Santa Clara,
CA.. According to the Great Americaliterature:
freefall is 129 feet (39.1)
tower height is 224 feet (67.9 m)
braking acceleration is 4.0g's.
Our freefall time is about 2.8 seconds which yields:
D=12at"2=125ft(38.0m)

CBL\ LAKE. DAT

Water sample data collected from Hagg Lake, OR on 8-Oct-96 by Scott
Holman and Dan Holmquist.

Water collected using the Vernier Water Depth Sampler. D.O., pH, and TDS
readings were taken from raised samples. Temperature taken using the Vernier
ExtraLong Temperature Probe.

CBL\ RUNNI NG. DAT

50-year old male running on hilly terrain.
0-4 min getting ready to run
0- 13 minrolling hills (neighborhood)
13-32.5 hills, including Hamilton
32.5-37.5 walk on uphill
37.5-44.5 climb to summit
44.4-48.5 down
48.5 short water break
48.5-58 mostly down, with final hill.
58-62 walk downhill
62- sitting down

CBL\ SPACEN. DAT

Acceleration and air pressure data taken during aride up the Seattle Space
Needle.

CBL\ STORM DAT

Pressure in Portland, OR, for the storm on 12/11/95. Data was collected in four
parts using a CBL. The data was added in with the time adjusted for the start of
the each new run.
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Appendix B
Other Vernier Software Products

Vernier Software has been publishing science software since 1981. We have software and hardware for Macintosh,
Windows, MS-DOS, and Apple || computers, aswell as Texas Instruments Graphing Calculators. The followingisa
list of some of our other products. If you would like to receive a complete catalog of Vernier Software products,
please contact us at:

Vernier Software & Technology
13979 SW Millikan Way
Beaverton, Oregon 97005-2886
Phone (503) 277-2299
FAX (503) 277-2440
WWW.Vernier.com
info@vernier.com

Hardware, Software, and Books for Computer Data Collection

Hardwar e

LabPro: LabPro offers unparalleled flexibility, power, portability, and ease of use at an affordable price. Not only can
you use LabPro with a computer, but you can also use it with a Texas Instruments Graphing Cal culator. When you use
LabPro with a computer, you have a choice of Windows or Macintosh computers and a choice of connecting it to a
serial port or USB port. If you use LabPro with a graphing calculator, the calculator programs you need are stored
within LabPro.

Serial Box Interface: Our Serial Box Interface isthe low-cost way to take data with your PC computer. Plug the
Serial Box Interfaceinto the seria port of the PC computer, connect your sensor(s), and graph temperature, pH,
pressure, heart rate, light intensity, voltage, and more. Use with any of the standard Vernier Software sensors with 5-
pin DIN connectors. May be powered by a battery pack mounted inside the box (sold separately). Serial Box Interface
i$$99.00. Software sold separately.

Universal Lab Interface: The Universal Lab Interface (for PC computers) allows awide variety of sensors and
probes to be interfaced to PC computers. Available sensors include motion detectors, force sensors, radiation
monitors, pH probes, pressure sensors, light sensors, magnetic field sensors, and microphones. $220. Software sold

separately.
For a complete listing of our products (including over 40 sensors), please check out our web site www.vernier.com.

Softwar e

Logger Proisour all-purpose data collection and analysis program. It combines the features of most of our older
programs (Data Logger, Motion, Sound, Rotary Motion, and ULI Timer) into one easy-to-use full-color program. It is
our newest software, works with all of our sensors, and has been very popular since we began shipping it in 1997.

Books
Chemistry with Computers by Dan D. Holmquist and Donald L. Volz. A collection of 30 chemistry experiments using
Vernier programs and sensors. $35.00

Physical Science with Computers by Donald L. Volz and Sandy Sapatka. A collection of 41 physical science
experiments using Vernier programs and sensors. $35.00

Biology with Computers by Dave Masterman and Scott Holman. A collection of 30 biology experiments using
LabPro, Serial Box Interface, or ULI for Macintosh or PC computers. $35.00
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Physics with Computers by Ken Appel, John Gastineau, Clarence Bakken, David Vernier, and Richard Sorensen. A
collection of 34 physics experiments using LabPro or ULI for Macintosh or PC computers. $35.00

Water Quality with Computers by Robyn L. Johnson, Scott Holman, and Dan D. Holmquist. A 250-page manua (and
accompanying CD) for using your computer and Vernier sensors to determine the water quality of streams, lakes, and
seawater. $35.00

Middle School with Computers by Donald L. Volz and Sandy Sapatka. This lab manual provides 38 ready-to-use
experiments for science classes in middle school. $35

Hardware and Books for Calculator Data Collection

Hardware

LabPro: LabPro offers unparalleled flexibility, power, portability, and ease of use at an affordable price. Not only can
you use LabPro with a computer, but you can also use it with a Texas Instruments Graphing Cal culator. When you use
LabPro with a computer, you have a choice of Windows or Macintosh computers and a choice of connecting it to a
serial port or USB port. If you use LabPro with a graphing calculator, the calculator programs you need are stored
within LabPro.

Texas Instruments CBL 2™ is perfect for anyone who wants to collect datawith a Tl Graphing Calculator. Within
the classroom, you can use the CBL 2 and a graphing calculator as alow-cost aternative to computers for collecting
and analyzing real-world data. The CBL 2 System includes the CBL 2 interface, a new stainless steel temperature
probe, light probe, voltage probe, calculator cradle, short link cable, use's guide, and a Tl Resource CD. The calculator
programs you need are stored within the CBL 2.

For a complete listing of our products (including over 40 sensors), please check out our web site www.ver nier.com.

Books

Chemistry with Calculators by Dan Holmquist and Donald L. Volz. A collection of 35 experiments using
LabPro/CBL 2 with TI graphing calculators and Vernier sensors. Included are the word processing files for the student
handouts on disk. $35.00

Physical Science with Calculators by Donad L. Volz and Sandy Sapatka. A collection of 40 physical science
experiments using LabPro/CBL 2 with the T1-82 or T1-83 and Vernier sensors. $35.00

Biology with Calculators by Dave Masterman and Scott Holman. A collection of 30 biology experiments using
LabPro/CBL 2 with the TI graphing calculators and Vernier sensors. Included are the word processing files for the
student handouts on disk. $35.00

Physics with Calculators by Ken Appel, John Gastineau, Clarence Bakken, David Vernier, and Richard Sorensen. A
collection of 34 physics experiments using LabPro/CBL 2 with TI graphing calculators and Vernier sensors. Included
are the word processing files for the student handouts on disk. $35.00

Water Quality with Calculators by Robyn L. Johnson, Scott Holman, and Dan D. Holmquist. A 250-page manual
(and accompanying CD) for using your LabPro/CBL 2 and Vernier sensors to determine the water quality of streams,
lakes, and seawater. $35.00

Middle School with Calculators by Don L. Volz and Sandy Sapatka. This lab manual provides 38 ready-to-use
experiments for science classesin middle school. $35
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