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Part 1 Introduction 

ProTuner for iSS is a software that Leadshine developed to configure and tune iSS series stepper servo motors 

including iSS57-10 and iSS57-20 at the moment (more models will be added in the future). With that software, a 

user can configure iSS motors’ output current, micro step, command type, and other parameters. It can be also 

used to fine-tune iSS series motors’ current loop and position loop parameters. 

System Requirements 

To be able to install Leadshine ProTuner for iSS Setpper Servo Motor software, a computer should have a Windows XP/7 

operation system installed, and at least 512 MB memory. 

Hardware Setup 

Connecting an iSS Stepper Servo Motor to a DC Power Supply 

First, connect a DC power supply (20-50 VDC) to the power connectors of the iSS stepper servo motor. See Leadshine iSS 

Integrated Stepper Servo Motors Hardware Installation Manual for detail. If you don’t have such a power supply, go to 

Leadshine website at http://leadshine.com/Product_Show.aspx?ID=142 to find one compatible DC regulated switching, 

unregulated switching, or linear power supply. 

Connecting an iSS Stepper Servo Motor to a Computer 

To connect a Leadshine iSS series stepper servo motor to a computer, use a Leadhsine special RS232 cable, model 

Cable-Pc-i, to the serial port of your computer. If your computer does not have a serial port, Use one USB-RS232 

converting cable  

        

Software Installation 

The compressed zip file of Leadshine ProTuner for iSS stepper servo motors can be downloaded at 

http://www.leadshine.com/UploadFile/Down/ProTunerV1.0_iSS_Setup.zip. After the zip file is downloaded 



 

 

successfully, unzip it to a local fold on your computer. From that folder, run the executable exe file, and follow the 

on-screen instructions to get the software installed. 

Software Layout 

Workspace 

See the following screen shot for the layout of Leadshine iSS software interfaxe 
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Menus and Toolbar 

Menus and toolbars are at the top of the workspace. You can click menu bar to view pull-down menu. The toolbar 

below offers the most frequency commands. 

Menu Pull Down Toolbar Function 

Projects -> 

Connect to Drive 
 

Open a computer’s serial port and 
connect to an iSS stepper servo motor 

Exit - Exit from ProTuner 

Drive Settings-> 

Current/Position 
Loops  

Tune the current loop, adjust the 
position loop parameter and perform 
Motion Test. 

Inputs / Outputs 
         

Cofigure input command type, active 
level of the I/O signals, pulse 
bandwidth. 

Download to Drive 
 

Download settings to the drive board’s 
NVM (No-volatile Memory) of an iSS 
stepper servo motor 

Reset - Reset all configurations to default. 

Motor Settings-> Motor Settings 
 

Set micro step resolution, position 
error limit, and encoder resolution. 

Tools-> Parameters 
 

Download / upload configurations to / 
from iSS motor’s drive board. It can 
also save configurations to a file, or 
restore them from a file. 



 

 

 Check Errors 
 

Check drive current / historical error(s) 

Help-> About ProTuner  
Display ProTuner software version and 
drive board firmware version 

 

  

4 / 26 



                                                                               Leadshinie Protuner for iSS Software User Manual 

5 / 26 

 

Part 2 Using Software 

Project Menu 

Connect to Drive 

Connect to Drive window appears every time when ProTuner for iSS software is started. A connection between an 

iSS57 step motor and a computer can be opened by selecting the right connection serial port and clicking “Open” 

button. That could take a few seconds, because the software will load current drive board settings to the computer 

memory, from the connected iSS stepper servo motor. After connection is opened successfully, the caption of the 

button will be changed to “Close”. The connection can be closed by clicking “Close” button.  

     

 

 

Before connecting the drive, make sure: 

1)  The RS232 cable has connected the drive and PC serial port securely. 

2)  The iSS stepper servo motor has been powered on and the green LED is turned on. 

 

Do not connect or disconnect serial cable while drive is powered on. Otherwise, the drive’s 
communication circuit could be damaged. 

 

  

!
Notice

!
Caution



 

 

Exit 

Exit window appears when Project -> Exit menu item is clicked. Click “Yes” to exit ProTuner for iSS software, 

or click “Cancel” button to cancel. 
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Drive Setting Menu 

Inputs / Outputs 

Click Drive -> Inputs/Outputs to open the I/O configuration window. You can chose to free or lock motor 

shaft after disabling drive, select the Pulse Active Edge, active level of In-position output, active level of 

fault output, active low disabling or active high disabling and pulse bandwidth. 

 

  



 

 

Inputs / Outputs  (Continued) 

Item Description Range 

After 
Disabling 

Drive 

Select to free or lock the motor shaft after disabling drive. 
If the “free motor shaft” is selected, the drive board will 
close all the power state after disabling drive and the 
motor coil current is set to zero. You can perform manual 
move via the “free motor shaft” selection. Otherwise, if 
the “lock motor shaft” is selected, the motor shaft will be 
locked and the motor current will be set to the value of 
holding current. 

Free motor shaft / 
Lock motor shaft 

In-position Signal 
Level 

Set the active output impedance of the in-position 

signal. If it is active low, the impedance between 
PED+ and PED- is low when the target position is 
reached. Otherwise if it is active high, the impedance 
between PED+ and PED- is high when the target 
position is reached. 

Active Low / 

Active High 

Pulse Mode 

Pulse mode of control signal. Select PUL/DIR or CW/CCW 
according to command type of motion controller. 
PUL/DIR means pulse and direction mode; CW/CCW 
means double pulses mode. 

PUL/DIR, or 

CW/CCW 

Fault Output 

Set the active output impedance of the fault signal. If it 

is active low, the impedance between ALM+ and 
ALM- is low when the target position is reached. 
Otherwise if it is active high, the impedance between 
ALM+ and ALM- is high when the target position 
is reached. 

Active Low / 

Active High 

Disabling Set active input level of disable signal. 
Active Low / 

Active High 

Pulse Bandwidth 
Select the input pulse bandwidth or the maximum input 
frequency. 

200K / 500K 

8 / 26 



                                                                               Leadshinie Protuner for iSS Software User Manual 

9 / 26 

 

Current / Position Loops 

Click Drive->Current / Position Loops to open this window. You can adjust the current loop Kp (proportional gain) 

and Ki (integral gain) in this window. To test the iSS motor performance for parameter performance change, click 

the “Start” button to run the motor. 

 

  

Position Following Error curve is 

displayed during motion test. Now 

you can see the error is between -6 

pulses to 6 pulses. 



 

 

Motion Test Tab 

In the Motion Test tab, you can make the motor move without an external pulse generator or motion controller. 

Configure the trapezoid velocity file first and then click the Start button.  
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Motion Test Tab   (Continued) 

Item Description Range 

Velocity (r/s) Target velocity of Motion Test. 1– 50 rps 

Accelerate 
(r/r/s) 

Acceleration of Motion Test. 
1 – 65535 
r/s^2 

Distance (r) Move distance of Motion Test. 1 – 65535 r 

Intermission 
(ms) 

Interval between moves. 1 – 65535 ms 

Repeat Repeat times. 1– 65535 

Run Direction Move direction. 
Positive/ 
Reversal 

Run Model 

Motion Test mode includes single direction 
motion or two direction Motion. 
Undirectional: Run in one direction, Round 
Trip: Run forward and back 

- 

Trace Time 
The time to sample the position following 
error data. 

100 - 3000 
ms 

Start Click to start the Motion Test. - 

Stop Stop the move immediately. - 

Close Close the Current / Position Loops window - 



 

 

Current Loop Tab 

Click Current Loop tab to open this window. The current loop parameter is related to the motor resistance and 

inductance.  

 

When power-up, the drive board will perform the auto-configuration and the current loop 
parameters will be calculated automatically. Here, this window is just for check. It is unnecessary to 
the current loop parameters by your self. 

 

 

…… Continued on next page 

!
Notice
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Current Loop Tab  (Continued) 

Item Description Range 

Current Loop Kp 

(Proportional Gain) 

Increase Kp to make current rise fast. Proportional Gain 
determines the response of the drive to current setting 
command. Low Proportional Gain provides a stable system 
(doesn’t oscillate), has low stiffness, and large current error, 
causing poor performances in tracking current setting command 
in each step. Too large Proportional Gain values will cause 
oscillations and unstable systems. 

1 – 65535 

Current Loop Ki 

(Integral Gain) 

Adjust Ki to reduce the steady error. Integral Gain helps the drive 
to overcome static current errors. A low or zero value for the 
Integral Gain may have current errors at rest. Increasing the 
Integral Gain can reduce the error. If the Integral Gain is too 
large, the systems may “hunt” (oscillate) about the desired 
position. 

1 – 65535 

Test Value (A) 
The current amplitude for the step response. Let this value not 
exceed the maximum output current of the drive. 

0.5-2A 

Start 
Enter Kp and Ki and click this button to activate the test. A target 
curve (red) will be displayed on the screen for user analysis. 

- 

  



 

 

Position Loop Tab 

Click Position Loop tab to open this window. You can adjust the position loop parameter to get lower noise or fast 

response of the motor. Double click the value to change the parameters. 

This tab only allows you to change parameter values. For testing the performance for your changes, switch to 

“Motion Test” tab, and click “Start” button. 

 

 

The default values of the position loop parameters have been optimized and they should 
be plug-and-play for most applications. It is unnecessary to tune them when the motor 
runs well. It is only recommended for fine-tuning and only adjusts those parameters when 
you see abnormal symptoms such as loud motor noise, or motor stalls easily at high speed. 

 

 

 

…… Continued on next page  

!
Notice

Double click the cell in Value 

column to change the value.  
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Position Loop Tab  (Continued) 

Item Description Range 

Position Loop Kp 

(Proportional Gain) 

Position Proportional Gain. Proportional Gain determines the 
response of the system to position errors. Low Proportional Gain 
provides a stable system (doesn’t oscillate), has low stiffness, and 
large position errors under load. Too large Proportional Gain 
values will cause oscillations and unstable systems. 

0 - 32767 

Position Loop Ki 

(Integral Gain) 

Integral Gain. Integral Gain helps the control system overcome 
static position errors caused by friction or loading. The integrator 
increases the output value as a function of the position error 
summation over time. A low or zero value for the Integral Gain 
may have position errors at rest (that depend on the static or 
frictional loads and the Proportional Gain). Increasing the Integral 
Gain can reduce these errors. If the Integral Gain is too large, the 
systems may “hunt” (oscillate at low frequency) about the desired 
position. 

0 - 32767 

Position Loop Kd 

(Derivative Gain) 

Position Derivative Gain. Derivative Gain provides damping by 
adjusting the output value as a function of the rate of change of 
error. A low value provides very little damping, which may cause 
overshoot after a step change in position. Large values have 
slower step response but may allow higher Proportional Gain to 
be used without oscillation. 

0 – 32767 

Position Loop Kvff Feed-forward gain. It speeds up the system response. 0 – 32767 

Holding Current (%) Motor current when there is no pulse applied to the drive. 0 - 100% 

Open-loop Current (%) Motor current when the drive goes into open loop control mode. 0 - 100% 

Close-loop Current (%) Motor current when the drive goes into close loop control mode. 0 - 100% 

Anti-interference Time Reserved 0 - 1000 



 

 

 

Position Loop Tab  (Continued) 

The effect of Kp, Kd, Ki and Kvff of position loop has similar functions as those parameters in normal brushless servo 

drives. Although their adjustable values are displayed as 0-32767, their actual adjustable ranges are limited. It is 

recommended to only adjust 10 - 30% from their default settings. Beyond the range, you may see an iSS57 runs 

abnormal, such as vibration or stall. 

 

* Position loop Fine-Tuning Tips 

Use the following table as guidance for position loop fine-tuning. 

Desired Results Actions 

Faster Response, High 
Speed, High Torque, 
Smooth Move 

Increase the Kp, Kd, Kvff, Open-Loop Current and Close-loop Current 

Lower Motor Noise, 
Lower Motor Heating  

Decrease Kp, Kd, Kvff, Open-Loop Current and Close-loop Current 
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Scope Tab 

Click Scope tab to open this window (shown in the next image). You can monitor the position following error in the 

left scope window. When you use this feature from ProTuner for iSS software, you may not be able to see anything 

without motor load. However, when an iSS motor runs in a real application, Scope window can help to monitor the 

performance of Position Following Error. 

 

 

 

Item Description Range 

Trace Time 
Time to sample the position following error. For 
example, if the trace time is 1000ms, the drive board 
acquires the error data every 1000ms. 

0 - 32767 

Start Start to monitor and display the position following error. - 

Stop Stop monitoring. - 

 



 

 

Download to Drive 

To permanently save those configured / tuned parameter values to the iSS stepper servo motor, you must perform 

“Download to Drive” action. Otherwise, all changes will get lost after the iSS motor is powered off. 

Click Drive Setting -> Download to Drive menu item bring up the following warning message. Click “Yes” button to 

save all parameters to the drive board’s non-volatile memory. Click “Cancel” button to cancel all your changes. 
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Reset 

A user can click Drive Settings -> Reset menu item to bring up the following warning message. Click “Yes” will to 

reset all the settings back to default settings. Click “No” to cancel reset. 

 

 

 

  



 

 

Motor Settings  

Click Drive->Motor Settings to open this window. You can set the micro step resolution, position following error 

limit and encoder resolution in this window. 

 

Item Description Range 

Micro Step Resolution Drive’s Micro Step setting for the motor. 1 - 51200 

Position Error Limit 

The limit of the difference between commanded 
position and the actual measured position. When 
position following error exceeds the Position 
Following Error Limit in the drive, the following error 
protection will be activated. 

0 - 65535 

Encoder Resolution 

The encoder lines. 4 × of the actual resolution. For 
example, if the encoder resolution is 1000, it is 4000. 

Note: Do not change the default value as it must be 
corresponded to the actual encoder resolution. 

200 - 10000 

------ Continued on next page 
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Motor Settings  (Continued) 

 

In order to be able change micro step resolution, DIP switch 1, 2, and 3 of an iSS stepper servo motor must be all 

set to “ON” positions. Resolution can be set to any value of 200- 51200 (increased to by 200). Higher resolution 

Micro Step makes the motor move smoother, but requires higher motion controller frequency.  

The default value of Position Error Limit is set it to 1000. If the application requires small position following error, 

reduce the Position Error Limit. 

The “Encoder Resolution” indicates the resolution (in lines) of the integrated encoder. It is for informational and you  



 

 

Tools 

Parameters 

Click Tools->Parameters to open the “Parameters” window.  

This window lets a user read current settings from the iSS motor drive board, load parameter values to the RAM of 

the iSS motor drive board, open a previously saved configuration file, save the current configuration to a file, reset 

motor configuration, or download those settings to the iSS stepper servo motor. 

Although a user can change parameter values from this window, it is recommended to use menu items in “Drive 

Settings” or “Motor Settings” for configuration / tuning, unless the user is sure what parameter value to set. 

 

 

------ Continued 

  

Double click the cell in Value 

column to change the value.  
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Parameters  (continued) 

Functions for left side buttons are described as follows: 

1) Read Drive: Read parameters from the drive 

Click “Read drive” button to upload all parameters from drive. Double click the value of the parameter, 

you can change the value. 

2) Load to Drive: Load parameters to drive 

Click “Load to Drive” button to load parameter values in the current window to the iSS stepper servo 

motor RAM for configuration / tuning. 

3) Open File: open a previously saved configuration file 

Click Open File button to open a previously saved configuration file to the “Parameters” window you 

want to load parameters from a PC file. The parameters in the software’s workspace will be updated.  

4) Save File: Save the parameters to a PC configuration file with .lsr extension 

Click Save File button to save the parameter of current workspace to a file. This file can be used for the 

other drive. 

5) Download to Drive: Download parameters to the drive’s nonvolatile memory; 

Click Download to Drive button to write parameter values in the current window to the iSS stepper 

servo motor. Read 6.2.3, “Download to Drive”, for detail. 

6) Reset: Restore factory settings of the drive. 

Click “Reset” button to reset all parameters to factory default. Read 6.2.4, “Reset”, for detail. 



 

 

Error Check 

You can check the active error or the error log of the drive in this window. Type of error is shown as follows: 

Item Description 

Over Current Error 
Error occurs when the motor coil current exceeds 
the drive’s current limit. 

Over Voltage Error 
Error occurs when the input voltage exceeds the 
drive’s voltage limit 

Position Following Error 
Error occurs when the actual position following 
error exceeds the limit which is set in Position 
Error Limit. 
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Part 3 Configuration Tips 

Suggested steps to configure a iSS stepper servo motor 

Usually, you can follow the fllowing steps below to configure /tune the drive board of an iSS motor from Protuner 

for iSS software.  

1) Set “Input/Output” parameters such as pulse mode, pulse bandwidth, pulse active edge, active level of 

fault output, position following limit and micro step resolution for your application 

2) Set “Motor Setting”. 

3) Adjust the position loop parameters when lower noise or fast speed is required.  

Configure Current Output 

When an iSS stepper servo motor runs, the output current from the drive board outputted to the motor ranges 

between the holding current and the close-loop current. When there is no pulse sent to the drive, it goes into idle 

mode and the actual output current is determined by the holding current percentage (similar to “idle current” of 

open loop stepper drives). In normal working mode, the iSS motor’s drive board monitors the actual shaft position 

all the time. The current outputted to the motor changes dynamically based on the tracking error between the 

actual position and the commanded position. 

By default, an iSS57 motor’s holding current percentage is set to certain percentage of the peak current and the 

close-loop current percentage is 100%, unless you change them from Leadshine’s configuration software (see 

software manual). Actual current outputted to the motor can be calculated as follows: 

(%)6 PercentageCurrentHoldingACurrentHolding   

(%)6 PercentageCurrentLoopCloseACurrentloopCloseMAX   

Low holding current can reduce motor heating however also reduces the holding torque which is used to lock the 

motor shaft at standstill. It is recommended to determine the holding current by whether or not there is big 

vibration at start-up and how much lock torque is required, based on your actual applications. 

 

Higher holding current results higher high-speed torque. To keep the motor heating extreme low, iSS 
motor default holding current percentage is set to 20-40% of the maximum output current. If you can’t 
get enough torque for in an application, try to increase that percentage. Please note that higher holding 
current percentage will result in higher motor heating. Try to find a balanced holding current 
percentage value.  

!
Caution



 

 

Contact Us 

Leadshine Technollogy , Ltd.         Headquarters 

Address 

3/F, Block 2, Nanyou Tianan Industrial Park, Nanshan District Shenzhen, China 

Web 

http://www.leadshine.com 

Sales 

Tel:  0086-755-2641-7674 (for Asia, Australia, Africa areas) 

     0086-755-2640-9254 (for Europe areas) 

     0086-755-2641-7617 (for Europe areas) 

Fax: 0086-755-2640-2718 

Email: sales@leadshine.com 

Technical Support 

Tel:  0086-755-2641-8447 / 0086-755-2641-8774 / 0086-755-2641-0546 

Fax:  0086-755-2640-2718 

Email:  tech@leadshine.com 

Leadshine America, Inc.        North America Office 

Address 

  Leadshine America, Inc. 

25 Mauchly, Suite 318 

Irvine, CA 92618 

U.S.A. 

Telelphone 

1-949-608-7270 (Sales & Technical Support) 

Fax 

1-949-608-7298 

Web 

http://www.leadshineUSA.com  

Email  

sales@leadshineUSA.com 

Technical Support 

support@leadshineUSA.com 
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