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Editing with the Spreadsheet Editor (G11)
The Spreadsheet Editor provides a numerical view of an INTREPID dataset. It 
enables you to directly edit data, create and manipulate fields, and perform search 
and replace operations using mathematical formulas.

You can edit line, point, polygon, grid, voxets and SEGY data using the Spreadsheet 
Editor. In this guided tour we will edit a line dataset.

The following illustration shows the specifications for a search and replace operation 
and some resulting values1.

IF mlevel_mag > 1969 && linetype == 2 

THEN mag_adj1 = mlevel_mag*.9994 

ELSE mag_adj1 = mlevel_mag

You can view and edit all of the new extended datatypes using this tool, including 
tensor, components, gradient vectors, complex structural geology and dates.

Overview
The INTREPID Spreadsheet Editor is one of the INTREPID editors (Spreadsheet, 
Flight Path, split cruise, clip line and Profile).

The INTREPID Spreadsheet Editor enables you to:
• Directly edit data by erasing and retyping individual values;
• Search for data according to a mathematical formula;
• Create a new field in a vector dataset or a new grid band;
• Use an ‘If .. Then .. Else ..’ search and replace operation to assign values in a 

dataset. 
• Apply arithmetic, statistical and geophysical functions in a flexible formula 

format

1.8 Use the field name mag_adj1, not mag_adjust1 when you use this guided tour.

Not greater than 1969 Greater than 1969
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The Spreadsheet Editor:
• Has a wide range of arithmetic, statistical and geophysical functions in a flexible 

formula format,
• Supports ALL INTREPID data formats—vector (line, point, polygon) grid, voxet 

and SEGY
• Supports grid-level arithmetic—you can add and subtract entire grids and create 

new grids.
• Supports user-written code,
• Supports smart geophysical observed data objects, such as Full magnetic tensor 

gradients combined with a scalar magnitude reading, or at V5.0, MT data 2D 
complex tensor decays.

• The V5.0 replacement tool is known as Gravitas.

Context of this guided tour
In the context of your data processing cycle, this tour represents direct editing 
and mathematical enhancement of data that you could wish to do at any stage. The 
use of the fully corrected mlevel_mag field puts the tour slightly out of sequence in 
our case study, since this field will be ‘officially’ created in a later tour (See 
Levelling—decorrugation and microlevelling (G14)). We chose mlevel_mag because 
the example in this tour would most likely be applied to fully corrected data.

Should you complete this guided tour?
This guided tour is intended for intermediate level users. Its process is more complex 
than that of an introductory level tour and its instructions are less detailed. If you are 
a beginner or wish only to have a brief overview of INTREPID’s capabilities, you can 
omit this guided tour. Omitting this guided tour will not affect your understanding of 
later tours. 

The ability to directly edit values and mathematically enhance data using your own 
formula is a desirable feature of a geophysical data processing system. You should 
note that INTREPID includes an extensible API for this kind of operation. The 
example macros are distributed.
Location of sample data for Guided Tours
We provide two complete sets of sample datasets, one in INTREPID format and one 
in Geosoft format.  INTREPID works equally well with both formats.  When you want 
to open a dataset, navigate to the directory containing the required data format.

Where install_path is the path of your INTREPID installation, the project 
directories for the Guided Tours sample data are   
install_path\sample_data\guided_tours\intrepid_datasets and  
install_path\sample_data\guided_tours\geosoft_datasets. 

For example, if INTREPID is installed in  
C:\Program Files\Intrepid\Intrepid4.5.nnn,  
then you can find the INTREPID format sample data at  
C:\Program Files\Intrepid\Intrepid4.5.nnn\sample_data\ 
guided_tours\intrepid_datasets 

This is the default location for the sample data.  If you have installed INTREPID 
normally, the data resides there. If you have installed INTREPID elsewhere, the 
exercises will work just as well. Just use the appropriate pathnames.
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For more information about installing the sample data, see  "Sample datasets—
installing, locating, naming" in INTREPID Guided Tours Introduction (G01)

For a more detailed description of INTREPID datasets, see Introduction to the 
INTREPID database (G20).  For even more detail, see INTREPID database, file and 
data structures (R05).

Location of sample data for CookBooks
Right next to the Guided tours data, is a rich set of more exotic geophysics datasets 
and grids, already prepared for the cookbook training sessions. A casual user might 
also gain some trial and error insights into the capbilities of the software, just by 
testing the Project Manger’s ability to preview and describe the attributes of each of 
the cookbook datasets.

What you will do
Flowchart Summary
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Steps to follow
Launch the 
Spreadsheet 
Editor

1 Start the Project Manager. Navigate to the directory 
install_path\sample_data\guided_tours\intrepid_datasets. Start 
the Spreadsheet Editor.  Choose File > Open Dataset. When the Load Dataset 
dialog box appears, select the line dataset ebagoola_ST.
See Locating datasets, viewing, statistics, launching tools (G02) for instructions 
about navigating to different directories and selecting datasets.
Choose Spreadsheet Editor from the Editors menu. After opening the dataset 
ebagoola_ST, it displays the tabular data in the Spreadsheet Editor window. 
Each column in the spreadsheet corresponds to a field in the dataset. The first row 
of each column is preceded by the name of the field.

Directly editing a value
Directly edit an 
individual 
value

2 Change the value of mlevel_mag in the first row to 1973.71. 
Click the value of mlevel_mag in the first row. INTREPID displays the value in 
the Edit Cell text box. Click immediately to the right of the number in the Edit 
Cell text box.

Press BACKSPACE twice or more to erase the 67.  Type 71.
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Press ENTER. INTREPID displays the new value in the spreadsheet.

Tip: Remember that INTREPID saves your changes directly to the dataset files 
when you use the Spreadsheet Editor. This enables you to edit very large datasets 
without having to load them into your computer’s memory.

Finding a certain value in a field
Search for a 
data point 
matching a 
condition

3 Find the first data point in the dataset where the field mlevel_mag has a value 
less than 1959.
Choose Find from the Edit menu. INTREPID displays the Find dialog box. Type 
mlevel_mag < 1959 into the Search for text box. Choose Forward.

INTREPID will find and display the first data point that matches this condition.

Choose OK in the Find dialog box to dismiss it.

First value < 1959

Position in the dataset
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Creating a new field (column) and assigning values using the Replace operation
Navigate to the beginning of the dataset

4 Return to Row 1 of Group (line) 1 of the dataset.
Choose Navigate from the Edit menu. INTREPID displays the Navigate dialog 
box. Enter the value 1 into each of the three text boxes.

Choose Apply. INTREPID displays the first row of the first group (line) in the 
Spreadsheet window.

Choose Close in the Navigate dialog box to close it.
Tip: You can leave the Navigate dialog box open for further use if required. You 
can change focus between the Spreadsheet window and the Navigate dialog box as 
required.
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Create a new 
field

5 Create a new column (i.e, new field) called mag_adj1.
Choose Create Column from the Edit menu. INTREPID displays the Create 
Column dialog box. Type mag_adj1 into the Field name text box.

Choose OK. INTREPID will create the new column at the right hand end of the 
spreadsheet. By default, all values in the field will be set to Null. Use the 
horizontal scroll bar to view the new field (move the scroll box to the right).

New 
column 
contains 
nulls at 
first.
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Set decimal 
places for 
display

6 Set the number of decimal places for the field to 2
From the Format menu choose Format Column. INTREPID displays the Format 
Columns dialog box. Select (double-click) the field mag_adj1. INTREPID will 
display its default display values for width and decimal places. Enter 2 into the 
Decimals text box.

Choose Apply. Choose Cancel to dismiss the box.
Use Replace 
with an 
expression to 
assign values 
to the new field

7 Assign the value of the new column (field) mag_adj1 by using the Replace function 
to define a logical condition expression.
From the Edit menu choose Replace. INTREPID displays the Replace dialog box. 
Enter the following into the corresponding text boxes of the dialog box.
If      mlevel_mag > 1969
Then     mag_adj1 = mlevel_mag*.9994
Else      mag_adj1 = mlevel_mag 

Use of logical AND operator. (optional) You can  use the following for the IF 
text box instead if you wish. This restricts the replacement to acquisition lines 
(line type 2). && is the notation for logical AND, and == is the notation for ‘is equal 
to’ in a condition expression (following the C language convention). 
If                mlevel_mag > 1969 && linetype == 2
Choose OK. 
INTREPID displays a Confirm Overwrite dialog box.

Choose Yes.
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INTREPID will calculate values for the mag_adj1 column (field).
Note: Use the field name mag_adj1, when you use this guided tour not 
mag_adjust1 as shown in the illustrations.

Examine the 
new field 
values

8 Use the scroll bars and Previous and Next Groups buttons to examine the results 
of your search and replace operation.

Exit 9 If someone else will be using this guided tour, restore the value changed in Step 2 
and delete the field mag_adj1 from the dataset. Exit from the Spreadsheet tool. 
Return to Row 1 of Group 1 as explained in Step 4. Reverse the process in Step 2 
to restore the value to 1973.67. Choose Delete a Field from the Edit menu. 
INTREPID displays the Select Field to Delete dialog box. Select (click) mag_adj1 
and choose OK. INTREPID displays a confirm dialog box. Choose Yes. INTREPID 
will delete the field. Choose Quit from the File menu to exit from the Spreadsheet 
Editor.

New column 
now contains 
values.

Greater than 1969
(Group 1, Rows 1–20)

Not greater than 1969
(Group 1, Rows 476–495)
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Key points for this guided tour
In this guided tour of the Spreadsheet Editor you have:

• Directly edited data by erasing and retyping individual values,
• Searched for data according to a mathematical formula,
• Created a new field in a vector dataset;
• Used an ‘If .. Then .. Else ..’ search and replace operation to assign values in a 

dataset using a mathematical formula.
Note that the Spreadsheet Editor:
• Has a wide range of arithmetic, statistical and geophysical functions in a flexible 

formula format,
• Supports ALL INTREPID data formats—vector (line, point, polygon) grid, voxet, 

SEGY
• Supports geophysical fields using appropriate algebra and graphical 

representations
• Converts to/from scalar components to tensor/vector/quaternion etc.
• Supports user written macro code.

Frequently Asked Questions
Q : You say a wide range of operators is supported. What are they?
A : The INTREPID Acalc@ class is available to a number of tools (including 
Spreadsheet, Subsection and Levelling). See INTREPID expressions and functions 
(R12) for a complete list. The list includes:
• Arithmetic expressions
• Trigonometric functions
• Logical expressions
• Statistical functions
• Tensor conversions
Q : I wish to use my own secret high performance filter. Can I use it with 
INTREPID without having to reveal it outside my organisation?
A : Yes. You can write code for your filter/macros using our very simple published 
database Application Programmer Interface. You can then call your code and pass 
parameters to it like any other Spreadsheet function. If you require assistance with 
this process contact our technical support service.
Q : Can I edit grids?
A : Yes. The INTREPID Spreadsheet Editor supports grids. You can perform simple 
and effective grid operations using arithmetic operations. 
Q : Can I load multiple grids and compare them?
A : Yes. The Spreadsheet Editor supports activities such as grid arithmetic between 
grids.
Q : Can you delete and split groups and rows?
A : Yes. You can automate the process using conditional operators.
INTREPID expressions and functions (R12)
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Q : Can I edit tensor data?
A : Yes, a Mohr circle diagram is used to visualise the tensor relationships.
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