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Welcome! 
Welcome to PlanMaker Mobile – the only spreadsheet application that renders 

your documents on smartphones and tablets exactly like on a PC.  

PlanMaker is part of SoftMaker Office Mobile, the most powerful office package 

for Android devices.  

More information, updates, downloads, etc.: 

www.softmaker.com 

http://www.softmaker.com/


Support forum: 

www.softmaker.com/forum 

Enjoy! 

User Interface 
In this section, you will learn how to use the program. The following topics are 

covered: 

 Working with menus 

 Working with toolbars 

 Working with the worksheet tabs 

 Entering text or data 

 Selecting text, objects, etc. 

 Exiting the application 

Working with menus 

The main menu contains all of the application’s commands in the form of clearly 

arranged menus.  

http://www.softmaker.com/forum


 
The main menu 

To open the main menu, push the Menu key on your device.  

To invoke one of its commands, first tap on a menu entry, then tap on a command.  

For a detailed list of all menu commands, see the section “Overview: Menu 

commands”. 

Note: Some devices are not equipped with a hardware menu key, but instead 

display a menu button on the screen. It is usually labeled with three dots and can 

be found either at the very right of the title bar or below the application window. 

Context menu 

In addition, a menu called context menu is available. It contains commands de-

pending on the current situation. For example, when you select text and open the 

context menu, it will offer commands for cutting, copying, and formatting the text. 

To open the context menu, tap on any place in the document and hold your finger 

there for at least one second. 



Working with toolbars 

Toolbars contain icons for most commonly used menu commands. 

The main toolbar (also called Standard toolbar) is shown right below the docu-

ment. 

 

 

Its icons have the following functions (from left to right): 

1 Keyboard on/off 

2 File toolbar on/off 

3 Edit toolbar on/off 

4 Format toolbar on/off 

5 Worksheet toolbar on/off 

6 Change zoom level 

7 Row and column headers on/off 

8 Open settings dialog (only on tablets) 

9 Open help file 

Hint: When you tap on an icon and hold your finger there for a second, the func-

tion of the respective icon is displayed on the screen. 

Note: Some toolbars are wider than the screen and can’t be displayed in a whole. 

To see the rest of such a toolbar, wipe over it with your finger (to the left or right). 

For a list of all toolbars and their icons, see the section “Overview: Toolbars”. 

Working with the worksheet tabs 

The worksheet tabs are displayed above the document. 



 
The worksheet tabs 

They represent the worksheets that a document contains. To switch to a different 

worksheet, tap on the corresponding tab.  

You can enable or disable these tabs anytime using the View > Worksheet Tabs 

command. 

Entering text and data 

This section describes how to enter text and data in a document or in dialogs. 

In documents 

To edit the content of a table cell, proceed as follows: 

 First, tab on the table cell of interest. Then, tap into the large input field in the 

Input toolbar displayed above the table. A blinking text cursor will appear 

there, indicating that you can start typing now. 

 Alternatively, simply double-tap on a cell. The text cursor appears inside the 

cell, and you can start editing the cell directly. 

Note: The on-screen keyboard will open automatically whenever you can enter 

text. If you don’t want this, turn the option Show/hide keyboard automatically 

in the Tools > Options dialog off. 

You can always open and close the on-screen keyboard manually, as follows: 

A) Tap on the keyboard icon  in the main toolbar. 

B) Or: Press-and-hold the Menu button for at least one second. (This does not 

work on all devices.) 

To close the on-screen keyboard, proceed exactly the same way. Alternatively, 

you can press the Back button to close the keyboard.  



Finishing your input 

When you want to finish editing a cell, tap on either of the two icons displayed at 

the very right of the Input toolbar: 

 Hit the  icon to accept your changes.  

 (Alternatively, simply press the Enter key – or tap on any other cell.) 

 Or: Hit the  icon to reject your changes and restore the previous content 

of the cell. 

In dialogs 

In dialogs, you simply tap into the text field that you want to edit. The on-screen 

keyboard will open automatically. 

Note: In dialogs, the Show/hide keyboard automatically option is not respected. 

There, the keyboard will always appear automatically when you tap into a text 

field. This behavior is dictated by the Android system. 

Switching input methods 

To switch to a different input method (e.g. to a different on-screen keyboard), tap-

and-hold on any place in the document. A context menu appears. Choose the 

Input Method command, and select the keyboard that you want to use.  

Selecting cells, text, objects, etc. 

Some commands expect you to first select e.g. the cells on which you want to 

carry out the command. In this section, you will learn how to select cells, text 

segments, and objects (pictures etc.). 

Selecting cells 

To select cells, proceed as follows: 

1. Tap on the starting cell once. (There should not be a blinking text cursor 

appearing in the cell.) 



2. Wait a little moment, then tap on the same cell once more, and drag your 

finger to the cell where you want the selection to end. 

Alternatively, you can use the Edit > Select menu command to select, for exam-

ple, the current row/column or the entire table. 

Selecting text 

You can also select just a segment of text within a cell. The easiest way to achieve 

this is the following: 

1. Double-tap on the cell of interest. The text cursor should start blinking in it. 

2. Double-tap on any word inside the cell. This word will be used as the starting 

point of the selection.  

3. The word is now selected. Large “handles” appear before and after the word. 

  

4. These two handles represent start and end of the selection. They allow you to 

extend the selection easily: Simply drag these handles to the desired positions. 

 Tip: On small displays, it might be useful to close the on-screen keyboard 

while you do this. 

As an alternative, the Edit > Select menu command offers additional commands 

for selecting text. 

Hint: To remove a selection, simply tap into the document (at any position). 

Selecting objects 

To select an object (picture, drawing, etc.), simply tap on it.  

There’s one exception: If you want to select an object that contains text (e.g. a text 

frame), you have to tap on the border of the object. 



Exiting the application 

There are two different ways to exit PlanMaker: 

Actually ending the application 

When you hit the Back button or execute the File > Exit menu command, the 

application is actually closed down. 

“Parking” the application in background 

On the other hand, when you push the Home button or switch to another app, the 

application continues running in background. 

As a result, the next time you open the application, it will be restored exactly the 

way you left it. 

Overview: Menu commands 
The main menu contains all of the application’s commands in the form of clearly 

arranged menus. To open the main menu, hit the Menu key (or tap on the menu 

button on the display). 

This section covers all sub menus and menu commands available: 

 File menu 

 Edit menu 

 View menu 

 Format menu 

 Table menu 

 Tools menu 



File menu 

The File menu contains commands related to working with files, including: 

New 

Creates a new document. 

Open 

Opens an existing document. 

Documents can be stored in any of the following locations: 

 In the device memory (e.g. SD card) 

 In external memory (e.g. USB stick) 

 Or in an online storage (Dropbox, Evernote, Google Drive, or Microsoft 

Skydrive)*. 

 * Note: Dropbox, Evernote, Google Drive, and Microsoft Skydrive are third party services not 

affiliated with SoftMaker. Account required. Basic accounts are offered free of charge; addi-

tional storage space may require a fee. 

Save 

Saves the current document. 

Save as ... 

Saves the current document under a different name, in a different folder, or in a 

different file format. 

Summary 

Opens a dialog where you can enter supplemental information on the current 

document (title, author, etc.). 



Page setup 

Allows you to modify the paper format of the document. 

Export as PDF 

Exports the document to a PDF file.  

PDF files can be viewed on virtually any computer, provided that it has a PDF 

viewer installed. Text formatting and objects (images etc.) are rendered exactly as 

in the original file. 

Send 

Sends the current document to someone else, for example, by e-mail or by Blue-

tooth. 

The following dialogs will appear: 

In the first dialog, choose the file format in which to send the file (e.g. PlanMaker 

document or Excel document). 

In the second dialog, a list of all applications that are able to send files is dis-

played to choose from. It contains entries like your e-mail program, Bluetooth, 

and any other suitable apps installed. 

After that, usually a third dialog is displayed by the chosen app. It allows you to 

set up the recipient and other options, and to initiate the transfer. 

Exit 

Exits the application (closes it down entirely). See also section “Exiting the appli-

cation”. 

List of most recently used documents 

At the bottom of the File menu, a list of the most recently opened documents is 

displayed. If you tap on an item, the corresponding file will be opened.  



Edit menu 

The Edit menu contains commands for editing the content of a document, includ-

ing: 

Undo 

Reverses the most recently made change. 

Redo 

Restores the effect of the most recent undo action. 

Select 

Opens a menu with commands for selecting the current row/column or the entire 

worksheet. For detailed instructions on selections, see section “Selecting text, 

objects, etc.”. 

Cut 

Deletes the content of the current selection and places it in the clipboard. To insert 

it somewhere else in the document, navigate to the desired position and invoke 

the Edit > Paste command.  

Copy 

Copies the content of the current selection into the clipboard. To insert it some-

where else in the document, navigate to the desired position and invoke the Edit > 

Paste command.  

Paste 

Inserts the content of the clipboard into the document. All formattings and objects 

(pictures etc.) will be preserved. 

Note: This works only within PlanMaker. 



External Paste 

Inserts the content of the clipboard into the document as well. However, this 

command doesn’t use PlanMaker’s internal clipboard but the system-wide clip-

board. 

Advantage: Allows you to insert data that was put into the clipboard with any 

other application. 

Disadvantage: Text format and objects are lost, since the Android clipboard 

doesn’t support this. 

Search 

Searches the document for a specific term. 

Replace 

Searches the document for a specific term and replaces it with another term. 

Search/Replace Again 

Repeats the most recent search/replacement operation, and advances to the next 

occurrence. 

Go to ... 

Jumps to the specified cell address. You can enter either the address of a single 

cell (e.g. D2) or the address of a range of cells (e.g. D2:D4). 

View menu 

The View menu contains commands that change the display of a document on the 

screen, including: 



Freeze 

Freezes the top rows and/or columns of a worksheet on the screen. This will cause 

them to stay in place when you scroll the worksheet – ideal for row or column 

headings. 

Before you invoke this command, navigate to the desired cell. All rows above this 

cell and all columns left of the cell will be frozen. 

To deactivate freezing, invoke the View > Freeze command once again. 

Zoom Level 

Changes the zoom level. 

Show Formulas 

If activated, cells containing a calculation will display the formula rather than the 

result.  

Syntax Highlighting 

If activated, cells will be colorized according to their content. For example, cells 

containing an error are displayed in red; cells containing a formula are displayed 

in green, etc. 

Row and Column Headers 

Turns the display of row headers (1, 2, 3 ...) and column headers (A, B, C ...) 

on/off in the current worksheet. 

Worksheets 

Allows you to switch to a different worksheet in the current document.  

Hint: The worksheet tabs (see below) provide a much faster way of switching 

between worksheets.  

For more worksheet related functions, see the Table > Worksheet command. 



Toolbar 

Turns the main toolbar on/off. See also section “Working with toolbars”. 

Input Toolbar 

Turns the Input toolbar on/off. That’s the bar displayed above the table, where you 

can edit cell contents.  

Note: When you have turned this toolbar off, you can still edit cells by double-

tapping on them. See also section “Entering text and data”. 

Worksheet Tabs 

Turns the worksheet tabs on/off. 

The worksheet tabs are displayed above the document. 

 
The worksheet tabs 

They represent the worksheets that a document contains. To switch to a different 

worksheet, tap on the corresponding tab.  

Keyboard 

Turns the on-screen keyboard on/off. See also section “Entering text and data”. 

Format menu 

The Format menu contains commands that allow you to format cells or text. You 

can select the desired cells (or the desired text segment) beforehand. Commands 

available: 

Number Format 

Changes the number format of cells. 



The number format determines how numbers are represented in cells. For exam-

ple, when you select the “Currency” number format, numbers are displayed with 

the chosen currency symbol and rounded to two decimal places (e.g. $42.50). 

Cell Alignment 

Changes the alignment of the cell content. Options available: 

Horizontal alignment: Changes the horizontal alignment. 

Vertical alignment: Changes the vertical alignment. 

Wrap text: If this option is checked, the cell content will automatically be 

wrapped to multiple lines, if it does not fit into a single line. 

Vertical text: If this option is checked, the cell content will be displayed vertical-

ly (top to bottom instead of left to right). 

Join cells: Lets you join a cell with neighboring cells. Joined cells are treated as if 

they were a single cell. To join cells, select them and activate this option.  

Character 

Changes the character format of text. Options available: Font face, size, style, 

color. 

Tip: In SoftMaker Office, you can even use fonts that are not installed in your 

Android system. To learn how, visit the Tips and Tricks page on our website. 

Bold, Italic, Underline 

Turns boldface, italics, or underlining on/off 

Borders 

Adds border lines to cells. 

Shading 

Adds a shade or fill pattern to cells. 

http://www.softmaker.com/english/tipsandroid_en.htm#fonts


Table menu 

The Table menu contains commands for editing tables, including: 

Insert Function 

To utilize arithmetic functions in formulas, either just type in their function name 

manually – or use the function lists provided in the Table > Insert Function 

dialog box.  

In the two list boxes, first choose a category, then choose the desired function. 

The function name will be transferred to the edit control at the top of the dialog, 

where you can enter parameters or make any other kinds of changes. When you 

have finished composing the formula, hit the OK button to insert the calculation 

into the current cell. 

Tip: If you want to learn more about PlanMaker’s more than 330 arithmetic 

functions, their utilization, their parameters, etc., download the manual for the 

Windows version of PlanMaker. You will find it in the Download section of our 

website www.softmaker.com. It covers every single function in detail. 

Column 

Offers commands for editing columns, including: 

 Width: Lets you enter a numerical value for the column width. 

 Optimum width: Sets the column width automatically, corresponding to the 

space required by the cell contents. 

 Hide: Hides the current column (or the currently selected columns). 

 Show: Makes hidden columns reappear. Hint: Select a cell range that includes 

the columns to be restored beforehand. 

Row 

Offers the same commands as Table > Column but applies to rows instead of 

columns. 

http://www.softmaker.com/


Worksheet 

Offers commands for editing worksheets, including: 

 Go to: Switches to another worksheet. 

 Insert: Inserts a new worksheet (after the current one). 

 Delete: Deletes the current worksheet (including its entire content). 

 Rename: Renames the current worksheet. 

 Hide: Hides the current worksheet. 

 Show: Makes hidden worksheets reappear. For that purpose, a list of all 

currently hidden sheets is displayed to choose from. 

Insert Cells 

Inserts an additional cell, row, or column. 

Tip: When you select e.g. 3 columns beforehand, 3 columns will be inserted (left 

of the selected columns). 

Delete Cells 

Deletes the current cell, row, or column. 

Tip: You can select a range of cells before invoking this command. When you do 

so, all cells, rows, or columns covered by the selection will be deleted. 

Join Cells 

Joins the currently selected cells. Joined cells are treated as if they were a single 

cell.  

Note: When cells are joined, except for the upper left corner cell of the selected 

range, cell content is automatically deleted. 

Divide Cells 

Disconnects cells that have been joined. 



Sort 

Sorts the currently selected range of cells according to one or more criteria. 

Tools menu 

The Tools menu contains additional commands, including: 

Insert Comment 

Adds a comment to the current cell. A small box will open, allowing you to enter 

the comment. When you have completed your comment, tap anywhere in the table 

to leave the comment box. 

Cells with a comment attached to them have a yellow triangle in their top-right 

corner. To display the comment, simply tap on the corresponding cell.  

To edit an existing comment, tap on the corresponding cell and invoke the com-

mand Tools > Insert Comment once more. 

Delete Comment 

Deletes the comment attached to the current cell (if any). 

If you select some cells beforehand, the comments for all of these cells will be 

removed at once. 

Recalc Automatically 

If this option is enabled, calculations are updated automatically every time the 

content of any cell is changed. 

Recalc Now 

If you have turned the Tools > Recalc automatically option off, this command 

can be used to update calculations manually whenever needed. 



Customize Toolbars 

Allows you to customize the program’s toolbars by adding additional icons to 

them. 

Options 

Opens a dialog with all program settings. See section “Overview: Program set-

tings”. 

Help 

Displays the help file. 

Check for Updates 

Checks if a program update is available.  

Note: This command is available (and necessary) only if you have downloaded 

the installation archives for the software directly from the SoftMaker website. If 

the software was installed via the “Google Play Store”, updates will be delivered 

by the store automatically. 

Register 

Allows you to register the software. 

Registered users are entitled to free technical support. Registering is free of 

charge, and there are no obligations to you. 

About 

Displays information on the application (revision number etc.). 

Overview: Toolbars 
This section lists all available toolbars and their icons. 



Hint: When you tap on an icon and hold your finger there for a second, the func-

tion of the respective icon is displayed on the screen. 

For more information on using toolbars in general, see the section “Working with 

toolbars”. 

Standard toolbar (or: main toolbar) 

 

 

Contains the following icons: 

1 Keyboard on/off 

2 File toolbar on/off 

3 Edit toolbar on/off 

4 Format toolbar on/off 

5 Worksheet toolbar on/off 

6 Change zoom level 

7 Row and column headers on/off 

8 Open settings dialog (only on tablets) 

9 Open help file 

Input toolbar 

 

 

Contains the following icons: 

1 Insert function 

2 Insert SUM function 

3 The input box in the center can be used to edit the content of the current cell. 



4 Accept input 

5 Reject input 

See also: section “Entering text and data” 

File toolbar 

 

 

Contains the following icons: 

1 File > New 

2 File > Open 

3 File > Save 

4 File > Save as 

5 File > Export as PDF 

See also: File menu 

Edit toolbar 

 

 

Contains the following icons: 

1 Edit > Select 

2 Edit > Undo 

3 Edit > Redo 

4 Edit > Cut 

5 Edit > Copy 

6 Edit > Paste 

7 Edit > Search 



8 Edit > Go to ... 

9 Table > Insert Function (only on tablets) 

10 Table > Sort (only on tablets) 

See also: Edit menu 

Format toolbar 

 

 

Contains the following icons: 

1 Font face 

2 Font size 

3 Bold/italic 

4 Underline 

5 Format > Character 

6 Format > Borders 

7 Format > Shading 

8 Format > Cell alignment (only on tablets) 

See also: Format menu 

Worksheet toolbar 

 

 

Contains the following icons: 

1 Add new worksheet 

2 Delete current worksheet 

3 Previous worksheet 



4 Go to worksheet ... 

5 Next worksheet 

See also: Table menu (especially the Table > Worksheet command) 

Overview: Program settings 
The Tools > Options menu command allows you to customize the application.  

Its dialog box contains several tabs, each of them related to a different topic area. 

For example, if you tap on the Files tab, you will be able to make settings that 

control the opening and saving of files. 

Options available: 

General tab 

User interface 

Lets you select the language to be used in menus and dialogs.  

User-defined font paths 

Here you can specify paths to supplementary fonts for PlanMaker. To do this, 

enter the subdirectory in which the font files reside. If you want to enter multiple 

directories, separate them with colons. 

PlanMaker can then use these fonts in addition to the fonts available to it from the 

operating system.  

Note: Changes to this setting become effective only after the program is restarted. 

OpenGL acceleration 

When this option is enabled, PlanMaker utilizes a technology called “OpenGL” to 

accelerate screen output. 



Please note that there are devices that have a faulty OpenGL implementation. 

PlanMaker will usually detect this automatically and turn the OpenGL option off.  

On a few devices, screen output is erroneous when this option is enabled. In this 

case you should turn this option off. 

Note: Changes to this setting become effective only after the program is restarted. 

Display scroll handle for fast scrolling 

When this option is enabled, a “handle” is displayed at the rightmost part of the 

screen whenever you swipe up or down (in order to scroll). This handle displays 

your current position within the document. 

Hint: Grabbing this handle with your finger and dragging it upwards or down-

wards allows you to scroll through a large document very fast. 

Show/hide keyboard automatically 

When checked, the on-screen keyboard pops up automatically whenever you are 

given an opportunity to enter text in your table (for example, after you have 

double-tapped on a cell or tapped into the Input toolbar displayed above the table).  

See also section “Entering text and data”. 

Note: In dialogs, the keyboard will always appear automatically when you tap 

into an input field – no matter if this option is enabled or not. This behavior is 

dictated by the Android system. 

Edit tab 

After input, move selection ... 

Determines where to move the selection after the user has entered data in a cell 

and pressed the Enter key. For example, if you choose “Down”, the selection will 

move down to the cell below the current cell.   



Files tab 

Default file format 

Here you can select the file format that PlanMaker will use by default to save 

newly created documents.  

Create backup files 

If this option is enabled, whenever you save a document, the program will first 

create a backup copy of the last saved version in a file with the name exten-

sion .BAK.  

Autosave documents every ... minutes 

When you enable this option, PlanMaker automatically makes a backup copy of 

the currently open document in a temporary folder on a periodic basis. You can 

enter a period of 1 to 100 minutes. 

When you exit PlanMaker in the normal manner, this copy is automatically delet-

ed. However, if PlanMaker is terminated abnormally (e.g. by a program crash) 

while you are working on a document, this copy become available when the 

program is restarted. PlanMaker recognizes that there has been a failure and offers 

to open the backup copy of the document, if it had been modified but not saved 

just prior to the failure. 

You can then check the document to determine if any of the most recently made 

changes have actually been lost, and then save it using the File > Save command. 

User tab 

User info 

Here you can enter your name and your initials.  
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