


Kingsoft Spreadsheets 2013

Kingsoft Spreadsheets is a flexible and efficient commercial application. It is widely used by professionals

in many fields such as business, finance, economics, and so on. It features calculation, graphing tools, and

many other tools for complex data analysis. Kingsoft Spreadsheets supports more than 100 commonly used

formulas and has a battery of supplied functions (e.g. conditional expressions, sorting, filtering and

consolidating) to make it much more convenient to analyze data.

Kingsoft Spreadsheets has a variety of spreadsheets templates that allow the users to create all kinds of

spreadsheets easily and efficiently. Kingsoft Spreadsheets is completely compatible with all Microsoft

Excel files and is also capable of displaying other file formats such as txt., csv., dbf. etc.
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1 Kingsoft Spreadsheets Basic Operation

1.1 Brief Introduction

As one of three Kingsoft Office 2013 components, Kingsoft Spreadsheets is an independent and powerful

spreadsheet application. Kingsoft Spreadsheets can not only fulfill your daily needs of analyzing data, but

also help you to perform more professional data processing tasks.

1.2 Kingsoft Spreadsheets Interface

If you have worked by any Windows programs or Microsoft Excel before, you are already familiar with

the Kingsoft Spreadsheets user interface. It has all of the standard window components, such as the title

bar, menu bar, status bar and so on.

 Title Bar: The title bar displays the name of the workbook. When you create new workbooks,

the system will automatically name your workbooks as Book1, Book2 and so on.

 Menu Bar: The menu bar contains different commands that you can use to edit the

worksheet.

 Name Box: The name box displays the selected cell address. If you select more than one cell,

it will display the first selected cell address.

 Formula Bar: The formula bar will display the content you are editing in the cell.

 Rows: The rows are labeled with the numbers 1 to 65536.

 Document List: You can easily switch among multiple documents by clicking the Document

List icon.

 Columns: The columns are labeled with letters in the following pattern: A, B, C, ... Z, AA,

AB, AC, ... AZ, BA, BB, BC, ... BZ, CA, ... IA, IB, ... IV, which is the last possible column.

 Active Cell: The active cell has a bold border around it and the row and column headers have

a deep shading over them. It is this cell that receives your keystrokes and commands.
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1.3 Basic Operations

1.3.1 Operations in Cells

Cell is the basic unit for storing data in the spreadsheets. You can select, copy, cut, paste, edit, clear, move,

and join cells.

1.3.1.1 Editing in Spreadsheets

There are two types of data in Kingsoft Spreadsheets: text (i.e. Characters or the combination of characters

and numbers) and number. All numeric values can be used to carry out calculations.

In Kingsoft Spreadsheets, the data in text format will be aligned to the left and the data in number format

will be aligned to the right by default.

1.3.1.2 Inputting Text

In Kingsoft Spreadsheets, text refers to characters or the combination of characters and numbers.

To input number as text , enter ' ' ' before you enter the text data.

1.3.1.3 Inputting Numbers

Numbers are composed of the digits 0-9 and some special characters such as: +, -, $, %, etc. There are

several tips to consider when inputting numbers:

 When you enter a positive number, you do not have to add a '+' before the number. Even if you

add it, it will automatically be omitted.

 When you enclose a number in "()", or parentheses, it means you have input a negative number.

For example: (123) refers to -123.

 If you want to enter a fraction, you should add a '0' before it, otherwise the system will display

it as date. For example, if you want to input 1/2, you should input 0 1/2. There should be a

blank space between 0 and 1/2. Otherwise it will display as 01-Feb.

 When the input number is longer than the cell width or more than 11 digits, it will be

automatically displayed in scientific notation.
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1.3.1.4 Inputting Date and Time

When inputting date, you can use '/' or '-' to separate the year, month and day. For example, '11/4/19' or

'11-4-19'. When inputting time, you can use ':' to separate hours, minutes and seconds. For example, '9:30'

and '10:30 AM".

There are several tips you should pay attention to:

 In Kingsoft Spreadsheets, the date and time are treated as numbers, which means that you can

perform calculations with them.

 If you want to enter a 12-hour time, you should add 'AM' or 'PM' after the time. Otherwise it

will be treated as a 24-hour time.

 If you want to enter the time and date in to the same cell, you should use a blank space to

separate them. For example, '2011-4-19 8:30".

1.3.1.5 Entering the same data into a discrete area

To enter the same data in to a discrete area, follow the steps below:

(1) Hold the <Ctrl> key and select the cells where you wish to enter the same data.

(2) Enter data in to the active cell.

(3) Press <Ctrl+Enter>.

1.3.2 Multiple summary results in the status bar

In Kingsoft Spreadsheets, multiple summary results will appear in the status bar if you select several

numbers at a time. The summary results include: Sum, Average and Count.
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Figure 1.3—1 multiple summary results

The three summary results mentioned above are defaults in Kingsoft Spreadsheets. To adjust any of them,

you can right-click the status bar or click the AutoSum icon in the Home tab. The option list will then

open and you can add or delete the summary results according to your needs.

1.3.3 Smart Contraction

Sometimes we have to enter a lot of information in a cell, which makes it inconvenient to check

information in other cells. Kingsoft Spreadsheets provides a smart contraction function to make it much

easier to deal with such situation.
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Figure 1.3—2 Smart Contraction

1.3.4 AutoComplete Function

The AutoComplete Function makes it easier to enter the same or similar data into different cells. This can

improve the speed and efficiency of data entry. To apply this function, the steps are as follows:

(1) Find the Application menu and click Options at the bottom right corner.

(2) Select the Edit tab in the Options dialogue box and select the Enable AutoComplete for cell values

check box, shown as below:

Figure 1.3—3 Select Enable AutoComplete for cell values check box

(3) When you enter the first character of similar content, the system will automatically provide a
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drop-down list for you to choose from.

1.3.5 Switching Skins

As you might already know, Kingsoft Office offers three skin / interface styles: 2013 Elegant Black, 2013

Water Blue, and Classic Style. Both Office Free 2013 and Office Professional 2013 support to switch

skins among the three styles. Follow these two methods to choose your favorite interface.

 Choose skin for Office 2013 during the installation

During the installation process of Office 2013, you can choose a skin from the left list, and press Next in

the following steps to finish installation. In this way, the three components: Writer, Spreadsheets and

Presentation will apply the same interface you’ve chosen here. See below:

Figure 1.3—4 Choose interface style for Office 2013

 Switch skin in Office 2013 programs after installation

If you want to apply another interface after the installation of Office 2013, you can easily switch to another

within the Office programs. Take Spreadsheets 2013 for example - you can switch skins by the following

steps:

(1) In Spreadsheets 2013, click the Switch UI icon at the top right corner of the screen.

(2) Select a different skin from the current one and press OK. You will need to restart the program to see

the change.
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Figure 1.3—5 The Skin Manager drop-down list

Figure 1.3—6 Switch skin style in Office 2013 - Classic Skin

Tips:

Under 2013 style interface, you can press the <Alt> shortcut key to bring up the Classic menu, which is

shown under the main toolbar. Press <Alt> again to hide it. This menu style is also available by clicking

the arrow beside the program icon. See below:



Spreadsheets 2013 User Manual

8

Figure 1.3-7 Show classic menu in 2013 style interface

1.3.6 Activating Kingsoft Office

To activate Kingsoft Office 2013, you need to purchase a product key first. When you purchase our

product and complete the payment, you will receive an email confirming your order with a license code.

The code is composed of five groups of alphanumeric codes, which are connected with hyphens. One

product key can be used to activate three PCs.

To install and activate Kingsoft Office 2013, follow the steps below:

(1) Run the installer and follow the instructions in the wizard to start installing Kingsoft Office 2013 to

your computer.

(2) In the third step of the installation wizard, enter the product serial number you have purchased.

Figure 1.3-8 Enter product serial number

(3) Press Next in the following steps. After the installation, your office 2013 is successfully installed and

activated.

To add serial number to Office 2013, follow the steps below:

(1) If you already have Office 2013 free trial version installed, then simply open one of the three Office

components: Writer, Spreadsheets or Presentation.

http://www.ksosoft.com/office/229-install-office-2013-free-trial.html
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(2) Click the Help button to open the Product Management Center.

(3) Click the Add button to enter your product key and click OK to finish.

Figure 1.3-9 Add product serial number

The product key will be recorded as Not limited.

1.3.7 Switching Among Multiple Files by the Unique Tab

Feature

Much like a modern web browser which allows a user to open multiple web pages as tabs under the same

window, Kingsoft Office (Free Office, Professional Office) tab feature offers users the same luxury for

word documents, spreadsheets and presentations.

1.3.7.1 Advantages of Kingsoft Office Tab Feature

Common Office suites such as Microsoft Office and OpenOffice force users to open a new window every

time they want to start a new document, which has a tendency to create a cluttered desktop and in some

cases even impacts user’s decision whether or not to create a new document. Kingsoft Office’s tab feature

eliminates the problem of having too many documents / workbooks / presentations open at one time,

allowing user to conveniently switch between documents in one window by pressing the shortcut key

<Ctrl+Tab>.
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Figure 1.3-10 Open multiple files in Writer

Figure 1.3-11 Open multiple files in Spreadsheets

Figure 1.3-12 Open multiple files in Presentation

The ability to create document tabs not only allows the user to easily see what documents they have

opened but also, most importantly, saves the user’s time and ultimately allows the user more time to think

about what to write rather than where to find a certain document.

Figure 1.3-13 Organize tab orders

Users can organize the order of tabs by clicking and dragging a document tab to its desired location, which

gives the user control on how to prioritize tabs based on each one’s importance.

1.3.7.2 Closing File Tabs by Double Clicking

Kingsoft Office’s tab feature is built to save user’s time, quickly close the window by double clicking on

the desired tab or create a new blank document by right-clicking, pressing the shortcut key <Ctrl+N> or

even pressing the tab for a new page as you would on a normal browser.
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1.3.7.3 Saving All Tabs in One Click

Figure 1.3-14 Quick functions

Right clicking on the tab allows some quick functions including Close Window, Save, Save All, Save As,

Close Other Windows, Close All, and Open Folder which is a more practical way of saving work, it

avoids a situation where a user is not sure what documents are open and may have to re-check or in rare

circumstances save the document under the wrong name.

The interface Kingsoft Office offers is for the best convenience of the user and this feature alone saves

time, has improved functionality and usability compared to other less innovative office suites. It eliminates

everyday problems that a user may encounter when working with other word processors, spreadsheet

software and presentation programs like Microsoft Word, Excel and PowerPoint.

1.3.8 Hiding and Showing the Toolbar

By clicking the Hide the Toolbar icon at the top right corner of the screen, you can hide or show the

toolbar.

1.4 The Application Menu

The Application menu is the green icon at the top left corner of the Kingsoft

Spreadsheets main interface. The Application menu includes the following functions: New, Open, Save,

Save As, Print, Print Preview, Send E-mail, File Information, Backup Management, Help, and so on.

See below:
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Figure 1.4-1 Application Menu

1.4.1 The New Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the New tab and you can see four

options listed in the NewWorkbook section as shown below:

Figure 1.4-2 The New tab

 New Blank Workbook: select this option to create a new blank workbook.

 New Excel 2007/2010Workbook: select this option to create a new 2007/2010 excel workbook.

 New from Other Templates: select this option to open the Templates dialogue box as shown below:
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Figure 1.4-3 The Templates dialogue box

You can choose preferred templates from the General, Business, Education, Office, and Personal

tabs. Click the OK button to create a new workbook by the chosen template.

 New From Default Template: Select this option to create a new workbook by the default template ( a

blank workbook here).

1.4.2 The Open Option in the Application Menu

Click the Application Menu icon to open the drop-down list and choose the Open option. The Open

dialogue box will open and show as below:

Figure 1.4-4 The Open dialogue box

Choose the intended document in the Open dialogue box and click the Open button at the right bottom to

open the document.
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Tips: You can also open the intended document by clicking the Open icon at the top left corner of the

screen or press <Ctrl+O>.

1.4.3 The Save Option in the Application Menu

There are three ways to save the changes you have made to the current workbook:

(1) Click the Application Menu icon to open the drop-down list and choose the Save option.

(2) Click the Save icon at the top left corner of the screen.

(3) Press the shortcut combination <Ctrl+S>.

1.4.4 The Save As Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the Save As tab and you can see

seven options listed in the Save a Copy of the Document section as shown below:

Figure 1.4-5 The Save As tab

As you can see, you can save the current document as Kingsoft Spreadsheets Files, Kingsoft

Spreadsheets Templates, Microsoft Excel 97-2003 Files, Microsoft Excel 97-2003 Templates,

Microsoft Excel 2007/2010 Files, and Other Formats. The steps are as follows:

(1) By choosing any one of them, you can open the Save As dialogue box shown as below:
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Figure 1.4-6 The Save As dialogue box

(2) Enter the name you prefer for the current document in the File name text box and choose the file type

in the Save as type drop-down list.

(3) Click the Save button to complete the operation.

(4) If you want to cancel the operation, click the Cancel button or click the red cross at the top right

corner of the dialogue box.

(5) By clicking the Encryption button at the bottom right, you can open the Security tab in the Options

dialogue box. Shown as below:

Figure 1.4-7 The Security tab
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(6) You can set the security related setting here, such as the Document password, Reenter password,

Password to modify, etc.

(7) Click the OK button to complete the operation.

You can also export the current file to PDF format. The steps are as follows:

(1) Choose the Export to PDF option in the Save As tab. The Export to Adobe PDF File dialogue box

will open and show as below:

Figure 1.4-8 The Export to Adobe PDF File dialogue box

(2) In the Save to section, choose the location where you want to save the current file.

(3) In the Export range section, select the preferred options.

(4) Click the OK button to complete the operation.

1.4.5 The Print Option in the Application Menu

To print the file, the steps are as follows:

(1) Click the Application Menu icon to open the drop-down list and choose the Print option. The Print

dialogue box will open and show as below:
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Figure 1.4-9 The Print dialogue box

(2) In the Printer section, you can choose the preferred printer in the Name drop-down list.

(3) In the Page range section, you can choose the range of the file which you want to print. You can also

enter the specific pages you prefer in the Pages text box.

(4) In the Copies section, choose the number of copies in the roll-down list. Choose the Collate check

box and the document will be print one copy after another.

(5) Click the OK button to print the document.

1.4.6 The Print Preview Option in the Application Menu

Click the Application Menu icon to open the drop-down list and choose the Print Preview option, or

click the Print Preview icon at the left corner of the screen. The Print Preview tab will open and show

as below:

Figure 1.4-10 The Print Preview tab

 Print: click the arrow on the Print icon to open the drop-down list. Select the Print option or press

<Ctrl+P> to open the Print dialogue box shown in Figure 1.4-9. Then you can set the values there.

You can also choose the Print Directly option in the drop-down list to directly print the current file.

 Previous Page: click to switch to the previous page.
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 Next Page: click to switch to the next page.

 Zoom: zoom the current file to your preferred percentage in the drop-down list.

 Page Break Preview: this view mode will display where the pages will break when printed.

 Normal View: exit the print preview mode and view the current file in the normal mode.

 Portrait: set the worksheet pages to portrait.

 Landscape: set the worksheet pages to landscape.

 Header and Footer: edit the header and footer of the document.

 Page Setup: open the Page Setup dialogue box and set the corresponding values there.

 Margins: specify the distance between the contents of the worksheet and the edges of the printed

page.

 Close: close the Print Preview tab.

1.4.7 The Send E-mail Option in the Application Menu

To send the current file to others by E-mail, the steps are as follows:

(1) Click the Application Menu icon to open the drop-down list and choose the Send E-mail option. The

Send E-mail task window will open.

(2) You can set the information such as the addressee, the sender, the main topic, and the attachments in

the task window.

(3) Click the Send button to send the E-mail.

1.4.8 The File Information Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the File Information tab and you

can see two options listed in the Document Protection and Properties section as shown below:
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Figure 1.4-11 The File Information tab

Choose the Encryption option and you can open the Security tab in the Options dialogue box as shown

in Figure 1.4-7. Then you can set the security related setting here, such as the Document password,

Reenter password, Password to modify, etc. Click the OK button to complete the operation.

Set the properties of the document, the steps are as follows:

(1) Choose the Properties option and open the dialogue box shown as below:

Figure 1.4-12 The Property dialogue box

(2) In the General tab, you can see the basic information of the document, such as Type, Location, Size,

MS-DOS file name, Created time, Accessed time,Modified time, etc.

(3) In the Summary tab, you can enter the information in the corresponding text box, such as Title,

Subject, Author,Manager, Company, Category, Keyword, and Comments. Shown as below:
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Figure 1.4-13 The Summary tab

(4) In the Custom tab, you can set the Name, Type, Value, and Property of the file. Shown as below:

Figure 1.4-14 The Custom tab

(5) Click the OK button to complete the operation.

1.4.9 The Backup Management Option in the Application Menu

By choosing the Backup Management option in the Application Menu, the Backup Management task

window will open at the right side of the screen. Click the Backup Management icon again to open the

drop-down list, and then you can choose the options listed there, namely New Workbook, PivotTable,

Selection Pane, AutoShapes, and Backup Management. By choosing any one of them, the
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corresponding task window will open and you can set preferred values there.

1.4.10 The Help Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the Help tab and you can see the

options listed in the Feedback and Product Information section as shown below:

Figure 1.4-15 The Help tab

You can choose any of the options, namely Kingsoft Spreadsheets Help, Kingsoft Office Homepage,

Kingsoft Office Facebook, Check for Updates, Purchase Serial Number, and About Kingsoft

Spreadsheets, to open the corresponding web pages and know more about Kingsoft Spreadsheets.

Tips: You can also click the Help icon at the top right corner of the screen or press the <F1> shortcut

key to open the relevant web pages.

1.4.11 The Options Function in the Application Menu

Click the Application Menu icon to open the drop-down list. Click the Options icon at the bottom right

of the drop-down list. The Options dialogue box will open and show as below:
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Figure 1.4-16 The Options dialogue box

You can see a number of tabs at the left side of the dialogue box. By choosing any one of them, the

corresponding tab will open at the right side where you can select or deselect the check box to set the

preferred values.

Click the red Exit icon at the bottom right or click anywhere in the document to close the Application

Menu.

2Home tab

2.1 Clipboard Functions

After selecting the text or object, you can move, copy, delete and carry out various other commands on the

selected content. You can complete all of these operations through the control command, the shortcut keys

or the mouse. The clipboard functions offered by Kingsoft Spreadsheets are shown as below:

Figure 2.1-1 The clipboard functions
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2.1.1 The Paste Function

Paste refers to moving the contents from the system clipboard to the file at the designated insertion point.

The paste operation can only be performed unless the clipboard is not empty. To paste contents, follow the

steps below:

(1) Select the contents you want to paste and click the arrow on the Paste icon in the Home tab. The

Paste drop-down list will then open and show as below:

Figure 2.1—2 The Paste drop-down list

(2) Kingsoft Spreadsheets provides seven different methods of pasting contents.

 Formulas:Paste the formulas contained in a data set rather than the data itself.

 No Borders:Only paste the cell contents without the cell borders.

 Values:Copy the selected cells containing formats and formulas and select the Values option in the

Paste drop-down list. By doing this, you can paste the values in the cells without changing the

formats and formulas.

 Transpose:To rearrange row data to be displayed in columns, you should choose the Transpose option

in the Paste drop-down list. Copy the selected row data and choose the Transpose option in the

desired position to complete the action.

 Paste as Picture: Select the contents which you want to paste as a picture, put the cursor to the place

where you want to paste and choose the Paste as Picture option in the drop-down list. By doing this,

you can paste the intended contents as picture.

 Paste as Unformatted Text: Choose this option and the selected contents will be removed all formats

and pasted as plain text.

 Paste Special option includes the options mentioned above. However, you can also choose Paste
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Special in the Paste drop-down list directly, which offers more options for you. Just right-click and

choose the Paste Special option in the context menu and the Paste Special dialogue box will open

and show as below:

Figure 2.1—3 The Paste Special dialogue box

You can then select the preferred check box in the above dialogue box to set the values for pasting

contents.

(3) You can also paste by pressing <Ctrl+V>. This method will paste all copied content to the designated

area.

(4) Right-click on the document to open the context menu, you can then select the Paste option there to

paste the content.

2.1.2 The Cut Function

Cut refers to removing the currently selected contents within the file, and moving them to the system

clipboard where you can paste these contents to other places. You can use the cut function by any of the

three methods listed below:

(1) Open the Home tab and click the Cut icon .

(2) Press <Ctrl+X>.

(3) Right-click the selected contents and select the Cut option in the context menu.
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2.1.3 The Copy Function

Copy refers to duplicating the currently selected contents to the system clipboard, so that you can paste

these contents to other places. However, the selected contents are still retained in the file. You can use the

copy function by any of the three methods listed below:

(1) Click the Copy icon in the Home tab.

(2) Press the <Ctrl+C>.

(3) Right-click the selected contents and select the Copy option in the context menu.

2.1.4 Format Painter

Format Painter is a commonly used tool to replicate formats. It can replicate the format of selected objects,

text, and cells, and apply it to the corresponding content you prefer.

(1) Put the cursor on the cells or objects whose format will be replicated.

(2) Click the Format Painter icon in the Home tab.

(3) The mouse pointer will then change into .

(4) Select the object or cells which would be formatted to complete the operation.

Tips:If you want to use format painter continuously, you can double-click the Format Painter icon to

highlight it as .

2.2 Font

The content of different cells can be set in different font formats, borders, fill colors, etc. according to your

needs. All of these things make it easier to highlight and emphasize the content you prefer.

2.2.1 Font Format

The font format setting refers to set the font, size, style, color of the contents.

2.2.1.1 Font

Kingsoft Spreadsheets provides a variety of fonts for your choice. There are appropriate fonts for different

tastes, situations and requirements. To set the font, follow the steps below:
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(1) Select the cell or text for which you want to set the font.

(2) Click the Font drop-down list in the Home tab and select an appropriate font.

The list is shown in the following figure:

Figure 2.2—1 The Font drop-down list

2.2.1.2 Font Size

Different font sizes can be used within a single document. To set the font size, follow the steps below:

(1) Select the cell or text for which you want to set the font size.

(2) Click the Size drop-down list in the Home tab and select the appropriate font size. You

can also input numbers between 1 and 409 in the drop-down list box and press Enter.

It is also possible to quickly Increase and Decrease the font size. These icons can be found in the

Home tab.

2.2.1.3 Font Style

Font style represents the format of the characters within the text. There are several commonly used control

buttons. These buttons are used to set the font style of the selected text. The functions of these buttons are

as follows:

Bold:Set the selected text in bold or cancels the setting if the text is already in bold.

Italic:Set the selected text in italic or cancels the setting if the text is already in italic.

Underline: Set an underline for the selected text or cancels the setting if the text is already

underlined.
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Text color:Set an appropriate color for the selected text. Click the arrow in the icon

and open the drop-down list to make the selection. The automatic color is black.

Clear: clear everything in the selected cell, or selectively remove the formats, contents, or

comments in the selected cell. You can also apply this function by clicking the Format icon in the

Home tab and select the preferred option in the Clear drop-down list.

Fill Color: click to select a background color for the selected cell in the drop-down list.

2.2.2 Border

The color of the grid lines in the worksheet is gray by default. Grid lines are not displayed when you print

the file, but if you need to print the grid lines, you should set the borders for them. To set the borders,

follow the steps below:

(1) Select the cells for which you want to set the borders.

(2) Click the Other Borders icon in the Home tab and select different borders from the drop-down

list. The list is shown in the following figure:

Figure 2.2—2 Border drop-down list

 Draw Border: Click the Draw Border icon and select the Draw Border option in the drop-down

list. The mouse will then change into a pen shape which allows you to draw an outside border for the

selected cell area.

 Draw Border Grid: Click the Draw Border icon and select the Draw Border Gird option in the

drop-down list. The mouse will then change into a pen shape which allows you to draw border grid
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lines for the selected cell area.

 Erase Border: Click the Draw Border icon and select the Erase Border option. The mouse will

then change into an eraser and you can erase the border of the selected cell area.

 Line Color: Select a preferred color for the border line in the drop-down menu. The automatic color

is black.

 Line Style: Select a preferred style for the border line in the drop-down menu. The automatic style is

straight line.

An alternative method to set cell borders is by the Format Cells dialogue box:

(1) Select the preferred cell area.

(2) Click the Other Borders icon in the Home tab and select the More Borders option at the

bottom of the drop-down list. Choose the Border tab in the Format Cells dialogue box.

(3) You can set the print display of the outside border and inside border in the Presets section.

(4) Select the style of border lines in the Style drop-down list.

(5) Select the color of border lines in the Color drop-down list.

(6) Complete the operation by pressing the OK button at the bottom.

Figure 2.2—3 Set the border in the Format Cells dialogue box
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2.2.3 Patterns

You can complete the cell shading setting by the following steps:

(1) Select the cell or cell range that you want to apply shading to. In the Home tab, click the Other

Borders icon and select the More Borders option in the drop-down list. The Format Cells dialogue box

will open and show as below:

Figure 2.2—4 The Patterns tab

(2) Choose the Patterns tab in the Format Cells dialogue box and several options will be available.

Background Color section offers shading colors for the cell. Pattern Style section offers shading patterns

for the cell and Pattern Color section offers shading pattern colors for the cell. Choose the appropriate

option in the corresponding sections.

(3) Press the OK button to complete the operation.

You can select the cell or the cell range and right-click it to open the Context menu. Select the Format

Cells option and the dialogue box will pop up.

2.3 Alignment

2.3.1 Aligning Text

Select a cell or a cell range and go to the Home tab. Kingsoft Spreadsheets provides six alignment icons:
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Top Align ,Middle Align , Bottom Align , Align Text Left , Center , and Align Text Right .

Select the proper style you want by clicking the corresponding icon. You can also set the alignment of cells

by the Format Cells dialogue box.

The steps are shown as follows:

(1) Select the cells you want to align.

(2) Click the Other Borders icon in the Home tab.

(3) Choose the More Borders option in the drop-down list to open the Format Cells dialogue box.

Select the Alignment tab and choose an appropriate Horizontal and Vertical alignment option in the Text

alignment section.

Figure 2.3-1 Set the alignment in the Format Cells dialogue box

(4) Press the OK button to complete the operation.

2.3.2 Wrapping Text

If you need to input multiple lines of data into a cell, take the following steps:
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(1) Select the cell with the data you want to wrap.

(2) Click theWrap Text icon in the Home tab to wrap the data.

Aside from the way mentioned above, you can also wrap the data through the Format Cells dialogue box.

The steps are shown as follows:

(1) Select the cell with the data you want to wrap.

(2) Click the Other Borders icon in the Home tab and choose the More Borders option in the

drop-down list.

(3) The Format Cells dialogue box will open. In the Alignment tab, select the Wrap text check box in

the Text control section. Shown as below:

Figure 2.3-2 The Wrap text check box

(4) Click the OK button to complete the operation.

The keyboard shortcut combination <Alt+Enter> also performs this function.

2.3.3 Merging Cells

There are four options in the Merge and Center drop-down list: Merge and Center, Merge Across,

Merge Cells, and Across Center.

In the Home tab, select options in the Merge and Center drop-down list as shown below. These options

can make the merging of cells much quicker and easier.
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Figure 2.3-3 Merge and Center drop-down list

 Merge and Center:The selected cells will be merged and the content they contain will be aligned to

the center.

 Merge Across:Selected columns and rows will be merged, but the number of columns and rows will

not change in this case.

 Merge Cells:Merge the selected cells.

 Across Center:The content in every cell will be aligned to the center, but the cells will not be merged.

The alignment standard is based on the longest cell selected.

You can merge or split cells by the following steps:

(1) Select the cell or cells.

(2) Click theMerge and Center icon in the Home tab.

You can also merge or split cells by the Format Cells dialogue box. Follow the steps below:

(1) Select the cells that need to be merged or split.

(2) Right click and choose the Format Cells option in the context menu.

(3) Choose the Alignment tab in the Format Cells dialogue box and select or deselect the Merge cells

check box in the Text control section.

Figure 2.3-4 Merge cells by the Format Cells dialogue box
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(5) Press the OK button to complete the operation.

2.3.4 Adjusting Indent

To change the indent of the cell content (the margin between the border and the text), you can use the

Decrease Indent icon and the Increase Indent icon in the Home tab.

 Decrease Indent: Reduce the distance between the cell border and the content.

 Increase Indent: Increase the distance between the cell border and the content.

2.4 Number

2.4.1 Quick Set Format

You can easily set the format of the selected cells by several icons in the Home tab such as: Currency,

Percent Style, Comma Style, Increase Decimal, and Decrease Decimal.

 Currency:Add a currency format for the selected cell(s).

 Percent Style:Display the values in the selected cell(s) as percentages.

 Comma Style:Add thousands separator to the data in the selected cell(s).

 Increase Decimal:Display the data in higher accuracy by increasing the decimal digits.

 Decrease Decimal:Display the data in lower accuracy by decreasing the decimal digits.

2.4.2 Cell Format

There are 12 categories in the cell format properties. These categories are: General, Number, Currency,

Accounting, Date, Time, Percentage, Fraction, Scientific, Text, Special, and Custom.

There are several ways to open the Format Cells dialogue box in order to set the format properties for the

cell.

 Click the Settings icon in the Home tab and choose the Cells option in the drop-down

list. The Format Cells dialogue box will open and the Number tab will be available.

 Right click the mouse and choose the Format Cells option in the context menu. The Format

Cells dialogue box will pop up and the Number tab will be available.
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 Click the Format icon in the Home tab and choose the Cells option in at the bottom of the

drop-down list. The Format Cells dialogue box will open and the Number tab will be

available.

 Press <Ctrl+1> to open the Format Cells dialogue box and select the Number tab.

You can choose a format type in the Category section of the Number tab. When you choose different

format types, there will be different information references displayed at the right side of the dialogue box.

You can adjust the values according to the references so as to achieve a custom effect.

 General

The General format is the default number format when you type a number into a cell. It does not include

any special format for numerical values.

 Number

Select the Number option in the Category section and a Sample box will appear at the right side of the

dialogue box, which previews the changes of decimal, 1000 separator, and negative value made to the

number format. Shown as below:

Figure 2.4-1 Number format and options

After selecting the Number option, you can adjust the following settings in the dialogue box:

 Decimals and 1000 separator can be added to the number format.

 You can set the negative number format in the Negative numbers list box.

 Currency

Select the Currency option in the Category section and a Sample box will appear at the right side of the
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dialogue box, which previews the changes in decimal, currency symbol and negative value usage. Shown

as below:

Figure 2.4-2 Currency format and options

After choosing the Currency option, you can set the basic display style for currency in the dialogue box.

These display settings allow you to customize the Decimal places, Symbol and the display format of the

Negative numbers.

 Accounting

Choose the Accounting option in the Category section. The Sample box on the right displays the format

changes. You can define the basic accounting display format by customizing the Decimal places, Symbol,

etc. Figure 2.4-3 displays the Accounting format and options.
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Figure 2.4-3 Accounting format and options

 Date

Select the Date option in the Category section. You can choose the preferred date style in the Type list

box and preview the change there. See below:

Figure 2.4-4 Date format and options

 Time

Select the Time option in the Category section. You can choose the preferred time style in the Type list

box and preview the change there. See below:
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Figure 2.4-5 Time format and options

 Percentage

Select Percentage in the Category section. You can set the decimal digits in the roll-down list and

preview the changes in the Sample box. See below:

Figure 2.4-6 Percentage format and options

 Fraction

Select Fraction in the Category section. You can choose the preferred fraction type in the Type list box

and preview the change in the Sample box. See below:
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Figure 2.4-7 Fraction format and options

 Scientific

Select Scientific in the Category section. The Sample box on the right displays the format changes. You

can set the decimal digits in the roll-down list. See below:

Figure 2.4-8 Scientific format and options

 Text

Select Text in the Category section. Contents in the text format cells are treated as text even if they are

numbers. The cell is displayed exactly as entered.
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 Special

Select Special in the Category section. There are three types of special formats, namely the Zip code, Zip

Code + 4 and Social Security Number. See below:

Figure 2.4-9 Special format and options

 Custom

Select Custom in the Category section. You can set various kinds of customized data formats in the Type

list box. See below:

Figure 2.4-10 Custom format and options

Click the OK button to complete the operation.
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2.5 AutoSum

Kingsoft Spreadsheets provides the AutoSum function which could be applied to perform several simple

operations, namely Sum, Average, Count,Max, andMin. See below:

Figure 2.5-1 The AutoSum icon and options

Select the intended cells and you can perform the corresponding operation by choosing the preferred

option. The result will be displayed directly after the selected cells.

 Sum: Sum up the numbers in the selected cells.

 Average: Work out an average of the numbers in the selected cells.

 Count: Count the number of the selected cells.

 Max: Choose the maximum among the numbers in the selected cells.

 Min: Choose the minimum among the numbers in the selected cells.

Choose the More Functions option in the bottom of the AutoSum drop-down list and the Insert

Function dialogue box will then open where you can apply preferred function to the selected cells.

2.6 Filter

Filtering data is a quick and easy way to find and work with a subset of data in a range of cells or in a table.

Filtered data displays only the rows that meet the criteria you have specified and hides rows that you don’t

want to display.

2.6.1 AutoFilter

AutoFilter makes it easier to find and process subsets of data in the spreadsheets. You can create criteria to

filter data. Only those rows which meet the criteria you have specified will be displayed. Filtering doesn’t

rearrange rows. It just hides the rows you don’t want to display.
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Automatic filter includes: Filter by value, filter by color, text filter, number filter, and custom filter. Here

we’ll introduce these features.

2.6.1.1 Filter by Value

To filter by value, follow the steps below:

(1) Select the column(s) you want to filter. Click the AutoFilter icon in the Home tab and choose the

AutoFilter option in the drop-down list.

(2) A drop-down button will appear at the first row of the columns you have selected.

(3) Click the drop-down button and you can set the filter in the drop-down menu. For example, select

item 3 in the Student No. drop-down list. See below:

Figure 2.6-1 Filter by Value

Then the selected columns will be filtered by the value you have specified. And all the rows that meet the

criteria will be displayed. See below:

Figure 2.6-2 Filter effect
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2.6.1.2 Filter by Color

In Kingsoft Spreadsheets, if you have applied different colors to the data or different cell colors, you can

filter the data by these colors.

Follow the steps below to filter data by the cell color or the font color:

(1) Select the range of cells you want to filter.

(2) Click the AutoFilter icon in the Home tab.

(3) Click the drop-down arrow in each cell of the first line in the selected range. Choose the Filter by

Color tab in the drop-down menu. See below:

Figure 2.6-3 The Filter by Color tab

(4) You can either filter the data by cell color or font color. Choose one color from the above cell color

and font color list. For example, select the font color of Red. You will see the filter result like below:

Figure 2.6-4 Filter result

If you want to remove the color filter you have applied to the worksheet data, follow the steps below:

(1) Click the drop-down button in the column header.

(2) Click the Clear icon at the upper side of the menu. See below:
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Figure 2.6-5 Clear the Filter by Color

Thus the filter by color will be removed.

2.6.1.3 Text Filter

When the contents in the column is in text form, click the drop-down button and choose the Text Filter tab

at the top right corner of the drop-down menu. A series of options are offered as shown below:

Figure 2.6-6 The Text Filter tab

You can specify the filter condition as Equals, Not Equal To, Begin With, End With, Contains, and
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Dose Not Contain. By choosing any one of them, the Custom AutoFilter dialogue box will open where

you can set the values to meet your requirements.

2.6.1.4 Number Filter

When the contents in the column is in number form, click the drop-down button and choose the Number

Filter tab at the top right corner of the drop-down menu. A series of options are offered as shown below:

Figure 2.6-7 The Number Filter tab

You can specify the filter condition as Equals, Not Equal To, Greater Than, Greater Than Or Equal To,

Less Than, Less Than Or Equal To, and Between. By choosing any one of them, the Custom

AutoFilter dialogue box will open where you can set the values to meet your requirements.

The most frequently used options are Top 10, Above Average, and Below Average. You can select them

either in the Number Filter tab or at the bottom of the drop-down menu.

Select the Above Average or the Below Average option, the corresponding filter function will be applied

to the selected cells.

To apply the Top 10 AutoFilter, follow the steps below:

(1) Choose the Top 10 option in the Number Filter tab and the Top 10 AutoFilter dialogue box will

open and show as below:
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Figure 2.6—8 Top 10 AutoFilter dialogue box

(2) Enter the values in the Show section and click the OK button to complete the operation.

2.6.1.5 Custom Filter

If you want to create a criteria to filter by a data range or filter by some comparison operators more

complex than 'Equal to', you can customize the filter function. The operation steps are shown as follows:

(1) Select the data columns.

(2) Click the AutoFilter icon in the Home tab and choose the AutoFilter option in the drop-down list.

(3) Click the roll-down button and choose the Custom Filter option at the bottom of the Text Filter or

Number Filter tab. See below:

Figure 2.6-9 Custom Filter option

(4) In the Custom AutoFilter dialogue box, set the operation conditions and upper and lower limit

values. See below:
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Figure 2.6-10 CustomAutoFilter dialogue box

(5) Click the OK button to complete the operation. The filter result is shown as below:

Figure 2.6-11 The Custom Filter result

2.6.2 Reapply

After making changes to the data, you can use the Reapply function in the Autofilter drop-down list to

re-filter the data by the same condition you have specified. For example, you have filtered the Score 1

column by the condition Above Average. Then you change the score in B7. See below:

Figure 2.6-12 Modify the data

At this point, select the Reapply option in the AutoFilter drop-down list. The score in B7 after the change

is no longer qualified for the condition you have specified, i.e. Above Average. Thus it is filtered out. See

below:
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Figure 2.6-13 Filter result

2.6.3 Advanced Filter

The Advanced Filter option allows you to use complex conditions to filter a range. The filter result can be

displayed either in the original worksheet or in a new location. Those rows which don’t meet the criteria

will be hidden.

To specify the conditions of the Advanced Filter function, you have to create the specific Criteria range

first. Mind that the criteria range should be created out of the data range which you want to filter.

 Multiple conditions in a single column: if you want to filter the data by conditions of the same

category, you can simply enter the conditions under the header of the category. For example, to filter

the data by the condition “Name is Jane or Flora”. The criteria range and filter result are shown as

below:

Figure 2.6-14 Multiple conditions in a single column

 Multiple conditions in a single row: if you want to filter the data by more than two conditions, you

can enter them from the right to the left under the corresponding categories. For example, to filter the

data by the conditions “ Age > 20” and “Occupation is teacher”. See below:

Figure 2.6-15 Multiple conditions in a single row
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 Multiple conditions in multiple rows and columns: if you want to filter the data by one or another

condition, you can enter the name of the conditions in different columns and enter the condition in

different rows under the corresponding name. For example, to filter the data by the condition “Age <

36” or “Occupation is policeman”. See below:

Figure 2.6-16 Alternative conditions

If you want to filter the data by the same condition in one category and by alternative conditions in

another category, enter the same condition under the former category while enter the alternative

conditions in different rows under the later category. For example, to filter the data by the same

condition “20<Age<55” and by the alternative conditions “Occupation is teacher” or “Occupation is

policeman”. See below:

Figure 2.6-17 The same condition and alternative conditions

Tips: if you want to filter the data multiple conditions, you should enter them in the same row. If you want

to filter data by alternative conditions, you should enter them in different rows of the same column.

To apply the Advanced Filter function, follow the steps below:

(1) Select theAdvanced Filter in the AutoFilter drop-down list. The Advanced Filter dialogue box will

open and show as below:
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Figure 2.6-18 The Advanced Filter dialogue box

 Filter the list, in-place: hide data rows that don’t fit the filter condition and display the filter

result in the original worksheet.

 Copy to another location: copy the data rows that fit the filter condition to another location.

But the data rows which don’t fit the filter condition will remain in the original worksheet

and won’t be hidden. It is very convenient to compare the data in this way.

(2) Select the Copy to another location and the Unique records only check box. The filter result will be

copied to the specified place you have chosen.

(3) Select the List range, Criteria range (which you have created as shown above), and Copy to range in

the worksheet. See below:

Figure 2.6-19 Select the ranges

(4) Click the OK button to complete the operation.

2.6.4 ShowAll

If you want to restore the filtered data, you can either select the Show All option in the AutoFilter
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drop-down list or press <C> in the keyboard. Then all the data will be restored and displayed in the

worksheet.

2.7 Sort

At times, it is better to have the worksheets in your workbook arranged in a specific order, which will

make it easier to navigate through your document. The sort function in Kingsoft Spreadsheets allows you

to arrange the data in descending and ascending order. The operation steps are as follows:

(1) Select any cell or cells in the worksheet which you want to sort.

(2) Click the Sort icon in the Home tab and you can see that there are three options in the drop-down list,

namely Ascending, Descending, and Custom Sort. See below:

Figure 2.7-1 The Sort drop-down list

(3) You can choose the Ascending option to sort the data in the ascending order or choose the

Descending option to sort the data in the descending order. When you select the Custom Sort option, the

Sort dialogue box will open and show as below:

Figure 2.7-2 The Sort dialogue box

(4) Choose the sort range in the drop-down list and select the corresponding check box on the right

according to your needs.

(5) Press the OK button to complete the operation. The data in the worksheet will be sorted by the values

you have specified. The result is shown below:
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Figure 2.7-3 Sort result

2.8 Format

2.8.1 Convert Text to Number and Hyperlink

Kingsoft Spreadsheets provides the function to convert text to number and hyperlink. You can apply the

Convert Text to Number function or the Convert Text to Hyperlink function.

 When you want to convert a large amount of data in text format to numeric format, do the

following: Click the Format icon in the Home tab and select the Convert Text to Number option

in the Format drop-down list.

 When a large number of hyperlinks are not active, you can activate them altogether. Select the

contents you want to change to hyperlinks. Click the Format icon in the Home tab and select the

Convert Text to Hyperlink option in the Format drop-down list.

2.8.2 Conditional Formatting

You can set conditions for the cells. When the cells meet these conditions, the program will automatically

apply some type of formatting to them.

You can set three conditions at a time and use formulas or cell values as the condition. For example,

change the color of the cell to yellow when the date in the cell matches the current date. This function can

be used to remember the birthday of friends or employees. To set this kind of condition, follow the steps

below:
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(1) Select the intended cell or cells.

(2) Click the Format icon in the Home tab and choose the Conditional Formatting option in the

drop-down list. The Conditional Formatting dialogue box will open and show as in Figure 2.5-1.

(3) Select the Cell value is option and the equal to option in the Condition 1 drop-down list. Input

'=today()' in the edit box.

(4) Click the Format button and the Format Cells dialogue box will open where you can set the fill

color of the selected cell into yellow. You can also set other formats for the cell, such as Number, Font,

Border, and Patterns. Click the OK button at the bottom right to return to the Conditional Formatting

dialogue box.

(5) Click the OK button to complete the operation. The effect is shown below:

Figure 2.8-1 Conditional Formatting dialogue box

(6) You can add other conditions to the selected cell by clicking the Add button at the bottom and

repeating the operation above.

2.8.3 Style

In Kingsoft Spreadsheets, you can use the built-in styles directly. To use these styles, follow the steps

below:

(1) Select the cells to which you want to apply a style.

(2) Click the Format icon in the Home tab and choose the Styles option in the drop-down list.

Figure 2.8-2 The Styles option
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(3) The Style dialogue box will open and show as below:

Figure 2.8-3 Style dialogue box

(4) There are six styles in the Style name drop-down list: Comma, Comma[0], Currency, Currency[0],

Normal, and Percent. Choose one from the list and you will see its styles in the Style includes part.

(5) If you need to modify an existing format, clickModify and the Format Cells dialogue box will open

where you can change the patterns, border, font, etc. Press OK to return to the Style dialogue box.

(6) Click the OK button to complete the operation.

To add new styles, follow the steps below:

(1) Select a range in your worksheet.

(2) Choose the Styles option in the Format drop-down list to open the Style dialogue box (see Figure

2.8-3).

(3) Enter a name for the new style in the Style name section and then press Add.

Figure 2.8-4 Add a new style

(4) Click Modify to set the values of the new style in the Format Cells dialogue box. Click OK to return

to the Style dialogue box.

(5) Click the OK button to complete the operation.

2.8.4 Clear

Select the Clear option in the Format drop-down list or click the Clear icon in the Home tab and you can

see that Kingsoft Spreadsheets provides four types of clear options.
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 All:Select the cells that you want to clear. Choose the All option in the Clear drop-down list. You can

then clear all the contents in the selected cells.

 Formats: Select the cells whose formatting you want to clear. Choose the Formats option in the Clear

drop-down list, which will clear the format but keep the content intact.

 Contents: Select the cells whose contents you want to clear. Choose the Contents option in the Clear

drop-down list, which will clear the contents but keep the format intact.

 Comments: Select the cells whose comments you want to clear. Choose the Comments option in the

Clear drop-down list. When the little red triangle disappears, this means cell comments have

already been cleared.

Thus, you can select the clear options according to your requirements.

2.9 Rows and Columns

You can change the structure of the worksheet by performing operations on it. The main operations include:

select, move, set row height and column width, insert, delete, fill, and hide and display rows and columns.

2.9.1 Selecting Rows and Columns

If you want to carry out operations on rows or columns, you have to select them first. Click the row

number or the column label to select a single row or a single column. You can select a single row or

column first, press the <Shift> key, and click another row number or column label at the same time. In this

way, you can select two or more than two rows (or columns) which are adjacent. An alternative is to press

the <Ctrl> key and click different row numbers or column labels at the same time. In this way, you can

select more than one row (or column) which are non-adjacent.

2.9.2 Moving Rows and Columns

If you want to adjust the display order of the rows and columns, you can move them to the proper position.

To do so, follow the steps below:

(1) Select the rows or columns you want to move.

(2) Move the mouse to the border of the selected rows or columns. When the shape of the mouse changes

from an arrow to a cross, you can drag the mouse to the specified position.
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(3) Release the mouse and the rows and columns will be moved to the specified position.

2.9.3 Setting Row Height and Column Width

You can adjust the height of the rows and width of the columns if you feel they are not suitable at the

default size. To set the row height and column width, follow the steps below:

(1) Select the rows and columns.

(2) Click the Rows and Columns icon in the Home tab. The Rows and Columns drop-down list is

shown below:

Figure 2.9-1 Rows and Columns drop-down list

(3) Select the Row Height or Column Width option in the drop-down list and the corresponding

dialogue box will open where you can set the row height and the column width. See below:

Figure 2.9-2 Set the Row Height and the Column Width

(4) Select the AutoFit Row Height or AutoFit Column Width option in the drop-down list and the row

height and column width will automatically fit the contents of the rows and columns.

(5) Select the Standard Width option and the corresponding dialogue box will open where you can set

the standard width for the columns. See below:
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Figure 2.9-3 Standard Width dialogue box

(6) Click the OK button to complete the operation.

Tips: You can also accomplish the aforesaid operations by the context menu. Select the rows or columns,

right-click the mouse, and choose the Row Height or Column Width option in the context menu.

2.9.4 Inserting Cells, Rows, and Columns

Select the Insert Cells option in the Rows and Columns drop-down list, you can see that there are three

options, namely Insert Cells, Insert Rows, and Insert Columns.

To insert cells, follow the steps below:

(1) Select the position where you want to insert cells.

(2) Choose the Insert Cells option in the Insert Cells drop-down list. The Insert dialogue box will open

and show as below:

Figure 2.9-4 The Insert dialogue box

(3) Then you can adjust the position of the inserted cells by setting the values in the dialogue box.

(4) Click the OK button to complete the operation.

To insert rows, follow the steps below:

(1) Select the position where you want to insert rows.

(2) Choose the Insert Rows option in the Insert Cells drop-down list. You can then insert a row in the

worksheet. The process is shown below:
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Figure 2.9-5 Insert Rows

Insert Columns works the same way as Insert Rows.

2.9.5 Deleting Cells, Rows, and Columns

You can delete any unwanted cells, rows, and columns by the following two ways:

 Select the unwanted cells, rows, and columns. Click the Rows and Columns icon in the Home tab

(1) Select the position
where you want to
insert rows.

(2) Select the Insert
Rows option in the
Insert Cells drop-down
list.

The effect after

inserting the row.
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and choose the Delete Cells option. There are three options in the drop-down list. You can delete the

selected cells, rows, and columns by choosing the corresponding option. See below:

Figure 2.9-6 The Delete drop-down list

 Select the unwanted cells, rows, and columns, right-click the mouse, and choose the Delete option in

the context menu.

2.9.6 Fill

To avoid entering large amounts of repetitive data manually, you can use the Fill function to fill cells in a

more efficient manner.

2.9.6.1 Allow Cell Drag and Drop

Kingsoft Spreadsheets allow users to apply the fill function by default. You can also manually turn on or

turn off the Allow cell drag and drop function. The steps are as follows:

(1) Click the Application Menu icon at the top left corner of the screen to open the drop-down list. Click

the Options icon at the bottom right and open the Options dialogue box. Choose the Edit tab in the

dialogue box as shown below:
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Figure 2.9-8 The Edit tab

(2) Select or deselect the Allow cell drag and drop check box to turn on or turn off this function.

2.9.6.2 Fill Data by the Fill Handle

There are two types of data series commonly used to fill cells in Kingsoft Spreadsheets.

The first type includes: years, months, weeks, quarters, and other text-type sequences. For text-type

sequences, all you need is to enter values in the first cell, and then drag the fill handle to

accomplish the filling. The operation steps are as follows:

(1) Select the cell range.

(2) Move the mouse to the lower right corner of the data field and the pointer will change into a cross.

(3) Drag the cross down to the last cell in the cell range and release the mouse. The result is shown as

follows:
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Figure 2.9-7 Auto Fill

The second type includes: 1,2,3, 2,4,6, and other numeric sequences. For numeric sequences, you need to

enter the first two numbers which display the change pattern, and then drag the fill handle to fill in the

specified pattern.

For non-sequence text (such as “Office”) and numeric sequences that don’t specify the change pattern

(such as 200), drag the fill handle to duplicate the content.

2.9.6.3 Fill Data by the Fill Drop-down List

You can also apply the fill function by the Fill drop-down list. Follow the steps below:

(1) Select the position adjacent to the cells, rows, and columns whose content you want to duplicate.

(2) Choose the Fill option in the Rows and Columns drop-down list. There are several options offered in

the Fill drop-down list. See below:
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Figure 2.9-8 The Fill drop-down list

(3) You can choose the option according to your needs. The function of the options are as follows:

 Down: insert the contents in the above cells or rows to the lower position.

 Right: insert the contents in the left cells or columns to the right.

 Up: insert the contents in the lower cells or rows to the upper position.

 Left: insert the contents in the right cells or columns to the left.

Tips : The difference between filling with duplicated data and filling with sequence data lays in that if you

want to fill the cells with duplicated data, you have to press <Ctrl> and drag the fill handle at the same

time; if you only drag the fill handle, the system will automatically fill the cells with sequence data.

2.9.6.4 Across Sheets

The operation steps are as follows:

(1) Select the data that you want to fill into other worksheets within the same workbook.
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Figure 2.9-9 Select the intended data

(2) Press <Shift> and select the worksheet you want to fill with the data.

(3) Select the Across Sheets option in the Fill drop-down list. There are three options in the Fill Across

Worksheets dialogue box as shown below:

Figure 2.9-10 Fill Across Worksheets dialogue box

 All: The same contents and formats will be filled without change.

 Contents: Only fill with the same contents while the existing formats remain.

 Formats: Only fill with the same formats while the existing data remains.

(4) Select the All option and press the OK button to complete the operation. The result is shown as

below:

Figure 2.9-11 The Fill effect
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2.9.6.5 Series

To set the fill series, follow the steps below:

(1) Select the rows and columns to which you have applied the fill series function.

(2) Select the Fill option in the Rows and Columns drop-down list.

(3) Choose the Series option and the Series dialogue box will open and show as below:

Figure 2.9-12 The Series dialogue box

(4) The Rows or Columns option will automatically be selected specifying the target object in the Series

in section.

(5) Select a series type in the Type section.

 Linear: the contents will be inserted in the linear type.

 Growth: the contents will be duplicated.

 Date: the contents will be inserted in the date format.

 AutoFill: the contents will be inserted by default.

(6) Enter the step value and stop value in the corresponding enter box.

(7) Click the OK button to complete the operation.

2.9.6.6 Custom Fill Series

To make entering a particular sequence of data such as a department name or an employee name easier,

you can create a custom fill series. A custom fill series can be based on a list of existing items on a

worksheet, or you can type the list from scratch. The operation steps are as follows:

(1) Click the Application Menu icon at the top left corner of the screen to open the

drop-down list.

(2) Click the Options icon at the bottom right and open the Options dialogue box.

(3) Choose the Custom Lists tab in the dialogue box as shown below:
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Figure 2.9-13 The Custom Lists tab

(4) Choose the New list option in the Custom lists section and enter the new list in the List entries

section as shown in Figure 2.9-12.

(5) Click the Add button at the bottom right to add the new list.

(6) Click the OK button to complete the operation.

(7) Enter “Red” in the Spreadsheets and drag the fill handle. The new list you have just added will be

applied. The effect is shown below:

Figure 2.9-14 Fill data by custom fill series

(8) You can also delete custom list by clicking the Delete button in the Custom Lists tab. Mind that you

can’t edit or delete the built-in fill series, such as the fill series for days and months.

2.9.7 Hiding and Showing Columns and Rows

If you don’t want other people to see some particular content in your worksheet, you can hide the rows or

columns that contain the content. The steps to hide rows and columns are as follows:

(1) Select the rows and columns which you want to hide.

(2) Select the Hide and Unhide option in the Rows and Columns drop-down list. There are four options
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offered as shown below:

Figure 2.9-15 The Hide and Unhide drop-down list

(3) Choose the Hide Rows and Hide Columns option to hide the selected rows and columns.

(4) Choose the Unhide Rows and Unhide Columns option to cancel the operation above.

Skills: Select the intended rows and columns, right-click the mouse, and select the Hide and Unhide

option in the context menu to perform the hide and unhide function.

2.10 Worksheet

You can carry out a series of operations on worksheets, including select, insert, delete, protect, rename,

move, copy, set the tab color, and hide and unhide worksheets.

2.10.1 Selecting Sheet

If you want to move, copy, cut, or delete worksheets, you have to select them first. Simply click the

worksheet label to select the intended worksheets.
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Figure 2.10-1 Selecting a single sheet

You can hold the <Shift> key to select multiple worksheets that are adjacent to one another.

You can hold the <Ctrl> key to select multiple worksheets that are non-adjacent to each other.

Select the current worksheet, right-click the mouse, and choose the Select All Sheets option in the context

menu to select all sheets. The effect is shown below:

Figure 2.10-2 Select All Sheets

2.10.2 Inserting Sheet

If you want to insert one or more worksheets, take the following steps:

(1) Select the current worksheet.

(2) Click theWorksheet icon in the Home tab to open the drop-down list. Select the Insert Sheet option

as shown below:

Selecting all the

sheets
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Figure 2.10-3 The Insert Sheet option

(3) The Insert Sheet dialogue box will then open and show as below:

Figure 2.10-4 Insert Sheet dialogue box

(4) Enter the number of worksheets you want to create in the Insert count enter box.

(5) Choose either the After current sheet or the Before current sheet option to specify the location

where you want to create the new worksheets.

(6) Press the OK button to complete the operation.

Skills: You can also insert worksheets by the context menu. Select the current worksheet, right-click the

mouse, and choose the Insert Sheet option in the context menu. The Insert Sheet dialogue box will then

open. Repeat the operation above to insert new worksheets.

2.10.3 Deleting Sheet

If you want to delete one or more worksheets, follow the steps below:

(1) Select the worksheets you want to delete.

(2) Choose the Delete Sheet option in theWorksheet drop-down list.

(3) If there is data in the current worksheet, the following dialogue box will open.

Figure 2.10-5 Delete data in sheet

(4) If you’ve made up your mind to delete the worksheet, you can press the OK button to complete the
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operation.

Skills: You can also delete worksheet by the context menu. Select the worksheets that you want to delete,

right-click the mouse, and choose the Delete Sheet option in the context menu.

2.10.4 Protect Sheet

If you want to protect the worksheet, follow the steps below:

(1) Select the worksheets which you want to protect from others.

(2) Choose the Protect Sheet option in theWorksheet drop-down list.

(3) The Protect Sheet dialogue box will then open and show as below:

Figure 2.10-6 The Protect Sheet dialogue box

(4) The password is optional and you can enter it according to your need.

(5) Select or deselect the check boxes offered to specify the operations which other users are allowed to

carry out on the worksheets.

(6) Click the OK button to complete the operation.

2.10.5 Renaming Sheet

By default, Kingsoft Spreadsheets names worksheets by the model of “Sheet + serial number”. In most

cases, you would want to rename the worksheets. The following are methods to rename worksheets.

 Double-click the worksheet label and when the label is selected enter the new name. When finished,

press the <Enter> key or click any place except the worksheet label to finish the operation.

 Right-click the worksheet label which you want to rename. Select the Rename option in the context

menu and enter the new name. Press the <Enter> key or click any place except the worksheet label to

finish the operation.
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 Select the worksheet label, go to the Home tab, and select the Rename option in the Worksheet

drop-down list. After entering the new name, press the <Enter> key or click any place except the

worksheet label to finish the operation.

2.10.6 Moving or Copying Sheet

There are two ways to move and copy worksheets: by the Move or Copy Sheet option in the Worksheet

drop-down list and by the mouse.

 Move or copy worksheets by the dialogue box.

(1) Select the worksheets that you want to move or copy.

(2) Click the Worksheet icon in the Home tab and select the Move or Copy Sheet option in the

drop-down list. TheMove or Copy Sheet dialogue box will open and show as below:

Figure 2.10-7 The Move or Copy Sheet dialogue box

(3) In the To workbook drop-down box, select the workbook where you want to put your worksheet. If

you want to move or copy the selected worksheet into a new workbook, select the New workbook option.

(4) Select the worksheet before which you want to insert or copy the intended worksheet in the Before

Sheet list box.

(5) If you want to copy rather than move the worksheet, select the Create a copy check box.

(6) Click the OK button to complete the operation.

 Move or copy worksheets by the mouse.

This method is suitable for moving or copying worksheets that are in the same workbook. The steps are as

follows:

(1) Select the worksheets that you want to move.



Spreadsheets 2013 User Manual

70

(2) Drag the selected sheets along the row of the sheet tabs to the intended position. There will be a little

dark triangle on the top left of the first tab, which indicates the location of the worksheet.

(3) Select the worksheets that you want to copy.

(4) Hold the <Ctrl> key and drag the sheets to the intended position.

(5) When the little dark triangle moves to the intended position, first release the mouse button, and then

release the <Ctrl> key. You can also release them at the same time.

Figure 2.10-8 Before moving

Figure 2.10-9 After Moving

Figure 2.10-10 Copying the worksheet
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2.10.7 Tab Color

You can set the tab color for the worksheets by the following steps:

(1) Select the worksheets that you want to set the tab color.

(2) Click theWorksheet icon in the Home tab and select the Tab Color option in the drop-down list.

(3) Choose the preferred tab color in the drop-down menu as shown below:

Figure 2.10-11 Tab Color

(4) The tab color of the selected worksheets will change into the one you have chosen. The effect is

shown as below:

Figure 2.10-12 Tab Color effect

(5) You can choose the No Color option in the drop-down menu to clear the tab color.

2.10.8 Hiding and Showing Sheet

There are two methods to hide or unhide a worksheet:

 Select the worksheet that you want to hide or unhide. Click the Worksheet icon and select the Hide

and Unhide option. Choose the Hide Sheet or Unhide Sheet option in the drop-down list.

 Select the worksheet that you want to hide or unhide. Right-click the mouse and choose the Hide or
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Unhide option in the context menu.

2.11 Find and Replace

2.11.1 Find

To use the Find function, follow the steps below:

(1) Click the Find and Replace icon in the Home tab and select the Find option in the drop-down list, or

you can press the <Ctrl+F> combination. The Find dialogue box will then open and show as below:

Figure 2.11-1 The Find dialogue box

(2) Input the text you want to find in the Find what enter box.

(3) Click the Options button to unfold the dialogue box where you can set the finding condition in a

more specific way.

(4) Click the Find Next button to locate the next cell which contains the target text.

(5) Click the Find All button and all the data which meet your requirement will be listed.

(6) Click the Close button to close the dialogue box.

2.11.2 Replace

To use the Replace function, follow the steps below:

(1) Click the Find and Replace icon in the Home tab and select the Replace option in the drop-down list,

or you can press the <Ctrl+H> combination. The Replace dialogue box will then open and show as

below:

Figure 2.11-2 Replace Tab
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(2) Input the contents you want to find in the Find what enter box and input the contents you want to

replace with in the Replace with enter box.

(3) Click the Replace button to replace once.

(4) Click the Replace All button to replace all the content in the worksheet.

(5) Click the Close button to close the dialogue box.

Tips: You can enter nothing in the Replace with enter box to delete all the contents which you have find.

2.11.3 Go To

You can quickly locate data in the worksheet by the Go To function offered by Kingsoft Spreadsheets.

To use the Go To function, follow the steps below:

(1) Click the Find and Replace icon in the Home tab and select the Go To option in the drop-down list,

or you can press the <Ctrl+G> combination. The Go To dialogue box will then open and show as below:

Figure 2.11-3 The Go to dialogue box

(2) You can specify the conditions by selecting or deselecting the check boxes in the above dialogue box.

(3) Click the Go To button to locate the cells which meet the conditions you have specified.

(4) Click the Close button to close the dialogue box.

2.11.4 Select Objects

You can easily select objects in the Kingsoft Spreadsheet by the selecting objects mode. Follow the steps

below:

(1) Click the Find and Replace icon in the Home tab and choose the Select Objects option in the

drop-down list. See below:
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Figure 2.11-4 The Select Objects option

(2) When the cursor changes into a arrow-headed cross, you can then select the target objects simply by

clicking them.

(3) You can also click and hold the mouse, and then drag the mouse to cover the objects you want to select.

There will be a shadow area with dotted lines as its borders and objects in it will altogether be selected.

3 Insert Tab

3.1 Tables

3.1.1 PivotTable

PivotTables are dynamic tabulations which allow you to quickly combine and compare data to produce

tailored information to suit your needs. In pivot tables, by rotating rows and columns, users can view

details from different perspectives. In brief, pivot tables allow users to simplify complicated data and

discover an internal model which otherwise would be difficult to find in a disordered list. However, it is

recommended to use pivot tables only when you have a long list of complicated data and want to analyze

the related details. Otherwise, it is not necessary to use this function.

To apply the PivotTable function, follow the steps below:

(1) Click the PivotTable icon in the Insert tab.

Figure 3.1-1 The PivotTable icon

(2) In the Select a range section of the Create PivotTable dialogue box, choose the data range which

you want to base your pivot table (If you have already activated a cell in the source data range before
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performing the first step, Kingsoft Spreadsheets will automatically select that range for you) and the data

range will be enclosed by dotted boarders. You can also modify a pivot table that already exists in the

spreadsheet. There are two options offered, namely the New Worksheet and the Existing Worksheet, for

you to choose where you want to place the pivot table.

Figure 3.1-2 Create a pivot table

(3) After clicking the OK button in the Create PivotTable dialogue box, an empty pivot table will

appear in the position you have chosen. You can use the PivotTable task window which automatically

pops up on the right to put contents into the pivot table you have created. Items presented in the Field List

section can be dragged to the Page Area, Column Area, Row Area and Data Area in the Pivot Table

Areas section. By moving these items to different areas, you can view them in different perspectives. To

delete any of them, you can simply move them out of the areas. By this way, you can analyze the detailed

information contained in the data range.
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Figure 3.1-3 Set the pivot table

3.1.1.1 PivotTable Tools Tab

After you have created a pivot table in the worksheet, the PivotTable Tools tab will appear on the top of

the window. See below:

Figure 3.1-4 The PivotTalbe Tools tab

The functions of these tools are as follows:

 Modify PivotTable: Click this icon and the Modify PivotTable dialogue box will open where you

can modify the existing pivot table.

 Refresh Data: After you have made changes to the source data, click this icon and the data in the
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pivot table will be refreshed.

 Sort: Click this icon and the PivotTabel Field Advanced Options dialogue box will open and show

as below. In the AutoSort section, you can choose to sort the data by default (manually change the

item order), in ascending order, and in descending order. Choose the using field in the drop-down list.

Figure 3.1-5 The AutoSort tab

You can choose the Top 10 AutoShow tab to show the top 10 or other number of items in the pivot table.

Choose the using field in the drop-down list.

Figure 3.1-6 The Top 10AutoShow tab

 Hide: Click this icon to hide the items in the pivot table fields.

 Order: By choosing options offered in the Order drop-down list, you can move the row or column in

the pivot table to the beginning or to the end.

Figure 3.1-7 The Order drop-down list

 Delete: Click this icon to delete the currently selected pivot table.

 Show Detail: Click this icon to show all items of the active field.

 Hide Detail: Click this icon to hide all items of the active field.

 Field Settings: Click this icon and the PivotTable Field dialogue box will open.
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Figure 3.1-8 The PivotTable Field dialogue box

In the Subtotals tab, you can select the options offered to calculate a subtotal.

Figure 3.1-9 The Display tab

In the Display tab, you can select to display the items which you prefer. Select the Show items with no

data check box and only those items with no data will be displayed.

When you select a field in the pivot table, you can choose the type of calculation to summarize data in that

field. See below:
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Figure 3.1-10 The Summarize Values By tab

 Subtotals: Click this icon to show or hide subtotals.

 PivotTable Optoins: Click this icon and the PivotTable Options dialogue box will open where you

can specify the settings of the pivot table by selecting or deselecting the check boxes. See below:

 Hide Field List and Show Field List: Click this icon to hide and show the PivotTable task window

at the right side of the screen.

3.2 Chart

In order to enhance the explanatory effect of the data and make the data vivid for the reader, you can use

chart to display data. Chart is the most intuitive way to analyze data. Kingsoft Spreadsheets can

automatically generate various kinds of charts according to the data in the cells, such as the Column chart,

Bar chart, Line chart, Pie chart, Area chart and so on. All these types of charts can easily convert between

one another. In the following section we’ll introduce the chart type, chart structure, how to create chart,

chart tools tab, and custom chart.
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3.2.1 Chart Type

Kingsoft Spreadsheets offers 11 types of charts, and you can choose the appropriate one to best convey

what you want to express effectively. They are the Column chart, Bar chart, Line chart, Pie chart,

XY(Scatter) chart, Area chart, Doughnut chart, Radar chart, Bubble chart, Stock chart, and Custom.

You can choose different styles and colors for each type of charts. See below:
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Figure 3.2-1 Chart types

Click the Chart icon in the Insert tab and the Chart Type dialogue box will open and show as below. You

can modify chart settings there.
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Figure 3.2-2 Chart Type dialogue box

3.2.2 Chart Structure

A chart is composed of the chart area and other elements in the area, such as the chart title, legend, axes

and so on. Some elements such as the legend and data series can be subdivided into separate elements. The

elements of chart are shown as follows:

 Data Source: Refers to the data range you select to create charts.

 Data Series: Data series are automatically generated by the group of data which is going to be

illustrated on the chart. You can choose row data or column data to generate the series.

 Data Labels: To quickly identify a data series in a chart, you can add data labels in the chart. By

default, the data labels are linked to values in the worksheet. You can set the properties of data labels

via the Data Labels tab in the Chart Settings dialogue box.

 Axes: Axes are lines on the edge of the charts used to measure and compare data. Charts usually have

two axes: a vertical value (y) axis, and a horizontal (x) axis.

 Chart Title: Chart titles are usually a short description of the chart, and it is usually found at the top

center of the chart or aligns with the axes automatically.

 Legend: Displays the names of the data series in corresponding patterns and colors.
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Figure 3.2-3 Chart structure

3.2.3 Creating Chart

To create charts, follow the steps below:

(1) Select the cells that contain the data you want to plot in a chart. For example, select the cell range as

shown below.

Figure 3.2—4 Select the data area

(2) Click the Chart icon in the Insert Tab. The Chart Type dialogue box will pop up.

(3) Select the suitable chart type in the Chart Types section. Here we choose the Clustered Column in

the Column chart group. See below:
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Figure 3.2-5 Select chart type

(4) Click the Next button to open the Source Data dialogue box. There are two tabs in the dialogue box:

Data Range and Series. The Data Range tab is used to modify the data range of the chart while the

Series tab is used to change the name, values, and category (x) axis labels of the data range.

Figure 3.2-6 Select the data range

You can select the data range and series in the corresponding sections in Figure 3.2-6.

Figure 3.2-7 The Series tab
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Choose to add or remove series by the Add and Remove button. Select the Name, Values, and Category

(X) axis labels areas in the corresponding sections in Figure 3.2-7.

(5) Click the Next button to open the Chart Settings dialogue box containing 6 tabs where you can

specify the settings of the chart.

 Titles tab: Enter titles for the chart, the category (X) axis, and the category (Y) axis in the

corresponding enter box. See below:

Figure 3.2-8 The Titles tab

 Axes tab: Select the way you prefer to display the primary axis X and Y by the check box. Axis Y

usually displays the values of the data. You can choose to automatically display axis X or to

display axis X by category or in the mode of time-scale. See below:

Figure 3.2-9 The Axes tab

 Gridlines tab: You can choose to show or hide the major and minor gridlines in axis X and Y by

selecting or deselecting the corresponding check boxes. See below:
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Figure 3.2-10 The Gridlines tab

 Legend tab: You can choose to show or hide the legend by the Show legend check box. Select the

position of the legend in the Placement section. The default selection is Right. See “Score 1”

and “Score 2” below:

Figure 3.2-11 The Legend tab

 Data Labels tab: You can add labels to data in this tab. Select the Series name, Category name,

and Value check box in the Label contains section to add the corresponding data labels. See

below:

Figure 3.2-12 The Data Labels tab
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 Data Table tab: You can show the data table in the chart by selecting the Show data table check

box in this tab. See below:

Figure 3.2-13 The Data Table tab

(6) Click the Finish button to complete the operation. You can then insert the chart you have specified in

the current worksheet. See below:

Figure 3.2-14 Chart

3.2.4 Chart Tools Tab

After you have inserted the chart into the current worksheet, the Chart Tools tab will appear at the top of

the screen. See below:
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Figure 3.2-15 The Chart Tools tab

The functions of these icons are as follows:

 Change Chart Type: Click this icon the Chart Type dialogue box will open where you can change

the current chart type.

 Chart Objects: Select the chart elements here in the drop-down list so as to format it.

 Format Chart: Click this icon to open the Chart Area Properties dialogue box where you can set

the border, fill color, font, and other properties of the chart.

 Data Table: Click this icon to add or remove the data table to the chart.

 Legend: Click this icon to show or hide the legend in the chart.

 Select Data: Click this icon to open the Source Data dialogue box where you can change the data

range and series contained in the chart.

 Switch Row: Click this icon to create chart series in rows.

 Switch Column: Click this icon to create chart series in columns.

3.2.5 Custom Chart

Kingsoft Spreadsheets contains various chart styles and a vibrant color scheme. It also provides a custom

chart option. When creating a chart, you can save them for future use. It’s also very easy to access your

previously designed charts.

To create a customized chart, follow the steps below:

(1) Create a chart in the current worksheet (follow the steps in chapter 3.2.4).

(2) Click the Change Chart Type icon in the Chart Tools tab. The the Chart Type dialogue box will

open and show as below:
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Figure 3.2-16 The Chart Type dialogue box

(3) Click the Add to Custom Type button in the bottom and the Add User-Defined Type dialogue box

will open and show as below.

Figure 3.2-17 The Add User-Defined Type dialogue box

(4) Add the name and description in the corresponding enter box.

(5) Press the OK button to complete the operation.

After adding the custom chart, you can see it in the Custom section of the Chart Type dialogue box. See

below:

Figure 3.2-18 Add to the Custom Type
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You can delete the custom chart type by selecting it in the Custom section of the Chart Type dialogue

box. Then click <Delete> on the keyboard.

3.3 Picture

If the worksheet only contains raw data and text, it would be boring and without main points. Pictures are

very useful in presenting the data, which visually display the contents of the data to the user. If you have

pictures which you feel would enhance the demonstration of the data, you can insert these pictures into the

worksheet.

To insert pictures in the worksheet, follow the steps below:

(1) Click the Picture icon in the Insert tab. The Insert Picture dialogue box will open and show as

below:

Figure 3.3-1 The Insert Picture dialogue box

(2) Find the picture in the File Name search box. Then click the Open button and the picture will be

inserted in the current worksheet.

Tips: After inserting the picture, the Picture Tools tab will show up where you can modify the properties

of the picture (more detailed information, see the corresponding chapters in User Manual of Writer 2013)

3.4 Shapes

If inserting pictures are still not enough demonstration, then you can insert shapes. Kingsoft Spreadsheets

provides various kinds of shapes which will enrich the data.

To insert Shapes, follow the steps below:
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(1) Click the Shapes icon in the Insert tab and the Shapes drop-down list will open. See below:

Figure 3.4-1 The Shapes drop-down list

(2) Click the shape that you prefer. When the cursor changes into a cross, you can draw the shape in the

current worksheet.

Tips: After inserting the shape, the Drawing Tools tab will show up where you can modify the properties

of the shape (more detailed information, see the corresponding chapters in User Manual of Writer 2013).

3.5 Text Box

Kingsoft Spreadsheets provides two types of text box: Horizontal and Vertical. In the Insert tab, you can

select the Horizontal or Vertical option in the Text Box drop-down list. When the cursor changes into a

cross, you can drag it to insert the text box in the current worksheet.

Right-click the text box, select the Format Text Box option in the context menu. The Set Text box

Format dialogue box will open and show as below.
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Figure 3.5-1 Set Text box Format

You can set the text font, font style, size, underline style, color, and effects in the corresponding sections in

Figure 3.5-1.

3.6 Word Art

Kingsoft Spreadsheets provides a series of WordArt style. To insert WordArt in the worksheet, follow the

steps below:

(1) Click theWordArt icon in the Insert tab. TheWordArt Gallery dialogue box will open and show as

below:

Figure 3.6-1 WordArt Gallery

(2) Choose the WordArt style you prefer and click the OK button. The Edit WordArt Text dialogue box

will open and show as below:
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Figure 3.6-2 Edit WordArt Text

(3) Enter the contents in the Text enter box and set the font, size, bold, and italic style for the text.

(4) Click the OK button to complete the operation.

Tips: After you have inserted the WordArt in the worksheet, theWordArt tab and Format tab will appear

where you can specify the properties of the WordArt (for more detailed information, see the corresponding

chapters in User Manual of Writer 2013).

3.7 Header & Footer

You can add header and footer to the worksheet. The steps are as follows:

(1) Click the Header and Footer icon in the Insert tab. The Page Setup dialogue box will open and

show as below:

Figure 3.7-1 The Page Setup dialogue box

(2) Open the Header and Footer tab where you can customize the header and footer. Click the Custom

Header button to open the Header dialogue box shown as below:
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Figure 3.7-2 The Header dialogue box

 Enter the contents of the header in the Left section, Center section, and Right section enter box.

 If you need to set the format of the text, put the cursor in the edit box, and then click the Font

button .

 If you need to insert Page Number , Number of Pages , Date , Time , File , and

Sheet Name , put the cursor in the edit box and press the corresponding icon.

 If you need to insert pictures, click the Insert Picture icon . If you need to set the format of

pictures, put the cursor in the edit box, and click the Reset Picture icon .

(3) After you have finished all the settings, press OK to return to the Header and Footer tab where you

can preview the effect. Custom Footer works the same way as Custom Header.

(4) Click the Options button at the bottom to set the page layout.

(5) If you want to print the worksheet, you can click the Print button at the bottom to set the print

properties in the Print dialogue box.

(6) Click the OK button to complete the operation.

3.8 Hyperlink

3.8.1 Create Hyperlink

In Kingsoft Spreadsheets, you can establish hyperlinks between cells, and between cells and files, web

pages, or even e-mail accounts.



Spreadsheets 2013 User Manual

95

To create hyperlink in the worksheet, follow the steps below:

(1) Select the cell where you want to add a hyperlink.

(2) Click the Hyperlink icon in the Insert tab. The Hyperlink dialogue box will open and show as

below:

Figure 3.8-1 The Hyperlink dialogue box

(3) Select the target file in the Link to section.

(4) Press the OK button to insert the hyperlink between the selected cell and the target file.

(5) Click the cell where you’ve added the hyperlink and you can quickly switch to the target file. You can

also open the hyperlink by right-clicking the cell and choosing the Open Hyperlink option in the context

menu.

Figure 3.8-2 Cell with hyperlink

(6) To edit the hyperlink you have created, right-click the cell and choose the Edit Hyperlink option in

the context menu. The Edit Hyperlink dialogue box will open where you can modify the target file.

To meet the different requirements of the customers, Kingsoft Spreadsheets provides a hyperlink control

tab, which means you can input information about the Internet or the network path. You can decide

whether to automatically change internet links into hyperlinks in the worksheet. The steps are shown as

follows:

(1) Open the Application menu at the top left corner. Click the Options button at the



Spreadsheets 2013 User Manual

96

lower right corner.

(2) Select the Edit tab in the Options dialogue box. See below:

Figure 3.8-3 The Edit tab

(3) In the Edit Settings section, select the Replace Internet and network paths with hyperlinks as you

type check box and the hyperlinks will be activated by default.

3.8.2 Group Create and Cancel Hyperlinks

If the web page address or the e-mail address are not automatically changed into hyperlinks in a document,

you can convert them altogether. Kingsoft volume conversion tool allows you to perform this function so

as to facilitate your document or e-mail needs. The steps are as follows:

(1) Only the URL and e-mail addresses can be converted into hyperlinks. Therefore select the cell range

whose contents need to be converted into hyperlinks.

(2) Click the Format icon in the Home tab and choose the Convert Text to Hyperlink option in the

drop-down list. Then the URL and e-mail addresses will be converted into hyperlinks. See below:

Figure 3.8-4 Convert Text to Hyperlink

If you want to remove the hyperlink you have created, right-click the target cell range and choose the
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Remove Hyperlink option in the context menu. See below:

Figure 3.8-5 Remove Hyperlink

3.9 Symbol

You can insert symbol in Kingsoft Spreadsheets. The steps are as follows:

(1) Select the cell where you want to insert the symbol.

(2) Click the Symbol icon in the Insert tab. The drop-down list will open and show as below:

Figure 3.9-1 The Symbol drop-down list

(3) Click the symbol that you prefer in the Recently Used Symbols section and the Custom Symbols

section. The symbol will be inserted in the worksheet.

(4) You can also choose the More Symbols option at the bottom to open the Symbol dialogue box. See

below:
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Figure 3.9-2 The Symbol dialogue box

(5) Choose the symbols in the Symbols and Special Characters tab.

(6) You can also customize symbols in the Custom Symbols tab, e.g. move and remove the custom

symbols, or even reset the symbol tool bar.

(7) Click the Insert button to insert the symbol. Or click the Cancel button to cancel the operation.

3.10 Equation

You can insert equation in Kingsoft Spreadsheets, follow the steps below:

(1) Select the cell or cell range where you want to insert the equation.

(2) Click the Equation icon in the Insert tab.

(3) The Equation Editor will open where you can edit the equation. See below:

Figure 3.10-1 The Equation Editor

(4) Close the Equation Editor and the equation you have edited will be inserted to the selected cell or

cell range.
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3.11 Insert Object

The steps to insert an object in the worksheet are shown as follows:

(1) Click the Object icon in the Insert tab and the Insert Object dialogue box will open and show as

below:

Figure 3.11-1 The Insert Object dialogue box

There are two options to insert objects:

 Create New: Insert object directly. Select the type of the object you want to insert in the

Object type roll-down list. Kingsoft Spreadsheets supports a variety of object types, such as

Kingsoft Spreadsheets Workbook, WordPad document, and Microsoft Excel among others.

 Create from file: Insert objects which already exist in the system.

(2) Select the Display as icon check box. Then the inserted object will be displayed as an icon.

(3) Press the OK button to complete the operation.

3.12 Insert File Object

To insert file object in the worksheet, follow the steps below:

(1) Click the File Object icon in the Insert tab. The Insert File Object dialogue box will open and show

as below:
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Figure 3.12-1 Insert File Object dialogue box

(2) Find the target file and click the Open button to insert the file in the worksheet.

3.13 Insert AutoShape

You can also insert AutoShape in Kingsoft Spreadsheets, such as Label, Group Box, Button, etc.

 Label : Click this icon to insert label in the worksheet. Double click the label you have inserted and

set the size, properties, and control in the Format AutoShape dialogue box. See below:

Figure 3.13-1 Format label

 Group Box : Click this icon to insert group box in the worksheet. Double click the group box you

have inserted and set the size, properties, and control in the Format AutoShape dialogue box.

 Button : Click this icon to insert button in the worksheet. Double click the button you have inserted

and enter the macro name and description in the corresponding enter box of the Assign Macro

dialogue box. See below:
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Figure 3.13-2 The Assign Macro dialogue box

 Check Box : Click this icon to insert check box in the worksheet. Double click the check box you

have inserted and set the colors and lines, size, properties, and control in the Format AutoShape

dialogue box.

 Option Button : Click this icon to insert option button in the worksheet. Double click the option

button you have inserted and set the colors and lines, size, properties, and control in the Format

AutoShape dialogue box.

 List Box : Click this icon to insert list box in the worksheet. Double click the list box you have

inserted and set the size, properties, and control in the Format AutoShape dialogue box.

 Combo Box : Click this icon to insert combo box in the worksheet. Double click the combo box you

have inserted and set the size, properties, and control in the Format AutoShape dialogue box.

 Scroll Bar : Click this icon to insert scroll bar in the worksheet. Double click the scroll bar you have

inserted and set the size, properties, and control in the Format AutoShape dialogue box.

 Spinner : Click this icon to insert spinner in the worksheet. Double click the spinner you have

inserted and set the size, properties, and control in the Format AutoShape dialogue box.

 Control Properties : Click this icon to open the Format AutoShape dialogue box and set the

properties of the selected AutoShape.

 Edit Code : Click this icon to open Microsoft Visual Basic and edit the selected form code.

 Selection Pane : Click this icon to open the Selection Pane task window on the right side where

you can easily locate a specific object and set its order and visibility.
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4 Layout Tab

4.1 Page Setup

You can use the Page Setup dialogue box to set the Page, Margins, Header and Footer, and Sheet to meet

your requirements.

4.1.1 Margins

To set the margins of the worksheet, follow the steps below:

(1) Click the Margins icon in the Layout tab. The Margins tab in the Page Setup dialogue box is

shown as below:

Figure4.1-1 The Margins tab

(2) In theMargins tab you can:

 Control the spacing of margins by editing the Top, Bottom, Left and Right options.

 Control the margins between the header and the top of the page, or the footer and the bottom of the

page, by inputting numbers in the Header and Footer spinner.

 In the Center on page section, set the way you want your table to be centered. You can select

Horizontally or Vertically options according to your requirements.

(3) Click the OK button to complete the operation. Or click the Cancel button to exit.
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4.1.2 Orientation

There are two ways to set the orientation of the page:

 Click the Orientation icon in the Layout tab and choose the Portrait or Landscape option in the

drop-down list. See below:

Figure 4.1-2 The Orientation drop-down list

 Click the Size icon in the Layout tab. The Page Setup dialogue box will open. Select the Page tab

shown as below:

Figure 4.1-3 Page Orientation Setting

In the Orientation section, select the Portrait or Landscape option button.

4.1.3 Size

To set the size of the page, follow the steps below:

(1) Click the Size icon in the Layout tab and the Page Setup dialogue box will open. Select the Page

tab. See below:
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Figure 4.1-4 The Page tab

(3) Select the size of the paper in the Paper Size drop-down list.

(4) Press OK to complete the operation.

4.1.4 Print Area

To set the print area, follow the steps below:

(1) Click the Print Area icon in the Layout tab and choose the Set Print Area option in the drop-down

list. See below:

Figure 4.1-5 The Print Area drop-down list

(2) Then you can drag the mouse to select the area need to print.

(3) Open the Application menu at the top left corner of the screen. Choose the Print

Preview option in the drop-down list. Then you can see the effect of the printing area.

(4) Choose the Clear Print Area option in the drop-down list to clear the print area you have set.

4.1.5 Print Titles

In order to print the titles on each page in spreadsheet documents, Kingsoft provides the title printing

function. To use this function, follow the steps below:

(1) Click the Print Title icon in the Layout tab and the Page Setup dialogue box will open. Select the

Sheet tab. See below:
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Figure 4.1-6 Print titles

(2) In the Sheet tab, there are five functions which are shown as follows:

 Rows to repeat at top: If you want to print the column label on every page, you have to

select the row number in which your column label is located in the Rows to repeat at top

section.

 Columns to repeat at top: If you want to print the row label on every page, you have to

select the column number in which your row label is located in the Columns to repeat at top

section.

 Print Gridlines: You can choose whether or not to print the grid lines, and you can also

choose to print only the horizontal grid lines or the vertical grid lines. When you choose not

to print the grid lines, you can print the spreadsheet much faster.

 Print Row and column headings: Select the Row and column headings check box to print

the row number and column labels

 Page order: You can choose the print order of pages: Down, then over or Over, then down.

(3) Press OK to complete the operation.

4.1.6 Breaks

If you want to print your worksheet in several pages, you can insert breaks in the worksheet. Follow the

steps below:

(1) Select the row where you want to insert the break.

(2) Click the Breaks icon in the Layout tab and select the Insert Page Break option in the Breaks

drop-down list. See below:
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Figure 4.1-7 The Insert Page Break option

(3) Then you can see there is a dotted line above the row you have selected. See below:

Figure 4.1-8 The dotted line

(4) Open the Application menu at the top left corner and choose Print Preview in the

drop-down list. Then you can see the effect of the breaks.

(5) If you want to cancel the break you have inserted, select the same row and choose Delete Page Break

in the Breaks drop-down list. See Figure 4.1-7.

(6) If you want to reset all the breaks you have inserted in the worksheet, select Reset All Page Breaks in

the Breaks drop-down list. See Figure 4.1-7. Then all the page breaks in the worksheet will be deleted.

4.1.7 Page Zoom

You can set the zoom scaling when you print the work sheet. If the sheet is too small, you can increase its

percentage. If the sheet is too large, you can decrease its percentage to fit it in one page.

To zoom the page, do as follows:

(1) Click the Page Zoom icon in the Layout tab and the Page Setup dialogue box will open. Select the

Page tab. See below:
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Figure 4.1-9 Zoom the page

(2) You can adjust the print scaling in the Scaling section. Enter the proportion you want to zoom the

worksheet in the Adjust to enter box. Kingsoft Spreadsheets supports worksheet zoom from 10% to

400%.

(3) Enter the number of page that you want the worksheet to fit to in the Fit to enter box.

(4) Enter the width of the worksheet in the wide by enter box.

Tips: When you select Adjust to, the system will automatically ignore the manually created breaks.

Change the values in the Adjust to enter box, the spreadsheet will then be printed according to your needs.

4.2 Arrange

4.2.1 Arrange Object Orders

To rearrange the object orders in Kingsoft Spreadsheets, follow the steps below:

(1) Select the objects which you want to rearrange orders

(2) Use the Bring Forward and Send Backward drop-down list in the Page Layout tab. See below:

Figure 4.2-1 Bring Forward and Send Backward

The function of these options are as follows:

 Bring Forward: Bring an object one step closer to the front.

 Bring to Front: Bring an object to the front of the stack.

 Send Backward: Send an object one step toward the back.
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 Send to Back: Send an object to the back of the stack.

Tips: Select the object you want to move. If the object is hidden, select any object, and then press <Tab>

or <Shift+Tab> until the object you want is selected.

4.2.2 Align

4.2.2.1 Align Objects

Kingsoft Spreadsheets provides 6 align options: Align Left, Align Center, Align Right, Align Top, Align

Middle, and Align Bottom. The operation steps are shown as follows:

(1) Select the objects you want to align.

(2) In the Page Layout tab, select the options in the Align drop-down list. See below:

Figure 4.2-2 The Align drop-down list

4.2.2.2 Distribution

Kingsoft Spreadsheets provides two distribution methods: Distribute Horizontally and Distribute

Vertically. If objects are arranged in equal distance, you can use the horizontal and vertical distribution

methods. The operation steps are shown as follows:

(1) To distribute objects, you have to select multiple objects. Hold <Ctrl> to select multiple objects.

(2) In the Page Layout tab, select Distribute Horizontally or Distribute Vertically in the Align

drop-down list. See Figure 4.2-2.
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4.2.2.3 Object Size Adjustment

If you want to adjust the size of the inserted objects, you can do as follows:

 Equal Height: Select the desired objects. In the Page Layout tab, select Equal Height in the Align

drop-down list. The selected objects will be adjusted to the same height.

 Equal Width: Select the desired objects. In the Page Layout tab, select Equal Width in the Align

drop-down list. The selected objects will be adjusted to the same width.

 Equal Size: Select the desired objects. In the Layout tab, select Equal Size in the Align drop-down

list. The selected objects will be adjusted to the same size.

4.2.2.4 Snap to Gird

If you want the object you have inserted to snap to the grid, you can do as follows:

(1) Select the desired objects.

(2) In the Page Layout tab, open the Align drop-down list and select the Snap to Grid option. See Figure

4.2-2.

(3) Then you can use the mouse to drag the objects to align them to the grid.

(4) If you want to cancel the operation, select the Snap to Grid option again in the Align drop-down list.

4.2.2.5 Show Grid

In Kingsoft Spreadsheets, you can set whether or not to show grid.

If you want to show grid, select the Show Grid option in the Align drop-down list of the Layout tab. See

Figure 4.2-2.

If you don’t want to show grid, select the Show Grid one more time in the Align drop-down list.

4.2.3 Group

You can group shapes, pictures, and other objects. Grouping allows you to rotate, flip, move, and re-size

all shapes and objects at the same time as if they were a single shape or object. The operation steps are as

follows:

(1) You can hold <Ctrl> when clicking to select multiple objects.

(2) In the Page Layout tab, select Group in the Group drop-down list. See below:
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Figure 4.2-3 The Group drop-down list

(3) Select Ungroup in the Group drop-down list to ungroup the multiple objects.

4.2.4 Rotate

In order to allow you to freely edit pictures, Kingsoft Spreadsheets provides Free Rotate, Rotate Left 900,

Rotate Right900, Flip Horizontally, and Flip Vertically options. The operation steps are shown as

follows:

(1) Select the pictures which you want to edit.

(2) In the Layout tab, click the Rotate icon to open the drop-down list. Choose the rotate style that you

prefer according to your needs. See below:

Figure 4.2-4 The Rotate drop-down list

5 Formulas Tab

Formulas are equations that are used to analyze and calculate the numeric values. You can use a formula,

which usually begins with an equal mark (=), to perform some simple calculations such as addition,

subtraction, multiplication and division. Meanwhile, formulas can include any of the following elements:

functions, references, operators, and constants. If you want to input formula in a cell of a worksheet, you

can input a combination of these elements.

5.1 Formulas Grammar

In Kingsoft Spreadsheets, whether a cell contains a formula or not is based on whether it starts with “=”.

Specifically, a formula is usually composed of the following elements:
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 = equality sign.

 Numbers: 0~9 or cell addresses (numbers contained in the cells).

 Other arguments that can be referred to by formulas or functions.

 ( ): to set the priorities.

 Operators: to connect data. There are three different types of operators in Kingsoft

Spreadsheets: arithmetic, comparison, and text and reference. See below:

Category Operator Feature Remark

Arithmetic

+ (plus sign) Addition The calculate orders are: the

data in “()” has higher

calculation priorities;

multiplication and division

first, and then addition and

subtraction; for the same

level of operations, calculate

from left to right.

- (minus sign) Subtraction

* (asterisk) Multiplication

/ (forward slash) Division

% (percent sign) Percent

^ （caret） Exponentiation

Comparison

= Equal to
You can compare two values

with the operators on the

left. When two values are

compared by using the

operators, the result is a

logical value, i.e. TRUE or

FALSE.

> Greater than

< Less than

>=
Greater than or

equal to

<=
Less than or

equal to

<> Not equal to

Text &

Text

concatenation

operator

Use the ampersand (&) to

join, or concatenate one or

more text strings to produce

a single piece of text.
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Category Operator Feature Remark

Reference

: (colon) Range operator

Produces one reference to all

the cells between two

references, including the two

references. (For example,

A1:A3)

, (comma) Union operator

Combines multiple

references into one

reference. (For example,

SUM (A1:A3, B1:B5)

(space)
Intersection

operator

Produces the reference to the

intersecting cells of two

references. (For example,

A1:A3 A2:B5)

Table 5.1-1 Operators offered in Kingsoft Spreadsheets

5.1.1 Create Formulas

Formulas are equations that perform calculations on values in your worksheet. You can create formulas by

using constants, calculations operators, cell references, and names that you have defined. The operation

steps are as follows:

(1) Click the cell where you want to create a formula.

(2) Input constants, functions, operators, cell references and so on.

(3) Press <Enter> after inputting the formula.

5.1.2 Input Formulas

To input formulas in a cell, follow the steps below:

(1) Select the cell where you want to input the formula.

(2) In the edit bar, input “=” and the specified contents of the formula.

(3) Press <Enter> or click in the edit bar.

(4) If you want to cancel the contents, click .
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5.1.3 Copy a Formula

The operation steps are as follows:

(1) Select the cell that you want to copy.

(2) Right-click the cell and select Copy in the context menu.

(3) Right-click the cell to which you want to copy the formula and select Paste Special in the context

menu. Then the Paste Special dialogue box will open and show as below:

Figure 5.1-1 Paste Special dialogue box

(4) In the Paste section, select Formulas.

(5) Press OK to complete the operation.

5.2 Function Library

Kingsoft spreadsheets provides a number of functions for you. You can create formulas by using these

functions, so that you can conveniently and quickly calculate data in the spreadsheet. In Kingsoft

Spreadsheets there mainly are nine kinds of functions, namely Financial, Logical, Text, Date and Time,

Lookup and Reference, Math and Trig, Statistical, Engineering, and Information.

5.2.1 Insert Function

If you insert a function in Kingsoft Spreadsheets, it will automatically be saved in the Insert Function

dialogue box. Next time when you open the Insert Function dialogue box, the function you used will be

listed at the top of Recently Used functions. For example, if you insert ADDRESS in the spreadsheet, then

when you open the dialogue box next time, it will be listed in the recently used functions category, shown

as follows:
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Figure 5.2-1 The Insert Function dialogue box

Tips: In Kingsoft Spreadsheets, there are only seven functions kept by default in the Insert Function

dialogue box. If there are more, the system will automatically delete them. But the most recently used one

will always be listed at the top.

5.2.2 Use Functions in the Table

The syntax to call a function is the same. The basic format is: = function name (argument 1,argument 2,

argument 3,...). Here are some examples:

(1) Click the cell where you want to input a function. Cell C9 is taken as an example in the following

illustration.

Figure 5.2-2 Select the cell

(2) Click the Insert Function icon in the Formulas tab. The Insert Function dialogue box will open and

show as below:
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Figure 5.2-3 The Insert Function dialogue box

(3) Select SUM in the Choose a function list box and press OK.

(4) Then the Function Arguments dialogue box will open where you can input or select the desired cells

in the Number 1 input box. Press OK. See below:

Figure 5.2-4 The Function Arguments dialogue box

(5) The function is inserted successfully and the result is displayed as below:

Figure 5.2-5 The calculated result

Tips: Click the Recently Used icon in the Formulas tab and the recently used formulas will be listed in

the drop-down list for you to choose.

Click the All icon in the Formulas tab and all the formulas which Kingsoft Spreadsheets provide will be

listed in alphabetical order in the drop-down list for you to choose.
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5.2.3 Function Category

5.2.3.1 Financial Functions

There are 19 financial functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

ACCRINT (date of issue, value

date, transaction date, rate,

face value)

Returns the interests of the securities whose interests

should be paid off once the time is due.

ACCRINTM (date of issue,

maturity date, rate, face value,

basis)

Returns the interests of the securities whose interests

should be paid off once the time is due.

DB (cost, salvage, life, period,

month)

Returns the depreciation of an asset for a specified period

using the fixed-declining balance method.

DDB (cost, salvage, life,

period, factor)

Returns the depreciation of an asset for a specified period

using the double-declining balance method or some other

method you specify.

FV (rate, nper, pmt, pv, type)
Returns the future value of an investment based on

periodic, constant payments, and a constant interest rate.

IPMT (rate, per, nper, pv, fv)

Returns the amount of interest payment for an investment

within a given period, based on periodic, constant

payments, and a constant interest rate.

IRR (values, guess)
Returns the internal rate of return that is represented by

numbers for a series of cash flows

ISPMT (rate, per, nper, pv)
Calculates the interest that should be paid within a

specific investment period.

MIRR (values, finance_rate,

reinvest_rate)

Returns the modified internal rate of return for the given

periodic cash flows. MIRR takes both the cost of

investment and the interest received on reinvestment of

cash into account.
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Function Name Explanations

NPER (rate, pmt, pv, fv, type)

Returns the number of payment periods for an

investment based on periodic, constant payments, and a

constant interest rate.

NPV (rate,value1,value2, ...)

Returns the net present value of an investment, using a

discount rate and a series of future periodic payments and

income.

PMT (rate, nper, pv, fv, type)
Returns the payment for a loan based on constant

payments and a constant interest rate.

PPMT (rate, per, nper, pv, fv)

Returns for a given period the payment on the principal

for an investment based on periodic, constant payments,

and a constant interest rate.

PRICE (transaction date,

maturity date, rate, yid,

redemption)

Returns the price per＄100 face value of a security that

pays periodic interest.

PV (rate, nper, pmt, fv, type)
Returns the present value of an investment, calculating

from a series of future payments.

RATE (nper, pmt, pv, fv, type) Returns the interest rate per period of an annuity.

SLN (cost, salvage, life) Returns the linear depreciation of an asset per period.

SYD (cost, salvage, life,

period)

Returns the sum-of-years' digits depreciation of an asset

for a specified period, which is based on its cost, salvage

value and anticipated life.

VDB (cost, salvage, life,

start_period, end_period)

Returns the depreciation of an asset for an given period

or partial period using the double-declining balance

method or some other method you specify.

Table 5.2- 1 Financial Functions

5.2.3.2 Logical Functions

There are 7 logical functions in Kingsoft Spreadsheets. See below:
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Function Name Explanations

AND (logical1, logical2, ...)

Returns FALSE if any of the arguments is

FALSE; returns TRUE only if all arguments are

TRUE.

FALSE Returns the logical value FALSE.

IF (logical_test, value_if_true,

value_if_false)

Checks whether a condition is met, and returns

one value if TRUE, and another value if FALSE.

IFERROR (value, value_if_error)

Returns the values you specify if the calculated

result of the formula is an error and the calculated

result otherwise.

NOT (logical) Reverses the logical value of the argument.

OR (logical1, logical2, ...)

Returns TRUE if any of the arguments is TRUE;

returns FALSE only if all the arguments are

FALSE.

TRUE Returns the logical value TRUE.

Table 5.2- 2 Logical Functions

5.2.3.3 Text Functions

There are 33 text functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

ASC (text)

Converts full-width (doubt-byte) characters to

half-width (single-byte) characters. Use with

doubt-byte character sets (DBCS).

CHAR (number)

Returns the character specified by the code

number from the character set for your

computer.

CLEAN (text) Removes all nonprintable characters from text.

CODE (text)
Returns a numerical code for the first character

in a text string in the character set used by your
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Function Name Explanations

computer.

CONCATENATE (text 1, text 2,...) Joins several text strings into one text string.

DOLLAR (number, decimals)
Converts a number to text, using the currency

format (US dollar) and specified digits.

EXACT (text 1, text 2)

Returns TRUE if one string is exactly equal to

the other string (EXACTLY means

case-sensitive); returns FALSE otherwise.

FIND (find_text, within_text,

start_num)

Returns the starting position of one text string

within another (case-sensitive, and wildcard

characters are not allowed).

FINDB (find_text, within_text,

start_num)

Searches another text string’s starting location in

one text string. FINDB is case-sensitive and

doesn’t allow to use wildcard. Use double-byte

characters (DBCS).

FIXED (number, decimals,

no_commas)

Rounds number to the specified number of

decimals in decimal format and returns the result

as text with or without commas.

LEFT(text, num_chars)
Returns the first character with a specified

number from the first character of a text string.

LEFTB (text, bytes number)

Returns the specified number of characters from

the leftmost appointed position of a text string.

Use with double-byte character set (DBCS).

LEN (text) Returns the length of a text string.

LENB (text)
Returns the number of characters in a text. Use

with double-byte character set (DBCS).

LOWER (text) Returns the lowercase version of a text string.

MID (text, start_num, num_ chars)
Returns the characters with a specific length

from a given starting position in a text string.
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Function Name Explanations

MIDB (text, start_num, bytes number)

Returns the specified number of characters from

the appointed location of a text string. Use with

double-byte character set (DBCS).

PROPER (text) Capitalizes the initials of all the words.

REPLACE (old_text, start_num,

num_chars, new_text)

Replaces characters within a text string with

another different text string.

REPLACEB (old_text, start_num, bytes

number, new_text)

Replaces characters within a text string with

another different text string. Use with

double-byte character set (DBCS).

REPT (text, number_times)

Returns repetitions of string for specified times.

You can use REPT to fill a cell with a text string

repeatedly.

RIGHT (text, num_chars)
Returns the specified number of characters from

the end of a text string.

RIGHTB (text, byte number)

Returns the specified number of characters from

the last character of a text string. Use with

double-byte character set (DBCS).

RMB (number, decimals)
Converts a number to text, using currency

format (RMB) and the specified digits.

SEARCH (find_text, within_text,

start_num)

Returns the first found location of the specified

character or string with in a text string, reading

from left to right (not case-sensitive).

SEARCHB (find_text, within_text,

start_num)

Returns the first found location of the specified

character or string with in a text string, reading

from left to right (not case-sensitive). Use with

double-byte character set (DBCS).

SUBSTITUTE (text, old_text,

new_text, instance_num)

Replaces part of the old text with new text in a

string.



Spreadsheets 2013 User Manual

121

Function Name Explanations

T (number) Returns the text that the value refers to.

TEXT (value, format_text)
Returns value as a string with the specified

format.

TRIM (text)
Returns text with only single spaces between

words.

UPPER (text) Returns the upper-case version of a text string.

VALUE (text) Returns the numeric value of a text string.

WIDECHAR (text)

Converts half-width (single-byte) characters to

full-width (double-byte) characters. Use with

double-byte character set (DBCS).

Table 5.2- 3 Text Functions

5.2.3.4 Date and Time

Kingsoft Spreadsheet provides 21 functions in Date and Time category. See below:

Name Explanations

DATE (year, month, day) Returns the number that represents the date in

Kingsoft Spreadsheet date-time code.

DATEIF (start_date, end_date,

comparison unit)

Counts the number of days, months, and years

between the two dates.

DATEVALUE (date_text) Converts the date in text form to a number that

represents the date in Kingsoft Spreadsheets

date-time code.

DAY (serial_number) Returns the day of the month; a number from 1 to

31.

DAYS360 (start_date, end_date,

method)

Returns the number of days between two dates

based on a 360-day year (30 days a month and 12

months a year), which is used in some accounting

calculations. Use this function to help compute
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Name Explanations

payments if your accounting system is based on a

360-day year.

EDATE (start date, number of

months)

Returns the serial number that represent the date

which is the indicated number of months before or

after a date (the start_date). Use this function to

calculate the maturity dates that fall on the same day

of the month as the date of issue.

EOMONTH (start date, number of

months)

Returns the serial number for the last day of the

month which is the indicated number of the month

before or after the start date. Use this function to

calculate the maturity dates that fall on the last day

of the month.

HOUR (serial_number) Returns the number as a number from 0 (12:00

A.M) to 23 (11:00 P.M).

MINUTE (serial_number) Returns the minute; a number from 0 to 59.

MONTH (serial_number) Returns the month; a number from 1 (January) to 12

(December).

NETWORKDAYS (start_date,

end_date, holidays)

Returns the number of the workdays (except

weekends and legal holidays) between two dates.

NOW Returns the current date and time formatted as a

date and time.

SECOND (serial_number) Returns the second; a number from 0 to 59.

TIME (hour, minute, second) Converts hours, minutes, second given as numbers

to a Kingsoft Spreadsheets serial number in date and

time format.

TIMEVALUE (time_text) Converts a text time to a Kingsoft Spreadsheets

serial number for a time.

TODAY Returns the current date formatted as a date.
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Name Explanations

WEEKDAY (serial_number,

return_type)

Returns a number from 1 to 7 identifying the day of

the week.

WEEKNUM (serial_number,

return_type)

Returns the number identifying the order of the

week of a year.

WORKDAY (start date, number of

days, holidays)

Returns a date that is the indicated number of

workdays (except weekends and holidays) before or

after a date (start date). Use this function when

calculating the invoice due dates, expected delivery

date, and the number of days you have worked.

YEAR (serial_number) Returns the year of a date; an integer in the range

1900-9999.

YEARFRAC (start_date, end_date,

basis)

Returns the percentage of the year presented by the

number of days between two dates (start date and

end date). Use this function to identify the

proportion of a whole year’s benefits or obligations

under some specified condition.

Table 5.2- 4 Date and Time Functions

5.2.3.5 Lookup and Reference Functions

There are 18 lookup reference functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

ADDRESS (row_num, column_num,

abs_num, al, sheet_text)

Creates a cell address as text according to the

specified row and column numbers.

AREAS (reference) Returns the number of areas in a reference. An

area is a range of contiguous cells or a single

cell.

CHOOSE (index_num, value1,

value2, ...)

Returns a value from the list of arguments based

on the given index number.
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Function Name Explanations

COLUMN (reference) Returns the column number of a reference.

COLUMNS (array) Returns the number of columns in an array or

reference.

EVALUATE (formula_text) Evaluates a formula or expression which is

expressed in text and returns the result.

GETPIVOTDATA (data field, pivot

table area)

Extracts data stored in a PivotTable.

HLOOKUP (lookup_value, table_array,

row_num, range_lookup)

Searches for a value in the top row of a table or

an array of values, and then returns a value in the

same column from a row you specify in the table

or array(The table is ascending by default).

HYPERLINK (hyperlink position,

display text)

Creates a shortcut or jump that opens a document

stored on a network server, Intranet, or Internet.

INDEX (array, row_num, column_num,

area_num)

Returns the value of an element in a table or an

array, selected by the row and column number

indexes.

INDIRECT (ref_text, al) Returns the reference specified by a text string.

LOOKUP (lookup_value,

lookup_vector, result_vector)

Looks up a value whether from a one-row or

one-column range or from an array.

MATCH (lookup_value, lookup_array,

match_type)

Returns the relative position of an item in an

array that matches a specified value in a

specified order.

OFFSET (reference, rows, cols, height,

width)

Returns a reference to a range that is a given

number of rows and columns from a given

reference.

ROW (reference) Returns the internal row number of a specified

reference.

ROWS (array) Returns the number of rows in a reference or
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Function Name Explanations

array.

Transpose (array) Returns a horizontal range of cells as a vertical

range, or vice versa. Transpose must be entered

as an array formula in the range that has the

same number of rows or columns respectively

with those of an array. Use transpose to shift

vertical or horizontal orientation of an array in a

worksheet.

VLOOKUP (lookup_value, table_array,

col_index_num, range_lookup)

Searches for a specified value in the leftmost

column of a table and returns a value in the

current row from a column you have specified.

Table 5.2- 5 Lookup and Reference Functions

5.2.3.6 Math and Trigonometry Functions

There are 60 math and trigonometry functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

ABS (number) Returns the absolute value of a number, a

number without its sign.

ACOS (number) Returns the arccosine of a number, in radians

in the range from 0 to Pi. The arccosine is the

angel whose cosine is the Number.

ACOSH (num_digits) Returns the inverse hyperbolic cosine of a

number.

ASIN (number) Returns the arcsine of a number within

radians from -Pi/2 to Pi/2.

ASINH (number) Returns the inverse hyperbolic sine of a

number. The inverse hyperbolic sine is the

value whose hyperbolic sine is number, so
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Function Name Explanations

ASINH(SINE<number>) equals number.

ATAN (number) Returns the arctangent of a number in radians

from -Pi/2 to Pi/2.

ATAN2 (x_num，y_num) Returns the arctangent of the specified x_ and

y_ coordinates, in radians between -Pi and Pi

(excluding -Pi).

ATANH Returns the inverse hyperbolic tangent of a

number. The number must between -1 to 1

(excluding -1 and 1). The inverse hyperbolic

tangent is the value whose hyperbolic tangent

is number, so ATANH(TANH<number>)

equals number.

CEILING (number，significance) Rounds a number up, to the nearest integer, or

to the nearest multiple of significance.

COMBIN (number, number chosen) Returns the number of combinations for a

given number of items.

COS (number) Returns the cosine of a given angel.

COSH (number) Returns the hyperbolic cosine of a number.

DEGREES (angle) Converts radians to degrees.

EVEN (number) Rounds positive numbers up and negative

numbers down to the nearest even integers.

EXP (number) Returns e raised to the power of a given

number.

FACT (number) Returns the factorial of a number. The

factorial of a number is equal to 1*2*3*...*

number.

FACTDOUBLE (number) Returns the double factorial of a number.

FLOOR (number, significance) Rounds numbers down, toward zero, to the
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Function Name Explanations

nearest multiple of significance.

GCD (number 1, number 2, ...) Returns the greatest common divisors of two

or more integers.

INT (number) Rounds a number down to the nearest integer.

LCM (number 1, number 2, ...) Returns the least common multiples of two or

more integers.

LN (number) Returns the natural logarithm of a number.

LOG (number, base) Returns the logarithm of a number to the base

you specify.

LOG10 (number) The LOG10 function returns the base-10

logarithm of a number.

MDETERM (array) Returns the matrix determinant of a number.

MINVERSE (array) Returns the reverse matrix for the matrix

stored in an array.

MMULT (array1, array 2) Returns the matrix product of two arrays. The

result is that the array has the same number of

rows with array 1 and the same number of

columns with array 2.

MOD (number，divisor) Returns the remainder after the number is

divided by a divisor.

MROUND (number, significance) Returns a given number rounded to a special

multiple.

MULTINOMIAL (number 1, number

2, ...)

Returns the ratio of the factorial of a sum of

values to the product of factorials.

ODD (number) Rounds positive numbers up and negative

numbers down to the nearest odd integers.

PI The PI function returns the value of Pi,

3.14159265358979, accurate to 15 digits.
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POWER (number，power) The POWER function returns the result of a

number raised to a power.

PRODUCT (number1,...) The PRODUCT function multiplies all the

numbers given as arguments and returns the

result.

QUOTIENT (dividend, divisor) Returns the integer portion and discard the

remainder of a division.

RADIANS (angle) The RADIANS function converts degrees to

radians.

RAND The RAND function returns an evenly

distributed random real number greater than

or equal to 0 and less than 1 (changes on

recalculation).

RANDBETWEEN (bottom, top) Returns a random integer number between the

two numbers you have specified.

ROMAN (number, type) Converts Arabic number to Roman, as text.

ROUND (number, num_digits) Rounds a number to a specified number of

digits.

ROUNDDOWN (number, num_digits) Rounds a number down, toward 0.

ROUNDUP (number, num_digits) Rounds a number up, away from 0.

SERIESSUM (x, n, m, coefficients) Returns the sum of a power series.

SIGN (number) Returns the sign of a number. Returns 1 if the

number is positive, zero (0) if the number is 0,

and -1 if the number is negative.

SIN (number) Returns the sine of the given angle.

SINH (number) Returns the hyperbolic sine of a number.

SQRT (number) Returns the square root of a number.

SQRTPI (number) Returns the square root of a number which
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Function Name Explanations

has been multiplied by Pi.

SUBTOTAL (function_number, ref1,

ref2, ...)

Returns a subtotal in a list or database.

SUM (number1，number2 ...) Returns the sum of all the numbers in a range

of cells.

SUMIF (range, criteria, sum_range) Sum the values in a range that meet criteria

that you specify.

SUMIFS (sum range, range 1) Adds the cells specified by a given set of

conditions or criteria.

SUMPRODUCT (array1, array2,

array3, ...)

Multiplies the corresponding data in the given

arrays and returns the sum of those products.

SUMSQ (number 1, number 2) Returns the sum of the squares of all the

arguments. The arguments may vary as

numbers, arrays, names, or references to cells

which contain numbers.

SUMX2MY2 (array 1, array 2) Returns the sum of differences of squares of

corresponding values in two arrays.

SUMX2PY2 (array 1, array 2) Returns the sum of sum squares of

corresponding values in two arrays.

SUMSMY2 (array 1, array 2) Returns the sum of squares of differences of

corresponding values in two arrays.

TAN (number) Returns the tangent of the given angle.

TANH (number) Returns the hyperbolic tangent of a number.

TRUNC (number, num_digits) Returns an integer by removing decimal part

of the number.

Table 5.2- 6 Math and Trigonometry Functions
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5.2.3.7 Statistical Functions

Click the More Functions icon in the Formulas tab, and choose the Statistical option in the drop-down

list. There are 83 statistical functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

AVEDEV (number1,number2, ...) Returns the average of the absolute deviations of

data points from their mean. It is a measure of

the variability in a data set.

AVERAGE (number1,number2, ...) Returns the average of the arguments.

AVERAGEA (number1,number2, ...) Returns the average (arithmetic mean) of all the

arguments, including numbers, text, and logical

values. Evaluate text. FALSE in argument as 0;

TRUE in argument as 1.

AVERAGEIF (range, criteria, average

range)

Returns the average (arithmetic mean) of all the

cells in a range that meet a given criteria.

AVERAGEIFS (average_range, range

1)

Returns the average (arithmetic mean) of all cells

that meet multiple criteria.

BETADIST (value x, alpha, beta, lower

bound of the x range, upper bound of

the x range)

Returns the beta cumulative distribution

function.

BETAINV (distribution probability,

alpha, beta, lower bound of the x range,

upper bound of the x range)

Returns the inverse of the cumulative

distribution function for a specified beta

distribution.

BINOMDIST (number_s, trials,

probability_s, returns the cumulative

distribution function)

Returns the individual term binomial distribution

probability.

CHIDIST (number, degrees of freedom) Returns the one-tailed probability of the

chi-squared distribution.

CHIINV (distribution of probability, Returns the inverse of the one-tailed probability
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degrees of freedom) of the chi-squared distribution.

CHITEST (actual range, expected

range)

Returns the test for independence.

CONFIDENCE (alpha, standard_dev,

number_sample)

Returns the confidence interval for a population

mean, using a normal distribution.

CORREL (array 1, array 2) Returns the correlation coefficient between two

data sets.

COUNT (value1, value2, ...) Counts how many numbers are in the list of

arguments.

COUNTA (value1, value2, ...) Counts the number of cells that are not empty.

COUNTBLANK (range) Counts empty cells in a specified range of cells.

COUNTIF (range, criteria) Counts the number of cells within a range that

meet the criteria that you have specified.

COUNTIFS (range1, criteria 1) Counts the number of cells within a range that

meet multiple criteria.

COVAR (array 1, array 2) Returns covariance, the average of the products

of paired deviations.

CRITBINOM (trials, probability_s,

alpha)

Returns the smallest value for which the

cumulative binomial distribution is greater than

or equal to a criterion value.

DEVSQ (number 1, number 2) Returns the sum of squares of deviations.

EXPONDIST (x, x, return the

cumulative distribution function)

Returns the exponential distribution.

FDIST (value x, degrees_freedom 1,

degrees_freedom 2)

Returns the F probability distribution. Use this

function to determine whether two data sets have

different degrees of diversity.

FINV (distribution probability,

degrees_freedom 1, degrees_freedom 2)

Returns the inverse of the F probability

distribution.
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FISHER (number) Returns the Fisher transformation.

FISHERINV (number) Returns the inverse of the Fisher transformation.

FORECAST (x, known_y’s,

known_x’s)

Returns a value along a linear trend.

FREQUENCY (data array, bins array) Returns a frequency distribution as a vertical

array.

FTEST (array 1, array 2) Returns the result of a F-test.

GAMMADIST (number, alpha, beta,

return the cumulative distribution

function)

Returns the gamma distribution.

GAMMAINV (distribution probability,

alpha, beta)

Returns the inverse of the gamma cumulative

distribution.

GAMMALN (number) Returns the natural logarithm of the gamma

function, Γ(x).

GEOMEAN (number 1, number 2) Returns the geometric mean of an array or range

of positive numeric data.

GROWTH (known_y’s, known_x’s,

new_x’s, const)

Returns values along an exponential trend.

HARMEAN (number 1, number 2) Returns the harmonic mean of a data set.

HYPGEOMDIST (sample_s, number

sample, population_s, number

population)

Returns the hypergeometric distribution.

INTERCEPT (known_y’s, known_x’s) Returns the intercept of the linear regression line.

KURT (number 1, number 2) Returns the kurtosis of a data set.

LARGE (array, k) Returns the k-th largest value in a data set.

LINEST (known_y’s, known_x’s, const,

stats)

Returns the parameters of a linear trend.

LOGEST (known_y’s, known_x’s, Returns the parameters of an exponential trend.
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const, stats)

LOGINV (distribution probability,

arithmetic average, standard deviation)

Returns the inverse of the cumulative lognormal

distribution function of x, where In(x) is the

normal distribution of parameters mean and

standard_dev.

LOGNORMDIST (number, arithmetic

deviation, standard deviation)

Returns the cumulative lognormal distribution.

MAX (number 1, number 2, ...) Returns the largest value in a set of values

(ignore text values and logical values).

MAXA (number 1, number 2, ...) Returns the largest value in a list of arguments,

including numbers, text, and logical values.

MEDIAN (number 1, number 2, ...) Returns the median of the given numbers.

MIN (number1, number 2, ...) Returns the smallest number in a set of values

(ignore text values and logical values).

MINA (number 1, number 2, ...) Returns the smallest value in a list of arguments,

including numbers, text, and logical values.

MODE (number 1, number 2, ...) Returns the most frequently occurring, or

repetitive, value in an array or range of data.

NEGBINOMDIST (number_f,

number_s, probability_s)

Returns the negative binomial distribution.

NORMDIST (number, arithmetic

average, standard deviation, return the

cumulative distribution function)

Returns the normal cumulative distribution.

NORMINV (distribution probability) Returns the inverse of the normal cumulative

distribution.

NORMSDIST (number) Returns the standard normal cumulative

distribution.

NORMSINV (distribution probability) Returns the inverse of the standard normal
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cumulative distribution.

PEARSON (array 1, array 2) Returns the Pearson product moment correlation

coefficient.

PERCENTILE (array, percent) Returns the k-th percentile of values in a range.

PERCENTRANK (array, number,

num_digits)

Returns the rank of a value in a data set as a

percentage (0..1, exclusive) of the data set.

PERMUT (number, number_chosen) Returns the number of permutations for a given

number of objects.

POISSON (number, arithmetic average,

return the cumulative distribution

function )

Returns the Poisson distribution.

PROB (x_range, prob_range, lower

bound of the x range, upper bound of

the x range)

Returns the probability that values in a range are

between two limits.

QUARTILE (array, quartile) Returns the quartile of a data set.

RANK (number, ref, order) Returns the rank of a number in a list of

numbers.

RSQ (known_y’s, known_x’s) Returns the square of the Pearson product

moment correlation coefficient.

SKEW (number 1, number 2) Returns the skewness of a distribution.

SLOPE (known_y’s, known_x’s) Returns the slope of the linear regression line.

SMALL (array, k) Returns the k-th smallest value in a data set.

STANDARDIZE (number, arithmetic

average, standard deviation)

Returns a normalized value.

STDEV (number 1, number 2, ...) calculates standard deviation based on a sample

(ignore text values and logical values).

STDEVA (number 1, number 2) Estimates standard deviation based on a sample,

including numbers, text, and logical values.
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STDEVP (number 1, number 2, ...) Calculates standard deviation based on the entire

population given as arguments (ignore text

values and logical values).

STDEVPA (number 1, number 2) Calculates standard deviation based on the entire

population, including numbers, text, and logical

values.

STEYX (known_y’s, known_x’s) Returns the standard error of the predicted

y-value for each x in the regression.

TDIST (value x, degrees of freedom,

one/two-tailed(1/2) distribution)

Returns the Percentage Points (probability) for

the Student t-distribution.

TINV (distribution probability, degrees

of freedom)

Returns the t-value of the Student's t-distribution

as a function of the probability and the degrees

of freedom.

TREND (known_y’s, known_x’s,

new_x’s, not force the coefficient to be

1)

Returns values along a linear trend.

TRIMMEAN (array, percent) Returns the mean of the interior of a data set.

TTEST (array 1, array 2, tails, type) Returns the probability associated with a

Student's t-test.

VAR (number 1, number 2, ...) Estimates variance based on a sample (ignore

text values and logical values).

VARA (number 1, number 2, ...) Estimates variance based on a sample, including

numbers, text, and logical values.

VARP (number 1, number 2, ...) Calculates variance based on the entire

population (ignore text values and logical

values).

VARPA (number 1, number 2, ...) Calculates variance based on the entire

population, including numbers, text, and logical
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values.

WEIBULL (number, alpha, beta,

returns the cumulative distribution

function)

Returns the Weibull distribution.

ZTEST (array, sample standard

deviation, u0)

Returns the one-tailed probability-value of a

z-test.

Table 5.2- 7 Statistic functions

5.2.3.8 Engineering Functions

Click theMore Functions icon in the Formulas tab, and choose the Engineering option in the drop-down

list. There are 39 engineering functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

BESSELI (lambda, n) Returns the modified Bessel function In(x).

BESSELJ (lambda, n) Returns the Bessel function Jn(x).

BESSELK (lambda, n) Returns the modified Bessel function Kn(x).

BESSELY (lambda, n) Returns the Bessel function Yn(x).

BIN2DEC (binary number) Converts a binary number to decimal.

BIN2HEX (binary number,

places)

Converts a binary number to hexadecimal.

BIN2OCT (binary number,

places)

Converts a binary number to octal.

COMPLEX (real_num, I_num,

suffix)

Converts real and imaginary coefficients into a complex

number.

CONVERT (number,

from_unit, to_unit)

Converts a number from one measurement system to

another.

DEC2BIN (number, places) Converts a decimal number to binary.

DEC2HEX (number, places) Converts a decimal number to hexadecimal.

DEC2OCT (number, places) Converts a decimal number to octal.
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DELTA (number) Tests whether two values are equal.

ERF (integral lower bound,

integral upper bound)

Returns the error function.

ERFC (integral upper bound) Returns the complementary error function.

GESTEP (number, alpha) Tests whether a number is greater than a threshold value.

HEX2BIN (hex, places) Converts a hexadecimal number to binary.

HEX2DEC (hex) Converts a hexadecimal number to decimal.

HEX2OCT (hex, places) Converts a hexadecimal number to octal.

IMABS (Inumber) Returns the absolute value (modulus) of a complex

number.

IMAGINARY (Inumber) Returns the imaginary coefficient of a complex number.

IMARGUMENT (Inumber) Returns the argument ɵ (theta), an angle expressed in

radians.

IMCONJUGATE (Inumber) Returns the complex conjugate of a complex number.

IMCOS (Inumber) Returns the cosine of a complex number.

IMDIV (plural 1, plural 2) Returns the quotient of two complex numbers.

IMEXP (Inumber) Returns the exponential of a complex number.

IMLN (Inumber) Returns the natural logarithm of a complex number.

IMLOG10 (Inumber) Returns the base-10 logarithm of a complex number.

IMLOG2 (Inumber) Returns the base-2 logarithm of a complex number.

IMPOWER (Inumber, power) Returns a complex number raised to an integer power.

IMPRODUCT (Inumber 1,

Inumber 2)

Calculates the products of complex numbers in x+yi or

x+yj text format.

IMREAL (Inumber) Returns the real coefficient of a complex number.

IMSIN (Inumber) Returns the sine of a complex number.

IMSQRT (Inumber) Returns the square root of a complex number.

IMSUB (plural 1, plural 2) Returns the difference between two complex numbers.

IMSUM (Inumber 1, Inumber

2)

Returns the sum of complex numbers.



Spreadsheets 2013 User Manual

138

OCT2BIN (octal number,

places)

Converts an octal number to binary.

OCT2DEC (octal number) Converts an octal number to decimal.

OCT2HEX (octal number,

places)

Converts an octal number to hexadecimal.

Table 5.2- 8 Engineering Functions

5.2.3.9 Information Functions

Click theMore Functions icon in the Formulas tab, and choose the Information option in the drop-down

list. There are 16 information functions in Kingsoft Spreadsheets. See below:

Function Name Explanations

CELL (info_type, ref) Returns information about the formatting, location, or

contents of a cell.

ERROR.TYPE (error_val) Returns a number corresponding to the given error value,

or returns the #N/A if no error exists.

ISBLANK (value) Returns TRUE if a value refers to an empty cell, and

returns FALSE otherwise.

ISERR (value) Returns TRUE if the value is any error value except

#N/A, and returns FALSE otherwise.

ISERROR (value) Returns TRUE if the value is an error value and returns

FALSE otherwise.

ISEVEN (number) Returns TRUE if the number is even and returns FALSE

otherwise.

ISLOGICAL (value) Returns TRUE if the value is a logical value and returns

FALSE otherwise.

ISNA (value) Returns TRUE if the value is the #N/A error value and

returns FALSE otherwise.

ISNONTEXT (value) Returns TRUE if the value is not text and FALSE

otherwise.
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ISNUMBER (value) Returns TRUE if the value is a number and FALSE

otherwise.

ISODD (number) Returns TRUE if the number is odd and FALSE

otherwise.

ISREF (value) Returns TRUE if the value is a reference and FALSE

otherwise.

ISTEXT (value) Returns TRUE if the value is text and FALSE otherwise.

N (value) Returns a value converted to a number.

NA Returns the error value #N/A, an abbreviation of “value

not available”.

TYPE (value) Returns a number indicating the data type of a value.

Table 5.2- 9 Information Functions

5.3 AutoSum

Kingsoft Spreadsheets provides AutoSum (automatic summary) function. This makes it more convenient

and easy to calculate data in rows and columns. You can select calculation options in the AutoSum

drop-down list.

5.3.1 Sum of row(s)

The operation steps are as follows:

(1) Select the rows which you want to sum. See below:

Figure 5.2-6 Sum of a row
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(2) In the Formulas tab, click the AutoSum icon and select Sum in the AutoSum drop-down list.

Figure 5.2-7 The AutoSum drop-down list

(3) The result will be displayed in the cell to the right of the selected row. See below:

Figure 5.2-8 Display the result of AutoSum

5.3.2 Sum of Column(s)

The operation steps are as follows:

(1) Select the columns which you want to sum. See below:

Figure 5.2-9 Sum of a column

(2) In the Formulas tab, click the AutoSum icon and select Sum in the AutoSum drop-down list. See

Figure 5.2-7.

(3) The result will be displayed in the cell at the bottom of the selected row. See below:
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Figure 5.2-10 Display the result of AutoSum

5.4 Define Names

In the Kingsoft Spreadsheets, you can name a cell range. You can also name a formula or constant. A name

is a meaningful shorthand that makes it easier to understand the purpose of a cell range, formula or

constant, which may be difficult to comprehend at first glance.

The following is a list of syntax rules that you need to be aware of when creating and editing names.

 The first character of a name must be a letter or an underscore (_). Remaining characters in the name

can be letters, numbers, periods, and underscore characters.

 Names cannot be the same as the cell reference.

 Spaces are not allowed as part of a name. Use the underscore character(_) and period(.) as word

separators.

 A name can contain uppercase and lowercase letters. However, Kingsoft Spreadsheets does not

distinguish between uppercase and lowercase letters. For example, if you create the name “ABC”,

and then create another name “abc” in the same workbook, Kingsoft Spreadsheets will remind you to

choose a unique name.

5.4.1 Define Name

Defining the name for selected cells will make it easier to refer to the contents in the cell. To define a cell

name, follow the steps below:
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(1) Select the cells which you want to define.

(2) In the Formulas tab, click the Name Manager icon and the Define Name dialogue box will open and

show as below:

Figure 5.4-1 The Define Name dialogue box

(3) Input the name of the cells in the Names in workbook enter box, and then click Add on the right.

(4) Click OK to complete the operation.

5.4.2 Create Names

Cell range can be just a cell or multiple cells. These cells can be adjacent or non-adjacent. If you want to

define a cell range name, follow the steps below:

(1) In the Formula tab, click the Create icon and the Create Names dialogue box will open and show as

below:

Figure 5.4-2 The Create Names dialogue box

(2) You can create names in Top row, Left column, Bottom row and Right column.

(3) Click OK to complete the operation.

Tips: In this way, you can only name a single row or column separately.

5.4.3 Define Formula Name

The operation steps are as follows:

(1) In the Formulas tab, click the Name Manager icon and the Define Name dialogue box will open.

See Figure 5.4-1.
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(2) Input the name of formulas in the Names in workbook text box, click Add, and input the

corresponding formulas in the Refer to box.

(3) Press OK to complete the operation.

(4) If you want to delete the name of the cell, cell range or formula, you can select the corresponding

name in the list box and click Delete.

5.4.4 Paste Name

You can paste the name used in the current workbook as formula to the selected cells. Follow the steps

below:

(1) Define the name for the selected cell (follow the steps in 5.4-1).

(2) Select the cell where you want to paste the name you have defined.

(3) Click the Paste icon in the Formulas tab and the Paste Name dialogue box will open and show as

below:

Figure 5.4-3 The Paste Name dialogue box

(4) Select the name you have defined in the Paste Name list box.

(5) Click OK to complete the operation. The result is shown as below:

Figure 5.4-4 The Paste Name result
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5.5 Calculation

Calculation is the process of computing formulas in the worksheet and then displaying the results as values

in the cells which contain the formulas. By default, the spreadsheet will automatically compute formulas in

the workbook when you open it.

In Kingsoft Spreadsheets, there are plenty of ways to compute data such as Automatic Calculation,

Manual Recalculation and Iteration.

To avoid unnecessary calculations, Kingsoft Spreadsheets automatically recalculates formulas only when

the cells which contain the formulas change, or the structure of the spreadsheet changes.

5.5.1 Automatic Calculation

If you turn on the automatic calculation mode, when the cells which contain the formulas change, Kingsoft

Spreadsheets will recalculate formulas automatically.

The automatic calculation mode is turned on by default in Kingsoft Spreadsheet, but you can also

manually turn on this mode. Follow the steps below:

(1) Open the Application menu at the top left corner of the window and click Options at

the bottom.

(2) Choose the Recalculation tab in the Options dialogue box. See below:

Figure 5.5-1 Automatic Calculation

(3) Select the Automatic option button in the Calculation section.

(4) Click OK to complete the operation.
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5.5.2 Manual Recalculation

When there are complex circular references in a formula, you can turn on the manual calculation mode and

recalculate manually. The operation steps are shown as follows:

(1) Open the Application menu at the top left corner of the window and click Options at

the bottom.

(2) Choose the Recalculation tab in the Options dialogue box. See below:

Figure 5.5-2 Manual Calculation

(3) In the Calculation section, selectManual.

(4) Press OK and finish theManual Recalculation setting.

If you turn on the manual calculation mode, when the cells which contain the formulas change, Kingsoft

Spreadsheets won’t recalculate formulas automatically.

 If you need to calculate the current sheet, click the Calculate icon in the Formulas tab.

 If you need to calculate the entire workbook, click the Recalculate Workbook icon in the Formulas

tab.

5.5.3 Iteration

Kingsoft Spreadsheets provides an iteration calculation function. Iteration refers to repeated recalculation

of a worksheet until a specific numeric condition is met. When the number of times of recalculating
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exceeds the required number, or the results of two calculations meet some specified limit, the calculation

will end. To apply the iteration calculation function, follow the steps below:

(1) Open the Application menu at the top left corner of the window and click Options at

the bottom.

(2) Choose the Recalculation tab in the Options dialogue box. See below:

Figure 5.5-3 Iteration

(3) Select the Iteration check box.

 Enter the number of times of iteration, in theMaximum iterations spinner.

 Enter the error value, in theMaximum change spinner.

(4) Press OK to complete the operation.

6 Data Tab

6.1 Import Data

External data refers to data stored outside of Kingsoft Spreadsheets such as Access, dBASE, SQLServer,

and databases created on the Web service. You can click the Import Data icon in the Data tab to import

data from a majority of data sources into Kingsoft Spreadsheets. The two ways to get external data will be

demonstrated in the following part.
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6.1.1 Open data file directly

The first way is to get external data by opening data files directly, which is very easy. The operation steps

are shown as follows:

(1) Click the Import Data icon in the Data tab and the Select Data Source dialogue box will open and

show as below:

Figure 6.1-1 Select Data Source

(2) Select the Open data file directly check box, click the Select Data Source button, and the Open

dialogue box will appear where you can select the source data. Click the Open button to return to the

Select Data Source dialogue box.

(3) Click Next and The second step: Select table and fields dialogue box will open and show as below:

Figure 6.1-2 Select table and fields

(4) The usable fields will be listed in the Available fields list box. You can use the control button in the
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middle to add fields into the Selected fields list box on the right.

(5) Click Next and The third step: data filtering and sorting dialogue box will open and show as

below:

Figure 6.1—3 The third step: Data filtering and sorting

(6) You can choose sorting by field or in order. You can also set the filtering field, filtering condition and

filtering range in the filtering and sorting dialogue box. You can enter the query statement directly as well.

If you want to perform a more complicated sorting and filtering operation, you can click Advanced

Query.

(7) Click Next and The fourth step: Preview dialogue box will open and show as below:

Figure 6.1-4 The fourth step: preview dialogue box

You can preview the worksheet into which you’ve inserted external data in this dialogue box. If you are
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not satisfied with it, you can click Back to reset until you are satisfied.

(8) Click OK to complete the operation.

6.1.2 Use ODBC data source connection guide

The second way is to use the ODBC data source connection guide. The operation steps are shown as

follows:

(1) Click the Import Data icon in the Data tab and the Select Data Source dialogue box will open and

show as below:

Figure 6.1-5 Import Data

(2) Select the Use ODBC data source connection guide option button and the Data Link Properties

dialogue box will open and show as below:
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Figure 6.1-6 Data Link Properties

(3) In the Select the data you want to connect to list box, select the preferred data and click Next to go to

the Connection tab:

Figure 6.1-7 Data link properties

(4) In the 1. Specify the source of data section, select Use data source name and you can click the data

source name you want. Then type the location of the data in the 3. Enter the initial catalog to use section.

(5) Press OK to complete the operation.

6.1.3 Edit OLE DB Query

After you have imported external data into Kingsoft Spreadsheets, you can perform simple queries by

using the SQL language. Click Edit Query in the Import Data dialogue box. See below:

Figure 6.1-8 Edit Query

The Edit OLE DB Query dialogue box will open where you can preform simple queries. See below:
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Figure 6.1-9 Edit OLE DB Query

6.1.4 External Data Range Properties

You can define the Name, Data formatting and layout, and If the number of rows in the data range

changes upon refresh of external data source. Click Properties in Figure 6.1-8. The External Data

Range Properties dialogue box will open where you can carry out the aforesaid operations. See below:

Figure 6.1-10 External Data Range Properties

6.1.5 Refresh Data and Refresh All

Refresh Data and Refresh All are designed to refresh data imported from external data source.

Click the Refresh All icon in the Data tab to open the drop-down list. There are two options offered:

Refresh Data: refresh data that you have selected.

Refresh All: refresh all the data you have imported.

6.2 Text to Columns

Kingsoft Spreadsheets provides a Text to Columns function. It plays an important role in importing text

data and performing data storage format conversion. For example, import long digital data and fast data

format conversion. To use this function, follow the steps below:

(1) Create a blank worksheet. Copy text data from files, such as *.txt and *.csv, and paste it in the A1 cell.
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See below:

Figure 6.2-1 Paste the text data

(2) Select column A and click the Text to Columns icon in the Data tab.

(3) In the Convert Text to Columns Wizard - Step 1 of 3 dialogue box, you can select a suitable file

type according to the basic characteristics of the file. In this example we select Delimited. Shown as

below:

Figure 6.2-2 Convert Text to Columns Wizard

(4) Click Next.

(5) You will see the Convert Text to Columns Wizard - Step 2 of 3 dialogue box, where you can choose

further options. Click the Space check box in the Delimiters section. Other settings are all by default. See

below:
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Figure 6.2-3 Delimiters

(6) Click Next. In the Convert Text to Columns Wizard - Step 3 of 3 dialogue box, you can set the data

format of every column. See below:

Figure 6.2-4 Set column data format

(7) Click Finish to complete the operation. The result is shown as below:

Figure 6.2-5 The effect of Convert Text to Columns
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6.3 Duplicates

The Duplicates function provided by Kingsoft Spreadsheets will help you display data that is duplicated in

a single row or a single column. It will display a warning when you input duplicated data in a single row

or column. In addition, it can delete the unwanted duplicated data directly and keep the original data. The

operation steps are shown as follows:

Click the Duplicates icon in the Data tab. We can see there are three options in the drop-down list, namely

Highlight Duplicates, Reject Insert Duplicates and Remove Duplicates.

 Highlight Duplicates: Select one row or one column and choose Highlight Duplicates in the

Duplicates drop-down list. The Highlight Duplicate dialogue box will open to ask your permission

to highlight the cells which contain duplicate contents in orange. Then if there is duplicated data in

the row or column, the corresponding cells will be highlighted.

 Reject Duplicate Entries: Select one row or one column and choose Reject Duplicate Entries in the

Duplicates drop-down list. After selecting it, whenever you insert duplicate data into the row or

column, Kingsoft Spreadsheets will automatically display warning information to remind you that the

row or column already contains this data. Then you can choose whether or not to insert the data.

 Remove Duplicates: Select one row or one column and choose Remove Duplicates in the

Duplicates drop-down list. The Duplicated data in the row or column will be removed and only one

will be kept.

6.4 Validation

In order to ensure the accuracy and normative of the input data, Kingsoft Spreadsheets provides the

validation function to check data and prevent input error. This function can make your work more efficient.

The operation steps are shown as follows:

(1) Select the cell or cell range which you want to validate.

(2) Click the Validation icon in the Data tab. Then the Data Validation dialogue box will open and show

as below:
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Figure 6.4-1 Set the Data Validation

 You can set the Validation criteria in the Settings tab.

 You can set the display information when you select the cell in the Input Message tab. See below:

Figure 6.4-3 Set the input message

 You can set the warning information when you input invalid data in the ErrorAlert tab.

(3) Press OK to complete the operation. The effect is shown below:

Figure 6.4-3 The effect after setting
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6.5 Consolidate

By the consolidation function, data in the cells stored in several worksheets will be combined into one

place, helping the user to analyze and manage it more conveniently. For example, a company makes a

census about the total sales in 2012 and 2013 and creates a statistics forecast of sales for each year

separately, but you want to combine them together in one worksheet. Here you can use the consolidation

function.

Here are some terms in the consolidation function:

 Goal Sheet: The sheet which stores the consolidated result.

 Goal Range: The range which receives the consolidated data.

 Original Sheets: The sheets which have been consolidated.

 Original Ranges: The ranges which have been consolidated.

Kingsoft Spreadsheets provides two methods to consolidate: by position and by category.

6.5.1Consolidate by Position

When you want to consolidate data by position, make sure that each range of data has the same layout.

That means each range of data to be consolidated must be in the corresponding position on each separate

worksheet. For example, in the example workbook, the first two worksheets are 2012 Data and 2013 Data.

We want to consolidate data in the first two worksheets and put the result in the Total Sales worksheet.

The operation steps are as follows:

(1) Click the 2012 Data worksheet tab, and input the data. Shown as follows:



Spreadsheets 2013 User Manual

157

Figure 6.5-1 2012 Data worksheet

(2) Click the 2013 Data worksheet tab, and input the data. Shown as follows:

Figure 6.5-2 2013 Data worksheet

(3) Click the Total Sales worksheet tab, and input row and column labels. Shown as follows:

Figure 6.5-3 Total Sales worksheet

(4) Choose the Total Sales worksheet as the target worksheet. And select B3:D9 as the target range of

data.

(5) Click the Consolidate icon in the Data tab. The Consolidate dialogue box will open and show as

below:
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Figure 6.5-4 The Consolidate dialogue box

 In the Function box, click SUM or the function that you want Kingsoft Spreadsheets to use to

consolidate the data.

 Enter the range path in the Reference box. Or click the source worksheet and select the range of data

to be consolidated. Then the range path of the original data will be displayed automatically in the

Reference box. Click the 2012 Data tab, and select B3:D9 as the source range. Shown as follows:

Figure 6.5-5 Add the 2012 Data cells area

(6) Click Add. Then the range will be added in the All References box.

(7) Repeat the steps mentioned above. Add the range of B3:D9 in 2013 Data in the All References box.

Shown as follows:
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Figure 6.5-6 Add the 2013 Data cells area

(8) Press OK. Then the result of consolidation will be displayed in the target worksheet. See below:

Figure 6.5-7 The result of Consolidation

6.5.2Consolidate by Category

If the ranges of data to be consolidated don’t have the same layout, you can use the consolidation by

category feature instead of consolidation by position. For example, as you can see in Figure 6.5-1 and

6.5-2, the scores are different in 2012 and 2013.

To consolidate the two worksheets by category, follow the steps below:

(1) Open the Total Sales worksheet tab and enter the title. See below:

Figure 6.5-8 Total Sales worksheet

(2) Select cell A2 and click the Consolidate icon in the Data tab. Then the Consolidate dialogue box will

open.

(3) In the Function box, select SUM or the function that you want Kingsoft Spreadsheets to use to
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consolidate the data.

(4) Select cell ranges as we mentioned above. In the 2012 Data worksheet, the selected source range is A2:

D9. In the 2013 Data worksheet, the selected source range is A2: D9. Select Top row and Left column

check boxes in the Use Labels section. See below:

Figure 6.5-9 The Consolidate dialogue box

(5) Press OK to complete the operation. Then the result of consolidation will be displayed in the target

worksheet. See below:

Figure 6.5-10 The result of consolidation

6.6 Group

(1) Select the range of data where you want to create a group.

(2) Click the Group icon in the Data tab and the Group dialogue box will open and show as below:
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Figure 6.6-1 The Group dialogue box

(3) Select either Rows or Columns option button that you want to group by.

(4) Click OK to complete the operation.

If you want to ungroup the range, do as follows: In the Data tab, open the Ungroup drop-down list and

select Clear Outline.

6.7 Subtotal

To use the subtotal function, follow the steps below:

(1) You need to sort the fields that you want to subtotal first so that the fields with the same keyword will

gather together. Shown as follows:

Figure 6.7-1 Sort by GOODS

(2) Click the Subtotal icon in the Data tab and the Subtotal dialogue box will pop up.

(3) In the At each change in drop-down list, select the field you want to subtotal.

(4) Select the function you need in the Use function drop-down list in the Subtotal dialogue box.

Figure 6.7-2 The Subtotal dialogue box

(5) In the Add subtotal to dialogue box, select the field you want to subtotal.

(6) Select corresponding check box according to your needs to specify the subtotal conditions.

 Replace current subtotals:subtotal according to current sorting.
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 Page break between groups: each group should be displayed on separate page.

 Summary below data: put the subtotal result at the end of each group.

(7) Press OK. Then you can get the subtotal result. See below:

Figure 6.7-3 The result of Subtotal

6.8 Show Detail and Hide Detail

If you can’t see the outline symbols in Kingsoft Spreadsheets, you can click Group in the Data tab. After

creating a group, you can perform the following operations:

 If you want to show detail in a group, click the Show Detail icon in the Data tab.

 If you want to hide detail in a group, click the Hide Detail icon in the Data tab.

Tips: you can also click the Show Detail icon and Hide Detail icon on the right side of the

worksheet.

6.9 Form

Kingsoft Spreadsheets provides a data form function for you to add, delete, and find a series of data more

easily in the worksheet.

To use the form data function, follow the steps below:

(1) Select the title of the column in the worksheet and click the Form icon in the Data tab. The Form

Data dialogue box will open with the worksheet title as its name. See below:
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Figure 6.9-1 The Form function

(2) The data in each row will be displayed together and in separate categories on the left side of the

dialogue box.

(3) You can click the New button at the right side to add new data in the worksheet.

(4) You can click the Delete button to remove the current displayed data from the worksheet.

(5) You can view previous or next row of data by clicking the Find Prev and Find Next button.

(6) You can click Criteria to set the criteria.

(7) Click Close to exit the dialogue box.

6.10 What-If Analysis

Kingsoft Spreadsheets provides the what-if analysis function, which includes Goal Seek and Solver

Parameters.

6.10.1 Goal Seek

Kingsoft Spreadsheets provides the Goal Seek function to obtain the value in the changing cell when a

result value is assumed for a formula. For example, an employee has already known the product sales price

is $80 and the product cost is $50, and he wants to know how much is the product sales when the expected

total profit reaches $15000.

To use this function, follow the steps below:

(1) Create a worksheet containing the product sales information. The value in B3 is unknown and no need

to enter data in it. Enter the formula “= (B1-B2)*B3” in B4.

(2) Click the What-If Analysis icon in the Data tab and choose Goal Seek in the drop-down list. The

Goal Seek dialogue box will open and show as below:
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Figure 6.10-1 The Goal Seek dialogue box

(3) Select cell B4 in the Set cell section, enter 15000 in the To value enter box, and select B3 in the By

changing cell section.

(4) Click OK to complete the operation. You can see the result as shown below:

Figure 6.10-2 Goal Seek Status

(5) Click OK to preserve the result.

6.10.2 Solver Parameters

Simply speaking, Solver Parameters can help you forecast the problem which contains more than one

variable. For example, the shopkeeper wants to know which kinds of pens he should sell and the potential

revenue. Assuming that there are three kinds of pens, namely gel pen, pen, and ball pen, and their prices

are $1, $2, and $2.5.

To use this function, follow the steps below:

(1) Create a worksheet containing the product sales information. See below:

Figure 6.10-3 Worksheet containing the information
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(2) The target cell, here G4, is achieved by adding the three variable cells, namely D6, D10, D14.

Whereas the value in the three variable cells are achieved by multiply the price with the volume of sales of

each kinds of pen separately. The constrains area contains limiting conditions. You can list them down to

help you organize your thoughts.

(3) In the Data tab, select the Solver Parameters in the What-If Analysis drop-down list. The Solver

Parameters dialogue box will open and show as below:

Figure 6.10-4 Set the Solver Parameters dialogue box

(4) Select the target cell in the Set Objective section. Here we choose cell G4.

(5) ChooseMax in the To section to get the possible maximum revenue.

(6) Select the changing cells in the By Changing Variable Cells section. He we select cell D5, D9, and

D13.

(7) Click Add to add constraints. The Add Constraint dialogue box will open and show as below:

Figure 6.10-5 The Add Constraint dialogue box

(8) The three constrains in Figure 6.10-4 means that first, the total sales volume should be less than or

equal to the maximum sales volume of all pens, here 500; second, the sales volume of pen and ball pen

should be less than or equal to the maximum sales volume of pen and ball pen, here 350; third, the sales

volume of ball pen should be less than or equal to the maximum sales volume of ball pen, here 125.

(9) Choose the Simplex LP option as the solving method.
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(10) Click Solve to complete the operation.

(11) Click OK to solve the results. See below:

Figure 6.10-6 The Solver Results dialogue box

The solver results will be like below:

Figure 6.10-7 The results of solver parameters

You can see the possible maximum revenue is $ 912.5. At this point, the shopkeeper have to sell 150 gel

pen, 225 pen, and 125 ball pen.

7 Table Style Tab

Kingsoft Spreadsheets provides the Table Style tab for you to set the style for the table. See below:

Figure 7-1 The Table Style tab

By selecting or deselecting the six check boxes at the left side of the Table Style tab (see the figure above),

you can emphasize or normalize the First Row, Last Row, Banded Rows, Banded Columns, First
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Column, and Last Column of the table.

To use the theme style in the current worksheet, follow the steps below:

(1) Selected the cells where you want to use the theme style.

(2) Click the arrow at the right side of the theme style list box to open the drop-down list. See below:

(3) Click the preferred theme style in the drop-down list and it will be applied to the selected cells.

(4) Click the Clear Table Style icon at the end of the Table Style tab to clear the style for the table.

8 Review Tab

8.1Check Spelling

Kingsoft Spreadsheets provides a Check Spelling function to proofread the text in the worksheet according

to the values you have set and the dictionaries which you have choose as the check spelling criteria.

To spell check the worksheet, follow the steps below:

(1) Open the worksheet which you want to spell check.

(2) Click the Check Spelling icon in the Review tab, or select the Check Spelling option in the

drop-down list. See below:

Figure 8.1-1 The Check Spelling drop-down list
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(3) Then Kingsoft Spreadsheets will automatically spell check the worksheet and remind you when the

spell check has been completed. See below:

Figure 8.1-2 Complete the check spelling

You can also set language for the spell check, follow the steps below:

(1) Choose the Set Language option in the Check Spelling drop-down list. See Figure 8.1-1.

(2) The Set Language dialogue box will open and show as below:

Figure 8.1-3 The Set Language dialogue box

(3) Choose the preferred language in the Available Languages list box.

(4) You can click Set as Default to set the chosen language as the default language for spell check.

(5) Click Close to complete the operation.

To set the dictionaries for check spelling, follow the steps below:

(1) Open the application menu at the top left corner of the screen. Click Options at the

right bottom.

(2) Open the Spelling tab in the Options dialogue box. See below:
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Figure 8.1-4 The Spelling tab

(3) In the Spelling section, you can select Always suggest corrections, Ignore words in uppercase, and

Ignore words with numbers check box according to your needs.

(4) In the Customize dictionaries section, you can add new words or delete words in the current

dictionary by theModify button.

(5) Click the New button to select the new custom dictionary in the corresponding dialogue box.

(6) Click the Add button to add dictionary files.

(7) Click the Remove button and choose to remove the selected dictionary either from list or from disk.

(8) You can set the selected dictionary as default by the Set as Default button.

(9) Click OK to complete the operation.

8.2 Comment

Just like Kingsoft Writer, Kingsoft Spreadsheets allows you to insert comments as well. This function

makes it very convenient for you to do business without papers.

In Kingsoft Spreadsheets, you can insert comments when you want to illustrate the cell(s). After adding a

comment, there will be a little red triangle shown at the top right corner of the cell. The content will appear

automatically when you move the mouse to the cell.

8.2.1 Create Comment

If you want to set up a reminder for a cell or a cell range, you can add comments. The steps are shown as

follows:
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(1) Select the cell or cell range to which you want to add comment.

(2) Click the New Comment icon in the Review tab. Or right-click and select Insert Comment in the

context menu.

(3) Input the content of comment in the Comment dialogue box.

(4) After inputting the comment, press OK to complete the operation.

8.2.2 Edit Comment

You can edit comments that you have created in the Kingsoft Spreadsheets. The operation steps are as

follows:

(1) Select the cell or cell range you want to edit comment.

(2) Click the Edit Comment icon in the Review tab. Or right-click and choose Edit Comment in the

context menu.

(3) Then the Comment dialogue box will pop up where you can edit the comment.

(4) After editing the comment, press OK to complete the operation.

8.2.3 Delete Comment

In Kingsoft Spreadsheets, you can either delete the comment of a single cell or delete all the comments in

the worksheet simultaneously. The operation steps are as follows:

(1) To delete the comment, you need to select it first.

(2) Click the Delete icon in the Review tab. When the little red triangle disappears, it means the comment

has been deleted.

If you want to delete all the comments in the worksheet, follow the steps below:

(1) Press <Ctrl+A> to select all the comments.

(2) Open the Home tab and click the Format icon.

(3) Choose Comments in the Clear drop-down list. Then you can delete all the comments.

8.3 Lock Cell

There are three ways to protect a specified cell:

 Click the Lock Cell icon in the Review tab.
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 Press <Ctrl+A> to select the whole worksheet. In the Home tab, click the Format icon and select

Lock Cell in the Format drop-down list.

 Select the whole worksheet, right-click and select Format Cells in the context menu. In the Format

Cells dialogue box, open the Protection tab and select or deselect the Locked check box. Then you

can lock the cells or unlock the cells.

Tips: The worksheet protection only works on locked cells.

8.4 Protect sheet

In order to protect your data, Kingsoft Spreadsheets allows you to set a password for the worksheet or

workbook by which you can prevent unauthorized users to modify the worksheet or workbook.

You can protect a worksheet by the Protect Sheet function provided by Kingsoft Spreadsheets. Moreover,

you can protect cell range, decide cell ranges can be filled or not, and lock the corresponding content to

avoid covering important data when filling.

This function can be used to make tables which need to be filled, or protect important data from being

modified. The operation steps are shown as follows:

(1) Click the Protect Sheet icon in the Review tab. The Protect Sheet dialogue box will open and show as

below:

Figure 8.4-1 The Protect Sheet dialogue box

(2) By default, only Select locked cells and Select unlocked cells are checked. If you want some other

protection, such as Format cells, you can select the check box to activate it.

(3) Enter the password in the Password input box.

(4) Click OK to complete the operation.



Spreadsheets 2013 User Manual

172

Tips: This protection for worksheet only works on locked cells. After setting the protection, all you have

to do is to save the file and the setting will go into effect.

If you want to cancel the worksheet protection, click Unprotect Sheet in the Review tab. Or you can try

the other way: Select Unprotect Sheet in the Format drop-down list in the Home tab.

Enter the password you have set and the entire worksheet will be as it was before you locked it.

8.5 Protect Workbook

Workbook protection can prevent altering the structure of the workbook, which includes deleting, moving,

hiding, unhiding, and renaming the worksheet. You cannot insert a new worksheet or move and adjust the

window either when the workbook has been protected.

The operation steps are shown as follows:

(1) Select the workbook you want to protect.

(2) Click Protect Workbook in the Review tab. Then the Protect Workbook dialogue box will open and

shown as below:

Figure 8.5-1 The Protect Workbook dialogue box

(3) Input the password, and then press OK.

(4) If you want to remove the protection on a workbook, click the Unprotect Workbook icon in the

Review tab, and then input the password to cancel the protection.

8.6 Share Workbook

If you want multiple users to edit a workbook at the same time, you can share your workbook, which

means to put the workbook under a shared directory—a web server for example. Then others can access

the shared workbook through the Internet. This feature makes it more effective and easier for multiple

users to edit a workbook simultaneously. The operation steps are as follows:

(1) Select the workbook you want to share.

(2) Click the Share Workbook icon in the Review tab. The Share Workbook dialogue box pops up.



Spreadsheets 2013 User Manual

173

Figure 8.6-1 Set for sharing workbook

(3) Click the check box in front of Allow changes by more than one user at the same time. This also

allows workbook merging.

(4) Click OK and the Save As dialogue box will open. Choose Kingsoft Spreadsheets Files(*.et) as the

Save as Type. Input the File Name and press Save to complete the operation.

(5) After sharing the workbook, the file name on the title bar will be added with “(shared)”.

(6) After sharing the workbook, you can protect or unprotect it by clicking the Protect Shared

Workbook and Unprotect SharedWorkbook icon in the Review tab.

Tips: If you created a new file, before you can confirm to share it, the system will warn you to save it first.

After you have saved the file, it will be shared automatically.

8.7 Protect and Share Workbook

If the workbook has already been shared and you wish to protect the sharing of track changes by entering a

password, the steps are shown as follows:

(1) Select the workbook you want to protect.

(2) Click Protect and Share Workbook in the Review tab. Then the Protect and Share Workbook

dialogue box will open and show as below:
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Figure 8.7-1 Protect and Share Workbook dialogue box

(3) Enter the Password and press OK to complete the operation.

8.8 Allow Users to Edit Ranges

Sometimes you may want others to make changes only to part of the data in the worksheet, but keep the

rest of it locked. To achieve this, follow the steps below:

(1) Click the Allow Users to Edit Ranges icon in the Review tab. The Allow Users to Edit Ranges

dialogue box will open and show as below:

Figure 8.8-1 Allow Users to Edit Ranges

(2) Click New.

(3) In the New Range dialogue box, set the title in the Title enter box, select the cell range you wish to

allow others to edit in the Refer to cells section and enter the range password in the Range Password

section.
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Figure 8.8-2 New Range dialogue box

(4) Click OK to return to the Allow Users to Edit Ranges dialogue box.

(5) Click the Protect Sheet button in the lower left corner of the dialogue box.

(6) Reenter the range password you have set in step 3 twice to protect the selected range.

(7) Now the selected range has been protected and users have to enter the password to make changes to it.

8.9 Track Changes

You can use the Track Changes function if you want to track the changes made in your worksheet. Each

reviewer who inserts or deletes data will be recorded when the Track Changes function is turned on.

Kingsoft Spreadsheets provides the Highlight Changes function in order to distinguish changes made by

different users. So when you open the worksheet, you can see all of the changes at once. The operation

steps are shown as follows:

(1) Click the Track Changes icon in the Review tab to open the drop-down list and select the Highlight

Changes option. The Highlight Changes dialogue box will open and show as below:

Figure 8.9-1 The Highlight Changes dialogue box

(2) Select the Show track changes description check box and set criteria for changes, namely When,

Who, andWhere in the Highlight which changes section.

(3) Press OK to complete the operation.

(4) Then you can make changes in the worksheet, and press Enter to finish. You will notice that the data

that has been changed will be marked up.

Tips: The Track Changes function can only be used in the shared workbook.
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9View Tab

9.1 View Mode

Kingsoft Spreadsheets provides five different workbook view modes: Normal, Print Layout, Page Break

Preview, Full Screen, and Reading Layout. You can select different view mode to suit your needs.

9.1.1 Normal

Normal view is the default view of Kingsoft Spreadsheets. You can edit the content, format, and layout

directly in the normal view. If currently you are not in the normal view, you can return to it by clicking the

Normal View icon in the View tab.

9.1.2 Print Layout

In the Print Layout mode, you can check the appearance of printed tables. You can check the start

position, end position of the documents, and the header and footer on the page.

There are two ways to open the Print Preview tab in Kingsoft Spreadsheets:

 Click the Print Layout icon in the quick access tool bar and the Print Preview tab will open

where you can preview files before printing.

 You can also choose the Print Preview option in the Application menu in the top

left corner to enter the Print Preview interface. Shown as follows:

Figure 9.1-1 The Print Preview tab

You can perform the following operations by the Print Preview tab.

 Print: Click to set the print properties and get the file(s) printed.

 Next Page and Previous Page: If a worksheet contains more than one page of data, you can click this

two icons to preview the next or previous page.

 Zoom: Select the preferred zoom size of the current worksheet in the Zoom drop-down list.

 Page Break Preview: Switch to the page break preview mode.
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 Normal: Switch to the normal view mode.

 Portrait and Landscape: Click the corresponding icon to set the pages to portrait or landscape.

 Header and Footer: edit the header and footer of the document.

 Page Setup: open the Page Setup dialogue box and set the corresponding values there.

 Margins: specify the distance between the contents of the worksheet and the edges of the printed

page.

 Close: close the Print Preview tab.

9.1.3 Page Break Preview

If you are working in a long document and want to break it into many pages, you can insert a page break in

the worksheet. After the insertion, you can preview the worksheet in the page break preview mode.

There are two ways to insert a page break: automatic and manual.

9.1.3.1 Automatic Page Break

In the Page Setup dialogue box (see 4.1.6 and 4.1.7 ), select the Page tab to set suitable paper size for

printing. If you set values in the Adjust to section, the system will ignore all the page breaks you have

manually set. After setting the values in Adjust to section, click the Page Break Preview icon in the View

tab and the worksheet will automatically be separated into pages you have set.

For example, set Adjust to two-page width and one-page tall, click Page Break Preview in the View tab,

and the worksheet will be separated into two pages automatically. Shown as below:

Figure 9.1-2 Workbook divided into two pages

You can drag the horizontal page break line and vertical page break line to adjust the size of the entire

page.
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9.1.3.2 Manual Page Break

If you don’t set values in the Adjust to section of the Page tab, the worksheet will be separated into

several pages according to your specified width when you click Page Break Preview in the View tab. At

this moment, you can put the pointer on the horizontal or vertical page break line. See below:

Figure 9.1-3 Point to the vertical page break line

By dragging the mouse, you can move the horizontal and vertical page break line freely, and you can

enlarge the width of separated pages and increase the number of separated pages by doing that.

9.1.4 Full Screen

Click the Full Screen icon in the View tab, the worksheet will be displayed in full screen with all the tool

bars hided. Click the Close button at the top right corner of the screen, or press <Esc> on the keyboard to

exit the full screen mode.

9.1.5 Reading Layout

We often have to deal with spreadsheets with a large number of rows and columns. It is inevitable that

lines and columns will be misread when we check for formulas or data. As for this, Kingsoft Spreadsheets

provides Reading Layout which makes it easier to check the data.

To use the reading layout mode, follow the steps below:

(1) Click the Reading Layout icon in the View tab to enter into the Reading Layout mode. See below:
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Figure 9.1-4 View the data in the Reading Layout mode

(2) Click a cell (or cell range) and Kingsoft Spreadsheets will highlight the line and column of the current

cell.

(3) The default color for this mode is a light yellow as shown above and you can choose the preferred

color in the Reading Layout drop-down list. See below:

Figure 9.1-5 Choose color for the Reading Layout mode

(4) You can re-click Reading Layout in the View tab to exit the Reading Layout mode. Then you can get

back to the normal view.

In addition, reading layout belongs to documents level. If you open a number of documents at the same

time, all the documents need to enter in the reading layout mode to set or cancel the setting.

9.2 View Check Boxes

There are six check boxes listed in the View tab by which you can hide or display certain items in the

worksheet. See below:

Figure 9.2-1 Check boxes in the View tab
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The function of these check boxes are shown as follows:

 Formula Bar: Select or deselect this check box to show or hide the formula bar in the worksheet.

 View Gridlines: Select or deselect this check box to show or hide the gridlines in the worksheet.

 View Headings: Select or deselect this check box to show or hide the row and column headings in

the worksheet.

 Task Window: Select or deselect this check box to show or hide the task window at the right side of

the worksheet.

 Print Gridlines: Select this check box to print gridlines in the worksheet.

 Print Headings: Select this check box to print the row and column headings in the worksheet.

9.3 Zoom

To specify the zoom size of the worksheet, follow the steps below:

(1) Click the Zoom icon in the View tab. The Zoom dialogue box will open and show as below:

Figure 9.3-1 The Zoom dialogue box

(2) Choose the preferred proportion in theMagnification section.

(3) You can choose the Fit Selection option to let Kingsoft Spreadsheets automatically choose for you.

(4) You can also enter the proportion in the Custom enter box.

(5) Click OK to complete the operation.

9.4 Freeze

Usually, we edit a large number of rows and columns in Spreadsheets. But when scrolling, it is

inconvenient to keep the row or column label shown all the time. Sometimes we need to check the labels

for the data in some rows or columns. We don’t want the row or column to move, for which it is very
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helpful to freeze the window.

The steps to freeze the window are shown as follows:

(1) In the worksheet, select the leftmost cell of the cell range you want to freeze.

Figure 9.4-1 Select the cell

(2) Click the Freeze icon in the View tab.

(3) There will be a line above the selected cell range. Drag the scroll bar and the rows and columns in the

frozen range won’t scroll. The frozen range is always in the top and left-most position. See below:

Figure 9.4-2 Effect after freezing the window

(4) Click Unfreeze in the View tab and you can unfreeze the window.

9.5 Window Functions

Kingsoft Spreadsheets provides six window functions in the View tab. See below:

Figure 9.5-1 Window functions in the View tab

The window functions are shown as follows:
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 NewWindow: To open a new window containing the contents of the current worksheet.

 Arrange All: When there are more than two opened worksheets, you can view them horizontally,

vertically, or in cascade by choosing the corresponding option in the drop-down list. Double click the

window head to return to the normal view mode.

 Split: To split worksheet to multiple re-sizable panes containing views of the current worksheet.

Click this icon again to cancel the operation.

 Switch Windows: To switch to the desired window by this icon.

 Close Other Windows: To close other unused windows by this icon.

 Close Window: To close the current window.

10 Developer Tab

10.1 Macros

To set macros in Kingsoft Spreadsheets, follow the steps below:

(1) Click the Macros icon in the Developer tab, or in the View tab. The Macros dialogue box will open

and show as below:

Figure 10.1-1 The Macros dialogue box

(2) Enter the macro name in theMacro name enter box.

(3) Select the range you want to apply the macro in theMacro in drop-down list.

(4) Add description for this macro in the Description enter box.

The functions of the buttons at the right side are shown as follows:

 Run: Click to run the current macro.
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 Edit: Click to edit the macro in Microsoft Visual Basic.

 Delete: Click to delete the macro.

 Options: Click to add shortcut key for the macro.

(5) Click Cancel to exit.

10.2 Security

In Kingsoft Spreadsheets, you can set security level for the macros, follow the steps below:

(1) Click the Security icon in the Developer tab. The Security dialogue box will open and show as below:

Figure 10.2-1 The Security Level tab

(2) In the Security Level tab, choose Very High, High,Medium, and Low according to your needs.

(3) Click OK to complete the operation.

10.3 Other Functions

 Visual Basic Editor: Click to open the Visual Basic Editor and edit the macros there.

 Add-Ins: Manage the Add-Ins available in this file.

 COMAdd-Ins: Manage the COMAdd-Ins available in this file.

 Design Mode: Enter design mode to edit control’s name and functions.

 Control Properties: View and modify properties for the selected control.

 View Code: View and modify the code for the selected control in the Visual Basic Editor.

To add objects in the worksheet, you can click the corresponding icon in the Developer tab. See below:
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Figure 10.3-1 Add objects icons

You can add check box, text box, command button, option button, list box, combo box, toggle button, spin

button, scroll bar, label, image, and more controls in the worksheet by the corresponding icon.

When the cursor turn into a cross, hold and drag it to insert the object in the worksheet. After the object

was drawn, double click it to edit it in the Microsoft Visual Basic.
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