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• What is geocoding?

• Components in the geocoding
process

• General process of geocoding

• How to use this book
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How the Geocoding Rule Base Developer Guide
can help you
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What is geocoding?
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Components in the geocoding process
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General process of geocoding
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The standardization process
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Reference File Attribute Table

Address Items
ESRI's
geocoding
applications

Data Dictionary and Match
Rules (<file>.mat)

Match Variables

MatchWare
Engine

Matching Process
Compare to determine match or unmatch

Match Key Fields

Standardization Process:
Commands (<process.stn>)
Match Key Definitions
Keyword Classification
(<process.cls>)
Patterns and Actions
(<process.pat>)

Address Event

Address Field

Relationship between MatchRules and StanRules (standardization process)
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Overview of the match file
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��


7>�.&)�89>'-�&O7����(����������������0

Match key field

�������F������������������0�����	��
�	�����	�������������	���
�����������D1	��E�����1

Reference file variable name

����(���� ���������
�	�����	��������)�&�������	1

m probability

��������� � ����0��
�������� � ����0��������������	������
@���(��
���������	�������
���������D��������
���������������������������	�����
������	������	E1

u probability

��������� � ����0��
�������� � ����0��������������	������
���
���	��1

6�������������������������������	������ � ������
@�
�������B����	
����� � ������
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�������������
��������1

Additional parameters
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���
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��������������
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�������� � �0�����
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�������� � �0�	��������

:$$���	�����
��������������
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���������
����������0�	��������

Mode

������	���
���C����	������0��
�397>�J

A.&'9)�873

A.&'9>588

MATCH commands



THE MATCH FILE 17

.7��.&
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��0���������� ��������������������������	1
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����	��
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A.&'9>588���	�����
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���(��������������
�����(��1

.7��.&��
���C����	������0��
�8&9���&���	�8&95>�.&�1�7�
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�	�1���
�;���������.7��.&��
�
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� ����1

����������	������	������������������ !"� ! #

  ! ��$����

�������	������	�������	
��� !"� ! #�
  ! 

�����������%&�%��&��� !�� !#

�����������%��%���'��� !
� !#

���������������(���)&��� !�*� !#

������&�$	���	�+�,�������,�����+�,��������,�����
 !"""� ! *����-����$&
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VARTYPE commands

����"�
#&'(	�������	����
�����������%�����������	
���
��������������1�����)�&�,-.�������	���	�����
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1

Format

������������������)�&�,-.�������	
�
����	� ���
�������
J

)�&�,-.

P������(���� �������Q

P������Q

�����

P������Q�JJL

>'6&.W�D��	�����
������������C����0�����0
�
�
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��������	E
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J

����������	������	������������������ !"� ! #
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��� !"� ! #�
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�����������%&�%��&��� !�� !#

�����������%��%���'��� !
� !#

���������������(���)&��� !�*� !#

������&�$	���	�+�,�������,�����+�,��������,�����
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���������)�&�,-.�������	�����
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��������	������������������1
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m and u probabilities
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Matching weights

'����0�����(���
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1�7���
�������������
�������"������
����
�
�������������������0�������	����	�	���
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���)�����1;1�����(��@�.=&7?
������������	�������	���
@�
�����

%��' 2���
@����7%=@���	�����7=@��������"������
��������������01
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�������������������	����	�	�����
�����������	������������
���$X#$$� �
�	���������������	���;�����
����1

Candidates Composite Score

101 199 N MAIN ST
  +   + +     +  +

101 199 MAIN ST
  +   + -     +  +

101 199 N MAIN AVE
  +   + +     +    -

101 199 MAIN
  +   + -     +  -

100

60

85

90

This table shows examples of candidate scoring based on the event
123 N MAIN ST. The higher the score, the better the match.

Examples of candidate scoring
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Modifying the
.mat file
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Adjusting the weight of
the StreetName element

1. Open the us_addr1.mat file in
the geocode folder in a text
editor, such as Notepad.

The .mat file will display. �

�

The .mat file is displayed.
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�2. Change the m probability of
the StreetName to 0.8. This
reduces how much the
m probability adds to the
score, thus reducing the
weight of the
StreetName element.

3. Click the File menu and click
Save.

Tip

MatchRule syntax checker
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�
���������������������������
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Overview of the command file

����������	������
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RECORD <record-size>
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TYPE <file-type>
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{OUTFILE <output-file>}
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{<Parsing parameters> }
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Parsing parameters
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Adjusting parsing
parameters
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1. Navigate to the .stn file you
wish to modify.

2. Right-click the file, point to
Send To, and click Notepad
or another standard text
editor.

3. After the STANDARDIZE
command in the .stn file, add
the parsing parameters.

4. Click the File menu and click
Save.

�
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Adding the
DEBUG and
OUTFILE
keywords to the
us_addr.stn file
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1. Navigate to the us_addr.stn
file in Windows Explorer.
Right-click the file, point to
Send To, and click Notepad.

The us_addr.stn file displays.

2. Add the DEBUG and
OUTFILE keywords to the file.

3. Click the File menu and click
Save.

The us_addr.stn file is displayed.
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The match key dictionary 5
• Overview of the match key

dictionary

• Modifying the match
key dictionary
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Overview of the match key dictionary
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Modifying the
match key
dictionary
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Adding match key fields
to the .dct file

1. Open the us_addr.dct file in
Notepad.

2. Add the fields you want to the
file—in this case, City and
State—and define the data
type, field length, and
missing value code.

3. Click the File menu and click
Save when you are done with
your edits.
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Tip

Adding fields to the .dct file
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Removing fields from the
.dct file

1. Open the .dct file in Notepad.

2. Remove the field or fields
that you don’t want—in this
case, Zone.

3. Click the File menu and click
Save.

�

Zone has been removed from the .dct file.
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Removing fields from the
.dct file
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The classification table 6
• Overview of the classification table

• How to get to the classification
table

• How the classification table is
formatted

• Modifying the .cls file
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Overview of the classification table
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How to get to the
classification
table
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1. Locate the .cls file in
Windows Explorer.

2. Open the file in a text editor,
such as Notepad.

The file will display in
Notepad.

Note that if you would like to
use another text editor, such
as WordPad, you may do so,
but make sure you don’t save
the file with any extra
formatting.

The file displays in the text editor.

�
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How the classification table is formatted
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Explanation of classes in .cls file Example of some columns as they appear in the classification table
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Modifying the .cls
file
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Modifying the .cls file to
change standardization
of ordinal suffixes

1. Open the .cls file in Notepad.

2. Scroll down to the ordinal
numbers you wish to change,
for example, FIRST.

3. If you wish to change your
data so it is standardized as
a full word (rather than the
numeral), change the second
column to the full word.

4. When you are done editing
the .cls file, click the File
menu and click Save.
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Modifying the .cls file to
change AVE to AV

1. Open the .cls file in Notepad.

2. Scroll down to Avenue (use
the Find tool in the Edit
menu).

3. Change the text in the
second column from AVE to
AV.

4. Click the File menu and click
Save.
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Removing Spanish street
types for datasets that
store prefix types in the
street name field

1. Open the .cls file.

2. Scroll down to Avenida.

3. Comment out Avenida by
placing a semicolon in front
of it.

4. Repeat the process with
Calle and Paseo, if desired.

5. Click the File menu and click
Save.
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Adding new keywords
and standard
abbreviations to the .cls
file

1. Open the .cls file in Notepad.

2. Scroll down to the bottom of
the file.

3. Type the words you want to
add (for example, Close) in
the first column.

4. Type the words as they
should be standardized in
the second column.

5. Type a T in the third column
to standardize as a type.

6. Click the File menu and click
Save.
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Changing abbreviated
names in the address
data to match data in the
reference files

1. Open the .cls file in Notepad.

2. Scroll down to MLK.

3. Change the second column
from MARTIN LUTHER KING
to MLK.

4. Click the File menu and click
Save.

Your address data should
now be the same as your
reference file data, which will
result in much better
candidate scores.
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Pattern rules
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Single token
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Floating positioning specifier
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���������	�����	�������
���
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Reverse floating positioning specifier
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Fixed position specifier
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Negation class qualifier
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Conditional patterns
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Simple conditional values
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Series of conditional values

��������	��	�����������	��������
�
�������	� 0�	�������������
������
1�����������
����� ��	�������	��
�����������
����
���
�����
1�=�@������;�����@��������	��������(����
����� ��
�������	
������� 0J

��L�H=�I�@�H�)I@�H-8I

��J

��L�L�H=�I�H�)I�H-8I

��
����
����(����
����� ����
��	������
�����������	���������
������
��
����1�6����;�����J

4�5���5�9�	:�P�E��$	FM�E���FM�E�-���R�F

7��0���������
������������������0@�������
����
��������������������
������	
@������	���	���	��	�����1

Tables of conditional values
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Conditional expressions
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Referencing current operand contents
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original token is greater than

=T=

abbreviation is not equal to

abbreviation and original
token are not equal to

original token is greater than
or equal to

original token is less than or
equal to

original token is equal to

abbreviation is equal to

abbreviation or original
token is equal to

original token is not equal to

original token is less than

!=T=

!=A=

!=

>=

<=

=A=

=

>

<
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Referencing match key contents
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Referencing constants, literals, and variables
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Referencing the length of an operand
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Referencing a template of an operand
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Referencing a substring of an operand
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Arithmetic expressions
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Combining conditional expressions
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Actions
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Copying information (COPY)
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Copying user variables
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Copying match key fields

,����������0���������0�����	
������������������0�����	
1�'��
�;������������
��
J

�-%.�9�	:�9��:

7�����
��;�����@�����(��������U�>V��
������	����U��V1

Copying standardized abbreviations (COPY_A)
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Copying with spaces (COPY_S)
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Converting information (CONVERT)
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Retyping operands (RETYPE)
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Retyping multiple tokens (RETYPE)
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Soundex phonetic coding
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Terminating pattern matching (EXIT)
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Subroutines

=� �������
��������������
�������

������	����� ����(���	� 0��
��88�������1�=� ������������
�
����	��������� �������#���	
������������
@��������
�����������������������
�� ������� ����1����
�������
����	� ���
�������
J

��88�P
� �������Q

6����;�����J

b#�%

��88��-�=

Writing subroutines (SUB, END_SUB)
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Returning from a subroutine (RETURN)
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Modifying the
pattern file
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Encoding the .xat file

1. Open the .xat file you wish to
modify in Notepad. The .xat
files are located in the
geocode subfolder of the
Geocode folder.

2. Make any changes in the .xat
file.

3. Click the File menu and click
Save.

4. Open STANEDIT.

5. Click the File menu and click
Open Process.

6. Click the .stn file you wish to
use (has the same filename
as the .xat file you modified).

7. Click the Tools menu and
click ENCODE PAT.

ENCODE PAT converts the
.xat file into a binary file with
the .pat file extension.

�

�
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Adding quickly filterable
patterns to the pattern
file

1. Note in the address:

123 23rd St. Ct.

that 23rd St. represents the
street name, and Ct.
represents the street type.

2. Open the us_addr.xat file in
Notepad.

3. Add the following pattern at
the top of the .xat file:

Pattern is:
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4. Click the File menu and click
Save.

5. Open STANEDIT (for
information on using
STANEDIT, see Chapter 8,
‘Developer’s Kit tools’).

6. Click the Tools menu and
click ENCODE PAT.

The .xat file is converted to a
binary .pat file.
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Modifying the .pat file for
a special circumstance

1. Open the us_addr.xat file in
Notepad.

2. To quickly process the
special case for “Trail West”,
add a section to the top of the
.xat file with the pattern
outlined in the graphic to the
right.

3. Click the File menu and click
Save.

4. Open STANEDIT.

5. Click the Tools menu and
click ENCODE PAT.

The .xat file will be converted
to a binary .pat file.
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Dealing with ST

1. Navigate to the .xat file you
wish to modify (default
location is C:\programfiles\
ESRI\GeoKit\Geocode).

2. Right-click the .xat file, point
to Send To, and click
Notepad (or another
standard text editor).

3. Add the text in the example at
the right to the top of your .xat
file.

4. Add the text in the example at
the right to your .xat file after
your pattern–action
sequence pairs.

5. Click the File menu and click
Save.

6. Open STANEDIT (default
location is C:\program
files\ESRI\Geokit\Bin).

7. Click the File menu, click
Open Process, and click the
process you are working on
(same filename as the .xat
file you modified).

8. Type an address to be
standardized in the text box.

9. Click the Tools menu and
click Encode PAT.

The .pat file is outputted to
your geocode folder where
the software is installed (for
example, if you are using
ArcGIS, the default location is
C:\arcgis\arcexe83\geocode).
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Matching and standardizing street intersections
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Defining MatchRules for street intersections
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Dealing with street intersections
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1. Look at the graphic on the
right to see how the .dct file
parses the address into
components.

2. Navigate to the .xat file you
wish to modify in Windows
Explorer (the default location
is at C:\program
files\ESRI\GeoKit\Geocode).

3. Right-click the file, point to
Send To, and click Notepad.

4. Type the pattern at the right
in the .xat file. Note that \&
denotes you are looking at
an actual ampersand in the
address, rather than an
operand.

5. In the very last line (after
EXIT), add a carriage return.

6. Click the File menu and click
Save.

7. Open STANEDIT (default
location is C:\program
files\Esri\GeoKit\Bin).

8. Type an address to be
standardized in the text box.

9. Click the Tools menu and
click Encode PAT.

The .pat file is outputted to
your geocode folder where
the software is installed (for
example, C:\arcgis\
arcexe83\geocode).
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intersection
.xat/.pat files
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1. Open STANEDIT (default
location is C:\program
files\ESRI\GeoKit\Bin).

2. Click the File menu and click
New Process.

3. In the Save As dialog box,
type the name of your new
process, then click Save.

The files that make up the
standardization process
open.

4. In the .xat file, add the
pattern–action sequence to
standardize your address.

5. You can also add a custom
routine, for example, to
remove directions. This is
useful if you want to stan-
dardize the address without
worrying about the {PD}
field.��

Tip

Actions in the .xat file
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pattern file
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6. Type the text in the graphic at
the right into the .xat file.
DIRECTIONS is the name of
the subroutine.

RETURN in the pattern–
action sequence at the right
is what moves the action to
the next pattern.

A [2] is used under COPY_A
[2] under \SUB_DIRECTIONS
because the subroutine only
deals with direction; this
removes direction to
streamline standardization.

7. When you are finished, click
the File menu and click Save.

8. To create a new process, you
need to add PD and ST to
the .dct file. Add the text at
the right to the .dct file you
just created. For information
on adding fields to the .dct
file, see Chapter 5, ‘The
match key dictionary’.

9. You need to update the .cls
file. Add the text at the right to
the .cls file you just created. It
should replace the “0 0
0” line. For information on
adding fields to the .cls file,
see Chapter 6, ‘The
classification table’.

10. Open the process in
STANEDIT and enter an
address to standardize.

11. Click the Tools menu and
click Encode PAT to convert
the .xat file into a .pat file.
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Editing an existing process
to create a new process
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Developer’s Kit tools 8
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STANEDIT and
the DEBUG and
OUTFILE
keywords
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Adding the DEBUG and
OUTFILE keywords to the
command file

1. Open the us_addr.stn file in a
standard text editor, such as
Notepad.

The us_addr.stn file displays.

2. Add the DEBUG and
OUTFILE keywords to the file.

3. Click the File menu and click
Save.

The us_addr.stn file is displayed.

�

�
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Using STANEDIT to
standardize an address
using us_addr.stn

1. Click Start, point to Programs,
point to Esri, point to
Standardizer Editor, and click
Standardizer Editor.

2. Click File and click Open
Process in the Standardizer
Editor window.

The Open dialog box
appears.

3. Click the us_addr.stn file in
the Open dialog box.

4. Type the address you wish to
standardize in the
Standardizer text box and
click Process.

The address will standardize
in the Standardizer Editor
window.
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Tip

Entering multiple
addresses
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Checking pattern rules
syntax using STANEDIT
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Creating a new
process with
STANEDIT
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1. Click Start, point to
Programs, point to Esri, point
to Standardizer Editor, and
click Standardizer Editor.

2. Click the File menu and click
New Process.

3. In the Save As dialog box,
type the name of the new
process, then click Save.

The files open in a text editor
(the default is Notepad).

4. Edit the files and add the
rules accordingly (for
information on editing the
files, see the section, ‘Adding
custom routines to the
pattern file’ in Chapter 7).

5. After you have edited each
file, click the File menu and
click Save.
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ENCODPAT
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Encoding the .xat file
using ENCODPAT

1. When you are finished
standardizing and debugging
your process in STANEDIT,
click the Tools menu and click
Encode PAT.

If you are running
ENCODPAT from STANEDIT,
the .pat file will be outputted
to the same folder where all
the other files in the
standardization process are.

If you are running
ENCODPAT from the DOS
prompt, the .pat file will go to
the current folder of the
prompt if you don’t specify a
path for the .pat file.
Otherwise, everything will be
saved to whatever folder it
shows after the prompt.

Tip

Running ENCODPAT from
DOS
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What to do before adding your files to the folder
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Data dictionaries and match rules syntax A
• Introduction

• Data dictionaries and match
specifications

• Geocoding

• Record linkage concepts
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Specifying the m and u probabilities
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Counting errors in fields (CNT_DIFF)
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Delta percentage comparisons
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Distance comparisons (DISTANCE)
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Interval comparison with parity
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Left/Right interval comparisons (D_INT)
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Left/Right character comparisons (LR_CHAR)
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Left/Right uncertainty character comparisons
(LR_UNCERT)
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Numeric comparisons (NUMERIC)
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Prefix comparisons for truncated fields (PREFIX)
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Prorated comparisons (PRORATED)
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Time comparisons (TIME)
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Character uncertainty comparisons (UNCERT)
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Geocoding
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Record linkage concepts
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Feasibility of record linkage
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Selecting blocking strategies
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Weights
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Composite weights
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Introduction
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Postal addresses
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Files used by STANEDIT
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Getting started quickly
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Input file format specifications

Running STANEDIT
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Preparing a STANEDIT command file
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Output file name specification (OUTFILE)
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Specification of record size (RECORD)
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File type specification (TYPE)
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Interactive processing (INTERACTIVE)
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Debugging patterns (DEBUG)
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Classification table format
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Pattern matching
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The pattern rules
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Conditional patterns
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Conditional expressions
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Referencing current operand contents
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Referencing the length of an operand
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Referencing a template of an operand
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Referencing a substring of an operand
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Arithmetic expressions

������������;���

���
����� �������	�	��
����������������	�����
���	���������;���

���1����������������������������������
����
�(���� ��J

L �		�����

� 
� ��������

� ��������������

B 	�(�
���

M ��	���


������������
�������	�����������������������;���

���1�>�
��������
�
�������������	1�������	���
������������
����

������	�����������������	�(�
���1�6����;�����@���M�#��
�$�������
��� ����
�	�(�
� ��� 0����1�7���
�#����������� ����
��		1�������

�������������	�
��

���@�����������������������������	�������
�;���

�������� �����
����	J

P����F������	Q�P����������F��������Q�P�����F������	Q

���������������	���0� �J

(���� �������

UV

UV�-7��

UV�8.>

UP��������0�����QV�-7��

UP��������0�����QV�8.>

(���� ��������-7��

(���� ��������8.>

UP��������0�����QV

P����������F�;���

���Q

�����������������������
�����P@�Q@�PL@�QL@�dL@�L

����������������	���0� �J

(���� �������

�������

���
����

���������������;���

�����


P����F�����F������	Q�P�����F��������Q�P�����F�����F������	Q

������F�����F������	��
��

(���� �������



128 GEOCODING RULE BASE DEVELOPER GUIDE

U�P��������0�����QV

UV

�������������������
�G�F�Y�<�b

�������F�����F������	���0� �

(���� �������

���
����

.;�����
����������������;���

���
����

�����F�� �������
���������F��

UV�b�� ��������������	�(�������	�����

���
�	��������	���������;���

���������������������(��F��� ���	
���
�
1

^�SUV�b���L�$T

.(������ ��
�����	�(�
� ��� 0��@����
��������
����� �����	�����
�
�"���1

>��������������������������������
�������������
�	�������������������
���������D�����C����
���E1

�����	���������;���

�����
��
�	����
������������������������	
	�(�	�	� 0��������
�������������������������
����(���� �������J

^�SUV�<���Q�����T

����������������������������0����������
���	����������������������
������������������������������������1�'������;�����
�������	������
�;���

���
���(��(������������������J

S������Y�������Q�������T

S�UA-V�G���Q�#���*T

Combining conditional expressions
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Copying information (COPY)
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Copying substrings
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 Copying leading/trailing characters
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Copying user variables
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Copying match key fields and formatted fields
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Copying standardized abbreviations (COPY_A)
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Copying with spaces (COPY_S)

�����(������������������	�D�E��������������������
�DYYE��

�����	��������������0�������
���(���� ��@�������	�(�	�������	
����
�����������	���������1�7���
�������������
�������������������0
����	� ���
�	�������������������������� ��
@���	����
�C�����0@

����
�
����	� �����
��(�	� ����������	
1����
����� �
��������
��	� 0��
���������'-,9=����������
���	���������'-,
������1��'-,9=���C����
����������	��
�����
��������	���������
��������0�����	�������
���(���� ����
���������1

���
�	������������
������
�����
J�#���'83���.&&,��788�&31

��
���	��	����0�����	����	����H'83��.&&,�788I@� ��
�'-,9=�����	����������
�������
J

^�_���_�

�'-,�S#T�U�>V

�'-,9=�S�T�U=>V

�'-,9��S�T�U=�V

����U=>V�����	����������������0�����	��������J�'83���.&&,
�7881

7���������(��
������������������	�������
�	@���������������
���
����
�������	�����������	� �������	1�6����;�����@����
�	��
����(�������������������������
��������������0�����	�����	
U-&V1�6�������������		��

�
�����
J

#���%����=��D����������*���=�E�����������+

������������J

ZD�_�YY�_�ZE

�'-,9=�S�T�U-&V

�'-,9=�S�T�����

����	���(��H����������*���=�I����������������0�����	�U-&V1����

����	����������(�
�����
������������������������
���(���� ��
����1

Copying the closest token (COPY_C)
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Moving information (MOVE)
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Concatenating information (CONCAT, PREFIX)
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Converting information (CONVERT)

�����'>).&����������
��
�	�������(����	���������	��������
��������� ���������
��F
������	��������1

Introduction (converting place codes)
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CONVERT considerations
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Assigning fixed values
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Converting prefixes and suffixes (CONVERT_P,
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Retyping multiple tokens (RETYPE)
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Matching and standardization file conventions and limits D
• Conventions and limits
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Pattern file conventions
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