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Copyright and trademark notice 

The INM VizionDB Editor is free to use and redistribute. Integration New 
Media, Inc. withholds all rights to the INM VizionDB Editor. 

Please refer to the license agreement on the VizionDB website for additional 
information on INM VizionDB copyright requirements: 
http://www.VizionDB.com  

Adobe, Macromedia, Director and Xtra are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States and/or other 
countries. FileMaker is a trademark of FileMaker, Inc., registered in the U.S. 
and other countries. Microsoft, Windows and Windows NT are trademarks or 
registered trademarks of Microsoft Corporation, registered in the U.S. and/or 
other countries.  Apple, Mac and Macintosh are trademarks or registered 
trademarks of Apple Computer, Inc.   

INM VizionDB includes Onix Search and Retrieval Tools, ©1994 – 2006, 
Lextek International, http://www.lextek.com/

Other trademarks, trade names and product names contained in this manual 
may be the trademarks or registered trademarks of their respective owners, 
and are hereby acknowledged. 

http://www.viziondb.com/
http://www.lextek.com/
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Introduction 

The INM VizionDB Editor is a utility application that helps you create, view 
and edit V12 databases. In general, a project involving the use of INM 
VizionDB goes through five steps:  

• Step 1: Deciding on the data model,  

• Step 2: Preparing and exporting the data, from an existing database, 

• Step 3: Creating the V12 database,  

• Step 4: Importing data, and  

• Step 5: Implementing the user-interface. 

The INM VizionDB Editor is designed to reduce the time and effort you spend 
on steps 3 and 4, thus enabling you to focus on the user-interface 
implementation.  

In addition to the INM VizionDB Editor, Director users can take advantage of 
the INM VizionDB Behaviors to reduce the efforts required on Step 5 and 
implement user-interfaces without scripting.   

 

Requirements to run the INM VizionDB Editor 
INM VizionDB Editor is an executable application that can run on Windows or 
Mac OS X. You can launch it on Windows by clicking Start > Program Files 
> Integration New Media >INM VizionDB > INM VizionDB Editor, or 
access it from Director by clicking Xtras > INM VizionDB > INM VizionDB 
Editor.   

A database file cannot be open in both the INM VizionDB Editor and in 
Director at the same time. If you have a database file open when you launch 
the INM VizionDB Editor from Director, that file is closed.  

If you plan to import data from MS Access or SQL Server you will need to 
make sure the ODBC drivers are installed correctly. Refer to the 
documentation accompanying those applications for details. Note that on Mac 
OS it is often more efficient to export the data to a more common file 
format—comma separated value (csv) or tab separated value (txt), for 
example—and import them into your INM VizionDB file using the INM 
VizionDB Editor. 
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How to Install 
The INM VizionDB Editor is installed with the full installer for INM VizionDB.  

To start the INM VizionDB Editor on Windows, click Start > Integration 
New Media > INM VizionDB > INM VizionDB Editor  

On Mac OS X double-click the file named INM VizionDB Editor.app.  

 

Partial install 

INM VizionDB Editor has its own installer that is useful if you want to install 
an update to the editor, without having to install the full INM VizionDB 
product.   

The installer will attempt to install the INM VizionDB Editor application to the 
folder named Program Files\Integration New Media\INM VizionDB on Windows 
or Applications\Integration New Media\INM VizionDB on Mac. 

Where to start 
Before reading this entire manual we recommend that you install INM 
VizionDB and the INM VizionDB Editor, and work through the First Steps 
tutorial. This will give you an overview of what you can do with the editor so 
that you can get started quickly. 

This manual describes, in detail, the features of the INM VizionDB Editor. Use 
this manual to assist you in creating, viewing and editing database files. 

The INM VizionDB User Manual should be your main source of reference on 
important topics such as data modeling and database creation.  
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Benefits of the INM VizionDB Editor 

 Ease of Creation 

Using the INM VizionDB Editor makes creating your V12 database quick and 
easy! Everything you normally need is right at your fingertips, through a 
simple point and click interface.  

For the most complex of projects, you can still use the INM VizionDB methods 
to create your database through SQL or to further customize your database, 
but the INM VizionDB Editor will usually satisfy all your needs! 

 Use data from a variety of sources 

Using the INM VizionDB Editor you can avoid writing scripts for importing 
data. The INM VizionDB Editor does it all for you! You can Import data from 
Text, MS Excel, MS Access, DBF and V12 files through the INM VizionDB 
Editor’s point-and-click interface, or directly key-in data. 

 Edit and massage data 

The INM VizionDB Editor's straight-forward, spreadsheet like interface allows 
you the flexibility to browse the data, edit contents of individual cells, filter 
records for inconsistencies, sort records and find and replace values. 

Very useful for last minute changes in a project or data updating. 

 Export data for analysis 

You can use the INM VizionDB Editor to export your data to Tab-delimited or 
Comma-separated Text files, in order to analyze it and generate reports using 
your favorite tools (FileMaker, MS Excel, MS Access, etc.). 

 Separation of Workflow 

If a project contains large amounts of text, writers and editors should ideally 
be able to edit it, revise, and check spelling using their favorite text editors. 
At the same time you want programmers and integrators to be able to work 
on the user interface.  Since the INM VizionDB Editor can quickly import from 
a text file to a V12 database, programmers and integrators can work with a 
draft version of the text in their Director projects and import the finalized 
version of the text at the end of the production cycle.   
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 Adapt the user interface to any language 

Each button label and message within the INM VizionDB Editor can be 
translated to any language so that you can distribute this editor to your 
clients.  It comes with three different language settings. 
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Navigating the INM VizionDB Editor 

This section explains how to work with the INM VizionDB Editor. You will learn 
how to browse through your data, how to modify it, how to import and export 
it, how to use auxiliary functions like changing passwords, how to view and 
modify the database structure, and more. 

Opening a database 
To open an existing INM VizionDB database, choose File > Open INM 
VizionDB Database…. A standard Open dialog box will appear, from which 
you can select an INM VizionDB database file.  The default file extension is 
.vzd. 

Click OK to open the file.  The last table viewed is opened in the Main window 
datagrid. 

Browsing through data 
If you already know how to use a spreadsheet program like MS Excel, it will 
be easy for you to understand how to browse through your data using the 
INM VizionDB Editor because it uses the same visual paradigm.  

The INM VizionDB Editor uses a grid to display the data from one table at a 
time. Each row corresponds to a record and each column corresponds to a 
field of your database. You can navigate through your data using the up-
down, left-right arrows on your keyboard and the mouse. 



 

Slider bar allows 
you t o adjust the 
height of the grid 
vs. the edit area 

 

Figure 1: INM VizionDB Editor's main window 

 

 

Figure 2: INM VizionDB Editor Toolbar 
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If your database contains more than one table, click the table popup list to 
switch between them.  

Use the vertical scrollbar to view records that are not currently visible; use 
the horizontal scrollbar to view fields (columns) that are not visible in the 
grid.  

In addition you can use the following keyboard keys and shortcuts to 
navigate: 

Up arrow :  Move to the previous record 

Down arrow :  Move to the next record 

Left arrow :  Move to the previous field 

Right arrow : Move to the next field. 

Home: Move to the first record of the selection 

End: Move to the last record of the selection 

Page Up: Move one page up 

Page Down: Move one page down 

 

Note: When you are editing data, within a cell of the grid, the 
keyboard shortcuts behave differently.  See the section on 
editing data to learn those keyboard shortcuts. 

Changing view options 
To change the width of a field column, click and drag the boundary between 
columns.   

To show or hide field columns and rearrange their order in the grid, select 
View > Show/Hide fields, or click the corresponding toolbar button. 

To display display the data using the font of your choice, click View > 
Fonts… 

Click a field name to sort the records of the table by the values of that field.  
If the sort arrow points up the field is sorted in ascending order (lower values 
at the top); if it points down the field is sorted in descending order. To 
remove the sorting, click until no arrow appears. 
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Editing data 
To edit a cell in the grid double-click inside the cell and begin typing. The TAB 
key moves you to the next field in that same record; Shift+TAB moves you to 
the previous field. 

For large text use the scrollable text edit area at the bottom of the screen. To 
avoid using the mouse to switch between fields or records, press Alt+right, 
left, up or down arrow keys to keep the focus within the text edit area, and 
edit the grid cell that is right, left, above or below the one you are currently 
editing. 

Adding a Record 

Click the Add Record button or right-click anywhere in the main grid and 
select Add Record from the context menu.  You can also use the keyboard 
short-cut (Alt+A). A new, empty row is added to the bottom of the grid. When 
you are done editing the new record, click the mouse elsewhere in the grid, or 
TAB out of the last field in the record, and the new record will be added to the 
database.  

Once the record is added, it may seem to disappear from the grid. This is not 
a mistake! The record is inserted in the database according to its sort order, 
so its sorted position may be higher or lower in the list and therefore it is no 
longer visible in the grid. To avoid this behavior, turn off the sorting options 
by clicking the sorted field heading until there is no arrow. 

 

Automatic Data Validation and other error prevention 

Automatic Data Validation is turned on by default.  This feature highlights the 
contents of cells that do not comply with the settings defined for a field.  For 
instance, if you enter an invalid format in a formatted field, or a numeric 
value that is higher than the maximum value or lower than the minimum 
value allowed for the field, the Automatic Data Validation highlights the cell.  
You can turn off Automatic Data Validation by clicking Tools > Automatic Data 
Validation, or clicking the button with the check mark in the toolbar.  When 
the feature is turned off, the toolbar button becomes darker. 



 

Figure 3: The main window of the INM VizionDB Editor: Active Validation  
highlights cells where values do not correspond to field definitions 

 

If you attempt to enter characters into a field of numeric type, the data is 
simply not accepted.  If you attempt to leave a record where a required field 
value is NULL, the INM VizionDB Editor signals an error and refuses to leave 
the currently edited record. You can either type a valid entry in that field, or 
choose to delete the current record.  

Deleting a Record 

To delete the current record, click Edit > Delete Record(s) or right-click 
and select Delete Selected Record from the context menu. There is a 
confirmation dialog warning you that this action is permanent. Use this option 
with caution. 

Deleting All Records 

To delete all records of the current selection choose Edit > Delete All 
Records. A dialog will ask you to confirm the operation. If you confirm, the 
operation cannot be undone – all records are deleted from the table. 
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Closing a database 
To close a database, select File > Close, or click the corresponding toolbar 
button. This closes the current database and empties all the fields of the main 
window without quitting the INM VizionDB Editor. If you are in the process of 
editing data when you close the database, the last data entered will be saved. 

Creating a new database 
There are several options for creating a new INM VizionDB database:   

• create from scratch,  

• create from a predefined template,  

• convert from an existing database (INM VizionDB or other format) 

Create from scratch: 

1 Choose File > New Database > From Scratch…. The standard 
open dialog window opens, 

2 Browse to a file location and type in a file name for your new 
database.   

3 Click OK.  The Modify Database Strcuture window opens, from 
which you can add a table and begin defining the fields.   

See Modifying the database structure for more details on how to proceed. 

 

Create from a template: 

The INM VizionDB templates are provided to get you started quickly when you 
don’t already have an existing database.   

1 To view the structure of a INM VizionDB template, click File > New 
Database > Create from template….  The available database 
templates are listed on the left side of the dialog box that opens.  

2 Select a template name and view its structure on the right side of 
the dialog.   

3 Select the template structure that most closely fits the kind of 
project you are building; click Create Database; supply a database 
filename and click OK.  The new INM VizionDB is created. 

4 Now click Tools > Modify Database Structure… to remove tables 
you don’t need, add new tables or modify the fields within a table. 
See Modifying the database structure for more information. 



 

Figure 4: Create database from template 

 

Create from an existing database 

You can create an INM VizionDB database from various existing database 
files.  If you have data in the following formats, the INM VizionDB Editor can 
convert directly: 

MS Access, V12 Database, Valentina 

For other file formats you can create your INM VizionDB database structure 
first (see creating from scratch) and then import the data for each table. 

See Converting an existing file to INM VizionDB format for details on how to 
convert or import form various file formats. 

 

Adding or changing the database password 
If your database is password-protected, the password will need to be supplied 
in order to open the database in the INM VizionDB Editor and in Director.  

1 Click File > Assign/Change Password.  

2 Enter a new password in the New Password text box.   

3 Enter that password again in the Confirm Password text box.   

4 Click OK to set the new password.  If there was a different 
password for the database previously, that password is changed to 
the new one. 
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To remove an existing password leave the boxes empty in the Assign/Change 
password dialog. 

Note: In addition to password protection, INM VizionDB databases are encrypted 
automatically so that they cannot be opened by any other applications. 

 

Modifying the database structure 
Click Tools > Modify Database Structure to enter the Modify Database 
Structure window.  Here you can add, edit and delete tables and define 
relationships between tables, whether you have just created an INM VizionDB 
database from scratch, or from a predefined template, or if you just want to 
refine the structure of your existing database. 

 

Figure 5: Modify Database Structure window 

 

Adding and editing tables 

If you have just created a new database from scratch, click Add Table to 
begin defining your table structure.  If you created your database from a 
template or converted from a different data file format, you can Add Table to 
add a new table, or select one of the existing table names and click Edit 
Table to add, remove or change the definition of the fields in an existing 
table. 

The Modify Table window contains a text box labeled Table name at the top. 
If you are adding a new table, click in this text box and enter the name of 
your new table. Table names must begin with a letter and cannot contain 
spaces.  If you are editing an existing table, the Table name text box is not 
editable.   

 

VizionDB-Editor-Manual.doc p.16/29 

Integration New Media, Inc. 10 Nov 2006  

 



Adding a field to a table 

The main portion of the Modify Table window contains a grid.  Each row of the 
grid represents a field of the table.  To add a new field, click the Add Field 
button or right-click anywhere in the grid area and select Add Field from the 
context menu. 

 

Figure 6: Modify Table Structure window 

  

The columns represent the properties that are common to each field: 

Field name: Enter a descriptive name for each field.  Fieldnames must begin 
with a letter or number and cannot contain spaces. 

Field type: The field types supported are: 

• Integer (whole numbers between 32768 and -32767)  

• Double Precision (for all floating point numbers),  

• Varchar (for text data that is not longer than 1000 characters),  

• LongVarchar (for text data that can be longer than 1000 characters),  
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• Media (for binary data such as bitmap images, Flash movies, Director 
members, sound clips, etc.).  Media can be stored in the database, but 
cannot be inserted or viewed through the INM VizionDB Editor; they 
must be accessed from Director using the GetMedia and SetMedia 
methods. 

• Timestamp (used to store dates or date and time in the current 
operating system format) 

 

Indexed: Indexed fields can be searched more quickly than those that are 
not indexed. There are four possible choices for this property:  

• No means the field is not indexed 

• Yes (Unique) means the field is indexed and the value of this field 
must be different for each record in the table. 

• Yes (Duplicates allowed) means the field is indexed and the value 
of this field does not have to be different for each record. 

 

Required: If this checkbox is checked, the field must contain a value for each 
record in the table. 

Description: In this area you can enter a description of the data, or hints as 
to the values expected. 

 

Deleting a field from a table 

To delete a field, click within the row of the field you want to delete and either 
click the Delete Field button, or double-click and select Delete Field from the 
context menu.   

A warning message tells you that this operation is not reversible and that any 
data stored in that field will be lost if you continue. 

Adding and Editing Relationships 

INM VizionDB Editor allows you to define relationships between your tables.  
Relationships make it easy to view and store data in a logical way and allow 
you to avoid duplicating the same information used in different places within 
the database.  For a more detailed discussion of relational databases, please 
see that section in the INM VizionDB User Manual. 

To add or edit database relationships from the INM VizionDB Editor, click 
Tools > Modify Database Structure. Then click Relationships.  A dialog 
box opens allowing you to view existing table relationships and add new ones. 



Click Add Relationship to add a new relationship or select a relationship 
from the list and click Edit Relationship to change an existing one. On the 
left-hand side of the Add/Edit Relationship window, select the reference 
table and field (where the field chosen is unique for each record of that table).  
In the dropdown menus on the right-hand side of that window select the table 
and field where many records may have the same value. 

 

Figure 7: Add/Edit Relationship window 
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Importing, Exporting and Converting Data Files 

INM VizionDB Editor is specifically designed to make the task of getting data 
from other formats into INM VizionDB format, and vice versa.   

Convert allows you to create a new INM VizionDB database from an existing 
database.  

Import Table Data allows you to bring data from an existing database or 
text file into an already existing INM VizionDB table. 

Export Table Data allows you to write out the data from an INM VizionDB 
table to a text or XML-formatted file to be used with other applications. 

Export Database Structure creates an XML file containing the tables and 
fields that make up the structure of the database. 

Converting an existing file to INM VizionDB format 
If you have an existing database in MS Access, Valentina or INM V12 
Database format, the INM VizionDB Editor can convert the database directly 
to INM VizionDB format. For all these different formats, the basic procedure is 
approximately the same: 

• During the conversion, a log window appears where you can view 
the status of the conversion.  From this window you also have the 
option to Abort the procedure if you wish. 

• The new INM VizionDB database is opened after it is converted. 

 

Converting from MS Access 

Choose File> Convert…, select MS Access for the type of database, browse 
to locate the MS Access .MDB file, enter the password, if required, and click 
Convert.  

Converting from V12 Database 

1 Choose File> Convert…, select V12 Database, specify the 
database file name and password and click Convert.   

2 Browse to the location for the new INM VizionDB database, specify 
the new .VZD file name. Then click Save. 
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Converting from Valentina 

1 To enable conversion from Valentina you simply need to copy the 
VMD4 Xtra file (.x32 on Windows) to the folder named Xtras inside 
the INM VizionDB folder.   

2 Choose File> Convert…, select Valentina, specify the database file 
name and password and click Convert.   

3 Browse to the location for the new INM VizionDB database and 
specify the new .VZD file name. Then click Save. 

 

Converting from other database formats 

If your original source data is in a format that is not directly supported by the 
Convert function, such as MS Excel or DBase, use the original application to 
export the table data to either comma separated values (CSV) or tab-
separated values (TXT).  You can then import the data into your INM VizionDB 
table. 

 

Importing data 
Before importing data from another database, you need to create an INM 
VizionDB database that contains a structure that is similar to the one you are 
importing from.  

The INM VizionDB Editor imports data from an external file into the current 
table view displayed in the main datagrid at the time the import function is 
started.  Therefore, if your INM VizionDB table fields are not in the same 
order as those of your source data file, or if you have additional fields in your 
INM VizionDB table, you can still successfully import the data by rearranging 
or hiding field columns of the main data grid.   

Click View > Show/Hide Fields to select which fields you want to display 
and in which order. 

Click File > Import Table Data… and select the file format of your source 
data.  The following file types are supported: 

• MS Access 

• Another INM VizionDB database 

• CSV (comma separated values) – Each field is separated by a 
comma, and each record by a RETURN character.  If the data 
within a field contains commas, it needs to be contained within 
quotes.  If the field contains the quote character within its text, the 
entire field must be surrounded by quotes, and the quote 
characters within the field should be doubled. 
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• TXT (TAB separated values) – Each field is separated by a TAB, and 
each record by a RETURN character.  If the data within a field 
contains a TAB that field needs to be contained within quotes. If 
the field contains the quote character within its text, the entire 
field must be surrounded by quotes, and the quote characters 
within the field should be doubled. 

• XML – the format needs to be as follows: 
   <records> 

       <record> 

           <field>field value 1 for record 1</field> 

           <field>field value 2 for record 2</field> 

           ... 

       </record> 

       <record> 

           <field>field value 1 for record 2</field> 

           <field>field value 2 for record 2</field> 

           ... 

       </record> 

     ... 

   </records> 

The data imported is appended to any existing data already in the INM 
VizionDB table.  So if you want to replace the original data, delete all records 
from the table before importing. 

 

 

 

Exporting data 

Exporting to a Text File 

To export data from the currently selected V12 table to a text file, choose 
File>Export to Text…. Enter the destination file name and/or browse to the 
folder where you want it created. Enter the field and record delimiters. 

Exporting to an XML File 

To export data from the currently selected V12 table to a text file, choose File 
> Export to XML…  The XML format of the file created is the same as the 
format accepted when importing from XML.  

Exporting the database structure 
Choose File > Export Database Structure to export the database structure 
as an XML-formatted file.  

Here is an example database file exported in XML format: 
<database> 
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<table name="BRANDS"> 

  <field attrname="BRAND_ID" fieldtype="Integer" required="true" width="4" />  

  <field attrname="BRAND" fieldtype="VARCHAR" required="true" width="100" />  

  <field attrname="WEBSITE" fieldtype="VARCHAR" width="150" />  

 </table> 

 <table name="CATEGORIES"> 

  <field attrname="CATEGORY_ID" fieldtype="Integer" required="true" width="4" />  

  <field attrname="CATEGORY" fieldtype="VARCHAR" required="true" width="100" />  

  </table> 

<table name="PRODUCTS"> 

  <field attrname="PRODUCT_ID" fieldtype="Integer" required="true" width="4" />  

  <field attrname="PRODUCT_NAME" fieldtype="VARCHAR" required="true" width="100" 
/>  

  <field attrname="BRAND" fieldtype="VARCHAR" required="true" width="100" />  

  <field attrname="CATEGORY" fieldtype="VARCHAR" required="true" width="100" />  

  <field attrname="ROOM" fieldtype="VARCHAR" required="true" width="100" />  

  <field attrname="MODEL" fieldtype="VARCHAR" required="true" width="20" />  

  <field attrname="PRICE" fieldtype="Double Precision" width="8" />  

  <field attrname="DESCRIPTION" fieldtype="VARCHAR" width="800" />  

</table> 

<table name="ROOMS"> 

  <field attrname="ROOM_ID" fieldtype="Integer" required="true" width="4" />  

  <field attrname="ROOM" fieldtype="VARCHAR" required="true" width="100" />  

</table> 

</database> 

 

Error log messages 
During import and convert operations an error log is generated and displayed 
in a scrollable Log window. To review the contents of the last generated error 
log at any time, click Tools > Log Window…. 



Cleaning up your data 

The INM VizionDB Editor has several functions that allow you to validate and 
massage your data so that it can be used within your application.  This 
section discusses those functions. 

Filtering the selection 
The Filter options allow you to show all records that have a particular value in 
a given field, or share a common characteristic. 

Filter based on criteria 

Click View > Filter with Criteria… to open a dialog box from which you can 
specify criteria for the records you want to view. 

 

Figure 8: Filter with criteria dialog 

1 Select the field you want the search to be performed on, from the 
Field dropdown list.  

2 Select the Operator for comparison from the popup menu. 
Operators include '=' equal to, '<' less than, '<=' less than or equal 
to, '>' greater than, '>=' greater than or equal to, ‘not’, ‘like’ and 
‘contains’. 

3 Type the value in the corresponding Value box. 

4 Select a second search criterion if needed. Selecting 'And' means 
that both the first and the second criteria must be true for a 
particular record to be selected. Selecting 'Or' means that either the 

 

VizionDB-Editor-Manual.doc p.24/29 

Integration New Media, Inc. 10 Nov 2006  

 



first or the second criterion must be true for a particular record to 
be selected. 

5 Specify the field and order in which you want the selection to be 
sorted. 

6 Click OK to apply the filter. 

7 The filtered selection displays all records that match the criteria 
specified. The label “Data is filtered” appears just above the data 
grid to show that you are looking a subset of the total data. 

 

Filter duplicates 

Often you need to make sure that each record in a table contains unique 
information.  The Filter duplicates option allows you to quickly identify records 
where the data is duplicated within a particular field. 

Click View > Filter Duplicates…; identify the field in which you want to 
search for duplicate entries and click OK. The filtered selection appears in the 
main grid and the label “Data is filtered” appears just above the grid to show 
that you are looking a subset of the total data. 

Filter values based on data in another table 

To make sure that all the entries in a particular field are valid, you typically 
will create your user interface such that users can only select data from a pre-
defined list.  However, if your data comes from an unreliable source there 
may already be extraneous values and typos in a particular field.   

To correct such erroneous data, rather than reading through each record and 
trying to spot the errors, you can create a table in your database that 
contains only valid entries, and then compare the field values of your main 
table to the valid entries of this new table. 

Click View > Filter on Other Table…  The following dialog opens: 

 

Figure 9: Filter based on values in another table 
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1 Select the field in the current table which you want to verify.  

2 Select table containing the valid entries. 

3 Select the field of the other table that contains the data to compare 
to your current table’s field values.  

4 Click OK.  

The filtered selection contains only records where the values of the selected 
field do not match any of the values in the other table.  The label “Data is 
filtered” appears just above the grid to show that you are looking a subset of 
the total data. 

Removing filters 

To remove a filter (thus selecting the whole table) select View > Remove 
Filters command, or click the corresponding button on the toolbar. 



 

Creating and running queries 
The INM VizionDB Editor contains a built-in Query Designer tool, which allows 
you to build select queries via a graphical interface.  The queries can then be 
executed on the spot to examine large data sets in very specific ways.   

 

Figure 10: Query Designer window 

Specifying fields and criteria 

In each column of the grid you can select a Table and Field, or choose all 
fields (*) to include all the fields of the selected table. 

Select Ascending, Descending options in the Sort row if you want the data to 
appear sorted.  The sort options are disabled if all fields (*) is selected in the 
column. 
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If you want to include a criteria on a specific field, but don’t want that field 
displayed in the result set check off the Show checkbox. This checkbox is 
always on if all fields (*) is selected in the column, 

To add criteria, select an Operator (=, >, >=, <, <=, like, contains) and 
then enter a Value.  If you enter multiple criteria for different fields they are 
added to the SQL statement using the Boolean AND operator, except if they 
are entered in the row labeled (OR). 

The (OR) row is used in two different ways: 

a) To add a second constraint on the same field, such as Room = 
’Kitchen’ OR Room = ‘Dining room”.  In this case you would enter the 
second criteria in that same column of the grid. 

b) To add a Boolean OR constraint based on different fields.  In this case, 
you would select the table and column of the other field and place the 
criteria for it in the (OR) row. 

Adding relationships (JOINs) to your query 

You can specify relationships for the query, which translate into JOIN 
operations in SQL.  Click Add in the Relationships section of the Query 
Designer tab.  The dialog that opens allows you to select tables and fields that 
you want to join in your query.  Note that if you have defined relationships at 
the database level (from the Modify Structure window), those relationships 
will automatically be proposed if the corresponding tables are included in the 
query.   

Click Edit to edit a relationship.   

Click Delete to remove the selected relationship. 

Viewing the SQL statement and running the query 

Based on the fields and criteria that you enter in the graphical design 
interface, the INM VizionDB Editor generates an SQL statement that you can 
copy and paste into other applications.  For instance, you can paste it into an 
INM VizionDB Recordset member property dialog in Director. Click Copy SQL 
to copy the SQL statement to the clipboard.   

Choose Run to run your query on the spot.  The selected records are 
displayed in a table view in the Results tab of the window.  The records 
displayed in this tab are not editable. 

The SQL tab of the window allows you to enter your own SQL statement, 
without using the visual query designer.  Alternatively, you can start by 
selecting tables and fields in the query designer tab; then copy the generated 
SQL statement and paste it into the SQL tab, where you can further refine the 
query statement, and run it. 
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Creating a Searchable Library of PDFs 

A "Searchable Library of PDFs" is a feature that combines the strengths of 
INM VizionDB 4.1 and INM Impressario 3 to allow you to perform text 
searches across multiple PDF documents.  

The Searchable Library Wizard, accessible via the Tools menu of the INM 
VizionDB Editor, runs through an entire folder hierarchy of PDFs and indexes 
the text of each PDF in a special index that allows for full-text searching.  It 
also stores the metadata (document properties, such as Title, Author, 
Subject, etc.) and creates a table named, "Searchable_Library" within your 
INM VizionDB database.  

Once you have built a Searchable_Library table, you can incorporate 
sophisticated full-text searches of PDF content in your Director project. 

For complete documentation and samples on the Searchable Library feature, 
download the Searchable Library Toolkit from our website at: 

http://www.INM.com/products/VizionDB/Desktop/Tools  
 

Download INM Impressario from this link: 

http://www.INM.com/products/Impressario/download/  
 

Note that the Searchable Library Wizard is only enabled if you install INM 
Impressario 3 after the INM VizionDB Editor was installed.  If you don't see 
the menu item Tools > Create Searchable Library… in the INM VizionDB 
Editor, download and run the installer for Impressario 3 and then proceed. 

http://www.inm.com/products/VizionDB/Desktop/Tools
http://www.inm.com/products/Impressario/download
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