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RELEASE NOTES

FLEXMOTION 5.0
FlexMotion 5.0 is the motion control software and VIs for interfacing with
all National Instruments FlexMotion series motion controllers.

Caution If you have developed motion control systems using a previous version of
FlexMotion, you may need to recompile your code before it will work correctly with
FlexMotion 5.0. Refer to the Compatibility Issues section of this document for more
information.

These release notes discuss compatibility issues, describe how to install
FlexMotion 5.0 and related hardware, and summarize changes and
improvements associated with this version. Topics include:

• FlexMotion 5.0 Contents

• Changes and Improvements

• Controllers

• Compatibility Issues

• FlexMotion Software Installation

• Hardware Installation

• Using the Online Manuals

FlexMotion 5.0 Contents
FlexMotion VI Library 5.0 is the motion control software for interfacing
with all National Instruments FlexMotion series motion controllers using
the National Instruments LabVIEW and LabVIEW DSC visual
development environments.

The FlexMotion VI Library 5.0 is compatible with LabVIEW version 5.1
or later and LabVIEW DSC version 2.0 or later.

FlexMotion Software 5.0 is the motion control software for interfacing with
all National Instruments FlexMotion series motion controllers using C,
LabWindows/CVI, or Visual Basic development platforms.
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Changes and Improvements
There are several changes and improvements to the FlexMotion VI Library
and Software functions that make them easier to use and expand their
functionality. Code you have created and validated in the past still works
with FlexMotion 5.0. A broad description of changes made in version 5.0
follows.

Measurement & Automation Explorer
Motion control is now integrated into the National Instruments global
configuration utility, Measurement & Automation Explorer (MAX). You
can set static motion parameters in the configuration panels, which reduces
your programming tasks to a simple Initialization call and motion control
application development. MAX for motion also includes an interactive
environment that allows you to interactively test your motion configuration
and view single or multi-axis movement in plot graphs.

Reentrant LabVIEW FlexMotion VIs
The FlexMotion VIs are now all reentrant, allowing LabVIEW to
simultaneously execute two instances of the same VI on seperate
processors in a multi-processor system running Windows 2000/NT.
Even on a single-processor computer, multiple instances of a VI can be
time-sliced more effectively.

With the FlexMotion VIs marked as reentrant, they cannot be debugged,
and the front panel of an open VI will not reflect the values last sent to it.
If you need to debug a FlexMotion VI with your application, you can
temporarily uncheck the Reentrant Execution box in the VI setup options.

Contouring
Contouring allows you to create any arbitrary motion profile. You specify
an array of positions that are a specified interval apart, in milliseconds.
Your FlexMotion controller then uses a cubic spline algorithm to smoothly
interpolate between the contour positions. For more information on
contouring, refer to the FlexMotion VI or function online help.
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Expanded Example Set
Several programming examples have been added to the 13 examples in
the previous release of the FlexMotion VI Library. You can find these
examples in examples»Motion»FlexMotion»Onboard.llb under the
LabVIEW Open VI option.

You can find C and Visual Basic examples in C:\\Program 

Files\National Instruments\Motion\FlexMotion\Examples.

Limit Filters
In FlexMotion 5.0, the limit and home inputs must be active for at least
1 ms to guarantee it will be recognized, instead of the 20 µs filter in the
previous version of FlexMotion. This digital filter is always enabled and
can not be disabled.

Changes to VIs and Functions
The VIs and functions in Table 1 have been added to or changed in
FlexMotion 5.0.

Table 1. FlexMotion VI and Function Changes and Additions

VI Function Description

Initialize Controller flex_initialize
_controller

New VI/function; replaces all previous
initialization mechanisms; applies configuration
settings from MAX to your controller

Configure Buffer flex_configure_
buffer

New VI/function; allows you to set up a buffer on
your FlexMotion controller

Write Buffer flex_write_
buffer

New VI/function; after a buffer has been
configured, this VI/function allows you to write
to the buffer.

Read Buffer flex_read_
buffer

New VI/function; after data is written to a buffer,
this VI/function reads the data

Check Buffer flex_check_
buffer

New VI/function; this VI/function provides
information about the state of the buffer and how
many points have been written to or read from the
buffer.

Clear Buffer flex_clear_
buffer

New VI/function; clears a buffer from RAM

Set Breakpoint
Output MOMO

flex_set_
breakpoint_momo

Allows you to specify an input vector; the VI has
a new terminal and the new function replaces
flex_set_bp_momo



FlexMotion Version 5.0 4 www.ni.com

Set Operation Mode flex_set_op_
mode

Existing VI/function enhanced with two additional
operation modes for contouring

Configure
High-Speed Capture

flex_configure_
hs_capture

New VI/function replaces Set High-Speed Capture
Polarity and flex_set_hs_cap_pol. You can
now choose six configurations, including digital
input on 7344 family FlexMotion controllers.

Enable High-Speed
Capture

flex_enable_hs_
capture

New VI/function replaces Enable High-Speed
Position Capture and flex_enable_hs_caps.

Enable Breakpoint
Output

flex_enable_
breakpoint

New VI/function replaces Enable Breakpoint and
flex_enable_bp, and allows you to enable or disable
a breakpoint without having to set the breakpoint
configuration parameters.

Configure
Breakpoint

flex_configure_
breakpoint

New VI/function; contains the configuration
parameters previously located in the Enable
Breakpoint VI/function.

Select Signal flex_select_
signal

Existing VI/function has new options for routing
encoder and index signals over RTSI, making
cross-board synchronization easier.

Wait for Move
Complete/
Wait for Blend
Complete

Does not apply 
to equivalent 
functions

Existing VIs; the default timeouts have changed
from 1,000 ms (1 s) to 10,000 ms (10 s).

Read I/O Port/
Set I/O Port Polarity/
Set I/O Port MOMO

flex_read_port/
flex_set_port_
momo/
flex_set_port_
pol

Existing VIs/functions; the Real-Time Systems
Integration (RTSI) port has changed from port 5 to
port 9. Your older VIs and programs that use port 5
will still work with this release, but will cease to
function with the next release.

Table 1. FlexMotion VI and Function Changes and Additions (Continued)

VI Function Description
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Controllers
The FlexMotion controllers and their respective bus types are listed in
Table 2.

The FlexMotion 5.0 software is compatible with
Windows 2000/NT/Me/9x.

Compatibility Issues
If you have previously developed programs using the FlexMotion VI
Library and/or Software 4.5, you should read this section. If you are a
first-time user of FlexMotion, skip this section. This section describes the
compatibility of FlexMotion 5.0 with earlier versions of FlexMotion.

For FlexMotion 5.0 to work, you must have version 5.0 firmware or later
on your FlexMotion controller. Refer to the MAX online help for
information on updating your FlexMotion controller firmware.

Your VIs developed with FlexMotion 4.5 will continue to work with
FlexMotion 5.0, but National Instruments recommends you update them
to take advantage of the new features in version 5.0. Refer to the Changes
to VIs and Functions section of this document for a list of new and changed
VIs.

Error Code Changes Affecting C, LabWindows/CVI, and
Visual Basic Users

As part of the FlexMotion 5.0 Software release, the error codes returned by
the functions in the FlexMotion DLL have been changed. This change
gives you better integration with other National Instruments products. This
change moves the error codes to the –70000 to –79999 and 70000 to 79999
range with 0 remaining the value for no error. As always, you should

Table 2. FlexMotion Series Motion Controllers

Controller Bus Type

PXI-7344 PXI/CompactPCI

PCI-7344 PCI

FW-7344* IEEE-1394

PCI-FlexMotion-6C PCI

PC-FlexMotion-6C ISA

* Windows 2000/Me/98 only.
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use the predefined symbolic names found in the MotnErr.h and 
MotnErr.bas header files. A list of these symbolic names can be
found in the FlexMotion Software Reference Online Help.

You must recompile existing applications that directly compare return
values from a function call to a specific error code. These comparisons will
no longer work correctly and your application will not respond as expected.
If you cannot recompile your applications, do not install FlexMotion 5.0
Software.

If your code only uses the constant NIMC_noError to check for the
presence of errors, you do not need to recompile.

Converting LabVIEW Applications Using Earlier FlexMotion VIs
The 4.5 release of the FlexMotion VIs provided a way to convert older
LabVIEW applications to use the improved error handling features of the
new VI set.

This method of converting user applications is no longer supported by
LabVIEW and the 5.0 release of the FlexMotion VIs. You have three
options if you have applications written with the FlexMotion VIs 4.0 or
older and want to upgrade to the FlexMotion 5.0 VIs:

• You can install the compatibility libraries that contain all the older VIs.

• You can rewrite your applications using the new VIs.

• You can first install the FlexMotion 4.5 VIs and go through the
conversion process and then install the FlexMotion 5.0 VIs.

To learn more about the conversion process, refer to the FlexMotion VIs 4.5
Release Notes.

The FlexMotion VI Library works with LabVIEW versions 5.1 and later.
If you have an older version of LabVIEW, contact National Instruments for
an upgrade.

FlexMotion Software Installation
Install the FlexMotion software before installing a FlexMotion series
motion controller for the first time. If you are upgrading from a previous
version of the FlexMotion software, you do not need to remove your
FlexMotion controller before installing the upgrade. Your existing
Windows configuration settings are not affected by the upgrade.
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Complete the following steps to install your FlexMotion software:

1. Insert the NI-Motion 5.0 CD into your CD-ROM drive. The CD will
automatically show the NI-Motion installation screen.

2. Click FlexMotion 5.0 Installation and then choose the Install option.

3. Follow the installer prompts through the rest of the installation.

4. Refer to the ReadMe.txt file after the installation is complete for
last-minute information not contained in this document or the
FlexMotion online help.

The FlexMotion software you selected is installed.

FlexMotion ServoTune
The FlexMotion ServoTune application for tuning servo motors is
provided free of charge on your NI-Motion 5.0 CD in the
\Other\ServoTune\FlexMotion directory. To install the
ServoTune application, run setup.exe from the Disk1 subfolder.

If you install the FlexMotion VI Library 5.0, you do not need to install
ServoTune. The tuning VIs are included on the FlexMotion LabVIEW
function palette.

You will need to manually enter the PID parameters you established in
ServoTune into the PID configuration panel in MAX. To access the PID
configuration panel:

1. Expand the Devices and Interfaces category in the configuration tree.

2. Expand the device and default initialization settings items.

3. Select Axis Settings from the configuration tree and select Control
Loop from beneath the configuration view.

4. Use the slides and numerical edit boxes to enter you PID parameters.

The serial number for the ServoTune application, which you need during
installation, is f45m45454.

Software Updates
You can find FlexMotion 5.0 updates and patches by visiting
ni.com/motion and clicking on Drivers & Downloads.
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Hardware Installation
If this is the first time that you have installed the FlexMotion software
on your computer, then complete the following steps to install your
FlexMotion series motion controller.

Note Refer to Chapter 2, Configuration and Installation, of your motion controller
hardware user manual if you need additional hardware installation and handling
instructions.

PCI/PXI/FW Installation
Complete the following steps to install your PCI/PXI/FW motion
controller:

1. Shut down your computer.

2. If you are installing a PCI or PXI controller, install the controller in an
available slot in your computer. If you are installing the FW-7344,
connect the controller to your computer’s IEEE-1394 port.

3. Restart your computer.

4. Click on the Start button on your Windows 2000/NT/Me/9x taskbar
and select Programs»National Instruments»Measurement &
Automation to launch MAX. Expand the Devices and Interfaces
category in the configuration tree and select your installed FlexMotion
controller. MAX automatically assigns the first available board ID to
your controller.

5. Press F1 or select Help»Help Topics»NI-Motion to view the online
help for MAX. The online help contains complete information on
verifying your configuration, testing the installed FlexMotion
controller, and downloading new firmware.

Your PCI/PXI/FW motion controller is successfully installed.

ISA Installation (PC-FlexMotion-6C Only)
For ISA installation instructions, refer to the online help topic Adding
Your Motion Controller in MAX. To access MAX online help for
Motion, click the Start button on your Windows task bar and select
Programs»National Instruments»Measurement & Automation. Next,
select Help»Help Topics»NI-Motion»Motion Configuration Help from
the MAX menu.
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Using the Online Manuals
The FlexMotion documentation is shipped with your software as Adobe
Acrobat portable document format (PDF) files. The software
documentation is also installed as a Windows online help file.

Note If you do not already have Acrobat Reader version 4.0 or later installed on your
system, you can install it from the FlexMotion Software CD. Run the rs40eng.exe file
found in the CD’s Other\Adobe Acrobat\Win32 directory. To view the installed PDF
documents, click on the Start button on the Windows taskbar and select Programs»
National Instruments»Motion»FlexMotion Software 5.0 and then the document that
you wish to view. This automatically launches the Acrobat Reader and opens the selected
PDF file. You can assemble your own printed manuals, printing either the entire
documentation set or just the sections relevant to your application.

Click on any entry in the table of contents to jump directly to the
corresponding manual page. You can jump to major sections within each
document quickly and easily by clicking on the bookmarks.

When you choose the View»Go To Page option or are printing pages, you
must use the page numbers in the lower left corner of the Acrobat window,
not the number displayed in the bottom center of each manual page or listed
in the contents and index. Acrobat assigns consecutive numbers to each
page throughout the document and displays the page number. The numbers
may not match those shown at the bottom center of each manual page.
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