
 

Microsoft Dynamics™ GP

Electronic Signatures



Copyright Copyright © 2006 Microsoft Corporation. All rights reserved.

Complying with all applicable copyright laws is the responsibility of the user. Without limiting the 
rights under copyright, no part of this document may be reproduced, stored in or introduced into 
a retrieval system, or transmitted in any form or by any means (electronic, mechanical, 
photocopying, recording, or otherwise), or for any purpose, without the express written 
permission of Microsoft Corporation. Notwithstanding the foregoing, the licensee of the software 
with which this document was provided may make a reasonable number of copies of this 
document solely for internal use.

Trademarks Microsoft, Dexterity, Microsoft Dynamics, and Windows are either registered trademarks or 
trademarks of Microsoft Corporation or its affiliates in the United States and/or other countries. 
FairCom and c-tree Plus are trademarks of FairCom Corporation and are registered in the United 
States and other countries.

The names of actual companies and products mentioned herein may be trademarks or registered 
marks - in the United States and/or other countries - of their respective owners.

Unless otherwise noted, the example companies, organizations, products, domain names, e-mail 
addresses, logos, people, places, and events depicted herein are fictitious. No association with 
any real company, organization, product, domain name, e-mail address, logo, person, place, or 
event is intended or should be inferred.

Intellectual property Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual 
property rights covering subject matter in this document. Except as expressly provided in any 
written license agreement from Microsoft, the furnishing of this document does not give you any 
license to these patents, trademarks, copyrights, or other intellectual property.

Warranty disclaimer Microsoft Corporation disclaims any warranty regarding the sample code contained in this 
documentation, including the warranties of merchantability and fitness for a particular purpose.

Limitation of liability The content of this document is furnished for informational use only, is subject to change without 
notice, and should not be construed as a commitment by Microsoft Corporation. Microsoft 
Corporation assumes no responsibility or liability for any errors or inaccuracies that may appear 
in this manual. Neither Microsoft Corporation nor anyone else who has been involved in the 
creation, production or delivery of this documentation shall be liable for any indirect, incidental, 
special, exemplary or consequential damages, including but not limited to any loss of anticipated 
profit or benefits, resulting from the use of this documentation or sample code.

License agreement Use of this product is covered by a license agreement provided with the software product. If you 
have any questions, please call the Microsoft Dynamics GP Customer Assistance Department at 
800-456-0025 (in the U.S. or Canada) or +1-701-281-6500.

Publication date March 2006



Contents 
Introduction ................................................................................................ 2 

What’s in this manual? ...............................................................................................................2 
Symbols and conventions...........................................................................................................3 
Resources available from the Help menu ................................................................................3 

Printable Manuals ...............................................................................................................3 
Orientation Training ...........................................................................................................3 
Microsoft Dynamics GP Online.........................................................................................3 
Customer Feedback Options..............................................................................................4 

Send us your documentation comments..................................................................................4 

Chapter 1: Installation ............................................................................... 5 
System requirements ..................................................................................................................5 
Before you begin..........................................................................................................................5 
Registering Electronic Signatures..............................................................................................5 
Installing Electronic Signatures .................................................................................................6 

Chapter 2: Electronic signatures overview ............................................. 8 
How does Electronic Signatures work?....................................................................................8 
Deciding where to apply electronic signatures .......................................................................8 

Chapter 3: Setup ........................................................................................ 9 
Creating electronic signatures ...................................................................................................9 
Creating an electronic signature reason code........................................................................10 
Setting up electronic signature authorizations......................................................................12 

Chapter 4: Working with electronic signatures..................................... 14 
Authorizing changes with Electronic Signatures..................................................................14 
Viewing change history for electronic signatures.................................................................15 

 E L E C T R O N I C  S I G N A T U R E S  1  



 Introduction  
Electronic Signatures for Microsoft Dynamics™ GP enables companies to increase 
control over their system changes.  Electronic Signatures supports one or more 
electronic signature authorizations for system changes, as well as the ability to attach 
electronic signature reason codes and comments to change history. Electronic 
Signatures provides controls to help companies meet the requirements of data 
compliance regulations such as FDA 21 CFR Part 11 and the Sarbanes-Oxley Act. 

The following capabilities are provided by Microsoft Dynamics GP Electronic 
Signatures: 

• Works with any Microsoft Dynamics GP modules or Dexterity-based, third-party 
developed modules. 

• Supports one or more password authorizations and the capture of electronic 
signature reason codes and comments on specified system changes.   

• Provides control on who can authorize each electronic signature.   

• Provides flexibility to set up electronic signatures on system changes that are 
important to you.   

What’s in this manual? 

This manual contains a detailed description of Electronic Signatures, step-by-step 
instructions to guide you through the installation and set up of your Electronic 
Signatures module, and instructions for how to use Electronic Signatures for your 
company. 

This manual assumes that you are familiar with navigation principles in Microsoft 
Dynamics GP and that you know how to operate the Microsoft Dynamics GP 
business system. It also assumes that Microsoft Dynamics GP 9.0 has been installed 
and configured on your computer. 

To make the best use of Electronic Signatures, you should have a working knowledge 
of each Microsoft Dynamics GP module that you use with Electronic Signatures. 
Electronic Signatures integrates with every Microsoft Dynamics GP module, the 
Dynamics system database, and Dexterity-based, third-party developed modules.  

This manual contains the following chapters: 

• Chapter 1, “Installation,” has step-by-step instructions that guide you through 
the installation of your Electronic Signatures module. 

• Chapter 2, “Electronic signatures overview,” includes an explanation of how 
electronic signatures work and a perspective on deciding where to apply 
electronic signatures.     

• Chapter 3, “Setup,” explains how to set up electronic signatures for your 
company. 
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• Chapter 4, “Working with electronic signatures,” explains how authorizations are 
performed with electronic signatures.  It also explains how to access change 
history information associated with electronic signatures.   

Symbols and conventions 

This manual uses the following symbols and conventions to make information stand 
out. 

The warning symbol indicates situations you should be especially aware of when completing 
tasks. Typically, this symbol includes cautions about performing steps in their proper order, or 
important reminders about how other information in Microsoft Dynamics GP may be affected.  

The light bulb symbol indicates helpful hints, shortcuts and suggestions. 

The (>) symbol indicates selections to make from a menu. In this example, from the 
File menu, choose Print. 

File > Print  

Resources available from the Help menu 

The Microsoft Dynamics GP Help menu gives you access to user assistance resources 
on your computer, as well as on the Web. 

Printable Manuals 
Displays a list of manuals in Adobe Acrobat .pdf format, which you can print or 
view. 

Orientation Training 
Accesses online tutorials that show you how to complete basic procedures within 
Microsoft Dynamics GP. Additional tutorials are available through the 
CustomerSource Web site. 

Microsoft Dynamics GP Online 
Opens a Web page that provides links to a variety of Web-based user assistance 
resources. Access to some items requires registration for a paid support plan. 

Current Installation and Upgrade  The most recent revisions of upgrade and 
implementation documentation, plus documentation for service packs and payroll 
tax updates.  

Document Library  The most recent user guides, how-to articles, and white papers 
for users. 

Developer Resources  The most recent documentation and updated information for 
developers. 

Product support information  Information about the Microsoft Business Solutions 
product support plans and options that are available, along with information about 
peer support and self-support resources. 
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Services information  Information about Microsoft Business Solutions support, 
training, and consulting services. 

Microsoft Dynamics GP Community  Access to newsgroups, where you can ask 
questions or share your expertise with other Microsoft Dynamics GP users. 

CustomerSource home page  A wide range of resources available to customers 
who are registered for a paid support plan. Includes access to Knowledge Base 
articles, software downloads, self-support, and much more. 

Customer Feedback Options 
Provides information about how you can join the Customer Experience Improvement 
Program to improve the quality, reliability, and performance of Microsoft software 
and services. 

Send us your documentation comments 

We welcome comments regarding the usefulness of the Microsoft Dynamics GP 
documentation. If you have specific suggestions or find any errors in this manual, 
send your comments by e-mail to the following address: bizdoc@microsoft.com. 

Note: By offering any suggestions to Microsoft, you give Microsoft full permission to use 
them freely. 
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 Chapter 1: Installation  
This chapter explains how to install and register Electronic Signatures. Information is 
divided into the following sections: 

• System requirements 
• Before you begin 
• Registering Electronic Signatures 
• Installing Electronic Signatures 

System requirements 

Electronic Signatures works with the same computers you use to run Microsoft 
Dynamics GP. For the latest compatibility information for Microsoft Dynamics GP, 
see CustomerSource (https://mbs.microsoft.com/customersource). Due to the size of 
some of the Electronic Signatures windows, we recommend a screen resolution of 
1024 x 768 or greater. At this resolution, you will need, at minimum, a 17” CRT 
monitor or equivalent flat screen monitor. 

Electronic Signatures can be used only with the Microsoft SQL Server™ 2000 or the 
Microsoft SQL Server™ 2005 database.  

Before you begin 

The following steps should be completed before you begin the installation of 
Electronic Signatures:  

• Verify that Microsoft Dynamics GP has been installed on your computer. 
 

• Obtain a valid registration key. You will need this to use the product. 

 
No registration key is required when installing Electronic Signatures into Fabrikam, the 
sample company database that comes included with Microsoft Dynamics GP 

• Create a backup copy of your important data. 

• Note the directory location of your Microsoft Dynamics GP installation—you will 
need to know this during the installation. 

• Exit all applications. 

Registering Electronic Signatures 

Before you can use Electronic Signatures in your company database, you must 
register your software. Without a registration key you will only be able to use the 
product in Fabrikam, the lesson company that comes included with your Microsoft 
Dynamics GP software. Microsoft Dynamics GP registration keys may be obtained 
from your Microsoft Partner or from Microsoft customer support directly.  
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Installing Electronic Signatures 

To install Electronic Signatures software on a Microsoft Dynamics 
GP workstation: 
 
1. Double-click the ElectronicSignatures90Setup.msi file. In the Welcome window, 

click Next. 

2. In the License Agreement window, review the End User License Agreement. If 
you accept the terms of the agreement, click I Agree, then click Next. 

3. In the Select Installation Folder window, select the Microsoft Dynamics GP folder 
instance for this product to be installed into. Click Next. 

 

4. In the Confirm Installation window, click Next. The installation program copies 
the Electronic Signatures software and documentation to the Microsoft Dynamics 
GP folder.  

5. When the Installation Complete window appears, click Close. 

To install Electronic Signatures into the company database: 
 

1. Start Microsoft Dynamics GP.  

If the message “Do you wish to include new code now?” appears, click Yes. 

2. In the Company Login window, select the company you want to install Electronic 
Signatures into.  

3. Open the Electronic Signatures Installation window (Tools > Setup > Company > 
Electronic Signatures > Install Electronic Signatures). 

Perform these steps 
once on each company 
that will use Electronic 
Signatures.   
 

4. Click Install: 

6 E L E C T R O N I C  S I G N A T U R E S  



 

5. Click OK. 
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 Chapter 2:  Electronic signatures overview  
This chapter presents an overview of electronic signatures.  Information is divided 
into the following sections: 

• How does Electronic Signatures  work? 
• Deciding where to apply electronic signatures 

How does Electronic Signatures work? 

Electronic Signatures applies preventative controls on changes to fields or windows 
within Microsoft Dynamics GP.  When a user attempts to complete a system change 
that is controlled by an electronic signature, a window becomes visible that requires 
one or more authorized passwords to be entered before the system change can be 
completed.  

Electronic signatures may be applied to most windows and fields within Microsoft 
Dynamics GP.  Electronic signatures may not be set up on changes that occur within 
scrolling windows. 

Deciding where to apply electronic signatures 

Electronic signatures are typically applied to the fields and windows in Microsoft 
Dynamics GP that require preventative controls according to your business processes 
and the needs of your organization.  To decide where you should set up electronic 
signatures: 

Identify the points within Microsoft Dynamics GP that require preventative control. 

Decide who within the organization should be authorized to release the control. 

Decide what information should be captured at the point of the control, and what 
rules should apply capturing this information.  

 
This information may be set up as mandatory, optional or the information can remain hidden. 

Creating electronic signatures requires an understanding of the Microsoft Dynamics 
GP windows and field names.  A good approach is to use Electronic Signatures in a 
test environment prior to activating Electronic Signatures in your live Microsoft 
Dynamics GP environment. 
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 Chapter 3:  Setup 
This chapter covers the process of setting up Electronic Signatures. Information is 
divided into the following sections: 

• Creating electronic signatures 
• Creating an electronic signature reason code 
• Setting up electronic signature authorizations 

Creating electronic signatures 

Electronic signatures are set up in windows associated with the records, or ‘electronic 
documents’, you want to control.  For example, you might want to require an 
electronic signature when a change is made to an inventory item, which is contained 
in the Item Master table, and changed in the Item Maintenance window. 

Prior to creating a new electronic signature, obtain the following related Microsoft 
Dynamics GP information about the location within the system that you would like 
to apply the electronic signature: 

• Product 
• Series 
• Form Name 
• Window Name 
• Attachment Resource (button that saves the document or closes the window) 
• Record Keys 

If you are not familiar with Dexterity Technical names for Forms, Fields, and Windows, a 
good reference within Microsoft Dynamics GP is the Window Descriptions window (Tools > 
Resource Descriptions > Windows). The Window Name can also be found by opening up the 
window for which you want to set up an electronic signature. The Window Name is found at 
the top of the window in the title bar. 

To add an electronic signature to the Item Maintenance window: The electronic signature 
is ‘attached’ to the 
function of this button.  
When the Save button is 
clicked, the electronic 
signature will look for 
any changes to the 
Window.  If there were 
changes, the electronic 
signature will open the 
Signature Entry 
Window, capture 
authorized passwords, 
then close itself and 
allow the Window to 
complete the Save 
process.  

1. From the Tools menu, select Signature Setup (Tools > Company > Electronic 
Signatures >  Signature Setup). 
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2. Select the Record Key or Record Keys for the Signature as follows: 

• Lookup (Tools > Resource Descriptions > Tables) to find the key fields for the 
Microsoft Dynamics GP tables. 

• Click the ellipses button to open the Table Names window.  Select Item 
Master. 

 

Select the information you will capture at the point of the control.  Information to 
capture with the Electronic Signature may include: 

• Electronic signature reason codes 
• Comments 

3. Indicate the capture options that will be applied to the information.  There are 
three (3) capture options for electronic signature reason codes and comments: 

Hide: Disable on the Signature Entry window. The user will not be able to see 
or use this field. 

Provide:  Enable on the Signature Entry window. The user has the option to use 
the field.  However, it is not required for the electronic signature to be valid. 

Require:  Enable on the Signature Entry window. The user must fill in this field 
for the electronic signature to be valid. 

4. Click OK 

Users must log out of Microsoft Dynamics GP and log in again for changes to take effect. 

   
Creating an electronic signature reason code 

Each electronic signature can have its own set of electronic signature reason codes. 
Electronic signature reason codes are user-defined codes that a user can (or must) 
select before completing an electronic signature. An unlimited number of electronic 
signature reason codes can be created for an electronic signature. 

To create an electronic signature reason code for an electronic signature: 
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1. On the Tools menu select Signature Setup (Tools > Setup > Electronic Signatures 
> Signature Setup).  

2. Click the Go To button located in the upper right of the window.  Select Reason 
Codes to open the Signature Reason Code Entry window: 

 

3. Existing electronic signatures are displayed in the upper part of the window.  
Click an electronic signature name to select it. 

4. The Signature name will appear in the Signature field: 

 

5. Enter a Reason Code and Description into their respective fields. 

6. Click the disk icon button next to the Reason Code field to save the electronic 
reason code. 

 
These are required fields. 

The Reason Code will be displayed in the bottom detail section.  
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Setting up electronic signature authorizations 

When a change is made to a field or window that is controlled by an electronic 
signature, a window will appear requiring authorization for the change. Each 
electronic signature may have its own list of authorized approvers.   

To set up authorized approvers for an electronic signature: 

1. On the Tools menu, select Signature Setup (Tools > Setup > Electronic Signatures 
> Signature Setup). 

2. Click the Go To button located at the top right of the window to select Signature 
Authorization.   

3. Existing electronic signatures are displayed in the upper section of the window. 
The Signature Label will appear in the Signature field.  Click an electronic 
signature to select it: 

 

4. Click the User ID lookup button.  

5. Select the user that will be authorized to approve this electronic signature. Click 
the disk icon button next to the User ID field to save the authorized User ID.   

This is a required field. 

 6.  The authorized User ID will be displayed in the bottom detail section: 
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7. Click Done. 
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 Chapter 4:  Working with electronic signatures 
This chapter provides information on how to use Electronic Signatures. The chapter 
is divided into the following sections: 

• Authorizing changes with electronic signatures 
• Viewing change history for electronic signatures 

Authorizing changes with Electronic Signatures 

When an electronic signature is enabled on a window, the window requires 
authorized passwords to be entered before the system change can be completed.  This 
section includes an example of authorizing a change with an electronic signature set 
up on the Item Maintenance window: 

To authorize a change: 

1. Open the Item Maintenance window (Cards >Inventory > Item). 

2. Using the Item Number lookup button, select 100XLG. 

3. Change the Short Description field to "xxxx" :  

 

4. Click Save to attempt to save the record and the Signature Entry window will 
open.  Enter your password, and capture the user name and password from a 
second authorized signer if required.  Also select a reason code and description if 
required. 
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If you are unable to provide the correct information, you must click the Abort button. 

 5. The Signature Entry window will close and return you to the original window. 

Viewing change history for electronic signatures 

Electronic signature data is captured and viewed in the Microsoft Dynamics GP 
Audit Trails module if activated, and in the Extras menu associated with each 
electronic signature.  To view electronic signature history information in Dynamics 
GP Audit Trails, refer to the Dynamics GP Audit Trails user manual. To view 
historical information accessible within the electronic signature:  

1. Open the window where an electronic signature has been attached and select the 
record that has been changed: 

 

2. Select the electronic signature (Extras > View Signature). 

3. The Signature View window will open and display the following information: 

• Record/Document Number 
• Signed By 
• Date of last change 
• Time of last change 
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• Document Version (number of signed changes) 
• Reason Code and Description 
• Comment 

 

4. If the field or window selected does not have an attached electronic signature, the 
following message will appear: 
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