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Basic Safety Instructions

Please read this entire Manual before attempting to Print.

Follow all warnings on and about your printer.•	
Use the proper power source type indicated on the printer’s label and in its •	
User’s Manual.
Connect all equipment to grounded outlets. Do not use the same outlet for •	
any other system, such as a copy machine, an air conditioning unit or a Heat 
Press that may cycle ON and OFF.
Place the printer where the power outlet is easily seen.•	
Do not allow the power cord to become damaged.•	
If you are using an extension cord, ensure the extension cord’s power  •	
ampere rate does not exceed that of the printer’s cord.
Keep electromagnetic devices and other potential sources of magnetic •	
fields away from your printer and computer hard drive(s).
Do not use the printer in locations that may experience  high humidity, •	
shocks, vibrations, debris or dust.
Leave enough space around the printer for proper ventilation.•	
Do not leave your printer near heat sources such as radiators or heat vents.•	
Do not leave the printer in direct sunlight.•	
Place the printer on a stable surface that extends beyond the length •	
and width of the printer supports. The printer will not work properly if it is 		
tilted or leaning.
When packing and moving the printer, do not set the printer on its side or •	
upside down. This may cause the ink to spill.
Turn the printer OFF before cleaning. Clean with a damp cloth and avoid •	
spilling any liquid on the printer.

Caution:

Do not unplug the printer to turn it OFF. Use the power button instead. •	
Do not unplug the printer until the Main Power Switch has been turned 			 •	
OFF. 
Do not block any of the printer’s vents or insert foreign object into its •	
slots. 
Do not attempt to service the printer yourself beyond the troubleshooting •	
techniques covered in this Manual.
Do not attempt to modify any software or device settings not covered in this •	
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Keep the machine on a level surface.•	

Safety Instructions for Ink Cartridges:

Always keep ink cartridges out of the reach of children.•	
While handling ink, be careful not to spill it on your skin. If ink does get on •	
your skin, wash thoroughly with soap and water. If ink gets in your eyes, 			
flush them immediately with water.
Do not put your hand in the printer or touch the ink cartridges while the •	
printer is in operation.
Do not move the Print Head by hand- doing so may damage the •	
printer.
If you remove the ink cartridges, make sure to place them in individual •	
bags and keep them away from dust, dirt and debris.
Store unused ink cartridges in a cool dark place.•	
Allow ink cartridges to warm to room temperature before using them after •	
storage.
Do not dismantle the ink cartridge.•	
Do not touch the IC chip on the ink cartridges. This will adversely effect 			 •	
normal printing operations.

Legend of Symbols
Throughout this Manual you will see three symbols used to notify you of
important facts or procedures.

This icon is used to denote important points that may affect the 
proper operation of your machine or the viability of its output. Think 
of this as more than just a helpful hint.

This icon indicates recommendations based on 
research and development or years of experience within the 
Garment Decorating business. Following these helpful Hints, Tips or 
Reminders will make printing with your Fast T-Jet more enjoyable.

Where you see this icon, you should take note of the warnings. 
Failure to follow any of the listed procedures could result in severe 
damage to your printer, computer or software, large amounts of 
downtime and/or costly repairs, or the possibility of severe bodily 
injury or death.
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Chapter 1
Installation and Getting Started

Welcome to FastARTIST
Your version of FastARTIST includes this Manual, an installation CD, a CD with clip 
art and fonts, a training CD and a training DVD. Your version of FastARTIST will 
work with any Fast T-Jet Inkjet-to-Garment printer, including the T-Jet 3 and the 
Fast T-Jet Blazer.

You should have also received a “Dongle.” The Dongle 
looks very similar to a “Flash Drive” and it plugs into any free 
USB port on your computer. The Dongle acts as a hardware 
protection key. Much like your car keys allow you to start 
your car, the Dongle allows you to use FastARTIST and 
FastRIP. 

DO NOT LOSE OR DAMAGE the Dongle. Without the Dongle, your 
software will not function. Should you lose your Dongle, you will be 
required to PURCHASE a replacement. DO NOT 
insert your Dongle into your computer until instructed to do so by 
this Manual.

System Resources and Requirements

The speed and configuration of your PC will have a significant effect on the 
performance of the FastARTIST program. The minimum system requirements are:

A Pentium IV 1.8 GHz PC with Windows XP, 2000 or Vista Operating System. 	¾¾
	 This application is not compatible with Windows ME.

1 MB RAM (If you are currently using, or planning to upgrade to Windows 		 ¾¾
	 Vista, you will need 2 GB of RAM for the best performance.)

10 GB of free hard drive space for the program files with an additional 50 		 ¾¾
	 GB needed for saved images, artwork, fonts and clip art

A free USB port for the Dongle (A total of three USB ports may be required 		¾¾
	 to accommodate the Dongle, a mouse and a printer connection.)
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FastARTIST is a customized version of a sign and vinyl cutting program called 
SignLAB. Some routines and features that are not applicable to Inkjet-to-
Garment printing have been removed, however this is still a very powerful 
program that can be used as a standalone graphics application comparable to 
Adobe Photoshop or CorelDRAW.

The purpose of this Manual is to familiarize you with this program, as well as get 
you started printing to garments as quickly as possible. It is not intended to be 
a comprehensive guide. If you wish to utilize any of the application’s advanced 
features, the complete SignLAB 7.1 Help Section is accessible via a dropdown 
menu within the FastARTIST program.

It is extremely important that you read the entire User’s Manual 
that came with your Fast T-Jet printer BEFORE you begin printing. 
That Manual contains specific details about your printer that are 
necessary for trouble free operation.

Installing FastARTIST
Insert the FastARTIST CD into your CD drive. Most 
Windows configurations will automatically launch 
the setup program, however, if this is not the case, 
double-click on your desktop My Computer icon and 
locate the drive containing the installation CD. Right-
click on the driver and select Explore. Double-click on 
the Setup icon to launch the Installer.

Note: Due to software upgrades and changes, your installation menus may not 
look exactly like the following images.

You should always close any applications that are running before 
starting an installation. DO NOT insert the Dongle until AFTER 
FastARTIST has been installed.

You will be prompted for what language you wish 
the installation to use. Although FastARTIST menus 
and operations are ONLY in English, you may choose 
another language for installation prompts. The next 
screen will welcome you to the FastARTIST installation. 



Click on Next.

5.	 You will be asked if you wish to install the Fonts. Click 
on Continue to Install all the fonts that came with 
FastARTIST. You may be prompted to insert the Fonts 
CD. If the system does not find the fonts, you can 
copy the Fonts folder from the CD into your FastARTIST 
directory and install them later.

6.	 You will then be asked if you wish to Install the available clip art. This can take 
a long time and uses a fair amount of hard disk space. If you have the time 
and a large hard drive, go ahead and Install them. 

3

You will be prompted to approve 1.	
the license agreement. Check 
Accept and click on Next.

2.	 You will be asked to choose an 
Installation Directory. Advanced 
Windows Users may wish to change the 
destination. For most Users, the default 
destination is the best choice. Click on 
Next.

3.	 You will be prompted to approve the 
Program Folder. Advanced Windows 
Users may wish to change the folder 
name. For most Users, the default name 
is the best choice. Click on Next. 4.	 This screen will appear while 

FastRIP is being installed.
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7.	 When the installation is complete, check 
“Yes, I want to restart my computer now” 
and click on Finish.

After your computer reboots, you should see a FastARTIST icon 
on your desktop.  

If you do not have an icon and you wish to place one 
on your desktop, go to Start > Programs and locate 
the FastARTIST program folder. Mouse over the folder 
to expand contents and you will see two FastARTIST 
listings- one will have a version number after it, the 
other will have “Demo”. Right-click on the icon with 
the version number and select Send To > Desktop.

Any time you wish to launch FastARTIST, 
double-click on the desktop icon.

Dongle Error- Unknown USB Device

The USB Port Dongle is a sealed plug that is provided with 
FastARTIST as a means of preventing software piracy. 
It is important you do not connect your Dongle to your 
computer until AFTER FastARTIST has been installed. 
Otherwise, there is a risk that Windows will label the Dongle 
as an “unknown USB device.”

After plugging your Dongle into your computer, if you receive a Windows error 
balloon stating, “Unknown USB device”:

Go to Start > Settings > Control Panel and double-click on it to open a new 
window.
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Within the Control Panel window, locate and 1.	
double-click on the System icon. Click on the 
Hardware tab. Click the Device Manager 
button. You will see displayed all of the 
hardware that is currently connected to your 
computer.

Within the Device Manager window, locate 2.	
the USB device that is identified as an 
unknown device (this is your Dongle) and 
choose Uninstall.

Exit the Device Manager and close System window.3.	

Unplug the Dongle from your computer.4.	

Place the FastARTIST installation CD in your CD drive. If prompted to choose a 5.	
language, click Cancel.

Go to 6.	 Start > Run. Within the Run dialogue, click Browse and locate the file 
called “HINSTALL.EXE” on the installation CD. Double-click on it to select.

“HINSTALL.EXE” will now be displayed 7.	
in the Run dialogue field. Click within 
the field and type “ -i” (space-hypen-
lowercase letter “i”) immediately after 
the filename.

Click OK and the Dongle driver will be reinstalled. After the installation is 8.	
complete, restart your computer.
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When your computer has rebooted, connect the Dongle to any available 9.	
USB port. It should be properly recognized and associated with FastARTIST as 
a device. If you are still encountering problems, please contact Technical 
Support.

Support Hours
Toll Free 			   +1 888-MYTJETS (698-5387)
Technical Support 		 +1 480-929-2937 
Corporate Office	      	 +1 480-929-0640 
Fax		          		  +1 480-929-0766 
E-mail  			   support@usscreen.com
Internet 			   www.screenprinters.net   Click on the Support tab.
Support hours  		  7:00am to 8:00pm Monday through Friday  
                               		  9:00am to 3:00pm Saturday and Sunday 
                             		
		  24 hr. Emergency Support is available

All times listed are Mountain Standard Time USA
Note: Arizona does not observe “Daylight Savings Time.”  

Do Not Lose the Dongle
The Dongle acts like the key to a lock. It is an integral part of the 
FastARTIST and FastRIP programs and must be treated accordingly. 
If you lose the Dongle, you will be required to purchase a 
replacement. Protect the Dongle! Without it, your software will 
not function. The easiest way to protect yourself from loss or theft 
is to make sure the software AND the “hardware” Dongle are 
covered by your business or commercial insurance plan. (Most 
Homeowner’s policies do not cover business related property!) To 
purchase a replacement Dongle, contact us for pricing 
and details

Dongle Warranty
If failure of the hardware (Dongle) has resulted from accident, abuse or 
misapplication, we shall have no responsibility to replace the hardware. 
Replacement will be warranted for the remainder of the original warranty period 
or 1 year, whichever is longer. If the Dongle ceases to operate within the 1 year 
warranty period, it will be replaced at no charge AFTER it has been returned. 
You must insure the Dongle for at least 
$750 against loss or damage during mailing. If the Dongle is not under warranty, 
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a replacement Dongle may be purchased. Contact us for pricing or 
for details on purchasing or returning a defective Dongle. All returns must be 
shipped by a trackable carrier and have a return authorization number on the 
box provided.

Installing and Configuring FastRIP
FastRIP is the heart of the printing process, 
performing the task of a Raster Image Processor 
(RIP), controlling how much ink is laid down, how 
many passes are made by the Print Head and 
how White ink is printed. FastRIP also manages 
the memory needed for raster images and the 
spooling of multiple jobs to the printer by utilizing 
Virtual Memory (VM) disk processing.

FastRIP does most of this with PostScript. PostScript is an industry-standard 
scripting language used to communicate the text and graphic elements of a 
job from a computer to a printer . When FastRIP processes a job, these PostScript 
elements are used to generate a raster image (a series of horizontal lines) that 
the printer is capable of rendering. The printer will then output your image one 
raster (line) at a time.

When the FastARTIST installation is complete, it can be launched by double-
clicking on its icon. However, you will not be able to PRINT an image using your 
Fast T-Jet until FastRIP has been configured.

From your desktop go to Start > Programs > 
FastARTIST.  A dropdown menu will open to the 
right. Click on the FastRIP listing. A Configure Printers 
window will open, prompting you to select a printer. 
Select the applicable Fast T-Jet printer.

The second window will query you for the location of a Printer Package. A 
printer package contains all of the custom Print Modes that tell FastRIP how to 
print on garments and they located are on the FastARTIST CD labelled “Printer 
Package Drivers.” (Also check www.screenprinters.net for any recently released 
Printer Package updates.)

When prompted, select the option “Search for new printer package versions 
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from CD” and insert the CD in the CD Drive.  Put a check mark by “Search CD-
ROM or floppy drive.” Click Next. Click Next. Click Finish.

You will then be asked to tell FastRIP to which port 
your printer is attached. Select your printer and verify 
the connection port. If the printer is connected to 
your computer by a USB cable, the correct port will 
look like Epson Stylus 2200_USB00*, Epson Stylus Pro 
4800_USB00*, Epson Stylus 7600, or Epson Stylus Pro 
1800_USB00*. If you are using a parallel port cable 
(this option is not available for the Fast T-Jet Blazer), 
the extension will be LPT*. 

Configuring FastRIP from within FastARTIST
You may also configure FastRIP from within FastARTIST. 
Select File > FastRIP Setup. This will bring up a different 
window that will determine how your printer is 
connected. It will then launch FastRIP, allowing you to 
perform the setup process. (Chapter 7 covers in detail 
FastRIP configuration as well as Print Modes and other 
options.)

The FastRIP Queue
This is the same window you will see when the RIP 
is working. The top menu allows you to change 
many of the RIP settings. 
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Verify Printer Installation
Open the Manage Printers window. Go to Printers 
> Manage Printers and ensure sure your Fast T-Jet 
appears under Printers. Verify the Port settings as 
well.

From this screen, you may also troubleshoot and 
change ports, if necessary. 

If you wish to be able to print DIRECTLY to FastRIP from programs 
like CorelDRAW, Illustrator or Photoshop, you MUST put a check 
in by it in the Control Panel menu. This will add the printer to the 
Printers Window, allowing other programs access to it. Fast T-Jet 
Blazer Users may ONLY print directly from programs other than 
FastARTIST when outputting CMYK images that do not need 
white ink. However, we recommend you Import ALL images into 
FastARTIST for printing, even if using an eight color system.

Removing FastARTIST
If FastARTIST is not operating correctly and you 
are asked to uninstall it, move any artwork you 
have stored in the FastARTIST root directory into 
a separate folder before deleting the program. 
Select Add/Remove programs from the Control 
Panel (Start > Settings > Control Panel), highlight 
FastARTIST and select Change/Remove.

Repeat this process to remove FastRIP. You 
MUST remove BOTH FastARTIST and FastRIP or 
the reinstallation can cause serious system errors.

After removing both FastARTIST and FastRIP, locate the FastARTIST folder on your 
hard drive and delete it. Empty your Recycling Bin and begin the reinstallation 
process as directed. 
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Chapter 2
An Overview of the Workspace

Workspace Elements
The FastARTIST Workspace is a visual representation of a Page in which you can 
compose and/or manipulate an image for output. Surrounding the Page are 
numerous Toolbars to assist in creating and modifying text and images. The 
dimensions of the Page Size are determined by the printable area of your Fast 
T-Jet (consult your printer’s User’s Manual for more details), but what you can 
create using this powerful software is limited only by your imagination.
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The basic display of Workspace Objects may be modified by accessing the 
View menu. The functions available from this dropdown are summarized in the 
following table:

Show Page Size  Toggles ON/OFF an outline that visually represents the Page Size.

Show Substrate 

Set the Page Size color according to the substrate color, as 
indicated by the currently selected Sheet Layer Plate. When the 
Show Substrate option becomes disabled, the Page Color will be 
reset to White.

Show Fill  Toggles ON/OFF the use of wireframes to improve screen refresh 
time.

Show Bitmap 
Outlines 

Toggles ON/OFF outlines in place of bitmaps to improve screen 
refresh time.

Link Show Fill and 
Bitmap Outlines

When Show Fill is toggled, this causes wireframes to be shown 
instead of the bitmap image.

Show Line Style  Toggles ON/OFF the display of line styles for Workspace Objects.

Show Overprint and 
Overlap 

Toggles ON/OFF the display of crosshatch and diagonal patterns 
used to indicate a shape that will be printed with the Overprint or 
Overlap property.

Show Rulers  Toggles ON/OFF the display of the Workspace rulers.

Show Bitmaps Only Hides all Objects that are not bitmaps.

Show Reduced 
Bitmaps 

For display purposes only- reduces the color depth and resolution 
of bitmaps. This will improve the screen refresh time.

Show Grid  Toggles ON/OFF the display of grid lines.

Show Guide Labels  Toggles ON/OFF the display of guideline labels.

Palettes  Allows the User to choose which color palettes are visible.

Toolbars  Allows the User to choose which custom toolbars are visible.

Show Instant Replay  Displays the Instant Replay window.

Show Storage Bin  Displays the Storage Bin window.

Multiple Document Windows

To have more than one design window open at the same time, enable Multiple 
Instance under the Options menu. To create additional windows, you would 
use the File > New command. To manage these windows, there will be two 
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additional commands under the File menu:

Close – Closes the current design window (You will be prompted to ▪▪ Save 		
	 your work.)

Close All – Closes all open design windows▪▪

Having extra FastARTIST windows allows for components of a design to be edited 
separately and then combined. To move a selected Object between windows, 
use the Copy and Paste commands. You may also drag-and-drop Objects 
between windows.

Workspace Colors

This will customize the basic appearance of the Workspace. For access, select
Options > Workspace Colors:

Background Color refers to the area around the ▪▪ Page.
Grid Color refers to the grid lines in the Workspace.▪▪
Guideline Color refers to the guides.▪▪
Page Color refers to the edge of the ▪▪ Page.

The color of the Page is set within the Current Selection attributes found in the 
Layout > Page Size dialogue.

Refresh Screen

To refresh the Workspace, select Edit > Redraw.

Origin Selection

Origin Selection is used to indicate the zero-zero (0, 0) position of the Page. By 
default, this position is set to the top left corner.
 
Orientation

Orientation refers to the rotation of the Page. This setting is independent of Page 
Orientation, which is used when printing.

Page Size

Page Size is a visual representation of the area that is available for placement of 
a printable image. This allows for the spatial arrangement of Workspace Objects 
to be verified prior to sending a job to FastRIP. Page Size is normally selected by 
using a template specifically designed for your Fast T-Jet printer, but you may 
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customize this as long as you don’t exceed the maximum printable dimensions 
of your machine. (Consult your printer’s User’s Manual for details.)

The Page Size dialogue is accessed by choosing Layout > Page Size. 
       

  

Current Selection

The Current Selection dropdown menu is used to choose the dimensions (width 
by height) of the Page Size. If Custom Size is chosen, then the Width and Height 
fields must be manually entered.

FastARTIST refers to its Page dimensions in terms of “Width” and 
“Height.” For purposes of printing a two-dimensional image on a 
garment or non-textile item, it is important to be aware of the fact 
that “height” means the same thing as “length.” 

Dimensions

The Dimensions section of the Page Size dialogue displays the current dimensions 
of the Page. If the Landscape option is enabled, the image’s orientation will be 
rotated 90° clockwise.

Advanced Settings

Click on the Advanced button to 
toggle ON/OFF the display of the 
Advanced Blank Size Controls.

(Note: Blank and Page are 
synonymous within this application). 
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These controls are used to create a new Page Size (Blank) that can be added to 
the Current Selection list.

The Advanced Controls window contains two lists of Page Sizes. The top 
list contains Page Sizes that have yet to be added to the Current Selection 
dropdown menu. The bottom list contains Page Sizes that are already available 
from the Current Selection dropdown menu.
 
Create and Add a New Blank

If the Create and Add new blank 
size button is pressed, the Advanced 
Blank Size Controls will be temporarily 
replaced with controls for entering a 
new Page Size.

After entering the Name, Width, 
Height and Units for the new Blank, 
click on the Add New Blank button. 
The new Page Size will be added to 
the list of available Page Sizes.

Add to List

For a selected Page Size in the top list, click on the Add to List button to add it to 
the Current Selection dropdown menu.

Delete

For a selected Page Size in the top list, click on the Delete button to remove it 
completely.

Remove From List

To remove a Page Size from the Current Selection dropdown menu, highlight it 
in the bottom list and click on the Remove From List button. The Page Size will 
remain in the top list to be selected at a later time.

Display at Start Up

If the Display at start up option is enabled, the Page Size dialogue will open 
when a new Workspace is created.

Chapter 2- An Overview of the Workspace
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Order of Workspace Objects 
Objects are usually edited in terms of their width and height, however 
Workspace Objects also have a layering order that determines which Objects 
appear on top of other Objects. The order of individual Objects may be 
modified using the following commands from the Arrange > Order menu.

To Front [Ctrl + F] Position the selected Object before all other Objects

To Back [Ctrl + B] Position the selected Object behind all other Objects

Forward [Ctrl + U] Increase the relative position of the Object

Backward [Ctrl + L] Decrease the relative position of the Object

Reverse [Ctrl + M] Invert the relative order for a group of selected Objects

Toolbars
There are four toolbars available in FastARTIST- System, Operation, Workspace 
and Tools.

To toggle a toolbar ON or OFF, select ▪▪ View > Toolbars.
To customize the toolbars, select ▪▪ View > Toolbars > Customize.
Toolbars may also be customized by▪▪  right-clicking on them.

 
Custom Toolbars 

The System, Workspace and 
Tools toolbars are available 
by default. The additional 
toolbar, Operation, may be 
toggled ON from the View 
menu. 
 

Circle has a lower layer 
order than the square

Circle has a higher layer 
order than the square
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Should you wish to create a new Toolbar, you would use the Customize Toolbar 
dialogue to Add, Remove or rearrange the available commands.

The Customize Toolbar controls available are:

Available 
Toolbar Buttons

This list displays the buttons that are not currently on the Customizable 
Tool Palette. To add a button to the palette, first select the button from 
this list, and then click on the Add button.

Add To add a button to the Customizable Tool Palette, select a button from 
the Available toolbar buttons list, and then click on the Add button.

Current Toolbar 
Buttons

This list displays the buttons that are currently on the Customizable Tool 
Palette. To remove a button from this list, first select the button from this 
list, and then click on the Remove button.

Remove
To remove a button from the Customizable Tool Palette, select a button 
from the Current toolbar buttons list, and then click on the Remove 
button.

Close Click on the Close button to exit the Customize Toolbar dialogue.

Reset The Reset button returns the Customizable Tool Palette to the settings 
that were in effect when the Customize Toolbar dialogue was opened.

Help Press the Help button to access the On-line Help.

Move Up To increase the priority of a button, first select that button in the Current 
toolbar buttons list, and then click on the Move Up button.

Move Down To decrease the priority of a button, first select that button in the Current 
toolbar buttons list, and then click on the Move Down button.

System Toolbar

The System toolbar includes the tools for file operations. To toggle the toolbar 
ON/OFF, select View > Toolbars.

New Open a new Workspace

Blank Size Opens the Blank Size dialogue where you can change the 
dimensions and orientation of the Page

Open Open a previously stored selection of operations
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Save To save operations for later use, select the desired operations and 
click on Save File. 

Import Import a file into the Workspace

Export Exports the Workspace, allowing you to save it in a variety of file 
formats

Undo Reverse the previous operation. When node editing, only five levels 
of Undo are permitted.

Redo Reverse the previously performed Undo operation

Close 
Window Closes the current FastARTIST window

Exit Exit FastARTIST.

Workspace Toolbar

Remove All Guides

Instant Replay

Show Storage Bin

Simplify

Gradient Fills

Multi-Spot Gradient Fills
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Pattern Fills

Metamorphosis

Render to Bitmap

Clipping

Clipping Clear

Contour Cut

Array

Alignment

Outline

Shadows

Transformation

Fit Text to Path

Sort Colors - By All Objects

Pan State

Percent Zoom

Print and Cut

Tools Toolbar
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Select The Select tool is used to select Objects.

Measure Measure tools are used to label Workspace dimensions, and to 
place notes about Workspace Objects.

Text Text tools are used for creating text on the Workspace.

Zoom Zoom tools are used to zoom in and out to view the Page.

Weld Weld tools are used to bond overlapping shapes into a combined 
Object.

Shape Basic shapes are available from the Shapes toolbar.

Graphics 
Edit

The Graphics Edit tools are available for node, free, and arc 
editing.

Scan The Scan tools include FastScan, Photo Machine, and Center Line 
Tracing. 

Stroke 
and Fill

Line Style, Gradient and Pattern Fills are available from the Stroke 
and Fill toolbar

Ginsu 
Knife

Open and Close Path tools are available from the Ginsu Knife 
toolbar.

Zoom Tools 

The zoom functions:
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Zoom In [F5] Focus on marquee drawn by cursor. Right-click on 
to zoom out.

Zoom Out [F6] Display more area of the Workspace.

Zoom to 
Selected Object [F7] Fit the viewing area to the selected Objects. If no 

Objects are selected, then fit to all Objects.

Zoom to Blank 
Size [F8] Fit the viewing area to the Page.

Zoom to 
Previous View [F9] Toggle between the current and previous zoom 

levels.

Pan Workspace [Middle 
Button] Click-and-hold on Workspace, then drag view.

Percent Zoom [Mouse 
Wheel] View Workspace at a specific zoom level.

SmartBar Controls

The SmartBar is a special toolbar in FastARTIST that provides context-sensitive 
controls according to the type of operation that is being performed. When a 
shape is selected, the SmartBar displays information such the Object’s Size and 
Position.

If you undock or close the SmartBar, there is no button to push 
to “find” or restore the SmartBar. If you do not have a SmartBar, 
please call Technical Support for help with restoring it.

Objects Selected

The Object type is listed at the far-left of the SmartBar. 
The number after the Object type indicates the database 
order of the Object. When pressing [TAB] to advance 
between different Objects, the [TAB] order is the same as 
the database order.
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Current Nub

Selecting an Object will reveal its 
bounding-box, which are nine square 
nubs used for moving, scaling and 
resizing. Within the SmartBar, the anchor 
controls indicate the current nub. When 
the SmartBar is used to move or resize an 
Object, the current nub is used as the 
reference point. For example, clicking the 
lower-left nub in the SmartBar will indicate 
that Object should be resized with respect 
to its lower-left bounding box.

If the anchor nub is clicked in the SmartBar, then a small, “anchor” icon will 
appear within the bounding box. To use the anchor nub, position the anchor 
over a specific part of the shape and type new X and Y coordinates in the 
SmartBar. The anchor will be moved to the new coordinates and the Object will 
be moved with the anchor.
 
X & Y Coordinates of Mouse/Cursor

Below the Objects Selected field, the X and Y coordinates 
of the cursor are displayed, as well as the current units of 
measurement that are being used on the Workspace.

Object Coordinates 

The X and Y fields display the coordinates of the selected Object.

These coordinates may be changed by dragging the 
Object with the mouse or by entering a new value in one 
of the fields. After entering new data in a field, press the 
[Enter] key to confirm the new coordinates.

Object Width and Height

The Width and Height fields display the size of the selected Object.

These dimensions may be changed by resizing the Object 
with the mouse or by entering a new value in one of the 
fields. After entering new data in a field, press the [Enter] 
key to confirm the new values.
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Object Scale

The Object Scale fields are used to resize the Object as a 
percentage of its original dimensions.

The Object Scale arrows will resize the Object in 5% 
increments or you may the values by manually entering data into one or both 
fields. After entering new data in a field(s), press the [Enter] key to confirm the 
new values.

Aspect Ratio

When an Object is either resized or scaled, the Aspect 
Ratio button may be maintained by activating this button.

Rotation

The Rotation field indicates to what degree the Object will be rotated.

Rotation Arrows will rotate the Object in 15 degree 
increments. Rotation may be manually changed by 
entering a new value in the field. After entering new data 
in a field, press the [Enter] key to confirm the new value.

Object Color

The Fill and Stroke color for the selected Object is 
displayed at the far right of the SmartBar . If no Object is 
currently selected, then the default Fill and Stroke colors 
are displayed.

Fill Primer

The Fill Primer indicates which Primer color has been 
applied to the Object Fill. If no Object is currently 
selected, then the Fill Primer will not be displayed.

Stroke Primer

The Stroke Primer indicates the primer color that has 
been applied to the Object Stroke. If no Object is 
currently selected, then the Stroke Primer will not be 
displayed.

Chapter 2- An Overview of the Workspace



24

Fill Halftone

Fill Halftone indicates the halftone that has been 
applied to the Object Fill color. If no Object is currently 
selected, then Fill Halftone will not be displayed.

Stroke Halftone

Stroke Halftone indicates the halftone that has been 
applied to the Object Stroke color. If no Object is 
currently selected, then Stroke Halftone will not be 
displayed.

Scrolling and Panning 
Scroll bars along the vertical edge and bottom of the screen enable viewing 
any portions of a graphic not currently in the window. 
 
Vertical/Horizontal Scroll Bars
	
Vertical and Horizontal Scroll Bars are used to scroll through the current window 
to view another part of the image. This is very useful when viewing a graphic in 
zoom mode.

Scroll Bar Arrows

Clicking on an Arrow causes the viewing window to move in the direction 
indicated by that Arrow. This will have the appearance of moving the graphic in 
the opposite direction a short distance. This distance is approximately 1/10 the 
width or height of the view screen, depending on whether you are moving the 
screen vertically or horizontally.

Scroll Bar Elevators

Clicking on a Scroll Elevator causes the viewing window to move in the 
appropriate direction a large distance. The distance moved is approximately 
equal to 1/3 the width or height of your view screen, depending on whether you 
are moving your view vertically or horizontally.

Scroll Bar Thumb

Dragging a Scroll Bar Thumb within the Scroll Bar causes the viewing window to 
move in the direction of the thumb in very large increments. How far the view 
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screen actually moves depends on how far the thumb is moved within the Scroll 
Bars. When deciding how far to drag the Scroll Thumb, be aware that the ends 
of the Scroll Bar represent the outer edges of the file on screen.

Guidelines 
A guideline is a vertical or horizontal reference that is used for placing Objects. 
Objects will “snap” to a location when they pass over a guideline.

You may create and edit guidelines several different ways:

Right-click1.	  on a ruler to create a guide

To create guidelines for 2.	
a selected Object, press 
[Shift] and right-click on the 
Object handles. (This will 
not work when editing a 
parametric shape.)

To add guides when Node editing, press [Shift] and 3.	 right-click on the Node

Open the 4.	 Edit Guides dialogue by right-clicking on the Workspace with no 
Objects selected

Open the 5.	 Edit Guides dialogue by selecting Options > Guides > Edit Guides

When dragging the position of a guide, press [Shift] to constrain a guideline 6.	
to the nearest ruler increment

To remove a guide, press [Shift] and 7.	 right-click on the guide with no Objects 
selected

As an example, the following steps will create a guideline between two points:

Right-click on 1.	 the Workspace to open the Edit Guides dialogue

Set the guideline orientation to diagonal and choose two points from the 2.	
drop-down list

Set the coordinates for Point 1 and Point 2 and click on the 3.	 Add button. The 
resulting guideline will pass through the indicated points

Note: As many as sixty guidelines in either direction may be displayed on the 
screen at one time.
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Align Palette 

Holding down the [Ctrl] key while right-clicking on the Workspace will display 
the Align Palette. This provides tools for aligning Objects with respect to any grid 
lines. 

Set Origin Set the grid origin to the selected location.

Resize grid Resize the grid increments based on the distance between the 
selected location and the grid origin.

Snap to Grid 
Intersection

Move the Object, such that the nub is at the nearest grid 
intersection.

Snap 
Vertically

Move the Object, such that the nub is at the nearest horizontal 
grid line.

Snap 
Horizontally

Move the Object, such that the nub is at the nearest vertical grid 
line.

To reset the Origin, choose Reset Origin under the Options menu.

Workspace Options
General Preferences

The General Preferences dialogue contains 
basic Workspace settings that are common 
to most features. To access this window, 
select Options > FastARTIST Setup > General 
Preferences.

Units

Unless otherwise specified, the Units set in the General Preferences dialogue 
will be used throughout the FastARTIST Workspace and features. You may also 
change the Units used by clicking on the Workspace rulers.

Layer Number

The Layer Number toggles the display of Color Plate numbers.
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Speed Scrolling

If Speed Scrolling is active, then dragging off the edges of the Workspace will 
cause the Workspace to scroll. There are three options for speed scrolling:

Off Disable speed scrolling

Object Move Only perform speed scrolling when dragging an Object.

Full Perform speed scrolling when dragging an Object, or when dragging a 
marquee.

Duplicates

When using the Duplicate command, Offsets specified here will be applied to 
the placing of new Objects with respect to the original.

Grid Size

The grid dimensions are set in the General Preferences dialogue. The Snap Angle 
is used when [Ctrl] is held during certain operations, such as when editing line 
segments and corners.

Polyarc/Polygon

The Polyarc/Polygon setting indicates the type of shape that is produced by 
certain features, such as Welds, Shadows or Outlines.

Export Error Tolerance

When Exporting a file from FastARTIST, the file sometimes contains a very large 
number of Nodes. This is especially true of artwork that was originally imported 
from another software application. As a solution, FastARTIST files can be 
exported using a certain Tolerance Level. This will make the exported artwork 
smoother, as well as substantially reduce the number of required Nodes.
 
Error Tolerance is specified using the current 
Workspace units. We caution against a high Error 
Tolerance value, since this may introduce distortions 
of the exported Objects. Generally, the default values 
(0.001 or 1/1,000 of an inch) will work very well for most 
files.
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Undo Setup

The Undo Setup dialogue is used to limit the 
resources that are used for storing Undo 
operations. Limiting the resources can 
prevent the loss of system performance 
that could occur when large quantities of 
image data are in the Undo stack.
 
Font Setup

Font Settings are used to specify the font type 
and point size used in dialogue boxes.

Use 
Default

Indicates that the standard Windows 
font should be used.

Automatic Chooses the most appropriate font 
to be used.

Select Enables the dialogue font to be 
chosen.

Color Management
Monitors and printers are sometimes referred to by the quality of their gamut. 
Gamut represents the entire range of colors that a device is capable of 
reproducing. Although it is not possible, a perfect gamut would be all the 
colors the human eye is capable of perceiving. Compared to large format 
printers, monitors have a smaller gamut. Furthermore, some printer colors are not 
reproducible on a monitor and vice-versa.

Color Management settings can be accessed through the Options menu. These 
settings indicate the input and output profiles that will be used when:

Using a device (i.e., a scanner) to import an image or line art▪▪

Using a monitor to display the artwork while editing▪▪

Printing to a specific model of printer with specific media and loaded inks▪▪
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When FastARTIST is installed, 
SignLab 7.1 settings are used as 
the default profile. For previous 
FastARTIST users, SignLab 7.0 
profiles are available if needed. 

Select Custom and click on 
Advanced to select the specific 
desired.

When using FastARTIST for screen 
proofing, the Color Management 
profile is used to reconcile printer 
colors with that of the monitor and 
produce an image as it would 
appear when printed.

Selection Tool Settings
The Selection Settings determine Workspace behavior when shapes are 
selected and moved using the cursor.

Use Live Cursor

The Use live cursor will recognize 
when it passes over an Object. 

                  

Use Filled Region to Select

By default, clicking within the filled region of a shape will cause that shape 
to become selected. However, this may not be desirable where a complex 
Workspace has multiple overlapping shapes. If the Use Filled Region to Select 
option is disabled, then a shape may only be selected by clicking the edge of 
that shape.

Use live cursor (OFF) Use live cursor (ON)

Chapter 2- An Overview of the Workspace



30

Use Default Snapping Range

The Snapping Range determines how close a mouse click must be before it 
snaps to the nearest grid or line. The default range is three pixels. Uncheck this 
option and enter a number in the data box to create a custom range.

Highlight Selected Objects

The Highlight selected Objects option is used to draw a border around the 
desired Objects. The Highlight size field may be used to make the highlight more 
prominent.

Shapes that are on a Cut Only layer will be given a Red highlight. For shapes 
that are on a Print and Cut layer, you may select the color for the highlight. 
These highlights are intended as a quick visual cue to confirm the nature of a 
given shape. 

Sketch Tool Settings
Sketch Tool Settings are used in 
conjunction with Graphic Creation 
tools and for editing vector 
graphics.

Under the Curve node behavior 
heading there are two options.

The 1.	 Lines pass through nodes 
option will cause lines to pass 
directly through the center of a 
given Node.

The 2.	 Lines pass near nodes option 
will cause the line to pass near but 
not touching the Node.

Import Bitmap Setup
When importing a monochrome bitmap, the 
Bitmap Import Color Settings dialogue will specify 
the Foreground and Background colors of the 
bitmap.

(1)			       (2)
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Display Units 
The Unit Properties dialogue specifies the units and 
precision with which Workspace controls are displayed. 

Automatic Save
The Automatic Save feature is used to 
store the current Workspace at preset 
intervals. This protects against the loss of 
work due to system failure. 

If a system failure does occur, then 
restarting FastARTIST will restore the 
Workspace. The amount of work 
recovered will depend on the Time between saves setting. If the time interval is 
too large, then a significant amount of work could potentially be lost. However, 
setting a time interval that is too small will cause FastARTIST to frequently interrupt 
your work when performing auto saves.

Automatic Load Enabled
Automatic Load is only valid when the Automatic save enabled option is 
checked. When active, restarting FastARTIST will automatically restore the last 
Workspace that had been stored by the Automatic save enabled option.

This feature is useful where FastARTIST has been shut down using the File > Exit 
command, but when you neglected to save the Workspace.

Create Backup Files When Saving
When the Save or Save As commands are used, 
a backup (.BAK) file will also be created. The 
backup file will have the same preface name as 
the Workspace (.CDL) file, and it will be stored in the 
same directory.

Backup files are a good safety measure against losing work. 
However, old backup files must be periodically purged from the 
system- they can potentially consume tremendous amounts of 
hard drive space. 
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Ruler Positions
To change the ruler positions on the Workspace, select Options > Ruler Positions. 
Select View > Show Rulers to toggle the rulers ON or OFF.

Hot Key Listings
Customize Shortcuts

This dialogue box allows you to modify any Hot Key combination to one of your 
choosing. Listed on the following pages are the default Hot Key combinations.

Generic Hot Keys

Nudge selected Object by one pixel [Arrow key]

Nudge selected Object by five pixels [Shift + arrow key]

Change current focus to next Object in sequence [Tab]

Change current focus to previous Object in sequence [Shift + Tab]

Move/Draw/Edit/Select with horizontal and vertical constraint [Ctrl + Select tool]
 
Alignment Hot Keys

Horizontally align Objects along left-edge of bounds [Alt + 1]

Horizontally center Objects within bounds [Alt + 2]

Horizontally align Objects along right-edge of bounds [Alt + 3]

Vertically align Objects along top-edge of bounds [Alt + 4]

Vertically center Objects within bounds [Alt + 5]

Vertically align Objects along bottom-edge of bounds [Alt + 6]

Center Objects both horizontally and vertically [Alt + 7]

Note: “Bounds” refers to the rectangular outline of each Object.

File Menu Hot Keys

New Workspace [Ctrl + N]
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Open Workspace [Ctrl + O]

Save Workspace [Ctrl + S]

Print Workspace Objects [Ctrl + P]

Edit Menu Hot Keys

Undo last command [Ctrl + Z] or [Alt + Backspace]

Redo last command [Ctrl + Y] or [Ctrl + Backspace]

Repeat last command [Ctrl + R]

Cut selected Object [Ctrl + X] or [Shift + Del]

Copy selected Object [Ctrl + C] or [Ctrl + Insert]

Paste Object [Ctrl + V] or [Shift + Insert]

Delete selected Object [Del]

Duplicate selected Object [Ctrl + D]

Edit selected Object [Ctrl + E]

Edit font of selected text [Ctrl + I]

Select all Objects on Workspace [F3] or [Ctrl + A]

Deselect all Objects [Shift + F3]

Inverse the selection of Objects [Alt + F3]

Refresh the Workspace display [F4] or [Alt + D]

Layout Menu Hot Keys

Activate the Alignment feature [Alt + K]

Apply the current Alignment dialogue settings [Ctrl + K]

Group the selected Objects [Ctrl + G]

Ungroup the selected Objects [Alt + G]

Arrange Menu Hot Keys

Move the selected Object to the top layer [Ctrl + F]
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Move the selected Object to the bottom layer [Ctrl + B]

Move the selected Object up one layer [Ctrl + U]

Move the selected Object down one layer [Ctrl + L]

Reverse the layer order of the selected Objects [Ctrl + M]

Create a common path from the selected Objects [Ctrl + H]

Reverse the common path that was applied to a group of selected Objects [Ctrl + J]

Convert the selected text to graphic Objects [Alt + B]

Simplify the selected Object [Shift + F2]

Create a clipping shape from the current selection [Alt + C]

Remove the clipping that was created [Alt + U]

View Menu Hot Keys

Toggle the display of Object fills [Alt + S]

Toggle the display of bitmaps [Alt + M]

Toggle the display of the line style [Alt + N]

Toggle the display of the rulers [Alt + R]

Toggle the display of the Instant Replay window [Alt + I]

Options Menu Hot Keys

Snap to grid [Ctrl + W]

Use guides [Alt + W]

Functions Keys

Help [F1]

Disable all Shop palette colors except the current target color [F2]

Select all Objects [F3]

Refresh the Workspace [F4]

Activate the Zoom In tool [F5]
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Zoom out [F6]

Zoom in [Shift + F6]

Zoom to selected Object [F7]

Zoom to Page [F8]

Toggle between current and previous zoom levels [F9]

Select the menu bar [F10]

Pan Workspace toward current mouse position [F11]

Cut Menu Hot Keys

Open the Cut Preview plotting controls [Alt + P]

Chapter 2- An Overview of the Workspace
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Chapter 3
Working with Text

Text tools can be accessed through the Text Tools flyout. Here you will find four 
options:

Text Composition
This is the main option you will use when 
adding text. Select this option and drag a 
marquee within the Workspace with the 
mouse. The marquee will be represented by 
a dashed rectangular that will remain fixed as 
text is typed. When adding characters inside 
the marquee, its properties will determine 
how the text will compress, expand and 
wrap.

The Horizontal Compression, Vertical 
Compression and Line Properties buttons are 
used to change the behavior of how text fits 
within the frame.

37

Text 
Composition

Frame Text
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Kerning
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Horizontal Compression

Click on the Horizontal Compression 
button to modify how text is arranged 
to fit on a line. Using compression, text 
may be prevented from exceeding a 
set line length. Conversely, expansion 
may also be used to spread text over 
the entire line length. Word Wrap can 
be set to occur after a specific amount 
of compression has occurred. This 
command is only available when the 
text frame width is fixed.

Vertical Compression

The Vertical Compression button may 
be clicked to specify how lines of text 
are arranged within a text frame. This 
command is only available when the 
text frame height is fixed.

If a given line of text contains a mix of character sizes, then vertical 
compression will be based on the height of the first character on 
that line.

Line Properties

Clicking on this button brings up the Text 
Line Properties dialogue.

The ▪▪ Free Length option allows the line 	
	 to run to its “natural” length, based on 	
	 the height, width and kerning settings.

Relative Length▪▪  will resize the line to a 	
	 percentage of its natural length. 

Absolute Length▪▪  will fix the line to a specific length.
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Spacing is used to determine the vertical distance between successive lines of 
text.

Relative Spacing▪▪  is expressed as a percentage of the font height. 			 
	 Typically, a relative spacing of 150% is a reasonable default.

Absolute Spacing▪▪  will maintain a set distance between successive lines, 		
	 expressed in current Workspace units.

The X and Y fields will position a line of text at specific coordinates.

Frame Text

The purpose of a Text Frame is to constrain text 
to a given height and width. Click on the Frame 
Properties button to open the Text Frame Properties 
dialogue.

If you select the Free Width or Free Height options, 
the text will be set according to the default height, 
width and kerning settings for the given font. Fixed 
Height and Fixed Width will constrain fonts to User 
Defined values.

The X and Y fields are used to position a line of text at 
specific coordinates.

Text frame Margins may be set in terms of absolute distances from the text frame 
edge, or by a percentage of the text frame size.

Auto Spacing

Checking the Auto Spacing option will enable the 
Settings button. Clicking on the Settings button will 
open the Auto Spacing dialogue.

To use the Auto Spacing controls, the 
text must have been created using the 
Frame Text Compose option.
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Equal 
Spacing

Equal Spacing establishes lines of text at equal distances apart. The Top/
Bottom Margin Size settings affect interline spacing. A value of less than 0 
will decrease the distance between the lines of text. A value greater than 0 

will increase the distance between the lines of text.

Weighted 
Spacing

Selecting Weighted Spacing will enable the spacing between lines of text to 
vary. Entering a value of greater than 100% in Extra Bottom Weighting will 

increase the size of the bottom margin. Entering a value of less than 100% in 
Extra Bottom Weighting will decrease the size of bottom margin.

Line Compression

Next to the Frame Properties button is the Line Compression field. This field is used 
to compress a line to a percentage of its original width. For example, enter 50 to 
compress the line to 50% of its original length.

Choosing the Font

The Typeface dropdown list will display a 
menu of all installed fonts in alphabetical 
order.

In addition to the dropdown list, the Font 
Detective can be used to search for 
installed fonts based on specific criteria, 
such as thickness, script lettering and 
serifs. In addition to general info and location information about each font, 
Panose font information is displayed. Panose is a typeface matching system 
used to classify and/or match type styles.

For example, if you wished to locate all 
Small Caps fonts, set the Type of font 
to “Decorative” and limit the Range 
of characters to “Small caps.” After 
clicking on the Filter button, the Font 
Detective will show all the available 
Small Caps fonts.
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Picture Guide

When choosing which font attributes to filter for, a picture guide is provided as 
an aid. Some examples are as follows:

Display CADlink VEF fonts

Display CADlink VEF fonts and TrueType fonts

Installing New Fonts

FastARTIST supports a wide range of font 
technologies, such as TrueType and 
Adobe Type 1 fonts. To use a new font 
with FastARTIST or to use a VEF that was 
not installed with FastARTIST go to File > 
Install > Fonts.

You will be prompted for the location of 
the new font(s). Use the browse button to 
select the folder in from which the font(s) 
will be copied. If you are copying fonts 
from a CD, select the drive in which the 
CD is located.

Be cautious of registering fonts on a CD or other removable media, 
since this will require that the media containing the font be inserted 
prior to beginning FastARTIST sessions.

Specify the type of font formats that are desired and click on the Search Now 
button. A list of recognized fonts will populate the data field. These fonts may 
be installed individually, or you may select the Install All button. Once the fonts 
have been installed, they are registered for use within FastARTIST and they will be 
available from the Typeface dropdown menu when editing text.

Although not recommended for regular usage, the Reset button will remove 
all fonts from the database, except for CADlink VEF fonts. The Reset button is 
provided as a means of purging the database. This is a convenient means of 
reconciling many different font references. The fonts should be loaded again 
from a common folder.

Chapter 3- Working with Text
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Text and Special Effects
Slant 

Slant is used to tilt the text either right or left. This is not a substitute for choosing 
an italic font, but it does create an effect that is similar to italics.

Slant is expressed in degrees with a range of +30 (right) to -30 (left) degrees. 
Clicking on the Slant button will reset the value to zero.

Text Orientation

Horizontal Text Arrange text from left-to-right.

Vertical Text Arrange text from top-to-bottom.

Justification					     Line Spacing

Left Justify

Center Justify

Right Justify

Align text with top of frame

Center text within frame

Align text with bottom of frame
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Case Control

Character Placement

You may right-click on both the 
Superscript and Subscript buttons to 
customize their settings. 

Bullets

Clicking on the Bullets button will place a bullet. To customize the shape 
of the bullet, right-click on the Bullets button. 

The bullet design may be selected from any 
registered font. You may also use the Font 
Detective to assist in finding a desired font and 
bullet.

Spell Check

When editing text, click on the Spell Check button to verify the spelling 
of the currently selected text. If no text is selected, then the entire text 
object will be checked.

If spelling errors are found, the Spell Checker dialogue will open.

Upper Case Convert selected text to upper case.

Lower Case Convert all selected text to lower case.

Proper Name 
Case

For each word selected, the first letter will be upper-case 
and the remaining letters will be lower-case.

Superscript Create raised lettering.

Subscript Create lowered lettering.

Unscript Remove superscripts and subscripts.

Chapter 3- Working with Text
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Default dictionaries for several 
languages are provided. The Main 
Dictionary selection represents the 
active dictionary. In addition, a User 
Dictionary may be created by clicking 
on the New button.

When checking for spelling errors, 
both the Main and User Dictionaries 
are referenced. If new words are 
added, the User Dictionary will be 
used to store the new word. The Main 
Dictionary always remains static.

Style Painter

When editing a paragraph 
of text, the Style Painter tool 
is used to copy the font style 

from one sentence to another. By 
right-clicking on the Style Painter 
button, the Text Style dialogue is used 
to select what style elements will be 
copied.

Character Width

The Character Width tool 
can apply compression to 
individual characters of a 
word. Right-clicking on the 

Proper Character Width button opens the 
Character Width Style dialogue.

The Width Style options are as follows:
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Relative width % Adjust the character width as a percentage of the original width.

Absolute width Adjust the character width to be a specific width.
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Once the type of Width Style has been selected, highlight the text and enter 
a value into the Character Width field. For example, the following screenshot 
indicates that some characters have been compressed to 50% of their normal 
widths.

Kerning

The Auto Kern 
command 
balances the 

white space between characters. 
The Kern Percent field is used to 
specify what percentage of standard 
kerning is to be applied. Reducing 
the percentage will decrease 
the space between characters. 
Increasing the percentage will move 
characters further apart.

Customize the Auto Kern feature by right-clicking on the Auto Kern button.

Normal Balance the amount of white space, while maintaining normal character 
spacing.

Wide Insert approximately 20% extra white space between characters.

Narrow Remove approximately 20% of white space between characters.

Touching Arrange the characters so that their finials touch, yet do not overlap.

Overlap Force adjacent characters to overlap by approximately 5%.

Chapter 3- Working with Text
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Accuracy versus Speed- Due to the number of calculations 
involved with finding the best kerning for a given pair of 
characters, it may be desirable to sacrifice some of the kerning 
accuracy in exchange for faster results. If so, then choose the Fast 
setting instead of Accuracy. The Fast setting will often produce 
acceptable results.

Manual Kerning

The On-Screen Kerning feature is used to make manual adjustments to text using 
a special set of kerning nubs. The kerning nubs may be used to adjust inter-line 
spacing, line kerning, individual letter pair kerning and the alignment skew of 
text.

Holding [Ctrl] and double-clicking on a text object will also allow you to access 
On-Screen Kerning mode.

Kerning handles may be dragged using the mouse. In addition, clicking on a 
handle will cause that handle to become selected and the cursor keys may be 
used to move that handle one pixel at a time. Holding the [Shift] key will move a 
handle by five pixels.

The types of kerning handles are:

The •	 Line Movement Handle - used to position the line of text. Holding the 
[Ctrl] key may be used to constrain the movement of the line. Holding the 
[Shift] key will align all the text lines along a path between the current handle 
and the handle of the first line.

The •	 Line Kerning Handle- used to adjust kerning for the current line. Holding 
the [Ctrl] key will adjust the word kerning, while keeping the space between 
adjacent characters constant.

The•	  Letter Kerning Handle- adjusts the kerning of characters that are opposite 
the Line Kerning handle.
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Font Editing and Creation
FastARTIST can modify existing fonts or create new ones from scanned, digitized, 
or hand-drawn objects. Regardless of whether the font is new or edited, it will 
always be saved in .VEF format, even if the original font had been stored in 
another format, such as True Type (TTY) or Postscript (PFB).

Any Workspace object can be converted into a font character. However, the 
object must be a single-path graphic. Imported or grouped objects must be 
welded and/or converted to a single path prior to creating a font version from 
those objects.

To import objects that have multiple paths, use the Make Path command to 
convert them into a single path. The Text to Graphics command must also be 
applied.

Editing an Existing Font

When editing fonts, it is important to understand how the placement of 
individual letters is accomplished. As a rule, each character’s font metrics 
include two general types of information: (a) the shape and size of the 
character itself and (b) its placement in relation to the other characters in the 
font.

The area that a character occupies can be thought of as being 
an enclosed box. The box is considered to have an x-axis, a y-axis 
and an origin in the lower-left corner.

Such placement information is necessary to help arrange adjoining letters 
correctly, while also considering any possible descenders. The three primary 
adjustments are White space after the character, Character backspace and 
Offset from the baseline.

Choosing Edit Font from the Edit menu will 
open the Create/Edit Font dialogue.
When editing a font, there are two broad 
classes of adjustment:

Global Attributes▪▪  are applied to all of 	
	 the characters in a given font.

Character Attributes▪▪  are specific to a 	
	 single character within the font.
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Creating a New Font
To create a new font, click on the Create 
button. Enter the name of the new font in the 
Create New Font dialogue and click on OK. 
You will be prompted for a name under which 
to save the font.

You must use a Font Name that is different from an original font. 
Otherwise, the original font data will be overwritten.

Global Attributes

Adjustments to the Global Attributes are used to define the general 
appearance of a font. These adjustments will be applied to all the characters 
within the font.

Font Height

Font Height defines the actual height of the font as it was 
created. When creating a new font, the height of a reference 
letter should be entered so that the remaining characters can 
be sized correctly.

For example, suppose that an uppercase ‘H” were chosen 
as the reference letter (this is a typical choice). For the Height 
field, you would measure the height of the ‘H’. It is very 
important to assign an appropriate height to a font being 
created. The height of a font is often based on the height 
of an uppercase M or H. The precise letter height will be used when creating 
a block-style font, whereas script fonts may require a more creative estimate 
of height. Notice how the script character is slightly taller than the non-script 
character.

Interspace

Interspace is the nominal amount of trailing white 
space that provides a gap between following letters. By 
modifying the Interspace, fonts can be given either a 
wide or a narrow kerning.

For example, using a negative value will create a 
condensed font.
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Use Bottom of Sign Blank (Page) as Baseline

The baseline will determine the vertical position of a character. When creating 
a new font, the vertical position of each character is defined in relation to the 
baseline. Two options are available to assign the vertical position of characters:

Offset from Baseline•	 - Used to manually adjust each of the characters

Use Bottom of Sign Blank as Baseline•	 - Automatically assigns the character 
baseline. To enable, check the Define Character as Selected Object option 
under the Character Attributes section of the dialogue and use the Align 
feature to arrange the characters along the bottom of the sign blank.

Monospace Font

The Monospace Font option converts the font to a fixed-width font in which 
each character occupies the same amount of horizontal space regardless of its 
width. For example, the character ‘i’ would have as much width as an ‘m’.

Stretch

The Stretch Font dialogue is used to 
adjust the ratio between the font height 
and width, expressed as a percentage. 
A value less than 100 produces a font 
that is short and wide, whereas a value 
greater than 100 produces a font that is 
narrow and tall.

Slant

The Slant Font dialogue is used to specify 
the slant degree for the font characters. 
A positive slant will create an Italic font, 
whereas a negative slant will create a 
“backhand” appearance.

Character Attributes
Letter

This box is used to specify the character currently being created or modified. The 
edit box displays the actual character.
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Code Value

For computers to recognize text characters, a numeric value called the ANSI 
standard is used. This is a widely accepted standard that ensures text data will 
be understandable between different models of computers. For a given font, 
there are 255 characters in the ANSI character set, which encompasses upper-
case letters, lower-case letters, numbers and (sometimes) special symbols.

Because some of these ANSI values are intended for communication protocols 
between devices, not all of the characters will be printable. For example, the 
first 31 characters are reserved for special command sequences that would be 
recognizable by a modem or printer, but which have no significance for our 
purposes of editing a font. 

The following table indicates some sample values:

ANSI Code 
Value Which we know as: CASHEWB Font EMBASSY Font

65 The letter ‘A’

66 The letter ‘B’

67 The letter ‘C’

97 The letter ‘a’

98 The letter ‘b’

99 The letter ‘c’

48 The number ‘0’
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White Space After Character

This field is used to adjust the width of a character bounding 
box. In effect, this will increase the separation from the 
following character. Although this is similar to Interspace, 
keep in mind that this setting is applied on a per character 
basis. Interspace is used to adjust the overall kerning of the 
font characters.

Character Backspace

Character backspace is used to move the character with respect 
to its bounding box origin. In effect, this will place the character 
either further away, or closer to, the preceding character.

Offset from Baseline

The Offset from Baseline adjusts the vertical character placement with respect 
to the baseline.

For example, an uppercase H in a sans serif font will generally have 
an offset of 0 (no offset). This means that the bottom of the actual 
letter will be the same as the bottom of the letter’s bounding box.

On the other hand, a lowercase ‘g’ will require a negative offset, so 
that its descender (the tail) will fall below the baseline.

Select Previous and Select Next Buttons

Font characters can be designed on the FastARTIST Workspace and then 
added to a new font. FastARTIST orders Workspace objects according to the 
sequence in which they were created. Using the Select Previous and Select Next 
buttons, you may browse Workspace objects without leaving the Create/Edit 
Font dialogue. When the correct object is selected, click on the Apply Changes 
button to create the character.

For example, if you have created a new alphabet, with objects for “A B C D E 
F...” etc. in the Workspace, you would go to the Create/Edit Font dialogue and 
set the Code Value to 65. You would then use the Select Next button to select 
the ‘A’ object within the Workspace.
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Click on Apply Changes to create the new character and then increment 
the Code Value to 66. Click on the Select Next button to select the ‘B’ object, 
and click on Apply Changes again. This process would be repeated for each 
character that you created for the font.

Define Character as Space

There is also a non-printing character that is often forgotten, but which must be 
present in a font: the Space character. Without the Space character, which 
appears when the space bar is pressed, there would be no spaces between 
the words created when composing text, Therefore it is critical that a Space 
character be included when generating a font.

There are two ways to create the Space character:

To use an existing character, select a character that best represents an 		 •	
	 appropriate space and enable the Define character as space option.

To create the •	 Space character using an object, exit the Create/Edit Font 		
	 dialogue and create an object that has an area that is appropriate for 		
	 the font. Once the object is selected, open the Create/Edit Font dialogue 		
	 and enable the Define character as space option.

Define Character as Selected Object

When editing a font, select an object to be included in the font as a character. 
To designate a selected object as the current character, check this box.

Note: If the Not a Path warning appears, then select Arrange > Make Path.

Apply Changes

Clicking on Apply Changes will save the character information and allow you to 
begin editing another character. Note that the changes are not saved to disk 
until the font is saved using the Save Font or Save Font As button.

Display Box

This box displays the current information for 
the character being edited. It also displays the 
bounding box for the selected character (including 
a top line representing the font height) and the 
character’s current placement within the box. 
When changes are made to the character, those 
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changes are immediately reflected in the display box.

The Display Box will display kerning pairs, as well as words where necessary.

Kern Letter

The Kern letter field indicates the character to be 
manually kerned in the trailing position, relative to the 
character currently being edited. The letter pair will 
then be displayed in the display box.

This setting identifies the exact distance between the 
start points of the two characters. A larger number 
increases the space while a smaller figure reduces the 
space. This setting is grayed out and unavailable unless a kern letter is selected 
to be paired with the current character.

Display Word

To examine the kerning set for a given letter in a realistic context, type a word 
containing the letter in the Display Word box. The word will be displayed in the 
Display Box.

In order for the word to appear in the display box, it must contain 
the character currently being edited.

Auto Kern

This button opens the Auto Kern 
dialogue box.

Auto Kern is used to automatically 
generate a kerning table for a 
given font. Kerning tables contain 
information about the spacing 
between pairs of characters.

The Auto Kern feature is similar to the Text On-Screen Kerning feature that is 
available from the Text Tools menu. Once kerning information is created for a 
font, FastARTIST will simply duplicate the kerning table already defined.

Due to the time required to generate a kerning table on-the-fly, the main 
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advantage of using Auto Kern at the font generation stage is that FastARTIST 
generates paragraphs of text very quickly when entered in Text Compose, since 
Auto Kern will not be used at that stage.

There are four settings that can be adjusted in order to generate a custom 
kerning able for a font:

1st Character¾¾ - By definition, a kerning pair has a first (or leading) character  
	 and a second (or trailing) character. Use the two entry boxes to specify 		
	 the range of characters (from first to last) to be set to Auto Kern in the first 
	 position. By default, FastARTIST will kern all 255 ANSI characters in the 		
	 leading position.

2nd Character¾¾ - Use these two entry boxes to specify the range of 			 
	 characters to be set to Auto Kern in the second position. By default, 			
	 FastARTIST will Auto Kern all 255 ANSI characters in the trailing position.

Accuracy vs. Speed¾¾ - Auto Kern works by checking and adjusting the 		
	 distances between a number of points along the height of letter 			 
	 pairs. From the Accurate versus Speed dropdown menu, you may choose 
	 a value between Accurate and Fast, providing the ability to find a 			 
	 balance between speed and precision.

Using ○○ Fast will speed up the kerning 		
	 process by examining only a 			 
	 limited number of points.

Using ○○ Accurate will result in kerning 		
	 based on the examination of 			 
	 substantially more points.

Style¾¾ - Auto Kern can generate a font with one of five different kerning 		
	 styles — Normal, Wide, Narrow, Touching and Overlap.

The ○○ Normal setting kerns the font by adding white space roughly in 		
	 proportion to the width of the letter.

The ○○ Wide setting kerns fonts at a rate of Normal kerning plus 20% 		
	 (i.e., there is 20% more white space added between each letter).

The ○○ Narrow option sets kerning at Normal kerning minus 20%.
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The ○○ Touching setting causes letters to touch but not overlap.

The ○○ Overlap setting causes letters to overlap each other by 5% of 		
	 their Normal kerning.

Saving a New Font

When editing a font, the new information is not written to your hard drive until 
you actually Save the font. Until then, the font is buffered. A buffered font is 
somewhat in limbo — it exists and is available to Text Compose, but it has not 
been committed to the hard drive. This means you still have the option to Save 
or Discard changes to the font before exiting FastARTIST.

Saving a font means moving the information out of the buffer and onto the hard 
drive, making it permanently available. Any font saved is placed in the directory 
where the existing .VEF fonts are currently located.

Clicking on the Save Font button will result in the font being written to disk 
immediately. The alternative is that FastARTIST provides the option to Save the 
font when issuing an exit command. If the font is not saved before exiting the 
Create/Edit Font dialogue box, you will be prompted to do so when either 
beginning a new session or exiting FastARTIST.

Save Font As

The function of this button is very similar to the Save As command in the File 
menu. Specifically, it provides the opportunity to give an edited font a new 
name and then save the font under that new name. This is particularly useful 
when creating a new font by editing an existing font, since it provides for saving 
the changes under a new name without losing the original font information.

Clicking on OK will accept the current font changes and close the Create/Edit 
Font dialogue.

Exiting FastARTIST 

Should you choose to not Save any font changes before exiting FastARTIST, they 
will be discarded.
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Chapter 4
Importing and Exporting Files

All graphic software applications have proprietary file formats for storing data 
and each of these formats is designed for a specific type of image. Generally 
speaking, formats are designed to store either line art (vectors and curves) or 
bitmaps (raster images). This creates many challenges when swapping data 
between different applications. Fortunately most graphics applications provide 
Import and Export filters to facilitate the exchange of files.

The FastARTIST Workspace supports both line art and bitmaps, so either type of 
data may be Imported or Exported. The native FastARTIST file format, CADlink 
Drawing File (*.CDL), is referred to as a “combination file” because it can 
contain both line art and bitmap data.

Working with CDL Files

The CADlink Drawing File (*.CDL) can 
be opened into its own Workspace, 
using File > Open. A CDL file may 
also be imported into an existing 
Workspace (File > Import) provided 
the Merge option is enabled.

When using the File > Open command 
for the first time, FastARTIST will query 
whether the intention had actually 
been to use the Import command.

Restoring Printer Info

When a CDL is saved (File > Save), the information from the Print and Cut Setup 
dialog is stored within the CDL file. When opening the file in the future, enable 
the Restore Printer Information checkbox to load the printer and cutter settings.

Zoom Open

When the File > Open command is used, the Workspace will zoom to the loaded 
Objects. The File > Zoom Open command is similar, except that the zoom level 
will alternate between 1) the current zoom level and 2) zooming to the loaded 
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Objects.

FastARTIST Import Filters
Import filters are designed to convert file data into Objects that can be edited 
within the FastARTIST Workspace. Often, a customer will provide an obscure file 
format for an ordered job. You may also need to reuse artwork from older CAD 
software that is no longer in use. In either case, FastARTIST supports a wide range 
of import filters which should allow you to load such files with few restrictions.

FastARTIST will Import a wide variety of common file formats including TIFF, PSD, 
JPEG and EPS.

The Import command is located in the File menu. When Importing with 
the Merge option checked, the imported file will be added to the existing 
Workspace. If the Merge option is unchecked, then the existing Workspace 
will be overwritten. For certain types of files, the Customize button will become 
active in order to specify certain parameters for the given file type.

The Filter button is used to customize file types that are listed within the Files of 
type menu.

EPS Files

When importing Encapsulated PostScript (*.EPS), be aware that there is a fair 
amount of variety in how different graphics applications Export data to an EPS 
file. If you encounter problems when importing an EPS file into FastARTIST, then a 
useful alternative is to Export the data as an Adobe Illustrator (*.AI) file instead. 

Importing from CorelDRAW

CorelDRAW uses its own proprietary file type called a 
CDR, however FastARTIST will not Open or Import a CDR 
file. If you wish to keep the vector properties of the file, 
you must Export or Save it in a generic format such as 
EPS, AI or CMX. If you examine the dropdown menu Files 
of type under the Import feature, it lists all the file formats 
that FastARTIST can import.

Note: EPS, AI and CMX will keep the files in vector format 
and won’t convert them to bitmaps.
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Importing PDF Files

Although there are any number of file formats that can be used (PDF, EPS, etc.), 
the most reliable format is PDF. If possible, request that the customer provide you 
with a high quality (high resolution) PDF file to avoid any compatibility issues.

Guidelines for Obtaining PDF Artwork

When working in other graphics applications, it is recommended you save your 
original design as a PDF file and then Import the PDF into FastARTIST. By saving 
your design as a PDF, this avoids compatibility issues with different versions of 
software. It has the added benefit of embedding fonts to ensure correct type 
matching. The method of saving your design as a PDF will vary, however, there 
are common commands for saving a PDF:

File•	  > Publish to PDF – Some design applications have a dedicated Publish to 
PDF command under the File menu. This will typically open a Settings dialog 
that allows you to specify parameters for saving the PDF file.

File•	  > Save As – Some design applications use the Save As dialog to create a 
file. In the Save dialog, designate the file type as “Portable Document Format 
(PDF).” In some cases, choosing the file type will reveal a Customize button 
that will allow you to specify the PDF parameters.

File•	  > Export – Older design applications will likely not have a specific PDF 
save tool, in which case you are expected to use the Export command 
under the File menu. In the Export dialog, designate the file type as “Portable 
Document Format (PDF).” In some cases, choosing the file type will reveal a 
Customize button that will allow you to specify the PDF parameters.

When choosing your PDF save parameters, each application will present •	
different controls, and there are usually more controls than are discussed 
here. However, this list highlights the most pertinent settings that you need to 
check. Take care to ensure that the following settings are in effect:

 
Font1.	  Folder – Some design applications provide the ability to save the font 
files in a separate folder, which can be distributed along with the PDF file. 
When importing the PDF into FastARTIST, the PDF Import Options dialog will 
read the fonts from this folder.

Font2.	  Embedding – If a Font Folder is not used, then Font Embedding 
should be ON to ensure that font information is available in FastARTIST.

 3.	 The entire font should be embedded, as opposed to a subset that consists 
only of characters used in the saved PDF. Otherwise, if your design 
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requires any text substitution or serialization, the subset may be missing 
required characters.

Subset fonts when percent of characters is less than…4.	  – This option should 
either be turned off, or its value set to 0% (zero) to indicate that the entire 
font should be embedded.

Override Distiller Font Options5.	  – Distiller options should be overridden to 
avoid any unexpected compression, color management or partial font 
embedding. The Distiller refers to the application that Adobe provides for 
converting documents into PDF.

PDF Quality / Image Compression6.	  – If possible, turn off all compression to 
ensure the highest image quality. In some cases, there will be slider that 
allows you to choose the quality.

PDF Compatibility7.	  –Compatibility should be set to the most recent version 
available. Compatibility settings are used in consideration of distributing 
the PDF, where users may be using an older version of Adobe’s PDF 
Reader.

Save the PDF Settings8.	  – If possible, save the configuration settings that you 
are using to create your PDF. By having these settings available, less time 
will be required when a PDF is saved and there is less risk of accidentally 
forgetting a required setting.

Importing a PDF•	

Choose File > Import to open the Import 
File dialog. Set the file type as “Portable 
Document Format (*.PDF)” and select the 
desired PDF file to Import. Click the Import 
button and the cursor will become an angled 
cursor. Click on the FastARTIST Workspace to 
position the top left corner of the imported file.

At this point, the PDF Import Options dialog will 
open, allowing you to select from the following 
Import settings:

Import Text As Graphics1)	  – It is 
recommended that this option be OFF 
to preserve the original font information.

Use Alternate Font Location2)	  – This option is used when a Font Folder 
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was created containing the fonts used in the PDF file. By default, it is 
expected that this folder is named “Fonts” and is in the same directory 
as the PDF file being imported. If the Font Folder is in a different 
directory, click the Browse button to specify the location.

Allow Subfonts3)	  – A subfont is a subset of the original font info that is 
restricted to the characters used in the saved PDF file. If this option 
is enabled, then any embedded fonts will be used. Otherwise, an 
alternate font location will be searched, followed by a search of the 
locally installed fonts. If the font info is not found, then a substitute font 
will be required.

Import Pages4)	  – For a multiple-page PDF, indicate which pages to 
Import. After the pages are imported, the Paging Tool can be used to 
browse through each page.

Do Not Show This Dialog5)	  – Check this option if you wish to hide this 
dialog. Hidden dialogs can be restored within the General Preferences 
window.

Click on OK to close the PDF Import Options dialog. If 
any font information is not found, the Font Replacement 
dialog will open. The missing font will be listed and a 
substitute font must be selected from the dropdown list 
of locally installed fonts. The Font Replacement dialog 
will reappear for each font that requires a substitution.

A Final Note about Importing Files

The Import command is designed to load designs from other applications, while 
trying to remain true to the types of Objects that were in the original file. For 
example, a square with a gradient should come in as a square with a gradient, 
as opposed to a thousand individual Objects that each have a different hue to 
form the gradient.

Not all applications have the same Object types or attributes, which may 
cause the Object to be converted. For example, a mesh fill could be arbitrarily 
converted into a bitmap Object.

Retaining and matching fonts can be problematic also. If possible, save the 
original artwork as a PDF with embedded fonts. Otherwise, you will need to 
substitute for a font with the nearest match that you have on the FastARTIST-
installed system. You do have the option of converting Text to Curves if you are 
certain no further text editing is required. This will convert the text to a graphic, 

Chapter 4- Importing and Exporting Files



62

making spell checking and additional editing unavailable.

After importing, various Objects are often grouped and bitmaps are sometimes 
clipped. When an Object is selected, the far left of the SmartBar will indicate the 
Object type.

If the Object is a “Group,” then use Layout > Ungroup or [Alt + G] to break up 
the grouping. If the Object is a “Clip Group,” then use Arrange > Clipping > 
Clipping Clear or [Alt + U] to remove the clipping. After disassembling Object 
groupings, you will likely need to specify any underbase attributes on an Object-
by-Object basis.

FastARTIST Export Filters
The Export command is used mainly for line art shapes. However, for file formats 
that are capable of storing both line art and bitmap shapes (i.e., combination 
files), the Export command can also be used to export bitmap shapes.

When exporting line art, caution is required to prevent creating file Objects that 
contain an excessive numbers of Nodes. This is especially true of artwork that 
was originally imported from other software. To overcome this problem, click the 
Customize button on the Export File dialog. The Parameter Specification dialog 
will open

The Parameter Specification dialog is used to 
substantially reduce the Nodes of exported 
Objects. If the default value is insufficient, then 
caution is urged against setting a high value for 
the Export error tolerance. As a rule, the default 
value (0.001 or 1/1,000 of an inch) will work very 
well with most files.

Exporting an Image

The Export Image command is used for bitmap (raster) 
images, such as BMP, JPEG and PNG files. If line art 
shapes are being exported, then FastARTIST will render 
the line art into raster data during the exporting process. 
During the Save, you will be prompted for the resolution 
and color depth of the raster data.

Publish to PDF

The File > Publish to PDF command will save the current Workspace as a 
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Portable Document Format (PDF) file. An advantage of PDF files is that they can 
be viewed using Acrobat Reader, available from the Adobe web site. This is a 
free program and a very common application. Most computer users have some 
version of it installed on their system.

Exporting Palettes to CorelDRAW and Illustrator

Spot and Duotone colors in FastARTIST palettes may be exported to either 
CorelDRAW or Adobe Illustrator, ensuring that the same color information will 
be used when designing an image in these applications. If the finished design 
is then saved as either an EPS or AI file, it can be imported it into FastARTIST 
(using the Map Named Colors feature) while preserving the one-to-one 
correspondence between the original colors and the FastARTIST palette.

A common technique is to create a custom Shop Palette that has all the Foils, 
Spots and Duotone colors available in your shop. By exporting these colors to a 
CorelDRAW or Adobe Illustrator palette, you ensure your designs are not using 
colors that will be difficult to find or substitute for.

Scanning to Acquire an Image
The Acquire Image option provides access to TWAIN support offered by 
FastARTIST. This support provides the ability to operate TWAIN-compliant 
scanners directly from within FastARTIST without any intermediary software. 
However, to function properly the scanner control software must be properly 
installed within Windows. The Acquire Image options are available from the File 
menu.

Acquire

This option calls the TWAIN-compliant software, initializes your scanner and 
prepares the system to receive a scanned image. Upon exit from the scanning 
software, the acquired image will be automatically imported into FastARTIST.

Acquire Vector

This is a variation on the Acquire command. Where the Acquire command will 
produce a bitmap image, the Acquire Vector will produce line art from the 
scanned image.

Select Source

The Select Source option provides the ability to choose the TWAIN input device 
that will acquire images. If there is only one source (i.e., only one scanner) 
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attached to the system, set this once. 
If there is more than one input source 
available on your system (i.e., a flat bed 
scanner or a hand-held device), this 
feature provides the ability to choose 
between the devices. Select Source 
opens the Select Source dialog box:
 
The Sources list will contain all available TWAIN-compliant devices attached to 
your computer. After choosing the desired device, click on the Select button.

Scan and Trace Wizard
The Scan and Trace Wizard includes all the steps to Import and trace an image. 
In addition to importing a scanner image, the Wizard can accept either an 
image data file or images that were copied to the Windows clipboard from 
another application.

Digitizing Setup

FastARTIST has the ability to interface with 
a digitizing tablet without the need for 
intermediary software drivers. Once the 
tablet is connected, configure it using the 
Digitizing Tablet Setup dialog available in 
the Edit menu.

Enable Digitizer

This check box is used to enable and disable the Digitizer. In order to reduce 
the load on your system, it is recommended the Digitizer be disabled when 
not in use. This will prevent FastARTIST from polling the tablet, freeing up system 
resources.

Track Pen

This check box is used to enable and disable the tracking of the Digitizing Pen. 
In order to reduce the load on the system, it is recommended that the digitizer 
be disabled when not in use. This will prevent FastARTIST from polling the tablet, 
freeing up system resources.

Reset Baseline

When starting a new drawing, or if the original angle and position of the tablet 
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baseline needs to be restored, select the Reset Baseline option. The baseline of 
the tablet will be reset to match that of the material.

Set Baseline

The baseline of a drawing defines both the bottom of the artwork, as well as the 
angle of the horizontal axis.

Typically, a Digitizer designates the bottom of the tablet as the baseline, which 
FastARTIST will use as a reference. Use the Set Baseline button to align the 
baseline with that of the artwork, rather than the tablet bottom. This avoids the 
requirement that the artwork be precisely aligned with the bottom of the tablet.

Using a Digitizer

Curve Nodes drawn by a Digitizer are different from those created by the mouse 
in standard Draw Mode. Draw Mode uses the Nodes as control handles that pull 
at the curve as it is formed. A curve drawn in Digitizing mode will pass directly 

Button Function Description

Top Corner node Place corner node on Workspace

Left Curve node Place curve node on Workspace

Bottom Tangent node Place tangent node on Workspace

Right Finish
End and close contour, or create 
custom shapes. Double-clicking 
will close the contour.
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through the Nodes in a more “connect-the-dots” fashion.

When using a Digitizer, certain button combinations may be used to form basic 
shapes. Place two Corner Nodes to form the opposite corners of a rectangle 
and then double-click the Finish button to complete the rectangle. You can 
place two Curve Nodes to form the diameter of a circle and then double-click 
the Finish button to complete the circle. Placing three Curve Nodes and then 
double-clicking the Finish button will fit a circle within the three Nodes. If four or 
more Curve Nodes are placed, then a circle will be created to best fit within 
those Nodes.
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Chapter 5
Palettes, Strokes and Fills

Working with Color Palettes 

The Line Style, Gradient and Pattern Fill tools are 
available from the Stroke and Fills Toolbar.

The default color palette of FastARTIST is the Shop palette. This lists the color 
plates available for use in the Workspace. Other palettes are provided as an aid 
for working with Spot colors, particularly with respect to foils. By default, color 
palettes are docked at the edges of the FastARTIST Workspace.

A palette may be “undocked” by clicking-and-dragging the palette to its new 
position. Double-clicking a palette will toggle its position between docked and 
undocked.

FastARTIST also has the ability to open standalone Manufacturer’s palettes. 
Specific color plates may be dragged from a palette and added to the Shop 
palette. This allows for quick customization of the Shop palette to include the 
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most frequently used color plates.

The Shop Palette

The default location of the Shop palette is along the bottom of the Workspace. 
It is commonly referred to as “the color palette” and it contains all of the color 
plates currently available for use within the Workspace.

Left-clicking a color plate will set the default Fill color for new shapes, as well as 
set the Fill color of any currently selected shapes. To change a shape’s Fill color 
without changing the default Fill, drag-and-drop a color plate onto a shape.

When the mouse button is released, it is the location of the cursor 
tip that determines where the new color will appear. In the 
example above, if the tip of the cursor arrow was touching the 
outer line of the star, then the Stroke color would change to Green 
rather than the Fill color.

Changing the Stroke Color

Right-clicking a color plate will 
set the default Stroke color for 
new shapes, as well as set the 
Stroke color of any currently 
selected shapes. You may also 
drag-and-drop color plates onto 
the outline of a shape to change 
the color. When holding the 
color plate over a shape, the 
dragged color plate will appear 
to be hollow, indicating that 

Click-and-drag a color plate Release mouse button when 
cursor is over object

Shape changes to color of 
color plate

Drag a color plate. When 
over the shape line style, 
the plate appears hollow.

Release the mouse 
button, and the line style 
color changes.



69

releasing the mouse button over that Spot will change the Stroke color of the 
shape.

By default, Workspace shapes have no Line Style. When the mouse 
is released, it is the location of the tip of the cursor that determines 
where the new color will appear. In the example on the previous 
page, if the tip of the cursor was touching the inner line of the star 
when the mouse was released, this would cause the Fill color rather 
than the Stroke color to change to Blue.

Changing the Fill Color of Grouped 
Shapes

If you drag-and-drop a color plate onto a 
collection of grouped shapes, that will set all 
of the shape Fills to that color. Hold down the 
[Ctrl] key to target a single shape within the 
group for that color.

Changing the Order of Color Plates

To change the order of the color plates within the Shop palette, any color may 
be dropped into a different location of the palette. The color will be inserted at 
the new location and colors to the right of that color will be shifted to the right.

Modifier Keys and Color Plates

Additional functionality is available by holding the [Shift], [Ctrl] or [Alt] keys while 
clicking on a color plate. The following table summarizes these modifiers:

Action Result

Left-click Set Fill color of current Object

Right-click Set line style color of current Object

[Shift] + Left-click Include all Objects of that Fill color in current selection

[Ctrl] + Left-click Disable the color plate. All Objects with that Fill color will appear as 
dashed outlines on the Workspace.

[Alt] + Left-click Disable all color plates, except for the plate that was clicked

Holding the [Ctrl] key and clicking on a palette color will toggle the “active” 

Magenta plate is dragged-and-
dropped into new location

Magenta plate is inserted in new 
location
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status of that color plate. Objects that have inactive colors will not be editable.

The Invisible Color Layer

The first two “colors” of the Shop palette are the Invisible Colors, which are used 
to indicate the absence of color for either an Object Fill or Line Style. Invisible 
Colors may be applied to Objects as a regular palette color. When applied as a 
Fill color, the Object will be reduced to the sum of its thick line attributes, which is 
useful for creating cutting paths. When applied as a Stroke color, the Object will 
effectively have no thick line attribute.

The Line/Fill Selector Button

The button prior to the Invisible Colors is the Line/Fill button which is used to 
toggle between Fill Mode and Line Mode.

If Fill Mode is selected, then clicking on a color plate will set the Fill color of a 
selected shape. Right-clicking on a color plate will set the Stroke color.

If Line Mode is selected, then left-clicking a color plate will set the Stroke color of 
a selected shape. Right-clicking on a color plate will set the Fill color.

The Halftone palette also has a Line/Fill button, which operates in similar fashion 
for Knock Out, Overprint, Overlap, Primers and Halftones.

Color Plate Labels

Each plate on the Shop palette is indexed according to the order of colors in 
the palette.

To hide these labels, uncheck Show Layer Numbers 
from the Context Menu or select the Options > 
Palette > Show Layer Numbers.

When an Object is selected, its color plate is shown 
on the SmartBar and the index number is visible 
within the plate.
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In addition to its index number, each plate displays a letter that identifies its color 
type: Process (P), Spot Foils (SF), or Spot Color (SC). The letter designation is also 
visible from the SmartBar.

Edit Color Dialog

The Edit Color dialog is opened by double-clicking 
on a color plate in the Shop palette. The main 
controls of the Edit Color dialog are within the 
top third of the dialog. These controls are used to 
indicate the specific color value, its color space 
(RGB, CMYK, etc.) and how the color should 
appear on the Workspace. The lower two-thirds of 
the dialog has additional controls that are used to 
indicate the type of color (Process or Spot) and the 
manufacturer of this color.

Setting the Color Value

Sliders indicate a specific color value according to the Color Space setting 
(RGB, CMYK, etc.). You can change the Color Value by adjusting these 
sliders. You may also click on the Measure button to read a color from a color 
measurement device. Once a color value is adjusted, it will be previewed next 
to the current color. The RGB value of the new color will be shown below the 
preview.
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Color Space
Color Space may be chosen from the dropdown list in the top right corner of the 
Edit Color dialog. The choice of Color Space will determine the method used to 
define the color.

RGB

RGB is the most common format used for additive color mixing. For example, a 
computer monitor is designed to emit Red, Green and Blue (RGB) light which 
combine to form the desired color.

CMY

Cyan, Magenta, and Yellow (CMY) is the format most commonly used when 
performing subtractive color mixing. This sort of mixing works on the principle that 
an external light source will be required to view the image.

CMYK

Cyan, Magenta, Yellow  and Black (CMYK) is an extension of the CMY model, 
where equal portions of CMY colorants are replaced with a single portion of 
Black (K).

HLS

The Hue, Lightness and Saturation (HLS) model identifies colors according to the 
following parameters:

Hue▪▪  is the visual perception of a specific color, such as Red, Orange, 		
	 Violet or Green.

Lightness▪▪  is the appearance of a color in terms of how White or Black it 		
	 appears.

Saturation▪▪  is the perceived richness of a color in consideration of its 			
	 intensity.

LAB

The L*a*b* Color Space, otherwise known as CIELAB, was promoted as 
a standard in 1976 by the International Commission on Illumination (CIE). 
The purpose of L*a*b* was to standardize the practice of predicting color 
differences, where previously there had been as least twenty alternative 
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formulas in use to account for color differences in production workflows. The 
L*a*b* color space is used to maintain color consistency between devices used 
in color reproduction workflows. As such, the L*a*b* color space is a superset of 
both RGB and CMYK color spaces.

The “L*” component refers to the Lightness. The “a*” component varies from 
Green to Red and the “b*” component varies from Blue to Yellow

Context Menus
With the exception of the Manufacturer palettes, all 
of the color palettes have context menus that are 
accessed by right-clicking within the bounds of the 
palette. Clicking on the “three dots” in the lower left 
quadrant of the Workspace will bring up the Context 
Menu.

Opening a Pantone Palette

Selecting Open Pantone Palette will open the Pantone Library folder where you 
can select from several Pantone palettes. These palettes are representative 
of the swatches available through the PANTONE MATCHING SYSTEM. Any of 
these palettes may be set as the default Shop palette or they may be opened 
as Manufacturer palettes. In FastARTIST, these colors are identified as Spot 
Colors (SC) and are defined in terms of their LAB color values for accurate color 
matching.

The first four colors in each palette are not Pantone colors. These 
are system colors that are kept in the FastARTIST palettes for your 
convenience. The system-specific colors are Invisible, Clear Color, 
RGB Black and RGB Process White. Pantone colors are to the right 
of these system colors.

Save

The Save command will save the current Shop palette settings. This will either 
be your current default palette or a palette that you have loaded using the 
Context menu > Load > New command or the Options menu > Palette > Load > 
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New.

When your software is initially installed, the Shop palette is set 
to FactoryDefault.pal located in the main directory. This default 
palette will be automatically used when a new Workspace is 
opened. To change this default, use the Context Menu Load > Set 
default or the Options > Palette > Load > Set default.

You can view the file path of the current 
Shop palette by double-clicking on an 
empty portion of the palette (between 
color plates). The palette will become 
a “floating” toolbar and the file path will be displayed in the toolbar name. 
Double-click again to dock the toolbar in its original position.

Save As

The Save As option it used to save the current Shop palette settings as a new 
PAL file. Saving the Shop palette is desirable after it has been customized with 
commonly used color plates. The saved palette may then be opened like a 
manufacturer palette or it may be set as the default palette that is loaded with 
each new FastARTIST Workspace.

Save Default on Exit

If the Save default on exit item is enabled (a checkmark should appear next to 
the item), then all changes to the Shop palette will be saved when FastARTIST is 
shut down. 

Creating a new FastARTIST Workspace will not cause palette 
settings to be saved. You must use the Save As command to save 
such settings before creating a new Workspace.

Load

During installation, a Palettes directory was created within the FastARTIST 
directory. The Palettes folder contains color palettes for a variety of 
manufacturers and each palette can be identified by its *.PAL file extension.

To load a FastARTIST color palette, choose Load > New from the Context Menu 
and the new palette will replace the current Shop palette configuration.

Merge is used to select a palette (.PAL) file and append it to the current Shop 
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palette. Use this command to combine color plates of two-or-more commonly 
used palettes.

When FastARTIST is launched, a standard palette is loaded with a selection of 
commonly used process colors. Use Set default to specify an alternate palette 
to be loaded instead of the standard palette. 

Shop Palette Wizard

The Shop Palette Wizard is a visual browsing tool used to create a custom 
palette by browsing and selecting from any of the palettes that were installed 
with FastARTIST. Colors from more than one palette may be combined with no 
restrictions on creating a palette containing colors from different manufacturers.

View Installed Palettes

During the FastARTIST installation, purchased modules will determine what color 
palettes are included. To confirm available palettes, choose View Installed 
Palettes from the Context Menu.

Export Palette

FastARTIST palettes (including Spot and Duotone colors) may be exported to 
either CorelDRAW or Adobe Illustrator.

Map Named Colors

The Map Named Colors feature is used to perform color substitutions when 
importing either AI or EPS files. 

Truncate

Truncate will remove all color plates that are to the right of the currently 
selected color plate, with the exception of any colors that are currently being 
used on the Workspace.

Sort Colors

The Sort Colors menu can be used to rearrange the Shop palette color plates. 
Sorted colors will be moved to the front, which is the far-left of the Shop palette.

The table on the following page lists the various sort parameters available.
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Find Color

Find Color is the same as Move Color to Front. The Move Color to Front dialog is 
used to select from an alphabetical list of Spot Colors within the Shop palette. 
click on OK to move the selected color 
to the front of the Shop Palette. Only Spot 
Colors are listed.

Find and Edit Color

The color selected from the alphabetical list of colors is located and opened for 
editing within the Edit Color dialog. Only Spot Colors are listed.

Reset

The Reset option will reload the Shop palette, discarding any changes that may 
have been made to the color plates. The default Shop palette will be loaded, 
unless it has been specified that a default palette should be loaded. Using 
the Reset option will allow you to return to the original palette colors without 
deleting Objects currently on the Workspace.

By Selected 
Objects

For the given selection of Objects, their color plates will be shifted to 
the left of the Shop palette.

By All Objects Colors that are currently being used on the Workspace will be shifted 
to the left of the Shop palette.

By Active Colors Active colors are shifted to the left, or front of the Shop palette, while 
inactive colors are shifted to the right or end of the Shop palette.

By Hue All of the palette colors will be clustered according to color value.

Move Process 
Colors to Front Shift all process colors to the front of the Shop palette.

Move Spot Foils to 
Front Shift all Spot foils to the front of the Shop palette.

Move Duotone 
Colors to Front Shift all Duotone colors to the front of the Shop palette.

Move Color to 
Front

Select from a list of colors, and move the selected color to the front 
of the Shop palette.
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Show Layer Numbers

Layer Numbers refer to the Shop palette color plates, where each color plate is 
assigned both an index number, as well as a letter designation that indicates the 
correction mode for that color. If the Layer Numbers option is set to OFF, then 
the index numbers and letter designations are hidden.

Creating a Palette Swatch

The Create Palette Swatch is used to prepare a swatch for each color shown in 
the Shop palette. This tool places a palette swatch on the Workspace and the 
swatch can then be printed. This is a very useful tool to compare colors between 
printers, to compare color variances between monitor and printer or to match a 
customer’s color request.

Job Palette 

The Job palette shows colors 
currently being used on the 
Workspace. By default, the Job 
palette shows the Color View, 
which lists all the color plates, 
primer colors and halftones that 
are currently in use on the Workspace.

Selecting Foil View within the Context Menu will display only those Spot Colors 
or Spot Foils that are currently in use on the Workspace. This serves as a quick 
summary of the foils that will be used when rendering the job.

Performing a Global Color Substitution

The Job palette can be used to substitute one color for another and this 
substitution will take place throughout the entire Workspace.

For example, suppose that there are several Red shapes on the Workspace, 
which need to be changed to Orange. From the Shop palette, left-click and 
drag the orange color. (The cursor will appear to be dragging the color plate.) 
Move the cursor to the Job palette and position the tip of the cursor over the 
red color. Release the left mouse button, and all red shapes will now become 
orange.

Halftone Palette

The Halftone Palette is used to apply Knock Out, Overprint, Overlap, Underbase 
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and Halftone properties to Workspace shapes. Since a halftone dot is not 
needed when printing to an inkjet printer, the halftone feature has been 
disabled, BUT this palette is still called the Halftone Palette. The main purpose of 
this palette is to apply an underbase to an image.

The Line/Fill Selector Button

The Line/Fill Selector button is used to toggle between Fill Mode and Line Mode. 

If the Fill Mode is selected, then left-clicking a halftone or primer will apply it 
to the Fill of a selected shape. If the Line Mode is selected, then left-clicking a 
halftone or primer will apply it to the line style of a selected shape.

Line Style Tool
The Line Style Tool is used to apply a “thick line” effect 
to Workspace shapes.

When a shape is selected, the color of its line style is visible in the 
SmartBar. For example, the following screenshot of the SmartBar shows 
that the current Fill color is blue (process color plate 2). The red outline 
around the blue square indicates that the line style color is red.

To change the line style color for a shape, right-click a color plate in the Shop 
palette. Alternatively, you can drag and drop a color plate onto the outline of 
a shape. The color will appear where the tip of the cursor is located when the 
mouse is released. If the mouse is released when the tip of the cursor is within the 
shape, then the Fill Color will change.

In cases where Workspace shapes should have thick Line Styles, 
but none are visible, verify that the Show Line Style option has been 
selected in the View menu.

To add a Line Style to a selected shape, choose Line 
Style from the Stroke and Fill Tools flyout.
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The SmartBar controls will appear similar to the following:

At the far left of the SmartBar, the type of line style may then be selected. The 
available line styles are:

At the far right of the SmartBar, the color picker may be used to select 
the Line Style color. In addition, clicking on a Shop palette color will 
also change the Line Style color.

For the Thick Line attribute, parameters of the line may be set from the SmartBar.

Click the Set Default Line Style button to store the current SmartBar settings for 
reuse. However, line color will not be stored as part of this default.

Lock Proportions

If the Lock Proportions option is enabled, 
scaling the shape will cause the stroke 
thickness to be scaled in proportion.

For example, the two rectangles have been scaled by 
200%. However, the Yellow shape has a stroke with Lock 
Proportions enabled, therefore its stroke is also been 

No line Removes any previously applied line style.

Hair Line Creates a 1 pixel wide line. This line cannot 
be cut, but it may be applied as a line stroke.

Thick Line This is initially zero, so the line will not be 
visible until the Thickness field is incremented.
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scaled by 200%.

Line Above

By default, a thick line will actually overlap the contour of the shape. If the Line 
In Front option is enabled, then the line style will partially obscure the shape. 
Alternatively, the Line Behind option will cause the line style to be partially 
obscured by the shape.

End Styles
There are three different line styles, which are used to modify the termination of 
open paths:

Butt End Cap The line style will extend only to the end of the open path.

Extended 
End Cap Create square end caps as terminators for an open path.

Round End 
Cap Perform rounding of open paths.

Corner Styles
There are three corner styles:

Line In Front The line style will appear as if it were above 
the shape.

Line Behind The line style will appear as if it were below 
the shape.

Star with line behind the shape.
Star with line in front. Note 

that the star shape is partially 
obscured by the line style.
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Sharp Corner Corners retain sharp angles as per the base Object.

Round Corner Corners are rounded.

Mitre Corner

For a sharp corner of the original Object, the corner formed 
by the line style may be quite steep. Use the Mitre Amount 
to clip the line style according to a percentage of the line 

thickness.

Gradient and Pattern Fills
Gradient and Pattern Fills are applied to Object Fills from 
the Stroke and Fill Tools flyout.

Gradient Fills

The Gradient Fill styles are selected at the far left of the SmartBar.

Examples of the Fills are as follows:

Gradient Fills Create a process color Fill

Pattern Fills Create a process color Fill effect by tiling a bitmap pattern

Spot Gradient 
Fills Create Fill effects only using one or two Spot colors

Multi Spot 
Gradient Fill Create Fill effects using one or more Spot colors
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Uniform Fill Conical Fill

Linear Fill Square Fill

Radial Fill Triangle Fill

Choosing a Fill Style

When a Fill style is selected, color nubs will appear around 
the Object on the Workspace.

The placement of color nubs will depend on the given 
style. The initial color nubs will also be represented in the 
Gradient Bar.

The two end nubs of the Gradient Bar are fixed, but double-clicking within the 
bar will add a color nub.

The new nubs will also be shown on the Workspace.

A line joins the two initial color nubs, which will indicate 
valid regions for creating color nubs. Double-clicking 
within this valid region will create a color nub.
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Changing Nub Colors

On either the Gradient Bar or the Workspace, a color nub may be clicked to set 
it as the focus. Once designated, the nub color may be changed by clicking on 
the color picker. The color picker is located above the Gradient Bar.

Dragging Color Plates

Color plates may be dragged from the Shop palette and dropped onto a color 
nub. The color nub will then be assigned the given color.

If a plate is dropped onto an area of the shape that does not already contain a 
color nub, then a new color nub will be created.

Deleting Color Nubs

On either the Gradient Bar or the Workspace, control-clicking a color nub will 
delete that nub. To clear all color nubs, click on the Clear Nubs button.

Horizontal and Vertical Position

By default, the Gradient Fill is placed at the center of the 
Object. The Horizontal and Vertical Position fields may be used 
to place the gradient Fill.

Gradient Angle

Dragging the color nubs may be used to adjust the angle of the 
Fill. The Angle field on the dialog bar may also be used.

Dragging a color plate from 
the Shop palette

The color nub is assigned the 
new color.

Hold the color plate over the 
existing color nub, and then 
release the mouse button.
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Repeats

The Fill can be applied with either as a Single or repeating Sawtooth or Wave 
pattern.

Single Render the Fill from the initial color through to the final color.

Sawtooth

Render the transition from the initial color through to the final color, 
which then repeat the specified number of times. For example, five 
colors with 4 repeats would display shades in the following order: 

1-2-3-4-5, 1-2-3-4-5, 1-2-3-4-5 and 1-2-3-4-5.

Wave

Render the transition from the initial color through to the final color, 
and then from the final color through (in reverse order) to the initial 
color. For example, five colors with 2 repeats would display shades 

in the following order: 1-2-3-4-5, 5-4-3-2-1.

Pinstripe versus Blend

By default, Fills have a Blend style.

Spectrum Up and Down

By default, a gradient Fill between two colors will only have progressive shades 
between those two colors. By doing so, the intervening colors of the spectrum 
are ignored. By clicking on either the Spectrum Up or Spectrum Down buttons, 
the blend of colors will include these intervening spectrum colors.

For example, consider the memory aid ROYGBIV, which is short for Red, Orange, 
Yellow, Green, Blue, Indigo and Violet. If the gradient Fill is initially between 
Orange and Blue, then the following is true:

The Pinstripe style will create an abrupt transition 
between each Fill color.

Using a Blend style will create a gradual transition 
between each Fill color.

Spectrum Up Orange, Red, Violet, Blue

Spectrum Down Orange, Yellow, Green, Blue
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Save Fill

At the far right of the SmartBar is the Save 
Fill button. When this button is clicked, the 
Gradient Fill will be saved as a new color 
plate and appended to the end of the Shop 
palette.

The Gradient Fill plate may then be applied like a regular palette color.

By default, the name of the plate will be Gradient Fill. If the Gradient Fill plate is 
double-clicked, then the Edit Gradient Fill dialog will open.

The Edit Gradient Fill dialog may then be used to rename the Fill, choose 
different colors for the Fill, or change the type of Fill.

The Triangle Fill type is not available from the dropdown list. The 
Triangle Gradient Fill has a different Edit Gradient Fill dialog that is 
incompatible with the other gradient Fills.

  Linear gradient – Orange to Blue
	   Spectrum Down					             Orange to Blue

      Orange to Blue gradient – Spectrum Up 

Chapter 5-  Palettes, Strokes and Fills



86

Editing a Triangle Gradient Fill

For a Triangle Gradient Fill, the Edit Gradient Fill 
dialog behaves slightly differently than for the 
other Fills. However, the only real difference is 
that there are three color pickers, which are 
used to select the Fill colors.

Gradient Fills and Color Layers

When a shape is applied with a Gradient Fill, that shape will be considered to 
remain on its original color plate layer, even though the shape will be rendered 
using the indicated Fill.

If the Instant Replay window is open, then the Fill of the selected shape will be a 
Special Fill to indicate that it has a Spot Gradient Fill.

If the Special Fill is selected and then the [Del] key is pressed, the Gradient Fill will 
be deleted and the shape will have the Fill of its original layer color.

Original shape with an aqua Fill
(plate layer 13)

The same shape with a Spot 
gradient Fill. This shape is 
considered to be on layer 13.
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Selecting Shapes by Their Color

As previously mentioned, Shift-clicking on a color plate in the Shop palette will 
select all shapes that have that color Fill. However, this also includes Gradient Fill 
shapes that originally had that color Fill.

For example, consider five shapes that had a Beige color applied and where 
one shape was has also had a Spot Gradient Fill applied.

Later, it was decided that the Beige shapes should be selected. From the Shop 
palette, the Beige color plate was Shift-clicked, resulting in all of the Beige 
shapes being selected. The Gradient Fill shape will also become part of the 
selection, since it is considered to be on the Beige color layer.

Deleting a Color Layer

If the Beige shapes from the previous example have 
been deleted, and the Gradient Fill shape is the only 
remaining shape on the Workspace, double-clicking 
the Beige color plate will cause the Edit Color dialog 
to open. If the Remove button is now clicked, then a 
warning dialog will prevent the color plate from being 
removed.

The Beige color plate cannot be removed because the gradient Fill shape uses 
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Beige as its original layer color. To delete the color plate, the gradient Fill shape 
must be assigned a different (non-gradient) Fill color from the Shop palette.

Gradient Fills and Welds

When creating a design that includes gradient Fills, it is recommended that 
detailed editing be postponed until after all welds have been completed. 
The problem is that when shapes are welded, their original color layers are 
reasserted, thereby losing any gradient Fills.

For each shape that will eventually be applied with a Gradient Fill, assign a 
unique layer color instead. This will allow such shapes to remain distinct from the 
other Workspace shapes. After all welds have been completed, the Gradient 
Fills may be applied to the unique color shapes. If necessary, the unique color 
shapes may be selected by Shift-clicking their color plate on the Job palette.

Pattern Fills

Pattern Fills use a bitmap pattern as a template, which is 
then tiled over the surface of a shape.

Pattern Fills are accessible from the Stroke and Fill Tools 
flyout.

When editing Pattern Fills, the SmartBar is similar to the following:

At the far left of the SmartBar is the Select Pattern Bitmap 
button. click on this button to choose the bitmap that will be 
used as the Fill.

Cell Width and Cell Height indicate the dimension 
of one tile. The bitmap will be scaled to cover the 
entire tile. The X and Y coordinates indicate the 
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Bitmap pattern of 
leaves tiled over a 
rectangle shape.



placement of the initial tile.

The Skew field is useful for creating a slanted effect for the bitmap. 
The Rotate field indicates the rotation that is applied to the bitmap 
tiles.

If Use Partial Fill is checked, then a border will 
be formed about each tile. The border will be a 
percentage of the tile size, and the border color is 
selected from the color picker.

Color Swatches
Color swatches are used to reference the hues that a given printer can 
produce. The precise hue will depend upon the operating environment of 
the printer, such as humidity and ambient temperature. In addition, hues are 
affected by the type of inks and media that are loaded into the printer.

After color swatches are printed, store the printed sheets in a binder for quick 
reference. If there are any changes to the printer operating conditions (i.e. new 
type of media, different manufacturer of inks, etc.), it is worthwhile to create a 
new set of printed color swatches.

There are two tools for creating color swatches: Under the File menu, there are 
the Color Swatches and in the Context Menu there is the Create Palette Swatch 
tool.

The Color Swatches tool is used to create standard process color swatches 
for RGB, CMY or CMYK color values. The Spot Swatches tool is used to create 
Duotone swatches using Spot Foils that are in the Shop palette. The Create 
Palette Swatch tool is used to prepare a swatch for each color that is in the 
Shop palette.

Creating a Set of Process Color Swatches

From the File menu, choose the Color Swatches tool. 
In the Color Swatches dialog:

Use the •	 Standard option to create preset swatches
Use •	 Customization to create a custom set of swatches

Standard RGB Swatches

From the File menu, select Color Swatches. Select Standard, select RGB and 
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click on OK.

The standard RGB swatches are comprised of thirteen sets of swatches, where 
each set has thirteen rows and thirteen columns. The rows indicate the amount 
of Red, which varies top-down from 255 to 0. The columns indicate the amount 
of Green, which varies left-to-right from 255 to 0. Each set of swatches indicate 
the amount of Blue, where each set varies left-to-right from 255 to 0.

Standard CMY Swatches

From the File menu, select Color Swatches. Select Standard, CMY and click on 
OK.
The Standard CMY swatches vary from 0 to 100% of each colorant. The rows 
indicate the percentage of Cyan, which varies top-down from 0 to 100. The 
columns indicate the amount of Magenta, which varies left-to-right from 0 to 
100. Each set of swatches indicate the amount of Yellow, where each set varies 
left-to-right from 0 to 100. Above each set of swatches is a swatch representing 
the given percentage of Yellow.

Standard CMYK Swatches

From the File menu, select Color Swatches. Select Standard, CMYK and click on 
OK.
The standard CMYK swatches are the same as the CMY swatches, except that 
Black is introduced as a fourth colorant. Each swatch is quartered, with 5% Black 
in the top-left, 10% Black in the top-right, 20% Black in the bottom-left and 30% 
Black in the bottom right of each swatch.

Customized Swatches

As an alternative to using the standard swatches, a custom set of swatches may 
be generated. From the File menu, select Color Swatches. Select Customization 

and click on OK. The swatch parameters are set from the SmartBar.

At the far left of the SmartBar, the color model may be set as either RGB or 
CMYK.  If RGB colors are used, then each primary will vary from 0 to 255. If CMYK 
colors are used, then each primary (as well as black) will vary from 0% to 100%.

Grid Size
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The size of the grid can be Small, Medium or Large. The larger the grid, the more 
color swatches that will be created.
Axis Colors

The choice of axis colors will determine how the color swatches 
are arranged. For example, if the horizontal axis is yellow, then the 
yellow content of the patches will increase from left-to-right. The amount of the 
increase is determined by the Percent change between swatches.

Percent Change between Swatches

This percentage indicates the hue shift that will occur between 
successive patches. This value must be positive with small values 
requiring more swatches to complete the grid.

Multiple Charts

More than one chart may be created at once, where 
successive charts will vary according to the chart axis 
color. For example, if the horizontal axis is yellow and 
the chart axis is also yellow, then each successive chart will have its horizontal 
axis shifted by an additional percent change between swatches.

This is shown in the following SmartBar settings. Three charts will be created, 
where the percent change is 5%.

For the resulting charts, notice that the horizontal axis is shifted for each 
successive chart.
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Placing Objects on Layers
By default, shapes are placed on sheet layer 1. To add new layers, double-click 
Layer 1 to open the Sheet Layer dialog. Select Add to add a new layer. 

The following screen shot shows a Workspace where there are three layers 
present.

For selected Objects, clicking on a layer 
plate will place those Objects on that layer. 
An Object may also be assigned to a layer 
by clicking on and dragging the layer plate 
from the Sheet layer palette.

A small square will appear to be dragged 
by the cursor. Hold the dragged square over 
a Workspace shape and then release the 
mouse button. That shape will now belong to 
the given layer.

Selecting All Shapes on a Layer

All shapes on a given sheet layer may be selected by holding the [Shift] key and 
left-clicking the layer plate. The shapes will be added to the current selection.

Highlight Selected Objects 

The Highlight Selected Objects option is used 
to draw a highlight border around selected 
Objects. Shapes that are on a Cut Only layer 
will be given a red highlight. For shapes that 
are on a Print and Cut layer, you can select 
the color for the highlight. These highlights are 
intended as a quick visual cue to confirm the 
nature of a given shape. 

To enable or disable these highlights, select Options > FastARTIST Setup > 
Selection Tool Settings and check or uncheck the Highlight Selected Objects 
option. The Highlight Size field may be used to make the highlight more 
prominent. Select a color from the Color Picker for the Print and Cut Layer 
highlights.
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Image Properties
Image Size

To obtain professional looking prints, it is important to use high quality images 
with a resolution of 150 to 300 DPI (dots per inch). Under Bitmap > Image Size 
you can find the size and resolution information for a selected image. This 
information will be displayed within the SmartBar, as follows:

Pixel refers to the on-screen image size in pixels. Resolution is listed in pixels per 
inch (i.e., like DPI). Image reflects the actual size at which the image will be 
printed, expressed in the current ruler units. Image dimensions are not editable 
within the Image Size edit mode. You must use the Select state to change the 
size of the image. File Size indicates the total amount of hard drive space the 
image will require when saved. Please be careful when creating large, high 
resolution images, the file size can quickly become excessive.

The Maintain Aspect Ratio preference is applied when changing Pixel 
Dimensions or Resolution. Below the Maintain Aspect Ratio checkbox is the 
Sampling Method dropdown list. This indicates the resampling method that will 
be used when changing the Pixel Dimension or Resolution. Resampling involves 
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changing the pixel dimensions, and thus the display size, of an image. The 
available options are:

Normal Resize the image normally, by adjusting the pixel dimensions and/or the 
resolution.

Resample Uses interpolation and averaging to produce a higher quality image.

Bicubic Uses Bicubic interpolation and averaging to produce a higher quality image, 
but is slower than resample.

Many of the options available within Bitmap menu can be applied 
to Vector images without converting them to bitmaps. Tools such 
as Hue and Saturation will transform a Vector image in the same 
manner as it would a bitmap. However, most of filters require you 
first convert a Vector image into a bitmap with a Clipping Path 
in order to perform the adjustment. In these instances you will be 
asked to enter a resolution for use when creating the bitmap. 

Transforming an Image
Render to Bitmap

The Render to bitmap feature in the Transform menu converts any selected 
vector or bitmap Object. The possible color depths are as follows:

Color Depth Description

Monochrome Convert the selected Objects to Black and White bitmaps

16 Gray levels Convert the selected Objects to grayscale bitmaps with 16 shades

256 Gray levels Converts the selected Objects to grayscale bitmaps with 256 shades 
of gray

16 Colors Convert the selected Objects to 4-bit color bitmaps with 16 colors

256 Colors Convert the selected Objects to 8-bit color bitmaps with 256 colors

Full Color Convert the selected Objects to 24-bit color bitmaps with millions of 
colors

The Resolution of the bitmap is specified in Dots per Inch (DPI). The default 
resolution is 72 DPI.
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Render Contour Bitmap

The Render Contour bitmap feature is used to create 
three-dimensional chiselled or bevelled patterns using 
process colors. When a shape varies in thickness, 
the effect will be adjusted to maintain consistent 
proportions throughout the shape.

When the Render Contour bitmap command is 
chosen, the Set bitmap DPI dialog will open. The DPI 
field indicates the “Dots per Inch” of the bitmap that 
will be produced. A high DPI setting will produce a 
higher resolution bitmap (i.e. less aliasing) but a larger file size.

The Constant Slope option will cause the chisel/bevel effect to reach its 
maximum height/depth at the same rate. For areas of the bitmap that have a 
short distance between the edge and center, the bitmap will tend to plateau. 
The Constant Height option will cause the chisel/bevel effect to dip/peak 
along the centerline of the shape. The Direction option creates a chiselled 
appearance that is effective with lettering.

Clicking on OK will 
close the Set bitmap 
DPI dialog and a 
preview of the bitmap 
will be displayed. In 
the SmartBar, the 
gradient bar will 
indicate the range 
of shades used to 
construct the chisel/
bevel effect. The left 
edge of the gradient 
bar indicates the color 
that will be present 
along the outer edges 
of the shape. The right 
edge of the Gradient 
Bar indicates the color that will be present at the center of the shape.

Clicking on either the left- or right-edge of the Gradient Bar will select that edge 
and the color picker may then be used to change the color.

Using the Constant Slope 
setting, a plateau is produced 
at the intersection between two 
rectangles.

Using the Constant Height 
setting, the slopes are varied so 
that a peak is produced at the 
maximum height.
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By double-clicking within the Gradient Bar, a color nub will be created. Initially, 
the color nub will be assigned the shade of color that was present where the 
Gradient Bar was clicked. This color may be changed by utilizing the Color 
Picker.

Note: To remove a color nub, hold the [Ctrl] key and then Left-click the nub.

Subdividing Shapes

Before converting a shape into a contour bitmap, the Ginsu 
Knife tool may be used to subdivide the shape.

For example, suppose that the Ginsu Knife tool has been used to subdivide 
a rectangle shape into several small pieces. Using the Select tool, resize and 
nudge the pieces to create a small gap between each piece. When ready, 
select all of the pieces and apply a Render Contour bitmap operation. A chisel/
bevel effect will be created for each piece, which is then combined into the 
final bitmap.

If a small gap is not created between the pieces, then the Render Contour 
bitmap feature will create a bitmap that shows no separation between the 
adjoining shapes.

Clipping the Edges of a Bitmap

Once a contour bitmap has been created, the original shape may be used to 
clip the bitmap. When editing the contour bitmap, enable the Keep Original 
option at the far-right of the SmartBar.

After click on ing on the Apply button, return to the Select mode. 

Rectangle shape that has been 
subdivided using the Ginsu Knife 
tool.

Select the pieces and apply a 
Render Contour bitmap operation.
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Click the bitmap to make it the “current selection.” From the Arrange menu, 
select Order and To Back. The bitmap will now be behind the original shape. 
Drag a selection marquee around both the bitmap and shape to select both.
Under the Arrange menu, choose Clipping. The bitmap will now be clipped 
according to the contour of the original shape.

Render Multitone Bitmap

The Render Multitone bitmap feature is used to create three-dimensional 
chiselled or bevelled patterns by varying the tints of up to four spot colors. 
Process colors may also be selected, but the Render Contour bitmap feature is 
better suited for working with spot colors.

At the far-left of the SmartBar, the Number of Tones dropdown list indicates 
the number of spot colors that will be used in the multitone bitmap. Up to four 
different spot colors may be selected.

For the Monotone option, only one color picker will be available in the SmartBar.

The Quadtone option will cause four color pickers to be available.

Beneath the color pickers is the Gradient Bar, which is used to indicate the 
range of tints that will be applied as the chisel/bevel effect. The left-hand 
end of the Gradient Bar represents tints that will be applied nearer the edges 
of the shape. The right-hand end of the Gradient Bar represents tints that will 
be applied nearer the center of the shape. If more than one color has been 
chosen, then the Gradient Bar will show their combined tints.

If dark tints are arranged at the left-hand end of the Gradient Bar and light tints 
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are arranged to the right, then a raised bevel effect will be created. If light tints 
are arranged at the left end of the Gradient Bar and dark tints are arranged to 
the right, then a chisel effect will be created.

Next to each color picker is a graph button that indicates the distribution of tints 
for the color.

Click the graph button to open the Tone Reproduction 
Curve dialog, which is used to edit the distribution 
of tints (of that color) in the chisel/bevel effect. By 
default, the curve will be a straight line from the 
bottom-left (250) to the top-right (0) of the graph.

From left-to-right, the graph is 
arranged into ten intervals. Clicking 
within the graph will create a node 
at the given interval which may be 
dragged up or down to vary the 
tint. As a node is dragged, the curve 
values will be automatically adjusted 
to maintain a smooth gradation 
of tints. For example, the following 
screenshot shows two nodes that 
have been created at the 3rd and 6th 
intervals. The 3rd interval has been set 
to 150 and the 6th interval has been set 
to 50.

When varying the tint at a given 
interval, the remainder of the curve will 
be automatically adjusted to provide 
a smooth gradation.

To remove a node, hold the cursor 
over the node and right-click. Choose 
Remove from the context menu and 
the node will be deleted.
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Right-clicking within any other part of 
the graph will access more Context 
Menu commands. The Reset Curve 
command from this menu will delete 
all of the intervening nodes and reset 
the curve to a straight line from the 
bottom-left (250) to the top-right (0) of 
the graph.

Render Pattern Fill Bitmap

The Render Pattern Fill bitmap feature, available in the Transform menu, is used 
to create a custom pattern bitmap that will be used with the Pattern Fill tool 
available from the Stroke and Fill Tools flyout. An example of how to create a 
bitmap pattern follows:

Create the bitmap Pattern•	

Using the 1.	 Rectangle tool, create 2” square 
shape.
Apply a 2.	 Radial Gradient Fill that is 
centered in the square
Select the square and choose 3.	 Render 
Pattern Fill bitmap from the Transform 
menu. The Convert Selection to a Fill 
bitmap dialog will preview the bitmap 
that will be created.
Set the 4.	 Color Depth. For a bitmap that has “millions of colors,” choose the Full 
Color option.
Set the 5.	 Resolution high enough to maintain acceptable print quality. Simple 
patterns will not require a resolution higher than approximately 150 DPI; 
detailed bitmaps should be set for 200-300 DPI.
Type a 6.	 Name that will be used to identify this bitmap pattern and click on OK 
to continue.

The resulting pattern bitmap will now be saved in the Fills directory of the 
FastARTIST installation folder. The pattern bitmap can be applied using the 
Pattern Fill tool.

Apply the New Pattern bitmap•	

Create and select a large shape to be tiled with the new pattern bitmap.1.	
From the 2.	 Stroke and Fill Tools flyout, choose Pattern Fill. The Pattern Fill controls 
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will appear in the SmartBar.
Locate the pattern bitmap you wish to use.3.	
Set the SmartBar controls for the 4.	 size, skew and 
rotation of the pattern bitmap.
Click on 5.	 Apply to produce the finished pattern.
Click on an empty portion of the workspace to 6.	
finish editing.

Easy Color Adjustments
Within the bitmap dropdown menu are several “one-click” tools designed to 
simplify editing bitmap images. You may use any option repeatedly on an 
image to get a stronger effect if you don’t achieve the desired results at first.

Clean Up White

The Clean Up White option will make pixels that are very close to White turn 
White. Using this tool creates a cascading effect within the colors, turning the 
lightest pixels White and averaging the color change with surrounding pixels. 
Each successive mouse click will increase the amount of pure White pixels within 
the image.

Clean Up Black

This command will make pixels that are very close to Black go to Black. Using 
this tool creates a cascading effect within the colors, turning the darkest pixels 
Black and averaging the color change with surrounding pixels. Each successive 
mouse click will increase the amount of pure Black pixels within the image.

Make Lighter

The Make Lighter option is very similar to a Brightness control. Using this feature 
will lighten the entire image from Blacks to Whites.

Make Darker

The Make Darker feature is just the opposite of Make Lighter. Using this option will 
darken the image across the entire tonal spectrum. 

Increase Saturation

The Increase Saturation command will increase the intensity of the CMYK colors 
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with changing their hue.

Blur Image/ Sharpen Image

These two options are very similar to the Blur and Sharpen Filters discussed later 
in this chapter.

CMYK Color Adjustments
Levels

Levels adjusts the distribution of color intensities throughout the bitmap, either to 
correct a scanned image, or to create an artistic effect. Increasing the Black 
level will equate the darkest portions to Black. Decreasing the White level will 
equate the lightest portions to White. Increasing or decreasing the Gamma will 
modify the overall intensity of the bitmap. End Limits are used to adjust the and 
values, which is an effective means of removing absolute White or Black from 
the image.

A histogram is a chart consisting of horizontal or vertical bars, the 
widths or heights of which represent the values of certain data (in 
this case, the data represents pixel brightness across the bitmap).

Example of Using Levels – After a grayscale image has been 
inverted, the separations between the parquetry in (2) are White. 
Using the Levels feature, the White point is lowered to equate all 
the separations to White. The White End Limit is then reduced to 
remove the separations. Finally the Gamma is reduced to create a 
bitmap that is as dark as in the original grayscale (3).
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Contrast/Brightness

The Contrast setting is used to modify the perceived difference between the 
light and dark areas of the bitmap.

The Brightness setting is used to modify the overall intensity of the bitmap.

Hue/Saturation

Hue/Saturation adjusts the Hue, 
Saturation and Lightness values of the 
bitmap.

Hue is the visual perception of a 
specific color, such as red, yellow, violet 
or orange-brown. The Hue setting is 
arranged like a color wheel (ROYGBIV), 
where adjusting this setting will rotate 
the bitmap colors through the color 
wheel.

Saturation is the colorfulness of an 
area in consideration of its brightness level. For example, as a color falls under 
increasing levels of shadow, the color appears darker, even though its saturation 
remains constant.

Lightness is the appearance of a color in terms of how White or Black it appears.

Curves

The Curves menu adjusts the 
tonal range (Shadows, Midtones 
and Highlights) of the bitmap. 
The horizontal scale of the graph 
represents the range of intensity 
values (shadows progressing to 
light or vice-versa) and the vertical 
axis represents the current intensity 
values. The initial diagonal line 
represents the original distribution of 
intensities across the bitmap tonal 
range.

The Toggle Gradient Mode button is used to alternate how the intensity values 
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are displayed. The graph can either display shadows to highlights, with values 
increasing from 0 to 255, or display highlights to shadows, with values increasing 
from 0% to 100%. To set specific intensity values, either click within the graph or 
enter the value using the edit fields. A maximum of thirteen intensity values can 
be set.

Invert

This selection inverts the colors in the 
bitmap, producing an effect similar to 
photographic negative. This feature 
can also be used to invert the color of 
a grayscale image, making the Black, 
White and the White, Black.

Posterize

Posterize limits the number of color levels 
per plane (red, green and blue). For 
example, two levels mean two of Red, 
two of Green and two of Blue. The valid 
range for the number of levels is from 2 to 
64.

Histo Contrast

Histo Contrast increases or 
decreases the contrast of the 
bitmap image, using a histogram to 
determine the median brightness. 
Once the median brightness has 
been determined, pixel values 
above the median are brightened, 
and pixel values below the median 
are darkened.

Stretch Intensity

Stretch Intensity increases the color contrast in the bitmap 
without changing the number of discrete intensity values 
(ordinary contrast adjustments can lose high- and low-end 
values).
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Histo Equalize

Histo Equalize linearizes the number of pixels 
in the bitmap, based on the specified color 
space (RGB, Grayscale etc.). This can be 
used to bring out detail in dark areas of an 
image.

Balance Colors

Balance Colors redistributes the RGB values of individual 
bitmap pixels. For each pixel, its Red, Green and Blue 
components are isolated, and the color sliders are then 
used to increase or decrease the percentage RGB 
values within each pixel. In this manner, a color cast can 
be removed from the bitmap or a color tinge can be 
created for an artistic effect.

Setting all color sliders to 100% will result in a bitmap that is 
entirely White. Setting all color sliders to 0% will produce a 
Black bitmap.

Swap Colors

Swap Colors swaps the color channels of 
the original bitmap. This feature is useful 
for obtaining artistic effects that would 
otherwise be difficult to achieve using the 
other Color Adjustment tools.

Image Filters
Unsharp Mask

The Unsharp Mask feature is actually considered to be a sharpening function 
because it increases the contrast between light and dark areas of the bitmap. 
Wherever there is a transition between light and dark, the light area is made 
lighter and the dark area is made darker, making the transition more distinct.

A blurred copy of the bitmap is created, where the amount of blurring depends 
upon the Radius setting. The blurred copy is then subtracted from the original 
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and the resulting difference bitmap is referred to as the “mask.”

Pixel-by-pixel, where the difference exceeds the Threshold setting, the difference 
is multiplied by Amount and then added to the original bitmap. Where the 
difference does not exceed the Threshold setting, the original pixel value 
remains unchanged.

Average Filter 

This filter changes the color of each bitmap pixel to the average color of 
surrounding pixels. This results in a blur effect.

Gaussian Blur 

Gaussian Blur smoothes or blurs pixels with respect to their surrounding pixels. The 
Radius determines the surrounding area that is considered when blurring a pixel. 

Motion Blur 

Motion Blur creates the illusion of movement within the image. The size of the 
blur is modified through the Blur Effect setting. Angle indicates the rotation of the 
blur, where a positive Angle indicates a clockwise blur, and a negative Angle 
indicates a counter-clockwise blur.

If the Unidirectional option is checked, then the blur effect will extend only in the 
direction specified by Angle. If the Unidirectional option is unchecked, then the 
blur effect extends in both directions.

Median Filter 

This filter changes the color of each bitmap pixel to the average color of 
surrounding pixels. The Median Filter is similar to the Average Filter, except that 
Median Filter is primarily used for noise reduction, rather than a blur effect.

Add Noise 

Add Noise adds random pixels to the bitmap. Adding noise can be an effective 
means of making an image appear older or dirtier, especially where the 
purpose is to distract the eye from imperfections in the original image.

Despeckle 

This removes speckles from a bitmap, such as those present in scanned images.
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Stylize / Artistic Filters

The following Stylize/Artistic Filters are available under the Image menu:

Emboss•	
 

Emboss applies an emboss effect to the bitmap, letting you specify the depth 
and direction of the effect. The Depth indicates the apparent depth of the 
emboss effect.

Solarize•	

Solarize creates an effect that mimics the accidental exposure of 
photographic film to light. This is done by inverting all color intensities that 
exceed the Threshold value.

Oilify•	

Oilify creates an oil-painting effect. For each pixel, the Amount indicates the 
number of surrounding pixels that are considered when creating the effect. 
Increasing the Amount will result in less detail in the resulting image.

Mosaic•	

Mosaic creates a mosaic effect by dividing the bitmap into tiles of the 
specified size, and then averaging the pixel colors within each tile.

Spatial Filter •	

The Spatial Filters are an assortment of mathematical effects that can be 		
applied to enhance the bitmap appearance. The usage of these filters 		
requires a bit of trial-and-error to achieve the desired result. The assorted 		
categories are:

Halftone•	

Halftone converts a bitmap into a grayscale halftone bitmap. The Angle 
setting is used to rotate the pattern.

Emboss▪▪ Gradient▪▪
Laplacian▪▪ Sobel          ▪▪
Prewitt▪▪ Shift and Difference▪▪
Line segment▪▪
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The available halftone patterns are:

Intensity Detect•	

Pixel intensities within the bitmap range from 0 to 255 for each color plane 
(red, green and blue). The Intensity Detect filter compares each pixel’s 
intensity with the Low and High values and sets the pixel’s intensity as follows:

Remove Red Eye
The Remove Red Eye feature is available under Bitmap > Filters. This filter 
removes the “red eye” effect that results from flash photography. For each 
pixel, only the red color component is evaluated. This feature has no effect on 
grayscale images, since there is no “red eye” effect in a grayscale image. If 
desired, a new color can be substituted that is closer to the original eye color.

The FastScan tool should be used to select a small region around the eye. 
Otherwise, all pixels within the bitmap will be affected.

Pixel Intensity Result

Between Low and High Increase intensity to 255

Less than Low Clear intensity to zero

Above High Setting Clear intensity to zero

Red Component of Pixel Result

Greater than Threshold Pixels are replaced (Lightness value is applied)

Less than Threshold No change

Circular Apply a circular halftone pattern

Elliptical Apply an ellipse halftone pattern

Linear Apply a linear halftone pattern

Print Apply a halftone pattern for printing

Random Apply a random halftone pattern

Rectangular Apply a rectangular halftone pattern

View Apply a halftone pattern for monitor display

Chapter 6- Working with Bitmap Images

107



Lightness is a Percentage value that indicates whether the pixels that are 
replaced are lightened or darkened. If this value is greater than 100, the 
replaced pixels will be lightened. If this value is less than 100, the replaced pixels 
will be darkened. This function preserves the lightness of the original pixels and 
substitutes the red color with the new color.

Plug-ins
Plug-ins are software modules used to create special 
effects for existing bitmaps or to create bitmaps from 
line art. Plug-in modules may be purchased through 
Adobe or other third-party developers. To use a plug-in, 
select a bitmap and then choose the given plug-in from 
the bitmap dropdown menu. Depending on the type of 
plug-in, a dialog may open allowing plug-in parameters 
to be edited.

FastARTIST includes five plug-ins from the Alien Skin Eye 
Candy 4000 CD. The available plug-ins are: Bevel Boss, 
Chrome, Corona, Gradient Glow and Shadowlab. 

Some plug-ins require that a foreground and 
background color be set. Bitmap > Options > Set 
Foreground Color or Set Background Color can be used 
to do this.

For instructions on using specific plug-ins, please refer to the 
documentation that was provided with the plug-in installation 
package. A plug-in file is recognized by its *.8bf file extension.

Plug-in Dialog

When a plug-in is applied to line art or line art that has 
been placed over a bitmap, the Plug-in dialog will 
open. For most plug-ins, the effect can be clipped 
by the line art contour to produce a good effect. 
However, some plug-ins will create an effect that 
extends past the line art contour. 

Effect Location•	

Plug-ins effects can create a bitmap from line art 
shapes. For the bitmap that is produced by the 
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plug-in effect, the Effect Location can be used to automatically apply your 
original line art as a clipping path on the bitmap. The benefits of using a 
clipping path are:

The “empty” portions of the plug-in bitmap are usually set to a White 1.	
color, which are undesirable when arranging the bitmap with surrounding 
Objects. Clipping to the original line art will hide the empty portions of the 
bitmap.

The bitmap that is produced by the plug-in will often have a jagged 2.	
edge, which will look poor when scaled up to a large poster size. Clipping 
will “trim” the jagged edge, such that scaling is acceptable.

It is a good idea to scale your original line art to the desired size 
before applying the plug-in effect. Line art shapes will scale 
without diminishing their details.

The Inside (Clipped) option will automatically clip the plug-in bitmap to your 
original line art shape. Use this option to hide empty potions of the bitmap, 
and to trim jagged edges that plug-ins can sometimes produce.

The Inside/Outside (No Clipping) option will not apply a clipping path. This 
option should be used when the plug-in effect extends beyond the bounds 
of the original line art shape, such as the Corona or Gradient Glow plug-ins.

Margin amount specifies the amount of empty margin around a resulting 
plug-in bitmap.

Image Quality•	

Image Quality determines the resolution (DPI) of the bitmap produced by 
the plug-in. The result will vary according to the size and complexity of the 
original artwork. Keep in mind, a high quality image will require a large file 
size.

 
•	 Bitmap Source

Most plug-ins allow for an effect to be applied to more than one Object, with 
the Objects being either line art or images. In a case where there is more 
than one original Object, it won’t be clear to FastARTIST which should be the 
“source” for use by the plug-in. To solve this problem, the following options 
are used to specify how these Objects will be used by the plug-in effect.

If the ▪▪ Use blank Object option is selected, then only the contour of the line 	

Chapter 6- Working with Bitmap Images

109



	 art shape will be used. The plug-in effect will be applied as if the line art 		
	 had a White fill color.

If the ▪▪ Use current fill option is selected, then both the contour and fill 		
	 pattern of the line art will be used. This option is typically used when 			
	 a fancy pattern or gradient fill has been applied to the line art.

The ▪▪ Use selected bitmap option should be used where line art has been 		
	 arranged over an image. The plug-in will be applied to the line art 			 
	 and the original image will be modified by the plug-in effect.

In the example below, both the text and image were selected before 
applying a Gradient Glow effect. The effect was created for the line art (text) 
with the Use selected bitmap option, so the original bitmap was modified to 
include the effect. 

Applying Plug-ins to Sections of a Bitmap

In some cases, a plug-in may require that only part of the bitmap be selected. 
If a selection has not been made, then a warning dialog will indicate that a 
selection is needed.

To select part of a bitmap, double-click the bitmap 
to activate FastScan Mode. At the far-left of the 
SmartBar will be tools for selecting portions of the 
bitmap.

For example, if a bitmap containing several leaves 
is being edited and you wish to apply an effect to 
only one of the leaves, the Draw Lasso tool would be 
useful.
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Select the Draw Lasso tool and sketch a 
selection area around a leaf.

From the Bitmap menu, choose your desired 
plug-in. The plug-in dialog will open, allowing 
parameters to be edited. Once the parameters 
have been set, the effect will be applied to the 
selected portion of the bitmap. In this case, the 
plug-in created a motion blur effect.

Applying Plug-ins to Text

Here are two examples of how a plug-in may be applied to text:

Create a text shape and scale it to the desired print size. 1.	

Go to 2.	 Bitmap > Eye Candy 4000 > Bevel Boss.

Choose the Inside (clipped) option from the plug-in dialogue.3.	

Click on the 4.	 Use current fill option.

Click on 5.	 OK to continue and the Bevel Boss dialog will open, which will be 
used to preview and adjust the bevel appearance.

Click on 6.	 OK to close the Bevel Boss dialog, and the bevel effect will be 
applied.

Chapter 6- Working with Bitmap Images

111



Create a text shape and scale it to the desired print size.1.	

Go to 2.	 Bitmap > Eye Candy 4000 > Shadowlab. Click on the Inside/Outside 
(no clipping) option and Margin Amount will become active.

Set the 3.	 Margin Amount to indicate how far the effect should extend from the 
text.

Click on 4.	 OK to continue and the Shadowlab dialog will open, which will be 
used to preview and adjust the shadow appearance.

Click on 5.	 OK to close the Shadowlab dialog and the shadow effect will be 
applied.

FastScan
The FastScan toolbar contains helpful utilities and menus for manipulating 
bitmaps and combining them with other Objects.

To use FastScan, select an imported bitmap and click on the FastScan 
tool or double-click on the bitmap. 

  
Even you have several Objects of the same type on your 
Workspace, it is important to remember only one bitmap at a time 
may be edited.

Applying Image Filters to Portions of a Bitmap

You may also use the FastScan tool to select a section of a bitmap an apply any 
filters or plug-ins to just that portion of the image

Selection Tools

The following selection tools are available when for use with bitmap images:
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Whole Bitmap Select the entire bitmap

Ellipse Select Select an oval area

Rectangle 
Select Select a rectangular area

Draw Lasso Select a freehand area

Draw Select Define an area that has an irregular shape.

Eyedropper Pinpoint a color in the bitmap.

Palette Select regions based on specific colors. Colors may be 
either added or subtracted from the current selection.

Magic Wand
Select region based on similar colors. The Magic Wand 

setup may be used to customize what is considered to be 
“similar.”

Magic Wand 
Setup

Adjust the range of color intensities that the magic wand 
uses when determining a region. The Fill Holes option will 

include any gaps as part of the overall selection.

Clip Region
Create a clipping shape from the current selection. The 
Clipping Clear command can be used to remove this 

clipping.

Invert 
Selection Invert the current selection area

Modifier Keys

When creating a selection to modify, holding down the [Shift] key while clicking 
with the left mouse button will add additional items, groups or areas to the 
selection. Holding down [Ctrl] and a mouse button click subtracts from the 
previous selection.
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Adjusting the Size

At the far right of the FastScan toolbar is the Region Selection field. Use these 
data fields to adjust the size of the current selection. 

Bitmap Palette

The Target palette color is displayed above the Palette button. 
Double-click on the Target color to add colors to the palette. The 
new color will not be added until used with either the Brush or Fill 
tools. New colors will be automatically appended to the end of 

the palette. clicking on the Palette button will display the current colors in the 
Bitmap palette.

The Image palette dialog may be used to select 
existing palette colors. Several of the colors may be 
selected, which will cause them to be highlighted.

Clicking on the To Front button will shift these colors to 
the start of the palette. Clicking on the To Back button 
will shift these colors to the end of the palette.

In addition, the Re-Order 
button will sort the palette 
from most- to least-prevalent 
colors in the bitmap. All palette 
colors will be sorted, and no 
selection is required. The Custom 
button may be used to add 
colors to the palette, though 
as mentioned previously, new 
colors will not be added until 
either the Brush or Fill tools are used with that color.

Brush Tool

The Brush tool uses the Target color to touch up the 
bitmap. There are several brush shapes available by 
clicking on the Brush Selection button. 

Move Region

The Copy tool may be used to move a selected area to another position 
within the bitmap or used to copy a selected area to another position.
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Copy a Selection•	

To copy a selected area, click on the Move Region button. The mouse cursor 
may then be used to drag the selection.

Move A Selection•	

To move a selected area, click on the Move Region button and then 
hold the [Ctrl] key when dragging the selection. The area vacated by the 
selection will be filled with the Target color.

Crop Tool

The Crop tool removes all of the bitmap except for selected areas.

Fill Region

The Fill Region tool will fill a selected area with the Target color. Select a 
Target color by double-clicking on one of the palette colors in the Image 
palette dialog. Select the area to be flooded using the selection tools 
and click on the Fill Region button

Quarter Bitmap

The Quarter bitmap button will reduce the resolution of the bitmap by 
50% in terms of its width and height. The storage requirements for the 
bitmap will be reduced, however the visual quality of the image may 
suffer.

Extended Information

This tool will display information concerning the dimensions and 
resolution of the bitmap. Clicking on the Resample button will perform 
the same function as the Quarter bitmap command.

Merge Colors
The Merge Colors button removes all unused colors from the Bitmap 
palette. It also merges colors that are selected in the Image palette 
dialog (opened by clicking on the Palette button) and replaces these 
colors with the current Target color.
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Posterize Region

Posterization is the process of 
generating a color palette for a 
bitmap where none exists. It will also 

expand or reduce the size of the palette 
attached to a bitmap. Click on the Posterize 
Region button to open the dialog and 
choose the number of colors that will compose the resulting bitmap.

The Sharpen option affects the color boundary between Objects in the bitmap, 
narrowing it to create the impression of sharp edges.

Bitmap Vectorization
Bitmap Vectorization tools are used to trace components of a bitmap and 
generate a corresponding sequence of vectors. These vectors may be then be 
edited and cut like regular workspace Objects.

The Vectorization feature may only be applied to bitmaps of 8 bits 
or less (256 colors). However, FastScan filters (discussed later) will 
produce 24-bit bitmaps. Therefore, if a filter has been applied to a 
bitmap, then the Mode of the bitmap must be reduced (Bitmap 
menu) before tracing may occur.

The level of Vectorization detail is determined by the Trace Setup controls, which 
are located at the far-right of the FastScan controls.

The Vectorization button will begin the process of 
generating the vectors, and the drop-list is available 
for selecting previous saved settings. Click on the 
Trace Setup button to edit these settings in the Trace 
Setup dialog.

Trace Setup

Vectorization
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Line Fit

The Line Fit controls will determine how close 
the tracing will occur along the edges of 
scanned artwork. In this way it is sometimes 
possible to produce a high-quality trace 
from poor quality bitmaps.

Tolerance•	

Tolerance determines the precision with which edges are traced. A tight 
Tolerance (7 or greater) will indicate that a high precision must be used. This is 
the recommended choice for for a detailed bitmaps. If the bitmap is of poor 
quality or has long, smooth edges, then a loose Tolerance should be used (3 
or less). A loose Tolerance will minimize imperfections in a bitmap, although 
fine details may be lost.

Corners•	

The Corners slider modifies corner recognition. This setting used to help 
distinguish parts of the bitmap that represent a corner, versus parts that 
represent a tight curve. For angular bitmaps that are composed mostly of 
sharp corners, use a Corners setting of 7 or greater. For bitmaps that are 
composed mostly of curves, then use a round Corners setting of 3 or less.

Tracing Options

Tracing Options define the general rules to be applied to the trace.

Speckle Filter•	

Bitmaps that are generated using 
a scanner can often contain 
undesirable speckles, which are 
typically caused by a scratched 
or dirty scanner bed. To ignore 
these imperfections, the Speckle 
Filter may be applied as part of 
the trace. However, be cautious 
of using a high setting, since small 
details may be potentially mistaken for speckles.
Set the Speckle Filter to the number of pixels that will be recognized as being 
a speckle. During the trace, only Objects that are larger than the set value 
will be considered.
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Speckles may also be recognized in terms of a percentage of the overall 
bitmap size. Setting the Speckle Filter to a percentage is useful when the 
bitmap is particularly dirty. 

While higher Speckle filter settings result in fewer extraneous 
Objects being traced, it may also result in the loss of smaller 
Objects. Exercise caution when choosing an appropriate filter 
setting.

Snap Long Lines to Vertical/Horizontal•	

When using a scanner to create a bitmap, the original document may not 
be perfectly aligned on the scanner bed. As a result, lines that were intended 
to be precisely horizontal or vertical will be slightly incorrect. The Snap long 
lines to vertical/horizontal setting can compensate for misalignment of the 
original document.

For example, a setting of 5 degrees will correct lines that are “off” by that 
amount. If the Degrees can not be set high enough, then the document 
should be scanned again or the bitmap can be rotated on the workspace.

Small Shape Accuracy•	

The effectiveness of the Line Fit settings may depend upon the relative size 
of the bitmap versus the component Objects that make up the bitmap. For 
example, a small Object may be considered as dirt when the bitmap is small. 
However, the same Object will be more significant when the bitmap is large.

To determine Small Shape Accuracy, assess the size ratio between the largest 
bitmaps Objects versus the smallest. When the ratio is large, set the accuracy 
to high (7-10). Where Objects are similar in size, set the accuracy to low 
(Off-3). 

Overlay•	

As part of the tracing, the bitmap is scanned in order to identify the 
component Objects of the bitmap. The Overlay option is used to choose the 
style of scanning that is used.

Traditional Scanning Style▪▪

If the Overlay button is disabled, then the Traditional scanning style will be 
used, and each Object will be identified as an independent part of the 
bitmap. 
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Overlay Scanning Style▪▪

Overlay scanning will create a mask for each palette color and each 
mask will then be evaluated to help identify distinct Objects.

Since masks are evaluated according to the order of their colors in the 
bitmap palette, it is recommended that the Re-Order button be used first 
(Image palette dialog) to signify the importance of more frequently used 
bitmap colors.

Overlay tracing would be the preferred choice if you wished for simpler 
Objects to be produced or for no overlap to occur between Objects.

Centerline Tracing
The Centerline feature is available in the FastScan tools. This tool uses the 
bitmap qualities to produce a centerline traced drawing that can be 
cut, routed or engraved by FastARTIST. This feature works best with larger 

size Objects where v-bits and/or conical bits have an obvious effect. As a result, 
this feature does not work as well with photographic images.

Applying Centerline Tracing 

Pressing the Vectorization button applies a Centerline Trace to the selected 
Object based on the settings provided.

Setting Up Transparent Backgrounds in FastARTIST
To set transparent backgrounds in FastARTIST, double-click on the image to enter 
Bitmap Editing Mode. 

Using the Eyedropper tool, click on the background color (Red in this example) 

Given this bitmap... the Overlay style would also yield these Objects.

Given this bitmap... the Traditional style would yield these Objects.
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and click on the Add Color button in the 
Color Selection dialog box. This will make the 
selected Red the current color.

To finish making Red transparent, click on 
the Eye icon next to the selected color. This 
acts as a toggle switch- selecting it again will 
deactive any transparent color.

The background color can be any solid color, not just Red. For 
example it can be White, Black, Blue etc. However, FastARTIST will 
remove one color only. If your image has a multi-color or gradient 
background, it may be necessary to use an application like 
Photoshop to make the image print ready. 
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Chapter 7
FastRIP Setup and Configuration

The Print button may tell your printer to start producing an image, however 
it must know what to do with the image data it is being given. That is the job 
of a Raster Image Processor, or RIP. The RIP translates the image data into a 
language called Postscript and Postscript conveys the image as a series of lines, 
or rasters, with information about what colors go where and how much ink to lay 
down. Given this data, your printer can then begin to produce an image.

FastRIP is a specially designed Raster Image Processor that 
makes Inkjet-to-Garment printing possible. This very powerful 
software tool is included as part of the FastARTIST software 
package, however it must be configured separately and prior 
to sending any Print commands to your Fast T-Jet.

Once installation has been completed, the first time you load FastRIP it will 
automatically present the configuration screens. Should you wish to reconfigure 
FastRIP at a later time, you must access FastRIP Setup through FastARTIST to 
recall the configuration menus.

Printer Tab
The Printer tab in FastRIP Setup lists all the available 
printers connected to your computer. If your Fast 
T-Jet is not currently listed as an available printer, 
click on the New Printer button.

For best performance, we recommend 
that your Fast T-Jet be the only printer 
connected to your computer when 
outputting to garments.

Hold Job

If this option is enabled, any jobs received by FastRIP will be automatically held. 
They will appear in the Queue but they will not print until manually Released.
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Spot Color Matching Option 

This option determines how Named Colors are printed. If this option is ON, then 
Named Colors are printed using their LAB lookup value. This creates a Process 
Color equivalent to the Named Colors. If this option is OFF, then Named Colors 
will be printed using their CMYK values from the Shop palette.

Print Modes
A Print Mode is a pre-set calibration file that is used to tell the Fast T-Jet how to 
print specific image types or materials.

There are three basic modes for printing – Cartoon, Photo, and Underbase. The 
Cartoon and Photo Print Modes will print the image in color when printing from 
FastARTIST or any other graphics program. These two modes were created to 
adjust print characteristics based on the image to be printed. If you are printing 
vector graphics with Spot Colors, use the Cartoon Print Modes. If you are printing 
photo-type bitmap images, use the Photo Print Modes. Underbase Print Modes 
pertain exclusively to White ink and how it is printed onto your garments. 

Cartoon Print Modes are designed to:
Lay down more ink with good color saturation•	
be used for non-critical images•	
allow a lower DPI to be selected•	

Photo Print Modes are designed to:
Lay down less ink with highly accurate colors•	
reproduce an extremely detailed image•	
utilize a higher DPI to ensure good print quality •	

Resolutions, Speed and Quality

You will notice that each Print Mode has several resolutions. This is because the 
resolution you choose will not only determine print quality, but print speed as 
well. If you use a lower resolution Print Mode, you will achieve a much faster print 
speed, but may not get the quality needed for photo images. Lower resolutions 
apply fewer ink dots per inch (DPI), which allows the Print Head to move much 
faster.

If you use higher resolution Print Modes, you will notice a decrease in print speed 
but an improvement in image quality. A higher DPI increases print quality by 
increasing the density of the dots per inch. Therefore, we recommend a lower 
resolution for cartoon images, but a higher resolution for photo type images. 
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Print Modes with the “HS” designation are bi-directional Print Modes. This means 
the Print Head will print during BOTH the out and back movements of the Print 
Head, compared to a unidirectional Print Mode that just prints on the outbound 
move. Bi-directional Print Modes are twice as fast as unidirectional Print Modes 
and will increase your print speed accordingly, especially if using a higher 
resolution. However, you must be aware of the increased potential for banding 
or shadowing. When using these modes, it is crucial the Nozzles are perfectly 
aligned. 

The number of Print Modes may seem like a lot of choices, however, once you 
start to print jobs you will find that they are not that hard to use. You should 
quickly discover the Print Modes that work best for you. (*The name of your 
printer, such as T-Jet 3 or Blazer will be listed before each CMYK Print Mode.)

When first starting out, the most versatile Print Mode combination 
for BOTH photos and cartoons is 720 DPI for CMYK and 1440 DPI 
for the Underbase. For images on light garments in which no 
Underbase is used, a 2 Pass Print Mode will result in better color 
saturation.

CMYK Print Modes

Cartoon

CMYK Cartoon 720 x 720•	
CMYK Cartoon 720 x 720 HS•	
CMYK Cartoon 720 Standard 2 Pass•	
CMYK Cartoon 720 HS 2 Pass•	
CMYK Cartoon 1440 x 720•	
CMYK Cartoon 1440 x 720 HS•	
CMYK Cartoon 1440 x 720 Standard 2 Pass•	
CMYK Cartoon 1440 x 720 HS 2 Pass•	

Photo

CMYK Photo 720 x 720•	
CMYK Photo 720 x 720 HS•	
CMYK Photo 720 Standard 2 Pass•	
CMYK Photo 720 HS 2 Pass•	
CMYK Photo 1440 x 720•	
CMYK Photo 1440 x 720•	
CMYK Photo 1440 x 720 Standard 2 Pass•	
CMYK Photo 1440 x 720 HS 2 Pass•	
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Eight Color Print Modes

FastARTIST and FastRIP support Eight Color Print Modes that replace White ink 
with the additional colors of Red, Green, Blue and Orange. This configuration 
of inks cannot be used to create an image on dark garments, however when 
printed on light garments, the additional colors create vibrant hues with better 
flesh tones and gradients.

If you did not originally order an eight color system, you may 
purchase inks and supplies as an additional option. If you switch 
between an eight color configuration and CMYK with four White, 
or vice versa, you MUST THOROUGHLY FLUSH ALL of your Ink Lines 
with cleaning solution (until all liquid runs ) before switching 
to the 8 color system. You must then re-initialize your Bulk System 
to get the ink flowing properly. (Refer to your User’s Manual for 
initialization procedures.)
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Slot #1-      Black Slot# 2-      Cyan Slot# 3-      Magenta

Slot# 4-     Yellow Slot# 5-      Red Slot# 6-      Green

Slot# 7-     Orange Slot# 8-      Blue

Slot #1-      Blue Slot# 2-      Orange Slot# 3-      Green

Slot# 4-     Red Slot# 5-      Black Slot# 6-      Cyan

Slot# 7-     Magenta Slot# 8-      Yellow

8C Photo 360/360 HS 8C Photo 360- 2 Pass/360- 2 Pass HS
8C Photo 720/720 HS 8C Photo 720- 2 Pass/720- 2 Pass HS
8C Photo 1440 x 720 8C Photo 1440 x 720 HS

Line #1-      Black Line# 2-      Cyan Line# 3-      Magenta

Line# 4-     Yellow Line# 5-      Red Line# 6-      Green

Line# 7-     Orange Line# 8-      Blue

The ink cartridge configuration for a Fast T-Jet Blazer utilizing an 8 color system: 

The ink cartridge configuration for a Jumbo 2 utilizing an 8 color system: 

The ink line configuration for a Fast T-Jet 3 utilizing an 8 color system: 

Eight Color Print Modes

(*The name of your printer will be listed before each 8 color Print Mode.)



We recommend starting with the 720 DPI HS Print Mode. Eight 
color Print Modes lay down a little more ink than do CMYK+4 
White Print Modes so one pass is generally sufficient. Pretreat shirts 
with FastCOLOR and you should have a very strong print that will 
withstand many washings.

Underbase Print Modes

These Underbase Print Modes may only be 
selected from within FastARTIST. With Cartoon 
and Photo Print Modes available in three different 
resolutions, you have the ability to select the 
proper Underbase Print Mode to match your 
graphic image and Top Color Print Mode. For dark 
shirts try using the 1440 DPI Print Mode to achieve 
a stronger, more consistent Underbase. This is due 
to the fact that the higher resolution will dispense 
more ink at a slower speed, creating an extremely 
even coverage. If you are printing lighter colored 
shirts, it may not be necessary to print such a 
strong Underbase- 720 DPI or 360 DPI may work 
better.

DO NOT check anything in this dialogue if you wish to produce 
ONLY a 4 color (CMYK) or 8 color (CMYKRGOB) output on White 
or light colored garments. If you alter anything within this window, 
FastRIP will think you wish to print White ink.

FastARTIST Underbase

Underbase Cartoon 720•	
Underbase Cartoon 720 HS (Bi-directional)•	
Underbase Cartoon 1440 x 720•	
Underbase Cartoon 1440 x 720 HS (Bi-directional)•	
Underbase Cartoon 1440•	
Underbase Cartoon 1440 HS (Bi-directional)•	

Underbase Photo 720•	
Underbase Photo 720 HS (Bi-directional)•	
Underbase Photo 1440 x 720•	
Underbase Photo 1440 x 720 HS (Bi-directional)•	
Underbase Photo 1440•	
Underbase Photo 1440 HS (Bi-directional)•	
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Windows Underbase

The following Windows Underbase Print Modes can be selected when printing 
from graphics programs such as Adobe Photoshop, CorelDRAW, or Adobe 
Illustrator. There are four Print Mode options and each is available in different 
resolutions. Bi-directional is also offered for each Print Mode as well. 

Select Image modes when printing a bitmap, raster or gradient image. This also 
applies when printing a gradient image in a Vector program. Anytime you have 
a gradient in any image, Image modes must be used. Vector modes should be 
selected when printing solid vector images. You will also be able to print White 
areas as a “Highlight White” on the color pass only if you use Named Spot Colors 
and apply the Named Color White.

Heavy/Normal Underbase changes the intensity of the Underbase. The Heavy 
Underbase modes use a preset that applies more ink in dark and light areas 
then the Normal Underbase modes. Because Underbasing is such a crucial part 
of image quality, we recommend you familiarize yourself with the different Print 
Modes to get better understanding of the uses for each one. 
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720DPI Image Normal Underbase
720DPI Image Normal Underbase HS 
(Bi-directional)

720DPI Vector Normal Underbase
720DPI Vector Normal Underbase HS 
(Bi-directional)

720DPI Image Heavy Underbase
720DPI Image Heavy Underbase HS 
(Bi-directional)

720DPI Vector Heavy Underbase
720DPI Vector Heavy Underbase HS 
(Bi-directional)

1440x720DPI Image Normal Underbase
1440x720DPI Image Normal Underbase HS 
(Bi-directional)

1440x720DPI Vector Normal Underbase
1440x720DPI Vector Normal Underbase HS 
(Bi-directional)

1440x720DPI Image Heavy Underbase
1440x720DPI Image Heavy Underbase HS 
(Bi-directional)

1440x720DPI Vector Heavy Underbase
1440x720DPI Vector Heavy Underbase HS 
(Bi-directional)

1440DPI Image Normal Underbase
1440DPI Image Normal Underbase HS 
(Bi-directional)

1440DPI Vector Normal Underbase
1440DPI Vector Normal Underbase HS 
(Bi-directional)

1440DPI Image Heavy Underbase
1440DPI Image Heavy Underbase HS 
(Bi-directional)

1440DPI Vector Heavy Underbase
1440DPI Vector Heavy Underbase HS 
(Bi-directional)
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Non-Textile Print Modes

Non-textile Print Modes will be used when printing on golf balls and similar items 
that are not of a fabric composition. These Print Modes can be obtained by 
downloading the most recent Printer Package Update for your Fast T-Jet printer. 
The following is a list of available Print Modes (including (2) eight color options):

Non-Textile Photo 1440 Standard•	 Non-Textile Photo 1440 HS•	
Non-Textile Cartoon 1440 Standard•	 Non-Textile Cartoon 1440 HS•	
Non-Textile Photo 2880 Standard•	 Non-Textile Photo 2880 HS•	
Non-Textile Cartoon 2880 Standard•	 Non-Textile Cartoon 2880 HS•	

Options Tab
Within this tab are controls to verify print settings within the Print Mode. There is 
no need to make changes here because any Print Mode you select will override 
User changes.

Preferences Tab
The Preferences tab is used to customize 
workspace elements that will be sent as output 
to the printer.

Copies

The Copies field indicates the number of times 
that the job will be sent to the printer.

Printing Mode

The Printing Mode determines what workspace 
shapes that are valid for printing. The available 
options are:

Selected Objects Only▪▪

Print only those shapes that are currently selected.

Sign Blank▪▪

Print everything that is within the confines of the workspace. Any shapes 
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Non-Textile 8 Color 1440 Standard•	 Non-Textile 8 Color 1440 HS•	



outside the workspace are not printed. Objects that are partially within 
the workspace will be printed accordingly (i.e. they will be partially 
printed).

	
Entire Area▪▪

All objects on workspace are valid for printing, including objects that are 
both within and outside the bounds of the page borders.

▪▪ Fit to Printer

For the currently loaded printer sheet, this option will adjust the image to 
fill the sheet

Maintain Curves in EPS Link Files▪▪

If a linked EPS file contains color curve information, then these curves can 
be retained by checking the Maintain curves in EPS link files option on the 
Print and Cut Setup dialog, Preferences tab.

Page Setup Tab
The Page Setup tab is used to specify page 
margins and the amount of overlap between 
adjoining tiles.

Page Size

Match the Shirtboard that is loaded into 
the printer by either choosing from the list of 
predefined page sizes (a template) or specify a 
Custom Page Height and Width.

Margins

If you wish to apply margins to the printable area of a garment, you would 
set these in the Page Setup tab. These margins will then be shown in Print with 
Preview.

Orientation

Orientation indicates the rotation of the Page Size. Landscape indicates that 
the Page Size will be rotated 90 degrees clockwise. In Print with Preview, the 
orientation is controlled by the Landscape option.
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ICC Profile Tab
The International Color Consortium 
(ICC) has specified a broad variety of 
input and output device profiles that 
are suitable for storing color space 
information. By using the ICC Profile 
format, a color management system 
is ensured of being able to use color 
space information, regardless of the 
manufacturer that was responsible for 
generating the profile. Because of its 
non-proprietary format, the Desktop 
Publishing (DTP) industry has widely 
adopted the ICC profile format for use 
with color management systems.

When your software was installed, ICC 
profiles were loaded into a directory 
labeled “icc” within the FastARTIST root 
directory.

The ICC Profile tab specifies which ICC profile should be used when mapping 
colors. All FastRIP Print Modes use generic monitor profiles for input of RGB data 
and a specific output ICC profile for the media and ink combination used by the 
printer.

Checking Override print mode and selecting Custom will enable the ICC Profiles 
options. For RGB, LAB, and CMYK options that are enabled, their colors will be 
mapped using the best color matching that ICC rendering can produce.

By default, ICC Profiles are enabled for RGB and CMYK. ICC profiles are not 
enabled by default for LAB (LAB is only used in linked EPS files). 

ICC profiles are generic for mapping colors to an output device. Although these 
generic profiles will be minimally adequate for most printers, the profiles are not 
specific to the printer operating conditions, nor the loaded media and inks. To 
provide no mapping at all, simply disable the Line Art and Bitmaps options.

If the RGB options are disabled, then RGB values will be converted into CMY 
values and mapping colors will include Black generation.
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CMYK Color Adjustments Tab
The Color Adjustments tab provides curve 
controls to adjust the tonal range (Shadows, 
Midtones and Highlights) of each separation. 
The horizontal scale of the graph represents the 
range of intensity values (shadows progressing 
to light, or vice-versa), and the vertical axis 
represents the current intensity values. The initial 
diagonal line represents the original distribution 
of intensities across the bitmap tonal range.

Maximum Ink Level Adjustments Tab
The Maximum Ink Level refers to the total volume 
of ink allowed when printing a job. Maximum Ink 
information is contained within the Print Mode. 
Maximum Ink Level Adjustments may be used to 
override Print Mode settings.

FastRIP Queue Functions
FastRIP is the software that manages 
print output. It applies the proper Print 
Mode and allows you to stack jobs, 
reprint jobs and save jobs. Changes 
you make within FastRIP will often 
override settings coming from a Print 
Mode.

FastRIP also allows you to sort print 
jobs, control the sending job batches, 
collect jobs that are similar in nature 
(such as the same type of media) and 
spool print jobs (rasterizing or RIP’ing) in 
advance of sending them to your printer.
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When you press Print, the 
FastRIP Queue will appear. 
Here is where the job is 
processed. 

Sending Jobs to the Queue

When printing jobs, the Queue will automatically open. You may also access the 
Queue by choosing Launch FastRIP from the File menu. 

Naming the Queue

When a workstation has been installed with the 
FastRIP, that workstation becomes a Queue. Other 
workstations may then send print jobs through that 
computer. If you have several networked workstations, 
then it is useful to give each Queue a meaningful 
name that distinguishes it from the others. When a 
computer is initially configured, it is assigned a default 
“My Queue” name, but this can be changed in 
Queue Properties.

To change the Queue Name, select Queue > 
Properties and enter a new name in the Queue Name field.

Sorting Print Jobs 

The Queue window provides real-time control over print jobs as they are sent 
from FastARTIST to local or networked printers. The Queue can collect similar 
print jobs until there are a sufficient number to proceed with a series of print runs.

Multiple Queues- Optional Upgrade

FastRIP is able to support Multiple Queues for users of more than one Fast T-Jet 

printer. Multiple Queues can be configured and used for a variety of different 
uses and you are not limited to the number of Queues that can be configured. 
However, there are restrictions on the number of printers that can be driven at 
one time.

Once you have setup Multiple Queues, they can easily be accessed by click 
oning on their individual tabs. Each Queue acts as a separate RIP, allowing you 
to individually start or stop a job, print different images on different color shirts 
simultaneously or even output different images with different resolutions on 
separate printers.
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Printer Pooling and Printer Echoing utilize a single Queue to control multiple 
printers of the same type (i.e. two Fast T-Jet Blazers). In Printer Pooling, as each 
new job comes in, it would be allocated to the next available printer. For 
example: Job ”A” arrives, is processed and starts printing to your first T-Jet. Job 
”B” arrives and gets processed, but Job ”A” is still printing on the first T-Jet. As a 
result, Job ”B” starts printing on a second T-Jet.

Printer Echoing would output the job to both devices simultaneously. If you 
wanted to get 10 shirts with the same image done in a hurry, use Printer Echoing 
to output 5 copies on each T-Jet.

The Print Manager Window
The Queue window is the main console 
for monitoring print job activity. The main 
elements of this console are:

A •	 dropdown Menu Bar that provides 
the main controls for the Queue and 
selected print jobs

A •	 Toolbar that provides basic (Start/
Stop) controls for the queue and 
selected print jobs

An •	 Active Jobs list that displays all of the active or pending print jobs for the 
Queue

An •	 Archived Jobs list that displays previous print jobs that are now available 
for reprocessing

Each list of print jobs provides real-time information about:

Status of the print and/or cut jobs1.	

Print Modes being used for each print job2.	

File sizes of the spooled print data3.	

Date and time stamps of the print and/or cut jobs4.	

Port destination of the print and/or cut jobs5.	
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Archived Jobs

Active Jobs

Toolbar
Menu bar
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Tool Bar Controls

Below the FastRIP menus are the Toolbar 
controls which are used to start and stop 
the Queue, as well as edit print jobs within 
the Queue.

Add Job

The Add Job button is used to add previously saved PostScript files to the list 
of Active Jobs. The Add Multiple Files dialog will open, which is used to select 
the jobs. At the right-hand side of the list, the order of the batch jobs can be 
adjusted.

The main controls are:

Use the Open File button to select jobs to be added. Once the job has been 
selected, click on the Add to Queue button.

If there are several jobs that should always be loaded as a group, then click on 
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Add Job Add previously saved PostScript files to the Active Jobs list. (See the 
following Add Job section)

Remove Job Remove the selected job from the list.

Release Job Release print job that had been previously held.

Hold Job Place the selected job on hold. This job will remain on hold until it has 
been    released.

Clear Errors
If a problem occurs when printing (such as paper out), the print job will 

be put on hold. After the printing problem is resolved, use the Clear 
Errors item to remove the error flag.

Abort Jobs Delete the selected job.

Start Queue Start the queue and process each print and/or cut job according to its 
status.

Stop Queue Stop all print jobs from being processed. The queue will not proceed until 
the Start Queue button has been pressed.

Open File

Open File List

Save File List
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the Save File List button. For future sessions, this batch list can be loaded by click 
oning the Open File List button.

Queue Menu

The Queue menu contains the basic queue controls.

Jobs Menu

The Jobs menu contains the basic controls for adding, deleting and editing print 
jobs.

Add Opens the Add Multiple Files dialog, enabling you to add PostScript 
files to the Active Jobs list.

Remove Deletes the selected print job.

Restore jobs Used for managing archived print and/or cut jobs.

Select all Selects all print jobs in the Active List. If a job is selected in the 
Archive List, then all archived jobs will be selected.

Select none Clears the current selection of print jobs.

Release Activates a print job that has been put on hold.

Hold Pauses the selected print job.
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Start Same as the Start Queue Tool Bar button. Start the queue and process 
each print job according to its status.

Stop
Same as Stop Queue Tool Bar button. Stop all print jobs from being 

processed. The queue will not proceed until the Start Queue button has 
been pressed.

Clear Job 
Errors

If a problem occurs when printing (such as paper out), the print job will be 
put on hold. After the printing problem is resolved, use the Clear Errors 

item to remove the error flag.

Properties Edit the queue properties. For more information please refer to Queue and 
Print Job Properties within the Index.
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Abort Cancels a job that is currently being spooled to the printer.

Clear error
If a problem occurs when printing, the print job will  

        be put on hold. After the printing problem is resolved, use Clear 
Errors to remove the error flag.

Print When the Queue is paused, print the selected print job and keep the 
remaining print jobs in a pending state.

Spool only
(Preview)

Used to preview printer output. The print job must first be spooled 
and then the spool file can be previewed. This preview is useful to 

confirm layout, but it is not intended to show exact colors.

Reprocess Applied to an archived print job, it moves the selected archived job to 
the Active Jobs list.

Close nesting Manually shuts off the nesting process. New print jobs will not be 
added to the current nest.

Properties View the properties of the selected print job.

Show log console
Will display a window showing the status of the job. This option may 
be used when contacting Technical Support in order to identify any 

errors that might be occurring.

Job Properties

The Job Properties item will open the Job Ticket Properties dialog. These settings 
are inherited from the Queue, so the dialog controls are generally the same as 
when editing the Queue properties with the exceptions being the Job Name 
and Job ID.

The Job Name is the name that is listed within the Active Jobs list and the Job 
ID is the name of the PostScript (*.PS) file that is generated for this job. This file 
name can be found within the Queue directory. The PostScript file name is 
generated by the Queue to avoid conflicts with other print jobs.

Job Errors and Logs

If a problem occurs when printing (such as paper out), the print job will be put 
on Hold. After the problem is resolved, use the Clear Errors item to remove the 
error flag.

If a job has encountered an error condition, Job Properties will summarize the 
errors. Job Properties also include a detailed Log of the tasks completed before 
the error was encountered.
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Job Notes

Job Notes are taken from the Job/Cost Notes accessible under the File menu. 
Use this information to retain a record of job particulars, such as delivery date 
and customer contact info.

RIP Settings
RIP Settings are found under Tools > Options 
> RIP. The sliders are used to specify the 
resources available for spooling print 
jobs. These controls will directly influence 
the workstation that is performing the RIP 
calculations.

Amount of Memory to Use

Memory refers to the maximum amount of computer memory (RAM) that may 
be used by the RIP. It is recommended you set this number to approximately 
50% of the amount of RAM you have available. Should the RIP require more RAM 
than you have allocated, it will turn to Virtual Memory (VM) to meet its needs. 
VM refers to a process where space on your hard drive is allocated for use by 
applications to process data. Processing images and graphics uses a lot of 
memory so you should make sure no other applications are running when you 
are preparing your images for print. It is also recommended you have 1-2 GB of 
RAM installed in you computer. Exchanging data between the hard drive and 
your CPU is a much slower process than just using RAM.

RIP Priority Level

All software processes have a Priority Level that determines how the computer’s 
memory will be “multi-tasked.” Normally, processes are assigned equal priority 
levels by default. However, modifying the priority of individual processes is 
acceptable when this improves overall computer performance.

If the RIP Priority Level is increased, print jobs will be processed faster, although 
this will slow down all other software processes that are running on the 
computer. Conversely, if the RIP Priority Level is decreased, then print jobs will 
require more time to complete.

If possible, avoid using the RIP computer for any other applications 
other than print output. If other applications are running, close them 
to prevent long delays and/or a potential computer “crash.”
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Concurrent RIP Operations

To access the Process options, select 
Tools > Options > Processing.

Although the Queue can spool a print 
job quickly, there is still time required 
to send the spool data to the printer, 
especially over a network. Additionally, 
the printer has a physical limit with 
respect to how quickly ink can be laid 
upon the media. Instead of waiting idle 
for a spool file to be completely received 
by the printer, the Queue can begin 
creating spool files for subsequent print 
jobs concurrently.

Only one spool file will be compiled at any given time and the Maximum 
number of concurrent jobs setting limits the number of spool files that can be 
compiled while the current job is printing.

Queue and Print Job Properties

The Queue has default properties (archiving, scaling, levels, etc.) that are 
automatically applied to jobs received by the Queue. In effect, each print job 
inherits the properties of the Queue.

Under the Queue menu, the Properties 
are applied to all print jobs when they 

are received by the Queue.

Under the Jobs menu, the Properties 
for a selected print job can be edited.
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If there is a specific job property that is being frequently modified, then it may be 
more efficient to change the Queue Properties so that all subsequent jobs will 
“inherit” that property by default.

Note: Changing Queue Properties will not affect the properties of jobs that are 
already in the Queue.

Default Printer

FastRIP can accept print jobs from graphic software applications other than 
FastARTIST and PostScript files can be drag-and-dropped into the Queue 
window. In these cases, the Default printer and Default Print Mode would be 
used.

If you wish to print an image requiring white ink for Underbasing 
or Highlights, we strongly recommend you Import the image into 
FastARTIST and print from within that application. If you are printing 
on a Fast T-Jet Blazer, you MUST print images requiring white ink 
from within FastARTIST.

Default Print Mode

If no Print Mode is selected prior to spooling, FastRIP defaults to the Print Mode 
that you set in Setup window.

Hot Folder

A Hot Folder is a directory on the workstation hard drive. The Queue will monitor 
this directory and if any print files are placed in the directory, these files will be 
added to the Queue as new jobs. 

Typically, a Hot Folder setup is used when several computers are linked within a 
network. The Hot Folder would be used by other designers on your network. They 
would copy their jobs into the Hot Folder and your workstation Queue would 
process those jobs.
 
Job Scheduling

Job Scheduling is used to automatically place jobs on Hold. These jobs would 
not be processed until you verify the printer is ready. Jobs may be spooled 
before being put on hold. To access the Scheduling tab, select Queue > 
Properties > Scheduling.
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If the Queue is stopped, ALL jobs are automatically placed on 
Hold, regardless of Job Scheduling settings.

Archiving

After a print job has been completed, Archiving will store the job files for reuse. 
This is an especially important feature where a spool file of a print job has 
been archived. When a spool file has been archived, resending the job does 
not require the time that was spent compiling the spool file. However, keep in 
mind that spool files can require large amounts of hard drive space. To access 
Archiving from the Print and Cut Manager select Queue > Properties > Archiving.

Adjusting the Properties of an Archived Job

If a Spool Folder has been archived, then the properties of the print job will not 
be editable from the Archived Jobs list. The reason for this is that the Spool Folder 
has already incorporated the properties for this job (Levels, ICC Profiles, Scaling, 
etc.). The only way to change these settings is to rasterize the original PostScript 
file. If only the PostScript file has been archived, then the properties of the print 
job can be edited.

Color Adjustments
The Color Adjustments tab (Queue > 
Properties > Color Adjustments) adjusts 
the color levels of the print job. These 
adjustments are not typically required 
because an ICC profile is created for use 
with a specific calibration. Performing Color 
Adjustments will actually distort the color 
accuracy of the ICC profile.

One reason for color adjustments would 
be to create an artistic effect. However, 
the main reason for color adjustments is to 
compensate for non-standard media and 
inks, where the cost of producing a new 
ICC profile is prohibitive.

Making color adjustments by eye is neither 
quick nor easy, especially when adjusting the curve of individual color planes. 
Unless very experienced in color theory, the wisest advice is to keep any 

Chapter 7- FastRIP Setup and Configuration



140

changes simple. For example, if adjustments were made to Shadows for Cyan, 
Highlights for Magenta and Midtones for Yellow without checking the results 
of each step, then there would be confusion over which adjustment caused a 
given effect.

Tonal Correction

Use Shadows, Midtones and Highlights sliders to lighten or darken the image. 
The easiest way to adjust the tonal range is to adjust the highlights first, then the 
shadows and finally the Midtones. Once the Midtones are correct, the Highlights 
and Shadows can be further tuned.

All adjustments should be checked by using a Test Page, which is automatically 
created by choosing Print test page from the Printers menu. This Test Page is 
specifically designed to help recognize changes due to tonal adjustments. The 
individual tints can be checked by referring to the tint percentage boxes. The 
overall balance is checked by looking at the color graduation.

When the test page looks correct, perform an additional test using a 
photographic image.

If the 5% tint box appears to be empty and the 10% tint box appears too light, 
then reduce the white point (Highlights slider) by ten. Should these tint boxes 
appear too dark after another test, incrementally raise the white point and 
continue printing test pages.

If the 90% to 100% tints are too dark, then increase the dark point (Shadows 
slider) by ten. Should these tint boxes appear too light after another test, 
incrementally reduce the black point.

The Shadows Slider

The Shadows slider adjusts the black 
point, which is the lower end of the 
curve. Increasing the Shadows value 
causes the darkest parts of the print to 
be recognized as pure black, which also 
causes the darkest details to be lost in the 
shadows. Generally, the purity of printed 
black depends on many factors, such as 
how many colors are being used. Use the 
mouse to adjust the Shadows slider.
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The Midtones Slider

The Midtones slider adjusts the gamma 
curve. This curve affects the Midtones of 
an image without changing the black 
and white points (the lower and upper 
ends of the curve, respectively). Raising 
the Midtones of a color plane, results in 
laying down less ink on the media for that 
color. 

The Highlights Slider

The Highlights slider adjusts the white 
point of an image. Lowering the 
Highlights value causes the lightest parts 
of the print to be recognized as pure 
white. The more you lower the white 
point, the more shades of lighter colors 
are turned to white. This causes the 
lightest details to be lost. Use the mouse 
to adjust the Highlights slider.

When both Highlights and Shadows are 
adjusted, the contrast between light and 
dark areas will be more pronounced. 
However, light and dark details will be lost 
as those tones were forced to either 0% 
or 100%.

The Highlights and Shadows controls are 
useful for preserving details on printers 
that are incapable of differentiating the 
darkest and lightest pixels accurately. 
By adjusting the white and black point 
values, more of the image details will 
fall within the range that the printer is 
capable of rendering.
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Density Curve

The Density Curve is used to set densitometer 
values for each color plane. This curve is similar 
to using the X-Rite colorimeter, although lower-
cost hand held devices may instead be used 
and the data must be entered manually.

Removing a Color Cast

A color cast is a visual imperfection that is usually caused by a dominant ink 
(or set of inks). In a simple case, removing a color cast is possible by adjusting 
the tonal settings of the individual colors that are causing the cast. Begin by 
adjusting the overall tonal balance. The color balance may then be adjusted 
using the Midtones slider for each offending color individually.

Print a test page after 
each adjustment. When 
all adjustments appear 
complete, perform a 
final test by printing a 
photographic image.

Where a complex color cast must be 
removed, the primary consideration 
is that each adjustment will affect the 
overall color balance of the image. 
Decreasing one color (for example 
Magenta) will increase its opposite 
color on the color wheel (Green).

The effect occurs because Green 
is composed of both Yellow and 
Cyan. Reducing Magenta effectively 
increases the proportions of Yellow and Cyan (relative to the previous CMY 
proportions), making the image appear more Green.

The first step is to identify the color(s) that are causing the problems. This is a 
personal talent that develops with experience, so continue to practice. A 
Test Page is a useful starting tool when identifying problems with color. All the 
necessary ingredients for judging color reproduction are contained in this file. 
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Analyzing the hue wheel (printed as a 1” border), will reveal any bias toward a 
particular color.

Once the problem colors are identified, the alternatives are:

Raise the •	 Midtones value of the problem color, which will result in a less 
saturated print.

Lower the •	 Midtones values of the non-problem colors, which will result in a 
more saturated print.

Combine alternatives (1) and (2) by raising the •	 Midtones value of the 
offending color, while also lowering the Midtones values of the other colors.

Other options:

Although the chosen model may be CMYK, •	 Green can still be adjusted by 
modifying Magenta (which is the complement of Green in the color wheel). 
For example, increasing the amount of Magenta will reduce the green in the 
final print.

Where one color is dominant, such as an overall •	 Yellow tinge to the whole 
page, the solution may be to reduce the Shadows slider for Yellow. This will 
reduce all areas of the page that have a large percentage of Yellow (90% 
- 100%).

Max Ink

Max Ink is used to control the maximum ink capacity that is available across 
the whole page of output. The valid range is from 50% to 400%. By summing the 
total percent of each ink used on the page, the sum will not exceed the Max 
Ink setting. This control overwrites the Print Mode setting. To access the Max Ink 
settings, select Queue > Properties > Max Ink.

Case % MaxInk % Cyan % Magenta % Yellow % Black

1 400 100 100 100 100

2 200 100 0 100 0

3 200 50 50 50 50
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Image Adjustments
The Image Adjustment controls are used 
in addition to the Color Adjustment 
controls. Select the Queue > Properties > 
Image Adjustments.

Image Sampling

Image Sampling controls are used to 
reduce the output quality of the RIP in the 
interest of speed. Reducing the quality 
in this fashion is useful when creating a 
proof of the finished job.

Sharpen / Blur 

The job may be set to either Sharpen or Blur the printed images. The Blur setting is 
useful as a means of creating the effect of a painted image.

Image Saturation

The Image Saturation slider is used to create an artistic touch. As with the tonal 
settings, saturation may be separately adjusted for each color plane. In general:
Increasing the Saturation produces a more colorful print. Decreasing the 
Saturation produces a more grayscale print.

ICC Profiles

A Print Mode contains color space info that determines how colors are mapped 
from the original artwork to the printer. However, this color space info can be 
overridden with the use of ICC Profiles.

Printer Options

Printer-specific options are defined within the Print Mode. Please note that 
these options vary according to your printer model so please refer to the User’s 
Manual that was provided with your printer.

Log View

The Log is used to review statistics about print jobs as they are processed 
through the Queue. In the event of problems, Technical Support can use this 
information to help provide a solution.
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Managing Printers
The Manage Printers dialog (Printers > Manage Printers) lists all of the devices 
that are currently configured for printing through the Queue. From this menu you 
can check connectivity or set printer protocols for network use. Although several 
different means of connecting your printer to your computer are listed, not all 
may be applicable for your machine. Please consult the User’s Manual that 
came with your Fast T-Jet for the recommended method of connection.

File Port

Selecting File as the Port spools the print job and then store 
the spool file in the indicated directory. The spool file can be 
transferred to another workstation for printing. Click on on the 
ellipsis button next to the Port, to open the Port Settings dialog.

FireWire Port

FireWire is the term used by Apple Computers for their implementation of 
the IEEE 1394 standard, which calls for a high performance serial bus that 
connects peripherals to your workstation. This standard has been implemented 
under other commercial names, such as iLink from Sony Corporation. It is also 
sometimes referred to generically as IEEE 1394.

TCP/IP

The TCP/IP port is used with printers that are accessed 
across a TCP/IP network. In order to use a TCP/IP network 
printer, your network system administrator should be 
consulted to determine the IP Address, Port number, and 
Protocol of the printer. To access the Port Settings dialog, 
click on the ellipsis button next to the Port.

LPT Port

The LPT Port, also known as a parallel port, is commonly-
used as a printer port. LPT Mode, also known as Printer 
Port Mode, determines the transmission rate when 
sending data to the printer. Although fast rates of 
transmission are preferable, the printer must be capable 
of sustaining the selected mode. Faster data rates also 
increase the chances of transmission errors, so using a 
good quality IEEE 1284 cable is important.
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If “gaps and lines” are appearing in the output, then this can indicate that the 
LPT mode has been set too high, which prevents the printer from receiving data 
consistently.

For reference, the following table summarizes commonly available Printer Port 
Modes:

ECP Fastest

In this mode, data is sent to the printer at the 
fastest possible rate. Generally most printers can 
support this speed, but if your prints show errors, 

your printer may not be capable of this mode.

EPP Mid-range

This is the mid-range speed setting. It is not often 
used, but may be a good compromise between 

ECP and SPP modes.

SPP, Normal or 
Compatible Slowest

These modes are synonymous and refer to the 
same setting. In this mode, data from the computer 

to the printer is transmitted at the slowest rate 
possible. In this mode there are very few errors 

however, printing time will also be at its longest. If 
your printer can not operate without errors in any of 
the faster modes, you will have to use this mode.

Automatic

If the Automatic option is enabled, FastRIP will attempt to determine the fastest 
possible mode for sending data to the printer. FastRIP will test for ECP (fastest 
rate) capability first, followed by EPP (mid-range rate), and then SPP (slowest 
rate). 

DMA Channel

If the computer hardware supports Direct Memory Access (DMA), then enabling 
the DMA channel option on the Port Settings dialog will allow the printer to 
access memory on the computer motherboard. This allows data transfer to 
occur without involvement of the microprocessor (CPU), which improves overall 
system performance. If DMA is not supported, then the DMA channel setting will 
be ignored. 
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Use Windows LPT Driver

Leave this option disabled.

Null Port

The Null port option simply discards the RIP data, which is useful as a means of 
troubleshooting a print job.

USB Port

A Universal Serial Bus (USB) port has the benefits of allowing new hardware to be 
added without configuration concerns or hardware conflicts. In addition, a USB 
device may be added without requiring the workstation to be restarted.

Aborting a Print Job
This can be a BIG issue. If for some reason you have to cancel a print job in the 
middle of printing, you may find that no matter what you do, the printer wants to 
keep printing.

Here are the steps to take to completely stop or “abort” a printing job:

Turn the printer OFF. (Make sure you follow your printer’s recommended 1.	
procedure for a system shutdown.)

Open the FastRIP program. 2.	
Select and highlight the job in 
the Active List. Go to the Jobs 
menu and select Abort. 

You may get the 3.	 Port Locked warning pop-up. 
Click on Unlock. 

You may also nee to clear the job from the Windows 4.	 Printer Queue. Go to 
Start > Control Panel > Printers and Faxes. Go to View and select Details. 
Double-click on your printer and cancel any jobs listed.
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If you are using a USB or FireWire port, look for a printer called “PhotoScript 
Passthru” and cancel any jobs listed. 

Remove the job from the FastRIP 5.	 Queue. Right-click on the job and select 
Remove.

Extreme cases may require unplugging your printer from the wall outlet. This 
flushes the entire contents of the printer’s memory. Unplug the power cord and 
wait about 10 seconds. Plug the power cord back into the wall and turn the 
printer ON.

This should stop all running print routines and clear 
out the queue. However, if you are printing a 
large job, or if there are multiple pages stacked 
up waiting to print, the print job may still not 
be dead. If you turn the printer back ON and it 
starts to print out page after page of “Postscript 
computer code” then you haven’t totally flushed 
the system.

You need to stop this immediately. Code prints very fast and can be literally 
hundreds of pages in volume. If you are printing on multiple garments, it can ruin 
all of them in very short order. You should ALWAYS make sure your printer starts 
to print an image before you walk away to another room.

This code is a result of the Windows Print Manager retaining objects that have 
already been ripped (using FastRIP) even after a PC or printer shutdown. Check 

A screen of computer code
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the System Tray window to see if there is a small Printer Icon showing. If so, 
double-click on this to open the Print Manager. Select the printing job(s) and go 
to File > Purge Print Jobs.

If FastRIP Doesn’t Print 

If for some reason FastRIP doesn’t print, or if you continue to get PostScript code 
output even after you cancel a print routine, you may need to re-install the 
program or the printer driver. It is possible for the program or printer driver to 
become corrupted.

Auto Head Cleaning
We recommend you schedule Automatic Head Cleanings 
every 12 hours using FastRIP. This will help prevent Print Head 
and Capping Station issues caused by dried ink. This is especially 
important if the printer will be idle longer than ONE day (24 hrs).

FastRIP offers an Auto Head Cleaning function. One of the most common 
problems with printing white ink is that it has a tendency to clog the Print Head. 
The Auto Head Cleaning function allows your printer to perform Head Cleanings 
throughout the night which keeps the white ink from settling and/or clogging 
the Print Heads. Your Fast T-Jet will be ready to print first thing in the morning, in 
addition to requiring less maintenance.

To setup the Auto Head Cleaning function, 
open FastRIP and go to the Queue menu. 
Select Properties > Printer Status. 

Check the box to the left of Head Cleaning 
and select the amount of time until the first 
procedure (hours and minutes). 

For example, if you activate the Head 
Cleaning option at 5pm with a time frame 
of 7 hours, FastRIP will perform a head 
cleaning at 12am (midnight). Unless the box is unchecked to deactivate the 

Printer Icon
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Auto Head Cleaning, FastRIP will perform another Cleaning at 7am. Head 
Cleanings will then continue every 7 hours until deactivated. 

Once you have selected the time frame, you have the option of performing a 
Head Cleaning immediately or clicking on OK to confirm your settings.

The printer and computer must REMAIN ON (DO NOT SHUT OFF) for 
FastRIP to perform the Auto Head Cleaning. The computer monitor 
may be turned OFF.   

An Important Note for Fast T-Jet 2 Users
Waste Bottle Valve

Your printer is equipped with an external Waste Bottle and 
valve to protect against the possibility of siphoning. This valve 
must remain in an OPEN position whenever the machine is 
powered ON. This also includes any time when the Fast T-Jet 
2 is in Standby Mode, awaiting a new print job, or if you have 
activated the Auto Head Cleaning function. 

In all other instances, when your printer is POWERED OFF 
(using the POWER button located on the control panel), 
the Waste Bottle valve must be CLOSED. As the Fast T-Jet 2 
is powering OFF, the Print Head will dock with the Capping 
Station and run a Head Cleaning to remove excess ink. 
Wait until the printer has turned itself OFF completely 
before closing the valve. 

The Waste Bottle Valve must remain in the OPEN position when 
utilizing the Auto Head Cleaning function. Failure to OPEN the 
Waste Bottle Valve during printer operation may cause 
serious damage to your Fast T-Jet 2. If the Waste Bottle Valve 
remains CLOSED during a Head Cleaning, pressure in the 
Capping Station will force the Waste Ink Line to disconnect, 
resulting in a large ink spill inside of your machine.

We are is not liable for any property damage caused by ink and/or ink 
siphoning. Please be sure to read and understand all operating/maintenance 
procedures before using your Fast T-Jet 2.
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Fast T-Jet 2 and Fast T-Jet 3 Additional Functions
Within the Device Options window of FastRIP, users of the Fast T-Jet 2 and Fast 
T-Jet 3 have the ability to reset the Waste Tank (Ink Pad) Counter as well as 
execute a strong head cleaning cycle (Initial Charge).

To use these additional functions, make sure your printer is ON, connected to 
your computer and in Ready Status. To access these options, open FastRIP and 
go to Printers > Printer Properties or click on on the last icon in the FastRIP Toolbar 
that says Print status and settings.

Reset Ink Pad Counter

Your T-Jet printer counts the number of ink drops used during printing and in any 
maintenance, such as Head Cleanings and Nozzle Checks. The printer has as 
preset threshold of ink usage, that once exceeded, would indicate the Waste 
Tank Pad is full. This will cause the printer to error and you can no longer print. 
The Reset Ink Pad Counter option will clear this error.

Upon receiving this error, it is very important that you visually inspect the status of 
your Waste Ink Pad prior to resetting the counter. It may need to be replaced. 
Just resetting the counter without checking the pad could cause an overflow 
of waste ink, seriously damaging components of your printer and perhaps other 
personal property and equipment.

After pressing the Reset Ink Pad Counter button, the error should clear in about 
10 seconds.

Initial Charge

This feature can be used when a bulk system is first installed or when you 
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encounter a serious head clog. Keep in mind this utility uses a significant amount 
of ink.

Removing FastRIP
Should you need to reinstall ANY version 
of FastRIP or if you are upgrading to a 
newer version and you are instructed to 
uninstall your current application, you 
must do a COMPLETE uninstall or you 
may create registry issues that could 
affect the operation of your computer. 

To uninstall FastRIP from your computer, 
click on Start > Control Panel and 
find the icon labelled Add or Remove 
Programs. Double-click on this icon and 
another window will open. Scroll through 
the listings until you see FastRIP. Click on the program to highlight and then click 
on the Remove button. From the FastRIP Setup window, select Remove and click 
on Next.

The uninstall process will remove most of the program components, however a 
folder MUST still be deleted from you hard drive. Right-click and Explore your My 
Computer icon on your desktop. Double-click on your C: drive and double-click 
on Program Files. Right-click on the FastRIP folder and select Delete. Delete the 
RIP driver by going into Start > Settings > Printers and Faxes. Right-click on your 
printer and select Delete.  

Other FastRIP Errors or Concerns
Dongle or RIP Conflicts

If you are printing to other devices that use a Dongle, or if you have another 
RIP installed for other applications, there may be conflicts. Remove the other 
Dongle(s) or disable the other RIPs before printing to resolve any conflicts.

Make Sure You Have Enough RAM

RAM is the temporary memory that your computer uses when processing 
complex data. RAM is NOT expensive. Most computers ship with 512 MB 
(Megabytes) of RAM. This is not enough, especially when using FastARTIST and 
FastRIP. Your computer should have 1 to 2 GB (Gigabytes) of RAM.
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If you are currently using or planning on upgrading to Windows 
Vista, you will need a minimum of 2GB of RAM for proper operation 
of your printer and software.

Start FastRIP BEFORE Sending a Print Job

If you encounter errors when a job is sent to print, try opening FastRIP before you 
send the Print command.

When in Doubt – Unplug Everything

Sometimes inkjet printers just get “confused,” especially if you stop them in the 
middle of a run. If the printer is suddenly acting abnormally, turn everything 
OFF and unplug the power. Make sure to disconnect your Fast T-Jet from the 
computer to end any data transmission that still may be occurring. Leave 
everything unplugged for a few minutes and then plug it all back in and start 
over.

You MUST cancel all print jobs for this to be effective or they may 
start back up when you turn the computer and printer back ON.
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Chapter 8
Printing with FastARTIST 

and a Fast T-Jet
Your Fast T-Jet is designed to produce an image using the four colors of CMYK 
(Cyan, Magenta, Yellow and Black), along with White, if it has been specified as 
a print color for Highlights or as an Underbase.

To print an image, Open or 
Import a file using the File menu. 
If you Open or Import a bitmap 
file from Photoshop or another 
program, ensure the file is in 
RGB format. The file may open 
on the page the wrong size if it 
is in CMYK format.

Because this software is a very 
powerful tool, you also have 
the option of creating the entire 
image in FastARTIST.

Once the image is placed in 
the Workspace, select Print to 
FastRIP from the File menu. This command will send the image to your printer 
through a printer driver called FastRIP. FastRIP is a Raster Image Processor that 
tells the printer how many passes to make, how much ink to lay down, whether 
to print in unidirectional or bi-directional mode and how to print White ink if 
applicable.

If you have not configured FastRIP, you cannot output an image 
to your Fast T-Jet Inkjet-to-Garment printer. Before continuing with 
this Chapter, please ensure you are familiar with all the information 
contained in Chapter 7, especially Print Mode selection.

Printing to a Fast T-Jet using Templates

The easiest way to print with Fast T-Jet is to use preconfigured Templates. These 
have been precisely laid out to correspond to the Shirtboard size(s) on which 
you’ll be printing. 

Go to File > Open and locate the Template folder in the FastARTIST directory. 
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Double-click to open this folder and you’ll notice files for each Shirtboard size. 
(Consult your printer’s User’s Manual for the exact specifications and dimensions 
of any available Shirtboards.) Each template may be loaded in either Portrait or 
Landscape Mode and there are three template types:

Custom Image Placement,1.	
Automatic Image Placement – Template2.	
Automatic Image Sizing – Proportional3.	

Custom Image Placement File•	

Custom Image Placement brings up a 
representation of the full bed with guidelines 
showing where the individual Shirtboards are 
located. You may import or create file(s) that 
fit within the guidelines and place them on the 
template. (This file opens with a square in the 
first location, but you may delete this square.)

Template Placement File•	

When a file is opened, you are prompted for 
a Template and then asked for the image 
name(s) to be placed within the Template. 
FastARTIST will automatically place your 
image(s) on the Template. This template uses 
text placeholders that are replaced when 
images are loaded, therefore you may get a 
“Missing font error” when loading this template 
if you do not have Arial Black Italic on your 
computer. You may Ignore any missing font 
errors.

    
Proportional Placement File•	

The Proportional Placement option file is similar to the Template file but it 
automatically resizes any file to fit proportionally within the guidelines.

Print Preview

To print a job, choose Print to FastRIP from the File menu. FastARTIST will preview 
the job as it would appear upon the media. 
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At the top of the Workspace, the current 
print settings are displayed in the SmartBar. 
In addition, the Print Toolbox provides 
additional commands that may be applied 
to the job.

If the image is too large for the preset page 
size the image will be tiled across multiple 
pages. Since the T-Jet cannot tile, you must 
size the image so it falls on one page only. 
Once you have it sized to fit on a page, the 
commands for moving it and centering it 
are available in the SmartBar.

Printing the Same Image Multiple Times with Gang Mode

When printing with the standard templates, FastARTIST needs to build a very 
large file. Imagine how large a file would be if it was 17” x 47” rather than a 
standard 13” x 18” image? When printing the same image multiple times, you 
can actually conserve computer memory by using Gang Mode. In Gang Mode, 
only one file is loaded and the computer places it in the proper location on a 
template without duplicating the file multiple times in memory.

To use 1.	 Gang Mode, you must place the image to be printed on one of 
the preset Page Sizes that correspond with the Shirtboard(s) you are using 
(Layout > Page Size). Click on File > FastRIP Setup and set the final Page Size. 
Click on the Page Setup tab and select Roll. When you are finished with these 
settings, click Ok.
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Send the file to FastRIP by selecting 2.	 File > Print to FastRIP. Check the small box 
that says Gang Mode. This will bring up the Decal Setup screen. Remember, 
FastARTIST at its core was a sign printing program and this routine was 
designed to print multiple images that are all the same on a sheet of decals.

In the 3.	 Decal Setup window, choose the appropriate Shirtboard configuration 
from the dropdown selection window. Choose the orientation– Landscape or 
Portrait. 

Once you have choosen the orientation, 4.	
FastARTIST will display the image the way it will 
look on the Shirtboard. You will be unable to 
move the images around at this point.

Press the 5.	 Print icon in the Print Toolbox.

Print Preview Controls
Landscape versus Portrait Orientation

The Landscape option is used to toggle the media orientation between portrait 
and landscape.

Toggling the Landscape option will reset any scaling or positioning 
previously performed.
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Tile Overlap (horizontal and 
vertical) settings are applied 
with respect to the media that 
is loaded into the printer, not 
the orientation of the image 
upon the media. For example, 
if the Landscape option is 
toggled, the image will be 
rotated, however, the Tile Overlap settings will not be rotated with the image.

Repeats and Gang Mode

These modes are designed for multiple images on the same page.

Alignment

The Alignment buttons are used to adjust the placement of the shapes 
upon the media. These buttons are only available when the image(s) 
are smaller in area than the media size.

Size and Move 
Clicking the Size and Move button will open the Translation dialog.

In addition to moving the shapes to a specific 
location on the media, the shapes may be 
scaled as follows:

Orientation Leading edge of media

Portrait Top edge of preview

Landscape Left edge of preview

Absolute 
Values

Set a specific width and height for the shapes. The 
original proportions of the shapes will not be preserved.

Percentage 
Values

Scale the shapes by a percentage of their original sizes. 
The proportions of the shapes will be preserved.

Ratio
As an alternative to expressing a percentage, the shapes 
may be scaled according to a ratio value of their original 
sizes. The proportions of the shapes will be preserved.
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Fit to Page

At the far-right of the SmartBar is the Fit to Page button. Clicking this 
button will maximize the shape(s) upon the media, while preserving their 
aspect ratios.

Page Size

Page Size indicates the area 
that is available for printing. 
This is represented by a 
green rectangle around the 
shapes being output. The 
dimensions of the green rectangle are determined by in the Page Setup tab 
from the File > FastRIP Setup menu.

FastARTIST refers to its page dimensions in terms of width and 
“height.” For purposes of printing a two-dimensional image on a 
garment or non-textile item, it is important to be aware of the fact 
that “height” means the same thing as “length.” 

Print Toolbox

The Print Toolbox is the floating toolbar that becomes active in the Print Preview 
mode.

Rotation•	
 
Rotates the shapes by +/- 90 degrees. Perform a rotation to help 
minimize wasted material.

Mirror•	  

Mirror the shapes either vertically or horizontally. Typically, Mirror 
is used where the media is to be reverse-applied, such as the 
inside of a window pane.
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Zoom•	

The Zoom tools are used to 
change the perspective of the 
shapes being previewed. In 
addition to these buttons, keyboard shortcuts may be used.

Print Button •	

Clicking the Print button will send a print 
job to FastRIP. 

The FastRIP Queue will open and the 
job will start to process. 
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Chapter 9
Printing with White Ink

Modern Inkjet printers are 
designed to print either 
four color CMYK or some 
combination of seven or 
eight colors with the addition 
Light Cyan, Light Magenta, 
Light Black and even Light 
Light Black. In order to print 
White ink, however, it is 
necessary to replace the 
four light colors with White. 
This allows the White ink to be 
applied through four sets of 
nozzles because its pigment 
on a garment is very weak.

This is why FastRIP and FastARTIST were created. These programs were 
specifically designed to handle the requirements of printing White ink. When you 
combine the power of FastRIP to “open the valves” and the unique ability to 
control White ink output, printing on dark shirts becomes a reality. 
 
So, with all of this great software and hardware, printing White ink should be 
simple, right? Well, it’s not. For example, what happens if customer brings in a 
piece of artwork with Black type and requests some prints on light shirts and 
some on Black shirts? It would be nice, but your software won’t automatically 
“know” that the Black type needs to be outlined in White or converted to White 
type.

This is where the human factor comes into play- you will still have to make some 
decisions. If you are new to computer graphics and to printing on dark shirts, this 
can result in a slight learning curve. However, with a little patience and a little 
practice, you’ll soon be printing shirts like a pro.

If you have not configured FastRIP, you cannot output an image 
to your Fast T-Jet Inkjet-to-Garment printer. Before continuing with 
this Chapter, please ensure you are familiar with all the information 
contained in Chapter 7, especially Print Mode selection.
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Understanding Underbasing and Highlight White for Garments

When printing on light shirt colors, a little White below the colors will help the 
image stand out. If the image has any White in the actual design, it will help 
the image look complete. When printing on dark or Black shirts, you need more 
White under an image. In order to help the lightest parts of the design really 
stand out, you may need an additional White pass called a Highlight.

FastARTIST and FastRIP can control all of this. In fact, many images need multiple 
passes of White to lay down enough ink. For very bright White on a Black shirt, it 
is common practice to do two or three or passes of the base color (Underbase), 
followed by a pass that prints the CMYK colors AND the Highlight White.

       

Types of Underbase

Cartoon prints, with solid Spot 
colors, often require a solid White 
Underbase. Photographic images, 
or images with lots of gradations, 
do not always need a solid 
Underbase. The secret to great 
looking Black garments is to let 
the shirt be part of the image. A 
grayscale Underbase that only puts 
White where it is needed will create 
a soft and professional looking print. 

Therefore, you will have to choose the type of Underbase you want to use for a 
given piece of artwork. Yes, decisions, decisions, decisions! Printing White ink on 
dark shirts will require a few “sample prints” as you experiment with the proper 
number of White passes, solid or grayscale Underbases and more.
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Underbasing Simple Line Art
Vector based images created in FastARTIST, or images imported from 
applications such as CorelDRAW or Illustrator, are easy to Underbase. 

If you were to create a solid White Underbase for 1.	
this image, you would access the FastRIP Setup 
dialogue from the File menu.

Click on the 2.	 Underbase Setup tab. 
Check Underbase all objects with 
this Underbase color and choose 
the White SF color swatch from the 
dropdown color field. 

Check 3.	 Underbase with Solid Color and set the number of passes in the 
Number of Underbase Colors window. Select your Print Mode and click on 
OK.

Configuring FastRIP to Hold a Job
When printing an Underbase, it is often desirable to 
view the final print image prior to outputting onto a 
garment. To do this you must tell FastRIP to “HOLD” 
a print job before it spools it. Check Hold Job in the 
Printer tab. This will force FastRIP to let you decide 
when you want to print. 

When you are ready to print the job, click on the 
Printer Button. This will start FastRIP.

If you have the Print with Preview 
option enabled you will be taken 
to that screen. Once you are done 
analyzing the preview, you would 
select the printer icon from the Print Toolbox.  
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FastRIP will open and the job will say Pending. Right 
click on the job title and select Spool Only.

The job will start to process and you will see it 
Interpreting, Processing, etc. Eventually it will say 
Holding. Right click on the job title again and 
select View Raw Data.

View Raw Data Window

The View Raw Data 
window is VERY 
informative. Here 
you can select to 
see All Planes (all 
the actual printing 
functions including 
each actual pass 
or Layer) or change 
the background 
color to simulate 
the color of the 
garment.

You may also turn 
off a Layer (uncheck it) to see what it looks like. Layer 1 is the FIRST print pass 
your T-Jet will make. We indicated in the FastRIP Setup window we wanted 
THREE passes of White, so you will notice that there are three layers that show 
ONLY White being printed. In this example, Layer 4 shows the CMYK colors being 
printed. We did NOT tell this image we wanted a highlight White.
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You may also choose to view only the Underbase to 
see how it looks. 

The View Raw Data screen can be made larger along with the Select Planes 
window. This routine actually scans the image to be printed and displays it 
pixel by pixel, if you choose. However, this can be a VERY slow process. It is 
often easier to just Zoom in to view a portion of the image. This is where a fast 
computer with a lot of RAM really helps!

 
For any part of an image that requires White as a printed color, you 
MUST fill that section with Spot White and not Process White.

Underbase Strength

For even more control of your Underbase output, 
an Underbase Strength option containing four 
Underbase level modifiers and a Gama Adjustment 
control are available. Upon importing a PSD, TIFF, EPS 
or PNG bitmap file with a transparent background, 
this window will automatically query whether you 
wish to apply an Underbase to the image. The 
options available are:

None•	

Weak-•	  This is identical to the Normal setting within the Underbasing Wizard. 		
	 The Underbase Strength will be 100% for White Areas, 80% Underbase in Light 		
	 Areas and 0% in Dark Areas.

Medium-•	  This is identical to the Heavy setting within the Underbasing Wizard. 		
	 The Underbase Strength will be 100% for White Areas, 80% Underbase in Light 		
	 Areas and 8% in Dark Areas.

Strong-•	  This new setting adds Underbase under Black image areas in to the 		
	 Medium setting distribution.

The Gamma Adjustment feature will affect the Midtones of the Underbase in the 
event it is too strong or too weak.
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The options available for Highlight White areas are:

None •	

Weak•	 - Regions 100% White 80

Medium•	 - Regions 100% White 90

Strong•	 - Regions 100% White 100

Choking the Underbase

FastRIP allows you to Choke the Underbase to 
prevent “peeking.” Peeking occurs when the 
White Underbase appears as a small fringe 
beyond the borders of an image. This is most likely 
to occur when different resolutions are used for the 
Underbase and CYMK colors, however peeking 
can occur even if both print modes are the same 
DPI. This is because the ink will bleed slightly as it 
becomes thicker.

The Choke feature will reduce the size of the Underbase image to prevent 
peeking. The amount of Choke applied to an image depends on the resolution 
the image. The ideal resolution for an image to be choked is 300 DPI. If the 
image you are working with is less that 300 DPI in resolution, the Choke feature 
will actually result in more pixels being affected. The four settings are:

None •	

Minimum•	 - Chokes the Underbase 	approximately 2 pixels on a 300DPI image

Medium•	 - Chokes the Underbase approximately 3 pixels on a 300DPI image

Maximum•	 - Chokes the Underbase approximately 5 pixels on a 300DPI image

Do not choke back too many pixels on light shirts. If you choke 
back too many pixels, the edge of your image may shift color 
because of a lack of Underbase under the color pixels. Use the 
Minimum or Medium settings. If you are printing to dark shirts, you 
may apply a slightly larger Choke. The edge of your image may 
shift color but it will not be noticeable on a dark shirt.
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If you use the Choke Underbase option, choose the Strong 
Underbase setting. This will apply Underbase under Black. If you 
do not, you may have areas in your image where there’s a gap 
between Black output and White output.

It is VERY important to choose a WHITE SF (spot color White) from 
the color palette. Process White looks White but will NOT print as an 
Underbase or highlight.

Printing an Underbase with a Highlight Pass
Our “Fighting Cardinal” sample image looks good, but it can look even better 
with the addition of Highlights. The teeth, eyes and the word Cardinal would all 
be brighter if another layer of White is printed at the same time as the colors. This 
layer is called Highlight White. 

Highlights work BEST with vector images, but they can also be 
applied to Bitmap images. The drawback to using Bitmap images 
is that FastARTIST views the entire image and does NOT take into 
account any canvas areas around the image. If the Bitmap has 
non-printing canvas (White) around the image, this will end up be 
printing as White.

FastARTIST gives you seven pre-configured Underbase settings covering the 
various combinations of Underbase and Highlights. Double-clicking on any of 
these icons will allow you to see the settings for each. 
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0– No Underbase or Highlight 1- Underbase Only with a Solid 
Color

2- Highlight Only 3- Underbase and Highlight with a 
Solid Color

4- Underbase and Highlight with a 
gradient tint from design

5- Underbase Only with the 
object’s tint

6- Underbase Only and Do NOT print the Object. Use the object’s tint. 
This is good for images that will be printed as Black and White on a 
Black shirt

     0     1      2     3     4      5      6  



To create a Highlight for the White in 
the word Cardinals, ungroup the design 
(if grouped) and select ONLY the word 
Cardinals. Double-click on the Underbase 
icon of choice.

This will open up the Underbase Highlight 
Menu. From here, you can decide what to 
do with the word Cardinals. In this case, we 
want all of the White in the word to be part 
of the Underbase and Highlight passes.

After clicking on Add, you can now select other parts of the image. If you want 
a solid Underbase under the entire design, group the image and double-click 
on the appropriate Underbase icon. You have now told FastRIP to create a solid 
Underbase for everything you have selected. You may also drag-and-drop the 
Underbase icon on a grouped image

Adding Highlights to Other Elements

We really should include the teeth and eyes in the 
Highlight layer, too. If you ungroup the entire design, 
you can drag the Underbase and Highlight icon 
onto the White of the eyes and teeth. This will now 
apply your previously set attributes to these objects 
as well.  

Underbase or Highlight attributes can automatically 
be applied to a selected object by selecting an 
object and clicking once on the desired Underbase 
icons. For an object that has a thick stroke, right-
click on the icon to apply the attribute to the stroke.

Viewing Raw Data of the Highlight

You can see how we have changed the 
final image by sending the file to FastRIP and 
choosing View Raw Data. You will see that 
when you view ONLY Layer 4 (Highlight and 
CMYK) White has been added to boost parts 
of the design.
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Underbasing Full Color Images
If you are working from a Bitmap image 
(scanned, a photo or a design from 
Photoshop, for example), you can’t select 
a specific object to Underbase. The image 
is considered one large square graphic to 
the computer. In most cases you will want a 
Grayscale Underbase (not solid) for an image 
like this so, it will not be heavy and rubbery on 
the shirt.

In order to create a “template” for the White 
ink on a dark shirt, the image must be a negative of the file. When you print a 
negative of the file with White ink, it becomes a positive. Potentially confusing, 
yes, but it’s the facts of life when making an Underbase.

When you convert a full color image to Grayscale and make a negative of it, 
you have a file ready to print with White ink. The image on the left shows what 
the final file would look like as a negative. The image on the right is the image 
printed with White ink. 

          

The Underbase Wizard

The Underbase Wizard was designed specifically to assist 
with the challenges of Underbasing Bitmap images. You 
can access it from the left Toolbar. 
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However, it can’t perform magic. The 
easiest artwork to use is art that has 
a hard edge like the Air Show image. 
Artwork that is harder to Underbase has 
soft or vignette edges like the Cowboy 
image.

When opening the Underbase Wizard, you are given the option of 
Saving/Loading previous Wizard settings in order to recall previous 
Underbase or Highlight settings. This comes in handy if you are 
working with similar images or if you need to use the Underbase 
Wizard for the same image more than once.

Since this is the first time we have are 
Underbasing an image, we have no 
configurations to recall, so have to do 
it manually.

To work with hard edge images that 
have White in the canvas - like the Air 
Show, first make sure you know the 
image resolution. Prior to using the 
Underbase Wizard, your image must 
be resampled to the final actual print 
size at 150 to 300 DPI. A good rule of 
thumb- the more text the higher a resolution should be used. If it is mainly an 
illustration (like the Cowboy) then 150 DPI is acceptable.

If the image is 72 DPI and a low quality JPG file (for example, 
from your customer’s website), it may be soft and jagged and no 
amount of upsampling will save the image.

Select the image with the Selection tool and click on the Underbase Wizard 
icon. The first screen you see will give a sampling of what the Underbase will look 
like. The default Preview Mode is Black on White. You really want to see how it 
will look with White ink on a Black shirt, so change this to White on Black. Make 
sure to pick the Underbase color of White.

You have a lot of control over the Underbase. You can control the Strength 
and make the entire layer solid White. You can also make the Underbase a 
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greyscale image that lets the shirt breath. Keep in mind, you are looking at how 
the Underbase will print on a dark shirt so, this may take a little practice. When in 
doubt, apply more Underbase, but try to avoid Underbasing areas of the image 
that will be dark or Black.

Using a Clipping Path

The White canvas of the original 
artwork is now the problem. If you 
are viewing the image with White 
on Black, you will note that there 
is White ink AROUND the image. 
FastARTIST is just doing what it is 
told. Any area of “White” is being 
printed with White. You must 
REMOVE THE OUTSIDE EDGE OF 
THIS IMAGE.

This is called Clipping and in 
computer graphics is commonly 
called a Clipping Path. A Clipping 
Path finds the outside edge of 
something and removes it. It is 
obviously easier to clip a hard 
edge than a soft edge. The Air Show image is perfect for removing the outside 
edge using the Clipping Path method.

Go to the 1.	 Transform > Contour Object to create a Clipping Path for an 
image.

Select 2.	 Clip Bitmap. Select Invert Bitmap for Black. Leave unchecked the 
option for White.

Click on 3.	 Cut inside bitmaps 

The two buttons on the 4.	 SmartBar just left of the Corner Styles 
selections provide the clipping options. Either the Outside or both 
Inside and Outside can be selected by engaging or disengaging 
the buttons.
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Select Apply5.	

     

You can see that Clipping would be harder if we were using the Cowboy image 
because it might give us a harder edge on what should be a soft edged image. 
When dealing with soft edged images, you’ll just have to experiment.

       

Creating a Highlight

The Underbase Wizard will also create a 
Highlight White. A Highlight will print on top 
of an Underbase White in areas that are very 
light in color or are White. The Highlight White 
prints at the SAME TIME as you print the CMYK 
colors.

The next window you get will ask you if you 
want a Highlight. If not, check No Highlight. If 
you want it to print with the CMYK colors this 
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is called Overlap Highlight. You can let FastARTIST do an Auto Highlight but you 
might feel more comfortable if you have more control. 

Remember that you do NOT want too much Highlight White printing on other 
colors. However, you do want a Highlight to print where there is White in the 
design.

Due to the nature of 
displaying images, the 
Highlight will display in 
negative of how it will print. 
Any areas that are Black 
are actually where the 
White ink will print! Also, 
the Highlight display will 
NOT take into account the 
Clipping Path. This is just for 
the display on the monitor. 
The outside edge of the 
image will be clipped if you 
choose Clipping Path.

Preparing to Print

FastARTIST now places the image on 
the main page with a sampling of the 
final printed image. To represent the 
Underbasing and Highlights, it uses 
diagonal lines across the image. Yes, 
the image is there, you just can’t see all 
of it. You are now ready to print! 

From the File menu, select Print to FastRIP. This 
will bring up the Print Manager.
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Checking Preferences in FastRIP 

Setup

You now need to check the Preferences 
in FastRIP Setup. You can go to the File 
menu and select FastRIP Setup or click 
on the three little dots in the icon on the 
SmartBar. Make sure the Page Size is set 
for the correct shirtboard in your Fast T-Jet 
under the Page Setup tab.

Make sure to tell FastRIP how many passes to make 
when it prints the Underbase in the Underbase Setup 
tab. You should also choose the correct print mode. 
If you want to make the Underbase a little skinnier, so 
it won’t bleed around images, you could also tell it to 
reduce the object’s tint by 3%.

You DO NOT have to check Underbase all 
objects with this Underbase color unless 
you want to overwrite what the Underbase 
Wizard has done. All you need to tell the 
Underbase Setup tab is how many passes 
to make.

Choose the correct printer. Make sure to 
check Hold Job so the job will NOT print 
before you get a chance to View Raw 
Data. Choose the Print Mode and click 
on OK. Make sure the image is in the 
correct location on the page and press 
the Print icon.

Viewing the Image in FastRIP

FastRIP will open and the image will 
say Holding. By right clicking, you can 
select the Spool Only option.
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When the job is done spooling 
(ripping and getting ready to print), 
right-click and choose View Raw 
Data.

Here you can change the background color to Black and see how each Layer 
(printer head pass) will look. Check to see if the Underbase looks correct. You 
might see errors here or an improper setting derived from FastRIP Setup.

If everything is correct, you are ready for output. With a shirt that should be 
pretreated, dried and loaded- press Print!

Two Versions of Your Artwork May Be Needed

It is important you have two versions of the artwork for more complex images 
(with lots of interior areas) or artwork with soft edges. If you are going on any 
other color but Black, you need to have a version of the artwork with a White 
canvas and a version with a Black canvas. The “White” version is used for the 
colors and the “Black” version is used for the Underbase and highlight.

You only need two versions if you want to avoid the problems 
associated with using a Clipping Path because of interior areas 
that need shirt color or DO NOT need White.

These files must be identical in size and resolution. Using the FastARTIST 
Underbase Wizard, you can automatically create the Underbase file and the 
Highlight file without using a Clipping Path routine. Then, all you have to do is 
tell FastRIP how many passes you want of the Underbase and if you want a 
Highlight. 
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Using Photoshop Files•	

If the image came to you as a PSD file with a transparent background, it is 
a simple matter of duplicating the file and creating one image with a White 
background and one image with a Black background.

For an image to Import correctly into FastARTIST from Photoshop, 
it must be saved as a single layer PSD file without a background 
layer. Upon removing the background layer, your image will 
have a grey and White checkerboard background signifying 
transparency.

Using Vector Files•	

If the image was made in a vector program like CorelDRAW or FastARTIST, 
you can duplicate the image and place a Black background around one 
version and a White background around the other. Export each file as a 
JPEG, TIFF or other format that can be Imported into FastARTIST.
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Using FastARTIST to Create the Proper Files
In many cases, the customer will NOT know what you need. They will give you 
artwork with the actual shirt color in the image. However, in most cases you will 
get artwork with White in the canvas area. You need to learn how to quickly 
replace the White in the canvas with Black. Remember, you don’t want to 
replace all the White. The design may have White in the image. You just want to 
get the image looking the way it would look if printed on a Black shirt.

FastARTIST has bitmap editing tools that will help. If the image has a soft edge, 
it is difficult to put White around it. The only real way to make the edges soften 
going out to Black is to use the Airbrush tool and actually paint around the 
image. Doing this will help you encourage customers to give you the correct art.

Using the Magic Wand
FastARTIST has a feature also found in Photoshop called a Magic Wand. To get 
to the Bitmap Editing tools, double-click on the image. If this does not change 
your SmartBar to the Bitmap tools, you need to convert the image to a Bitmap. 
From the Transform menu, click on Render to Bitmap.

With the SmartBar in Bitmap Editing Mode, you can see there are many more 
tools normally associated with Bitmap images.

The Magic Wand tool is designed to select areas of 
an image that have a similar color. You can adjust 
the strength of the Magic Wand in the Magic Wand 
Setup window. This is called the Color Match Radius. 
For now, set the number low.
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Before you select an area to fill with Black, you need to change the Color 
Palette to Black. Double-click on the Palette swatch (White rectangle) and 
choose Black. Click on OK.

Move the Magic Wand near the 
edge of the image and left click. 
Depending on the Color Match 
Radius strength, the Magic Wand 
will search around the image 
(it will not do interior areas) and 
select the edge. If the strength 
is too low, it will find only a White 
edge. 

You will now see a line around the image. This is called a selection, which can 
be filled with color. By clicking on the Paint Bucket icon, the selected area will 
be filled with Black. 

      

If the image has interior areas that need to be changed to Black, use the 
Magic Wand the same exact manner and work your way through all the interior 
sections.

You should always be using a working copy of any image so you 
don’t ruin the original. When you have completed any changes or 
modifications, save the new image under a name that is different 
that of the original artwork.
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Using the Underbase Wizard on White and Black Files

Once you have both versions of an image prepared, import them into FastARTIST 
and let the Underbase Wizard work both at the same time. With two files open 
on the screen, drag the cursor to encompass both to select them. Or, click on 
one image, hold down the [Shift] key and click on the other.

Select the 1.	 Underbase Wizard icon 
from the toolbar and you will be 
prompted to designate which file is 
for a White shirt and which file is for a 
Black shirt.

When you get to the 2.	 Clipping Path 
page, do not check it. Having two 
images makes things very simple.

When you are finished with the 3.	 Underbase 
Wizard, this file is ready to print, except that 
FastARTIST will still be showing the “Black” 
version of the artwork. It is done using this 
file for the Underbase calculations so you 
can delete it.

 4.	 Press Print!
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Additional Underbase Wizard Options

Creating the ideal Underbase is a key component 
to the quality of the print. Due to FastARTIST’s ability 
to import images with transparency, there are three 
additional options for the Underbase Wizard.

When selected, the Underbase/Highlight Wizard will take you 
through a series of dialog boxes with an additional Save/Load 
Settings option located in the lower left corner of the dialogue 
box. This Save/Load option would be utilized if you wish to recall 
previously configured Underbasing settings or if you wish to save a 
new configuration for future use. 

 

The three icons that represent Underbase and Highlight presets will run 
automatically with one click of the mouse. The order from left to right is as 
follows:

Heavy Underbase Wizard •	

This option produces a heavy Underbase with a Highlight pass.

Normal Underbase Wizard•	  

The option creates a Normal Underbase with a Highlight pass.

Last Setting Underbase Wizard•	

The fourth icon will automatically run the last configuration you created when 
you ran the full Wizard (first icon). 
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The three Wizard options listed above will 
not display any dialog boxes unless two 
bitmaps are selected (Black and White mask 
versions of an image). In this case, you will be 
prompted to identify which is the image with 
the Black background and which is the image 
with the White background.

Printing From Various Graphics Programs
Underbase and Color Print Modes

At this time, the Fast T-Jet Blazer will not support printing directly 
from third party applications. Fast T-Jet Blazer users MUST use 
FastARTIST when printing ANY image requiring White ink output.

The various Underbase and Print Modes available for use are listed 
and discussed in Chapter 7 of this Manual. Please consult that 
Chapter for specific resolutions and image compatibility.

Adobe Photoshop- Design Setup

When printing a design from Photoshop, FastRIP will determine which 
components of the image are pure White and configure the output so that 
those areas do not receive an Underbase (RGB 255,255,255 or CMYK 0,0,0,0). 
If you wish to override these settings, set these areas to a slight tint of off-White 
(RGB 254,254,254 or CMYK 1,1,1,1).

In this first example, arrows identify that 
the “N” in California has been set to RGB 
254,254,254, meaning that it will print White.

The arrows in this second example show that 
the background is set to RGB 255,255,255, 
making the background transparent when 
printing with FastRIP. 
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Color Management must be turned 
OFF before sending the image to print. 
Color Management is found in the Print 
with Preview window. Go to File > Print 
with Preview. For more information 
and instructions on how to Print from 
Photoshop, refer to Chapter 9 of your 
FastARTIST User’s Manual.

Printing from Adobe Photoshop

Go to the File menu - Print with Preview. Click 
Page Setup. Click on Printer. In the Page Setup 
menu, select your printer. Click on Properties. Click 
on Advanced. Set the Page Size. Go the Printer 
Features section. Bring the Print Mode menu down 
to select the Color Print Mode. Bring the Underbase 
Mode menu down to select the Underbase Print 
Mode. Set the number of ink passes for Underbase 
and color. Click on OK in Advanced Options. In 
Document Properties set to Landscape or Portrait 
for orientation. Click on OK. Click on Print.

Select either Image Heavy or Normal as your 
Underbase Print Mode.

CorelDRAW – Design Setup

When designing in CorelDRAW, set areas where no Underbase is desired as pure 
White (RGB 255,255,255 or CMYK 0,0,0,0). To print an area as White, set the area 
to a slight tint of off-White (RGB 254,254,254 or CMYK 1,1,1,1).

In this first example, the selected area is 
set to CMYK 1,1,1,1, which is recognized as 
White and will receive an Underbase when 
printed through FastRIP.
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When working with vector images, if you 
use Named Spot Colors, use the Spot Color 
White and FastRIP will create a Highlight 
White when it prints the Top Color pass. 
This means an Underbase will be applied 
and then Highlight White will be printed 
in conjunction with the Top Colors. In this 
example, the arrow is identifying the use of 
Spot White.

Adobe Illustrator – Design Setup

When designing in Adobe Illustrator, set areas where no Underbase is desired as 
pure White (RGB 255,255,255 or CMYK 0,0,0,0). To print an area as White, set the 
area to a slight tint of off-White (RGB 254,254,254 or CMYK 1,1,1,1).

In this example, the selected area is not 
a pure White (RGB 254,254,254), meaning 
that the image will print White.

When working with vector images, if you 
use Named Spot Colors, use the Spot Color 
White and FastRIP will create a Highlight 
White when it prints the Top Color pass. 
This means an Underbase will be applied 
and then Highlight White will printed in 
conjunction with the Top Colors. In this 
example, the arrow is identifying the use of 
Spot White.

Solid Spot Colors - No Gradients

Go to File > Print and select your printer from the General tab. Click on 
Properties. Click on Advanced. Set the Page Size and go to the Printer Features 
section to access the Print Mode menu. Select your desired Color Print Mode 
and use the Underbase Mode menu to select your preferred Underbase Print 
Mode. Set the number of ink passes for both the Underbase and Top Colors. 
Click on OK in Advanced Options. In Document Properties select Landscape or 
Portrait for orientation and click on OK. Click on Print. 
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Gradients, Gradients with Solid Spot Colors, Bitmap with Vector 
Objects 

Go to File > Print. From the General tab, select your 
printer and click on Properties. Click on Advanced 
and set the Page Size. Go to the Printer Features 
section and access the Print Mode menu. Select 
the Color Print Mode. Use the Underbase Mode 
menu to select the Underbase Print Mode. Set 
the number of ink passes for both Underbase and 
color and then click on OK in Advanced Options. 
In Document Properties, select Landscape or 
Portrait for orientation and click OK. Click on Print.

A Final Note
By using a third party graphics application to print your images, you sacrifice 
several features offered by FastARTIST. FastARTIST was DESIGNED to print images 
on garments; applications like Photoshop and CorelDRAW were not. If you do 
not Import your images into FastARTIST first, you cannot utilize the Highlight White 
option. Additionally, you will not be able to access the Highlight/Underbase 
Wizard and its one-click options. These can complete the entire Highlight and 
Underbase functions with one click of your mouse button, saving you a lot of 
time compared to configuring your Underbase manually.
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For more information on designing and printing vector or bitmap 
images, Spot Colors and gradients, consult your Chapters 4-6 of this 
Manual and the Help sections of your graphics application.




