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About this Manual 

This manual is about Multiframe Shape Editor, a section properties calculation and 

design system. Multiframe Shape Editor works with the Multiframe range of structural 

design software. 

 

Chapter 1  

Introduction 

Provides an overview of the program and introduces you to some important concepts 

used within the program. 

 

This chapter also discusses the numerical methods used by Multiframe Shape Editor. It is 

important for you to understand these methods and their limitations before using 

Multiframe Shape Editor for sections properties calculations.  

 

Chapter 2  

Learning Multiframe Shape Editor 

Gets you started drawing, calculating properties and installing a section in the 

Multiframe Sections Library. In this chapter you will find a series of exercises designed 

to help you learn the basics of Multiframe Shape Editor and become confident in using it 

to design your own custom sections. 

 

Once you are familiar with the basic concepts used, you may refer to the step-by-step 

instructions in Chapters 3, 4 and 5. 

 

Chapter 3  

Using Multiframe Shape Editor 

This chapter introduces the basic techniques used to interact with the various windows in 

Multiframe Shape Editor. 

 

Chapter 4  

This chapter explains most of the tasks you will carry out in designing and installing a 

new section into the sections library. 

 

Chapter 5 

Sections Library Management 

Multiframe Shape Editor is also used to manage the content of Multiframe Section 

Libraries. This chapter describes how to edit the data in the library, how to add new 

sections and new groups of sections. 

 

Chapter 6 

Multiframe Shape Editor Reference 

Gives an overview of the operations of Multiframe Shape Editor and a summary of the 

commands used.  
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Notation 

The following notation has been adopted within Multiframe Shape Editor. 

Material Properties 

 

Property Description 

E Young's Modulus 

G Shear Modulus 

 Poisson’s ratio 

Fy Yield Stress 

Fu Ultimate Stress 

Dimensions 

 

Property Description 

D Depth 

B Width (or breadth) 

tw Web thickness 

tf Flange thickness 

 

Fillet radius Radius of fillets in the section 

Toe radius Radius of toes in the section 

d1, d2 Minor depth dimensions 

b1, b2 Minor width dimensions  

taper Taper angle 

 

xl Position of left extent of section 

xr Position of right extent of section 

yt Position of top extent of section 

yb Position of bottom extent of section 

Section Properties – Japan/International 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

xc, yc Position of centroid 

xs, ys Position of shear centre 

Ix Moment of inertia about x axis 

Iy Moment of inertia about y axis 

J Torsion constant 

Iw Warping constant 

Zxt Elastic Modulus about x axis at top of section 

Zxb Elastic Modulus about x axis at bottom of section 

Zyl Elastic Modulus about y axis at left of section 

Zyr Elastic Modulus about y axis at right of section 

rx Radius of gyration about x axis 

ry Radius of gyration about y axis 
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Property Description 

Ixc Mmt of inertia about x axis through centroid 

Iyc Mmt of inertia about y axis through centroid 

Ixyc Product of inertia about centroid 

I1 Mmt of inertia about major axis through centroid 

I2 Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asx Shear area for shear in the minor (x) direction 

Asy Shear area for shear in the major (y) direction 

Z1t Elastic Modulus about principal axis at top of 

section 

Z1b Elastic Modulus about principal axis at bottom of 

section 

Z2l Elastic Modulus about minor principal axis at left 

of section 

Z2r Elastic Modulus about minor principal axis at right 

of section 

xp, yp Position of plastic axis 

Sx Plastic Modulus about x-axis 

Sy Plastic Modulus about y-axis 

S1 Plastic Modulus about major principal axis 

S2 Plastic Modulus about minor principal axis 

  

Section Properties - United States 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

xc, yc Position of centroid 

xs, ys Position of shear centre 

Ix Moment of inertia about x axis 

Iy Moment of inertia about y axis 

J Torsion constant 

Cw Warping constant 

Sxt Elastic Modulus about x axis at top of section 

Sxb Elastic Modulus about x axis at bottom of section 

Syl Elastic Modulus about y axis at left of section 

Syr Elastic Modulus about y axis at right of section 

rx Radius of gyration about x axis 

ry Radius of gyration about y axis 

Ixc Mmt of inertia about x axis through centroid 

Iyc Mmt of inertia about y axis through centroid 

Ixyc Product of inertia about centroid 

I1 Mmt of inertia about major axis through centroid 

I2 Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asx Shear area for shear in the minor (x) direction 

Asy Shear area for shear in the major (y) direction 

S1t Elastic Modulus about principal axis at top of 

section 
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Property Description 

S1b Elastic Modulus about principal axis at bottom of 

section 

S2l Elastic Modulus about minor principal axis at left 

of section 

S2r Elastic Modulus about minor principal axis at right 

of section 

xp, yp Position of plastic axis 

Zx Plastic Modulus about y axis 

Zx Plastic Modulus about zaxis 

Z1 Plastic Modulus about major principal axis 

Z2 Plastic Modulus about minor principal axis 

R0 Polar radius of gyration about shear centre 

(See AISC LRFD Appendix E) 

H Flexural Constant 

(See AISC LRFD Appendix E) 

Section Properties – Europe (Eurocode) 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

yc, zc Position of centroid 

ys, zs Position of shear centre 

Iy Moment of inertia about x axis 

Iz Moment of inertia about y axis 

It Torsion constant 

Cw Warping constant 

Wel.y.1 Elastic Modulus about y axis at top of section 

Wel.y.1 Elastic Modulus about y axis at bottom of section 

Wel.z.2 Elastic Modulus about z axis at left of section 

Wel.z.2 Elastic Modulus about z axis at right of section 

Iy Radius of gyration about y axis 

Iz Radius of gyration about z axis 

Iyc Mmt of inertia about y axis through centroid 

Izc Mmt of inertia about z axis through centroid 

Iyzc Product of inertia about centroid 

Iu Mmt of inertia about major axis through centroid 

Iv Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asy Shear area for shear in the minor (y) direction 

Asz Shear area for shear in the major (z) direction 

Wel.u.1 Elastic Modulus about principal axis at top of 

section 

Wel.u.2 Elastic Modulus about principal axis at bottom of 

section 

Wel.v.1 Elastic Modulus about minor principal axis at left 

of section 

Wel.v.2 Elastic Modulus about minor principal axis at right 

of section 

yp, zp Position of plastic axis 
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Property Description 

Wpl.y Plastic Modulus about y-axis 

Wpl.z Plastic Modulus about z-axis 
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Chapter 1  
Introduction 

This chapter provides a brief introduction to Multiframe Shape Editor. 

 About Multiframe Shape Editor 

 Error! Reference source not found. 

 Section Property Calculations 

 Interaction with Multiframe 

 

About Multiframe Shape Editor 

Multiframe Shape Editor may be used to calculate the sectional properties of arbitrary 

structural shapes and install them as sections in the Multiframe Sections Library.  

Section Property Calculations 

It is important that you understand the techniques used by Multiframe Shape Editor to 

calculate section properties. Before using the program, you should read the remainder of 

this chapter to ensure you understand how to model sections to get accurate results. 

Overlapping Shapes 

If you create a section that is composed of a number of shapes you should be aware of 

how Multiframe Shape Editor treats these for calculation purposes. 

 

First, don't partially overlap shapes, the properties won't be computed correctly. You may 

have a shape completely inside another or completely separate but they may not partially 

overlap. 

 

Exact and Approximate properties 

Most section properties computed by Multiframe Shape Editor are exact and are based 

upon the theory of plane areas. However, some properties cannot easily be computed for 

arbitrary section shapes and so it is necessary for Multiframe Shape Editor to identify a 

shape as one of the standard shapes. The following properties will only be determined 

correctly when Multiframe Shape Editor has identified a section as a standard section 

shape. 
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 Shear Areas 

 Torsion Constant and Torsion Modulus 

 Warping Constant 

 Shear Centre and derived properties 

 

To indicate that the J and Iw values are approximate, SectionMaker displays a * 

character after the variable in the Properties window (J* and Iw*). 

 

If you use the Advanced calculations option from the Shape menu, SectionMaker uses a 

finite element analysis of the cross section to calculate an accurate value for J and Iw. 

When this method has been used, the * character will not be displayed to indicate that the 

value shown is accurate.(J and Iw) 

 

When installing a section of unknown shape the Advanced Property Calculations option 

can be used to accurately compute the torsion constant, warping constant and the location 

of the shear centre. 

 

IMPORTANT: Non-standard shapes 

When Multiframe Shape Editor does not identify the section drawn within 

the shape window as one of its standard section shapes some properties will 

not be computed correctly. When installing a section of unknown shape to 

the sections library the user should review the value of the following 

properties to ensure their accuracy. 

Shear Areas – Approximated as gross area of section. 

Torsion constant – Approximated as sum of torsion constant of shapes. 

Warping Constant – Set to Zero. 

Shear Centre – Assumed to be coincident with centroid. 

H, r0 – LRFD properties based upon shear centre. 

 

Note 

The advanced calculations option can be used to accurately compute the 

torsion constant, warping constant and the location of the shear centre. 

Composite Sections 

For a section composed of more than one material, Multiframe Shape Editor computes 

modulus weighted section properties as described in Pilkey. In determining the elastic 

properties of a section, the modulus weighted concept scales the properties of the 

individual shapes forming the section by the ratio of the elastic modulus of the shape and 

the elastic modulus of a reference material. 
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For example, a reinforced concrete section, Multiframe Shape Editor would default to 

using concrete as the reference material. In determining the overall properties of the 

section, the properties of the steel shapes would be factored by the modular ratio Es/Ec 

where Es is the Young's Modulus of the steel and Ec is the Young's Modulus of the 

concrete. 

 

The calculation of the plastic properties, such as the plastic modulus, for a composite 

section uses a similar concept. Instead of scaling the properties of shapes by the ratio of 

the elastic moduli, the properties are factored by the ratio of the yield strength of the 

shape to the yield strength of the reference material. 

Interaction with Multiframe 

When constructing a frame in Multiframe it is often necessary to use Multiframe Shape 

Editor to design the sections shapes used within the model. There are a number of ways 

to share or transfer data from Multiframe Shape Editor for use in Multiframe. 

Sharing a library 

Multiframe Shape Editor and Multiframe can open the same sections library 

simultaneously. As the sections library is a file, care must be exercised to avoid 

overwriting changes made in one program with changes made in the other. The simplest 

way to avoid this is to always modify the sections library using Multiframe Shape Editor 

and reload the updated library into Multiframe in order to use the new sections. 

IMPORTANT: Using Multiframe Shape Editor with Multiframe 

Be careful when using Multiframe Shape Editor with the Multiframe 

program open in the background. If you have both Multiframe Shape Editor 

and Multiframe open at the same time, any changes you make to the Section 

Library with Multiframe Shape Editor will not be reflected in the sections 

available to Multiframe until they are saved and re-loaded into Multiframe. 

To make any changes to the library available within Multiframe you must  

 Save the section library from Multiframe Shape Editor using the Save command 

 Switch to Multiframe 

 Use Open Library->Sections Library from the File menu to re-load the saved library 

into Multiframe 

Note that it is not necessary to close the model open within Multiframe when opening the 

sections library. Multiframe will automatically locate sections used within the model 

within the updated library. 

The Frame Group 

In Multiframe, an extra group of sections is added to the end of the sections library. This 

group, named the “Frame” group, is stored as part of the Multiframe model instead of 

within the sections library. As this group is not accessible from Multiframe Shape Editor, 

the only way of adding a section to this group is via the Add Section command within 

Multiframe. It is then necessary to copy the property data from Multiframe Shape Editor 

into the Add Section dialog open within Multiframe. 
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To facilitate this and enable the section property data to be readily exchanged, the 

Properties Window in Multiframe Shape Editor contains a table listing the properties of 

the Frame group. These properties can be copied directly from here and inserted into the 

table within the Add Section dialog. Care should be taken to ensure the same units are in 

use within both programs. 
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Chapter 2  
Learning Multiframe Shape Editor 

This chapter provides a tutorial to help you learn the basics of working with Multiframe 

Shape Editor. 

 Starting Multiframe Shape Editor 

 Drawing a Shape 

 Adding the Section to the Sections Library 

 

Starting Multiframe Shape Editor 

Start up the Multiframe Shape Editor program and then use the Drawing Layout 

command from the Window menu to lay out three windows on the screen titled Shape, 

Properties and Data. This will provide you with the most convenient window 

arrangement for creating new sections. 

Drawing a Shape 

To introduce you to the concepts and techniques you will use in Multiframe Shape 

Editor, this chapter will describe the creation of a structural section step by step. The 

section you will draw is shown below.  

 

 

First, you will draw the section to scale, inside the Shape window. Make sure that your 

units are set up correctly by using the Units command from the View menu. This 

example is carried out in American units; you can use other units if you wish. 

 

It is necessary to set up the sizes for drawing in the Shape window.  

 Choose Size… from the View menu.  

A dialog box will appear with four fields in it specifying the maximum dimensions of the 

section. 
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 Type 4 for the maximum x coordinate and then press the Tab key to move 

to the second field 

 Type in -4 for the minimum x coordinate and then use the Tab key to 

move to the next two fields entering 6 and -6 for the maximum and 

minimum y coordinates.  

 Click the OK button when you have finished entering the values.  

If you make a mistake entering the numbers, you can use the backspace key to delete the 

character just to the left of the blinking cursor and you can use the Tab key to move from 

one field to the next. 

Placing a Shape 

To create the I-beam that forms the basis of the section, you can use Multiframe Shape 

Editor's commands for automatically generating a common structural shape. 

 

A note on terminology: 

Multiframe Shape Editor uses the term "section" to refer to a structural cross sectional 

shape and its associated sectional properties that is stored in the Multiframe Sections 

Library. The term "shape" is used to refer to a geometric shape such as a polygon, circle 

or rectangle or an assemblage of these shapes. A section is made up of one or more 

shapes. 

 Choose Place Shape from the Shape menu.  

A dialog will appear with a picture of an I shape and fields where you can enter the 

dimensions of the shape. 

 

 Choose Steel for the material type 

 Type in 12 for the depth then enter 8 for the width, 0.5 for the flange 

thickness and 0.25 for the web thickness. 

 Click the OK button 
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The I shape will be drawn on the screen centred in the Shape window. The I shape is 

generated as an assembly of three rectangles. The corners of the rectangles will be 

highlighted with small black boxes (called handles) to indicate that the rectangles are 

selected. 

Note:  

The properties for the section are displayed in the Properties window. 

Placing a Section 

To place the channel on the top of the I shape, you can take an existing channel from the 

Sections Library. 

 Choose Place Section… from the Shape menu 

A dialog will appear allowing you to select a section from the Sections Library 

 

 Click on the C name in the list of groups 

The names of the channel sections stored in this group will be displayed in the list on the 

right. 

 Click on the name C10x20 to select this section 

 Click the OK button 

The dimensions of the section will be taken from the library and the section will be 

drawn in the centre of the Shape window. This C shape will be made up of three 

rectangles modelling the web and two flanges and two shapes modelling the fillets 

between the web and flange. The corners of the placed section will be highlighted to 

indicate that the group of shapes is selected. 

Rotating the Shape 

Before you can place this C shape on top of the I shape, you need to rotate it by 90 

degrees 

 Choose Rotate … from the Geometry menu 

A dialog will appear allowing you to enter the number of degrees to rotate the shape. The 

angle of rotation is measured in degrees with positive being anti-clockwise  
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 Type in -90 for the angle of rotation 

 Click the OK button 

The C shape will be rotated so that it is oriented ready to move on to the top of the I 

shape. 

Dragging the Shape 

You can move shapes in Multiframe Shape Editor by dragging them with the mouse. 

 

To drag the C shape 

 Point anywhere inside the C shape but away from the black boxes, which 

show that it is selected. 

 Press and hold down the mouse button. 

 

 Drag the shape until its sits evenly on top of the I shape 



Chapter 2 - Learning Section Maker 

Page 15  

 

 Release the mouse button. 

As you drag the shape it will be redrawn at its new position 

 

At every change that you make to the section, the new section properties will be 

automatically recalculated and updated in the Properties window. 

Drawing a Shape 

Now you can draw the additional plate on the bottom flange of the section. 

To make it easier for you to draw the frame, you can use Multiframe Shape Editor's Grid 

option to make drawing automatically align to a grid with regular spacing. 

 Choose Grid… from the View menu.  

A dialog box will appear with values for the x (horizontal) and y (vertical) spacing of the 

grid. 

 

 Type 0.5 for the x spacing, use the Tab key to move to the y spacing and 

type 0.5 for it also 

 Click on the Visible check box to display the grid in the window.  

 Click on the Snap check box to make subsequent drawing align with the 

grid.  

This will also turn on the Visible button to make the grid visible in the Shape window.  

 Click on the OK button to confirm your settings. 
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Now move the pointer inside the Shape window and notice that as you move the mouse, 

the coordinates of the pointer are shown at the bottom left hand corner of the window. 

The coordinates are shown in the same units as Deflection in the Units dialog. The 

coordinates will automatically align to the nearest point on the grid. You can now begin 

to draw the shape to scale in the Shape window. 

 Click on the Rectangle tool to select it 

 

 Press the mouse button at the bottom left corner of the I shape 

 Drag down and to the right to draw the bottom plate 

 

 Release the mouse button when the plate is the correct size, i.e. when the 

coordinates read x=4, y=-6.5 

Notice that the properties for the rectangle displayed in the Data window are negative. 

This is because as yet no material types have been assigned to that shape. Any shape, 

which does not have a material type, is assumed to be a hole and is subtracted from the 

property calculations. Next we will set the material for the rectangle. 

Selecting Materials 

In order to compute the deflections in a structure, Multiframe needs to know the Young's 

Modulus and Shear Modulus for the materials in the section. You can choose what type 

of material each shape in the section is made of by choosing from the range of materials 

properties stored in the Sections Library. 

 

The rectangle you have just drawn should be selected. If not, select it by clicking on it. 

 Choose Select Material from the Shape menu 

A dialog box will appear with a list of the materials in the library. 
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 Click on the name of the group containing the materials in the left hand 

list  

 Click on the name Steel in the list of the right hand side. 

 Click the OK button 

This will define the bottom plate to take its material properties from those for steel stored 

in the library. The shapes will be drawn filled with the colour depending on shape type 

and patterned for their material, solid for steel in this case. 

Aligning to the Centroid 

Before you install your section in the Sections Library you will probably want to align 

the Centroid of its area with the x-y axes so that all properties will be calculated relative 

to the Centroid. 

 

To align the Centroid of the section with the axes 

 Choose Select -> All from the Select sub-menu under the Edit menu 

This will select all the shapes in the section 

 Choose Align To Centroid->Centroid from the Geometry menu 

All of the selected shapes in the Shape window will be moved so that their common 

Centroid is aligned with the x-y axes. 

 Choose Size To Fit from the View menu 

This will make the whole section visible in the window. 

 

Once the shapes move, the properties will be automatically recalculated and displayed in 

the Properties window. You can check that the section is aligned with the axes by 

verifying that the coordinates of its Centroid (xc, yc) are 0.000,0.000. 

Adding the Section to the Sections Library 

Now that you have created the section you want, you can install it in the Sections 

Library.  

 

If Multiframe Shape Editor finds a library named "SectionsLibrary.slb" in the same 

directory as Multiframe Shape Editor, it will automatically open it on start-up.  

 

If you have installed Multiframe Shape Editor correctly, this library should automatically 

have been opened. 
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 Choose Add to Library… from the Shape menu 

A dialog box will appear with the properties of the section, a list of groups and a list of 

symbols indicating the shape of the section. The section's properties displayed in the 

table will be the same as those calculated in the Data window. If you wish you can 

change them before installing the section in the library. In this case we will leave them 

set to the calculated values. 

 

 Type in a name for the section 

 Select the name of the group where you would like to store the section eg 

Custom1 

Since it is not one of the standard shapes, in this case we will leave the shape set to the 

“Unknown Section” setting. 

 Click the OK button 

Viewing Sections 

You can verify that your section has been correctly installed into the library by checking 

its properties in the Tables in the Sections Window. 

 Choose Sections from the Window menu 

The Sections Window will be brought to the front. 

 Click on the tabs at the bottom of the Libraries Window 

Tables of sections are displayed in this window. Each group is displayed in a separate 

tab. Click on the tab with the name of the group to which the section was added  at the 

bottom of the screen to display the sections 

 

To choose which group to display 

 Click on the tab with the name of the group to which the section was 

added. 

The table of sections for that group will be displayed in the Sections Window. You can 

check the name and properties are correctly stored by scrolling through the table to view 

the section's name and properties. 
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Saving your Work 

You can save the changes you have made to the Section Library by using the Save 

command from the File menu. 

 Choose Save Library from the File menu 

The Sections Library will be saved to disk complete with the section you added to it. 

Printing your work 

You can print the shape you have created 

 Bring the Shape window to the front 

 Choose Page Setup from the File menu and choose your paper size 

 Choose Print Window from the File menu 

 Click the Print button to print out the shape 

This will print the shape on your printer. You can bring the Properties window to the 

front and use Print Window to print the properties table for the shape. 
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Chapter 3  
Using Multiframe Shape Editor 

If you have read Chapter 1 and 2, you are now familiar with some of the features of 

creating a section using Multiframe Shape Editor. The next three chapters describe all the 

commands available within Multiframe Shape Editor. They present a series of step-by-

step instructions of the tasks covered in Chapter 2 as well as other procedures you will 

want to know about. 

 

This chapter describes the basics of how to interact with the various windows used 

within Multiframe Shape Editor. 

 Summary of Mouse Techniques 

 Summary of Keyboard Techniques 

 Resizable Dialogs 

 Working  

 Working in Table 

 Printing 

 

Techniques 

This section describes several techniques you can use in Multiframe Shape Editor.  

 Summary of Mouse Techniques 

 Summary of Keyboard Techniques 

 Resizable Dialogs  

 

See also:  

 Working in Shapes Window 

 Working in Table Windows 

 

Summary of Mouse Techniques 

You will use the following mouse techniques to do just about all of the tasks in this 

chapter. 

 Click to select or activate something 

 Press to cause a continuous action 

 Drag to select, choose from a menu or move something 

 Shift-Click to select or to extend or reduce a selection 

 Double-Click to choose from a dialog box 

 

To Click 

Position the pointer on what you want to select or activate 

Press and quickly release the mouse button 

To Press 

Position the pointer on something 

Without moving the mouse, press and hold down the mouse button. 
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The effects of pressing continue as long as the mouse button is held down. 

Pressing on a scroll arrow results in continuous scrolling. Pressing on a menu title 

pulls down the menu and keeps it down until you release the mouse button. 

To Drag 

Position the pointer on something 

Press and hold down the mouse button and move the mouse 

Release the mouse button. 

To Shift-Click or Ctrl-Click 

Shift-click is used to extend or reduce the selection. In the Shape Window this will 

select or deselect the shapes. Hold down the shift key and click on the shape you 

wish to add to the selection or which you wish to remove from the selection 

To Double-Click 

Double click is used as a short cut equivalent to opening the properties dialog.. 

In the Shape Window, point to the shape you wish to edit and then click twice 

quickly in succession without moving the mouse. 

To Scroll 

In the windows with tabular data, the mouse wheel can be used to scroll the view 

up or down.  

To Zoom 

In the Shape Windows the mouse wheel can be used to dynamically zoom the 

view within the Window.  

To scroll a table one line up or down 

Click the appropriate arrow at the top or bottom of the vertical scroll bar 

To scroll a table one column left or right 

Click the appropriate arrow at the left or right of the horizontal scroll bar 

To scroll a table continuously line by line 

Press the appropriate arrow at the top or bottom of the vertical scroll bar 

To scroll a table continuously column by column 

Press the appropriate arrow at the left or right of the horizontal scroll bar 

To scroll up or down by the windowful 

Click in the grey area above or below the scroll box in the vertical scroll bar. 

To scroll left or right by the windowful 

Click in the grey area to the left or right of the scroll box in the horizontal scroll 

bar. 

To go to the beginning or the end of the table 

Drag the scroll box to the top or the bottom of the vertical scroll bar. 

To go to the left or right hand edge of the table 

Drag the scroll box to the left or the right of the horizontal scroll bar. 

To go to any part of a large table 

Drag the scroll box to a place in the scroll bar that's about equivalent to where the 

data is in the table. 

Summary of Keyboard Techniques 

This section describes keyboard techniques you can use as shortcuts when using 

Multiframe Shape Editor. 
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Tab 

You can use the Tab key to move horizontally within a table or to move from one 

field in a dialog to the next. 

Enter 

The Enter key can be used to confirm the entry of numbers into a table and is the 

same as clicking OK in a dialog. 

Arrow Keys  

The keys may be used to move the selection in their respective 

directions in the Data or Result tables. 

Delete (Or Backspace) 

The Delete key may be used to delete the current selection. If nothing is selected 

and you are typing text or numbers, it will delete the character to the left of the 

blinking cursor. In the Shape window it will delete the currently selected shapes. 

Ctrl 

The Ctrl key may be held down while typing another key to choose a command 

from a menu without using the mouse. Menu items, which have a key to the right 

of the name, may be chosen in this way. For example, to choose Undo from the 

Edit Menu you could hold down the Ctrl key and type Z. 

Shift 

You can hold down the shift key while clicking on something to add it to the 

current selection or remove it from the selection if it is already selected. 

 

Holding down the shift while drawing a member, dragging a member or dragging 

a joint will constrain the movement to be horizontal, vertical or at a 45 degree 

angle. 

 

Holding down the shift key while starting up the application will reset the 

application (window sizes, toolbars etc) back to the default settings. 

Scrolling 

Scrolling is a technique for moving a table of data up, down, left or right in a 

window so that you can bring any part of the table into view. 

Resizable Dialogs 

Some of the dialogs in Multiframe Shape Editor can be resized to provide more room for 

some controls within the dialog. Generally dialogs with tables or list boxes will be 

resizable. A small icon in the bottom right hand corner of the dialog (as shown below) 

identifies dialogs that can be resized. 
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Working in Shapes Window 

The Shape Window is the only graphical window in Multiframe Shape Editor. This 

section described the commands used to control what is displayed is the window and 

how that is displayed.  

Zoom 

Zoom allows you to increase the size of the drawing in the Shape window.  

 Choose Zoom from the View Menu 

 Move the pointer to the top left hand corner of the area you wish to view 

in close detail 

 Drag a rectangle down and to the right, which encloses the area of 

interest, and release the mouse button 

The window's contents will be re-drawn to display the part of the shape contained in the 

rectangle you have drawn. 

 

The mouse wheel may also be used to dynamically zoom the view within the Shape 

Window. By moving the mouse wheel, the view will move in or out. 

Pan  

Pan allows you to shift the display of the shape within the window upwards, downwards, 

to the left or right.  

 Choose Pan from the View Menu. 

The cursor will change to a hand. 

 Press inside the window and hold down the mouse button 

 Drag the drawing to its new location.  

 Release the mouse button to re-draw the contents of the window.  

If not enough memory is available to move the image, a rectangle the size of the window 

will be moved around as you move the mouse. 
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The middle mouse button may also be used to dynamically pan the view within the 

Shape Window. To pan the view, depress with middle mouse button within the view and 

drag the mouse to pan the view. When the desired view is obtain simply release the 

mouse button to stop panning. 

Shrinking the View 

Shrink allows you to decrease the size of the drawing on the screen. 

 Choose Shrink from the View Menu 

The drawing will shrink down to 50% of its current size and be re-drawn. If the Shift key 

is held down when the Shrink command is selected the drawing will shrink by only 20%. 

Sizing To Fit 

Size To Fit automatically resizes the drawing in the Shape window so that the section 

just fits inside the window in the current view. This is most useful after you have been 

zooming, panning or shrinking as it returns you to a viewing scale that just fits the 

section inside the window. 

Working in Table Windows 

There are 3 windows in Multiframe Shape Editor that display tabular information. The 

data for the library is displayed in tables in the Sections  and Materials Window. 

Information about the geometry of the section drawn in the Shape Window is displayed 

in the Data window while the properties for this section are displayed in the Properties 

window.  

 

Use the scroll bars on the side or on the bottom of the table to scroll through the table to 

view rows or columns that are not visible.  

 

In this section:  

 Column Widths 

 Text Styles 

 Number Styles 

 Changing Numbers or Name 

 Selecting Numbers in Tables 

 Copying and Pasting Numbers 

 Copying and Pasting Sections 

 

Column Widths 

If you want to change the width of a column in the table 

 Press on the line dividing the column's title from the next column 

 Drag the column divider to make the column wider 

 Release the mouse button 

Text Styles 

If you wish you can change the font and text size used to display the numbers in the table 

by using the Font command from the View menu.  
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To change the font and/or size of the text in a table 

 Choose Font from the View menu 

 

 Click on the name of the font you require 

 Click on a font size or type in a size 

 Click the OK button 

Number Styles 

You can also choose what numeric format to use for displaying the numbers by using the 

Numbers command from the View menu. 

 

To change the number of decimal places or the decimal format of the numbers in a table 

 Choose Numbers from the View menu 

 

 Choose Decimal or Scientific notation 

 Type in the number of decimal places you require 

 Click the OK button 

Changing Numbers or Name 

To change a number or name in a table 

 Click on the name or number to be changed 

 Type in a new value 
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 Press the Enter key 

Selecting Numbers in Tables 

You can also copy and paste data in tables. The copy or paste will act on the current 

selection in the window. You can select a number or a range of numbers, a row or range 

of rows, or a column or range of columns. 

 

To select a number 

 Click on the number 

To select a range of numbers 

 Press on the number at the top left of the range to be selected 

 Drag the mouse until the last number is selected 

 Release the mouse button. 

If the last number you want to select is outside the window, drag the mouse outside the 

window and the table will automatically scroll to bring the number into view. 

 

To select a row 

 Click on the number at the left of the row 

To select a range of rows 

 Press in the number at the left of the first row 

 Drag down until the last row is selected 

 Release the mouse button 

If the last row is outside the window, drag outside the window and the table will scroll to 

bring the row into view. 

 

To select a column 

 Click on the title at the top of the column 

To select a range of columns 

 Press in the title of the left hand column in the range 

 Drag the mouse across until the right hand column is selected 

 Release the mouse button 

If the right hand column is outside the window, drag outside the window and the table 

will scroll to bring the column into view. 

 

To select the whole table 

 Click in the box at the top left corner of the table 

Copying and Pasting Numbers 

To copy or paste numbers in Multiframe Shape Editor, first select the numbers then 

choose the command you require. 
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To copy a number or range of numbers 

 Select the numbers to be copied 

 Choose Copy from the Edit menu 

The numbers will be placed on the clipboard. Each row of numbers will have a return 

character at the end and the numbers in the row will be separated by a Tab character. 

You can transfer data copied from Multiframe Shape Editor into other programs or you 

can paste them into other tables in Multiframe Shape Editor. 

 

To paste the numbers on the clipboard into a table 

 Select the numbers in the table that will be replaced by the numbers on 

the clipboard 

 Choose Paste from the Edit menu 

Copying and Pasting Sections 

The table in the Sections Window can be used to copy sections between groups or even 

into the same group.  

 

To copy a section or a number of sections to another group  

 Select the entire row of the sections to be copied 

 Choose Copy from the Edit menu 

 Select a new current group from the Group toolbar or by using the Select 

Group… command in the Library menu. 

 Choose Paste Special from the Edit menu 

The copied sections will be appended to the end of the current group. Multiframe Shape 

Editor will maker automatically map the section properties of the sections to the match 

the fields of the group into which they have been pasted. Caution should be exercised 

when copying sections between groups to ensure that section property data is not lost and 

that the data is available for all the fields in the destination group. 

 

Printing 

The contents of any of the windows in Multiframe Shape Editor can be printed and you 

can also print out a complete table of every section in the Sections Library. When 

printing tables they will be printed over multiple pages as there will generally not be 

enough room on one page for all the rows and columns in the table. 

Setting up the Printer 

Before printing you should set up the printer with the page size and orientation that you 

wish to use. 

 

To Set up the Printer 

 Choose Page Setup from the File menu 
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The standard page setup dialog will appear allowing you to enter the appropriate 

information. You may also enter text to be displayed at the head and foot of each page 

and set the width of the margins on the page. 

Printing a Window 

To print the contents of the front window 

 Choose Print Window from the File menu 

The standard print preview dialog will appear. Click the Print button to print out the 

contents of the front window. 

Printing the Library 

To print the entire contents of the Sections Library 

 Choose Print Library from the File menu 

The standard print preview dialog will appear. Click the Print button to print out the 

library. The tables of sections for each group in the library will be printed. If there are 

more rows and columns than will fit one a page the printout will be spread over a number 

of pages.
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Chapter 4  
Working with Shapes 

Creating a section with Multiframe Shape Editor involves defining the geometry of the 

shapes by drawing in the Shape window. You can also use the pre-defined generation 

aids to automatically place common structural shapes into the section. 

 

In this section: 

 Drawing a Shape 

 Moving a Shape 

 Copying and Pasting Shapes 

 Resizing a Shape 

 Deleting a Shape 

 Duplicating a Shape 

 Rotating a Shape 

 Rescaling a Shape 

 Reflecting Shapes 

 Making shapes equal in size 

 Aligning Shapes 

 Stacking Shapes 

 Converting Shapes to Polygons 

 Merging Polygons 

 Shape Properties 

 Grouping Shapes 

 Aligning to Centroid 

 Generating Standard Shapes 

 Using Existing Sections 

 Importing a Shape 

 Setting Materials 

 Advanced Property Calculations 

 Viewing Properties 

 Validating the Shape 

 Adding a Section to the Library 

 Symbols 

 Legend 

Drawing a Shape  

The shapes, which make up a section, may be drawn directly in the Shape window.  
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The scale at which this drawing is carried out may be specified by choosing the Size… 

command from the View Menu. The maximum and minimum coordinates to be used in 

the x and y directions may be entered and Multiframe Shape Editor will scale these 

coordinates to the current size of the Shape window. All movements in the window are 

accompanied by a display of the current pointer coordinates in the lower left hand corner 

of the window. All coordinates are shown in the current units. You can change units 

using the Units command from the View menu. 

Setting the Size 

Before starting drawing, you will need to set up the drawing area for the size of section 

you intend working with. To do this 

 Choose Size…from the View Menu… 

A dialog box will appear with the dimensions of the section 

 

 Enter the maximum and minimum coordinates you wish to use in each 

direction 

 Click the OK button 

Using the Grid 

Multiframe Shape Editor has a built-in facility to allow you to have your drawing 

automatically align with an evenly spaced grid. You can control the spacing, display and 

use of this grid with the Grid command from the View Menu. 

 Choose Grid… from the View Menu 

 Type in values for the x and y spacing of the grid 

 Click on the On button if you want drawing to align to the grid 

This will switch on the Visible button to make the grid to visible. 

 Click the OK button 

 

If you want to have the shapes automatically align with the grid but don't want to see the 

grid, simply click on the Invisible button before clicking OK. Similarly you can click on 

the Visible button to have the grid displayed as a visual guide but click on the Off button 

to disable the automatic alignment with the grid. 
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All drawing and dragging in the Shape window will align to the grid while the grid is 

switched on. 

Drawing Tools 

Multiframe Shape Editor has six drawing tools for drawing different types of shapes. A 

change in background colour surrounding the tool’s icon indicates the drawing tool 

which is currently active. If the Arrow tool is selected this allows you to select, move and 

resize shapes with the mouse. 

 

Before you start drawing a new section, if there are any shapes in the Shape window 

Choose Select All from the Select sub-menu under the Edit menu and press the Delete 

key. This will remove the existing shapes. 

Rectangle Tool 

The rectangle tool can be used for drawing solid rectangular shapes or for drawing 

rectangular holes in a section. 

 

To draw a rectangle 

 Click on the rectangle tool to select it 

 

 Press at the position of the top left corner of the rectangle you wish to 

draw 

 Drag down to the right until the mouse points to the bottom right corner 

of your rectangle 

 

 Release the mouse button 

If you have the Grid turned on then the corners of the rectangle will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 
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Hollow Rectangle Tool 

The hollow rectangle tool can be used for drawing hollow rectangular shapes 

(rectangular or square structural tubing). 

 

To draw a hollow rectangle 

 Click on the hollow rectangle tool to select it 

 

 Press at the position of the top left corner of the rectangle you wish to 

draw 

 Drag down to the right until the mouse points to the bottom right corner 

of your rectangle 

If you have the Grid turned on then the corners of the rectangle will align to the grid.  

 

 Release the mouse button 

When you release the mouse button a dialog will appear allowing you to enter the wall 

thicknesses of the shape you have drawn 

 

 Type in values for the web and flange thicknesses 

 Click the OK button 
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The new shape will be immediately added to the list of shapes displayed in the Data 

window. 

Circle Tool 

The circle tool can be used for drawing solid circular shapes or for drawing circular holes 

in a section. 

 

To draw a circle 

 Click on the circle tool to select it 

 

 Press at the position of the centre of the circle you wish to draw 

 Drag down outwards from the centre until the mouse points to the radius 

you require 

If you have the Grid turned on then the centre and radius of the circle will align to the 

grid. 

 

 Release the mouse button 

The new shape will be immediately added to the list of shapes displayed in the Data 

window. 

Tube Tool 

The tube tool can be used for drawing hollow circular shapes or tubes. 

 

To draw a tube 
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 Click on the tube tool to select it 

 

 Press at the position of the centre of the tube you wish to draw 

 Drag down outwards from the centre until the mouse points to the radius 

you require 

If you have the Grid turned on then the centre of the circle and the position of the circle 

will align to the grid.  

 

 Release the mouse button 

A dialog will appear allowing you to enter a wall thickness for the tube. 

 

 Type in a value for the wall thickness 

 Click the OK button 

 

The new shape will be immediately added to the list of shapes displayed in the Data 

window. 
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Polygon Tool 

The polygon tool can be used for drawing solid polygonal shapes or for drawing 

polygonal holes in a section. Note that the calculation of sections properties for a 

polygon will be accurate for all properties except for the torsion constant J. For convex 

polygons the calculation of J will be a reasonable approximation however for any 

polygon with one or more re-entrant corners the calculation of J can not be relied upon. 

 

To draw a polygon 

 Click on the polygon tool to select it 

 

 Click at the location of the first vertex of the polygon 

The first side of the polygon will be drawn as you move the mouse 

 Click at the location of each of the other vertices of the polygon 

 Double click at the location of the last vertex to close the polygon or … 

 Press Enter to close the polygon or … 

 Click close to the first vertex to close the polygon 

 

If you have the Grid turned on then the vertices of the polygon will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 

Open Polygon Tool 

The open polygon tool can be used for drawing polygonal shapes made of thin material. 

Thin means the thickness of the material is very small compared with the size of the 

shape. This is most useful for modelling structural shapes made from cold rolled thin 

steel or aluminium. 

 

To draw an open polygon 

 Click on the open polygon tool to select it 
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 Click at the location of the first vertex of the polygon 

The first side of the polygon will be drawn as you move the mouse 

 Click at the location of each of the other vertices of the polygon 

 Double click at the location of the last vertex to complete the polygon or 

… 

 Press Enter to complete the polygon 

 

If you have the Grid turned on then the vertices of the polygon will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 

Moving a Shape 

You can move a shape by dragging it with the mouse in the Shape window 

 

To move a shape 

 Point anywhere inside the shape 

 Press the mouse button 

 Drag the shape to the new location 

 Release the mouse button 

Holding down the shift key while you drag will constrain the movement to be vertical or 

horizontal. 

Moving a Number of Shapes 

You can move a number of shapes at once by selecting them and dragging them to the 

new location with the mouse. 

 

To select a shape 
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 Click on or in the shape with the mouse 

If you have turned off the display of materials, you must click on the boundary of the 

shape rather than inside it. The shapes handles will be highlighted to indicate that it is 

selected. 

 

To add a shape to the current selection 

 Shift-click on or in the shape  

To move a number of shapes 

 Select the shapes to be moved 

 Press on or inside any one of the selected shapes 

If you have turned off the display of materials, you must click on the boundary of a shape 

rather than inside one 

 Drag the shapes to their new location 

 Release the mouse button 

The shapes will be re-drawn in their new position. 

Moving Shapes Accurately 

You can also move the selected shapes with great accuracy by using the Move command 

from the Geometry menu. 

 Choose Move from the Geometry menu 

 

 Type in the distance to move in each direction 

 Click the OK button 

Copying and Pasting Shapes 

To copy a shape or shapes in the section 

 Select the shape or shapes to be duplicated 

 Choose Copy from the Edit menu or press Ctrl+v 

The selected shapes are placed on the clipboard. To paste the shapes stored on the 

clipboard into the Shape Window  

 Choose Paste from the Edit menu or press Ctrl+v 

The duplicated shapes inserted into the Shape window slightly offset from there original 

position.  
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Resizing a Shape 

You can change the size of a shape by dragging its handles (the small black boxes which 

appear when it is selected). 

 

To resize a shape 

 Press on the handle closest to the part of the shape you want to move 

 Drag the handle to its new location 

 Release the mouse button 

When you resize a polygon each of the vertices moves independently of the others. 

Deleting a Shape 

To delete a shape or shapes from the section 

 Select the shape or shapes to be deleted 

 Press the Delete key or … 

 Choose Delete from the Edit menu 

Duplicating a Shape 

To duplicate a shape or shapes in the section 

 Select the shape or shapes to be duplicated 

 Choose Duplicate from the Geometry menu 

A dialog box will appear allowing you to specify the spacing of the duplicated shapes 

and how many are to be created 

 

 Type in the spacing in each direction and the number of duplicates 

 Click the OK button 

The duplicated shapes will be drawn and selected in the Shape window. 

Rotating a Shape 

Multiframe Shape Editor allows you to rotate shapes that you have already drawn. 

Shapes are rotated about the axes at an angle measured positive in the anti-clockwise 

direction. Rectangles may only be rotated in increments of 90 degrees. 

 

To rotate a shape or shapes 

 Select the shape or shapes to be rotated 
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 Choose Rotate from the Geometry menu 

A dialog box will appear with a field for the angle of rotation 

 

 Type in the angle of rotation 

 Click the OK button 

The selected shapes will be rotated about the origin of the axes and re-drawn in the 

Shape window 

Rescaling a Shape 

Multiframe Shape Editor allows you to rescale shapes that you have already drawn. The 

coordinates of the shapes are multiplied by a scaling factor in each direction to rescale 

the shape. 

 

To rescale a shape or shapes 

 Select the shape or shapes to be rescaled 

 Choose Rescale from the Geometry menu 

A dialog box will appear with two fields for the scaling factor in each direction 

 

 Type in the x and y scaling factors 

 Click the OK button 

The selected shapes will be rescaled and redrawn in the Shape window 

Reflecting Shapes 

You can reflect shapes in Multiframe Shape Editor by using the Flip Horizontal and Flip 

Vertical commands from the Geometry menu 

 

To reflect the selected shapes about a vertical axis passing through the centre of area of 

the selected shapes 

 Choose Flip Horizontal from the Geometry menu 

 

To reflect the selected shapes about a horizontal axis passing through the centre of area 

of the selected shapes 

 Choose Flip Vertical from the Geometry menu 
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Making shapes equal in size 

You can also change width or height of a shape by making it equal in size to another 

shape. 

 

To make a shape of a number of shapes equal in width 

 Select the shapes to be made equal in size. The first shape selected will be 

the dominant shape to which the others will be resized. 

 Choose Width from the Make Equal Size submenu under the Geometry 

menu, or 

 Click on the Make Equal Width button in the Geometry toolbar 

Each of the shapes will be resized so that they have the same width as the dominant 

shape. A similar procedure can be followed to make shapes equal in height or equal in 

both width and height by using other commands from the Make Equal Size submenu. 

Aligning Shapes 

The Align commands moves the selected shapes so that the edges or centres of the 

shapes align to the edges or centres of the first shape selected. The Align submenu has 

commands for aligning the top, bottom, left and right hand edges of shapes. It also has 

commands to align the centres of shapes by moving the shapes either horizontally or 

vertically.  

 

To align the left-hand side of a number of shapes 

 Select the shapes to be aligned. The first shape selected will be the 

dominant shape to which the others will be aligned. 

 Choose Left from the Align submenu under the Geometry menu, or 

 Click on the Align Left button in the Geometry toolbar 

Each of the shapes will be moved so that left hand side of each shape is aligned to the 

left hand side of the dominant shape. A similar procedure can be followed to align other 

sides of shapes by using other commands from the Align submenu. 

Stacking Shapes 

The Stack commands, which complement the Align commands, move the selected 

shapes so that shapes are arranged from left to right or top to bottom such that adjoining 

edges aligned to one another. By stacking shapes horizontally, the select shapes will be 

moved so that they are arranged from left to right, the right-hand edge of left most shape 

will be aligned to the left-hand edges of the next and so forth. The first select shape will 

remain in its original position and all the other shapes will be arranged around it. 
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To vertically stack a number of shapes 

 Select the shapes to be stacked. The first shape selected will be the 

dominant shape about which the others will be rearranged. 

 Choose Stack Vertically from the Geometry menu, or 

 Click on the Stack Vertically button in the Geometry toolbar 

Each of the shapes will be moved vertically so that top of one shape is aligned to the 

bottom of the adjacent shape. 

Converting Shapes to Polygons 

Shapes other than polygon shapes can be converted to closed polygons using the Convert 

to Polygon command in the Shape menu. While it is not recommended that shapes be 

converted to polygons, it can be useful to do this in a number of situation such as to 

allow shapes to be rotated by arbitrary angles or to generate complex shapes by merging 

over lapping polygon shapes. 

 

To convert a number of shapes into polygons 

 Select the shapes to be converted. 

 Choose Convert to Polygon from the Shape menu. 

Each of the shapes will be converted to a polygon. 

Merging Polygons 

Polygons can be merged together to form complex shapes. Open polygons and closed 

polygons cannot be merged together; they can only be joined to other polygons of the 

same type. Open polygons will be joined to other open polygons only if they have a 

common end point. Closed polygon shapes can be merged with other closed polygons. 

The result may not be a single polygon as the merged shape will take into account which 

polygons are solid and which represent holes in the shape. However, no distinction is 

made between different materials and so any resulting solid polygons will be allocated a 

single material. 

 

To merge a number of polygons 

 Select the polygons to be merged together. 

 Choose Merge Polygon from the Shape menu. 

The selected shapes will be merged together to form a number of other polygons. 

Shape Properties 

The properties of any shape can be modified by double clicking on the shape. This will 

open a property dialog that contains the dimensions and location of the shape. This 

dialog may also be opened by selecting a shape and choosing the Properties menu 

command from the Edit menu or the Properties command from the right-click context 

sensitive menu. 
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This dialog also lets you reposition shapes by specifying the location of an anchor point 

on the shape. This makes it easy to align shapes to other shapes within the section. The 

anchor point you choose is moved to the location you enter in this dialog.. For example, 

if you wanted to move a plate to just sit on top of the top flange of a beam, you would 

double click on the plate, choose the anchor point to be Bottom-Centre and set the x 

coordinate to zero and the y coordinate to the height of the top of the flange of the beam. 

Grouping Shapes 

Multiframe Shape Editor allows you to group together shapes within the Shape View. 

This allows shapes to be manipulated together as a single item. This grouping is 

hierarchical so groups may also be grouped inside other groups. 

 

To group together a number of shapes 

 Select the shapes to be grouped 

 Choose Group from the Geometry menu 

To ungroup a group of shapes 

 Select the shape group 

 Choose Ungroup from the Geometry menu 

 

When placing a section or shape within the Shape View, the basic shapes representing 

the section or shape will automatically be grouped together as a single item. When 

placing a section from a library, the group will store the name of the section and display 

this in the Kind column in the Data table. If, however, the shape is ungrouped, this 

information will be lost. 

Aligning to Centroid 

Most times when you create a section you will want to calculate its properties relative to 

a set of axes at the centroid of its area. The Align To Centroid command moves all of the 

selected shapes so that their common centre of area is aligned with the origin of the axes. 

After using Align To Centroid the coordinates of the centroid of the selected shapes will 

always be x=0,y=0. 

 

To align the centroid of a shape or shapes with the axis origin 

 Select the shape or shapes to be aligned 

 Choose Align To Centroid from the Geometry menu 

 Choose from the sub-menu whether to align one or both axes 

The shapes will be moved as a group to centre their area about the axis origin 
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Generating Standard Shapes 

Rather than having to draw common structural shapes such as I beams, channels and 

angles, Multiframe Shape Editor lets you generate such shapes by typing in a few key 

dimensions. 

 

To generate a standard shape 

 Choose Place Shape from the Shape menu 

A dialog box will appear with a diagram of the shape and its key dimensions 

 

 Choose the type of shape you wish to generate 

 Choose a material for the shape 

 Type in the dimensions of the shape 

 Click the OK button 

The generated shape will be placed in the Shape window centred about the origin of the 

x-y axes. 

Fillets and Toes 

If you enter non-zero values for the fillet and/or toe radii, r1 and r2, these radii will be 

modelled as small polygons in the placed shape. This improves the calculation of section 

properties so that the computed values compare very closely to values published by 

manufacturers. The radii of the fillet and toes are also stored in section property fields r1 

and r2 in the sections library. 
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Using Existing Sections 

If you want to create a section, which is made up from other sections, you can place the 

existing sections using the Place Section command from the Shape menu. You can place 

standard sections from the Sections Library as well as sections you have drawn and 

stored previously. 

 

To place a section 

 Choose Place Section from the Shape menu 

A dialog box will appear allowing you to pick the section you wish to place 

 

 Click on the group and section name of the required section 

 Click the OK button 

The chosen section will be placed in the Shape window. 

Importing a Shape 

If you have a shape in another CAD system you can import it into Multiframe Shape 

Editor by way of a DXF file. 

 Choose Import DXF from the File menu 

The standard file dialog will appear and you can choose the DXF file. 
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Multiframe Shape Editor will extract all the rectangles, circles and polygons from the 

DXF file and place them in the Shape window. If there are lines in the DXF file which 

form a polygonal shape, Multiframe Shape Editor will joint them together at the ends 

during the import process. 

 

Note that Multiframe Shape Editor does not support the import of arcs within polylines 

in DXF files. You should explode the polyline in your CAD system before importing. 

Also make sure to check that the units setting in your cad system matches the units in 

Multiframe Shape Editor’s import dialog. Lastly, ensure that the origin of your 

coordinate system in your CAD system matches the x-y origin in Multiframe Shape 

Editor. 

Setting Materials 

To enable Multiframe to calculate deflections in structures, values for Young's Modulus 

and Shear Modulus need to be stored with sections in the Sections Library. Multiframe 

Shape Editor takes these values from the materials you choose for the various shapes, 

which make up a section. Multiframe Shape Editor allows you to use a number of 

different materials within the one section. Materials are stored in the Sections Library, 

standard steel and concrete data is included and you can add your own custom materials 

to the library. 

 

If you do not assign a material to a shape, Multiframe Shape Editor will assume the 

shape is a hole and will deduct its properties from the overall properties of the section. 

Shapes, which are holes, will have negative properties displayed in the Data window. 

 

When shapes you have drawn lie inside each other, you may find it difficult to see which 

is which, especially when the material patterns are displayed in the shapes. You can 

control the order in which the shapes are displayed by using the commands under the 

Arrange sub-menu under the Geometry menu. 

 

To move the selected shapes to the front of all the others 

 Choose Move To Front from the Arrange menu 

 

To send the select shapes behind all the others 

 Choose Move To Back from the Arrange menu 

 

To move the selected shapes just in front of the ones currently in front of them 

 Choose Move Forwards from the Arrange menu 

 

To move the selected shapes just behind the shapes behind it  

 Choose Move Backwards from the Arrange menu 

Note that shapes can be contained inside other shape e.g. steel bar inside a concrete beam 

or a void inside a beam but shapes cannot overlap partially. See Overlapping Shapes in 

Chapter 4 for more information. 

Setting Material Types 

To set the material type of a shape 

 Select the shape 
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 Choose Material from the Shape menu 

 

 Click on the name of the material you require 

 Click the OK button 

See "Adding a Material" below for information on how to add materials to the library. 

Advanced Property Calculations 

For non standard sections Multiframe Shape Editor uses a finite element technique to 

accurately compute the torsion constant, warping constant and the location of the shear 

centre for the section.   

 

The calculation of section properties using this technique requires the shape to be 

analysed. This is performed by executing the Advanced Calculations command from the 

Analyse Shape submenu in the Shape menu. 

 Choose  Shape | Analyse shape | Advanced calculations  

 Upon executing this command the software will automatically mesh the shape drawn in 

the Shape window and perform a finite element analysis of the section to determine the 

torsion constant, warping constant and the location of the shear centre.  

 

The accuracy of these properties is reflected in the size of the elements in the finite 

element mesh. More accurate results may be obtained by refining the mesh size via the 

Mesh Size command in the Analyse Shape submenu. 

 Choose  Shape | Analyse shape | Mesh size 
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The display of the finite element mesh can be controlled via the Toggle mesh command 

in the Analyse Shape submenu. 

Viewing Properties 

When you draw a shape and specify its material properties, as each change is made the 

sectional properties are automatically recalculated and displayed in the Properties 

window 

 

The last row in most of the tables shown in the Properties Window displays the Standard 

Section shape that Multiframe Shape Editor has determined is displayed in the Shape 

Window. This shape is used as the basis for estimating some of the section properties of 

the sections. See Chapter 4 for further details on how Multiframe Shape Editor computes 

section properties. 

 

If you see properties that are displayed in red it means that the shape drawn in the Shape 

Window is not properly constructed and the section properties have not been computed 

correctly. See the Validating the Shape section that follows this section for the rules 

required to ensure the section properties will be computed correctly. 
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Validating the Shape 

For Multiframe Shape Editor to correctly evaluate the section properties of the shapes 

drawn in the Shape Window it is necessary for the geometry of the shape to satisfy the 

following criteria. 

 

1) A shape cannot be hidden by another shape that is drawn in front of it. If a shape is 

obscured it will be flagged as invalid and ignored when computing the properties of the 

section drawn in the Shape window. 

 

2) A shape can only intersect one other shape. Further, one of these shapes must contain 

the other. 

 

When the shapes drawn in the Shape Window do not meet the above criteria, the values 

of the section properties displayed in the Property Window will be displayed in red. 

Furthermore, any individual shapes that are identified as failing the criteria will be shown 

in red in the Sections table in the Data Window. 

 

Further information about why the section drawn in the Shape Window is invalid can be 

determined using the Validate command. To validate a shape 

 Choose Validate from the Shape menu 

If the section is invalid, one or more messages will be displayed to the user that identify 

the invalid geometry within the section. Furthermore, if any invalid shapes are detected, 

the selection in the Shape Window will be cleared and the invalid shapes will be 

selected. 

 

In general it is only necessary to use the Validate command if the section properties in 

the Properties Window are displayed in red. 

Adding a Section to the Library 

Once you have drawn a section to your satisfaction, you can install it into the Sections 

Library for later use by Multiframe or Multiframe Shape Editor. 

 

To install your section 

 Choose Add to Library… from the Shape menu 

A dialog box will appear which lets you specify where the section will be stored, a field 

for the name of the section, a table with the calculated section properties and a pop-up 

menu to indicate the shape of the section. 
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 Type in a name for the section 

 Choose the name of the group where you want to store the section 

 Choose a shape for the section (or just leave it set to unknown) 

 If you wish you can change the sections properties to override the ones 

that have been calculated for you. Click on the number to be changed and 

type in a new value. 

 Click the OK button 

The section will be stored in the library in the group you have nominated. Note that the 

library with the new section included will not be saved permanently on the disk until you 

choose Save Library from the File menu. 

 

If you have Multiframe running, you can now choose Save Library, then switch to 

Multiframe and choose Open Library->Sections Library from the File menu to reload the 

library into Multiframe. This will make the section you have added available for use in 

Multiframe. 

Symbols 

The content of the Shape Window can be modified to annotate shapes with labels, 

display dimensions and axes and to control how the shapes are displayed. 

Shape Numbers 

Each shape in the Shape window can be labelled with its number. To turn on or off the 

display of the shape numbers 

 Choose Shape Numbers from the Symbols submenu under the Display 

menu, or 

 Click the Shape Numbers button on the Symbols toolbar 

Polyline Numbers 

Each point along a polyline can be labelled with its index which identifies its positions 

within the polyline. To turn on or off the display of the polyline numbers 
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 Choose Polyline Numbers from the Symbols submenu under the Display 

menu, or 

 Click the Polyline Numbers button on the Symbols toolbar 

Dimensions 

The overall height and width of the section drawn in the Shape Window can be drawn as 

dimensions. Similarly, the location of the shapes centroid can also be displayed as 

dimensions. To turn on or off the display of the overall size of the section in the Shape 

Window 

 Choose Overall Dimensions from the Symbols submenu under the Display 

menu 

Or, to turn on or off the display of the centroids location 

 Choose Interior Dimensions from the Symbols submenu under the 

Display menu 

Principal Axes 

The principal axes of the shape also be displayed in the Shape Window. To turn on or off 

the display of the principal axes 

 Choose Principal Axes from the Symbols submenu under the Display 

menu 

Axes 

The origin of the x-y axis system, which represents the location about which the section 

properties are computed, may also be displayed in the Shape Window. To turn on or off 

the display of the these axes 

 Choose Axes from the Symbols submenu under the Display menu 

These axes are displayed by default. 

Fill 

Shapes within the Shape Window can be represented as either the outline of the shape or 

as a solid object drawn filled. To turn on or off the display of shapes as filled objects 

 Choose Fill from the Symbols submenu under the Display menu 

When shapes are displayed as filled, the outline of the shapes will be displayed in black 

and the fill colour determine by the colour scheme selected by the user (See the section 

on Colours which follows). Any shapes that have not been allocated a material and 

represent a hole will not be filled and will be drawn using a black outline only. 

 

When shapes are displayed as outlines without any fill, the colour of a shapes outline will 

be determined from the current colour scheme specified by the user. 

Material Patterns 

When shapes are displayed with fill the user has the option of using the pattern 

associated with the shapes material to draw the interior of the shape. To turn on or off the 

display of material patterns 

 Choose Material Patterns from the Symbols submenu under the Display 

menu 
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Legend 

A legend can be displayed that explains the meaning of each colour used to draw shapes 

in the Shape Window. The location and style of the legend can be adjusted using the 

commands in the Legend submenu. 

 

To turn on or off the display of a legend within the Shape Window.  

 Choose Visible from the Legend submenu under the Display menu, or 

 Click the Legend button on the Symbols toolbar 

Note that for most colour schemes the contents of the legend is dynamic as will reflect 

only the colour used within the Shape Window. In such cases a legend will not be visible 

until colour has been used.  

Selecting Shapes 

A feature of the legend is that it can be used to select all the shapes that correspond to a 

particular menu item. To set the selection to all the shapes corresponding to a particular 

legend item simply double click on the text within the legend associated with that item. 

Holding down shift or control while double clicking on the legend item will extend the 

current selection. 

Position 

The position of the legend can be set to any corner of the Shape Window. To display the 

legend in the bottom right hand corner of the window  

 Choose Bottom Right from the Legend submenu under the Display menu, 

or 

 Right click on the legend and choose Bottom Right from the popup menu 

A similar procedure can be followed to display the legend in any corner of the screen 

using the commands in the Legend submenu. 

Title Font 

The style of the font used to draw the title of the legend can be set by the used. To 

modify the style of the title font 

 Choose Title Font from the Legend submenu under the Display menu, or 

 Right click on the legend and chose Title Font from the popup menu 
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 Specify the required colour style in the Font dialog. 

 Click OK 

Font 

The style of the font used to draw the text of each item in the legend can be set by the 

used. To modify the style of this font 

 Choose Font from the Legend submenu under the Display menu, or 

 Right click on the legend and chose Font from the popup menu 

 

 Specify the required colour style in the Font dialog. 

 Click OK 

Note that the same colour is used to draw both the item text and the title. Changing the 

colour of either font will change the colour of the other text. 
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Colours 

The user can modify the colour corresponding to a particular item in the legend. To 

modify the colours associated with an items in the legend 

 Choose Item Colour from the Legend submenu under the Display menu, 

or 

 Right click on the legend and chose Item Colour from the popup menu 

 

or 

 

 Select the legend item to be modified 

 To change the colour of the selected item, click on the Colour box in the 

top left hand corner 
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 Choose a new colour from the Colour dialog 

 Click OK 

The colour of a particular legend item can also be modified by double clicking of the 

colour box associated with that item in the legend.  
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Chapter 5 
Sections Library Management 

This chapter describes the use of all of the commands available in Multiframe Shape 

Editor that are related to the management of sections libraries. It contains a number of 

sections – 

 Working with Libraries 

 Working with Sections 

 Working with Groups 

 Working with Groups of Materials 

Multiframe Shape Editor allows you to add, delete and modify the groups of materials 

stored in a sections library. 

 

In this section:  

 Viewing Groups 

 Locking/Unlocking a Group 

 Adding a Sections Group 

 Editing a Sections Group 

 Duplicating a Group 

 Deleting a Group 

 Reordering Groups 

 

Please note that all the commands described in this section are only available when you 

have the  Materials window activated. Some of the command swill only be available 

when the Groups tab is activated within this window.  

 

Viewing Material Groups 

The groups of materials stored in the Library can be viewed and changed in the Groups 

tab within Materials Window of Multiframe Shape Editor. A list of all the groups of 

material within the library is displayed in the Groups tab within this window. 

 

To make the Groups Table visible 

 Choose Materials from the Window menu 

 Click on the Groups tab in the navigation bar at the bottom of the 

window. 
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Locking/Unlocking a Group of Materials 

Groups are locked using a checkbox in the “Locked” column in the Groups tab in the 

Materials Window. To unlock a group, clear the checkbox in the “Locked” column of the 

Groups tab in the Materials window. Groups can also be locked/unlocked via the Group 

Properties dialog. 

Adding a Materials Group 

Material Maker allows you to add groups to or remove groups from the library you 

currently have open. This makes it more convenient for you to choose materials. If there 

are groups in the library you never use you could remove them or if there is a table of 

custom materials you often use you could add them in a separate group in the library. 

 

To Add a Materials Group to the Library 

 Choose Add Materials Group from the Materials submenu under the 

Library menu 

A dialog box will appear with a field for the group's name, a table showing where key 

properties will be stored in the group, a text box for the number of fields of data to be 

stored with each material in the group and a pop-up menu to indicate the shape of 

materials in the group. 

 

 

 Type in a name for the group 

 Choose the kind of materials to be stored in this group 

If you have more than one kind of shape or the shape is not one of the standard shapes, 

leave the shape set to the Unknown Material value. 

 Click the OK button 

The group will be added to the library and will display in the Materials Window. 

Editing a Materials Group 

The properties of material groups are edited via the Group table in the Materials 

Window. To edit the properties of a material group in the current sections library 

 Click on the Group tab in the list a tabs in the bottom corner of the 

Materials Window. 
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The name and kind can be edited directly with the table. 

 

Duplicating a Group of Materials 

To duplicate a group from the Materials Library 

 Choose Duplicate Material Group from the Materials submenu under the 

Library menu 

A copy of the current group, including all materials contained within the group, will be 

added to the end of library and made the current group on display in the Materials 

Window. 

 

Deleting a Group 

To remove a group from the Materials Library 

 Choose Delete Material Group from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 

 

 Click on the group to be removed 

If you wish to remove more than one group, hold down the shift key while clicking on 

the names of the other groups 

 Click the OK button 

The groups selected and all the materials stored in them will be removed from the 

library. 
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Reordering Groups 

The order in which groups appear within the materials library can be modified. To 

change the order of groups within the materials library 

 Choose Reorder Material Groups from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 

 

 Click on the group to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the group and release the 

mouse button. 

If you wish to move than one group then simply repeat the above two steps for each 

group to be moved to a new position within the library. 

 Click the OK button 

The new ordering of groups will be saved to the library. 

 

 Working with Materials  

Working with Libraries 

As well as enabling you to draw and add individual sections to the library, Multiframe 

Shape Editor has a number of features that make it easier for you to manage your 

sections library. You can add and remove groups of sections or materials from the 

library, add or remove a large number of sections at once, add, edit or remove materials 

from the library.. 

 

You can change the contents of the library via the Sections or Materials Windows that 

tabulate the properties of all the sections and materials stored in the library. In the 

Sections Window, each group of sections is displayed in a separate tab. Each tab displays 

a table in which you can view and change any of the section properties. The Sections 

Window also contains a Group tab which lists all the groups of sections contained in the 

library and their properties. The Material Window contains a number of tables listing the 

properties of all the materials in the library. This window contains separate tabs for each 

of the material groups in the library as well as a tab listing the groups of materials and 

the properties of those groups. 
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You can also create completely new libraries or read, modify and write any number of 

sections libraries. This means you can keep a number of libraries on your disk and use 

them for different applications. 

 

In this section: 

 Fields and Section Properties 

 Creating a New Library 

 Opening a Library 

 Saving a Library 

 Saving as Text 

 Group Organiser  

 

Fields and Section Properties 

The concept central to the structure of the sections library is that the section property 

data associated with a group of sections should reflect the data tables published by 

manufacturers or industry organisations. With this in mind the data displayed in the 

sections table in the Sections Window should reflect the published section properties. 

Each column of data in this table represents a field. In order to utilise this data in 

Multiframe it is necessary to identify which section property that a field represents. For 

some types of sections, typically symmetric sections, several section properties may be 

mapped to the same field. For example if Ix=Iy then there is only a need for a single I 

field. In addition, a factor must be specified with each field to convert the value in the 

field to the base units of newtons, metres and kilograms. 

Creating a New Library 

Multiframe Shape Editor allows you to create a new library for use with any of the 

Multiframe applications. All you have to do to make the new library the default is to 

place it in the same folder as the application and name it "SectionsLibrary.slb". If you 

already have a sections library in the folder with that name, rename the existing library to 

a different name and then name your new library "SectionsLibrary.slb". 

 

To create a new library 

 Choose New Library from the File menu 

A new library will be created with no groups or sections. You can add groups and 

sections to the library (see Adding a Group and Adding a Section below) before saving it 

to disk with the Save As command from the File menu. 

Opening a Library 

You do not have to work with the sections library that automatically opens when 

Multiframe Shape Editor starts up. (If Multiframe Shape Editor finds a library named 

SectionsLibrary.slb in the same folder as Multiframe Shape Editor, it will automatically 

open it on start-up) If you wish you can open any other library and work with it in the 

normal way. 

 

To open a sections library 

 Choose Open Library from the File menu 
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 Click on the name of the library you wish to open 

 Click the Open button 

The contents of the library will be read in and the groups, materials and sections in the 

library will be displayed in the tables within the Sections and Materials Windows 

respectively. 

Saving a Library 

If you have installed any sections in the library or you have changed the section or group 

properties in any way, you will have to save the Sections Library to disk to make the 

changes permanent. 

 

To save the Sections Library to disk 

 Choose Save Library from the File menu 

 

To save the Sections Library to disk with a new name 

 Choose Save As from the File menu 

 Select the folder or disk where you will save the library 

 Type in a name for the library 

 Click the Save button 

Saving as Text 

Another way to view the data in the library is to save it in text format. Text files can be 

read into a word processor or you could write your own software which extracts data 

from a text file of sections. 

 

To save the contents of the library in a text file 

 Choose Export -> Text File from the File menu 

 Type in a name for the text file of data 

 Choose which disk or folder you want to store the data in 

 Click the Save button 
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The complete contents of the sections library will be saved to disk in a text file. The 

format of this file is documented in Chapter 4. 

Group Organiser 

Groups of sections or materials may be copied between libraries using the Group 

Organiser. The Group Organiser may also be used to delete groups from a sections 

library. The Group Organiser dialog (shown below) provides this functionality by 

opening two sections libraries. The groups of section and materials in these libraries are 

listed on either side of the dialog. Groups can be copied between the libraries by 

selecting the group(s) to be copied and clicking the Copy button. Similarly, groups may 

be deleted from a library by selecting the groups to be deleted and clicking the Remove 

Selected Groups button. 

 

Any two libraries may be displayed in the Group Organiser dialog. By default, one of 

these libraries is set to the current sections library when the Group Organiser is first 

opened. 

 

To import a group of sections or materials from another sections library into the library 

currently opened by Multiframe Shape Editor  

 Choose Group Organiser… from the Library menu 
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The current library is already open in the dialog and displayed down the left hand side. 

 Click the Open Library… button on the right hand side of the dialog. 

 Using the resulting file dialog, choose the sections library from which to 

import the group of sections.  

This library will be displayed on the right hand side of the Group Organiser dialog. 

 Select the group(s) to be imported to the current library from the right 

hand list of groups. 

 Click the <<Copy<< button. 

 Click the left hand Close Library button 

This will save the current library 

 Click the OK button. 

Working with Groups of Sections 

Multiframe Shape Editor allows you to add, delete and modify the groups of sections 

stored in a sections library. 

 

In this section:  
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 Viewing Groups 

 Locking/Unlocking a Group 

 Adding a Sections Group 

 Editing a Sections Group 

 Duplicating a Group 

 Deleting a Group 

 Reordering Groups 

 Adding a Field 

 Editing Fields 

 Deleting a Field 

 Reordering Fields 

 

Please note that all the commands described in this section are only available when you 

have the  Sections window activated. Some of the command swill only be available when 

the Groups tab is activated within this window.  

 

Viewing Groups 

The groups stored in the Library can be viewed and changed in the Groups tab within 

Sections Window of Multiframe Shape Editor. A list of all the groups of section within 

the library is displayed in the Groups tab within this window. 

 

To make the Groups Table visible 

 Choose Sections from the Window menu 

 Click on the Groups tab in the navigation bar at the bottom of the 

window. 
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Locking/Unlocking a Group of Sections 

Groups are locked using a checkbox in the “Locked” column in the Groups tab in the 

Sections Window. To unlock a group, clear the checkbox in the “Locked” column of the 

Groups tab in the Sections window. Groups can also be locked/unlocked via the Group 

Properties dialog. 

Adding a Sections Group 

Multiframe Shape Editor allows you to add groups to or remove groups from the library 

you currently have open. This makes it more convenient for you to choose sections. If 

there are groups in the library you never use you could remove them or if there is a table 

of custom sections you often use you could add them in a separate group in the library. 

 

To Add a Sections Group to the Library 

 Choose Add Sections Group from the Sections submenu under the 

Library menu 

A dialog box will appear with a field for the group's name, a table showing where key 

properties will be stored in the group, a text box for the number of fields of data to be 

stored with each section in the group and a pop-up menu to indicate the shape of sections 

in the group. 

 

 

 Type in a name for the group 

 Choose from the Shape list the kind of shapes stored in this group 

If you have more than one kind of shape or the shape is not one of the standard shapes, 

leave the shape set to the Unknown Section value. 

 Click the Set Shape Default Fields button. 

This will set up a default number of fields that represent the information required for the 

shape of section selected in the step above. 
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If you wish you could type in the number of fields you require. If you do add extra fields, 

you can type a number next to each of the key properties to tell Multiframe in which 

field that property will be stored. For example the first line of the table indicates that the 

mass per unit length of the section is stored in a field named Mass and this is the first 

field of the group. If you do change any of these values it is very important that you keep 

the naming and units for the property consistent and always store the property in the field 

indicated. Multiframe relies on this information to do analysis and if you make an error 

entering the key properties, the results of analysis may be incorrect. If in doubt, leave the 

group with the standard fields and properties. 

 Click the OK button 

The group will be added to the library and will display in the Sections Window. 

Editing a Sections Group 

To edit the properties of a Group in the current sections library 

 Choose Section Group Properties from the Sections submenu under the 

Library menu 

A dialog box will appear with a field for the group's name, a table showing where key 

properties will be stored in the group, a text box for the number of fields of data to be 

stored with each section in the group and a pop-up menu to indicate the shape of sections 

in the group. 

 

 

 

The table displays the mapping of section properties to data fields. The first column 

named Property shows the internal Multiframe property contained in the filed. The 

second column named Field Index indicates which field in the group this property can be 

found in. This column can contain a zero if the group does not contain that property. The 

final column Field Name will be updated when you change the Field Index to let you 

know which field in the group is being referred to. IN fact it is easier to change the Field 

Name column via the drop down menu in the cell, and the Field Index will be updated 

for you. 

If you do change any of the values in this table,  it is very important that you keep the 

naming and units for the property consistent and always store the property in the field 

indicated. Multiframe relies on this information to do analysis and if you make an error 

entering the key properties, the results of analysis may be incorrect. If in doubt, leave the 

group with the standard fields and properties. 
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 Click the OK button 

 

Duplicating a Group of Sections 

To duplicate a group from the Sections Library 

 Choose Duplicate Section Group from the Sections submenu under the 

Library menu 

A copy of the current group, including all sections contained within the group, will be 

added to the end of library and made the current group on display in the Sections 

Window. 

 

Deleting a Group 

To remove a group from the Sections Library 

 Choose Delete Section Group from the Sections submenu under the 

Library menu 

A list of the groups in the library will be displayed 

 

 Click on the group to be removed 

If you wish to remove more than one group, hold down the shift key while clicking on 

the names of the other groups 

 Click the OK button 

The groups selected and all the sections stored in them will be removed from the library. 

 

Reordering Groups 

The order in which groups appear within the sections library can be modified. To change 

the order of groups within the sections library 

 Choose Reorder Section Groups from the Sections submenu under the 

Library menu 

A list of the groups in the library will be displayed 
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 Click on the group to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the group and release the 

mouse button. 

If you wish to move than one group then simply repeat the above two steps for each 

group to be moved to a new position within the library. 

 Click the OK button 

The new ordering of groups will be saved to the library. 

 

Adding a Field 

The properties of each section in a group are stored in a number of fields in the group. 

When you create a new group the standard properties are placed in the first fields in the 

group. If you wish you can add more fields to a group. You could do this to make data 

available for use in Multiframe's CalcSheet or you could store additional data for easy 

reference. 

 

To add a field to the current group 

 Choose Add Field from the Sections submenu under the Library menu 

A dialog box will appear allowing you to enter the properties of the new field you wish 

to add 
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 Type in the name of the new field 

 Select the section properties that will correspond to the new field. 

 Select the units for the new field. 

 Click the OK button. 

The additional fields will be displayed in the Groups Table in the Sections  window and 

additional columns will be added to the Sections table in the Section Window. 

Editing Fields 

You can change the information about fields in the Groups Tables in the Sections 

Window. To change the name of the field, click on its current name, type in a new name 

and press the enter key.  

 

 

The units for the field may also be modified. In the units column, type in the name of the 

units you want to use to store properties in this field. For example, if you added a field 

named Iw for a warping constant your units might be in^6 (inches to the sixth power) so 

you should type this into the units column. You should also type in a factor to convert the 

fields values into Multiframe Shape Editor's internal units system. This will allow you or 

another user to change units and still have the properties displayed correctly. The factor 

is the number the entered value must be multiplied by to convert it into a Newton, meter, 

kilogram units system. i.e. in the case where Iw will be entered in units of in^6, the factor 

will be 6.820907E-12 (i.e. 1/39.37 to the power of six as there are 39.37 inches in a 

meter) 

 

Some common units factors are 

 

  Metric  English  

Name Property Unit Factor Unit Factor 
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Mass Mass per unit length kg/m 1.0 lb/ft 1.488 

A, Asx, Asy Cross sectional area mm2 1E-6 in2 6.452E-4 

Ix Major moment of 

inertia 
mm4 1E-12 in4 1.638E-5 

Iy Minor moment of 

inertia 
mm4 1E-12 in4 1.638E-5 

J Torsion constant mm4 1E-12 in4 1.638E-5 

E Young's Modulus MPa 1E-6 ksi 6895000 

G Shear Modulus MPa 1E-6 ksi 6895000 

D Depth mm 0.001 in 0.0254 

B Breadth or Width mm 0.001 in 0.0254 

tf Flange thickness mm 0.001 in 0.0254 

tw Web thickness mm 0.001 in 0.0254 

 

Deleting a Field 

You can delete fields that you have added by using the Delete Field command from the 

Sections submenu under the Library menu. 

 

To delete a field or fields from the current group 

 Choose Delete Field from the Sections submenu under the Library menu 

 Click in the name of the field to be removed 

If you wish to remove more than one field, shift click on the additional field names 

 Click the OK button 

WARNING: Do NOT delete any of first eleven standard fields in a group as Multiframe 

uses them in its analysis. 

 

Reordering Fields 

The order in which fields are presented for a group can be modified as follows. 

 Choose Reorder Fields from the Sections submenu under the Library 

menu 

A list of fields within the group will be displayed 

 

 Click on the field to be moved, keeping the mouse button depressed  
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 Drag the cursor to locate the new position for the field and release the 

mouse button. 

If you wish to move than one field then simply repeat the above two steps for each field 

to be moved to a new position. 

 Click the OK button 

The new ordering of fields will be displayed in the Groups Tables in the Sections 

Window. 

Working with Sections 

Multiframe Shape Editor allows you to add, delete and modify data associated with each 

section stored in a sections library. 

 

In this section: 

 Viewing Sections 

 Adding a Section 

 Deleting a Section 

 Changing Section Properties 

 Custom Shape Data 

 Section Colour 

 Reordering Sections 

 Generating Tapered Sections 

 

Please note that all the commands described in this section are only available when you 

have the a table of sections active  in the Sections Window.  

Viewing Sections 

The sections stored in the Sections Library can be viewed and changed in the Sections 

Window of Multiframe Shape Editor. The sections are displayed, a group at a time, in the 

Sections Table within this window. 

 

To make the Sections Table visible 

 Choose Library from the Window menu 

 Click on a tab at the bottom of the window to select the group of sections 

to be viewed. 
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Adding a Section 

To add a section or a number of sections to the current group in the librarySelect Window 

| Sections to bring the Sections window to the front 

 Click on the tab at the bottom of this window with the name of the group to which 

the new sections are to be added. 

 Using the Group Toolbar, select which group you wish to add a section to. 

Note 

You can only add sections to groups that are unlocked. To unlock a group, 

see Locking/Unlocking a Group on page 62. 

 Choose Add Section from the Sections submenu under the Library menu 

A dialog box will appear allowing you to specify how many sections you wish to add. 

 

 Type in the number of sections to be added 

 Click the OK button 

 

A number of sections titled Section1, Section2 and so on will be added to the current 

group. They will initially have all their properties set to zero. You can view and edit the 

added sections in the Section table in the Sections Window.  

Deleting a Section 

To remove a section or a number of sections from the library 

 Choose Delete Section from the Sections submenu under the Library 

menu 

A dialog box will appear with a list of the names of the sections in the current group 
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 Click on the name of the section to be removed 

If you want to remove more than one section, hold down the shift key and click or drag 

over the additional sections to be removed 

 Click the OK button 

The sections will be removed from the library. Remember that the changes will not be 

made permanent until you save the library to disk using the Save Library command from 

the File menu. 

Changing Section Properties 

To change the value of a property stored with a section 

 Click on the property to be changed 

 Type in a new value 

 Press the Enter key 

 

When you change the properties of a section, you must use the units indicated at the top 

of the column for the property displayed in that column of the table. The standard 

properties stored in a group are 

 

Name Property Metric English 

Mass Mass per unit length kg/m lb/ft 

A Cross sectional area mm2 in2 

Ix Major moment of inertia mm4 in4 

Iy Minor moment of inertia mm4 in4 

J Torsion constant mm4 in4 

E Young's Modulus MPa ksi 

G Shear Modulus MPa ksi 

D Depth mm in 

B Breadth or Width mm in 

tf Flange thickness mm in 

tw Web thickness mm in 

fy  Yield Strength MPa ksi 

fu Ultimate Strength MPa ksi 

Sxt (or Zxt) Elastic Modulus about x at top mm3 in3 

Sxb (or Zxb) Elastic Modulus about x at bottom mm3 in3 

Sxt (or Zxt) Elastic Modulus about x at top mm3 in3 
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Name Property Metric English 

Syl (or Zyl) Elastic Modulus about y at left mm3 in3 

Syr (or Zyr) Elastic Modulus about y at right mm3 in3 

rx radius of gyration about x mm in 

ry radius of gyration about y mm in 

Sx (or Zx) Plastic Modulus about x mm3 in3 

Sy (or Zy) Plastic Modulus about y mm3 in3 

Iw Warping constant mm3 in3 

rz radius of gyration about weakest axis mm in 

Asx Shear area in weak axis direction (x) mm2 in2 

Asx Shear area in strong axis direction (y) mm2 in2 

b1,b2 Additional width dimensions required for some 

section shapes. 

(e.g. Width of Zed flanges) 

mm in 

d1,d2 Additional width dimensions required for some 

section shapes. 

(e.g. Depth of lip for Cee or Zed sections) 

mm in 

b2 Width of bottom Zed flange mm in 

d1 Depth of lip of Cee or Zed shape mm in 

D2 Depth of lip of Cee or Zed shape mm in 

xc, yc Position of centroid as measured for bottom 

left hand corner of section 

mm in 

Ø Angle of principle axes from section axes. degrees degrees 

Iu Moment of inertia about major principle axis. mm4 in4 

Iv Moment of inertia about minor principle axis. mm4 in4 

Ru Radius of gyration about major principle axes mm in 

Rv Radius of gyration about minor principle axes mm in 

Sut or Zut Elastic Modulus about major principle axes in 

positive v axis direction. 
mm3 in3 

Sub or Zub Elastic Modulus about major principle axes in 

negative v axis direction. 
mm3 in3 

Svt or Zvt Elastic Modulus about minor principle axes in 

positive u axis direction. 
mm3 in3 

Svb or Zvb Elastic Modulus about minor principle axes in 

negative u axis direction. 
mm3 in3 

xs, ys Position of shear centre as measure from 

centroid. 

mm in 

P Perimeter of section mm in 

Tan(Ø) Tan of principle axis angle   

s Spacing parameter mm in 

r1 Primary radii (e.g. Fillet radius) mm in 

r2 Secondary radii (e.g. Toe radius) mm in 

Ixy Product of Inertia mm4 in4 

 

The following diagram will help you determine the dimensional properties. These 

properties are used by Multiframe for rendering and display of member details and 

stresses and by Multiframe Shape Editor for placing standard shapes and existing 

sections. 
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Custom Shape Data 

When a section designed within Multiframe Shape Editor is added to the sections library 

extra geometric data is stored in the library along with the section properties.  This data 

is used to recreate the geometry of the section within both Multiframe Shape Editor and 

Multiframe.  This data cannot be viewed or edited.  Caution should be exercised when 

cutting and pasting data within the Sections Table so as to not change the order of the 

sections in this table.  

 

 

Section Colour 

A colour may be associated with each section in the library. This colour is used by 

Multiframe when displaying section colours in the Frame Window. In Multiframe Shape 

Editor, the colour of each section is displayed in the Section Table in the Sections 

Window. 

 

To change the colour associated with a section 

 View the section properties in the Section Table in the Sections Window 
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 Double click on the cell in the Colour column. 

The standard Windows dialog for selecting colours will appear. 

 Click on the new colour for the section 

 Click the OK button 

Section colours may also be cut and pasted between sections and the Fill Down function 

may be used to set ranges of sections to the same colour. Remember that the changes will 

not be made permanent until you save the library. By default all section colours are set to 

black. 

Reordering Sections 

The order in which sections appear within a group can be modified as follows. 

 Choose Reorder Sections from the Sections submenu under the Library 

menu 

A list of fields within the group will be displayed 

 

 Click on the section to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the section and release the 

mouse button. 

If you wish to move than one section then simply repeat the above two steps for each 

section to be moved to a new position within the group. 

 Click the OK button 

The new ordering of sections will be displayed in the Section Tables in the Sections 

Window. 

Generating Tapered Sections 

Multiframe Shape Editor allows you to automatically create a number of sections, which 

interpolate between two existing sections. This can be used to model the changing 

sectional shape in a tapered member. Suppose you were modelling a tapered beam in 

Multiframe that started with a 12inch (300mm) deep section and tapered to a 

24inch(600mm) deep section. You could draw the first section and install it in the 

library, then draw the second section and install it. To create the intermediate sections 

you use the Taper command from the Shape window. 

 

To install a number of intermediate sections between to existing sections 
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 Choose Generate Tapered Sections… from the Library | Sections 

submenu. 

A dialog box will appear which allows you to select the start and finish sections 

 

 Click on the Start Section button 

A dialog box will appear listing the available groups and sections 

 Click on the group and section names of the starting section 

 Click the OK button 

 Do the same for the end section. 

The two sections you have chosen will be displayed in the dialog. 

 Type in the number of intermediate sections you want to generate 

The sections properties will be calculated at the mid point of each subdivision of the 

range between the start and end sections. Multiframe Shape Editor makes an 

approximation to the intermediate section properties by interpolating between the 

properties at each end. All the properties except the moments of inertia and the torsion 

constant are interpolated linearly and will be exactly correct. The moments of inertia and 

torsion constant are interpolated using a cubic approximation to the variation in property 

along the tapering member. This will result in a small error in the moments of inertia and 

torsion constant but in most cases this should not impact significantly on your analysis. If 

you have a problem, which is sensitive to the value of torsion or moments of inertia, you 

should determine that this error will not have an adverse impact on your analysis. A 

quick check of the values at the mid-point will give you a guide to the maximum error. 

 

 Type in a name for the section 
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This name will form the basis of the names for the added sections. If "TestShape" is the 

name you give to the sections, the intermediate sections will be named TestShape1, 

TestShape2 … and so on up to TestShapen, where n is the number of intermediate shapes 

you requested. 

 If you want to remove the original start and end sections check the check 

box at the bottom of the dialog 

 

Most times you will want to do this if you have drawn the sections as the original 

sections will not be used in the Multiframe analysis. The sections will only be deleted if 

the groups they belong to are not locked. To unlock a group, see Locking/Unlocking a 

Group on page 62. 

 Specify which group you wish to install the intermediate sections into 

 Click the OK button 

If you want to view or change the properties of the sections which are created, you can 

view them in the Sections Tab in the Sections Window (see Viewing Sections on page 

69). 

Note 

Remember that whenever you install sections in the library using 

Multiframe Shape Editor, these new sections will only become available 

after saving the library and opening it in Multiframe. 

Working with Groups of Materials 

Multiframe Shape Editor allows you to add, delete and modify the groups of materials 

stored in a sections library. 

 

In this section:  

 Viewing Groups 

 Locking/Unlocking a Group 

 Adding a Sections Group 

 Editing a Sections Group 

 Duplicating a Group 

 Deleting a Group 

 Reordering Groups 

 

Please note that all the commands described in this section are only available when you 

have the  Materials window activated. Some of the command swill only be available 

when the Groups tab is activated within this window.  

 

Viewing Material Groups 

The groups of materials stored in the Library can be viewed and changed in the Groups 

tab within Materials Window of Multiframe Shape Editor. A list of all the groups of 

material within the library is displayed in the Groups tab within this window. 

 

To make the Groups Table visible 
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 Choose Materials from the Window menu 

 Click on the Groups tab in the navigation bar at the bottom of the 

window. 

 

 

Locking/Unlocking a Group of Materials 

Groups are locked using a checkbox in the “Locked” column in the Groups tab in the 

Materials Window. To unlock a group, clear the checkbox in the “Locked” column of the 

Groups tab in the Materials window. Groups can also be locked/unlocked via the Group 

Properties dialog. 

Adding a Materials Group 

Material Maker allows you to add groups to or remove groups from the library you 

currently have open. This makes it more convenient for you to choose materials. If there 

are groups in the library you never use you could remove them or if there is a table of 

custom materials you often use you could add them in a separate group in the library. 

 

To Add a Materials Group to the Library 

 Choose Add Materials Group from the Materials submenu under the 

Library menu 

A dialog box will appear with a field for the group's name, a table showing where key 

properties will be stored in the group, a text box for the number of fields of data to be 

stored with each material in the group and a pop-up menu to indicate the shape of 

materials in the group. 

 

 

 Type in a name for the group 

 Choose the kind of materials to be stored in this group 
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If you have more than one kind of shape or the shape is not one of the standard shapes, 

leave the shape set to the Unknown Material value. 

 Click the OK button 

The group will be added to the library and will display in the Materials Window. 

Editing a Materials Group 

The properties of material groups are edited via the Group table in the Materials 

Window. To edit the properties of a material group in the current sections library 

 Click on the Group tab in the list a tabs in the bottom corner of the 

Materials Window. 

 

The name and kind can be edited directly with the table. 

 

Duplicating a Group of Materials 

To duplicate a group from the Materials Library 

 Choose Duplicate Material Group from the Materials submenu under the 

Library menu 

A copy of the current group, including all materials contained within the group, will be 

added to the end of library and made the current group on display in the Materials 

Window. 

 

Deleting a Group 

To remove a group from the Materials Library 

 Choose Delete Material Group from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 
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 Click on the group to be removed 

If you wish to remove more than one group, hold down the shift key while clicking on 

the names of the other groups 

 Click the OK button 

The groups selected and all the materials stored in them will be removed from the 

library. 

 

Reordering Groups 

The order in which groups appear within the materials library can be modified. To 

change the order of groups within the materials library 

 Choose Reorder Material Groups from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 

 

 Click on the group to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the group and release the 

mouse button. 

If you wish to move than one group then simply repeat the above two steps for each 

group to be moved to a new position within the library. 
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 Click the OK button 

The new ordering of groups will be saved to the library. 

 

Working with Materials 

Multiframe Shape Editor also stores material information in the Sections Library. You 

can add your own materials and apply them to various parts of your section being 

designed in the Shape Window. The materials will also be available for use in 

Multiframe is order to assign the appropriate material properties for use in analysis.  

 

In this section: 

 Viewing Materials 

 Adding a Material 

 Deleting a Material 

 Changing a Material 

 

Please note that all the commands described in this section are only available when you 

have the Materials tab in the Materials window activated. It is also important to note that 

only materials groups must be unlocked in order to add, edit or deleted materials from 

within that group.  

Viewing Materials 

The materials stored in the Sections Library can be viewed and changed in the Materials 

Window of Multiframe Shape Editor. This windows contains a separate table for each 

group of materials in the library and all the materials contained in the groups are 

displayed in this table. 

 

To display the Materials Table 

 Choose Material from the Window menu 

 Click on the tab in the navigation bar at the bottom of the window to 

select the material group to display. 

 

Adding a Material 

To add a material to the library 

 Choose Add Material from the Materials submenu under the Library 

menu 
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A dialog box will appear allowing you to specify how many materials you wish to add. 

 

 Type in the number of materials to be added 

 Click the OK button 

 

A number of materials titled “Material 1”, “Materials 2” and so on will be added to the 

current group. They will initially have all their properties set to default values. You can 

view and edit the added materials in the table within the Materials Window.  

Deleting a Material 

To delete a material from the library 

 Choose Delete Material from the Materials submenu under the Library 

menu 

 

 Click on the name of the material you want to delete 

 Click the OK button 

Changing a Material 

To change the name, pattern or properties of a material 

 Choose Edit Material from the Materials submenu under the Library 

menu 

The Select Materials dialog will appear. 

 Choose the Material to be edited and click OK. 

The material properties dialog will appear. 
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 Click on the name of the material you want to edit 

 Type in a new name, change the pattern or type in new values for the 

material's properties 

 Click the OK button 

Note that only the materials in unlocked materials groups can be edited. 

Reordering Materials 

The order in which materials appear within a group can be modified as follows. 

 Choose Reorder Materials from the Materials submenu under the 

Library menu 

A list of fields within the group will be displayed 

 

 Click on the material to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the material and release the 

mouse button. 



Chapter 5 - Sections Library Management 

Page 86 

If you wish to move than one material then simply repeat the above two steps for each 

material to be moved to a new position within the group. 

 Click the OK button 

The new ordering of materials will be displayed in the Materials Window. 

 

Material Colour 

A colour may be associated with each material in the library. In Multiframe Shape 

Editor, the colour of each material is displayed in the table of materials in the Materials 

Window. 

 

To change the colour associated with a material 

 View the materials properties in a table of materials in the Materials 

Window 

 

 Double click on the cell in the Colour column. 

The standard Windows dialog for selecting colours will appear. 

 Click on the new colour for the material 

 Click the OK button 

Materials colours may also be cut and pasted between materials and the Fill Down 

function may be used to set ranges of materials to the same colour. Remember that the 

changes will not be made permanent until you save the library. By default all material 

colours are set to black. 
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Chapter 6 
Multiframe Shape Editor Reference 

This chapter summarises the overall structure and menu commands of Multiframe Shape 

Editor. The following sections describe the  

 Windows  

 Sections Window 

This window is used for viewing and editing the data stored for each of the groups of 

sections in the Library. You can use the tabs at the bottom of this window to switch 

between editing the properties of the groups, or the sections properties data contained 

within the groups. 

Materials Window 

This window is used for viewing and editing the data stored for each of the groups of 

materials in the Library. You can use the tabs at the bottom of this window to switch 

between editing the properties of the groups, or the properties of the materials contained 

within the groups. 

 Toolbars  

 Menus 

Windows 

Multiframe Shape Editor uses a range of graphical, tabular, graph and report windows. 

Shape Window 

This window is used for drawing sections comprising one or more shapes prior to 

installing it in the sections library. See Drawing a Shape on page 31 for more 

information.  

Data Window 

This window is used for viewing and editing the data describing the shapes in the Shape 

window. It can display tables of section properties for the shapes within a section and 

also displays dimensions of the shapes that make up a section.  

Properties Window 

This window is used for displaying the calculated sectional properties for the shape in the 

Shape window.  

Sections Window 

This window is used for viewing and editing the data stored for each of the groups of 

sections in the Library. You can use the tabs at the bottom of this window to switch 

between editing the properties of the groups, or the sections properties data contained 

within the groups. 

Materials Window 

This window is used for viewing and editing the data stored for each of the groups of 

materials in the Library. You can use the tabs at the bottom of this window to switch 

between editing the properties of the groups, or the properties of the materials contained 

within the groups. 
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Toolbars 

Users of Multiframe Shape Editor can use the icons on the toolbars to speed up access to 

some commonly used functions. You can hold your mouse over an icon to reveal a pop-

up tip of what the icon does. 

File Toolbar 

 

The File toolbar contains icons for open, and saving files. 

 

New Library - Open Library - Save Library - Cut - Copy - Paste - Print Preview - About 

Group Toolbar 

 

The Group toolbar contains icons for changing the current group. 

 

Previous Group - Next Group 

View Toolbar 

 

The View toolbar contains icons for changing the view in the Shape window. 

 

Zoom - Shrink - Pan – Size To Fit – Toggle Grid – Toggle Axes 

Shape Toolbar 

 

The Shape toolbar contains icons for drawing shapes in the Shape window. 

 

Select – Rectangle - Hollow Rectangle - Circle - Tube - Closed Polygon - Open Polygon 

Geometry Toolbar 

 

The Geometry toolbar contains icons for modifying the size and layout of shapes in the 

Shape window. 

 

Stack vertically – Stack horizontally – Align left edges – Align horizontally to centres – 

Align top edges - Align vertically to centres - Align bottom edges – Make same width – 

Make same height – Make same size 
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Symbols Toolbar 

 

The Symbols toolbar contains icons for displaying symbols in the Shape window. 

 

Fill Shapes – Material Patterns – Shape Numbers – Polygon Numbers – Legend 

 

Menus 

Multiframe Shape Editor uses the standard set of Windows menu commands for File, 

Edit and Windows operations. It also has a range of menus for working with sections and 

groups of sections. 

 

In this section:  

 File Menu 

 Import Submenu 

 Export Submenu 

 Edit Menu 

 Select Submenu 

 View Menu 

 Geometry Menu 

 Make Equal Size Submenu 

 Align Submenu 

 Align to Centroid Submenu 

 Arrange Submenu 

 Shape Menu 

 Library Menu 

 Sections Submenu 

The commands in this submenu are only available if the Sections window is front most. 

Some commands in this submenu will only available if a tab displaying section 

properties window is active. 

 Select Window | Sections to bring the Sections window to the front 

 Select tab on the bottom of this window other than the Groups tab. 

 

Also see the section on Working with Sections on page 68 for more information. 

 

This submenu also contains others commands for working with groups of sections in the 

library. The commands in this submenu are may only available if the Groups tab in the 

Sections window is front most. 

 Select Window | Sections to bring the Sections window to the front 

 Select the Groups tab on the bottom of this window. 

In some cases, commands acting upon groups of may be available when the Groups 

window is not front most in which case the command may act upon the group currently 

being displayed in the window. 

  



Chapter 6 - Reference 

Page 90 

See the section on Working with Groups on page 61 for more information.  

Add Section 

Add a section or a number of sections to the current group. The sections will be 

displayed in the current table of sections displayed in the Sections Window where you 

can type in values for the sections' names and properties. 

Reorder Sections 

Modify the order of sections within a group. 

Delete Section 

Delete a section or a number of sections from the current group. 

Generate Tapered Sections 

Create a number of sections from two existing sections by interpolating the sections 

properties. This is useful for modelling the sections needed to simulate a tapered sections 

with a number of intermediate sections. You can use this in conjunction with the 

subdivide command in Multiframe for modelling tapered members.  

 

See Generating Tapered Sections on page 74 for more information. 

  

 Material Submenu 

 Sections Submenu 

 Display Menu 

 Properties Submenu 

 Data Submenu 

 Error! Reference source not found. 

 Symbols Submenu 

 Colours Submenu 

 Legend Submenu 

 Window Menu 

 Sections 

Make the Sections Window visible and bring it to the front 

Materials 

Make the Materials Window visible and bring it to the front 

 Help Menu 

 

File Menu 

The File menu contains commands for opening and saving files as well as import and 

export and printing. 

New Library 

(Ctrl N) 

Use this to start work on a new library. If you have any changes to the current library 

unsaved, Multiframe Shape Editor will prompt you to save any changes before starting 

the new work. 
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Open Library 

(Ctrl O) 

Open a library which has previously been saved on disk. 

 

If you have any changes to the current library unsaved, Multiframe Shape Editor will 

prompt you to save any changes before opening the new file. 

Import 

See “Import Submenu” 

Export 

See “Export Submenu” 

Close Library 

Closes the library and removes all groups and sections from display. 

Save Library 

(Ctrl S) 

Save the current library data with the same name you saved with last time or the same 

name the file had when you opened it. 

Save Library As 

Save the current library in a file with a new name. 

Page Setup 

Set up the printer for printing. 

Print Window 

Print the contents of the front window on the screen. 

Allows you to set margins, header and footer titles and options on printing the date, time 

and page numbers. 

Print Library 

Print the entire contents of the Sections Library. 

Recent File 

Recently opened files will appear at the bottom of the File menu. You can choose them 

as a shortcut to open them. 

Exit 

Leave the Multiframe Shape Editor program. If you have any work unsaved, Multiframe 

Shape Editor will prompt you to save any changes to the library before quitting. 

Import Submenu 

The Import submenu provides you with options to import sections and sections libraries. 

DXF 

Imports the shapes in a DXF file into the Shape window. 

Text File 

Import the text version of the sections library. 
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Spacegass Library 

Import a sections library from the Spacegass program. 

Microstran Library 

Import a sections library from the Microstran program. 

 

Export Submenu 

The Export submenu allows you to export a sections library. 

Text File 

Save the sections library in a text file format. 

Sections Library v7 

Save the sections library in a file format compatible with Multiframe versions 7 and 

earlier. You can also use this format to move a sections library back to the Macintosh 

version of Multiframe Shape Editor or Multiframe. 

Sections Library v9 

Save the sections library in a file format compatible with Multiframe version 8 and 9. 

Edit Menu 

The Edit menu contains commands for copying and pasting tabular data, selecting 

objects and working in tables. 

Undo 

(Ctrl Z) 

Undo the last action you carried out. The name of this item will change to reflect the 

command that can be undone. You can undo up to 20 actions. 

Redo 

(Ctrl Y) 

Redo the last action you undid. The name of this item will change to reflect the 

command that can be redone. 

Cut   

(Ctrl X) 

Remove the current selection and place it on the clipboard  

Copy 

(Ctrl C) 

Copy the current selection to the clipboard 

Paste 

(Ctrl V) 

Paste the contents of the clipboard into the current selection 

Paste Special 

(Ctrl V) 

Pastes data for entire sections copied from the Sections Table in the Sections Window 

into the current group. These sections will be appended to the end of the group. 
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Delete 

Remove the current selection without placing it on the clipboard. 

Select 

The Select menu has commands for automatically selecting parts of the drawing in the 

Shape window. 

See “Select Submenu” 

Fill Down 

(Ctrl Down Arrow) 

Repeat the cell at the top of the list of selected cells in the Data window down the list of 

selected cells. 

Fill Right 

(Ctrl Right Arrow) 

Repeat the cell at the left of the list of selected cells in the Data window across the list of 

selected cells. 

Preferences 

Allows the user to modify the applications settings. 

Properties 

Displays the properties of the object selected within the Shape Window. 

Select Submenu 

The Select submenu has commands for automatically selecting parts of the drawing in 

the Shape window. 

Select All 

(Ctrl A) 

Automatically selects all the shapes in the Shape window 

Select Polygons 

Automatically selects all the polygonal shapes in the Shape window. 

Select Circles 

Automatically selects all the circular shapes in the Shape window 

Select Rectangles 

Automatically selects all the rectangular shapes in the Shape window 

View Menu 

The View menu contains commands for controlling the display in the Shape window. 

Zoom 

(Ctrl W) 

Zoom in on part of the current display. A cross-hair will appear and the view to be 

viewed in close-up may be selected by pressing the mouse button and dragging a 

rectangle surrounding the area of interest. Release the button to draw the zoomed view. 

Pan   

(Ctrl R) 
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Pan across the drawing displayed in the Shape window. Press and drag in the window to 

move the drawing. 

Shrink 

(Ctrl E) 

Reduce the size of the drawing in the Shape window to half its current size. 

Size To Fit 

(Ctrl T) 

Scale the drawing in the Shape window so that it just fits inside the window. 

Size 

Set the maximum and minimum coordinates available in the Shape window. Use this to 

set up the overall coordinates before you begin drawing a section. 

Grid 

Switch on or off the use of the grid in the Shape window and set the spacing of the grid. 

Font 

Set the font size and style for the text in the front most window. 

Numbers 

Set the type of numeric format you would like to use to display numbers in the front 

most window. You can choose to use decimal or scientific notation and specify how 

many digits of precision you wish to display. 

Units 

Choose to work in Metric (mm) or English (inches) units. 

Colours 

Choose to colours used to display content in the Shape Window. 

Status Bar 

Allows you to turn on or off the display of the status bar 

Toolbars 

Allows you to turn on or off the display of the toolbars at the top of the Multiframe 

Shape Editor program window. 

 

See the “Toolbar” section above for more information on the toolbars available in 

Multiframe Shape Editor. 

Geometry Menu 

The Geometry menu contains commands for modifying the geometry and layout of 

shapes in the Shape window. 

Duplicate 

(Ctrl D) 

Duplicates all the selected shapes in the Shape window a given number of times in a 

specified direction. A dialog allows you to enter the spacing in each direction and the 

number of duplicates to be created. 
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Rotate 

Rotates all the selected shapes in the Shape window a specified number of degrees about 

the origin of the axes. A dialog allows you to enter the number of degrees of rotation. 

Rotation is positive anti-clockwise. 

Rescale 

Multiplies the coordinates of all the selected shapes in the Shape window by a specified 

scaling factor in each axis direction. This has the effect of rescaling the selected shapes 

by the specified amounts. 

Move 

Allows you to move the selected shapes in the Shape window a specified distance This 

provides a more accurate way of moving shapes rather than dragging them with the 

mouse. 

Flip Horizontal 

Reflects the selected shapes in the Shape window about a vertical axis passing through 

the centroid of the area of the selected shapes. 

Flip Vertical 

Reflects the selected shapes in the Shape window about a horizontal axis passing through 

the centroid of the area of the selected shapes. 

Make Equal Size 

 See “Make Equal Size Submenu” 

Stack Horizontal 

Align the selected shapes in the Shape window by moving them horizontally such that 

the left and right hand sides of adjacent shapes are aligned to each other. 

Stack Vertical 

Align the selected shapes in the Shape window by moving them vertically such that the 

top and bottom sides of adjacent shapes are aligned to each other. 

Align 

 See “Align Submenu” 

Align To Centroid 

 See “Align To Centroid Submenu” 

Arrange Submenu 

See “Arrange Submenu” 

Group 

Group together the selected shapes in the Shape window. 

Ungroup 

Ungroup any selected groups in the Shape window. 

Make Equal Size Submenu 

The Make Equal Size submenu has commands for resizing shapes drawn in the Shape 

window such that they have the same width or height as the dominant shape. The 

dominant shape is the first shape that was selected within the current selection. 
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Width 

Scales the width of all selected shapes to be equal to the width of the first selected shape. 

Height 

Scales the height of all selected shapes to be equal to the width of the first selected shape. 

Both  

Scales the width and height of all selected shapes to be equal to the width and height of 

the first selected shape. 

Align Submenu 

The Align submenu has commands for moving shapes drawn in the Shape window such 

that they are aligned to the dominant shape. The dominant shape is the first shape that 

was selected within the current selection. 

Left 

Aligns left hand sides of the selected shapes. 

Horiz. Centre 

Moves shape horizontally to align the centres of the selected shapes. 

Right  

Aligns right hand sides of the selected shapes. 

Top 

Aligns top edges of the selected shapes. 

Vert. Centre 

Moves shape vertically to align the centres of the selected shapes. 

Bottom  

Aligns bottom edges of the selected shapes. 

Align 

Align the selected shapes in the Shape window. A dialog will let you specify whether to 

align the objects to the grid or to each other and whether the align is done vertically or 

horizontally. 

Align to Centroid Submenu 

The Align to Centroid submenu moves the selected shapes in the Shape window as a 

group so that the centroid of the area of the selected shapes is aligned with the origin of 

either or both of the x and y-axes. You will usually use this command prior to installing 

the section in the Sections Library as it will make the calculation of all the sections 

properties relative to a set of axes passing through the centroid of the section. 

Centroid 

Aligns both x and y centroids to the x and y axes. 

X Axis Only 

Aligns the x centroid to the x axis 

Y Axis Only 

Aligns the y centroid to the y axis 
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Arrange Submenu 

The Arrange submenu has commands for controlling the order in which shapes are 

drawn in the Shape window. If you have the display of material patterns turned on, the 

shapes drawn last may obscure the shapes drawn first. 

Move To Front 

Move the selected shapes forward so that they are drawn last and will be in front of all 

other shapes. 

Move To Back 

Move the selected shapes backward so that they are drawn first and may be obscured by 

other shapes. 

Move Forwards 

Move the selected shapes just in front of the shapes in front of them so that they are 

drawn after those shapes and will be displayed in front of them on the screen. 

Move Backwards 

Move the selected shapes just behind the shapes behind them so that they are drawn 

before those shapes and may be obscured by them. 

Shape Menu 

The Shape menu contains commands for working with Shapes in the Shape window. 

Place Section 

Place an existing section from the Sections Library into the Shape window. You can use 

this to build up a section out of existing sections. 

Place Shape 

Place a standard structural shape in the Shape window. This provides an easy and precise 

way of automatically placing an I, C, L or T section or a rectangular or circular tube or a 

rectangular or circular bar. You can type in dimensions on a sketch of the shape to create 

it. 

Material 

Choose a material from the Sections Library to be used for the selected shapes in the 

Shape window. When the section properties for the section are calculated, these shapes 

will take their Young's Modulus and Shear Modulus from the data stored with the 

material. The pattern of the material will be displayed in the shapes that are selected 

when you use this command. 

Reference Material 

Choose the material to be used as the reference material in the calculation of section 

properties for composite sections. 

Convert to Closed Polygon 

Converts the selected shapes into closed polygons, see Converting Shapes to Polygons 

on page 43. 

Merge Polygons 

Merges the selected polygons. Open polygons will be joined if their ends are connected. 

Closed polygons will be merged if they overlap. 



Chapter 6 - Reference 

Page 98 

Validate 

Validate the geometry and topology of the shape drawn in the Shape Window. 

Add to Library 

(Ctrl I) 

Install the shapes in the Shape window as a section in the Sections Library. You do this 

to make the sections data available to Multiframe for analysis or so you can use the 

section with other shapes in Multiframe Shape Editor in the future. 

Library Menu 

The Library Menu contains commands for modifying the contents of the sections library. 

Also see the section on Working with Libraries on page 57 for more information. 

Sections 

See “Sections Submenu” 

Materials  

See “Material Submenu” 

Group Organiser 

Displays a dialog allowing you to move groups of sections from one sections library to 

another. 

Sections Submenu 

The commands in this submenu are only available if the Sections window is front most. 

Some commands in this submenu will only available if a tab displaying section 

properties window is active. 

 Select Window | Sections to bring the Sections window to the front 

 Select tab on the bottom of this window other than the Groups tab. 

 

Also see the section on Working with Sections on page 68 for more information. 

 

This submenu also contains others commands for working with groups of sections in the 

library. The commands in this submenu are may only available if the Groups tab in the 

Sections window is front most. 

 Select Window | Sections to bring the Sections window to the front 

 Select the Groups tab on the bottom of this window. 

In some cases, commands acting upon groups of may be available when the Groups 

window is not front most in which case the command may act upon the group currently 

being displayed in the window. 

  

See the section on Working with Groups on page 61 for more information.  

Add Section 

Add a section or a number of sections to the current group. The sections will be 

displayed in the current table of sections displayed in the Sections Window where you 

can type in values for the sections' names and properties. 

Reorder Sections 

Modify the order of sections within a group. 
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Delete Section 

Delete a section or a number of sections from the current group. 

Generate Tapered Sections 

Create a number of sections from two existing sections by interpolating the sections 

properties. This is useful for modelling the sections needed to simulate a tapered sections 

with a number of intermediate sections. You can use this in conjunction with the 

subdivide command in Multiframe for modelling tapered members.  

 

See Generating Tapered Sections on page 74 for more information. 

Add Sections Group 

Add a group to the Sections Library. A new group can be used to store a number of 

related sections together. You enter a name and type for the group. It will be made the 

current group displayed in the Sections Window. 

Reorder Sections Groups 

Modify the order of groups within the Sections Library. 

Delete Sections Group 

Remove a group or a number of groups from the Sections Library. 

Add Field 

Add a field to the current group in the Sections Library. A field can be used for storing 

additional properties for a section. When adding a field, you should enter the name, units 

and units factor for the field in the Groups Tables in the Add Fields dialog. 

Edit Field 

Edit the properties of fields in the current group displayed in the Sections Window.  

Reorder Fields 

Modify the order of fields within a group. 

Delete Field 

Delete a field or number of fields from the current group in the Sections Library. You 

should NOT delete any of the first eleven standard fields as Multiframe requires them for 

analysis. 

Properties 

Displays a dialog allowing you to specify the properties and name of the current group. 

Material Submenu  

The Material submenu contains commands for working with materials in the sections 

library. The commands in this submenu are only available if the Materials Window is 

front most. 

 Select Window | Library to bring the Materials window to the front 

 Select the Materials tab on the bottom of this window. 

 

Also see the section on Working with Groups of Materials 

Multiframe Shape Editor allows you to add, delete and modify the groups of materials 

stored in a sections library. 

 

In this section:  
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 Viewing Groups 

 Locking/Unlocking a Group 

 Adding a Sections Group 

 Editing a Sections Group 

 Duplicating a Group 

 Deleting a Group 

 Reordering Groups 

 

Please note that all the commands described in this section are only available when you 

have the  Materials window activated. Some of the command swill only be available 

when the Groups tab is activated within this window.  

 

Viewing Material Groups 

The groups of materials stored in the Library can be viewed and changed in the Groups 

tab within Materials Window of Multiframe Shape Editor. A list of all the groups of 

material within the library is displayed in the Groups tab within this window. 

 

To make the Groups Table visible 

 Choose Materials from the Window menu 

 Click on the Groups tab in the navigation bar at the bottom of the 

window. 

 

 

Locking/Unlocking a Group of Materials 

Groups are locked using a checkbox in the “Locked” column in the Groups tab in the 

Materials Window. To unlock a group, clear the checkbox in the “Locked” column of the 

Groups tab in the Materials window. Groups can also be locked/unlocked via the Group 

Properties dialog. 

Adding a Materials Group 

Material Maker allows you to add groups to or remove groups from the library you 

currently have open. This makes it more convenient for you to choose materials. If there 

are groups in the library you never use you could remove them or if there is a table of 

custom materials you often use you could add them in a separate group in the library. 

 

To Add a Materials Group to the Library 
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 Choose Add Materials Group from the Materials submenu under the 

Library menu 

A dialog box will appear with a field for the group's name, a table showing where key 

properties will be stored in the group, a text box for the number of fields of data to be 

stored with each material in the group and a pop-up menu to indicate the shape of 

materials in the group. 

 

 

 Type in a name for the group 

 Choose the kind of materials to be stored in this group 

If you have more than one kind of shape or the shape is not one of the standard shapes, 

leave the shape set to the Unknown Material value. 

 Click the OK button 

The group will be added to the library and will display in the Materials Window. 

Editing a Materials Group 

The properties of material groups are edited via the Group table in the Materials 

Window. To edit the properties of a material group in the current sections library 

 Click on the Group tab in the list a tabs in the bottom corner of the 

Materials Window. 

 

The name and kind can be edited directly with the table. 

 

Duplicating a Group of Materials 

To duplicate a group from the Materials Library 

 Choose Duplicate Material Group from the Materials submenu under the 

Library menu 
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A copy of the current group, including all materials contained within the group, will be 

added to the end of library and made the current group on display in the Materials 

Window. 

 

Deleting a Group 

To remove a group from the Materials Library 

 Choose Delete Material Group from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 

 

 Click on the group to be removed 

If you wish to remove more than one group, hold down the shift key while clicking on 

the names of the other groups 

 Click the OK button 

The groups selected and all the materials stored in them will be removed from the 

library. 

 

Reordering Groups 

The order in which groups appear within the materials library can be modified. To 

change the order of groups within the materials library 

 Choose Reorder Material Groups from the Materials submenu under the 

Library menu 

A list of the groups in the library will be displayed 
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 Click on the group to be moved, keeping the mouse button depressed  

 Drag the cursor to locate the new position for the group and release the 

mouse button. 

If you wish to move than one group then simply repeat the above two steps for each 

group to be moved to a new position within the library. 

 Click the OK button 

The new ordering of groups will be saved to the library. 

 

Working with Materials on page 76 for more information. 

 

Add Material 

Add a material to the Sections Library. This material will then be available for use in any 

of the sections you draw. You enter the properties for the material and can design a 

pattern to be used in shapes made from this material 

Delete Material 

Remove a material or a number of materials from the Sections Library. 

Edit Material 

Change the name, properties or pattern of a material stored in the Sections Library. 

Colours 

Change the colours associated with the materials stored in the Sections Library. 

Display Menu 

The items in the Display menu control the display of tables in the Data and Properties 

windows and the symbols in the Shape window. 

Properties  

See Properties Submenu on page 97. 

Data 

See Data Submenu on page 98. 

Library 

See Error! Reference source not found. on page 98. 
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Symbols  

See Symbols Submenu on page 98. 

Colours 

See Colours Submenu on page 99. 

Legend 

See Legend Submenu on page 99. 

Properties Submenu  

The Properties submenu contains commands for selecting the table displayed in the 

Properties Window. 

X-Y 

Display the table of section properties for the shape drawn in the Shape window. Only 

properties related to the x-y axes will be displayed in this table. 

Principal  

Display the table of section properties for the shape drawn in the Shape window. Only 

properties related to the principal axes will be displayed in this table. 

Dimensions  

Display the table of section properties for the shape drawn in the Shape window. Only 

the dimensional properties will be displayed in this table. 

Current Group  

Display the table of section properties for the shape drawn in the Shape window. The 

properties listed in this table will correspond to the fields contained within the current. 

The units used in this table will correspond to the units associated with the data in the 

current group. 

Frame Group  

Display the table of section properties for the shape drawn in the Shape window. The 

properties listed in this table will correspond to the fields contained within Multiframe’s 

Frame group.. 

All  

Display the table with all section properties for the shape drawn in the Shape window. 

Data Submenu  

The Data submenu contains commands for selecting the table displayed in the Data 

Window. 

Properties  

Display the table of section properties for each of the individual shapes that make up the 

total shape drawn in the Shape window. 

Polygons 

Display the table of polygon coordinates, material types and thicknesses for the polygons 

in the Shape window. 
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Circles 

Display the table of circle coordinates, material types and thicknesses for the circles in 

the Shape window. 

Rectangles 

Display the table of rectangle coordinates, material types and thicknesses for the 

rectangles in the Shape window. 

Symbols Submenu  

The Symbols submenu contains commands for controlling how shapes are drawn in the 

shape windows and how these shapes are labelled. 

Shape Numbers 

Turns on and off the display of the number of each shape in the Shape window. The 

number is displayed in the centre of the shape and is prefixed by a letter code for the type 

of shape, p for polygon, c for circle and r for rectangle. You can use these numbers to 

refer to the shapes in the Data window. 

Polygon Numbers 

Turns on and off the display of the number of each vertex of each polygon in the Shape 

window. You can use these numbers to refer to the polygon coordinates displayed in the 

Data window. 

Axes 

Turn on or off the display of axes in the Shape window 

Principal Axes 

Turn on or off the display of the principal axes of the section in the Shape window 

Overall Dimensions 

Turn on or off the display of the overall depth and width of the section in the Shape 

window 

Interior Dimensions 

Turn on or off the display of the minor dimension of the section drawn in the Shape 

window 

Fill Shapes 

Turn on or off the display of shapes as solid objects. When fill is turned off, the outline 

of shapes will be displayed using the current colour scheme. 

Material Patterns 

Turn on or off the display of material patterns when drawing the fill colour of the shapes 

drawn in the Shape window. 

Colours Submenu  

The Colours submenu contains commands for choosing the colours used to display 

shapes in the Shape Window. 

No Colour  

Display shapes in the Shape Window in black and white only. 
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By Material  

Display shapes in the Shape Window using a separate colour for each Material. 

By Shape  

Display shapes in the Shape Window using a separate colour for each Shape. 

By Shape Type  

Display shapes in the Shape Window using a separate colour for each type of Shape. 

Legend Submenu  

The Legend submenu contains commands for controlling the display of the legend in the 

Shape window. 

Visible 

Turn on or off the display of the legend in the Shape window. 

Top Left 

Display the legend in the top left corner of the Shape window. 

Top Right 

Display the legend in the top right corner of the Shape window. 

Bottom Left 

Display the legend in the bottom left corner of the Shape window. 

Bottom Right  

Display the legend in the bottom right corner of the Shape window. 

Title Font  

Select the font used to display the title of the legend drawn in the Shape Window. 

Font 

Select the font used to display the text of each item listed in the legend drawn in the 

Shape Window. 

Item Colours  

Select the colour of each item displayed in the legend drawn in the Shape Window. 

Window Menu 

The items in the Window menu control the display of windows in Multiframe Shape 

Editor  

Tile Horizontal 

Arranges the currently visible windows down the screen to fill the screen. 

Tile Vertical 

Arranges the currently visible windows across the screen to fill the screen. 

Arrange Icons 

Tidies up the display of window icons in the program window. 
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Drawing Layout 

Resizes the windows so that the Shape, Properties and Data windows are conveniently 

located for drawing new sections and viewing their properties. 

Shape 

Make the Shape window visible and bring it to the front. 

Data 

Make the Data window visible and bring it to the front. 

Properties 

Make the Properties window visible and bring it to the front. 

Sections 

Make the Sections Window visible and bring it to the front 

Materials 

Make the Materials Window visible and bring it to the front 

Help Menu 

The Help menu contains commands for accessing Multiframe Shape Editor's on-line help 

system. 

Multiframe Shape Editor Help 

Gives access to the Multiframe Shape Editor manuals.  

About Multiframe Shape Editor 

Displays version information for this version of Multiframe Shape Editor. 
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Appendix A - File Formats 

In appendix A: Section Library Text File Format.  

Section Library Text File Format 

When you save a sections library in text format the data is formatted according to the 

following procedure- 

 
Number of groups in the file 

 For each group 

  1 if the group is locked or 0 otherwise 

  Name of the group 

  Number of the group in the library 

  Kind of material 1 for steel, 2 for concrete, 3 for timber, 

    4 for aluminium, 0 otherwise 

  Shape of sections in the group I=1, Channel=2, Equal 

    Angle=3, Unequal Angle =4, Tee=5, Rectangular Tube =6, 

    Square Tube (SHS)=7, Circular Tube=8, Circular bar=9, 

    Rectangular bar=10 , Folded Cee=11, Folded Zed=12 

  No of sections, no of fields and no of analysis properties in the group 

  Position of the analysis properties in the fields of the group 

  For the number of fields 

    Name of the field 

  For the number of fields 

    Units of the field 

  For the number of fields 

    Factor of the field 

  For the number of sections 

    Name of the section 

    For the number of fields 

      Value of the field for this section 

 For each material 

  Name of the group 

  Number of the group in the library 

  Kind of material 1 for steel, 2 for concrete, 3 for timber, 

    4 for aluminium, 0 otherwise 

  Density of the material 

  Thermal Coefficient of the material 

  Poisson’s Ratio of the material 

  Young’s Modulus of the material 

  Shear Modulus of the material 

  Yield Stress of the material 

  Ultimate Stress of the material 

 

The easiest way to understand the format is to use the Export command to save a text file 

from a sample library and to review or modify that text file. 
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