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Interfase Co-op Module Addendum 
 
TRADEMARKS & REGISTERED PRODUCTS 

 
The following products are registered and/or trademarked to the listed companies:  
Microsoft is a registered trademark, and Internet Information Server, Internet Explorer, Windows and 
Windows NT are trademarks of Microsoft Corporation. 
Netscape is a trademark of Netscape, Inc. 
All other names are registered trademarks of their respective companies. 

 
CONVENTIONS 
 

The following conventions are used in this manual: 
CSO represents CSO Research, Inc. 
WWW represents the World Wide Web 
URLs and email addresses are printed in blue and underlined. 

 
LICENSING 

 
With your office’s signature on a new Interfase contract including the co-op module or a signature on a 
co-op module addendum to an existing contract, you are granted an annually renewable, nonexclusive, 
non transferable license to use the Interfase software. Refer to your purchase agreement for more 
details 

 
SUPPORT 

 
Every attempt has been made to make this documentation complete. If questions or problems do 
arise, you can get technical support from CSO Research, Inc. 

 
CSO Research, Inc. 
P.O. Box 340819 
Austin, TX 78734 
(866) 705-4201 (toll free); Press 1 for Support 
support@csoresearch.com 

 
 

 

(Copyright © CSO Research, Inc. ) 

 
 

 

mailto:support@csoresearch.com
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Support Information  
 
For complete information on available support services please visit  
http://www.csoresearch.com/support.  

 
There are three main options for obtaining support for Interfase. The CSO Research services team is available 
Monday through Friday from 8am to 6pm CT 

 
 LIVE CHAT: To access the Live Chat service, please visit http://www.csoresearch.com/support,   
       go to the Live Chat section and click the Live Chat button  
 

 EMAIL: support@csoresearch.com  
 

 PHONE: 1-866-705-4201 (Toll Free). Press “1” for support.  
 
 

Support Help Menu  
 
As an Administrator you will have access to the Help menu option. You will find the Help menu in the main menu of 
your Interfase system. Clicking on this menu will load the CSO Support website and display the Support 
Information. All support options are listed there for your convenience. 

 

 

 

http://www.csoresearch.com/support
http://www.csoresearch.com/support
../../Local%20Settings/Temporary%20Internet%20Files/OLK1/support@csoresearch.com
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CO-OP MODULE 
 
What is the co-op module?  
 
The co-op module is an additional Interfase component that allows administrators to manage co-op student 
timelines and any associated position information. In this addendum we will cover setting up a co-op timeline, 
as well as how to link the timeline to the employer that the student will be working for. 
 
 NOTE: Schools that use the co-op module may or may not use the placement activity tab. Information in 

the Placement tab will not be linked to information in the Co-op Records tab. 
 

STUDENT PROFILE AND ACTIVITY 
 

CO-OP INFORMATION SECTION 

 
For the co-op module, there will be a new section added to the student’s profile called the Co-op Information 
Section. This section will allow you to link the student to their co-op manager and keep track of their current 
co-op status.  
 

 
 
 
 

CO-OP RECORDS ACTIVITY TAB 

 
To view the student’s co-op timeline go to the Student Profile and click on View Activity under Page Functions 
on the left, and then click on the Co-op Records tab. 
 

  
  
  
 

The Primary and Secondary Co-op 
Manager fields will allow you to 
link a student profile directly to an 
admin profile. You will then be able 
to pull these fields into a report to 
keep track of the student’s co-op 
managers. 
 

The Co-op Status field is 
independent from the Co-op 
Records activity tab. This field can 
be used when doing uploads or if 
you have a limited access admin 
role that cannot view a student’s 
activity. Information in this field 
must be manually entered. 
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CREATING A STUDENT’S CO-OP TIMELINE AS AN ADMIN 
 

To create the student’s co-op timeline you will click on the Co-op Records tab in activity and then click on “Add 
to Timeline”. 
 

   
 
STEP ONE: Select what term the student’s co-op timeline should start in. 
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STEP TWO: Select if the student will be at work, at school, etc. until the term that they will be graduating. Then 
click the Create button. If for a specific term you do not know where the student will be you can leave it at “Do 
not create”. 
 

  
 
STEP THREE: If you know what company and job the student will have, assign this to their timeline. 
 

 
 
After clicking the assign button you will be able to search for the employer and job that the student will be 
working with and link it to their co-op timeline. 
 

  
 

Check the term 
that you want to 
start the 
assignment with 
and then click 
the Assign 
button. 
 

Work Term Number 
counts the number of 
terms the student is at 
work or at school. This 
number is 
automatically 
generated when you 
first create the co-op 
timeline. If you make 
changes or add to the 
timeline you will have 
to manually change 
these numbers as this 
is only a text field in 
the record. 
 

Enter the job 
title and/or the 
organization 
name and then 
click Search. 
 

Select if you want the job to 
be assigned to only the 
record that you selected or 
to the record you selected 
and all following records. 
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After selecting the job the system will fill in the information for the selected records and all following records if 
that option was selected. 
 

NOTE: If you select to assign the current record plus records following the information will 
automatically be added to all of the following terms. If the student changes jobs you will be able to re-
assign those terms. This also means that if a term is changed from “At School” to “At Work” it will 
already be assigned to the appropriate position. 

 

 
 

Viewing co-op record before evaluation survey is completed: 
 

 
 

NOTE: Student Surveys will not be emailed out if there is not an Employer linked to the co-op record. 
 
Viewing co-op record after evaluation survey is completed: 
 

 

The current term will 
be highlighted in red. 
 

These page functions will 
allow you to resend the 
student and/or employer 
evaluation email that 
includes the link to the 
evaluation survey. 
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STEP FOUR: Set up the Approval Work Flow. 
 
The Approval Work Flow will allow you to send the student co-op record to different approvers for them to fill 
in and approve sections of the co-op record using an external view of the record. 
 

NOTE: This step is not mandatory and can be removed if your office does not want to approve the co-
op record within the system. 

 

  
 
*If you plan to use “Other 1” or “Other 2” in your Work Flow Approval Process you will need to set up these 
roles and their permission. See the New Role Setup under the “Co-op Module Setup” section. 
 
**If you plan to use “Contact” in your Work Flow Approval Process and select to use the "Co-op Timeline 
Supervisor” you will need to set up a new role and set the permissions. See the New Role Setup under the “Co-
op Module Setup” section. 
 
After you have filled in the Approval Work Flow you can initiate it by going to the Approval Work Flow section 
under the Profile View tab and clicking the “Initiate Approval Process” link. 
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Once the approval process has been initiated the email will go out to the person in Step 1 of the Approval 
Work Flow. After the person in Step 1 approves the co-op record the email will be automatically sent to the 
person in Step 2. If one of the people decides to reject the co-op record or they miss their deadline the 
approval process will stop until an admin has resolved the issue.  
 
After the approval process has been initiated you will have the option to delete approvers, approve the co-op 
for them and re-send the email to the approver. 
 

  
 
You can keep track of where co-op records are in the Work Flow Approval process by clicking on “Co-op Work 
Flow In Progress” under Quick Links in your left nav bar. 
 

NOTE: This will only show you the status of all work flows in progress for which you are listed as the 
primary/secondary manger. 

 

 
 

This field will 
automatically change to 
“Yes” after all steps in the 
Approval Work Flow have 
been approved. 
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STEP FIVE: Upload co-op documentation file. 
 
This step is optional, but if you have any file that you would like to store with the co-op record you can upload 
it to the Documentation section. You can only upload one file to this section per co-op record. 
 

  
 

CREATING A STUDENT’S CO-OP TIMELINE AS A STUDENT 
 
A student can now initiate the co-op process using the “Report a Co-op/Intern Hire function under their left 
nav menu. 
 

  
 

Term selection defaults to current term.  If we are not in a current term, it selects the upcoming term. 
 

  
 

NOTE: This process works similar to the regular “Report a Hire” function. The student will have the 
option of selecting a job that they already referred themselves to or they can manually enter the co-op 
position. 
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Below is an example of what the student will need to fill in when they Report a Co-op/Intern Hire. 
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If a student already has a Co-op Record marked At Work for the selected Co-op Term and it is linked to an 
employer/contact/job they will receive the message below and will not be able to continue with this term 
selected. 
 

  
 
Once the student has reported their Co-op/Intern Hire it will go into your Co-op Records pending bin for 
approval. 
 

  
 

EVALUATION SURVEYS 

 
To create evaluation surveys you will need to go to Databases>Surveys. After you have created the survey you 
will need to mark that it is a Co-op survey and mark if it is for Students or Contacts. 
 

 
 
From here you can also designate an evaluation question. The answer to this question will be recorded within 
the Co-op Records activity tab in the Student Evaluation and Employer Evaluation fields. These fields can then 
be pulled into a report. 
 

If you set prompt to 
TRUE they will be 
prompted to take the 
survey when they log 
into the site. This will 
be the same link they 
receive in the email, 
so they will still only 
be able to take the 
survey once. 
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Student co-op record with completed evaluation survey: 
 

  
 

  

  
 

Once the evaluations are 
completed you will be able 
to view and edit the 
evaluations directly from the 
student’s co-op record. 
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TRACKING CO-OP REFERRALS AND HIRES 

 
We have added two management consoles under Quick Links to help you easily track the students that are 
working in a co-op position or who have had co-op referrals for this term. With these management consoles 
you will only see the information for students where you are listed as their Primary or Secondary Co-op 
Manager in the Student Profile. 
 

  
 
Co-op Referred Students: Shows referrals that have been made for any co-op job by term and optionally by 
job for employers, administrators, and/or faculty. 
 

  
 
Co-op Hired Students: Shows those students working in co-op positions by term for employers, administrators 
and/or faculty. 
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REPORTS 

 
To run reports on the Co-op Timeline you will need to go to Tools> Reports>New Report and select the report 
type of “Co-op Timeline” and click continue. On the next page you will check off all of the fields that you would 
like to see in your report. For more detailed instructions please refer to the Interfase User’s Manual. 
 

  
 
View of generated report: 
 

  
 

CO-OP MODULE SETUP 

 

CO-OP TIMELINE TERMS 

 
To add new co-op terms you will need to go to Tools>Setup>Co-op Timeline Terms. 
 

  
 

In the Co-op Timeline 
report you can pull in 
the results for the 
student/employer 
evaluation questions, 
as well as when the 
survey was started 
and completed. 
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Once you are under the Co-op Timeline Terms setup menu you will need to click “Add New” to create the new 
timeline term. This will give you a pop-up box to fill in the name of the term, date range and select which 
evaluation survey should be sent for this term. 
 

 
 
Co-op Term: 
 Description: Insert the name of the term that you are trying to create. The co-op timeline terms will 

sort by the description, so we suggest putting Year, Term. 
 Active: If you would like this term to be available when setting up a student’s co-op record please 

check the box. 
 Start Date: This is the date that the term should start. * 
 End Date: This will be the last day for this term. * 
 
* The start and end dates must be filled out prior to saving the new co-op term. 
 
Student/Employer Survey: Select the evaluation survey that you would like the students/employers to take 

for this term. You will be able to mass change these surveys for particular records if 
you have a special evaluation for specific majors. 

 Start Date: This will be the start date for the survey and it will prompt the email to be sent to the 
student/employer to notify them that the evaluation survey is ready. 

 Deadline Date: This is the last day that the student/employer will be able to take the survey. 
 Reminder Date: If you would like the student/employer to receive a reminder before the deadline date 

you will need to fill in the reminder date. 
 Reminder Interval: If you would like the student/employers to receive more than one reminder to take 

the survey you can set up the interval for how often it should be sent up until the deadline date. 
 

SYSTEM EVENT EMAIL TEMPLATES 

 
To customize the emails that are sent to students/employers about the evaluation surveys you will need to go 
to Tools>Setup>Templates. There are four templates for each the student and the employer.  Please refer to 
the Supervisor’s Manual for more information on editing and activating system event email templates. 
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The Employer – Co-op Evaluation notification and reminder emails will contain all students from that Co-op 
Term.  This means that the employer will receive one email containing a link for each student evaluation 
survey that they are linked to. 
 
EMPLOYER – Co-op Evaluation Notification and Reminder Email Setup: 
 

1. Everything except the student data needs to be in the header or footer. This includes any merge fields 
for employer or term data. 

2. The header and footer must be a section header and footer. You can create the section header and 
footer in the Word document by going to Page Layout – Breaks then select Continuous to insert a 
break. Once this is done you will notice that the header and footer say “Section 1”.  

 

REFERRAL SETTINGS 

 
To customize if existing referrals change statuses when a student is hired into a position, you will need to go to 
Tools>Setup>Settings. 
 

  
 
When these settings are in use the system will change all referral statuses with the status indicated in the 
“Status From” setting to the status indicated in the “Status To” setting automatically when one referral for 
that student is changed to have the status indicated in the “Employment Offer” setting. 
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NEW ROLE SETUP 

 
If you plan to use “Other 1”, “Other 2”, or “Co-op Timeline Supervisor” as approvers for your Work Flow 
Approval Process then you will first need to create these roles under Tools>Setup>Roles. 
 

 
 
From here you will need to type the new role into the “New Role Name” box. If you are planning to use “Other 
1” as an approver then your role name will need to be “CoopOther1Role”. If you are planning to use “Other 2” 
as an approver then you will need to create a second role for “CoopOther2Role”. If you are planning to use 
“Co-op Timeline Supervisor” under the Contact approver then you will need to create a role for 
“CoopContactSupervisorRole”. 
 
After you type in the new role name you will need to decide which existing role you want to copy. The new 
role will start with the same permissions selected as the role you copy, so will want to select the existing role 
that most closely represents what you want the “Other 1”, “Other 2”, or “CoopContactSupervisorRole” 
approver to see. Once you have selected the correct role to copy, click the “Update” button to create your 
new role. 
 

  
 
Once you have created the new roles you will need to go to Tools>Setup>Permissions to set up what part of 
the co-op record this approver should be able to see and edit. 
 
 NOTE: For more detailed instructions on how to change permissions please refer to the Interfase 

Supervisor’s Guide, which you can find by clicking on the “Help” menu when logged in as an admin. 
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