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Contact Us 

For full contact details, visit the ZyLAB website - http://www.zylab.com  

For support, visit our ZyLAB support website - http://support.zylab.com  
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About ZyINDEX 

ZyINDEX creates and manages all components of your archives that contain scanned and electronic 
information. 

Searchable archives 

The structure of a ZyINDEX archive is comparable with the index of a hard copy encyclopedia. An 
encyclopedia's index is an alphabetical list of major words and concepts with references to specific books 
and the pages on which a word or concept is located. ZyINDEX goes one step further: it records the position 
of all the words so that you can contextually search for any word or combination of words and sort the 
results in order of relevance, a concept called 'full-text search'. 

Creating archives 

ZyINDEX creates and manages archives that contain all your scanned paper documents and electronic files. 
Just point to a location (folder) in your network and ZyINDEX will index all the electronic files in this 
location. ZyINDEX supports over 700 different electronic file formats, such as Microsoft® Word, Microsoft® 
Excel, Microsoft® PowerPoint®, Adobe® PDF, Microsoft® Outlook PST files. ZyINDEX can create as many 
archives as you need for your company and each index can contain millions of scanned pages or 
Gigabytes/Terabytes of electronic information. With the ZyFIND search program, you are able to search all 
the indexed documents. 

Other functionality 

ZyINDEX can automatically update your index with new and changed documents. With the archiving 
function, information selected on the scanning date or the manual indexes can be deleted or moved to 
other archives. Information in the searchable archives can be published to any media type (CD-ROM, DVD, 
ZIP and more) so that you can easily transport, archive, copy or distribute information. One CD-ROM can 
hold up to 15,000 scanned pages plus the free ZyLAB search engine (non-commercial only). 

NTFS security can be set on indexes and documents through the file system. The optional Security Module 
goes one step further and allows you to set NTFS security through the ZyINDEX interface and set security on 
specific documents based on the manual indexes and the functionality of the ZyLAB programs. 
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Options 

The ZyINDEX Options contain the general settings for the various functions in ZyINDEX. Many of the options 
are not activated until you select its related feature button in the ZyINDEX user interface. 
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Interface Language 

Go to Options > Interface Languages... 

 

The Interface Languages selector lets you select a new language for the user interfaces in the ZyLAB 
Information Management Platform programs. You have to restart to see the new language, and the 
language is applied to all programs in the ZyLAB Information Management Platform. 
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Global Settings 

Go to Options > Global Settings... 

Global Settings has the following options: 

• Folders (page 5) 

• System Settings (page 6) 

• Services (page 7) 

4 

 



ZyINDEX Manual 

 

 

Folders 

Go to Options > Global Settings... 

The Folders tab lets you specify the paths to the various folders ZyINDEX uses to store index and processing 
data. 
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System Settings 

Go to Options > Global Settings... 

The System Settings tab lets you set the following: 

• To log every function that is being used, select Enable statistics logging. The output is saved in a .deb 
file in the /bin directory. 

• Select Recycle bin enabled to move deleted items from ZyINDEX to the recycle bin instead of removing 
them from the hard disk immediately. 

• Maximum number of files specifies the maximum number of files that can be opened in one go. 

• Analytics Server location specifies the link to the ZyLAB Analytics Server (which is part of the 
ZyLAB Analytics Bundle). This link is required for the ZyFIND Analyze function in ZyVIEW. Contact your 
System Administrator to obtain the server location. The Test Connection button verifies that there is a 
valid connection to the ZyLAB Analytics Server. 
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Services 

Go to Options > Global Settings... 

The Services tab lets you set the default addresses for TBIE indexes: 

• the connection to the indexing service and  

• the connection to the content access service.  

Normally they are hosted on localhost, but they can be hosted on another machine too. 
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TIFF Conversion Settings 

Go to Options > Tiff Conversion Settings 

The 'TIFF On The Fly Settings' are used for the TIFF Conversion feature in ZyView. The settings used will 
depend on the quality of the original file, and the quality you want the output TIFF to be. Colour settings 
and a high resolution will give the best quality but will also give the largest TIFF file, which can cause 
indexing and finding to be slower. Use settings that give a usable TIFF output. 
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Publish 

1. First, select Publish . 

2. Then, go to Options > Publish. 

The ZyPublish Control Properties options let you add new drive types and capacities to the Volume type list. 
The Location of ZySEARCH and the Location of Autorun files are also specified here. 
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Web Client 

The general options are applied to all web clients you will make. Configure these options before you create 
a web client. 

1. First, select Web Client . 

2. Then, go to Options > Web Client. 
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The options are as follows: 

• HTTP root directory 
For Microsoft Internet Information Servers this is default C:\inetpub\wwwroot 

• Directory for temporary files. 
Choose a temporary folder that every user of this computer has full-control access rights for. 

• Default index 
This is an index that will be in every web client you create. An entry here is not mandatory; you can 
choose indexes to include when you create the web client. 

• HTML Editor 
Define a HTML editor, for example Notepad.exe. 

• HTML browser 
Define the internet explorer you want to use to open your web client. By default, Microsoft Internet 
Explorer is installed in C:\Program Files\Internet Explorer\iexplore.exe. 

• Web Site 
Define the URL of your website (for example 'www.zylab.com' or a TCP/IP number such as 
'193.67.146.1'). 

• Run Web Server as 
To add security, click the 'Change' button and define how the ZyLAB Web Client should be run: 

 Define the User name, Password, and Logon domain. 

 Click OK. 

• Treat these user agents as search engines 
If you want to make your web client accessible to user agents (for example a web browser or search 
engine crawler), select the checkbox 'Treat these user agents as search engines', and click the Change 
button. 

 Define a user agent, and click the + button. 

 Repeat to add more user agents. 

 To delete a user agent, select it, and click the - button. 

 Click OK. 

For more information, see Internet Search Engine Integration (page 120). 

Click OK to save the changes. In the next dialog click Yes to confirm the changes. 
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Using the Command line 

Go to Start > Run. The Run dialog box appears, with the Command Line text box active. Type this 
information into the box to start ZyINDEX: 

Path to the shareable files, e.g.  

“d:\Program Files\ZyLAB\Information Management Platform\Bin\”  

Executable program file, e.g. 

ZyINDEX.EXE 

For the commandline options described below it is essential to follow the following format rules: 

• \ separates the executable program name from the path 

• a space must precede each of the parameters, e.g. -i and -b  

• -i is contiguous with the index name; no space is allowed 

To execute a command, click OK. 
The dialog box gives you the option of running the program minimized, a convenient way to use ZyINDEX 
while you work with ZyFIND or some other Windows® program. 

In ZyINDEX, the command line can be used to build, update and optimize indexes.  

Command line option to build an index 
 use -b to begin a ZyINDEX session in a full-size window 

 or 

 use -b0 to begin a ZyINDEX session iconized, which closes upon completion if no error occurs 

 use -i to select an index 

Command line option to update an index 
 use -u for Update! 

 or 

 use -u0 to Update! iconized 

Command line option to optimize an index 
 use -o to Optimize! 

 or 

 use -o0 to Optimize! iconized.  

You can also use the parameter -StartTimer, this option will start ZyINDEX with TIMER running. This may be 
part of your Windows start menu if you have a dedicated machine running ZyINDEX. 

The parameters, -b, -u, and -o are mutually exclusive. ZyINDEX responds to the first one 
in the command, and ignores any others, if present. 
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In ZyINDEX, indexes can be created, erased and deleted from the command line. 

Command line option to create a new index 

ZyINDEX.exe  -c  

-name[short index name, long index name]  

-n[noise word list]  

-com[commandfile name]  

-s[settings file] ...for create 

Command line option to delete index 

ZyINDEX.exe  -d  

-name[short index name] ...for delete 

Command line option to erase an index 

ZyINDEX.exe  -e  

-i[<short index name>] ...for erase 

For example: "C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyINDEX.exe" -e -
i[<archivexx>] 

There are no warnings on delete and erase! 

In ZyINDEX, webclients can be created and deleted from the command line.  

Command line option to create a new web client 

-CreateClient[arguments] 

arguments 

All arguments are obligatory 

1. Client's long name 

2. Client's short name (http alias) 

3. Client's root directory 

4. Client's email address 

5. Client's language 

6. Client's index path 

If any white space occurs within one of these arguments, the argument has to be quoted. For example: 

-CreateClient["Test Client", "Test", "C:\inetpub\wwwroot\Test" ,"webmaster@zylab.nl" , "English", 
"C:\ZyLAB Data\Indexes\Test"] 
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Command line option to delete a new web client 

-DeleteClient[<client’s short name(http alias)>] 

In ZyINDEX, indexes can be added to TIMER. 

Command line option to add an index to TIMER 

-x[<shortindexname>;"<indexpath>";<datetime>;1;1;1;0;0] 

Command line option to remove an index from TIMER 

-y[<shortindexname>] 
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Build 

Prepare the index 

Prepare documents for full-text retrieval 

Make all your documents accessible. To make your documents accessible, you have to archive them. 
Archive your documents, using ZyINDEX and ZySCAN. During archiving, your documents are formatted 
(prepared for full-text retrieval). This allows you to search and find your documents. 

When preparing documents for full-text retrieval, follow the steps below: 

1. Create an index 
See Create a standard index or Create an advanced index. 

2. Create a job template 

3. Scan and/or Import 

4. Add fields (optional) 

5. OCR (optional) 

6. Export 

7. Build the index 

One or more steps (of steps 3 to 6) may be fully automated once you have defined the settings in a job 
template in ZySCAN.  
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Create a standard index 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Go to File > New. 
 

 
3. Enter a Short name (max. 8 characters). 

4. Enter a descriptive Long name (max. 80 characters). Use the name to describe the contents of the 
index. 

5. Click OK. 

Result 

You have created a standard index. 

Important 

Once saved, the short Short index name cannot be changed! 
To change the Long Index Name, see Change the Long Index Name (page 72). 
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Create an advanced index 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Go to File > New. 
 

 
3. Enter a Short name (max. 8 characters). 

4. Enter a descriptive Long name (max. 80 characters). Use the name to describe the contents of the 
index. 

5. Select Index Wizard. 

6. Click OK. 

Result 

Step 1: Locations and language (page 18) of the Index Wizard appears. 
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Step 1: Locations and language 

Conditions 

You are creating an advanced index. Step 1 (Locations and language) of the Index Wizard is open. 

 

Instructions 

1. Choose between the (old) HAPI or the (new) TBIE search engine. When you choose the TBIE search 
engine, you have to define the connection to the indexing service and the content access service. 
Normally they are hosted on localhost, but they can be hosted on another machine too. 

2. In 'Index directory' you can change the location (Index directory) where you want to store the index. 
Click the Browse button to select a new location. Put the index on a shared network drive if you want 
to share the index with others. 

3. Specify whether new data folders have to be created for each year, month, week, day or guid (Globally 
Unique IDentifier). This allows you to physically separate data per time frame or identifier. 
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4. Choose the language for your 'Noise Word List'. Noise words are frequently occurring words with little 
relevance when searching an index (for example 'and', 'the', 'to', 'in', etc.). Select the language of the 
majority of the documents that will be in your index. If necessary, you can combine word list languages 
to cope with multi-language indexes (Edit noise words and character map (page 73)). 

5. If necessary you can change the Index's 'Long name'. This is the name you gave to the Index in the 
'Create new index dialog' (Create an advanced index (page 17)).  

6. If you want your Index to be backward compatible select 'Use Windows code page' then select the 
language you want to use. Note the following: 

- The Index can only be in one language. 

- The Index size is limited to 10GB. 

It is recommended not to use this option. 

7. Click Next. 

Result 

You have completed step 1. Step 2 (Modules) of the Index Wizard appears.  
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Step 2: Modules 

Conditions 

You are creating an advanced index. Step 2 (Modules) of the Index Wizard is open. 

 

Instructions 

1. If necessary, select a module and transfer it to the right panel using the arrow .  

2. If you want to de-select a module select it and transfer it to the left panel using the arrow . 

3. Click Next. 

Result 

You have completed step 2. Step 3 (Data folders) appears. 
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Note 
• The XML Wrapper allows you to add fields to electronic documents of any format. For more 

information, see the ZySCAN manual > Add fields to electronic documents. 
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Step 3: Data folders 

Conditions 

You are creating an advanced index. Step 3 (Data folders) of the Index Wizard is open. 

 

Instructions 

1. Specify the location of the Data folders. 

Data folders are the (txt, tiff, electronic and xml) folders where the scanned, imported or electronic 
data is stored. These folders are automatically created each time an index is built. Place the data on a 
shared network drive if you want the data to be accessible for different users. 

 If you want to be able to easily move your data collection (without indexing it again), select the 
checkbox 'Index files relative to the standard data folder'. Via Index Settings > Data folders you can 
define a new standard data folder location. Related files do not need to be updated, which saves 
you time. 
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Note: If the standard data folder is changed, the XML index must inherit the same settings. Do this 
by opening the main index in ZyINDEX and closing it without building it. 

or 

2. Drag and drop your data to the custom data folders. 

1. Click Edit. The Custom data folders window appears. 

2. Drag and drop files to the ZySCAN Text Files tab, the ZySCAN Tiff Files tab or the Other Electronic 
Files tab as follows: 

- Drag and drop individual files from Windows Explorer to one of the tabs (it is not important which 
tab). The files are automatically placed in the correct folder (Text, Tiff and Other). 

- Open a specific tab, and drag and drop a folder from Windows Explorer to that tab. Only the files 
permitted in that tab are added; other files types in the folder are NOT added to the other tabs; you 
must add the folder to those tabs if you want to index the folder's files. 

3. Click the Excluded Filetypes tab. Use the right mouse button to add file types to the exclude list. 
Files types that are on the list will be skipped during indexing and therefore will not be searchable. 

4. If you want to delete an item or folder you added to a tab select it, right click on your mouse, then 
select Delete. 

5. Click OK to return to the Wizard. 

3. If you want to separate files that give an error during indexing select "Copy files that have index errors". 
Specify a "Destination directory" to store these files. After indexing you can check these files to 
determine the reason that an error occurred. 

4. Click Next. 

Result 

You have completed step 3. Step 4 (Settings) appears. 
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Step 4: Settings 

Conditions 

You are creating an advanced index. Step 4 (Settings) of the Index Wizard is open. 

 

Instructions 

Choose between settings. You can choose from: 
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• Fuzzy search (recommended) 
Allows you to execute fuzzy searches after indexing. 

• Reverse search (recommended) 
Allows you to execute searches with wild cards at the beginning of your search query after indexing. 

• Hyperlinks (recommended)  
Allows you to create hyperlinks between (parts of) documents after indexing (in ZyFIND). 

• Add new documents to the Table of Contents  
All new documents will be placed in a "New" folder in the Table of Contents. You can define a name for 
the Table Of Contents folder for new documents. 

 If you select the option 'Add new documents to the Table Of Contents', you can also select the 
option to 'Disable creation of subfolders'. Use this option if you have an index with fields with the 
option 'Add new documents to TOC folders specified in field value' selected (Step 5: Define fields 
(page 27)), and you do not want to use slashes, semicolons or commas to create subfolders. 

 You can choose the option 'Use path of document in the file system' if you want to add documents 
to the Table of Contents using the file path. Define the number of folders that should be removed 
from the root. Do this if you do not want to include the whole path, but only the path from a 
certain root folder. 

 You can choose to 'Exclude tiff files', from being added to the Table of Contents. 

• Audit 
Allows you to keep track of user actions. 

• Quick build enabled (recommended) 
Allows you to use Quick build when building the index. Only files that are marked new, changed or 
deleted are indexed. 

• Export electronic document properties to xml wrapper 
During indexing, document properties of any new or modified electronic document that can be 
extracted by Inso will be copied into an XML wrapper if an XML wrapper field definition is found with a 
matching field ID (start delimiter without brackets).  
Note: Whenever the index is erased and indexed this process will be repeated, therefore it is advised to 
define these fields as read only fields. 

• Secure delete enabled 
The 'Secure delete enabled' option allows you to savely sweep files from your hard disk, when they are 
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deleted. With this option selected, files will be shredded (or 'scrubbed' according to the DoD 5220.22-
M standard) so they cannot be undeleted. 

• Append electronic document properties at end of indexed text (recommended) 
Extracts the document properties and adds them to the end of the indexed text so a search will also 
include these properties. 

If you want to index (large) indexes which may cause problems (for example with corrupt files or 
unrecognizable file formats), select the Advanced button. 

 
 'Index PDF files with Adobe Acrobat/Reader' allows you to index PDF files with Adobe 

Acrobat/Reader during indexing. All standard PDF properties will be extracted, and will be indexed 
along with the content. PDF-file names (including points, etc.) will not be indexed. 

 'Index MSG attachments (requires MAPI)' allows you to index mail messages and attachments 
during indexing. Both will be searchable after indexing. MAPI (Message Application Programming 
Interface) is part of Microsoft Outlook. 

 'Index compressed files' allows you to index documents stored in compressed (ZIP) files. Password-
protected ZIP files cannot be indexed but will be logged. 

 'Try to index non recognised file format as ASCII' allows you to index files that cannot be opened, 
select the option 'Index non recognised file format as ASCII' (via ZyINDEX > Options > Global 
Settings > Index preferences). 

 Define the maximum number of files to be processed in each index session. 

 Define the maximum size of the token spill file. 
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Step 5: Define fields 

Conditions 

You are creating an advanced index. Step 5 (Define fields) of the Index Wizard is open. 

 

Instructions 
1. Click Define. 

The Field definitions window appears. 

2. Click Add definition. 
The New Field Definition window appears. 
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3. Enter the Name of the field. 

A field name may not contain spaces. Spaces are automatically replaced with an underscore. 

4. It is advised to keep the Id (delimiter) identical to the Name. However, you can change it. 

Use the Id (delimiter) to define a search query. Query syntax:  
<delimiter> to "/<delimiter>" {} 
 
For example: 
name to "/name" {john} will return all documents with the value john in the name field 
name to "/name" {*} will return all documents with values in the name field 
name to "/name" {} will return all documents with empty values in the name field 
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5. Select a Type from the dropdown list. For information about the different field types see the Glossary > 
Field types. 

6. Select the Storage & Index tab. 
 

 
7. If you selected the XML Wrapper in Step 2: Modules, Store field in XML Wrapper is selected by default. 

You can also store in database fields, document, document catalog, workflow or audit. Whether a 
storage option is available depends on the index configuration. 

 Define if the field should be full text searchable. If so, you can search the contents (field value) of 
the field. 

 Define if the field value should be synchronized with internal field storage of index at build. 

For information on Additional options, see the Note below. 

8. Click OK.  

9. Click OK. 
You are in the Create new index wizard (Step 5:Define fields) dialog again. 
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10. If you want to define Sort options for the Web Client, click Define. 

The Define sort options dialog appears. 

 Click Add to define a new sort option. 

 Enter a name. For example (if you want to sort the results ascending on the send date) SendDate 
(Asc). 

 Click Enter. 

 Click the Edit button. 

 Select one or more of the available fields and move with the arrow to the Selected fields. 
You can move the selected fields up or down. 

 Select a selected field and click Edit. 

 Choose the Sort direction (Ascending or Descending). 

 If you want to sort words with numbers naturally, select the checkbox 'Use natural sort'.  
This will result in the following order:  
 
Picture1.jpg 
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Picture2.jpg 
Picture3.jpg 
Picture4.jpg 
Picture5.jpg 
Picture6.jpg 
Picture7.jpg 
Picture8.jpg 
Picture9.jpg 
Picture10.jpg 
Picture11.jpg 
Picture12.jpg 
 
Instead of: 
 
Picture1.jpg 
Picture10.jpg 
Picture11.jpg 
Picture12.jpg 
Picture2.jpg 
Etc. 

 Click OK. 

 Click OK. 
The Sort option will be added to the Web Client. 

11. If you want to select a datasource that contains a table with records that can be synchronized with 
fields in text documents that are indexed, select Synchronize fields. Click Browse to select a datasource.  
Enabling this option will activate the database synchronization frame in the field definition dialog. 
For more information, see Synchronize fields and database records with ODBC (page 33). 

12. If required, click Modify to select which email properties (of emails in a .pst email archive) should be 
included (extracted and indexed) as fields. 

13. If you want to connect your index to a database click Wizard. For full details about using the database 
wizard see Database Settings Wizard (page 37). 

14. Click Next. 

Result 

You have completed step 5. Step 6 (Security) appears. 

Note 
• For more information about adding fields/values, see the ZySCAN manual > Add fields. 

• The Primary field (Storage & Index tab) is related to ODBC synchronization. The Primary field checkbox 
is disabled when an existing field definition is being edited. The option is only enabled for new field 
definitions. This is to protect the user from promoting an existing field to a primary key while duplicate 
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values might exist in the repository, which would introduce a corrupt primary key and cause 
unpredictable behaviour.  

• Obtain as document property from electronic file (Storage & Index tab) means that in case you give in 
the same field definition as the document properties in this electronic file the content of this file will be 
put in the files of ZyFIELD. 

• Add new documents to TOC folder specified in field value (Storage & Index tab) means that all new 
documents with this field definition will be put in an upfront created folder with this field definition in 
the table of contents. If you want to use this option, make sure that the index setting "add new 
documents to the Table Of Contents" is selected (see Step 4: Settings (page 24)). 
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Synchronize fields and database records with ODBC 

Database synchronization can be used in advanced installations to synchronize key fields of documents in a 
ZyINDEX archive and field information in a database. Database synchronization has been implemented to 
enable the import and export of document field values from and to a table in a database that supports 
ODBC (see ZyLAB Information Management Platform > Glossary). 

The record in a table of the database can be linked to the ZyINDEX document by selecting a primary 
keyfield in the field definitions of the index. Depending on the value of the primary keyfield in the 
document the correct record is selected in the database table from which other field values may be read 
and put in a document field, or alternatively to which an existing field value may be saved. This exchange of 
field values is called synchronization.  

Note that synchronization only occurs when ZyINDEX is indexing the index for either new files or files that 
have changed. No synchronization will occur for database records that have changed while the document 
has remained unchanged. 

To make sure that the values of the linked fields match, we advise using barcodes that correspond with the 
documents during scanning. Recognizing the barcodes during scanning is very reliable and it is easy to print 
barcodes from a database. 

The procedure to process the documents has to be the following: 

• Enter the information for the document in the database. Print a Barcode containing the value of the 
primary key field on a label and stick the label on the first page of the document. Alternatively you may 
print the barcode on a white page that can be used as a front page and as a patch page when scanning 
the paper documents. 

• Scan the document. 

• Build the index. Now the key field info is copied from the database to the corresponding document. 

• When the document information within the database changes the key field information within the 
document will be automatically updated during the next index update. 

The following steps implement this operation: 

• Create a (system) data source (DSN) in the control panel of your system for the database (e.g. Access 
database) that you want to synchronize fields with. It is recommended to make a system data source 
because a user data source can only be used on the machine where it is created and is only visible to 
the one who created it. 

• In WIN2000 you have to add the type of database via Control panel > Administrative tools > Data 
sources (ODBC) > tab System DSN, and add to choose the right type of database. In Windows NT the 
Data sources (ODBC) can be found right under the control panel. 

• Below is an example for an ODBC set-up for Microsoft Access. A name and description for the coupling 
have to be made. With Database > select, one can connect with a database. 
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• Now we have made a connection to the database via a data source. If we hook this data source up to 

an index the database and ZyINDEX are connected to each other. 

• First an index has to be made. In order to get the fields synchronized check the synchronize fields box 
and select the appropriate DSN (the data source you just created) and the table of the database you 
want to synchronize with. This function can be found in step 5 of the Index Wizard (Create an advanced 
index (page 17)). 
 
Note: You can only select one table in the data source per index. 

• Select Define Fields and views to define a field and specify (in the ODBC tab of the New Field Definition 
dialog) whether it should be synchronized with the data source of the index. Note that this section of a 
field definition is not enabled if no data source is selected. 
 

 
• At least one field should be selected as primary keyfield that links the ZyINDEX document to a unique 

record in the database so that other fields may either be written to or read from the database at 
indexing time. The other fields have to be synchronized by selecting regular fields. 

• In order to synchronize the fields from the database and ZyINDEX the name of the field in the database 
must be entered in the 'Database field name' field in the ODBC tab of the New Field Definition dialog. In 
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case there are fields in the database or in ZyINDEX that you don’t want to synchronize choose do not 
synchronize. 

• The indexing process triggers the synchronization. Only if a document is changed, its fields will be 
synchronized with a record in the database that matches the primary keyfield. Synchronization will 
store all fields that are write-type to the database and will read all fields that are read-type. 

Working like this will save you a lot of time typing all this data from the database into the fields of ZyINDEX. 
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Field Definition Option: Use for visualization 

 

ZyINDEX > Build > Define Fields > Define > Add definition > Client tab 

The option 'Use for visualization' enables you to refine your search results by filtering on the content of the 
field (see Refine Your Results). For the Single-select list field, the Multi-select list field and the Logical field, 
'Use for visualization' is a default option.  

Once the 'Use for visualization' checkbox is selected, you can define the Value separator (the default value 
is a comma). The defined delimiter will be used for dynamic filtering (Refine your Results), including the 
Star Tree and Tree Map. It is recommended to use punctuation characters. If the value separator is empty, 
the field value will not be split. A value separator can include, start or end with one or more space 
characters. 

Notes 
• When editing fields, still a comma will be used to split or combine field values. 

• In eDiscovery the Value separator is particularly useful. For example, in Microsoft Outlook fields with 
email addresses are split with a semicolon (;). These fields should be linked to a ZyINDEX field with a 
semicolon as the Value separator. 
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Database Settings Wizard 

Conditions 

You want to connect a ZyLAB index to a database to access/manage data stored in that database. With the 
Database Settings Wizard you will be able to define all the settings needed to establish a connection 
between ZyINDEX and the database. 

Instructions 
1. Create an advanced index to Step 5: Define fields (page 27) (see Create an advanced index (page 17)). 

2. To define the database connection, in Step 5 click the Wizard button. 
 

 
3. The ZyLAB Database Settings Wizard appears. 

The wizard allows you to connect ZyINDEX to ADO in order to access/manage data through an OLE DB 
Provider, ODBC or native provider. The ZyLAB Ado.xml file enables the link between the ZyLAB 
index(es) and the type of database that is being used. 
 

  
4. Click Next. 

5. Choose a type of database engine, the software component that is used to create, retrieve, update and 
delete data from a database. 
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Choose from: 

 MS Access 97 

 MS Access 2000 

 MS SQL Server 

 PostgreSQL 

 Oracle 

 MySQL 

6. Click Next. 

7. If you selected the Database Fields module in Step 2: Modules (page 20), select a Database Fields 
scenario from the dropdown listbox. 
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Fields are listed in the Fields.txt file of the index, which can be found at \\ZyLAB Data\Indexes\[index 
name]\FIELDS 
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 Double click on the chosen Database Fields scenario. 

 Double click on a table. 
 

 
 The Fields for the table appear. 

 

 
 Double click on a cell to change it.  

It is possible to change the names of the fields, only the name and path fields (or guid) can not 
change because of the database connection.  
 
The values of the Id fields are used for the database values and for the fields.txt. 

 To save and close, click OK. 
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 Click Close. 

8. If you do not want to use the existing tables, select the checkbox Drop Existing Tables. 

9. Click Next. 

10. Before you can create a connection to a database, a database needs to be created.   
 

 
11. First, the connection method of ZyINDEX with the database needs to be defined. For this, the 

Connection String needs to be constructed. 

 Click the Construct button. 
The Construct Connection string dialog appears. 
 

 
 
Define the connection method and choose one of the three following methods:  
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 Provider 
If you want to connect to the database using OLE DB as the connetion method, select an OLE DB 
Provider from the dropdown listbox.  

 Dsn 
If you want to connect to the database using ODBC as the connection method, select a Data Source 
Name (DSN) from the dropdown listbox.  
 
A DSN is a data structure that contains the information about a specific database that an Open 
Database Connectivity (ODBC) driver needs in order to connect to it. It is created beforehand via 
the ODBC Data Source Administrator program. Included in the DSN is information such as the name, 
directory and driver of the database, and, depending on the type of DSN, the ID and password of 
the user. 

 SQLServer 
If you want to connect to the database using SQL Server as the connection method, select an 
SQLServer from the dropdown listbox. Click on the Retrieve Remote SQLServers button to collect all 
available servers. 

 Click OK. 

12. Select a script to create a database. Choose from: 

 Toc_DP_MySQL.sql 
This script will generate a Table of Contents DP? database (including folders and items). 

 Toc_DP_Oracle.sql 
This script will generate a Table of Contents DP? database for Oracle (including folders and items). 

 Toc_DP_SQLServer.sql 

 Toc_MySQL.sql 
This script will generate a Table of Contents database (including folders and items). 

 Toc_Oracle.sql 

 Toc_SQLServer.sql 

 Workflow Management_SQLServer.sql 

 DatabaseFields.sql (if the module Database Fields was selected in Step 2: Modules (page 20)) 

 DatabaseFields_GUID.xml 

 DatabaseFields.xml 

 DatabaseFields_PrimaryField.xml 

 DatabaseFields_HapiDocId.xml 

 DatabaseFields_AnalyticsServer.xml 

13. Define a Username and Password. This user is allowed to change the database and the tables within 
the database. 
 
or 
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Select (if you selected MS SQL Server as the databaser provider) the checkbox Windows Authentication. 

14. Databasename 
Define the name of the database. 

15. Select the database that should be used. Choose from: 

 Use existing 

 Create new 

 Create new and drop old 

16. The option "Use double quotes" is selected by default. This will minimize the risk of failure when 
generating the database. 

17. Click Generate. 
The database is generated.  

18. Click Next. 

19. The Connection String you defined is copied. You only have to define a separate Username and 
Password. This user is allowed to view and change data in the tables. 

20. Click Test Connection. 
If the connection is not correct, try using other settings. 

21. Click Next. 

22. To retrieve data from the database, select the correct SQL Dialect. As a rule of thumb, select a dialect 
that corresponds with the chosen database engine. 

23. Click Next. 

24. Click Save. 

25. Click Finish. 

26. Click Next. 

27. Define Step 6: Security (page 45). 

28. Click Finish. 

Result 

You have created an index. Also, you defined the database settings and created an ado.xml file that will 
create a link between the ZyLAB index and the database. 

Note 

Run this wizard during the creation of an index. The connection can only be made if the Database Fields 
module has just been added. If you want to create a new connection (to another database or other fields), 
the module must be removed and added again. Then, you need to run the wizard again to create the 
connection. 
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Linking to ZyLAB Analytics Server 

When ZyLAB Analytics Server is installed (part of ZyLAB Analytics Bundle) you can analyze single documents 
opened in ZyVIEW using ZyLAB Analytics Server (see ZyFIND > Working With Documents > Analyze with 
ZyLAB Analytics Server. 

Conditions 

When you want to use the Analysis Dialog button in ZyView (see ZyFIND > Working With Documents > 
Analyze with ZyLAB Analytics Server) you must use the Database Settings Wizard (page 37) to link your 
index to a database with a specific fields scenario. 

Instructions 

1. Create an Advanced Index with Database Fields and XML Wrapper modules (Create an advanced index 
(page 17)), then follow the steps for the database wizard (Database Settings Wizard (page 37)) until the 
Module Fields screen. 

2. In the database wizard's Module Fields screen select the DatabaseFields_AnalyticsServer.xml and the 
TocFieldBindings.xml scenarios from the drop-down lists. 

3. Continue with the Database Settings Wizard (page 37). 

Result 

You have created an index from which documents can be analyzed directly in ZyView using ZyLAB Analytics 
Server. 
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Step 6: Security 

Conditions 

You are creating an advanced index. Step 6 (Security) of the Index Wizard is open. 

 

Instructions 
1. Select a role in the right hand corner of the dialog. 

To change the settings of the roles, go to ZyINDEX > Security. 

2. Select a user or user group from the available users and groups on the left.  

3. Click on the arrow to the right: . The user or user group inherits the settings (permissions) of the 
selected role. 

4. By default, 'Inherit from roles' is selected. The inherited user group is grayed out. If the 'Inherit from 
ZyLAB roles' option is deselected, the inherited user group turns black. Now you are able to delete it. 
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Inherited user groups are used to automatically add default users to your index, which makes the 
creation of new indexes much faster, and adds security.  

5. Click Finish. 

Result 

You have completed step 6. The index is created. Use this index to store your data (Build the index (page 
61)). 
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Forensic Investigation Index 

The Forensic Investigation index template allows users to index information more quickly as some of the 
search functions for the indexed data are disabled. Search options such as fuzzy search and reverse search 
are disabled, which will increase the indexing speed. PDF files are indexed using the standard filters and not 
with Adobe Reader (Acrobat). The Unicode version of this index template allows larger sets of indexed files 
and uses Unicode, allowing you to index different character sets in one index. 

The settings shown below are for an index created with the Forensic Investigation template. As you can 
see, only two options are selected. 
The option 'Index compressed files' in Advanced Index Settings allows you to index documents of 
compressed (ZIP) files. Password protected ZIP files cannot be indexed, but will be logged. 
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Taxonomy Field Index 

A taxonomy enables you to classify and manage your documents, based on hierarchical structures. An 
existing taxonomy may be linked to a ZyINDEX index, ensuring faster and more precise access to relevant 
information. The classification values will be part of the document, stored as field values belonging to the 
field Taxonomy. This enables dynamic structuring of information, which saves storage space and enhances 
search capabilities. 

Instructions 
1. First, create a Taxonomy index. Open ZyINDEX > Build. 

2. Go to File > New. 

3. Fill out a Short name (max. 8 characters). 

4. Fill out a Long name (max. 80 characters). Describe the contents of the index in more detail. 

5. Select Taxonomy Field Index. 

6. Click OK.  
You have created an index with a Taxonomy facet field, which is linked to a taxonomy.  

7. Click Define Fields . 

8. Select the Taxonomy field. 

9. Click Edit definition.  

10. To replace the Value file name (the taxonomy), click Browse. 

11. Fill out the new File name. 

12. Click Select. 

13. Click OK twice.  

14. Add documents to your index and build it. 

15. Open ZyFIND, and the index you just created. 

16. Search your documents. 

17. Add (taxonomy) field values via ZyRESULT or ZyVIEW. Select the Taxonomy field and use the Taxonomy 
Browser (displayed below the Taxonomy field) to make a selection. To make multiple selections, press 
Alt and select as many selections as you like. Click Save Multiple Selections.  

18. Go to ZyINDEX and build the index. 

Result 

You created a Taxonomy index, added documents and (taxonomy) field values. Now, you can search the 
index. Either in ZyFIND > Fields, or via a Web Client.  
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Concepts & Field Extractor 

It is possible to extract document properties, file system, concept, language and/or field information from 
documents while indexing. This information is added as Xmlfields (C:\Program Files\ZyLAB\Index 
Data\'Short Index Name'\XmlFields). 

Instructions 
1. Create a HAPI index with XML Wrapper.  

2. Go to the Index Settings and select the Data Extractors tab. 

3. Select Concept, Document properties, File System and/or Field Extractor. 

Concepts are (complex) search statements with a name. For example, the concept 'Legal' may be 
defined as 'lawyer OR justice OR rechtsanwald OR advocaat OR court'. So, you will extract information 
(and place it in fields) based on queries. 
 
Document properties is information attached to a document with meta information. For example, 'Last 
Saved By', 'Word Count', 'Status'. 
 
File system is information defining a document on the system. For example, 'File name' or 'Date 
created'. 
 
Field Extractor extracts information from documents based on a start and end delimiter. The delimiters 
can be anything. 

4. If you want to control storage space and maintenance, select the option Exclude TIFF files. Properties of 
TIFF files will be filtered, preventing the creation of fields for non-existing or non-relevant properties. 

5. Define the Extract mode (only new/modified or all documents). 

6. Click Apply. 

7. If you selected Concept, select the Concept tab. 

 Browse for a Concepts file (to create a new one, see Create Concepts File (page 51). Or, to use the 
example concepts file, browse to \\Program Files\ZyLAB\Information Management 
Platform\Extractors\Concepts). Make sure that the fields defined in the Concepts file are defined in 
the index. 

 Click Apply. 

8. If you selected Document properties, select the Document Properties tab. 

 Define the maximum number of fields (document properties) allowed to be extracted. This is 
recommended if you are working with large document sets with many different formats. 

 Click Apply. 

Only document properties that are defined in the documents and listed (Document Comment, 
Keyword, Last Saved By, Author, Subject, Title, Abstract, Account, Address, Attachments, Authorization, 
Backup Date, Bill To, Blind Copy, Carbon Copy, Category, Checked By, Client, Completed Date, Character 
Count, Page Count, Word Count, Creation Date, Department, Destination, Disposition, Division, 
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Document Type, Minutes Edited, Editor, Forward To, Group, Language, Last Print Date, Mail Stop, 
Matter, Office, Operator, Owner, Project, Publisher, Purpose, Received From, Recorded By, Recorded 
Date, Reference, Revision Date, Revision Notes, Revision Number, Secondary Author, Section, Security, 
Source, Status, Typist, Version Date, Version Notes, Base File Location and Version Number) are 
extracted.  

9. If you selected File System, select the File System tab. 

 Select the system file properties you want to extract. For example, File name and Date created. 

 Click Apply. 

10. If you selected Field Extractor,  

 Create key fields, with Module field XML Wrapper, first. 

 Select the Field Extractor tab. 

 Browse for the correct Field Extractor file. This is an XML file. To create one, see Create Field 
Extractor File (page 53). 

 Click Open. 

 Click Apply. 

XML and HTML files must be indexed using the indexing format ANSI-Nowrap instead of 
AutoSenseINSO. Otherwise, the delimiters in the files will not be indexed and therefore cannot be used 
to extract field information. 

Select the custom data folders icon . In the ZySCAN Text Files tab, select the *.xml folder, and 
double click in the right hand pane on Format. Select from the dropdown listbox the ANSI NoWrap 
value, and click OK. 

11. Click OK. 

Result 

You defined an index with XML Wrapper and defined the data you want to extract while indexing. 

Now, you can add documents to your index, and build it. Remember to select the option 'Extract data' 
before clicking GO. 
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Create Concepts File 

Conditions 

You have created a HAPI index with XML Wrapper, and selected Concept as the Data Extractor.  

Instructions 

1. Select the Concepts icon . 

2. Go to File > New. 

3. Select New File and click the right mouse button. 

4. Select New. 
The New concept dialog appears. 
 

 
5. Define the name of the concept (for example, Possible Suspects).  

6. Click the Index button. Select an index with XML Wrapper and Concepts selected as the Data Extractor. 

7. Click OK. 

8. Select a field from the dropdown list box. A successful search executed with the concept Possible 
Suspects, will be placed in the Suspect field. 

If the selected field is a list field (with a number of defined list field values), it is possible to Generate a 
concept entry for each list field value. This means that several searches can be executed which will be 
placed in the selected field. 

9. Click OK. 

You can create as many concepts to a XML concepts file as you like. 

10. Click Add. 

11. Define the ID, the value and the query. 
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For example, value "John Doe" is added to the field Suspect if the query "John Doe OR John Dune OR 
Joe Doe OR Joe Dune" was successful. 

12. Click OK. 

You can add as many concept entries to a concept as you like. 

13. Select New file. 

14. Click the right mouse button. 

15. Click Save. 

16. Define a name for the XML Concepts file, for example Investigation. 

17. Click Save. 

Result 

You have created a new Concept file. 
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Create Field Extractor File 

Conditions 

You have created a HAPI index with XML Wrapper and key fields, and selected Field Extractor as the Data 
Extractor.  

Instructions 
1. Select the Field Extractor icon. 

2. Go to File > New. 

3. Select New File. 

4. Click the Add button. 
The New Field dialog appears. 

5. Define the Field name. 

6. Select the Index button. 

7. Select the index with XML Wrapper and key fields you just created. 

8. Click OK. 

9. Select a key field from the dropdown listbox. 

10. Define the start and the end delimiter of the selected key field. These delimiters may but do not need 
to be bounded by brackets. 

11. Click OK. 

If you want to add more fields, repeat step 4 to 11. 

If you want to edit/delete a field, select the correct field and click the appropriate button. 

12. Select New file. 

13. Click the right mouse button. 

14. Click Save. 

15. Define a name and location for the Field Extractor Xml file. 

16. Click Save. 

Result 

You have created a new Field Extractor file. 
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Reuse an index (template) 

Using index templates saves time as all the fields and . You can create your own templates (based on 
existing indexes - see Create an index template (page 57)), or you can choose one of the following basic 
templates (see Create an index based on a template (page 59)). 
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Index Series templates 

Index Series templates are used to automatically create new indexes in the same series when the current 
index reaches a cutoff limit set by a time interval or the index size. The index series can later be searched as 
a single index. For the Index Series Template to function you must add the index to the Timer. 

Instructions 
1. Go to ZyINDEX. 

2. Open an index. 

3. Go to Build > Save as template. The Save index as template window opens. 

 
4. Enter a Name for the Index Series template. 

5. Check the Save as index series checkbox.  

6. Select to cutoff the active index using either Time or Size: 

 Time creates a new index in the series in periods of Weeks, Months or Years. You set the interval 
between index creation using Count. A new index in a series is then created at that interval from 
the date the template was created. Choose the period that best suits your situation. 

 Size creates a new index when the current index in the series reaches the set limit. Set the limit in 
Mb to the size that best suits the capability of your system and the performance of the index. 
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7. Enter the path for the index data store: 

 Data root is the UNC path name when the index is accessed by other users over a network. 
Accessing a UNC path name is slower than using a mapped drive, so if there are no users over a 
network leave this blank. 

 Local data root is the mapped path name for the index on the PC where it is stored. 

8. Click OK to save the template. 

A new sub-folder is created in the index's data folder.  

9. Add the Index to the Timer (Set up Timer Service (see "Set-up Timer Service" page 208)). 

When the cutoff limit is reached a new sub-folder is created for the subsequent new index in the series. 

Result 

The index is converted to a series template, and the Timer Service is activated to create new indexes in the 
series according to the cutoff rules. 

56 

 



ZyINDEX Manual 

 

 

Create an index template 

Conditions 

ZyINDEX is open. 

Instructions 
1. Go to File > Open. 

2. Select the index you want to reuse. 

3. Click OK. 

4. Go to Build > Save as template. The Save as template dialog appears: 
 

 
5. Give the template a name. 

6. Select, if necessary, one or more of the following options: 

 Save table of contents 
Saves the table of contents made for the existing index in ZyFIND. 

 Save command script 
Saves the locations where the existing index was built over. 

 Save module settings 
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 Save as index series 
Index Series templates are used to automatically create new indexes in the same series when the 
current index reaches a cutoff limit set by a time interval or the index size. The index series can later 
be searched as a single index. For the Index Series Template to function you must add the index to 
the Timer. See Index Series templates (page 55) for instructions. 

Result 

You have created an index template. 
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Create an index based on a template 

ZyINDEX in installed with some standard templates. These are: 

• Audit Trail database 
Contains Audit Trail module, link to Audit Trail database, and all relevant fields (see About Audit Trail 
(page 189) for more details). 

• eDiscovery 
Contains all fields necessary for storing document information necessary for the eDiscovery process. 

• Email Archive 
Contains all fields necessary for storing information about emails and their attachments. 

• Exchange Connector 
This is an index series based on Email Archive, and specific Exchange Connector fields. 

• Forensic Investigation 

• Legal Review 
Contains all fields necessary for the legal review process. 

• Redaction 
Contains a Redaction field (linked to Redaction.xml value file with Exemption codes) and XML Wrapper. 

• Taxonomy Field index 
Has an XML Wrapper and two XML Wrapper fields of the Taxonomy facet field type. Both fields are 
linked to a value file (see Taxonomy Field Index (page 48) for more details). 

• Workflow Archive 
Workflow module, customized short description, and TOC view (see the ZyLAB Workflow manual for 
more details) 

Conditions 

ZyINDEX is open. 
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Instructions 

1. Click the BUILD icon: . 

2. Go to File > New. 
 

 
3. Enter a Short name (max. 8 characters). 

4. Enter a descriptive Long name (max. 80 characters). Use the name to describe the contents of the 
index. 

5. Select a template from the "Create index using" list. 

6. Click OK. 

Result 

You have created an index based on a template. 
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Build the index 

Conditions 

An index is created. The (electronic, scanned and/or imported) documents are stored in the data folders. 

Refer to the ZySCAN manual for information on scanning documents and adding them to an index, and to 
the relevant Review Guides for information about adding data folders to an index. 

Instructions 

1. Open ZyINDEX. 

2. Click the Build icon: . 

3. Go to File > Open. 

4. Select the index you want to build. 

5. Click OK. 

6. Click the Now button  to display Build dialog: 
 

 
7. Select one or more of the following options: 

 Add new documents from file system to index 
Adds all new documents to the index, whether directly from the file system or from a ZyLAB 
program. 

 Quick build (to select, deselect all the other options first). 
Quick build only indexes documents that have been added or changed by a ZyLAB program. All 
other documents are skipped. 

 Update: Check presence of files in index on file system 
Checks the contents of you index with the source files in a file system and updates where 
necessary. 
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 Optimize index 
Removes empty entries from the index to compact it. 

 Extract Data 
Extracts document properties metadata from files to store in fields. 

 Generate report database 

8. Click Go. 

9. Wait for the index to build. You can monitor the indexing status at the bottom of the ZyINDEX window. 
Click OK. 

To stop indexing, click the stop button: . 

Stop: Abort indexing and discard the temporary index file. 
Merge: Combine the temporary index file with the current index, without processing any more files. 
The current file is still indexed. 
Continue: Complete indexing. 

Result 

The index is built. You can now search for information using ZyFIND, ZySEARCH or the ZyLAB Web Client. 

Add, Quick build, Update, Optimize and/or Extract Data? 

Add 
• To build a new index 

• To add all new documents 

• To update existing documents 

The Add option uses the date to check if documents are new or updated. All documents are checked. 

Quick build 

Use Quick Build to quickly index documents that are marked new, changed or deleted. All other documents 
are skipped. 

Marked documents are known to ZyINDEX, even before indexing starts, because they have an entry in the 
database. These references to the documents are created when they are exported to the index data 
directories with ZySCAN or when they are imported to the index data folder with the ZyINDEX import 
directory. Since only marked documents are indexed and all other documents are skipped, the indexing 
process is accelerated.  

You can only use Quick Build if a link to the index is present. Also, check if 'Quick build enabled'' is selected 
(ZyINDEX > Index Settings > Settings). 
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Update 
• To index moved source documents 

• To delete selected documents from the index 

Optimize 

To optimize index storage space and search speed. Use this option to maintain the index after large 
changes. 

Extract Data 

To extract document properties, file system, concept, language and/or field information from documents 
while indexing.  

Save time 

If building indexes is taking too much time reduce the number of 
Update and Optimize actions. If existing index documents are not 
changed or deleted and only new documents are added to your index 
then doing a frequent Add action will be sufficient to update the 
index. 

Indexing large unknown data sets 

If you are indexing large unknown data sets (for example a hard drive 
of a confiscated PC), raise the number of recognizable file extensions 
via ZyINDEX > Options > Global Settings > Index wizard. For more 
information, see Power User Manual > Advanced Indexing > Indexing 
recovery/problem files. 

View Log File 
1. Go to View > Log File. 

2. Select an index. 

3. Click Open index. 

4. View the Log File. 
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Technical implications 

ZyINDEX reads designated sets of text files and records the following information about every content word 
within each file: 

• name of each file in which a given word appears 

• location of each word, relative to other words in the file 

The index stores names and dates of graphics-only files in these formats: TIFF, PCX and BMP, so that you 
can make file name and date searches. During processing ZyINDEX ignores bitmapped graphic objects 
embedded in a text file. 

When ZyINDEX encounters a new content word, it adds the word to a set of files called the dictionary. 
The location files store information about content word position. The term index refers to a directory 
holding dictionary, location and other files which were were made while creating an index. 

Limitation 

Buffer overruns can be caused by long (>256) folder/file paths.  
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Maintain the index 

After you have created indexes, you may want to change them. You might want to remove, erase or delete 
an index. Or, you might want to change the index settings, including the Long Index Name. 

65 

 



ZyINDEX Manual 

 

 

Remove, erase or delete an index 

You can choose from three options to clean up your data: 

• Remove 
The index is removed from the list of indexes. The data will remain on the system. You can add the 
index again, if you want to (File > Open. File > Add index). Removing an index may be helpful in case 
you have many indexes you don't use, but are not prepared to throw away. Also, less indexes makes it 
easier to find the right one. Moving indexes to categories also makes them easier to find. See Create 
and edit categories. 

• Erase 
Only the vocabulary of the index will be erased. All index settings (keys fields, Table of Contents, 
Concepts, etc.) will remain available. The next time you build an index, you can use the same index 
definition. Erase your index if you get many unresolved links, or if you want to clean up your index. 
Also, erase and rebuild your index, if the index has been corrupted (for example, due to an system 
crash during indexing). 

All files within the index directory (except files within the Text and Tiff directories), will be erased. Files 
that are not expected within this directory, will also be erased from the system! 

• Delete 
All index files (including thesaurus, character sets and noise words) and the index directory (including 
files that are not index related), will be deleted. Deleting your index means that the index definition, as 
well as the contents of the index, are deleted. This is done when the index is not needed anymore. 
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Remove an index 

Conditions 

ZyINDEX is open. 

Instructions 
1. Go to File > Delete. 

 
or 
 

Click the Delete button:  
The Index Management dialog appears. 
 

 

2. Click the Remove from index list button: . 

3. Click Close. 

4. Click Yes. 

Result 

The index is removed from the index list. 
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Erase an index 

Conditions 

ZyINDEX is open. 

Instructions 
1. Go to File > Delete. 

 
or 
 

Click the Delete button:  
The Index Management dialog appears. 
 

 
2. Select an index. 

3. Click the Erase button: . 

 Click Yes. 

 Click OK. 

 Click Close. 

Result 

The index is erased. 
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Delete an index 

Conditions 

ZyINDEX is open. 

Instructions 
1. Go to File > Delete. 

 
or 
 

Click the Delete button:  
The Index Management dialog appears. 
 

 
2. Select an index. 

3. Click the Delete selected index button: . 

4. Click Yes. 

5. Click OK. 

6. Click Close. 

Result 

The index is deleted. 
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Change the index settings 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Open an index. 

3. Select the Index Settings button: . 

4. Change one or more settings.  

5. Click OK. 

Result 

You have changed one or more settings of the index. 

 

Note 

Use the remaining buttons to directly change  

• the list of noise words  
Noise words are frequently occurring words, with little meaning. You would not search for this words. 
These words are not added to the index. Noise words are, for example, prepositions (to, in, of), 
conjunctions (and, or, but), articles (the, an), pronouns (she, he, they), and certain common verbs 
(come, see, take). All other words are content words (tokens). You search on content words. 
Change the list of noise words before files are added to the index.  

• the character set (charset)  
The character set determines how words are separated, which characters are indexed, which ones are 
used for punctuation, etc.  

• the field definitions (Define fields)  
You can change the field definitions. For more information, see the ZySCAN manual > Add fields. 

• the email properties  
You can identify which email fields of messages in a .pst email archive, should be extracted and indexed 
as key fields. 

• the custom data folders  
You can start the old (v4) interface of ZyINDEX. This enables you to change the locations of the data 
folders like you did in v4. All created indexes will be stored in the index list. In earlier versions the 
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format of this file was .lst, now an .XML file is created as well.  
Edit the excluded file types 

a) Click the Custom data folder button. 

b) Start Explorer. 

c) Go to the directory with the data folders. 

d) Drag and drop the folder(s) with OCRed files to the ZySCAN Text files tab. Text is taken from the 
contents of your files to form a comment. From your image-text files the first 1,024 characters of 
the file are taken. 

e) Drag and drop the folder(s) with TIFF files to the ZySCAN TIFF Files tab. Your TIFF files are 
automatically formatted to autosense. The comment for all your image-TIFF files is standard the 
word image. 

f) Drag and drop the folder(s) with your electronic files to the Other Electronic Files tab. For these 
electronic files the text format is automatically set to autosense and the comment taken from your 
files is the first 1.024 characters of your digital file. 

Comments, formats and keys can be edited by double clicking on these words. Changing of the 
comment mode can be handy in case it is necessary that no comment be shown in the result list of 
ZyFIND. 

g) The Excluded Filetypes tab shows all files (extensions) that should be excluded. You can always 
change the automatic file formats, and customize them to your wishes. Keep in mind that formats 
must be identified before indexing, otherwise the lines will be shifted and the synchronization 
between the hits on the image, the hits in the text, and the location of the hyperlinks won’t agree.  
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Change the Long Index Name 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Open an index. 

3. Select the Index Settings button: . 

4. Select the Locations and language tab. 
 

 
5. Define a new Long name. 

6. Click OK. 

Result 

The Long Index Name is changed. 

 

72 

 



ZyINDEX Manual 

 

 

Edit noise words and character map 

Noise words 

Noise words are frequently occurring words, with little meaning. You would not search for this words. 
These words are not added to the index. Noise words are, for example, prepositions (to, in, of), 
conjunctions (and, or, but), articles (the, an), pronouns (she, he, they), and certain common verbs (come, 
see, take). All other words are content words (tokens). You search on content words. 

Edit noise words 

Change the list of noise words before files are added to the index. 

1. Select Edit noise words . 
The noise words list is opened in Notepad. 

2. Add or remove words. 

3. Save. 

In case you have an archive containing two different languages it is possible to combine the noise words 
of these two languages. This will save hard disk space. Words that are used as operators in search 
queries can be removed but it is still not possible to search on them. In case there are some words you 
don’t want users to be able to search on: add them to the noise word list. The other way around is also 
possible of course. 

The noise word list is stored in the index and has a .NOI extension. 

Character set 

The character set determines how words are separated, which characters are indexed, which ones are used 
for punctuation, etc. All possible characters that can be recognized and searched on can be found in the 
character set. 

Edit the character map 

Character sets and Windows Code Pages 
The most common character set is the American Standard Code for Information Interchange (ASCII) which 
describes 256 characters, punctuation including old style signals such as the bell signal etc. However, after 
the fast internationalization of the computer there became a need to customize these codes for certain 
languages containing accented characters. Most accented characters used in western-European languages 
are coded in the standard ASCII set. However, languages with entirely different character sets, for example 
Russian and Arabic, or some Latin based languages with very rare accents, i.e. Serbia, are not present in the 
standard ASCII table. To facilitate such international character sets Microsoft has introduced the concept 
of code pages in Windows. Basic concept of the codepage is that it represents every one of its 256 
characters with a single byte. Examples of code pages in Windows are: 
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• Code page 1252: Windows Latin-1 

• Code page 1251: Windows Cyrillic 

For example, the Windows Latin-1 character set consists of the standard US ASCII 7-bit set containing 128 
characters: 

 

And the next 128 characters are specific to the Windows Latin-1 character set: 

 

The Index Character Map 
ZyINDEX can index text in any code page. However, depending on the code page, some characters should 
be ignored, or two different characters should be treated as the same character or should be indexed but 
treated in some special way because they are at the end of a sentence, i.e. period, exclamation mark etc. 
These settings are stored in the index character map specifying two properties for every one of the 256 
characters in the code page: 

• Should it be mapped to another character? 

• What type of processing is needed for the character? 

Character Mapping 
The character set shows the different types of processing that are used for the characters. The character 
mapping can be different for different languages. Typically, indexes are made case insensitive by mapping 
all upper case characters to their lower case variants. Thus A is mapped on a, B on b etc. Furthermore, a 
user searching an English index probably does not want to distinguish accented characters such 
as À, Á, Â, Ã, Ä and Å. All these characters will be mapped to a. For instance in the Swedish language these 
characters have different mapping numbers.  
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Type of processing 
Five different types of character processing can be distinguished: 

• Token 

• Hyphen 

• Punctuation 

• Apostrophe 

• Unused 

Token processing 
In a typical character map all normal letters of the alphabet and all numbers are processed 
as tokens. Token processing is normal Build-an-Index processing. After processing is complete, any 
string made up of characters receiving token processing can be the subject of a search. In other 
words, tokenized characters make up the words you search for. Certain other characters, while 
considered part of the Token set, require special processing. 

Hyphen processing 
Hyphen is the minus sign and is used as a connector in case a word at the end of a line continues at 
the next line. Such a word is stored four times in the index: as the word before the hyphen, as the 
word after the hyphen, as the word connected with the hyphen and as the complete word without 
the hyphen. For example, hard-disk will be searchable as hard, disk, harddisk and hard-disk. 
 
In case you have a set of hyphens in a row, it is possible that the Index engine doesn’t understand it 
any more and will give a too many tokens error. This may happen for instance in cases with low 
quality images causing the OCR engine in ZySCAN to produce many hyphens. (Note that this can be 
prevented by selecting the prevent punctuation option in the scan template). 

Punctuation processing 
Build uses punctuation processing for characters trailing a word, for example example: !, #, $, %, &, 
*, +,  , , ., /, :, ;, =, ?, @. Build strips these characters during processing so that they do not 
interfere with searches. For example, a name J.R.Ewing will be searchable as jrewing. 
 
Note that ( ) and < > are not typical punctuation characters.  

Apostrophe processing 
When words contain a normally occurring apostrophe, for example, she’s or they’re or O’Brien, 
Build uses apostrophe processing. The word appears to ZyINDEX as if they are not present 

Unused characters are characters we cannot search on. 

The file with the character set can be found in the index directory and has a .CHR extension. The file that 
controls the actual mapping of characters on another character is the .EN3 file. 
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XML Wrapper in the index 

In order to generate a universal key field structure over all your scanned paper and electronic file formats, 
ZyLAB designed the XML Wrapper. This XML Wrapper will connect all your electronic files such as text, XML, 
MS Word, MS Excel, PDF, WAV, MPG, etc. to an XML file that contains the key field information of this file. 
In this way, you can give all your electronic files the same key field structure as your scanned paper 
documents. 
The XML Wrapper module will generate for every document that is stored in the ZyLAB Archive an XML file 
when manual indexes are created for this document. In addition, the XML Wrapper contains three types of 
data extraction options: File name extraction, Document property extraction and Concept extraction 
(see Data Extractors (page 93)). 

Internet/Intranet 

A new upload function is added to the ZyLAB Webserver to enable you to add electronic files to your 
archive over the Internet. The upload function starts a dialogue in which you can add your manual indexes 
and save these in an XML file together with the electronic file in your archive. For more information, see 
Upload Electronic Files. 

Batch processing 

To increase the flexibility of this solution, the ZyLAB software comes with a special program, 
ZyINDEXimport.exe. This program adds electronic files immediately to the archive and can include manual 
indexing data as well. This manual indexing data must be stored as an XML file and the ZyINDEXimport.exe 
file will convert this information into the archive where it is used as a manual index. The ZyINDEXimport.exe 
can be used with command line options, so you can use this program from within your own program to 
store information in the ZyLAB Archive. This makes it possible to easily integrate the ZyLAB software with 
numerous applications. Indexes that contain the XML wrapper module work in close harmony with the 
ZyINDEXimport functionality. 

 

76 

 



ZyINDEX Manual 

 

 

Create an XML index 

Instructions 
1. Open ZyINDEX. 

2. Select the Build icon. 

3. Go to File > New. 

4. Fill out a Short Index Name (max. 8 characters).  

5. Fill out a Long Index Name (max. 80 characters). Describe the contents of the index in more detail.  

6. Select Index Wizard. 

7. Click OK. 

8. Click Next. 

9. Select the XML Wrapper and use the arrow to the right to select the module. 

10. Click Next until Finish. 

11. Click the Define Fields button . 

12. Click Add Definition. 

13. Enter a field Name, for example Title. 

14. Select the Index tab. Select Module field and choose the XML Wrapper 

15. Click OK. 

16. You can repeat steps 13 to 15 for all the fields you want to create. 

17. Click OK. 

18. Click Now (blue triangle) to build your index. 

19. Click Go. 

20. Click OK. 

Result 

You created an XML index, and added some fields. 

Structure of an index that contains an XML Wrapper 

The structure of an index that contains the XML wrapper module differs slightly from a ‘normal’ index. An 
extra folder called ZxpPlugin is created in the index folder. In this folder two extra folders are created, 
named PluginGuid and XMLFields, the latter contains the index that makes the XML tags with the field 
values full-text searchable. The XML files itself are stored in the Index data > "Short Index Name" > 
XMLFields folder. The first contains a database that keeps record of which XML files belong to which 
documents. 

When you build the index that contains the XML wrapper, not only the data stored in the index will be 
made searchable, but the XMLindex will be build as well. So you will be able to search on the field 
information as well. 
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Note: It is possible that you import documents that already have information stored in a XML file that 
contains information about the document. For the field definitions in the index use the definitions from the 
XML files that are connected to the documents that have to be imported. 
An example of the fields used in an XML file is: 

<field id="identification">testvalue</field> 

In this xml line, “identification” is a field that has to be in the index (if you want to be able to search on it 
later). This means that the start and end delimiter have to have the same value (<identification> and 
</identification>). 

It will also be possible to work with ‘friendly fields’ instead of the sometimes rather technical or 
incomprehensible field definitions form the XML fields. That is why it is made possible to create field 
definitions that have other values then the start and end delimiters of the fields. These delimiters still have 
the same field values in the XML files. (In this example this HTML tag is called ‘identification’.) 
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Create a New Job Template 

Instructions 
1. Open ZySCAN. 

2. Click New Job. 

3. Click Template Wizard. 

4. Select Define new job template. 

5. Click Next. 

6. Select External Link. 

7. Click Select. 

8. Select your XML index. 

9. Click OK. 

10. Click Next. 

11. Select ZyIMPORT. 

12. Click Next. 

13. Browse for a location to import from. For example, C:\Program Files\ZyLAB\Information Management 
Platform\Examples\Import\Multipage TIFF 

14. Select a filter. For example, the Multipage Import Filter. 

15. Click Next. 

16. Click Next. 

17. Click Next. 

18. Select "Export to default data directory and modules of the index". 

19. Select the Export method: XML/TIFF Export. 

20. Click Next. 

21. Select Save as job template. 

22. Enter a Template Name. 

23. Click Finish. 

Result 

You created a new job template. 
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Importing Electronic Files with Corresponding XML File 

With the help of ZySCAN, electronic documents together with a corresponding XML file can be imported 
and stored directly in the index (the names of the document and the XML file have to be the same). In 
order to achieve this you have to create a job template that has the correct settings for importing these 
documents. 

Instructions 
1. Open ZySCAN. 

2. Click New Job. 

3. Click Template Wizard. 

4. Select Define new job template. 

5. Click Next. 

6. Select External Link. 

7. Click Select. 

8. Select your XML index. 

9. Click OK. 

10. Click Next. 

11. Select ZyIMPORT and ZyFIELD. 

12. Select "Exclude ZyFIELD from workflow", since all necessary field values are already defined in the XML 
file. 

13. Click Next. 

14. Browse for a location to import from. 

15. Select the Electronic Import Filter. 

16. Click Next. 

17. Click Next. 

18. Click Next. 

19. Select "Export to default data directory and modules of the index". 

20. Select the Export method: XML/TIFF Export. 

21. Click Next. 

22. Select Save as job template. 

23. Enter a Template Name. 

24. Click Finish. 

Result 

You created a job template that has the correct settings for importing electronic files with corresponding 
XML file. Run this job to process your electronic files. 
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Process your Paper Documents 

Instructions 
1. ZySCAN is open. 

2. Select New Job. 

3. Select the correct template. 

4. Click Import. 

5. Close the job. 

Result 

Your documents have been processed. Check the XML files that are generated by the importfilter. If the 
import filter finished this job, then you can find a few XML files in the XMLFields folder in the index data 
directory of the index. 

When there were three fields present in the imported XML file, the XML file ZyFIND uses for searching the 
index will look like this: 

<?xml version="1.0" encoding="UTF-16" standalone="no"?> 

<zylab> 

    <document version="1.1"> 

  <fields> 

   <field id="identification">myname</field> 

   <field id="date">20021029</field> 

   <field id="test">sometestdata</field> 

  </fields>      

    </document> 

</zylab> 

Note 

To import and process a complete directory in one go, one can use the ‘ZySCAN NT service’ or the ‘run 
unattended’ options. For more information, see the ZySCAN manual > (Semi-)automatic job processing. 
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Move/Copy or Upload Electronic Files 

With the ZyINDEXImport command line utility one can move or copy files to a data directory of a 
designated index or upload them to an index via a website. Users do not have to know where the data 
locations are. They just point to a file they want to upload to a specific index, give in some field values and 
the files will be uploaded to the index. 

You can also design shortcuts with which one can point in explorer to one or more files and send them to 
the default index data directory. Other possibilities are to design shortcuts on which one can drag and drop 
files to move them to the default index data directory. One can even place those shortcuts in the "Send to" 
directory. 

For more information on these possibilities, see Archiving with ZyINDEX Import (page 83). 
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Archiving with ZyINDEX Import 

Conditions 

Before you can move or copy files to a local/network index, you have to create an index in ZyINDEX. Before 
you can upload files to an inter/intranet index, you have to create a Web Client in ZyINDEX which links to 
one or more indexes . If you want to add field(values) to files you are importing, the index needs to be 
created with xml wrapper. Refer to the ZyLAB Information Management Platform manual for detailed 
information about these features. Also, in this index, fieldnames need to be defined. Then, when files are 
moved/copied or uploaded to the index, fieldvalues can be added.  

Instructions 

You can run ZyINDEX Import (and add arguments) via Start > Run, or you can work with ZyINDEX Import as 
follows: 

1. Create a shortcut of ZyINDEX Import. 

2. Place the shortcut anywhere you want (in Windows Explorer, on your desktop, in the "SendTo" 
directory (C:\Documents and Settings\user\SendTo)). 

3. Add arguments to the Target box (to archive the files in the preferred way). 

4. Click OK. 

5. Archive files: 

 Double click on the shortcut 

 Drag and drop folders ((with) files) to the shortcut 

 Select a file, click the right mouse button, select Send to > Shortcut to ZyINDEXImport.exe 
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List of arguments 

Move or copy files to local/network index 

-i Index directory or xml file with index list 
(formatted like the standard index.xml) 

-f Files or directories 

-m Move files instead of copy. Files will be removed 
when copied successfully, but the directories (in 
which they were saved) will not be. 

-r Recurse directories 

Advanced options 

-q Add files to the QuickBuild table only (which 
enables Quick Build in ZyINDEX). Files are not 
moved or copied, so only local/network indexes 
can be selected.  

-z Unzip zipfiles directly into indexdata directory 
structure. (Zip files are NOT extracted anymore 
as stated in previous versions. The future of this 
feature is not yet determined.) 
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Upload files to an inter/intranet index 

-h Hostname 

-n Long name of index 

-c Long name of webclient 

-f Files or directories 

-m Move file instead of copy 

-r Recurse directories 

-u Username 

-p Password 

-a Advanced security with the ZyLAB Security 
model instead of ISS 

Advanced options 

-l Complete http location of ZyNET, but without 
specified webclient and index, which allows you 
to add functionality. 

 

Adding fields to one or more files 

-v Field name and value to set with the file(s) 

-x Specifies a xml file which contains fields for the 
file(s) 

-o Shows the field editor to add fields manually 

 

More options 

-s Message boxes will not be displayed. 

-d Enables logging of ZyINDEXImport.exe. For more 
information on logging, see Logging. 

-z Extracts zipfiles directly to index data directory 
structure. Used in combination with -f to locate 
the zip file. 
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Examples 

To explain the different arguments and the combinations in which they can be used, a number of examples 
are given below.   

Tip 
• To keep an overview of what you're doing, type your arguments in Wordpad (or a similar program) first, 

then copy & paste the whole command line.  

Examples 
• Copy files from your local folder to your local index, and leave the local copy: 

 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYINDEX"  

• Move files from your local folder to your local index: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYINDEX" -m 

• Move files (including the ones in subdirectories) from your local folder to your local index: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYINDEX" -m -r 

• Move files from your local folder to your local index, and automatically add a fieldvalue (field(names) 
are already defined): 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYXML" -m -v 
"Fieldname=Fieldvalue" 
 
Note: When multiple files are moved, the fieldvalues will automatically be set for every file. 

• Move files from your local folder to your local index, and manually add a fieldvalue (field(names) are 
already defined): 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYXML" -m -o 

• Add (not move or copy) files from your local folder to your local index. The files are only added to the 
Quick Build tabel (which allows Quick Build in ZyINDEX), and not to the index data directory: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYINDEX" -q 

• Copy (extract) (zip)files from your local folder to your local index: 
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"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -i "C:\ZyLAB Data\Indexes\MYINDEX" -z 

• Upload (copy) files from your local folder to an inter/intranet index, and leave the local copy: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -h "localhost" -c "WebClientName" -n "LongIndexName" 

• Upload (copy) files from your local folder to a inter/intranet index, leave the local copy and add 
functionality: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -l "http://ServerName/SharedIndex" -c "WebClientName" -n 
"LongIndexName" 
 
Note: The complete http location enables you to add functionality. For example, https://localhost/etc. 

• Upload (copy) files from your local folder to an inter/intranet index, leave the local copy, and 
automatically add a fieldvalue: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder" -h "localhost" -c "WebClientName" -n "LongIndexName" -v 
"Fieldname=Fieldvalue" 

• Upload (copy) files from your local folder to an inter/intranet index, leave the local copy, and 
automatically add fieldvalues (which are derived from a xml file): 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -f "C:\Documents 
and Settings\User\Desktop\MyFolder\" -h "localhost" -c "WebClientName" -n "LongIndexName" -v 
"Fieldname=Fieldvalue" -x "C:\Documents and Settings\User\Desktop\xml fields" 

• Upload (move) files from your local folder to an inter/intranet index and add security: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -m -f 
"C:\Documents and Settings\User\Desktop\MyFolder" -h "localhost" -c "WebClientName" -n 
"LongIndexName" -u "username" -p "PassWord01" 

• Upload (move) files from your local folder to an inter/intranet index and add advanced security: 
 
"C:\Program Files\ZyLAB\Information Management Platform\Bin\ZyIndexImport.exe" -m -f 
"C:\Documents and Settings\User\Desktop\MyFolder" -h "localhost" -c "WebClientName" -n 
"LongIndexName" -u "username" -p "PassWord01" -a 
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Logging 

If you encounter problems while archiving with ZyIndexImport, you can add -d to your command line. This 
enables logging of ZyIndexImport.exe. The logfile 'ZyIndexImport.log' is written to the temporary folder as 
specified in the 'TEMP' environment variable. When multiple instances of ZyIndexImport are running, the 
log is written simultaniously and is not locked. Loss of logging information is possible. Also, each new time 
you're logging, old logging information will be lost. You can use -d for both local/network indexes, and 
inter/intranet indexes.  

Contact us for more information. 
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Define field(names) 

Create an index (and define field(names)) 

When creating an index with xml wrapper (using the Index Wizard), define a plain text field as follows: 

1. In Step 5: Define Fields, click Define. 

2. Click Add Definition. 

3. Fill out a Name. 

4. Select the Index tab. 

5. Select Module field > XML Wrapper. 

6. Click OK twice. 

7. Continue with the Index Wizard. 

Edit an index (to define field(names)) 

To edit an index, open it in ZyINDEX (File > Open), then click the Index Settings button: . Select the 
Define fields tab and click Define. Follow step 2 - 6 above. 
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XML file with Fieldnames and -values 

<?xml version="1.0" standalone="no" ?> 
<zylab> 
 <document version="1.1"> 
  <fields> 
   <field id="FieldName1">Value1</field> 
   <field id="FieldName2">Value2</field> 
   <field id="FieldName3">Value3</field> 
  </fields> 
 </document> 
</zylab> 
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Archiving Documents from Applications 

Archiving documents from applications will be possible as well. For instance mail messages can be stored in 
the index via Outlook. After installation an extra button called archive messages in Outlook appears with 
which you can archive important mail. Select the messages you want to store in the index and press this 
button. A copy of the file is made and will be stored in the index. 
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Index Folder Structure 

Index data folders 

The index data folders are automatically made when an index is created. The locations of the index data are 
physically separated from the locations where the indexes are stored. The folder with the index data 
contains 4 folders: electronic, tif, txt and XML. 

The folders are there to store the documents processed with ZySCAN (txt, tif, xml) or the documents that 
are stored directly in the index with the ZyINDEXImport. 

When you create a XMLFields plugin index an extra folder (XMLFields) is created. In this folder the XML 
wrappers that contain the field information are stored. 

Indexes folder 

In the indexes folder an extra ZxpPlugins folder is created when an index with a module/plug-in is created.  

The content of the ZxpPlugin folder depends of the selected module/plug-in.  

In this folder the index for the module/plug-in is stored. An extra index for a module/plug-in is made if they 
work with XML tags. These XML tags have to be made searchable as well. In order to accomplish this an 
index in the index will be created.   

The templates folder within the indexes folder stores the indexes that can be used as a template. A 
template is created when you open index, go to build in the menu and select the save as template option. 

92 

 



ZyINDEX Manual 

 

 

Data Extractors 

It is possible to extract document properties, file system, concept, language and/or field information from 
documents while indexing. This information is added as Xmlfields (C:\Program Files\ZyLAB\Index 
Data\'Short Index Name'\XmlFields). 

Instructions 
1. Create an index with XML Wrapper.  

2. Go to the Index Settings and select the Data Extractors tab. 

3. Select Concept, Document properties, File System and/or Field Extractor. 

Concepts are (complex) search statements with a name. For example, the concept 'Legal' may be 
defined as 'lawyer OR justice OR rechtsanwald OR advocaat OR court'. So, you will extract information 
(and place it in fields) based on queries. 

Document properties is information attached to a document with meta information. For example, 'Last 
Saved By', 'Word Count', 'Status'. 

File system is information defining a document on the system. For example, 'File name' or 'Date 
created'. 

Field Extractor extracts information from documents based on a start and end delimiter. The delimiters 
can be anything. 

4. If you want to control storage space and maintenance, select the option Exclude TIFF files. Properties of 
TIFF files will be filtered, preventing the creation of fields for non-existing or non-relevant properties. 

5. Define the Extract mode (only new/modified or all documents). 

6. Click Apply. 

7. If you selected Concept, select the Concept tab. 

 Browse for a Concepts file (to create a new one, see Create Concepts File (page 51). Or, to use the 
example concepts file, browse to \\Program Files\ZyLAB\Information Management 
Platform\Extractors\Concepts). Make sure that the fields defined in the Concepts file are defined in 
the index. 

 Click Apply. 

8. If you selected Document properties, select the Document Properties tab. 

 Define the maximum number of fields (document properties) allowed to be extracted. This is 
recommended if you are working with large document sets with many different formats. 

 Click Apply. 

Only document properties that are defined in the documents and listed (Document Comment, 
Keyword, Last Saved By, Author, Subject, Title, Abstract, Account, Address, Attachments, Authorization, 
Backup Date, Bill To, Blind Copy, Carbon Copy, Category, Checked By, Client, Completed Date, Character 
Count, Page Count, Word Count, Creation Date, Department, Destination, Disposition, Division, 
Document Type, Minutes Edited, Editor, Forward To, Group, Language, Last Print Date, Mail Stop, 
Matter, Office, Operator, Owner, Project, Publisher, Purpose, Received From, Recorded By, Recorded 
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Date, Reference, Revision Date, Revision Notes, Revision Number, Secondary Author, Section, Security, 
Source, Status, Typist, Version Date, Version Notes, Base File Location and Version Number) are 
extracted.  

9. If you selected File System, select the File System tab. 

 Select the system file properties you want to extract. For example, File name and Date created. 

 Click Apply. 

10. If you selected Field Extractor,  

 Create key fields, with Module field XML Wrapper, first. 

 Select the Field Extractor tab. 

 Browse for the correct Field Extractor file. This is an XML file. To create one, see Create Field 
Extractor File (page 53). 

 Click Open. 

 Click Apply. 

XML and HTML files must be indexed using the indexing format ANSI-Nowrap instead of 
AutoSenseINSO. Otherwise, the delimiters in the files will not be indexed and therefore cannot be used 
to extract field information.  

Select the custom data folders icon . In the ZySCAN Text Files tab, select the *.xml folder, and 
double click in the right hand pane on Format. Select from the dropdown listbox the ANSI NoWrap 
value, and click OK. 

11. Click OK. 

Result 

You defined an index with XML Wrapper and defined the data you want to extract while indexing. 

Now, you can add documents to your index, and build it. Remember to select the option 'Extract data' 
before clicking GO. 
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Create Concepts File 

Conditions 

You have created an HAPI index with XML Wrapper, and selected Concept as the Data Extractor.  

Instructions 

1. Select the Concepts icon . 

2. Go to File > New. 

3. Select New File and click the right mouse button. 

4. Select New. 
The New concept dialog appears. 
 

 
5. Define the name of the concept (for example, Possible Suspects).  

6. Click the Index button. Select an index with XML Wrapper and Concepts selected as the Data Extractor. 

7. Click OK. 

8. Select a field from the dropdown list box. A successful search executed with the concept Possible 
Suspects, will be placed in the Suspect field. 

If the selected field is a list field (with a number of defined list field values), it is possible to Generate a 
concept entry for each list field value. This means that several searches can be executed which will be 
placed in the selected field. 

9. Click OK. 

You can create as many concepts to a XML concepts file as you like. 

10. Click Add. 

11. Define the ID, the value and the query. 
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For example, value "John Doe" is added to the field Suspect if the query "John Doe OR John Dune OR 
Joe Doe OR Joe Dune" was successful. 

12. Click OK. 

You can add as many concept entries to a concept as you like. 

13. Select New file. 

14. Click the right mouse button. 

15. Click Save. 

16. Define a name for the XML Concepts file, for example Investigation. 

17. Click Save. 

Result 

You have created a new Concept file. 
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Intelligent Redaction 

Conditions 

You want to replace search hits in ZyFIND with redactions. The Intelligent Redaction option is an extension 
on the current redaction option. Redaction is part of the XML Wrapper Module and allows users to redact 
scanned documents. The redactions are stored in the XML Wrapper and during an export action in ZyFIND, 
the redactions can be made permanent. 

Instructions 
1. Start ZyINDEX. 

2. Go to File > New.  

3. Enter a Short and a Long name. 

4. Select the Redaction template. 

5. Click OK. 

6. Build the index: Use the Now button . 

7. Click Go. 

8. Click OK to finish building. 

9. Add some scanned documents using ZySCAN.  

Please check the Review Guide Index Scan Find, on how to add scanned documents to an index. 

10. After adding some documents, rebuild the index. 

11. Start ZyFIND and select the Redaction index. 

12. Enter a query and click Search. 

13. Select a document to redact and double click to view. 

14. To redact all hits on the image, go to Redaction > Hits > Redact All. 

15. To redact the currently selected (green highlighted) hit, go to Redaction > Hits > Redact Current. After 
redaction, the next hit will be selected. 

16. To customize the appearance of the redactions, go to Redaction > Hits > Customize Appearance. 

17. To restore the appearance of the redactions to their original state, go to Redaction > Hits > Reset 
Appearance. 

18. Go to File > Export to export the image with the redaction to a new TIFF file or email. The redaction will 
thus be made permanent. 

Result 

You have replaced search hits in ZyFIND with redactions, and exported them. 

Note 

Intelligent Redaction only works with ZySCAN documents. 
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ZyVIEW - Stamp Tool 

Conditions 

You want to add a stamp to a document. You have created an index with XML Wrapper in ZyINDEX/Build, 
and added scanned documents using ZySCAN (for more information on how to proceed, see Review Guide 
Index Scan Find). 

Instructions 

1. Start ZyFIND and select the correct index. 

2. Enter a query and click Search. 

3. Select a document and double click to view. 

4. Go to Stamps > Stamp Tool > Stamp or select the Stamp tool icon . 
The Stamp Properties dialog appears. You can select a stamp from the library, or create a new one. 

Create Image is in development. 

5. If you want to create a text stamp, click Create Text. 
The Define Text Stamp dialog appears. 

 Define a Title for the stamp. 

 Define the Text. 
If you want to include the date, use %ZD to list the date in the format of the regional settings of the 
OS. 
If you want to include the time, use %ZT to list the time in the format of the regional settings of the 
OS. 

 If you want to select another font, click Select font. 
Define the font (type, style, size, effects, color, script) and click OK. 

 For a solid background, select the checkbox Solid. Select a background color via the dropdown box. 

 Click OK. 
The stamp will be added to the library. 

6. To edit or delete a stamp, select Edit or Delete. 

7. To use a stamp, select it and click OK. 

8. Choose a location to place the stamp, and click your left mouse button. 

9. The chosen stamp will be available (visible through the arrow with stamp image) and can be used 
repeatedly until you turn the stamp tool off via Stamp > Stamp Tool > Off. 

10. Once the stamp tool has been turned off, you can rotate stamps. Select a stamp and go to Stamp > 
Rotate Left or Rotate Right. Or select one of the icons (Rotate stamp left or Rotate stamp right). 

11. Once you are finished and want to make all stamps permanent, go to Stamps > Make Permanent. Click 
Yes. 

12. To hide/show all stamps, go to Stamps > Show Stamps. 
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13. Adjustments to stamps can be made via Stamps > Stamps Tool > Preferences. 

14. If you want to print your document, go to File > Print. Select the option Print annotations, if you want 
to include them. 

15. If you want to export your document, go to File > Export. 

Result 

You have created text stamps, and added them to a document. 
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Timer 

Scheduled Indexing 

If you want to build the index(es) at specific times or intervals, you can schedule indexing. You can have 
different schedules for the respective functions Add, Quick build, Update and Optimize. This allows one to, 
for example, build the index hourly and to update and optimize it daily.  
Also, any number of indexes can be scheduled. However, too many scheduled indexes and they will be 
skipped automatically, due to lack of time. The same holds for a frequency that is too high. 

You can either index at specific intervals, or automatically. 

Service 

It is also possible to run TIMER as a NT service. This means that you can shut ZyINDEX down and log off of 
the system, while the scheduled building of the index will continue.  
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Scheduled indexing (manual) 

Conditions 

ZyINDEX is open. You want to build the index at specific intervals. 

Instructions 

1. Click the TIMER icon: . 

2. Go to File > New. 
The Add Index dialog appears. 
 

 
3. Click Select. 

4. Select an index. 

5. Click OK. 

6. Select a date. 

7. Specify the Hour. 

If you process many documents per day, schedule the starting time after office hours. This saves you 
time and keeps processor usage at an acceptable level 

8. Specify the Minute. 

9. Determine the Frequency. 

10. Select an Action. 
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11. Click Add Now. 
 
The schedule of the index is added to the list. You can have different schedules (with different actions 
and frequencies) for the same index. 

12. Click the Start now button: . 
The scheduled indexing process starts. 
 
Stop TIMER or close ZyINDEX to end the process. 

13. After the process, check the values in the schedule. If a process wasn't completed successfully, it will be 
noticed by the value of the Last Update column. 

Result 

You have scheduled indexing. The index will be processed on the specified time and with the defined 
action(s). 
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Scheduled indexing (automatic) 

Conditions 

ZyINDEX is open. You want to build the index automatically when new/changed documents are added.  

Instructions 

1. Click the TIMER icon: . 

2. Go to File > New. 
The Add Index dialog appears. 
 

 
3. Click Select. 

4. Select an index. 

5. Click OK. 

6. Select Quick build. 

7. Select 'Automatic mode'. 

Result 

As soon as files are added or changed (TIMER monitors modfiles.mdb to make this possible), TIMER will 
automatically build the index. Only new or changed files are added to the index.  
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Note 

Please note that only changes that take place in ZyINDEX, ZyFIND or ZySCAN are added to the Index. For 
example, users might modify files outside of these products if a hard drive of users' active edocs has been 
indexed, and in this case to see the changes an Add/Update/Optimize Build should run. 
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Scheduled indexing (service) 

Conditions 

ZyINDEX is open. 

Instructions 

1. Select the TIMER icon: . 

2. Add schedules to the list. See Scheduled indexing (manual) (page 101) and Scheduled indexing 
(automatic) (page 103). 

3. Go to Timer > Service. 
 

 
4. Fill out the Domain Name. 

5. Fill out the User Name. 

6. Fill out a Password. 

7. Browse for the Temporary directory. 

8. Set the Process priority. 

9. Define the Number of seconds before assuming indexing thread in 'hung' state. 

This will stop and start the TIMER service if TIMER started to index a document opened by INSO and 
INSO does not give a reaction anymore. After the restart the document is stored in the exclude list. 

10. Define the Number of seconds to allow the service to finish.  

This is the amount of seconds the service is allowed to use for finishing indexing after stopping of the 
services. 

11. Click OK. 
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Result 

The Service will be added to the list of available NT services and is started immediately. It will also run when 
the system is logged off.  

Verify 
1. Go to Start > Settings > Control Panel > Services (Windows NT) 

 
or 
 
Go to Start > Settings > Control Panels > Administrative tools > Services (Windows 2000) 

2. Verify that TIMERservice has started. 

3. If not, make sure that the user (used to run this service), has been granted access to run NT services. 
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Monitor scheduled indexing 

You can monitor the scheduled indexing using the log file.  

Conditions 

ZyINDEX is open. If you are running the scheduled indexing as service, it is possible to check the log file 
without stopping it. When scheduled indexing is running in the foreground, stop the indexing process to 
enable the ZyINDEX interface. 

Instructions 

1. Click the TIMER icon: . 

2. Click the View Log File button: .  

Result 

The log file tells you if the indexing process ran, and when, how long and how many files were indexed 
before merging (to the existing index/word list). 
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Publish 

PUBLISH allows you to put your indexes on removable media such as CD-ROM, DVD, ZIP and Jazz drives. 
You can search your documents with ZySEARCH, which is published together with the indexes. However, if 
you want to work with your published documents (i.e. split, merge, etc.), you need ZyFIND. 

Publishing your index(es) means that you can carry your data around. This is a great advantage when you 
are always on the road, but still want to search your documents. For example, service technicians can 
search their manuals, without carrying along all their (heavy) documents. 

Conditions 

ZyINDEX is open. The index you want to publish is working correctly. You have enough free space on your 
local hard drive to publish to. 

Instructions 

1. Select the Publish icon: . 

2. Go to File > Open. 

3. Select the index you want to publish. 

4. Select Properties: , and check the settings. 

5. It is possible to create new media (volume types), where you want to publish your archive on. In that 
case, select New and fill out the Edit media properties dialog. Click OK. 

6. Make sure the location of ZySEARCH is C:\Program Files\ZyLAB\Information Management 
Platform\AddOn\ZySEARCH Install. 

7. Make sure the location of Autorun files is C:\Program Files\ZyLAB\Information Management 
Platform\AddOn\Publish files\English. 

8. If you made some changes, click Apply. 

9. Click OK. 

10. Make sure the General tab is selected. 

11. Select the different parts that have to be published: 

 Browse for a path to publish to. 
Select the path where the published files should be copied. If you plan on publishing a CD-ROM, you 
should copy these files to a CD-ROM media after publishing. If you plan on publishing to a Jazz drive 
or another re-writable medium, you can publish directly to the media. 
 
Keep in mind that you need to have enough free disk space! 
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Note that PUBLISH estimates the storage overhead on the CD based on a typical publication. 
However, in case you are publishing many small files, the size of the storage overhead, i.e. the CD 
directory, will be relatively large. In that case we advise you to decrease the predefined capacity of 
the volume you are publishing to. 

 Copy index files copies the index files to the publishing media and should always be enabled if the 
person who is going to use the CD doesn’t have an installation of ZyINDEX. 

 Copy search engine is an option to create a self contained CD, so you have an installation of 
ZySEARCH on the CD as well. An installation of ZySEARCH is only necessary in case ZyFIND is not 
installed on the computer of destination. ZySEARCH has the same functionalities as ZyFIND. 
 
Note: If copy search engine is checked please make sure that the latest service pack is present in the 
ZySEARCH install files in the ZyLAB directory. If you do not want to distribute ZySEARCH with a 
servicepack, please check on ZyLAB’s support site if an updated ZySEARCH installation is available. 

 When the Store current ZyFIND settings for publishing media option is checked, a copy of the 
ZyFIND registry settings of the current machine will be made. You can make a selection of settings 
using the dialog on the ZyFIND Settings - tab. They will be published on the volume.  The receiver 
of the volume is now able to view the published index with the same ZyFIND settings. Copy Autorun 
files  allows you to make an auto-start CD-ROM. If this option is checked, PUBLISH will install an 
AutoStart file and some set-up HTML pages for the published CD-ROM. If these are copied into the 
root of the CD-ROM, the CD will open an HTML (customizable) screen that allows the user to install 
ZySEARCH, run ZySEARCH or obtain information on ZyLAB or the ZyLAB Software. The user can 
indicate where to copy the HTML files. The entire contents of this directory need to be copied into 
the root of the final published volume. 

12. Select the Media tab. 

13. Select the appropriate volume type and enter a volume name. 

 Volume type: Select your publishing media here. This is especially important to determine the 
capacity of the media for multi-volume publishing. If the medium is not in the standard list, you can 
define it yourself in the PUBLISH setting dialog.  

 Size: Remember to decrease the predefined volume capacity to anticipate large storage overhead.  

 Final Volume Label Published Media: The final published volume name will be stored in the index 
files. This is important in order to make the published volume drive insensitive. That is, it should not 
matter whether the CD-ROM is stored in a drive with letter D: E: or F: It should always work. 
Therefore, the ZyINDEX index will look for a volume name instead of a drive letter. The final volume 
name should be specified here. If you copy the published files to a CD-ROM, do not forget to create 
a CD-ROM with exactly the same volume name as indicated here (ZyINDEX is case sensitive for 
volume names!).  

 Write Volume Label to Media: If you use re-writable media, you can write the volume name directly 
to the published media (e.g. in case of a ZIP or Jazz drive). 

14. Select the Print tab. 

15. If you want to print labels that will be put on the CD ROM, select Print label. 

 Select a printer. 
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 Select a text font. 

 Define the position of the text. 

 If you want to print a test page, click Test Page. 

16. Select the ZyFIND Settings tab. 

17. Determine what kind of settings and which parts of ZyFIND are going to be copied. If all the settings 
have been entered correctly you can start publishing the index.  

18. Click Start . 
The index is going to be published and a status bar will be shown. Once publishing is finished, a 
summary will appear (this summary and additional help on publishing to CD ROM can be found below). 

19. Click OK. 

20. Close ZyINDEX. 

Summary text 

Publish was successful. xx Mb in xx files. 

If you are creating a CD-ROM, you can now copy the published files under "C:\PublishDir" to a CD-ROM 
with a CD-write program. Be sure to copy the same path ("C:\PublishDir" and all of its contents) to the 
target drive. 
In order to create a self-starting CD, you must copy the files in "C:\PublishDir\autorun" to the root folder of 
your CD-ROM (with the CD-write program). Publish was successful. 0.25 Mb in 64 files. 
If you are creating a CD-ROM, you can now copy the published files under "C:\PublishDir" to a CD-ROM 
with a CD-write program. Be sure to copy the same path ("C:\PublishDir" and all of its contents) to the 
target drive. 
In order to create a self-starting CD, you must copy the files in "C:\PublishDir\autorun" to the root folder of 
your CD ROM (with the CD-write program).  

Publish to CD ROM 

After publishing with PUBLISH you will have to use a CD-writing program to create your CD. Because there 
are several CD-writing programs, it is not possible to go into to much detail here. However, there are 
several general things you have to keep in mind. Also, some tips are given on how to make sure your CD will 
work correctly on other computers. 

Tips for burning the CD after publishing: 

1. Copy the whole path  
If you used the default path to publish to (C:\PublishDir\) make sure you use the same path for burning 
the data to CD. So drag and drop the folder 'PublishDir' to the CD writing program. Do not reparent. 

2. Volume labels are case sensitive!  
With all CD writing programs you will have to give a volume label (or volume name) to the CD you will 
burn. Make sure you use exactly the same volume label you entered in ZyPUBLISH. It is also very 
important you use the same case for each letter! 
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3. The autorun files have fixed locations.  
The autorun files makes the installation of the CD very easy for the user. They consist of several files 
that should be on the CD on specific locations. After burning your CD, the Welcome.htm and 
Autorun.inf files should be in the root of the CD together with the folders \Bin, \html and \images. If 
you used the ZyPUBLISH default autorun files location 'C:\PublishDir\autorun\', you have to reparent 
these files with your CD writing program so they will be burned to the root. 

4. Make a disc readable on more than one operating system. 
Not all CDs can be read by all operating systems; much depends on what file system and filenaming 
option is used when the disc is created. If you need to make a disc readable on more than one 
operating system keep these points in mind: 

 If your CD is going to be used on early Win95 (before OSR2) computers or on computers with old CD 
players, the number of folder levels between the root of your disk and the deepest data folder 
should not exceed 8 levels. If this is the case, do not change the location of your data files or index 
files. Instead you should rearrange your data structure: Start ZyINDEX and erase the old index 
contents and rebuild it. Then use ZyPUBLISH again. To save one more level, publish the index 
directly to c: instead of c:\PublishDir. 

 CD writing programs offer several filenaming options as ISO9600, Joliet, Romeo. ISO9600 will work 
on the most platforms but does not allow longer filenames and directory names than 8+3 
characters. This setting therefor is not recommended. The Joliet specification is ISO9600 compliant, 
but allows filenames and directory names up to 64 characters. For most indexes this will be 
sufficient. The Romeo specification allows for filenames up to 128 characters, but is not offered by 
all CD writing program. 

Tips for testing the proper working of your CD after burning: 

1. Test the CD on another computer than the one you made the index on or used for publishing the CD 
with ZyPUBLISH. 

2. Make sure the test computer on which you test the CD does not have drives with the same volume 
label as the CD (hint: for this reason do not use company names as volume label in ZyPUBLISH.) 

3. To test if your CD is drive letter independent, choose a test computer with a CD player that has another 
drive letter than on the computer on which you published the CD. 

4. If ZyFIND is already installed on the test computer, it is not recommended to install ZySEARCH. 
Therefore cancel installing ZySEARCH after the first installation dialog. Use the existing ZyFIND for 
testing the index. Add the published index to the list of available indexes by browsing for the .ic1 file as 
described in the help files. At least try to find and open one of the documents on the CD to make sure 
the data paths are valid. 

And finally: 

• The CD can not be used in a multi-CD tower using drive letters. 
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Web Client 

The ZyLAB Web Client uses ZyLAB scanning and full-text retrieval technology to provide transparent 
Internet or intranet access to scanned and indexed information. You can access the ZyLAB Web Client with 
any Internet browser and search for documents that contain the information you are looking for. 

In ZyLAB Web Client you can organize, group, print, upload and download documents from multiple indexes 
using all the features that make ZyFIND so powerful. 

Using the ZyLAB Web Client, you can easily share information throughout your company even if you have 
offices in different locations. All you have to do is start your Internet browser and access the URL of your 
archive. The intuitive and fully customizable interface allows you and your colleagues to find what you are 
looking for. 

A ZyLAB Web Client contains various HTML pages. We will discuss the Default HTML web pages that are 
used when creating a Web Client. The Default template includes all module options and KWIC view (see 
ZyLAB Web Client for Users). Once a module index is added to the Web Client in ZyINDEX, those options 
become available. 

The HTML pages of the Web Client are easy to change so they can be adapted to your in-house style 
(however, the functionality of ZyLAB Web Client itself cannot be changed). 

We will provide information about creating and configuring a Web Client in ZyINDEX, and further 
configuration of the Web Client in an internet browser. For User instructions refer to ZyLAB Web Client for 
Users, wich is included with created Web Clients. 
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Web Client Overview 

Web Clients are created and configured in ZyINDEX.  

In ZyINDEX click the Web Client button to display the following screen: 

 

The left panel shows the Web Clients that have been created. The right panel contains the following 
buttons: 

• Security. Displays the ZyLAB Security Settings web page in your internet browser. For detailed 
information about ZyLAB security, see the ZyINDEX manual > Security (page 158) chapter. 

• ZyAlert. Displays the ZyALERT Subscriptions web page in your internet browser. For detailed 
information, see the ZyALERT manual > ZyALERT: Automatic Searches. 

• Monitor ZyWebserver. Displays the monitor webserver page in your internet browser from where you 
can monitor your Webserver. See Monitor Webserver (page 114) for more details. 

• Federator. Obsolete. 
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Monitor Webserver 

The Monitor Webserver page lets you monitor the activity of your webserver and the resources it is using 
on your computer. In the Web Client, go to Admin > Monitor Webserver. 

 

Click on a menu item to display the item's page: 

• Disk Space 
Shows the total, used and free space available on your computer. 

• CPU and Memory 
Displays graphs of the total CPU and Memory usage. 

• Webserver 
Displays the amount of CPU capacity the Webserver is using. 

• ZyLAB Services 
Lists the ZyLAB Windows Services. The checkbox 'Show all services' displays all the Windows services. 
You can start, stop, pause, continue, interrogate and shutdown selected services. 

• Event Logfiles 
Lets you open the event log from a specified period. 

• ZySCAN Jobs 
Shows the ZySCAN jobs queue. 
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Set the Web Client General Options 

The general options are applied to all web clients you will make. Configure these options before you create 
a web client. 

1. First, select Web Client . 

2. Then, go to Options > Web Client. 
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The options are as follows: 

• HTTP root directory 
For Microsoft Internet Information Servers this is default C:\inetpub\wwwroot 

• Directory for temporary files. 
Choose a temporary folder that every user of this computer has full-control access rights for. 

• Default index 
This is an index that will be in every web client you create. An entry here is not mandatory; you can 
choose indexes to include when you create the web client. 

• HTML Editor 
Define a HTML editor, for example Notepad.exe. 

• HTML browser 
Define the internet explorer you want to use to open your web client. By default, Microsoft Internet 
Explorer is installed in C:\Program Files\Internet Explorer\iexplore.exe. 

• Web Site 
Define the URL of your website (for example 'www.zylab.com' or a TCP/IP number such as 
'193.67.146.1'). 

• Run Web Server as 
To add security, click the 'Change' button and define how the ZyLAB Web Client should be run: 

 Define the User name, Password, and Logon domain. 

 Click OK. 

• Treat these user agents as search engines 
If you want to make your web client accessible to user agents (for example a web browser or search 
engine crawler), select the checkbox 'Treat these user agents as search engines', and click the Change 
button. 

 Define a user agent, and click the + button. 

 Repeat to add more user agents. 

 To delete a user agent, select it, and click the - button. 

 Click OK. 

For more information, see Internet Search Engine Integration (page 120). 

Click OK to save the changes. In the next dialog click Yes to confirm the changes. 
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Create and Edit a Web Client 

When you create a web client you link one or more indexes to it, specify users, customize its appearance by 
changing styles and templates, and apply various search functionalities. 

Create and edit a Web Client using the following procedures: 

• Create a Web Client (page 118) 

• General options (page 119) 

• Add or Delete Users (page 124) 

• Add or Delete Index(es) (page 126) 

• Templates and Styles (page 127) 

• Edit Hit Markers (page 131) 

• Added login via cookie (page 132) 

• Disable Caching (page 133) 

• View Hit Highlighting in Adobe PDF Files (page 134) 

• Global Search Folders for Web Client (page 135) 

Be careful when making changes as certain changes are saved immediately without a prompt! For every 
template a number of styles are available. If a style is not relevant for a template, it is not 
mentioned/changed. 
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Create a Web Client 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the Web Client icon: . 

2. Go to File > New. 

3. Define a Long Client Name.  

4. Define the HTTP alias (URL).  

5. Browse to the directory where you want to store the Web Client. 

6. If required, define a Client email address. 

7. Select a language for the Template language. 

8. Click OK twice. 

Result 

You have created a Web Client.  
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General options 

Conditions 

ZyINDEX > Web Client is open. You created a Web Client and the web client tree is expanded in the ZyINDEX 
web client panel. 

Instructions 
1. Select General in the expanded web client tree. 

2. Check the options you defined while creating a Web Client. 

3. Set the following options where necessary: 

 Enable Automatic Login 
Allows users to register without using a username/password. 
 
Note: For security reasons, it is advised to deselect this option. 

 Disable caching in browser 
When caching is enabled, ZyNET will send a new version only if documents/images have been 
changed, otherwise stored (cached) content will be used. It is recommended to disable caching 
when using Annotations. For more information, see Disable Caching (page 133). 

 Always view PDF files with Adobe 
Opens PDF files directly in an Adobe Acrobat program (for example, Reader or Exchange). If this is 
not selected PDF files are converted to TIFF and the image is displayed. 
 
Note: To enable hit-highlighting in PDF files you must change the Adobe Preferences (refer to View 
Hit Highlighting in Adobe PDF Files (page 134)). 

 Disable total hit count for Fast Results 
For large indexes, use this option to greatly increase the speed results that are shown. During a 
search from the Web Client when the 'Fast results, last indexed first' option is selected, only the 
first 15 found items are shown in the results list. The following 15 results are searched for when the 
"next" link (above the results list) is clicked. See Starting a Simple Search in the Web Client manual 
for more details (in the Web Client, go to Help > Help Contents). 

4. For more information on the Generate sitemap button, see ZyINDEX Internet Search Engine 
Integration (page 120). 

Result 

You checked and defined the General options. 
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ZyINDEX Internet Search Engine Integration 

Conditions 

You want to open ZyLAB Archives via Internet search engines such as Google, Yahoo, etc. In order to do so, 
a sitemap must be created. A sitemap is used by webmasters to inform search engines about pages on their 
sites that are available for crawling. Using the Sitemap protocol does not guarantee that web pages are 
included in search engines, but provides hints for web crawlers to do a better job of crawling your site. 

Documents need to be transformed to plain HTML for indexing by search engines. A special template 
(Search engine optimization) is created for that reason. To edit this template and optimize your web 
presence, go to the Templates section of a Web Client, and double click on the Search engine optimization 
template. All options of the template are explained clearly in the template. The template works for both 
electronic and scanned documents. 

Once ZyNET.exe detects a defined user agent (for example a web browser or search engine crawler), 
ZYNET.exe will display a special page that shows the HTML text version of a document. 

Instructions 
1. Open ZyINDEX > Web Client. 

2. Select the Web Client that will be indexed by Internet search engines. 

3. Make sure one or more indexes are added to your Web Client. 

4. On the General page, click the Generate sitemap button to create a SiteMap XML file which informs 
search engines about pages that are available for crawling. 
The SiteMap Generator dialog appears. 
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Periodically refresh the SiteMap to make sure URLs of new documents are added. 

 

 
5. In the Sitemap path field enter the location where the SiteMap XML file will be saved. If required use 

the Browse button select a location. 

Due to security issues, the SiteMap XML file must be placed in the root folder of the Web Client. 

6. Enter a name for the (to be created) SiteMap XML file in the Sitemap name field. 

Make sure you use a different Sitemap name for each Web Client that you want to be indexed by user 
agents. If you do not, older files with the same name will be overwritten. 

7. In the Internet Server URL field enter the external server on which the SiteMap XML file will run. 

8. To create a new SiteMap, select the checkbox Generate a new SiteMap. If you do not select this option, 
only new documents (URLs) will be added.  

 To limit the number of SiteMaps, select the checkbox Try to create just one file. 

9. To create a separate SiteMap file for every index, select the checkbox Create sub sitemaps for every 
index. Note that this option cannot be combined with the option Try to create just one file. 

The maximum size of a SiteMap is 50000 URLs or 10MB. The maximum size of a SiteMap index is 1000 
SiteMaps.  

10. To provide user agents with information on the latest modification date of a file, select the checkbox 
Add last modified tag (uses file date). 
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11. To define how frequently pages are likely to change, select the checkbox Add change frequency. This 
value provides general information to search engines and may not correlate to exactly how often they 
actually crawl the page. Choose from: 

 always 

 hourly 

 daily 

 weekly 

 monthly 

 yearly 

 never 

The value 'always' should be used to describe documents that change each time they are accessed. The 
value 'never' should be used to describe archived URLs. 
Please note that the value of this tag is considered a hint and not a command. Even though search 
engine crawlers may consider this information when making decisions, they may crawl pages marked 
'hourly' less frequently than that, and they may crawl pages marked 'yearly' more frequently than that. 
Crawlers may periodically crawl pages marked 'never' so that they can handle unexpected changes to 
those pages. 
Due to technical limitations the generated values are default values. These values can only be changed 
manually. 

12. To define the priority of a URL relative to other URLs on your site, select the checkbox Add priority. 

Valid values range from 0.0 to 1.0. This value does not affect how your pages are compared to pages on 
other sites - it only lets the search engines know which pages you deem most important for the 
crawlers. 
The default priority of a page is 0.5. 
Please note that the priority you assign to a page is not likely to influence the position of your URLs in a 
search engine's result pages. Search engines may use this information when selecting between URLs on 
the same site, so you can use this tag to increase the likelihood that your most important pages are 
present in a search index. 
Also, please note that assigning a high priority to all of the URLs on your site will not guarantee that 
web pages are included in search engines. As the priority is relative, it is only used to select between 
URLs on your site. 
Due to technical limitations the generated values are default values. These values can only be changed 
manually. 

13. To create the sitemap, click the Generate button. 

14. Click OK. 
The SiteMap XML file(s) can be found at the location defined in the Sitemap path field. 

15. Open the SiteMap XML file(s), to check the contents. 

16. To define the user agents that are allowed to crawl your pages, go to Options > Web Client. 
The Web Site dialog appears. 
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17. Select the checkbox 'Treat these user agents as search engines'. 

18. Click the Change button. 

19. Define a user agent (for example, googlebot-pm or yahooseeker), and click the + button. 

20. Repeat to add more user agents. 

21. To delete a user agent, select it, and click the - button. 

22. Click OK. 

Result 

You have created a web client that will be indexed by Internet search engines, and created a sitemap to 
inform search engines about pages which are available for crawling, then you defined the user agents that 
are allowed to crawl your pages. 

Note 

Ensure that user agents will also view the latest documents by periodically generating a new sitemap. 

123 

 



ZyINDEX Manual 

 

 

Add or Delete Users 

Conditions 

ZyINDEX > Web Client is open. You have created a Web Client and the web client tree is expanded in the 
ZyINDEX Web Client panel. You have imported/created Users and User Groups in ZyINDEX > Security. For 
more information, see the ZyINDEX manual > Import Users (page 173), Create Users (page 179) and Create 
User Groups (page 169). 

Instructions 
1. Expand 'User Roles' in the Web Client tree. 

2. Select Administrator/Editor/User or Guest. 

3. Select Add. 

4. Select a user (group) you want to give access to the Web Client.  

5. If you want to add more users and/or user groups, repeat steps 3 and 4. 

6. By default, 'Inherit from roles' is selected. The inherited user group is grayed out. If the 'Inherit from 
roles' option is not selected, the inherited user group turns black. Now you are able to delete it. 
Inherited user groups are used to automatically add default users to your Web Client, which makes the 
creation of new Web Clients much faster, and adds security. For more information on Roles refer to the 
ZyINDEX Manual > Functional (Application) Security (page 215). 

Result 

You have added users and/or user groups to the Web Client. 

Note 

To delete a User or User Group, select one and click Delete. 
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Deny Access 

Conditions 

You want to deny access to an index (on a Web Client) for specific user(s), group(s) or role(s). 

Instructions 

1. Go to ZyINDEX > Security . 

2. Select File System (Network) Security. 

3. Select an index (to which you want to deny access for a specific user, group or role) from the dropdown 
listbox. 

4. Select from the Section dropdown listbox, the option Index Directory. 

5. Select all items. 

6. Click Create. 
The View/Edit Permissions dialog appears. 

7. Select from the Users, Groups or ZyLAB Roles dropdown listbox a user, group or role. 

8. Select from the dropdown listbox Apply onto, the option This folder, subfolders and files. 

9. Deny all permissions. 

10. Click OK. 

Result 

You have denied access (for a user, group or role) to an index. If this index is added to a web client, it will 
not be visible to this user, group or role.  
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Add or Delete Index(es) 

Conditions 

ZyINDEX > Web Client is open. You created a Web Client and the web client tree is expanded in the ZyINDEX 
web client panel. 

Instructions 
1. Select Indexes in the expanded web client tree. 

2. Click the Select button. 

3. Select one or more index(es). 

4. Click OK. 

Result 

You added index(es) to the Web Client. 

Note 
• The sequence of the indexes can be changed using the blue arrows on the right hand side. This 

sequence will be shown in the Web Client search panel. 

• To delete an index, select it and click the Delete button. 

• If the user does not have permission to access the folders where an index is stored, then that index will 
not appear in the list on the Web Client search panel. 
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Templates and Styles 

The Web Client is made from Templates (page 128) with Styles (page 129) controlling the appearance of 
the templates. ZyLAB Web Client is supplied with standard Default, Classic and Enterprise styles with can be 
applied to your Web Client to change its appearance. The changes are visible in the browser when the 
screen is refreshed. 

It is also possible to edit the individual templates, but a good working knowledge of HTML is required for 
this. 

Check all changes you have made to Web Client styles in your internet browser before releasing the Web 
Client. 
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Templates 

List of Templates 

The templates are listed with their current style. Right click on a template to choose the View and Edit 
options (see below). 

Change the style 

A new style can be applied to the templates to change the style of the Web Client (Change the style of the 
templates (page 130)). 

View 

To view a template from the dialog box, right click on it and select View. This will only work if you have 
defined an HTML browser in Options > Web Client (see General options (page 119)). 
You can also browse to the particular template you want to see. The file should have an *.HTM extension 
and should be located in the WWW root directory that can be found in the Inetpub folder. 

Edit 

You can edit individual HTML pages using a text editor, for example Notepad. You can define the HTML 
Editor in Options > Web Client (see General options (page 119)). 
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Styles 

One of the listed styles can be applied to your Web Client to change its appearance (Change the style of 
the templates (page 130)): 

• Default - contains all basic functionalities and is a user-friendly and intuitive HTML style. 

• Section508 
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Change the style of the templates 

Conditions 

ZyINDEX > Web Client is open. You created a Web Client and the web client tree is expanded in the ZyINDEX 
Web Client panel. You want to change the style of the Web Client's user interface. 

Instructions 
1. Select Templates in the expanded web client tree. 

2. In the Templates drop-down list select a template style (Styles (page 129)). The default template is 
"Default". 
 

 
3. If you want to change all templates (Templates (page 128)) to the selected template style, click Yes. If 

not, click No to exit. 

If you want to change the style of one template, first select the template from the list, and select 
another available style for that template only. Now, when asked if you want to change all templates, 
click No. 

4. Click Apply. A message warning that all manual modifications to a style will be lost is shown. Click Yes to 
apply the changes or No to cancel the changes. 

Result 

You have changed the style (user interface) of a Web Client. If your ZyLAB Web Client is open in an internet 
browser refresh the screen to show the changes. 

Note 

If you want to view a template, select it, and click View. This will only work, if you defined a HTML browser 
via Options > Web Client (see General options (page 119)). 
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Edit Hit Markers 

The hit markers appear each side of a hit and are used to jump to the previous or next hit: 

. You can change the markers to your own preferred marker image by 
creating new images and replacing the original images. 

Note: Hit markers only appear in electronic documents and not in scanned documents. 

Instructions 
1. In the www root images folder for your web client ("\Inetpub\wwwroot\<webclient>\images") rename 

the PrevHit.gif and NextHit.gif files to "PrevHit.gif.orig" and "NextHit.gif.orig".  

Renaming the files allows you to revert to the original hit markers. 

2. Create new previous and next hit markers of a suitable size (the original hit markers are 14 x 9 pixels) in 
a graphics editor, for example Microsoft Paint. 

3. Save the new previous and next hit markers as .gif files in the www root images folder with the names 
"PrevHit.gif" and "NextHit.gif". 

4. Refresh your Web Client browser window. The new hit markers will now appear each side of a hit. 

Result 

You have changed the hit markers. 
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Added login via cookie 

A cookie device is enabled to allow removal of the NT_User details from the URL. Also, your username and 
password are saved so you do not have to login each time. 
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Disable Caching 

Conditions 

When caching is enabled, you can save bandwidth and reduce processing time when viewing documents 
and images on the web. ZyNET will send a new version only if documents/images have been changed, 
otherwise stored (cached) content will be used. Caching is enabled by default. 

Instructions 
1. Go to ZyINDEX > Web Client. 

2. Select the folder of an index. 

3. Select the option 'Disable Caching in browser'. 

Result 

Caching will be disabled. 

Note 
• It is recommended to disable caching when using Annotations. Changes to certain plugin fields are not 

shown when caching is enabled (this has to do with the fact that changes are not reflected in the 
modified date/time).  

• Caching works for the following ZyNET actions: 

 ZyActionD (file display) 

 ZyActionG (INSO inline image, and images with document-level security) 

 ZyActionW (download/launch) 

 ZyActionP (download as PDF) 

 ZyActionM (view as TIFF) 

• tiff2png (showing images as inline-PNG-images) also supports caching. Caching cannot be disabled, but 
tiff2png has no problems with plugin fields.  
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View Hit Highlighting in Adobe PDF Files 

To be able to see hit highlighting in Adobe PDF files you must change a setting in Adobe Acrobat or Acrobat 
Reader. You must do this on each work station or PC used to access the ZyLAB Web Client. (Make sure 
Adobe Acrobat or the free Acrobat Reader is installed. Visit www.adobe.com for more information.) 

You cannot see PDF hit highlighting on the host server. 

Instructions 
1. On the work station open Adobe Acrobat or Acrobat Reader (v8.0 or higher). 

2. Go to Edit > Preferences > Search.  

3. Check the Enable search highlights from external highlight server checkbox.  

4. Click OK. 

5. If the ZyLAB Web Client is open, press key F5 to refresh the screen, then do the search again. 
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Global Search Folders for Web Client 

Conditions 

You want to link to one or more Global Search Folders. A Global Search Folder makes it possible to search 
multiple indexes automatically with one search query. For each Global Search Folder you can define a 
search query, which will be stored on the network. Global Search Folders are created in ZyFIND - Search 
Folders: Dynamic TOC for more details. 

Instructions 
1. Open a Web Client in ZyINDEX > Web Client. 

2. Select 'Global folders'. 

3. Click the Add button. 

4. Find an existing Global Search Folder. 

5. Click Save. 

6. To delete a Global Search Folder, select it, and click the Delete button. 

Result 

You have created one or more Global Search Folders. You can edit, delete and add folders to a Global 
Search Folder in the Web Client and in ZyFIND. 
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Delete a Web Client 

Conditions 

ZyINDEX > Web Client is selected. 

Instructions 

1. Select the Web Client you want to delete. 

2. Click the Delete button: . 

3. If you want to delete the client, click Yes. 

Result 
• The Web Client and its settings from your server's Registry are removed. 

• The physical files of the Web Client are removed.  

Note 
• You cannot re-activate the client once you have deleted it. 

136 

 



ZyINDEX Manual 

 

 

Reactivate a Web Client 

Conditions 

You can reactivate a Web Client which has had its entry in the Windows registry removed (for example, 
moved to another computer), but whose physical files were kept, or when ZyINDEX was removed and 
reinstalled. ZyINDEX > Web Client is open. You cannot reactivate a deleted Web Client. 

Instructions 

1. Go to File > Open. 

2. Browse to the Web Client configuration file. This is a file with extension *.ZyC and it should be located 
in a directory called "Config" or "HTML" somewhere within the HTTP root directory. For example, 
C:\inetpub\wwwroot\demo\html 

3. Select the *.ZyC file. 

4. Click Open. 

Result 

If the client can be reactivated it will be added to the tree dialog. 
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Advanced Options in the Web Client 

Before a user can use the Web Client in the Internet browser it will be necessary to adjust the configuration 
to obtain the correct viewing environment. You must first start the Web Client and log in. 

The Web Template options let you adjust the way the results and documents are presented and displayed. 
Click the Options button  to display the Options page. The page has the following tabs: 

• Search (see "Search Options" page 139) 

• Results (see "Results Options" page 141) 

• File (see "File Options" page 143) 

• Global (see "Global Options" page 146) 

You can find information about editing web templates in the Templates and Styles (page 127) topic (ZyLAB 
Web Client for System Administrators manual). 

Click Save to save any changes you made. To return to the default settings, click Load Default Settings. 
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Search Options 

The Search options page defines how searches are made. 
 

 

• Look for 
Choose from the listbox to search the ZyINDEX query, all words, any of the words or exact phrase.  

• Date 
Select a date to define the period to search in. 

• Define the Maximum number of indexes to show and the Number of query box rows. 

• Remember query history 
Choose from 'No', 'Only when something is found' and 'Always'. 

• Search suggestions 
When defining a search term, search suggestions are given (based on the indexed content) when this 
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option is enabled. Search suggestions will be shown after 3 inserted letters/numbers. The search 
suggestions can be sorted on alphabet (from a to z) or (number of) occurences (from high to low). 

• Search Tools 
Select the Search Tools you want to be available for the Web Client. 

- Contents (locate documents via Table of Contents) 
- Search Folders 
- History (reuse previous searches) 
- Vocabulary (find related documents) 
- Thesaurus (broaden the scope of your search statement and include synonyms) 
- Concepts (use (complex) search statements with a name) 
- Fields (meta information: Search for information about your documents) 
- Subscriptions (determine what kind of information will be sent to you via alerts) 
- Taxonomy (classify and manage your documents, based on hierarchical structures) 

• Search tool to show at start up 
Select a search tool to open the Web Client with at start up. You can choose from Contents, History, 
Vocabulary, Thesaurus, Concepts, Fields, Subscriptions, and Taxonomy. 

• Search tool selection 
Define how you want to select search tools, via tabs or a dropdown menu. 
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Results Options 

The Results Options page defines how results are displayed. 
 

 

• Results per page 
Select the maximum number of files you want to display in the View Page. 

• Rank Search results on 
Define the way files are ranked. You can choose between Number of hits, Hitdensity, File size, File date, 
Comment, File Name and File path.  
Choose between Ascending and Descending. 

• KWIC options 
The options are: 

- Enable KWIC 
- Display type: Compact or Separated. Compact displays all contexts one after the other, Separated 
displays all contexts on a separate line 
- Show n hits with n words around hit: Defines the maximum number of hits shown per result, and 
the number of words (maximum 50) around the hit. 
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• Enable functions in toolbars 

- Toolbar function to select all entries 
- Show or hide all fields 
- Delete entries 
- Move entries 
- Copy entries 
- Select target toc (for move or copy) 

• Search result options 
Shorten long field contents to no more than n characters displays only the first part of a field's contents 
to decrease the width of the search results screen. 

• Default action 

- File display 
- Launch file in original application 
- View as PDF 
- View as multi-page TIFF 
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File Options 

The File Options page controls what you will see when a item is opened. 
 

 

• Control which page will be viewed first 
Choose whether you want to view the first page of a file, or the first hit within a file. 

• What to display, and which image quality to use 
Images displays the image format. Choose the Image quality: low, medium, high, 200% enlarged, 280% 
enlarged, 400% enlarged and TIFF.  
Specify whether the Original format must be displayed. If it is not displayed then an ASCII file is 
displayed containing the text of the original file. With the original format you can also view the 
following: 

- Document properties. These are the document properties stored by the original program. 
- Show hidden rows/columns/sheets. These are rows/columns/sheets normally hidden by the 
program used to create the file (for example Excel).  
- Show hidden text. This is text normally hidden and comprises reference codes and text marked as 
hidden by the program used to create the file (for example Word).  
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- Show change tracking. Will show change tracking marked as hidden by the program used to create 
the file (for example Word).  
- Show table of contents. Will show (for electronic documents) the table of contents. If you click on 
it, the correct chapter will appear. 
 

 
Note that these options are disabled if Original format is not selected. 
 
Specify whether the Highlights (these are the hit highlights) are shown. 

Shorten long field contents to no more than n characters reduces the length of a field's contents to the 
first n characters, but will also disable the hit-highlighting in fields. 
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• Thumbnail display for viewed documents 
To view a small image of a page in advance, select the checkbox Enable thumbnails. Select the 
maximum number of thumbnails per page, and the size of the thumbnails. Choose from default, small 
or large.  

• View TIFF converted documents first 
Views the TIFF version of a file first. 
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Global Options 

The Global Options page controls the web client style and the visibility of some buttons. 
 

  

Style sheet 

• To change the appearance of the web client, choose another Style sheet. The style sheet is applied 
when you click the Save button. 

Visibility 

• By default, the result list remains visible while viewing documents.  

• To use the Visualization Module, select the checkbox Show visualization buttons. 

• To show the mail button, select the checkbox Show mail button. 

• The Use dynamic results option reloads search results each time a document is selected. This ensures 
that the latest documents and the field data are always shown. This is useful for indexes that are 
constantly being updated but you may notice that for large results lists documents open more slowly. 

• To show the print button, select the checkbox Show print button. 
Choose 'Print client side' or 'Print server side'. 
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Client side printing allows you to add a selection of Document key fields (and their values) and/or 
Document properties to a page preceding the print output. 
For more information, see Print Service for the Web Client (page 150). 
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Style Sheets 

The web template style uses a large set of style sheets to control the lay-out and functionality. Style sheets 
used by this style use the naming convention 'ZFE_name.ccs'. All style sheets except for the ZFE_user.ccs 
control the coloring and fonts. These style sheets can be activated by the user in the Global (see "Global 
Options" page 146) tab. 
 
The ZFE_user.css is intended to control the options and buttons on the HTML pages. The ZFE_user.css 
overwrites all settings in the other style sheets that are used in the HTML pages. The ZFE_user.css will not 
be updated with new versions of ZyLAB software. By default all options are displayed in the Template Style. 
In the ZFE_user.css you can remove options by activating the "display:none" tag for each option.  

You activate the "display:none" tag by removing the "/ *" and "* /" delimiters. 

You can also copy parts of the ZFE_default.css to the ZFE_user.css to make more settings default for the 
users. 
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Admin Options 

In the Web Client, go to Admin > 

Monitor Webserver (page 114) 

Security (page 158) 

Services Manager 

Workflow Management (page 253) 

ZyALERT 
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Server Side Printing and Print Service 

To make printing of documents quicker and to allow you to continue working the printing is done directly 
from the server where the index is stored, and not from the PC where the document is viewed. To see 
available network printers in the print dialog on your PC the ZyLAB print service must be configured and 
started, and the printers selected. 

• ZyLAB Print Service Setup (page 151) 

• Server Side Printing (page 153) 
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ZyLAB Print Service Setup 

Conditions 

You want to set-up the ZyLAB Print Service to be able to print directly from your server. 

Instructions 
1. Open ZyLAB Web Client (in your web browser). Click on Admin > Services Manager to display 

the Monitor page. 

2. Check that the ZyLAB Print Service appears in the list of services. If the ZyLAB Print Service is not in the 
list: 

a) Click the Options button to display the Options page. 

b) Select the correct Domain. 

c) In Computers > Available select the server where the index is stored and use the arrow button (>) to 
transfer it to the Selected panel. 

d) In Services > Available select ZyLAB Print Service and use the arrow button (>) to transfer it to 
the Selected panel. 

e) Click OK. 

3. On the Monitor page, click Select on the ZyLAB Print Service. 
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4. Click Start to start the ZyLAB Print Service. The Status changes to Running. 

 
5. To automatically start the service click Control Panel > Administrative Tools > Services. Double-click 

on ZyLAB Print Service to open its properties window. Change the Startup type to Automatic. Click OK. 

Result 

The ZyLAB Printer Service is correctly configured and started. 
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Server Side Printing 

Conditions 

You want to print a document you have found on a printer connected to the server. You can either print it 
by selecting it from the found documents list, or when you have already opened it. The ZyLAB TIFF Export 
Printer is installed and the ZyLAB Print Service is running. 

Instructions 

1. If you cannot see the print icon  click the Show print button (print server side) on the Global 
Options (page 146) page. 

2. To print click on the print icon . The Printer Options window appears. 

3. If necessary, set-up the printer: 

a) Click on the Add/remove printers tab. 
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b) From the list of printers select the printers you want to use for printing. Transfer them to the 
Selected Printers panel using the > button. 

c) If you want to give the printer a user-friendly name, select the printer and type the name in the Edit 
printer name/handle box. Click Enter to change the printer's name. 

d) Choose a printer to select as the default printer. 

e) Press Refresh to see your changes. 

f) Press Save 

4. Click the Print setup tab to show the print window. 

 
5. Press the Refresh button to show all changes you have made to printers. 

6. In the Printer box, select a printer. 

7. In the Document, Layout and Finishing boxes choose the required settings. 

8. Click Print to print the document. 

Result 

You have printed the (selected) document. 
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Client Side Printing 

Conditions 

You want to print a document you have found on a printer connected to your PC. You can either print it by 
selecting it from the found documents list, when you have already opened it, from the result list for 
batches, or from the document basket.  

Instructions 

1. If you cannot see the print icon  click the Show print button (print client side) on the Global 
Options (page 146) page. 

2. To print click on the print icon . The Print Options window appears. 
 

 
3. Select the Document key fields and/or Document properties you want to print. 

4. Define if you want to 

 Print hits in documents 

 Print documents one by one 
You will have one print job per document, instead of one print job for all documents. 
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5. Click the Preview button to view the page that will precede your printed document. 

6. Click Print. 
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Memory Limit of OS 

When multiple indexes (more than 50) are opened and each index returns multiple results, the system may 
reach the 2 GB RAM limit for application use of the OS. Users get a warning if this happens and the search 
will be terminated. 
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Security 

Securities can be set on different levels on the folders (NTFS Security), documents (Document Security) or 
functionalities (Functional Security). Also, using Audit Trail, all user actions can be logged. 

• Basic (NTFS) Security can be divided in  

 Standard NTFS Security and  

 ZyLAB NTFS Security.  
 
Standard NTFS (Windows New Technology File System) Security provides performance, security, 
reliability, and other advanced features, such as file and folder permissions, encryption, disk quotas, 
and compression. You can enhance this security with File System (Network) Security (page 198). 

• Document (Repository) Security (page 206) 

• Functional (Application) Security (page 215) 

• Audit Trail (page 189) 

Standard Security 

ZyLAB supports standard 
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• VPN (Virtual Private Network) 

• Http (no firewall issues) 

• Secure Https (HTTPS) 

• SAN (Storage Area Network, use mounted drives)  

 
Direct disk access is not required: 

a) A storage area network (SAN) device can be used for (secure) storage of files, 

b) a virtual private network (VPN) connects outside users to the internal LAN, and 

c) a HTTPS connection can provide a secure connection to a Webserver in the demilitarized zone 
(DMZ). 

User Authentication 
• Windows authentication 

 ZyLAB Webserver: IIS Integrated or Basic Clear Text Authentication 

 ZyINDEX, ZyFIND, etc.: Windows logon 

• ZyLAB authentication 

 ZyLAB Webserver only 

 Standard use of SHA1 (Secure Hash Algorithm 1 (see Glossary > Hash code)) to communicate and 
store password hash: 

159 

 



ZyINDEX Manual 

 

- Create a fingerprint from every document/file in the ZyLAB System (ZySCAN Export, Upload 
Webserver). 
- Use secure http (https) to achieve a higher level of security 
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Basic Web Login 

• Webclient login page prepares 
a login request 

• Server processes request: 
- Authenticate user 
- Set security context 
- Check if requested action is 
permitted 

• Server determines the user 
role 

 

161 

 



ZyINDEX Manual 

 

Advanced Web Login 

• Features: 
- Single point of logon 
- Domain user authentication 
- No NTFS permissions required 

• Advantages: 
- Integrated windows 
authentication 
- Better support for NAS and SAN* 
- Restricted access to XML based 
Information store 
 
* ZyLAB Webserver runs 
anonymously under a standard 
user and is able to retrieve files 
from other files servers while the 
user was authenticated using 
challenge response 

 
For more information, see ZyNETLogin 
(page 175). 
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User Management 

Before security can be set, users have to be added to a user database. This database is located at \\ZyLAB 
Data\Users. User groups will be defined in the groups database, and in the group profiles database will be 
defined in which NT groups a certain user is located. After a fresh installation these databases are empty 
and can be filled with the Security tab in ZyINDEX. Underneath the Security tab folders can be found in 
which the users/groups can be imported, created and the identities of the users can be defined.  

Default user roles are created, which can be used or adjusted to fit your needs.  

During installation you can choose between five types of security: 

• No ZyLAB Security: standard network access only 

• Advanced Server: Import user (groups) from the NT domain 
An anonymous user account enables you to access the databases and add your own user (groups). 

• Advanced Server: Enter your own user (groups) 

• Advanced Client: Use existing database (NT domain) 

• Advanced Client: Use existing database (own user groups) 

The first option does not install security. If you are no Domain Administrator, you choose for Advanced 
Server: Import user (groups) from the NT domain. The 4th and 5th option both assume a working security 
database is in place. 
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General 

Before security can be set, users have to be added to a user database. This database is located at 
~\Program Files\ZyLAB\Information Management Platform\Users. User groups will be defined in the groups 
database, and in the group profiles database will be defined in which NT groups a certain user is located. 
After a fresh installation these databases are empty and can be filled with the Security tab in ZyINDEX. 
Underneath the Security tab folders can be found in which the users/groups can be imported, created and 
the identities of the users can be defined.  

Default user roles are created, which can be used or adjusted to fit your needs.  

During installation you can choose between five types of security: 

• No ZyLAB Security: standard network access only 

• Advanced Server: Import user (groups) from the NT domain 
An anonymous user account enables you to access the databases and add your own user (groups). 

• Advanced Server: Enter your own user (groups) 

• Advanced Client: Use existing database (NT domain) 

• Advanced Client: Use existing database (own user groups) 

The first option does not install security. If you are no Domain Administrator, you choose for Advanced 
Server: Import user (groups) from the NT domain. The 4th and 5th option both assume a working security 
database is in place. 
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Settings 

Before you start using ZyLAB Security, walk through some basic settings. 

Instructions 

1. Select ZyINDEX > Security  (or in ZyLAB Web Client click the Admin > Security menu). 

2. Go to General > Settings. 

3. If you want to enable Functional Security, select On. A folder with two subfolders will appear in the tree 
structure. Here you can add security to (functions of) ZySCAN, ZyINDEX, ZyFIND, ZyLAB Web Client and 
ZyALERT. For more information, see Functional Security (page 216) and Functional (Application) 
Security (page 215). 

4. If you want to automatically import NT users (and groups), select On. 

 If you only want to import NT users from existing NT groups, select the check box. 

5. Default Refresh Time (the default time after which newly created or imported users will be expired) 
may be set on  

 No caching 
Each time a user performs an action in ZyINDEX, ZySCAN and ZyFIND, his account will be checked on 
the network. Information about the account, will not be saved. However, this will slow down 
performances. It is the opposite of ‘Never’, where the account will never be checked and exists with 
no time limit. 

 Minute 

 Hour 

 Day  

 Week 

 Month 

 Never 

6. If you want users to renew their session (enter username and password) on the Web Client after a 
certain time frame, select a time frame for Webserver Session Timeout from the dropdown listbox.  

7. If you want to be able to send email (PIN codes) via an external server, define the SMTP server. For 
example, 01.companyname.wan. If no SMTP server is defined, the current machine will be used as 
SMTP server. If you want to send PIN codes, select that option. PIN codes can be sent either locally (for 
example, IIS), or via an external server specified in the field above.  

8. When you are finished, choose one of the following options: 

 If you changed some settings, click Update. 

 If you want to restore the default settings, click Reset. 

 If you want to define settings for users and groups, click Advanced Actions. 
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Result 

You updated or restored the basic settings. 

Note 

Each time the Settings are adjusted, the settings.xml file will be modified, thereby encrypting the 
passwords. 
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Advanced Actions 

In this dialog, you can: 

• Update expire date to one day for "All imported NT users" or "All other users" 

• Create NT groups 

• Import all NT groups 

• Restore subgroups relations 

• Apply NTFS on install directory 
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Groups 

Import Groups 

Conditions 

ZyINDEX > Security is open (or in the ZyLAB Web Client page select the menu Admin > Security).  

Instructions 
1. Go to General > Groups > Import Groups. 

2. Select one of the following options from the Source dropdown listbox: 

 WinNT 
If you want to import Windows NT groups through a domain. 
Working in a network domain, the network administrator already defined for each group a name 
with security policies. Members of the group log on to the network using this account and they will 
be able to navigate over the network. Drives or directories that are secured for this group cannot be 
visited or opened. 

 ZyLAB 
If you want to import groups through (known) ZyLAB groups. 

 Active Directory 
If you want to import groups through distributed networking environments. 

3. If you selected  

 WinNT, select a Domain from the dropdown listbox. 
If you have multiple domains, only trusted domains from the domain your machine is in will be 
known to the application. If therefore your group domain is not listed, you could opt for another 
source, or you can manually create groups (see Create, Edit or Delete Groups (page 169)). 

 ZyLAB, select a Table (database) from the dropdown listbox. 

 Active Directory, select an Organizational Unit from the dropdown listbox. 

4. Select groups from the list, and click Import, or, to import all groups, click Import All. 

Result 

You have imported groups. 

Note 

Whenever you import users/groups from AD (or even RMA) you should adjust the settings.xml (default 
settings.xml looks at ZyLAB Active Directory). 
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Create, Edit or Delete Groups 

After you have created one or more users, you can add them to a group. Users can be added to the default 
ZyLAB User Groups, or you can create new groups. 

Conditions 

ZyINDEX > Security is open.  

Instructions 
1. Go to General > Groups > Available Groups. 

An overview of all available (default ZyLAB) groups is shown. 

2. Click Create. 

3. Define an account name. 

4. Click Create. 

Result 

You have created a new group. Now, users can be added.  

Note 

• To change the name of a group, select it, and click the "Change the name for this group" icon: . 
Change the name, and click OK. 

• To delete a group, select it, and click the "Delete this group" icon: . Click OK. 

• Optimize database is a technical solution, and is not recommended for frequent use. You can use it to 
minimize the size of the ZyLAB user database, after major changes. 
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Add users using a name list 

Conditions 

ZyINDEX > Security is open. You have created a group. You want add users to groups by selecting them one 
by one from a name list.  

Instructions 
1. Go to Security > Groups > Available groups. 

2. Select the correct group. 

3. Click the "Select users to be member of this group" icon: . 

4. Select one or more users (members). 

5. Click OK. 

Result 

You have added users by selecting them one by one. 
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Add users dynamically 

Conditions 

ZyINDEX > Security is open. You have created a group. You want to dynamically add users to groups by 
selecting them with a template or query based on field values. 

Instructions 
1. Go to Security > Groups > Available groups. 

2. Select the correct group. 

3. Click the "Define templates or queries to dynamically add users to this group" icon: . 

4. Click Create (or Create with user fields) 

5. Select one or more fields and define the values you want to use to create a group. For example, for 
Field 'Department' enter the Value 'sales'. Now, every user with Value 'sales' (see Create users (page 
179)) will be added to the User group. 

6. Click OK. 

7. Click Close. 

Result 

You have dynamically added users by selecting them with a query (based on field values). 
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Add subgroups 

Conditions 

ZyINDEX > Security is open. Groups are created. You want to add subgroups. 

Instructions 
1. Go to Security > Groups > Available groups. 

2. Select the correct group. 

3. Click the "Add and remove subgroups" icon: . 

4. Select one or more groups (subgroups). 

5. Click OK. 

Result 

You have added users by selecting groups (subgroups). 
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Users 

Import Users 

Conditions 

One of the first steps in Security is to import or create users. There are two default users, the anonymous 
and the administrator. One user is created for you, so that you can manage the accounts. If that is not done 
yet, you can follow the steps below to import yourself (and other users). 

Instructions 
1. Open ZyINDEX > Security (or in ZyLAB Web Client click the menu Admin > Security). 

2. Go to General > Users > Import Users. 

3. Select one of the following options from the Source dropdown listbox: 

 RMA 
If you want to import users through the Records Management Application. 

 WinNT 
If you want to import Windows NT users through a domain. 
Working in a network domain, the network administrator already defined for each user an account 
name with security policies. Users log on to the network using this account and they will be able to 
navigate over the network. Drives or directories that are secured for this user cannot be visited or 
opened. 

 XML 
If you want to import users through an XML list. 

 ZyLAB 
If you want to import users through (known) ZyLAB users. 

 Active Directory 
If you want to import users through distributed networking environments. 

4. If you selected  

 RMA, select a Location from the dropdown listbox. 

 WinNT, select a Domain from the dropdown listbox. 
In case you have multiple domains, only trusted domains from the domain your machine is in, will 
be known to the application. If therefore your user domain is not listed, you could opt for other 
user types, like import from a XML file, or you can manually key in users (see Create users (page 
179)).  

 XML, select a File from the dropdown listbox. 

 ZyLAB, select a Table (database) from the dropdown listbox. 

 Active Directory, select an Organizational Unit from the dropdown listbox. 

5. Select individual users from the list. 

6. Click Import user(s). 
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Result 

You imported users through the RMA, a Windows NT domain, a XML file or a ZyLAB table. 

Note 
• The authentication of the users will be done automatically with use of the NT domain security settings. 

The users and groups used for the NTFS security has to be NT based otherwise the authentication will 
not work. Also see, ZyNETLogin: Import Windows NT users (page 175). 

• Whenever you import users/groups from AD (or even RMA) you should adjust the settings.xml (default 
settings.xml looks at ZyLAB Active Directory). 
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ZyNETLogin: Import Windows NT users 

ZyNETLogin enables you to authenticate users by using integrated or basic clear text authentication. This 
will allow you to import Windows NT users, without manually adding (new) passwords to the ZyLAB User 
tables, while still keeping a firm security policy in place. If a user is authenticated, then ZyNETLogin 
generates a cookie using the random password that was generated for the user when the account was 
imported. This cookie and a login page is submitted to the client which can then automatically logon to the 
Web Client. The webserver zynet.exe is running in anonymous mode as a user that has full permissions to 
access the indexes and data. 

ZyNETLogin gets you authenticated on the domain, takes your username, searches the name in the User 
table, and gets the password you have in ZyINDEX. It encodes the password and username in the cookie 
and hands over the cookie. Then it goes to the default login page for automatic login. As you see it does not 
matter what password you use for the user. 

Instructions 
1. Go to Start > Settings > Control Panel > Administrative Tools > Internet Information Services (IIS). 

2. Right click the Websites folder and select Properties. 

3. Select the Directory Security tab. 

4. Click Edit. 

5. Select as the Authentication method (Anonymous and) Integrated Windows Authentication, and click 
OK. 
If selecting Anonymous: 

a) Select the Exe folder. 

b) In the right pane right click ZyNETLogin.exe.  

c) Select Properties.  

d) Select the File Security tab.  

e) Select Edit. 

f) Select just Integrated Windows Authentication. 

g) Click OK twice. 

6. Import users from WinNT/Domain to ZyINDEX.  
For more information, see Import users (page 173). 

7. Apply rights as necessary: webclient, indexes, data, ZyFILES, OS files, etc. 

8. Create a new Webclient: 

a) Go to ZyINDEX > Webclient 

b) Go to File > New. 

c) Define the Long Client Name, HTTP alias, client email address (for example, support@...com) 

d) Click OK. 

9. Select the Indexes folder, and click Select. 
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10. Select one or more indexes, and click OK. 

11. Add users to the Webclient: 

a) Select User Roles > Administrator. 

b) Deselect "Inherit from ZyLAB roles". 

c) Select ZyLAB_Administrators, and click Delete. 

d) Click Add. 

e) Select a user or user group, and click OK. 

f) Repeat step d and e to add more users or groups. 

g) Delete the standard (inherited) user groups for Editor, User and Guest. 

12. Select the Templates folder, and select Advanced Security from the dropdown listbox. 

13. Click Yes, click Apply, click Yes. 

Note 

If ZyNET or ZyNETlogin (advanced security) is running in integrated authentication mode in IIS, users that 
are members from imported LDAP groups are not automatically imported in ZyLAB security based on their 
group membership when they perform an automatic login action to access a WebClient (This information 
applies to: ZyINDEX Security, Version V5.0 SP4c). 

For more information on how to solve this, see Knowledge Base article PZ01713. 
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Automatic user import from LDAP groups 

Problem 

Users in groups imported from an active directory using WinNT or LDAP are not authenticated at logon.  

When an active directory group is imported in ZyLAB security users, that group is not authenticated and 
added to the ZyLAB security user database.  
When a LDAP group is imported a member of this group that is logged on as the current logged is not 
authenticated by ZyLAB security.  
If the ‘Automatic logon’ setting is active in ZyLAB security (General/Settings) users in LDAP groups should be 
automatically imported in the ZyLAB security users database from the LDAP group directory when logging 
on to a WebClient (Automatic login) or starting a ZyLAB windows application.  
This is not happening, users are not imported and thereby authenticated as an anonymous user account 
that can result in denied access permissions. 

Solution 

If you want to setup import from active directory, you have to complete the "activedirectory" attribute 
(marked with green). If it appears you can automatically import or refresh a user when logging in using 
'basic clear text' authentication but not when using 'integrated windows' authentication, then probably you 
have to configure a special user and password which has rights to access the active directory (marked blue). 

How to configure ZyLAB LDAP integration to import users and LDAP groups from an active 
directory to support users to be automatically imported from imported LDAP groups on logon. 

When a LDAP group is imported, a member of this group who is logged on as the current logged can be 
authenticated by ZyLAB security. In case the ‘Automatic NT Import’ setting is active in ZyINDEX Security > 
General > Settings, users in LDAP groups can be automatically imported in the ZyLAB security users 
database from the LDAP group directory when logging on to a WebClient (Automatic login) or starting a 
ZyLAB windows application. 
To do so you must specify the active directory domain name you want to connect to in the settings.xml 
file which can be found in the ZyLAB\Users folder. 

1. Go to the ‘Domains’ section, which is the first configurable section in the settings.xml: 
 
Example: 
<settings id="Domains" activedirectory="LDAP://domainname/DC=domain name,DC=domain 
extention"> 

2. Add in the ‘domain name’ section the name of the domain you want to connect to. 
This is the domain name without the domain extension.  

3. In order to retrieve active directory information you need to query the domain, to do so you must 
specify the separate domain components (DC’s) in the LDAP connection path.  
(There are freeware tool available to retrieve LDAP paths (DC’s etcetera) and many more LDAP 
compliant properties from the active directory.) 
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A domain can consist of multiple DC’s for example SAMPLEDOMAIN and WAN these are two domain 
components in the full domain name: ‘sampledomain.wan’. 
Add the DC strings next to the domain name separated by commas in the “Domains” section. 
 
Example:  
<settings id="Domains"activedirectory="LDAP://sampledomain/DC= sampledomain,DC=wan "> 

4. Leave the WinNT string as it is, it is not required to configure a WinNT import source when you are 
using LDAP import. 
 
Example:  
<source id="WinNT://SAMPLEDOMAIN">SAMPLEDOMAIN</source>  

5. To connect to an organizational unit in the active directory in order to retrieve the actual users 
accounts/groups it contains you need to query the LDAP domain with the /OU argument 
(organizational unit). 
In order to do so you need to specify the organizational unit to be queried (for example the 
organizational unit in England: SAMPLEDOMAINUK) followed by the domain components that have to 
be specified in separate domain component strings DC’s. 
It is possible to retrieve more then one organizational unit from a LDAP source. 

6. Add the OU connection strings in the ‘Active Directory|Organizational Units’ section: 
 
Example:  
- <settings id="Active Directory|Organizational Units"><source 
id="LDAP://SAMPLEDOMAIN/OU=SAMPLEDOMAINUK,DC=SAMPLEDOMAIN,DC=WAN">England</sourc
e> 
</settings> 
 
(Between the angle quotation marks you can find the name that is displayed in the organizational unit 
selection list in ZyLAB security for example ‘England’.) 

7. In case required you can authenticate to the LDAP directory by specifying your users name and 
password. 
Add this authentication line as the first line in the ‘Active Directory|Organizational Units’ section: 
 
Example:  
<source id="LDAP://SAMPLEDOMAIN" username="SAMPLEDOMAIN\JOHN" 
password="mypassword"/> 

Note 

If ZyNET or ZyNETlogin (advanced security) is running in integrated authentication mode in IIS, users that 
are members from imported LDAP groups are not automatically imported in ZyLAB security based on their 
group membership when they perform an automatic login action to access a WebClient (This information 
applies to: ZyINDEX Security, Version V5.0 SP4c). 

For more information on how to solve this, see Knowledge Base article PZ01713 
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Create Users 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the Security icon: . 

2. Go to General > Users > Available Users. 
An overview of all available (default ZyLAB) users is shown. 

3. Click Create. 

4. Define an Account name. 

5. Define the Fullname. 

When auditing, this full username will be registered in the Audit trail, and used for logging the user. 

6. Click Create.  

Result 

You have created a user. 

Note 
• Two important options are to Reload or Refresh user(s) from the original source. This makes sure that 

all user properties are synchronized. Reload will check if the user is still present in the domain, and if 
so, update the expiration date. Refresh will check if there are any modifications. Changes that are made 
to users via WinNT will be updated.  

• Optimize database is a technical solution, and is not recommended for frequent use. You can use it to 
minimize the size of the ZyLAB user database, after major changes. 
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Define User Identities 

Conditions 

The identities of users can be defined by adding values to relevant user fields, such as Company, 
Department, Address, etc. 

Instructions 
1. In ZyINDEX > Security, select Users > Available Users. 

2. Select a user. 

3. Select Edit user fields . 

4. Fill out/edit the (relevant) fields. 

5. Click OK. 

Result 

You have added/edited information about the identity of a user. 

Note 
• In the ZyLAB user groups the added information can be used to base queries on and store the results of 

the query in a user group. For instance, create a couple of new users with in the department field the 
value sales. They will become a member of the sales group (if the sales group is defined of course). 

• Two important options are to Reload or Refresh user(s) from the original source. This makes sure that 
all user properties are synchronized. Reload will check if the user is still present in the domain, and if 
so, update the expiration date. Refresh will check if there are any modifications. Changes that are made 
to users via WinNT will be updated.  

• Optimize database is a technical solution, and is not recommended for frequent use. You can use it to 
minimize the size of the ZyLAB user database after major changes. 
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View User Properties 

Conditions 

You want to view the user properties of a user. 

Instructions 
1. In ZyINDEX > Security, select Users > Available Users. 

2. Select a user. 

3. Select User properties: date created/modified/expired . 

4. Click OK. 

Result 

You have viewed the user properties of a user. 
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Add/change password 

Instructions 
1. In ZyINDEX > Security, select Users > Available Users. 

2. Select a user from the list. 

3. Select Set user password . 

4. Define a (new) password and repeat it. 

5. Click Change password. 

Result 

You have created/changed the password. 

Note 

This User/Password combination will be used in ZyINDEX, and is different from the domain password. 

Difference between passwords and PIN codes 
• Every user in ZyINDEX can have a PIN code, but imported users preferably do not have a ZyINDEX 

password. 

• PIN codes are saved in another way than passwords. PIN codes are essential for the use of digital 
signatures. If a user signs with a different PIN code, this will result in a different signature. Therefore, an 
overview of old PIN codes (and their users) is kept, so also signatures set with old PIN codes can be 
checked for authenticity. 

• Users receive a certificate that their PIN code is submitted by ZyLAB.  
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Create/change PIN code 

Conditions 

You want to create a PIN code for a user, so he can get access to documents with Digital Signature fields 
(for example in Modules > Workflow (see the ZyLAB Workflow manual > Security (page 268) > Digital 
Signature (page 270))). 

Instructions 
1. Go to ZyINDEX > Security. 

2. Select General > Users > Available Users. 

3. Select a user. 

4. Click the "Generate a new PIN code for the user" button . 

5. Determine if the user should have a 4 or 6 digit PIN code.  
A 6 digit PIN code is safer, but a 4 digit PIN code is easier to remember. 

6. Determine the expiration time (number of days valid) of the pincode. 

7. Fill out the email address of the user.  
An email will be sent to the user with the PIN code in the subject line. 

8. Fill out the email address of the sender. 
This can be a random address. 

9. Click Generate. 

Result 

You have generated a PIN code for a specific user. 

Difference between passwords and PIN codes 
• Every user in ZyINDEX can have a PIN code, but imported users preferably do not have a ZyINDEX 

password. 

• PIN codes are saved in another way than passwords. PIN codes are essential for the use of digital 
signatures. If a user signs with a different PIN code, this will result in a different signature. Therefore, an 
overview of old PIN codes (and their users) is kept, so also signatures set with old PIN codes can be 
checked on authenticity. 

• Users receive a certificate that their PIN code is submitted by ZyINDEX.  
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Remove Users 

Instructions 
1. In ZyINDEX > Security, select Users > Available Users. 

2. Select a user from the list. 

3. Select Delete this user . 

4. Click OK. 

Result 

You removed a user from the ZyINDEX Users list. 
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Search Users/Groups 

Conditions 

You want to search on a specific user or group name. 

Instructions 
1. Go to ZyINDEX > Security. 

2. Select Security > General > Groups (or Users) > Import Groups (or Users). 

3. Select as Source, from the dropdown listbox, the Active Directory. 

4. Select an Organizational Unit. 

5. Click on the Search User/Group icon . 
The Active Directory Search dialog appears. 

6. Define a search value. 

7. Click OK. 

Result 

You have searched on a specific user or group name. 
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Expand this level/recursively 

Conditions 

You want to search for users/groups on a specific part of an organizational unit. 

Instructions 
1. Go to ZyINDEX > Security. 

2. Select Security > General > Groups (or Users) > Import Groups (or Users). 

3. Select as Source, from the dropdown listbox, the Active Directory. 

4. Select an Organizational Unit. For example, Sales. 

5. If you want to expand the level of the selected Organizational Unit, click the Expand this level icon. This 
will result in, for example, the sublevels Sales UK, Sales US, and Sales Europe. To view the sublevels, 
select the dropdown listbox Organizational Unit. 

6. If you want to expand once more, click the Expand recursively icon. This will result in, for example, the 
sublevels Sales Netherlands, Sales Germany, Sales France (for the sublevel Sales Europe). 

If you want to return to the previous level, select the Expand this level icon again.  

7. Select the (sub)level you want to search, via the dropdown listbox Organizational Unit. 

8. Click the Load button. 

Result 

You have searched for users/groups on a specific part of an organizational unit. 
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XML Backup 

Conditions 

You want to backup or restore users, groups and/or profiles. 

Instructions 
1. Go to ZyINDEX > Security. 

2. In the General folder, select XML Backup. 
The Security XML Backup screen appears. 
 

 
3. Define the Object Types you want to backup/restore. Choose from: 

 Users 

 Groups 

 Profiles 
Profiles describe the relations between users and groups (memberships as well as sub-group 
relations). For example, define for a user the groups of which he is a member via Available users > 

Edit group memberships for this user   

4. To backup (export) to an XML file, define the file you want to export to, and click Backup. 

 Overwrite existing file 
During backup an existing XML file will be replaced. 
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 Keep original object id's 
Each object has its own unique ID number, a GUID (for example, {A85924EA-A572-4F92-B454-
A1F76F118C44}). By default, this number will be backup to allow occurrences of the same number 
in the database (possible if an object with saved GUIDs is imported twice). A user may, for example, 
appear in more than one group. 

5. To restore (import) objects from an XML file, select the file you want to import from the dropdown 
listbox, and click Restore. 

You can also choose to delete a (backed up) XML file, if it has become obsolete. 

 Assign original object id's (if possible) 
Only possible, if you kept the original object id's. 

 Restore all objects present in the file (selected object types will be ignored) 
If this option is selected, you do not have to choose the objects to import.  

 Replace existing objects (warning: existing data will be permanently deleted!) 
Every table in which objects are imported, are cleaned first. 

Result 

You have backed up and/or restored users, groups and/or profiles. 
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About Audit Trail 

The Audit Trail module stores in an XML file all user activities such as searching, viewing and editing 
documents and opening, deleting and building indexes. Every user action performed on the audited index 
creates XML files containing information on the action, the user, etc. You can select the activities you want 
to store in the XML file. With ZyLAB you are able to index and search all these XML files and view the 
activities the users have performed. 

Once a user (administrator) enables Audit Trail in ZyINDEX, all user actions performed on the chosen index 
will be logged (when selected) by the Audit trail, including ZyFIND, ZyINDEX and ZySCAN actions. By default, 
the module audits 43 actions, but an administrator can enable or disable individual Audit trail actions.  

Audit trail generates a new XML document for every selected Audit action performed by a user to store the 
log data. These XML files are stored (by default) in folders in the directory ~\\ZyLAB Data\Index 
Data\<<short name>>\XML by a Hash Table system to minimize the retrieval time. This means that ZyINDEX 
in the beginning will create a new folder for every new XML document and starts filling the folders 
afterwards.  

As mentioned, every selected Audit action that a user performs will generate an XML document containing 
the logged information. The name of the XML file is a GUID (Global Unique ID). All extra information about 
the XML file is stored in a database. This database can be found in the index directory (\\ZyLAB 
Data\Indexes\<<short name>>\ZxpPlugins\audit) and is called AUDIT.dbf. Much information is logged in 
this database and are linked with the XML files due to the GUID. Some examples are: User, Computer 
name, date and time, index name, file name, Guid, Application. For more information about the data that 
can be logged, see Retrieve Audit Trail data (page 192). 
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Create an Audit Trail index 

Instructions 
1. Open ZyINDEX > Build. 

2. Go to File > New. 

3. Enter a Short name (for example, Audit). 

4. Enter a Long name (for example, Audit Trail Index). 

5. Select Audit trail database. 

6. Click OK. 

7. An Audit trail index contains 12 fields by default. To be able to search on these fields in ZyFIND, do the 
following: 

a) Select Define Fields . 

b) Select a field. 

c) Select Edit definition. 

d) Select the Search tab. 

e) Select Add to index. 

f) Click OK. 

g) Repeat steps a to f for every field you want users to be able to search on. 

h) Click OK. 

8. Build the index once: Click Build > Now (blue triangle) > Go > OK. 
The Audit Trail index is built and ready to store all actions for specific indexes. 

Note 

The user has to enable Audit in ZyINDEX and select the Audit Trail index to be used to log audit actions, and 
to select the Indexes and Jobs that must be audited. See Enable Audit Trail (page 191). 
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Enable Audit Trail 

Instructions 
1. Open ZyINDEX > Build. 

2. Open the index you want to audit. 

3. Click on Index Settings  and select the Settings tab.  

4. Make sure the Audit option is selected.  

5. Click OK. 
Now all actions related to this index will be audited. 

6. Go to ZyINDEX > Security > General > Audit Trail. 

7. Select Enable Audit Trail. 

8. Select an Audit Trail index from the dropdown listbox. 

9. Click Save. 

10. Deselect the actions you do not want to Audit. 

11. If you want to enable Audit trail in one or more indexes, click the Indexes button. 

 Select the indexes you want to Audit. 

 Click OK. 

12. If you want to enable Audit trail in one or more job templates, click the Job Templates button. 

 Make sure that the job templates you want to Audit are selected. 

 Click OK. 

13. Click Save. 

Result 

Your actions on the selected indexes and job templates will now be saved in the Audit Trail index. 

You can use ZyTIMERService and Quickbuild to build the Audit Trail index every 10 minutes. 
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Retrieve Audit Trail data 

Instructions 
1. Open ZyINDEX and build your Audit Trail index. 

2. Start ZyFIND. 

3. Go to File > Select Index(es) > Audit Trail tab. 

4. Select the Audit Trail index. 

5. Click OK. 

6. Search for EOD and select 'Search Audits'. 
This will list all Audit Trails.  

If a normal search is done on the Audit Trail index, you get a result list that is filled with XML files that 
contain the logged document actions done by the users. 

7. Open one of the results. The contents will be similar to the following example: 

<ID>{BB1A09AF-98F9-4225-A5CB-68D125C087F7}</ID> 
<TYPE>11</TYPE> 
<APP>ZYFIND.EXE</APP> 
<DATE>Wish lists.xls</DATE> 
<USER>ZYLAB\Gerry as ZyLAB Anonymous User {9B2473D0-4FC5-1348-AA20-
D1FEDF5E629C}</USER> 
<COMPUTER>ZYNLWS0230</COMPUTER> 
<DOCNAME>Wish lists.xls</DOCNAME> 
<DOCPATH>C:\TEMP\CULLING INPUT\</DOCPATH> 
<INDXNAME></INDXNAME> 
<INDXPATH>C:\ZyLAB Data\Indexes\ZyEXAMPL</INDXPATH> 
<DOCFLDS> 

The fields displayed contain the audit trail information (see table below). These are stored in the audit 
database. 

The additional XML file can contain more information on the event, for example the result list from 
ZyRESULT. 

The following table shows the available fields and a description of their contents. 
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Field name 
containing logged 
info 

Description 

ID Global Unique ID 

Type The reference number of the action that was performed by 
the user (see he following table for a list of these numbers 
and their descriptions). 

Application ZySCAN, ZyINDEX or ZyFIND 

Date Creation date of XML log file 

User User whose action has been logged 

Computer Computer that processed the action 

Document name Document on which the action was performed by user (if 
applicable) 

Document Path Path of this document 

Index name Index on which the action was performed by user (if 
applicable) 

Index path Location of this index 

Info Additional event details, depending on type of event 

Last modification 
date 

Last modification date of the document (if applicable) 

Filename Name of the XML log file 

Path Path of the XML log file 

Creation Date Creation date of the XML log file 

Size Size of the XML log file 

For all ZySCAN (job template) events, the following additional information is logged as a field value:  

• Job name, 

• Job root path 

• Template name. 

For example: <job name="00000000" path="C:\ZyLAB Data\ZySCAN Jobroot" template="template.job"/> 

The Type number in an Audit Trail shows the action that was logged. The value of this field is shown in the 
result list, but in ZyVIEW the values will only be shown when you double-click the field. 
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Type 
No. 

Description What will be logged? 

0 Search Index The search statement(s). 

1 Get results The result list. 

2 Create Index The index that was created. 

3 Delete Index The index that was deleted. 

4 Erase Index The index that was erased. 

5 Import index A modification in the modfiles database. 

6 Edit document fields Document fields that have been edited. 

7 Delete document The document that was deleted. 

8 Merge documents Documents that have been merged. 

9 Split document Documents that have been split. 

10 Delete page The page that has been deleted. 

11 View document The document that is viewed. 

12 Export document The document that is exported. 

13 Print document The document that is printed. 

14 Start application The ZyLAB application that is started. 

15 End application The ZyLAB application that is ended. 

16 Start function The ZyLAB function that is started. 

17 Stop function The ZyLAB function that is stopped. 

18 Open Job The job that is opened. 

19 Close Job The job that is closed. 

20 Delete Job The job that is deleted. 

21 Create New Job The new job that is created. 

22 Create New Job 
template 

The new job template that is created. 

23 Create document The document that is created. 

24 Create page The page that is created. 

25 Export page The page that is created. 

26 Enable audit trail Audit trail is enabled. 

27 Disable audit trail Audit trail is disabled. 

28 Change audit trail index The audit trail index that is changed. 

29 Change audit trail event The audit trail event that is changed. 

30 Generate PIN code The PIN code that is generated. 
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31 Enable add document 
fields 

Add document fields is enabled. 

32 Disable add document 
fields 

Add document fields is disabled. 

33 Create redaction A redaction was created 

34 Modify redaction A redaction was modified 

35 Delete redaction A redaction was deleted 

36 Create TIFF conversion A TIFF conversion was done 

37 Delete TIFF conversion A TIFF conversion was deleted 

38 Import user group A user group was imported 

39 Delete user group A user group was deleted 

40 Change user group A user group was changed 

41 Change general settings The general settings were changed 

42 Audited: Indexes / Job 
Templates 

Which indexes and/or job templates were audited 

43 Change file system 
security 

The file system security was changed 

44 Change document 
security 

The document security was changed 

45 Change functional 
security 

The functional security was changed. 

The easiest way to retrieve this log information is to press  in the vertical icon bar of ZyFIND. 

Obviously, you can also perform full-text search queries on the Audit Trail index. Any other feature that is 
available for regular indexes is also supported for Audit Trail indexes. For information about the Field 
viewer, see Indirect (Field) Search: Retrieve Documents (page 196). 
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Indirect (Field) Search: Retrieve Documents 

When the audit trail index is selected in ZyFIND, it is possible to search on the fields of the audit index. If 
you want to see the actual documents users viewed, it is possible to do an indirect search. An indirect 
search means that you search for every document that has been, for example, viewed and see the actual 
results instead of the XML files containing the name of the viewed document. Now you can see the viewed 
documents yourself, read the information and export or copy them.  

For indirect searching you need to select not only the Audit Trail index, but also the index that contains the 
documents you want to view. Also, the option ‘Search Documents’ and 'With Audits' has to be enabled to 
do such a search (these options are available when the Audit index is selected): 
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Suppress job in Audit Trail 

It is possible to log all actions of ZySCAN which are defined in an Audit Trail index, therefore it is possible to 
see exactly who, and on which day, and at what time, opened a job, closed a job, deleted a job, created a 
new job, created a new job template, created a new text (txt/XML) file, created a new image (TIFF) file, 
exported an image (TIFF) file and edited fields. 

 

If you want to prevent that actions performed during a job in ZySCAN are logged, select 'Suppress job in 
Audit Trail' when creating a job template. Using this template when processing a job deactivates the Audit 
Trail in ZySCAN. 

If you are running a large number of jobs, it may be convenient to turn the Audit Trail off. It will prevent the 
accumulation of large quantities of data, which could potentially slow down system performance.  

197 

 



ZyINDEX Manual 

 

 

File System (Network) Security 

File System or Standard NTFS (Windows New Technology File System) Security provides performance, 
security, reliability, and other advanced features, such as file and folder permissions, encryption, disk 
quotas, and compression.  
ZyLAB NTFS Security can be given on general folders of ZyLAB (installation directory, indexes directory, 
index data directory, etc.) and the different folders of the index. NTFS rights are set on the actual files of 
the archive, or the data, or the program. This is normally done when setting up the program, and this is a 
task for an administrator. NTFS rights are irreversible, so make sure that you do not exclude yourself from 
the list. Always make sure that the Administrators group has full control. 
The NTFS security module enables you to create an index that leaves the results a user is not authorized to 
see out of the result list. The references of the documents that are shown in the result list are only the 
references to the documents that the user is allowed to see. When you set normal NTFS security (without 
using the module) on folders containing documents or document groups, you will see the results you are 
not allowed to open appear in the result list. If you double click such a reference the program will tell you 
that the document can not be opened. 

In order to set NTFS Security, create a NTFS Security index. The locations (folders and subfolders) where the 
data is stored, can be secured with the help of the module. 

If you build an index and set security on the data folders over which the index is built, you will still be able 
to search on the full-text of all the documents that are in the data folder. The reason for this is that the 
contents of all the documents are stored in the index and as long as you have access to that index you can 
search on every word that is in the index and hence know if the word(s) you are searching for are present. 
The only thing is that the documents cannot be opened when you select a reference, or do not even appear 
in the result list (if you use the NTFS Security Module). 

Once you have created a NTFS Security index, you can assign NTFS rights to user groups. You can enable 
user rights on for instance the wwwroot (where web clients are called from). This enables you to set rights 
for groups to access the entire website. It is not intended for setting rights to individual web clients. It is 
best to let an administrator first design a security plan, and then enforce it. That limits the chance that you 
get locked out. As said earlier; setting NTFS rights is usually irreversible! 

NTFS rights with custom groups can only be set if you have chosen NTFS rights during installation, or when 
the appropriate groups have been created on the domain. NTFS group rights settings exist on the basis of 
user groups on the local domain, or machine. If you have not created user groups on the domain, you will 
only see default domain user groups, not the ZyLAB user groups. Individual (imported) users will be seen by 
the NTFS security setting engine, because these can be led back to their original NT user account. 

You can set rights for specific indexes and data. This enables individual settings per index. Once again bare 
in mind that settings are basically irreversible, and limited to the installation type! 
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Create an NTFS Security index 

Instructions 
1. Open ZyINDEX > Build. 

2. Go to File > New.  

3. Fill out a Short Index Name (max. 8 characters).  

4. Fill out a Long Index Name (max. 80 characters). Describe the contents of the index in more detail.  

5. Select Index Wizard.  

6. Click OK.  

7. Click Next. 

8. Select NTFS Security and use the arrow to the right to select the module. 

9. Click Next four times. 

10. Select 'Enable default NTFS security'. 

11. Click Finish. 

12. Click on the Now button (blue triangle) to build the index for the first time. 

13. Click Go. 

14. Click OK to finish the build process.  

Result 

You created a NTFS Security index. 
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Set General NTFS Security 

Instructions 

1. Go to ZyINDEX > Security . 

2. Select File System (Network) Security. 

3. Select General from the dropdown listbox. 

4. Select from the Section dropdown listbox, one of the following options: 

 All Files and Folders 

 Bookmarks 

 ZyALERT default 

 ZyIMAGE directories 

 ZyIMAGE License 

 ZyIMAGE User 

 ZyIMAGE Webserver 

 ZyINDEX Default 

 ZySCAN Default 

The folders, files, directories, etc. on which rights can be set, will be listed and numbered. Each folder, 
file, etc. is accompanied by user groups on which rights (permissions) can be set. 
Grey user groups (g) can only be viewed, their rights are inherited. 
Blue user groups (g) can be edited, their rights are 'access granted'. 
Red user groups (d) can be edited, their rights are 'access denied'. 
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5. Click on a user group, for which you want to set/edit or view NTFS Security rights. 
The View/Edit Permissions dialog appears. 

 
6. For each group, you can select Users, Groups and Roles from the dropdown listboxes. 

7. The rights (permissions) may be applied onto: 

 This folder only 

 This folder, subfolders and files 

 This folder and subfolders 

 This folder and files 

 Subfolders and files only 
So, not on the folder on which the permission is set! 

 Subfolders only 

8. Select the permissions for this user group. You can choose from: 
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 Full control (f) 
Allows viewing, running, changing, deleting, and changing owner 

 Modify (m) 
Allows viewing, running, changing, and deleting 

 Read and Execute (e) 
Allows viewing and running 

 Read (r) / List folder contents (l) 
Allows viewing 

 Write (w) 
Allows viewing, running, changing, and deleting 

Each selected right (permission) is displayed with a character. The inheritance type is also displayed 
with a character: 
o: Object Inheritance (file inherits the right) 
c: Container Inheritance (folders inherit the right) 
p: No Propagate (subfolders and files inherit the right, but not subfolders of subfolders or files of 
subfolders) 
i: Inherit Only (right is inherited, but not for the folder itself) 
h: Inherited (right is inherited, set on a higher level (and thus displayed in grey)) 

9. Alternatively, you can select 'Apply these permissions to objects and/or containers within this container 
only'. 

10. Click OK. 

11. Repeat these steps for the different sections and user groups for which you want to set NTFS Security 
rights. 

Result 

You set the NTFS Security rights for a number of sections and user groups. 
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Set Index NTFS Security 

Conditions 

You created an NTFS Security index. ZyINDEX is open. 

Instructions 

1. Select Security . 

2. Select File System (Network) Security. 

3. Select an index from the dropdown listbox 

If you select an index, created without the NTFS Security module, but with the option 'Enable functional 
security and default NTFS security' selected (Step 6: Security), you can also set the index NTFS rights. 
However, users will be able to see the documents (they are not allowed to open) in the result list. 

4. Select from the Section dropdown listbox, one of the following options: 

 All Files and Folders 

 Data Directories 

 Index Character Set 

 Index Directory 

 Index Fields 

 Index Noise Words 

 Index Operators 

 Table Of Contents 

The folders, files, directories, character sets, etc. on which rights can be set, will be listed and 
numbered. Each folder, file, etc. is accompanied by user groups on which rights (permissions) can be 
set. 
Grey user groups (g) can only be viewed, their rights are inherited. 
Blue user groups (g) can be edited, their rights are 'access granted'. 
Red user groups (d) can be edited, their rights are 'access denied'. 
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5. Click on a user group, for which you want to set/edit or view NTFS Security rights. 
The View/Edit Permissions dialog appears. 

 
6. For each group, you can select Users, Groups and Roles from the dropdown listboxes. 

7. The rights (permissions) may be applied onto: 

 This folder only 

 This folder, subfolders and files 

 This folder and subfolders 

 This folder and files 

 Subfolders and files only 
So, not on the folder on which the permission is set! 

 Subfolders only 

8. Select the permissions for this user group. You can choose from: 
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 Full control (f) 
Allows viewing, running, changing, deleting, and changing owner 

 Modify (m) 
Allows viewing, running, changing, and deleting 

 Read and Execute (e) 
Allows viewing and running 

 Read (r) / List folder contents (l) 
Allows viewing 

 Write (w) 
Allows viewing, running, changing, and deleting 

Each selected right (permission) is displayed with a character. The inheritance type is also displayed 
with a character: 
o: Object Inheritance (file inherit the right) 
c: Container Inheritance (folders inherit the right) 
p: No Propagate (subfolders and files inherit the right, but not subfolders of subfolders or files of 
subfolders) 
i: Inherit Only (right is inherited, but not for the folder itself) 
h: Inherited (right in inherited, set on a higher level (and thus displayed in grey)) 

9. Alternatively, you can select 'Apply these permissions to objects and/or containers within this container 
only'. 

10. Click OK. 

11. Repeat these steps for the different sections and user groups for which you want to set NTFS Security 
rights. 

Result 

You set the NTFS Security rights for a number of sections and user groups for a specific index. 
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Document (Repository) Security 

Document Security enables you to secure your indexes on document level, and allow access to certain 
groups of documents, based on a field query. Document Security is based on the meta information of the 
documents. First, document groups have to be created that contain users or user groups. To these created 
groups queries over the meta information of the index can be added. So everybody who is a member of a 
certain group is only allowed to view the documents that meet the defined search query. Document 
Security is effective only if field values are added during archiving. 

There is of course an evident relation between document security and functional security. The actions that 
can be done on the documents are secured with functional security. So in case you allow a user group to 
search in certain document groups, the actions the user group can perform on the documents depend on 
the given functional security. 

In order to use document security on indexes, the Document security module has to be selected when you 
create the index (step 2 of the Index wizard). Do not forget to define the fields; document security is based 
on them. For more information, see Create Document Security index (page 207). 
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Create Document Security index 

Instructions 
1. Open ZyINDEX. 

2. Select the Build icon. 

3. Go to File > New.  

4. Fill out a Short Index Name (max. 8 characters). 

5. Fill out a Long Index Name (max. 80 characters). Describe the contents of the index in more detail. 

6. Select Index Wizard.  

7. Click OK. 

8. Click Next. 

9. Select Document Security and use the arrow to the right to select the module. 

10. Click Next three times. 

11. Click Define. 

12. Click Add definition to define a new field. 

13. Fill out the Name field, and select a Type from the dropdown listbox. 

14. Select the Search tab. 

15. Make sure "Add to Index" and "Input required for searching", and "Add to index comment" and "Show 
in result list" are selected. 

16. Click OK. 

17. Repeat step 14 to 18 to add more fields. 

18. Click Next. 

19. Click Finish. 
The Document Security index is created. 

20. Go to ZyINDEX and click on the Now button (blue triangle) to build the index for the first time. 

21. Click Go. 

22. Click OK to finish the build process.  

Result 

You created a Document Security index and added fields. These fields enable Document Security. Add 
documents, fill out the field values, and build the index again. Now the index is ready for full-text searching. 

Note 

The Document Security index may be added to an (Enterprise) Web Client. This will allow users to use 
Document Security via the web. 
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Set-up Timer Service 

It is recommended that the TIMER Service is used to build the index automatically after changes to fields, 
thus ensuring that the index is always up-to-date. Installing the Timer as a service enables the Timer to run 
constantly in the background, building the index as changes are made (Automatic mode) or at a set time 
frequency (manual settings). 

Note: You can only apply automatic mode when the selected index has quick-build 
enabled. 
 
Note: As the Timer is run as a Windows Service, it continues to run in the background, 
even when ZyINDEX is closed. 

Instructions 

1. Select the TIMER icon . 

2. Click New to display the Add index window. 
 

 
3. Click Select.  

The Select Index window appears.  

4. Select the (Document Security) index.  

5. Click OK. 

6. Select the mode: 

 Automatic mode starts a quick-build each time an Index item is changed or added. 

Note: Automatic mode is only active when the selected index has quick-build enabled. 

 Manual settings run the selected Action(s) at the specified frequency. 
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7. Click Add Now. 

8. Click the Service button (or select Timer > Service from the menu bar) to display the Install Timer as 
Service window. 

You can run the timer as a service either locally or in a domain. For a domain you must obtain the 
domain name, the user name, and the password. Make sure the defined user has full control on all 
index, data and temporary folders. 

 Select Use local system account, or enter the domain name, the user name, and the password.  

 The default Temporary directory is the standard ZyLAB folder. If required, you can change the 
folder. 

 Set the process priority to the level required (default is Normal). 

Click Install Service to install the service. 
 

 

Result 

The Timer is set up. The service runs in the background and continuously updates an index (automatic 
mode) and/or starts the manually-selected actions on an index. 

Note: It is recommended that the index receives a full build periodically (for example 1 
time per day) to ensure all changes appear in the index. You can add this manually to 
ZyTIMER using the Add Index window and choosing the Add action. 
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Create, Edit or Delete Document Groups 

Document groups can be selected in the indexes folder of the security tab. Indexes that are created with 
the Document Security module consists of three parts: Document groups, Document security and NTFS 
security. If you set permissions on, for example, the data folders, users will at least need to have read rights 
on the documents, otherwise they will not be able to see the documents, even if they are in the correct 
document group. 

Before you can create Document Groups, ZyLAB users will have to be defined.  

Conditions 

You have created an Index with the security module.  

Instructions 
1. ZyINDEX is open. 

2. Click the Security icon . On the right pane click > Document (Repository) Security > "Index Name". 

3. Click Create to define a new document group for a specific User (Group). 

4. Enter an Account name. Click Create. 

5. Click  to define queries which are used to define a group of documents. 

6. Click Create. 

 Define the field values on which you want to base the document group that users are allowed to 
view/search. 

 Click OK. 

7. Alternatively, if you want to link a user field to an index field, click Create with user field. The contents 
of the document group will in that case depend on the user that logs in. If, for example, each document 
in the index has a field 'Department', you could create a document group with 
'department=$department'. If a user of Department Sales logs in, then the document group is at that 
moment defined as 'department=sales'.  

 Select a field value from the dropdown listbox. 

 Click OK. 

8. Repeat steps 6 to 8 to create as many queries as you want. Select the queries you want to use. 

9. Repeat steps 3 to 9 to create more document groups. 

Result 

You created document groups. 
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Note 

• To define subgroups, click , select the groups you want to add, and click OK. 

• To change the name of a document group, select it, and click the "Change the name for this group" 

icon: . Change the name, and click OK. 

• To delete a document group, select it, and click the "Delete this group" icon: . Click OK. 

Document Security Query Syntax 

The following syntax rules apply: 

• You can use the ? character in Document Security queries comparable to the ZyFIND usage as a 
wildcard operator to replace individual character positions in a value. 
For instance a query on AA?AA will find documents that contain a AABAA 

• CONTAINS operator (default): a basic query value is matched against the document field value using the 
contains operator, for example: 
cat matches cat, but also cats and dogs 

• EXACT MATCH operator “”: a query value within quotes is matched using the exact match operator, for 
example: 
“cat” matches cat, but not cats or cats and dogs 

• NOT operator !: using the exclamation symbol boolean queries can be negated, for example: 
!cat matches dogs, but not cat, cats or cats and dogs 

• Combination of EXACT MATCH and NOT operator, for example: 
!”cat” matches dogs, cats and cats and dogs, but not cat 

• WILDCARD operator *: Wildcards used at beginning or the end of a word are interpreted as respectively 
"starts with" and "ends with". As a consequence *cat* has the same meaning as cat while *cat and cat* 
will in general generate less results than just cat (but more results than “cat”), for example: 
Ams*dam 

NOTE: Too many wildcards inside a value can give an unpredictable result. Do not use more than one 
wildcard operator inside a value (So Ams*dam and *ms*dam are valid conditions, but Am*st*dam is 
not).  

• AND and OR and precedence operators ( ): using AND and OR operators and brackets you can construct 
complex conditions, for example: 
Amsterdam and !(Paris or Washington) 

• USER PROPERTY resolving: $ followed by the name of a user property will be replaced by the 
corresponding value of the current logged-on user. The user property may be enclosed by quotes to 
indicate an exact match condition, for example: 
$COMPANY 
$”DEPARTMENT” and !”Test Department” 

• USER GROUPS restriction #GROUPS: #GROUPS as a query value can be used for fields containing a 
comma separated list of ZyLAB groups and/or user account names. The user will be granted access to 
the document if the user is member of one of the listed groups/accounts in the document field, for 
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example: 
#GROUPS 

NOTE: This value cannot be combined with other values. 
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Set Access Masks for Document Groups 

Conditions 

You want to define which actions the members of a document group are allowed to perform on an index. 

Instructions 
1. ZyINDEX is open. 

2. Click the Security icon . On the right pane click > Document (Repository) Security > "Index Name". 

3. Select one of the document groups you created for this index. 

4. Click . 

5. From the dropdown listbox, select either Users or Groups. 

6. Select the user/group (or select more than one) for which you want to set the access mask. 

7. Click Set Mask. 

8. Select the actions this user/group is allowed to perform. Choose from: 

 view as result 

 view document 

 edit doc. fields 

 delete document 

 split doc. pages 

 merge doc. pages 

 delete doc. pages 

 export document 

 print document 

 change doc. status 

 make anonymous 

 sign document 

 edit document 

 archive document 

To select all actions with one click, select the first checkbox (next to Permission). 
 
If, for certain users or groups, actions are blocked with functional security, it will not be possible to 
execute these actions. 

9. Click OK. 

10. Click Close. 
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Result 

You set the access masks for a document group.  
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Functional (Application) Security 

Functional Security allows you to add security to (functions of) ZySCAN, ZyINDEX, ZyFIND, ZyALERT, ZyLAB 
Web Client or ZyLAB Federator. Functional Security is role based. This means that security is defined based 
on the role a user (group) has been assigned. The functions a role is allowed to perform (see Roles and 
their (default) Functions (page 220)), can be changed. The order of steps to be taken to set Functional 
Security is as follows: 

1. Install the Security license key. 

2. Enable Functional Security in ZyINDEX > Security, via General > Settings. Select Functional Security > On. 
Click Update. 

3. Create Users and User groups in ZyINDEX > Security, via General > Users (page 173), and General 
> Groups (page 168). 

4. Assign Users to Roles, and Assign Roles to Functions (see Functional Security (General) (page 216)). 

Functions of specific Web Clients, or specific indexes can be secured too. So, there are 3 security contexts:  

• ZySCAN, ZyINDEX, ZyFIND, ZyALERT and ZyLAB Web Client),  

• Index and  

• Web Client.  

In the ZyLAB context, the Webclient context will be ignored. If a user has been assigned to more than one 
role within a single context, the stronger one (from weak to strong: Guest, User, Editor and Admin) will 
prevail. 

If you want to add users to roles, or if you want to define which user roles are allowed to perform a specific 
function, you need to go to ZyINDEX > Security > Functional (Application) Security.  
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Functional Security 

You want to define which users/groups are (not) allowed to perform specific functions (actions) in ZyLAB. 

Assign Users to Roles 
1. Select ZyINDEX > Security > Functional (Application) Security > Assign Users to Roles. 

2. Select a role from the dropdown listbox Role. 

 If you select an Index role, select an index from the dropdown listbox Index. 

 If you select a Webclient role, select a Webclient from the dropdown listbox Webclient. 

3. To view Users, Groups, or Users/Groups that have already been assigned to the role, select via the 
dropdown listbox View Users, Groups or Assigned only. 

4. Select User(s) or Group(s) from the list, and click Save. 

5. Check to see if the User(s)/Group(s) have been assigned to role, by selecting the View Assigned only. 

6. Repeat step 2 to 5 to add more user(s)/group(s) to roles. 

Assign Roles to Functions 
1. Select ZyINDEX > Security > Functional (Application) Security > Assign Roles to Functions. 

2. Select a product from the dropdown listbox Product. 

3. Select a part from the dropdown listbox Part. 

4. Select a function from the dropdown listbox Function. 

5. Deselect the User Roles which are not allowed to perform this function. 
Make sure you added users/user groups to the roles who are allowed to perform this function. 

Click on a role, for an overview of all the functions this role has access to. 

6. Click Save. 

7. Repeat step 2 to 6 to define the permissions of roles for more functions. 

Result 

You have added users/user groups to roles, and secured/defined the permissions of these roles for 
functions (within ZySCAN, ZyINDEX, ZyFIND, ZyALERT, ZyLAB Webserver or ZyLAB Federator). All users/user 
groups that are a member of a User Role, have the same permissions. 

Note 

So, there are 3 security contexts: ZyLAB, Index and Webclient. In the ZyLAB context, the Webclient context 
will be ignored. If a user has been assigned to more than one role within a context, the stronger one (from 
weak to strong: Guest, User, Editor and Admin) will prevail. 
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Functional Security (Index) 

You want to define which users/groups are (not) allowed to perform specific functions (actions) in a specific 
index. 

Instructions 
1. Go to ZyINDEX > Build. 

2. Go to File > Open. 

3. Select an index. 

4. Click OK. 

5. Click the Index Settings button: .  

6. Select the Security tab. 
 

 
7. Select a role from the dropdown listbox. 

8. Add/remove users and groups assigned to a role with the arrow buttons. 
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9. Repeat steps 7 - 8 for all roles. 

10. Click 'Enable default NTFS security'. 

11. Click OK. 

Result 

You have defined which users/groups are (not) allowed to perform specific functions (actions) in this index.  

Note 

If you do not want to inherit the default user group for a role, deselect the option 'Inherit from roles'. To 
enhance security, it is recommended to create separate users/groups which are allowed to work with this 
index.  
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Functional Security (Webclient) 

You want to define which users/groups are (not) allowed to perform specific functions (actions) in a specific 
index. 

Instructions 
1. Go to ZyINDEX > Webclient. 

2. Select a Webclient. 

3. Go to User Roles. 

4. Select one of the roles. 

5. Click Add. 

6. Select a user or group you want to assign to this role. 

7. Click OK. 

8. Repeat steps 5 - 7 to add more users/groups to this role. 

9. To remove a user/group from this role, select it, and click Delete. 

Result 

You have defined which users/groups are (not) allowed to perform specific functions (actions) in this 
webclient.  

Note 
• If you do not want to inherit the default user group for a role, deselect the option 'Inherit from ZyImage 

roles'. To enhance security, it is recommended to create separate users/groups which are allowed to 
work with this webclient.  
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Roles and their (default) Functions 

In order to keep the configuration of Security easier different roles are created. These roles are created 
during the installation and are stored in the initgroups.xml file, a description of the different roles be found 
in the security.xml file. (both files are stored in the users folder: \\ZyLAB Data\Users) 
Administrators can set rights via ZyLAB to specific files or folders of the index and the corresponding data 
directories. For every separate index different user roles are available:  

• Guest 

• User 

• Editor 

• Administrator 

Every role can be attached to a group for which rights on index related NTFS objects can be set. 
Groups can be every ZyLAB group but NT security can only be changed with imported NT groups. Functional 
security can be set with every group type. The authentication of the users will be done automatically with 
use of the NT domain security. 
The different roles that are available by default are given below. The options for the different user roles are 
default and can be changed if required. 

general zyimage roles: 

zyimage_admin 

zyimage_editor 

zyimage_user 

zyimage_guest 

zyscan_user 

zyalert_qc_user 

index roles: 

index_admin 

index_editor 

index_user 

index_guest 

webclient roles: 

webclient_admin 

webclient_editor 

webclient_user 

webclient_guest 

Default User Groups (see ZyINDEX > Security > General > Groups > Available Groups) are member of these 
roles. See the table below: 
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default User Group is member of default User Role 

ZyALERT_QC_Users ZyAlert Quality Control User 

ZyIMAGE_Administrators • ZyImage Administrator (global functions),  

• Webclient Administrator (webclient functions), 

• Index Administrator (index specific functions, for 
example 'Build index') 

ZyIMAGE_Editors • ZyImage Editor (global functions),  

• Webclient Editor (webclient functions), 

• Index Editor (index specific functions, for example 
'Build index') 

ZyIMAGE_Guests • ZyImage Guest (global functions),  

• Webclient Guest (webclient functions), 

• Index Guest (index specific functions, for example 'Build 
index') 

ZyIMAGE_Users • ZyImage User (global functions),  

• Webclient User (webclient functions), 

• Index User (index specific functions, for example 'Build 
index') 

ZySCAN_Users ZySCAN User 

The functions that can be secured (and followed in an Audit Trail) are listed in the following sections, 
together with the default functions for each default ZyLAB User Role: Index Administrator (IA), Index Editor 
(IE), Index User (IU), Index Guest (IG), Webclient Administrator (WA), Webclient Editor (WE), Webclient 
User (WU), Webclient Guest (WG), ZyIMAGE Administrator (ZA), ZyIMAGE Editor (ZE), ZyIMAGE User (ZU), 
ZyIMAGE Guest (ZG), ZyAlert Quality Control User (Q), ZySCAN User (Z).  

Click on a role, for an overview of all the functions this role has access to. 
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General 

All User Roles are allowed to perform General functions. 

Part Function 

Audit Trail Update Audit Settings 

 View Audit Settings 

NTFS Security Update NTFS Security 

 View NTFS Security 
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ZySCAN 

Part Function ZA ZE Z ZG 

Global Edit Global Options v    

 Edit Image Enhancement Settings v v v  

 Edit Import Source v    

 Edit Import Source Properties v v   

 Edit Scan Source v    

 Edit Scan Source Properties v v   

 Run Unattended v v v  

 Service Configuration v    

 

Part Function ZA ZE Z ZG 

Job Create Template v v   

 Delete Job v v   

 Delete Page v v v  

 Merge/Split Documents v v   

 Modify Job Settings v v   

 New Job v v v  

 Next Stage v v v  

 Open Job v v v  

 

Part Function ZA ZE Z ZG 

ZyScan Do Scan v v v  

 Enter Stage v v v v 

 Modify Scan Settings v v   
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Part Function ZA ZE Z ZG 

ZyImport Do Import v v v  

 Enter Stage v v v v 

 Modify Import Settings v v   

 

Part Function ZA ZE Z ZG 

ZyField Edit Field Definitions v v   

 Edit Fields v v v  

 Enter Stage v v v v 

 

Part Function ZA ZE Z ZG 

ZyOCR Delete Text Files v v v  

 Do OCR v v v  

 Enter Stage v v v v 

 Modify OCR Settings v v   

 OCR All Deferred Jobs v v v  

 

Part Function ZA ZE Z ZG 

ZyExport Do Export v v v  

 Enter Stage v v v v 

 Modify Export Settings v v   
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ZyINDEX 

Part Function ZA ZE ZU ZG 

Menu Create Index v v   

 Delete Index v    

 License Manager v    

 Select Index v v v v 

 Set Interface languages v v v  

 View Log File v v v  

 ZyIndex Options v v   

 

Part Function ZA ZE ZU ZG 

ZyIndex Options Directory Options v    

 Global Options v v   

 Index Preferences v v   

 Index Wizard v v   

 Recovery v    

 Table of Contents Options v v   
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Part Function IA IE IU IG 

Build Build Index v v v  

 Custom Data Folders v v   

 Define Fields v v   

 Edit Index Folders v    

 Edit Settings v v   

 Email Properties v v   

 Erase Index v    

 Modify Character Set v v   

 Save Index as Template v v   

 View Logfile v v v  

 View Noise Words v v v  

 

Part Function ZA ZE ZU ZG 

Timer Add Index Schedule v v   

 Delete Index Schedule v    

 Edit Index Schedule v    

 Install Timer as Service v    

 Remove Service v    

 Settings v v   

 View Logfile v v v  

 

Part Function ZA ZE ZU ZG 

Cold Delete v v   

 Edit v v   

 Edit Properties v v   

 Move Up/Down v v   

 New v v   

 Start/Stop v v   

 View Logfile v v   

 
226 

 



ZyINDEX Manual 

 

Part Function ZA ZE ZU ZG 

Webclient Create Client v v   

 Delete Client v v   

 Edit Image Markers v v   

 Edit Indices v v   

 Edit Properties v v   

 Edit Templates v v   

 Edit User Rules v v   

 Enable Automatic Login v v   

 Reactivate Client v v   

 

Part Function ZA ZE ZU ZG 

Federator Settings View WebClientIndexes v v   

 Edit WebClientIndexes v    

 View Configurations v v   

 Edit Configurations v    

 View Federator Clients v v   

 Edit Federator Clients v    
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Part 

 

Function 

ZA, IE, 
WA 

ZE, IE, 
WE 

ZU, IU, 
WU 

ZG, IG, 
WG 

Security Add/Delete Users/Groups v    

 Edit Document Groups v    

 Edit Document Security v    

 Edit Functional Security v    

 Edit Index NTFS Security v    

 Edit Index Roles v    

 Edit Security Settings v    

 Edit User/Groups v    

 Edit Webclient Roles v    

 Generate Pincode v    

 View Document Groups v    

 View Document Security v    

 View Functional Security v    

 View Index NTFS Security v    

 View Index Roles v    

 View Security Settings v    

 View Users/Groups v    

 View Webclient Roles v    

 

Part Function ZA ZE ZU ZG 

Tasks Archive v v   

 Briefcase v v v  

 Build v v v  

 Cold v v   

 Publish v v v  

 Security v    

 Timer v v   

 Web Client v v   
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ZyFIND 

Part Function ZA ZE ZU ZG 

Menu License Manager v    

 Open Result File v v v  

 Select Search Tools v v   

 Set Interface Languages v v v  

 Transliteration Assistant v v v  

 Update Fields Edit to Index v v   

 ZyFind Options v v  v 

 

Part Function ZA ZE ZU ZG 

ZyFind Options Audit Trail Options v    

 Directory Options v    

 Global Options v v   

 Search Preferences v v   

 Table of Contents Options v v   

 

Part Function IA IE IU IG 

Table of Contents Automatic Generations v v   

 Contents Options v v   

 Create Personal Table of Contents v v   

 Database Maintenance v v   

 Delete Documents v v   

 Edit Entries v v   

 Edit Folders v v   

 Print Documents v v v  

 Select View v v v  

 Update Comment Fields v v   
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Part Function IA IE IU IG 

Bookmarks Database Maintenance v v   

 Edit Bookmarks v v   

 Edit Folders v v   

 Import v v   

 Options v v   

 Report v v v  

 

Part Function IA IE IU IG 

Thesaurus Edit v v   

 Insert v v   

Concepts Create New Concept Collection v v   

 Edit v v   

Fields Edit Definitions v v   
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Part Function IA IE IU IG 

ZyResult Copy as Hyperlink v v v v 

 Copy Document v v v  

 Delete Document v v   

 Delete Reference v v   

 Edit Fields v v   

 Edit Options v v   

 Export v v v  

 Insert Annotation v v   

 Launch Document v v  v 

 Merge v v   

 Open Document v v v v 

 Print Document v v v v 

 Print Result List v v v  

 Save Result List v v v  

 Send Result List v v v  
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Part Function IA IE IU IG 

ZyView Annotations v v   

 Copy v v v v 

 Delete Contents v v   

 Delete Page v v   

 Delete Reference v v   

 Edit Fields v v   

 Edit Hyperlinks v v   

 Edit Options v v   

 Edit Redaction v v   

 Export v v v v 

 Insert Bookmark v v   

 Launch Document v v v v 

 Print Document v v v v 

 Send Document v v v v 

 Split v v   

 

Part Function IA IE IU IG 

Workflow Create Workflow v v   

 Lock Workflow v v v  

 Delete Workflow v    

 View Other Workflow v v   

 Unlock Workflow v    
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ZyALERT 

All User Roles are allowed to perform ZyALERT functions. 

Part Function 

Windows Add Index 

 Add Special Alerts 

 Add User 

 Delete Alert 

 Delete Index 

 Delete User 

 Edit Alert 

 Edit User 

 Generate Report 

 Install Service 

 New Alert 

 Quality Control 

 Set Options 

 Start 

 Table Maintenance 

 View Logfile 

 

Part Function 

Webpages ... 
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ZyLAB Webserver 

Part Function WA WE WU WG 

File Display Delete Document v v   

 Download Document v v v  

 Edit Fields v v   

 Print Document v v v v 

 Split Document v v   

Print Setup Add/Remove Printers v v   

Search Use Concepts v v v  

 

Part Function WA WE WU WG 

Search Results Add Document to Table of Contents v v   

 Download Document v v v  

 Edit Fields v v   

 Merge Document v v   

 Print Documents v v v v 

 

Part Function WA WE WU WG 

Document Basket Download Document v v   

 Print Document v v   
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Part Function WA WE WU WG 

Server Actions Add Documents to Table of Contents v v   

 Delete Documents v v   

 Download Documents v v v  

 Edit Fields v v   

 Edit Table of Contents v v   

 Merge Documents v v   

 Print Documents v v v  

 Split Document v v   

 Upload Documents v v   

 Use Concepts v v v  

 

Part Function WA WE WU WG 

Table of Contents 
List 

Select Edit Mode v v   

 Upload Document v v   
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ZyLAB Federator 

Part Function 

Search Search Client 

 Download Document 
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Workflow 

ZyLAB Workflow enables you to thoroughly yet easily manage specific workflow processes and link 
documents from a ZyLAB archive to specific steps in a process. ZyLAB Workflow capabilities are ideally 
suited for handling all aspects of established procedures with little or no reconfiguration required of 
internal subtasks. 

A workflow process can be triggered by making a simple scan of a document, whether on a traditional 
scanner or a digital copier. Immediately, the document is archived and fully searchable in the ZyLAB 
archive, which allows easy retrieval of relevant information and starts a new workflow process. Users can 
be alerted that new tasks are pending or open their workflow inbox to see if new tasks need attention. A 
workflow process can also be initialized from an e-mail message or an electronic document, such as 
Microsoft® Word. 

In the new design, ZyLAB Workflow is able to address large volumes of data (>100.000 workflows) with an 
outstanding performance.  
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Installation ZyLAB Workflow 

Conditions 

You want to install ZyLAB Workflow. First, you have installed ZyLAB Information Management Platform. For 
more information, see the Review Guide Installation ZyLAB Information Management Platform. You can 
continue with creating a Workflow index (see Create a Workflow index (page 245)), or continue with 
installing ZyLAB Workflow. 
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Instructions 
1. Start the ZyLAB Workflow Installer file. The Preparing to Install screen appears. 
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2. The Welcome screen appears. Click Next. 
 

 
3. Accept the terms in the license agreement. Click Next. 

 

 

240 

 



ZyINDEX Manual 

 

4. If necessary change the destination folder. Click Next. 
 

 
5. Click Install to start installation. 
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6. Monitor the installation process. 
 

 
 

7. Click Finish when the installation process is complete. 
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Result 

You have installed ZyLAB Workflow. Continue with the configuration of ZyLAB Workflow. 
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Configuration ZyLAB Workflow 

Conditions 

Once you have installed ZyLAB Workflow, some additional settings need to be configured. First, the 
ZyINDEX Workflow needs to be defined. You can choose to work with Custom Workflow Fields. Finally, if 
you want to import or scan documents, you need to create a template in ZySCAN. 

Instructions 
1. Define the ZyINDEX Workflow 

 Create a Workflow Index 

 Adjust the web.config file 

 Create a Data Index 

 Create a New Web Client 

 Adjust ZyINDEX Workflow Settings 

2. Workflow and Custom Workflow Fields. 

3. Set up a Workflow via ZySCAN. 

Result 

You have configured ZyLAB Workflow. Now, workflows can be started. For more information, see Using 
ZyLAB Workflow (page 283). 
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ZyINDEX Workflow 

Create a Workflow index 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Go to File > New. 
 

 
3. Enter a Short name (max. 8 characters). 

4. Enter a descriptive Long name (max. 80 characters). Use the name to describe the contents of the 
index. 

5. Select Index Wizard.  

6. Click OK. 

7. Select the checkbox 'Use Windows code page'. 

8. Click Next. 

9. Double click on the Workflow Management module to select it. 

A standard set of workflow templates is included with ZyLAB Workflow. See \\Program 
Files\ZyLAB\Information Management Platform\AddOn\Workflow Library. 

10. Click Next. 

11. If shown, read the message and click OK. 
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12. Click Next twice. 

13. At Step 5: Define Fields, click the Wizard button. 
The ZyLAB Database Settings Wizard appears. 

14. Click Next. 

15. Select the Database provider MS SQL Server. 

16. Click Next. 
The Module fields dialog appears, with Module Workflow Management added to the list. 
 

 
17. Click Next. 

The Generate database dialog appears. 

246 

 



ZyINDEX Manual 

 

 

 
18. Click the Construct button. 

19. Select from the dropdown list the Provider SQLOLEDB. 

20. Select the SQL Server that you want to use. Alternately, you can click Retrieve Servers and select the 
desired server from the returned list. 

21. Click OK. 

22. Define a Username and Password. These credentials are already known on the database server. This 
user is allowed to change the database and the tables within the database. 

23. Click Create new. 

24. Click the Generate button. 
The database is generated. 

25. Click Next. 
The Connection String you defined is copied. You only have to define a separate Username and 
Password. This user is allowed to view and change data in the tables. 

26. Click Test Connection. 
If the connection is not correct, try using other settings. 

27. Click Next until Finish. 
You will return to the index wizard. 

28. Click Next until Finish. 

29. Build the index.  
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Result 

You have created a Workflow index. This index is used for creating a Workflow. Create a data index (page 
250), for storing documents related to the Workflow (index). 
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Adjust the web.config file 

Conditions 

You have installed ZyLAB Workflow. 

You have created a Workflow index and defined the database settings. Now define the database settings 
need to be defined in the web.config file.  

Instructions 
1. Go to \\Program Files\ZyLAB\Workflow\webroot. 

2. Open the web.config file. 

3. Search for the connection string parameters: 
 
<!-- fill in the connection string parameters before using workflow  -
-> 
    <add name="WorkFlowConnectionString" connectionString="Data 
Source=;Initial Catalog=;Persist Security Info=True;User 
ID=;Password=" providerName="System.Data.SqlClient" /> 

4. Fill out the Data Source (the name of the database server you are using), the Initial Catalog (the 
database created during the creation of the Workflow index or the short index name of the Workflow 
index if you have left everything as default), the User ID and the Password (that you used in the 
Database Wizard). 

5. Save and Close. 

Result 

You have defined the database settings in the web.config file. 
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Create a Data Index 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the BUILD icon: . 

2. Go to File > New. 
 

 
3. Enter a Short name (max. 8 characters). 

4. Enter a descriptive Long name (max. 80 characters). Use the name to describe the contents of the 
index. 

5. Select Index Wizard. 

6. Click OK. 

7. Click Next. 

8. Double click the XML Wrapper if you would like to create an XML Wrapper index, otherwise, click Next. 

9. Click Next. 

10. If shown, read the message and click OK. 

11. Click Next until the wizard is finished. 

12. Click Finish to complet the wizard. 

Result 

You have created a Workflow data index. This index will be used to archive all the (uploaded or scanned) 
documents needed for working with the workflow. 

250 

 



ZyINDEX Manual 

 

Note 
• It is advised to use a data index with XML Wrapper when adding fields. 

• If you want to add documents to your workflow, make sure to define the data index in the workflow 
template. For more information, see Create Workpool Templates (page 256). 
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Create a New Web Client 

Conditions 

ZyINDEX is open. 

Instructions 

1. Click the Web Client icon: . 

2. Go to File > New. 

3. Define a Long Client Name.  

4. Define the HTTP alias (URL).  

5. Browse to the directory where you want to store the Web Client. 

6. If required, define a Client email address. 

7. Select a language for the Template language. 

8. Click OK twice. 

9. Select the Indexes part. 

10. Click Select. 

11. Select the data index and the workflow index. 

Make sure the workflow index is the last index in the indexlist of the web client. 

12. Click OK. 

Result 

You have created a new web client. 
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Adjust ZyINDEX Workflow Settings 

Settings (Office Hours/Holidays) 

Conditions 

You want to define the office hours which can be used for task transfer duration. Also, holidays can be 
indicated. 

Instructions 
1. ZyINDEX is open.  

2. Click the Workflow icon: . 

3. Click Settings. 
 

 
4. Select the correct days. 

5. Select the correct office hours for each day. 

6. Define holidays: 

 To add holidays, select the correct month and day from the dropdown listboxes, and click . 

 To delete holidays, select the appropriate boxes and click . 
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Result 

You have defined the office hours which can be used for task transfer duration. During holidays, no task 
transfer actions will occur. 
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Create Workpools 

Conditions 

You have created a Workflow database (index). ZyINDEX is still open. Now you want to define the members 
of each workpool. If a user is not a member of a workpool, he has no access to the tasks available for that 
workpool. 

Instructions 

1. Select the Workflow icon: . 

2. Select the Workflow folder, and the database you just created. 

If you do not see the database, click your right mouse button and select Refresh. The database will 
appear in the list. 

3. Select Workpools. 

4. Click Create. 

5. Define a Name for the new workpool. 

6. Describe the goal and/or tasks of the members of the workpool. 

7. To add a user to the workpool, click the yellow folder icon: . 

 Define whether the workflow database must be updated after completion of this dialog. 

 Select the users you want to add. 
Users can be assigned to multiple workpools. 

 Click OK. 

8. Click Update. 

9. Repeat steps 3 - 7 to create all the workpools you need. 

Result 

You have created one or more workpools, and added users. 

Note 
• To delete a workpool, select it and click Delete. Click OK. 

• To copy a workpool, select it and click Copy. Select it to make some changes. 

• To remove a user from a workpool, select it in the Edit screen, and click Update. 

• Users can (temporarily) be excluded from the workpool, for example when a user is on holiday. Click 
Disable in the Edit screen, and click Update. The member will be displayed in red. 

• Use the  arrows to navigate to the overview screen with all workpools. 

• Use the  and  arrows to hide or show the poolmembers. 
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Create Workpool Templates 

Conditions 

Once you have created a new workflow index and workpools with members, it is possible to create 
workflow templates. A workflow template consists of a collection of tasks and actions. A task is assembled 
from a number of actions. First tasks, then actions for those tasks and finally the sequence of tasks is 
defined in a workflow template. Multiple workpool templates may be created for the same workpool 
database. By default, the Invoice Authorization template is added. Other standard templates that can be 
used are: Review, QuickReview, Helpdesk authorization, and ExpensesAuthorization. They can be imported 
via Export/Import (page 264). 

Instructions 

1. If you are not already in ZyINDEX > Workflow, click the Workflow icon: . 

2. Select the Workflow folder, and the correct database folder. 

3. Select Templates. 

4. Click Create. 

5. Define the Template Name. 

6. Set the priority. 

7. You can select Required, Optional or No for the option "When a workflow based on this template is 
created a user has to be assigned to the initial task".  

8. If you selected Required or Optional, define whether or not the user must be notified (through email). 
This email will include the Workflow name, - task, - sender, and a link to the Web Client. If the user 
must be notified, make sure that the SMTP Server is defined correctly (see ZyINDEX Security > General 
> Settings (page 165)). Also, make sure the Webserver and Web Client are indicated (see Preferences 
(page 263)). 

Only the first user will be notified through this option, the following user can be notified by selecting 
the option 'Notify transfer user' via the Transfer Matrix (step 12d) for each following step in the 
Workflow. 

9. To define the Management Pool, select one of the Workpools.  

Use the Table icon  to switch between selected item and overview of items. 

Use the  and  icons to show/hide item descriptions. 

10. To create a task, click the New folder icon  in the lower part of the screen. See Create New Task 
(page 258). 

11. To create a new action type, click the second New folder icon . See Create New Action Type (page 
259). Actions are predefined key fields that can be added to a Workflow task. 
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12. To define the sequence of tasks (the workflow task transfer), select the Table icon  (Transfer 
Matrix). 

Use the Table icon  to switch between selected initial task and transfer matrix overview. 

Use the  and  icons to show/hide item properties. 

a) Find the first task in one of the rows and the second in one of the columns (the numbers refer to 
the corresponding tasks).  

b) Click on the matching cell. 

c) Define the prompt (message) an end-user receives when this task is due. You can also use HTML 
code to include, for example, an image. 

d) Select the actions that must be executed for this task, and define if the action is required 
(mandatory) or not. 
If you select the option to 'Add documents', make sure you select a data index to store the 
documents in. This should not be a Workflow index!   

e) Define the number of days when the workflow database must be updated  
- from end of the task 
- from start of the workflow 
- before due date of the workflow 

f) It is possible to trigger a custom VB script whenever a transfer is successfully executed. VB scripts 
can be used, for example, to send an email notification or to trigger a process in another system. 

g) If you want to assign the next task to a specific user (group), select the checkbox and select a task 
from the dropdown listbox. 

h) If you want to display the transfer options as radiobuttons, select that checkbox. 

i) Click OK. 

13. To create a new Document Category, select the third New folder icon . See Create New Document 
Category (page 261). 

With Document Categories you can search your document Index by putting queries in the document 
fields in ZyINDEX. When you start a new workflow, all the documents are shown that are linked to the 
query. 

14. Click Update. 

15. Repeat steps 4 - 12 to create another workpool template. 

Result 

You have created one or more workpool templates. The first task will be highlighted green. 
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Create New Task 

Instructions 
1. Define a name for the Task. 

2. Associate one or more workpools with the task. 

Click the table icon  to view/hide all workpools. The blue workpool is selected. 

Click the  and  icons to view/hide additional information on all workpools.   

3. Define the Type of the task. Choose from 

 Regular (single user, multiple target states) 
One user must complete a task, another user must complete the next task, etc. 

 Review (multiple users, single target state) 
If you select Review, define the default number of reviewers. 
For example, 2 users must review a task. When both reviewers are done, the workflow will 
continue with the user of the next task. 

4. Define the Duration of the task. 
This duration time is used to calculate a due date for the workflow when this task is active. 

5. Click OK. 

Result 

You have created a new task. 
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Create New Action Type 

Instructions 
1. Define a Name for the action type. 

2. Select whether or not the action should be disabled for now.  

3. Define the Data Type. Choose from Date, DateTime, Float, Logical, Number, Text, Memo. 

4. Define the Action Type. Choose from Custom Action, Auto Increment, or Workflow Counter (see Note 
below). 

5. Optionally, define the Control Type. If you do not select a Control Type, it will be automatically selected 
in the workflow. 

 If you selected Date, select StandardDate. 

 If you selected DateTime, select DateTimeControl. 

 If you selected Float or Text, choose from CurrencyControl, FileControl, PincodeControl, 
TextControl, TextAreaControl, MultiSelect, SingleSelect. 

 If you selected Logical, choose from LogicalCombo, MultiSelect, SingleSelect. 

 If you selected Number or Memo, choose from CurrencyControl, FileControl, PincodeControl, 
TextControl, TextAreaControl, MultiSelect, SingleSelect. 
If you select CurrencyControl, and want to change the currency (by default EUR €), go to 
C:\Program Files\ZyLAB\Workflow\webroot\App_Data\Settings.xml. Open the Settings file, and 
change the currency in the localization/CurrencyCulture node using, for example, en-US, en-GB, es-
MX, de-DE, or ja-JP. The Culture node defines numerical and date settings. 
If you select MultiSelect or SingleSelect, click Edit to define the values users are allowed to choose 
from. Define a value, click enter, define the next value, etc. With MultiSelect, users can select one 
or more values from a dropdown listbox. With SingleSelect, users can only select one value from a 
dropdown listbox. 

6. Optionally, define a default value and/or format mask. If you open a Workflow template, you will see 
the default value for this action type. For example, always a 100 euro fine. 

 If you selected Date/Time, you can use the following formats: 
YYYY year, eg 2006 
YY year, eg 06 (2006) 
MM month, eg 09 (September) 
DD day of the month, eg 31 
hh hour of the day, eg 23 
mm minute of the hour, eg 08 
ss second of the minute, eg 56 
(for an overview of all other (more technical) formats, see the ZyLAB Information Platform Manual 
> Glossary > Strftime specifiers) 

 If you did not select Date/Time, you can still use the date formatting. However, in that case the 
current Date/Time will be used. There are a few possibilities for the used Data Type: 
- String (or Memo): replace %s with the default text. 
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- Whole number (Integer): replace c with the default number.  
If the default number is 3, and the format is ccc, it will result in 003 (leading zeros). 
Other examples: Value is 76, format is YYYY-MM-ccc which results in 2006-01-076. Value is 
20060103231156 (a date), format is %Y %b %d %I:%M:%S %p which results in 2006 Jan 03 11:11:56 
PM. 

7. Click OK. 

Result 

You have created a new action type. 

Note 

If you want to be able to count each occasion a Workflow item is created, you can create a Workflow 
counter.  

• As the Data Type, choose Number. 

• As the Action Type, choose Workflow Counter. 

Users will find the Workflow counter in the Workflow Editor in ZyFIND. 

260 

 



ZyINDEX Manual 

 

 

Create New Document Category 

With Document Categories you can search your document index, by putting queries in the document fields 
in ZyINDEX. When you start a new workflow, all documents that are linked to the query are shown. 

Instructions 
1. Define a name for the Document Category. For example, Education. 

2. Enter a description. For example, Type of education required.  

3. Select an index from the dropdown listbox. This document index will be searched. The index may, for 
example, consist of CVs. 

4. Click Edit to define the query.  

5. Select the fields, and define the field values. For example, Technical. 

6. Click OK twice. 

Result 

You have created a new document category. Each time a workflow item is created, documents that 
correspond with this query, will be linked dynamically to the workflow. The Workflow editor in 
ZyFIND/Webclient will show the documents which correspond with the fieldvalue/query defined as the 
Document Category. 

Note 

To link the Document Category to an Action, use the # sign. For example, if you have a workflow action 
called "PropertyRegistrationNumber" and an index with a field called "PropertyId", then the document 
category for the workflow could be defined as "PropertyId = #PropertyRegistrationNumber". 
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VB Scripts 

VB scripts can be used, for example, to send an email notification or to trigger a process in another system. 

Workflow XML and VB Scripting 

• OnTaskBeforeTransfer 
Sub OnTaskBeforeTransfer(WorkflowXmlDocument, PropertyXmlDocument) 
   WorkflowXmlDocument.save "C:\Temp\WorkflowXmlDocument.xml"  
   PropertyXmlDocument.save "C:\Temp\PropertyXmlDocument.xml"  
End Sub 

• OnTaskAfterTransfer 
Sub OnTaskAfterTransfer(WorkflowXmlDocument) 
   WorkflowXmlDocument.save "C:\Temp\WorkflowXmlDocumentAfter.xml"  
End Sub  

• Archiving workflow actions as document data 

• Triggering events in other systems 
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Preferences 

Conditions 

You want to define the Preferences. 

You want to sent an email to a user who has been assigned with a task. This email contains a link to the 
Web Client, where the user can continue the workflow. In order to enable this link, the Preferences need to 
be filled out. 

Instructions 
1. Define IncludeCounts. Obsolete. 

2. Define IncludeCounts (Management). Obsolete. 

3. Define MaxResults. These are the maximum number of rows shown per page in the Workflow tabs. 

4. Define MaxResults (Management). These are the maximum number of rows shown per page in the 
Workflow Management tab. 

5. Define the TocRefreshTime. Obsolete. 

6. Define the TocRefreshTime (Management). Obsolete. 

7. Insert the Long index name of the (ZyNET) Web Client with the correct indexes for the workflow. 

8. Insert the (DNS) name of the Webserver (which can be accessed from an extern location). 

9. The ZyNetUrl defines the location where mails are sent to (only used if a workflow is created by ZyNET 
(Web Client)) or ZySCAN(Service)). 

Result 

You have defined the Preferences. 

The link to the Web Client will be enabled in the email to the user who has been assigned with a task. 
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Export/Import 

Conditions 

You want to export or import information regarding Workflow, for example templates, users, data. 
Standard templates include Invoice Authorization, Review, QuickReview, Helpdesk authorization, and 
ExpensesAuthorization. 

Instructions 
1. Define which types of information you want to export or import. Choose from: 

 Include related objects 
Select this option if you do not want to forget to export all related objects. For example, Templates 
are related to Workpools (but Workpools do not necessarily need Templates); A task in a template 
cannot be completed without a member of a Workpool executing that task. If you do not 
select Include related objects, you can choose to export/import only Templates. Data is related to 
Indexes (but Indexes do not necessarily need Data). If you do not select Include related objects, you 
can choose to export/import only Data. 

 Templates 
Workflow templates, including all Tasks and Action Types. 

 Workpools 
WorkPools and PoolMembers. 

 Indexes 
DocumentIndexes (a list of all indexes which include documents related to a Workflow) 

 Data 
Workflows, ActionValues, WorkflowDocuments and TransitionUsers (per executed task a record is 
created in the TransitionUser table of the database) 

2. If you want to export to an XML file, define the file you want to export to, and click Export. 

 Overwrite existing file 
During Export an existing XML file will be replaced. 

 Keep original object id's 
Each object in the Workflow database had its own unique ID number, a GUID (for example, 
{A85924EA-A572-4F92-B454-A1F76F118C44}). By default, this number will not be 
imported/exported to prevent occurrences of the same number in the database (possible if a file 
with saved GUIDs is imported twice). Under certain circumstances the GUIDs should remain the 
same. For example, when migrating from an Ms-Access database to an Sql Server.  

 Export as friendly XML 
Recommended. If you do not export as friendly XML, the XML is difficult to read and understand. 
There is no clear structure; All database records are placed one after the other. 

 Remove template locking 
Recommended. Templates are locked when working on them in ZyINDEX. This lock information 
could cause problems.  
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3. If you want to import an XML file (for example, a template), select the file you want to import from the 
dropdown listbox, and click Import. 

 Assign original object id's (if possible) 
Only possible, if you exported with the original object id's (see step two, point two). 

 Import all objects present in the file (selected object types will be ignored) 
If this option is selected, you do not have to choose the objects to import.  

 Replace existing objects (warning: existing data will be permanently deleted!) 
Every table in which objects are imported, are cleaned first. 

Result 

You have exported or imported information. 
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Archiving 

Conditions 

You want to archive completed workflows to improve performance. 

Instructions 

1. Select the Workflow icon: . 

2. Select the Workflow folder, and the correct database folder. 

3. Select Archiving. 

4. Select a date. Workflows that are completed before that date will be archived. 

5. Define the number of completed items. 

6. Select a target index. This target or archive index is created with the Workflow Archive template in 
ZyINDEX Build.  

7. Click Archive. 

Result 

You have archived completed workflows. The completed workflows are stored as XML files in the XML 
folder of a Workflow Archive index. All archived workflows are searchable. The Workflow Archive index can 
be connected to a web client. 
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Action Codes 

In the task transfer schedule overview of the Workpool templates, cells contain an encoding of the 
programmed actions. View the table below for an explanation: 

Code Action 

S Sign 

C Comment 

D Add Comment 

P Specify Priority 

T Specify Due Date 

Red Required 

! Run Script 

[0-9] Custom Action 
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Security 

Automatically Log in to Workflow: Enable Windows Authentication 

Conditions 

You want to enable Windows Authentication, which makes it possible for users to automatically login to 
ZyLAB Workflow. Windows Authentication does not prompt users for a user name and password. If the 
authentication exchange initially fails to identify the user, the browser will prompt the user for a Windows 
user account user name and password. 

Instructions 
1. Go to \\Program Files\ZyLAB\Workflow\webroot 

2. Open the web.config file. 

3. Scroll down to the authentication mode: 
 

 
4. Add comment code around the authentication mode Forms. 
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5. Delete the comment code around authentication mode Windows. 

6.  
 

 
7. Save and close the web.config file. 

Result 

You have enabled Windows Authentication and will be able to automatically login to ZyLAB Workflow. 
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Digital Signature 

Conditions 

Workflow is secured with a built-in digital signing action, for which users need to have a pincode. With this 
pincode workflows can be authenticated. A pincode is not the same as a user password. Pincodes are 
generated in ZyINDEX.  

Instructions 
1. Go to ZyINDEX > Security. 

2. Select General > Users > Available Users. 

3. Select a user. 

4. Click the "Generate a new PIN code for the user" button . 

5. Determine if the user should have a 4 or 6 digit PIN code.  
A 6 digit PIN code is safer, but a 4 digit PIN code is easier to remember. 

6. Determine the expiration time (number of days valid) of the pincode. 

7. Fill out the email address of the user.  
An email will be sent to the user with the PIN code in the subject line. 

8. Fill out the email address of the sender. 
This can be a random address. 

9. Click Generate. 

Result 

You have generated a PIN code for a specific user. 

Note 
• Import users to the user list if they are not on it already. For more information, see the ZyLAB 

Information Management Platform Manual > ZyINDEX > Security > General > Users > Import Users 
(page 173). 
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Enable Quickbuild for ASP.NET User 

To enable quickbuild for ASP.NET users, enable writing on 

• "..../ZyLAB Data/Index Data/[Data Index]" to store documents 

• "..../ZyLAB Data/Indexes/[Data Index]" to store quickbuild options 

 

Quickbuild 

Use Quick Build to quickly index documents that are marked new, changed or deleted. All other documents 
are skipped. 

Marked documents are known to ZyINDEX, even before indexing starts, because they have an entry in the 
database. These references to the documents are created when they are exported to the index data 
directories with ZySCAN or when they are imported to the index data folder with the ZyINDEX import 
directory. Since only marked documents are indexed and all other documents are skipped, the indexing 
process is accelerated.  

You can only use Quick Build if a link to the index is present. Also, check if 'Quick build enabled'' is selected 
(ZyINDEX > Index Settings > Settings). 
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Adjust Functionality via the Settings.xml file 

Change the Currency 

If you want to change the currency (by default EUR €), go to C:\Program 
Files\ZyLAB\Workflow\webroot\App_Data\Settings.xml. Open the Settings file, and change the currency in 
the localization/CurrencyCulture node using, for example, en-US, en-GB, es-MX, de-DE, or ja-JP.  

Show or Hide the Search tab 

The Search tab can be hidden/shown via the settings.xml file. Go to \\Program 
Files\ZyLAB\Workflow\webroot\App_Data\ and open the settings.xml file. Set 'searchtab visible' to false 
or true and save the file. 

<options> 

    <!-- set visible = false to hide search tab --> 

    <searchtab visible="true"/> 

    <!-- set enableInitialDocument to true to be able to show the initial 
document--> 

    <newWorkflow enableInitialDocument="false" 
initialDocumentMandatory="false"/> 

  </options> 

Show or Hide Uploading a Document to a New Workflow 

When creating a new workflow the ability to upload a document can be hidden/shown via the settings.xml 
file. Go to \\Program Files\ZyLAB\Workflow\webroot\App_Data\ and open the settings.xml file. Set 
'newWorkflow enableInitialDocument' to false (users will not be able to upload a document) or true (users 
will be able to upload a document) and save the file. 

Uploading a document to a new workflow can be made mandatory; Set 'initialDocumentMandatory' 
to true. 

Add Custom Workflow Fields 

See Workflow and Custom Workflow Fields (page 274). 

Change the order of the mappings and/or define an alternative mapping 

If you want to change the order of the mappings and/or define an alternative mapping, the codes 
<mappings ordered="true|false">, <own ordered="true|false">, <management ordered="true|false"> 
and/or <completed ordered="true|false"> can be added to the settings.xml file, located at \\Program 
Files\ZyLAB\Workflow\webroot\App_Data. All nodes can contain fields: 

• <mappings ordered="true"> 
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This node will replace the node <mappings>; The columns in the grid will have the same order as the 
columns in the settings file.  

• New (optional) childs of this node are: 

 <own ordered="true">  
<field ... 
</own> 
 
This node means a separate configuration for the own workflow grid. Order will not be obtained 
from the mappings node. 

 <management ordered="true">  
<field ... 
</management > 
 
This node means a separate configuration for the management grid. Order will not be obtained 
from the mappings node. 

 <completed ordered="true">  
<field ... 
</completed> 
 
This node means a separate configuration for the completed grid. Order will not be obtained from 
the mappings node. 

 <field ...  
</mappings> 
 
This node means a separate configuration for all grids that are not configured.  
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Workflow and Custom Workflow Fields 

Conditions 

You want to add Custom Workflow Fields to your workflow to add functionality.   

Instructions 
1. Go to ZyINDEX > Build. 

2. Open the workflow data index. 

3. Add fields (step 4 to 13). If fields are already added, continue with step 14. 

4. Click Define Fields . 

5. Click Add definition. 
The New Field Definition window appears. 
 

 
6. Fill out the Name of the field definition.  

A field name may not contain spaces!    
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7. Select a Type from the dropdown list.  

8. Select the Index tab. 
 

 
9. If the data index was created with an XML Wrapper, select Module field > XML Wrapper.  

It is advised to use a data index with XML Wrapper when adding fields. 

10. Click OK.  

11. To add more fields, repeat step 5 to 10. 

12. Click OK. 

13. Build the index. 

14. Go to \\Program Files\ZyLAB\Workflow\webroot\App_Data 

15. Open the settings.xml file. 

16. Scroll to line <field id="Documents" hide="true">Number of Documents</field> 

17. Below this line, add the following line for each custom workflow field: 
 
<field id="Custom01" hide="false">Custom01</field> 

18. Scroll to section <customfields> 

19. Replace <!-- fill here your own document fields --> with <field id="Custom01" name="Custom01" 
property="Custom01" type="2"></field> for each custom workflow field. 

20. Scroll to section <mappings> 

21. Replace <!-- fill here your own document fields --> with <field id="Custom01" hide="false" 
width="200">Custom01</field> for each custom workflow field. 

22. Save the settings.xml file. 
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Result 

You have added Custom Workflow Fields to your workflow. 

Note 

If you want to change the order of the mappings and/or define an alternative mapping, the codes 
<mappings ordered="true|false">, <own ordered="true|false">, <management ordered="true|false"> 
and/or <completed ordered="true|false"> can be added to the settings.xml file, located at \\Program 
Files\ZyLAB\Workflow\webroot\App_Data. All nodes can contain fields: 

 

• <mappings ordered="true"> 
 
The columns in the grid will have the same order as the columns in the settings file.  

 

New (optional) childs of this node are: 

• <own ordered="true">  
<field ... 
</own> 
 
This node means a separate configuration for the own workflow grid. Order will not be obtained from 
the mappings node. 

• <management ordered="true">  
<field ... 
</management > 
 
This node means a separate configuration for the management grid. Order will not be obtained from 
the mappings node. 

• <completed ordered="true">  
<field ... 
</completed> 
 
This node means a separate configuration for the completed grid. Order will not be obtained from the 
mappings node. 

• <field ...  
</mappings> 
 
This node means a separate configuration for all grids that are not configured.  
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Update Document Fields 

Conditions 

You want to regularly update document fields. 

Instructions 
1. Create a scheduled task. Creating a scheduled task is different for each Operating System.  

a) For Windows XP, for example, go to Start > Control Panel > Scheduled Tasks.  

b) Double click on Add Scheduled Task. 
The Scheduled Task Wizard will appear. 

c) Click Browse. 

d) Go to \\Program Files\ZyLAB\Workflow\webroot\bin and select ZyLAB.Workflow.TaskConsole.exe 

e) Define the name for this task: ZyLAB.Workflow.TaskConsole UpdateFields 

f) Define how often this task should be performed. 

g) Click Next. 

h) Define the time schedule more precise. 

i) Click Next. 

j) Define the Windows user name and password. 
  
If Windows authentication is used in the configuration (see Automatically Log in to Workflow: 
Enable Windows Authentication (page 268)), this should be a Windows user known by ZyLAB 
Workflow.  
If a ZyLAB User will be used, a Windows user only has to be able to start an application. 
 
For using ZyLAB user authentication, the user has to be defined in the 
ZyLAB.Workflow.Taskconsole.exe.config file, located at \\Program 
Files\ZyLAB\Workflow\webroot\bin. See Note below. 

k) Click Next. 

l) Click Finish. 

Result 

You have defined how often document fields should be updated. 
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Note 

Define the ZyLAB Platform username and password in the ZyLAB.Workflow.Taskconsole.exe.config file, 
located at \\Program Files\ZyLAB\Workflow\webroot\bin and set the UseFormsAuthentication value 
to true. 
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Notify Users of Due Tasks 

Conditions 

You want to notify a user a few days in advance of due tasks. 

Instructions 
1. Create a scheduled task. Creating a scheduled task is different for each Operating System.  

a) For Windows XP, for example, go to Start > Control Panel > Scheduled Tasks.  

b) Double click on Add Scheduled Task. 
The Scheduled Task Wizard will appear. 

c) Click Browse. 

d) Go to \\Program Files\ZyLAB\Workflow\webroot\bin and select ZyLAB.Workflow.TaskConsole.exe 

e) Define the name for this task: ZyLAB.Workflow.TaskConsole notify [DueDays] 
Where DueDays are the number of days before the scheduled date that the task should be 
performed by the user. 

f) Define when this task should be performed. In this case: One time only. 

g) Click Next. 

h) Define the start time and start date. 

i) Click Next. 

j) Define the Windows user name and password. 
  
If Windows authentication is used in the configuration (see Automatically Log in to Workflow: 
Enable Windows Authentication (page 268)), this should be a Windows user known by ZyLAB 
Workflow.  
If a ZyLAB User will be used, a Windows user only has to be able to start an application. 
 
For using ZyLAB user authentication, the user has to be defined in the 
ZyLAB.Workflow.Taskconsole.exe.config file, located at \\Program 
Files\ZyLAB\Workflow\webroot\bin. See Note below. 

k) Click Next. 

l) Click Finish. 

Result 

You have defined when and how a user is notified of due tasks. 
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Note 

Define the ZyLAB Platform username and password in the ZyLAB.Workflow.Taskconsole.exe.config file, 
located at \\Program Files\ZyLAB\Workflow\webroot\bin and set the UseFormsAuthentication value 
to true. 
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Set up a Workflow via ZySCAN 

Conditions 

You want to start a workflow whenever a document is exported to an index/database. Either the workflow 
template and user can be specified (for run unattended processing) or the user can set this interactively (in 
attended processing). 

Instructions 
1. Open ZySCAN.  

2. Go to Options > Global Options. 

3. Select a Workflow index from the dropdown listbox. 

4. Click OK. 

5. Go to Template > New template. 

6. Define a new template, or choose an existing template to base the new one on. 

7. Click Next. 

8. Select Use XML internally. 

9. Select External Link. 

10. Select another index, in which you want to store your data (documents related to the Workflow index 
selected in step 3). This should not be a Workflow index, but a standard index. 

11. Select the checkbox Create ZyLAB Workflow. 

12. Click Next. 

13. Select ZySCAN or ZyIMPORT. Select ZyFIELD, ZyOCR, and ZyEXPORT. 

14. Click Next. 

15. Define your settings for ZySCAN or ZyIMPORT. 

16. Click Next. 

17. Click ZyLAB Workflow. 

18. Select a template, and select a user. 

If the Workflow template allows it, more users can be selected (see Create New Task (page 258) > 
Type) 

19. Click OK. 

20. Click Next twice. 

21. Notice that no export directories can be chosen. 

22. Click Next. 

23. Click Finish. 
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Result 

You have created a job template which can be run to start a Workflow. For unattended processing, see the 
ZySCAN manual > (Semi-)automatic job processing. 

Note 

For more information on creating a template, see the Standard User Manual > Preparing documents for 
full-text retrieval > Creating job templates. 
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Using ZyLAB Workflow 

For a complete manual of ZyLAB Workflow (including Installation and Configuration), contact support 
(http://support.zylab.com). 
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Start a Workflow 

Conditions 

You have installed and configured ZyLAB Workflow. Now it is time to start a workflow. 

Instructions 
1. Launch Internet Explorer. 

2. Go to http://<workflow server>/zyworkflow. 

3. Login using a username and password defined in ZyINDEX Security. The user is added to a workflow 
workpool. 

4. In the Own Workflow or Management Workflow tab, select New Workflow. 

Only authorized users can view and use the Management Workflow tab. For more information, 
see Create Workpools (page 255) and Create Workpool Templates (page 256). By connecting 
workpools (user groups) with tasks, user rights are defined. 

5. Select a workflow template. 

6. Select a user. 

7. Click OK. 

8. The user to which the workflow is assigned, can select the first task via the Active Tasks folder. 

 
9. Double click on the first task to get started with the workflow. 

 

 
10. In the To Do tab, the first task will appear. 

The actions that can be completed depend on the template chosen. 

284 

 



ZyINDEX Manual 

 

 

 

Result 

You have started a workflow.  
 
Alternatively, a workflow is started via ZySCAN (see Start a Workflow via ZySCAN (page 286)), ZyLAB 
Archiving (see Start a Workflow via ZyLAB Archiving (page 287)), or ZyVIEW (see Start a Workflow via 
ZyVIEW (page 288)). Once the user has logged in to ZyLAB Workflow, the first task can be selected 
immediately via the active tasks folder. 

Note 
• To group tasks by column, drag a column header to the row above the columns. 
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Start a Workflow via ZySCAN 

Conditions 

You want to start a workflow via ZySCAN. You can start an attended workflow, or an unattended one. 

Instructions Attended Mode 
1. Open ZySCAN. 

2. Click New Job. 

3. Select the correct template. See Set up a Workflow via ZySCAN (page 281). 

4. Click OK. 

5. When you are done scanning or importing, continue with the next stage. 

6. In the Field Editor the ZyLAB Workflow field shows the selected Workflow template and user(s). 
Click Modify, to choose another template and/or user(s). For each document, another template and/or 
user(s) can be selected. 

7. Click OK. 

If no template/user is selected, a warning appears. 

8. Continue with the next stages. 

9. If Export fails, check in ZyFIELD if for every document a template/user is selected. 

Result 

You have started a workflow via ZySCAN. 

Unattended Mode (Job > Run > Unattended > Entire job, or ZySCAN NT Service) 

If not all parameters (Workflow template, user(s)) are added correctly in the ZySCAN template, you cannot 
select a template. Correct the parameters via the Template Wizard (Template > New template). 
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Start a Workflow via ZyLAB Archiving 

Conditions 

You want to start a workflow via ZyLAB Archiving. 

Instructions 
1. In MS Outlook, go to ZyLAB > Archive Options. 

2. Select the Profiles tab. 

3. Click Add Profile. 

4. Define the Profile. 

5. In the Additional Processing dialog, select the option 'Enable Workflow'. 

 Browse to the applicable Workflow Template. 

 Enter the Workflow User name. 

6. Finish the Profile. 

Result 

When email is archived, the profile can be selected and a new workflow will start with the email as 
attachment. If you archived to a webclient, the workflow can be viewed in the webclient. 

Note 

For more information on defining a Profile, see the ZyLAB Archiving Services for MS Office manual. 

287 

 



ZyINDEX Manual 

 

 

Start a Workflow via ZyVIEW 

Conditions 

You have searched an index, and opened a document in ZyVIEW. 

Instructions 
1. In ZyVIEW, go to Workflow (in the menu bar). 

2. Select the Workflow (template) to which you want to link the document. 

3. Select a user to whom you want to assign the first task. 

4. Click OK twice. 

Result 

You have linked a document to a new Workflow. The first task has been created, and assigned to a user. 
Double clicking on the task will start the Workflow. 
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Continue and Complete a Workflow 

The first task of a Workflow is completed. The second task will most likely be processed by another user. 
After the second task is completed, it will be assigned to another user, or - when the Workflow is 
completed - it will be closed.  
Users can only see the tasks assigned to them in the Own Workflow tab. Managers can view all tasks of all 
users and all completed workflows in the Management Workflow and Completed Workflows tabs. 
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To Do 
• In the To Do tab you can define how the task should be completed, information can be defined and 

documents added. 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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Documents 
• In the Documents tab you can view all documents attached to the workflow. 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 

291 

 



ZyINDEX Manual 

 

 

Authorizations 
• In the Authorizations tab you can view the tasks which have been authenticated. Tasks can be 

authenticated using the pincode generated for the logged in user. For more information, see Digital 
Signature (page 270). 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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Custom Actions 
• In the Custom Actions tab you can view the information defined so far. 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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History 
• In the History tab you can view the tasks that have been completed so far. 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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General 
• In the General tab you can view information on the current task and the current workflow. 

• Tasks can be completed or assigned to another user. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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Own Workflow 

The Own Workflow tab is the opening screen of ZyLAB Workflow. All tasks of the logged in user and 
unassigned tasks can be viewed here. 

Refresh 

To view newly added tasks, select the Refresh button. 

New Workflow 

To start a new workflow, select the New Workflow button. 

Report 

To create a report, select the Report button. A report contains the following information: 

  

Workflow Name Text 

Workflow Creator Text 

Workflow Creation Date Date/Time 

Workflow Creation Time Date/Time or Empty 

Workflow Due Date Date/Time or Empty 

Priority Number 

Is Locked? Yes/No 

Locked By Who? Text 

Locked On Date/Time or Empty 

Current Task Name Text 

Template Name Text 

Current Assigned User Text 

   

Open fast workflow 

To efficiently process a list of workflow tasks, select the Open fast workflow button. 
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Instructions 
1. Make sure the active tasks folder is selected.  

The active tasks will appear in the right pane. 

2. Select the Open fast workflow button. 
 

 
3. Double click on a task to start a workflow. 

4. You can complete a task while still viewing the other tasks. If a task is completed, you can continue 
immediately with the next task. 

5. If you completed a task, click OK. 

6. To skip a (previous or next) task, select one of the Skip buttons. 
 

 
7. To return to the main page, click the Close fast workflow button. 

Result 

You have processed a number of workflow tasks. 

Note 
• As soon as a workflow is opened that is already in use, this workflow will be locked. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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Management Workflow 

Only authorized users can view and use the Management Workflow tab. For more information, see Create 
Workpools (page 255) and Create Workpool Templates (page 256). By connecting workpools (user groups) 
with tasks, user rights are defined. 

Refresh 

To view newly added tasks, select the Refresh button. 

New Workflow 

To start a new workflow, select the New Workflow button. 

Suspend 

To suspend a task, select it and click the Suspend button. The task will be stored in the Suspended 
workflows folder. 
Suspension of a task will delay the due date of a workflow. 

Resume 

To resume a task, select it via the Suspended workflows folder and select the Resume button. The task will 
return to the Active tasks folder. 

Delete 

To delete a task assigned to a user, select it and click the Delete button. 

Assign 

To assign a task to a user, select the task, select a user from the dropdown listbox and click the Assign 
button. The task will appear in the Active tasks folder of the assigned user. 
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Open fast workflow 

To efficiently process a list of workflow tasks, select the Open fast workflow button. 

Instructions 
1. Make sure the active tasks folder is selected.  

The active tasks will appear in the right pane. 

2. Select the Open fast workflow button. 
 

 
3. Double click on a task to start a workflow. 

4. You can complete a task while still viewing the other tasks. If a task is completed, you can continue 
immediately with the next task. 

5. If you completed a task, click OK. 

6. To skip a (previous or next) task, select one of the Skip buttons. 
 

 
7. To return to the main page, click the Close fast workflow button. 

Result 

You have processed a number of workflow tasks. 

Note 
• As soon as a workflow is opened that is already in use, this workflow will be locked. 

• To define the first tab that must appear on startup and all other tabs which must appear (when 
available), select the Options button. Click OK. 
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Report 

To create a report, select the Report button. A report contains the following information: 

  

Workflow Name Text 

Workflow Creator Text 

Workflow Creation Date Date/Time 

Workflow Creation Time Date/Time or Empty 

Workflow Due Date Date/Time or Empty 

Priority Number 

Is Locked? Yes/No 

Locked By Who? Text 

Locked On Date/Time or Empty 

Current Task Name Text 

Template Name Text 

Current Assigned User Text 
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Completed Workflow 

Only authorized users can view and use the Completed Workflow tab. For more information, see Create 
Workpools (page 255) and Create Workpool Templates (page 256). By connecting workpools (user groups) 
with tasks, user rights are defined. 

Refresh 

To view newly completed workflows, select the Refresh button. 

New Workflow 

To start a new workflow, select the New Workflow button. 

Delete 

To delete a completed workflow, select it and click the Delete button. 

Open fast workflow 

To efficiently view a list of completed workflows, select the Open fast workflow button. 

Instructions 
1. Select a folder with completed workflows. 

2. Select the Open fast workflow button. 

3. Double click on a workflow to view the Custom Actions, History and/or General properties. 

4. If you completed viewing a workflow, continue with the next one. 

5. To return to the Completed Workflow tab, click the Close fast workflow button. 

Result 

You have viewed a number of workflows. 

Note 

To define the first tab that must appear on startup and all other tabs which must appear (when available), 
select the Options button. Click OK. 
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Report 

To create a report, select the Report button. A report contains the following information: 

  

Workflow Name Text 

Workflow Creator Text 

Workflow Creation Date Date/Time 

Workflow Creation Time Date/Time or Empty 

Workflow Due Date Date/Time or Empty 

Priority Number 

Is Locked? Yes/No 

Locked By Who? Text 

Locked On Date/Time or Empty 

Current Task Name Text 

Template Name Text 

Current Assigned User Text 
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Search 

Conditions 

You want to search documents in archives that are connected to the workflows.  

Instructions 
1. Select the Search tab. 

The Search Portal appears. 

2. Enter your Username and Password. 

3. Click Register. 
The Search page appears. 

4. Enter your search query. 
For more information on searching the archives via the ZyLAB Web Server, select the Help button. 

5. Click Search. 

Result 

You have searched documents in archives that are connected to the workflows. 

Note 

The Search tab can be hidden via the settings.xml file. Go to \\Program 
Files\ZyLAB\Workflow\webroot\App_Data\ and open the settings.xml file. Set 'searchtab visible' to false 
and save the file. 
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