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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY
(OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO Spotfire, and TIBCO Enterprise Runtime for R are either
registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

THIS SOFTWARE MAY BE AVAILABLE ON MULTIPLE OPERATING SYSTEMS. HOWEVER, NOT
ALL OPERATING SYSTEM PLATFORMS FOR A SPECIFIC SOFTWARE VERSION ARE RELEASED
AT THE SAME TIME. SEE THE README FILE FOR THE AVAILABILITY OF THIS SOFTWARE
VERSION ON A SPECIFIC OPERATING SYSTEM PLATFORM.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

Copyright © 2006-2015 TIBCO Software Inc. ALL RIGHTS RESERVED.

TIBCO Software Inc. Confidential Information
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TIBCO Documentation and Support Services

All TIBCO documentation is available on the TIBCO Documentation site, which can be found here:

https://docs.tibco.com

Product-Specific Documentation

The following documents for this product can be found in the TIBCO Documentation Library for
TIBCO Spotfire Professional:

● TIBCO Spotfire® User's Guide

● TIBCO Spotfire® Deployment and Administration Manual

● TIBCO Spotfire® Administration Manager User's Manual

● TIBCO Spotfire® License Agreement

How to Contact TIBCO Support

For comments or problems with this manual or the software it addresses, contact TIBCO Support as
follows:

● For an overview of TIBCO Support, and information about getting started with TIBCO Support,
visit this site:

http://www.tibco.com/services/support

● If you already have a valid maintenance or support contract, visit this site:

https://support.tibco.com

Entry to this site requires a user name and password. If you do not have a user name, you can
request one.

How to Join TIBCOmmunity

TIBCOmmunity is an online destination for TIBCO customers, partners, and resident experts. It is a
place to share and access the collective experience of the TIBCO community. TIBCOmmunity offers
forums, blogs, and access to a variety of resources. To register, go to:

https//www.tibcommunity.com
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New Features

The following new features have been added to version 7.0.0 of TIBCO Spotfire®.

Recommendations
Spotfire Recommendations is a new, easier and faster way of creating visualizations, learning about
your data and letting you get to insights quicker—regardless of whether you are an experienced
analyst or a newcomer to visual analytics. With Spotfire Recommendations you can look at your data
from different angles, discover new insights, and get a visual overview of your data.

New Data Panel
Spotfire 7.0 allows you to get a better overview of the loaded data in the new data panel. Here, all
columns in the data are visible. By default, the columns are divided into categories such as number,
category, or time, which makes it easier to find what you are looking for. The data panel is the basis
for interacting with your columns; you can grab a column and drop it on the visualization, rename a
column, delete a column or filter the data based on the column values.

New Visual Themes
The possibility to change the look of your Spotfire application and analyses has been introduced with
the new visual themes. There is a light and a dark theme available by default, but you can also create
custom themes. You change themes using the Visual Theme button on the toolbar, or by selecting
View > Visual Theme in the main menu. You can import a custom theme from an analysis stored on
disk or in the library. Use the Import Theme from File/Import Theme from Library option available on
the button in the toolbar to import a theme.

Overview of Changed Filters
An overview of changed filters is provided in the filters panel and in the new data panel.

Improved Default Titles for Visualizations
With the new default title (${AutoTitle}) used when creating a new visualization, the title changes
dynamically to reflect the current configuration of the visualization.

Trellis in Legend
You can trellis using column selectors directly in the legend similar to the color by and shape by
features in earlier releases.

Grouping of Categories

The new easy-to-use grouping feature allows you to combine two or more marked categories
displayed in the visualization into one. This is very useful in several situations:

● When you want to compare the total of more than one category against other categories. For
example, when you want to compare the sales in (Boston + New York) against sales in Los
Angeles.

● When you spot spelling errors or alternative spellings that cause data to be split into more
categories than needed.

● When you want to compare, for instance, the top 10 categories against the rest.

In addition, it is also possible to create a binned column by manually grouping any combination of
values from the column.

Support for Nested Aggregations in Expressions
Now TIBCO Spotfire® allows aggregations in expressions to be nested. This removes the need of
having to create intermediate calculated columns, and allows you to instantly visualize, for instance,
the maximum or minimum of an aggregated number.

New Expression Shortcut: Top Category
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A quick calculation shortcut has been added to appropriate column selectors, which allows you to
easily find the top category on a map or in other categorizing visualizations. For example, this can be
used to visualize the winning party in an election for each state, to color a map chart based on the best
selling product or to view which crime has the highest rate in each region of a map.

Improved Column Matches
When visualizing data from different data tables in one visualization, you can now add transforms to
convert column values from one column so that they match the values in the other data table.

OLAP Cubes Connection Improvements
It is now possible to limit the data of interest from OLAP Cube connections. By limiting the selection
to suitable chunks it is also possible to import cube data into Spotfire and analyze the selection in-
memory rather than in-database.

Improved Data Recognition
The ability to automatically recognize common data values, such as months or weekdays, as well as
the default formatting of timespan data have been improved. For example, if your data contains the
names of months, you can now get the correct sort order right from the start, without having to create
a custom sort order. There have also been some improvement to the TIBCO Spotfire client's ability to
detect binary data, so that many types of images can be shown in the visualizations directly.

Improvements in Views in Connection Dialog
Custom relations in the Views in Connection dialog now allow you to specify a different join type.
Custom queries are now placed in a separate "Custom queries" folder. Context menus for Exapand/
Collapse and Select/Deselect have been added. Views now include tooltips showing original table
names.

Calculated Columns for In-Database Data Tables
It is now possible to insert calculated columns into data tables based on (non-cube) in-database data.
The expression is evaluated in the underlying DBMS. A new preview has been added showing
calculated values for the first 100 rows (applicable to both in-db and in-memory).

Improvements for Administrators
A new tab has been added to the Edit Properties dialog, displaying additional metadata for analyses
in the library. These library properties that may be useful for estimating resource consumption for
analyses in the library. The Support Diagnostics dialog has gotten better options for investigating
issues with analysis files.

Expression Language Improvements
A new BinByTimeSpan method has been added to the expression language, which lets you set up
your own TimeSpan hierarchies in calculated columns and custom expressions. The Find function has
been updated with an optional third argument for multiple matches. The Base64Encode/
Base64Decode functions have been added to be able to convert binary large objects so they can be
viewed as an image in Spotfire. Also, various performance improvements have been made.

Map WMS Layer Transparency
Standard map and WMS layers now support transparency. You control the transparency via a slider
on the General page of visualization properties for these layer types.

Map Chart Geocoding Improvements

Several improvements have been made to the Map Chart geocoding, including:

● Improved center point calculation. For instance, the marker for Florida is now better placed.

● Most common geocoding tables are now sorted by population. This gives a better result when the
geocoding is ambiguous, like, when geocoding on a city column only and several cities with the
same name exist.

Easy Access to Sample Data
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A set of useful sample data is now available from the start page.

Hierarchy Slider for TimeSpan Columns
Just like for DateTime columns, columns of type TimeSpan now automatically get a Hierarchy slider.

Improved Organize Filters Dialog
The organize filters dialog now includes search capabilities and the capability to select/deselect all
filters in a specific data table or group.

Drag-and-Drop Hierarchy Level from the Data Panel to a Visualization
It is now possible drag a sub-level in a dimension hierarchy to the X-axis, in order to only show the
sub-hierarchy of interest in the visualization.

Mark from Legend
Spotfire 7.0 introduces the ability to mark elements in the visualization by clicking on categories in the
legend. This is useful especially in visualizations with many graphical elements and lets you compare
the marked category with the other categories. Mark from legend works for the color and shape axis
for categorical and binned columns.

Improved Script Management and Script Trust
When opening an analysis containing untrusted scripts, you have the option to trust all scripts with
one single click. This works for both IronPython and Java scripts. The feature is available
automatically when opening analyses containing untrusted scripts, and it is handled from Document
Properties, the Scripts tab.

Automatic Updates of Data Table from Current Analysis
The ability to automatically update a data table based on another data table from the current analysis
has been introduced. Now, the new data table can be automatically updated whenever the source
table changes. For new analyses, this is the default setting. For old analyses, you can go in and change
to automatic updates using Edit > Data Table Properties > Refresh Data > With Prompt, and selecting
Automatic update in the Data Table from Current Analysis dialog.

Syntax Highlighting for Data Functions and Expression Functions
Now TIBCO Spotfire® provides syntax highlighting for data scripts and expression scripts written
using TIBCO Enterprise Runtime for R, open-source R, or S-PLUS. Syntax highlighting colors were
selected to closely match the default settings of Notepad++. In this version of Spotfire, the colors are
not customizable.

TERR Tools
Under the Tools menu you can now access TERR Tools which are a collection of useful features when
working with TERR. For example, it is now possible to launch a TERR console, access the TERR
language reference and launch RStudio (if installed on your machine). It is also now much easier to
install R packages locally for use with the embedded TERR engine.

Broader R Compatibility in TERR
The embedded TERR engine features much broader R compatibility, performance improvements and
many features for integration with a variety of products. See the TERR Release Notes for full details.
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Changes in Functionality

The following are changes in functionality in version 7.0.0 of TIBCO Spotfire.

Text Area
Editing the text area is made in an external pop-up window instead of directly in the text area field.

Scripts in the text area are executed each time the text area is loaded. The Professional and the web
clients now have the same behavior.

Tooltips
Tooltips are shown when moving the X-axis zoom slider.

Drag and Drop of Axis Expressions
An axis expression is moved instead of copied when dropping the expression on the drop target in the
same visualization.
You copy an expression by pressing Ctrl when dropping the expression on the drop target in the same
visualization.

Display Filter Settings
Current filter settings are shown at the bottom of the Data panel and at the bottom of the Filters panel
instead of as a tooltip when moving the cursor over the Filters panel header.

Visualization Properties
Double-clicking a visualization title bar will edit the visualization title instead of opening the
visualization Properties dialog.

Default Colors
The default color scheme has been updated. Analyses created in earlier versions will retain their
original color scheme.

Default Font
You can set the font to '(Default)' in Tools > Options, the Fonts page. A default font setting will inherit
the font setting from the loaded visual theme.
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Deprecated and Removed Features

The following tables list any features that have been deprecated or removed as of version 7.0.0 of
TIBCO Spotfire®.

For deprecated features, if relevant, useful alternatives to the deprecated features are listed. Any use of
a deprecated feature should be discontinued as it may be removed in a future release. You should
avoid becoming dependent on deprecated features and become familiar with the suggested alternative
features.

Deprecated Features

Affected
Component Description

Text Area v3.0 It is not possible to create new instances of an old type of non-HTML Text
Area (Spotfire v3.0 and earlier versions). Instead, all new text areas will be of
the type introduced in Spotfire v3.1.

You can still open analyses containing old versions of the Text Area.
However, support for displaying old non-HTML text areas will be dropped
in a future Spotfire version.

Bookmarks v3.2 Opening an analysis containing an old type of bookmarks (Spotfire v3.2 and
earlier versions) will automatically convert the bookmarks to the new type
of bookmarks used in Spotfire v3.3 and later.

Map Chart v5.5 It is not possible to create new instances of the old single layer map chart
(Spotfire v5.5 and earlier versions). Instead, all new map charts will be of the
type introduced in Spotfire v6.0, which is capable of displaying multiple
layers.
You can still open analyses containing old versions of the map chart.
However, support for displaying old map charts will be dropped in Spotfire
v8.0.

It is recommended that you convert old map charts to the new
type by selecting Switch To Map Chart in the visualization's
context menu.

Multiple selection
with Shift+F8

It is not possible to select several values in a list box filter using the multiple
selection mode (Shift+F8). Instead, select several values in the standard way,
that is, use Ctrl + mouse click.

Removed Features

Affected Component Description

Popover mode The legend cannot be in popover mode.

The Collaboration panel cannot be in popover mode.

Floating panels It is not possible to move floating panels outside of the Spotfire
window.
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Affected Component Description

Context menus Context menus are not accessible from:

● Right-clicking or double-clicking in the description for a
visualization

● Right-clicking in the visualization title bar

Drag and drop operation in
the Table visualization

The disabled drop target for adding a column that already exists is
not shown when dragging a column over a Table visualization.

Resizing images in text areas It is not possible to resize an image and maintain the aspect ratio by
pressing Shift while resizing the image.
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Migration and Compatibility

The following are instructions on how to migrate from a previous release to version 7.0.0 of TIBCO
Spotfire.

Installation of Release 7.0.0

1. First install/upgrade the TIBCO Spotfire® Server to version 7.0.

2. Install TIBCO Spotfire® Professional 7.0 on all client computers.

3. Finally, deploy the TIBCO Spotfire® 7.0 distribution on the TIBCO Spotfire® Server 7.0.

Upgrading from Previous Version without Installing

1. First install/upgrade the TIBCO Spotfire® Server to version 7.0.

2. Deploy the TIBCO Spotfire® 7.0 distribution on the TIBCO Spotfire® Server 7.0.

3. Start the old version of TIBCO Spotfire® Professional, log on to the TIBCO Spotfire® Server 7.0 and
accept the update.

Installation Notes

● If the .NET 4.5 framework is not installed, it will be downloaded and installed when launching the
TIBCO Spotfire® Client installer.

● If the product localization is defined as a user group preference, a client restart is required after the
initial login to the server for the changes to be fully applied. Note that clients are not informed that
such a restart is required. It is also important that the appropriate localization packages are
deployed to the TIBCO Spotfire® Server prior to setting the user group preference.

Note that the correct Language pack and the matching server preference must be set on the very first
server that the user connects to. Changing the settings on the Server will not have any effect. If the
localization group preference does not have any effect, it can be enforced on clients using Tools >
Options.
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Closed Issues

The tables list important closed issues in version 7.0.0 of TIBCO Spotfire®.

Key Summary

TS-35327 Marking in a visualization with a Holt-Winters Forecast was many times slower in
6.5 than in 6.0.

TS-31114 Spotfire did not support hierarchical sets in Microsoft SQL Server Analysis
Services, i.e., when a dynamic set returned more than one column .

TS-30062 Refreshing a schema definition in Spotfire based on external data did not provide a
warning if the table had been renamed in the external system.

TS-29967 Error message was shown in visualization for some invalid expressions (with, for
example, mismatched parentheses) that were allowed in 5.0.

TS-24512 When exporting a map chart to PDF using vector graphics, the map was not
rendered correctly.

SNXT-3689 Issues with Data Functions running the local TIBCO Enterprise Runtime for R
engine:

Running library(sjdbc) throwed error when loading required package terrJava due
to no JAVA_HOME environment variable set.

TS-36937 Client error when tags column was frozen and new rows were added.
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Known Issues

The tables list known issues in version 7.0.0 of TIBCO Spotfire.

OLAP Import

Key Summary

Summary: On-demand is not supported for cube data sources.

Workaround: You can limit the data in the data connection by using Limit Data in
the Data Selection in Connection dialog. Only fixed values can be used.

Summary: In contrast to data connections from relational data sources, selections
for cube data connections always result in a single data table in Spotfire.

Workaround: To get multiple data tables, create a connection per table and add all
connections separately.

Summary: You cannot switch from an imported configuration to an in-database
configuration in a cube data connection, the way you can with relational data
sources, or vice versa.

Workaround: You can replace a data table based on an imported cube data
connection with another data table based on an in-db connection, or vice versa.

Summary: When cube hierarchies have been added to a connection, the hierarchies
in Spotfire will not be updated when the data connection is edited.

Workaround: Recreate new hierarches manually.

Summary: Import of large amounts of data may not work.

Workaround: If you try to import and it fails, you can edit the connection and limit
the selected dimensions and/or categories some more.

Summary: The estimation of the expected import size is only an approximation
and cannot give any definitive information regarding whether or not an import
will work. If the estimation takes a long time it often, but not always, means that
the selection is too big to import.

Workaround: None

Summary: If multiple instances of one leaf value exist you may get different
behavior between imported data and in-db data, since the imported data may have
lost hierarchical information required in order to distinguish the leaf values from
each other. For example, there is more than one city called Berlin in the world and
after an import, all of those cities will be clumped together into one group in the
flattened data table, unless you make sure to always include full hierarchies on all
axes.

Workaround: Include full hierarchies on all axes, if this is an issue.

Summary: You can only select full hierarchies, not single columns from a
hierarchy.

Workaround: None
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Key Summary

Summary: PKI:s are not supported when working with Microsoft SQL Server
Analysis Services.

Workaround: None

Summary: In SAP BW, user hierarchies are built from attribute hierarchies. It is not
possible to import user hierarchies together with the underlying attribute
hierarchies.

Workaround: None

Calculated Columns for In-Database Data Tables

Key Summary

Summary: Cube data connectors are not supported.

Workaround: None

Summary: Binning is not supported.

Workaround: None

Summary: OVER expressions are not supported.

Workaround: None

Views in Connection Dialog

Key Summary

Summary: The join type can only be specified for user defined relations, not for
relations set up by the database administrator.

Workaround: None

Other Known Issues

Key Summary

TS-24612 Summary: When setting a document property value from an expression in a
property control in the text area, it is not possible to select columns from any data
table.

Workaround: Change the default data table in Data Table Properties.

TS-39291 Summary: With some configurations, Recommendations may display empty map
chart visualizations.

Workaround: Turn on auto-load option for all geocoding tables.

Summary: Filtering in the Data Relationships results table will prevent re-
calculation of the Data Relationships.

Workaround: Reset filters and then Data Relationships can be re-calculated again.
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