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VueLink 1
Introduction
VueLink for Documentum provides an interface between the Documentum 
Webtop and the AutoVue family of products. This interface enables you to add 
powerful Viewing and Markup capabilities to your Documentum Webtop via 
web browser in an intranet or the Internet.

VueLink and AutoVue will provide you with the following functionality:

1 Document viewing of native formats.
2 Graphically marking up documents using a rich set of graphical and textual 

tools.
3 Reviewing your Markups and the Markups of your coworkers.
4 Full security linking to the Docbase access control list (ACL).

This manual is intended for the users of VueLink, as well as, the System 
Administrator or other individual who performs the VueLink setup.

Note:  

• Throughout this manual the family of AutoVue Products is referred to as 
AutoVue. The AutoVue family of products includes AutoVue, AutoVue 
Professional, AutoVue SolidModel, AutoVue SolidModel Professional and 
Office. These products are available in Windows, UNIX or Java.

• AutoVue Professional, AutoVue SolidModel Professional and Office 
provide Markup features. Refer to the User’s manual for further information 
about the specific features and file formats supported by each AutoVue 
product.

Functional Overview
VueLink for Documentum adds document Viewing and Markup capabilities to 
Documentum Webtop. It provides a seamless user interface between Webtop 
clients and AutoVue. All Webtop clients are supported via a Web browser in an 
intranet/Internet environment. Markups are automatically saved on the Docbase 
server and are available for other users to edit or view depending on their 
document access level.
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2 VueLink
VueLink and AutoVue are also available with special handling capabilities for 
CAD documents created with AutoCAD or MicroStation directly from 
Documentum under the CADLink Review product name. If your needs include 
AutoCAD and/or MicroStation, please contact your Documentum account 
representative for more information. CADLink Review is developed by 
CADSpace Inc., a Documentum Signature Partner.

VueLink for Documentum and AutoVue provide users with the following 
powerful features and capabilities, locally or remotely via a Web browser:

• Securely view documents in their native format without editing them.
• View more than 200 2D, EDA & 3D Engineering and Business document 

formats.
• View multi-content objects.
• Simultaneously work with multiple Markup layers and files.
• Create Markups directly on stored documents or renditions using a rich set 

of annotation tools.
• Create hyperlink connections to other related documents.
• Consolidate several Markup files (perhaps from different reviewers) into a 

single Markup file.
• Control access to Regular, Read only, Master and Consolidated Markup 

files.
• Associate Markups with a specific document revision. Markups may be 

migrated to new revisions as required.
• Graphically compare different revisions of engineering drawings.
• Print documents with header, footers and watermark information queried 

from specified document attributes.
• Create and store Adobe Acrobat PDF renditions of documents and 

associated Markups directly from your workstation (Adobe Acrobat Distiller 
required).

VueLink for Documentum also provides you with a basis to which other 
powerful functions can be added via custom designed tools to further enhance 
your Documentum installation. Custom designed tools offer many possibilities. 
For example, you could create 'intelligent' custom stamps such as an engineering 
stamp that queries for information that could be included as Markups.

In addition, custom applications could be created to extract relevant information 
from an AutoCAD or MicroStation file, and automatically link it with 
information from your Documentum Docbase or other system. This brings the 
concept of intelligent drawings to a new level. All these features are available 
from your Web browser by using the AutoVue Web Edition.
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VueLink 3
AutoVue is fully configurable for you to customize your own tools. If you prefer, 
contact your account manager or our technical support representatives to discuss 
the possibilities of us designing a tool to meet your specific needs.

Why does the Documentum user 
need a Viewing/Markup tool?
Typically, in an organization, a document has a life cycle and is routed to several 
people as part of a workflow cycle. The following is an example of a possible 
workflow cycle.

At minimum, there are three types of people that interact with a document:

Creator/Author of a document: The creator is usually the person responsible 
for creating or modifying a document with an editing application such as 
Microsoft Word or AutoCAD.

Reviewer of document: This individual usually reviews a document and 
provides comments to the author or other reviewer. In a paper-based 
environment, the document would be printed and sent to a list of reviewers. Each 
reviewer would provide feedback in several ways, directly annotate the paper 
output using a pen, attach sticky notes to the paper output, and create one or more 
annotation documents. The annotated document along with other material is then 
sent to a supervisor who will review the material, possibly from several 
reviewers and may consolidate the comments into one set. This set is then passed 
Oracle Corp.



4 VueLink
back to the creator for making modifications to the document. Several revisions, 
or versions of the document may be produced during this process.

Users of documents: Once the review cycle is complete, possibly involving 
several versions of the document, the document is published. The final document 
is made available to those requiring View only access to the document. At this 
stage, the document may be provided for viewing either in its native format or as 
a print rendition.

VueLink provides the capability of marking up a document and storing Markup 
information in an annotation file in the Docbase server. There are different types 
of Markup entities offered in addition to hyperlink capabilities.

Markup File Management
More than one Markup file can be attached to a document or a rendition. In 
addition, users have the option of displaying one or more Markup files 
simultaneously. If the currently displayed document has registered Markups, a 
red lightbulb button displays in the lower left corner of the status bar alerting the 
user to the existence of one or more Markup files. Markup files also 
automatically track the revisions of a document so that each revision has a 
distinct set of related Markup files. When Markups are valid for a subsequent 
revision they can be promoted to that revision.

Other Useful Features

Compare
With the Compare feature, documents of the same type (raster or vector) are 
visually compared. The two selected files are simultaneously displayed in their 
own windows with the comparison findings displayed in a third viewing window. 
This feature is very useful for finding similarities and differences in revisions of a 
drawing.

Conversion
Documents can be converted from any of the AutoVue supported file formats to 
some popular graphics formats such as TIFF.
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Engineering documents
VueLink is fully equipped to handle complex engineering documents that may 
consist of external references (XRefs), layers and blocks.

Cached metafiles
With AutoVue it is possible to enhance the viewing performance of large 
drawings by using cached metafiles. A metafile is a lightweight format 
developed by Oracle and represents a true replica of the original format.

When viewing a file, AutoVue checks if a cached metafile rendition exists inside 
Documentum. If there is one, AutoVue checks it out instead of the native file.

There are two ways you can generate metafiles and cache them as renditions 
inside Documentum:

• Online caching of metafiles
• Offline caching of metafiles

Online caching of metafiles
Every time you view a file with AutoVue and you close the client or view another 
file, AutoVue automatically generates a metafile and checks it into Documentum 
as a rendition of the original format.

Offline caching of metafiles
Oracle has developed a utility that uses AutoVue server as a rendition tool to 
generate and check in metafiles into Documentum. For instructions on how to 
install and configure the offline utility, refer to readme.doc (“Utility for Caching 
Metafile Renditions for Documentum”) in:

<vuelink install folder>\metafile_utility.
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6 VueLink
VueLink Features
This section covers the following tasks or features in AutoVue and VueLink for 
Documentum:

• Viewing documents
• Viewing renditions in Documentum for Webtop
• Viewing multi-content documents
• Accessing DMS files

•   DMS Search
•   DMS Browse

• Markups
•   Creating Markups
•   Saving Markups
•   Displaying existing Markups
•   Promoting Markups
•   Deleting Markups
•   Consolidating several Markups into a single Markup
•   Saving as Master Markup

• Printing document attributes as headers, footers or watermarks
• Converting a document to another format
• Comparing files
• Cross Probing
• MockUp
• Batch Print
• File Overlays

Viewing documents
To view documents from within Documentum and from within AutoVue, follow 
the appropriate instructions for Webtop.

Viewing a document in Documentum 
Webtop
1 Open your Web browser and go to the Webtop home page.

Example: http://doc42:8080/webtop
2 Log on and go to the stream line interface.
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3 Browse to the folder from where you want to view a file.

4 Click the AutoVue link next to the file.
AutoVue client loads the file.
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Note:  You can also launch AutoVue by clicking File > AutoVue.
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In Classic View, you can also launch AutoVue by clicking File > AutoVue.

Note:  

• To view a file from a local disk or network drive, select a file with the File 

Open icon .

• A red lightbulb button  on the left side of the AutoVue client status bar 
indicates that one or more Markup files are associated with the document 
you are viewing. 

• A resource icon  on the left side of the AutoVue client status bar 
indicates that one of the components required to accurately and fully display 
the document is missing. Click this icon for the details about the missing 
information.

• If a document has other files associated with it, as is the case with XRefs, 
AutoVue checks out all the associated files as well.
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10 VueLink
Virtual Documents
VueLink for Documentum supports the XRef schema defined as virtual 
documents. If the relationship between the base file and the XRef file is defined, 
VueLink downloads and displays all XRefs for the base document.

Viewing renditions in 
Documentum for Webtop
AutoVue displays all renditions from the list of supported file formats.

1 Select View and then Renditions for the file you want to view.
2 Click the rendition you want to view.

AutoVue client launches and displays the file you selected.

Viewing multi-content documents
Multi-content documents contain several files known as Content files. Complete 
the following steps for viewing a content file in a multi-content document.

1 Display a multi-content file in AutoVue.
2 From the View menu, select MultiContent.
3 Select Next Document, Previous Document, or Document Number.

If you selected Document Number the Document Number dialog box 
appears.

4 Enter the number of the Content file and click OK.
The Content file whose number you entered displays.

Viewing pages in a multi-page Content file
1 Display a file in AutoVue.
2 Select View > Page.
3 Select Next, Previous, or Page Number.
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If you selected Page Number the Page Number dialog box appears.

Accessing DMS files
AutoVue provides two ways to access files that are in the docbase from within 
the AutoVue window: DMS Browse and DMS Search. You can use these ways to 
select files from within the repository when you need to open files for viewing, 
comparison, cross-probe, Mockup, batch printing or Overlays

If any operation requires you to open files, the File Open dialog box lets you 
search or browse the repository.

DMS Search
1 Click the DMS Search button in the File Open dialog box.
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12 VueLink
A dialog box appears that lets you specify a search criteria.

2 To search for a file in the DMS, enter the Name, Title and/or Author of the 
file in the DMS search dialog box. 

3  When you finish specifying your search criterion, click Search.
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4 AutoVue looks for all documents in the repository that match the search 
criteria and populates the Search results section with the search results.

5 Select a file from the Search results section and select Load File to display 
the file in AutoVue.

DMS Browse
1  Click the DMS Browse button in the File Open dialog box. 
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14 VueLink
A dialog box appears that lets you browse through the repository.

2 Browse through the repository and click OK to select a file.

Markups
The three types of Markup files are normal Markups, consolidated Markups and 
Master Markups.

Normal or regular Markups: The default Markup when using a brand new 
setup.

Consolidated Markups: You can load several files simultaneously and edit 
them to create a consolidated Markup where the contents of all files consolidate 
to display as one file. This type of Markup is especially helpful when you want to 
group reviews from various individuals to forward collectively to another person 
or group of reviewers.

Master Markups: Markup files that display automatically when you open a 
document. This type of Markup alerts the viewer that important changes were 
made to the document content. This benefits the workflow cycle when changes to 
a document need to be noted but the document itself has not been modified in the 
authoring application.
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Creating Markups
1 Display a document within AutoVue. (Refer to the section on Viewing 

documents.)
2 Select File > Markup to enter Markup mode. 

You can also right-click and select Markup, or click the Markup button 

 in the toolbar.

The current active document is displayed in Markup mode, unless there are 
existing Markups.

If there are existing Markups, the Open Markup dialog box appears when you 
try to enter Markup mode.

3 To create a new Markup file, click New in the Open Markup dialog box.
The current active document is displayed in Markup mode. You are ready to 
create Markups.

4 If after you have finished creating a Markup you want to create another one, 
select File > New. 

You can also click the New button  in the toolbar.

Saving Markups
1 Select File > Save to open the Save Markup File As dialog box.
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16 VueLink
Note:  For existing Markup files, Save is enabled only when the Markup 
file has been modified.

2 Enter the Markup Name.
3 From the drop-down list, select the Markup Type.
4 From the drop-down list, select the Folder where you want the Markup file 

saved.

5 Set Keep Permanent to TRUE to automatically promote Markups to 
newer revisions of the base document.

6 Click OK.
The Markup file is saved and remains displayed in AutoVue.

Displaying existing Markups
When you are viewing a base file that has one or more Markup files, a red 
lightbulb button  displays on the AutoVue client status bar.

1 Display a base document that you know has Markup files.
2 Select File > Markup to enter Markup mode.

Alternatively, you can right-click and select Markup, or click the Markup 

button  in the toolbar.
The current active document is displayed in Markup mode unless there are 
existing Markups.
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VueLink 17
If there are existing Markups, the Open Markup dialog box appears.

3 From the Markup list, select one or more Markup files you want to view.
4 From the drop-down list, select the Active Markup.

Note:  If you did not select more than one Markup in step 3, the Active 
Markup option does not appear

5 Click OK.
All the Markups you selected are displayed simultaneously.

Promoting Markups
You can promote Markups from an earlier version of a document to the current 
version. When you promote a Markup, essentially you are saving it as a Markup 
for the latest version of a document.

1 Display a document with AutoVue.
2 Select File > Markup to enter Markup mode. 

You can also right-click and select Markup, or click the Markup button 

 in the toolbar.
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18 VueLink
The Open markup dialog box appears.

3 Select All revisions to display the Markup files from previous versions of 
the base file.
(If previous versions of the file has Markups, AutoVue lists all the Markups.) 
All the previous Markup files for previous versions of the base file are 
displayed.
Note:  In the following image, some columns were narrowed to show the 
Version column.

4 Select the Markup file for the previous version of the base file that you want 
to promote.

5 Click OK.
The Markup file is displayed with the latest version of the base file.

6 Click File > Save to save the Markup as a Markup for the latest version of 
the base file.
The Markup is saved as the Markup of the latest version of the base file.
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Note:  Save is only enabled if you have made modifications. To save 
without modifications, click Save As.

Deleting Markups
1 Display a document with AutoVue.
2 Select File > Markup to enter Markup mode.

You can also right-click and select Markup, or click the Markup button 

 the toolbar.
The Open markup dialog box appears.

3 From the Markup list, select one or more Markup file(s) that you want to 
delete.

4 Click Delete.
For each Markup file that you selected to delete, you are prompted to 
confirm deletion.

5 Click Yes to delete the Markup.
The selected Markup files are deleted from the Markup list in the Open 
markup dialog box.

Consolidating several Markups into a 
single Markup
The consolidate option allows you to create a new Markup file that combines 
copies of selected parts, or layers, of different Markup files. It is only available if 
multiple Markup files have been loaded using the multi-load option. (The multi-
load option enables you to open several Markup files at the same time.) During 
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20 VueLink
the review cycle consolidation simplifies document revisions by providing the 
author with one combined markup file instead of several Markup files.

1 Display a document with AutoVue.
2 Select File > Markup to enter Markup mode. 

You can also right-click and select Markup, or click the Markup button 

 in the toolbar.
The Open markup dialog box appears.

3 Select more than one Markup file to view.
4 From the drop-down list, select the Active Markup.

Note:  If you did not select more than one Markup in step 3, the Active 
Markup option does not appear.

5 Click OK.
All the Markup files you selected are simultaneously displayed.

6 Select File > Consolidate.

Review

Document

AUTHOR

Revise

Consolidate
all reviews
into one 
document

EDITORSAUTHOR

Review

Review
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The Consolidated Markups dialog box appears.

7 Select the Markup layers you want to consolidate.
8 Enter a Name for the consolidated Markup file.
9 Click OK.

The consolidated Markup file is saved.

Saving as Master Markup
Master Markups are instantly displayed when their base document is displayed. 
When viewing a document Master Markups are automatically loaded and 
displayed in Markup mode. Although non-owners can view Master Markups they 
are not able to change them or create Markups based on Master Markups.

After you have finished marking up a document, complete these steps to save a 
newly created Markup file as a Master Markup.

1 In AutoVue, select File > Save or Save As.
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22 VueLink
The Save Markup File As dialog box appears.

2 Enter the Markup Name.
3 For Markup Type, select master from the drop-down list.

4 Click OK.
The Master Markup file is created and stored in the Markups database.
The next time a user logs on and views this file, AutoVue will launch in 
Markup mode and display the Master Markups.

Printing document attributes as 
headers, footers or watermarks
With AutoVue you can print document business object attributes in a header, 
footer or as a watermark.

1 In AutoVue, select File > Print.
The Print Properties dialog box appears.
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2 Customize the Print Properties by taking the steps in sections Printing in 
headers and footers and Printing as a watermark.

Printing in headers and footers
With the headers/footers group you can define what will be included on every 
page of your document.

1 In the Print Properties dialog box, click the Headers/Footers tab.
2 To input information for the headers and footers, enter text under Headers 

and under Footers.
You can also select a code in the Insert Code drop-down list.
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3 Click OK when you are done.

Printing as a watermark
A watermark prints faint and transparent characters “under” the current 
document's content. With the Watermark group, you can define what you want to 
appear on your printed document.

1 In the Print Properties dialog box, click the Watermark tab.
2 Enter text under Watermark Text.
Oracle Corp.
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The text displays as it will appear in the document.

3 Click Font to customize the font.
4 Click OK when you are done.

Converting a document to 
another format
You can use AutoVue to convert documents to other formats such as TIFF and 
then check in the converted document back into Documentum as a rendition of 
the original.

Note:  Only the TIFF format is currently supported for saving as a rendition.

1 Display a document with AutoVue.
2 Select File > Convert.
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The Convert dialog box appears.

3 From the Convert to Format drop-down list, select the TIFF format.
4 Check the Rendition option under Output.
5 Modify any other options if you need to.
6 Click OK.

File conversion begins. AutoVue converts the file to the TIFF format and 
checks it into Documentum as a rendition of the original file.

Comparing files
You can use AutoVue to compare the current version of a document with any of 
its past versions.

1 Display a document with AutoVue.
2 Select File > Compare.
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The File Open dialog box appears.

3 From the Document Versions drop-down list, select the version to which 
you want to compare the file viewed in step 1.
AutoVue displays three windows, the first containing the original document 
viewed in step 1, the second containing the version you compared the 
original against, and the third the comparison result window.

Note:  The comparison result window uses color to communicate the result 
of the file comparison:
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•   Green is for additions.
•   Red is for deletions.
•   Blue is for no change.

Cross Probing
AutoVue lets you specify files saved in the docbase for crossprobing.

1 Display a document with AutoVue.
2 Select File > Cross Probe. 
3 In the Cross Probe dialog box that appears, select Add File.

The File Open dialog box opens

4 Click Browse to select a local file. Browse through the local file system 
and select a file.

5 Click DMS Browse to select a file from the docbase. Browse through the 
DMS and select a file. See Accessing DMS files for more information 
regarding DMS Browse.
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6 Click DMS Search to search the docbase for a file. Select a file from the 
search results. See Accessing DMS files for more information regarding 
DMS Browse.

7 To specify a URL, type the URL in the File Name field.
8 Click OK when you finish selecting a file.

MockUp
With AutoVue, it is possible to import 3D files from Docbase into the current 
AutoVue window.

1 Display a 3D document in AutoVue.
2 Select File > MockUp.
3 The Import Design dialog box appears.

4 To specify a URL:
a.  Click Add in the Import Design dialog box.
b.  In the File Open dialog box that appears, type the URL in the File 

Name field, then click OK.

5 Click Browse in the Import Design dialog box to select a local file. Browse 
through the local file system and select a file.

6 Click DMS Browse in the Import Design dialog box to select a file from 
the Docbase. Browse through the DMS and select a file. See Accessing 
DMS files for more information regarding DMS Browse.
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7 Click DMS Search in the Import Design dialog box to search the docbase 
for a file. Select a file from the search results. See Accessing DMS files for 
more information regarding DMS Browse.

8 Click OK when you finish selecting a file.
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Batch Print
You can use AutoVue to print a set of files simultaneously instead of printing one 
at a time.

1 Display a document in AutoVue.
2 Select File > Batch Print. 

The Batch Print dialog box appears.

3 To specify a URL:
a.  Click Add in the Batch Print dialog box.
b.  In the File Open dialog box that appears, type the URL in the File 

Name field, then click OK.

4 Click Browse in the Batch Print dialog box to add a file from the local file 
system. In the File Open dialog box that appears select the file you want to 
add to the print list.

5 Click DMS Browse in the Batch Print dialog box to browse through the 
repository. In the dialog box that appears, browse through the repository and 
click OK to select a file.
Note:  See Accessing DMS files for more information.

6 Click DMS Search in the Batch Print dialog box to search through the 
DMS. In the Search dialog box that appears, specify a search criteria and 
select the file from the search results to add it to the print list
Note:  See Accessing DMS files for more information.
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7 When you finish selecting files, click Print. The selected files are printed.

File Overlays
AutoVue lets you specify a file saved in the Docbase for an overlay.

1 Select File > Overlay. 
The File Open dialog box appears.

2 Click Browse to select a local file. Browse through the local file system 
and select a file.

3 Click DMS Browse to select a file from the Docbase. 
The DMS Browse dialog box appears. Browse through the DMS and select a 
file.

4 Click DMS Search to search through the docbase. Specify a search criteria 
and select a file from the Search Results.

5 Type the URL in the File Name field to specify a URL.
6 Click OK after you select a file.
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Feedback
Oracle products are designed according to your needs. We would appreciate your 
feedback, comments or suggestions. Contact us by fax, e-mail or telephone. 
There is a feedback button on our Web site that activates an easy-to-use feedback 
form. Please let us know what you think!

General Inquiries

Sales Inquiries

Customer Support

Telephone: +1 514-735-3219

Fax: (514) 735-6440

E-mail: info@cimmetry.com

Web Site: http://www.cimmetry.com

Telephone: +1 514-735-3219 or 1-800-361-1904

Fax: (514) 735-6440

E-mail: sales@cimmetry.com

Telephone: +1 514-735-9941

Web Site: http://www.cimmetry.com/support
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