
 

 

  

 
4.0 

User’s Manual 
By Justin Boyd 



SuperBooks 4.0 User’s Manual Table of Contents 

Table of Contents 
Introduction .................................................................................................. 3 

Getting Started 

Login Form .................................................................................................... 3 

User Interface ................................................................................................ 4 

Setting Username and Password ................................................................... 5 

Invoices 

Invoice Navigator .......................................................................................... 7 

Create a New Invoice ..................................................................................... 7 

Modifying an Invoice ..................................................................................... 8 

Deleting an Invoice ........................................................................................ 8 

Reports 

Single Invoices Viewer ................................................................................ 10 

All Invoices Viewer ....................................................................................... 11 

More SuperBooks 

Edit Font....................................................................................................... 13 

Edit Color ..................................................................................................... 13 

Data Backup .................................................................................................14 

Help ..............................................................................................................14 

Justin
Text Box



SuperBooks 4.0 User’s Manual Table of Contents 

Appendices 

Appendix 1: All Invoices Report  .................................................................  15 

Appendix 2: Single Invoices Report  ...........................................................  16 

Appendix 3: Main Entry Code  ....................................................................  17 

Appendix 4: Splash Screen Code  ...............................................................  29 

Appendix 5: Login Form Code ....................................................................  31 

Appendix 6: About Form Code  ..................................................................  33



SuperBooks User’s Manual 

Page 4 of 34 

Getting Started 

Introduction 
Welcome to SuperBooks v. 4.0 by Justin Boyd. SuperBooks is an invoice program 
for web designers, graphic designers and related professions. With SuperBooks 
you can enter your clients billing information, store it in a database and print out 
invoices! SuperBooks is designed to handle all of your invoiceing needs. 

Login Form 
Upon launching the 
SuperBooks file, the user will 
be presented with a Login 
Form. By default, the 
username and password are 
both Admin (case sensitive) the 
first time the program is run 
and will be so until they are 
changed. It is highly 
recommended that you change 
the username and password 
upon its first run. 

For security purposes, the user 
is allowed three attempts at 
logging in to the SuperBooks 
program. Upon a failed 
attempt the user will see a 
Username/Password Error 
dialog notifying them that the 
username or password they 
have entered was incorrect. 

After user’s third try they will see a Failed Login dialog and then SuperBooks will 

 
Login Form 

 
Username/Password Error 

 
Failed Login 
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close. Contact your system administrator if you are unable to login or have 
forgotten your username or password. 

User Interface 
The mmeennuu  bbaarr, ttaabb  ccoonnttrrooll and ssttaattuuss  bbaarr

 

 are the main parts of the user interface. 

SuperBooks User Interface 
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The menu bar, highlighted in red, in the above image contains your traditional 
menu functions, as well as some additional tools. SuperBooks features an Invoice 
Tab for you to enter in your invoice information and a Viewer Tab that shows you 
a quick, yet complete list of all invoices in the database. The status bar displays 
the current time as well as userful information and hints based on where the 
cursor is located within the form. 

A more detailed explanation of the user interface and its different areas, 
functions and parts will be covered throughout this documentation. 

Setting Username and Password 
Now that you have logged into SuperBooks for the first time it is highly 
recommended that you set your username and password. 

First, click on the Tools menu and select Set Username and enter a username.  

 
Set Username dialog 

Second, click on the Tools menu again and select Set Password. 

 
Set Password dialog 

When setting your password it is important to choose a password that you can 
remember, but that someone could not guess. A strong password is highly 
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recommended. A strong password is at least eight characters long and should 
have at least two uppercase letters, two lowercase letters, two special character 
and two numbers.
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Invoices 
SuperBooks is an invoicing program and does just that – accepts your invoices, 
calculates totals, stores your invoices and generates reports for your clients. 
Below you will learn how to navigate through your invoices, enter a new invoice , 
modify and save and invoice and delete an invoice. 

Invoice Navigator 
After logging in to SuperBooks, the Invoice Tab is displayed and your invoices are 
available, having populated their appropriate text boxes. The invoice navigator, 
located just below the Invoice Tab, allows you to: 

 
Invoice Navigator 

• Scroll through invoices 
• Create a new invoice  
• Save an invoice  
• Delete an invoice  

Create a New Invoice 
In order to create a new record, click the Create Invoice  button. The Invoice 
Tab is broken down into two groups: 

Client Information: enter your client’s company and mailing information. 

Invoice Information: enter the product, rate and hours information. 

By default the rate and hours have a recommended maximum amount. If you 
enter a rate higher than 150 or more than 40 hours, you will see one of the two 
warnings displayed below. Simply choose No to confirm your rate and hours, or 
choose Yes to enter a different number. 
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Rate Range Check Hours Range Check 

Finally, once you have created your new invoice, you must save

 To save your new invoice you have a few 
different options. You can choose to press 
the save button  on the invoice 
navigator, the save button  located 
below the Invoice Tab. Finally, you can 
select File and then Save or press Ctrl + S. 

! Your new invoice 
will not save automatically. 

 

Modifying an Invoice 
Modifying an invoice is very straightforward. Because your current invoices are 
displayed in the same text boxes that you use to enter a new invoice, you can 
simply begin editing any invoice that is displayed on the Invoice Tab.  

However, in order for your modifications to save, you must use on of the saving 
methods discussed above. 

Deleting an Invoice 
The user only has one method, 
for deleting an invoice. Simply 
press the delete button  on 
the Invoice Navigator to delete 
the invoice that is currently 
being viewed. 

 
File  Save 

 
Deleting Invoice Dialog 
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When the user presses the delete button, a warning dialog will appear asking the 
user if they are sure that they want to delete the current file. Keep in mind, that if 
the user chooses Yes, then the invoice will be permanently removed.
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Reports 
Now that you know how to create, save and delete your invoices, the next 
powerful feature available to you in SuperBooks includes Invoice Reports. To 
access reports, the user can click Reports from the Menu Bar or right click on the 
anywhere on the Invoice Tab. 

 
File  Reports 

Single Invoices 
When you select Single Invoices from the Report menu, the Single Invoices Viewer 
will open in a separate window.  

 
Single Invoices Viewer 

Within this new window you will see a Single Invoice for the first invoice from 
your SuperBooks database. Use the left and right arrows  to navigate 
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through the Single Invoice Reports. You can find a Single Invoice report at the end 
of this documentation in Appendix 1. 

To print a Single Invoice Report, click the print icon , at which point a default 
Windows Print dialog will open in a separate window and the user can choose to 
print one, multiple, or all single invoice reports. 

The Single Invoice Report lists the company and the product associated with the 
invoice, including the hours, rate, subtotal, tax and total – everything you will 
need to properly bill your client! 

All Invoices 
When you select All Invoices from the Report menu, the All Invoices Viewer will 
open in a separate window.  

 
All Invoices Viewer 

Within this new window you will see a single All Invoices report. This report is 
designed to show you a report that is similar to the information found on the 
Viewer Tab in the main program. The All Invoices report is designed to give the 
user a quick view of all invoices, including rate, hours and subtotal. 
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Additionally, at the bottom of the All Invoices report, you will find totals for rate, 
hours and subtotal. Finally, you will also find an average of the rate, hours and 
subtotals of all invoices. You can find an All Invoices report at the end of this 
documentation in Appendix 2. 
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More SuperBooks 
The following section is intended to show the user some more features found in 
SuperBooks that are not essential to the basic SuperBooks invoicing programs. 

Edit Font 
SuperBooks includes a function that 
allows the user to change the font, 
font size and font style of the Invoice 
program by selecting Edit and then 
Edit Font. This ease of use function is 
designed to help users choose a font 
of their choice, perhaps one that is 
easier for them to see. 

Edit Color 
In addition changing the font, font 
size and font style, SuperBooks also 
includes a function that allows the 
user to change the font color. Found 
by selecting Edit Color from the Edit 
menu, this feature is designed to 
allow the user the ability to alter the 
user interface to their liking.  

The user can reset the both the 
custom font selection and custom 
color selection back to the 
SuperBooks default by select Reset 
from the Edit menu. 

 
Font dialog 

 
Color Dialog 
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Data Backup 
Data Backup should be handled by the system administrator or delegated to a 
trained and qualified user by a system administrator. There is essentially only one 
file that must be backed up at a regular interval. That file is the superbooks.mdb 
file and is located in the same directory as the superbooks.exe application. 

The interval of backing up the database is at the discretion of the system 
administrator. The interval should be set depending on the amount of data being 
entered into the SuperBooks program and how often. Backups could be daily, 
weekly, monthly or any other interval the system administrator deems 
appropriate. 

FAQ 
SuperBooks includes a Frequently Asked Questions in place of a traditional help 
file and can be found under the Help menu. The FAQ file is designed to answer 
some of the most frequent questions asked by SuperBooks users.  

Additional help can be found with the system administrator, the SuperBooks 
website or the SuperBooks toll-free 800 number. 

 
FAQ and the Help menu 
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Appendix 1: Single Invoices Report 
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Appendix 2: All Invoices Report 
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Appendix 3: Main Entry Code 
'WHO: Justin Boyd 1 
'WHAT: SuperBooks, VB 2008 Invoice Program 2 
'WHEN: SCF, Spring 2010 - COP 2171C with Floyd J. Winters 3 
 4 
'TO DO: 5 
'Documentation Packet 6 
 7 
Option Strict On 8 
 9 
Imports System.Drawing 10 
Imports System.Drawing.Image 11 
Imports System 12 
Imports System.IO 13 
 14 
Public Class sbMainEntry 15 
 16 
#Region "START" 17 
    'GLOBAL VARIABLES 18 
    'calculation and formatting variables 19 
    Dim varRate As Decimal 20 
    Dim varHours As Decimal 21 
    Dim varSubTotal As Decimal 22 
    Dim varTaxRate As Decimal = 0.07D 23 
    Dim varTax As Decimal 24 
    Dim varTotal As Decimal 25 
    'collection and control variables 26 
    Dim colFormControls As New Collection() 27 
    Dim ctrlFormControls As New Control 28 
 29 
    'LOAD 30 
    Private Sub sbMainEntry_Load(ByVal sender As System.Object, ByVal e As 31 
System.EventArgs) Handles MyBase.Load 32 
        'TODO: This line of code loads data into the 33 
'SuperbooksDataSet.invoices' table. You can move, or remove it, as needed. 34 
        Me.InvoicesTableAdapter.Fill(Me.SuperbooksDataSet.invoices) 35 
        statSysDate.Text = CStr(Now()) 36 
        statToolTip.Text = "" 37 
        Me.Size = New System.Drawing.Size(660, 720) 38 
        Call Calculation() 39 
        'Control Collection 40 
        With colFormControls 41 
            'Client Info Labels 42 
            .Add(lblCompany) 43 
            .Add(lblFirstName) 44 
            .Add(lblLastName) 45 
            .Add(lblPhone) 46 
            .Add(lblEmail) 47 
            .Add(lblAddress1) 48 
            .Add(lblAddress2) 49 
            .Add(lblCity) 50 
            .Add(lblState) 51 
            .Add(lblZip) 52 
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            'Invoice Info Labels 53 
            .Add(lblInvoiceID) 54 
            .Add(lblProduct) 55 
            .Add(lblOther) 56 
            .Add(lblRate) 57 
            .Add(lblHours) 58 
            .Add(lblInvoiceDate) 59 
            .Add(lblSubTotal) 60 
            .Add(cbxTax) 61 
            .Add(lblTotal) 62 
            'Client Info TextBoxes / ComboBoxes 63 
            .Add(DbCompanyTextBox) 64 
            .Add(DbFirstNameTextBox) 65 
            .Add(DbLastNameTextBox) 66 
            .Add(DbPhoneNumberTextBox) 67 
            .Add(DbEmailTextBox) 68 
            .Add(DbAddress1TextBox) 69 
            .Add(DbAddress2TextBox) 70 
            .Add(DbCityTextBox) 71 
            .Add(DbStateComboBox) 72 
            .Add(DbZipTextBox) 73 
            'Invoice Info TextBoxes / ComboBoxes 74 
            .Add(DbInvoiceIDTextBox) 75 
            .Add(DbProductComboBox) 76 
            .Add(DbOtherTextBox) 77 
            .Add(DbRateTextBox) 78 
            .Add(DbHoursTextBox) 79 
            .Add(DbInvoiceDateDateTimePicker) 80 
            .Add(txtTax) 81 
            .Add(txtTotal) 82 
        End With 83 
 84 
 85 
    End Sub 86 
 87 
#End Region 88 
 89 
#Region "CLIENT INPUTS" 90 
    'Company Inputs 91 
    Private Sub DbCompanyTextbox_Enter(ByVal sender As Object, ByVal e As 92 
System.EventArgs) Handles DbCompanyTextBox.Enter 93 
        DbCompanyTextBox.BackColor = Color.PaleTurquoise 94 
        DbCompanyTextBox.SelectAll() 95 
        statToolTip.Text = "::  Enter or Edit Company Name" 96 
    End Sub ' Company TextBox Enter 97 
    Private Sub DbCompanyTextBox_Leave(ByVal sender As Object, ByVal e As 98 
System.EventArgs) Handles DbCompanyTextBox.Leave 99 
        DbCompanyTextBox.BackColor = Color.White 100 
        statToolTip.Text = "" 101 
    End Sub ' Company TextBox Leave 102 
 103 
    'First Name Inputs 104 
    Private Sub DbFirstNameTextbox_Enter(ByVal sender As Object, ByVal e As 105 
System.EventArgs) Handles DbFirstNameTextBox.Enter 106 
        DbFirstNameTextBox.BackColor = Color.PaleTurquoise 107 
        DbFirstNameTextBox.SelectAll() 108 
        statToolTip.Text = "::  Enter or Edit First Name" 109 
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    End Sub 'First Name TextBox Enter 110 
    Private Sub DbFirstNameTextbox_Leave(ByVal sender As Object, ByVal e As 111 
System.EventArgs) Handles DbFirstNameTextBox.Leave 112 
        DbFirstNameTextBox.BackColor = Color.White 113 
        statToolTip.Text = "" 114 
    End Sub 'First Name TextBox Exit 115 
 116 
    'Last Name Inputs 117 
    Private Sub DbLastNameTextbox_Enter(ByVal sender As Object, ByVal e As 118 
System.EventArgs) Handles DbLastNameTextBox.Enter 119 
        DbLastNameTextBox.BackColor = Color.PaleTurquoise 120 
        DbLastNameTextBox.SelectAll() 121 
        statToolTip.Text = "::  Enter or Edit Last Name" 122 
    End Sub 'Last Name TextBox Enter 123 
    Private Sub DbLastNameTextbox_Leave(ByVal sender As Object, ByVal e As 124 
System.EventArgs) Handles DbLastNameTextBox.Leave 125 
        DbLastNameTextBox.BackColor = Color.White 126 
        statToolTip.Text = "" 127 
    End Sub 'Last Name TextBox Leave 128 
 129 
    'Phone Inputs 130 
    Private Sub DbPhoneNumberTextbox_Enter(ByVal sender As Object, ByVal e As 131 
System.EventArgs) Handles DbPhoneNumberTextBox.Enter 132 
        DbPhoneNumberTextBox.BackColor = Color.PaleTurquoise 133 
        DbPhoneNumberTextBox.SelectAll() 134 
        statToolTip.Text = "::  Enter or Edit Phone Number" 135 
    End Sub 'Phone TextBox Enter 136 
    Private Sub DbPhoneNumberTextBox_Leave(ByVal sender As Object, ByVal e As 137 
System.EventArgs) Handles DbPhoneNumberTextBox.Leave 138 
        DbPhoneNumberTextBox.BackColor = Color.White 139 
        statToolTip.Text = "" 140 
    End Sub 'Phone TextBox Leave 141 
 142 
    'Email Inputs 143 
    Private Sub DbEmailTextbox_Enter(ByVal sender As Object, ByVal e As 144 
System.EventArgs) Handles DbEmailTextBox.Enter 145 
        DbEmailTextBox.BackColor = Color.PaleTurquoise 146 
        DbEmailTextBox.SelectAll() 147 
        statToolTip.Text = "::  Enter or Edit Email Address" 148 
    End Sub 'Email TextBox Enter 149 
    Private Sub DbEmailTextBox_Leave(ByVal sender As Object, ByVal e As 150 
System.EventArgs) Handles DbEmailTextBox.Leave 151 
        DbEmailTextBox.BackColor = Color.White 152 
        statToolTip.Text = "" 153 
    End Sub 'Email TextBox Leave 154 
 155 
    'Address1 Inputs 156 
    Private Sub DbAddress1Textbox_Enter(ByVal sender As Object, ByVal e As 157 
System.EventArgs) Handles DbAddress1TextBox.Enter 158 
        DbAddress1TextBox.BackColor = Color.PaleTurquoise 159 
        DbAddress1TextBox.SelectAll() 160 
        statToolTip.Text = "::  Enter or Edit Address Information" 161 
    End Sub 'Address1 TextBox Enter 162 
    Private Sub DbAddress1Textbox_Leave(ByVal sender As Object, ByVal e As 163 
System.EventArgs) Handles DbAddress1TextBox.Leave 164 
        DbAddress1TextBox.BackColor = Color.White 165 
        statToolTip.Text = "" 166 
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    End Sub 'Address1 TextBox Leave 167 
 168 
    'Address2 Inputs 169 
    Private Sub DbAddress2Textbox_Enter(ByVal sender As Object, ByVal e As 170 
System.EventArgs) Handles DbAddress2TextBox.Enter 171 
        DbAddress2TextBox.BackColor = Color.PaleTurquoise 172 
        DbAddress2TextBox.SelectAll() 173 
        statToolTip.Text = "::  Enter or Edit Supplemental Address 174 
Information" 175 
    End Sub 'Address2 TextBox Enter 176 
    Private Sub DbAddress2Textbox_Leave(ByVal sender As Object, ByVal e As 177 
System.EventArgs) Handles DbAddress2TextBox.Leave 178 
        DbAddress2TextBox.BackColor = Color.White 179 
        statToolTip.Text = "" 180 
    End Sub 'Address2 TextBox Leave 181 
 182 
    'City Inputs 183 
    Private Sub DbCityTextbox_Enter(ByVal sender As Object, ByVal e As 184 
System.EventArgs) Handles DbCityTextBox.Enter 185 
        DbCityTextBox.BackColor = Color.PaleTurquoise 186 
        DbCityTextBox.SelectAll() 187 
        statToolTip.Text = "::  Enter or Edit City" 188 
    End Sub 'City TextBox Enter 189 
    Private Sub DbCityTextbox_Leave(ByVal sender As Object, ByVal e As 190 
System.EventArgs) Handles DbCityTextBox.Leave 191 
        DbCityTextBox.BackColor = Color.White 192 
        statToolTip.Text = "" 193 
    End Sub 'City TextBox Leave 194 
 195 
    'State Inputs 196 
    Private Sub DbStateComboBox_Enter(ByVal sender As Object, ByVal e As 197 
System.EventArgs) Handles DbStateComboBox.Enter 198 
        DbStateComboBox.BackColor = Color.PaleTurquoise 199 
        DbStateComboBox.SelectAll() 200 
        statToolTip.Text = "::  Enter or Edit State" 201 
    End Sub 'State ComboBox Enter 202 
    Private Sub DbStateComboBox_Leave(ByVal sender As Object, ByVal e As 203 
System.EventArgs) Handles DbStateComboBox.Leave 204 
        DbStateComboBox.BackColor = Color.White 205 
        statToolTip.Text = "" 206 
    End Sub 'State ComboBox Leave 207 
 208 
    'Zip Inputs 209 
    Private Sub DbZipTextbox_Enter(ByVal sender As Object, ByVal e As 210 
System.EventArgs) Handles DbZipTextBox.Enter 211 
        DbZipTextBox.BackColor = Color.PaleTurquoise 212 
        DbZipTextBox.SelectAll() 213 
        statToolTip.Text = "::  Enter or Edit Zip" 214 
    End Sub 'Zip TextBox Enter 215 
    Private Sub DbZipTextbox_Leave(ByVal sender As Object, ByVal e As 216 
System.EventArgs) Handles DbZipTextBox.Leave 217 
        DbZipTextBox.BackColor = Color.White 218 
        statToolTip.Text = "" 219 
    End Sub 'Zip TextBox Leave 220 
 221 
#End Region 222 
 223 
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#Region "INVOICE INPUTS" 224 
 225 
    'Product Inputs 226 
    Private Sub DbProductComboBox_Enter(ByVal sender As Object, ByVal e As 227 
System.EventArgs) Handles DbProductComboBox.Enter 228 
        DbProductComboBox.BackColor = Color.PaleTurquoise 229 
        DbProductComboBox.SelectAll() 230 
        statToolTip.Text = "::  Enter or Edit Product" 231 
        Call Calculation() 232 
    End Sub 'Product ComboBox Enter 233 
    Private Sub DbProductComboBox_Leave(ByVal sender As Object, ByVal e As 234 
System.EventArgs) Handles DbProductComboBox.Leave 235 
        DbProductComboBox.BackColor = Color.White 236 
        statToolTip.Text = "" 237 
        Call Calculation() 238 
    End Sub 'Product ComboBox Leave 239 
    Private Sub DbProductComboBox_SelectedIndexChanged(ByVal sender As 240 
System.Object, ByVal e As System.EventArgs) Handles 241 
DbProductComboBox.SelectedIndexChanged 242 
        If DbProductComboBox.Text = "Site Design" Then 243 
            varRate = CDec(25.0) 244 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 245 
        ElseIf DbProductComboBox.Text = "Page Design" Then 246 
            varRate = CDec(20.0) 247 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 248 
        ElseIf DbProductComboBox.Text = "Logo Design" Then 249 
            varRate = CDec(100.0) 250 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 251 
        ElseIf DbProductComboBox.Text = "Flash Design" Then 252 
            varRate = CDec(150.0) 253 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 254 
        ElseIf DbProductComboBox.Text = "SEO" Then 255 
            varRate = CDec(25.0) 256 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 257 
        ElseIf DbProductComboBox.Text = "Maintenance" Then 258 
            varRate = CDec(25.0) 259 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 260 
        ElseIf DbProductComboBox.Text = "Other" Then 261 
            varRate = CDec(0.0) 262 
            DbRateTextBox.Text = FormatNumber(varRate, 2) 263 
            DbOtherTextBox.Enabled = True 264 
            DbRateTextBox.Enabled = True 265 
        End If 266 
        Call Calculation() 267 
    End Sub 'Product Combobox Set Rate 268 
 269 
    'Rate Inputs 270 
    Private Sub DbOtherTextBox_Enter(ByVal sender As Object, ByVal e As 271 
System.EventArgs) Handles DbOtherTextBox.Enter 272 
        DbOtherTextBox.BackColor = Color.PaleTurquoise 273 
        DbOtherTextBox.SelectAll() 274 
        statToolTip.Text = "::  Enter or Edit your own Product" 275 
        Call Calculation() 276 
    End Sub 'Rate TextBox Enter 277 
    Private Sub DbOtherTextBox_Leave(ByVal sender As Object, ByVal e As 278 
System.EventArgs) Handles DbOtherTextBox.Leave 279 
        DbOtherTextBox.BackColor = Color.White 280 
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        statToolTip.Text = "" 281 
        Call Calculation() 282 
    End Sub 'Rate TextBox Leave 283 
 284 
    'Rate Inputs 285 
    Private Sub DbRateTextBox_Enter(ByVal sender As Object, ByVal e As 286 
System.EventArgs) Handles DbRateTextBox.Enter 287 
        DbRateTextBox.BackColor = Color.PaleTurquoise 288 
        DbRateTextBox.SelectAll() 289 
        statToolTip.Text = "::  Enter or Edit Rate" 290 
        Call Calculation() 291 
    End Sub 'Rate TextBox Enter 292 
    Private Sub DbRateTextBox_Leave(ByVal sender As Object, ByVal e As 293 
System.EventArgs) Handles DbRateTextBox.Leave 294 
        varRate = CDec(Val(DbRateTextBox.Text)) 295 
        Dim CheckRate As Windows.Forms.DialogResult 296 
        If IsNumeric(DbRateTextBox.Text) Then 297 
            DbRateTextBox.Text = Format(Val(DbRateTextBox.Text), 298 
"##,###0.00") 299 
        Else 300 
            MessageBox.Show("Please enter only numbers in the Rate TextBox.", 301 
"Rate TextBox Entry Error") 302 
            DbRateTextBox.Focus() 303 
            DbRateTextBox.SelectAll() 304 
            Exit Sub 'Keeps Out of Range Check from executing on a non-305 
numeric entry 306 
        End If 307 
        If CDec(DbRateTextBox.Text) > 150 Then 308 
            CheckRate = MessageBox.Show("Is that Rate too high?", "Rate Out 309 
of Bounds Check", MessageBoxButtons.YesNo, MessageBoxIcon.Question, 310 
MessageBoxDefaultButton.Button2) 311 
            If CheckRate = Windows.Forms.DialogResult.Yes Then 312 
                DbRateTextBox.Focus() 313 
                DbRateTextBox.SelectAll() 314 
            End If 315 
        End If 316 
        DbRateTextBox.BackColor = Color.White 317 
        statToolTip.Text = "" 318 
        Call Calculation() 319 
    End Sub 'Rate TextBox Leave 320 
 321 
    'Hours Inputs 322 
    Private Sub DbHoursTextBox_Enter(ByVal sender As Object, ByVal e As 323 
System.EventArgs) Handles DbHoursTextBox.Enter 324 
        DbHoursTextBox.BackColor = Color.PaleTurquoise 325 
        DbHoursTextBox.SelectAll() 326 
        statToolTip.Text = "::  Enter or Edit Hours" 327 
        Call Calculation() 328 
    End Sub 'Hours TextBox Enter 329 
    Private Sub DbHoursTextBox_Leave(ByVal sender As Object, ByVal e As 330 
System.EventArgs) Handles DbHoursTextBox.Leave 331 
        varHours = CDec(Val(DbHoursTextBox.Text)) 332 
        Dim checkHours As Windows.Forms.DialogResult 333 
        If IsNumeric(DbHoursTextBox.Text) Then 334 
            DbHoursTextBox.Text = Format(Val(DbHoursTextBox.Text), 335 
"##,###0.00") 336 
        Else 337 
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            MessageBox.Show("Please enter only numbers in the Hours 338 
TextBox.", "Hours TextBox Entry Error") 339 
            DbHoursTextBox.Focus() 340 
            DbHoursTextBox.SelectAll() 341 
            Exit Sub 'Keeps Out of Range Check from executing on a non-342 
numeric entry 343 
        End If 344 
        If CDec(DbHoursTextBox.Text) > 40 Then 345 
            checkHours = MessageBox.Show("Are those Hours too high?", "Hours 346 
Out of Bounds Check", MessageBoxButtons.YesNo, MessageBoxIcon.Question, 347 
MessageBoxDefaultButton.Button2) 348 
            If checkHours = Windows.Forms.DialogResult.Yes Then 349 
                DbHoursTextBox.Focus() 350 
            End If 351 
        End If 352 
        DbHoursTextBox.BackColor = Color.White 353 
        statToolTip.Text = "" 354 
        Call Calculation() 355 
    End Sub 'Hours TextBox Leave 356 
 357 
    'Invoice Date Inputs 358 
    Private Sub DbInvoiceDateDateTimePicker_Enter(ByVal sender As Object, 359 
ByVal e As System.EventArgs) Handles DbInvoiceDateDateTimePicker.Enter 360 
        DbInvoiceDateDateTimePicker.CalendarMonthBackground = 361 
Color.PaleTurquoise 362 
        statToolTip.Text = "::  Enter or Edit Invoice Date" 363 
        Call Calculation() 364 
    End Sub 'Invoice Date DTP Enter 365 
    Private Sub DbInvoiceDateDateTimePicker_Leave(ByVal sender As Object, 366 
ByVal e As System.EventArgs) Handles DbInvoiceDateDateTimePicker.Leave 367 
        DbInvoiceDateDateTimePicker.CalendarMonthBackground = Color.White 368 
        statToolTip.Text = "" 369 
        Call Calculation() 370 
    End Sub 'Invoice Date DTP Leave 371 
 372 
    'Tax CheckBox     373 
    Private Sub cbxTax_CheckedChanged(ByVal sender As System.Object, ByVal e 374 
As System.EventArgs) Handles cbxTax.CheckedChanged 375 
        If cbxTax.Checked = True Then 376 
            varTaxRate = CDec(0.0) 377 
        Else 378 
            varTaxRate = 0.07D 379 
        End If 380 
        Call Calculation() 381 
    End Sub 'Tax CheckBox 382 
 383 
 384 
#End Region 385 
 386 
#Region "FUNCTIONS" 387 
 388 
    Private Sub Calculation() 389 
        Try 390 
            varSubTotal = CDec(Val(DbRateTextBox.Text) * 391 
Val(DbHoursTextBox.Text)) 392 
            varTax = varSubTotal * varTaxRate 393 
            varTotal = varSubTotal + varTax 394 
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            SubTotalTextBox.Text = "$" & " " & CStr(FormatNumber(varSubTotal, 395 
2)) 396 
            txtTax.Text = "$" & " " & CStr(FormatNumber(varTax, 2)) 397 
            txtTotal.Text = "$" & " " & CStr(FormatNumber(varTotal, 2)) 398 
        Catch ex As Exception 399 
            MessageBox.Show("There was a calculation error", "Calculation 400 
Error") 401 
            DbFirstNameTextBox.Focus() 402 
        End Try 403 
    End Sub 404 
 405 
#End Region 406 
 407 
#Region "MENUS & BUTTONS" 408 
 409 
    'Menu Strip 410 
 411 
    Private Sub mnuFileNew_Click(ByVal sender As System.Object, ByVal e As 412 
System.EventArgs) Handles mnuFileNew.Click 413 
        BindingNavigatorAddNewItem.PerformClick() 414 
    End Sub 'File -> New 415 
    Private Sub mnuFileSave_Click(ByVal sender As System.Object, ByVal e As 416 
System.EventArgs) Handles mnuFileSave.Click 417 
        InvoicesBindingNavigatorSaveItem.PerformClick() 418 
    End Sub 'File -> Save 419 
    Private Sub mnuFileExit_Click(ByVal sender As System.Object, ByVal e As 420 
System.EventArgs) Handles mnuFileExit.Click 421 
        Dim CheckExit As Windows.Forms.DialogResult 422 
        CheckExit = MessageBox.Show("Are you sure you want to exit? Any 423 
unsaved changes will be lost.", "Exit SuperBooks", 424 
MessageBoxButtons.OKCancel, MessageBoxIcon.Exclamation) 425 
        If CheckExit = Windows.Forms.DialogResult.OK Then 426 
            Me.Close() 427 
        End If 428 
    End Sub 'File -> Exit 429 
 430 
    Private Sub mnuReportsSingle_Click(ByVal sender As System.Object, ByVal e 431 
As System.EventArgs) Handles mnuReportsSingle.Click 432 
        sbReportSingle.ShowDialog() 433 
    End Sub 'Reports -> Single 434 
    Private Sub mnuReportsAll_Click(ByVal sender As System.Object, ByVal e As 435 
System.EventArgs) Handles mnuReportsAll.Click 436 
        sbReportAll.ShowDialog() 437 
    End Sub 'Reports -> All 438 
 439 
    Private Sub mnuEditColor_Click(ByVal sender As System.Object, ByVal e As 440 
System.EventArgs) Handles mnuEditColor.Click 441 
        dlogColor.ShowDialog() 442 
        For Each Me.ctrlFormControls In colFormControls 443 
            ctrlFormControls.ForeColor = dlogColor.Color 444 
        Next 445 
    End Sub 'Edit -> Color 446 
    Private Sub mnuEditFont_Click(ByVal sender As System.Object, ByVal e As 447 
System.EventArgs) Handles mnuEditFont.Click 448 
        dlogFont.ShowDialog() 449 
        For Each Me.ctrlFormControls In colFormControls 450 
            If dlogFont.Font.SizeInPoints <= 14 Then 451 
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                ctrlFormControls.Font = dlogFont.Font 452 
            Else 453 
                MessageBox.Show("Font Size must be size 14 or less.", "Font 454 
Size Too Big!") 455 
                dlogFont.ShowDialog() 456 
            End If 457 
        Next 458 
 459 
    End Sub 'Edit -> Font 460 
    Private Sub mnuEditReset_Click(ByVal sender As System.Object, ByVal e As 461 
System.EventArgs) Handles mnuEditReset.Click 462 
        For Each Me.ctrlFormControls In colFormControls 463 
            ctrlFormControls.ForeColor = 464 
System.Drawing.Color.FromArgb(CType(CType(64, Byte), Integer), 465 
CType(CType(64, Byte), Integer), CType(CType(64, Byte), Integer)) 466 
            ctrlFormControls.Font = New System.Drawing.Font("Segoe UI", 467 
11.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, 468 
CType(0, Byte)) 469 
        Next 470 
    End Sub 'Edit -> Reset 471 
 472 
    Private Sub mnuToolsSetUser_Click(ByVal sender As System.Object, ByVal e 473 
As System.EventArgs) Handles mnuToolsSetUser.Click 474 
        Dim UserFile As System.IO.StreamWriter 475 
        Dim UserSet As String 476 
        UserFile = System.IO.File.CreateText("system.nfo") 477 
        UserSet = InputBox("Please enter your SuperBooks Username. The 478 
username will be used to log into the program.", "Set User Name") 479 
        UserFile.WriteLine(UserSet) 480 
        UserFile.Close() 481 
    End Sub 'Tools -> Set User 482 
    Private Sub mnuToolsSetPassword_Click(ByVal sender As System.Object, 483 
ByVal e As System.EventArgs) Handles mnuToolsSetPassword.Click 484 
        Dim PassFile As System.IO.StreamWriter 485 
        Dim PassSet As String 486 
        PassFile = System.IO.File.CreateText("accesss.nfo") 487 
        PassSet = InputBox("Please enter your SuperBooks Password. This 488 
password will be used to log into the program.", "Set Password") 489 
        PassFile.WriteLine(PassSet) 490 
        PassFile.Close() 491 
    End Sub 'Tools -> Set Password 492 
    Private Sub mnuToolsCalculator_Click(ByVal sender As System.Object, ByVal 493 
e As System.EventArgs) Handles mnuToolsCalculator.Click 494 
        Try 495 
            Process.Start("Calc") 496 
        Catch ex As Exception 497 
            MessageBox.Show("Calculator program was not found on this 498 
computer", "Calculator Launch Error", MessageBoxButtons.OK, 499 
MessageBoxIcon.Error) 500 
        End Try 501 
    End Sub 'Tools -> Calculator 502 
    Private Sub mnuToolsNotepad_Click(ByVal sender As System.Object, ByVal e 503 
As System.EventArgs) Handles mnuToolsNotepad.Click 504 
        Try 505 
            Process.Start("Notepad") 506 
        Catch ex As Exception 507 
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            MessageBox.Show("Notepad program was not found on this computer", 508 
"Notepad Launch Error", MessageBoxButtons.OK, MessageBoxIcon.Error) 509 
        End Try 510 
    End Sub 'Tools -> Notepad 511 
 512 
    Private Sub mnuHelpContents_Click(ByVal sender As System.Object, ByVal e 513 
As System.EventArgs) Handles mnuHelpContents.Click 514 
        Process.Start("NotePad", "../../Resources/FAQ.txt") 515 
    End Sub 'Help -> Contents 516 
    Private Sub mnuHelpAbout_Click(ByVal sender As System.Object, ByVal e As 517 
System.EventArgs) Handles mnuHelpAbout.Click 518 
        sbAboutBox.ShowDialog() 519 
    End Sub 'Help -> About 520 
 521 
    'Data Binding 522 
    Private Sub InvoicesBindingNavigatorSaveItem_Click(ByVal sender As 523 
System.Object, ByVal e As System.EventArgs) Handles 524 
InvoicesBindingNavigatorSaveItem.Click 525 
        Try 526 
            Me.Validate() 527 
            Me.InvoicesBindingSource.EndEdit() 528 
            Me.TableAdapterManager.UpdateAll(Me.SuperbooksDataSet) 529 
            Dim SaveData As Windows.Forms.DialogResult 530 
            SaveData = MessageBox.Show("Your changes/additions have been 531 
saved.", "Save Dialog", MessageBoxButtons.OK, MessageBoxIcon.Information) 532 
            If SaveData = Windows.Forms.DialogResult.OK Then 533 
                Call Calculation() 534 
                DbCompanyTextBox.Focus() 535 
            End If 536 
        Catch ex As Exception 537 
            MessageBox.Show("SuperBooks was unable to save or modify your 538 
record. Please restart the program.", "Saving Error") 539 
            Exit Sub 540 
        End Try 541 
 542 
    End Sub 'Binding Save Button 543 
    Private Sub BindingNavigatorDeleteItem_Click(ByVal sender As 544 
System.Object, ByVal e As System.EventArgs) Handles 545 
BindingNavigatorDeleteItem.Click 546 
        Dim DeleteItem As Windows.Forms.DialogResult 547 
        DeleteItem = MessageBox.Show("Are you sure you want to delete this 548 
invoice?", "Deleting Invoice", MessageBoxButtons.YesNo, 549 
MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button2) 550 
        If DeleteItem = Windows.Forms.DialogResult.Yes Then 551 
            InvoicesBindingSource.RemoveCurrent() 552 
            InvoicesBindingSource.EndEdit() 553 
            InvoicesBindingNavigatorSaveItem.PerformClick() 554 
        Else 555 
            Exit Sub 556 
        End If 557 
    End Sub 'Binding Delete Button 558 
    Private Sub BindingNavigatorMoveFirstItem_Click(ByVal sender As 559 
System.Object, ByVal e As System.EventArgs) Handles 560 
BindingNavigatorMoveFirstItem.Click 561 
        Call Calculation() 562 
    End Sub ' Binding First Button 563 
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    Private Sub BindingNavigatorMovePreviousItem_Click(ByVal sender As 564 
System.Object, ByVal e As System.EventArgs) Handles 565 
BindingNavigatorMovePreviousItem.Click 566 
        Call Calculation() 567 
    End Sub 'Binding Previous Button  568 
    Private Sub BindingNavigatorMoveNextItem_Click(ByVal sender As 569 
System.Object, ByVal e As System.EventArgs) Handles 570 
BindingNavigatorMoveNextItem.Click 571 
        Call Calculation() 572 
    End Sub 'Binding Next Button 573 
    Private Sub BindingNavigatorMoveLastItem_Click(ByVal sender As 574 
System.Object, ByVal e As System.EventArgs) Handles 575 
BindingNavigatorMoveLastItem.Click 576 
        Call Calculation() 577 
    End Sub 'Binding Last Button 578 
 579 
    'Right Click (Context) Menu 580 
    Private Sub rtcReportAll_Click(ByVal sender As System.Object, ByVal e As 581 
System.EventArgs) Handles rtcReportAll.Click 582 
        mnuReportsAll.PerformClick() 583 
    End Sub 'Right Click -> Report -> All 584 
    Private Sub rtcReportSingle_Click(ByVal sender As System.Object, ByVal e 585 
As System.EventArgs) Handles rtcReportSingle.Click 586 
        mnuReportsSingle.PerformClick() 587 
    End Sub 'Right Click -> Report -> Single 588 
    Private Sub rtcEditFont_Click(ByVal sender As System.Object, ByVal e As 589 
System.EventArgs) Handles rtcEditFont.Click 590 
        mnuEditFont.PerformClick() 591 
    End Sub 'Right Click -> Edit Font 592 
    Private Sub rtcEditColor_Click(ByVal sender As System.Object, ByVal e As 593 
System.EventArgs) Handles rtcEditColor.Click 594 
        mnuEditColor.PerformClick() 595 
    End Sub 'Right Click -> Edit Color 596 
    Private Sub rtcHelp_Click(ByVal sender As System.Object, ByVal e As 597 
System.EventArgs) Handles rtcHelp.Click 598 
        mnuHelpContents.PerformClick() 599 
    End Sub 'Right Click -> Help 600 
 601 
    'Misc Buttons 602 
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As 603 
System.EventArgs) Handles btnSave.Click 604 
        InvoicesBindingNavigatorSaveItem.PerformClick() 605 
    End Sub 'Save Button 606 
    Private Sub btnClear_Click(ByVal sender As System.Object, ByVal e As 607 
System.EventArgs) Handles btnClear.Click 608 
        Dim ClearInvoice As Windows.Forms.DialogResult 609 
        ClearInvoice = MessageBox.Show("Clearing the form DOES NOT update 610 
your database. You still must save for changes to take effect.", "Clearing 611 
Invoice", MessageBoxButtons.OKCancel, MessageBoxIcon.Information, 612 
MessageBoxDefaultButton.Button1) 613 
        If ClearInvoice = Windows.Forms.DialogResult.OK Then 614 
            DbCompanyTextBox.Clear() 615 
            DbFirstNameTextBox.Clear() 616 
            DbLastNameTextBox.Clear() 617 
            DbPhoneNumberTextBox.Clear() 618 
            DbEmailTextBox.Clear() 619 
            DbAddress1TextBox.Clear() 620 
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            DbAddress2TextBox.Clear() 621 
            DbCityTextBox.Clear() 622 
            DbStateComboBox.Text = "FL" 623 
            DbZipTextBox.Clear() 624 
            DbInvoiceIDTextBox.Clear() 625 
            DbInvoiceDateDateTimePicker.Text = CStr(Now()) 626 
            DbRateTextBox.Clear() 627 
            DbProductComboBox.SelectedItem = "Site Design" 628 
            DbHoursTextBox.Clear() 629 
            Call Calculation() 630 
        End If 631 
    End Sub 'Clear Button 632 
    Private Sub btnExit_Click(ByVal sender As System.Object, ByVal e As 633 
System.EventArgs) Handles btnExit.Click 634 
        mnuFileExit.PerformClick() 635 
    End Sub 'Exit Button 636 
 637 
#End Region 638 
 639 
End Class640 
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Appendix 4: Splash Screen Code 
Public NotInheritable Class sbSplashScreen 1 
 2 
    'TODO: This form can easily be set as the splash screen for the 3 
application by going to the "Application" tab 4 
    '  of the Project Designer ("Properties" under the "Project" menu). 5 
 6 
 7 
    Private Sub frmSplashScreen_Load(ByVal sender As Object, ByVal e As 8 
System.EventArgs) Handles Me.Load 9 
        'Set up the dialog text at runtime according to the application's 10 
assembly information.   11 
 12 
        'TODO: Customize the application's assembly information in the 13 
"Application" pane of the project  14 
        '  properties dialog (under the "Project" menu). 15 
 16 
        'Application title 17 
        If My.Application.Info.Title <> "" Then 18 
            ApplicationTitle.Text = My.Application.Info.Title 19 
        Else 20 
            'If the application title is missing, use the application name, 21 
without the extension 22 
            ApplicationTitle.Text = 23 
System.IO.Path.GetFileNameWithoutExtension(My.Application.Info.AssemblyName) 24 
        End If 25 
 26 
        'Format the version information using the text set into the Version 27 
control at design time as the 28 
        '  formatting string.  This allows for effective localization if 29 
desired. 30 
        '  Build and revision information could be included by using the 31 
following code and changing the  32 
        '  Version control's designtime text to "Version {0}.{1:00}.{2}.{3}" 33 
or something similar.  See 34 
        '  String.Format() in Help for more information. 35 
        ' 36 
        '    Version.Text = System.String.Format(Version.Text, 37 
My.Application.Info.Version.Major, My.Application.Info.Version.Minor, 38 
My.Application.Info.Version.Build, My.Application.Info.Version.Revision) 39 
 40 
        Version.Text = System.String.Format(Version.Text, 41 
My.Application.Info.Version.Major, My.Application.Info.Version.Minor) 42 
 43 
        'Copyright info 44 
        Copyright.Text = My.Application.Info.Copyright 45 
    End Sub 46 
 47 
End Class  48 
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Application Events 
The following code is located in the ApplicationEvents.vb file, created when a Splash Screen is created 
and responsible for the Splash Screen’s display time. 

Namespace My 1 
 2 
    ' The following events are available for MyApplication: 3 
    '  4 
    ' Startup: Raised when the application starts, before the startup form is 5 
created. 6 
    ' Shutdown: Raised after all application forms are closed.  This event is 7 
not raised if the application terminates abnormally. 8 
    ' UnhandledException: Raised if the application encounters an unhandled 9 
exception. 10 
    ' StartupNextInstance: Raised when launching a single-instance 11 
application and the application is already active.  12 
    ' NetworkAvailabilityChanged: Raised when the network connection is 13 
connected or disconnected. 14 
    Partial Friend Class MyApplication 15 
 16 
        Protected Overrides Function OnInitialize( _ 17 
        ByVal commandLineArgs As  _ 18 
        System.Collections.ObjectModel.ReadOnlyCollection(Of String) _ 19 
        ) As Boolean 20 
            ' Set the display time to 5000 milliseconds (5 seconds). 21 
            Me.MinimumSplashScreenDisplayTime = 4000 22 
            Return MyBase.OnInitialize(commandLineArgs) 23 
        End Function 24 
 25 
    End Class 26 
 27 
End Namespace28 
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Appendix 5: Login Form Code 
Imports System 1 
Imports System.IO 2 
 3 
Public Class sbLoginForm 4 
 5 
    ' TODO: Insert code to perform custom authentication using the provided 6 
username and password  7 
    ' (See http://go.microsoft.com/fwlink/?LinkId=35339).   8 
    ' The custom principal can then be attached to the current thread's 9 
principal as follows:  10 
    '     My.User.CurrentPrincipal = CustomPrincipal 11 
    ' where CustomPrincipal is the IPrincipal implementation used to perform 12 
authentication.  13 
    ' Subsequently, My.User will return identity information encapsulated in 14 
the CustomPrincipal object 15 
    ' such as the username, display name, etc. 16 
 17 
    'Dim varUserName As String = "j" 18 
    'Dim varLastName As String = "1" 19 
    Dim userTry As Integer = 1 20 
 21 
    Private Sub OK_Click(ByVal sender As System.Object, ByVal e As 22 
System.EventArgs) Handles OK.Click 23 
        Dim UserGet As String 24 
        Dim PassGet As String 25 
        Using ur As StreamReader = New StreamReader('Location of Username) 26 
        Using pr As StreamReader = New StreamReader('Location of Password) 27 
                Dim ULine As String 28 
                Dim PLine As String 29 
                ULine = ur.ReadLine() 30 
                PLine = pr.ReadLine() 31 
                UserGet = ULine 32 
                PassGet = PLine 33 
                If txtUserName.Text.Trim = UserGet And txtPassword.Text.Trim 34 
= PassGet Then 35 
                    sbMainEntry.Show() 36 
                    Me.Close() 37 
                Else 38 
                    userTry += 1 39 
                    If userTry > 3 Then 40 
                        MessageBox.Show("Too many failed attempts. Closing 41 
program. Contact your System Administrator.", "Failed Logon", 42 
MessageBoxButtons.OK, MessageBoxIcon.Error) 43 
                        Me.Close() 44 
                    Else 45 
                        MessageBox.Show("Incorrect User Name / Password 46 
Combination", "Username / Password Error", MessageBoxButtons.OK, 47 
MessageBoxIcon.Warning, MessageBoxDefaultButton.Button1) 48 
                        txtUserName.Focus() 49 
                    End If 50 
                End If 51 
                pr.Close() 52 
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                ur.Close() 53 
            End Using 54 
        End Using 55 
    End Sub 56 
 57 
    Private Sub Cancel_Click(ByVal sender As System.Object, ByVal e As 58 
System.EventArgs) Handles Cancel.Click 59 
        Me.Close() 60 
    End Sub 61 
 62 
    ' CLICK LOGO FOR TEMPORARY PASSWORD BYPASS :: Delete Before Finalized 63 
    Private Sub lblBD_Click(ByVal sender As System.Object, ByVal e As 64 
System.EventArgs) Handles lblBD.Click 65 
        sbMainEntry.Show() 66 
        Me.Close() 67 
    End Sub 68 
 69 
End Class 70 
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Appendix 6: About Form Code 
Public NotInheritable Class sbAboutBox 
 
    Private Sub AboutBox1_Load(ByVal sender As System.Object, ByVal e As 
System.EventArgs) Handles MyBase.Load 
        ' Set the title of the form. 
        Dim ApplicationTitle As String 
        If My.Application.Info.Title <> "" Then 
            ApplicationTitle = My.Application.Info.Title 
        Else 
            ApplicationTitle = 
System.IO.Path.GetFileNameWithoutExtension(My.Application.Info.AssemblyName) 
        End If 
        Me.Text = String.Format("About {0}", ApplicationTitle) 
        ' Initialize all of the text displayed on the About Box. 
        ' TODO: Customize the application's assembly information in the 
"Application" pane of the project  
        '    properties dialog (under the "Project" menu). 
        Me.LabelProductName.Text = My.Application.Info.ProductName 
        Me.LabelVersion.Text = String.Format("Version {0}", 
My.Application.Info.Version.ToString) 
        Me.LabelCopyright.Text = My.Application.Info.Copyright 
        Me.LabelCompanyName.Text = My.Application.Info.CompanyName 
        Me.TextBoxDescription.Text = My.Application.Info.Description 
    End Sub 
 
    Private Sub OKButton_Click(ByVal sender As System.Object, ByVal e As 
System.EventArgs) Handles OKButton.Click 
        Me.Close() 
    End Sub 
 
End Class 
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