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1ZICConverter

1. Introduction

1.1. What is 1ZICConverter

IZICConverter is an application which provides users to convert ZIC files with the corresponding ICV files into 1ZIC
files. This manual introduces how to use 1ZICConverter.

1.2. System Requirements

Operation System (OS) Windows 7 64-bit or Windows 8 64-bit
Processer (CPU) 3.4 GHz or better

Memory (RAM) 8GB or better

Graphic Card (GPU) NVIDIA GeForce GT 620 or better

1.3. About This Manual

In this manual, chapter 2 introduces each part of main window of 1ZICConverter. Chapter 3 introduces how to convert
I1ZIC files. Chapter 4 introduces how to generate streaming video files by commands.

Words in single quotes with Italics type (like ‘File”) mean the name of window, box or menu.
Words in square brackets [] mean the name of button.
Each number behind chapter, section, and page can connect to corresponding place by using ‘czri’ + left click.

Each “Figure” and “Table” in this manual can link to corresponding figure and table by using ‘czrl’ + left click.
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2. Main Window
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Speed: 0.000 frames/s , Total progress: 0/0

Figure 2-1 (Main Window)

1ZICConverter consists of four parts as follows:

2.1. Menus and Buttons

Table 2-1 (Menus and Buttons in Main Window)

File (F) Open ‘File’ menu

Help (H) Open ‘Help’ menu

Start converting work
Abort current converting
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2.1.1. File Menu

Open the ‘File” menu to open log file or close ‘1ZICConverter’ window (Figure 2-2).

File(F) | Help(H)
Open log file(L)

Close(X)

Figure 2-2 (File Menu)

2.1.2. Help Menu

Open ‘Help’ menu to see version and import license file.

Help(H) |
Version(A)...
Import License.dat(I)

Figure 2-3 (Help Menu)

Click ‘Version’in ‘Help’ menu to open ‘About IZICConverter” window to see “Assembly Version” and “Publish
Version”, this window can be closed by clicking on [OK] button (Figure 2-4).

About IZICConverter [ty

FICCorwerter

fzzembly Version 1000
Publizh Version 1.0.0.74
Copyright @ 2014

- |

Figure 2-4 (1Z1CConverter Version Information)

Click ‘Import License.dat’ in ‘Help’ menu to choose a license file to import.

2.1.3. Convert
Click on [Convert] button to start converting files.
2.1.4. Abort

Abort current converting. Converting operation can only be restarted by clicking on [Convert] button.
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2.2. Task List

The added ZIC and ICV files will be shown in Task List’.
Users can arrange added files in an ascending/descending order of the value in each label by clicking on them.

aoZlD  srcloV imaeWidth  mageHeicht  framefum  cameralm  diviehum frameRste dstZl0 dstubefroniormardStresmbn  dsiOubsRer ReverseStresmb  dstophersf ormardStreamOn  dstphereReversestmsmD  statis praeress 7| 215 T Gube Stream (7] Sphers Stream

Figure 2-5 (Task List)

Table 2-2 (Labels in Task List)

srcZIC ZIC file name

srclICV ICV file name

imageWidth Image width of an 1ZIC file

imageHeight Image Height of an 1ZIC file

frameNum Total number of frames of an 1ZIC file
cameraNum Total number of cameras

divideNum Number of pieces which one frame will be divided
frameRate Frame rate of camera

dstlZIC A root of generated I1ZIC files

dstCubeFrontForwardStreamDir | A root of generated image files of cube forward
dstCubeRearReverseStreamDir | A root of generated image files of cube reverse

dstSphereForwardStreamDir A root of generated image files of sphere forward

dstSphereReverseStreamDir A root of generated image files of sphere reverse

status Status of current operation (Running, Abort or Complete)

progress Progress of converting

1ZIC ChO(t))sing whether generate 1ZIC files by clicking on small white box
nearby

Choosing whether generate cube image files by clicking on small
white box nearby

Choosing whether generate sphere image files by clicking on small
white box nearby

Cube Stream

Sphere Stream

4 Skip to first or last ZIC files and the corresponding ICV files
4 Skip to previous or next ZIC files and the corresponding ICV files
Remove current ZIC files and the corresponding ICV files from Task
List’
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2.3. Settings

Settings

Output Directary(O):

JPEG Quialits( J): = %
Thread Mumber{T:

&l

Figure 2-6 (Settings)

Table 2-3 (Labels in Settings)

Output Directory Output directory of generated 1ZIC files
| | Choose a output directory

JPEG Quality Quality of generated 1ZIC files

Thread Number Thread number of converting at one time

2.4. Command Line and Parameters

Command line After Convert
Command lined &)

4 ;
Parameters( Pl

iarcsfIc srclchy)  FlimagetWidth)  $limageHeight) Ecamerar\luma $framebum) $lframeRate) $(d=tIZIC)
PloutputDirector ifiletame dstCubeFrontForwardStreamDir (dztCube Rear PeverseStraamDir)
FidztSphereForwardstreamDir)  $ldstSphere BeverseStreamDir)

Figure 2-7 (Command Line and Parameters)

Command line provides users multiple functionalities (for example, generating streaming video files and so on) by
commands.

Each parameter in ‘Parameters’ part has same meaning with same label name in ‘Task List’.

More details of the commands refer to section 3.3.
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3. Converting IZIC Files

Converting 1ZIC files is the main functionality of IZICConverter. Users can convert ZIC files and the corresponding
ICV files into 1ZIC files. In this chapter, a method to convert 1ZIC files is explained.

Before introducing how to convert 1ZIC files, some notations are introduced as a background.

ZIC files: Contain JPEG files token by camera.

ICV files: Contain location information and CV calculation.

1ZIC files: Contain JPEG files with location information and CV calculation.
Cube streaming files: Streaming files only contain cube image files.

Sphere streaming files: Streaming files only contain sphere image files.

3.1. Adding ZIC Files and ICV Files

Users can add ZIC files by dragging them into ‘Task List’ box (Figure 3-1), and then the corresponding ICV files will
be added into Task List” automatically (Figure 3-2).

File(F)  Help(H)
Task List

P4 o of0 | b bl | X

sreZIC imageWidth imageHeight frameNum

Share with + Burn

Name

cameralum divideNum
__| Sanroku_2_5400:2700 zic
| Sanroku_1_5400:2700 zic
|| kanjyo_2_5400:3700.zic
| kanjyo 1 5400x2700.zic
|| Sanroku_2_540052700.icv
] Sanroku_1_5400:2700.icv
| kanjyo_2_5400x2700.icv

|| kanjyo_1_5400:3700.icv

Figure 3-1 (Add ZIC Files)

The added files can be removed from ‘Task List” by choosing them and clicking on button.

Task List
P 4|1 ofd [ b M | X

imageWidth imageHeight frameNum

CAZIC ICV FilehSanroku_2_5400c2700.zic CAZIC ICV FilehSanroku_2_5400:2700.icv
CAZIC ICV FilehSanroku_1_54002700.zic CAZIC ICV FilehSanroku_1_54002700.icv
CAZIC ICV Filg“kanjyo_2_54002700 zic CAZIC ICV File“kanjyo_2_540027000cv
CAZIC ICV Filg“kanjyo_1_B4002700 zic CAZIC ICV File“kanjyo_1_540027000cv

Figure 3-2 (Task List after Adding ZIC and ICV Files)

10
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3.2. Setting

After adding ZIC and ICV files into ‘Task List’, some converting parameters should be set (Figure 3-3).
First select a directory to store generated 1ZIC files. Then enter JPEG quality (usually use 95%) and thread number (it
can be any number but more threads means lower converting speed, so 2 or 3 threads will be appropriate).

Settings
Output Dirsctory(@):  CAIZIC_OUTPUT :]

JPEG QualitylJ): (3% =
Thread Numben(T): |2 =

Figure 3-3 (Set Converting Parameters)

3.3. Command Line

In 1ZICConverter command line provides users many functionalities through commands in ‘Command line’ box.

A command form is:
“ROOT\FILENAME.bat” “PARAMETER1” “PARAMETER2” ---

Parameters from 1ZIC files should be written as: $(PARAMETER).

For example, a parameter which means output path of 1ZIC files, they should write this parameter into ‘Command line’
box as: “$(outputDirectory)”.

If users want to enter a subdirectory of the output path they should write this parameter as: “$(outputDirectory)
\SUBDIRECTORYPATH”

Another situation that an 1ZIC file named “Sapporo.izic” then write a parameter like “$(frameNAME) _Center”, the
command will recognize this parameter as “Sapporo_Center”.

Parameters in command will input into BAT files after converting. Then users can achieve different functionalities by
different commands.

The parameters of 1ZIC files can be entered into ‘Command line” box through keyboard or clicking parameter labels in
‘Parameters’ part.

In addition, commands can only be set before converting and will start to work after converting.

3.4. Converting Files

Before converting work, users can choose output file types they need from 1ZIC files, cube streaming files and sphere
streaming files by clicking corresponding small white box.

After all settings have been completed, converting work can be started by clicking on [Convert] button.
Then converting work will start in current order, converting speed and total progress will be shown on the bottom of
main window (Figure 3-4).

In ‘Task List” green background color means running thread, white background color means idle thread and blue
background color means chosen thread.

11
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File(F)  Help(H)

Task List

THOd e ofd | b M| XK
seZIC srelCV imageWidth imageHeight  frameMNum cameraNum  divideNum  frameRate  dsf
CAZIC ICV Filekanjyo... | CAZIC ICV Filekanjy... | 5400 2700 835 2 1.3 16.00256 | C:\|
CAZIC ICV Filekaniyo... | CAZIC ICV Filekanjy... | 5400 2700 953 2 1.3 16.00256 | C\|

CAZIC ICV File\Sanro... | CAZIC ICV File\Sanr

- |G / \Sanr...

< i 3
Settings —
Output Directory(0): |C NZIC_QUTPUT | -

JPEG Quality(J): %
Thread Number{T):

Command line After Convert
Command line{A):

4 1

Parameters(F):
8srcZIC) SErclCV)  $(mageWidth) S$(mageHeight) S{cameraNum) SframeNum) SframeRate) S{dstlZIC) S{outputDirectory) SfileName)
8{dstCubeFrontForwardStreamDir)  ${dstCubeRearReverseStreamDir)  $(dstSphereForwardStreamDir) - ${dstSphereReverseStreamDir)

Convert(E)
Speed: 1,858 frames/s , Total progress: 0/4 A
Figure 3-4 (Converting Work)
Task List
P 41 ofd | b bl | K |
be Front Forward StreamDir w dstCubeRearRever dstSphereForwardS dstSphereReverse! status progress

ZIC_OUTPUT kaniyo_2 5400627 CANZIC_OUTPU.. CAIZIC_OUTPU.. CMZIC_OUTPU.. | Running
ZIC_OUTPUT kaniyo_1_5400x27... |CNZIC_OUTPU... |CAIZIC_OUTPU... |CAZIC_OUTPU... | Runming 89/9393 (1/2)

Figure 3-5 (Add Class Dialog Box)

After converting work, the background color of converted threads will turn to white and status will turn to “Complete”
(Figure 3-6)

Complete | 895/895 (2/2)
Complete | 9937983 (2/2)
Figure 3-6 (Converted Threads)

3.5. Aborting Converting Work

If users want to stop current converting work or change some settings, they can click on [Abort] button.
Then the converting work will be aborted after processing current image file, meanwhile background color of aborted
threads will turn to yellow and the status will turn to “Abort” (Figure 3-7).

The aborted threads can only be restarted from the beginning by clicking on [Convert] button.

12
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status progress FIC Cube Stream Sphere Stream
Abaort 3991647 (1/2)

&bart BO1LA1123 (1520
Figure 3-7 (Aborted Threads)

13
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4, Generating Streaming Video Files

Generating streaming video files is an important functionality which is achieved by commands.

The generating streaming video files commands have a same form:
“ROOT\BATCHFILE.bat” “INPUTPATH” “OUTPUTPATH” “FRAMERATE” “FILENAME”

The functionalities of BAT files in generating streaming video files are similar, that are combining image files into
streaming video files (contain FLV files and MP4 files).

Figure 4-1 gives an example of commands of generating streaming video files.

Command line After Convert
Command line(4):

"C:h\cubeconviwebalp 3wcreate_cube bat” "S{dstCubeFront Forward StreamDir)" " $loutput Directory)stream” "$frameRate)” "Sfile Name)_cube_fromt_forward”
"C:\cubeconvtwebalp 3'create_cube bat” "${dstCubeRearReverse StreamDir)" "${output Directory)stream™ " $frameRate)” "$fileName)_cube_rear_reverse”
"C:\oubeconviwebalp 3wcreate_sphere bat" "$(dst Sphere Forward StreamDir)" " $(output Directory)stream” "$frameRate)" "SfileName)_sphere_forward”

"C:

‘cubeconv'webalp 3\create_sphere bat" "${dst Sphere Reverse StreamDir)" "${output Directory)'stream” "SframeRate)” "$ffileName)_sphere_reverse"”

Figure 4-1 (An Example of Generating Streaming Video Files Commands)

Table 4-1 (An Example of One of Generating Streaming Video Files Commands)

Command Form Example Command
“ROOT\BATCHFILE.bat” “C:\cubeconv\webalp3\create cube.bat”
“INPUTPATH” “$(dstCubeFrontForwardStreamDir)”
“OUTPUTPATH” “$(outputDirectory) \stream”
“FRAMERATE” “$(frameRate)”

“FILENAME” “$(fileName) _cube_front_forward”

The functionality of BAT file “create_cube.bat” is combining cube image files into a cube streaming video file (contain
a FLV file and a MP4 file).

14
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