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Introduction 
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1 Introduction 
These additional help topics provide a description of the functionality available in the TIBCO 
Spotfire Connector for Pipeline Pilot. It is important to note that these topics do not cover 
protocol generation in detail, nor any work done within Pipeline Pilot. See Accelrys for training 
in these areas. Neither does these help topics cover any further analysis done in TIBCO 
Spotfire. See the main TIBCO Spotfire help topics for more information about the available 
functionality. 
The TIBCO Spotfire Connector for Pipeline Pilot allows you to combine the visual interactive 
analytics of Spotfire with the high-throughput data pipelining capabilities of Accelrys SciTegic 
Pipeline Pilot. The connector allows you to deploy Pipeline Pilot protocols to other TIBCO 
Spotfire users, so that they can take advantage of powerful computations without having to 
learn any details of creating protocols themselves. 
The TIBCO Spotfire Connector for Pipeline Pilot gives you the opportunity to define input 
prompts and appropriate output parameters. The Pipeline Pilot computation can then be run 
from within TIBCO Spotfire. 
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2 Logging In 
2.1 Logging In 

When you run any of the TIBCO Spotfire Connector for Pipeline Pilot tools and you have 
selected which server to run against, a login dialog appears: 

 
Enter your Username and Password, and click on the OK button to connect to the Pipeline Pilot 
server. 
If you are working on a large company with multiple Pipeline Pilot servers, you may 
occasionally also need to change the server you are connecting to. This is done in the Select 
Server step before reaching the login dialog. New servers can be added to the list by clicking on 
the Manage Servers... link in the Server Administration - Select Server dialog.  
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3 Server Administration 
3.1 Determining which Pipeline Pilot Protocols 

Should be Available in Spotfire 
When you have created a set of protocols on the Pipeline Pilot server, you need to specify 
which ones should be available in TIBCO Spotfire. This is done with the Server Administration 
tool. 
Only those protocols that have been published here will be available for configuration in the 
Configure Pipeline Pilot Computation dialog. 
Protocols that are intended to be used as a data source or a data transformation in TIBCO 
Spotfire must have one and only one output parameter of the type URL or DestinationURL in 
Pipeline Pilot. This parameter is then automatically populated with the Data output handler in 
the configuration of the protocol in TIBCO Spotfire. See Adding a New Computation and 
Editing Parameters for more information about configuration. 

► To make a protocol available in TIBCO Spotfire: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Server 

Administration.... 
Response: The Server Administration - Select Server dialog is displayed. 

2. Select the Pipeline Pilot server of interest from the drop-down list. 
Comment: If you need to add another server to the list, click on the Manage server... 
link and follow the instructions under Managing Pipeline Pilot Servers. 

3. Click OK. 
Response: The Pipeline Pilot Server Login dialog is displayed. 

4. Enter the Username and Password for the selected server. 
5. Click OK. 

Response: The Server Administration - Publish Protocols dialog is displayed. 
6. Click on the protocol you want to make available in the Pipeline Pilot protocols 

available for selection list. 
7. Click on Add >. 

Response: The selected protocol is moved to the Selected protocols available in 
TIBCO Spotfire list. 

8. Repeat steps 6 and 7 for all protocols you want to make available.  
9. When you are done, click OK. 

3.2 Managing Pipeline Pilot Servers 
Use the instructions below to add or edit the list of available Pipeline Pilot servers. 

► To add a new Pipeline Pilot server to the list of available 
servers: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Server 

Administration.... 
Response: The Server Administration - Select Server dialog is displayed. 

2. Click on the Manage servers... link. 
Response: The Manage Servers dialog is displayed. 

3. Click on Add.... 
Response: The Add Server dialog is displayed. 
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4. Enter the address to the new Pipeline Pilot server. 
5. Click OK. 

Response: The new server address is shown in the Manage Servers dialog. 
6. Click OK. 

Response: The new server can now be selected in the Server Administration - Select 
Server dialog. 

► To edit the address to a Pipeline Pilot server: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Server 

Administration.... 
Response: The Server Administration - Select Server dialog is displayed. 

2. Click on the Manage servers... link. 
Response: The Manage Servers dialog is displayed. 

3. Click on Edit..... 
Response: The Edit Server dialog is displayed. 

4. Edit the address to the Pipeline Pilot server. 
5. Click OK. 

Response: The updated server address is shown in the Manage Servers dialog. 
6. Click OK. 

Response: The updated server address can now be selected in the Server 
Administration - Select Server dialog. 

3.3 Details 
3.3.1 Details on Server Administration - Select Server 

You must always connect to a Pipeline Pilot server if you want to use any of the TIBCO 
Spotfire Connector for Pipeline Pilot tools. The Server Administration tool helps you to 
configure which protocols should be available on each server. 

► To reach the Server Administration - Select Server dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Server 

Administration.... 

  
Select the Pipeline Pilot server to use from the drop-down list. If you want to add a server, or 
edit the address to a server, click on the Manage servers... link. 

3.3.2 Details on Server Administration - Publish 
Protocols 

This dialog allows you to specify which of the protocols on the Pipeline Pilot server should be 
available for configuration of TIBCO Spotfire computations. 
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► To reach the Server Administration - Publish Protocols dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Server 

Administration.... 
2. If you have not previously logged into a server then you will be prompted to do so 

now. 

 

Option Description 
Pipeline Pilot 
protocols available 
for selection 

Lists all protocols that are available on the selected Pipeline Pilot server 
and have not yet been published to TIBCO Spotfire. 

Selected protocols 
available in 
TIBCO Spotfire 

Lists all protocols that have been selected to be available for 
configuration into computations in TIBCO Spotfire. 

3.3.3 Details on Manage Servers 
► To reach the Manage Servers dialog: 

1. Click on the Manage servers... link in the Server Administration - Select Server 
dialog. 

5 
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Option Description 
Available Pipeline 
Pilot servers 

Lists all available Pipeline Pilot servers. You must always connect to a 
Pipeline Pilot server if you want to use any of the TIBCO Spotfire 
Connector for Pipeline Pilot tools. 

Add... Opens a dialog where you can add a new server to the list. 

Edit... Opens a dialog where you can edit the path to the server selected in the 
list. 

Delete Removes the selected server from the Available Pipeline Pilot servers 
list. 

3.3.4 Details on Add/Edit Server 
► To reach the Add Server dialog: 

1. In the Server Administration - Select Server dialog, click on the Manage Servers... 
link. 

2. In the Manage Servers dialog, click Add.... 

► To reach the Edit Server dialog: 
1. In the Server Administration - Select Server dialog, click on the Manage Servers... 

link. 
2. In the Manage Servers dialog, click to select a server, then click Edit.... 

 
Type the address to the Pipeline Pilot server in the field.  
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4 Configure Computations 
4.1 Adding a New Computation 

Once some Pipeline Pilot protocols have been made available in TIBCO Spotfire you can start 
to configure computations. A computation is what determines how the result from the Pipeline 
Pilot protocol should be used in TIBCO Spotfire. It could be a new data source, a 
transformation step used when retrieving data from other sources or a stand-alone tool used 
from a link in a text area of a guided analysis. Each protocol can result in several different 
computations. 

► To add a new computation: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computations.... 
Response: The Configure Pipeline Pilot Computations dialog is displayed. 

2. Click Add..... 
Response: The Add Computation - Select Server dialog is displayed. 

3. Select the Pipeline Pilot server of interest from the drop-down list. 
Comment: See Managing Pipeline Pilot Servers for more information about how to 
add Pipeline Pilot servers to the list of available servers. 

4. Click OK. 
Response: The Add Computation - Select Pipeline Pilot Protocol dialog is displayed. 

5. Select the protocol of interest from the list of Available protocols. 
Comment: Only the protocols that have been published in the Server Administration - 
Publish Protocols dialog will be available. See Determining which Pipeline Pilot 
Protocols Should be Available in Spotfire for more information. 

6. Click OK. 
Response: The Add Computation - Select Usage Mode dialog is displayed. 

7. Click on a radio button to determine how the computation should be used. 
Comment: It could be used as a new data source, as a transformation step used when 
retrieving data or as a stand-alone tool. See the note below for more information. 

8. Click OK. 
Response: The Add Computation - Configure dialog is displayed. 

9. If desired, edit the description of the computation or edit the parameters by clicking on 
the button to the right for each parameter. 
Comment: See Editing Parameters for more information. 

10. Determine whether or not the computation should be available to end users by 
selecting or clearing the check box at the bottom of the dialog. 

11. Click OK. 
Response: The new computation is added to the list of Available computations in the 
Configure Pipeline Pilot Computations dialog and it can also be used from the 
specified location as defined in the Add Computation - Select Usage Mode dialog. 

Note: Protocols that are intended to be used as a data source or as a data transformation in 
TIBCO Spotfire must have one and only one output parameter of the type URL or 
DestinationURL in Pipeline Pilot. This parameter is then automatically populated with the Data 
output handler in the configuration of the protocol in TIBCO Spotfire.  
A protocol that should be used as a data source cannot have an input parameter that operates on 
existing data, e.g., a parameter that is configured with a Data from Spotfire input handler. 
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4.2 Editing a Computation 
Once some Pipeline Pilot protocols have been made available in TIBCO Spotfire you can start 
to configure computations. A computation is what determines how the result from the Pipeline 
Pilot protocol should be used in TIBCO Spotfire. 

► To edit a computation: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computations.... 
Response: The Configure Pipeline Pilot Computations dialog is displayed. 

2. Click Edit.... 
Response: The Edit Computation dialog is displayed. 

3. If desired, edit the Name or Description of the computation, or edit the parameters by 
clicking on the button to the right of each parameter. 
Comment: See Editing Parameters for more information. 

4. To publish a computation so that end users can see it, select the Make this 
computation available to end users check box. 

5. Click OK. 
Response: The computation is updated. 

4.3 Editing Parameters 
You can edit some settings for the parameters which have been defined at the creation of the 
Pipeline Pilot protocol. This is done by clicking on the   button to the right of the parameter 
in the Add Computation - Configuration dialog or in the Edit Configuration dialog. 
It is normally a good idea to find out as much as possible about a parameter before you edit any 
of the settings. Depending on the type of parameter, you can change whether it should be an 
Input or an Output parameter. However, changing something that has been created to be of one 
type to another might lead to strange results. The most common case of editing parameters is 
probably that you need to change the handlers that determine what to do with each parameter. 
However, the available handlers for a certain parameter will depend on the type of parameter. 
You cannot select a handler that does not agree with the character of the selected parameter. See 
Details on Edit Parameter for descriptions of all handlers. 

Input handlers 
Input handlers will determine whether the input will be treated as a string, integer or real, or as 
data from a data table currently available in TIBCO Spotfire. You can only use one input 
handler per parameter. Input parameters can often be filled with content by prompting the end 
user for information.  
A protocol that should be used as a data source cannot have an input parameter that operates on 
existing data, e.g., a parameter that is configured with a Data from Spotfire input handler. 

Output handlers 
If the computation is run as a tool, you can use more than one output handler for a parameter. 
For example, this means that the result from the computation may be added both as new 
columns to be incorporated with the current data table in the analysis and as a new data table. 
This gives the end users of the computation the opportunity to decide how to use the results for 
themselves. 
The Add columns, Add data table, Add rows, Replace data table and Data output handlers all 
require a file to be produced by the Pipeline Pilot protocol. The file type can be either a tab 
delimited text file or an SD file. The path to the file must be given to a parameter of the type 
URL or DestinationURL in Pipeline Pilot which is then configured in TIBCO Spotfire with one 
of the handlers listed above. 
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Some output handlers require a little more configuration than others. See the examples below. 
 
Add properties: 
This output handler allows you to use the output parameter results as document properties in the 
analysis.  
Example: You can use the resulting document properties to define lines in a visualization, 
representing the approved higher and lower limits of the displayed values. 
1. In the Pipeline Pilot computation, specify the property names to use: 

 
The number of entered property names must match the number of values returned by the 
parameter. If you have not created the protocol yourself, this information should be available 
from the creator of the protocol. 
2. Run the computation to apply the properties to the current analysis. 
3. In the selected visualization of your TIBCO Spotfire analysis, specify custom expressions to 
use when defining straight lines using the defined properties.  

9 
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You reach the dialog shown above by selecting Edit > Visualization Properties, going to the 
Lines & Curves page and Add > Horizontal Line > Y-axis: Straight Line.... 
4. If desired, add more lines. 
5. Look at the results: 

 
In the image above, both the higher limit and the lower limit have been shown in the scatter 
plot. 
 
Set link template: 
This output handler specifies the LinkTemplate property on a column, so that the content of that 
column is shown as hyperlinks leading to the URL defined in the protocol. Search for 
LinkTemplate in the main TIBCO Spotfire help for more information about this property. 
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A simple example; if we have a table visualization containing a column with different animals, 
we can use the set link table output handler to connect each animal type to its corresponding 
Wikipedia page by doing the following: 
1. In the Pipeline Pilot protocol, specify an output string parameter with the default value 
http://en.wikipedia.org/wiki/{$}. 
2. Configure a computation in TIBCO Spotfire using the Pipeline Pilot protocol and edit the 
output parameter to use the Set link template output handler.  

 
3. Determine whether to prompt the end user for input or predefine the table and column to use. 

 
4. Run the computation. 

 
 
Show in text area: 
This output handler populates a text area in Spotfire with the values of the output parameter.  

11 
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In this example, we have a text area entitled Results available in the analysis and we want the 
output results from a computation to be shown on a specific location in that text area. 
1. In the text area, type "$(PipelinePilotResult)" where you want the results from the output 
parameter to appear. 

 
2. Edit the configuration for the output parameter so that it uses the Show in text area handler 
and specify the predefined value to the name of the desired text area (in this example, 
"Results"). 

 
3. Run the computation. 

 
The results are shown in the specified text area instead of the placeholder. 
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4.4 Details 
4.4.1 Details on Configure Pipeline Pilot Computations 

► To reach the Configure Pipeline Pilot dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computations.... 

 

Option Description 
Available 
computations 

Lists the currently available computations. The usage mode, the server 
name and whether or not the computation has been made available to 
end users (published) are also shown. 

Add... If you have not previously logged in to a Pipeline Pilot server, you need 
to do so now. 
Opens the Add Computation wizard where you can choose which 
protocol from the server you wish to add as an available computation. 
You also get a chance to configure the computation according to your 
own choice. 

Edit... Opens the selected computation for editing. 

Delete Deletes the selected computation. 

Description Displays the description added by the creator of the protocol. This 
description can also be changed by clicking Edit.... 

Parameters Displays the available parameters. 

13 
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4.4.2 Details on Add Computation - Select Server 
This dialog allows you to select from which Pipeline Pilot server you wish to add a 
computation. 

► To reach the Add Computation - Select Server dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computation.... 
Response: The Configure Pipeline Pilot Computation dialog is displayed. 

2. Click Add.... 

  
Select the Pipeline Pilot server to use from the drop-down list.  

4.4.3 Details on Add Computation - Select Pipeline Pilot 
Protocol 

In this dialog, you select which Pipeline Pilot protocol to add as a new computation available in 
TIBCO Spotfire. 

► To reach the Add Computation - Select Pipeline Pilot Protocol 
dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computations.... 
2. If you have not previously logged into a server then you will be prompted to do so 

now. 
3. In the Configure Pipeline Pilot Computation dialog, click Add.... 
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Option Description 
Available 
protocols 

Lists the protocols that have been specified to be available in TIBCO 
Spotfire using the Server Administration - Publish Protocols dialog. 

Description Shows the description of the selected protocol as the creator of the 
protocol wrote it in Pipeline Pilot. 

Parameters Lists the parameters that have been defined for the selected protocol. 

4.4.4 Details on Add Computation - Select Usage Mode 
This dialog is used to specify where you want the new computation to appear. It is 
automatically shown when you have selected to add a Pipeline Pilot protocol. You cannot go 
back to change the selection once you have clicked OK; add another computation instead. 

 
The selection made in this dialog affects the choices available for further configuration of the 
computation at a later stage. 

Option Description 
As a data source Select this option if you want the Pipeline Pilot computation to be 

shown among the available data sources from the File > Open From 
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menu and in tools that can add data such as the wizards listed below. 
In the Add Data Table wizard, the Replace Data Table wizard, the 
Insert Columns from External Data wizard and the Insert Rows from 
External Data wizard, the TIBCO Spotfire Connector for Pipeline 
Pilot option will be shown in the Other drop-down list once this 
option has been selected. 

As a data 
transformation 

Select this option if you want the Pipeline Pilot computation to be 
shown among the available transformations in the Add Data Table 
wizard, the Replace Data Table wizard, the Insert Columns from 
External Data wizard and the Insert Rows from External Data wizard.
See the main TIBCO Spotfire help for more information about 
transformations and the various wizards. 

From the 'Tools' 
menu 

Select this option if you want the Pipeline Pilot computation to be 
available when selecting Tools > TIBCO Spotfire Connector for 
Pipeline Pilot > Run Computation.... 
This option should also be selected if you want to use the 
computation as a guide tool. 

4.4.5 Details on Add Computation - Configure 
This dialog is used to configure the new computation before it is added to the specified usage 
point in TIBCO Spotfire. 
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Option Description 
Pipeline Pilot 
server 

[Read only.] 
Lists the Pipeline Pilot server that the protocol resides on. 

Protocol name [Read only.] 
Lists the name of the protocol on the Pipeline Pilot server. 

Usage mode [Read only.] 
Lists where this computation should be available. The usage mode is 
specified in the Add Computation - Select Usage Mode dialog, prior to 
this step. Add a new computation using the same protocol if you need to 
change this setting. 

Name The name of the computation as you want it to be displayed to the end 
users. This can be a different name than the original protocol name. 

Description Lists the description of the protocol as it was written by the protocol 
creator. You can edit the text by simply writing in the Description field. 
The updated description will be shown in the Description field of the 
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Configure Pipeline Pilot Computations dialog and the Pipeline Pilot 
Computation dialog. 
The description should be written as clearly as possible to help the end 
users select the correct computation at all situations. 

Parameters Lists the specified parameters for the selected protocol. You can click to 
select a specific parameter and then click on the edit parameter button, 

, to change the settings of the selected parameter, See Editing 
Parameters for more information. 
Only parameters promoted to the protocol level will be visible in this 
list. 

Make this 
computation 
available to end 
users 

Select this check box to make the computation available to end users 
which do not have the license to configure protocols. Keep the check 
box cleared until you are finished with all configurations and the 
computation works as it should. 

4.4.6 Details on Edit Computation 
This dialog is used to edit a previously configured computation. 

► To reach the Edit Computation dialog: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure 

Computations.... 
2. Click Edit.... 
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Option Description 
Pipeline Pilot 
server 

[Read only.] 
Lists the Pipeline Pilot server that the protocol resides on. 

Protocol name [Read only.] 
Lists the name of the protocol on the Pipeline Pilot server. 

Usage mode [Read only.] 
Lists where this computation should be available. The usage mode is 
specified in the Add Computation - Select Usage Mode dialog, prior to 
this step. Add a new computation using the same protocol if you need to 
change this setting. 

Name The name of the computation as you want it to be displayed to the end 
users. This can be a different name than the original protocol name. 

Description Lists the description of the protocol as it was written by the protocol 
creator. You can edit the text by simply writing in the Description field. 
The updated description will be shown in the Description field of the 
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Configure Pipeline Pilot Computation dialog and the Pipeline Pilot 
Computation dialog. 
The description should be written as clearly as possible to help the end 
users select the correct computation at all situations. 

Parameters Lists the specified parameters for the selected protocol. You can click to 
select a specific parameter and then click on the edit parameter button, 

, to change the settings of the selected parameter, See Editing 
Parameters for more information. 
Only parameters promoted to the protocol level will be visible in this 
list. 

Make this 
computation 
available to end 
users 

Select this check box to make the computation available to end users 
which do not have the license to configure protocols. Keep the check 
box cleared until you are finished with all configurations and the 
computation works as it should. 

4.4.7 Details on Edit Parameter 
The parameters of a computation can be edited by clicking on the edit parameter button, , in 
the Add Configuration - Configure or the Edit Configuration dialog.  
However, the available handlers for a certain parameter will depend on the type of parameter. 
You cannot select a handler that does not agree with the character of the selected parameter. 
The usage mode of the computation also limits the available handlers. 

TIBCO Spotfire configuration: 

Input parameters: 

 

Option Description 
Parameter 
description 

Displays the description of the parameter for the TIBCO Spotfire users. 
The general description that was written upon creation of the protocol 
can be edited for further detail.  
The description written here is displayed in the prompt dialog, if a 
prompt step is defined. This allows you to write specific instructions on 
the type of input that is required for this parameter. 
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Note: If the protocol requires certain columns to be included, it is 
important to add that information here to help users select the correct 
columns in the prompt dialog. 

Direction Specifies whether this should be an Input or Output parameter. 

Handler Specifies how the parameter should be handled: 
Empty (unhandled) - No input handler has been selected. This option 
can be used if the parameter not is required by the protocol. 
String - Specifies that the input parameter should be treated as a string. 
It can either be a single value or an array. 
Integer - Specifies that the input parameter should be treated as an 
integer.  It can either be a single value or an array. 
Real - Specifies that the input parameter should be treated as a real. 
(This parameter type corresponds to the DoubleType in Pipeline Pilot.) 
 It can either be a single value or an array. Note that if there are legal 
values set for a Real parameter, no validation will be done. 
Data from Spotfire - Specifies that the input parameter should be data 
from a data table currently available in TIBCO Spotfire. A prompt 
allows you to specify what data to use at runtime. 
The Data from Spotfire input handler can be used for the parameter type 
URL or DestinationURL in Pipeline Pilot (PP). The PP protocol then 
needs to have one of two file reader components, e.g., a tab delimited 
text reader or an SD file reader. The second reader must be used when 
the data contains Molfiles and the first reader is used in any other case. 
Note: If the protocol requires certain columns to be included, it is 
important to add that information in the Parameter description to help 
users select the correct columns in the prompt dialog. 

Value  

   Prompt at 
runtime 

Select this option to prompt the end user of the computation for input. 

   Pre-defined 
value 

[Not available for the Data from Spotfire option.] 
Select this option to specify a value (or an array of values) to use as 
input manually. 

   Set... Opens a dialog where you can specify the input parameter. 
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Output parameters: 

 

Option Description 
Description Displays the description of the parameter for the TIBCO Spotfire users. 

The general description that was written upon creation of the protocol 
can be edited for further detail.  

Direction Specifies whether this should be an Input or Output parameter. 

Handlers Specifies how the parameter should be handled: 
Add columns - Specifies that the output parameter should add new 
columns to the currently available data table. If the computation is run 
as a tool, you will be prompted to specify which join type to use. 
Add data table - Specifies that the output parameter should be sent to 
the Add data table tool so that it can be used as a new data table in the 
open analysis. 
Add properties - Specifies that the output parameter values should be 
used as document properties in the analysis. You can either predefine 
the document properties or prompt for them at runtime. The properties 
must be defined on the form "prefix.suffix". Search for Document 
Properties in the main TIBCO Spotfire help for information about 
where document properties can be used. 
Add rows - Specifies that the output parameter should be sent to the 
Add rows tool so that it can be used to add new rows to the currently 
available data tables. 
Replace data table - Specifies that the output parameter should be sent 
to the Replace data table tool where it can replace any of the currently 
open data tables. 
Data - This output parameter returns some form of data to Spotfire and 
is always used when the usage mode for a computation is a data source 
or a data transformation. 
Set link template - This output handler specifies the LinkTemplate 
property on a column, so that the content of that column is shown as 
hyperlinks leading to the URL as it has been defined in the protocol. 
Search for LinkTemplate in the main TIBCO Spotfire help for more 
information about this property. 
The title of the table visualization and the column name for the column 
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which should contain the hyperlinks is specified in a prompt dialog. 
Show in text area - This output handler populates a text area in Spotfire 
with the values of the output parameter. It is possible to show the values 
in an existing text area or to create a new text area. When this output 
handler is selected, you will be prompted to specify the name of the text 
area where you want the values to appear. 
If a text area with the given title is found in any page of the current 
analysis, that text area will be used. If no text area is found that matches 
the given title, a new one will be added. 
It is also possible to specify a position in an existing text area where the 
output parameter values will be added. Simply type 
"$(PipelinePilotResult)" in the text area of interest and that placeholder 
will be replaced with the result from the Show in text area output 
handler. The first occurrence of the placeholder will be replaced with 
the first value.  
Note: If no placeholder is found in the specified text area, the entire 
content of the text area will be replaced. 
If more than one placeholder is added, each following instance of the 
output handler will replace the first available occurrence of the 
placeholder. It is therefore possible to display the results from multiple 
parameters or from multiple computations in the same text area. 
Show in browser - This output handler is used to display the output 
URLs from the computation in your web browser. 
 
The Add columns, Add data table, Add rows, Replace data table and 
Data output handlers all require a file to be produced by the Pipeline 
Pilot (PP) protocol. The file type can be either a tab delimited text file 
or an SD file. The path to the file must be given to a parameter of the 
type URL or DestinationURL in PP which is then configured in TIBCO 
Spotfire with one of the handlers listed above. 

Add Adds the handler selected in the drop-down list to the list of chosen 
handlers. You can add more than one handler for all parameters. See 
Details on Add/Edit Output Handler for more information about 
available settings for different handlers. 

Edit... Opens a dialog where the settings for the selected output handler can be 
changed. Only a few of the output handlers have any settings. See 
Details on Add/Edit Output Handler for more information about 
available settings for different handlers. 

Remove Removes the selected handler from the list of chosen handlers. 

 

Pipeline Pilot parameter information: 
All the information in this group box is read-only. It shows the settings specified at the creation 
of the protocol in Pipeline Pilot and it can be of help if you are going to configure parameters 
for a protocol that someone else has created. 

Option Description 
Description Displays the original description of the parameter from the protocol. 

Type Displays the parameter type. 

Attributes Displays whether the parameter is required or optional, and whether it 
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should use a single value or multiple values. 

Legal values Lists the allowed values for this parameter. For example, for a file input 
value this could be HTML or PDF. The legal values are shown as 
selectable values in the prompt dialog if the parameter requires input 
from the end user at runtime. 

Default value Lists the default value of the parameter. 
 
Note: If you are using a Pipeline Pilot protocol with an output parameter 
intended as a URL to a file, then this parameter must have the directory 
set to one of the following: $(runDirectory), $(jobDir) or $(userDir). 
If the parameter is set to any other path you must configure this in 
Pipeline Pilot or the file will not be found from TIBCO Spotfire. 

 

4.4.8 Details on Add/Edit Output Handler 
The Output Handler dialog looks different depending on the type of output handler you have 
selected. Below are examples of the various output handler dialogs.  

Add columns 

 
Note: To use this output handler, the computation must supply a data table where one of the 
columns can be used to match an ID column in the existing data table. 

Option Description 
Prompt Click this radio button to prompt the end user of the computation to 

determine which join method to use. 

Set predefined 
value 

Click this radio button to predefine which join method to use. 

Join method  

   Left outer Data will be kept (and columns added) only for rows that are available 
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in the current data table. If additional rows exist in the new data, they 
will not be added to the current data table. 

   Full outer Data will be kept (and columns added) for all rows available in any of 
the data tables. If additional rows exist in the new data, they will be 
added to the current data table. 

   Inner Data will be kept (and columns added) only for rows that are available 
in the new data. If the new data contains fewer rows than the current 
data table, rows will be removed from the current data table after this 
operation. 

   Right outer Data will be kept (and columns added) only for rows that are available 
in the new data. If the new data contains fewer rows than the current 
data table, rows will be removed from the current data table after this 
operation. 

Add data table 

 

Option Description 
Prompt Click this radio button to prompt the end user of the computation for the 

name of the new data table. 

Set predefined 
value 

Click this radio button to predefine the name of the resulting data table. 

Enter data table 
name 

Type the name of the new data table. 
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Add properties 

 

Option Description 
Prompt Click this radio button to prompt the end user of the computation for 

property names. 

Set predefined 
value 

Click this radio button to predefine the property names to use for this 
output parameter. 

Enter property 
names, one name 
per row 

Type the names of the document properties that should use the results 
from the output parameter. 
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Set link template 

 

Option Description 
Prompt Click this radio button to prompt the end user of the computation for the 

table visualization title and the column name of the column to edit. 

Set predefined 
value 

Click this radio button to predefine the table visualization title and the 
column name. 

Enter table 
visualization title 

Type the title of the table visualization you wish to edit. 

Enter column 
name 

Type the column name of the column containing the data that is going 
to be converted to hyperlinks. 

Show in text area 

 

Option Description 
Prompt Click this radio button to prompt the end user of the computation for the 

title of the text area to update with the parameter results. 

Set predefined 
value 

Click this radio button to predefine the title of the text area to update 
with the parameter results.  
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Enter text area 
title 

Type the title of the text area that should be updated with the results 
from the output parameter in the field. Leave the field blank to present 
the results in a new text area. 

Show in Browser 
For the Show in Browser handler to work, you must design the output parameter of the PP 
protocol in one of the following ways: 
A PP protocol can be designed in two ways for use with the Show in Browser handler: 
1. For each output file from PP, an output parameter of type URL need to be created. A Show in 
Browser output handler must then be configured for each such parameter. 
2. Instead of a file, output parameters of type String or StringArray can be created in PP and be 
returned as result properties. A Show in Browser output handler must then be configured for 
each such parameter.  
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5 Run Computation 
5.1 Using Computations 

Once the Pipeline Pilot protocols have been configured into computations in TIBCO Spotfire 
they are ready to be used for various types of calculations. Depending on how the computation 
was set up in the Add Computation - Select Usage Mode dialog, it will show up on different 
places in the Spotfire user interface. 

► To run a computation from the Tools menu: 
When the usage mode is set to "From the 'Tools' menu", the computation is displayed as a 
standalone tool in the Pipeline Pilot Computation dialog. 

1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Run 
Computation.... 

2. If you have not previously logged into a server then you will be prompted to do so 
now. 

3. Depending on the type of computation, you may be presented with one or more prompt 
dialogs where you need to provide some input. See the Details on Parameter (prompt 
dialogs) for more information. 

► To use a computation as a data source in the wizards: 
When the "As a data source" option has been selected, the computation is added to all places 
where you can select a new data source: It can be used in the Add Data Table wizard, the 
Replace Data Table wizard, the Insert Columns from External Data wizard and the Insert Rows 
from External Data wizard. See an example below. It is also available if you select File > Open 
From > TIBCO Spotfire Connector for Pipeline Pilot.... 

1. Select File > Add Data Table.... 
Comment: Follow the same steps for either of the wizards listed above if you want to 
add Pipeline Pilot data somewhere else. 

2. Click Other. 
3. Select TIBCO Spotfire Connector for Pipeline Pilot from the drop-down list. 
4. Click Browse.... 
5. In the Pipeline Pilot Computation dialog, select the computation of interest and click 

OK. 
6. Continue with the wizard according to the instructions in the main TIBCO Spotfire 

help. 

► To use a computation as a transformation in the wizards: 
When the "As a data transformation" option has been selected, the computation is added to all 
places where you can perform a transformation: It can be used in the Add Data Table wizard, 
the Replace Data Table wizard, the Insert Columns from External Data wizard and the Insert 
Rows from External Data wizard. Example: 

1. Select File > Add Data Table.... 
Comment: Follow the same steps for either of the wizards listed above if you want to 
add a Pipeline Pilot transformation somewhere else. 

2. Select the source type for the data you wish to transform. 
3. Click Browse.... 
4. If the transformation section of the dialog is hidden, click on the show transformation 

arrow, , to display it. 
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5. In the Transformations drop-down list, select TIBCO Spotfire Connector for Pipeline 
Pilot. 

6. Click on Add.... 
7. In the Pipeline Pilot Computation dialog, select the computation of interest and click 

OK. 
8. Continue with the wizard according to the instructions in the main TIBCO Spotfire 

help. 

5.2 Details on Pipeline Pilot Computation 
► To reach the Pipeline Pilot Computation dialog: 

1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Run 
Computation.... 

2. If you have not previously logged into a server then you will be prompted to do so 
now. 

In this dialog, you select which Pipeline Pilot computation to use in the current situation. You 
can reach this dialog from other places in the user interface too. For example, it will be 
available if you have selected to add a data table or a transformation from a Pipeline Pilot 
computation. 

 

Option Description 
Available 
computations 

Lists all Pipeline Pilot computations that have been defined to be 
available at this specific place of usage. 
The usage mode is configured during the set up of a new computation. 
It may often be so that a computation that is available in the Add Data 
Table or Replace Data Table tools is unavailable when you select to run 
a Pipeline Pilot computation from the Tools menu.  
If you have the license for configuring computations, you may see 
computations that have not yet been made available to end users with 
the check box in the Edit Computation dialog. These computations 
have "No" in the Published field, as indicated in the image. 
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Description Shows the description of the selected computation as it was set up 
during the configuration. 

Parameters Lists the parameters that have been defined for the selected protocol. 

5.3 Details on Parameter Prompt Dialogs 
The Parameter prompt dialogs may look very different depending on the type of parameter and 
the text that the person configuring the computation has entered in the Edit Parameter dialog. 
Below are some examples of the various prompt types. Note that the look of each prompt dialog 
type also varies depending on whether the parameter is a single value or an array and whether 
or not it has some legal values defined. See also More About Parameters and Prompt Dialogs. 

Data from Spotfire 
Use this dialog to define what data from your currently open analysis in TIBCO Spotfire should 
be used as input to this parameter. 

 

Option Description 
[Description] In most cases the text at the top of the dialog should give you 

instructions regarding what type of input is required. If you do not 
understand what data to choose, please contact the person who 
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configured the computation. 

Data table Select the data table in your current analysis from which the data should 
be picked. 

Available columns Lists the columns in the selected data table that are available for 
selection. 

Add > Moves the selected column to the Selected columns list. 

< Remove Removes the selected column from the Selected columns list. 

All rows Specifies that all rows from the selected columns should be retrieved. 

Filtered rows Specifies that only the rows remaining after filtering should be 
retrieved. 

Marked rows Specifies that only the marked rows should be retrieved. 
If multiple markings are available in the analysis, select the one to 
define your input data from the drop-down list. 

 

String 

 

Option Description 
Enter value Type a string value matching the parameter you are prompted for. In 

most cases the text at the top of the dialog should give you instructions 
regarding what type of input is required. If you do not understand what 
you should write, please contact the person who configured the 
computation. 
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Integer 

 

Option Description 
Enter value Type an integer value matching the parameter you are prompted for. In 

most cases the text at the top of the dialog should give you instructions 
regarding what type of input is required. If you do not understand what 
you should write, please contact the person who configured the 
computation. 

 

Real 

 

Option Description 
Enter value Type a real value matching the parameter you are prompted for. In most 

cases the text at the top of the dialog should give you instructions 
regarding what type of input is required. If you do not understand what 
you should write, please contact the person who configured the 
computation. 
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5.4 More About Parameters and Prompt Dialogs 
The Parameter prompt dialogs that are displayed for the end users of a computation will also 
vary depending on the choices made when creating the protocol in Pipeline Pilot. Below are 
some examples of what the resulting prompt will look like for a certain Pipeline Pilot 
configuration. In the example below, all dialogs with a blue frame come from Pipeline Pilot and 
all dialogs with a lighter blue-grey color come from TIBCO Spotfire. 

Overview: 
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Single value string without legal values: 
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Any string value can be entered. 
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Single value string with legal values: 
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Only the predefined legal values can be selected from the 
drop-down list. 
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String array without legal values: 
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Any string values can be entered. 
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String array with legal values: 
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Only the predefined values can be selected by entering 
them in the textbox. 
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6 Guide Tools 
6.1 What are Guide Tools? 

The Pipeline Pilot guide tools are five slots in the Tools menu where you can place any five 
Pipeline Pilot computations and use them directly from the Tools > TIBCO Spotfire 
Connector for Pipeline Pilot menu. The guide tools can also be incorporated in a guided 
analysis via a link in a text area. 

Example: 

 
This functionality allows the person configuring the Pipeline Pilot computations to make the 
most commonly used computations more available to the end users. 
Note: The configuration of guide tools only applies to the current document, so you can have 
different sets of guide tools in different analyses. 

6.2 Configuring Pipeline Pilot Guide Tools 
If you want to be able to use a Pipeline Pilot computation as a stand-alone tool from the Tools 
menu, or, if you want to be able to incorporate the computation in a text area of an analysis, you 
first need to configure the computation as a Pipeline Pilot Guide Tool. Always follow the steps 
in the Configuration workflow overview below when setting up guide tools. 

► Configuration workflow: 
1. Configure the protocol to run as a tool. 

Comment: This is done in the Add Computation - Select Usage Mode dialog. See 
Adding a New Computation for more details. 

2. Test the computation by selecting Run Computation.... 
Comment: Make sure that the computation works as expected. 

3. When satisfied with the result, configure the computation to run as a guide tool. 
Comment: See the step instruction below for more details. 

4. Create a link to the tool in a Text Area. 
Comment: Go to the Function page in the Insert Link dialog and select the tool from 
its predefined slot under Tools > TIBCO Spotfire Pipeline Pilot Connector. See How 
to Use the Text Area in the main TIBCO Spotfire help for more information about how 
to add links. 

5. Save the analysis. 
Note: If the configuration of the protocol needs to be changed, all steps above must be 
repeated. Hence, you must configure the computation as a guide tool once more. 
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► To specify a computation as a guide tool: 
1. Select Tools > TIBCO Spotfire Connector for Pipeline Pilot > Configure Pipeline 

Pilot Guide Tool.... 
Response: The Configure Pipeline Pilot Guide Tool dialog is displayed. 

2. Click to select the slot you wish to define. 
Comment: Use Pipeline Pilot Guide Tool &1 if this is your first configuration. 
Otherwise, use the first empty slot or the one you wish to change or update. 

3. Click Select Computation.... 
Response: The Pipeline Pilot Computation dialog is displayed. 

4. Select the computation you wish to use as a guide tool. 
Comment: Only computations that have been defined with the usage mode "From the 
'Tools' menu" will be available for selection. 

5. Click OK. 
Response: The computation is run so that you can provide any necessary parameters. 
However, this execution will not affect your current document. Once the execution is 
finished, the Configure Pipeline Pilot Guide Tools dialog is updated so the name of the 
specified computation is shown after the selected slot name. 

6. If desired, repeat steps 2 to 5 for the other slots. 
7. Click OK. 

Response: The Configure Pipeline Pilot Guide Tools dialog is closed and the guide 
tool is ready to be used. 

6.3 Details on Configure Pipeline Pilot Guide Tools 
This dialog allows you to configure five different computations that can be run directly from 
the pre-configured slots under the Tools > TIBCO Spotfire Connector for Pipeline Pilot menu. 
They can also be incorporated in a guided analysis via a link in a text area. 

 

Option Description 
Select 
Computation... 

Opens the Pipeline Pilot Computation dialog where you can select a 
computation that should be placed in the selected guide tool slot. 

Prompt Settings... Opens the Select Prompted Parameters dialog where you can select 
which values the user should be prompted for when running the 
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selected guide tool. 

Clear Computation Removes the computation from the selected guide tool slot. 

6.4 Details on Select Prompted Parameters 
This dialog is displayed when you click the Prompt Settings... button in the Details on 
Configure Pipeline Pilot Guide Tools dialog, or after you've entered all parameters when setting 
up a guide tool. 

 
The list displays all parameters for the selected guide tool. Select the parameters that should 
prompt the user for values when running the selected guide tool. 
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7 Appendix 
7.1 Third Party Software Notices 

► Pipeline Pilot (nalpp.dll) 7.5.2.300 
Copyright ©2009, Accelrys Software Inc. 
All rights reserved. 
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