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PREFACE 

Space  technology and GIS applications  continue  to be underutilized primarily because of  the 

lack  of  capacity  in  developing  countries  in  terms  of  human,  scientific,  technological, 

organizational and institutional resources in Asia‐Pacific countries, particularly least‐developed 

countries  (LDCs),  land‐locked developing countries  (LLDCs) and Small  Island developing states 

(SIDS).  

Against  this  backdrop,  the  UNESCAP  conducted  a  project  entitled  “Improving  disaster  risk 

preparedness in the Economic and Social Commission for Asia and the Pacific (ESCAP) region”, 

under the United Nations development Account 7th tranche (DA‐7). The aim of this project is to 

strengthen government capacities  in  the  implementation of  the Hyogo Framework  for Action 

(HFA),  through  the establishment  and use of  geo‐reference  information  systems  for disaster 

risk  management  (Geo‐DRM)  in  the  Asia‐Pacific  region.  Beneficiaries  were  selected  from 

disaster prone member countries in the region with a special focus on LDCs, LLDCs, SIDS as well 

as  from  other  disaster‐prone  countries.  Policy  and  decision makers  responsible  for  disaster 

management,  information,  communication  and  space  technology,  geographic  information 

systems  (GIS),  and  statistics were  identified  as  the  target  group.  In  this  context,  this project 

supports the  implementation of the five action areas of the HFA, through enhancing technical 

capacity  building  of  these  countries.  In  addition  the  project  encouraged  systematic 

development,  improve  analytical  skills,  and  maintenance  and  sharing  of  disaster  risk 

management information.  

Readily available statistical and geographical information is a life‐saving asset at the onset of a 

natural  disaster.  Unfortunately  in  many  countries  information  scattered  among  various 

agencies making  the  integration  of  information  in  DRR  a  challenging  task.  Also, when  such 

information is most needed, its availability is at its lowest and obstacles towards data collection 

are  at  their  highest  due  to  destruction,  displacements,  and  possible  security  concerns.  The 

initial response phase requires rapid decision‐making, while supporting information frequently 

takes up to months to collect.  

The current project aims to address this bottleneck through enhancing the national capacity of 

selected LDCs, LLDCs and SIDS. ESCAP has been promoting the use of online Geo‐DRM portal 

since 2011. A prototype Geo‐DRM portal based on existing disaster database  for South Asian 

Association  for  Regional  Cooperation  (SAARC)  countries  has  been  developed.  The  portal 

integrates geospatial data, disaster  information and critical socio‐economic  information;  it  is a 

highly effective platform for sharing geospatial and other  information products from different 

organizations to various stakeholders, and a tool in supporting evidence‐based decision making 

for disaster preparedness and rapid analysis/impact assessment. In the advent of a disaster, the 



Geo‐DRM aims to provide the most reliable information, to the right people, at the right time to 

enable sound, evidence‐based decision making. 

During the  implementation of the project, extensive hands‐on sessions and technical assistant 

missions  were  conducted  to  give  the  related  SAARC  member  countries  a  real  practical 

experience  in  developing  the  systems.  Training  manuals  were  prepared  with  complete 

instructions  and  illustrations  to  explain  about  installation,  operational,  and  maintenance 

procedures. Further, coaching videos were prepared as a quick and easy reference mechanism 

for the users to get a better picture about the overall process. 

This manual serves as self  learning guidebook that could be used by any agency  in a member 

state of UNESCAP,  in particular the SAARC member countries,  in  installing a Geo‐DRM portal, 

uploading  geographical  data,  sharing  data,  customizing  the  portal,  and  publishing  data.    An 

audio‐visual DVD explaining the step‐by‐step installation is also available, and this manual may 

be used in conjunction with the DVD to further assist the self‐installing process. 
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GeoNode Quickstart 
 

GeoNode is a web-based application and platform for developing geospatial information 
systems (GIS) and for deploying spatial data infrastructures (SDI). 

After this exercise you will learn the following: 

1. to register a new account to get started 

2. add a new layer 

3. create a map using your new layer 

Open a web browser and type http://203.159.29.6/ . You will get the following page. 

 

1. Register a new account 

You need to login to the system as the Administrator, in order to create a new user 

account. 
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Then go to the Admin Panel. 

 

 

 

 

You will get the access to Admin Panel as shown in the following image. 
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Add a new user and give required permissions. 

 

Now you can use the newly created User Account to login to the system. 

Optional: User Registration Process 

You can optionally configure GeoNode to allow new users to register through the web. 

New registrants will be sent an email inviting them to activate their account. Once the 

system is configured accordingly, the users can register themselves through the login 

interface. 
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2. Add a new layer 

Once you logged in to the system, you can add layers to your account. Layers are a 

published resource representing a raster or vector spatial data source. Layers also can 

be associated with metadata, ratings, and comments. 

1. To add a layer to your account, navigate to the welcome page. There the following 

toolbar can be seen: 

 

 

 

2. By clicking the Layers link you will be brought to the Layers menu where a new sub-

toolbar can be seen. This toolbar allows you to Explore and Upload layers. 

3. Now click Upload Layers and you’ll see the upload form. 
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4. You have two possibilities to add your files. You can either do that by using drag & 

drop or you choose to browse them. Be aware that you have to upload a complete 

set of files, consisting of a shp, a prj, a dbf and a shx file. If one of them is missing, 

GeoNode will warn you before you upload them. 

5. You should now be able to see all the files you want to upload. 

 

6. GeoNode has the ability to restrict who can view, edit, and manage layers. On the 

right side of the page you can see the Permission section, where you can limit the 

access on your layer. For an example, by selecting “Any registered user”, from “Who 

can view and download this data”; you will ensure that anonymous view access is 

disabled. Similarly, by selecting your username, in “Who can edit this data”; you  will 

ensure that only you are able to edit the data in the layer. 
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7. To upload data, click the Upload button at the bottom. 

8. One you upload a data set, you would get the following options.

 

9. It is recommended to enter relevant Meta Data as much as possible by clicking on 

the “Edit Metadata” option. 

 

10. Similarly you can upload GeoTIFF files to the Geo-Portal as show in the following 

image. 
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11. You can find all uploaded layer in “Explore Layers” section.  

 

 

3. Create a new map 

The next step for you is to create a map and add the newly created layers to this map. 

1. Click the Maps link on the top toolbar. This will bring up the list of maps. 
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2. To add new map; click the “Create a New Map” button and a map composition 

interface will display as follows. 

 

In this interface there is a toolbar, layer list, and map window. The map window 

contains the MapQuest OpenStreetMap layer by default. Further, there are other 

base layers such as Bing Aerial Map, MapQuest and OpenStreetMap available. 

3. Click on the New Layers button and select Add Layers. 

 

 

 

4. Now you should be able to see all the available layers. 

5. Select the layers you want to show on the map. Click Add Layers to add them all to 

the map. You may select multiple layers by pressing the CTRL key while 

selecting layers. Once you have added all the layers, press “Done”.  
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6. The selected layers are now shown on the map as follows. 
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7. To save the map click on the Map button in the toolbar, and select Save Map. 

 

8. Enter a title and abstract for your map. 

 

9. Click Save. You can find the newly created map under Maps.  
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Recommended Minimum System Requirements 

For deployment of GeoNode on a single server, the following are the bare 

minimum system requirements: 

 6GB of RAM, including swap space. 

 2.2GHz processor. (Additional processing power may be required for multiple 

concurrent styling renderings) 

 1 GB software disk usage. 

 Additional disk space for any data hosted with GeoNode and tiles cached with 

GeoWebCache.  

 64-bit hardware recommended. 

Operating System Requirements 

Linux 

Ubuntu 

The easiest way to install using APT, the standard installation management tool for 

Ubuntu and other Debian-based systems. 

CentOS/RHEL and other *nix distros 

We recommend you to download the latest release and modify the 

included install.sh and support/config.sh. GeoNode has been installed in 

CentOS/RHEL using this mechanism. 

Windows, OSX and others 

The recommended install method in these platforms is to use a virtualization 

solution, like Virtual Box, install the latest Ubuntu Linux and then proceed with the 

steps mentioned above. 

 

We would proceed with Ubuntu Linux.  
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Step 1 

The first thing you should do is head 

to  http://www.ubuntu.com/download/ubuntu/download and download Ubuntu 12.04LTS  

LiveCD 

 

Step 2 
Using your disc burning software, burn the .iso you downloaded to a CD.  

Step 3 

Before you go any further, ensure all important data is backed up in case of data loss on 

your drives. This guide assumes you have media backups of your Windows partitioned 

hard drive and you are safe to proceed. 

Step 4 

Ensure you have a network cable connected, restart your computer, and boot from the 
CD drive. 

Step 5 

The LiveCD will load up, and you'll be presented by the following box: 

 

Click "Install Ubuntu". 
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Step 6 

You will get the "Preparing to install Ubuntu" screen, as below: 

 

Step 7 

The next screen you will see is "installation type," what you see will be dependent on 
whether you have an existing Windows installation or not.  
I have divided this into three different sub-steps, to address three different scenarios. 

Step 7-A 
For those installing in a virtual machine or to hard disks without an OS you will see the 
following screen: 

 

You have two choices: 
1. Erase the entire disk and use all of it for installation -- Ubuntu will automatically 
partition your disk and proceed with installation. 
2. Select "something else" and manually create your partitions (which is covered in detail 
in step 7-C). 
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Step 7-B 

Those of you that have current Windows installations or are going to dual-boot with 
another existing OS will be presented with a screen similar to below: 

 

You have three options available: 
 
1. You can choose the first option and install Ubuntu alongside your existing OS.  
2. You can opt to replace your Windows installation with Ubuntu, allowing the installer to 
format your current partitions and automatically create new ones for Linux. 
3. You can choose "something else" and create your own partition scheme and sizing 
(covered in detail in step 7-C). 

Step 7-C 

Having selected the "something else" option you will be presented with the following 
window somewhat like below: 
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Linux recognizes and assigns IDs to drive in a different manner to Windows. In the 
above image, you can clearly see the hard disk in the list. It is identified by "/dev/sda." 
Linux recognizes drives in the following way:  
• Sda = 1st drive 
• Sdb = 2nd drive 
• Sdc = 3rd drive and so on  
 
Partitions are also shown after the drive letters. So if there are 2 partitions on the first 
disk, they would be identified as: 
• Sda1 – 1st drive, 1st partition 
• Sda2 – 1st drive, 2nd partition 

Firstly, identify your Windows installation. In this case, it's sda1 (which is the first hard 
disk, first partition). 

Step 8 

Now we need to create a minimum of three partitions: 

Select the free space and Click "Add". The following box will appear: 

Creating boot partition 

 

 

 

Set partition size to 200 MB, file system to Ext4 and Mount Point to /boot. 

Click OK once you have finished setting the partition information and you will return to 
your partition screen, now showing the boot partition you just created. 
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Creating SWAP partition 

Select the free space and Click "Add". 

 

 

Set partition size to 4096 MB (i.e. 2GB) and use as option to swap area. 

The size of the SWAP partition needs to be set at least the size of your available RAM. If 
you have enough of hard disk capacity it is recommended to use double the size. So if 
you have 2GB of RAM, set it to either 2GB or 4GB. 

Click OK once you have finished setting the partition information and you will return to 
your partition screen, now showing the SWAP partition you just created. 
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Creating root partition 

Select the free space and Click "Add". 

 

 

 

Set partition size to all available free space, file system to Ext4 and Mount Point to “/”. 

So in the above example the resulting partition table would have: 
/dev/sda1 is your Windows partition. 
/dev/sda2 boot partition 
/dev/sda3 is your SWAP space 
/dev/sda4 is your root partition 
 
Once you are done with the partitioning, click install now and proceed to the next step. 
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Step 9 
As the installation starts to copy the required files to the hard disk, you will be presented 
with a screen to select your location.  
 

 
 

Just double check it is correct location, and then select continue. 

Step 10 
The next screen to appear will be keyboard layout: 

 

Ensure the correct option is selected. Choose English US.  
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Step 11 
You will now be greeted by the "who are you" screen, ready for you to fill out with your 
user details: 

 

The computers name and username will automatically populate when you type your full 
name. You can however edit them as you please. Fill in the details and then click 
continue. 

Step 12 
The installation information screens will now appear as Ubuntu continues the installation: 
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Step 13 

Once the installation has finished, you will be presented with the following box: 

 

Select "restart now" and when requested, remove your installation CD and reboot. 

Step 14 

If  Ubuntu is the only OS the computer will boot directly into Linux. If you're dual-booting, 
you will see the GRUB menu appear something similar to below 

 

Select Ubuntu from the list, if it is not the default selection 

Step 15 

Enter you username and password and login to Ubuntu Desktop environment 

 

Now your machine is ready with working Ubuntu Platform. 
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Reference 

http://www.ubuntu.com/download/desktop 

http://docs.geonode.org/en/latest/tutorials/admin/install/quick_install.html 

http://www.techspot.com/community/topics/step‐by‐step‐beginners‐guide‐to‐installing‐ubuntu‐11‐

10.172128/ 
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Setup and Configure GeoNode 

Quick Installation Guide 

The following is a quick guide to get GeoNode up and running in your computer. 

Recommended Minimum System Requirements 

For deployment of GeoNode on a single server, the following are the bare 

minimum system requirements: 

 6GB of RAM, including swap space. 

 2.2GHz processor.  

 1 GB software disk usage. 

 Additional disk space for any data hosted with GeoNode and tiles cached with 

GeoWebCache. A decent baseline size for GeoNode deployments is 100GB. 

 64-bit hardware recommended. 

Setup GeoNode 

We assume that your computer satisfy the above system requirements and ready with 

Ubuntu 12.04 OS platform. Follow the following steps to install GeoNode. 

 First, make sure you have the add‐apt‐repository binary available 

sudo apt‐get install python‐software‐properties 

 Set up the GeoNode PPA repository 

sudo add‐apt‐repository ppa:geonode/testing 

 Install the package. This step will also automatically download all necessary 

dependencies: 

sudo apt‐get update 

sudo apt‐get install geonode 
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Configure GeoNode 

Configuring the IP address 

By default GeoNode runs in http://localhost/, but when running in production it 

needs to know the public IP address. 

To configure it, edit the SITEURL setting in local_settings.py; which can be found 

in your /etc/geonode/local_settings.py folder. 

Finding your IP address 

Open a terminal and type “ifconfig”. 

 

Backup local_settings.py 

It is recommended to take a backup of your “local_settings.py” before you make 

any changes. 

$ cd /etc/geonode/ 

$ sudo cp local_settings.py local_settings.py.backup 
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Set your IP address 

To set the IP address to be used in your GeoNode Application you can run: 

$ sudo geonode‐updateip <key in your IP‐ADDRESS> 

You can observe the performed change by opening the file “local_settings.py”.  

$ sudo nano /etc/geonode/local_settings.py 

 

 

 

 

 

 

 

 

 

 

Press Crtl + X to exit from the editor. 

Creating a super user 

For all the administrative purposes; it is required to create an Admin User Account. 

To create a superuser you can run the following command: 

$ geonode createsuperuser 

 

Your IP
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To make it unique for the training purpose; set the admin username as “admin” and 

password as “gic”. It is recommended to use a strong password for the admin user when you 

setup a server for production environment.  

 

 

 

 

 

Set the correct GeoServer Proxy URL value 

Navigate to http://localhost/geoserver, log in and click on the Global link in the 

Settings section. You can use the admin user login credentials you just created. 

 

Your Name
Your email



26 
 

Find the Proxy Base URL text field, put the complete address there. 

 

 

 
 

 

 

 

 

 

 

 

 

Set the Site Name 

Login to the GeoNode using your administrator account. (admin/gic) 

Then go to the Admin Panel. 

 

 

 

 

Go to Site Administration 
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By default there is a site named “example.com”. Click on that site and open the detail 
view of that site. Change the display name to a something relevant. 

 

 

 

 

 

 

 

 

Observe the difference in the title bar of your web browser. 

 

 

 

 

 

 

 

 

 

<your‐country‐name>‐GeoPortal
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Create a new user account (to upload data) 

Now create another user account as explained in previous session.  

Admin Panel > Auth Section > Users > Add new user 

 

 

 

 

 

 

 

 

Give all the necessary permissions for the user and save.  

You can create any number of users with different privileges depending on your 
need. 

Creating Groups 

Optionally you can create a group and assign required permissions for the group; if 
more than one user needs to be given the same permissions. 

 

Then you can assign users to the group rather than assigning privileges individually. 

Use your country name
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Now basic GeoNode setup and configuration is done. Now logout from the Admin 
User and login from the User Account you just created. 

 

 

 

 

 

 

Enjoy uploading your data to the newly configured GeoNode! 
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Usage of the GeoNode’s Django Administration Panel 
 
GeoNode has an administration panel based on the Django admin which can be used to do 
some database operations. Although most of the operations can be done through the normal 
GeoNode interface, the admin panel provides a quick overview and management tool over 
the database. 

Accessing the admin panel 

Only the staff users (including the superusers) can access the admin interface. 

Note 

User’s staff membership can be set by the admin panel itself, see how in the Manage users 

and groups through the admin panel section. 

The link to access the admin interface can be found by clicking in the upper right corner on 
the user name. 

 

 

 

 

 

 

Manage users and groups through the admin panel 
The site administration section “Auth” has two links to access the Users and Groups 
sections, as follows. 

 

Adding a user 

By clicking on the “add” link on the right of the Users link, it is possible to add a new user to 

the GeoNode site. A simple form asking for username and password will be presented as 

follows. 
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Upon clicking “save”; a new form will be presented asking for some personal information and 

the rights the user should have. For a normal unprivileged user, it is sufficient to just fill the 

personal information and then confirm with “save”. If the user has to access the admin panel 

or be a superuser; it’s required to tick the “staff” and “superuser” checkboxes.  

 

 

 

 

 

 

 

 

 

 

 

But if you need to provide some specific privileges to a user; you need to explicitly define 

them. 
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Changing a user 

If you want to modify an existing user; click on “Users” then on a username in the list. 

 

 

Configuring User Registration (Optional) 
 

By default, the admin user could create new users or grant privileges to an existing user to 
create new users. If you need to allow the users, themselves to register with your GeoNode; 
you need to enable some setting as described below. In the scope of this workshop; this is 
not required. 

To allow new user registration: 

1. Set up the email backend for Django and add the appropriate settings to 

/etc/geonode/local_settings.py 
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For example: Assume you are going to use gmail SMTP server 

EMAIL_BACKEND = 'django.core.mail.backends.smtp.EmailBackend' 

EMAIL_HOST = 'smtp.gmail.com' 

EMAIL_HOST_USER = 'yourgmail@gmail.com' 

EMAIL_HOST_PASSWORD = 'your‐gmail‐pw' 

EMAIL_PORT = 587 

EMAIL_USE_TLS = True 

2. One week activation window: 

Edit /usr/local/lib/python2.7/dist-packages/geonode/settings.py file and set the activation 

window. 

ACCOUNT_ACTIVATION_DAYS = 7 

3. In the same settings file set 

REGISTRATION_OPEN=True 

4. Restart apache service 

$ sudo service apache2 restart 

 

Now you should be able to see the “Register” option. New registrants would be sent an email inviting 

them to activate their account. 
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Adding a Group 
It is possible to create new groups with set of permissions which will be inherited by all the 
group members. Say, you want to employee some people to just to upload data only. So, 
you can create login IDs for them but rather than assigning permissions individually; you 
may create a group and assign all the permissions required to upload data and then assign 
each data entry user.  

 

 

Layer Permissions 
 

Now that we’ve already created some users, we will take a closer look on the security of 
layers, how you can protect your data not to be viewed or edited by unwanted users. 

Hint 

As already mentioned before; it is important to know that a superuser does 
have unrestricted access to all your uploaded data. That means you cannot 
ban a superuser from viewing, downloading or editing a layer! 

The permissions on a certain layer can already be set when uploading your files. 

When the upload form appears (Layers -> Upload Layer) you will see the permission 

section on the right side: 
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As it can be seen here, the access on your layer is split up into three groups: 

 view and download data 

 edit data 

 manage and edit data 

The difference between manage and edit layer and edit layer is that a user assigned 

to edit layer is not able to change the permissions on the layer whereas a user 

assigned to manage and edit layer can change the permissions. You can now 

choose whether you want your layer to be viewed and downloaded by 

 anyone 

 any registered user 

 a certain user (or group) 

To set the permissions on a layer which is already being added, click on the layer. 

You will get the layer preview with many options as shown below.  
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Once you click on the “Edit Permission”, you will get the same permission menu you got 
during the layer upload process. 

Map Permissions 
 

The permissions on maps are basically the same as on layers. Click on any map and scroll 
down till you see the permission options. 

 

Document Permissions 
 

The permissions for documents are also same as the above two cases. You may set the 
permission while uploading the documents or you may change permissions by editing the 
document permissions later. 
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Creating/Saving a new map 
 

In a previous session we learnt about the process of creating maps using some data layers. 
In the following figure, you can observe a map with three data layers including two vector 
layer and a raster layer. Once you organize the layers and finished with the layer styling; you 
need to save the map at first. 

 

 

 

 

 

 

 

 

 

 
The created maps can be seen in Explore Maps section. 

Publishing a new map 
 
Once you saved your map; it is possible to publish it in order to use it in any other web site. 
By doing this, you can display your map in any web server hosted anywhere in the world. 
Once you click on “Publish Map” option you would get a URL of the published map as shown 
in the following image. 
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Now you can copy and paste the generated HTML code and place it in any web page.  

Please check the following sample HTML code 

 

 

 

 

 

 

 

This code is included in a web page call “geonode.html” and it is running in a different 
server. Check the URL of the following image. 

 

 

 

 

 

 

 

 

 

 

 

In this way, you can make your map available in any web site running anywhere in the world. 
Further, if you publish a map in this way; people would only be able to view your map but 
would not be able to download the data. 

 

 

 

 

<TABLE width="900" > 

<TR> 

<img src="logo.jpg" width="900" height="80" align="left"">   

</TR> 

<TR> 

   <iframe style="border: none;" height="400" width="600" 

src="http://203.159.29.6/maps/33/embed"></iframe></br> 

</TR> 

</TABLE> 
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Printing Maps 

To original Scale 
It is possible to print the maps available in Explore Maps sections. Go to the Map View and 
click on “Print” icon. First let us try to print the above map to its original scale. Observe the 
scale of the original map and that of the map print preview. The preview picks the closest 
scale of the original map. 

 

 

 

 

 

 

 

 

 

 

 

In the map preview, you can select the paper size (only A4 and legal), Resolution (75 dpi, 
150 dpi, 300 dpi). Also you can select whether to print the legends or not. You may update 
the Title and abstract of the image. 

In the generated map, you can find map elements such as Map Title, Map Body, Map Scale, 
Legends, Scale Bar, Abstract of the Map etc. Find below the printed map of the above 
example to its original scale. 
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To a Smaller Scale 
 

Now, if you want to print a small area of the map; you need to zoom in to the interested area. 
There are different scales available in the map preview. You need to select suitable scale in 
order to show the interested area. Simply zoom in or zoom out may not work well. It is 
recommended to zoom in to the interested area of interest by changing the map scale from 
the preview window. You may pan it to the correct area after selecting the desired scale. 
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The above figure shows a printed map of a smaller area of the same map we printed earlier. 
GeoNode printing module help you to print a map up to 1:25000 map scale. In the above 
figure, the scale is set to 1:200000 while in the original map preview it was 1:500000. 
Following is the map print of 1:200000 scale of the same map. 
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To a Larger Scale 
If you need to print a larger area of the earth surface, you need to select a larger scale. But 
there is a maximum limit in GeoNode printing module which is 1:4000000. So it is not 
possible to print larger areas such as continents using this option. 

 

 



43 
 

Open Maps on Google Earth 
 

Using Google Earth Plugin 
It is possible to open any data layer or a map on Google Earth. GeoNode is provided with a 
plugin to open any map on Google Earth without even downloading it. You need to have 
Google Earth installed in your machine. 

 

 

As a KML 
Alternatively, you can download the KML format of a data layer and open it on Google earth Client. 
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Theming your GeoNode project 
 

There are a range of options available to you if you want to change the default look and feel 

of your GeoNode project. Since GeoNode’s style is based on Bootstrap which is a powerful 

framework for web development; you will be able to make use of all that Bootstrap has to 

offer in terms of theme customization. The following image shows the default appearance of 

GeoNode interface. 

 

Logos and Graphics 

GeoNode intentionally does not include a large number of graphics files in its interface. This 

keeps page loading time to a minimum and makes for a more responsive interface. That 

said, you are free to customize your GeoNode’s interface by simply changing the default 

logo, or by adding your own images and graphics to deliver a GeoNode experience the way 

you envision int. 

Your GeoNode project has a directory already set up for storing your own images. You 

should place any image files that you intend to use for your project in this directory (cd 

var/www/geonode/static/geonode/img). 

Let’s walk through an example of the steps necessary to change the default logo. 

1. Change into the img directory: 

$ cd var/www/geonode/static/geonode/img 

2. If you haven’t already, download your logo image. Now copy it to this location: 

$ cp <path-to-your-logo>/yourlogo.jpg . 

$ cd ../../.. 
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3. Override the CSS that displays the logo  

Edit “/var/www/geonode/static/geonode/css/site_base.css” with your favorite editor and add 

the following lines. Make sure to update the width, height, and URL to match the 

specifications of your image. 

 

 ! Very Important 

You should always backup the original file before you change any configuration file. 

Otherwise certain misconfiguration may cause complete failure in your system. 

 

$ cd /var/www/geonode/static/geonode/css/ 

$ sudo cp base.css base.css.org 

$ sudo nano base.css 

Now change the following lines 

.nav‐logo { 

    width: 500px; 

    height: 50px; 

    background: url(../img/GIC‐logo.JPG) no‐repeat; 

} 

4. Restart your GeoNode project and look at the page in your browser: 

 

$ sudo geonode collectstatic ‐v0 

Now you can see your company logo instead of GeoNode default logo. Visit your site at 
http://localhost/ or http://<your-ipaddress> 
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Changing Background Color 

In the last section you already learned how to override GeoNode’s default CSS rules to 
include your own logo. You are able to customize any aspect of GeoNode’s appearance this 
way.  

Follow the following instructions to change the background color of the header to match the 
color in our logo graphic. 

1. Reopen /var/www/geonode/static/geonode/css/base.css in your editor and edit the following 

rule 

$ cd /var/www/geonode/static/geonode/css/ 
$ sudo nano base.css 

2. Add a rule to change the background color of the header to match the logo graphic we used: 

.navbar .navbar‐inner { 

    background: #0e60c3; 

} 

! Note 

To find the hexadecimal values of different colors; you may refer to the web link at 

http://www.javascripter.net/faq/rgbtohex.htm 

3. Restart your GeoNode project and look at the page in your browser: 

 

$ sudo geonode collectstatic ‐v0 

Now you can see the change in background color. Visit your site at http://localhost/ or 

http://<your-ipaddress> 
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Changing Menu Bar Color 

Similarly you can change the color of the menu bar by performing the following change to 
the same file. 

1. Reopen /var/www/geonode/static/geonode/css/base.css in your editor and edit the 

following rule 

$ cd /var/www/geonode/static/geonode/css/ 
$ sudo nano base.css 

2. Add a rule to change the background color of the header to match the logo graphic we used: 

.nav‐box { 

    background: :#0b803e; 

} 

3. Restart your GeoNode project and look at the page in your browser: 

 

$ sudo geonode collectstatic ‐v0 

 
Templates and static pages 

We have changed the default logo and adjusted the colors in header area and menu bar. 

The next step is to update the content of the homepage itself. Your GeoNode project 

includes basic templates that you will use to change the content of your pages. 

 

Customizing the home page 

GeoNode uses Django’s template engine. The folder “/etc/geonode/templates” is empty by 

default but it is above other folders in the template lookup hierarchy. This means that it is 

possible to copy any html template to that location and it will take presence. Let’s start by 

doing the following: 

$ cd /usr/local/lib/python2.7/dist‐packages/geonode/templates 
$ sudo cp index.html /etc/geonode/templates 

The copy of index.html that was just created takes precedence over the default one, the text 

in the main section can be changed there and a reload of the web page in the browser will 

show the updated version. 



48 
 

Note 

Changes to templates are picked up automatically and do not require a server restart. 

Now let’s make some changes to the index.html file we just copied to “/etc/geonode/templates” 

1. Open “/etc/geonode/templates/index.html” in your editor  

$ cd /etc/geonode/templates 
$ sudo nano index.html 

2. Edit the <h1> element to something other than “Welcome”: 

 <h1>{% trans "Welcome to GIC‐GeoPortal" %}</h1> 

3. Edit the introductory paragraph to include something specific about your GeoNode 

project: 

<div class="intro"> 
   <p> 
      {% blocktrans %} 
           Geoinformatics Center Geoportal provides a 
platform to magange geospatial data and maps in a 
convenient and user friendly manner. If you wish to build 
your your GeoNode. 
       {% endblocktrans %} 
    </p> 
</div> 

4. Now save and close the edited index.html file. 

5. Now browse http://localhost or http://<your-ipaddress>. You should find your home page 

with your own customized text. 
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Temporary Adding an External WMS 
 

The default Geo Explorer view consists with some base layers and some default 
data layers. The most of the data layers are from the local WMS server running in 
the Geo-Portal.  As shown in the following diagram, the system shows all the 
data layers available in the “My GeoServer WMS” and few other default layers.  

 

 

 

 

 

 

 

 

 

 

 

 

 
It is possible to add External WMS Sources to this Map View too. This feature would 
help using data layers from different WMS servers to create your maps.  Following 
are the instructions to add an external WMS source. 

1. Identify an External WMS  
 

First of all, you need to identify an external WMS source. Note, in this demonstration, 
our Geo-Portal is running in the IP Address 203.159.29.6 and as shown in the above 
diagram there are many data layers are available in the same. Now consider another 
Geo-Portal instance running in the IP Address 203.159.29.8 as shown in bellow 
diagram. There is only one data layer available in that portal. 
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2. Adding the External WMS to Map View 

Now let’s try to add this external WMS source to our map view. Click on Add Layer 
button 

 

 

 

 

Then select “Add New Server” 
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And now enter the WMS URL of the identified WMS Server. 

 

 

 

 

 
 

This should result a new WMS server entry in available layer list. Observe that the 
new WMS source shows the only data layer available in the WMS Server. 

 

 

 

 

 

 

 

 

 

3. Security Enhancement 

You can add external WMS to the Map View by following above instructions up to 
GeoNode 2.0 beta version. But starting from GeoNode 2.0 release, this feature has 
been limited to controlled access by introducing additional security measures. The 
administrator of the Geo-Portal needs to define the External WMS sources which 
users could temporary add to the Map View.  The administrator needs to configure 
the URLs or IP Addresses of the external WMS sources in the 
/etc/geonode/local_setings.py. 
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$ cd /etc/geonode/ 

$ sudo nano local_settings.py 

 

Then add the following entry to this file 

PROXY_ALLOWED_HOSTS = ('ip‐of‐GeoNode','ip‐of‐ext‐wms‐server',) 

If you go with the example scenario here the entry should be like 

PROXY_ALLOWED_HOSTS = ('203.159.29.6','203.159.29.8',) 

Note 

It is very important to follow the exact syntax given in the above example. Observe the 

colons, commas and parenthesis.   

 

After adding this entry, make sure to restart apache web server. 

$ sudo service apache2 restart 

 

Will People get access to all my data layers in this way? 

You may wonder whether your data are safe, if people can access them by 
connecting as an external WMS. But you need not to worry. By connecting your 
server as an external WMS source, people could access the data layers which you 
have shared with everyone. The following demonstration would clear your doubts.  

You have observed there was only one data layer in our external WMS. But actually 
there were two data layers with different permissions. One was shared with everyone 
and the other layer was opened only for registered users. 
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Permanently Adding an External WMS 
The process explained above would add an external WMS server to the Geo 
Explorer Map View for a given session. If you refresh your browser or you start 
another session you have to manually add it again.  

But it is possible to permanently add an external WMS source to the “Available 
Layer” list.  

Note 

Make sure the external WMS server is 24 x 365 up and running server before permanently 

adding it to layer tree. Otherwise it will give error message every time  you visit the Geo 

Explorer Map View 

Let’s add the same External WMS source to Layer List in our Geo-Portal. By default 
fallowing entries are in our layer list. 
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Open /etc/geonode/local_setting.py. 

$ cd /etc/geonode/ 

$ sudo nano local_settings.py 

Now add the following entry. Let’s name the new WMS server as “Remote WMS” 

{ 
    "source": { 
        "ptype": "gxp_wmscsource", 
        "url": "http://203.159.29.8/geoserver/wms", 
        "title": "Remote WMS", 
        "restUrl": "/gs/rest" 
     } 
  }, 

 

You need to restart apache after that. 

$ sudo service apache2 restart 

 

Now the newly added external WMS source should be permanently there in the 
Layer Tree. 
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Permanently Adding a Base Map 
 

Other than the WMS data sources, it is possible to add Base Maps to the Geo 
Explorer Map View. Following are the default Base Maps provided in the GeoNode 
based Geo-Portals. 

 

 

 

 

 

 

 

 

 

 

Open /etc/geonode/local_setting.py. Always make a backup of the file before editing 
it. 

$ cd /etc/geonode/ 

$ sudo cp local_settings.py local_settings.py.bak 

$ sudo nano local_settings.py 

Now add the following entry.  

  { 
    "source": { 
         "ptype":"gxp_googlesource", 
                 }, 
    "group":"background", 
    "name":"SATELLITE", 
    "visibility": False, 
    "fixed": True, 
  }, 

 

You need to restart apache after that. 
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$ sudo service apache2 restart 

Now the newly added Google Satellite Base Map should be permanently there in the 
Base Map List. 

 

 

 

 

 

 

 

 

 

 

 

 

Will it be Google Satellite only? 

No, once you add Google Satellite to your base map list it is possible to call Google 
Roadmap, Google Hybrid, Google Terrain maps to your map view. 

When you go to Available Layer list you can see an additional entry named “Google 
Layers” 
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Now if you select the newly added Google Layers list, you can find the available 
google map layers. 

 

 

 

 

 

 

 

 

Now it is possible to add any of these layers to your map view. 
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Accessing Geo-Portal Data via Quantum GIS 

It is possible to access data layers in the Geo-Portal via Quantum GIS desktop 
application. Quantum GIS supports populating data from various data sources such 
as vector files, raster files, Postgres/PostGIS databases and WMS sources. 
Therefore, we can define our Geo-Portal as a potential WMS source in QGIS and 
retrieve data from the same. This can be very useful feature as we can use available 
data in the Geo-Portal directly from QGIS desktop application where we can 
integrate with other data and do many GIS analysis. But it has to be noted that the 
data layers populated from Geo-Portal are loaded as WMS hence feature data are 
not available for analysis. 

1. Making a connection to Geo-Portal 
 

Click on “Add WMS Layer” icon 
 

  

 

Create a new WMS Connection to your Geo-Portal by define the WMS URL  
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2. Connecting to WMS Source 
 

Now it is possible to connect to the WMS Server using the new connection. Select 
the connection you just prepared and press connect. You will see the available 
layers in your Geo-Portal. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note 

In this case also, it is possible to access the data layers which have been provided with 

open access. That is, the data layers where permissions had been set to share with 

“Anyone” would be visible in this manner.   
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3. Populating data to QGIS 
 

Now select the required data layers and press “Add” to bring them in to Map View 
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Backing up your system 
 

 

In order to completely backup a GeoNode installation requires that each separate 
component of GeoNode be tackled separately. There are separate backup files for 
Geonode/Django and GeoServer. 

Consider the term “Original Geo-Portal” is being used to refer the Geo-Portal which 
we need to backup. The term “New Geo-Portal” is used to newly installed Geo-Portal 
for restoration purpose. 

1. Backup Configuration files 
 

First you need to stop all required services prior to back up your system. Backup 
following files and folders in the original Geo-Portal. 

 

 

 

 

 

 

 

 

 

 

 

Original Geo-Portal 

In this example the original Geo-Portal is running in IP Address 203.159.29.8 

Let’s assume we have another Geo-Node instance running in 203.159.29.154 and 
we consider that as the New Geo-Portal. 
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New Geo-Portal 

 

Now consider backing-up all the required files and folders. 

$ sudo service apache2 stop 

$ sudo /etc/init.d/tomcat7 stop 

$ cd /home/gic 

$ mkdir backups 

$ cd backups 

$ tar ‐cvzf geonodeConfigBackup.tgz /etc/geonode 

$tar ‐cvzf geonodeDataBackup.tgz  /var/lib/geoserver/geonode‐ 
data/ 

$ tar ‐cvzf geonodeCSS.tgz /var/www/geonode 

$ sudo service apache2 start 

$ sudo /etc/init.d/tomcat7 start 
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2. Restoring the Look and Feel 
Copy the backed-up geonodeCSS.tgz file to the new Geo-Portal. Let’s assume we 
have copied the geonodeCSS.tgz file to /home/gic/remote-backup folder of the new 
Geo-Portal. 

 

$ cd /home/gic/remote-backup 

$ sudo service apache2 stop 

$ sudo /etc/init.d/tomcat7 stop 

$ sudo tar ‐C / ‐xvzf geonodeCSS.tgz 

$ sudo service apache2 start 

$ sudo /etc/init.d/tomcat7 start 

 

If you browse New Geo-Portal, you should observe the difference in appearance. 
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3. Restoring templates 
Note the front page contents of Original and New Geo-Portals 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

Original Geo‐Portal 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

New Geo‐Portal 

Let’s try to restore the contents of index.html. 

Go to Original Geo-Portal and copy the index.html at /etc/geonode/templates. 

$ cd /etc/geonode/templates 

Now copy the index.html to New Geo-Portal backup directory (/home/gic/remote-
backup). You can use “scp” command to remotely copy the file. Otherwise you may 
use a thumb drive to transfer the file.  

Note 
Make sure to change the username, IP Address and backup directory path etc. of 
the following command, according to the credentials of your system. 

 

$ cd /etc/geonode/templates 

$ scp index.html gic@203.159.29.154:/home/gic/remote-backup 

Now move to New Geo-Portal and copy the index.html to /etc/geonode/templates of 
the New Geo-Portal 

$ cd /home/gic/remote‐backup/ 

203.159.29.154 203.159.29.8 
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$ sudo cp index.html /etc/geonode/templates/ 

Now open your browser and access the New Geo-Portal and observe the changes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Backing-up the Database	

This time we will learn how to back-up the “geonode” database and restore it later. 
Observe that we have only two data layers in our Geo-Portal. 

 

 

 

 

 

 

 

 

203.159.29.154
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Make a backup of the GeoNode database (PostgreSQL needs to be running): 

$ cd /home/gic/backups/ 

$ sudo ‐u postgres ‐i pg_dump ‐c ‐Fc geonode > geonodedb.backup 

 

Now let’s add some more data layers to our Geo-Portal 

 

Now there are four data layers in the Geo-Portal. Let’s assume we experienced a 
database crash at this point. Since we have a backup of our database at an earlier 
occasion; we can try to restore it to that state. Obviously, we would lose the data we 
uploaded after performing the database backup. 
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5. Restoring to a previous state 

First, stop all relevant services. 

$ sudo service apache2 stop 

$ sudo /etc/init.d/tomcat7 stop 

PostgreSQL needs to be running 

$ sudo service postgresql start 

$ sudo ‐u postgres psql 

Then you command prompt changes 

postgres=# 

postgres=# drop database geonode; 

DROP DATABASE 

postgres=# 

postgres=# create database geonode; 

CREATE DATABASE 

postgres=# 

Press Ctrl+z to escape this prompt. Now we have deleted the “geonode” database 
and created a blank database with the same name. Next, we need to restore the 
database backup to the newly created empty database. 

We may use a different approach to perform this task. Let’s install a GUI tool called 
“pgAdmin III” in our Ubuntu Linux system and try to access the database system via 
that. 
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Open pgAdmin III application and create a connection to the database 

 

 

 

 

 

 

For that, you need to know the login credentials. You can find them from 
local_settins.py file 

$ cd /etc/geonode 

$ nano local_settings.py 

 

DATABASE_ENGINE = 'postgresql_psycopg2' 

DATABASE_NAME = 'geonode' 

DATABASE_USER = 'geonode' 

DATABASE_PASSWORD = 'Tw2ogHrG' 

DATABASE_HOST = 'localhost' 

DATABASE_PORT = '5432' 

 

Using these login credentials, create a connection to the database management 
system. 
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You should observe an empty database call “geonode”. Right-click on the database 
and select “Restore” option and point to the database backup we obtained. 
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Now, start all relevant services. 

$ sudo service apache2 start 

$ sudo /etc/init.d/tomcat7 start 

 

If you access your Geo-Portal, there would be only two data layers after the restore.  
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Working on Data Resources for Disaster Response using Quantum GIS (QGIS) 

1. Available data online 

1.1 USGS Earthquake Data 

USGS provides earthquake worldwide event.   

http://earthquake.usgs.gov/earthquakes/map/ 

Available format:  

 KML (Keyhole Markup Language) – Allow to select which magnitude to display 

 GeoJSON – A format for encoding a variety of geographic data structure 

 CSV (Comma Seperated Values) – Able to create location using lat/lon using QGIS 

Practice:  

1) Browse to http://earthquake.usgs.gov/earthquakes/map/ > Download file 

2) In September 2011, Earthquake at Magnitude 6.9, Depth 20 km occurred in India-Nepal 

Border Region Browse to  the link below and download GIS File (HAZUS.Zip) 

http://earthquake.usgs.gov/earthquakes/shakemap/global/shake/c0005wg6/#download  

 

 

 

 

 

1.2 Open Street Map (OSM) 

 Open data http://www.openstreetmap.org 

 Free to use it for any purpose as long as you credit OpenStreetMap and its 

contributors.  

 Free to alter or build upon the data in certain ways, you may distribute the result only 

under the same license.  

Practice: Download vector baseline  

1) Browse to http://downloads.cloudmade.com/  

2) Select Asia > Southern Asia > Nepal > Nepal_shapefiles.zip > Save and Unzip 

3) Data available: Administrative Boundary, Highway, POI (i.e., school, hospital) 

 

 

Note: 

PGA – Peak Ground Acceleration 

Note: 

Save download data to use in GIS Application exercise 
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1.3 Digital Elevation Model – Aster GDEM 

Advanced Spaceborne Thermal Elevation Map (Aster) Global Digital Elevation Map 

(GDEM), In cooperation between the Ministry of Economy, Trade and Industry of Japan 

(METI) and the National Aeronautics and Space Administration (NASA) on a project to 

develop ASTER GDEM, a DEM data which is acquired by a satellite-borne sensor 

"ASTER" to cover all the land on earth [http://asterweb.jpl.nasa.gov/gdem.asp]. 

 

GDEM Available Sites:  

 National Aeronautics and Space Administration (NASA) 

http://reverb.echo.nasa.gov/reverb/#utf8=%E2%9C%93&spatial_map=satellite&spa

tial_type=rectangle  

 U.S. Geological Survey (USGS) Global Data Explorer http://gdex.cr.usgs.gov/gdex/  

 Japan Space Systems http://www.jspacesystems.or.jp/ersdac/GDEM/E/index.html  

 

Practice:  

1) Browse to http://gdem.ersdac.jspacesystems.or.jp  

2) On the left menu > Search 

3) Selection options (i.e. Select Tiles by polygon, Select Tiles by shapefile)  

4) Try: Select Tiles by polygon > Start > Click and close loop > OK > Next  

 

 

 

5) Check or Unchecked to download  

 

 

 

 

 

 

 

 

Note:  

If loop is not closed, system will ask to fix polygon > YES 
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6) In order to Download file, users are requested to register   

 

 

 

 

 

 

 

 

 

 

 

1.4 High Resolution Imagery   

 Commercial Earth Satellite imaging – Digital Globe www.digitalglobe.com  

Practice:  

1) Browse Digital Globe: https://browse.digitalglobe.com  

2) Select Area (i.e., Kathmandu, Nepal)  

a. Drawing polygon (i.e., drag box, point and click) 

b. Select by user shapefile 

3) Select Modify Filter (i.e., acquisition start date/end date) > Click Continue 

4) On Main Map Page > Click Search 
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          Source: Help (DigitalGlobe) 

5) Results display images meet user setting criteria  

6) Image Resize > Max available resolution > Right Click > Save Picture As 

[QB_04052013.png]  

 

 

 

 

 

 

 

 

 

 

7) Download > Selected Strips Shape File [This will be used in the next session (geo-

reference)] 

 

 

 

 

 

 

 

Note: 
 Parameter Description 

Archive Search for either strips or InTrack stereo imagery. 
Sensor Vehicle Search for imagery from QuickBird 2, WorldView 1, or both. 

Maximum Cloud Cover 
Limit search results by the maximum cloud cover percentage 
within the polygon or map extent for the strip. 

Acquisition Date 
Enter a date range between April 1, 2002 and the current date to 
limit search results to imagery captured between those dates. 

Maximum off-nadir angle 
Limit search results by maximum satellite off-nadir angle within 
the polygon or map extent for the strip. 

Minimum Sun Elevation 
Angle 

Limit search results by the minimum sun elevation angle within 
the polygon or map extent for the strip. 
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1.5 Diva GIS    

 Provide free spatial country level data 

Practice:  

1) Browse: http://www.diva-gis.org/  

2) Select Country  Nepal; Subject  Administrative areas 

 

 

 

 

 

 

 

 

 

1.6 World Pop    

 World Population Data 

Practice:  

1) Browse: http://www.worldpop.org.uk/ 

2) Menu Data > Data Availability > Population  

3) Scroll Down > Asia > Nepal > Click Go to summary page 

4) Fill out information to download data 
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2. QGIS 

2.1 Introduction 

 GIS tool 

 Free and Open Source Software 

 2.2 Function  

 View – Able to view and overlay different data format (vector, raster, PostGIS, 

Delimited Text Layer) in different projections.  

 

 

 

 

 

 

 

 

 

 

 

Practice:  

1) Add Vector               

2) Dataset > Click Browse > D:\ GIS_Training\Nepal\VDC_Nepal.shp > Open 

 

 

 

 

 

 

 

3) Add Raster  

4) Locate to Folder where data is kept  D:\ GIS_Training\Nepal\Aster_Image.tiff > Open 

5) Add few dataset (i.e., earthquake) which were downloaded from USGS Website 

 

Add Vector Layer 

Add Raster Layer 
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 Create – Able to view and overlay different data format (vector, raster, PostGIS, 

Delimited Text Layer 

Practice:  

1) Create layer from a Delimited Text File or CSV format where lat/lon are available   

 

 

               

 

 

 

 

 

2) Digitize     

 Edit – Able to edit, change or modify feature or attribute table 

Practice:  

This exercise, we will geo-reference image. 

There are two ways to geo-reference image, a) apply geo-referencer in QGIS > raster > 

georeferencer; and b) convert shape file foot print to grid and copy header file to original 

(non-georeference) image.   

a) Geo-referencer 

1) Add Vector layer (qb_footprint.shp) 

2) From Menu > Raster > Georeferencer > Georeferencer >  

 

 

 

 

 

 

 

3) Menu File > Open Raster 

4) Register with coordinate: Click Add Point           > Click Upper-Left Corner at QB raster 

image > [Enter map coordination pop-up] >  Click  From  map canvas botton 
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5) Click at the Vector layer (qb_footprint.shp) at the same corner 

6) Repeat the step for all 4 corners 

7) Georeferencer Window > Click Start georeferencing 

 

 

 

 

 

 

 

 

 

b) Header file creation (Trick) 

1) Add shape file > catalog.shp > Right click > Open Attribute table > Select feature (i.e. 

QB-ACQ-date 2013-05-04) 

2) From Catalog layer > Right Click > Save Selection As…> 

E:/GIS_Training/Nepal/QB_04052013.shp (give same name as QB PNG image) 

 

 

 

 

 

             Digital Globe 

 

 

 

 

 

 

3) Add E:/GIS_Training/Nepal/QB_04052013.shp  

4) From Raster Menu > Conversion > Rasterize (Vector to Raster) [Setting] > Click OK 
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5) Raster Menu > Projections > Extract Projection > [Setting] > Click OK 

6) Copy (.prj, .wld, and .xml) files to original QB image folder 

7) Open Raster E:/GIS_Training/Nepal/QB/ QB_04052013.png 

 

 

 

 

 

 

 

E:/GIS_Training/Nepal/QB_04052013.shp 

Input (Shapefile) 
E:/GIS_Training/Nepal/QB_04052013.shp 

Output (Raster) 
E:/GIS_Training/Nepal/QB_Temp/ QB_04052013.png 

Raster size in pixels 
Width: 1377           Height: 1260 

Check from original QB image downloaded 

Input file 
E:/GIS_Training/Nepal/QB_Temp/ QB_04052013.png 

Check: Create also prj file 
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 Visualize  

 

 

 

 

 

 

 

 

 

 

 

 

 

 Analyze – Perform spatial data analysis (i.e., vector analysis, geo-processing, database, 

and management tool) 

 

 

 

 Publish – Share information, be able to create a web map service (WMS) from QGIS 

project 

Practice:  

1) Set layer (if you have not done)  

2) Project Menu > Project Properties >  

OWS Server  

[Continued in GeoNode Session] 

 

 

 

 

 

Note: 

Practice: Geo-processing techniques on spatial and its attribute through GIS Applications  
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3. Applications 

3.1 Estimation on administrative areas affected by earthquake 

1) From QGIS > Add Vector (administrative boundary) and peak ground acceleration radius 

affected by earthquake  > NPL_adm3.shp and PGA.shp 

2) Adjust symbol > Right Click > Properties > Style 

 

 

 

 

 

 

 

 

 

 

3) Intersect Admin Boundary with earthquake PGA polygon (NPL_adm3.shp and PGA.shp) 

> Vector > Geo Processing Tools > Intersect > [Setting] > OK 

 

 

 

 

 

 

 

 

 

 

4)  Vector > Analysis tool > Basic Statistics  

 

 

 

Input (Shapefile) 
E:/GIS_Training/Nepal/NPL_adm3.shp 

Output (Raster) 
E:/GIS_Training/Nepal/pga.shp 

Output shapefile 
E:/GIS_Training/Nepal/District_PGA.shp 

Quiz: 

How many districts possibly sensed by the earthquake? 

Input Field  
ID_3 (District ID) 

 XX District  
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3.2 Estimation on infrastructure affected by earthquake 

1) From QGIS > Add Vector (Nepal Place of Interest) and district affected (create from 

previous exercise 3.1  > District_PGA.shp. and Nepal_POI.shp 

2) Menu Vector >  Geoprocessing Tools > Intersect 

 

 

 

 

 

 

 

 

 

 

 

 

3) Open Attribute table > Select by Expression 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Input (Shapefile) 
E:/GIS_Training/Nepal/nepal_poi.shp 

Output (Raster) 
E:/GIS_Training/Nepal/District_PGA.shp 

Output shapefile (Point) 
E:/GIS_Training/Nepal/District_PGA_POI.shp 

Quiz: 

1. What types of Poi possibly the most affected by the earthquake? 
2. How many places in Government and Public Services and Health care possibly 

affected by the earthquake and in each level. 

Note: 
 
 Check roughly in attribute table  
 Apply query expression  

 
"CATEGORY" = 'Tourism' AND "GRID_CODE" >= 
20 
 
"CATEGORY" = 'Government and Public Services' 
AND "GRID_CODE" >= 8 AND "GRID_CODE" <= 
16 
"CATEGORY" = 'Government and Public Services' 
AND "GRID_CODE" <= 4 
 
"CATEGORY" = ‘Health care' AND "GRID_CODE" 
>= 8 AND "GRID_CODE" <= 16 
"CATEGORY" = ‘Health care' AND "GRID_CODE" 
<= 4 
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Answer 1 

 

 

 

Answer 2 

 
POI 

Sensed 
Strongly  
(20-24) 

Moderate 
(8-16) 

Weak 
(2-4) 

Government and Public  0 3 298 
Health care 0 0 43 

 

You may classify each POI types 

 
POI 

Sensed
Strongly  
(20-24) 

Moderate 
(8-16) 

Weak 
(2-4) 

Automotive    

Eating&Drinking    

Government and Public     

Services    

Health care    

Leisure    

Lodging    

Night Life and Business    

Sports    

Tourism    

 

 

 

 

 

 

 

 

POI 
Sensed Strongly 

(20-24) 
Tourism 4 
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3.3 Estimation on people affected by earthquake 

1) From QGIS > Add Vector        (E:/GIS_Training/Nepal/NPL_adm3.shp) and Table 

(E:/GIS_Training/Nepal/district_pop2001.csv) > [Setting] > OK 

 

 

 

 

 

 

 

 

 

2) Right Click on NPL_adm3.shp > Properties > Joins> Add Vector Join          [Setting] > 

OK > Apply  > OK 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
3) Check Attribute Table > NPL_adm3 > Right Click > Open Attribute Table > 

4) Export to a new layer > NPL_adm3 > Right Click > Save as > 

(E:/GIS_Training/Nepal/Processed/NPL_adm3_Pop01.shp) 

File Name 
E:/GIS_Training/Nepal/NPL_adm3.shp 

File Format 
Check: CSV (Common separated value) 

Geometry definition 
Check: No geometry (attribute only table) 

Join Layer 
District_pop2001 

Join Field 
DISTRICT 

Target Field 
NAME_3 
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5) Add (E:/GIS_Training/Nepal/Processed/NPL_adm3_Pop01.shp) > Open Attribute Table 

> Toggle Editing mode           > Open Field Calculator         > [Setting] > OK 

 

 

 

 

 

 

 

 

 

 

 

 

 

6) Repeat by Adding 2 more Columns [Area, and Pop_Den (Pop Density)]   

 

 

 

 

5) Add Earthquake PGA polygon (E:/GIS_Training/Nepal/PGA.shp) > Intersect: from Menu 

Vector > Geo Processing Tools > Intersect > [Setting] > OK 

 

 

 

 

 

 

 

 

 
 

Check: Create a new field 

“district p"

Pop2001 

Pop Den  Expression: "Pop2001" / "Area"

Area  Expression: $area

Input (Shapefile) 
E:/GIS_Training/Nepal/NPL_adm3_Pop01.shp 

Output (Raster) 
E:/GIS_Training/Nepal/PGA.shp 

Output shapefile (Point) 
E:/GIS_Training/Nepal/Processed/Pop01_PGA.shp 

QUIZ: Which province and how many 
people affected at the strongest level of 

earthquake? 



Data	Preparation	
UNESCAP	Geo_DRM	Training	

 

 

 

 

 

 

   

 



86 
 

Representing Geographic Features 
 

How do we describe geographical features? 

• by recognizing two types of data: 

– Spatial data which describes location  (where) 

– Attribute data  which specifies characteristics at that location   
(what, how much, and when) 

How do we represent these digitally in a GIS? 

• by grouping  into layers  based on similar characteristics (e.g hydrography, elevation, 
water lines, sewer lines, grocery sales) and using either: 

– vector data model   (coverage in ARC/INFO, shapefile in ArcView) 

– raster data model   (GRID or Image  in ARC/INFO & ArcView) 

• by selecting appropriate data properties for each layer with respect to: 

–   projection, scale, accuracy, and resolution 

 

GIS Data Structures 
 

• Spatial data types and Attribute data types 
• Relational database management systems (RDBMS): basic concepts 

– DBMS and Tables 

– Relational DBMS 

• Raster data structures: represents geography via grid cells 

– tesselations 

– run length compression 

– quad tree representation 

– BSQ/BIP/BIL 

– DBMS representation 

– File formats 
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• Vector data structures: represents geography via coordinates 

– whole polygon 

– point and polygon 

– node/arc/polygon 

– Tins 

– File formats 

Spatial Data Types 
• continuous: elevation, rainfall, ocean salinity 

• areas: 

– unbounded: landuse, market areas, soils, rock type 

– bounded: city/county/state boundaries, ownership parcels, zoning 

– moving: air masses, animal herds, schools of fish 

• networks: roads, transmission lines, streams 

• points: 

– fixed: wells, street lamps, addresses 

– moving: cars, fish, deer 

Attribute data types 
 

Categorical (name): 

– nominal  

• no inherent ordering 

• land use types, county names 

– ordinal  

• inherent order 

• road class;  stream class 

• often coded to numbers eg SSN but can’t do arithmetic 
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Numerical: 

Known difference between values 

– interval 

• No natural zero 

• can’t say ‘twice as much’ 

• temperature (Celsius or Fahrenheit) 

– ratio 

• natural zero  

• ratios make sense (e.g. twice as much) 

• income, age, rainfall 

• may be expressed as integer [whole number] or floating point [decimal fraction] 

Attribute data tables can  contain locational information, such as addresses or a list of X,Y 
coordinates. ArcView refers to these as event tables. However, these must be converted to 
true spatial data (shape file), for example by geocoding, before they can be displayed as a 
map. 

Data Base Management Systems (DBMS) 
 

 

 

 

 

 

 

Contain Tables or feature classes in which: 

– rows:  entities, records, observations, features: 

• ‘all’  information about one occurrence of a feature  

– columns: attributes, fields, data elements, variables, items (ArcInfo) 

• one type of information for all features 

The key field is an attribute whose values uniquely identify each row  
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Relational DBMS 
 

Tables are related, or joined, using a  common record identifier (column variable), present in 
both  tables, called a secondary (or foreign) key, which may or may not be the same as the 
key field. 

 

 

 

 

 

Goal: produce mapof values by district/ neighborhood  

Problem:  no district code available in Parcel Table 

Solution: join Parcel Table, containing values, with Geograpahy Table, containing location 
codings, using Block as key field 

GIS Data Models 
 

• Raster data model 

– location is referenced by a grid cell in a rectangular array (matrix) 

– attribute is represented as a single value for that cell 

– much data comes in  this form  

• images from remote sensing (LANDSAT, SPOT) 

• scanned maps 

• elevation data from USGS 

– best for continuous features: 

• elevation 

• temperature 

• soil type 

• land use 

 

 

Parcel Table
Parcel # Address Block $ Value

8 501 N  Hi 1 105,450
9 590 N Hi 2 89,780
36 1001 W. Main 4 101,500
75 1175 W. 1st 12 98,000

Geography Table
Block District Tract City

1 A 101 Dallas
2 B 101 Dallas
4 B 105 Dallas
12 E 202 Garland

Secondary or foreign key
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• Vector data model 

– location referenced by x,y coordinates, which can be linked to form lines and 
polygons 

– attributes referenced through unique ID number to tables 

– much data comes in this form 

• DIME and TIGER files from US Census 

• DLG from USGS for streams, roads, etc 

• census data (tabular) 

– best for features with discrete boundaries 

• property lines 

• political boundaries 

• transportation 

 

Concept of Vector and Raster 
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Representing Data using Raster Model 
 

• area is covered by grid with (usually) equal‐sized cells 

• location of each cell calculated from origin of grid:  

– “two down, three over” 

• cells often called pixels (picture elements); raster data often called image data  

• attributes are recorded by assigning each cell a single value based on the majority feature 

(attribute) in the cell, such as land use type. 

• easy to do overlays/analyses, just by ‘combining’ corresponding cell values: “yield= rainfall + 

fertilizer” (why raster is faster, at least for some things) 

• simple data structure: 

– directly store each layer as a single table   

(basically, each is analagous to a  “spreadsheet”) 

– computer data base management system not required (although many raster GIS 

systems incorporate them) 
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Raster Data Structures: Concepts 
 

• grid often has its origin in the upper left but note:  

– State Plane and UTM, lower left  

– lat/long & cartesian, center  

• single values associated with each cell 

– typically 8 bits assigned to values therefore 256 possible values (0-255) 

• rules needed to assign value to cell if object does not cover entire cell 

– majority of the area (for continuous coverage feature) 

– value at cell center 

– ‘touches’ cell (for linear feature such as road) 

– weighting to ensure rare features represented 

• choose raster cell size 1/2 the length (1/4 the area) of  smallest feature to map 
(smallest feature called minimum mapping unit or resel--resolution element) 

• raster orientation: angle between true north and direction defined by raster columns 

• class: set of cells with same value (e.g. type=sandy soil) 

• zone: set of contiguous cells with same value 

• neighborhood: set of cells adjacent to a target cell  in some systematic manner 

 



Reference 
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