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Introduction 
 

This user’s manual provides information on using the GDI Communications 
software with its products.  The GDI Communications Graphical User Interface is 
designed to enable users to communicate and configure several GDI products in 
various setups and scenarios.  This software targets users who sustain different 
levels of experience when it comes to traffic communications.   
 

The GUI is designed to allow a “man in the street” to connect to the radio and do 
basic troubleshooting.  On the other hand, it is also designed to meet advance 
requirements for testing and troubleshooting radios and modems.  Although the 
GUI was primarily made to connect and configure the SS900FH radio, it can also 
be used to connect and configure smart modems and other serial interfaced 
devices.  This new approach was developed to overcome the setbacks of the old 
utilities used to communicate with GDI’s products. 
 

The GUI contains the main functions present in other graphical interfaces used for 
the same purpose and other new features.  This enables the GUI to perform better 
and give the user a more efficient and controlled testing environment.  In this 
manual, a detailed description of the functions of the GUI will be presented.  A 
summary and a list of suggested reference Material will follow. 
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Installation 
 

System Requirements: 

Windows 98 or higher 

 

Installation Steps: 

The installation script is compressed into a “zip” file (gdiGUI.zip) for ease 
of deployment. 
After decompressing the file (“unzipping” it), run the installation script 
gdiGUI.msi. 
If there is a previous version of the GDI GUI already installed the msi will 
prompt you to remove it.  After the previous installation is removed, re-run 
the gdiGUI.msi. 
 
 
When the Setup Wizard 
appears click on the “Next” 
button. 
 
 
 
 
 
 
 
 
 
 
 
 
Leave the Installation folder set 
to the default. 
Leave the user access to “Just 
me.” 
Click on the “Next” Button. 
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Click “Next” to start the 
installation. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Wait for the installation to 
complete. 
 
 
 
 
 
 
 
 
 
 
 
Click “Close” when the 
installation is complete. 
 
 
 
 
 
 
 
 
Click on the Start button, and then select “All Programs -> GDI 
Communications -> gdiGui” to run the program. 
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Getting Started 
 

This program is designed to allow users to communicate with and configure 
SS900fh modems.  Users utilizing this software can have varying levels of 
expertise in the field from beginners to experts. 
 

 
Features 
This program includes several features including but not limited to: 
• Store and upload configuration sets to the SS900FH radio 
• Update the SS900FH firmware 
• Communicate and configure GDI SS900FH modems 
• Serial port loopback testing using the BERT function 
• Polling, Spectrum Analyzer, Power and Data Monitoring 
• Terminal Interface 

 

Compatibility 
 

This program was tested on several windows platforms.  Its is not 
compatible with Linux or other, non windows, operating systems. 

 
Scalability 
 
This software is designed to run multiple instances, if required, on the 
same workstation.  This can come in handy if the workstation has multiple 
COM ports connected to different radios and the user is running polling or 
loopback testing. 
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Using the Program 
 

Main Menu 
 

The main menu is designed to allow easy access to all the functions of the 
program.  The default view displays all the function buttons.  However these can 
be hidden and the functions can be accessed through the “Tools” menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1 – Main Menu 
 
Using the mouse to click on the GDI logo will open the default web browser to the 
GDI web site.  This user guide and other documentation can be opened through 
the “Help” menu. 
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File Menu 
 

The file menu consists of several functions including: Opening a new configuration, 

opening an existing configuration file, saving a configuration file, A list of the most recent 

files opened, printing the current configuration and exiting the program (Figure 2).   

 

 
 

The functions in the file 
menu are straight 
forward and are 
commonly used except 
for two main utilities: the 
Manual Configuration 
and the Configuration 
Wizard used to create 
new configuration files. 
 
 
 
 
 

 
Figure 2 – File Menu 
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Manual Configuration 
 

This function is used for creating 

a configuration file from scratch.   

When  

“File->New File ->Manual Configuration” is 

clicked in the File menu, an 

extended portion of the main 

menu is opened that contains all 

necessary tools to establish a 

configuration file. 

 
 

 

 

 

 

 

 

 

 

 

To get started, the firmware version must first be selected in the “Firmware Defaults” 

pop-up window.  Selecting the firmware, populates the configuration parameters that are 

on the left side of the extended section seen here in green.  When a parameter is 

selected, its value and description are loaded into the edit pull down and the description 

box.  If the parameter is of the indexed type (ie., Baud rate) the possible values are 

loaded into the pull down menu.  If the parameter is of the variable type (ie., Maximum 

RF Packet Size), only the value will be loaded.  To change a value, either use the pull 

down menu or highlight the old value and enter the new value.  All changes will be saved 

but not written to the SS900FH until the “Write” or “Write All” button is depressed. 

 

The “Load Defaults” button restores all parameters to the currently displayed version 

default settings. 
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The “File I/O” buttons allow configurations to be saved and recalled from files.  These 

files can be used to configure  multiple SS900FH modems. 
 

The “Radio I/O” buttons allow configurations to be read from or written to the currently 

attached SS900FH. 

 

To exit the setup mode and collapse the extended display, click on the “SETUP” button 

again.. 
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Configuration Wizard 
 

The configuration 
wizard was designed 
to step through the 
configuration of a 
SS900FH modem.  
Figure 4 shows the 
welcome page of the 
wizard. 
 
 
 
 
 
 
 
 
 
 
 

Figure 4 – Configuration Wizard 
 
 
The second step in the 
wizard selects the version 
of SS900FH.  Upon 
selection a picture of the 
switching configurations 
shown to the left.  The 
user can click on it to open 
a pdf file of the image. 
 
 
 
 
 
 
 
 
 
 

Figure 5 – Configuration Wizard Step 2 
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Step 3 of the wizard.  In this 

step the user is asked to 

enter the baud rate and 

parity that the radio will be 

communicating on. 

 

 
 

Figure 6 – Configuration 
Wizard Step 3 

 

 

 

 

 

 

Step 4, asks the user 

to input the hopping 

sequence the radio is 

to be operating on and 

the Vendor ID. 

 
Figure 7 – 

Configuration Wizard 
Step 4 
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Step 5 is used to set 

the radio in a repeater 

network as either: a 

repeater, a master, or 

an end node.  If the 

user selects one of the 

three options then he is 

prompt to specify 

values for addressing 

parameters. Step 5 is 

shown in Figure 8. 

 
 

 

Step 6 is where the 

network performance 

is adjusted.  Higher 

values yield more 

stable 

communications.  

Lower values 

minimize the round 

trip delay. 
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Step 7 is for adjusting 

the power and frequency 

of the  radiated RF 

signal.  One watt works 

for most applications.  

However it can be 

decreased if necessary. 

 

 

 

 

 

The last step of the 

configuration wizard, 

Figure 9, shows a 

summary of the radio 

configuration with the 

user’s changes included.  

The user can then 

upload the configuration 

to the radio.  If the user 

clicks the “Finish” button 

before uploading then all 

changes are lost. 
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View Menu 
 

The View Menu contains an option to display a Tools toolbar that will appear on the main 

page when selected (Figure 11). 

 

 

Figure 11 – View Menu 
 

 

 

 

 

Toolbars 
 
 
 
Figure 12, shows the 
Tools toolbar present 
on the main page. 
 

Figure 12 – Main 
Page with Tools 

Toolbars 
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Tools Menu 
 

The Tools Menu contains five main utilities: Terminal, BERT, Polling, Firmware Update, 
and Spectrum Analyzer. 

 
Figure 13 – Tools 

Menu 
 

 

 

 

 

 

 

 

 

 

 

Terminal Program 
The Terminal Program is a terminal emulation tools that can be used with any modem. 
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The first button on the upper left of 
this utility is the “Port 
Configuration” button which 
activates the Port Configuration” 
tool used to configure the COM 
port and its properties.  After 
configuring  the COM port, the 
terminal window turns white and 
you can start communicating with 
your device.  
 

Port Configuration: 
 

When the menu appears, the currently active port is closed and deactivated. 

 

Port Name:  When activated, the Connection Configuration tool scans the system for 

available serial communications ports.  These ports can be real hardware 

ports or they can be virtual ports. 

 

Baud Rate:  The baud rate can be selected from the pull down menu and ranges from 

1200bps to 230400bps. 

 

Flow Control:  There are three choices for flow control. 

NONE – Handshaking is turned off and the control 

signals are fixed in the transmit mode. 

HARDWARE:  Activates the control signals to control the flow of data. 

Xon/Xoff:  This is a special software control of data flow and is not yet 

implemented.  The menu item is present only for display purposes. 

 

Data Bits:  Select the number of bits per data packet.  Choices are 6, 7, or 8. 

 

Parity:  Choices for parity are None, Odd, Even, Mark, and Space. 

 

Stop bits:  Select the number of stop bits.  Choices are 1 or 2. 

 

Connect:  Activates the selected ports with the selected parameters. 
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Next to the “Port Configuration” button is the Open/Close Port toggle button.  Closing 

the port allows access to it from other programs. 

 

The Help button when activated will show help messages when the cursor is 

maneuvered over a button or window.  The button will turn green when active. 

There are two ways to exit the Terminal program.  Using the cursor, position it over the 

“X” box  found in the upper right hand corner of the window and depress the 

left mouse button.  The other way is to click on the “Exit” button. 
 

The “Clear” button, clears the text from the terminal window. 
 

The AT Command String pull down list can save up to six command strings that can be 

sent to the device by clicking on the “Send” button.  The user can also delete these 

commands by first selecting the command and then click on the “Delete” button.  The 

“Save” button saves the entire AT Command String list to a file which will be recalled 

when the program is used again. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 14 – Terminal Program 
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The “Local Echo” check box when checked, enables the printing of characters typed on 

the keyboard.  When it is not checked, The attached device must “echo” the characters 

back to the screen. 

 

“CRLFx” when checked will append carriage return (0xD) and line feed (0xA) characters 

to the end of transmitted data. 

 

“ICLFs” when checked will append the carriage return and line feed characters to 

incoming data. 

 

When “Hardware” handshaking is selected the RTS and DTR check boxes assert or 

deassert RTS and DTR.  They are disabled when the handshaking is set to “None.” 

 

The three status displays, CTS, DSR, and DCD indicate the current state of those 

signals.  When the signal is asserted the display will be green. 

 
 

Otherwise it is black. 
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BERT 
 

The “BERT Tester” is a very useful utility for testing and troubleshooting SS900FH 

modems, and other GDI modems.  It has been designed to be a general purpose BERT 

tester that can be used on a wide range of devices. 

 

The BERT tester transmits a selected data packet to the device under test.  It then waits 

for the device to send the data packet back.  A comparison is made between the 

transmitted packet and the received packet.  The test then repeats until the user 

intervenes. 
 

Unlike other windows based test programs, this program performs dynamic hardware 

handshaking.  Typically, windows based test programs use the control signal RTS and 

CTS as a means to enable the PCs COM port UART.  Data is then transmitted and 

received without control.  But this program asserts RTS and then waits for CTS to be 

asserted by the attached modem, and then transmits the selected pattern.  At the end of 

the transmission, RTS is de-asserted until the next transmission.  Before the program 

will receive data, DCD must be asserted by the attached modem.  In this way, not only is 

the data path tested but also the  control signals. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 – BERT Tester 
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The “Help” button when activated will show balloon tips that can provide the user with 

some information about each control.  The “Help” button will turn green when active.  

The “Exit” button closes the “BERT Tester” and takes you back to the “Main Page”. 

 

After the COM port is configured, the first step for running a BERT test is to select a test 

“Pattern.”  One of the five standard patterns can be used or the user can input a custom 

pattern either by typing it in or “Pasting” it from a separate source.  The pattern 

selections are as follows: 
 

User:  A default string is generated and may be used or a alternate pattern can be 

entered either by typing or by “Copy” and “Pasting” from another source of text.  

The default string is useful because it creates a waveform on an oscilloscope 

with an easily recognizable marker. 

QBF:  The following text string “THE QUICK BROWN FOX JUMPS OVER THE LAZY 

DOG 0123456789.” 

63-BIT:  A 63 byte long, non-repeating data pattern. 

255-BIT:  A 255 byte long, non-repeating data pattern. 

511-BIT:  A 511 byte long, non-repeating data pattern. 

2047-BIT:  A 2047 byte long, non-repeating data pattern. 
 

BERT “BIT” patterns are designed to test every combination of a specific number of bits 

or word length.  For instance for a six bit word length there would be 26 or 64 

combinations of bits.  If 0 is the starting pattern then hex number patterns 0 – 63 will be 

generated, arranged into a random order, packed into 8 bit serial bytes, and transmitted 

out the serial port.  To transmit all 64 different combinations of 6 bits, a data string of 

“63” bytes is generated. 
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Packet Delay:  Sets a delay (in ms) between data packets during the BERT test. 

 

Receive Delay:  Sets a delay (in ms) to check for data on the receive port.  When 

working with the store and forward technology of the SS900FH, it is 

sometimes necessary to wait for the data to pass through the network 

before receiving it.  This is equivalent to the TIMEOUT delay on a 

controller. 

 

TXD Hold Off:  This is the time interval between when CTS is asserted and when data is 

transmitted.  When the BERT transmits s data packet, it first asserts RTS.  It then waits 

for CTS to be asserted by the modem.  The BERT then waits the time specified by the 

TXD Hold Off value (in ms) before transmitting the data. 
 

The time interval between RTS and CTS is dependent on the modem.  If 

the modem asserts CTS immediately, this setting can be used to create 

an artificial delay. 

 

Values are in ms. 
 

RTS Hold Over:  After the entire data packet has been transmitted, the BERT de-

asserts RTS.  Some of the data may be “cut off” if there is a delay 

between the input and output of the attached device.  This setting can 

extend the time that RTS remains asserted past the end of the data 

transmission.  Values are in ms. 

 

Constant RTS: Sets RTS in the asserted mode. 

 

Constant DTR:  Set DTR in the asserted mode. 

 

Ignore DCD:  When checked the BERT will ignore DCD. 

 

Ignore CTS:  When checked the BERT will ignore CTS.. 
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The “Status” box shows the status of CTS, DCD and DSR for the connected COM port.  

During any testing, these status indicators are active.  A yellow green light indicates that 

the signal  is on or high, whereas black  indicates the signal is off or low. 

 

 

 

The three buttons in the middle are special function buttons.  

 

 

Button “A” performs an analysis of the timing and shows both the CTS delay time and 

the data Round Trip Delay time.  RTD is from start of transmitted data to end of received 

data. 

 

Button “S” is used to test the anti-streaming function.  To use this function, click on the 

button.  After it turn green, start the BERT program.  As long as there is RXD data, the 

counter will continue, when RXD data stops, so does the counter. 

 

Button “D” is used to test smart modems.  Clicking on this button opens the “Dialer” 

window with which you can send AT commands to the attached smart modem.  Finally it 

can be used call another smart modem.  After connection, the BERT test can be ran 

across the  two smart modems.  

 

 

 

 

The loop count pull down box set the number of loops the BERT will run.  If it is set to 0, 

the BERT will run forever. 

 

 

 

To log the data results, click on file, create a filename, and then check the “Write to File” 

box.  This writes the send and receive data to a file. 
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The Tx Data window displays the current test pattern.  It’s length in bytes and its length 

in ms based on the current baud rate.   

 

The Rx Data window displays RXD data for each loop.  “Record all data” turns off this 

display. 

 

 

 

 

 

 

 

 

 

On the right side of the “BERT Tester” are the “Packets Meter” and the “RSSI Meter”.  

The “Packet Meter” indicates how many received packets were the same as the 

transmitted packets and how many were in error.  The meter shows the value where as 

the “Serial Data Analysis” group box shows the numeric representation.  The “RSSI 

Meter” shows the current value of the received signal strength off the SS900FH radio.  

The “RF Data Analysis” group box indicates the number of good RF packets received, 

the ones in error and the percentage of good RF packets. 

 

Note: The “RSSI Meter” can only be used with the SS900FH where as the “Packets 

Meter” can be used with other devices during a Loopback test. 
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Polling 
 

 
 

To use the Polling utility, there must be  two modems attached to the PC or  two PCs 

each with one modem attached. 
 

There are similar items on this menu as there were on the BERT menu and therefore will 

not be discussed here.  
 

Master: 

Master Check box:  Selects the attached modem 

as the polling master 

Range:  Sets the number of slave modems to poll. 

Polling Interval:  Set the time between each poll in 

ms. 

Wait Time:  Set the time to wait for the poll 

response from each slave modem. 

Retries:  Set the number of times the poll will be 

retried. 
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Slave: 

Slave Check Box:  Selects the attached modem as 

a polling slave. 

ID:  Set the ID of the slave modem.  

Response Time: Time to wait in ms to transmit a 

polling response. 

 

Transmitted Window:  Displays the Poll that is 

being transmitted. 
 

Received Window:  Displays the polling Response. 

Responses: 

Range:  The ID of the slave modem of which to 

report.  0 indicates all. 

Polls Sent:  Total number of polls transmitted. 

Responses: Total number of responses received. 

Retries:  Number of retries. 

Write to File:  Write data to a log file. 
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To start a polling test, 

launch two instances of 

the GDI GUI program.  Set 

one up for one COM port 

the other for another COM 

port using the Port 

Configuration tool. 

 

Set the first instance as the master and the second instance as the slave. 

 

Click run on the slave first and then click run on the master.  The “Wait time” on the 

master may have to be adjusted to accommodate the store and forward nature of the 

SS900FH.  Its value will depend on the packet settings. 
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Spectrum Analyzer 
 

 
 
 
The Spectrum Analyzer provides a means to monitor the transmissions levels of the 

SS900FH by reporting the receive level of the modem that the Spectrum Analyzer is 

being ran on.  The signal strength can then be adjusted through the standard means. 

 
The chart represents the 50 channels that the SS900FH Hops through for each 

transmission versus its received signal strength.  Note that the frequencies are not 

accurate and are representative of the actual frequencies. 
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Port Configuration works the same as the other utilities. 
 

 
 

Run – The run button starts the Spectrum Analyzer according to the Cont. and 
Duration setups. 

Stop – Stops execution and keeps the last sweep on the screen for examination 
and/or saving to a file. 

Cont. – When checked the analyzer runs continuously.  When not checked the 
analyzer will run once. 

Duration – Defines the time in seconds that the analyzer will sample the receive 
levels. 

Print – Prints the chart to the default printer. 
Save – Based on user input, saves either an image file or a text based data output. 
 

 
 
Exit – Exits the Spectrum Analyzer. 
Help – Evokes the help cursor.  Displays help information when displayed over a 
button. 
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Firmware Update 
 

The “Firmware Update” utility enables the user to update the SS900FH firmware using 

files of extension .gdi.  These files are distributed by GDI Communications and are not to 

be altered or changed by the user.  The “Firmware Update” form is shown in Figure 16. 

 
 
 
 
 
 
 
 
 
 

As shown in the figure above, the user can use the help button to get some tips on the 

controls present in the form. 

To update the firmware follow the steps below: 

1. Select a COM port and set the 

communications parameters by 

using the “Get I/O Info” function on 

the Main menu. 

2. Click on the “FIRMWARE” button. 

3. Click on the “Select Firmware” 

button to browse to the desired 

firmware button. 

4. Click on “Update Firmware” 
 

 

Note:  Do not turn the SS900FH  off once the firmware 

update starts.  Doing so could cause the SS900FH 

to be unresponsive to further communications. 
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Help Menu 
 

Typical and first time users of the software might wonder what some controls are meant 

to do.  If so, they can go the ‘Help Menu’ on the main page or click the help button on 

other tools and get offline and online help.  Figure 17 shows the ‘Help Menu’ on the main 

page. 

 
Figure 17– Help Menu 

 

Users of this software can be testing a radio on the streets where Internet access is 

nonexistent.  Thus offline help can be very handy.  Offline Help consists of: the “Ask Me” 

function, two pdf files for the AT Commands and the SS900FH radio, Help buttons 

distributed on different forms and “About”. 

 

When selected, the “Ask Me” tool converts the cursor from its default style to the Help 

style (a cursor with a question mark attached).  With that cursor the user can click any 

control and a balloon tip will show explaining what that control is used for.  The Help 

buttons on the BERT Tester, Terminal Program, etc… does the same thing.  To remove 

this help cursor the user has to click the “Ask Me” again (same for the help buttons). 

 

The software comes with two pdf files present in the “Help Menu”.  The first is the “AT 

Command Reference” which shows all the AT commands used with the SS900FH radio.  
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The second file is the “SS900FH User Guide” which details more information about the 

radio. 

 

The “About” shows the software version and GDI Communications physical address and 

phone support (Figure 18). 

 
Figure 18– About 

 

7.5.2 Online Help 
 

Users who have access to the Internet can utilize two online help features in this 

software.  They can click on the logo present in the “Main Page” which will direct them to 

the support link in the GDI Communications website.  Also under the “Help Menu” the 

users can get to the official website of GDI Communications. 
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Summary 
 

In this manual we have detailed the features of the software and explained how all its 

functions work.  This software helps users to communicate with GDI products in a user 

friendly environment.  This manual has been written for version 1.0.1 of the software.  If 

more information is needed please visit GDI Communications website at (www.sgdi.net) 

where you can download the latest version of this software or any available user manual 

for any GDI product.  You can also find the suggested reference material of section 9 on 

GDI Communications website for more details on AT Commands, the SS900FH radio or 

the bit error rate tester. 

 

Suggested Reference Material 
 

[1] “SS900FH User Guide”, GDI Communications, 

http://www.sgdi.com/User%20Guides/Manuals/SS900FH%20User%20Guide.pdf 

[2] “BT-1 BIT ERROR RATE TESTER USERS MANUAL”, GDI Communications, 

http://www.sgdi.com/User%20Guides/Manuals/GDI%20BT-1%20Manual.pdf 

[3] “SS900FH AT Command Reference”, GDI Communications, 

http://www.sgdi.com/User%20Guides/Manuals/SS900FH%20AT%20Command%20Refe

rence.pdf 
 

Abbreviations 
 

RTS: Request to Send 

DTR: Data Terminal Ready 

CTS: Clear to Send 

DCD: Data Carrier Detect 

DSR: Data Set Ready 

WOO: Windows of Opportunity  

SRT: Slave Response Time 
 


