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Copyright ©2014 Foxit Software Incorporated. All Rights Reserved. 

No part of this document can be reproduced, transferred, distributed or stored in any format 

without the prior written permission of Foxit.  
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claim as to its suitability for any purpose. 
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FOXIT CORPORATION LICENSE 

AGREEMENT FOR FOXIT PDF 

IFILTER SERVER 

 

 

IMPORTANT-READ CAREFULLY: This Foxit Corporation (“Foxit”) License 

Agreement ("License" or “Agreement”) is a legal agreement between You (either an 

individual or an entity, who will be referred to in this License as "You" or “Your”) and 

Foxit for the use of Foxit PDF IFilter, and which may include associated media, printed 

materials, and other components and software modules including but not limited to 

drivers ("Product"). The Product also includes any software updates and upgrades 

that Foxit may provide to You or make available to You, or that You obtain after the 

date You obtain Your initial copy of the Product, to the extent that such items are not 

accompanied by a separate license agreement or terms of use. BY INSTALLING, 

COPYING, DOWNLOADING, ACCESSING OR OTHERWISE USING THE 

PRODUCT, YOU AGREE TO BE BOUND BY THE TERMS OF THIS FOXIT 

LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS 

AGREEMENT YOU HAVE NO RIGHTS TO THE PRODUCT AND SHOULD NOT 

INSTALL, COPY, DOWNLOAD, ACCESS OR USE THE PRODUCT. 

The Product is protected by copyright laws as well as other intellectual property laws. 

The Product is licensed and not sold. 

1. GRANT OF LICENSE. Foxit grants You a non-exclusive, nontransferable license to 

install and use the Product subject to all the terms and conditions set forth here within. 

1.1. Single-Use Perpetual License. You may permit a single authorized end 

user to install the Product on a single computer for use by that end user only. 

Remote access is not permitted without the express written consent of Foxit. 

1.2. Single-Use Term License. Same usage terms as the Single-Use 

Perpetual License. The period of use is limited to a fixed duration at which the 

time the Product must be deinstalled from the computer unless the license is 

renewed for an additional period of time. 

2. ADDITIONAL LIMITATIONS. You may not reverse engineer, decompile, or 

disassemble the Product, except and only to the extent that it is expressly permitted 
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by applicable law notwithstanding this limitation. You may not rent, lease, lend or 

transfer the Product, or host the Product for third parties. The Product is licensed as a 

single integral product; its component parts may not be separated for use on more 

than one computer. The Product may include copy protection technology to prevent 

the unauthorized copying of the Product or may require original media for use of the 

Product on the computer. It is illegal to make unauthorized copies of the Product or to 

circumvent any copy protection technology included in the Product. The software may 

not be resold either by You or a third party customer without the prior written 

permission of Foxit. All rights not expressly granted to You are retained by Foxit.  

2.1. Third Party Software. The Product may contain third party software that 

Foxit can grant sublicense to use and which is also protected by copyright law 

and other applicable laws. 

3. EDUCATIONAL USE. If the Product You have received with this Agreement is an 

Educational Software Bundle (where the Product is received by virtue of Your 

participation in a Foxit program designed for educational or research institutions, or is 

provided by Foxit to You under some other arrangement), You are not entitled to use 

the Product unless You are an employee or student of such educational institution. 

Educational Software Products may be used for educational and research purposes 

only. Commercial and general production use of Educational Software Products are 

specifically prohibited. The Product is provided under a Single-Use Term License as 

described above. You may install one copy of the Product on one desktop computer in 

a designated computer used for educational purposes under Your license agreement. 

Your Educational license is granted for a period of one year, unless stated otherwise, 

from when the Product license keys are made available to You. Your Educational 

license entitles You to email and telephone support for up to two designated 

employees and product upgrades during the term of Your license. You grant Foxit the 

right to use material created under such license for marketing and advertising 

purposes. 

4. SUPPORT, MAINTENANCE, AND UPGRADE PROTECTION TERMS AND 

CONDITIONS.  

 

4.1. Term of Maintenance. Foxit agrees to provide Maintenance (as defined 

herein) to You pursuant to the terms and conditions set forth herein provided 

that You pay the Maintenance Fee for each Product for which Maintenance is 

desired and as further described in Section 4.4 below. Maintenance will be 

provided for a period of one year, unless otherwise agreed to by the parties in 
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writing, from the date of purchase of the Product (the “Initial Support and 

Maintenance Term”), and with renewals, annually from the expiration date of 

the prior Support and Maintenance Term. Failure to renew annual 

maintenance may result in You having to purchase a new license in order to 

receive future versions of software and associated ongoing support and 

maintenance. 

4.2.1. Maintenance Services. In exchange for the Maintenance Fee, Foxit 

agrees to provide to You during the term of this Agreement support and 

maintenance (collectively "Maintenance") as follows: 

4.2.1.1. Support: Foxit will provide email and telephone support to You for 

current versions of the Product. Foxit will investigate all of Your questions 

and problems promptly. You agree to provide adequate information to 

Foxit to assist in the investigation and to confirm that any problems have 

been resolved. Foxit does not provide guaranteed response time but will 

make good faith effort to answer emails and voice mails within twenty-four 

(24) hours or less during weekdays, excluding holidays. 

4.2.1.2. Maintenance: Foxit will supply to You, at no additional charge, 

any improvements, upgrades, or modifications to the Product that Foxit 

makes generally available. Any such improvements, upgrades, or 

modifications shall become part of the Product for all purposes of this 

Agreement. 

4.2.1.3. You acknowledge and agree that the Maintenance to be provided 

by Foxit hereunder is limited to the most current version of the Product 

and the immediately preceding version. 

4.2. Term of Upgrade Protection. Foxit agrees to provide Upgrade Protection 

(as defined herein) to You pursuant to the terms and conditions set forth herein 

provided that You pay the Upgrade Protection Fee for each Product for which 

Upgrade Protection is desired and as further described in Section 4.4 below. 

Upgrade Protection will be provided for a period of one year, unless otherwise 

agreed to by the parties in writing, from the date of purchase of the Product 

(the “Initial Upgrade Protection Term”), and with renewals, annually from the 

expiration date of the prior Upgrade Protection Term.  Failure to renew annual 

Upgrade Protection may result in You having to purchase a new license in 

order to receive future versions of software and associated ongoing Upgrade 

Protection. 

4.3. Exclusions. Foxit’s obligation to provide Support is contingent upon proper 

use of the Product and full compliance with this Agreement. Moreover, Foxit 
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shall be under no obligation to provide Support should such services be 

required due to (a) failure to operate the Product within the systems 

requirements provided for the Product (b) any modification or attempted 

modification of the Product by You or any third party or (C) Your failure or 

refusal to implement Product changes recommended by. 

4.4. Consideration. In payment of the Support, Maintenance and Upgrade 

Protection services to be provided by Foxit hereunder, You shall pay Foxit, or 

its authorized agent, the applicable fee for the Initial Support, Maintenance 

and Upgrade Protection Term as indicated on the related invoice, receipt, 

purchase order, or other ordering document ("Support, Maintenance and 

Upgrade Protection Fee"). At the end of the Initial Support, Maintenance and 

Upgrade Protection Term, or any subsequent Support, Maintenance and 

Upgrade Protection Term, You may renew participation in Support, 

Maintenance and Upgrade Protection services for additional annual term(s) 

provided You (a) are current on all payments due to Foxit and (b) pay Foxit, or 

its authorized agent, the applicable renewal fee, which Foxit, or its authorized 

agent, shall invoice prior to the end of the preceding term, unless terminated 

by You at least 30 days prior to the expiration of the then current Support, 

Maintenance and Upgrade Protection Term. The Support, Maintenance and 

Upgrade Protection Fee for renewal shall be equal to the Support, 

Maintenance and Upgrade Protection Fee for the immediate preceding annual 

term plus an increase by a percentage not to exceed the Consumer Price 

Index (CPI), as published by the U.S. Department of Labor. In addition, 

Support, Maintenance and Upgrade Protection shall be discontinued for any 

and all subsequent Support, Maintenance and Upgrade Protection Terms for 

which You fail to pay Foxit the invoice within ten (10) days after the prior 

Support, Maintenance and Upgrade Protection expiration date.  

4.5. Exceptions. For use of the Product or a Beta Software Product, only the 

Maintenance Services and Exclusions paragraphs of this section apply. For 

use of the Product under Educational Use terms, the Maintenance Services 

and Exclusion paragraphs apply as long as You pay for the maintenance 

period defined under Your Single-Use Term License. 

5. PAYMENT TERMS. Unless explicitly set forth in this Agreement, all fees and other 

amounts due under this Agreement are non-cancelable and non-refundable. Unless 

otherwise agreed to by the parties, You shall pay all fees or amounts within 30 days of 

the date of the invoice. A late fee shall be charged on any overdue amounts and any 

other fees and expenses not paid as provided under this Agreement at the rate of one 
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and one-half percent (1½%) per month, or the highest rate allowable under applicable 

law, whichever is less, commencing with the date payment was due. 

6. TAXES. The fees and all other amounts due as set forth in this Agreement are net 

amounts to be received by Foxit, exclusive of all taxes, duties, and assessments, 

including without limitation all sales, withholding, VAT, excise, ad valorem, and use 

taxes (collectively, the “Taxes”), and are not subject to offset or reduction because of 

any Taxes incurred by You or otherwise due as a result of this Agreement. You shall 

be responsible for and shall pay directly, any and all Taxes relating to the 

performance of this Agreement, provided that this paragraph shall not apply to taxes 

based solely on Foxit’s income. 

7. CONSENT TO USE OF DATA. If Foxit provides any support services to You, You 

agree that Foxit and its affiliates may collect and use all information You provide as a 

part of any such support services related to the Product. Foxit agrees not to use this 

information in a form that personally identifies You.  

Collection of this information occurs in accordance with the Foxit Privacy Policy 

(http://www.foxitsoftware.com/privacy.php) 

8. INTELLECTUAL PROPERTY RIGHTS. Subject to the license grant hereunder, all 

right, title and interest in and to the Product, the accompanying printed materials, and 

any copies of the Product are owned by Foxit and its licensors.  

9. EXPORT RESTRICTIONS. You acknowledge that Product is of U.S. origin. You 

agree to comply with all applicable foreign, federal, state and local laws and 

regulations governing Your use of the Product. Without limiting the foregoing, in the 

event that this Agreement permits export of the Product outside the U.S., You shall be 

solely responsible for compliance with all applicable U.S. export laws, rules, and 

regulations. The Product is subject to the U.S. Export Administration Regulations and 

other U.S. law, and may not be exported or re-exported to certain countries (currently 

Cuba, Iran, Libya, North Korea, Sudan and Syria) or to persons or entities prohibited 

from receiving U.S. exports (including those (a) on the Bureau of Industry and 

Security Denied Parties List or Entity List, (b) on the Office of Foreign Assets Control 

list of Specially Designated Nationals and Blocked Persons, and (c) involved with 

missile technology or nuclear, chemical or biological weapons). 

10. WARRANTY 

10.1. Warranty. Foxit warrants that for a period of 90 days from the date of 

delivery (“Warranty Period”), under normal use, the Product will perform 

substantially in conformance with the specifications published in the 
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Documentation. During such period, and as the sole obligation of Foxit and 

Your sole remedy under the warranty in this Section, if You provide written 

notice of Foxit’s failure to comply with the above warranty, Foxit will use 

reasonable commercial efforts to correct such nonconformity in the Product as 

in accordance with the terms of the Maintenance and Support Policy. In 

addition, if Foxit determines it is not commercially reasonable to correct the 

nonconformity, Foxit may elect to terminate the license to such Product, upon 

which termination Licensee will promptly return to Foxit all such copies of such 

Product. Upon receipt of the Product from Licensee, Foxit will return to 

Licensee all license fees (and any unused support fees) paid to Foxit by You 

for such Product. This warranty set forth above does not apply to, and Foxit 

shall have no obligation with respect to, any non-conformity arising as a result 

of (i) use of the Product other than as specified under this Agreement and the 

related Documentation; (ii) any modification or alteration of the Product 

performed other than by Foxit or its agents, or (iii) transfer of the Product to 

any computer system other than the ones on which Product is authorized to be 

stalled, except as permitted in this Agreement. 

10.2. Disclaimer. Other than the warranty set forth in Section 10.1 above, and 

to the maximum extent permitted by applicable law, Foxit, its authorized 

resellers and their subsidiaries provides the Product and any support services 

related to the Product ("Support Services") AS IS AND WITH ALL FAULTS, 

and hereby disclaim all other warranties and conditions, either express, 

implied or statutory, including, but not limited to, any implied warranties, duties 

or conditions of merchantability, of fitness for a particular purpose, of accuracy 

or completeness of responses, of results, of workmanlike effort, of lack of 

viruses, and of lack of negligence, all with regard to the Product, and the 

provision of or failure to provide support services.  

11. LIMIT OF LIABILITY AND EXCLUSION OF INCIDENTAL, CONSEQUENTIAL 

AND CERTAIN OTHER DAMAGES. TO THE MAXIMUM EXTENT PERMITTED BY 

APPLICABLE LAW, IN NO EVENT SHALL FOXIT, ITS AUTHORIZED RESELLERS 

OR THEIR SUBSIDIARIES BE LIABLE FOR ANY SPECIAL, INCIDENTAL, 

INDIRECT, PUNITIVE OR CONSEQUENTIAL DAMAGES WHATSOEVER 

(INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS OR 

CONFIDENTIAL OR OTHER INFORMATION, FOR BUSINESS INTERRUPTION, 

FOR PERSONAL INJURY, FOR LOSS OF PRIVACY, FOR FAILURE TO MEET ANY 

DUTY INCLUDING OF GOOD FAITH OR OF REASONABLE CARE, FOR 

NEGLIGENCE, AND FOR ANY OTHER PECUNIARY OR OTHER LOSS 
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WHATSOEVER) ARISING OUT OF OR IN ANY WAY RELATED TO THE USE OF 

OR INABILITY TO USE THE PRODUCT, THE PROVISION OF OR FAILURE TO 

PROVIDE SUPPORT SERVICES, OR OTHERWISE UNDER OR IN CONNECTION 

WITH ANY PROVISION OF THIS LICENSE, EVEN IN THE EVENT OF THE FAULT, 

TORT (INCLUDING NEGLIGENCE), STRICT LIABILITY, BREACH OF CONTRACT 

OR BREACH OF WARRANTY OF FOXIT, EVEN IF FOXIT HAS BEEN ADVISED OF 

THE POSSIBILITY OF SUCH DAMAGES. 

11.1. LIMITATION OF LIABILITY AND REMEDIES. Notwithstanding any 

damages that You might incur for any reason whatsoever (including, without 

limitation, all damages referenced above and all direct or general damages), 

the entire liability of Foxit, its resellers and their subsidiaries under any 

provision of this License and Your exclusive remedy for all of the foregoing 

shall be limited to the amount actually paid by You for the Product. The 

foregoing limitations, exclusions and disclaimers shall apply to the maximum 

extent permitted by applicable law, even if any remedy fails its essential 

purpose. 

11.2. NOTICE TO U.S. GOVERNMENT END USERS 

11.3. For contracts with agencies of the Department of Defense, the 

Government’s rights in: (1) commercial computer software and commercial 

computer software documentation shall be governed, pursuant to 48 C.F.R. 

227.7201 through 227.7202-4, by Foxit’s standard commercial license(s) for 

the respective product(s); (2) software and software documentation other than 

commercial computer software and commercial computer software 

documentation shall be governed by 48 C.F.R. 252.227-7014; (3) technical 

data for commercial items other than software or software documentation shall 

be governed by 48 C.F.R. 252.227-7015(b); and (4) technical data for 

non-commercial items other than software or software documentation shall be 

governed by 48 C.F.R. 252.227-7013. 

11.4. For contracts with U.S. Government agencies other than the Department 

of Defense agencies, the Government’s rights in: (1) commercial computer 

software and commercial computer software documentation shall be governed, 

pursuant to 48 C.F.R. 2.101 and 12.212, by Foxit’s standard commercial 

license(s) for the respective product(s); (2) software and software 

documentation other than commercial computer software and commercial 

computer software documentation shall be governed by 48 C.F.R. 52.227-14, 

Alternative III; and (3) technical data other than software and software 
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documentation shall be governed by 48 C.F.R. 52.227-14 including, where 

applicable Alternatives I or II. 

12. GENERAL. This Agreement will be governed by and construed in accordance with 

the laws of the State of California excluding that body of laws known as conflicts of 

law. The United Nations Convention on Contracts for the International Sale of Goods 

will not apply. Any legal action or proceeding arising under this Agreement will be 

brought exclusively in the federal or state courts located in San Jose, California and 

the parties hereby irrevocably consent to the personal jurisdiction and venue therein. 

You may not assign this Agreement or any right or interest hereunder, by operation of 

law or otherwise, without Foxit’s express prior written consent. Any attempt to assign 

this Agreement, without such consent, will be null and of no effect. Subject to the 

foregoing, this Agreement will bind and inure to the benefit of each party's successors 

and permitted assigns. Except as expressly set forth in this Agreement, the exercise 

by either party of any of its remedies under this Agreement will be without prejudice to 

its other remedies under this Agreement or otherwise. If for any reason a court of 

competent jurisdiction finds any provision of this Agreement invalid or unenforceable, 

that provision of the Agreement will be enforced to the maximum extent permissible 

and the other provisions of this Agreement will remain in full force and effect. All 

notices or approvals required or permitted under this Agreement will be in writing and 

delivered by confirmed facsimile transmission, by overnight delivery services, or by 

certified mail, and in each instance will be deemed given upon receipt. All notices or 

approvals will be sent to the addresses set forth in the applicable ordering document 

or invoice or to such other address as may be specified by either party to the other in 

accordance with this section. Neither party will be responsible for any failure or delay 

in its performance under this Agreement (except for any payment obligations) due to 

causes beyond its reasonable control, including, but not limited to, labor disputes, 

strikes, lockouts, shortages of or inability to obtain labor, energy or supplies, war, 

terrorism, riot, or acts of God. The failure by either party to enforce any provision of 

this Agreement will not constitute a waiver of future enforcement of that or any other 

provision. This Agreement, including Foxit’s support and maintenance services terms 

constitutes the entire and exclusive agreement between the parties concerning its 

subject matter and supersedes all prior written and oral understandings and 

agreements between the parties regarding its subject matter. The terms and 

conditions contained in any customer purchase order or other ordering document that 

are inconsistent with or in addition to the terms and conditions of this Agreement are 

hereby rejected by Foxit and will be deemed null and of no effect. 
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13. COMPLIANCE WITH LICENSES. If You are a business, company or organization, 

You agree that upon request from Foxit or its authorized representative You will within 

thirty (30) days fully document and certify that use of any and all Foxit Products at the 

time of the request is in conformity with Your valid licenses from Foxit. 

14. DISCONTINUING OR MODIFYING SERVICES. You acknowledge that Foxit has 

the right to discontinue the manufacture and development of any of the Product and 

the support for that Product, in its sole discretion at any time, including the distribution 

of older Product versions, provided that Foxit agrees not to discontinue the support for 

that Product during the current annual term of this Agreement, subject to the 

termination provisions herein. Notwithstanding the foregoing, if Foxit discontinues the 

manufacture and support for a particular Product, Support for any remaining Products 

covered by this Agreement shall not be adversely affected. Foxit reserves the right to 

alter the Support, in its sole discretion but in no event shall such alterations result in: 

(a) diminished support from the level of support set forth herein; (b) materially 

diminished obligations for Foxit; or (c) Your materially diminished rights. 

15. MARKETING. You agree that You and Your business, company, or organization 

may be identified as a customer of Foxit and Foxit may refer to You and your business, 

company, or organization by name and logo, and Foxit may briefly describe 

Licensee’s business in Foxit’s marketing materials and website. 

16. Should You have any questions concerning this License, or if You desire to 

contact Foxit for any reason, please call (510) 438-9090. 
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Chapter 1 - Overview 

Welcome to Foxit PDF IFilter - a professional tool that helps you to index PDF files. 

Foxit PDF IFilter is an application that extracts the contents, properties, bookmarks, form, 

annotations and attachments from PDF documents, indexes them, and returns the 

indexed results to the search engine so that users can search PDF documents with 

keywords.  

Foxit PDF IFilter supports PDF 1.7 specification and can be used in many Microsoft 

search engines, such as Windows Indexing Service, MSN Desktop Search, Internet 

Information Server, SharePoint Portal Server, Windows SharePoint Services (WSS), Site 

Server, Exchange Server, SQL Server, and all other products based on Microsoft Search 

technology. With Foxit PDF IFilter, all these search engines can find PDF files with ease. 

Why PDF IFilter? 

PDF IFilter is necessary for several reasons: 

 Microsoft creates and maintains office file formats, such as .doc, .xls, .ppt, etc. 

However, many other file formats are created and maintained by other companies. 

For example, PDF was created by Adobe.  

 With the advantages of security, reliability and accessibility, PDF is now being used 

by more and more people all over the world. 

 PDF IFilter is a plug-in that allows Microsoft search engines to index PDF files so that 

they become searchable. Without an appropriate PDF IFilter, contents of a PDF file 

cannot be indexed. 

Why Foxit PDF IFilter? 

Foxit PDF IFilter is favored by a large number of governments and well-known companies 

because of the following reasons: 

 Foxit PDF IFilter helps to do PDF indexing, which makes finding information much 

easier. 

 Foxit PDF IFilter supports multi-threading and makes full use of multi-CPU/core in a 

server. 

 Foxit PDF IFilter supports native 64-bit code. 

 Smaller and faster than other PDF IFilters. 

 Supports twelve languages. Please go to Language Support part for details. 
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How Foxit PDF IFilter works? 

Foxit PDF IFilter acts as a plug-in for full-text search engines. A search engine usually 

works in two steps: 

Step 1, the search engine goes through a designated place, e.g. a file folder or a 

database, and indexes all documents or newly modified documents, including PDF 

documents, in the background and creates internal data to store the indexed result. 

Step 2, a user specifies some keywords for search and the search engine looks up the 

indexing result and responds to the user with all the documents that contain the keywords. 

During Step 1, the search engine looks in the windows registry for appropriate IFilter 

implementations and uses those filters for indexing. It filters out embedded formatting and 

extracts text from the document and returns the result. Foxit PDF IFilter is one such 

implementation. Further information about the IFilter specification can be found on the 

Microsoft Web site. 

Key Benefits 

 Integrates with existing operating systems and tools within your company. 

 Provides an easy solution to search within PDF documents located on the local 

computer, local network, and/or intranet. 

 Greatly increases your ability to accurately locate information. 

 Much smaller and faster than PDF IFilters offered by other vendors. 

 Supports Chinese/Japanese/Korean PDF documents. 

 Supports native 64-bit code. 

 Supports searching and indexing PDFs by extracting subject, author and content of 

annotations. 

 Supports multi-threading and takes full use of multiple-CPU in a server. 

http://msdn2.microsoft.com/en-us/library/ms691105.aspx
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Chapter 2 - Getting Started 

Installing Foxit PDF IFilter  

To install Foxit PDF IFilter on your environment, please first download the current version 

with the link provided in the sales email after purchasing the license. Also, you could apply 

for 30-day trail from Foxit Website (http://www.foxitsoftware.com/products/ifilter/).  

There are two packs of Foxit PDF IFilter, which are respectively for 32bit OS and 64bit OS. 

Please get the proper one and install it as follows. 

1. Stop all the appropriate clients. 

2. Uninstall any previous version of Foxit PDF IFilter if installed. 

3. Launch the installer of Foxit PDF IFilter and follow the step to finish the installation. 

4. Restart all the appropriate clients after finishing the installation. 

Notes:  

 More installation steps are required for SQL, WSS and Moss environments. Please 

refer to the corresponding chapter. 

 Foxit PDF IFilter item will appear in program list of Control Panel after installation. 

 Foxit PDF IFilter has no user interface. 

 The installer will unzip an add-on called fpdfcjk.bin to the installation folder. The 

add-on will help you to index PDF documents containing Chinese/Japanese/Korean 

characters. 

Configuring Foxit PDF IFilter 

There are five registry items for configuring Foxit PDF IFilter. They are under the directory: 

“HKEY_LOCAL_MACHINE\SOFTWARE\Foxit Software\Foxit PDF IFilter”. 

FilterAnnotation[REG_DWORD] - sets the value to specify whether to filter out 

annotations. 0 represents no and other values represent yes. 

FilterBookmarks [REG_DWORD] - sets the value to specify whether to filter out 

bookmarks. 0 represents no and other values represent yes. 

FilterAttachFile [REG_DWORD] - sets the value to specify whether to filter out 

attachments. 0 represents no and other values represent yes. 

LogLevel [REG_DWORD] - sets the log level. Value can be from 0 to 3. 

http://www.foxitsoftware.com/products/ifilter/
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0 - no output  

1 - Error log only. Includes error information when errors happen, and stack 

message when the application crashes. 

2 - Simple log which only includes the main calling functions and returned values. 

3 - Detailed log which includes specific information such as date and chunk. 

LogFilePath [REG_SZ] - sets the output path of log file. 

Note:  

The default setting in Foxit PDF IFilter is to filter out bookmarks. Restart the application if 

you made any changes to the registry. 

Updating Foxit PDF IFilter 

To update Foxit PDF IFilter, please download the current version from Foxit website and 

then install it. During installation, the old version will be covered. 

Uninstalling Foxit PDF IFilter 

To remove the old version of Foxit PDF IFilter, please uninstall it from Control Panel or 

with the help of the installer as below: 

1. From Control Panel: 

 Choose Start > Control Panel > Add or Remove Programs. 

 Choose the “Foxit PDF IFilter” item and then click “Remove” button to uninstall it. 

2. From the installer: 

 Double-click the Foxit PDF IFilter.msi setup file that was used to install Foxit PDF 

IFilter. 

 In the Foxit PDF IFilter dialog box, select Remove Foxit PDF IFilter. 

 Click the Finish button to uninstall it. 
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Chapter 3 - Foxit PDF IFilter for 

SharePoint/MOSS 

Foxit PDF IFilter can help search text in PDF files. After installing Foxit PDF IFilter, you 

should upload your PDF documents and perform a full crawl with Microsoft Office 

SharePoint Server (MOSS) before you start searching. 

You don’t have to do full crawls every time you add new PDF files. You may schedule the 

incremental crawls for all the new ones.  

Working in SharePoint 2013 

Foxit PDF IFilter can work successfully on SharePoint 2013 with the hotfix KB2883000. 

So for SharePoint 2013, please make sure that you have installed the hotfix KB2883000. 

Installing Foxit PDF IFilter 

There are two packs of Foxit PDF IFilter, which are respectively for 32bit Windows OS and 

64bit Windows OS. Please choose one to install according to your server environment. 

Before installing Foxit PDF IFilter, please make sure that Microsoft Office SharePoint 

Server has been installed successfully. 

To install Foxit PDF IFilter, please follow these steps: 

1. Download Foxit PDF IFilter. 

You could get the download link by email after purchasing Foxit PDF IFilter or 

applying for the 30-day trial version. Then please download Foxit PDF IFilter onto the 

machine where you want to install it. 

2. Stop the IIS Admin service. 

Click Start > Administrator Tools > Services (Local) > IIS Admin Service > Stop > 

close window. 

3. Install Foxit PDF IFilter. 

Run the Foxit PDF IFilter Setup program to install it on the server. 

4. Set PDF icon for PDF Search. 

A. Download the Foxit PDF file icon from: 

http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif. 

B. Save the Foxit PDF file icon to the following file location: 

http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif
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"Drive:\Program Files\Common Files\Microsoft Shared\Web Server 

Extensions\15\TEMPLATE\IMAGES". 

C. Add the mapping entry to the DOCICON.XML. 

a. Locate to the XML file “Drive:\Program Files\Common Files\Microsoft 

Shared\Web server extensions\15\ TEMPLATE\XML\DOCICON.XML”: 

b. Right-click DOCICON.XML file > click Open With > select Notepad. 

c. Add an entry for the .pdf extension to XML file.  

For example, “pdficon.gif” is the name of Foxit PDF file icon. 

<Mapping Key="pdf" Value="pdficon.gif"/> 

 

d. File menu > click Save > exit Notepad.  

Note: This directly changes the icons shown on the search result. Make sure this change 

takes effect in the appropriate server where search results are displayed, such as any 

web front end (WFE) that supports user interface. 

5. Use a third PDF IFilter. 

To have a third PDF IFilter worked, you should replace the built-in PDF IFilter. 

A. Click Start > choose SharePoint 2013 Management Shell. 

Please make sure that you have run it as Administrator. Or you may fail to 

perform the commands in the following two steps. 

B. To replace the built-in PDF IFilter with a third one, please perform the following 

two commands: 

a. $ssa = Get-SPEnterpriseSearchServiceApplication 

b. Set-SPEnterpriseSearchFileFormatState -SearchApplication $ssa PDF $TRUE 
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$TRUE 

 

C. Please run the following command to retrieve information about "pdf" in the 

Search service application. 

Get-SPEnterpriseSearchFileFormat -SearchApplication $ssa pdf 

 

The returned value “UseIFilter: True” means that you have successfully used a 

third PDF IFilter. 

6. Perform an iisreset. 

To make the changes to take effect, you need to perform an iisreset. 

D. Click Start > Run > type “cmd” to go into the command prompt window > then 

type “iisreset”. 

 

E. Exit the command prompt window once if IIS stops and restarts successfully. 

7. Restart the SharePoint Search Service. 

To restart the SharePoint Search Service, please perform the following commands: 

a. net stop spsearchhostcontroller 

b. net start spsearchhostcontroller 

c. net stop osearch15 
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d. net start osearch15 

Note:  

If you changed the settings for PDF IFilter in the configurable registry, please perform the 

following commands in the command prompt window: 

a. iisreset 

b. net stop spsearchhostcontroller 

c. net start spsearchhostcontroller 

d. net stop osearch15 

e. net start osearch15 

Indexing PDFs 

To index PDF files on your computer, please follow these steps: 

1. Add the .pdf file type to the SharePoint content index list. 

A. Go to Application Management > Manage service applications > Search 

Administration  

B. In Search Administration page > go to Crawling section > click File Types 

C. Click New File Type > type “pdf” in the File extension field > click OK. 

 

D. Click New File Type > type “pdf” in the File extension field > click OK. 

E. Then you could find that pdf file type has been added to the page and it connects 

to the pdf file icon added. 



  Foxit PDF IFilter Server 

  Page 22 

 

2. Upload a PDF file and then perform a Full Crawl. 

A. Go to Documents and click new document. 

 

B. In the Add a document page, click Browse button to choose a PDF and click 

OK. 

 
C. Once uploaded successfully, you will see that the PDF has been listed in the 

Documents page. 
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D.  (Optional) To the PDFs uploaded, you could modify the properties, including 

Name, Title and so on, to whatever you want in the Edit Properties window. 
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E. Go to Search Service Application > click Content Sources > In Search 

Service Application: Manage Content Sources page > drop down your Local 

SharePoint sites > choose Start Full Crawl  

 

F. (Optional) If a full crawl has been done before, you could also choose Start 

Incremental Crawl only for all the PDFs newly uploaded. 

3. View Crawl Logs. 

A. Go to Documents page. 

B. Right-click a PDF and then choose Properties. 

C. In Properties window of a PDF, copy the link from Address (URL) without the 

PDF filename part. 
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D. Go to Manage Content Sources page, open the content source’s context  

menu by left-clicking the down arrow and select View Crawl Log  

E. In Crawl Log page, click URL View > paste the copied URL to the box (Type a 

URL or host name.) > click search.  

Once completed, all the uploaded PDFs will be listed, including the PDFs’  

whole URL and the crawling status.  
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Searching PDFs 

After finishing indexing PDF files, you can start a PDF search. A PDF could be found by its 

text, properties, bookmark, annotation and so on. 

To start a search, please follow these steps: 

1. In Documents page, type a keyword in the box to start a search. 

 
2. All the PDFs which contain the keyword will be listed. 

 

3. Click any search result and then you could open the PDF with the default PDF viewer. 

More Help 

For more information on how to work with Microsoft Office SharePoint Server (MOSS), 

please refer to Microsoft Office SharePoint Server (MOSS) Help included in the product. 
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Working in SharePoint 2010 

Installing Foxit PDF IFilter 

Foxit PDF IFilter has two versions respectively for 32-bit Windows and 64-bit Windows. 

You can choose one of them to install into your machine according to your system 

requirements. Before installing Foxit PDF IFilter, please note that Microsoft Office 

SharePoint Server has been installed successfully.  

To install Foxit PDF IFilter, please do the following: 

 Download Foxit PDF IFilter from Foxit Website (http://www.foxitsoftware.com) onto 

the machine where you wish to install it. 

 Stop the IIS Admin service: Start > Administrator Tools > Services(Local) > IIS Admin 

Service > Stop. Close window. 

 Run the Foxit PDF IFilter Setup program to install the filter on the server. 

 Download PDF icon from http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif. 

 Copy the downloaded .GIF file to "Drive:\Program Files\Common Files\Microsoft 

Shared\Web Server Extensions\14\Template\Images". 

 Edit the file “Drive:\Program Files\Common Files\Microsoft Shared\Web server 

extensions\14\Template\Xml\DOCICON.XML”: 

1. Right-click DOCICON.XML file > click Open With > select Notepad. 

2. Add an entry for the .pdf extension. For example, where ICPDF is the name of 

the .gif file:  

<Mapping Key="pdf" Value="pdficon.gif"/> 

http://www.foxitsoftware.com/
http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif
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1. On the File menu, click Save, and then quit Notepad.  

Note: This directly changes the icons shown on the search result. Make sure this change takes effect in 

the appropriate server where search results are displayed i.e. any web front end (WFE) that supports 

user interfacing. 

 Perform an iisreset: 

1. Click Start > Run > type “cmd” in the Open line> click OK > type “iisreset” at the 

command prompt > hit Enter. 

 

2. Close the window. 
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 Stop and start the Sharepoint Search Service by running the following commands: 

1. net stop spsearch4 

2. net start spsearch4 

3. net stop osearch14 

4. net start osearch14 

Note:  

If you changed the settings for IFilter in the configurable registry, please perform the 

following commands in the command prompt window: 

1. iisreset 

2. net stop spsearch4 

3. net start spsearch4 

4. net stop osearch14 

5. net start osearch14 

Indexing PDFs 

To index PDF files on your computer, please do the following: 

 Add the .pdf file type to the index list: 

1. Go to the Search Service Application: Search Administration page, in the 

Crawling section, click File Types. 

2. Click New File Type > type “pdf” in the File extension field > click OK. 
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The PDF file type has been added 

 Upload a PDF file, and perform a Full Crawl on the Search content indexes: 
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1. Go to the Shared Documents, and click Add new document. 

 

2. Click the Browse button to upload a PDF document and click OK. 

 

 

3. In Edit page, you can give the title, keywords, if you like, to your uploaded PDF 

file. Click the Save button. 
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4. When you are done, you will be returned to the Documents page where you will 

see that your PDF file has been uploaded. 

5. Return to the Search Application: Search Administration home page, in Crawling 

section, click Content Sources link. 

6. On the Manage Content Sources page, open the content source’s context menu 

by left-clicking the down arrow and select Start Full Crawl to index all files. This 

will start the indexing process. 

 

7. (Optional) To start an incremental crawl, please open the content source’s context 

menu by left-clicking the down arrow and select Start Incremental Crawl. 

 View Crawl Logs. 
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1. Return to the Shared Documents. 

2. Right-click the PDF document you have uploaded > choose Properties. 

3. Select the address (URL) of the PDF file except [filename.pdf] > right-click the 

selected area > choose Copy. 

 

4. Go to the Manage Content Sources page, open the content source’s context  

menu by left-clicking the down arrow and select View Crawl Log  

 

5. In Crawl Log page, click URL, paste the URl to URL or Host name >click 

search button. When you’re done, you can see the whole URL of the uploaded 

PDF file appear on the list. 
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Searching PDFs 

After you finish indexing PDF files, you can start a search to find text within PDF files. Also, 

you can search PDF document properties, such as author, title, etc. 

To start a search, please perform the following: 

 Go to the Shared Documents: All Documents page, type the text you want to 

search in the search box > hit Enter. 

 

 You will see your search results. Click to open one of the PDF files. 
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Search results 

 

Open one of the search results 

Working in Moss 2007 

Installing Foxit PDF IFilter 

Foxit PDF IFilter has two versions respectively for 32-bit Windows and 64-bit Windows. 

You can choose one of them to install onto your machine according to your system 
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requirements. Before installing Foxit PDF IFilter, please note that Microsoft Office 

SharePoint Server has been installed successfully.  

To install Foxit PDF IFilter, please do the following: 

 Download Foxit PDF IFilter from Foxit Website (http://www.foxitsoftware.com) onto 

the machine where you wish to install it. 

 Stop the IIS Admin service: Start > Settings > Control Panel > Administrator Tools > 

Services > IIS Admin Service > Stop. Close window. 

 Run the Foxit PDF IFilter Setup program to install the filter on the server. 

 Download PDF icon from http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif. 

 Copy the downloaded .GIF file to "Drive:\Program Files\Common Files\Microsoft 

Shared\Web Server Extensions\12\Template\Images". 

 Edit the file “Drive:\Program Files\Common Files\Microsoft Shared\Web server 

extensions\12\Template\Xml\DOCICON.XML”: 

1. Right-click DOCICON.XML file > click Open With > select Notepad. 

2. Add an entry for the .pdf extension. For example, where ICPDF is the name of 

the .gif file:  

<Mapping Key="pdf" Value="pdficon.gif"/> 

 

http://www.foxitsoftware.com/
http://www.foxitsoftware.com/pdf/ifilter/pdficon.gif
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2. On the File menu, click Save, and then quit Notepad.  

Note: This directly changes the icons shown on the search result. Make sure this change takes effect in 

the appropriate server where search results are displayed i.e. any web front end (WFE) that supports 

user interfacing. 

 Perform an iisreset: 

1. Click Start > Run > type “cmd” in the Open line> click OK > type “iisreset” at the 

command prompt > hit Enter. 

 

2. Close the window. 

 Stop and start the Sharepoint Search Service by running the following commands: 

1. net stop spsearch 

2. net start spsearch 

3. net stop osearch 

4. net start osearch 

You don’t have to do full crawls every time you add some new PDF files. You may 

schedule the incremental crawls for all the new ones. 

Note： 

 Click to check the parts of Updating Foxit PDF IFilter and Uninstalling Foxit PDF 

IFilter. 

 If you changed the settings for IFilter in the configurable registry, please perform the 

following commands in the command prompt window: 

1. iisreset 

2. net stop spsearch 

3. net start spsearch 

4. net stop osearch 

5. net start osearch 
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Indexing PDFs 

To index PDF files on your computer, please do the following: 

 Add the .pdf file type to the index list: 

1. Go to the Shared Service Administration: SharedServices 1 home page, click 

Search Settings link> under Crawl Settings click File Types. 

2. Click New File Type > type “pdf” in the File extension field > click OK. 

    

 

The PDF file type has been added 

 Upload a PDF file, and perform a Full Crawl on the Search content indexes: 

1. Go to the Document Center, and click Documents. 

2. Click Upload, and then Upload Document. 
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3. Click the Browse button to upload a PDF document and click OK. When it has 

uploaded, the Documents Edit Item page is displayed. You can give a title, if you like, 

to your uploaded PDF file. Click the Check In button. 

 

4. When you are done, you will be returned to the Documents page where you will 

see that your PDF file has been uploaded. 

5. Return to the Shared Service Administration: SharedServices 1 home page, 

click Search Settings link> under Crawl Settings click Content sources and crawl 

schedules. 

6. On the Manage Content Sources page, open the content source’s context menu 

by left-clicking the down arrow and select Start Full Crawl to index all files. This will 

start the indexing process. 
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7. (Optional) To start an incremental crawl, please open the content source’s context 

menu by left-clicking the down arrow and select Start Incremental Crawl. 

 View Crawl Logs. 

1. Return to the Document Center, and click Documents. 

2. Right-click the PDF document you have uploaded > choose Properties. 

3. Select the address (URL) of the PDF file except [filename.pdf] > right-click the 

selected area > choose Copy. 

 

4. Go to the Manage Content Sources page, open the content source’s context 

menu by left-clicking the down arrow and select View Crawl Log > paste the URL 

to Find URLs that begin with the following hostname/path field > click the Filter 

button. 
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5. When you’re done, you can see the whole URL of the uploaded PDF file appear in 

the Crawl Log list. 
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Searching PDFs 

After you finish indexing PDF files, you can start a search to find text within PDF files. Also, 

you can search PDF document properties, such as author, title, etc.  

To start a search, please perform the following: 

 Go to the Document Center, and click Search to visit the Search Center > type the 

text you want to search > hit Enter. 

 

 You will see your search results. Click to open one of the PDF files. 

 

Search results 
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Open one of the search results 
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Chapter 4 - Foxit PDF IFilter for 

Microsoft SQL Server 

Foxit PDF IFilter can help search text in PDF files. After installing Foxit PDF IFilter, it asks 

to upload the PDF documents and perform a full population with Microsoft SQL Server 

before you start a search. 

Note: 

Generally, all the instructions in this chapter are for Microsoft SQL Server 

2014/2012/2008/2005. And the screenshots are from Microsoft SQL Server 2012 by 

default. If there is any difference between SQL Server 2012 and 2014/2008/2005, we will 

point it out as well as attach a screenshot. 

Installing Foxit PDF IFilter 

Foxit PDF IFilter has two packs respectively for 32-bit Windows and 64-bit Windows. You 

can choose one of them to install into your machine according to your system 

requirements. Before installing Foxit PDF IFilter, please make sure that Microsoft SQL 

Server has been installed successfully.  

To install Foxit PDF IFilter on SQL server, please follow the steps as below. 

1. Create a new functioning database to store PDF files. 

A. Run SQL Server Management Studio. 

B. Create a new database.  

Right click the Database folder in the Object Explorer and select New Database. 

Type your Database name and click OK. 

C. Create a table.  

Right click the Table folder in the new database and select New Table. 

D. Complete the details in the “Column Name” column, the “Data Type” column, 

“Length” column, and “Allow Nulls” column.  

Foxit PDF IFilter indexes PDF files in SQL Server based on your specified 

column names. For example, you may add some fields for PDF files as below: 
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PdfText:  stores binary PDF files, whose data type should be 

varbinary(MAX). 

Ext:   stores the file extension of PDF files. It’s set as “.pdf” in this 

example. For more information, please refer to 

http://technet.microsoft.com/en-us/library/ms142499.aspx 

PdfID:   designates a unique ID for each PDF file, which will act as the 

return value when you’re trying to search PDFs. 

Note:  

The example of the table above is applied for Microsoft SQL Server in this 

manual. 

E. Click Save button and enter a name for the table. 

2. Install Foxit PDF IFilter. 

A. Download Foxit PDF IFilter installation pack by the given link in the sales email 

after purchasing the license. Also, you could get the 30-day trial version of Foxit 

PDF IFilter from Foxit Website (http://www.foxitsoftware.com). 

B. Run the Foxit PDF IFilter Setup and follow the steps to complete the installation 

on your server. 

Notes:  

 Foxit PDF IFilter appears in the program list after installation. 

 Foxit PDF IFilter has no user interface. 

 The installer will unzip an add-on called fpdfcjk.bin into the installation folder. 

This add-on will help index PDF documents containing the 

Chinese/Japanese/Korean characters. 

3. Register Foxit PDF IFilter. 

After the installation of Foxit PDF IFilter, it asks to register Foxit PDF IFilter. 

http://technet.microsoft.com/en-us/library/ms142499.aspx
http://www.foxitsoftware.com/
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A. Click the “Database Engine Query” button on the toolbar, and execute the 

following command to register Foxit PDF IFilter:  

Exec sp_fulltext_service 'load_os_resources', 1  

Exec sp_fulltext_service 'verify_signature', 0  

 

B. The message “Command(s) completed successfully.” means you have 

registered Foxit PDF IFilter successfully. 

4. Restart the server, or you can stop and start SQL server and the Full-text 

Search engine by right-clicking them. 

For SQL Server 2014/2012/2008: 

A. Click Start > Programs > Microsoft SQL Server 2014/2012/2008 > 

Configuration Tools > SQL Server Configuration Manager. 

 

B. In the pop-up SQL Server Surface 2014/2012/2008 Area Configuration dialog 

box, please select Surface Area Configuration for Services and Connections. 

C. Select MSSQLSERVER > Service > click Stop button and then Start button. 

D. Select Full-Text Search > Service > click Stop button and then Start button. 

For SQL Server 2005: 

A. Click Start > Programs > Microsoft SQL Server 2005 > Configuration Tools > 

SQL Server Surface Area Configuration. 

B. In the pop-up SQL Server Surface 2005 Surface Area Configuration dialog box, 

please select Surface Area Configuration for Services and Connections. 

C. Select MSSQLSERVER > Service > click Stop button and then Start button. 
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D. Select Full-Text Search > Service > click Stop button and then Start button. 

5. Confirm the registration. 

A. To check if PDF document type has been associated to Foxit PDF IFilter, 

execute the following commands.  

select document_type, path from sys.fulltext_document_types where  

document_type = '.pdf' 

B. Check the result under the Results tab. Check the results to confirm success 

visually. 

 

 

 

Note:  

To update and uninstall Foxit PDF IFilter, please refer to Updating Foxit PDF IFilter 

and Uninstalling Foxit PDF IFilter. 

Setting up full-text search 

To set up full-text search, you should take the following steps. 

1. Confirming the Full-text search service. 
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A. Launch Microsoft SQL Server Management Studio and execute the following 

command. 

print FULLTEXTSERVICEPROPERTY('IsFullTextInstalled') 

 

B. Check the result by the returned value. 

1  = Full-Text installed 

0  = Full-Text not installed 

Null  = invalid input, or error 

2. Installing Full-Text component and service. 

3. Enabling Full-Text indexing 

In order to use Full-Text indexing function, you must first check if it has been enabled. 

To enable Full-text indexing, please use one of the following two methods. 

 Launch Microsoft SQL Server Management Studio. Right-click the database you 

have created > select Properties > choose Files tab > check “Use full-text 

indexing” > OK. 

 Execute the following command: 

exec sp_fulltext_database 'enable' 
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4. Creating a full-text catalog to store full-text indexes. 

Please execute the following command. 

create fulltext catalog pdfCatalog 

5. Creating a unique index. 

A. Open the table you have created > right click one of the column names > select 

“Set Primary Key”. 

 

 

 

B. Execute the following command: 

create unique index ui_pdfIndex on dbo.pdftable(PdfId) 
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6. Create a full-text index 

For SQL Server 2014/2012/2008 

Right-click the table you have created > choose “Full Text Index” > set for it with all 

the default value. Please note the “PdfText” should be checked in Available 

Columns and “Ext” should be selected in Type Column. 

For SQL Server 2005 

Execute the following command: 

create fulltext index on dbo. pdftable 

( 

PdfText – Please assign the column name for full-text index.  

) 

key index ui_pdfIndex on pdfCatalog 

with change_tracking auto 

Uploading PDFs 

1. To upload PDF files to Microsoft SQL Server, please write a segment of codes.  

You could also copy the following example. 

For SQL Server 2014/2012/2008 

using System; 

using System.Collections.Generic;  

using System.Web;  

using System.Web.UI; 

using System.Web.UI.WebControls; 

using System.Data.SqlClient; 

namespace WebApplication1 

     { 

public partial class _Default : System.Web.UI.Page 

{ 

protected void Page_Load(object sender, EventArgs e) 

{ 

 } 

protected void Button1_Click(object sender, EventArgs e) 

{ 

//Create a byte[] from the input file 

int len = FileUpload1.PostedFile.ContentLength; 

byte[] PdfText = new byte[len]; 

FileUpload1.PostedFile.InputStream.Read(PdfText, 0, len); 
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// Insert the image and comment into the database 

//SqlConnection connection = new 

SqlConnection(@"server=QA-SQL2012;database=QA-2012;uid=Administrator;pwd="); 

SqlConnection connection = new SqlConnection(@"Integrated Security=SSPI;Persist 

Security Info=False;Initial Catalog=pdl;Data Source=QA-SQL2012"); 

try 

{ 

connection.Open(); 

SqlCommand cmd = new SqlCommand("insert into Table_1" + "(PdfText, PdfId, Ext) 

values (@PdfText, @PdfId, @Ext)", connection); 

 // Insert values into the three columns. 

  cmd.Parameters.Add(new SqlParameter("@PdfText", PdfText)); 

 cmd.Parameters.Add(new SqlParameter("@PdfId",17)); 

// You can only upload a pdf file at a time. 

 cmd.Parameters.Add(new SqlParameter("@Ext", ".pdf")); 

cmd.ExecuteNonQuery(); 

} 

finally 

{ 

connection.Close(); 

} 

} 

} 

}  

For SQL Server 2005 

using System.Web.UI.HtmlControls; 

using System.Data.SqlClient; 

using System.IO; 

public void OnUpload(Object sender, EventArgs e) 

     { 

        // Create a byte[] from the input file 

        int len = File1.PostedFile.ContentLength; 

        byte[] PdfText = new byte[len]; 

        File1.PostedFile.InputStream.Read(PdfText, 0, len); 

        // Insert the image and comment into the database 

        SqlConnection connection = new 

          SqlConnection(@"server=IP address or server 

name;database=pdfindex;uid=username;pwd=password"); 

        try 

        { 

            connection.Open(); 

            SqlCommand cmd = new SqlCommand("insert into pdftable " 

              + "(PdfText, PdfId, Ext) values (@PdfText, @PdfId, @Ext)", connection); 

            // Insert values into the three columns. 



  Foxit PDF IFilter Server 

  Page 52 

            cmd.Parameters.Add("@PdfText", PdfText); 

            cmd.Parameters.Add("@PdfId", 1);// You can only upload a pdf file at a time. 

            cmd.Parameters.Add("@Ext", ".pdf"); 

            cmd.ExecuteNonQuery(); 

        } 

        finally 

        { 

            connection.Close(); 

        } 

} 

2. Once if it succeeds, you will be prompted to upload your PDF files as below: 

For SQL Server 2012 

 

For SQL Server 2005 

 

Note:  

The codes above uses ADO.NET as the data access mechanism, and C# as the 

development language. 

Starting a full population 

After completing the steps above, you should start a full population for the uploaded PDFs. 

Actually, there are two ways under SQL Server 2012/2008/2005 to synchronize full-text 

indexes with their table data: Full Population and Incremental Population.  

1. Full Population 
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A population when the index entries are built for all the rows in all the full-text 

catalog's tables.  

2. Incremental Population 

A population only adjusts index entries for rows that have been added, deleted, or 

modified after the last population.  

You may select to start a full population or an incremental population according to your 

needs. 

1. To start a full population, right-click the table you created > Full-Text index > Start Full 

Population. 

2. To start an incremental population, right-click the table you created > Full-Text index > 

Start Incremental Population. 

Searching PDFs 

After you finish indexing PDF files, you can start a search to find text within PDFs. Before 

you start a search, you have to verify if the full-text catalog or full-text index has been fully 

populated. 

To check the population status, please execute the following command: 

select fulltextcatalogproperty('PdfText','populatestatus') 

You can start a search if the return value is 0. 

To start a search, please execute the following command: 

USE pdfindex; 

GO 

SELECT PdfId 

FROM Table_1 

WHERE CONTAINS(PdfText, 'Foxit'); 

GO 
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More help  

For more information on how to work with Microsoft SQL Server, please refer to Microsoft 

SQL Server Help included in the product. 
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Chapter 5 - Foxit PDF IFilter for 

WSS 

Foxit PDF IFilter can help search text in PDF files. After installing Foxit PDF IFilter, you 

should upload your PDF documents with Windows SharePoint Services (WSS) before you 

start searching. 

Installing Foxit PDF IFilter 

Foxit PDF IFilter has two versions respectively for 32-bit Windows and x64 Windows. You 

can choose one of them to install into your machine according to your system 

requirements. Before installing Foxit PDF IFilter, please note that Microsoft SharePoint 

Services 3.0 has been installed successfully.  

To install Foxit PDF IFilter, please do the following: 

 Download Foxit PDF IFilter from Foxit Website (http://www.foxitsoftware.com) onto 

the machine where you wish to install it. 

 Run the Foxit PDF IFilter Setup program to install the IFilter. 

 Add the following registry entry, and then set the registry entry value to pdf:  

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server 

Extensions\12.0\Search\Applications\<GUID>\Gather\Search\Extensions\ExtensionList\38 

Please do the following:  

 Click Start > Run, type “regedit”, and then click OK.  

 In “Registry Editor” dialog box, locate and then click the following registry 

subkey:  

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server 

Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList 

 On the Edit menu, point to New, and then click String Value.   

 Type 38, and then press ENTER. 

 Right-click the registry entry that you created, and then click Modify. 

 In the Value data box, type pdf, and then click OK. 

 Verify that the following two registry subkeys are present and that they contain the 

appropriate values. 

http://www.foxitsoftware.com/
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Note: These registry subkeys and the values that they contain are created when you installed the 

Foxit PDF IFilter on the server. 

 Locate and click the following registry subkey: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server 

Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf 

This registry subkey must contain the following registry entry:  

Name: Default 

Type: REG_SZ 

Data: {987f8d1a-26e6-4554-b007-6b20e2680632} 

 

 Locate and click the following registry subkey: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server 

Extensions\12.0\Search\Setup\Filters\.pdf 

This registry subkey must contain the following registry entries:  

1) Name: Default 

Type: REG_SZ 

Data: (value not set) 

2) Name: Extension 

Type: REG_SZ 

Data: pdf 

3) Name: FileTypeBucket 

Type: REG_DWORD 

Data: 0x00000001 (1)  

4) Name: MimeTypes 

Type: REG_SZ 

Data: application/pdf 

 

 Download PDF icon from http://www.foxitsoftware.com/images/icons/pdficon.gif. 

http://www.foxitsoftware.com/images/icons/pdficon.gif
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 Copy the downloaded .GIF file to "Drive:\Program Files\Common Files\Microsoft 

Shared\Web Server Extensions\12\Template\Images". 

 Edit the file “Drive:\Program Files\Common Files\Microsoft Shared\Web server 

extensions\12\Template\Xml\DOCICON.XML”: 

 Right-click DOCICON.XML file > click Open With > select Notepad. 

 Add an entry for the .pdf extension. For example, where ICPDF is the name of 

the .gif file:  

<Mapping Key="pdf" Value="pdficon.gif"/> 

 

 

 On the File menu, click Save, and then quit Notepad.  

Note: This directly changes the icons shown on the search result. Make sure this changes take effect in 

the appropriate server where search results are displayed i.e. any web front end (WFE) that supports 

user interfacing. 

 Perform an iisreset: 

 Click Start > Run > type “cmd” in the Open line> click OK > type “iisreset” at the 

command prompt > hit Enter. 
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 Close the window. 

Note: In WSS2.0, Foxit PDF IFilter is installed on the computer which has SQL2005 

server. In WSS3.0, Foxit PDF IFilter is installed on the computer which has WSS3.0. 

Click to check the parts of Updating Foxit PDF IFilter and Uninstalling Foxit PDF IFilter 

Uploading PDFs 

To upload PDF files to Windows SharePoint Services 3.0, please do the following: 

1. Open your Windows SharePoint Services site and click Shared Documents. 

2. On the Upload menu, please click Upload Document.  

3. Click the Browse button to upload a PDF document and click OK. When it has been 

uploaded, you will be returned to the Documents page where you will see that your PDF 

file has been uploaded. 

 

Uploading a PDF file 

4. Stop and then start the Windows SharePoint Services Search service. Please do the 

following: 
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 Click Start > Run, type “cmd”, and then click OK. 

 Stop the Windows SharePoint Services Search service. To do this, please type "net 

stop spsearch" at the command prompt, and then press ENTER.  

 Start the Windows SharePoint Services Search service. To do this, please type "net 

start spsearch" at the command prompt, and then press ENTER. 

 Exit the command prompt. 

 

The command prompt 

Searching PDFs 

After you finish uploading PDF files, you can start a search to find text within PDF files. 

Also, you can search PDF document properties, such as author, title, etc.  

To start a search, please perform the following: 

 Go to the Shared Documents, please type the text you want to search in the search 

box > and then click the Search button . 
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 You will see your search results. Click to open one of the PDF files. 

 
Search results 

 

 

Open one of the search results 

Note: If the Windows SharePoint Services 3.0 Web site already had PDF documents 

before you installed the Foxit PDF IFilter on the server, you may have to perform an 

additional step. After you install and configure the Foxit PDF IFilter on the server, modify a 

property of the existing PDF documents on the server. For example, modify a metadata 

property such as the title, or upload the PDF documents to the Windows SharePoint 

Services Web site again. When you do this, the Windows SharePoint Services Search 

service crawls the existing PDF documents again.  
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More Help 

For more information on how to work with Windows SharePoint Services (WSS), please 

refer to Windows SharePoint Services (WSS) Help included in the product. 
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Chapter 6 - Foxit PDF IFilter for 

Microsoft Exchange Server 

Working in Exchange 2010 

Modifying registry information 

1. Install Foxit PDF IFilter on the platform where Exchange 2010 was installed. 

2. Modify the registry information 

1) Click start > run > type regedit to open the Registry Editor (regedit) 

2) Locate the registry subkey through the following path: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\MSSearch\CLSI

D\{987f8d1a-26e6-4554-b007-6b20e2680632} 

Add the following string value to the subkey by double-clicking :   

Subkey  Value 

{987f8d1a-26e6-4554-b007-6b20e2680632} Drive:\Program Files\Foxit Software\Foxit 

PDF IFilter\pdffilt.dll  

 

3) Create the following string value in the subkey you modified in Step 2): 

Value Name Type  Value Data 

ThreadingModel String (REG_SZ) Both 
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4) Locate the registry subkey through the following path:  

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\MSSearch\Filters 

Add the following string value to the subkey by double-clicking . 

 

Subkey  value 

.pdf {987f8d1a-26e6-4554-b007-6b20e2680632} 

 

Please refer to the following picture: 
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3. Please restart the Exchange Search service with following the step shown below: 

1） Click Start > Run > type “cmd” > click OK > type “iisreset” in the command prompt 

window > press Enter. 

 

 

2） Restart the Microsoft Search (Exchange) Service through the services console or type 

the following commands in the Exchange Management Shell. 

 

Stop-Service msftesql-Exchange –Force 

Start-Service MSExchangeSearch 

 

Indexing PDF attachments  

1. Start ‘services.msc’. 

2. Restart MSExchange Information Store service.  

3. Create an index by executing the following command in the Exchange Management 

shell.  

 

ResetSearchIndex.ps1 -force –all  

 

After the system completes the indexing, the result will be saved in the same location with 

Mailbox database.    
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Alternatively, you can use the resetSearchIndex.ps1 script. This PowerShell script 

accepts the name of the database you want to work with as an input parameter. As shown 

above, to get started, enter cd $env:exchangeInstallpath\Scripts, then run the script by 

entering .\resetSearchIndex.ps1 which is followed by the name of the database, i.e. 

\resetSearchIndex.ps1 EngineeringMailboxDb.  

Searching PDFs 

After finishing indexing PDF files, you can find the target PDF file with Foxit PDF IFilter by 

searching the text within PDF files or its properties, such as author, title, etc. 

To search a PDF file, please perform the followings: 

 

1. Visit the website https://exchangesever/owa  to open OWA (Outlook Web App). 

 (i.e. https://ex01.cpandl.com/owa) 

2. Login the mailbox in which you want to search PDFs. 

 

 

3. Please type the words you want to search in the search box, and then click the Search 
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button . 

 

The PDFs that contain the search terms will be showed under the Search box.  

 

 

4. Double-click to open the target PDF. 

 

Work in Exchange 2007 

Modifying the registry information of Foxit PDF IFilter 

1. Install Foxit PDF IFilter on the platform where Exchange 2010 was installed.  

2. Modify the registry information. 

1) Click start > run…> type regedit to open the Registry Editor (regedit) 

2) Locate the registry subkey through the following path: 
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HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\MSSearch\CLSID\ 

Add the following string value to the subkey by double-clicking :  

Subkey  Value 

{987f8d1a-26e6-4554-b007-6b20e2680632} C:\Program Files\Foxit Software\Foxit PDF 

IFilter\pdffilt.dll 

 

3) Create the following string value in the subkey you modified in Step 2): 

Value Name Type  Value Data 

ThreadingModel REG_SZ Both 

Flags REG_DWORD 1 

 

 

4) Locate the registry subkey through the following path:  

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\MSSearch\Filters.   

Add the following string value to the subkey by double-clicking .  

 

Subkey  value 

.pdf {987f8d1a-26e6-4554-b007-6b20e2680632} 

 

Please refer to the following picture: 
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3. Please restart the Exchange Search Service with following the step shown below:  

1） Click Start > Run > type “cmd” > click OK > type “iisreset” in the command prompt 

window > press Enter. 

 

 

2） Restart the Microsoft Search (Exchange) service through typing the following 

commands in the command prompt window. 
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net stop msftesql-exchange 

net start msexchangesearch 

 

 

 

Indexing PDF attachments  

1. Start ‘services.msc’ 

2. Restart Microsoft Exchange Information Store service. 

3. Create an index by executing the following command in the Exchange Management 

Shell. 

 

ResetSearchIndex.ps1 -force  

 

 After the system completed the indexing, the result will be saved in the same location as 

Mailbox database.    
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Searching PDFs 

After finishing indexing PDF files, you can find the target PDF file with Foxit PDF IFilter by 

searching the text within PDF files or its properties, such as author, title, etc. 

 

To search a PDF file, please perform the followings: 

1. Visit the website https://IP/owa/  (i.e. https:// 192.168.0.128/owa) 

2. Click to open a category that contains the target PDF file. 

3. Please type the words you want to search in the search box, and then click the 

Search button . 

 

The PDFs that contain the search terms will be showed under the Search box. 

 

 

4. Double-click to open the target PDF. 
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Chapter 7 - Additional Information 

Microsoft Developer Support 

Foxit PDF IFilter is a Dynamic Link Library (DLL) file that provides a bridge between a 

Microsoft indexing client and a library of PDF files. It consists of code that understands the 

PDF Format as well as code that can interface with the indexing client. When an indexing 

client needs to index content from PDF files, it will look in its registry for an appropriate 

DLL and will find the Foxit PDF IFilter. Foxit PDF IFilter will return text to the indexing 

client. The indexing client will then index the results and return the appropriate results to 

the user. 

Language Support 

This section lists languages supported by Foxit PDF IFilter. 

 German 

 French 

 Italian 

 English 

 Spanish 

 Portuguese 

 Russian 

 Chinese (traditional and simplified) 

 Korean 

 Japanese 

 Arab 

 Hebrew 
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Contact Us 

Feel free to contact us should you need any information or have any problems with our 

products. We are always here, ready to serve you better. 

 

 Office Address: 

Foxit Software Incorporated 

42840 Christy Street, Suite 201 

Fremont, CA 94538 

USA 

 Mailing Address: 

Foxit Software Incorporated 

42840 Christy Street, Suite 201 

Fremont, CA 94538 

USA 

 Sales: 

1-866-680-3668 (24/7) 

 Support & General: 

1-866-MYFOXIT or 1-866-693-6948(24/7) 

 Fax: 

1-510-405-9288 

 Website: 

www.foxitsoftware.com 

 E-mail: 

Sales and Information - sales@foxitsoftware.com 

Marketing Service - marketing@foxitsoftware.com 

Support & General - enter a trouble ticket via our Support Portal 

Website Questions - webmaster@foxitsoftware.com 
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