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Introduction 
 
 
The PYROTEC Composer is a valuable tool for creating pyromusicals. 
 
The included database provides the possibility to copy effects into the script and to determine 
exactly when these effects are to be seen in the show. All delays are automatically calculated 
and considered by the program. 
 
Visualisation functions display all sequences in real-time while the music is being played. 
 
Once the script is finished it can be transferred to the PFS Profi or the PFC Advanced. 
 
The PFE Profi Audio is used to play the music in order to achieve maximum synchrony. A 
wide variety of applications presents itself on boats, ships and fairground rides. The music is 
invariably played in crystal-clear CD quality. 
 
When wide spaces have to be irradiated acoustically with several loud speakers, there are 
some unwanted echo effects due to the fact that sound travels with approx. 330 m/s only. 
Normally, this is avoided by use of bulky delay-lines. Galaxis has solved this problem simply 
and effectively by adding the possibility to set a time shift of the music to be played. 
 
 
Note: Users who want to control other equipment with timecode have the opportunity to use 
one audio channel for the music (mono) and the other one for the timecode. One channel is 
used to feed the PA system and the other for control tasks of the user's choice. Of course, 
music and timecode can also be played back by the PFE Profi Audio. 
  
It is also possible to feed the timecode directly into the PFC Advanced, so a PFE Profi Audio 
is dispensable. 
 
The decisive advantage of this concept is the excellent reliability resulting from the fact that 
neither a PC nor a notebook is needed for firing the pyrotechnic effects or playing the music. 
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Definitions 
 
Following are explanations of terms and proper names to advocate better understanding of the 
manual: 
 
'Galaxis Composer' is a software for creating pyromusicals on a PC.  
 
'Dongle' is a hardware device to protect software from being copied. It can be compared to a key. The 
dongle must be connected to the PC to run this program. The software may be installed on any 
number of PCs. In case of loss of the dongle there will be no replacement free of charge. 
 
'Wave file' is an audio file (*.wav). It contains uncompressed audio information. There are different 
kinds of Wave files, differing in quality (mono/stereo, sampling rate, bits per sample). Please make 
sure that Wave files used with Galaxis products comply with the following parameters: stereo (2 
channels), sampling rate 44.100 Hz (44,1 kHz), 16 bits per sample and channel.  
These parameters indicate CD quality. All Wave files with others than the above mentioned 
parameters can not be processed or will cause malfunction. 
 
'gpf file' (*.gpf) is a file created by the Project Maker. It contains only sound data.  
The extension stands for 'Galaxis Project File'.  
The PFE Profi Audio can only play gpf files.. In order to work with this device, a gpf file has to be 
generated from a WAV file with the Project Maker first. 
 
'gs2 file' (*.gs2) is the new extension for scripts created with Version 2. 
It is possible to import old scripts (gsc files) into the new version. 
 
'gd2 file' (*.gd2) is the new extension for database files created with the new Version 2. 
Database files with the extension *.gdb of Version 1.0 can be imported into Version 2.0 
 
'zip file' (*.zip) is a compressed file, also known as 'archive'. The well-known software WinZip can be 
used as a tool to extract a zip file.. 
 
'Card' or 'Flash card' – whenever one of these terms is used in this manual, CompactFlash cards type 
1 are meant exclusively. These cards are widespread in the field of digital photography and offer the 
best price per MB in comparison to other flash storage media. One minute of music needs approx. 10 
MB of memory space as a guideline. 
 
 
 

Trademarks 
 
CF

®
, CompactFlash

®
 are trademarks and / or registered trademarks of CompactFlash Association in 

the USA and / or other countries; CompactFlash
TM

  is a trademark of SanDisk Corporation; Microsoft
®
, 

Windows
®
, Explorer

®
, Excel

®
 are trademarks and / or registered trademarks of Microsoft Corporation 

in the USA and / or other countries;  WinZip
®
 is a trademark and / or registered trademark of WinZip 

computing Inc. In the USA and / or other countries. 

 

All other product or brand names are possibly trademarks or registered trademarks of the 
corresponding legal proprietors. 
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Minimum system requirements 
 
Please make sure that the following minimum system requirements are met: 
 

• Windows 98/2000/ME/XP/NT/Vista 

• Processor with a minimum clock frequency of 3,000 MHz = 3 GHz 

• 2048 MB = 2 GB RAM minimum 

• A minimum of 500 MB free disc space. For saving Wave files you need approx. 10 MB per 

minute of music, so please allow for some free GB of disc space for your Wave files if you 

plan extensive projects.  

• High capacity VGA graphics adapter, at least GeForce 7 series or comparable  

• CD-ROM drive 

• Stereo sound card with loudspeakers or headphones 

• Mouse or equivalent 

 
 
 

Installation 
 
Please proceed as follows: 

• Close all other applications. 

• Make sure that the supplied dongle is NOT YET INSERTED 

• Insert the enclosed CD-ROM into your drive. The installation program starts automatically. If 

you have deactivated the auto start function, you can start the setup file (setup.exe) in the root 

directory of the CD-ROM. 

 
 
Required setting when installing the program under Windows Vista: 
 
If you install our program under Windows Vista, please assure that the file setup.exe is executed in 
Windows XP compatibility mode and as administrator. For that purpose, please proceed as 
follows: right mouse click on setup.exe > properties. Select 'compatibility' in the following window. 
Check the check box 'Run Program in Compatibility Mode' and select 'Windows XP (Service Pack 2)' 
as operating system. The installation will start with the next right mouse click on setup.exe and a left 
mouse click on 'Run as administrator'.  
 
Then the following window appears: 
 

 
 
Click 'Install' to continue. 
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Now the driver for the provided dongle is installed. Please select the kind of dongle you ordered and 
click 'Next'. 
 
 

 
 
 
The installation program indicates the drive and directory where the software will be installed. You are 
then requested to quit all other applications. 
 
When this is done, please click 'Next'. 
 

 
 
Now the installation program updates your system. 
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When the installation is completed successfully click 'OK'. 

 
If you use an USB dongle, you may insert it now while your system is operating. 
 
If you use a resolution of 1.024 x 768 pixel (XGA), the Windows task bar will hide the lower part of the 
Composer window. Therefore please adjust your system so that the task bar is hidden automatically. 
In the 'Start' menu, select 'Settings', then 'Task bar and Start menu'. Now select 'Auto Hide', then click 
'Apply' and confirm with 'OK'. 
 
 

 

 
 
The installation program creates the entry 'Galaxis Pyrotec' in your start menu under 'Programs'. 
 
 
In case of questions, please contact the manufacturer: 
 
Galaxis Showtechnik GmbH 
Emmertinger Str. 2 
D-84524 Neuötting 
 
Phone: +49 8671 / 73411   Internet: www.galaxis-showtechnik.de 
Fax: +49 8671 / 73513   E-Mail: info@galaxis-showtechnik.de 
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Start the Composer 
 
To start the program, click 'PYROTEC COMPOSER V2' in your 'Start' menu. 
 
The start window appears, displaying the software version. 
Now select your language and click 'OK'. 
 

 

 

Illustration of the Composer's graphical user interface 
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Explanation of the Composer's graphical user interface 
 
1 Menu Bar 
2 Toolbar 

Allows quick loading / saving of the database and database / script search. Drag the cursor over 
an icon to see the tooltip. 

3 Effect Database Table 
All available effects can be entered and saved here with their detailed description. Entries like 
rising time, description, duration, colors, as well as the number of parts on stock, or videos are 
possible. By clicking 'Database' once, you maximize the window while minimising the script 
window. The number of entered effects is displayed in brackets. 

4 Index Tab Database Table 
Offers the possibility to save five different profiles for display settings by selecting 'File > 
Customize database table'. 

5 Index Tab Script Table 
The script is the firing script. Open the menu 'File' and select 'Open Script' on the menu bar to  
open an existing script. In case you want to open a script created with Version 1, please select 
'File > Open Script V1.0...'.  In brackets, the number of employed effects is shown. By clicking 
'Script' once, you maximize the window while minimising the database window. The graphic field 
is also maximized. The number of entered effects is displayed in brackets 

6 Index Tab Script Table 
By selecting 'File > Adjust Script-Table' six different profiles for display settings can be saved. 

7 Column for marking lines in the Script Table 
Marks the line in the script table that can currently be edited. By clicking into a field of this 
column, the corresponding line in the script is marked. All editing functions apply only to this  
exact line. The marked effect is displayed as a yellow underline in the graphic field (8). If several 
identical effects have been selected, only the first one is marked in the graphic field. Vice versa, 
you can also select an effect in the graphic field. 

8 Graphic field  'Effect Times' 
The purpose of this field is the visualisation of the timing parameters of all effects employed in a 
script. The firing time, effect delay, effect time, effect duration, effect color(s) and the ending of an 
effect are graphically displayed. 
Effects can be marked then be moved by pressing the left mouse button and the 'Shift' key 
simultaneously. 

9 Graphic field 'Wave Form of the Selected Section' 
This field displays the acoustic information of the music graphically. It always shows the 
information of the currently selected section of a Wave file. This could be the entire Wave file or 
only a fraction of it (see: zoom functions). 

10 Pointer 
The pointer indicates the current position in the Wave file for easy orientation while a piece of 
music is being played. A left mouse click either in field (8) or (9) moves the pointer to any 
position. The same result is achieved with a right mouse click, however then the Composer starts 
playing the music again from this position. 

11 Graphic field 'Total Waveform' 
This field is used to overlook the entire Wave file. The cyan rectangle in this field indicates which 
section is currently displayed in field (9). 

12 Control buttons 'Scroll Left' and 'Scroll Right' 
These buttons only work when the zoom function in the Wave file is activated. By clicking these 
buttons, the display section moves left, or right respectively. 

13 Control buttons 'Zoom Out Full' and 'Zoom In Full' 
Click 'Zoom In Full' for maximum zoom. When clicking 'Zoom Out Full' the entire Wave file is 
displayed in field (9), with no zoom function activated. These functions are also to be found in the 
menu 'Zoom'. 

14 Control buttons 'Zoom In' and 'Zoom Out' 
By clicking these buttons, the scale-up factor can be in- or decreased. These functions are also to 
be found in the menu 'Zoom'. 

15 Control buttons 'Amp +' and 'Amp -' 
Depending on the volume of the selected passages of music to be edited, the acoustic 
information is displayed in lower or higher curves. With these buttons, the display of the music's 
amplitude can be perfectly adapted to the graphic field, the amplification factor can be adjusted. 
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16 Control button 'Matching End' 
With this function, an effect can be integrated in the script in a way that its end matches exactly 
the position of the pointer. 

17 Control button 'Normal Mode' 
Enables you to return from 'Replace Effect' or 'Music Scan' mode back to normal mode 

18 Control button 'Replace Effect' 
With this button you change from normal mode or 'Music Scan' into 'Replace Effect' mode. 
Further information on this item is available under paragraph 'Replacing effects' in this manual. 
This function can be switched on or off under the menu item 'Script' on the menu bar. This 
function has to be activated again for each individual effect you wish to replace. 

19 Control button 'Music Scan' 
With this button you change from normal mode or 'Replace Effect' into 'Music Scan' mode. 
Further information on this item is available under paragraph 'Music Scan' in this manual. This 
function can also be operated via the menu bar under 'Extras'. 

20 Control elements for music 'Play', 'Pause', 'Stop' 
With these buttons, Wave files can be played from pointer position, be paused or stopped. After a 
stop the pointer returns to the beginning of the Wave file. 

21 Volume control 
With this slider the computer's play-back volume can be controlled. This parameter has no effect 
on the volume the music file is going to be played at later during the show. If you hear nothing or 
the volume is too low, please make sure that the volume sliders in the menu 'Sounds and Audio 
Devices Properties' of your operating system are set sufficiently high. This menu can be found 
under  'START > Control Panel > Sounds and Audio Devices > Volume'. 

22 Balance control 
This slider changes the volume ratio between left and right channel This is helpful if one of the 
channels is used as timecode source, so it can be set to mute. 

23 Display field 'Time' 
Always shows the exact position of the pointer.  

24 Display field 'SMPTE' 
Displays the position of the pointer in timecode. 

25 Display field 'dt' 
The abbreviation dt stands for 'delta time' meaning time differential. If your mouse pointer is 
positioned in field (8) or (9) and you keep the left mouse button pressed, moving the mouse to the 
left or right, a vertical yellow line appears at the position you started pressing the left mouse 
button. A red pointer moves with the mouse pointer. The 'dt' field shows the time interval between 
the yellow and the red lines, until the mouse button is released. So this function offers a 
convenient time scale. 

26 Display field 'Total €' 
Shows the total amount of sales prices of all effects included in a script, net as well as gross 
(subject to correct entries in the database). 

27 Display fields 'Progress Bar' and 'Message' 
If current procedures or calculations require some computation time, a progress bar appears in 
this field. Below it, a short description of the current procedures or calculations is displayed. 
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Effect database 
 
The effect database constitutes the basis for creating a script. Besides the regular item master data, it 
contains further important details, for example effect duration, effect delay and many more. 
 
By selecting 'File' on the menu bar, databases (*.gd2) can be opened, imported, saved and saved 
under a new name. 
 
By selecting 'File > Create Database' on your menu bar, you create a new database. 
You can see in the top window 'Database', that three records are already entered. 
The first entry named 'Music Scan' should be left unchanged, because this effect serves as a 
placeholder for effects that will be inserted later. 

 

The other two entries serve as examples and can be replaced with your own effects. 
 
For importing a database created with the Composer Version 1, please select 'File > Import Database 
V1.0' on your menu bar. We recommend to save the imported database with the file extension gd2. 
 
Vice versa it is also possible to export a Composer database to Excel (File > Export Excel Database). 
 
As the database gets a bit unwieldy displaying every single effect in details, we provide the possibility 
to create different profiles with individual display settings. Click 'File > Customize Script Table'  on your 
menu bar. In the following window, select a profile, choose a name for it and confirm with a click on 
the disc symbol. Now the effect characteristics to be included in this profile can be moved from the left 
to the right window. Confirm by clicking 'OK'. Up to six different layouts can be created for your 
database without having to reconfigure it. 
 
 
 

Edit and add new effects 
 
After having opened a database, effects can be edited or new effects added.  
You have to change the window to the database view. (Window -> Database) or (F9) 
Then, the editing window for database effects should appear. 
 

 
 

 
 
You can now enter various parameters. The most important characteristics for creating a pyromusical 
are item, size, effect delay or rather rising time, effect duration and color. 
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In order to be able to remove used effects from stock, the number of pieces on stock should be 
entered. It is also useful to enter the price per effect into the database to allow for an overview of the 
total costs all effects of your pyromusical are going to amount to. 
 
When adding a new effect, first a free ID has to be selected in the bottom window. This can be sped 
up by clicking once on the right lower button. Select 'Database > New Data Record' on the menu bar, 
then you can enter the characteristics of an effect. 
 
Under 'Database', effects can also be copied, pasted or deleted. 
 
The search function under 'Database > Search' (optional F1 or green 'spyglass' icon) makes it quite 
easy to find a particular effect even in a very extensive database. 
 
 
 

Import a Excel database 
 
In case you want to import an existing Excel database, please select 'Import Excel Database' in the 
menu 'File'. A dialogue window appears. Then the Excel file can be opened by clicking 'File > Open 
Excel Table…'. 

 

Note: To avoid malfunction when opening the Excel file, please make sure it does not contain 
superfluous information. We recommend to first create a new spreadsheet in Excel and copy only the  
required cells (without formulas and references) into it, before importing it into the Composer.  
 
The respective window could look as follows: 

 

 
 
With this window, your existing database can be adjusted to the new Galaxis database. The columns 
of your old file have to be assigned to the new one.  
 
The left window shows the contents of the open Excel file. 
 
Procedure: 
 

• Mark a column in the existing file with a mouse click in the column's header cell. 

• The display field 'Marked Column' now shows the number of this column. 

• Decide which column of the new Galaxis database you are going to assign it to and left-click 

into the empty field 'Column'. 
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• Then the indicated column number is entered into this field. 

• In order to delete the assignment of a column, click into the corresponding field with the right 

mouse button. 

 
If you want to delete all assignments, select 'Delete Assignment' in the menu 'Edit'.  
 
When your assignments are completed, click on the button 'Accept Assignment' at the bottom left.  
 
In addition, the database offers the possibility to export the stock list. Select 'Export Stock List' in the 
menu 'File'. In the dialogue window that appears then, you can enter the file name and memory 
location. 
 
Finally, also the entire database with all fields can be exported by selecting 'Export Database' in the 
menu 'File'. Empty records are disregarded. 
 
 
 

Open the effect database 
 
Effect database files are saved with the file extension *.gd2. 
The extension 'gd2' means 'Galaxis Database Version 2.0'. 
 
Effects are always transferred from the database to the script. With each entry in the script, all data 
are automatically transferred and included. Each effect that has been entered in the database can be 
included in the script, it just remains to be determined when this effect is going to be applied during the 
show. 
 
Open your effect database by selecting 'Open Database…' in the menu 'File'. 
 
 
 

Save the effect database 
 
If you have altered the stock list in your effect database (added, changed, deleted or taken effects out 
of stock), the database has to be saved in order to validate the changes.  
 
Save your effect database by selecting 'Save Database' in the menu 'File', or by clicking on the green  
'Save' Icon.  
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Database search function 
 
A search can be started as soon as a database has been opened. Select 'Database > Search' on the 
menu bar. Alternatively press 'F1' or the green 'spyglass' icon. The following window appears: 
 

 
 
Here you choose the column in which a given criterion or value is to be searched. Additionally you can 
indicate if you are looking for an indoor or an outdoor effect. 
 
If 'Stock' is checked, all effects where number on stock = 0 are excluded from the search. It is not 
necessary to write the complete name of the effect. In the above illustration you can see for example, 
that all effects that have 'cross' in their name will be listed, e.g. 'Crossette Shells' and 'Crisscross 
Shells', if their number on stock exceeds 0. 
 
Note: To see all entries of the effect database in the table, all search criteria have to be cleared by 
clicking on the crossed out green 'spyglass' icon. 

 
 
 
Refresh the Database 
 
It is not possible for the composer to update the value 'Used Effects' in the database all the time.  
This function would need to much system resources when you are inserting new effects.  
To calculate the current costs and the value of the 'Used Effects' use the function 'Refresh Database'. 

 
 
 
Remove effects from the stock 
 
You activate the 'Remove from stock'  function by selecting 'Database > Remove Effects from Stock" 
on your menu bar. 
 
After having finished a project, the effects you used for it can conveniently be deducted from your 
stock list in the database. 
 
Note: An error message is displayed, if an item in the script could not be found in the database. This 
happens easily when item names have been changed manually in the script. Where applicable, the 
stock list for these items has to be adjusted individually. 
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Open a Wave file 
 
When designing a music synchronized pyrotechnical display, the first step is the selection of the 
music. 
 
On a normal CD, the music is stored digitally. The commonly used file format is called RAW and 
almost every CD drive of any PC is able to read it. 
 
It is common practice to use the Wave file format to process music on a PC. A software that converts 
and copies the RAW tracks from the audio CD to the PC's hard disk is supplied with most CD writers. 
 
In case you do not have such a software, you can use the freeware program 'Cdex' we provide with 
our product. The program has been copied to the 'Tools' folder in the installation folder as a 
compressed zip-archive during installation.  
 
'C:\Program\PYROTEC COMPOSER\Tools\' 
 
Extract this file with WinZip and follow the instructions of the program 'Cdex'. In this context we would 
like to point out that we do not assume liability for supplied software products of other manufacturers 
or originators. 
 
After having saved the Wave file of your choice on the hard disc of your computer, you may edit this 
piece of music with appropriate programs and for instance cut the track or fade it with other tracks. 
Various programs are offered in the internet for this purpose. 
 
GoldWave is a recommendable program for editing music on a PC. This software is shareware and 
can be found in the 'Tools' folder as well.  
 
'C:\Program\PYROTEC COMPOSER\Tools\' 
 
Please take the opportunity to test it and consider buying it in accordance with the manufacturer's 
terms if you decide to use this product. In this context we would like to point out that we do not 
assume liability for supplied software products of other manufacturers or originators. 
 
The only file format which can be used as a source of music for the Composer is Wave format (file 
name.wav). 
 
The Wave files have to feature the following parameters if used with the PYROTEC Composer: 
 
Sampling rate:   44.1 kHz 
Channels:    2 (Stereo) 
Word length / Sample:  16 Bit 
 
These are the exact features that describe CD quality. The above mentioned programs save Wave 
files on the hard disc with these parameters most likely.  
 
These parameters strongly influence the sound quality and the required memory space. As memory 
space is no issue nowadays, we have not provided the option to use files with inferior quality. 
 
In case you wish to work with Wave files which do not comply with the above mentioned standard (for 
example 8 bits or mono or different sampling rates), they have to be converted with a suitable program 
before usage. 
 
The same applies for MP3 files which can be converted to Wave files by use of 'Cdex' or 'GoldWave'. 
 
Attention: The Wave files you use here are going to be played back by the PFE Profi Audio later. We 
recommend to take care from the beginning that the sound quality complies with the requirements of 
the show. 

 

Open a Wave file by selecting 'Open Wave file…' under 'File' on your menu bar. The dialogue window 
offers the choice of drive, folder and file name. 
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If you are opening a Wave file with the Composer for the first time, the following window appears: 
 

 
 
 
The Composer displays the audio information of the Wave file graphically and thus permits a 
convenient and precise cue alignment to the music. 
 
In order to avoid the program having to work constantly with the relatively extensive amount of data of 
a Wave file, we have included a data reduction. 
 
The result of this data reduction is the waveform file. 
 
Note: In this process, the program creates a new file. Therefore it is necessary that the source file 
(Wave file) is available on a drive which can be written on. Consequently, CD ROM drives and write 
protected drives cannot be used. 
 
Before creating the wave form, please determine which channel is to be used for computation: Both 
channels, only the left one or only the right one. Usually, both channels are used. Only if you want to 
use one channel for the music and the other one for timecode, you should exclude the latter one. 
 
The calculation of the wave form is quite complex. Each minute of music requires approx. one minute 
of computation time (assuming a system with a clock frequency of 3 GHz) 
 
During calculation, the message 'Creating Waveform', as well as a rotating hourglass appear. 
 
As soon as the waveform file has been created, the acoustic information of the source file is displayed 
on the Composer's graphical user interface. 
 
In case you alter the Wave file after having created the wave form file, the function 'Create new 
Waveform' in the 'File' menu can be used to adapt it, so the graphic information on your screen 
corresponds with the contents of the Wave file again. 
 
 
 

Create a Wave file 
 
This function is used to design a fireworks display without music with the Composer. 
 
Here a Wave file can be created that contains clock pulses once a second for better orientation on the 
time scale. Loading this file as a substitute for the music, the graphic field (9) shows the second's 
scale. 
 
After having selected 'Create Wave File...' from the menu 'File' a window appears asking you to 
determine a file name or to select an existing file for overwriting.  
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Afterwards the following window is displayed: 
 

 
 
 
Please enter the desired duration of the Wave file to be created, ranging from 1 to 100 minutes. After 
having confirmed your entry with 'OK', the program begins with the computation. Subsequently, the file 
can be opened by clicking 'Open Wave File...' in the menu 'File', and an *.ave file can be created. 
 
 
 

Create a Wave Timecode file 
 
In order to be able to control other show parts like light shows, dancing water fountains or Laser 
systems, it may be necessary to transmit a timecode signal. It is distributed by an audio cable like 
music and can be played back by any audio device, also by the PFE Profi Audio. 
 
If timecode is put on one audio channel, for example the right one, while the left channel is used for 
the music, an ingenious advantage is achieved: Music information and sync information (timecode) 
are played simultaneously. There isn't the slightest danger of mismatch, regardless of the duration of 
the show. 
 
This function provides the opportunity to create a Wave file which contains music on one stereo 
channel and timecode on the other one. 
 
There are various types of timecodes. The one most commonly used is SMPTE 25fps.  
Timecode was invented for the TV and video sector characterized by the 'fps' parameter. 'fps' stands 
for 'frames per second'. Solely this type is intended for use with the Composer. 
 
By selecting 'Create Wave-Timecode file...' in the menu 'File', the following window appears: 
 

 
 
 
'Wave Source' is for selecting the file which contains the audio information. 'Destination file' is used to 
enter the file name of the Wave file to be created which is gong to contain the audio as well as the 
timecode information. 
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With 'Timecode Start', the starting point of the timecode counter is determined. 
 
It is standard practice to agree upon a show start with the other show operators. It is also common to 
start with some minutes blank offset so that everyone can check if the synchronization works  
accurately. So you can stop the show right at the beginning without anyone noticing that there was a 
problem. Then you can retry after fault finding. 
 
If you agreed for example on 00h 00m 00s 00f as a show start, than the actual beginning of the 
transfer with a certain offset could be 23h 55m 00s 00f. This would lead to an overflow condition the 
moment the show started. As some devices with timecode inputs are not able to process this overflow 
correctly and may break down, it is advisable to set a show start where an overflow cannot occur. The 
show start could be set at 01h 00m 00s 00f with an offset at 00h 55m 00s 00f. 
 
It is also possible that you intentionally use another offset value at the PFC Advanced than the 
operators of the other show parts do e.g. if the pyro part is at the end of a longer concert. 
 
Small changes to the offset value can be used deliberately to fire the effects slightly earlier or later.  
In principle this leads to a slight offset of the whole firing sequence.  
 
'Wave Start' determines when the Wave file begins. If the entered value is higher than 0, the program 
inserts a pause. Here, the same amount of time that you intended as offset should be entered. 
 
'Duration' specifies the total duration of the Wave file to be created, the minimum value being the 
duration of the source file plus the selected offset. If your show is intended to last for example 15 
minutes, with an offset of 5 minutes, then the total duration should at least be 20 minutes, otherwise 
the end is going to be cut off. 
 
With the control buttons 'Timecode left Channel' and 'Timecode right Channel', the channel that will be 
used for storing the timecode is selected. 
 
By clicking 'Start' the computer starts creating the file. The 'Status' field informs you about the task's 
progress. 
 
When using a Wave file which contains both timecode and music, only the channel with the music 
information is to be drawn on when creating the *.ave file. Please see section 'Open a Wave file...' in 
this manual. 
When a Wave file which contains music and timecode is played back, both are audible. In order to 
suppress the sound of the timecode, the balance slider has to be adjusted so that only the music 
channel can be heard. Your operation system features a control window titled 'Playback Control', to be 
found under 'START > Control Panel > Sounds and Audio Devices > Volume'. If the audio outputs of 
your PC are connected to a sound system, the balance can also be adjusted at the amplifier. 
 
 
 

Display a Wave file 
 
The contents of the entire Wave file is always displayed in graphic field (11). Depending on the 
activation of the zoom function, the contents in part or in total is shown in graphic field (9). 
 
A cyan rectangle in graphic field (11) indicates which section is being displayed in field (9). Field (11) 
is intended to provide an overview. Field (9) is used for detailed script editing. 
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Zoom functions and zoom area 
 
With the control buttons 'Zoom In' and 'Zoom Out' the magnification factor of graphic field (14) can be 
adjusted. 
 
With 'Zoom In Full' (13) maximum zoom of the graphic display is set directly. 
With 'Zoom Out Full' (13) the zoom function is set inactive. 
 
With 'Scroll Left' and 'Scroll Right' the displayed section in graphic field (9) can be scrolled to the left or 
to the right if the zoom function is active. 
 
 
 

Adjust the amplitude 
 
With the control buttons 'Amp +' and 'Amp -' (15), the display of the music's amplitude can be adapted 
to the graphic field by increasing or decreasing the amplification factor, depending on the volume of 
the music to be edited. 
 
 
 

Play-back functions 
 
With 'Play', 'Pause' and 'Stop' (20) the play-back of music is controlled. 
 
The pointer (10) adjusts itself accordingly. 
 
If there are any effects included in the script, the line marking in the script table (5) is updated, too. 
 
 
 

Play the music with the PFE Profi Audio 
 

In order to play the music with the PFE Profi Audio it is necessary to convert the Wave file to a project 
file. This is done with the program 'Project Maker', which is available free of charge in the download 
section of our website. 'Project Maker' saves the project file on a flash card. A detailed description how 
to proceed is to be found in the manual of the PFE Profi Audio. 
 
 
 

Create a script file (firing script) 
 
Script files are saved in *.gs2 format. 
The extension 'gs2' stands for 'Galaxis Script Version 2.0'. 
 
Effects can only be inserted in a script, if a database has been opened. 
 
Double-click with the left mouse button in the line with the required effect in the database table in order 
to insert it into the script. 
 
The effect is inserted at exactly the point in time the pointer (10) is situated at. This can also be done 
while the Wave file is being played, however it may take a certain computation time. As soon as the 
pointer moves again, the next effect can be inserted. To set effect cues in real-time more comfortably, 
we recommend applying the function 'Music Scan', which is explained in details later on. 
 
After having inserted an effect into the script, a visualization of its delay, duration and color(s) is 
displayed in graphic field (8). The delay, for example in case of an outdoor firework, is the time the 
shell requires for its rise to the sky. Every effect is represented by a bi-colored line. A grey line means 
that the effect has already been fired, but is not yet visible. The colored part of the line indicates the 
effect duration, meaning the time the effect is actually visible, as well as the color. 
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What is inserted at the position of the pointer is the exact moment the effect bursts. The effect delay is 
included in the calculation of the ignition point. 
 
Note: For the consideration of the effect specific delay and duration it is mandatory to enter the data of 
all effects to be employed into the database. 
 
If several effects have been inserted into the script, so that their lines would overlap, the lines in field 
(8) are displayed stepped one upon the other. 
 
In case the complete visualization exceeds the height of field (8), the scroll bar at the right side of the 
display area can be used or you can choose the other views.  
Please use in the menu 'Window' the different views. 
 
Effects can be relocated directly in the graphic field (8) by keeping the 'Shift' key pressed and moving 
the displayed effect with the left mouse button held down. 
 
 
 

Edit a script 
 
Nearly every column of the table can be altered by a double click into any of its fields. 
If you have chosen more than one row of a column you can edit this with a click on the right mouse 
button. 
 
Changes become valid immediately after their entry. 
If for example the duration of an effect is changed from 2 to 10 seconds, the line that indicates this 
effect is instantly displayed much longer. 
An increase of an effect delay causes a corresponding earlier firing time for this effect. That's why the 
script is resorted each time a delay has been changed and the firing time had to be recalculated. 
 
The following fields can not be changed: 
 
- SC-ID 
- Channel 
- dt (s) 
- Firing time 
- Step Delay 
 
Please keep in mind that changes to the script are not passed on to your stock list. Only those effects 
that have been transferred from the effect database to the script are deducted from your stock. 
 
Double-click until the desired angle is reached or use the following short cuts on your keyboard after 
having marked the according field. 
Also here you can choose more than one row of these columns with the left mouse button and you 
can open the 'Edit Script' window by pressing the right mouse button. 
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Program the stepper 
 
In order to implement steps with intervals below 0.3 seconds, these must be entered in the script by 
use of the columns 'Step Channel' and 'Step Delay(s)' in the script window. 
 

 
 
The firing channel is to be entered in the column 'Step Channel'. 
The Step time which has to be used for programming the receiver is automatically calculated in the 
column 'Step delay (s)'.  
Also here you can choose more than one row of the column 'Step Cue' with the left mouse button and 
you can open the 'Edit Script' window by pressing the right mouse button. 
 

Please note that the step channel of the previous firing channel has to be entered, otherwise the step 
delay will be very long. 
 
 
 

Menu items of the menu 'Script' 
 
On opening the menu 'Script', the following items appear: 
 
 

Macro 
 
This function is for creating a series of firings at a predetermined position. For example, a series of 5 
Shells connected by a time fuse can be simulated. The Shells are displayed in the script as 5 
successive effects. 
 
 
 

Edit Effect Group 
 
With this function you can move a group of several effects. 
First choose the rows in your script that you want to move in a group. 
Then select the function 'Edit Effect Group' in the menu. 
The window 'Edit Effect Group' appears and you can choose if you want to move the whole group for 
some seconds or milliseconds or you can change the time between the firing of the effects like a 
stepping sequence.  
 
After you have made your selection press the 'Start' button to continue. 
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Replace effects 
 
First, the line that is to be furnished with another effect, has to be marked in the script or graphic 
window. 
 
Then, select the function 'Replace Effect' in the menu. Now double-click with the left mouse button into 
the line in your database with the required effect. 
 
Alternatively to this procedure in the 'Script' menu, you can also click on the control button 'Replace 
Effect' (18) on the graphic user interface  
 
 
 

Duplicate effects 
 
First mark the line in your script you want to duplicate. Then, select the function 'Duplicate Effect' in 
the menu 'Script'  (alternatively use the combination Strg + D on your keyboard). The program pastes 
a copy below the marked line.  
 
 

Multiply effects    
 
First mark the line in your script that you want to multiply. Then select the function 'Multiply Effect' in 
the menu 'Script' and type in a multiplier between 1 and 100. 
Then the program pastes copies below the marked line. 
 
 
 

Copy and paste effect(s) 
 

First, mark the line(s) to be copied in the script or graphic window. 
 
Then, select 'Copy Effect(s)' in the 'Script' menu, or use the shortcut Strg + F on your keyboard. 
 
For pasting, select 'Paste Effect(s)' in the 'Script' menu, or use the shortcut Strg + G on your keyboard. 
When pasting effects, there is the possibility to either paste the copy at exactly the same position 
('absolute time'), or to paste the copy at any new pointer position ('relative time against pointer'). 
 
This function is useful in case of repetitive music sections or if part of an already existing script are to 
be included in a new one. The copied effects are stored in an internal memory and are inserted also 
after a new Wave file or script has been opened. 
 
 

Delete lines 
 

First, mark the line(s) to be deleted in the script or in the graphic window. Select 'Delete Effect(s)' in 
the 'Script' menu to delete. Alternatively, you can use the shortcut Shift + Del. 
 
 

Delete a script 
 
In case the complete contents of a script table has to be deleted, select 'Delete Script' in the 'Script'  
menu. The program requests a confirmation in order to avoid the accidental deleting of data. 
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Device allocation depending on Position 
 

In the menu bar under 'Script' you find the function 'Device Allocation depending on Position'. 
The following window appears: 
 

 
 
After having decided how many positions you are going to use for your firework display, these are 
entered in the column 'Position'. 
 
By double-clicking the left mouse button, the appropriate of the above noted options for positions can 
be selected in the column 'Position' of the script window. Instead of selecting the position in the drop-
down menu, the line number for the desired position can also be entered by the num-pad. The 
allocation of positions for very complex scripts can be simplified that way. The entered numbers can 
be deleted by pressing 'Del' or with the comma key on the num-pad. 
 
It is indispensable to name a position for each effect that is going to be connected to an output. 
That is the only way to make sure that the exact number of outputs is going to be displayed correctly 
in the above window later on. If you plan, for example, to fire a series of effects by use of time fuse, it 
is advisable to allocate a position just to the first one of these effects. Only that way, one output is 
used for all connected effects. 
 
After completion of the script, the device allocation can be finished in the above window. To do so, 
please select one or more receivers in the line showing the different positions, bearing in mind that a 
sufficient number of outputs has to be available. 
 
It is also to be assured that each receiver is assigned to a specific device number, which has to be 
programmed at the corresponding Advanced receiver. Only PFE Advanced with 10, 50 or 100 outputs 
can be remotely programmed. The exact procedure of remote programming is to be found below in 
section 'PFM Advanced'. 
 
All Profi receivers have to be programmed directly and manually. Confirm your entries with the OK 
button. 
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Auto device and output allocation 
 
Now that all devices with their sufficient number of outputs have been allocated, the devices and their 
outputs have to be assigned to the firing channels. Select 'Auto Device and Output Allocation' and 
'Start' > 'Devices and Outputs' in the 'Script' menu. 
 

 
 
These are then displayed in the script window, in the columns 'Output#' and 'Device#'. The device 
number is taken over from the above table and the outputs are assigned in ascending order. 
Consequently, maximum utilization of the available outputs is achieved.  
 
If you would like to delete the allocation please select 'Auto Device and Output Allocation' and 'Delete'. 
 
 

 

Test delays 
 
If the firing time of channel 1 indicated in the script is not 00.00.00, you are advised that channel 1 is 
always immediately fired when an automatic program is started. Therefore we recommend to set a 
music scan at 00.00.00 at each firework display, even if no effect is to be fired. 
The cue 1 is usually used to start the PFE Profi Audio receiver. 
 
Also with this function, unacceptable delays between individual firings can be avoided. (column 'dt' in 
the script). Values below 0.3 seconds or exceeding 999.9 seconds cannot be processed. The program 
is going to issue an error message if that problem occurs. It can be avoided by a minor change of the 
effect time or by using the step function. 
 
Furthermore, firings with a resolution of 1/100s are not accepted. Firings can only be executed when 
entered with a resolution of 1/10s, otherwise please use the stepper, which can be programmed in 
steps of 1/100s .  
 
A data transfer with unacceptable delays cannot be executed. 
 
 
 

Transfer a script to the PFS Profi 
 

This function transfers the completed firing script to the automatic firing extension of the PFS Profi. 
 
Please proceed as follows: 
 
Connect the RS232-Port (COM-Port) of your PC with the PFS Profi by the provided serial interface 
cable. Make sure that it is properly plugged. 
 
Then switch on the PFS Profi, keeping the 'Range Test' button pressed for a few seconds, until 'IF' 
(= Interface) shows up on the display and there are no more acoustic signals audible. 
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Finally, select  'Transfer to PFS Profi' in the 'Script' menu of the Composer. Then the following window 
appears: 

 
 
 
Now, simply click on  'Search COM Port', then the program automatically identifies the COM-Port your 
transmitter is connected to. In case you know the number of the COM Port the transmitter has been 
connected to, you can select it also directly. 
 
A click on 'Start' starts the transfer. 
A progress bar appears. 
 
When the transfer is completed, the PFS Profi has to be switched off, and then on again. If the 'Fire' 
button is pressed down for a few seconds, the automatic firing function may be activated in this 
process, too. 
 
Note: In case the data transfer starts, but is interrupted after a few moments, the baud rate is set too 
high. Select 'Options > Composer > Interface Speed' on the 'Extras' menu bar. Adjust the slider to the 
middle and restart the data transfer. The baud rate can be increased slowly during the transmission in 
order to find the perfect settings for your system.  
 
 
 

Edit a script for the PFC Advanced 
 
The PFC Advanced provides the convenient function to display text for each individual channel. It can 
be edited with this script function. After its activation, a blank script table is displayed. Each firing 
channel is provided with 2 lines with 13 characters each. 
 
There are following alternatives for entering text: 
 
a) manually line by line 
 
By clicking on a text field, a dialogue window opens with another text field 'Infotext line' showing in its 
lower area. The cursor is already set into this field, a text can be entered. 
 
b) Automatic transfer by line 
 
By clicking on a text field, a dialogue window opens. Beneath the display of the cue (i.e. firing 
channel), text fields from the existing script that refer to the selected cue are shown. By clicking into 
these fields, their text is taken over as infotext. 
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c) Automatic transfer by column 
 
Select the required line 'Infotext Line 1' or 'Infotext Line 2' in the 'Cells' menu. 
Then the data source in the existing script has to be determined. Column, position, item, color and 
calibre are available as a choice. Of course, automatically inserted texts can now be edited manually 
now. When you have selected one of the two info text lines in the menu 'Cells', all text entries can be 
deleted with 'Delete'. 
 

If several different entries referring to one firing channel exist in a script, the text 'various' is shown in 
the info text field. An exact choice can then be made by editing manually or by transferring texts by 
line.  
 
 
 

Transfer a script to the PFC Advanced 
 
With this function, the contents of a script table, e.g. the firing script and the info texts can be 
transferred to the PFC Advanced. 
 
After having selected 'Transfer to PFC Advanced' the designated port has to be determined, either 
RS232 or USB. 
 
 
a) In case you selected RS232: 
 
Switch on the PFC Advanced and select 'Automatic Firing Mode' in the main menu. 
Then activate the menu item 'Download Script via V24/RS232'. This is followed by a safety check you 
have to confirm, if the transfer and the deletion of old data on the PFC Advanced that is involved in the 
process should be executed. 
 
Afterwards the device asks for a connection to the PC by a serial port cable. Please make sure it is 
properly plugged. 
 
The following window appears: 
 

 
 
 
Now, simply click on  'Search for COM-Port', then the automatically identifies the COM-Port your 
transmitter is connected to. In case you know the number of the COM Port the transmitter has been 
connected to, you can select it now directly. 
 
With a click on 'Start' the transfer is started. 
 
The display of the PFC Advanced shows a progress bar for this task. 
 
If no error message shows up at the end, all data has been transferred completely and correctly. 
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b) In case you selected USB: 
 
Switch on the PFC Advanced and select 'Automatic Firing Mode' in the main menu. 
Then activate the menu item 'Download Script via USB'. This is followed by a safety check you have to 
confirm, if the transfer and the deletion of old data on the PFC Advanced that is involved in the 
process should be executed. 
 
Afterwards the device asks for a connection to the PC by a USB cable. Please make sure it is properly 
plugged. 
 
The following window appears: 
 

                                                  

 
 
With a click on 'Start' the transfer is started. 
 
The display of the PFC Advanced shows a progress bar for this task. 
 
If no error message shows up at the end, all data has been transferred completely and correctly. 
 
 
Note (PFC Version 2.6BX):  
In case the data transfer starts, but is interrupted after a few moments, the transmission rate is set too 
high. Select 'Options> Composer > Port Speed' on the 'Extras' menu bar. Adjust the slider to the 
middle and restart the data transfer. The transmission rate can be increased slowly during the 
transmission in order to find the perfect settings for your system. 

 
Note (PFC Version 2.6CX): 
From PFC Advanced version V2.6C1 a faster data transfer via the USB port applies. For this kind of 
transfer, speed settings are irrelevant. 
Basically, we recommend the use of this new improved kind of transfer. If a communication error still 
occurs, please restart the Composer and the data transfer. 
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Save the script file 
 
To save the script table, select 'Save Script' in the 'File' menu. 
 
In case you want to save the file under a new name, for example as a back-up, please select 'Save 
Script As...' Then the program asks for entry of a new file name. A new memory location can also be 
chosen.  
 
 
 

Open the script V1.0 
 
Scripts that were composed with the Composer V1.X can be loaded in Version 2 to be altered and 
improved. 
 
 
 

Import Script 
 

 
 
With this window, your existing PD script can be adjusted to the Galaxis script. The columns of your 
Excel sheet have to be assigned to the Galaxis script.  
 
Use the time base "30 fps" and "hs" for the duration for PD scripts. 
 
The table on the left shows the content of the opened Excel file. 
 
Procedure: 
 

• Mark a column in the existing file with a mouse click in the column's header cell. 

• The display field 'Marked Column' now shows the number of this column. 

• Decide which column of the Galaxis script you are going to assign it to and left-click into the 

empty field 'Column'. 

• Then the indicated column number is inserted in this field. 

• In order to delete the assignment of a column, click into the corresponding field with the right 

mouse button. 
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If you want to delete all assignments, select 'Delete Assignment' in the menu 'Edit'.  
 
When your assignments are completed, click on the button 'Accept Assignment' at the bottom left.  
 
 
 

Export the script file 
 
With this function, the script can be exported, meaning it can be saved in a different file format in order 
to be edited in a spreadsheet program. 
 
For the data export, the format CSV is employed, as it can be imported by almost every spreadsheet 
program. 'CSV' stands for 'character separated value'. If the script file is exported to Excel, for 
example, select 'Text files' or 'All files' for opening it. 
 
For exporting your script file, select 'Export Script' in the 'File' menu. A note on the choice of the 
correct list separator is issued then. For Europe, this is a semicolon ';', for Great Britain and the US a 
comma ','. 
 
These settings are to be found on the menu bar under 'Extras > Options > Common > List Separator'. 
 
Then a dialogue window opens showing the text 'Save File Under...'. Here the file name and path are 
to be determined and the CSV file can be saved with a click on the according control button.  
 
 
 

Save as 'Project' 
 
If the database, a script and the wave form have been opened, the three files can be saved together 
as a project under 'File > Save Project'. 
 
Attention: Only the paths of the respective files are saved here. In case one of those files is saved 
under a new name or moved to a new memory location, the saved project is outdated or incomplete. 
 
 
 

'Show Listing' function 
 
The function 'Show Listing' in the 'File' menu provides the display of a print view or a parts list of the 
current script in a new window. 
 
Different profiles for display settings can be defined here. To do so, select 'Adjust Show Listing' in the 
'File' menu of the new table window. 
 
 

Parts list 
 
We recommend to establish a profile for the parts list under 'Adjust Show Listing'. The first column in 
this profile has to be 'Parts List'. Consequently, all identical effects of the script are added up and 
displayed in that column. 
 
The menu item 'Distinguish by…' is to be found under 'Parts List'. The criteria for the summation can 
be determined here. If the underlying database is well kept, differentiation of the effects by database  
characteristics ('DB-ID') is sufficient. 
 
Note: Please bear in mind that different kinds of spelling, for example with 'Peonies' and 'Peony', 
which may easily occur when editing the script or entering names manually, can lead to differing 
positions in the parts list. 
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Filtering by position 
 
The menu item 'Filter > Position' allows to focus the list on one single position. In a drop-down menu a 
list for every single position can be printed. 
 
 

Print lists and labels 
 
The printer for printing out the complete list, as well as the label printer are selected by the menu item 
'File > Printer Set-Up'. The software is laid out for the 'Dymo Label Writer 400 (Turbo)' with the label 
size: 89 mm x 36 mm, Dymo-Code 99012. 
 

     
 
Important: Please set the paper size on your operating system with  
'Start' > 'Settings' > 'Printers and Faxes' > 'Properties of the DYMO LabelWriter 400 Turbo' > 
'Advanced' to '99012 Large Address' 
 
In order to print an entire script, select 'File > Print > List'. 
 
For printing labels, select 'File > Print > Label > All / Selection'. 
Basically, one line per label is printed. 
 

 
 
There is a check box for every line in the script for selection. With a left mouse click into the grey 
check box you can activate the line. The left mouse button in addition with the 'Shift' key is used for 
deactivating. 
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Afterwards, the labels can be printed under 'Selection'. 
 
Here is a full-scale sample of a label: 

 
 
In case all labels are to be printed, select 'All'. 
 
 

 

Menu item 'Extras' 
 

Music Scan 
 
This function is an invaluable tool for capturing cues while the music is being played. It is activated 
and deactivated in the 'Extras' menu or by use of the control buttons 'Music Scan' (19) and 'Normal 
Mode' (17). 
 
With each double click on the left mouse button in the database table or each time the space bar is 
pressed, a line is inserted in the script, taking over the current time in the cell 'Effect Time'. To ensure 
that this cue is visible in the graphic field (8), an effect duration of 0.2 seconds is entered in the 
corresponding cell of the table. Depending on the length of the music, the zoom function may have to 
be activated to visualize the line. After all cues have been inserted, the exact placing of the individual 
effects has to be determined in detail. With the 'Replace Effect' function (18) the cues can be furnished 
with the desired effects. 
 

 

'Matching End' function 
 

This function is a means for easily integrating an effect in the script in a way that its end matches 
exactly the position of the pointer. 
 
A possible application is the finale of a pyromusical, where various effects are composed and should 
end simultaneously with the music. 
 
Activation and deactivation under 'Extras > Matching End' or by control button (16). 
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Menu item 'Options' 
 
The item 'Options' is to be found under 'Extras' on the menu bar. 
 
There are the following index tabs: 
 

Common 
 
Here the list separator for your region is defined. As mentioned in 
the section 'Exporting the script file', the correct separator has to 
be indicated for an error free export. 
 
For Europe, this is a semicolon ';', for Great Britain and the US a 
comma ','. 
 
In the window 'IDs', the option to display the column 'DB-IDs' in 
the database window can be selected, as well as the option to 
display the column 'SC-IDs' in the script window. 
 
In the 'Time Base' window, the time scale and accuracy applying 
to your script is determined. 
 
We recommend a resolution of 25 fps for the timecode. 
 
If for example a resolution of 100 fps is selected, all effect and 
firing times in your script are indicated in hundredths of seconds. 

 
Attention: The PFC Advanced only allows for firings on a tenths of second scale. Therefore scripts 
with a higher resolution have to be altered by way of using the stepper function for firings on a 
hundredths of seconds scale (see section 'Programming the stepper'). 
 
 
 

Composer 
 

In the 'Sounds' window, a firing sound or a bursting sound can be 
activated or disabled while the music is played. A volume control for 
these acoustic effects is also to be found here. 
 
Note: These settings can also be altered by use of the green and blue 
volume icons on the right upper side of the main screen. 
 
In the 'Prices' window, a field showing the current total amount of all 
used effects is activated. The correct currency is to be indicated. Thus, 
the choice of effects can constantly be checked against the budget, 
provided that all prices have been entered in the database correctly. 
 
 
 
 

 
In the 'Port Speed' window, the transmission rate for transferring a script to the PFC Advanced or PFS 
Profi can be changed. If the data transmission is interrupted after a few moments, the transmission 
rate may be set too high. If no transmission is possible at all, re-installing the driver may solve the 
problem. 
 
Please fill out the table with your equipment. The mortar size and the amount of mortars per rack is 
necessary. 
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PFM Advanced 
 

System ID Management 
This menu item has been implemented to enable the user to split his 
system. This means that he can operate the devices simultaneously 
and independently next to each other. That is very meaningful e.g. if 
you have two different projects at the same time within theoretical radio 
range. By this function the user can set the controller to a different 
system ID which is still a customer specific system ID. 
 
This function enables the user to perform a teach-in of the controller's 
system ID to all receivers besides PFE Profi Mini 1 Output and PFE 
Profi Mini 5 Outputs. 
 
Every time you press the button 'Transmit System ID' the PFM 
Advanced will transmit a command and all receivers which receive this 
 

 
will store this ID and they will only respond to this specific system ID in future. 
 
Please follow the steps as explained by pressing the 'Info' button to teach in the system ID. One after 
another all receivers can be programmed with the system ID of your PFM Advanced. 
� For more information please use the manual of the PFC Advanced Controller. 
 
Select the radio channel for this PFM Advanced 
Here the radio channel for remote programming / remote access by the PFM Advanced is configured. 
Your radio channel is to be found in the menu of the PFC Advanced or the PFE Advanced. Please 
save the radio channel after selection. 
 
Change the radio channel of a PFE Advanced 
First of all you can determine the radio channel of the PFM Advanced. In addition you can send a 
command to the Advanced receivers to change the radio channel. 
 
There are these two variants to remotely change the radio channel of the receivers: 
 
- Changing of the radio channel of a specific PFE Advanced by  
  entering the device ID number, a feedback is being sent 
- Command to all PFE Advanced within range and with the same  
  system ID to change the radio channel, without feedback 
 
� For more information please use the manual of the PFC Advanced Controller. 
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Remote access and remote programming with the PFM Advanced 
 
Before working with your PFM Advanced, the same radio channel has to be set up at the receivers 
and in the options.  
 
Therefore, please open 'Receiver Remote Programming' in the menu item 'PFM Advanced'. 
 
The following window appears: 
 

 
 
 
 

Manual programming 
 
First, the device number of the tool to be programmed has to be selected in the top area of the screen. 
When programming a receiver manually, channel programming can be done directly in the table at the 
left by clicking in the column 'Cue' (i.e. Channel). The column 'Delay' is intended for programming a 
stepper.  
 
Then, one or more outputs have to be marked by a right mouse click in the column 'Choice'. The 
check can be removed with the middle mouse button. 
 
 
 

Automatic programming 
 
First the receiver to be programmed has to be selected. If the functions 'Device allocation by Position' 
and 'Automatic Device allocation and Output' have been completed when the script was created (see 
script menu), the programming of the selected receiver is being displayed automatically in the table. 
 
In the right hand section 'Wireless Access' the commands for the PFM Advanced radio modem are 
indicated: 
 
 

 

General status information 
 

With a click on 'General Status Information' all settings and properties of the selected receiver are 
indicated. Furthermore, you can switch between operating modes '10 Output' and '100 Output Mode'. 
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Remote data request 
 

With this function, all marked outputs of the selected receiver can be queried. This serves as a 
verification of the programming. Furthermore, this column displays the detected resistance as well as 
the contents of the event memory. 
 
 
 

Remote programming 
 
All marked outputs of the selected receiver are programmed under this item. After successfully 
completed programming, the column 'Status' gets checked. 
 
 
 

Remote program deletion 
 
With 'Delete Progr.', the complete programming of the receiver is deleted. 
Attention! Only the programming of the selected mode (10 Output or Matrix) is deleted. 
 
 
 

Remote Switch-off 
 
By clicking this button, the receiver is switched off completely. 
 
 
 

Batch processing 
 
This function provides the possibility to automatically program a selected number of receivers 
successively. It is mandatory that the allocation of 'Device#' and 'Output#' has been accomplished in 
the script beforehand. No manual changes to the programming in the window on the left is taken into 
account in batch processing. 
 
The receivers to be programmed are selected at the top by keeping the 'Shift' key pressed while 
marking the device number with the left mouse button. Then, an 'X' appears beside the device 
number. 
 
The window 'Log List' displays the current status during programming. 
 
 
 

Radio Channel Scanner 
 

 
 
Use this function to monitor your radio frequency. 
Please choose the radio frequency with the buttons 'Up' and 'Down' and start the scan with the 'Start' 
button. The green graph will show you the radio interference and the maximum value is also being 
displayed on the right side. All values below 30% are not critical. 


