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List of Revisions 

Index Date Version Chapter Revision 

1 09.10.01 SyCon.exe 2.638 
AS-Interface.dll 2.670 

all created 

2 13.12.01 SyCon.exe 2.638 
AS-Interface.dll 2.672 

6.4 
6.5 
7.6 

Set Device Address complemented 
Set Parameter Bits complemented 
View Menu SyCon complemented 

3 24.07.03 SyCon.exe: 2.649 
AS-Interface.dll: 2.682 

6.6 
10.2 

Set Extended ID1 Code added 
ID2 Code added in existing table 

4 19.11.09 SyCon.exe: 2.71x 
AS-Interface.dll: 2.70x 

2.1 System Requirements: Windows® 2000 / Windows® XP / 
Windows® Vista / Windows® 7 

5 10.01.11 SyCon.exe: 2.71x 
AS-Interface.dll: 2.70x 

9.5 Error number 235 added 

6 13.06.12 SyCon.exe: 2.71x 
AS-Interface.dll: 2.70x 

2.1 System Requirements: Windows® 2000 removed 
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1 Overview SyCon  
1.1 Main Functions 

The main functions of the AS-Interface System Configurator are: 
Function Section Short Description 

Overview Communication Types Overview communication types and 
description of the configuration steps 

Configuration 

Automatic Network Scan Scans the network  

Diagnostic Functions Diagnostic functions, Debugger, Live 
List, Global State Field etc.  

Diagnostic 

User Data Transfer I/O Monitor, I/O Watch, Message 
Monitor 

Read Project Information Set the project information Documentation 

Print Print out the configuration 

Table 1: SyCon Main Functions  
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1.2 Properties 
SyCon is an universal Fieldbus Configurator  
This means you can configure the most important fieldbus systems like 
PROFIBUS, InterBus, CANopen, DeviceNet, AS-Interface etc. with the 
same tool.  

 

SyCon is a global Fieldbus Configurator  
You configure all devices with one tool. SyCon checks the dependencies 
between the devices. SyCon only allows configurations that make sense. In 
case of doubt SyCon will give you a warning.  

To Hilscher devices you can make downloads of the configuration data. For 
other devices, export functions or documentation possibilities are available.  

 

SyCon documents your Fieldbus system 
After the configuration you can print out a detailed documentation of your 
fieldbus network. The details can be switched on/off. You can print a 
documentation with details between the bus topology and the detail of one 
device.  

 

SyCon uses standardized configuration files 
Some protocols support standardized files containing information about all 
features and limitations of the slave device. SyCon uses these files for the 
configuration.  

 

SyCon is a diagnostic tool 
After the configuration you can switch SyCon into the diagnostic mode. You 
can watch all status information of Hilscher devices, see protocol 
dependent diagnostic information. In this case a slave is not operating 
correctly will be displayed in a different color.  

 

SyCon can be extended 
SyCon consists of a universal EXE file and several protocol specific DLLs. 
Most customers demand SyCon only for one bus system.  

SyCon can be enlarged later by adding one or more DLLs for any other 
available protocol. The configuration of the different protocols will be as 
similar as possible.  
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1.3 Legal Notes 

1.3.1 Copyright 
© 2001-2012 Hilscher Gesellschaft für Systemautomation mbH   

All rights reserved. 

The images, photographs and texts in the accompanying material (user 
manual, accompanying texts, documentation, etc.) are protected by 
German and international copyright law as well as international trade and 
protection provisions. You are not authorized to duplicate these in whole or 
in part using technical or mechanical methods (printing, photocopying or 
other methods), to manipulate or transfer using electronic systems without 
prior written consent. You are not permitted to make changes to copyright 
notices, markings, trademarks or ownership declarations. The included 
diagrams do not take the patent situation into account. The company 
names and product descriptions included in this document may be 
trademarks or brands of the respective owners and may be trademarked or 
patented. Any form of further use requires the explicit consent of the 
respective rights owner. 

 

1.3.2 Important Notes 
The user manual, accompanying texts and the documentation were created 
for the use of the products by qualified experts, however, errors cannot be 
ruled out. For this reason, no guarantee can be made and neither juristic 
responsibility for erroneous information nor any liability can be assumed. 
Descriptions, accompanying texts and documentation included in the user 
manual do not present a guarantee nor any information about proper use 
as stipulated in the contract or a warranted feature. It cannot be ruled out 
that the user manual, the accompanying texts and the documentation do 
not correspond exactly to the described features, standards or other data of 
the delivered product. No warranty or guarantee regarding the correctness 
or accuracy of the information is assumed.  

We reserve the right to change our products and their specification as well 
as related user manuals, accompanying texts and documentation at all 
times and without advance notice, without obligation to report the change. 
Changes will be included in future manuals and do not constitute any 
obligations. There is no entitlement to revisions of delivered documents. 
The manual delivered with the product applies.  

Hilscher Gesellschaft für Systemautomation mbH is not liable under any 
circumstances for direct, indirect, incidental or follow-on damage or loss of 
earnings resulting from the use of the information contained in this 
publication. 
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1.3.3 Exclusion of Liability 
The software was produced and tested with utmost care by Hilscher 
Gesellschaft für Systemautomation mbH and is made available as is. No 
warranty can be assumed for the performance and flawlessness of the 
software for all usage conditions and cases and for the results produced 
when utilized by the user. Liability for any damages that may result from the 
use of the hardware or software or related documents, is limited to cases of 
intent or grossly negligent violation of significant contractual obligations. 
Indemnity claims for the violation of significant contractual obligations are 
limited to damages that are foreseeable and typical for this type of contract. 

It is strictly prohibited to use the software in the following areas: 

• for military purposes or in weapon systems;  

• for the design, construction, maintenance or operation of nuclear 
facilities; 

• in air traffic control systems, air traffic or air traffic communication 
systems;  

• in life support systems;  

• in systems in which failures in the software could lead to personal 
injury or injuries leading to death. 

We inform you that the software was not developed for use in dangerous 
environments requiring fail-proof control mechanisms. Use of the software 
in such an environment occurs at your own risk. No liability is assumed for 
damages or losses due to unauthorized use. 

 

1.3.4 Warranty 
Although the hardware and software was developed with utmost care and 
tested intensively, Hilscher Gesellschaft für Systemautomation mbH does 
not guarantee its suitability for any purpose not confirmed in writing. It 
cannot be guaranteed that the hardware and software will meet your 
requirements, that the use of the software operates without interruption and 
that the software is free of errors. No guarantee is made regarding 
infringements, violations of patents, rights of ownership or the freedom from 
interference by third parties. No additional guarantees or assurances are 
made regarding marketability, freedom of defect of title, integration or 
usability for certain purposes unless they are required in accordance with 
the law and cannot be limited. Warranty claims are limited to the right to 
claim rectification. 
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1.3.5 Export Regulations 
The delivered product (including the technical data) is subject to export or 
import laws as well as the associated regulations of different counters, in 
particular those of Germany and the USA. The software may not be 
exported to countries where this is prohibited by the United States Export 
Administration Act and its additional provisions. You are obligated to 
comply with the regulations at your personal responsibility. We wish to 
inform you that you may require permission from state authorities to export, 
re-export or import the product. 
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2 Installation and Licensing 
2.1 System Requirements  

• PC with Pentium processor or higher 

• Windows® XP SP3 / Windows® Vista SP2 (32-bit) / Windows® 7 
SP1 (32/64-bit) 

• Free disk space: 30 - 80 MByte 

• DVD ROM drive  

• RAM: min. 256 MByte  

• Graphic resolution: min. 800 x 600 pixel, recommended 1024 x 768  

• Keyboard and Mouse  
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2.2 Software Installation  
Close all application programs on the system!  

Insert the DVD Hilscher System software in the local DVD ROM drive. The 
installation program will start by itself (Autostart enabled). Otherwise 
change into the root directory on the DVD and start Autorun.exe (Autostart 
disabled).  

Note: Administrator privileges are required on Windows® XP/Vista/7 
systems for installation!  

The installation program ask for the components you want to install. 
Answer these questions with Yes or No.  

 
Figure 1: Selection for the Installation of the System Configurator in basic version  
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Figure 2: Selection for the Installation of the licensed System Configurator  

It can be installed  

• System Configurator SyCon (Configuration and diagnostic tool)  

• OPC-Server (For OPC Communication)  

• CIF Device Driver (Device Driver for access to the CIF)  

If you have a license code or it is printed on the lable of the DVD, then 
answer the question for the license code with yes, otherwise a basic 
version of the System Configurator will be installed. Enter your name and 
the company name. 
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2.3 Installation of the System Configurator SyCon  
During the installation the user name and the company name must be 
entered. If you have a license code or it is printed on the lable of the DVD, it 
must also be entered now. Otherwise the system configurator will work as a 
basic version. In this case, all functions are available, but the configuration 
is limited to two devices on the network, which is sufficient for slave 
devices.  

A license can be ordered by filling out the order form under the menu item 
Help > Licensing and fax this order form either to the distributor or directly 
to us. 

Follow the instructions of the installation program by selecting the fieldbus 
system to be installed and answer all the questions with OK or NEXT. 

 
Figure 3: Enter the Name, the Company Name and the license code  

Note: The License Code 0123456789ABCDEF is no valid code and is only 
used for explanation.  

It is necessary to fill in the Name and the Company Name. It is optional to 
fill in the Address, the City, State, Zip and Country.  
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The installation program offers the following selections:  
Selection Default Settings  Meaning  
Directory C:\Programs\Hilscher\SyCon  Directory for Installation of the 

SyCon and its Components  

AS-Interface Selected 

CANopen Selected 

DeviceNet  Selected 

InterBus  Selected 

PROFIBUS  Selected 

Ethernet/Protocol Selected 

Program DLL and Components of 
the Fieldbus System or the Protocol 

CIF Device 
Driver  

Selected  
C:\Programs\CIF Device Driver 

CIF Device Driver 

Program Menu SyCon System Configurator  Folder under Start > Programs  

Table 2: Selection during installation  

The installation program copies the program files, GSD or EDS files and 
Bitmaps to the hard disk of your PC. Finally  

• System DLLs,  

• The Application,  

• OLE Controls and  

• ODBC Components  

are entered into the Registry.  
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2.4 Licensing  
This section describes the steps to license the System Configurator from 
the already installed basic version of the System Configurator. To license 
the System Configurator during installation was already described above.  

Deliveries that contain a license for the System Configurator have a formula 
with. Fill out this paper (formula) and fax it to your distributor or directly to 
us. After you receive the license code enter it as described in section Enter 
the License Code as described below on page 18.  

An order form for a license for the System Configurator can be printed out 
and is described in the next section.  

2.4.1 Ordering a License for the SyCon Configurator  
To order the license code for the selected fieldbus systems select the menu 
Help > Licensing. The licensing window will be opened. 

Fill in your name, the company name and the address for license 
information into the planed fields.  

Select one or more fieldbus modules. There are three tables to do this. The 
first table list the modules, that are not licensed. Double click or select and 
click the Add button to move the desired modules into the table in the 
middle that are printed on the order form later. The modules, which are 
already licensed, are shown in the last table.  
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Figure 4: Example for select the Fieldbus Module AS-Interface  

After selecting the modules select the button Print Order Form and send 
us this paper by fax or by mail. 

2.4.2 Enter the License Code  
This section describes the steps to license the System Configurator from 
the already installed basic version of the SyCon. To license the System 
Configurator during installation was already described above.  

Select the menu Help > Licensing. The licensing window will be opened.  

In the table in the middle are listed the fieldbus modules that were already 
selected for the order form. If this is not the case then select the fieldbus 
modules from the upper table by double click or by select and Add.  

Check if the name and the company name was entered exactly as printed 
on the fax. Observe that the spelling is the same as on the fax, especially 
the small and capital letters.  
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Then select the button Enter License Code. The following windows 
appears. Enter the 16 digits of the license code.  

Note: License codes with less than 16 digits can only be entered during the 
installation. In this case deinstall the System Configurator first and then 
restart the installation and enter the code. Also this System Configurator 
(license codes with less than 16 digits) expects a license in the device. 

 
Figure 5: Enter the License Code  

Note: The license code showed above is an invalid license code and is 
only used for explanation.  

After you have entered the license code select the button OK. The code is 
verified. If the license code is valid the System Configurator will ask you to 
exit and restart the system to activate the license. If the license code is 
invalid the following window appears.  

 
Figure 6: Note license code invalid 

In this case check  

• the license code with the information on the fax . 

• the right spelling of the name and the company name with the 
information on the fax. Check especially for small and capital letters.  
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2.5 Scope of Functions of the Basic Version and unlicensed 
Fieldbus Modules  

The basicmode and unlicensed fieldbus modules have the following 
functionality: 

• Full functionality for configuring up to two devices. For the 
configuration of one Hilscher slave device this is enough. 

• All diagnostic functions 

• Open and download of an existing configuration file. If the 
configuration file has more than two devices, a modification of this 
configuration is not possible. 
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3 Getting Started – Configuration Steps  
3.1 Overview Communication Types 

Select from the following the communication that you want to use. The 
configuration steps are described in the given section.  

Note: The booklet with the DVD ROM contains information for the 
hardware installation and information to the cable. At this point it is 
presupposed that the hardware installation was already done.  

Communication Device Device Described in section Page 
AS-Interface Hilscher 

AS-Interface 
Master 

Any  
AS-Interface 
Slave 

Configuration Hilscher AS-Interface Master to any AS-
Interface Slave 

22 

Table 3: Overview Communication Types 
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3.2 Configuration Hilscher AS-Interface Master to any AS-
Interface Slave 

The following table describes the steps to configure a Hilscher AS-Interface 
Master to any AS-Interface Slave as it is typical for many cases. 

# Action Menu in the System Configurator  Detail information in section Page 
1 Create a new project File > New > AS-Interface Setting up the AS-Interface 

Configuration 
23 

2 Select Hilscher AS-Interface 
Master 

Insert > Master Insert Master 24 

3 Select AS-Interface Slave Insert > Slave Insert AS-Interface Slave 26 

4 Assign the offset addresses Mark the Slave (left mouse click), then 
Settings > Slave Configuration 

Slave Configuration 28 

5 Set device assignment if no 
automatic assignment has 
occurred 

Mark the Master (left mouse click), then 
Settings > Device Assignment 

Device Assignment 31 

6 Save project File > Save Save and Save As 66 

7 Download Mark the Master (left mouse click), then 
Online > Download 

Downloading the 
Configuration 

46 

8 Start Debugger Mark the Master (left mouse click), then 
Online > Start Debug Mode  

Debug Mode (AS-Interface 
Master) 

55 

9 Device diagnostic Mark the Slave (left mouse click), then 
Online > Device Diagnostic 

AS-Interface Slave Device 
Diagnostic 

56 

10 Stop Debugger Online > Stop Debug Mode Debug Mode (AS-Interface 
Master) 

55 

11 Global diagnostic Mark the Master (left mouse click), then 
Online > Global State Field 

Global State Field 57 

12 Transfer user data: 
Write output, 
Read input 

Mark the Master (left mouse click), then 
Online > I/O Monitor 

I/O Monitor (*1) or 
alternatively: I/O Watch 

61 
62 

Table 4: Steps for Configuration Hilscher AS-Interface Master to any AS-Interface Slave 

Note (*1): Alternatively the CIF Device Driver Test program can be used for 
the test. After Board Select: Data Transfer > I/O Data > DevExchange I/O. 
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4 Configuration of AS-Interface with SyCon 
4.1 Setting up the AS-Interface Configuration  

To create a new configuration, choose the File > New menu. This will offer 
a selection list of fieldbus systems. Choose the AS-Interface. If only the 
AS-Interface fieldbus system is installed, the configuration window will open 
directly.  

The name of the project file can be allocated when the configuration is 
finished or with File > Save As.  

4.2 EDS Files  
EDS (Electronic Data Sheet of a device) files contain and describe the 
functions and characteristics of the AS-Interface devices. All the available 
EDS files together from the device database.  

When the System Configurator is started, the program automatically 
retrieves all the EDS files stored in the EDS directory. The device names 
for example are placed into an internal list. During the configuration, the 
device-specific data is retrieved directly from the EDS files.  

If an EDS file for a device is needed which does not appear in the selection 
list it can be copied into the EDS directory with File > Copy EDS. Another 
possibility is to copy the EDS file into the SyCon EDS directory with the 
Windows Explore and then retrieve the EDS files into the EDS directory 
with Settings > Path and OK.  

 
Figure 7: EDS files and bitmaps directory 

The EDS files for Hilscher devices as well as devices from other 
manufacturers are already included in the scope of delivery and installed. 
The files are based on no standard and couldn't obtained from other 
manufacturers because of this reason. 

If an EDS file for a Slave is missing you have to possibility to create it on 
your own with an ASCII editor. Therefore you have to copy an existing EDS 
files and to rename it. Then you can modify the new EDS file. 

The EDS directory is adjustable. In order to alter the directory from the 
default setting in another directory, use the Settings > Path menu. All EDS 
files must be placed in this directory.  
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4.3 Master 

4.3.1 Insert Master 
In order to insert a Hilscher Master into the configuration, choose the Insert 
> Master menu, in order to open the selection window, or click on the 
symbol:  
Insert > Master 

 

Figure 8: Insert > Master symbol 

The window opens from which exactly one Master can be chosen. After this 
selection the chosen master is at the first position in the configuration 
window. 

 
Figure 9: Insert > Master 

This example shows a CIF50-ASIM. It gets no Station address but the 
standard description Master. This description is changeable in the field 
Description. 

4.3.1.1 Hardware Assignment 

If you have configured the CIF Device Driver Setup for your hardware and 
you insert the correct Master in the SyCon it detects this hardware. SyCon 
displays at which board and which driver was detected and ask if the 
hardware should be assigned. 

 
Figure 10: Assign hardware Master 
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If you answer with Yes, the hardware is assigned. If you answer with No 
you have to assign this hardware with Settings > Device Assignment 
(look in section Device Assignment at page 31).  

4.3.2 Master Settings 
See section Master Settings at page 38. 

4.3.3 Replace Master 
If a Master already exists in the configuration and should be replaced 
against another Master, you first have to set the focus on the Master (left 
mouse click at the Master) and then choose the menu Edit > Replace. In 
the opened window appears the question if the Master should be replaced. 

 
Figure 11: Security question replace Master 

If you click the button Yes a new window opens, where you can replace the 
Master against the existing Master. 

 
Figure 12: Edit > Replace Master 

In this window you select the Master you want by clicking on it and then 
click the Add button to put the Master to Selected devices. With OK you 
confirm the selection and the Master will be replaced. 
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4.4 AS-Interface Slave 

4.4.1 Insert AS-Interface Slave 
In order to insert an AS-Interface Slave into the configuration, choose the 
menu Insert > Slave 

or  

click on the Insert Slave symbol:  
Insert > Slave 

 

Figure 13: Insert an AS-Interface Slave 

The mouse pointer automatically changes to the Insert Slave pointer. First 
the a mouse pointer for “no insert position” appears. 

Mouse pointer “no 
insert position” 

 

Figure 14: Mouse pointer “no insert position“ 

Possible insert positions are displayed with a colored circle .  

Note: In the case of an AS-Interface network the Master has possible insert 
positions for the Slaves because the Master card has two channels which 
work independent to each other and are two different networks. 

If you move the mouse pointer over the colored circle, it changes into this 
symbol to show that this is a possible insert position: 

Mouse pointer for 
Insert > Slave 

 

Figure 15: Mouse pointer for insert an AS-Interface Slave 
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Click on the position where the Slave is to be inserted. 

 
Figure 16: Possible insert positions of devices with identification by a colored circle 

The window opens where one or more Slaves could be selected. 

 
Figure 17: Insert > Remote Bus Device 

The list on the left displays for selection all the Slave devices whose EDS 
files have been put in the EDS directory. A filter can be used to limit the 
selection list of the manufacturer. Further information on a Slave is shown 
below the selection list (Available devices) when it is selected (one mouse 
click).  
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Apart from the vendor name and the description especially the I/O code, 
the ID code and the extended ID2 code, the file name and the file revision 
are given. The Slave appears on the right-hand list with a mouse click or 
with the Add button. All devices in the right-hand list are assigned to the 
current insert point that is also shown in this window. If the Slaves in the 
right-hand list are chosen one after the other (a mouse click), then every 
Slave can be assigned a name in the Description field.  

Furthermore you can assign a Address in the range of value from 1 to 62. 
This Address has to be unique. 

4.4.2 Slave Configuration  
First click the symbol of the Slave with the left mouse button and then 
choose the Settings > Slave Configuration menu.  

or  

open the Slave configuration window by double clicking on the AS-Interface 
Slave device.  

The slave-specific configuration is carried out in this window. Here, the 
modules and their addresses are assigned in the process data memory in 
the Hilscher Master. Note that the address must agree with that in the PC 
application program.  

Note: The information of the offset addresses refers to the addressing of 
the data in the Master! The address information does not refer to the 
addressing of the data in the Slave! The Slave organizes its own data 
addressing.  

 
Figure 18: Settings > Slave Configuration 
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The device-specific configuration is carried out here. These are in detail: 

• the Device address 

• a Description of the device, 

• Activate or Deactivate the Slave in the actual configuration, 

• configuring the Process Data Addressing (see following 
description), 

• selecting an other device without leaving the window. 

If Activate device in actual configuration is selected, the Master carries 
out an data exchange to this device. Is this setting deactivated, then the 
master doesn't carry out a data exchange to this device. In both cases 
however the memory in the process image is used respectively reserved in 
the Master. 

The I/O addresses can be automatically assigned by SyCon or can be 
allocated by the user. For this purpose you have to activate (Auto 
addressing) and deactivate (manual addressing) respectively it in the menu 
Settings > Auto Addressing the Process Data Auto Addressing. When 
the Auto Addressing is active, then the addresses of the Slaves will be 
allocated in their insert order by SyCon. The addresses can be viewed and 
checked in the View > Address Table. When the Auto addressing is 
deactivated, then only the address 0 is shown in the I Addr or O Addr and 
must be overwritten by the user.  

Depending on the Addressing mode, which can be set in the AS-
Interface Master Settings, the addresses are either Byte or Word 
addresses. For further details of this, see the description in the section 
Addressing Mode on page 40. 

At Actual device you can change to another Slave device without leaving 
the window. 

In the field Slave data are the I/O code and the ID code of this device are 
shown. The description to this you find in section I/O Code, ID Code,  at 
page 102. 

4.4.2.1 Parameter data 

The parameter data is vendor specific and they are read from the EDS file. 

If no more information is set in the EDS file the standard Reset respectively 
Set is shown. If information for the Parameterbit is set in the EDS file this 
information is shown. 

For example by a reflective photointerrupter "dark" instead of Reset and 
"light" instead of Set can be shown in the field Parameter bit 1. 

 
Figure 19: Setting of Parameter bits 
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4.4.3 Replace Slave 
To replace a Slave device in the configuration against another you first 
have to set the focus on the Slave (left mouse click at the Slave) to mark it. 
Then select the menu Edit > Replace or make a right mouse click at the 
Slave and select Replace.  

In the opened window the question appears if the Slave device should be 
replaced. 

 
Figure 20: Security question replace slave 

If you answer this question with Yes, the following window appears where 
you can select an other Slave device. 

 
Figure 21: Edit > Replace Device 

In this window you can choose the device you want by clicking on it. By 
clicking the Add button the Slave is shown under Selected devices. With 
OK you confirm the selection and the Slave will be replaced. 
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5 Settings  
5.1 Device Assignment 

The Device Assignment setting determines how the System Configurator 
communicates with the device. This is set in the device arrangement via the 
menu Settings > Device Assignment. The following possibilities are 
available:  
CIF Device Driver CIF Serial Driver  CIF TCP/IP Driver 

 

CIF Device Driver: 

• CIF Device Driver: The System Configurator communicates with the 
Hilscher device over the Dual-port memory of the device.  

• This communication is utilized when the System Configurator is used 
on the same PC on which the Hilscher device (CIF) is installed.  

• The CIF Device Driver must have been installed.  

 

CIF Serial Driver: 

• CIF Serial Driver: The System Configurator communicates with the 
Hilscher device over a serial connection. In this case, a COM port of 
the PC must be connected via a diagnostic cable with the diagnostic 
interface of the Hilscher device. The cable is shown in the manual for 
the DVD.  

• This communication is utilized when the System Configurator has 
access the device over the diagnostic interface of the Hilscher device. 
The following two application cases are possible:  

• Application case 1: The System Configurator is installed on another 
PC (e.g. a notebook) than the Hilscher device.  

• Application case 2: The System Configurator is installed on the same 
PC on which the Hilscher device is situated. Then the application can 
use the Dual-port memory to access the Hilscher device and the 
diagnostic interface can be used at the same time to communicate 
with the device (diagnostic data).  

 

CIF TCP/IP Driver: 

• CIF TCP/IP Driver: The system configurator communicates with the 
Hilscher device via a TCP/IP connection.  

• This communication is utilized when the System Configurator is 
installed on another PC than the Hilscher device and there is a 
TCP/IP connection between the two PCs.  

• Our CIF Device Driver and a server program is required on the PC 
with the CIF and this server program is situated on the DVD in the 
UTIL\TCPIPSRV directory. The program is called Tcpipsrv.exe.  
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5.1.1 CIF Device Driver 
The Device driver supports up to four devices in one PC and they are 
accessed via the Dual-port memory.  

The Device driver is selected via Settings > Device Assignment.  

 
Figure 22: Driver Selection > CIF Device Driver 

Choose CIF Device Driver and then OK, in order to select the CIF Device 
Driver. 

 
Figure 23: Driver Selection > CIF Device Driver 

The assignment is carried out if the checkbox is selected. In addition the 
checkbox need to be accessible (not grey colored). If the checkbox is grey 
colored and selected the device is already assigned. In this case another 
configuration file is opened. You first have to close it, so that the 
assignment can take place. 
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5.1.2 CIF Serial Driver 
The serial driver supports COM1 to COM 4, in order to communicate over 
the diagnostic interface with the device.  

The Device is selected via Settings > Device Assignment.  

 
Figure 24: Driver Selection > CIF Serial Driver 

Choose the CIF Serial Driver and then OK, in order to select the CIF Serial 
Driver.  

The connection must first be established using the button Connect COM1 
or Connect COM2 or Connect COM3 or Connect COM4. They can be 
used depending on which COM ports are installed and free on the PC.  

The System Configurator sends a request to the corresponding COM port 
and polls the Firmware name of the device. A display of the Firmware will 
indicate when a device is connected. In the other case, a Timeout error (-
51) appears, which will state that no device is connected.  
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Figure 25: CIF Serial Driver > Device Assignment 

The error number –20 indicates that this COM interface is not available or 
free.  
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5.1.3 CIF TCP/IP Driver 
The TCP/IP driver connects up to four devices that can be accessed over a 
TCP/IP connection.  

The driver must be installed on the PC with the CIF, the CIF must be 
configured and the Tcpipsrv.exe program, in UTIL\TCPIPSRV on the DVD, 
must be started.  

The TCP/IP driver is chosen via Settings > Device Assignment.  

 
Figure 26: Driver Selection > CIF TCP/IP Driver 

In order to select the CIF TCP/IP driver, choose CIF TCP/IP Driver and 
then OK. 

Then the IP address of the PC on which the CIF is situated must be 
entered and Connect to Server must be chosen.  

 
Figure 27: CIF TCP/IP Driver > Device Assignment 
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If the connection has been successful, the device that has been found will 
appear in the device selection. It will be selected if the name is the same as 
the selected device in the configuration. 

5.2 Bus Parameter 
The window Bus Parameter can be opened with the menu Settings > Bus 
Parameter. 

 
Figure 28: Settings > Bus Parameter 

The Behavior in case of defective slave device determines the 
procedure of the Master, if a Slave is detected as missed during run time 
and during the first network start up phase  

• Don't take care about the status of any connected slave devices. 
The Master tries to hold the network communication notwithstanding 
of the states of the connected Slaves. 

• Stop communication if a device is missing. The Master stops 
network communication for both channels, if it detects a missing 
Slave during the first network scan or during the data exchange. 

• Stop communication if a device is reporting a configuration 
failure. The Master stops network communication for both channels, 
if at least one Slave is reporting a configuration failure.  

• Stop communication if a device is missing or reporting a 
configuration failure. The Master stops network communication for 
both channels, if it detects a missing Slave or a Slave reports a 
configuration failure. 
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The Behavior during start up sequence determines the procedure of the 
Master during the start up. It distinguishes between the Slaves which are 
connected to the Channel 1 and the Slaves which are connected to the 
Channel 2 at the Master. 

• Auto start 
If this flag is set, the Master chip of the corresponding channel starts 
immediately after the initialization with data cycles. 

• Auto configuration 
If this flag is set, the offsets of the slaves in the process image will be 
calculated automatically from the master. The offsets corresponds to 
the salve addresses, i.e. slave 1 has the offset 1, slave 2 the offset 2 
and so on. 

• Protected mode 
This flag decides, if the Master chip of the corresponding channel 
goes in the "protected data exchange mode" or in the "configuration 
mode". 

• Auto address assignment 
If the Master detects a Slave which can replace a missing Slave (it 
needs the same I/O code, ID, ID1 and ID2 code) it assigns the 
address of the missing Slave to the detected on, if the new Slave has 
the address 0 (zero). 
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5.3 AS-Interface Master 

5.3.1 Master Settings 
To enter the Master settings, choose the Settings > Master Settings or 
click with the right mouse button on the corresponding Master symbol and 
select the menu Master Settings from the list that opens. 

The Master settings contain parameters that determine the behavior of the 
Master device as well as the user interface. These settings are only valid 
for Hilscher devices and are included in the download of the configuration. 

 
Figure 29: Settings > Master Settings 

• Startup behaviour after system initialization 
When Automatic release of the communication by the device has 
been set, the Master device starts with the data exchange at the Bus 
after the initializing has been finished. When Controlled release of 
communication by the application program has been set, the 
application program has to activate the data exchange at the Bus. 
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• User program monitoring 
The Watchdog time determines how long the device waits for a 
triggering of the software watchdog by the application program until it 
sets the outputs of the Slave devices to zero. This behaviour must be 
activated by the user program and does not start automatically.  

Note: This is not a special AS-Interface function. 

An example of the use of this function can be a SoftPLC. 

• Addressing mode 
The addressing mode of the process data image determines how the 
addresses (Offsets) of the process data are interpreted. Either of the 
addressing modes Byte addresses or Word addresses are 
possible. See also details on the next page. 

• Handshake of the process data 
These various types are used for setting the handshake of the 
process data for the Master. The choice of used type is important for 
the correct data exchange between the application program and the 
device. 

The used handshake of the process data needs to be supported by 
the application program. Mostly the buffered, host controlled 
handshake is supported. The setting no consistence, uncontrolled 
works without handshake and the processes run free. 

• Hardware parameter 
This parameter displays the full size of the dual-port memory. This is 
a read only information. If the size is for example 2KB then 1KB is 
usable for the process image. 
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5.3.2 Addressing Mode 
The addresses in the configuration of the nodes define the starting point of 
the data in the process depiction. This can work in a Word or Byte oriented 
method by means of the Addressing mode parameter. 
Addresses Meaning 
Byte addresses The process image has a Byte structure and each Byte has its own 

address.  

Word addresses The process image has a Word structure and each Word has its own 
address. 

Table 5: Addressing Mode 

This has nothing to do with the physical size of the Dual-port memory – this 
is always Byte-oriented! When the application makes a Word access, it is 
automatically divided by the PC into two sequential Byte accesses.  

The following table shows the different storing of the various data types in 
the Byte- or Word-oriented process image: 

IEC 
address 
in Byte 
mode 

IEC 
addresses 
in word 
mode 

Offset 
address
es in the 
dual-
port 
memory 

Data in 
the 
process 
image 

Output to an I/O Module 

QB 0 QB 0 0 0000 0000  

QB 1  1 0000 0000  

QB 2 QB 1 2 0000 0010 Output of QB2 / QB1 to a Slave: 
D7 D6 D5 D4 D3 D2 D1 D0 
  0    0    0    0    0    0    1    0 

QB 3  3 0000 0000  

QB 4 
QB 5 

QB 2 4 
5 

0000 0111 
0000 0000

Output from QB4 / QB2 to a Slave 
D7 D6 D5 D4 D3 D2 D1 D0  D7 D6 D5 D4 D3 D2 D1 D0  
  0    0    0    0    0    0    0    0    0    0    0    0    0    1    1    1 

Table 6: Example for data in the process data image 
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The following table is meant to clarify the method of addressing:  

 
Byte addressing  Word addressing 
Byte 0 IB 0  IB 0 

Byte 1 IB 1 

IW 0 

 

Word 0 

- 

IW 0 

Byte 2 IB 2  IB 1 

Byte 3 IB 3 

IW 2 

 

Word 1 

- 

IW 1 

Byte 4 IB 4  IB 2 

Byte 5 IB 5 

IW 4 

 

Word 2 

- 

IW 2 

Table 7: Image of the method of addressing for input  

Byte addressing  Word addressing 
Byte 0 QB 0  QB 0 

Byte 1 QB 1 

QW 0 

 

Word 0 

- 

QW 0 

Byte 2 QB 2  QB 1 

Byte 3 QB 3 

QW 2 

 

Word 1 

- 

QW 1 

Byte 4 QB 4  QB 2 

Byte 5 QB 5 

QW 4 

 

Word 2 

- 

QW 2 

Table 8: Image of the method of addressing for output  

5.3.3 Auto Addressing 
With the menu Settings > Auto Addressing it is set, if the process data 
addressing is executed automatically by SyCon (active selected) or 
manually by the user (active not selected). 
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5.4 Project Information 
If the user creates his own project, the project information can be typed in 
into the Settings > Project Information menu. Anybody can then read this 
entry when this menu is opened.  

 
Figure 30: Settings > Project Information  

By clicking the OK button the Project Information is saved. 

5.5 Path  
When the Settings > Path menu is selected, the search path for EDS files 
is displayed.  

 
Figure 31: Settings > Path  

If you click on the OK button all EDS files are read in. 
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5.6 Language 
Choose the Settings > Language menu and the following window opens: 

 
Figure 32: Settings > Language 

Here can be set the language of the System Configurator. Select the 
desired language and confirm the entry with the OK button.  

A message appears that the System Configurator must be started again in 
order to activate the selected language. Please carry this out.  

After restarting the System Configurator, the language will have changed to 
the one selected.  

Note: Up to now not all languages are available for all fieldbuses! 

5.7 Start Options  
Starting from the window Network View (menu Window > Network View) 
the menu Settings > Start... opens the window Start Options. The 
different start options or modes can be set. Some of these settings are only 
for the OPC server.  

Note: This menu option Start Options is only displayed in the selection 
Settings, if a project is loaded. 
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Figure 33: Settings > Start Options 

• Simulation mode ON/OFF 
Only valid for the OPC Server.  

• Start SyCon hidden if started via OPC  
Only valid for the OPC Server.  

• Start SyCon next time with last Configuration 
When this is marked the last saved configuration in the SyCon is 
automatically loaded when the SyCon is started again.   

• Logic Network View visible 
When this is marked, there is the possibility of diverting to the network 
mode without having to install the SyCon with OPC. It is also possible 
to use the Watch List from the network mode.  

• Fast start ON/OFF 
Only valid for the OPC Server.  

• TAG tracing ON/OFF 
Only valid for the OPC Server.  



Settings 45/109  

SyConASI | System Configurator AS-Interface 
DOC011101OI06EN | Revision 6 | English | 2012-06 | Released | Public © Hilscher, 2001-2012 

• OPC tracing ON/OFF 
Only valid for the OPC Server.  

• Auto connect ON/OFF 
If this is marked, when opening a configuration automatically a 
connection to that Hilscher devices is manufactured without the 
device assignment additionally have to be executed. 

• Start with multiple configurations 
If this option is selected you have the possibility to start SyCon with 
up to four configurations simultaneously. The paths are shown in the 
window and they are changeable there. 
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6 Online Functions 
6.1 Introduction 

In this section, all the functions that directly influence Hilscher AS-Interface 
devices, e.g. CIF50-ASIM, CIF30-ASIM, are presented.  

Note: Please note that this also permits an interruption of the running 
communication or that input and output can be switched ON or OFF.  

6.2 Online to the CIF  

6.2.1 Downloading the Configuration  
First, the desired device must be chosen for downloading by a left mouse 
click on the symbol of the device.  

In order to transfer the configuration, a transfer download to the 
CIF/COM/PKV devices must be carried out on the Online > Download 
menu. A warning will appear that the communication on the AS-Interface 
will be interrupted. This warning must be confirmed.  

 
Figure 34: Security question before download 

Attention: The download overwrites the configuration in the device and the 
communication with the connected devices is interrupted. 

 
Figure 35: Online > Download  
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Before the Download is executed, the configuration is checked by the 
Configurator. The most common cause of error is overlapping of addresses 
in the process data image. This can be checked by calling up the address 
table with the View > Address Table menu. 
If the assignment of addresses in the process data image should be carried 
out automatically, then the Auto addressing button in the Master 
Configuration window must be activated. 

The configuration is transferred into the selected device and is stored there 
in FLASH memory in a zero voltage manner so that the configuration is 
available when the power supply is switched off and on again.  

After the download, the device carries out an internal restart and begins 
with the communication if in Master Settings the Automatic Release of 
Communication by the Device menu has been set.  

6.2.2 Firmware Download  
If you want to carry out a Firmware download, act as follow: First the 
desired device for Firmware downloading must be chosen in that the 
symbol of the device is selected with a left mouse click. Then, call up the 
Online > Firmware Download menu. Select the new Firmware and 
retrieve it with Download into the device. The Firmware is now 
downloaded. 

 
Figure 36: Online > Firmware Download  
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6.2.3 Firmware / Reset  
The desired device must be chosen with a left mouse click on the symbol of 
the device. Then the Online > Firmware / Reset menu must be called up 
and the name and the version of the Firmware are displayed.  

 
Figure 37: Online > Firmware / Reset 

The device can be resetted with the Reset button. 

6.2.4 Device Info  
First the desired device must be chosen with a left mouse click on the 
symbol of the device. Then select the Online > Device Info menu in order 
to obtain further information on the selected device.  

The manufacturer date, the device number and the serial number of the 
device is read out and shown.  

 
Figure 38: Online > Device Info  

6.2.5 Read Project Information 
With the menu Online > Read Project Information can be read out the 
project information from a device. 



Online Functions 49/109  

SyConASI | System Configurator AS-Interface 
DOC011101OI06EN | Revision 6 | English | 2012-06 | Released | Public © Hilscher, 2001-2012 

6.2.6 Activate Driver – Driver Licensing  
The driver has to be licensed, if the software PLC or SyCon OEM is used. 

If the driver was ordered by buying the SyCon, you don't need to license it 
because this was done before. 

First the desired device must be chosen with a left mouse click on the 
symbol of the device. Then select the Online > Activate Driver menu.  

 
Figure 39: Online > Activate Driver 

Note: The code 01234567890ABCDEF is not a valid code and is only an 
example.  
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6.3 Automatic Network Scan 
This function scans the network structure. During the scan it will be 
detected which devices are connected to this AS-Interface. Therefore the 
following steps are necessary:  

• Create a new project: Select the menu File > New and AS-Interface. 

• Select the Master: Select the Master from the menu Insert > Master.  

• If the Master isn't initialized you need to make a download first. To 
make this download select the menu Online > Download. 

• Scan the network: Select the menu Online > Automatic Network 
Scan and select Channel 1 or Channel 2. Hereby the I/O code and 
ID code of all at the network attached devices are determined.  

 
Figure 40: Online > Automatic Network Scan (security question)  

Answer this question with Yes, if the connected AS-Interface network 
should be scanned. Answer this question with No, if this functions should 
not be performed.  

 
Figure 41: Online > Automatic Network Scan 
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6.3.1 Automatic Configuration 
If you activate the button Automatic Configuration, the following safety 
question appears.  

 
Figure 42: Online > Automatic Network Scan > Accept Configuration 

Answer the question with Yes, if the read in structure is to be taken over as 
configuration. Answer the question with No, if the old configuration is to be 
maintained.  

6.4 Set Device Address 
By selecting a device and the menu Online > Set Device Address or a 
right mouse click at the Slave device and the selection of Set Device 
Address the dialog for setting the device address appears. 

 
Figure 43: Online > Set Device Address 

You have to type in the actual address of the device in the field Old 
address. In the field New address type in the address the device should 
get from now on. By clicking the button Execute it is shown in the field 
Result, if the changing was successful or which error has appeared. 
Possible reports are: 
Report Meaning 

Address change succeeded. - 

Slave with new address detected. The address you want to assign already exists at the 
bus. 

Slave address is invalid. This address can not be used. 

Slave with old address not 
detected. 

The address in the field Old address was not found 
at the bus. 

New address stored temporarily. - 

Slave with address zero detected. The address assignment failed because a Slave with 
the address zero already exists. 

Table 9: Online > Set Device Address > Possible Results 
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6.5 Set Parameter Bits 
By selecting a device and the menu Online > Set Parameter Bits the 
following window appears: 

 
Figure 44: Online > Set Parameter Bits 

The parameter bits 0 to 4 can be set or resetted. The description and using 
of the parameter bits depend on the manufacturer of the device and have to 
be looked up in the manuals of the manufacturer. 

Note: The possibility to set and reset parameter bits is an Online function. 
That means the settings in this dialog are not stored in the configuration. 

6.6 Set Extended ID1 Code 
Selecting a device and then the menu Online > Extended ID1 Code, the 
following window opens: 

 
Figure 45: Online > Set Extended ID1 Code 

This function is only accomplish for a Slave with address 0 and if this Slave 
supports this function. If a Slave supports this function and the use are 
manufacturer specific and have to be looked up in the device description of 
the Slave. 

The new ID1-Code of the Slave has to be typed in the field Extended ID1-
Code. The permissible range of value is 0 to F. In the field Result it is 
shown, if the overwriting of the Extended ID1-Code was successful or if an 
error has occurred, selecting the Execute button. Possible reports are: 
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Report Meaning 

Slave with address '0' not detected - 

Error while setting extended ID1 - 

Error while reading extended ID1 The new ID1-Code could not read back from 
the Slave 

Table 10: Online > Set Extended ID1-Code > Possible Results 

6.7 Start/Stop Communication 
First the desired Master must be chosen with a left mouse click on the 
symbol of the Master. The communication between the AS-Interface Master 
and the AS-Interface Slaves can be manually started or stopped. In order to 
do this select the Online > Communication start or Online > 
Communication stop menu. 
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6.8 Diagnostic Functions 
The following table shows the diagnostic functions of SyCon: 
Diagnostic Functions Page 

Live List 54 
Debug Mode (AS-Interface Master) 55 
AS-Interface Slave Device Diagnostic 56 
Global State Field 57 
Extended Device Diagnostic 59 

Table 11: Diagnostic Functions 

6.8.1 Live List 
First you have to mark the Master with a left mouse click. Select the menu 
Online > Live List and Channel 1 or Channel 2 to get an overview over all 
active devices in the AS-Interface network. 

 
Figure 46: Online > Live List > Channel 1 

A blue number shows a connected Slave device, whereby the number 
indicates the Slave address. With a double click at a blue number the I/O 
Code, the ID Code and the extended ID1 and ID2 Code are shown. 

 
Figure 47: Slave Information 
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6.8.2 Debug Mode (AS-Interface Master) 
Starting from the Master select the Online > Start Debug Mode menu. The 
system configurator cyclically reads out the status of the network 
communication on the Hilscher device and the individual condition of the 
devices.  

To end the Debug Mode select the menu Online > Stop Debug Mode 

or 

in the running debug mode right mouse click on the Master and select Stop 
Debug Mode. 

6.8.2.1 Debug Window 

When the debug session is started the configuration window changes into 
the debug window. The devices and the line between them are displayed in 
green or red color depending on the established network communication.  

 
Figure 48: The Debug Window 

If a diagnostic information is available for a specific device the text Diag 
appears in red, next to the device icon. To get further device specific 
diagnostic information then doubleclick on the Slave device itself or set the 
focus to the device and select Online > Device Diagnostic.  

The master icon has the sign to show the Master is in stop mode.  

In run mode the master icon has the sign .  
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6.8.2.2 AS-Interface Slave Device Diagnostic  

After the debugger was started SyCon requests the status of all devices 
from the Master. If there is an error on a device the bus line to this slave is 
drawn in red color otherwise it is green. This information is displayed closer 
if you click with the mouse onto the corresponding device in debug mode.  

To activate the debug mode you have to mark the Master and select the 
menu Online > Start Debug Mode. Then set the focus at the Slave and 
with the menu Online > Device Diagnostic you activate the AS-Interface 
device diagnostic. To end the Debug Mode you have to mark the Master 
again and select the menu Online > Stop Debug Mode.  

 
Figure 49: Online > Device Diagnostic (AS-Interface standard diagnostic) 

The individual bits in the Device Diagnostic have the following meaning:  
Device status flags in the 
Device Diagnostic 

Meaning 

No response No Slave can be identified under the configured address. 

Error buffer overflow The maximum number of possible error entries (the 
maximum are 5 entries per Slave) was reached. 

Configuration fault The detected Slave corresponds in the I/O code and the 
ID code not to the Slave which was configured.  

Not active The Slave was deactivated, it is not included in the data 
exchange. 

Table 12: Meaning of the bits in the Device Diagnostic 
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6.8.3 Global State Field 
With the menu option Online > Global State Field and the selection 
Channel 1 or Channel 2 a window opens in that cyclically Statistic about 
the bus status and attached devices to be output.  

 
Figure 50: Online > Global State Field > Channel 2 

The first row displays the main status of the Master. It can have the status 
OPERATE or STOP. 
The next row displays individual bus errors. A pending error is displayed 
with a red field. The meaning of the individual abbreviations is described in 
the following. 
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Status Bits Meaning 

NRDY NotReady: The Master is in the state NotReady 

NEXC2 NoneExchange Channel 2: No data exchange at channel 2 

ACLR2 AutoClear Channel 2: AutoClear error channel 2 

NEXC1 NoneExchange Channel 1: No data exchange at channel 1 

ACLR1 AutoClear Channel 1: AutoClear error channel 1 

CTRL ControlError: Configuration error or heavy runtime error 

Table 13: Meaning of collecting status bits in the Global State Field 

Further displays are: 

Collective online error location and corresponding error 
Shows at which Slave address and which error has occurred. 

 
Interface flags Meaning 

Configuration okay shows that the real configuration is the same. The flag 
makes a simple supervise of the ASI configuration 
possible.  

Slave with zero address detected reports that a Slave with the address 0 is available 

Automatic address assignment shows that the automatic address assignment of the 
station address is released 

Automatic address available shows that automatic address programming is 
available, that means that a device with the address 0 
is insert for a missing device and the addressing has 
happened 

Configuration mode active shows the configuration mode. This flag is reset in the 
protected mode. 

Normal operation active is always set, if ASI is in the normal cyclic operation 
mode. The flag is set to zero during the initialization 
and the starting operation. 

ASi power fail shows that a voltage collapse at the ASI has occurred 

Offline ready shows that the offline phase is active that means that 
no data exchange take place 

Periphery OK this bit is set as soon as no Slave reports a periphery 
error 

Table 14: Interface flags and their meaning 

Devices specific status bits: 
These display the parameterized devices, the active devices, the 
devices with diagnostic and the device with peripheral errors according 
to the activated button. A pending diagnostic information can be received 
by a double click on the respective number of the station.  

This display is cyclically updated. 
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6.8.4 Extended Device Diagnostic  
The extended device diagnostic helps to find bus and configuration errors 
when the SyCon menu functions are of no further help.  

First select the Hilscher device with a left mouse click on the symbol of the 
device. Then select the Online > Extended Device Diagnostic menu.  

This menu opens a list of diagnostic structures. These contain online 
counters, status information and parameter information:  

 
Figure 51: Extended Device Diagnostic by the example of AS-Interface Master 

6.8.4.1 Extended Device Diagnostic for the AS-Interface Master 
ASI_TASK: AS-Interface Administration 

Task / Task State  Page 

ALI_TASK Common Variables 95 

PLC_TASK Status Variables 96 

ASI_TASK Common Information 97 

ASI_TASK Device Running States, Channel 1 99 

ASI_TASK Device Running States, Channel 2 99 

ASI_TASK Global State Field, Channel 1 100 

ASI_TASK Global State Field, Channel 2 100 

ASI_TASK Live List, Channel 1 100 

ASI_TASK Live List, Channel 2 100 

ASI_TASK IX System 101 

Table 15: Extended Device Diagnostic for the AS-Interface Master 
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6.9 User Data Transfer  
The following table shows test functions with user data transfer and the 
usability for Hilscher AS-Interface Master devices. 

User data transfer function  Usage Usable with Hilscher AS-
Interface Master devices 

I/O Monitor Read input data and set output data. (cyclic I/O 
data exchange) 

Yes 

I/O Watch Read input data and set output data. (cyclic I/O 
data exchange) 

Yes 

Table 16: Overview User Data Transfer 
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6.9.1 I/O Monitor  
The I/O Monitor is an easy way of displaying and changing the first 32 
Bytes of the process data image. To open the I/O Monitor select the menu 
Online > I/O Monitor. 

 
Figure 52: Online > I/O Monitor 

DEC/HEX get the representation of the input data. The output data is 
always in the decimal form.  

Enter the output value and then press Update.  

Always the first 32 input and output Bytes of the process data image are 
shown, also when these Bytes have not been occupied by the 
configuration.  

The display is always in a Byte manner. 

A more comfortable display is offered by the I/O Watch Monitor which is 
described in the next section.  
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6.9.2 I/O Watch  
The I/O Watch monitor can be used in place of the I/O Monitor and offers 
more functionality.  

• Various data formats: Hex, Unsigned Decimal, Signed Decimal, Bit.  

• The I/O Watch monitor works symbol oriented.  

• It is not necessary to know the offset addresses.  

The following firmware supports the I/O Watch monitor function:  
Fieldbus From Version 

PROFIBUS-DP Master 1.040 (Combimaster) resp. 1.140 (DP-Master)  

InterBus Master  2.040  

CANopen Master 1.040  

DeviceNet Master 1.058  

AS-Interface Master 1.010 

Table 17: Firmware for I/O Watch function 

The following table lists the typical steps to use the I/O Watch monitor.  

Preconditions:  

• The project/configuration already exists, containing an AS-Interface 
Master and the AS-Interface Slave(s) as described in section Getting 
Started – Configuration Steps on page 21.  

• The Configuration has been downloaded into the AS-Interface Master 
using Online > Download.  

• Running bus system  

 

1. Open the existing project using File > Open.  

2. Open the Windows dropdown menu and select Window > Logical 
Network View to change the window. A window with three sections opens  
Left Window Center Window Right Window 

Logical network view Tag list IO Watch 

 

3. Open the tree structure in the left window to reach the I/O module of the 
device desired:  

Project > Master > Channel > Slave > Modul > (possible) Submodul  
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Figure 53: Logical Network View and I/O Watch  

4. Left click on the module desired and the tags (I/Os) will be displayed in the 
center window of the Logical Network View.  

5. Select with the left mouse button the tag/symbol desired and drag and drop 
them in the right window (I/O Watch) of the Logical Network View.  

6. In the right hand side window select the desired tag with the left mouse 
click to highlight it then right mouse click to open a menu. Select Start. A 
new window called I/O Watch appears.  

7. A table shows the Device, Symbolic Name, IEC Address (Offset), Data type 
Representation and Value.  

8. Input data are displayed and can’t be changed. Output data can be entered 
into the value column.  

 
Figure 54: I/O Watch Window  

In the column representation can be selected the data type: Bit Pattern, 
Character (Byte), Decimal Signed, Decimal Unsigned, Hex  
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6.10 Message Monitor  
The Message Monitor permits access to the Mailbox of the CIF.  

Note: The usage of the  Message Monitor assumes advanced knowledge 
from the user.  

First the Hilscher device must be chosen with a left mouse click on the 
symbol of the Hilscher device. Then select the Online > Message Monitor 
menu.  

 
Figure 55: Online > Message Monitor  

A Message can be saved and loaded and has the file extension *.MSG.  

File > New: clears the window 

File > Open: opens a Message (Message can be loaded)  

File > Save or File > Save As: saves a Message  

File > Exit: ends the Message Monitor and returns to the SyCon.  
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Edit > Create answer: creates an answer Message  

Edit > Reset counter: resets the Message counter 

 

View > Review the received data: all received data is shown 

View > Review the  send data: all the send data is shown 

View > Number of receipt errors: the number of the received errors is 
shown  

View > Decimal/Hexadecimal: Switch the display format  

 

It is recommend to create a sub-directory MSG and to save the messages 
there.  

 
Figure 56: Save a Message  
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7 File, Print, Export, Edit and View 
7.1 File 

7.1.1 Open  
An existing project can be opened with File > Open.  

7.1.2 Save and Save As  
When the file name is known, then the configuration can be saved under 
the File > Save menu, otherwise the File > Save As menu must be 
selected.  

7.1.3 Close  
The current project can be closed with File > Close.  
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7.2 Print  
After the current printer has been selected in the File > Printer Setup 
menu, the configuration can be printed out under the File > Print menu. For 
a page view, select the File > Page View menu.  

7.3 Export Functions  

7.3.1 DBM Export  
Select the File > Export > DBM menu in order to save the previously 
saved project file (*.AS Microsoft Access Format) in a DBM file (Hilscher 
binary format). This DBM file can be loaded in the DOS Compro program. 
The configuration is stored in the Project directory in the path of the SyCon 
installation with the extension *.DBM. 

Attention: The file name can have max. 8 characters. 
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7.4 Edit 

7.4.1 Cut, Copy and Paste 
With Cut and Copy you put the cut/copied Slave device with its settings 
and configuration (only not the description of the device) in the Clipboard 
and with Edit > Paste it can be insert. 

The difference between Cut and Copy is: 

With the menu option Edit > Cut you move a Slave device from one point 
in the configuration to another. With the menu option Edit > Copy you 
duplicate an existing Slave device. 

If you select Edit > Cut a security question appears. 

 
Figure 57: Security question cut device 

If you answer this question with Yes the Slave device is cut and stays in the 
clipboard.  

When you select Edit > Paste the device can be insert again at the position 
you want. 

Possible insert positions are displayed with a colored circle . If you 
move the mouse pointer over this circles it changes into one of these 
symbols depended on which Slave device was cut or copied. 

possible insert 
positions 

 

Table 18: Mousepointer - possible insert positions 
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Figure 58: Paste a Slave device in the configuration 

Click on the position where the Slave is to be inserted. A window opens 
where the cut/copied Slave device can be selected. 

 
Figure 59: Edit > Paste Insert Device from Clipboard 

The cutted/copied Slave appears in the list Selected devices. In the field 
Address it is possible to assign a device address manually. Further you 
can type in a new name for the Slave in the field Description. With the OK 
button the Slave will be insert. 
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7.4.2 Delete 
To delete the Master or a Slave device you have to have to mark this 
device and then select the menu Edit > Delete. Before SyCon deletes the 
Master or a Slave a security question appears. 

 
Figure 60: Security question delete device 

Attention: When you delete a Master all connected Slaves, the settings 
and the configuration get lost.  

7.4.3 Replace 
With the menu Edit > Replace the Master or a Slave device can be 
replaced. How to replace the Master look in section Replace Master at 
page 25. If you want to replace a Slave device look in section Replace 
Slave at page 30. 



File, Print, Export, Edit and View 71/109  

SyConASI | System Configurator AS-Interface 
DOC011101OI06EN | Revision 6 | English | 2012-06 | Released | Public © Hilscher, 2001-2012 

7.5 View of the Configuration  
The configuration can be displayed in a table. The following tables are 
available:  

• Device Table 

• Address Table (Occupation of the process image memory in the 
Hilscher AS-Interface Master )  

7.5.1 Device Table  
The View > Device Table menu shows the list of all devices are used in 
the configuration. 

 
Figure 61: View > Device Table  
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7.5.2 Address Table  
A list of all addresses used in the process data image is displayed in the 
View > Address table menu.  

 
Figure 62: View > Address Table  

It is possible to sort addresses according to Slave numbers or data 
addresses.  

7.6 View Menu SyCon 

7.6.1 Logical Network View 
In the menu View > Logical Network View the user can activate or 
deactivate the network view by selecting its (with hook) or by not selecting it 
(without hook). 

The network view is used for example for the Start Options. 

7.6.2 Toolbars 
In the menu View > Toolbars the user has the possibility to activate or 
deactivate the Toolbars Standard and Fieldbus. If this function is 
deactivated the toolbars are not shown. 

7.6.3 Status Bar 
In the menu View > Status Bar this bar can be activated (with hook) or 
deactivated (without hook). 
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8 Tools 
8.1 PKV 40 Gateway 

The loading of new files into the Gateway or the setting of the IP address of 
the Gateway is carried out by means of the tools contained in the SyCon 
from version 2.620.  

To be able to use the configuration tools in the SyCon, it is necessary to 
create a configuration with a PKV 40 Gateway in SyCon. Now the menu 
entry PKV40-XXX (XXX here stands for the selected field bus system) 
appears in the Tools menu point. This makes it possible to choose 
between a serial RS-232 connection and a TCP/IP connection. 

A crossed RS-232 cable is necessary for operation at the serial interface. 
This can be ordered from the Hilscher company (KAB-SRV). 

The configuration via TCP/IP can also be carried out via a point to point 
connection with a crossed cable or, for example, via a Hub with 
commercially available Ethernet cables.  

The Gateway is supplied with a default IP address (see information sheet).  

 
Figure 63: Configuration dialog for the PKV 40-PB Gateway via TCP/IP 

The procedure for the serial configuration or the TCP/IP configuration is 
basically the same. First an IP address must be entered into the field 
provided for it or the serial interface with which the Gateway is connected 
must be selected. Then the Connect switch must be activated. If a valid 
connection to the Gateway has been established, the menu entries and the 
switches for configuration of the Gateway are released.  

In order to ensure communication via TCP/IP, the TCP/IP protocol on the 
PC must be configured in such a way that a connection with the default IP 
address is possible (see user manual for Windows NT). 
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8.1.1 Loading Files into the Gateway  
This function enables files to be loaded into the User FLASH or the RAM of 
the Gateway and to carry out applications after downloading or after the 
start of the operating system.  

Note: So that gateway takes over the IP address, it must be started again.  

Before a new application or a new and already available DLL can be 
downloaded, any running older versions of the application or programs that 
use DLLs must be ended. For this purpose, the corresponding running 
processes can be displayed under the Configuration > View Running 
Tasks menu entry. If an entry has been selected, then the Stop Process 
switch can be activated and the selected process is stopped.  

In order to transfer a new file, select the File > Copy to PKV40 menu point 
or activate the Copy to PKV button. Select the file to be loaded in the 
dialog that appears. 

 
Figure 64: Dialog for loading files on to the PKV 40 Gateway  

The path and name can be entered directly into the Source (PC) text field 
or select the path and file via the ... button. The Destination (PKV) field 
cannot be edited at present. All the copied files are read into the Windows 
directory of the Gateway. According to requirements, mark the buttons 
Save persistent, Execute after download and Execute after PKV boot. 
Activate the Download button and the software is transferred to the 
Gateway. Save persistent means that the downloaded files are stored in a 
zero-voltage secure manner in the FLASH-EPROM of the Gateway. Only 
then a start of the downloaded EXE file(s) is possible after a restart (Power-
Up). If Save persistent is not selected, the downloaded files are copied only 
temporarily in the RAM of the Gateway and are lost after a restart.  

Note: During a test phase, it is recommended that the files are not 
permanently stored in the FLASH-EPROM! 
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8.1.2 Loading Files onto the Host PC 
It is also possible to load files from the Gateway on to the Host-PC. For this 
purpose select the menu File > Copy to PC. 

 
Figure 65: Loading files from the PKV 40 Gateway to the Host PC  

The path of the file that is to be loaded can be entered directly into the 
Source (PKV) field or the contents of the FLASH can be viewed via the ... 
button and a file can be selected. Files that are situated only in the RAM 
system of the Gateway are not shown and must be entered manually into 
the Source field. Please note that there are no drive letters in Windows CE 
as is usual in other Windows operating systems. Instead a single dot must 
be entered as a drive designation (e.g.:.\Windows\ComSrv.exe). 

The target place and target name can be entered in the Destination (PC) 
field or selected via the ... button. 

After activating the Upload button, the file is loaded onto the Host PC. 
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8.1.3 Deleting Files  
In order to delete files, the menu File > View Flash Dir can be selected 
after a successful connection was built. A list of files that are permanently 
stored in the User FLASH memory is displayed. Now previously selected 
files can be deleted with the Delete Button. 

It must be noted that the files are only deleted from the file system of 
Windows CE but not actually out of the FLASH memory. For this reason 
also, this memory is not released for renewed writing to and with repeated 
copying it can happen that no more files can be permanently stored as the 
memory is full. 

In order to release memory again, the complete User FLASH must be 
deleted and the Delete All button is provided for this purpose. 

In order to prevent the deletion of important files necessary for operation, 
the SaveFile.dat file contains entries of all files that are not to be deleted. 
This file can be loaded on the HostPC and edited there and then returned 
to the Gateway again in order to protect files from being inadvertent 
deleted. However, these files are only protected from deletion of the whole 
FLASH memory. An individual deletion of the files is still possible.  

Attention: If the COM Server or a necessary DLL driver is deleted, then no 
configuration with SyCon is possible!  

8.1.4 Setting the IP Address  

 
Figure 66: Setting the IP Address 

Note: In order for the Gateway to accept the address, it must be restarted! 

It is possible to allocate a new IP address to the Gateway with the menu 
Configuration > Setting IP address. For this purpose, a connection with 
the Gateway is necessary as already mentioned. 

Now enter the desired valid IP address into the corresponding field. Press 
the Set button and the new address is allocated to the Gateway. 

If the alteration of the IP was successful, it will be displayed. A request for 
restarting the Gateway will appear. 

Please note that the newly allocated IP address is only valid after a restart 
of the Gateway. 
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8.1.5 Starting Applications 
Applications that have already been entered on to the Gateway can also be 
started manually. For this purpose the menu Configuration > Start 
Application is selected. Now enter the name of the application into the 
field provided for this purpose and press the OK button.  
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9 Error Numbers 
9.1 CIF Device Driver (Dual-port memory) Error Numbers (-1 

.. -49) 
This is the list of error numbers of dual-port memory access using the CIF 
Device Driver.  
Error Number Description  

-1 Driver: Board not initialized 
The communication board is not initialized by the driver.  
No or wrong configuration found for the given board, check the driver 
configuration.  
Driver function used without calling DevOpenDriver() first.  

-2 Driver: Error in internal ‘Init state‘  

-3 Driver: Error in internal ‘Read state‘  

-4 Driver: Command on this channel is active 

-5 Driver: Unknown parameter in function occurred 

-6 Driver: Version is incompatible 
The device driver version does not correspond to the driver DLL version. 
From version V1.200 the internal command structure between DLL and 
driver has changed. Make sure to use the same version of the device 
driver and the driver DLL.  

-10 Device: Dual port memory RAM not accessable (board not found) 
Dual-ported RAM (DPM) not accessible / no hardware found.  
This error occurs, when the driver is not able to read or write to the Dual-
port memory.  
Check the BIOS setting of the PC Memory address conflict with other PC 
components.  
Try another memory address, check the driver configuration for this 
board, check the jumper setting of the board.  

-11 Device: Not ready (RDY flag=Ready, flag failed) 
Board is not ready. This could be a hardware malfunction or another 
program writes inadmissible to the dual-port memory.  

-12 Device: Not running (RUN flag=Running flag failed) 
The board is ready but not all tasks are running, because of an 
initialization error. No data base is loaded into the device or a wrong 
parameter can causes that a task can't initialize. 

-13 Device: Watch dog test failed 

-14 Device: Signals wrong Operating System version 
No license code found on the communication board. Device has no 
license for the used operating system or customer software. No firmware 
or no data base to the device is loaded. 

Table 19: CIF Device Driver Error Numbers (-1..-14) 
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Error Number Description  

-15 Device: Error in dual port memory flags 

-16 Device: Send mailbox is full 

-17 Device: Function PutMessage timeout  
No message could be send during the timeout period given in the 
DevPutMessage() function.  
If you use an interrupt, check the interrupt on the device and in driver 
setup. These settings have to be the same! Is an interrupt on the board 
set? Is the right interrupt set? The interrupt could already be used by 
another PC component, also if the operating system reports it as 
unused. 
If you use polling mode, make sure that no interrupt is set on the board 
and that polling is set in the driver setup. These settings have to be the 
same!  
Device internal segment buffer full and therefore PutMessage() function 
is not possible, because all segments on the device are in use. This 
error occurs, when only PutMessage() is used but not GetMessage(). 
HOST flag is not set for the device. No messages are taken by the 
device. Use DevSetHostState() to signal a board an application is 
available. 

-18 Device: Function GetMessage timeout  
No message received during the timeout period given in the 
DevGetMessage() function. 
If you use an interrupt, then check the interrupt on the device and in 
driver setup. These settings have to be the same! Is an interrupt on the 
board set? Is the right interrupt set? The interrupt could already be used 
by another PC component, also if the operating system reports it as 
unused. 
If you use polling mode, make sure that no interrupt is set on the board 
and that polling is set in the driver setup. These settings have to be the 
same! 
The used protocol on the device needs longer than the timeout period 
given in the DevGetMessage() function. 

-19  Device: No message available 

Table 20: CIF Device Driver Error Numbers (-15..-19)  
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Error Number Description  

-20 Device: Reset command timeout 
The board is ready but not all tasks are running, because of an 
initialization error. No data base is loaded into the device or a wrong 
parameter can causes that a task can't initialize. 
The device needs longer than the timeout period given in the DevReset() 
function. Using device interrupts. The timeout period can differ between 
fieldbus protocols. 
If you use an interrupt, check the interrupt on the device and in driver 
setup. These settings have to be the same! Is an interrupt on the board 
set? Is the right interrupt set? The interrupt could already be used by an 
other PC component, also if the operating system reports it as unused. 
If you use polling mode, then make sure that no interrupt is set on the 
board and that polling is set in the driver setup. These settings have to 
be the same!  

-21 Device: COM flag not set 
The device can not reach communication state. Device not connected to 
the fieldbus. No station found on the fieldbus. Wrong configuration on 
the device. 

-22 Device: IO data exchange failed 

-23 Device: IO data exchange timeout 
The device needs longer than the timeout period given in the 
DevExchangeIO() function. 
If you use an interrupt, check the interrupt on the device and in driver 
setup. These settings have to be the same! Is an interrupt on the board 
set? Is the right interrupt set? The interrupt could already be used by 
another PC component, also if the operating system reports it as 
unused. 
If you use polling mode, make sure that no interrupt is set on the board 
and that polling is set in the driver setup. These settings have to be the 
same! 

-24 Device: IO data mode unknown 

-25 Device: Function call failed 

-26 Device: Dual-port memory size differs from configuration 

-27 Device: State mode unknown 

Table 21: CIF Device Driver Error Numbers (-20..-27) 
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Error Number Description  

-30 User: Driver not opened (device driver not loaded) 
The device driver could not be opened. Device driver not installed. 
Wrong parameters in the driver configuration. If the driver finds invalid 
parameters for a communication board and no other boards with valid 
parameters are available, the driver will not be loaded. 

-31 User: Can’t connect with device board 

-32 User: Board not initialized (DevInitBoard not called) 

-33 User: IOCTRL function failed 
A driver function could not be called. This is an internal error between 
the device driver and the DLL. Make sure to use a device driver and a 
DLL with the same version. An incompatible old driver DLL is used. 

-34 User: Parameter DeviceNumber invalid 

-35 User: Parameter InfoArea unknown 

-36 User: Parameter Number invalid 

-37 User: Parameter Mode invalid 

-38 User: NULL pointer assignment 

-39 User: Messagebuffer too short 

-40 User: Size parameter invalid 

-42 User: Size parameter with zero length 

-43 User: Size parameter too long 

-44 User: Device address null pointer 

-45 User: Pointer to buffer is a null pointer 

-46 User: SendSize parameter too long 

-47 User: ReceiveSize parameter too long 

-48 User: Pointer to send buffer is a null pointer 

-49 User: Pointer to receive buffer is a null pointer 

Table 22:CIF Device Driver Error Numbers (-30..-49) 

 
Error Number Description  

1000 If the operating system of the device reports an initialization error, then a 
value of 1000 will be add to the error number and shown to the user 

Table 23: CIF Device Driver Error Numbers (1000)  
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9.2 CIF Serial Driver Error Numbers (-20 .. -71) 
This is the list of error numbers using the serial driver.  
Error Number Description  

-20 Driver: No COM port found or COM port already in use.  

-21 Driver: COM port already opened 

-22 Driver: Function call into driver has failed 

-23 Driver: Internal driver error 

-24 Driver: Could not create read thread 

-25 Driver: Could not create read event 

-26 Driver: Could not create write event 

-27 Driver: Could not create timer event 

-28 Driver: Error by writing data 

-29 Driver: Wrong COM state 

-30 Driver: COM state error is set  

-31 Driver: COM buffer setup failed 

-32 Driver: COM set timeout failed 

-33 Driver: Receive buffer overrun 

-34 Driver: Receive buffer full 

-35 Driver: Send busy 

-36 Driver: Error during close driver 

-40 User: COM port not opened  

-41 User: Invalid handle value 

-42 User: Invalid COM number 

-43 User: Size parameter invalid 

-44 User: Size parameter zero 

-45 User: Buffer pointer is zero 

-46 User: Buffer too short 

-47 User: Setup error 

Table 24: CIF Serial Driver Error Numbers (-20..-47) 
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Error Number Description  

-50 User: Send message, timeout error 

-51 User: Could not send a message 
Cable not connected.  
Wrong cable. 
Device does not respond.  

-52 User: Send message, no device connected 

-53 User: Error by send message, message receiving 

-54 User: Telegram collision 

-55 User: Telegram, no acknowledgement received 

-56 User: Telegram, noise 

-57 User: Telegram, data overrun 

-58 User: Telegram, parity error 

-59 User: Telegram, framing error 

-60 User: Telegram, unknown error 

-70 User: Timeout by receive a message 

-71 User: No message received 

Table 25: CIF Serial Driver Error Numbers (-20..-47) 
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9.3 RCS Error Numbers (4 .. 93) 
This is the list of error numbers returned by the RCS (Realtime 
Communication System), that is the operating system of Hilscher devices. 
The error number is returned in an answer message. Command messages 
and answer messages are used to communicate between the application 
(e.g. the system configurator) and the Hilscher device. An example of this 
communication is the download of a configuration.  
Error Number Description  

4 Task does not exist  

5 Task is not initialized  

6 The MCL is locked 

7 The MCL rejects a send command because of an error  

20 The user will download a database into the device that is not valid for 
this device type. 

21 Data base segment not configured or not existent  

22 Number for message wrong during download  

23 Received number of data during download does not match to that in the 
command message  

24 Sequence identifier wrong during download  

25 Checksum after download and checksum in command message do not 
match  

26 Write/Read access of data base segment  

27 Download/Upload or erase of configured data base type is not allowed 

28 The state of the data base segment indicated an error. Upload not 
possible  

29 The access to the data base segment needs the bootstraploader. The 
bootstraploader is not present 

30 Trace buffer overflow  

31 Entry into trace buffer too long 

37 No or wrong license. The OEM license of the system configurator allows 
only communication to devices that have the same license inside  

38 The data base created by the system configurator and the data base 
expected by the firmware is not compatible  

39 DBM module missing  

Table 26: RCS error numbers (answer message) (4..39)  
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Error Number Description  

40 No command free 

41 Command unknown 

42 Command mode unknown  

43 Wrong parameter in the command  

44 Message length does not match to the parameters of the command  

45 Only a MCL does use this command to the RCS  

50 FLASH occupied at the moment  

51 Error deleting the FLASH  

52 Error writing the FLASH 

53 FLASH not configured 

54 FLASH timeout error 

55 Access protection error while deleting the FLASH  

56 FLASH size does not match or not enough FLASH memory 

60 Wrong structure type  

61 Wrong length of structure  

62 Structure does not exist 

70 No clock on the device  

80 Wrong handle for the table (table does not exist) 

81 Data length does not match the structure of this table  

82 The data set of this number does not exist 

83 This table name does not exist 

84 Table full. No more entries allowed  

85 Other error from DBM 

90 The device info (serial number, device number and date) does already 
exist 

91 License code invalid  

92 License code does already exist  

93 All memory locations for license codes already in use  

Table 27: RCS error numbers (answer message) (40..93)  
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9.4 Database Access Error Numbers (100 .. 130)  
The following table lists the error numbers of the database access errors  
Error Number Description  

100 Database already opened  

101 Dataset could not be opened 

103 Error while opening database occurred  

104 No valid path name  

105 No connection to data base. Call function DbOpen().  

106 Error in parameter  

107 Error during opening a table  

108 Nullpointer occurred  

109 Table not opened. Call function OpenTable() first. 

110 The first record is reached 

111 The last record is reached 

112 Unknown type in the record found  

113 Data has to be truncated 

114 No access driver installed on the system 

115 Exception received  

116 This table is set to read only 

117 There is no data set in the table 

118 The requested table could not be edit 

119 An operation could not be completed 

120 User gives an unexpected length in WritsDs().  

121 An assertion failed 

122 DLL not found  

123 DLL couldn't be freed 

124 Specified function not found in the DLL  

125 ODBC Function returns an error 

126 Count of data bytes in the record exceeds 1938 

127 DBM32 DLL is not loaded 

128 Field with the given index was not found 

129 This table contains no records 

130 Invalid character (' ') found in a Table or Column 

Table 28: Database Access Error Numbers (100..130)  
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9.5 SyCon Error Number (235)  
Error Number Description  

235 Project file with the same name already opened. Two project files with 
the same name can't be opended at the same time. 

Table 29: SyCon Error Number (235)  
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9.6 Online Data Manager Error Numbers  

9.6.1 Online Data Manager Error Numbers (1000 .. 1018)  
The following table lists the error numbers of the Online Data Manager.  
Error Number Description  

1000 Driver OnlineDataManager not opened 

1001 Initialization of the OnlineDataManager has failed  

1002 No DriverObject found. OnlineDataManager Sub DLL not found.  

1003 No DeviveObject found. Device not found.  

1004 Application not found 

1010 Application has requested an unknown event  

1011 Application has requested an unknown function mode, operating mode. 
Known function modes, operating modes are Reset, Download, Register 
Server, Unregister Server. 

1012 Application has requested an unknown command 

1013 Message Server already exists  

1014 Message Server not registered 

1015 Device already in use 

1016 Device not assigned  

1017 Device has changed  

1018 Command active 

Table 30: Online Data Manager Error numbers (1000..1018)  

9.6.2 Message Handler Error Numbers (2010 .. 2027)  
The following table lists the error numbers of the Message handler of the 
Online Data Manager.  
Error Number Description  

2010 Message handler: Messagebuffer empty 

2011 Message handler: Messagebuffer full 

2021 Message handler: Invalid Message ID (msg.nr)  

2022 Message handler: No entry  

2023 Message handler: Message already active 

2024 Message handler: Wrong Application  

2025 Message handler: Message Timeout  

2026 Message handler: Wait for Delete 

2027 Message handler: No cyclic Message 

Table 31: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)  
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9.6.3 Driver Functions Error Numbers (2501 .. 2512)  
The following table lists the error numbers of the Driver Functions of the 
Online Data Manager.  
Error Number Description  

2501 OnlineDataManager Sub DLL not found 

2502 Function missing 

2503 'Read Thread' not created 

2504 'Write Thread' not created 

2505 'IO Thread' not created  

2510 Function failed 

2512 Assign reports error. Return neither OK or cancel 

Table 32: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512) 

9.6.4 Online Data Manager Subfunctions Error Numbers (8001 .. 
8035) 

The following table lists the error numbers of the Subfunctions of the Online 
Data Manager.  
Error Number Description  

8001 Driver not opened. E.g. CIF Device Driver  

8002 Application has requested an unknown event  

8003 Application has requested an unknown command 

8004 Command has failed  

8005 Command active 

8006 Device invalid 

8010 No device was assigned 

8011 Device was already assigned  

8020 Driver not connected 

8021 Driver already connected 

8030 Faulty 'GetState'  

8031 Send error (PutMessage returns error)  

8032 Send active (PutMessage active) 

8033 Receive error (GetMessage returns error)  

8034 Receive active (GetMessage active) 

8035 IO Error (ExchangeIO returns error) 

Table 33: Subfunction Error Numbers of the Driver Functions of the Online Data Manager 
(8001..8035)  
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9.7 Data Base Functions Error Numbers (4000 .. 4199)  
The following table lists the error numbers of the converting functions.  
Error Number Description  

4000  File does not exist  

4001  Success in comprimizing  

4002  Dataset does not exist  

4003  Last respectively first entry reached  

4004  Not enough memory  

4005  File directory full  

4006  Max number of entries reached  

4007  No writing to this table possible, because the table is located in the 
FLASH  

4008  Table name does already exist  

4009  File name does not exist  

4010  Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2  

4011  Parameter ‘next’ wrong  

4012  Not enough free space to copy data set  

4013  Set is deleted  

4014  Value for Index is wrong  

4015  Access not allowed  

4016  open_file used before init_file  

4017 Drive is not ready 

4018 Not enough drive memory  

4019 File name or path does not exist 

4020 Cannot create path 

4021 Wrong path 

4022 Wrong flag 

4023 The delete path is the root path 

4024 Path file exists 

4025 Write error during write a file 

4026 Error during create a file 

4027 Error during close a file 

4028 No DBM file 

4029 Length of the read data is unequal of the file length 

Table 34: Error numbers of converting functions (4000..4029)  
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Error Number Description  

4030 Path too long 

4031 Directory changed 

4032 Directory created 

4034  Length of converting stream is 0  

4035  Non equal data set found 

4036  Non equal data set found 

4037  Non equal data set found 

4038  Data set has length 0 

4039  The function DbmInit has assigned a Zero pointer during RCS 
initialization 

4040  Printer not ready  

4041  The data base is used from another function  

4042  New length of data base is smaller than used  

4043  Unknown access mode  

4044  Old data base has to be converted  

4045  Error while converting. Function not known  

4046  Unknown type in set 0 found  

4047  No float function available  

4048  Function not in RCS module  

4049  Check failed  

4050  Checksum check failed  

4051  More segments are existing in file, than in the structure FILE_INFO_T in 
wMaxEintraege  

4052  SegLen in structure FILE_INFO_T is smaller then the length in the file. 
Return of function dbm_restore_data  

4053  The header file holds an other information for a length than in the 
segment itself  

4054  Not enough memory for allocation on the PC  

4055  No index for file handle in structure FLASH_DIR of RCS found  

4057  File type 2 can not be printed because of too many definitions  

4058  The definitions need too many lines to display them, than in the program 
available  

4059  An unknown format for the parameter. Valid is U, H, or S 

4060  Unknown parameter type  

Table 35: Error numbers of converting functions (4030..4060)  
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Error Number Description  

4061  The data base was transmitted into the FLASH  

4062  Set 0 contains no structure definition  

4063  Set 0 can not be deleted  

4064  Error during execution of a ODBC data base access  

4065  Initializing of DBM through RCS had no success  

4066  Passed data length incorrect  

4067  Sorting function not linked  

4068  Error in function parameter  

4069  Error from ODBC table  

4070  No free handle available. Too many data base links are already opened  

4071  Unknown data type found in the table  

4072  Structure of table GLOBAL not correct or no such table existing  

4073  No name of an ACCESS data base  

4074  Download window can’t be created  

4075  Download not fully performable  

Table 36: Error numbers of converting functions (4061..4075)  
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Error Number Description  

4082  More than 32 tables should be created  

4083  No entry in element szSourceFile  

4084  ODBC connection initialization not possible. This could happen when in 
file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no 
valid path to ODBCJT16/32.DLL. 

4085  Error in structure in the ACCESS data base that is in DBM format  

4086  Error in structure in the ACCESS data base that is in DBM format  

4087  No data in a ODBC table  

4088  No entry  

4089  ODBC set length not valid  

4090  Not enough data sets in ODBC table  

4091  Table CreateTab not found  

4092  Error in structure of table CreateTab  

4093  No entry in element szSourceTable  

4094  No entry in element szDestTable  

4095  Entry in iSourceType of table CreateTab is wrong  

4096  Entry in iTranslate of table CreateTab is wrong  

4097  Function SQLAllocStmt reports an error  

4098  ODBC source table not found  

4099 ODBC data truncated  

4100 Download timeout  

4101 Library load error  

4102 Library function error 

4103 Error in description 'toggle'  

4104 Error in description 'KB'  

4105 Column does not exist 

4106 ODBC structure different  

4107 ODBC address error  

4108 No CRC sum exists (table GLOBAL exists or old)  

4109 Table GLOBAL is old 

4110 Calculated CRC different to CRC in table GLOBAL 

4199 Programming error  

Table 37: Error numbers of converting functions (4082..4199)  
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9.8 Converting Functions Error Numbers (5001 .. 5008) 
The following table lists the error numbers of converting functions.  
Error Number Description  

5000 Function PackLongToByteShort: Not enough space in pvD (Number of 
elements greater than reserved memory)  

5001 Function PackLongToByteShort: Not enough space in pvD. Detected 
during converting of pvS  

5002 Function PackLongToByteShort: Not enough space in pvD 

5003 Function StringToByte: Not enough space in pvD  

5004 Function IntToByte: Not enough space in pvD  

5005 Function LongToShort: Not enough space in pvD  

5006 Function PackStringDumpToByteArray: Not enough space in pvD  

5007 Function PackStringBumpToByteArray: A character was found, which is 
not convertable into a HEX value 

5008 Function PackStringDumpToByteArray: Number of character odd 

5009 Function PackStringDumpToByteArray: Not enough space in pvD 

5010 Function PackStringDumpToByteArray: The current data set needs to be 
appended the previous one 

5011 Function PackStringDumpToByteArray: No corresponding function to the 
given number exist 

5012 Converting error 

Table 38: Error Numbers of data base functions (5000 .. 5012) 
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10 Appendix 
10.1 Extended Device Diagnostic Master 

On the following pages the task state structures of the AS-Interface Master 
are described.  

10.1.1 ALI_TASK Common Variables 

 
Figure 67: ALI_TASK Common Variables 

Variable Meaning 

Message counter Number of received command messages 

Mail box counter Number of received messages via the mail box 

Write parameter Number of received messages "Write parameter" 

Read parameter Number of received messages "Read parameter" 

Read actual config Number of received messages "Read actual config" 

Set operation mode Number of received messages "Set operation mode" 

Set online mode Number of received messages "Set online mode" 

Set data exch active Number of received messages "Set data exch active" 

Change slave address Number of received messages "Change slave address" 

Set auto address enable Number of received messages "Set auto address enable" 

User error counter Number of detected errors 

Error code Last detected error code 

Table 39: ALI_TASK Common Variables 
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10.1.2 PLC_TASK Status Variables 

 
Figure 68: PLC_TASK Status Variables 

Variable Meaning 

PLC task version PLC-Task compiled for ASI  

Task state is not used 

Cycle time is not used 

PLC mode set Handshake mode 
This value represents the actual handshake mode between 
application and CIF 
0 = Bus synchonous, Device Controlled 
1 = Buffered, Device Controlled 
2 = Uncontrolled 
3 = Buffered, Host Controlled 
4 = Bus synchonous, Host Controlled 

Event counter counter for detected task internal events 

Handshake counter for performed DPM handshakes 

Data update counter for the update of DPM I/O data 

Not ready event counter for detected "not ready events" 

Table 40: PLC_TASK Status Variables 
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10.1.3 ASI_TASK Common Information 

 
Figure 69: ASI_TASK Common Information 
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Variable Meaning 

Message counter number of detected messages 

Received answers number of detected answer messages 

Data exchange counter number of data cycles of the ASI task 

Project modules ch1 number of configured Slaves channel 1 

Project modules ch2 number of configured Slaves channel 2 

Activated modules ch1 number of activated Slaves channel 1 

Activated modules ch2 number of activated Slaves channel 2 

Detected modules ch1 number of detected Slaves channel 1 

Detected modules ch2 number of detected Slaves channel 2 

Initiate message is not used 

Start sequence is not used 

Parameter download number of performed parameter downloads 

Activate configuration number of performed "Activate configuration" commands 

Device diagnostic number of detected " Device diagnostic" commands 

Set permanent is not used 

Get permanent number of performed "Get Permanent Configuration" 
commands 

Get analog module number of performed "Get analog module Description" 
commands 

Auto configuration number of detected "Auto configuration" commands 

Set data exchange active number of detected instructions to activate/deactivate of the 
data transmission 

Get Asi task state number of detected commands "Get Task State" 

Error in channel Channel, where the error was detected 

Device address Slave address where the error was detected 

Error event detected error 

Error event description description of error as text 

Error counter number of detected errors 

Table 41: ASI_TASK Common Information 
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10.1.4 ASI_TASK Device Running States, Channel 1 

 
Figure 70: ASI_TASK Device Running States, Channel 1 

This table contains information about the actual state of all Slaves. Possible 
values/descriptions/entries für the device state are: Not initialized, Not 
activated, No fault, Missing, Found, Configuration fault. 

10.1.5 ASI_TASK Device Running States, Channel 2 

 
Figure 71: ASI_TASK Device Running States, Channel 2 

This table contains information about the actual state of all Slaves. Possible 
values/descriptions/entries für the device state are: Not initialized, Not 
activated, No fault, Missing, Found, Configuration fault. 
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10.1.6 ASI_TASK Global State Field, Channel 1 
See section Global State Field at page 57. 

10.1.7 ASI_TASK Global State Field, Channel 2 
See section Global State Field at page 57. 

10.1.8 ASI_TASK Live List, Channel 1 
See section Live List at page 54. 

10.1.9 ASI_TASK Live List, Channel 2 
See section Live List at page 54. 
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10.1.10 ASI_TASK IX System 

 
Figure 72: ASI_TASK IX System 

Variable Meaning 

State channel 1 Init, Operational, Failure 

State channel 2 Init, Operational, Failure 

IX state channel 1 Internal state of data transmission to ASI-ASIC 

IX state channel 2 Internal state of data transmission to ASI-ASIC 

Interrupts channel 1 Counter for detected interrupts for ASIC CH1  

Interrupts channel 2 Counter for detected interrupts for ASIC CH2 

LED state channel 1 State of card LEDs (off, red flashing, green flashing, green) 
CH1 

LED state channel 2 State of card LEDs (off, red flashing, green flashing, green) 
CH2 

Error in Error in channel 1 or channel 2 

Error counter Number of detected errors 

Event Error event / error number 

In line ...detected in line 

In file ...detected in file module 

Table 42: ASI_TASK IX System 
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10.2 I/O Code, ID Code, ID2 Code and Slave Profiles 
The I/O Code describes the direction of the data bits of a Slave. This can 
be: Input, Output, Bi-directional or Tristate. 

The ID Code and ID2 Code is programmed by the production of a Slave 
and can not be changed by the user. It serves for the identification of the 
Slaves, which correspond to a fixed profile.  

The identification of a Slave has to be done like the following: 

S-[I/O-Code].[ID-Code].[ID2-Code]. 
I/O Code  I/O Configuration 
(4 Bit) D0 D1 D2 D3 

0x0 IN IN IN IN 
0x1 IN IN IN OUT 
0x2 IN IN IN I/O 
0x3 IN IN OUT OUT 
0x4 IN IN I/O I/O 
0x5 IN OUT OUT OUT 
0x6 IN I/O I/O I/O 

0x7 I/O I/O I/O I/O 

0x8 OUT OUT OUT OUT 
0x9 OUT OUT OUT IN 
0xA OUT OUT OUT I/O 
0xB OUT OUT IN IN 
0xC OUT OUT I/O I/O 
0xD OUT IN IN IN 
0xE OUT I/O I/O I/O 

0xF TRI TRI TRI TRI 

Table 43: Possible I/O Codes of a Slave 

IN = Input data 
OUT = Output data 
I/O = In- and Output data 
TRI = Tristate 

For example the I/O Code 7 of a Slave:  

If a Slave has this profile all four data bits can be read and written, they are 
bi-directional. For this profile various ID Codes are already defined. 
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ID Code Slave Profile 

 0 1 2 3 4 5 6 7 8 9 A B C D E F 
0 I, I, I, I - 0.1  0.B  

1 I, I, I, O - 1.1   

2 I, I, I, B -   

3 I, I, O, O - 3.1   

4 I, I, B, B -   

5 I, O, O, O X.0   

6 I, B, B, B -   

7 B, B, B, B - 7.1 7.2 7.3 7.4  7.B  7.D 7.E

8 O, O, O, O - 8.1   

9 O, O, O, I   

A O, O, O, B X.0   

B O, O, I, I  B.1   

C O, O, B, B X.0   

D O, B, B, B  D.1   

E O, B, B, B X.0  

A
/B

 Slaves 

 

Free Profiles I/O
 C

od
e 

F T, T, T, T  

Table 44: defined Slave profiles (released 01.03.2000) 

I = Input data 
O = Output data 
B = In- and Output data 
T = Tristate 

The defined Slave profiles exist for: 

I/O=X, ID=F free profiles (X=O...E) 

I/O=X, ID=0 remote I/O ports (X=0...E, not 9, B, D) 

I/O=X, ID=A reserved for A/B Slaves (X=0...E, not 2, A) 

I/O=0, ID=1  two dual-signal sensors 

I/O=0, ID=B reserved for safety oriented sensors 

I/O=1, ID=1  single sensor with extended control 

I/O=3, ID=1  one dual-signal sensor, one dual actuator 

I/O=3, ID=A sensor with extended address function 

I/O=7, ID=1  interface for the transfer of 6 to 18-bit signals 

I/O=7, ID=2  extended Slave profile for the transmission of 6 to 
   21-bit signals 

E/A=7, ID=3 extended Slave profile for the transmission of  
   16 bit signals 

E/A=7, ID=4 extended Slave profile for the transmission of  
   16 bit signals to 4 bit digital values 

Note: This table shows the defined Slave Profiles from the state 
01.03.2000. Further extensions are possible. 



Appendix 104/109  

SyConASI | System Configurator AS-Interface 
DOC011101OI06EN | Revision 6 | English | 2012-06 | Released | Public © Hilscher, 2001-2012 

The profile S-7.1 for example describes a device for the transmission of 6 
to 18 bit signals (analog profile), the profile S-7.2 describes a device for the 
transmission of 6 to 21 bit signals (extended analog profile) and so on. 
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12 Glossary 
SyCon 

System Configurator.  

Configuration and Diagnostic tool.  
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