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Safety Information
SAFETY INFORMATION

This manual provides general and specific
maintenance procedures essential for reliable engine
operation and your safety. Since many variations in
procedures, tools, and service parts are involved,
advice for all possible safety conditions and hazards
cannot be stated.

Read safety instructions before doing any service and
test procedures for the engine or vehicle. See related
application manuals for more information.

Obey Safety Instructions, Warnings, Cautions, and
Notes in this manual. Not following warnings,
cautions, and notes can lead to injury, death or
damage to the engine or vehicle.

Safety Terminology

Terms are used to stress your safety and safe
operation of the engine.

Note: A note describes actions necessary for correct,
efficient operation.

Work Area

• Keep work area clean, dry, and organized.

• Keep tools and parts off the floor.

• Make sure the work area is ventilated and well lit.

• Make sure a First Aid Kit is available.

Protective Measures

• Wear protective safety glasses and shoes.

• Wear correct hearing protection.

• Wear cotton work clothing.

• Wear sleeved heat protective gloves.

• Do not wear rings, watches or other jewelry.

• Restrain long hair.

Vehicle

• Shift transmission to neutral, set parking brake,
and block wheels before doing diagnostic or
service procedures.

• Clear the area before starting the engine.

Safety Equipment

• Use correct lifting devices.

• Use safety blocks and stands.

Engine

• The engine should be operated or serviced only
by qualified individuals.

• Provide necessary ventilation when operating
engine in a closed area.

• Keep combustible material away from engine
exhaust system and exhaust manifolds.

• Install all shields, guards, and access covers
before operating engine.

• Do not run engine with unprotected air inlets or
exhaust openings. If unavoidable for service
reasons, put protective screens over all openings
before servicing engine.

• Shut engine off and relieve all pressure in the
system before removing panels, housing covers,
and caps.

• If an engine is not safe to operate, tag the engine
and ignition key.

Fire Prevention

• Make sure charged fire extinguishers are in the
work area.

NOTE: Check the classification of each fire
extinguisher to make sure that the following fire
types can be extinguished.

1. Type A — Wood, paper, textiles, and rubbish

2. Type B — Flammable liquids

3. Type C — Electrical equipment

Batteries

• Always disconnect the main negative battery
cable first.

• Always connect the main negative battery cable
last.

• Avoid leaning over batteries.

• Protect your eyes.

• Do not expose batteries to flames or sparks.

• Do not smoke in workplace.
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1. ServiceMaxx™ Diagnostic
Software
NOTE: This section contains a brief overview of
ServiceMaxx™ diagnostic software, and was current
at the time of publishing. Due to the automatic
updating function in ServiceMaxx™ software, screens
and functions may differ from this manual.

1.1. Introduction

Navistar electronically controlled engines have a
wide range of standard and optional features.
ServiceMaxx™ software provides real-time data
monitoring, enhanced diagnostic capabilities, and
parameter programming.

NOTE: To diagnose specific electronic control system
failures, always refer to the diagnostic manual for the
system being serviced.

ServiceMaxx™ diagnostic software provides the
capability to:

• Monitor engine control system input and output
signals.

• View and program selected Electronic Control
Module (ECM) programmable parameters.

• Display and clear active and previously active
Diagnostic Trouble Codes (DTCs).

• Create customized diagnostic sessions to
enhance troubleshooting capabilities.

• Display maintenance information such as Total
Engine Hours and Total Fuel Used.

• Detect active modules on various vehicle
networks and easily identify communication
problems.

• Record snapshots of live engine signals to be
stored for later playback.

• Perform automated diagnostic tests to quickly
identify faulty components.

1.2. Acronyms

Following is a list of acronyms and their meanings
used in this document:

• DPF - Diesel Particulate Filter

• DTC - Diagnostic Trouble Code

• ECM - Electronic Control Module

• ESN - Engine Serial Number

• EST - Electronic Service Tool

• FMI - Failure Mode Indicator

• NAVCoM - Navistar Advanced Vehicle
Communication Module - dealers only

• SPN - Suspect Parameter Number

• MIN - Minimum

• MAX - Maximum
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2. Installing ServiceMaxx™ Fleet Pro
Software
2.1. Remove All Versions of JRE 6

• Click the Windows® Start menu.

• Click Control Panel.

• Click Add or Remove Programs.

• Remove all versions of Java™ from this menu if
different than Java™ 6 Update 26.

— Click on the version

— Click Change/Remove

— Follow instructions for removal

2.2. Installing JRE 6 Update 10

NOTE: If the JRE 6 Update 10 installation CD is not
available, the program can be downloaded from the
Internet. Refer to the following steps:

1. Go to http://www.oracle.com/technetwork/java/
javasebusiness/downloads/java-archive-
downloads-javase6-419409.html.

2. Click on Java SE Development Kit 6u10.

NOTE: Accept License Agreement must be selected
before the download will begin.

3. Click on link labeled
ire-6u10–windows-i586–p.exe.

4. Click on Run in pop-up box.

5. Follow on screen installation instructions.

After ServiceMaxx™ software is loaded on the
computer, the user will need to register the
software by calling Nexiq @ 1-877-905-6716, by
filling out the Fleet Software Authorization Form
and faxing it to (248) 293-8211, or by e-mailing
customer.service@nexiq.com. When this form
is processed, a password will be provided that
enables the software to be used on the corresponding
computer.

NOTE: ServiceMaxx™ Lite is now available after
the registration period expires. ServiceMaxx™
Lite has limited functionality when compared to
ServiceMaxx™ Pro.

2.3. Starting ServiceMaxx™ Software From Desktop

Figure 1 ServiceMaxx™ Software Desktop Icon

1. Locate the ServiceMaxx™ software icon. The
icon is placed on the desktop during the software
installation process.

Figure 2 Windows Start Menu – ServiceMaxx™
Software

NOTE: If the ServiceMaxx™ software icon is not
available on the desktop, the program can be
easily started using the Windows® Start menu.

2. Click on the icon to start ServiceMaxx™ software.

EGES-550
Read all safety instructions in the "Safety Information" section of this Manual before doing any procedures.

Follow all warnings, cautions, and notes.
©September 2011 Navistar, Inc. All rights reserved.



1 SERVICEMAXX™ USER’S GUIDE 7

2.4. ServiceMaxx™ Software Updates

ServiceMaxx™ software provides automatic software
updates directly from Navistar any time the tool is
connected to the Internet. Upon starting the program,
the user may notice an update message prior to the
software starting.

Figure 3 Update Notification Message

ServiceMaxx™ software is fully functional when the
Electronic Service Tool (EST) is not connected to the
Internet, but the EST should be connected often to
check for available updates.
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2.5. Language Change Settings

Windows 7

ServiceMaxx™ software is capable of displaying
in certain foreign languages. This can be done by
changing the settings of the computer’s operating
system.

Figure 4 Start Menu

1. From the Start menu, click on Control Panel.

Figure 5 Control Panel

2. Click on Region and Language.

Figure 6 Region and Language

3. Click on Formats tab.

4. From the Format drop-down menu, select desired
language.
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Windows XP

Figure 7 Start Menu

1. From Start menu, click on Control Panel.

Figure 8 Control Panel

2. Click on Regional and Language Options.

Figure 9 Region and Language

3. Click on Regional Options tab.

4. From the Format drop-down menu, select desired
language.
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3. Vehicle Connection
3.1. Diagnostic Interface Cable Information

The following communication adapters have been
verified with all ServiceMaxx™ software:

• Movimento – NAV-Link

http://www.nav-linkvci.com/

• Dearborn Group Technologies – DPA 4 and
DPA 4+

http://www.dgtech.com/products/
diagnostic_truck_tools.html

• Movimento - NAVCoM (Navistar Advanced
Vehicle Communication Module - dealers only)

http://www.nav-linkvci.com/

• Nexiq Technologies – USB Link

http://www.nexiq.com/catalog/
product_detail.asp?GID=6&=85

• Noregon Systems, Inc. – DLA, DLA USB

http://www.noregon.com/

NOTE: IC3 and IC4 USB cables are not reliable when
connected to 2007 and newer Navistar vehicles.

Please refer to eachmanufacturer’s website for further
information.
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3.2. Interface Device Selection

1. Using interface cable, connect EST to vehicle’s
diagnostic connector.

2. Start ServiceMaxx™ software.

Figure 10 Select Com Link

NOTE: Beginning with release version 388,
ServiceMaxx™ software will autoconnect to the
vehicle without having the user select the protocol.

If ServiceMaxx™ software fails to autoconnect, use
the following procedure:

3. From the Tools drop-down menu, go to Select
Com Link.

4. Select the cable/interface device.

a. NEXIQ Technologies

• USB-Link

— J1708 - All pre-MaxxForce®
(pre-2007) electronic engines.

— J1939 - All MaxxForce® engines
(2007–2010).

b. Noregon

• DLA, DLA USB

— J1708 - All pre-MaxxForce®
(pre-2007) electronic engines.

— J1939 - All MaxxForce® engines
(2007–2010).

c. Movimento

• NAVCoM/NAV-Link, USB0

— J1708 - All pre-MaxxForce®
(pre-2007) electronic engines.

— J1939 - All MaxxForce® engines
(2007–2010).

— Keyword 2000 – All MWM
engines.

d. Dearborn Group

• DG DPA 4/4 Plus USB, USB

— J1708 - All pre-MaxxForce®
(pre-2007) electronic engines.

— J1939 - All MaxxForce® engines
(2007–2010)

• If software is still unable to connect, see
the troubleshooting documentation provided
for the specific interface cable being used
(provided from cable manufacturer).

• If cable is not at fault, see CAN
Communications or J1939 in the “Electronic
Control Systems Diagnostics” section of
applicable Engine Diagnostics Manual.
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3.3. Connecting ServiceMaxx™ Software

1. Turn ignition switch to ON. Do not start engine.

2. Using interface cable, connect EST to vehicle’s
diagnostic connector.

3. Start ServiceMaxx™ software. After starting
ServiceMaxx™ software and selecting the
appropriate interface device (page 11), a
detection process will begin and should connect
automatically.

• If ServiceMaxx™ software cannot detect the
Engine Serial Number (ESN), then it may be
necessary for the user to select the engine
by clicking on Select Engine from the File
drop-down menu. Then select engine from
pop-up box.

Figure 11 Select Engine

Figure 12 ECM Connected Icon

• If the software has connected to the ECM, active
signals will populate the startup screen, and the
ECM connected icon in the bottom right corner will
show connected.

Figure 13 ECM Disconnected Icon

• When the software is unable to connect to the
ECM, signals and vehicle information will not be
displayed, and the ECM disconnected icon in the
bottom right corner will show disconnected.

• If the software is unable to connect to the ECM,
go to (Interface Device Selection, page 11).
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4. ServiceMaxx™ Software
4.1. Using ServiceMaxx™ Software

Figure 14 Default Session

1. Menu Bar
a. File
b. View
c. Sessions
d. Tests
e. Procedures
f. Tools
g. Help

2. Communication Control and
Status Button

3. Trigger Setup Button

4. Trigger Arm/Disarm Button
5. Data Record Button
6. Sessions Buttons Bar

a. Default
b. Parameters
c. Signals

7. Parameters Window
8. Temperature Window

a. Voltage tab
9. Sniffer Window
10. ECM Connection Status Icon

11. Position & Pressure Window
a. Voltage tab

12. Diagnostic Trouble Codes
Window
a. Datalink Traffic tab
b. DTC Log tab

13. Message Area
14. Vehicle Information Window
15. Instructions Window
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4.2. Software Features

When ServiceMaxx™ software is started, a Default
session displays as the opening screen. The following
is a brief description of each area displayed in the
Default session.

1. Menu Bar

The menu bar at the top of the application window
contains a row of sevenmenu titles. When amenu title
is selected, a drop-down menu reveals a list of menu
options. These options enable the user to perform
various actions within the software. The seven menu
titles are:

• File - Displays the following options: Online Mode,
Select Engine, Open Recorded Signal File, Export
Parameters, Create Template, Open Template,
Print, and Exit.

• View - Displays the following options: Display
Metric Units of Measure, Datalink Traffic,
Diagnostic Trouble Codes, Permanent Diagnostic
Trouble Codes, Instructions, Parameters,
Signals, Sniffer, Stand Alone Real Time Clock,
and Vehicle Information.

• Sessions - Displays the following options:
Load Session, Save Session, Rename
Session, Default, Driver Switch Controls,
HD-OBD Monitors, Parameters, Programming,
Signals, Simple, MWM Sessions, Continuous
Monitor, Hard Start - No Start, Performance,
Aftertreatment, Vehicle Events, and Vehicle Trip
Report.

• Tests - Displays the following options: Load Test
Specific Session, Engine Off Tests, Engine
Running Tests, Aftertreatment Tests, 2008
BB Actuator Tests, Actuator Test, and Injector
Disable Tests.

• Procedures - Displays the following options:
Engine Off Procedures, Engine Running
Procedures, and Aftertreatment Procedures.

• Tools - Displays the following options: Activate
Com Link, Select Com Link, Simulate Engine,
Trigger Setup, Arm Trigger, Start Recording,
Recording Interval, Clear Statistics, Reset Trip
Report, and Reset VETS.

• Help - Displays the following options: About,
Messages, Detailed Logging, Registration,
License Agreement, and View Log.

2. Communication Control and Status Button

The communication control and status button turns
the connection to the ECM on and off and displays
connection status.

3. Trigger Setup Button

The trigger setup button is used to record session data
automatically, based on conditions determined by the
user. The user is required to provide conditions when
trigger setup is selected.

4. Trigger Arm/Disarm Button

The trigger arm/disarm button enables or disables
triggered recording.

5. Data Record Button

The data record button records signal and parameter
information using various recording intervals.

6. Sessions Button Bar

The Sessions button bar provides one click access to
frequently used software controls.

• The Default session monitors all position,
temperature, and pressure sensors.

• The Parameters session monitors vehicle events.

• The Signals session monitors specific signals.

10. ECM Connection Status Icon

The ECM connection status icon is used to show
connection status between the ECM and the EST.
The left plug represents data traveling to the ECM.
The right plug represents data traveling from the ECM.
When both sides are green and connected, data is
flowing between the ECM and EST. It separates when
the ECM stops responding to requests.

13. Message Area

The message area displays tool information such as:
what tests are running, completed, or aborted.

Default ServiceMaxx™ Panes

7. Parameters Window

The Parameters window displays a small list of
parameters such as: Event logs, Engine Warn
Protection System, Idle Shutdown, and Cruise
Control enablers. All Parameters can be viewed by
un-checking the Only Show Watched box.
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8. Temperature Window

The Temperature window displays all ECM-monitored
temperature sensor information for the engine.

• The Voltage tab in this window shows actual
voltage values for each temperature sensor.

9. Sniffer Window

The Sniffer window provides real-time monitoring of
the network activity for each module on the various
data links. This window is used to identify if the
individual modules are present and communicating
on the vehicle networks.

11. Position & Pressure Window

The Position & Pressure window displays all
ECM-monitored position and pressure sensors.
System status information, such as Diesel Particulate
Filter (DPF) Regen status and the Engine Shutdown
timer, are also available.

• The Voltage tab in this window displays the actual
voltage values of each of these sensors.

12. Diagnostic Trouble Code (DTC) Window

The DTC window displays all active or previously
active ECM DTCs. DTCs can also be cleared in this
window. The DTC window is displayed in all of the
software Default sessions.

• Datalink Traffic displays messages that are on the
datalink being used.

• DTC Log displays stored DTCs.

14. Vehicle Information Window

The Vehicle Information window provides vehicle
information for the connected vehicle. Displayed
information includes items similar to:

• Engine Type

• Software Identification

• Engine Family Rating Code

• Vehicle Identification Number

• Engine Serial Number

• Transmission Type

• Rated Horsepower

• Total Miles

• Total Fuel Used

• Total Engine Hours

15. Instructions Window

The Instructions window displays important
instructions and information related to the currently
selected session or test. Messages may include basic
instructions, test alerts, and other useful information.

4.3. ServiceMaxx™ Service Messages

Figure 15 Service Messages From Navistar

After an update, important messages about this
updated version are displayed. To disable a previous
message and prevent it from being displayed in the
future, select the box in the Don’t Show column for
the individual messages to be disabled.

To display messages that were previously disabled,
select Messages from the Help drop-down menu.
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5. Sessions
Sessions can display vehicle and engine information,
such as: module calibration, sensor signals, and
actuator command signals. Special engine and
vehicle features can also be programmed using these
sessions.

ServiceMaxx™ software has many default sessions
that load automatically when running any Service Bay
Test or Service Tool Procedure. Users are not limited
to any default session. Users are able to build their
own session and save or load it at anytime.

ServiceMaxx™ software also has a few added
sessions that do not load automatically, but can be
selected from the Sessions drop-down menu. These
sessions are available to help diagnose common
systems and program special features.

Predetermined sessions can be accessed from the
Sessions drop-down menu.

5.1. Sessions Menu

Figure 16 Sessions Menu
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Figure 17 Load Test Specific Session

NOTE: The check mark indicates the session will
automatically load.

Some of these sessions are associated with service
bay tests and will automatically load when a test is
commanded. However, the user does have the option
to disable the automatic load feature if wanting to run
a test using a different session.

5.2. Building a Session

Users can build their own sessions to monitor specific
parameters or signals not usually grouped together.

Figure 18 Menu Bar and Button Bar

1. Select the Parameters or Signals button from the
button bar or return to the Default session.

2. Select desired signals by check marking the
boxes in the Watched column.

3. Once all desired signals have been selected, click
on the Only Show Watched box to hide all signals
that were not selected.

NOTE: The list may be scrolled up and down using the
window scroll bar.

Figure 19 View Menu

NOTE: Other information can be added to a session
by selecting any of the items from the View drop-down
menu. All columns displayed are moveable and
configurable. Right-clicking on a column header
allows the user to add or remove columns.
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Figure 20 Signals Session

1. Signal Graph Display Window
2. Only Show Watched Box

3. Graph Legend
4. Watched Column Boxes

5. Signal Selection Window
6. Search Button

NOTE: Displayed signals are represented by different
colored graph lines. When multiple signals are
displayed, signal identification can be made using the
graph legend. Clicking on a Watched column box
gives the user the option to show or hide the graph.
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5.3. View and Clear Signal Value Statistics

ServiceMaxx™ software records minimum,
maximum, and average values for every signal (when
applicable). Use this procedure to view and reset
those statistics.

1. Right click on the signal selection window header.

Figure 21 Add Signal Value Statistics

2. Select Min Value, Max Value, or Avg Value.

Figure 22 Statistic Value Columns

NOTE: A new column will appear for each statistic
added.

Figure 23 Clear Statistics

3. From the Tools drop-down menu, select Clear
Statistics. This will reset the minimum, maximum,
and average values.
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5.4. Saving Session Files

Figure 24 Saving a Session File

Built or modified session files can be saved to be
loaded at a later time. This does not effect any of the
software’s pre-made sessions.

1. Click on the Sessions drop-down menu and select
Save Session.

2. Type in the desired session name in the file name
box.

3. Save the session to the desired location on your
computer by clicking on the Save button.

5.5. Loading a Saved Session

1. Click on the Sessions drop-down menu and select
Load Session.

Figure 25 Opening a Saved Session

2. Navigate to the previously saved session file and
click on the Open button.
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5.6. Recording Session Data (Snapshot)

ServiceMaxx™ software can record signal information
using various data sample rates (Recording Intervals).
Recording Intervals can be selected using the Tools
drop-down menu.

Figure 26 Recording Interval selection

Using the Recording Interval scale, the user can
adjust the amount of data being recorded in a
snapshot. The default setting is 0.2 seconds.

Figure 27 Record Button

1. Click on the Record button to start recording the
current session.

Figure 28 Recording Notification Message

NOTE: When the Recording function is active, a
Recording alert is displayed in the message area.

Figure 29 Stop Button

2. Click on the stop button to stop recording.

Figure 30 Recording Saved Confirmation Screen

3. When recording is stopped, a pop up message
alerts the user to the file name and location of
the recorded snapshot. Files created with the
recording function are saved in the SnapShots
desktop folder.
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5.7. Triggered Recording

ServiceMaxx™ software uses triggered recording to
record signal data automatically, based on conditions
determined by the user. Triggered recording is helpful
when recording snapshot information while trying to
duplicate an operating condition. Once the condition
is met (trigger is set), recording automatically begins.

Trigger Setup

Figure 31 Trigger Setup

1. Add Condition Button
2. Save Button
3. Cancel Button
4. Record Pre-Trigger
5. Post-Trigger
6. Recurring Trigger
7. Remove Column
8. Value Column
9. Operator Column
10. Remove Button
11. Signal column
12. Add Criteria button

1. Add Condition Button

The Add Condition button is used to begin set-up for
triggered recording.

2. Save Button

The Save button is used to save trigger set-up
information for future use.

3. Cancel Button

The Cancel button is used to cancel triggered
recording.

4. Record Pre-Trigger

Record Pre-Trigger is the number of seconds
information is recorded before the trigger is set.

5. Post-Trigger

Post-Trigger is the number of seconds information is
recorded after the trigger is set.

6. Recurring Trigger

Recurring Trigger is used to repeat recording every
time the trigger is set. Recurring Trigger only repeats
during the current session.

7. Remove Column

The Remove column is used to remove criteria.

8. Value Column

The Value column is used to provide the specification
signal value for triggered recording.

9. Operator Column

The Operator column is used to indicate if the trigger
should be set when signal value is less than, greater
than, equal to, or not equal to the specification in the
value column.

10. Remove Button

After criteria is added, the Remove button is used to
remove the selected trigger signal.

11. Signal Column

The Signal column is used to select what signals to
trigger.

12. Add Criteria Button

After the Add Condition button is selected, the Add
criteria button is used to add signals to trigger.

EGES-550
Read all safety instructions in the "Safety Information" section of this Manual before doing any procedures.

Follow all warnings, cautions, and notes.
©September 2011 Navistar, Inc. All rights reserved.



1 SERVICEMAXX™ USER’S GUIDE 23

Using Triggered Recording

Figure 32 Trigger Setup Button

1. From the Default session main screen, click on
the Trigger Setup button.

Figure 33 Add Condition Button

2. Click on the Add Condition button.

Figure 34 Add Criteria Button

3. Click on the Add Criteria button.

Figure 35 Selecting Signal

4. Select a signal to trigger.

Figure 36 Selecting Trigger Operator

5. Select a trigger operator (greater than, less than,
equal to, not equal to).

Figure 37 Selecting Signal Value

6. Add a signal value.

NOTE: To trigger more than one signal, repeat steps
2 through 6.

7. Click on the Save button and return to Default
session main screen.

Figure 38 Trigger Arm/Disarm Button

8. To arm trigger, click on the Trigger Arm/Disarm
button.

NOTE: Triggered recording begins automatically
when the value and pre-trigger are met.

NOTE: To disable triggered recording, click on the
Trigger Arm/Disarm button.
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5.8. Viewing ServiceMaxx™ SnapShots

Figure 39 SnapShots Desktop Folder

A snapshot is engine data that is recorded at a preset
interval, during a session, and saved.

NOTE: ServiceMaxx™ snapshots can be viewed at
any time by selecting Open Recorded Signal File
from the File drop-down menu or through the desktop
SnapShots folder.

Figure 40 File Menu

1. From the File drop-down menu, select Open
Recorded Signal File.

Figure 41 Opening Snapshot File

2. Select a previously recorded file from the Open
window.

Figure 42 Recorded Signal Playback

3. Select which signal(s) to view by clicking on the
Show in Chart boxes.
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6. Viewing Diagnostic Trouble Codes
6.1. DTC Window

DTCs can be viewed and cleared from any session
menu using the DTC window.

Figure 43 DTC Window

1. Diagnostic Trouble Code (DTC)
Column (pre-2010)

2. Suspect Parameter Number
(SPN) Column

3. Failure Mode Indicator (FMI)
Column

4. Fault Code Active Column
5. Clear DTCs Button

6.2. DTC Identification

DTC identification is accomplished using two fault
code identifiers. These two identifiers, known as the
SPN and the FMI, are displayed in the DTC Window.

1. Suspect Parameter Number (SPN)

The SPN identifies the individual component causing
the DTC.

2. Failure Mode Indicator (FMI)

The FMI identifies the fault or condition effecting the
individual component.

3. Diagnostic Trouble Code (DTC)

The DTC is a 3-digit or 4-digit number used to identify
DTCs. This 3-digit or 4-digit number is only used on
pre-2010 engines.

NOTE: 2010 model year vehicles no longer utilize
DTC identification by number. DTCs are now
identified using the SPN and FMI only.
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6.3. Active and Previously Active DTCs

• Active DTCs are faults that are currently present.

• Previously active DTCs are historical faults that
may be set by intermittent conditions, or by an
operating condition which is not currently present.

• All active DTCs will be indicated by a check mark
in the Active column. Previously active DTCs are
also displayed, but without a check mark.

6.4. Clearing DTCs

All active and previously active DTCs can be cleared
from the ECM using the following procedure.

1. Click on the Clear DTCs button.

2. Cycle the ignition switch.
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7. Parameters
NOTE: This section describes how to export and
view all parameters, search parameters by group,
search parameters by name, and change dealer
programmable parameters.

NOTE: It is recommended to export parameters prior
to programming any Navistar electronically controlled
engine.

7.1. Export Parameters

Figure 44 Export Parameters

1. Select Export Parameters from the File drop-down
menu.

Figure 45 Saving Exported Parameters

2. When prompted, save engine parameters on
desktop.

NOTE: The engine parameter data file can be viewed
using Microsoft Excel®.

7.2. View All Parameters

Figure 46 Parameters Button

From the Default Session main screen, click on the
Parameters button.

7.3. Search Parameters by Group

Figure 47 Parameters Button

1. From the Default Session main screen, click on
the Parameters button.

Figure 48 Parameter Filter

2. Click on the filter icon next to the ID column.

3. Highlight the group and press OK.
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Figure 49 Parameter Group

4. The parameters in that group will be brought to
the top of the list.

Figure 50 Clear Button

5. Clear the search by clicking the filter icon and
pressing the Clear button.

7.4. Search Parameters by Keyword(s)

Figure 51 Parameters Button

1. From the Default Session main screen, click on
the Parameters button.

Figure 52 Parameter Filter

2. Click on the filter icon next to the ID column.

Figure 53 Keyword(s) Box

3. Type the keyword(s) in the box labeled “Enter
search words” and press OK.

Figure 54 Parameters Grouped by Keyword(s)

4. The parameters with the keyword(s) will be
brought to the top of the list.

Figure 55 Clear Button

5. Clear the search by clicking the filter icon and
pressing the Clear button.

7.5. Change One Dealer or Customer Programmable
Parameter

To prevent making unwanted changes to parameters,
(Export Parameters, page 27) prior to making any
changes.

NOTE: Non‐Dealer or Customer Programmable
Parameters cannot be changed. In future versions
of ServiceMaxx™ software they will be grayed out to
make it easier to distinguish.
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Figure 56 Parameters Button

1. From the Default Session main screen, click on
the Parameters button.

2. Search for the parameter by group, keyword, or
scroll through the list.

3. Change the parameter.

NOTE: There are two ways to change
programmable parameters: Drop-down
(Drop-Down, page 29) and Numerical Value
(Numerical Value, page 30).

Figure 57 Program Engine Button

4. Click the Program Engine button.

Figure 58 Changed Parameters Prompt

5. Click on Yes.

• ServiceMaxx™ software will attempt to use
the default password. If the default password
doesn’t work, the software will ask for the
customer password.

• Type the customer password in the field
provided and press OK.

Figure 59 Engine Parameters Programmed
Successfully

6. Click on OK.

7.6. Drop-Down

Figure 60 Parameter Value

1. Click in the value field of the parameter that is
being changed.

Figure 61 Changing Parameter Value

2. Select the desired value for the parameter by
placing the pointer over the icon and left-clicking
the mouse.

Figure 62 Changed Parameter Value

3. Press the Enter key on the keyboard or click
elsewhere on the screen.
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7.7. Numerical Value

Figure 63 Changing Parameter Value

1. Click in the value field for the parameter.

2. Type the desired value for that parameter in the
box including any decimal points.

Figure 64 Changed Parameter Value

3. Press the Enter key on the keyboard or click
elsewhere on the screen.

7.8. Change Multiple Dealer or Customer
Programmable Parameters

NOTE: If changing multiple parameters on multiple
vehicles create a parameter template (Parameter
Templates, page 32).

1. Follow all steps from Change One Dealer or
Customer Programmable Parameter.

2. Repeat procedure for additional parameters that
need to be changed.

7.9. Undo Parameter Changes Before They Are
Programmed

1. Undo All Changes…

a. Press the Undo All Changes button to undo
all changes made to the programmable
parameters.

Figure 65 Undo All Changes Button

2. Undo

a. Press the Undo button to undo the change for
one parameter.

Figure 66 Undo Button

7.10. How to Change the Customer Password

NOTE: Not available on MWM engines.

Figure 67 Parameters Button

1. From the Default Session main screen, click on
the Parameters button.

Figure 68 Customer Password

2. Search for the parameter 87002 “Customer
Password”.

Figure 69 Changing Customer Password

3. Change the value of the parameter.

Figure 70 Changed Customer Password

a. Left-click in the Value field.

b. Type the new password.

c. Press the Enter key or click elsewhere on the
screen.

Figure 71 Program Engine Button
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4. Click the Program Engine button.

Figure 72 Changed Parameters Prompt

5. Click Yes.

6. Enter the current customer password and click OK
(if prompted).

Figure 73 Engine Parameters Programmed
Successfully

7. Click OK.

EGES-550
Read all safety instructions in the "Safety Information" section of this Manual before doing any procedures.

Follow all warnings, cautions, and notes.
©September 2011 Navistar, Inc. All rights reserved.



32 1 SERVICEMAXX™ USER’S GUIDE

8. Parameter Templates
A parameter template is used to easily program a
group of chosen parameters and values into multiple
vehicles within a short period of time.

A parameter template can also be used to copy a
current list of configured parameter values or features
from one vehicle to another.

Suggested uses of parameter templates:

• PTO/remote throttle settings

• Driver reward settings

• Road and cruise speed settings

• Progressive shift

• Service interval settings

There are two ways to create a parameter template,
connected to the engine and not connected to the
engine.

Connected to Engine

To build a parameter template or a copy of a vehicle’s
parameter template, establish a connection with the
vehicle before creating the template.

When connected to the engine, the current vehicle’s
engine parameters and values are available and can
be modified as needed.

Not Connected to Engine

When not connected to an engine, the default
template parameters and values are used. Default
template parameters can be modified see (Changing
Parameter Template Values, page 35).

When building a parameter template while not
connected to engine, be sure to choose the
appropriate engine family from the drop-down list.

NOTE: Save template before beginning programming.
Templates can only be programmed in the same
engine family, model, and year. Always check for the
latest calibration using the calibration scorecard.

8.1. Creating Parameter Template

Figure 74 Create Template

1. Click on Create Template from the File drop-down
menu.

8.2. Opening Existing Parameter Template

Figure 75 Open Template

1. Click on Open Template from the File drop-down
menu.

2. Browse for the template file on your computer.

NOTE: All parameter templates created with
ServiceMaxx™ have the filename extension
.template.
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8.3. Parameter Template Features

Figure 76 Template Editor

1. Create Template
2. Open Template
3. Save Template
4. Lock Template
5. Template Notes
6. Engine Family Selection

7. Available Parameters
8. Template Parameter List
9. Program Engine Button
10. Parameter Search
11. Parameter Field Search
12. Parameter Category

13. Parameter Name
14. Move Selected Parameter
15. Move All Parameters
16. Parameter Details Box
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1. Create Template Button

Starts a new blank template.

2. Open Template Button

Opens an existing template file.

3. Save Template Button

Saves the current template.

4. Lock Template Button

Password-protects the current template. A locked
template cannot be edited without first unlocking with
the password.

5. Template Notes Box

Enter customer and/or vehicle information into this box
to make the template easily identifiable.

6. Engine Family Selection Drop-Down Menu

Select desired engine family. Only available when not
connected to the vehicle. When connected to vehicle,
engine family automatically displays.

7. Available Parameters List

Lists available parameters.

8. Template Parameter List

Lists parameters that are selected from the Available
Parameters list. These are the parameters that will be
programmed to the vehicle after the Program Engine
button is selected.

9. Program Engine Button

Programs the template’s parameters to the vehicle.
This button is only active when connected to the
vehicle.

10. Parameter Search Box

This search field is used to search for a parameter by
name. Type in the name or partial name and press
enter. The Clear button clears the search results and
search field.

11. Parameter Field Search

This button allows the display of other parameter
fields, such as name, block, ID, abbreviation, and
units.

12. Parameter Category

Parameters are grouped in folders by category. Click
on the plus (+) sign next to category folder to expand
it. Complete categories can be selected and moved
to the template parameter list.

13. Parameter Name

Lists the name of the parameter and appears below
the parameter category. Individual parameters can be
selected and moved to the template parameters list.

14. Move Selected Parameter Button

Moves selected parameters to and from the template
parameter list.

15. Move All Parameters Button

Moves all parameters to or from template parameter
list.

16. Parameter Details Box

This box will display information about the selected
parameter.
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8.4. Changing Parameter Template Values

Figure 77 Template Editor

There are two ways to change a parameter value.
Either click on the arrow at right edge of the parameter
field and select desired specification or enter an exact
value (including any decimal points) into the Value
field.

NOTE: For additional information about changing
parameters, see (Change One Dealer or Customer
Programmable Parameter, page 28).
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9. Vehicle Trip Report
Vehicle Trip Report is used to view vehicle data during
a trip.

NOTE: Vehicle Trip Report and Vehicle Events are
intended for use with MaxxForce® 11, 13, and 15 liter
engines only.

9.1. View Vehicle Trip Report

Figure 78 Vehicle Trip Report

From the Sessions drop-down menu, select Vehicle
Trip Report.
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9.2. View Activity Report

Activity Report shows a table of trip information
for a single trip or for the life of the vehicle in an
easy-to-print format.

Figure 79 Activity Report

1. Activity Report Tab
2. Current Trip Information

3. Total Trip Information
4. Reset Trip Report

• Left-click on the Activity Report tab.

• The column on the left displays current trip
information.

• The column on the right displays total trip
information.

• Left-click on Reset Trip Report to reset vehicle trip
report.
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9.3. View Vehicle Events

Vehicle Events shows a chart of high values and
recent values of vehicle events and how for long the
event occurred.

Figure 80 Vehicle Events

1. Vehicle Events Tab 2. Reset VETS Button

• Left-click on the Vehicle Events tab to view vehicle
events.

• The Vehicle Events tab shows recent and highest
values of various parameters.

• To reset vehicle events, click on the Reset VETS
button.
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9.4. View Trip Data

Trip Data shows a list of vehicle trip data since the trip
was last reset.

Figure 81 Trip Data

1. Trip Data Tab 2. Save Button

• Left-click on the Trip Data tab.

• The Trip Data tab shows all current vehicle trip
information.

• Click on he Save button to save current vehicle
trip information.
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9.5. View Total Data

Total Data shows a list of vehicle data over the lifetime
of the vehicle.

Figure 82 Total Data

1. Total Data Tab 2. Save Button

• Left-click on the Total Data tab.

• The Total Data tab shows trip information for the
life of the vehicle.

• Click on he Save button to save trip information
for the life of the vehicle.
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9.6. Search Trip Data by Keyword(s)

Figure 83 Sessions Drop Down Menu

From the Sessions drop-down menu, select Vehicle
Trip Report.
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Figure 84 Trip Data

1. Trip Data Tab
2. Total Data Tab

3. Find Icon
4. Find Box

5. OK Button

• Left-click on either the Trip Data tab or Total Data
tab.

• Left-click on Find icon.

• Enter an ID number or name into the Find box.

• Left-click on OK button.

• The searched item(s) appears as the first column
on the screen.
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9.7. Printing Vehicle Trip Reports

Figure 85 File Menu

• Click on Print from File drop-down menu.

• Click on Trip Report.

Figure 86 Print Options

• Select desired printer and click on OK.

9.8. Resetting Vehicle Trip Report

Figure 87 Tools Menu

• A Trip Report is the time between vehicle trip
resets.

• To start a new Trip Report either:

— Select Reset Trip Report from the Tools
drop-down menu.

— Select Reset Trip Report from the Activity
Report in Vehicle Trip Report Session.
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10. MWM Session
MWM Session displays vehicle signals in a chart but
can be converted to show digital readouts or graphs
of the vehicle signals.

NOTE: MWM Sessions is only available for vehicles
equipped with MWM engines.

10.1. MWM Session

Figure 88 Sessions Menu

1. From the Sessions drop-downmenu, select MWM
Session.
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Figure 89 MWM Session

• A new screen appears showing minimum (MIN)
and maximum (MAX) values for several vehicle
signals.

• Right-click in each box to open a drop-down menu
displaying the following options of Signal Chart,
Rolling Graph, Bar Graph, and Choose Signal.

• Select Choose Signal to change or add a vehicle
signal to the box.

• Select Bar Graph, Rolling Graph, or Signal Chart
to graph the vehicle signal.

• There are three pages to select from at the top of
the screen. Each page can be programmed with
different vehicle signals.
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11. Print
Vehicle information can be printed and exported by
selecting Print from the File drop-down menu.

Figure 90 Print Options

11.1. Vehicle Information

Use this procedure to print vehicle information.

1. From the File drop-down menu, select Print.

2. Click on Vehicle.

3. Select printer.

11.2. Export Vehicle Data

Use this procedure to export vehicle information into
a .txt file.

1. From the File drop-down menu, select Print.

2. Click on Export Vehicle Data.

3. Select a location to save data.

11.3. Trip Report

Use this procedure to print vehicle activity report.

1. From the File drop-down menu, select Print.

2. Click on Trip Report.

3. Select printer.
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