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WHAT IS WEBWHACKER? 

WebWhacker 5.0 is an offline browsing and searching tool that enables you to save your favorite Web sites into 
easily transferable storage media, and organize them into categories. You can search downloaded Web sites for 
key-words using WebWhacker’s built- in, full-text indexing technology, as well as surf the Internet offline–with 
faster loading and no additional on-line charges. Developed by Blue Squirrel Software, WebWhacker 5.0 
downloads entire Web pages or sites–including text (HTML), images, and other objects–and stores them on 
your local desktop machine, company’s server, or removable media such as CDs, ZIP disks, etc. Whacked sites 
provide a locally stored mirror image of the original Web site, which can be navigated, viewed, annotated, and 
searched locally with a standard Web browser. By reducing your dependency on an Internet connection, 
WebWhacker 5.0 saves you time and money. 

How It Works 

For each of your favorite Web sites, you subscribe to its URL, assign it to a storage and/or category, specify 
how many levels of links to capture, and specify how often you want your subscription to be renewed. Then you 
whack, or download, the site to your local machine. Besides being economical, this approach gives you more 
control—you can even filter out content by size, type, location, etc. 

WebWhacker Storage 

The WebWhacker storage contains copies of all the URLs, images, and files you’ve selected and whacked. You 
can create as many WebWhacker storages as you need. Each Storage can have as many folders as you need. 
Instead of having information on a particular topic spread all over the Web, your WebWhacker storage lets you 
organize the sites into your own custom categories. The whacked pages are the same as the original pages, 
except that they are linked together. By setting whack level properties and content filters for a page, you control 
the amount and kind of information that is stored in your database. 

WebWhacker – File or Proxy 

WebWhacker has some very unique features that are unmatched by any offline browser.  WebWhacker can be a 
file-based offline browser or a proxy based offline browser.  Here is the difference: 
 
File Based – The HTML and graphic files are all placed in files and the HTML is modified so that they all link 
together.  You can copy the files to a CD, a network drive, or Zip™ Drive and use them by directing your 
browser to load the file(s). 
 
Proxy Based – This unique feature of WebWhacker lets you use your downloaded offline files as if they were 
still on the web.  By turning on the Local Proxy Cache, WebWhacker sets up a small web server on your 
computer, and reconfigures your browser to go only to your own tiny web server.  This web server will serve up 
the files that have been whacked, when you request them with their original URLs.  This feature is fantastic for 
presentations where it appears as though you are online, but with the safety, security and assurance that comes 
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with not depending on an online connection.  In this mode you would type in URLs like 
http://www.bluesquirrel.com/index.html to access a page. 
 
The proxy browser can also be used when you are online to protect against browsing sites that are not already 

pre-whacked. To activate this feature click on the Start Proxy button on the Tool bar . WebWhacker will 
take a moment to configure your Web browser. Then right-click on the proxy server icon  in your Windows 
System Tray, choose settings and mark the check box for Offline Mode. 
 

 
 
If the page isn’t already on the computer, you will get a page that lets you know you are in offline mode and the 
page isn’t available. This WebWhacker capability is great for protecting employees, or young students from 
browsing inappropriate Web pages. 

Offline Browsing 

If you’re not connected, you can look at all the sites in your storage.  Just double-click on any page to begin 
browsing. 

Scheduling WebWhacker to Whack a Web Site 

By using the scheduling function, you can be assured that the sites are kept up-to-date on a daily, weekly, or 
monthly basis. Of course, you can also re-whack individual sites or refresh your entire database at any time. 

INSTALLING WEBWHACKER 

This section will help you install and configure WebWhacker on your computer. The installation setup program 
is called WebWhacker5Setup.exe.  You must run the setup program to install WebWhacker to your hard disk 
(Product installation is found in section “Loading the CD”).  Here’s a summary of what the setup program does: 
 

• Copies the WebWhacker files to your hard disk. 
• Creates a WebWhacker program group and icons. 
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• At the end of the installation process WebWhacker presents you with the option to view the 
README.TXT.  We recommend looking this document over because it contains more information 
about WebWhacker. 

• When you first start the WebWhacker program the InstantX registration dialog box will appear.  To 
fully register your copy of WebWhacker please fill out the form, and send it electronically, or print the 
form and mail it back to Blue Squirrel.  If you don’t register WebWhacker the InstantX dialog box will 
pop up every time you run the program.  Once you have registered, you’ll see your License Key code in 
the About WebWhacker box. 

• You also have the option to purchase the program from the InstantX dialog box. 

System Requirements 

In order for WebWhacker to install and run properly, the following is required: 
• 486 or faster machine 
• Windows 95/98/Me/NT 3.5 or higher/2000/XP 
• 8 Megabytes of RAM 
• 10 Megabytes of free disk space on your hard drive 
• A Web Browser including: 

o Internet Explorerª version 2.0 or higher 
o Netscape Navigatorª version 2.0 or higher 
o Enhanced Mosaicª version 2.0 or higher, or any other Spy-Glass SDI standard-compliant browser 

How to Use the Blue Squirrel Catalog CD 

1. Insert the CD into the appropriate disk drive. 
2. The CD should automatically load.  If the CD does not load automatically, double click on the “My 

Computer” icon on your desktop.  Select your CD drive, go to File on the menu bar and click Open. 
Find the file named Index.html and double click.  The Blue Squirrel Products Index screen will pop up 
either in Netscape Navigator or Microsoft Internet Explorer. 

• As the mouse is placed over a title the product information will appear. 
• If you wish to purchase the product click on the Buy Now button.   
• For Blue Squirrel’s company information click the question mark (?). 
• To demo the product click on the title or on the demo install link.  

Product Installation for Microsoft Internet Explorer Users 

1. Once WebWhacker is found, click on the title.  Or click the Install Demo area.   
2. The File Download window will appear.  Change the settings from "Save this program to disk" to "Run 

this program from its current location" and click OK. 
Note: The default is “Save this program to disk”. 

3. In the Security Warning window that states "Do you want to install and run ... The publisher cannot be 
determined due to the problems below:  Authenticode signature not found." Select Yes. 

Note: The default is No. 
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4. Follow the steps of the Install wizard for WebWhacker to complete the installation. 

Product Installation for Netscape Navigator Users 

1. Once WebWhacker is found, click on the title.  Or click the Install Demo area.   
2. The Save as... window will appear.  Be sure to save this file in a memorable place. 
3. Click the Start button, which is found on the task bar and select programs.  Open Windows Explorer and 

browse to the location where the program was saved.  Once you have found the program 
(WebWhacker5setup.exe file) double click it, and the installation process will begin. 

4. Follow the steps of the Install Wizard for WebWhacker to complete the installation.  

Installation Troubleshooting 

If you have problems installing WebWhacker using any of the aforementioned methods, then here is an 
alternative to try: 

1. Insert CD, and go to your Windows Start Menu, click on Search or Find, and select For files or 
folders . The Search Results dialog box will appear. 

2. Set “Look in:” to your CD Rom drive. 
3. Type “WebWhacker5Setup.exe” in for the files or folder to search 
4. Hit “Search Now”. 
5. Double-click on WebWhacker5setup.exe once it is found and follow the steps of the Install Wizard. 

REGISTRATION 

Once you have installed WebWhacker you will want to register your copy. You must insert your VIP key in the 
appropriate field of the Registration Information Screen to fully enable WebWhacker 5.0. If you do not enter 
your VIP key, your program runs as an evaluation copy that will eventually expire. 

Registering Electronically 

Make sure you have an active connection to the Internet so you can submit your registration on- line. 
1. The first time you run WebWhacker 5.0, the InstantX Registration Dialog box appears. If the InstantX 

Registration dialog box does not appear you can access it by selecting Tools, Update, Settings, from the 
Menu Bar. 

2. Select the Purchase/VIP tab and enter in your customer information and your VIP key on the InstantX 
Registration dialog box and press the OK button to submit your information over the Internet. We 
recommend that you copy and paste your VIP key to avoid typographical errors. 

Registering Manually 

Access the InstantX Registration Screen by selecting Tools, Update, and Settings from the Menu Bar.  Enter in 
your customer information, and your VIP key and then select the Print button to print the form instead of 
sending it over the Internet. 
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Either fax the printout to us at 801-912-6032, or send it via post mail to Blue Squirrel, Attn: Customer Service, 
686 E. 8400 South, Sandy, UT 84070. 

SETTING PROGRAM OPTIONS 

Once you have installed WebWhacker, check your program Options to make sure they are set optimally. 
1. Start WebWhacker by choosing it from your Windows Start menu. The default location is Start > 

Programs  > Blue Squirrel > WebWhacker.  
2. Go to the Tools menu and choose Options . 
3. Select the Internet tab to ensure the Web Browser preference is set for the browser you want to use. If 

necessary, correct the settings. 
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INTERFACE 

UNDERSTANDING THE WEBWHACKER WINDOW 

The main program window presents the WebWhacker database and tools in an easy-to-use graphical format. 
 

 

Menu Bar 

Use the Menu Bar to access WebWhacker’s commands. 

Toolbar 

Use the Toolbar for one-click access to the most commonly used functions. The availability of the Toolbar 
buttons is context-sensitive, changing as you click to select various items on the WebWhacker Desktop. 
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WebWhacker Desktop 

The Desktop Working Area is the heart of the WebWhacker database. It uses a standard Windows Explorer-
style file system display to show which WebWhacker Storage is currently opened with its category folders, and 
individual URLs. Use this area to work with URLs, just as you work with files in the Windows Explorer. For 
example, you can: 
 

• Drag URLs to move them to new categories; 
• Right-click for a shortcut menu and context-sensitive properties 
• Double-click to open (view) a URL. 

 
Plus or minus signs indicate whether additional items are collapsed under that category. Icons next to the URLs 
and folders indicate their status as detailed in the table below. 
 

ICON TYPE 
 

STATUS 
 

 
Added URL When you Add a URL to WebWhacker it is a Remote link that has not been 

whacked.  

 
Whacked URL This icon appears next to URLS indicating that you have downloaded that 

particular Web site’s content to your hard drive.  

 
Link Checking When you perform a Link Check on a Web site this icon will appear next to 

URLs that receive a 404 error indicating that a Web page no longer exists. 

 
Image When you download a Web site to your hard drive it grabs all of the HTML and 

the images. This icon appears next to graphics including .gif, .jpg, and others.  

 
Search When you perform a search on a folder this icon will appear next to the search 

results page in the corresponding folder. 

 
Scheduled URL This URL has been Added to your WebWhacker database. And it is scheduled to 

perform the desired task including, Whack, Renew, Preview, & Link Check. 

 
Scheduled 
Whacked URL 

The Web site has already been downloaded to your computer. The clock over the 
top of the Web page indicates that it is scheduled to monitor the Web for changes. 

 
Scheduled Folder The clock over the top of a Folder indicates that it is scheduled to perform tasks 

on scheduled URLs. 

Whack Status Bar 

The Whack Status Bar contains information about the 
progress of a whack. Choose the appropriate tab to 
view status information about the Current Whack (in 
progress) or about Completed URLs. 



Interface    

 
 
WebWhacker  Page 11 

11 BLUE SQUIRREL SOFTWARE – www.bluesquirrel.com - 686 E. 8400 South, Sandy, UT  84070 

AppBar 

The WebWhacker AppBar gives you quick access to some of WebWhacker’s commands 
outside the WebWhacker window—for example, functions that work from within your 
Web browsers. The AppBar appears on your Windows desktop as a toolbar–similar to the 
Windows 95 Taskbar or the taskbars for the major office suites–and can be docked along 
any edge of your screen. To adjust the settings of the AppBar go to Tools, and select 

Options on the Menu bar. In the Options Dialog select the General Tab and check or uncheck the “Start AppBar 
automatically” check box. 

Properties Dialog 

There are two properties dialog boxes in WebWhacker, one for each folder, and one for each URL. To access 
the Properties dialog select a folder, or a URL, right click, and select Properties. 

Folder Properties 

The Folder Properties dialog lists current tasks scheduled for that folder. For more information about scheduling 
a task refer to the section in the advanced section of this manual titled ”Schedule WebWhacker to Perform 
Tasks”.  
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URL Properties 

The URL Properties dialog presents you with several tabs that allow you to configure the settings for a 
particular URL. 
  

 
 

On the Properties Tab you can change the following: 
• See the Title of the page (if the page has been downloaded). 
• Type in a different URL. 
• See the Folder that the local page is stored (if the page has been downloaded). You can also browse to that 

folder. 
• Set the File for the locally stored page. Press Launch to launch the page in a browser, or in your default 

graphic viewer. 
• Select the number of levels of the site you wish to download. One level will only download the current 

page; two levels will download the current page and it’s immediate links, and so forth.   
• Enter any Notes for that URL. 
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• Enter the User Name and Password needed to access the Web site. This only works for server authenticated 
sites. If the page has a name and password field on the page itself, then this name and password will not 
work with the site. 

 
 

 
 

On the Filters Tab you can select the check boxes to Remain in Site, and/or the Directory for that particular 
URL. Remain In Site will look at the original URL and if it begins with “www.”, then it will match any URL 
that has the www, or not, provided the rest of it is the same.  Example:  If you said to Remain In Site for 
http://www.bluesquirrel.com/index.html, then it would match URLs with 
http://www.bluesquirrel.com/graphics/somepic.jpg, and http://bluesquirrel.com/somepage.html, but not 
http://www.redfox.com/somepage.html. 
 
If the original URL does not begin with “www.”, then the entire domain must match (case insensitive).  
Example:  If you said to Remain In Site for http://hotdogs.someisp.au, then an image that was 
http://freeimages.someisp.au/dot.gif would not be whacked. 
 
Sometimes Web sites will link to images that are not on their site.  The filter (if too specific) may keep those 
images from being whacked. 
 
If you want more specific control, you can leave Remain in Site unchecked, and add your own filter to the 
advanced section that looks at more or less of the domain.  Make sure that you set it to “URL Filter, “Case 
insensitive”, “Contain the above text.” 
 
If you choose Remain in Directory, then WebWhacker will look at the original URL that you started with and 
make sure that the directory name appears in every URL. 
 
You can also choose which File types you do not want WebWhacker to download when you whack a site. To 
save memory you can filter files such as videos, audios, and images. 
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The Statistics Tab offers non-editable information that tells you the day, date, and time the URL was Created, 
Added, and Modified in WebWhacker. 
 
 
 

 
 
The Links Tab displays The Title and URL of Web pages that link back to the selected URL. This item will 
only display links if you have whacked more than 1 level of a Web site.   
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The Schedule Tab allows you to Schedule WebWhacker to download changes at a later time. To turn on 
Scheduling mark the check box for “Scheduling Enabled”, and then select the radio button for the type of action 
you want to perform. For detailed instructions on scheduling a URL refer to the section labeled “Schedule 
WebWhacker to Perform Tasks” in the Advanced section of this manual. Note: Link Check will be grayed out 
unless you specifically chose this task when you Added the URL to WebWhacker. 

CONFIGURING WEBWHACKER 

The WebWhacker Options tabs allow you to configure many different aspects of the program to suit your 
personal preferences. You can set options defining your default storage directory, whack performance levels, 
what information displays during a whack, renewal standards, update options, proxy settings, network 
information, Web browser settings, dial up networking, and more! To access the options tabs open 
WebWhacker, click Tools on the Menu bar, and select Options. The Options Dialog box will appear. 
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General Tab 

The General Options  tab determines whether or not the WebWhacker App Bar starts automatically, where 
your default storage directory is located, whack performance levels, and the HTML editor you want to use to 
edit the downloaded Web pages. 
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View Tab 

On the View Tab you can set preferences for “Options”, and “If Modified” to meet your desired needs. 
 
In the Options  section mark or unmark the check boxes to determine: 
 

• Always browse remote links – If you want to browse remote links when viewing a whacked site, rather 
than the downloaded site, select the Always browse remote links check box. 

• Automatically write headlines after each whack – Select this check box to have WebWhacker write 
out a Headlines page (wwhlines.htm page) with links to all of the sites for a category. 

• Update views in realtime during the Whack – Select this check box to have WebWhacker update the 
folder view and the title view during a whack.. 

• Double clicking browses rather than moving down a level – Select this check box if you prefer to 
have WebWhacker browse a Web page, rather than moving down from a folder to a subfolder by 
double-clicking. 

 
In the If Modified section you can control whether WebWhacker shows the whacked pages with a Modified 
icon.  If the whacked page has changed since the specified time, WebWhacker will put a yellow start on the 
icon next to the page. 
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When the View Options are configured to your satisfaction click OK to close the Options dialog box, or click 
Apply to apply the changes and leave the Options dialog box open. 
 

 
 

Proxy Tab 

The Proxy Tab allows you to set up your Proxy server. There are two proxy settings in WebWhacker.  The 
reason is that each of them does something different.  There is the Remote Proxy and the Local Proxy Cache .  
We describe each of them below. 

Enable Remote Proxy 

For most home users the Remote Proxy is not necessary.  The Remote Proxy only needs to be configured if the 
Internet connection you use is proxy-based.  This is common in large companies, schools and government.  You 
can tell if your Internet connection is proxy-based, by going to your Internet Explorer and choosing Tools-
>Internet Options…->Connections tab, and then hitting the LAN Settings… button.  If the Proxy server section 
is checked AND it is not set to 127.0.0.1 in the Advanced area, then you will need to set the Remote Proxy in 
WebWhacker to the same settings. 



Interface    

 
 
WebWhacker  Page 19 

19 BLUE SQUIRREL SOFTWARE – www.bluesquirrel.com - 686 E. 8400 South, Sandy, UT  84070 

Local Proxy Cache 

Local Proxy Cache is a just a horrible technical name for a baby web server tha t WebWhacker can run on your 
computer.  This baby web server can be started by hitting the P icon on the toolbar of WebWhacker, or by 
going to Tools->Options… and choosing the Proxy tab and putting a check mark by Enable Local Proxy Cache. 
 
When you do this, a baby web server is started on your computer.  WebWhacker also reconfigures your web 
browser to redirect all web requests through this web server.  It reconfigures your browser by setting the 
browser proxy setting to 127.0.0.1 which is your own IP address.  All web requests will then be sent first to the 
baby web server on your machine.  When you close WebWhacker or turn off the Local Proxy Cache, then 
WebWhacker will attempt to reconfigure your browser back to its previous settings.  If the reconfiguration fails, 
your browser will be rendered unusable until you manually set these back to the original settings (usually just 
setting them to blank values and unmarking the “Use proxy setting” in your browser. 
 
The Local Proxy Cache (aka baby web server) will first look in the WebWhacker storage for any URL, if it 
finds the URL, it will feed it to the browser.  If it doesn’t find it, it will either generate an offline-page, or it will 
go get it and feed it to the web browser.  This decision is determined by the Offline Mode setting.  To set the 
Offline Mode, just right-click on the P icon in your tray and choose Settings….  Put a check mark next to Offline 
Mode.  Offline Mode is used in cases where you are not connected to the Internet and you only want to browse 
information that was collected and stored by WebWhacker.  When in Offline Mode, you may get a page that 
says OFFLINE.  This indicates that the page you requested has not been stored by WebWhacker.  This is very 
useful for student browsing where you would prefer that the students remain limited to the information in the 
WebWhacker storage. 
 
Using the Local Proxy Cache (aka baby web server) is very useful for boardroom presentations, Internet 
training sessions and other instances where you would like the browser to show http URLs like 
http://www.bluesquirrel.com instead of file references like 
file:///C:/MyDocuments/WebWhacker/bluesquir rel.com/index.htm 
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Grabbing Tab 

In the Network Limits section enter the following criteria: 
 

• Enter the maximum number of times you want WebWhacker to attempt to download a site if a whack is 
unsuccessful. 

• Enter the maximum number of simultaneous pages per server you want WebWhacker to download in 
the Maximum Threads Per Server box. This keeps WebWhacker from overwhelming Web servers with 
too many requests. 

• If you want to limit the time spent whacking a site, select the Limit time spent whacking to ___ hours 
check box and enter the maximum number of hours you want spent in the text box. 

• If you want to limit the total size of a whacked site, select the Limit total whack size to ___ Kbytes 
check box and enter the maximum Kbytes you want in the box. 

 
In the File Storage Structure  section select checkboxes to determine: 
 

• If you want to store your whacked sites in a folders named after the original sites domain name, select 
Use Domain in Directory.  
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• If you want to re-create the original site structure in your file storage structure select the Preserve Site 
Structure check box. 

• To have WebWhacker use only MS-DOS 8.3 file names, select Use MS DOS 8.3 Filenames. 
 
In the Unavailable Links section you can select Use the edge page for links to pages that have not been 
Whacked if you want WebWhacker to place an Edge page for all links going off to pages that haven’t been 
downloaded. When WebWhacker finds a link that takes you off of the specified Web site, or when you stop 
WebWhacker before it downloads the entire site, then WebWhacker can convert those links to \edge\edge.htm. 
WebWhacker will copy all of the files in the EDGE directory to the folder you've specified in Default Folder on 
the General tab. You may add additional files to the EDGE directory, and you may edit the edge.htm file to fit 
your needs. 
 

 
 
When you have finished configuring Grabbing Options click OK to accept the current configuration and close 
the Options dialog box, or click Apply to apply the current configuration and leave the Options box open.  
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Internet Tab 

In the Web Browser section you can choose a Web browser to browse Added or Whacked Web pages with.  
 

• Select Default Browser to use your systems default Web browser 
OR 
• Select Specific Browser to use a Web browser you specify. Enter the full path to the browser you want 

to use, or click the browse button  to browse to where your Web browser is stored on your 
computer. 

 
In the Web Browser Emulation section you can set up WebWhacker to emulate a specific Web browser in 
order to gain access to browser specific information from the User Agent drop down menu. This feature is 
recommended for advanced users only. We have included this feature because some web servers supply 
different information depending on the browser you are using. When the Web server identifies WebWhacker as 
your browser it may give you different information than you expected. The Web Browser Emulation option 
enables WebWhacker to masquerade as your preferred browser in order to get the information you want. 
 
 



Interface    

 
 
WebWhacker  Page 23 

23 BLUE SQUIRREL SOFTWARE – www.bluesquirrel.com - 686 E. 8400 South, Sandy, UT  84070 

In the Microsoft Internet Explorer section you can choose the checkbox to Enable WebWhacker button in 
Internet Explorer to quickly Add or download pages to WebWhacker. By default this is turned on, and the 
WebWhacker icon  is displayed on the Internet Explorer’s Formatting toolbar. Any time you’re at a page you 
want to Add or Download to WebWhacker simply click on the WebWhacker icon, and it will start the URL 
Subscription Wizard. 
 
When you have finished configuring your Internet Options click the OK button to close the Options dialog box, 
or click the Accept button to accept the current settings and leave the Options dialog box open. 
 

 
 

Dial-Up Tab 

Click the Enable Dial-Up Networking check box to have WebWhacker use your systems Dial-up networking 
to access the Internet. If this option is not selected you will need to manually open a connection to the Internet 
before WebWhacker can perform any remote functions. 
 

1. From the Entry drop down menu, select the dial-up networking entry you want to use from the available 
entries. 
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2. Select the Authenticate using Information from entry above option to use the information from your 
selected dial-up networking entry for authentication. 

  OR 
 Select the Authenticate using information below option to enter authentication information in the 

following text fields. Authentication text fields are enabled. Enter all necessary information in the 
following fields: 

 
• Username 
• Password 
• Domain*IDH_Domain 

 
When you have finished configuring your Dial-Up Options click the OK button to close the Options dialog box, 
or click the Accept button to accept the current settings and leave the Options dialog box open. 
 

 
 

Searching Tab 

When you perform a search for key-words on downloaded Web sites WebWhacker, by default, is setup to 
highlight your search terms so that you can easily locate where they are found on a Web page. You can click on 
the color pallets to change the color of the text, and the background to meet your preferences. You can uncheck 
the Enable Search Word Highlighting in Browser View check box to turn this feature off. 
 
When you have finished configuring your Searching Options click the OK button to close the Options dialog 
box, or click the Accept button to accept the current settings and leave the Options dialog box open. 

MENU BAR OPTIONS 
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File Drop Down Menu 

 
File->New Storage… 

This menu option creates a completely new area for WebWhacker to store Web pages.  Use this if you want a 
completely new project. It creates an empty storage without any folders. You can add as many Folders as you’d 
like. Or, you can add your pages to the root of your new storage. You can type in any location, and 
WebWhacker will create the folders/directories on your computer. 

File->Open Storage… 

This lets you open a previously created storage.  Just enter the directory of the root of the storage. 

File->New Folder 

This creates a new folder in the storage.  The export and headlines pages, work on a folder level.  You should 
keep all related pages together in one folder. 

File->Headlines 

This launches the Headlines pages for a folder.  You must be on a folder for Headlines to be available. 
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File->Import 

This will let you import all of your links stored in your Netscape Navigator Bookmarks.  You can save a page in 
your browser to a temporary location and import all of the links. 

File->Export 

Export copies all of the Web files from a folder to a location that you specify. Export will not be available 
unless you are on a Folder.  It will also copy the edge pages. If you have selected Use the edge pages for links 
to pages that have not been Whacked in the Grabbing tab of the WebWhacker options, then all external links 
will go to the edge pages. Edge pages are pages that you can modify.  They are in the program directory under 
the Edge directory. If you check Autorun.inf, then WebWhacker will add additional files so that if you copy the 
files to a CD, the CD will automatically launch when you put it in the CD drive of a Windows computer. 

File->Export Page  

This will export a page or pages (and their graphics) to a specified location.  Export Page will not be available 
unless you have selected a page or pages in the Folder pane or the file pane. 

File->Schedule 

This lets you set the schedule for Whacking pages. If you are on a URL or page, you must mark it to be 
whacked during the scheduled whack. You must also set the schedule on the Schedule tab. The scheduler used 
the operating system’s scheduler, so you don’t have to leave WebWhacker running to have the scheduled work 
completed at the scheduled time. You do, however, have to mark items to be whacked during the schedule, 
AND schedule a time for the whack to occur. You cannot schedule a Folder to be whacked. 

File->Search 

The search will search the entire storage. The first time you search, WebWhacker will index the storage so that 
it can perform powerful searches. The first search might take some time, but subsequent searches will be fast. If 
you add information to the storage, WebWhacker will need to re- index the storage. Indexing is fast, but if you 
have whacked a lot of information, it could take a significant amount of time to do the indexing. 

File->Print… 

You can print multiple pages by selecting them in the file list pane of WebWhacker. 

File->Make a booklet 

This will let you make convenient books by printing multiple web pages to ClickBook.  You must own 
ClickBook from Blue Squirrel for this option to work. 

File->Turn Proxy On 

This turns on the Proxy server. The Proxy server lets you use your offline pages with real URLs and simulate a 
real live Internet connection. To learn more about the Proxy server, read about it in the Advanced section of this 
manual. 
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File->Turn Proxy Off 

This turns off the Proxy server.  To learn more about the Proxy server, read about it in the Advanced section of 
this manual. 

File->Exit 

This exits the program. 

Edit Drop Down Menu 

 
Edit->Cut 

This removes the selected item and places it on the Windows clipboard. 

Edit->Copy 

This copies the selected item and places it on the Windows clipboard. 

Edit->Paste 

This copies the contents of the Windows clipboard to WebWhacker.  Paste may not always be possible. 

Edit->Delete  

This deletes the selected item(s) from WebWhacker. 

Edit->Rename 

This renames the selected item in WebWhacker. 
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URL Drop Down Menu 

 
URL->Add 

This starts the Add URL wizard. WebWhacker will look for an active browser and attempt to use the URL from 
the active browser. It may not always get the intended URL because you may have more than one active 
browser. If there are no active browsers, you must fill in a URL. 

URL->Page Copy 

This will cause WebWhacker to look for an active browser and attempt to use the URL from the active browser 
and copy the page to the open WebWhacker folder. It will begin the whack immediately for that folder. This 
option is great for capturing pages that may not exist in the future. 

URL->Preview 

This will whack the site, but will not get the graphics, and will construct a tree view of the site. 

 URL->Whack 

This begins a whack.  It starts from the current selection.  You can Whack an entire folder, or start from a URL. 
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URL->Renew 

Renew is similar to Whack, except that it is optimized.  It will request the pages and graphics from the server, 
with a special request that tells the server to send the html or graphics only if they have changed. Dynamic, 
database driven sites will almost always report that they have changed, even if the pages that comes back is the 
same. Graphics rarely change and so this optimization can save a lot of time. 

URL->Resume 

This will continue a whack from where it left off. WebWhacker keeps track of the depth of the whack for each 
URL and will continue until the specified number of levels have been whacked. 

URL->Check Links 

This will run through the site again and check links. The URL must have been added initially with the check-
links option. 

URL->Up a level 

This moves the current selection up a level in the tree view or in the file view. In the file view it moves from the 
URL up to the first page that encountered the link. 

URL->Down a level 

This moves the current selection down a level in the tree view or in the file view. In the file view it moves the 
selection down to the URLs links. 

URL->Browse remote 

This launches the default browser with the real URL of the selected page. 

URL->Browse local 

This launches the default browser with the local file for the page. If the page has not been whacked, this option 
will be unavailable. If you are on a folder, it will launch the headlines page for that folder. 

URL->Stop 

This stops the whack. It may take some time to stop a whack as WebWhacker has to write headlines, and fix-up 
loose references when it stops. 

URL->Subscription Wizard 

This is similar to Add, but works on pages that have already been whacked. Select a page and use the 
Subscription Wizard to set additional levels. You can use this to continue to whack portions of a Web site. 
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URL->Properties 

This displays the properties of the selected page or URL. If you are on a folder, it will show you the schedule (if 
any) for that folder. 

 

View Drop Down Menu 

 
View->Toolbar 

This gives you a dialog box that lets you turn on and off various parts of the toolbar, or change it to smaller 
buttons. You can also customize the toolbar from this dialog. 
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View->Text Labels 

Turns the text labels under the toolbar buttons on and off. 
View->Status Bar 

Turns the status bar at the bottom on and off. 

View->Tree Window 

Turns the Tree Window (left-hand pane) on and off. 

View->Browser Window 

Turns the integrated browser on and off. 

View->Output Window 

Turns the Whack output status window on and off. 

View->Item Types->Pages Only 

Shows only the web pages in the File List View. 

View->Item Types->Images Only 

Shows only the images in the File List View 

View->Item Types->Pages and Images 

Shows both HTML pages and images in the File List View 

View->Item Types->Pages and Images 

Shows all downloaded files and URLs in the File List View including audio files and flash files. 

View->Sort By->Title 

Sorts the pages by their title.  The Whacked pages will be sorted first. 

View->Sort By->URL 

Sorts the pages by their URL. 

View->Sort By->Natural Order 

Does not sort the pages.  Adds them to the list in the fastest way. 

View->Refresh 

This reloads the Tree View and the File List View so that they are synchronized with the database. 
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View->Synchronize  

This closes all of the folders and reloads them.  If the view is not synchronized with the database, you can use 
this menu option to ensure tha t they are the same. 

Tools Drop Down Menu 

 
Tools->Customize Toolbar… 

This allows you to customize the toolbar and add the most commonly used menu option to the toolbar. 

Tools->Options… 

This lets you configure WebWhacker. See the CONFIGURING WEBWHACKER section for more details. 

Tools->Update->Update Now! 

This causes WebWhacker to manually check on the Internet for any new updates to the WebWhacker program. 

Tools->Update->Undo Last Update… 

This will roll back the last update so that if the update has problems or does not work as well, you can go back 
to the previous version. 

Tools->Update->Settings 

Use this to configure how often WebWhacker automatically checks for an update. 

Tools->Pack Database 

When pages have been removed from a folder, WebWhacker marks them for deletion, but does not remove 
them from the database until you choose this option. The selection must be on a Folder for this option to be 
available. There is a database for each folder. If you want to pack all of them, you will need to choose Pack 
Database for each folder. 

Help Drop Down Menu 
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Help->Help Topics 

This launches the WebWhacker help file. The help file contains the same information as the manual. 

Help->Blue Squirrel Homepage 

This takes you to the Blue Squirrel home page in your browser.  Visit Blue Squirrel to learn about new product, 
product enhancement, free online courses, and more. 

Help->License Agreement 

Use this option to view the WebWhacker license agreement. 

Help->Register… 

If you have not registered the software, use this menu option to register WebWhacker.  Registration is free, and 
is not the same as purchasing WebWhacker. 

Help->VIP Key… 

Use this menu option to enter your VIP key.  You can obtain a VIP key by visiting the Blue Squirrel web site 
and purchasing WebWhacker.  Entering your VIP removes all trial version messages and trial restrictions on 
WebWhacker. 

Help->About WebWhacker 

Use this to get the version number for WebWhacker. This information is very useful for our support technicians 
when diagnosing a problem. 
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UP & RUNNING IN 10 MINUTES: 

GETTING PRODUCTIVE WITH WEBWHACKER 

The procedures in this chapter will help you become more productive with the World Wide Web by: 
• Capturing useful information from the Web onto your hard drive. 
• Reducing the time spent waiting to download Web sites. 
• Avoiding the annoyance of “lost” or moved sites. 

Top Uses 

• Marketers can easily track competition, late breaking news, product reviews, etc. 
• Students and teachers can grab sites created by other schools around the world, building a multicultural 

database in the classroom. 
• Cooks can create a personalized online recipe book, drawing on sites from various food manufacturers, 

the government, and other cooking enthusiasts. 
• Investors can use this approach to build storage folders filled with stock prices, press releases, and other 

information relating to their portfolio. 
• Webmasters can duplicate the directory structure of a Web site, and find broken links. 
• Businessmen and businesswomen can surf the Internet without an Internet connection while they’re on 

the plane, in the car, or making a presentation. 

Objectives: 

To capture information from the Internet, you must bring the desired URLs into WebWhacker and organize 
them for easy retrieval. In this section, you will learn the most basic procedures needed, including: 

• Adding a URL while surfing the Internet. 
• Whacking a URL to download it to your hard drive. 
• Reviewing your list of Added and Whacked URLs. 
• Deleting unwanted URLs from WebWhacker 5.0. 

GETTING INFORMATION FROM THE WEB 

The World Wide Web has the potential to be a serious tool for business and personal productivity. No longer 
just an esoteric research medium nor simply an entertaining diversion, the Web offers our information hungry 
society immediate access to a rich variety of data. And the Web will only become more essential and more 
rewarding as it evolves into the next century. 

The Usual Scenario 

However, for all its potential, using the Web can be a frustrating experience. Right now, you probably: 
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• Look for the information you need by fo llowing links or using an Internet search engine—perhaps even 
a meta-searcher like Blue Squirrel’s WebSeeker. 

• Once you find a site, you bookmark it or add it to your favorites. 
• You may even print out information from some sites. 

 
But when you need the information and try to return to the site, you find that: 
The site has moved. 
 

• The Web site has moved or is gone. 
• Its content has changed. 
• The site is so busy you cannot connect to it. 
• Your printout is lost in a sea of filing cabinets and desk drawers. 

The WebWhacker Approach 

The basic WebWhacker techniques you’ll learn in this section let you be more productive with your 
information. Using WebWhacker, you simply: 

• Search for useful sites just once. 
• “Whack” (download) the sites to your hard drive. 
• Refer to the information stored on your computer whenever you want, without long waits or additional 

connection time. 

BUILDING YOUR WEBWHACKER INFOSTRUCTURE 

We’ll walk through the basic WebWhacker techniques for taming the World Wide Web as we build a storage 
full of information for everyone’s favorite semi-annual project: improving your fitness regimen. Even if you’re 
not interested in fitness at the moment, follow along through the steps, substituting sites pertaining to your 
particular interests. 

Creating a Storage Folder 

In the Tree Window of WebWhacker you’ll see a parent folder, and subfolders, 
similar to what you would see in Windows Explorer. The Parent folder at the top by 
default is named WebWhacker, indicating that you are capturing URLs and 
downloading sites to your WebWhacker Storage. You can create various storage 
folders to meet your needs. Once you’ve begun building your WebWhacker storage, 
you can use it to browse through the available sites and quickly display them in your 

integrated Web browser window. When you choose a whacked URL , it is loaded 
directly from WebWhacker and you will browse the site offline. When you choose a 

URL that has been Added  but not yet whacked, WebWhacker will use your Web 
browser to connect to the Internet and access the site on the Web. 
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To create a new storage folder follow these directions: 
1. Open WebWhacker and go to File, and New Storage on the Menu bar.  
2. The Select Directory dialog box will appear.  
3. Browse to the location where you want to save the storage folder, and type in a name for your storage, and 

click OK to finish. For example if you type in: C:\Windows\Math. WebWhacker will create a storage folder 
called Math that will be saved in the Windows directory on your C:\ drive. 

Reviewing a Storage Folder 

On the WebWhacker desktop, check the list of URLs currently in your storage folder. If you cannot see all your 
URLs, you may have collapsed a storage folder (much as you collapse folders or directories in your Windows 
Explorer). Click on the plus sign next to a Storage folder in order to display its contents. 

Identifying Local v. Remote Sites 

 
URLs marked with a globe on a page icon are local; that is, they have been whacked (or downloaded) to 
your hard drive.  

 
URLs marked with a page over a globe icon are remote; that is, they have been Added to your list of 
sites, but not yet whacked. 

 

Adding Sites to your WebWhacker Storage 

 
To quickly add URLs to WebWhacker 5.0 while 
you’re browsing online you can select URLs or 
hyperlinks and use your Internet Explorer’s right 
click menu to choose from the following: 
 
Add this page to WebWhacker – This will add 
the current URL of the page you are on to 
WebWhacker’s storage. 
 
Add this link to WebWhacker – This will add the 
URL for the selected link that you are on to 
WebWhacker’s storage. 
 
Drag & Drop – Select a URL and drag it onto the 
WebWhacker desktop. 
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For more in depth options to Add URLs to your WebWhacker storage refer to page 13 of this manual and 
follow the steps to “Capture and Organize URLs in WebWhacker”. 

Deleting Sites from your WebWhacker Storage 

If you wish to remove a URL from WebWhacker, click on its name once to select it, then press the Delete key 
on your keyboard. You can also right-click on a URL and choose Delete from the drop-down menu. 

Moving Sites in your WebWhacker Storage 

If you want to move a site from one folder to another, click and hold to select the URL, then drag it to the 
desired folder. Or select a URL and choose Edit, Cut from the menu bar. Then select the folder where you want 
to move the URL, and open the Edit menu and select Paste. 

URL Properties 

If you want more information about a particular URL, click once to select the Web address, then 
click the Properties button on the Toolbar. The URL Properties dialog provides you with 
information about the URL including the name, location, creation date, notes, filters, links, etc.    

      Review the screens, and click OK to close the dialog. 
 

• The Filters Tab displays the file types that you do and do not wish to download. Such as Video, Audio, 
Images, and Software programs. File types that have a check marked next to them will not be 
downloaded.  

• The Statistics properties tab lists the creation, Added, and modification dates. 
• The Links tab displays the URLs of any pages linked to the page that you downloaded. 
• The Schedule tab shows the scheduling options, and allows you to enable scheduling to perform an 

action. 

Capture and Organize URLs in WebWhacker 

When you Add a URL, WebWhacker captures the URL and stores it in a specified folder. Grabbing 
a URL does not download the site to your hard drive. This is good for organizing URLs, or for 
scheduling WebWhacker to Whack (download) URLs at a more convenient time. (Previous versions 
of WebWhacker referred to this feature as Grab.) 

 
1. Start WebWhacker if it is not already running. 
2. In WebWhacker select the folder where you want the URL(s) stored. 
3. Open your favorite Web browser and go to the site you want to capture to WebWhacker. For now, check out 

the USDA’s site at http://www.nal.usda.gov/fnic/reports/foodint.html. 
4. There are four ways you can Add a Url to WebWhacker: 

• Click the Add button on the AppBar,  
• Within the WebWhacker Program click on the Add button on the Toolbar 
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• From the URL Menu inside of WebWhacker click Add. 
• Drag a URL to an open folder. 

5. When WebWhacker displays step 1 of the URL Subscription Wizard, the URL for the page you added is 
already in the URL to Add text box. WebWhacker automatically enters the page’s title in the Notes text box. 
If you wish, you may edit or change this information, and click Next to continue. 

6. On step 2 of the URL Subscription Wizard, choose how much of the site to download. 
• Select the number of levels of this site you want to whack: 1 gives only the current page; 2 adds the 

current page and it’s immediate links, and so on.  
• Select Remain on Site to restrict the whack to download only pages located at the USDA site. 
• The USDA site does not require security precautions. If you are at a site that does require a user name or 

password, enter them here. 
• Click Next. 

7. Step 3 of the URL Subscription Wizard offers filtering options. To save memory you may want to filter 
out larger files such as software programs, videos, audios, and images. Place a check next to the file types 
you do not want to download and click Next to continue. 

8. Step 4 of the URL Subscription Wizard gives you the option to download the Web site immediately or 
later at a scheduled time. Select the radio button “Later, or as scheduled”.  By default WebWhacker will 
download the URL immediately. You’ll also need to select a radio button to indicate which type of Action 
you want to perform:  

• Whack – downloads the Web site to your hard drive, floppy, CD, Zip or any storage device. 
• Renew – If you have previously downloaded a Web site you can use this option to download new 

changes. 
• Preview - Get an overview of a Web site's tree structure before you whack the URL. 
• Check Links – Finds the broken links in a Web site. 

9. When you select Finish, WebWhacker captures the URL to your list. If you had chosen to whack 
immediately, it would also connect to the Web (if necessary) and download the site. We chose to whack the 
site later, so you must perform the whack manually or schedule it for later whacking. For instructions on 
how to do this refer to the next page. 

Downloading a Web Site Manually 

If you have Added URLs to WebWhacker that have this icon  (a page over a globe) next to the URL this 
indicates that the Web Site is remote (not yet whacked). You can manually have WebWhacker download the 
Web site’s content to your computer by: 
 
1. Connect to the Internet if you are not already. 
2. Open WebWhacker by going to Start, Programs, Blue Squirrel, and WebWhacker. 
3. Locate and select the name of the site on the WebWhacker desktop and use one of the following options: 

• Click the Whack button  on the Toolbar. 
• Go to the URL menu and select Whack. 
• In the Tree Window simply right-click and select Whack from the pop-up menu. 
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WebWhacker will connect to the Internet and begin downloading the content to your computer. 

Downloading a Single Web page 

Use WebWhacker’s PageCopy feature to quickly capture the content of a single Web page to 
WebWhacker.  PageCopy will only download the Web page for the specified URL. It will not 
download any links going off of that URL. 

 
1. Start WebWhacker if it is not already running. 
2. In WebWhacker select the folder where you want the URL(s) stored. 
3. Connect to the Internet and open your favorite Web browser and go to the Web page you want to capture to 

WebWhacker. 
4. Once you have browsed to a page that you want to download you can do any of the following: 

a. Click the PageCopy button on the AppBar.  
• In the WebWhacker Program click on the PageCopy button on the Toolbar. 
• From the URL Menu inside of WebWhacker click PageCopy. 

 
WebWhacker will connect to the Internet and download the content for that Web page to your computer. 

Downloading a Web Site 

With WebWhacker you can Whack (download) Web pages or entire Web sites to your hard drive, floppy, CD, 
Zip disk, or any storage device.  
 
1. Start WebWhacker if it is not already running. 
2. In WebWhacker select the folder where you want the URL(s) stored. 
3. Connect to the Internet and open your favorite Web browser and go to the site you want to capture to 

WebWhacker. For now lets go to the National Weather Service's Web page: http://www.nws.noaa.gov/. For 
example, if you're a teacher using weather as the topic of a multidisciplinary math and science unit, you may 
want to whack the tables of temperature and precipitation statistics for specific cities. Or check out the 
National Climactic Data Center's current and historical projects. 

4. Once you have browsed to a page that you want to download you can do any of the following: 
• Click the Add button on the AppBar. 
• Within the WebWhacker Program click on the Add button on the Toolbar. 
• From the URL Menu inside of WebWhacker click Add. 

5. When WebWhacker displays step 1 of the URL Subscription Wizard, the URL for the page you added is 
already in the URL to Add text box. WebWhacker automatically enters the page’s title in the Notes text box. 
If you wish, you may edit or change this information, and click Next to continue. 

6. On step 2 of the URL Subscription Wizard, choose how much of the site to download. 
• Select the number of levels of this site you want to whack: 1 gives only the current page; 2 downloads 

the current page and it’s immediate links, and so on.  
• Select Remain on Site to restrict the whack to download only pages located at the National Weather 

Service’s Web site. 
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• If you are at a site that requires a user name or password, enter them here, and click Next to move 
forward. 

7. Step 3 of the URL Subscription Wizard offers filtering options. To save memory you may want to filter 
out larger files such as software programs, videos, audios, and images. Place a check next to the file types 
you do not want to download and click Next to continue. 

8. Step 4 of the URL Subscription Wizard gives you the option to download the Web site immediately or 
later at a scheduled time. Select the radio button “Immediately after this subscription”. You’ll also need to 
select a radio button to indicate which type of Action you want to perform:  
• Whack – downloads the Web site to your hard drive, floppy, CD, Zip or any storage device. 
• Renew – If you have previously downloaded a Web site you can use this option to download new 

changes. 
• Preview - Get an overview of a Web site's tree structure before you whack the URL. 
• Check Links – Finds the broken links in a Web site. 

9. When you select Finish, WebWhacker will connect to the Web (if necessary) and download the site, and 
add the URL to the selected folder.  

Browsing a Web Site without an Internet Connection 

WebWhacker gives you the ability to view Web sites without an Internet connection. You can quickly display a 
URL’s Web page from the main program window. If you have whacked the Web page, it is loaded directly 

from your local storage. Ensure that the URL you want to browse has this icon  alongside of it, indicating 
that you have downloaded the site to your hard drive. 
 
To View a Site without an Internet connection, follow these steps: 
 

1. Open WebWhacker 
2. In the main program window, navigate to the correct Folder clicking on the boxed plus signs to expand 

Sub-Folders  as necessary and do any of the following: 
• To browse the site using WebWhacker’s integrated browser, select the URL for the Web page you 

want to browse by clicking once on its name to display the page in the browser window. (This 
Feature only works if you have Internet Explorer installed on your system. 

• To browse the site using your preferred Web browser, select the name of the site, and click the 

Browse button  on the toolbar. To change the default browser, go to Tools, and Options on the 
menu bar. In the Options dialog adjust the settings on the Internet tab, and click OK.  

• Select the name of the site, right-click, and choose the browse command from the pop up menu. 
 
NOTE: If you’ve used previous versions of WebWhacker you’re probably used to double-clicking to 
browse a site. By default WebWhacker has turned this feature off. You can easily turn it on by going to the 
Tools Menu and selecting Options. The Options Dialog box appears. Select the View tab and check the 
Double Clicking browses rather than moving down a level option and press OK. 
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Troubleshooting Access Problems 

If your Web browser suddenly seems unable to access its network connection or consistently tells you a 
whacked URL cannot be found, you may have your proxy configuration set incorrectly. This can occur while 
you are browsing with WebWhacker or even after you have closed the WebWhacker program. The interaction 
between WebWhacker and your Web browser is controlled by settings in both programs. For more information 
on configuring your Proxy, please look at the Proxy Tab information in the Interface section of this manual. 

Quickly Access WebWhacker using the Tray Icon 

 
 

When WebWhacker is running a small icon  will appear in the Windows tray (next to the clock on the 
Taskbar). Right-clicking this icon gives you quick access to commonly used functions. You can activate or 
close WebWhacker, turn the App Bar on, and easily Add or copy a page to WebWhacker. 
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ADVANCED 

Headlines 

The Headlines pages work much like many personal Web home pages, with a hierarchical series of links to 
information of interest. You’ll see a Headlines page pop-up when you click on folders, and Subfolders in the 
WebWhacker Tree Window. Businesses find this feature useful because they can offer a virtual Web to their 
employees, likewise, it allows teachers to teach students how to browse and search the Web as though they were 
online.  

 
 

To view Headlines for a folder fo llow these steps: 
1. If necessary, start the WebWhacker program. 
2. Click on the WebWhacker Storage Folder, or Subfolder that you want to browse. Then go to the 

Toolbar and click Headlines. 
3. WebWhacker opens your Web browser and loads the Headlines page. If you do not see the Headlines 

page, check the following: 
• In your Web browser, check to see that it is set to use a manual proxy. 
• In WebWhacker, go to the Tools menu and select Options, then the Internet tab. 
• Make sure that your browser is correctly identified. 

4. You can browse the Headlines page as though you’re online.  
• By default the Catalog view of the Headlines page is displayed. Catalog shows a list of links to your 

categories and any uncategorized site. Click on a link to a category to see a list of site titles in the 
category. Click on the links to view whacked Web pages in the WebWhacker browser. 

• Click Index to see a list of the complete URLs for all whacked sites. 
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Searching 

Have you ever come across a site that doesn't offer you the ability to search for key-words? WebWhacker 5.0 
gives you the capability to search a Web site that doesn't have a "search box". In WebWhacker 5.0 we vastly 
improved searching, and added a full indexer, giving you the ability to search through downloaded Web sites as 
though you were running a search on Yahoo, MSN, or Lycos.  
 
Use any of the following search operators in WebWhacker to look up key-words and find results: 
 

• AND – The AND operator links keywords together, narrowing the results of your search. When you are 
searching for a particular group of keywords, use the Boolean operator AND to restrict your search. For 
example, to search for "computer animation," type the keywords "computer animation" in the keyword 
text box. WebWhacker will search for Web pages including both keywords, "computer" AND 
"animation."  

 
• OR - The OR operator is often used to include any of two or more different keywords, effectively 

widening the search. Using the same example —"computer animation"— the results of an OR search 
will include all Web pages containing the word "computer" OR the word "animation." With an OR 
search, all keywords will not necessarily be found in each Web page, as they would in an AND search. 
An OR search might retrieve a large number of results that didn’t necessarily contain information on 
computer animation. OR searches expand your results to include results that might not otherwise be 
found. For example, if you searched for “airplane” OR “plane,” you would find many Web pages that 
contained the word plane but not the word airplane. 
 

• PHRASE – The PHRASE operator requires results to contain all of the listed keywords. In addition, 
PHRASE requires that the keywords be used together as a phrase. For example a search could be 
launched with the keywords “Planes, Trains, and Automobiles”. WebWhacker will only return results 
containing all of the keywords, in the exact order they were entered. 

 
• NEAR/SUBSTRING – The NEAR or some times referred to as SUBSTRING operator is similar to the 

OR Boolean Operator, in that, the resulting sites need only contain one of the listed keywords. However, 
a SUBSTRING search retrieves an even wider range of results than an OR search because resulting sites 
include any of the keywords within other words. For example, a SUBSTRING search of the word “flu” 
could return results including “influenza”, “fluent”, “flut”, etc. 
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To perform a Search in WebWhacker please follow these steps: 
 

1. Open WebWhacker, and select the folder or subfolder where you want to perform a search.  

2. On the Toolbar, click the Search button . The Search Properties dialog box appears. Or go to File, 
and select Search on the Menu bar. 

3. Enter the desired search terms in the Query text box. For example, type in Computer Animation. 
4. In the Title section, you can list a title for the search, or accept the default. 
5. Click OK to start the search. 
6. When WebWhacker completes the search, double-click on the search results page located in the tree 

window. The search results page has an icon of a magnifying glass  to the left of the search title. The 
results display in the list window. In WebWhacker 5.0 we enhanced the Search results page so that it 
highlights your search words in the integrated WebWhacker browser, and allows you to jump forwards 
and backwards through results. 

7. If you want to change the color of the highlighted results go to Tools, Options, and click on the 
Searching Tab. From there you can click on the color boxes to choose the color of your choice. Press 
OK to save your changes. 

Edit Web Pages 

 
In WebWhacker 5.0 we have made it so you can edit the HTML code for downloaded 
Web pages with one-click. You can easily add or remove text, and graphics, or change the 
appearance of downloaded Web pages. This is also a useful feature if you want to learn 
how other Web sites created neat effects. 
 

1. Select the URL that you want to edit. Ensure that the URL has this icon  to the 
left, indicating that you have downloaded the Web page. 

2. Right-click and select Edit. WebWhacker will open the HTML code in Notepad.  
3. Make the desired changes and ensure that you save the file. All changes will be 

applied in WebWhacker when you view the Web pages in the integrated Web 
browser. 

 
NOTE: By default WebWhacker will open Notepad with the HTML code. You can 
change the editor in WebWhacker by going to Tools, and Options. Select the General Tab, 
and under the HTML Editor section click on the ellipses box  to browse to the editor of 
choice. Press OK to save your changes. 



Advanced   

 
 
WebWhacker  Page 45 

45 BLUE SQUIRREL SOFTWARE – www.bluesquirrel.com - 686 E. 8400 South, Sandy, UT  84070 

Export a Web Site 

Exporting comes in handy when you need to be able to send a Web page home with someone that doesn’t have 
WebWhacker installed on his or her computer. When you export a Web page you can save it to a floppy, CD, 
Zip, etc. and browse the site with a Web browser without being connected to the Internet and without having 
WebWhacker installed. To export a Web page or entire Web site follow these steps: 
 

 
 
1. Open WebWhacker if it is not already running, and click on the page’s URL in the WebWhacker tree 

window that you wish to export. Please ensure that you have downloaded all of the Web site’s content. 
2. With the URL selected click on the File menu and select Export (exports all pages, and any linking 

pages) or Export Page (exports a single Web page). 
 

 
 
3. In the Export dialog box type in the location and the name of the folder. For example, if you are 

exporting a page that you want to call statistics, and you want to store the exported files in you’re my 
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documents directory on your C:\ drive the location would be typed in as C:\My Documents\statistics. 
Please note, you will need to enter the entire path. When you press OK WebWhacker will export the 
HTML file to the sub-folder "statistics" in the "My Documents" folder on your C:\ Drive. WebWhacker 
exports the main page file in .HTML format, and all associated files (graphics, sounds, etc.) in their 
native formats. The files can then be reloaded and viewed in any Web browser. NOTE: checking the 
“Autorun.inf” option in the Export dialog allows you to save Web pages to a floppy or CD. When the 
CD or Floppy is inserted into the corresponding drive on a computer the default Web browser will 
automatically launch with the Web page displayed. 

Prepare Web Sites For CD Distribution 

WebWhacker 5.0 makes it simple to build CDs containing Web site content. The handy AutoRun feature will 
automatically open a browser, and launch a Web page when the CD is inserted into a CD-Rom drive. You will 
need CD writing software to use this feature. After you have Whacked a Web Site, you can choose a folder in 
the left-hand pane in WebWhacker and choose File->Export....  Then you will be given the option to choose a 
location to copy the files. Choose an empty directory like “C:\Temp\MakeCD”  If you would like the CD to 
automatically start up when placed in a Windows computer, you can select the option for Autorun.inf, and 
WebWhacker will also create the files necessary to AutoRun your CD.  Once you have exported your files, you 
can use your CD software to burn all of the files from “C:\Temp\MakeCD” (or wherever you stored the files) to 
a CD. 

Import Netscape Bookmarks 

You may already have a collection of Internet shortcuts in Netscape that you would like to add to WebWhacker. 
To do so please follow these steps: 
 

1. On the WebWhacker desktop, select the folder into which you want to import your Bookmarks. 

2. From the File menu, select Import . A windows dialog box appears. 
3. Browse to the directory containing your Bookmarks file. Select the Bookmarks file and click OK. 

 
Tip: the default location for your Netscape Communicator Bookmarks is: 
C:\Program Files\Netscape\Communicator\Program\Defaults\bookmark.htm 

 
WebWhacker imports your Bookmarks into the selected folder. If you would like to download any of 
your bookmarked Web sites to your WebWhacker storage refer to page 15 and follow the steps to 
“Download a Web Site”. 

Transfer Storage Units Between Computers 

When you finish adding and whacking all the desired Web Sites to your WebWhacker Storage, or any storage 
you have created you can easily move the storage to your laptop, Network, or another computer. 
 
To move one of your WebWhacker Storage units to a laptop follow the steps outlined below. 
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1. If you have created the storage on your removable media, simply eject the media and insert it into the 

appropriate drive on your laptop. 
OR 
 
If you have created the storage on your hard drive, exit WebWhacker then right click on your Windows 
Start button, and choose Explore. In the Windows Explorer dialog locate the folder in which you stored 
the whacked sites, and copy it to your removable media using standard Windows copy and paste 
commands. If you are using WebWhacker’s default settings, the information is located in C:\My 
Documents\WebWhacker. Eject the Media and insert it into the appropriate drive on your laptop. 

2. Check your laptop to ensure that you have installed WebWhacker and your favorite Web browser. 
3. In the WebWhacker program on your laptop, go to the File menu, and choose Open Storage. 
4. In the Select Directory dialog, navigate to the removable media drive and the folder containing your 

WebWhacker storage, then click OK.  
5. To display sites go to WebWhacker and click the name of any site to display it in the integrated browser.  

 
OR 
 
Right-click a URL, and select Browse from the pop-up menu, to launch your Web browser and display 
the selected site in the browser’s window. 

Schedule WebWhacker To Perform Tasks 

You can use WebWhacker’s scheduling feature to download a Web site at a more convenient time during off-
peak hours. Or you can use the scheduling feature to monitor a Web site for changes on a daily, weekly or 
monthly basis. When you Add a URL, you create a subscription to that URL. It is called a subscription because, 
like a newspaper or magazine subscription, WebWhacker will automatically update information (a new Web 
page or pages) at regular intervals.  
 
Scheduling renewals requires you to coordinate between WebWhacker and Microsoft’s Task Scheduler. When a 
URL is set for renewal (or when you request one manua lly), WebWhacker looks at every URL in the storage 
and compares its modified date to the current date. Then, based on its Update Frequency property setting, the 
URL is scheduled for renewal, and WebWhacker queries the site server to determine whether the page has 
changed. If the server indicates that the page has been changed, WebWhacker downloads the changed page. 
 
If you're not connected to the Internet full-time and would like to perform unattended renewals, you must leave 
your computer on and have a Web account that uses a standard Windows 95 Dial-Up connection which does 
NOT require you to type your name and password into a dial-up window. If you must enter your name and 
password manually each time (rather than with a script or a remembered password), you cannot perform 
scheduled, unattended whacks or renewals. 
 
NOTE: WebWhacker works in conjunction with Microsoft's Task Scheduler. You must have Microsoft’s Task 
Scheduler installed to perform unattended actions. Please refer to our Online FAQ’s for instructions on how to 
obtain a copy of Microsoft’s Task Scheduler:  
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http://www.bluesquirrel.com/support/whacker/FAQ_WW2000.html 
 
If you have scheduled WebWhacker to perform a task, you do not have to leave WebWhacker running. 
Microsoft's Task Scheduler automatically launches WebWhacker and begins the task. 
 

1. In WebWhacker Explorer, locate and select the URL for which you want to schedule an action. 
2. Then choose from any of the following methods to activate the Schedule Dialog box: 

 
• From the File menu, select Schedule.  
• Or Right click and select Schedule 
• Or click the schedule icon on the Tool bar.  

 
The Schedule dialog box appears with the Action tab displayed. 
 

 
 
3. Select the Scheduling Enabled check box, and the action you want to perform. 

• Whack – downloads the Web site to your hard drive, floppy, CD, Zip or any storage device. 
• Renew – If you have previously downloaded a Web site you can use this option to download new 

changes. 
• Preview - Get an overview of a Web site's tree structure before you whack the URL. 
• Check Links – Finds the broken links in a Web site. 
 
NOTE: In order to schedule a Link Check the URL must be designated as Link Check. This is done on 
page four of the URL subscription Wizard in the Action to Perform section. 
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4. Then click on the Schedule Tab and click the New button to schedule the action. The default schedule 

time and frequency appear in the Schedule drop down menu. Modify the Schedule Task, Start Time, and 
Schedule Task Daily fields to reflect the time and frequency you want the task performed. Click the OK 
button. 

 

 
 
5. WebWhacker will place an icon next to the URL and its corresponding folder indicating that it is 

scheduled to perform an action. 
 

 

Scheduled URL This URL has been Added to your WebWhacker database but none of its Web 
content is downloaded to your computer. WebWhacker is scheduled to download 
the Web site at the specified time you input. 

 
Scheduled 
Whacked URL 

The Web site has already been downloaded to your computer. The clock over the 
top of the Web page indicates that it is scheduled to monitor the Web for changes. 

 
Scheduled Folder The clock over the top of a Folder indicates that it is scheduled to perform tasks 

on scheduled URLs in that folder.  
 

6. If the folder does not have this icon  located to the left of its name then you need to schedule the 
folder as well. Select the folder containing the scheduled URL, and right click and select Schedule. The 
Schedule dialog box appears. 

a. Click the New button to schedule the new action. The default schedule time and 
frequency appear in the Schedule drop down menu. Modify the Schedule Task, Start 
Time, and Schedule Task Daily fields to reflect the time and frequency you want the 
task performed. 
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b. Click the OK button. WebWhacker adds the new task to Microsoft’s Task Scheduler. 
The Task Scheduler will launch WebWhacker to perform the action at the designated 
time. 

 
 NOTE: A scheduled task will not run unless its folder is scheduled. Scheduling a folder does not 

automatically schedule sub-folders. All folders and sub-folders need to be scheduled. 
7. To see a listing of all your scheduled tasks, open the Microsoft Task Scheduler. 

 

Whacking Special Files 

WebWhacker can get special files tha t are not standard html, or image files that are loaded by script. If 
WebWhacker is not getting certain files that you need and those files are in quotes in the HTML, you can 
change a configuration file to have WebWhacker get those files for you. 
 
In the WW.INI in the applications directory, add this line. 
 
[Data] 
ScriptExtentions=gif,jpg,htm,html,js,swf,class,xml,jar 
 
Add any additional file extensions that you want WebWhacker to get to the end of the line and separate them 
with a comma (,). 
 

WebWhacker Limitations 

While WebWhacker is the best offline-browser currently available, it does have its limitations. 
 
WebWhacker cannot: 

• …determine the links that Flash files are linking to. As a workaround, you can add each link manually to 
the same storage and use the Local Proxy Cache to view the whole site. 

• …get files that are dynamically generated by script. WebWhacker will not interpret client script to 
determine the filenames. If the full filenames (with path) are in the script in quotes, and the extensions 
are in the [Data]/ScriptExtensions section of the WW.INI file, then WebWhacker will get 
them. 

• …get HTML resulting from a form. If you have to fill out fields, then WebWhacker can’t get it.  
WebSeeker (also from Blue Squirrel) can do forms. 

• …get HTML from a POST.  This is most commonly used for forms, but sometimes all the fields are 
hidden so it doesn’t look like a form. WebWhacker cannot POST information and get the result. 
WebSeeker (also from Blue Squirrel) can do forms. 

• …get server side script.  WebWhacker is only able to get what  the web server sends.  It receives the 
same HTML that the browser does.  WebWhacker will not retrieve the underlying Active Server Script 
(.ASP), Java Script (.JSP), .PHP code, .Cold Fusion code (.CFM), etc. 
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• …get handle server side image maps.  This is where the browser sends the location of where the user 
clicked on the image, and the server decides what to return. 
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Customer Support 
This User’s Manual supplies what you need to know to get productive with WebWhacker.  Below we have 
listed several options to choose from to assist you with any help you may need using WebWhacker.   

WebWhacker Help File 

To access the WebWhacker help file, click open the software by going to Start, Programs, Blue Squirrel, and 
WebWhacker. Then choose Help, and Help Topics.  We encourage you to use WebWhacker’s help, because it’s 
a complete, informative reference system.  In addition, Help offers several advantages over printed manuals: 
In the Help Index, you can type in a keyword, and the program automatically looks it up for you.  While reading 
the Help file you can click on a “hot” phrase to jump to a related topic.  And later you can retrace your steps; 
flipping backwards through the topics you jumped from.  Or you can read topics in order, like turning the pages 
of a book, either forward or backward. From the Help file, you can access the standard Windows Help interface.  
If you aren’t familiar with Help systems in other Windows applications, read about this interface in your 
Windows documentation. 

How to Find Specific Topics in the Help File 

The Help system displays both the Contents and Index lists, providing alternative ways to get information 
pertaining to a specific topic. The list of Contents shows the major categories of Help.  When a category is 
chosen, you’ll be presented with Help text directly, or a pop up menu of topics, from which your choices will be 
narrowed.  The index allows you to look up a word or phrase you have in mind.  Type the word or phrase, or 
look in the alphabetical list for your topic, select it, and click Display. Clicking on the highlighted word or 
phrase brings up a list of Associated Topics.  Double click on any associated topic to read the contents.  Or 
double click on the word or phrase to go directly to its first associated topic. If you prefer to browse or read 
straight through Help, go to any topic as a starting point.  From there, use the >> and << buttons to move 
through topics forward or backward.  You can read through the entire Help system in this way. 

Visit Our Web Site 

http://www.bluesquirrel.com/products/whacker/ 
If you cannot find the information you need in any of the preceding sources, try our FAQs located in our state-
of-the-art Technical Support page for assistance. 
http://www.bluesquirrel.com/support/ 

Technical Support  

http://www.bluesquirrel.com/support/ 
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Contact Us 

If you would like to speak with a Blue Squirrel representative regarding non-technical issues please select from 
the following options: 

Customer Service 

Phone: 801-352-1551 
Toll Free: 800-403-0925 
Fax: 801-912-6032 
E-mail: sales@bluesquirrel.com 
Hours: M-F, 8:00 a.m. to 5:00 p.m. Mountain Standard Time. 

Mailing address 

Blue Squirrel 
686 E. 8400 South 
Sandy, UT  84070 
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License Agreement 
THE BLUE SQUIRREL END USER LICENSE AGREEMENT REDISTRIBUTION  

NOT PERMITTED GRANT. 
 
BY INSTALLING THE BLUE SQUIRREL SOFTWARE, YOU ARE CONSENTING TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREE TO 
ALL OF THE TERMS OF THIS AGREEMENT, DO NOT INSTALL THE BLUE SQUIRREL SOFTWARE, OR IF YOU HAVE ALREADY INSTALLED IT, 
UNINSTALL IT IMMEDIATELY. 
 
Subject to payment of applicable license fees, Blue Squirrel grants you a non-exclusive license to use the Software and accompanying documentation 
("Documentation") in the manner described below under "Scope of Grant." 
 
SCOPE OF GRANT. 
You may: 

• use the Software on any single computer; 
• use the Software on a network, provided that each person accessing the Software through the network must have a copy licensed to that person; 
• use the Software on a second computer so long as only one copy is used at a time; 
• copy the Software for archival purposes, provided any copy must contain all of the original Software's proprietary notices;  
• or if you have purchased licenses for a 10 pack or a 50 pack, make up to 10 or 50 copies, respectively, of the Software (but not the Documentation), provided 

any copy must contain all of the original Software's proprietary notices. The number of copies is the total number of copies that may be made for all 
platforms. Additional copies of Documentation may be purchased. 

You may not: 
• permit other individuals to use the Software except under the terms listed above; 
• permit concurrent use of the Software; 
• modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable laws specifically prohibit such restriction), or create derivative 

works based on the Software; 
• copy the Software other than as specified above; 
• rent, lease, grant a security interest in, or otherwise transfer rights to the Software; or 
• remove any proprietary notices or labels on the software. 

 
LIMITED WARRANTY. Blue Squirrel warrants that for a period of thirty (30) days from the date of acquisition, the Software, if operated as directed, will substantially 
achieve the functionality described in the Documentation. Blue Squirrel does not warrant, however, that your use of the Software will be uninterrupted or that the 
operation of the Software will be error-free or secure. In addition, you must determine that the Software sufficiently meets your requirements. Blue Squirrel also 
warrants that the media containing the Software, if provided by Blue Squirrel, is free from defects in material and workmanship and will so remain for thirty (30) days 
from the date you acquired the Software. Blue Squirrel’s sole liability for any breach of this warranty shall be, in Blue Squirrel's sole discretion; (i) to replace your 
defective media; or (ii) to advise you how to achieve substantially the same functionality with the Software as described in the Documentation through a procedure 
different from that set forth in the Documentation; or (iii) if the above remedies are impracticable, to refund the license fee you paid for the Software. Repaired 
corrected, or replaced So ftware and Documentation shall be covered by this limited warranty for the period remaining under the warranty that covered the original 
Software, or if longer, for thirty (30) days after the date (a) of shipment to you of the repaired or replaced Software, or (b) Blue Squirrel advised you how to operate the 
Software so as to achieve the functionality described in the Documentation. Only if you inform Blue Squirrel of your problem with the Software during the applicable 
warranty period and provide evidence of the date you purchased a license to the Software will Blue Squirrel be obligated to honor this warranty. Blue Squirrel will use 
reasonable commercial efforts to repair, replace, advise, or refund pursuant to the foregoing warranty within 30 days of bein g so notified.

 


