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Because of the variety of uses for the products described in this
publication, those responsible for the application and use of this
control equipment must satisfy themselves that all necessary steps
have been taken to assure that each application and use meets all
performance and safety requirements, including any applicable laws,
regulations, codes, and standards.

The illustrations, charts, sample programs, and layout examples
shown in this guide are intended solely for purposes of example.
Since there are many variables and requirements associated with any
particular installation, Allen-Bradley does not assume responsibility
or liability (to include intellectual property liability) for actual use
based upon the examples shown in this publication.

Allen-Bradley publication SGI-1.1, Safety Guidelines for the
Application, Installation, and Maintenance of Solid-State Control
(available from your local Allen-Bradley office), describes some
important differences between solid-state equipment and
electromechanical devices that should be taken into consideration
when applying products such as those described in this publication.

Reproduction of the contents of this copyrighted publication, in
whole or in part, without written permission of Allen-Bradley
Company, Inc., is prohibited.

Throughout this manual we use notes to make you aware of safety
considerations:

!
ATTENTION: Identifies information about practices
or circumstances that can lead to personal injury or
death, property damage, or economic loss.

Attention statements help you to:

• identify a hazard

• avoid the hazard

• recognize the consequences

Important: Identifies information that is critical for successful
application and understanding of the product.

DeviceNet is a trademark of Open DeviceNet Vendor Association (O.D.V.A.).
Microsoft is a registered trademark of Microsoft Corporation.
Windows is a trademark of Microsoft Corporation.
WinDNet16 is a trademark of Allen-Bradley Co., Inc.

Important User
Information
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About This Manual

Read this preface to familiarize yourself with the rest of the manual.
This preface covers the following topics:

• what’s in this manual

• who should use this manual

• about the conventions

• about Allen-Bradley support services

This manual provides a general overview of the DeviceNet
Monitor software.

Chapter  3
Chapter 2

Chapter 1

Read this chapter
to install the
DeviceNet Monitor
software.

Read this chapter
to use the
monitor software.

Chapter  4

Read this chapter
to go online.

Chapter  5

Chapter 8
Chapter 7

Chapter 6

Read this chapter
to set the trace
buffer and time
display options.

Read this chapter
to configure the
point monitor and
trigger.

Chapter  9
Read this chapter
to configure the
display filters.

Read this chapter
for a quick start to
monitoring with the
DeviceNet monitor.

Read this chapter
to set the passive
MAC ID.

Read this chapter
to configure the 
acceptance filter. Chapter  10

Read this chapter
to monitor a
DeviceNet network.

Chapter  11

Read this chapter
to analyze
fragmentation.

This documentation is geared for control engineers, application
engineers, or system integrators who need to monitor activity on the
DeviceNet network.

The following conventions are used throughout the manual.

Type of text Example

Menu names Utilities
Text references to buttons OK

Text that you enter setup

What's in This Manual

Who Should
Use This Manual

About the Conventions
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This manual uses screen captures to represent the actual software.
This section describes the various screen captures you’ll see.

Menu and Tool Bars

Through the View menu, you can toggle the tool bar or status bar
menu item, choosing to show or hide the bar.  A checkmark indicates
that it’s visible.

View

new project

open project

save project

go offline

go to
the next
bookmark

set the
acceptance
filter

set the point
monitor/trigger

set the
display filter

start monitor

stop monitor

go online

print

Status Bar

The status bar appears at the bottom of your screen and provides the
current status of an application.

View

Understanding
the Screens
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Dialog Boxes

Dialog boxes contain buttons you choose to cause a particular
action to occur. 

Term Definition

CAN (Controller Area Network) A serial communications protocol

upon which the DeviceNet network is based.

MAC ID The address of a DeviceNet node.

Message ID The unique identifier that defines a particular connection within

a message group.  The message ID enables the establishment

of multiple connections within a single message group.

Message Groups The way in which the eleven CAN bits available on the

DeviceNet network are divided.

Node Hardware that has a single address on the network.

Terminology
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At Allen-Bradley, customer service means experienced
representatives at Customer Support Centers in key cities throughout
the world for sales, service, and support.  Our value-added services
include:

Technical Support

• SupportPlus programs

• telephone support and 24-hour emergency hotline

• software and documentation updates

• technical subscription services

Engineering and Field Services

• application engineering assistance

• integration and start-up assistance

• field service

• maintenance support

Technical Training

• lecture and lab courses

• self-paced computer and video-based training

• job aids and workstations

• training needs analysis

Repair and Exchange Services

• your only “authorized” source

• current revisions and enhancements

• worldwide exchange inventory

• local support

About Allen�Bradley
Support Services
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Quick Start to Monitoring a
DeviceNet Network

Read this chapter to quickly begin monitoring a DeviceNet network
with the DeviceNet Monitor software.

Follow these directions to start monitoring a DeviceNet Network.

1. To start the monitor software, double-click on the DeviceNet
Monitor icon.

You see this screen.

2. From the Network menu, choose Connect.

Network

You see this screen.

What's in This Chapter?

Monitoring a
DeviceNet Network
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3. From the pull-down menu, choose your driver.

Important: You cannot go online with the Allen-Bradley
1770-KFD DeviceNet RS-232 interface module.
You must use an interface card such as the
1784-PCD PCMCIA interface card or any other
WinDNet16  interface card.

4. Choose 

You see a screen similar to this one depending upon your driver.

The software automatically enters
your last used node address and
data rate for the driver.

!
ATTENTION:    Make sure that all devices are set
to the proper data rate.  Attempting to go online at
the wrong data rate may cause some or all devices
on the network to fault.

5. Select the proper settings and choose 

Once you are online, the status bar indicates you are online and
the proper baud rate.
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6. From the Options menu, choose Set Trace Buffer Size.

You see this screen.

7. Click on the arrow and choose the appropriate trace buffer size.

See page 5–1 for more information.

8. Choose 

9. Click on the radio button next to the appropriate time display
option.

This allows you to view a snapshot of the
interface's �time tick" when the message was
received.
You can also view the relative time between
messages by choosing the relative time option.
All times are displayed in ms/µs).

See page 5–2 for more information.

10.From the Monitor menu, choose Start Monitor .

Monitor

11.To stop the monitor, from the Monitor menu, choose
Stop Monitor.

Monitor

Since the default configuration settings were used, all network
traffic is captured in a trace buffer size of 4,000 messages.
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Notice the messages are displayed.
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Installing the DeviceNet
Monitor Software

Read this chapter to install the DeviceNet Monitor software.

For information on See page

Installing the software  2-1

Exiting the installation  2-4

Follow these steps to install the software.

1. Start Windows.

2. Insert the software disk into the 3.5” disk drive.

3. Click on the Start button in the task bar.

4. Choose Run.

5. Type a:\setup.exe  at the Command Line.

If you inserted the software
disk into another disk drive,
use the appropriate drive
letter instead of a:

What's in This Chapter?

Installing the Software
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6. Choose 

You see this installation screen.

You see this screen after the setup is complete.

7. Choose  to proceed with the installation.

You see this installation screen.

8. Click on the respective fields and enter your name and
company name.
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9. Choose 

You see this screen with the information you entered.

To Choose

Approve the information

Go back and make corrections

The software creates a default directory on the host hard drive
called Who for the test application.  All other related files will be
placed in this directory.

If you want to Then

Use the default settings
Choose

Change the default settings
a. Choose

b. Select the new directory.

c. Choose

d. Choose

Exit the installation process and

go to page  2-4

Choose

10.

11.
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When you choose Next, you see this installation screen.

You see this message.

To Choose

View the README file

Continue without viewing the README file

You see this message.

13.Choose 

An icon now appears in your Program Manager.

When available, you may stop the installation process by

choosing 

12.

Exiting the Installation
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Using the Monitor Software

Read this chapter to use the basic functions of the DeviceNet
Monitor software.

For information on See page

Creating a new file  3-1

Opening an existing file  3-2

Saving a file  3-3

Printing a file  3-4

Using bookmarks  3-5

Exiting the monitor software  3-6

From the File menu, choose New.

File

You see this screen.

What's in This Chapter?

Creating a New File
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Follow these directions to open an existing file.

1. From the File menu, choose Open.

You see this screen.

2. Choose the appropriate drive and folder and double-click on the
file name.

3. Choose 

Opening an Existing File
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Follow these directions to save a file.

1. From the File menu, choose Save As.

File

If you’ve already named the file, from the File menu, choose
Save to automatically save the file to the predetermined location.

You see this screen.

2. To save a file, enter the file name in the file name field and select
the directory to which the project will be saved.

3. Choose 

Saving a File

�
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Follow these directions to print a file.

1. From the File menu, choose Print .

File

You see this screen.

2. Click in the appropriate field and enter the range of data you
would like to print.

3. Choose 

You see this screen.

To access the print setup screen, from the File menu,
choose Print Setup.

Printing a File

�
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4. Click on the appropriate radio button to determine how much of
the file you wish to print.

5. Choose 

Once the messages are loaded, you can set bookmarks on specific
messages.

To set a bookmark, double-click on the specific message in the
left-most column (the numbered column).  The text becomes red
indicating it is a bookmark.

To view bookmarks you already set, from the View menu,
choose Next Bookmark.

View

To clear a bookmark, from the View menu, choose Clear Bookmark.

View

To clear the event list, from the View menu, choose Clear Event
List .

View

Using Bookmarks
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To exit the monitor software, from the File menu, choose Exit .

File

If you haven’t saved your changes, you see this screen.

To Choose

Save changes to the file

Exit without saving changes to the file

Return to the application

Exiting the
Monitor Software



Chapter  4

Publication 1787�6.5.8 - June 1997

Online Operation

Read this chapter to go online with a DeviceNet network.

For information on See page

Going online  4-1

Going offline  4-2

Follow these directions to go online.

1. From the Network menu, choose Connect.

Network

You see this screen.

2. From the pull-down menu, choose your driver.

Important: You cannot go online with the Allen-Bradley
1770-KFD DeviceNet RS-232 interface module.
You must use an interface card such as the
1784-PCD PCMCIA interface card or any other
WinDNet16 interface card.

What's in This Chapter?

Going Online
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3. Choose 

You see a screen similar to this one depending upon your driver.

The software automatically enters
your last used node address and
data rate for the driver.

!
ATTENTION:    Make sure that all devices are set
to the proper data rate.  Attempting to go online at
the wrong data rate may cause some or all devices
on the network to fault.

4. Select the proper settings and choose 

Once you are online, the status bar indicates you are online and
the proper baud rate.

To go offline, from the Network menu, choose Disconnect.

Network

Going Offline
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Setting the Trace Buffer and
Time Display Options

Read this chapter to set the trace buffer and time display options.

For information on See page

Setting the trace buffer options  5-1

Setting the time display options  5-2

The monitor tool has the ability to capture up to 10,000 messages.
This equals about 10 to 15 seconds of data on a network operating at
500k baud.  However, the default is 4000 for optimum performance.

The time it takes to display data depends upon the configuration you
are running:

• poll and strobe only

• poll, strobe, change of state, and cyclic

Another factor in the time it takes to display data is how often
changes occur in a change of state configuration.

Click on this radio button to clear the buffer
once it is full and continue monitoring.

Click on this radio button to stop the monitor
once the buffer is full.

Click on this radio button to delete the oldest
entry and continue to monitor the network.

1. From the Options menu, choose Set Trace Buffer Size.

Options

What's in This Chapter?

Setting the Trace
Buffer Options
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You see this screen.

2. Click on the arrow and choose the appropriate trace buffer size.

Important: If you are running Windows  95 or Windows,
version 3.1, with 16MB of RAM, do not select a
buffer size of more than 6000 bytes.  Doing so
can lock up your computer.  You need 32MB of
RAM to allow a 10000 byte buffer size.

3. Choose 

The time display option allows you to view a snapshot of the
interface’s “time tick” when the message was received.  The time
stamp default is absolute time (displayed in ms/µs).

You can also view the relative time delay between messages
(displayed in ms/µs) by choosing the relative time option.

Setting the Time
Display Options
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Setting the Acceptance Filter

Read this chapter to set the acceptance filter.  The acceptance filter
informs the DeviceNet interface which types of messages should be
received and passed up to the Monitor software to be displayed.

Setting the acceptance filter for “All Traffic” will pass all Group 1,
Group 2, and Group 3 messages to the DeviceNet Monitor software.
Setting the acceptance filter to a special value (ie., Group 3, Msg ID
5, MAC ID 63) informs the software to automatically capture data
for the 11-bit CAN identifier field for that particular set of values.

Follow these directions to configure the acceptance filter.

1. From the Options menu, choose Set Acceptance Filter.

Options

You see this screen.

What's in This Chapter?

Configuring the
Acceptance Filter
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2. Enter the appropriate information in the Identifier Field Bits
edit box.

3. Click on the radio button next to the type of messaging you
would like to receive.

4. If you clicked on a radio button other than All Traffic, go to
step 4.  If you click on the All Traffic radio button, go to step 6.

5. Click on the arrow in the MAC ID field and choose the
appropriate MAC ID from the list.

6. Click on the arrow in the Message ID field and choose the
appropriate Message ID from the list.

7. Choose 

You return to the main screen.
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Setting the Point Monitor
and Trigger

Read this chapter to set the point monitor and trigger.  The point
monitor and trigger begins capturing data after a pre-defined
condition (trigger) has been fulfilled.

The point monitor and trigger allows you to start capturing data only
after a particular event has occurred on the network.  This event is
defined by the trigger, which lets you access the bit-level of a
particular event.

Follow these directions to configure the point monitor and set
the trigger.

1. From the Options menu, choose Set Point Monitor Trigger.

Options

You see this screen.

2. Click on the appropriate radio button next to the group you wish
to configure.

What's in This Chapter?

Configuring the Point
Monitor and Trigger
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3. Click on the arrow in the MAC ID field and choose the
appropriate MAC ID from the list.

4. Click on the arrow in the Message ID field and choose the
appropriate Message ID from the list.

5. Enter the consumed connection size.

The consumed connection size is the received packet data size.

6. Choose 

Notice the screen updates to include
the new information.

7. Once you’ve finished creating point monitors, click on the point
monitor for which you would like to set a trigger.

8. Choose 

9. Choose 

You see this screen.

Click on this radio button to capture data
after the trigger has been detected.

Click on this radio button to capture data
before and after the trigger has been
detected.

Click on this radio button to capture data
before the trigger was detected.
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10.Click on the radio button next to the appropriate trigger trace
buffer display option.

This will be automatically filled in if you choose Enter.

11.Click in the Data Byte Offset field and enter the appropriate
value.

12.Enter the data byte acceptance filter in the appropriate fields.

13.Choose 

14.Choose 

You return to the Point Monitor and Trigger configuration screen.

15.Choose 

You return to the main screen.

Notice the trigger and then data is captured.
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Setting the Display Filters

Read this chapter to set the display filters.  The display filters further
separate the messages once the monitor has stopped and all
necessary data has been captured.

Follow these directions to configure the display filters.

You can filter after the monitor has captured data or even offline.
You can even bring up an existing file, and set the display
filters then.

1. From the Options menu, choose Set Display Filters.

Options

You see this screen.

2. Click on the appropriate radio button next to the group you wish
to configure.

3. Click on the arrow in the MAC ID field and choose the
appropriate MAC ID from the list.

4. Click on the arrow in the Message ID field and choose the
appropriate Message ID from the list.

What's in This Chapter?

Configuring the
Display Filters

�



 8–2 Setting the Display Filters

Publication 1787�6.5.8 - June 1997

5. Choose 

6. Choose 

You return to the main screen.

7. Begin monitoring the network.

Once the monitor has captured the data, if the display filter check
box is not marked, all data will appear in the list.
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If the display filter check box is marked, only the data you set
appears in the list.

Deleting a Display Filter

1. Click on the current display filter you wish to delete so it is
highlighted.

2. Choose 

3. Choose 
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Setting the Passive MAC ID

Read this chapter to set the passive MAC ID option.

The passive MAC ID displays a list of active nodes on a network by
doing a who and listening for nodes talking on the network.

If a node is not displayed, it does not necessarily indicate that the
node is not present.  It may only indicate that the node was not active
during the listening period.

The passive MAC ID listens to the network for a period of 60
seconds.  You may decrease this time by choosing the STOP button.

Follow these directions to configure the passive MAC ID.

1. From the Tools menu, choose Passive MAC IDs.

Tools

You see this screen.

2. To activate the passive MAC ID tool, choose 

What's in This Chapter?

Configuring the
Passive MAC ID
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Once 60 seconds has passed, you will see the active nodes on the
network.

To stop the passive MAC ID tool before 60 seconds,

choose 

3. Once you’ve finished viewing the passive MAC IDs,

choose 
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Monitoring a
DeviceNet Network

Read this chapter to monitor a DeviceNet network once all of your
parameters are set.

Follow these directions to start monitoring a DeviceNet Network.

Important: You must be online to monitor traffic on a DeviceNet
network.

1. From the Monitor menu, choose Start Monitor .

Monitor

2. To stop the monitor, from the Monitor menu, choose
Stop Monitor.

Monitor

Since the default configuration settings were used, all network
traffic is captured in a trace buffer size of 4,000 messages.

Notice the messages are displayed.

What's in This Chapter?

Monitoring a
DeviceNet Network
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Analyzing Fragmentation

Read this chapter to begin understanding fragmentation using several
examples from the DeviceNet Monitor Tool software.

In the following fragmentation examples, the 1771-SDN scanner
module and the 1794-ADN FLEX I/O adapter module are configured
for change of state messaging.

The 1771-SDN scanner module is the master at node 1.
The 1794-ADN FLEX I/O adapter module is the slave at node 13.

Transmitting and receiving sizes for the 1794-ADN adapter are
relative to the 1771-SDN scanner module as it is the master.
These are the 1794-ADN byte sizes:

• Tx (transmit) size 22 bytes

• Rx (receive) size 30 bytes

Slot Module Tx Size (bytes) Rx Size (bytes)

	 1794�ADN 0 2

0 1794�OB16 2 2

1 1794�IB16 2 2

2 1794�IE8 2 18

3 1794�OE4 12 2

4 1794�IA8 2 2

5 1794�OA8 2 2

For more information about packet structures, refer to Volume I of
the ODVA DeviceNet Communication Model and Protocol, release
2.0, section 4-4.1.

What's in This Chapter?

Understanding
Fragmentation Examples



 11–2 Analyzing Fragmentation

Publication 1787�6.5.8 - June 1997

Analyzing Buffer 153 (Master's Change of State)

The data captured for buffer 153 is described in the table below.

00 f0 00 00 00 ff 00 80

Byte(s) Data Description

0 00 This is the first fragment.  Packet count is 0.

1 and 2 f0 00 This is the 1794�OB16 output data from the 1771�SDN

scanner where f0 is the low byte (terminals 00 to 07) and

00 is the high byte (terminals 08 to 15).

3 and 4 00 00 This is the 1794�IB16 output data from the 1771�SDN

scanner where 00 is the low byte and 00 is the high byte

for the delay time.

5 and 6 ff 00 This is for the 1794�IE8/A.  Since the appropriate bits are

set to 1 in byte 5, the channels default to -10 to +10V dc.

7 80 This is for the 1794�OE4/A.  This is the low byte of

channel 0.
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Analyzing Buffer 155 (Master's Change of State)

The data captured for buffer 155 is described in the table below.

41 3e 00 00 00 00 00 00

Byte(s) Data Description

0 41 This is the middle fragment.  Packet count is 1.

1 3e This is the high byte of channel 0s data for 1794�OE4.

2 and 3 00 00 This is data from the 1794�OE4s channel 1.

4 and 5 00 00 This is data from the 1794�OE4s channel 2.

6 and 7 00 00 This is data from the 1794�OE4s channel 3.
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Analyzing Buffer 157 (Master's Change of State)

The data captured for buffer 157 is described in the table below.

42 0f 00 0f 00 00 00 ff

Byte(s) Data Description

0 42 This is the middle fragment.  Packet count is 2.

1 and 2 0f 00 Multiplex control of the 1794�OE4.  Use words 0, 1, 2,

and 3 as directed by the channel number n.  That is, use

the analog�data value and not the safe�state value.

3 and 4 0f 00 Full range bits for the individual channels are in byte 3,

which is the value 0f.  Only the lower nibble, bits 0 to 3, is

actually used.  Byte 4 has the configure�select bits.  This

has the value 00.  Actually only bits 8 to 11 are used.

Since the full�range bits are �1" and the configure�select

bits are �0", select 0 to 10V dc/0 to 20mA.

5 and 6 00 00 Bits 0 to 2 in byte 5 have the delay times for the

1794�IA8.

7 ff This is the lower byte of the 1794�OA8 data terminals 0

to 7.
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Analyzing Buffer 158 (Master's Change of State)

The data captured for buffer 158 is described in the table below.

83 00

Byte(s) Data Description

0 83 The upper nibble �8" indicates this is the final fragment.

The lower nibble �3" indicates this is packet count 3.

1 00 This is the upper byte of the data from 1794�OA8.

This byte is not usually used.
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Analyzing Buffer 162 (Master's Change of State Ack)

The data captured for buffer 162 is described in the table below.

Nothing

This is the master’s change of state ack of data previously received
from slave node 13.
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Analyzing Buffer 165 (Slave's Change of State Ack)

The data captured for buffer 165 is described in the table below.

Nothing

This is the slave’s (node 13) change of state ack of data received
from the master.
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Analyzing Buffer 166 (Slave's Change of State)

The data captured for buffer 166 is described in the table below.

00 c0 00 00 00 01 00 70

Byte(s) Data Description

0 00 This is the first fragment.  Packet count is 0.

1 and 2 c0 00 This is the 1794�ADN adapter status word.

3 and 4 00 00 This word of data from the 1794�OB16 is not used and

should be set to 0.

5 and 6 01 00 This is the input data from the 1794�IB16.  This data 01 is

the data from terminals 0 to 7.  The data 00 is from

terminals 8 to 15.

7 70 This is the low byte of data from the 1794�IE8s channel 0

data.
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Analyzing Buffer 167 (Slave's Change of State)

The data captured for buffer 167 is described in the table below.

41 00 00 00 60 00 58 00

Byte(s) Data Description

0 41 This is the middle fragment.  Packet count is 1.

1 00 This is the high�data byte from the 1794�IE8s channel 0.

2 and 3 00 00 Data from the 1794�IE8s channel 1.

4 and 5 60 00 This is data from the 1794�IE8s channel 2.

6 and 7 58 00 This is data from the 1794�IE8s channel 3.
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Analyzing Buffer 168 (Slave's Change of State)

The data captured for buffer 168 is described in the table below.

42 00 00 00 00 00 00 00

Byte(s) Data Description

0 42 This is a middle fragment.  Packet count is 2.

1 and 2 00 00 This is data from the 1794�IE8s channel 4.

3 and 4 00 00 This is data from the 1794�IE8s channel 5.

5 and 6 00 00 This is data from the 1794�IE8s channels 6.

7 00 This is data from the 1794�IE8s channel 7.  This is the

lower data byte only.
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Analyzing Buffer 169 (Slave's Change of State)

The data captured for buffer 169 is described in the table below.

43 00 00 00 03 00 00 00

Byte(s) Data Description

0 43 This is a middle fragment.  Packet count is 3.

1 00 This is upper data byte from the 1794�IE8s channel 7.

2 and 3 00 00 These bytes are also from the 1794�IE8.  The lower byte,

byte 2, gives us the under range bits for 4 to 20mA.  This

does not apply to this set up.  The upper byte has only

the most significant bit being used.  This is for the

power�up bit.

4 and 5 03 00 These two bytes are status information from the

1794�OE4.

6 and 7 00 00 This is the input data from the 1794�IA8.
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Analyzing Buffer 170 (Slave's Change of State)

The data captured for buffer 170 is described in the table below.

84 00 00

Byte(s) Data Description

0 84 This is the final fragment.  The packet count is 4.

1 and 2 00 00 This is from the 1794�OA8.  This data is not really used

and should be set to 0.
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Analyzing Buffer 182 (Master's Change of State Ack)

Nothing

This is the master’s change of state ack of data it received from the
1794-ADN adapter.
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