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generated by Processor Expert by a third party C
compiler.

1 Introduction

Microcontrollers Driver Suite is a rapid
application design tool targeted for Freescale
Kinetis and ColdFire+ Microcontrollers providing
the following key features:

A Graphical User Interface which allows
an application to be specified by the
functionality needed.

An application created from Embedded
Components encapsulating initialization
and functionality of basic elements of
embedded systems.

An automatic code generator which
creates tested and optimized C code which
is tuned to your application needs and the
selected Freescale device.
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A built-in knowledge base, which immediately flags resource conflicts and incorrect settings, so
errors are caught early in design cycle allowing you to get to market faster with a higher quality
product.

Processor Expert creates a Hardware Abstraction Layer (HAL) which provides a unified application
programming interface (API) allowing easy migration between Freescale devices.

The application created in Processor Expert is built from the building blocks called the Embedded
Components and the CPU components. The CPU components are special type of Embedded
Components. An Embedded Component provides:

Selection of peripheral module, pins and timing used by the selected component

Initialization of selected peripheral module according to the current setting of the selected
component

Methods to interface component functionality
Events to handle hardware or software events related to the component
The Processor Expert tool can generate code for IAR C Compiler, CodeWarrior C Compiler or GNU C
Compiler:
The tool can generate code for IAR C Compiler, CodeWarrior C Compiler, Arm Keil or GNU C Compiler.
For the Kinetis devices, the following compilers are supported:
CodeWarrior for MCU, 10.1 and higher.
IAR ARM compiler 6.3 and higher
GNU C Compiler for ARM architecture
Arm Keil C/C++ compiler 5.4 and higher

For the ColdFire+ devices, the following compilers are supported:
CodeWarrior for MCU, 10.1 and higher.
IAR ColdFire C compiler 1.2
GNU C Compiler for ColdFire architecture

The Microcontrollers Driver Suite is implemented as Eclipse plug-in that can be installed in an existing
Eclipse environment (3.6.x or 3.7.x). For installation instructions, see Installation Guide
(PEXDRVSINSTALLUG.pdf).

2 Creating New Processor Expert Project

The Microcontrollers Driver Suite provides two options for creating a new Processor Expert project.
You can either create an empty project directly using the New Processor Expert Project Wizard or you
can extend an already existing Eclipse project by the Processor Expert project.

2.1 Using New Project Wizard

To create a new Processor Expert project:

1. Run the Eclipse environment.
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2. Select File > New > Processor Expert Project from the IDE menu bar. The Create a Processor
Expert Project screen of the New Processor Expert Project Wizard appears (Figure 1Figure

D).

3. Type a name for the project in the Project name text box. For example, HelloWorld (Figure 1).

& New Processor Expert Project |z|@@

Create a Processor Expert Project

“haonse the location For the new project:

Project name: | Hellovworld

Use default location

®

Cancel

Figure 1. New Processor Expert Project Wizard - Create a Processor Expert Project Screen

4. To specify a different location for the new project, uncheck the Use default location checkbox,
and click Browse. The default setting of the Use default location checkbox is checked.

5. Click Next to display the Devices screen as shown in Figure 2.

Devices

Seleck the derivative you would like to use

Soc to be used:

& New Processor Expert Project |:|@@

type filker text

{=I Kinetis
ME10D {100MHz)
ME20D {100MHz)
ME30D {100MHz)
MES4OD {100MHz)
MKESOD {100MHz)
- MKEOD { 100MHz)
MEBODMNZE6Zxx10
MEBODMNS 0
MEBODXZSEZ:00x10

Creates project for MKEODMNS 127500210 derivative

@j [ < Back ” Mexk >

Cancel

Figure 2. New Processor Expert Project Wizard— Devices Screen
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6. Select the target derivative to be used for the project and click Next to display the Rapid
Application Development screen (Figure 3).

= Mew Processor Expert Project I/\\, = @

Rapid Application Development

Processor Expert, Device Initialization

Rapid Application Development
Device Initialization

@ Processor Expert

Start with perspective designed for

Hardware configuration (pin muxing and device initialization)

@ Use current perspective

Initialize all peripherals

Processor Expert can generate for you all the device initialization code. It »
includes many low-level drivers,

(N < Back || et » | ‘ Einish | | Cancel

Figure 3. New Processor Expert Project Wizard - Rapid Application Development Screen

7. Select the type of project, Processor Expert or Device Initialization.

8. Click Next to display the Processor Expert Target Compiler screen shown below. This screen
lets you select the target C compiler for which the project will generate code (the target compiler
can be later changed in the ‘Build options’ tab of the CPU component).

Processor Expert Software — Microcontrollers Driver Suite Getting Started Guide, Rev. 2

Freescale Semiconductor



= Mew Processor Expert Project L,\, o || -E| )

Processor Expert Target Compiler
Target compiler

Target cumpller

CodeWarrmr ARM C Compiler
GMNU € Compiler
IAR ARM C Compiler

@ Next > Einish ] ’ Cancel

Figure 4. New Processor Expert Project Wizard - Processor Expert Target Compiler Screen

Select the required target C compiler and click Finish to create the Processor Expert project. The
Processor Expert perspective is displayed as shown in figure below. The project HelloWorld is
created and appears in the Project Explorer view. The other views of the Processor Expert

perspective are also shown below.
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= C/C++ - HelloWorld/Sources/ProcessorExpert.c - Eclipse
File Edit Source Refactor MNavigate Search Project Run  pVision Processor Expert Window Help

E=N Nl )

\.¢| ProcessorExpert.c &2
=0 JEE ~
: ProcessorExpert.c
1 ProcessorExpert
: MK6BDN256ZVLQLe
: Driver @1.81
: GNU C Compiler
1 2912-89-19, B8:18, # CodeGen: @

5. Components - HelloWorl 22
TG mE 7| ..

4 [= Generator_Configurations

& FLASH .
= 05 -

4 = Processors

P EpuMKﬁOIE)Ni‘EG%VLE}lU [£ Problems 2 . ¥ Tasks Bl Console| = Properties

= Components 1 items
=
Description Resource Path Location Type
i Infos (1 item)
o~ Writable Smart Insert A3l

i B - Eraivdv@r Re®r @ B0~ QL @O v g [m & (@ c/cer
&~ &l - - -
L7 Project Explorer &2 = O |/%y Component Inspector - Cpu 22 Advanced Bpert Iy © — O[5z 0y = 2 =8
= <'===(> Properties . Methods | Events | Build options | Resources v
c
I HelloWorld i Name Value Details i Categories i
= Documentation
) CPU type MKG0DMN256ZVLQ10
= Generated_Code . Component Com...
. Clock settings
= Project_Settings (= CPU External
— Sources Initialization priority minimal priority 15 k=
= 2 Eventec Watchdeg disable yes = [z CPU Internal
E E\rentslh CPU interrupts/resets (= Logical Devic
. External Bus Disabled (= Operating Sy
|e| ProcessorExpert.c N B e
Clock configurations 1 =
% ProcessorExpert.pe N B
Clock configuration 0
|=| ProjectInfo.xml 5 R R
Clock source setting configuration 0
MCG mode FEI
System clocks
alepeo e AN ATIEN W ATICT KA i
=0

Filter on for MK60M512LQ100 (Hel

- =8

Figure 5. Processor Expert Perspective

The main views in the Processor Expert perspective are:
Project Explorer
Components
Component Inspector
Components Library
Problems

For more information on the Processor Expert perspective and its views in detail, refer the

Microcontrollers Driver Suite Processor Expert User Manual.

2.2

Adding Processor Expert Project to Existing Project

If an Eclipse project is already created in the Eclipse Environment (for example, a project for a third
party Eclipse plugin), it is possible to add the Processor Expert support to use generated code in this

project.

1. Run Eclipse environment.

2. Open the Eclipse project in which you want to add the Processor Expert support.
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3. Select File > New > Other from the IDE menu bar. The Select a Wizard screen appears.

& New |:E]

Select a wizard

—

Wizards:

= General

= CIC++

(= Cvs

= Processor Expert

Enable Processor Expert For Existing C Project:
[ Tasks

® [

Figure 6. Select a Wizard Screen

4. Click Next to open the Processor Expert Project File screen as shown in Figure 7.
5. Click Browse to select the project to which the Processor Expert project will be added.
6. Select Project Type as Processor Expert or Device Initialization.

= - B

Processor Expert Project File

This wizard creates a new Processor Expert project in existing
/T ++ project.

Project: | JHellovworld | [Browse... ]

Project Type
@ Processor Expert

() Device Initilization

@ [ <Back || Mext: | Finish

Figure 7. Processor Expert Project File Screen

7. Click Next to open the Target MCU selection screen as shown below. This screen lets you
select the target derivative to be used for the project.
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Processor Expert Project

Flease select karget MCL

Target MCU:
= = Kinetis

(= MKL0D (100MHz)

(= MK20D (100MHz)

(= MK30D (100MHz)

(2= MKADD (100MHz)

(= MKSOD (100MHz)

== MKEOD (100MHz)
4 MKEODNZSEZxxx 10
MG 0DNS 12250010
@ MKBODNESEZ 00k 10

@ [ < Back ][ Mexk = H Firiish H Cancel ]

oy

Figure 8. Target MCU Select Screen

8. Click Next to display the Processor Expert Target Compiler screen shown in Figure 4. This
screen lets you select the target C compiler for which the project will generate code (the target
compiler can be later changed in the ‘Build options’ tab of the CPU component).

9. Click Finish to create Processor Expert project. The Processor Expert perspective is displayed as
shown in Figure 5.

NOTE
The ProcessorExpert.c file placed in the Sources folder contains
definition of the main() function. If you are adding Processor Expert to
a project which already contains user code, it may be necessary to modify
the code. Some parts of the existing user code may also conflict with the
code generated by Processor Expert, for example, definition of the
interrupt vector table. It is recommended to back up the whole project
before the conversion.

3 Creating Simple Application

This section shows creation of a simple application, which blinks a LED and sends Hello World text to
the serial output.

NOTE

The project is designed to work with MK60DNS512ZVMD10 CPU and
Tower System Kit TWR-K60N512-KIT. However, it is not necessary to
have this hardware; the project can be created without it.
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3.1

Adding Components to Project

The HelloWorld application consists of four components:

CPU component MK60DN512ZVMDI10

GPIO_LDD which will control LED output, connected to PTA10 pin
TimerUnit_LDD which will provide periodical timing.

Serial_LDD which will send Hello World message to the serial output

To create the HelloWorld application:

1.

Create a new project for Kinetis MK60DN512ZVMD10 derivative. The new project will have
the CPU component automatically added when the project is created. See Creating New
Processor Expert Project.

To add components, select the Alphabetical tab in the Components Library window as shown
below.

% Components Library &3 =0
EdNAN
Cateqories | Alphabetical | Assistant | CPUs
Component Compaon,..
| T _LDD Logical De. ..
& CRC_LDD Logical De. ..
N DaC_LDD Logical De. ..
& pMa_LDD Logical De. ..
@ DMATransfer DD Logical De...
EJ Ethernet_LDD Logical De. ..
& FLASH_LDD Lagical De. ..
Logical De. ..
# 12C_1DD Logical De...

Figure 9. Components Library - Alphabetical Tab

Find the GPIO_LDD component and double-click on the component to add it to the project.
Find the TimerUnit_LDD component and double-click on the component to add it to the project.

Find the Serial_LDD component and double-click on the component to add it to the project. All
the components will be visible now in the Component view.
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L. Companents - kinetics 22 == - T =

== Generator_Configurations

# FLASH

=== 05z
M8 Mox1:mMoy

=|-[= Processars

-4 CpuMKLD4Z16vLF4
== Components

+-.= Referenced_Zomponents

B T11:TimerInt

+ B8 TIz:TimerInt

+- 84 a01:4ADC_LDD

+ 15 PT1:Init_PIT

Figure 10. Component View — List of Components

3.2 Configuring Components
The components are configured by defining/changing the values of the properties and enabling/disabling
methods and events. The Component Inspector view is used for accessing the component properties:

1. To configure CPU component, click on this component in the Component view to display
Component Inspector.

2. To match the CPU component settings to the parameters of the TWR-K60N512 board, set the
following properties:

System oscillator to Enabled

System oscillator > Clock source to External reference clock

System oscillator > Clock source > Clock frequency to 50.0

Clock source settings > Clock source setting 0 > MCG settings > MCG mode to PEE
Clock configurations > Clock configuration 0 > System clocks > Core clock to 48
Clock configurations > Clock configuration 0 > System clocks > Bus clock to 48

Clock configurations > Clock configuration 0 > System clocks > External bus clock to
24

Clock configurations > Clock configuration 0 > System clocks > Flash clock to 24

Processor Expert Software — Microcontrollers Driver Suite Getting Started Guide, Rev. 2
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‘%*Component Inspector &3 |Basic |F\dvanced Expert Il]h =

Properties |  Methods | Events |  Build options | Used |

Mame Yalue Details
CPU kype MEGODNS1 Z22vMD10
= Clock settings
=2 Internal oscillator
Slows inkernal reference « 32,768 32,768 kHz
Fast internal reference © 4.0 4 MHz
RTC oscillator Disabled
= System oscillator Enabled
= Clock source External reference clock
Clack Frequency [MF 50.0 50 MHz
= Clock source settings 1
= Clock source setting
= MCG settings
MCS mode FEE
MCE output [MH 45,0 45 MHz
MCG external re Syskemn oscillator
MCG external re 50,0 50 MHz
= FLL settings
FLL module  Disabled
FLL autput [I 0,0 0 MHz; FLL is disabled,
= PLL settings
PLL moduls  Enabled

PLL autput [I 45.0 45 MHz
Initialization priority rninimal pricrity 15
‘Watchdog disable yes
CPU interrupts/resets
External Bus Disabled
= Clock configurations 1
= Clock configuration 0
= Clock source setting configuration 0
MCG mode FEE
= System clocks
Core clack 458.0 48 MHz
Bus clock 4a.0 45 MHz

Flash clock 24.0 24 MHz

Figure 11. Component Inspector - CPU

3. To configure GPIO1 component, click on this component in the Component view to display
Component Inspector.
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% *Component Inspector £7 |Basic |Advanced Expert Il]h =
Properties |  methods | Events |
Marme Walue Details
Port FTA FTA
Port width 32 bits
Mask of allocated pins 400 .
Interrupt service/event Disabled
=] Bit fields 1
= Eit field
Field name LED_ELUE
= Pins 1
=] Pin
Fin PTALOJFTMZ_CHOJFTMZ_QD_PHAJT... PTALQJFTMZ_CHO/FTMZ_QD_PHA[T...
Pin signal

= Initial pin dire Qukput
Initial output o

Initial pin event  Disabled
Lock initialization no

=] Initialization
Auta intialization P N .
= Event mask
OnPortEvent Disabled

Figure 12. Component Inspector — GPIO1

4. Set the following properties:
Field name in the first Bit field group to LED_BLUE.
Pin to PTAI0. This pin corresponds to blue LED on the TWR-K60N512 board.
Initial pin direction to Qutput.
Auto initialization to yes to automatically initialize the component during startup.

5. To configure TU1 component, click on this component in the Component view to display the
Component Inspector.

% *Component Inspeckar £ |Basic |Advanced Expert |II|| =
Properties | Methods |  Events|
Mame Walue Details
Madule name PIT PIT
Counter PIT_CWALD PIT_CYALD
Counter direction Do
Counter width 32 bits
Yalue type Cptimal uink32_t
= Input clock source Internal
Counter frequency 45 [MHz 48 MHz
= Counter restart Cn-rakch
Period device PIT_LDWALD PIT_LDWALD
Period 0.5 sec 0,500 sec
= Interrupt Enabled
Inkerrupt priority mediurm prioricy g
Channel list ]
=2 Initialization
Enabled in init, code yes
Auko initislization
Event mask

Figure 13. Component Inspector - TU1
6. Set the following properties:
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Counter to PIT _CVALO
Counter direction to Down

Counter restart to On-match. This will allow setting desired period of interrupt, otherwise
interrupt invocation period is fixed to counter overflow.

Counter frequency - Use the available button and select the only value offered in the right
pane: 48 MHz.

Counter restart > Period - Click on the available button and set Init. value to 0.5 sec
Interrupt to Enabled
Auto initialization to yes

7. To configure AS1 component, click on this component in the Component view to display
Component Inspector.

%*Component Inspector &3 Basic |Adwvanced  Expert H]Ih] =

Propetties Methods Events
Mame Yalue Details
Device LARTS UARTS
= Interrupt service/event Enabled
Interrupt RxD priority medium priarity i
Interrupt TxD prioricy mediurm priority 8
Inkerrupt Error priority miediurn prioriky g
= Settings
Data width & hits
Parity Mone
Stop bits 1
Loop mads Mormal
Biaud rate 9600 baud 9600 baud

Skop in wait mode
Idle line mode

no
Skarts afker stark bit

= Receiver Enabled
R PTCI6/CANL_R%JUARTS_RXJENETO ... PTCIB/CANI_REUARTS_RX/ENETO_...

= Transmitter Enabled
TxD PTCI7ICANL_TH/UARTI_TH/EMETO ... PTC17JCAMI_THXUART3_THEMETO ...

= Initialization
Enabled in init. code yes

T - I

CnBlockSent Enabled

OnBlockReceived Enabled

OnTxComplete Disabled

OnError Disabled

COnBreak Disabled

Figure 14. Component Inspector - AS1

8. Set the following properties:

Device to UART3 (the Tower serial board is connected to the UART3 port on the TWR-
K60N512 board, using pins PTC16 and PTC17)

Baud rate - Click on the available button and set Init. value to 9600 baud
RxD to PTC16

TxD to PTCI17

Auto initialization to yes
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3.3 Generating Code

Select Project > Generate Processor Expert Code in the IDE menu to generate code. This process
generates source files for components to the Generated_Code folder in the Project Panel view. Other
modules (ProcessorExpert.c and Events.c) can be found in the Sources folder.

3.4  Writing Code

The Processor Expert components provide API, which is used by user code. Initially, you can put the
code into the ProcessorExpert.c file, which is automatically created by Processor Expert:

1. In the Project Explorer view, expand the Sources folder and double-click on the
ProcessorExpert.c module to open the file in the editor.
L™ Project Explorer &3 —| "= ¥ =0
= 1== kinetics
+-[= Documentation
+-[= izenerated_Code
+-[.= Project_Settings
- = Sources
% ProcessarExpert, pe
125 mg
125 mew
e proj-sim
+ E scl
= vb
= wybrid

+

+

Figure 15. Project Explorer - Main Module

2. In the ProcessorExpert.c file, do the following modifications:
Declare global variable with the message:
char HelloWorld[] = "Hello world";

In the main() function after PE_low_level_init(); call the SendBlock function to send the
message:

AS1_SendBlock(AS1 DeviceData, HelloWorld,sizeof(HelloWorld)-1);

Processor Expert Software — Microcontrollers Driver Suite Getting Started Guide, Rev. 2
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|.c| *ProcessorExpert.c &0

#include "PE_Const.h”
#include "I0 Map.h”

f% Uzer includes (finclude below this line iz not maintained by Processor
char HellaoWorld[] = "Hello world™;
void main (void)
{
f% Write your local varishle definition here %/
f %% Processor EXxpert internal initiaslization. DON'T REMOWE THIS CODE!!!
PE low level init(}:

f**%* End of Processor Expert internal initialization.

/% Write your code here */
451 SendBlock (AL31 DeviceData, HelloWorld,sizeof (HelloWorld)-1):

%% Don't write any code pass this line, or it will be deleted during c

J %% Processor Expert end of mwain routine. DON'T MODIFY THIS CODE!!! #%%

for(:;){}

/*#%% Processor Expert end of wmain routine. DON'T WRITE CODE EELOW!!! #+%
¥ /%% End of main routine. DO MNOT MODIFY THIS TEXET!!! ###%/

Figure 16. ProcessorExpert.c File

3. In the Component view, expand the list of events and methods of TU1 component.

4. Right-click on TU1_OnCounterRestart and select the View Code command from the pop-up
menu to open the code of TU1_OnCounterRestart in the editor.

LR WHIU Lk _LUU 3

-] TUL:TimerLinit_LDD ¢
..... W 1t ¢

----- M Deinit W

..... ¥ Enable =1

----- M Disable

----- ,E'—il GetInputFreguencyReal

----- ,E'—!| GetInputFrequency

----- M| SetPeriodTicks

----- M GetPeriodTicks

----- ,E'—1| ResetCounter

----- H| GetCountervalue =)

..... ,ﬁli' o

S

View Code
Toggle Enable Disable

Figure 17. View Code

5. Insert the following lines (toggling LED output) into the TU1_OnCounterRestart event
handler function body:

GP101_ToggleFieldBits(GP101_DeviceData,LED BLUE,1);

The application is complete and can be compiled and run using a third party toolchain.

4 Using Generated Code

Processor Expert uses the following sub-directory structure within the project directory:
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Generated_Code — the directory containing all generated source code modules for components.
Documentation — the directory with the project documentation files generated by Processor
Expert.

Sources — the directory for main module, event module and other user modules.
Project_Setings\Linker_Files — the directory containing linker file generated by Processor Expert

Project_Setings\Startup_Code — the directory containing the Processor Expert startup code
(compiler dependent)

4.1 Project Include Path

Set the following paths in the settings of the target IDE to correctly use the code generated by Processor
Expert with a third party C compiler:
{ProjectDirectory}\Sources
{ProjectDirectory}\Generated_Code
For Kinetis family, set the following paths:
{ProcessorkExpertDirectory}\lib\Kinetis\iofiles
{ProcessorExpertDirectory}\lib\Kinetis\pdd\inc
For ColdFire+ family, set the following paths:
{ProcessorExpertDirectory}\lib\ColdFirePlus\iofiles
{ProcessorExpertDirectory}\lib\ColdFirePlus\pdd\inc

The default location of the Processor Expert directory depends on the operating system and user rights.
By default, the Processor Expert directory is created as a subdirectory of the Eclipse installation:

{eclipse}\ProcessorExpert

The actual location can be found in the preferences of Processor Expert. Select Window > Preferences
> Processor Expert > Processor Expert Service to view the actual location.

Processor Expert Software — Microcontrollers Driver Suite Getting Started Guide, Rev. 2
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= Preferences
type filker text

. General

» CfC++

. Doxygen

» Help

. Install/Update

. Mylyn

4 Processor Expert
General
Paths

. Remote Systems

. Run/Debug

. Team

. Usage Data Collector

uVision

% ':'@

Paths =T v -

Processor Expert directories configuration:
Select PEx directory DAPExDr10.0_3.7_testd\eclipse\ProcessorExpert Browse...

Ch\ProgramDatat\Processor Expert\PEXDRV_PES5_3

Figure 18. Processor Expert Directory Location

4.2 Project Linker File

Linker file specific for the selected target CPU and compiler is generated by Processor Expert. The file
is stored at the following location: {pProjectDirectory}\Project_Settings\Linker Files

The name of the linker file is ProcessorExpert, extension of the linker file is compiler specific.

The code generated by Processor Expert components is tailored to the selected target compiler. Make
sure that the selected compiler matches used build tools. The target compiler is selected during project
creation. It can be later changed in the Build options tab of the CPU component.
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% *Component Inspector 2

| Properties || Methods || Events | Build options |Used |

Mame walue D

Compiler
= Unhandled vectors
Unhandled int code

Cne handler for all

IR

Properties | Methods E\-'ents: Build options | Used

= User initialization
User data declarations |
User code before PE initializal| |

Yalue D
CodeWarrior &RtM C Compiler ~

MName
Cornpiler
= Unhandled vectors
Unhandled ink code
= User initialization
User data declarations
User code before PE initializati

% *Component Inspector £

| Properties || Methods || Events | Build opkions |Used |

Yalue
TAR ARM C

Mame

M-

Compiler

= Unhandled vectors
Unhandled int code
FLASH reqisters initialization
= User initialization
User data declarations

One handler for all
2lineis) Select ko view) edit
Enabled

Olineis) Select ko view edit

User code before PE initialization 0lines) Select bo view/edit

Figure 19. Changing Target Compiler

5 Importing Example Projects

The Microcontrollers Driver Suite comes with a set of example projects. The example projects are stored
in the ProcessorExpert\Projects folder. To import an example project:

1. Select File > Import to open the Import wizard shown below.
2. Select General > Existing Projects into Workspace.

& Import |:

Select

Create new projects from an archive file or directory.

Select an import source:

== General

@; archive File
=

n
[, File 5y
=L Preferences

= i+

= s

(== Run/Debug

(= Tasks

= Team

2R R R IR}

®@

Figure 20. Import Screen

= Back. Einish

3. Click Next to display the Import Projects screen.
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4. Click Browse to select the ProcessorExpert\Projects folder. The Projects list box lists all the
projects available for import.

& Import |:@

Import Projects
Select a directory ko search For existing Eclipse projects. @

-

(&) Select root dirsctory: | pertiProjectsiMWR-KEONS 12, | Browse. .,

() Select archive file: | | Browse. ..

Projects:

CAN (CHiPExDrvieclipselProcessorExpertiPro; A Select Al
DA (CHPExDrv eclipselProcessorExpertiPro

Ethernet {Z:\PExDrveclipse'\ProcessorExpert Deselect Al

[ 15 A BT arlinest BrarecentFvnar Droi

< | 3

Copy projects into workspace

Working sets
] add project ko working sets

Select. ..

@ Mext = [ Finish H Cancel ]

Figure 21. Import Projects Screen

5. Check all projects that you want to import into your workspace. To copy the example project
into your workspace, check the Copy projects into workspace checkbox.

6. Click Finish to import selected projects.
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