
 
 
 
 
 
 
 

ASTER Processing Manual 
 

Compiled by Aleks Kalinowski  
and Simon Oliver 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Remote Sensing Applications 
Geoscience Australia 

October 2004 



 
Contents  

 
  

i. Introduction         2     
ii. Useful References 
        
Processing steps (for L1B scenes) 
 
1. Obtaining ASTER scenes       4 
2. Crosstalk Correction         4 
3. Importing into ER Mapper       6 
4. Image Rectification        11 
5. Radiance Calibration        13 
6. Dark Pixel Correction       16 
7. Registering ASTER images to Landsat     18 
8. Tips          21 
9. ASTER Band Ratios        22  
 
Some Useful Hints for Beginners  
 
10. Changing Format of PIMA Spectra Using SPECWIN   24  
11. Creating a Spectral Library in ENVI     27 
12. Using ENVI's Spectral Analyst to Determine Mineralogy   30 
13. Resampling Library Spectra to ASTER Band Resolution  31 
14. Minimum Noise Fraction Images      32 
15. Principal Components Images      34 
16. Decorellation Stretch Images      36 
17. Writing Scripts with ER Mapper      37 
  
 

     
 

 

 1



i. Introduction 
 
ASTER is the Advanced Spaceborne Thermal Emission and Reflection Radiometer, a multi-
spectral sensor onboard one of NASA’s Earth Observing System satellites, Terra, which was 
launched in 1999. ASTER sensors measure reflected and emitted electromagnetic radiation 
from Earth’s surface and atmosphere in 14 channels (or bands). There are three groups of 
channels: three recording visible and near infrared radiation (VNIR), at a spatial resolution of 
15m; six recording portions of shortwave infrared radiation (SWIR) at a spatial resolution of 
30m; and five recording thermal infrared radiation (TIR) at a resolution of 90m. The higher 
spectral resolution of ASTER (compared to Landsat, for example - Fig.1) especially in the 
shortwave infrared region of the electromagnetic spectrum makes it possible to identify 
minerals and mineral groups such as clays, carbonates, silica, iron-oxides and other 
silicates. An additional backward-looking band in the VNIR makes it possible to construct 
digital elevation models from bands 3 and 3b. ASTER swath width is 60km (each scene is 60 
x 60km) which makes it useful for regional mapping. 
 

 
 
Figure 1. Distribution of ASTER and Landsat channels with respect to the electromagnetic spectrum.  
 
There are a few things to note when using ASTER imagery for regional mineralogical 
mapping. Firstly, cloud cover, vegetation and atmospheric effects can severely mask or alter 
surface signals. Secondly, bands and band ratios do not indicate the occurrence of a mineral 
with absolute certainty or with any idea of quantity, so ground truthing and setting 
appropriate thresholds is essential. Thirdly, every terrain is different, so ratios which work in 
some areas for a particular mineral or assemblage may not show the same thing elsewhere. 
As a result of these factors, it is important not to look at ASTER images in isolation from 
other data. If possible, datasets such as geology and structural maps, geochemistry, PIMA 
analyses (ground truthing), radiometrics, and any other available data should be used in 
conjunction with ASTER for best results.    
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The processing steps described in the first part of this manual are relevant only to ASTER 
level 1B scenes. Level 1A scenes (in a less processed form) must be imported using image 
processing software such as Rastus. 
 
 
ii. Useful References 
 
For tutorials on remote sensing and image processing: 
 
• Canada Centre for Remote Sensing tutorial 

http://www.ccrs.nrcan.gc.ca/ccrs/learn/tutorials/fundam/fundam_e.html  
• NASA tutorial  http://rst.gsfc.nasa.gov/ 
• List of online tutorial sites  http://www.geography.eku.edu/Geo355/links.htm  
• ENVI hyperspectral analysis tutorial  http://www.ltid.inpe.br/tutorial/tut8.htm  

 
For more general information on ASTER: 
 
• ERSDAC  http://www.ersdac.or.jp   
• NASA TERRA website  http://terra.nasa.gov   
• NASA ASTER website  http://asterweb.jpl.nasa.gov                                                                                    
• CSIRO  http://www.syd.dem.csiro.au/research/MMTG/Exploration/ASTER/ASTER.htm 

 
Publications on ASTER and relevant authors: 
 
• NASA reference list  http://asterweb.jpl.nasa.gov/publications/aster-biblio-journals.pdf 
• Hewson, R. (CSIRO). 
• Rowan, L. (USGS), Abrams, Mars 
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1. Obtaining ASTER scenes  
 

1) Identify and define the area you want ASTER scenes for (either as a box or a point of 
interest in Lat / Long).  

2) Go to the ACRES Digital Catalogue website (http://acs.auslig.gov.au/intro.html). 
3) You will need to obtain a login - follow the instructions. 
4) On the website you will find the document "Procedures for accessing ASTER satellite 

image data on ACRES Digital Catalogue". This contains complete instructions on 
how to find your data. The ASTER scenes are stored on DVD at Geoscience 
Australia - contact an ACRES or RSA person to gain access to the DVDs.  

5) Copy your selected scene(s) to your hard drive or CD (generally it is better to have 
the scenes on your hard drive to speed up processing).  

 
2. Crosstalk Correction 
 
Crosstalk is an effect in ASTER imagery caused by signal leakage from band 4 into adjacent 
bands 5 and 9.  
 
"The primary band causing most of the cross talk problem is band 4. What they believe is 
happening is that some of the incident photons onto the band 4 detector plane are reflected 
(not a surprise since even a perfect, single detector can reflect as much as 30% of the 
incident light). The problem is that there are no baffles or other structures blocking light from 
band 4 bouncing around to the detectors for the other bands. Basically, the detectors are 
arranged in a rectangular geometry and the top of the rectangle contains all of the filters for 
all of the bands. The bottom contains the detectors for all bands (and all of the detectors 
have the same spectral response). Once an incident photon enters, it is basically trapped 
until some detector collects it. If the band 5 detector gets a photon through the band 4 filter, 
cross talk occurs. 
 
The basic problem is that the solar output in band 4 is considerably higher than the other 
SWIR bands. Hence, even a small number of band 4 photons leaking out can have a big 
effect in the other bands. The effect is largest in bands 5 and 9 because those detectors are 
physically the closest to the band 4 detectors. The correction at this point is assumed to be 
an offset based on the pixels location in the scene. Essentially, a Gaussian distribution is 
drawn around the pixel of interest in band 9 (for example). The band 4 scene is then 
examined to determine the radiance of each pixel within the Gaussian, and then the 
contribution due to cross talk from each of these pixels is determined by the radiance of the 
pixel and the Gaussian value acting as weighting function." (Rob Hewson, MMTG, 
Exploration and Mining, CSIRO. 22nd ASTER Science Meeting, 
(http://www.cossa.csiro.au/reports/hewson/22aster.htm)) 
 
 

1) There is a handy tool that automatically corrects your scene for crosstalk. Download 
and install the ERSDAC Crosstalk 3 tool from 
http://www.gds.aster.ersdac.or.jp/gds_www2002/service_e/u.tools_e/set_u.tool_ecro
ss.html . You will need a zip file extractor that can handle Japanese versions (e.g. 
Power Archiver 2001 or later).  

2) The tool comes with instructions in PDF, but you may have to download the 
Japanese Language Package for Acrobat Reader from the Adobe site if the 
document isn't opening properly.  

3) Navigate to Start menu → Programs → Crosstalk3 → Data IO Setup. The dialog box 
below opens.  
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4) On the left of the dialog box, select your (uncorrected) input image(s) by clicking on 
the  button to the text field. Only HDF or DAT file formats are accepted. A 
corresponding output file name will appear on the right (it is the same name but with 
"_chg" appended to the name). You can process up to 10 images at a time. 

5) Go to File → Start Process to correct the images. Close the dialog when finished.   
 

                           
 
 
Back to contents
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3. Importing Images Into ER Mapper 
 
A raw ASTER dataset contains all 14 bands. However, ASTER data consists of three types 
of datasets, each with a different spatial resolution, so each must be treated independently. 
The three datasets are VNIR (Visible and Near Infrared, bands 1-3), SWIR (Short-Wave 
Infrared, bands 4-9) and TIR (Thermal Infrared, bands 10-14). They have spatial resolutions 
of 15, 30 and 90m respectively. Two ways of importing ASTER datasets into ER Mapper are 
described below. The first method describes how to manually import the data, while the 
second makes use of the HDF Import Wizard. It is worthwhile going through the process 
manually at least once so that you know what is being done to the data every step of the 
way.  
 
Method 1: Manually importing the dataset 
 
A. Construct the VNIR dataset 

1) Start ER Mapper and open the algorithm window with a new image window. You 
should have one Pseudo layer in the empty algorithm. 

2) Load your crosstalk-corrected HDF file into the pseudo layer. 
3) Duplicate the layer twice (total of three layers). 
4) Select VNIR:band 1 for layer 1 and rename the layer to reflect the original band 

number (e.g. B1). 
5) Select VNIR:band 2 for layer 2 and VNIR:band 3 (3N not 3B) for layer 3 and rename 

the layers. 
 

 
 
6) Save the dataset as an ER Mapper raster dataset (.ers). The dataset should be 

saved as an 8-bit unsigned integer with 15m pixels (pixel width & height). Make sure 
output transforms are deleted and be sure to give the file a meaningful name, for 
example, reflecting the level of processing that has been applied.  
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B. Construct the SWIR  dataset 

1) Open a new algorithm window (or a new image window). You should have one 
Pseudo layer in the empty algorithm. 

2) Load your crosstalk-corrected HDF file into the pseudo layer. 
3) Duplicate the layer five times (total of six layers). 
4) Select SWIR: band 4 for layer 1 and rename the layer to reflect the original band 

number (e.g. B4). NB: Be careful not to load band 3B into band 1 of your algorithm 
(the real SWIR band 4 is actually called band 5 in the HDF dataset).  

5) Select SWIR: band 5 for layer 2 and repeat for the other layers up to band 9. 
Rename the layers. 

6) Save the dataset as an ER Mapper raster dataset (.ers). The dataset should be 
saved as an 8-bit unsigned integer with 30m pixels. Ensure output transforms are 
deleted.  

 
C. Construct the TIR raster dataset 

1) Open a new algorithm window (or a new image window). You should have one 
Pseudo layer in the empty algorithm. 

2) Load your crosstalk-corrected HDF file into the pseudo layer. 
3) Duplicate the layer four times (total of five layers). 
4) Select TIR: band 10 for layer 1 and rename the layer to reflect the original band 

number (e.g. B10).  
5) Select TIR: band 11 for layer 2 and repeat for the other layers up to band 14. 

Rename the layers. 
6) Save the dataset as an ER Mapper raster dataset (.ers). This dataset should be 

saved as 16-bit unsigned integer with 90m pixels. Ensure output transforms are 
deleted.  
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Method 2: Using HDF Import Wizard 
 
The HDF Import Wizard allows you to convert ASTER HDF data to native ER Mapper format. 
This tool allows you to import the dataset at different spatial resolutions, for example, 
importing VNIR data at 30m instead of 15m, and combining bands with different spatial 
resolutions (Note: You can also do this manually using the algorithm window).  
 

1) You can start the HDF Import Wizard from either the Wizards or Batch Processing 
toolbar (to add a toolbar to the main menu, go to Toolbars → tick Wizards or Batch 
Processing). Click the  button. The HDF Import Wizard appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2) Select whether you want to import one or multiple files and click Next.  
3) On the next panel, select your raw (crosstalk corrected) ASTER HDF input file and 

tick the box next to Produce .ers raster image. Type in a name for your output dataset 
and click Next.  
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4) 

e box. 
Click 

 
5) 

x - the wizard will automatically choose the 
cell size fro

 

On the next panel, you have the option of rotating the scene to true north (accounting 
for the rotation of the image due to the orientation of the satellite as it makes its 
pass). You can use this option or manually rotate the image later. Here you also have 
the option of setting a null value for null cells in the image. Type "0" into the Null 
Value text field if it isn't automatically there, and tick the Use a null cell valu

Next.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The next panel allows you to set cell attributes. Most importantly, it allows you to set 
the output cell size, which is chiefly useful if you are going to import bands with 
different resolutions into one dataset. To do this, tick the Custom cell size box. For 
example, if you are importing the VNIR and SWIR bands together, you can set the 
cell size to 15m or 30m for all bands. You then need to choose a resampling method 
(cubic is recommended). If you are importing bands with the same spatial resolution 
then don’t check the Custom cell size bo

m the metadata. Click Next.  
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6) The next panel is where you choose the bands you want to include in the final raster 
image. You can either enter the band numbers or select them from the list (click the 

 button on the right). Click Next. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7) The final panel and a batch status window appear. Check the batch status window to 
see what is being done to the image. Click Finish when the process has finished. You 
can now go to Step 5 - Radiance Calibration if you rotated your image to true north, 
or go on to Step 4 - Image Rectification if you haven't rotated your image yet.   

 
 
 
 
 

 
 
 

 
A disadvantage of using this wizard is that you can't set the method by which the dataset is 
saved (i.e. 8-bit, 4-byte etc.). It does save a bit of time but doing the same process manually 
is not particularly difficult or time consuming and therefore could be a better option.  
 
 
Back to contents 
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4. Image Rotation 
 
At the moment the images you have loaded are in satellite orientation, i.e. they are rotated 
with respect to the surface because the satellite does not travel exactly N-S on its passes. 
The image must be therefore be rotated back into map orientation (it is already projected, 
generally in WGS84 and UTM). You need to find what angle the image must be rotated 
through before using the Geocoding and Orthocorrection Wizard to rotate the image. (Note: 
if you used the HDF Import Wizard to convert your HDF files to ER Mapper format and you 
have already rotated your datasets then you can skip this step.)  
 

1) Go to File → Open (or press the  button in the main toolbar). 
2) Highlight the VNIR dataset you made in the previous section but don't open it. 
3) Click on the Info… button -  a new window will pop up with some metadata about the 

image (see below).  
4) Find Rotation in the list and take note of the angle. Close all of the windows.  

 

 
 

5) From the Process menu on the main toolbar open the Geocoding Wizard. The 
geocoding dialog box opens with several tabs (see below). 

6) Click on the first tab, Start, if it isn’t already selected. Select an Input file and set the 
Geocoding Type to Rotation.  

7) Click on the second tab, Rotation Setup. Here you will need the rotation angle you 
noted earlier. Type the rotation angle into the text box but multiply it by -1 (i.e. if you 
originally had a positive rotation angle, now it will be negative and vice versa). This is 
to make sure the image is rotated in the correct direction.  

8) Click on the final, Rectify tab. Select a meaningful output filename and pixel size (by 
default the pixel size should already be set to be the same as your input dataset). 
Cubic Convolution is the recommended Resampling method.  
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9) Click the Save File and Start Rectification button.  
10) Repeat the process for the SWIR and TIR datasets (the rotation angle will be the 

same as your datasets came from one original dataset).    
 
NB: This process is not necessary if your rotation angle is originally '0'. This happens for 
example when you've processed the image from Level 1A to Level 1B using Rastus and 
ENVI.  
 
 
 
 
 
 
 
 
 
 
 
 
 
Tip. Occasionally, after rotating your dataset back to zero, there is still a tiny rotation angle in 
the metadata of the dataset which you can't see (e.g. 0.0000001). This isn't a problem until 
you want to use the dataset in other software packages, such as ENVI, when the rotation 
angle prevents the software from reading the projection information correctly. To fix this 
problem, go to File → Open → Info… → Edit → Coord Space → Type "0" in the Rotation 
field (even if it seems to say "0" already). This will get rid of any tiny fractions of a rotation 
angle that might be there. It will not affect your dataset. Make sure you save changes.  
 
Back to contents 
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5. Radiance Calibration 
 
Radiance calibration is a process of rescaling the digital values to observed top of 
atmosphere radiance values. Scaling the sensor signal to 8-bit data is important for reducing 
information loss. Each ASTER HDF dataset contains scaling values (unit conversion factors 
→ UCF) which can be applied using the ER Mapper formula tool and the formula           
(Input1 - 1) × unit conversion factor. To retrieve the UCF it is necessary to first download the 
ASTER Data Opener, a tool which allows you to see the dataset's metadata.  
 

1) Download the ASTER Data Opener from the website 
http://www.gds.aster.ersdac.or.jp/gds_www2002/service_e/u.tools_e/set_u.tool_ecro
ss.html 

2) Start the data opener (the executable). In the dialog box, click the Ref button to 
choose a dataset (you must set file type to "all files" to see HDF format). You will see 
some information about the scene, as shown below.  

 

 
 

3) Click the Details button to obtain a more complete version of the metadata. About 
halfway down the page you will see Unit Conversion Coefficients listed for each band. 
The scaling factor you will use is the first (positive) number for each band.  
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4) Open a new image window and the algorithm window.  
5) Load your VNIR rectified dataset into the algorithm and assign each band to a new 

layer (layer1 = band1, layer2 = band2 etc.). Rename each layer to represent the 
original data band (B1, B2, B3).  

 

 
 

6) Select the first layer and open the formula editor.  
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7) Type in the formula (Input1 - 1) ×  UCF (in this case the UCF for VNIR:band 1 is 
0.676). Press Apply Changes. Repeat this process for every band in the algorithm, 
inserting the appropriate unit conversion factor each time.  

 

 
 
Tip: In the algorithm window, load the dataset into one layer. Type in the formula in the 
formula editor. Duplicate the layer, choose appropriate bands for each layer and rename the 
layers as required. Finally, go to the formula editor for the duplicated layers and edit the UCF 
to correspond with the band in that layer. This saves you typing out the formula many times.  
 

8) When finished, save the image as a raster dataset. This time, save it as a 4-byte real 
image. This is to preserve the original data integrity especially given radiance 
decreases with increasing wavelength (and band number). The pixel size remains 15, 
30 or 90m depending on the dataset. Ensure the Delete Transform button is checked.  

9) Repeat the process for the SWIR and TIR rectified datasets.  
 
 

Back to contents 
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6. Dark Pixel Correction 
 

Dark pixel correction is a simple method used to account for the effect of atmosphere on 
image radiance, related to additive scattering contributions (there are also multiplicative 
transmission effects which won't be corrected by this). This is a statistical method whereby 
the minimum value for each dataset is subtracted from the data. This minimum value is 
taken to represent / approximate the effect of atmosphere.  

 
1) Load your radiance-corrected dataset from the previous section into a new algorithm 

window. Again, assign each band to a different layer and rename the layers 
according to the original bands of the dataset.  

2) On the main toolbar, navigate to Process → Calculate statistics. In the dialog box, 
select the dataset you want to calculate statistics on (the one you've just loaded into 
the algorithm window) and set Subsampling Interval to 1. Just to be safe, you can 
check the Force recalculate statistics box. Press OK.  

 

 
 

3) Once ER Mapper has finished calculating statistics, you can close the statistics 
windows (or view the statistics and determine the minimum value for each band in the 
dataset). 

4) Select the first band in the algorithm and open the formula editor. Type in the formula 
I1 - RMIN(,R1,I1). RMIN gives the minimum value for a particular band; R1 specifies 
the region of interest (in this case, the whole scene) and I1 specifies the input band. 
Do this for each band. 
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Tip: In the algorithm window, load the dataset into one layer. Type in the formula in the 
formula editor. Now duplicate the layer, choose appropriate bands for each layer and 
rename the layers as required. This saves you typing out the formula many times.  
 

5) Save the dataset as an ER Mapper Virtual Dataset (put "VDS" in the filename so you 
can distinguish it from real datasets easily). The virtual dataset is really an algorithm 
that is saved to look like a dataset, but it actually references the original dataset(s) (in 
this case, the file you just created references your radiance-calibrated dataset, so any 
changes to that dataset will also be reflected in the VDS). Alternatively, save it as a 4-
byte real dataset for future work. Ensure rotation is "0" in the header file, else there 
could be problems importing the image into ENVI (see the Tips section at the back of 
this manual).  

6) Repeat this process for your other radiance-corrected datasets (SWIR and TIR).  
 
 
Back to contents
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7. Registering ASTER image to Landsat pan image 
 

Rotating ASTER scenes (as described in previous steps) puts the data in the correct 
orientation but not necessarily the correct position relative to the ground or to other ASTER 
scenes or bands. One way of correctly rectifying the ASTER scene is to register it to the 
Landsat pan mosaic image of Australia. The Landsat pan mosaic covers the entire continent 
and has been registered to differential GPS points around Australia. As such, it is accurately 
registered relative to the ground. Because it has a resolution of 12.5m, it is accurate enough 
to be used as a basis for registering other types of remotely sensed data such as ASTER. 
The visible bands, having pixels closest in size to the Landsat bands, will be most obviously 
affected by displacement and will need the largest block shift. The SWIR bands, having 
pixels twice as large, will be affected but only half as much as the VNIR bands; and the TIR 
bands, with pixels 6 times the size of the VNIR bands, must be adjusted by 1/6 of the shift 
experienced by the VNIR (which means they rarely need to be shifted). Normally the 
displacement between the Landsat image and the VNIR ASTER image will be between 0 to 
10 pixels (E-W and/or N-S). 
 

1) Open a new algorithm and image window.  
2) Change the colour mode to red-green-blue and delete the blue layer. 
3) Open Band 3 of the VNIR ASTER image into the red layer only and adjust the 

transforms (or use the shortcut Refresh image with 99% clip  button). 
4) Open the Landsat image: O:\Mount_Isa_Working\ETM_pan_mosaic_DN.ers (or 

equivalent reference image) into the green layer only and adjust the transform. 
5) With the two layers displayed together, zoom in and pan around the image and 

identify areas with misaligned red and green pixels. These are areas that show how 
much the ASTER image is displaced from the Landsat image. Good areas to look at 
are roads, airstrips, and road intersections; bad areas are water, rivers, lakes, 
because water levels are prone to change, and the images were almost certainly 
taken at different times and seasons. Ignore clouds (red). Turn off the smoothing 
option to better see individual pixels.  

6) Zoom in on a feature where the red and green pixels are not aligned, like a road 
(below left). As you can see, the road that appears in the red image is offset to the 
left from the green. Decide whether the feature is displaced to the east or west, north 
or south relative to Landsat, and by how many pixels (zoom in to do this). The feature 
will appear yellow when the two datasets are exactly aligned (red + green = yellow) 
(below right). 
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7) In the algorithm window, right-click on the red layer (containing the ASTER image) 
and select Properties from the bottom of the list. 

8) In the Dataset Information dialog box, click Edit. 
9) In the Dataset Header Editor, click Raster Info. 
10) In the Dataset Header Editor: Raster Information box, click Registration Point. The 

Registration cell, by default, is (0,0) i.e. the top left cell in the dataset. The 
Registration coordinates are the ground coordinates that the top left cell is assigned 
to. It is possible to change the ground coordinates, but much easier to pick a better 
registration cell.  

 

 
  

s displaced from the Landsat. If the 

+ve x: moves image east (i.e. you want to assign the e-n coordinate to a point 
further to the west than (0,0)) 
-ve x: moves image west (i.e. you want to assign the e-n coordinate to a point 
further to the east than (0,0)) 
+ve y: moves image north (i.e. you want to assign the e-n coordinate to a 
point further to the south than (0,0)) 
-ve y: moves image south (i.e. you want to assign the e-n coordinate to a 
point further to the north than (0,0)) 
 

12) Save the changes and assess your image again. You may need to repeat the 
process to get an exact fit (this is a trial and error process).  

13) Repeat this process for your corresponding SWIR dataset. The displacement amount 

14)

o be moved.   
 
 
 
 
 
 
 

11) Estimate how many pixels the ASTER image i
ASTER image is too far west, you need to move it east, as in the example above. 
Here, the registration point was first changed to (3,0), and this became the cell 
associated with the eastings and northings listed. The entire image shifted to the 
east. Next, the image was too far to the north, so to move it south, the registration 
point was changed to (3,-1). The rule is: 

 

will be half the value of the VNIR, as SWIR pixels are twice as large as VNIR pixels 
(e.g. in the example above, make the new SWIR registration pixel ~(1, 0)). 
 You probably won't need to repeat the process for the TIR dataset - the pixel size is 
too large to show much effect. The TIR dataset needs to be moved by 1/6 of the 
amount that the VNIR image is moved. Usually the overall shift is less than 6 pixels, 
so the TIR dataset doesn't usually need t
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Example: The
represent a ro ge, the ASTER scene is offset to the west 
from the Landsat scene. It must be moved to the east to align with the road as depicted in 
the
 
  

  

 
 

 image on the top right. 
s you can see, the images are now more closely aligned, although not yet completely. In 
e bottom-left image, the scenes are now well aligned E-W (with a registration coordinate of 

(-8,0)), but you can see they are not properly aligned N-S. The ASTER scene is slightly too 
r north and must be moved south. 

                                                                         

o aligned scenes. The registration cell coordinates for 
e ASTER scene are now (-8,-2). Using this information, the corresponding ASTER SWIR 

 changing its registration cell coordinates to   
4, -1) (divide by 2 because the pixel size is 30m i.e. twice that of the VNIR pixels). You can 
lso shift the TIR image by 1 pixel to the east. 

ack to contents

 linear N-S features in green (Landsat) and red (ASTER, VNIR band 3) 
ad. As you can see in the top left ima

 Landsat scene. In the top left image the registration cell is (0,0). 

 

 

 
 
 
 
 
 
 
 
 
 
The registration cell coordinates have been changed to (-5,0) in the
A
th

fa
 
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The bottom-right image shows the tw
th
image can be aligned to the Landsat image by
(-
a
 
 
B  



 8. Tips 

 Occasionally, after rotating your dataset back to zero, there is still a tiny rotation angle in 
the metadata of the dataset (like 0.0000001). This isn't a problem until you want to use 
the dataset in other software packages, such as ENVI, when the rotation angle prevents 
the software from reading the projection information correctly. To fix this problem, go to 
File → Open → Info… → Edit → Coord Space → Type "0" in the Rotation field. This will 
get rid of any tiny fractions of a rotation angle that might be there. It will not affect your 
dataset. Make sure you save changes. 

the Null value is automatically set to 0. If you 
import from some other programs, such as ENVI, the Null value may not be set (it 

 to have the null value set properly to 0, 
n doing calculations with the data. To set the null value to 0, go to File → 

Open → Info… → Edit → Raster Info→ Type "0" for Null cell value. 
 
 
Back to contents

 
•

 
• It is a good idea to make sure the pixel size of your dataset is an integer value (i.e. 15m 

not 14.9999999m). To fix the pixel size (if it is not an integer value) go to File → Open → 
Info… → Edit → Raster Info → Cell Size and adjust the cell size. You may have to 
adjust the pixel size to be an integer when saving a dataset (in the save dialog box).   

 
• When you create datasets in ER Mapper 

generally says "none"). It can be very important
especially whe
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Commonly used ratios 
 
F ae ture Band or Ratio Comments Reference 
Iron  
Ferric iron, Fe3+ 2/1  Rowan; CSIRO 
Ferrous iron, Fe2+ 5/3 + 1/2  Rowan 
Laterite 4/5  Bierwith 
Gossan 4/2  Volesky 
Ferrous silicates 
( t

5/4 Fe oxide Cu-Au 
bio , chl, amph) alteration 

CSIRO 

Ferric oxides 4/3 Can be ambiguous* CSIRO 
Carbonates / Mafic Minerals 
Carbonate / chlorite / 
epi te  do

(7+9)/8  Rowan 

E dpi ote / chlorite / 
amphibole 

(6+9)/(7+8) Endoskarn CSIRO 

Amphibole / MgOH (6+9)/8 Can be either MgOH 
or carbonate* 

Hewson 

Amphibole 6/8  Bierwith 
Dolomite (6+8)/7  Rowan, USGS 
Carbonate 13/14 Exoskarn (cal/dolom) Bierwith, Nimoyima, 

CSIRO 
Silicates 
Sericite / muscovite / 
illite / smectite 

(5+7)/6 Phyllic alteration Rowan (USGS); 
Hewson (CSIRO) 

Alunite / kaolinite / 
pyrophyllite 

(4+6)/5  Rowan (USGS) 

Phengitic 5/6  Hewson 
Muscovite 7/6  Hewson 
Kaolinite 7/5 Approximate only* Hewson 
Clay (5x7)/62  Bierwith 
Alteration 4/5  Volesky 
Host rock 5/6  Volesky 
Silica 
Quartz rich rocks 14/12  Rowan 
Silica (11x11)/10/12  Bierwith 
Basic degree index 
(gnt, cpx, epi, chl) 

12/13 Exoskarn (gnt, px) Bierwith, CSIRO 

SiO2 13/12 Same as 14/12 Palomera 
SiO2 12/13   Nimoyima 
Siliceous rocks (11x11)/(10x12)  Nimoyima 
Silica 11/10  CSIRO 
Silica 11/12  CSIRO 
Silica 13/10  CSIRO 
Other 
Vegetation 3/2   
NDVI (3-2)/(3+2) Normalised difference  

vegetation  index 
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Common ratio & band combinations 
 
Features Red Green Blue Reference 
Vegetation and visible 
bands** 

3, 3/2, or 
NDVI 

2 1  

AlOH minerals/advanced 
argillic alteration*** 

5/6 (phen) 7/6 (musc) 7/5 (kaol) Hewson (CSIRO) 

Clay, amphibole, laterite (5x7)/62 (clay) 6/8 (amph) 4/5 (lat) Bierwith 

Gossan, alteration, host 
rock 

4/2 (goss) 4/5 (alt) 5/6 (host) Volesky 

Gossan, alteration, host 
rock 

6 (goss) 2 (alt) 1 (host)  

Decorellation (envi) 13 12 10 Bierwith 

Silica, carbonate, basic 
degree index 

(11x11)/10/12 
(silica) 

13/14 (carb) 12/13 (basic) Bierwith 

Silica, carbonate (11x11)/(10x12) 13/14 12/13 Nimoyima 

Silica 11/10 11/12 13/10 CSIRO 

Discrimination for 
mapping 

4/1 3/1 12/14 Abdelsalam 

Discrimination in 
sulphide rich areas 

12 5 3  

Discrimination 4/7 4/1 (2/3) x (4/3) Sultan 

Discrimination 4/7 4/3 2/1 Abrams (USGS) 

  Silica, Fe2+ 14/12 (1/2) + (5/3) MNF Band 1 Rowan (USGS) 

Enhanced structural 
features 

7 4 2 Rowan (USGS) 

 
 
*Comments by Hewso
**Equivalent to Landsat RGB 432 
***Alunite/pyrophyllit

n 

e, mica, kaolinite/dickite  

ts

 
 
Back to conten  
 
 
 
 
 
 
 



10. Changing Format of PIMA Spectra Using SPECWIN 

tra can be ted into E r compa with ima nd 
ing. However, PIMA spectra m  the corr mat. PIMA  be 

 an  .dsp  .fos file as produced by PIMA software. PIMA 
an be saved as text files when they are collected, but this is a somewhat involved 

 rele once nvers
developed and is provided free of charge by Spectral International Inc. 

r ng th deliver ectra to 

 S  at h pimaus win.h

 
PIMA spec
groundtruth

impor NVI fo
ust be in

rison 
ect for

ge spectra a
 spectra must

imported as a text file
spectra c

d not as a or

process. It is easier to co
Specwin, which was 

nvert all the vant files at  using a co ion tool, such as 

Below are instructions fo
ENVI as text files.  

 obtaining, installing and usi e tool to  PIMA sp

 
1) Follow the link to II's website ttp://www. a.com/spec tml. Scroll to the 

bottom of the page and follow the download instructions.  You will need the files 
e , and DocWord.exe. When downloaded, double click on 

each to extract the required files to the c:\wpbin directory. In this directory you will find 
 specwin.exe (the actual application, different to the original file you 

downloaded). Put it on your desktop or double click to start it.  

 

2) Press the Launch the Program button. From the popup window, select Pima Files as 
shown below. You should now have a main window with a white subwindow open on 

3) From the main File menu, select Open Files… The "Select and Sort Spectral Files" 
window will pop up asking what to do. Press the Add Files, sort by name button and 
select the Data Files option. A file chooser window will now appear. Select the file(s) 
you want (in this case they are all .dsp) and select Open. The file chooser disappears 
and you are left once again with the "Select and Sort Spectral Files" dialog box. 
Press the OK: Return to Application button.  

TextUtil.exe, Sp cWin.exe

a file called

 
 
 
 
 
 
 
 
 
 
 
 
 

the screen. 
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4) 

 
 

 

 
 
 
 
 

 
 
6) 

e same folder as your original .dsp files, 

The names of the files you selected now appear in the white subwindow (which you 
can maximise) of the main application window. You can click on one the file names to 
display the associated spectra in the same window.  

 
 
 
 
 
 
 
 
 
 

5) Now the files must be converted to text files. Go to the View menu on the main 
toolbar and select "DSP2ASCI" (.dsp to ASCII i.e. text format). A new application 
window opens. Press the Get and Convert Files… button. Again, a file chooser 
opens.  

 

 
 

Select the files you want to convert and then exit the conversion application. New 
ascii files (.txt) are automatically created in th
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and with the same name. The files are created instantly, so no other windows or 
dialog boxes appear.  
You can now close SpecWin. This is mainly a display tool but there are a few things 
that you can do with your spectra in this progam. The most useful of these
moment is the ability to view the spectra and to convert them to ascii files 
into ENVI.  

7) 
 at the 
for import 

 
 
Back to contents 
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11. Cr
 

EN  
of the are 
these r 
examp port PIMA spectra from field sites, match them against a spectral library 

 find out what end-members can be identified, and resample the original spectrum to 
STER resolution. This is useful both for comparing the validity of ASTER signals and 

well as for seeing which features of the spectrum are distinctive for that 
mineral. In this way, you can see which ASTER bands, combinations or ratios are likely to 
produce the best results in terms of correctly identifying and mapping the minerals of 
interest.  
 

1) Start ENVI. From the Spectral menu on the main toolbar, select Spectral Libraries → 
Spectral Library Builder. From the pop-up box, select Ascii file and click OK. A file 
chooser appears. From the file chooser, select your ascii (.txt) file (one at a time for 
this process). The Input ASCII File dialog box appears.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2) In the Input ASCII File box, set the parameters to the following and click OK.  

a. Wavelength Column (ENVI is asking you which column of your text file 
represents the wavelength) - normally should be 1.  

b. Leave the FWHM text space blank.  
c. Change Wavelength units from unknown to Micrometres.  
d. The Y-scale factor is the amount that the reflectance in your spectrum has 

been multiplied by (so have a look at the spectrum in SpecWin to find out 
what kind of values you're getting for reflectance). In reality the reflectance 
value is between 0 (none) and 1 (all). If your values are around 2000, 4000, 
6000, then the y-scale factor is probably around 10,000 (i.e. values have been 
multiplied by 10,000). 

eating a Spectral Library in ENVI (from PIMA data)  

VI is an image processing program similar to, but more advanced than ER Mapper. One
chief advantages is the ability to import PIMA and library spectra and to comp
to spectra from your image, whatever the sensor you happen to be using. Fo
le, you can im

to
A
groundtruthing, as 
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3) The Spectral Library Builder window appears. From the Import menu, select From 
ASCII File.   Another file chooser appeas. Select the .txt file you're working on and 

a. X axis colu
b. Y axis colu
c. 
d. Y-scale fact

Back in the 
file you just imported a
this step for 

) From the Options menu on the Spectral Library 

you
continu
→ 
pre
to b
you wa
the sp
new w
Range
the min u like. You can also 
stack plots etc. to compare them. 

click Open. Another "Input Ascii File" window appears, looking similar to but not quite 
the same as the "Input Ascii File" window from step 1. 
 

This time, set the paremeters to the following and click OK.  
mn - 1 
mn - 2 

Wavelength units - micrometers 
or - 10,000 (same as previous) 

Spectral Library Builder window, the 
ppears in the list. Repeat 

all of your files.  
 
4

Builder, choose Plot End Members - you will see 
r spectra plotted together. To remove the 

um (i.e. hull quotient), go to Plot_Function 
Continuum Removed (or Normal, as you 

fer). You can also change the plot parameters 
lock out part of the spectrum. For example, if 

nted to see only the 1.8 to 2.5 region of 
ectrum, go to Edit → Plot Parameters. A 
indow opens with a lot of options. In the 
 text fields (about halfway down) change 
 and max values as yo
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5) Save your spectral library. From the File menu, select Save Plot As → Spectral 

Library… The "Output Plots to Spectral Library" dialog box appears. Click the Select 
All Items button and click OK. The Output Spectral Library window appears. Leave all 
the parameters as they are (see right). The only thing to do here is to select the file 
you want to save to at the bottom of the window. Make sure the Output Results to 
File is checked, and click Choose to select the directory and filename you wish to 
save to. Click OK to finish. Close the next dialog box that appears.  

 
 
6) 

spe g to the Main 
me  Spectral → 
Spe a  
Viewer
select y you want and press 

yed in the 
same window.  

 
 
Back t

You can view your (or any other) 
ctral libraries by goin
nu (main toolbar) →
ctr l Libraries → Spectral Library

. In the chooser that appears, 
which librar

OK. In the smaller chooser, click on a 
spectrum to display. Each spectrum 
that you click will be displa

o contents 
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12. 
 
Ground trut he field or 
from field samples is a g  First the 

and then 
compared to the ratio e several programs 

Geologist), which is 
a very usef ectral analyst, and is described 
below.   
 

1) Start ectral library 

2) Click on one
3) Start  the spectral 

e USGS library) and click 
OK.  

4) You can ch al mapping in the next 
dialog. Ther eature Fitting, 
and Binary Encoding. You can also choose to use a combination of these. In general 

 
                            
 
 

 
 
 
 
 
 
 
 
 

5) Analyst window, click 
library viewer window) against those in the ref  
work unless your spectrum is already 

en you will be asked which is the one you want to match. 
 a list of possible minerals with ranking values - the highest ones have 

the greatest probability of being correct. To compare your spectrum directly with one 
of the matches, click on, say, the first (best matched) mineral name in the Spectral 
Analyst window. A new display window will pop up showing both the reference 
mineral spectrum and your spectrum (you can show the plot key so that you know 
which is which). It is also a good idea to set the y-axis scale to adjust automatically.  

 
Minerals with matches below about 0.5 shouldn't be considered matches; usually the top few 
minerals are correct. However, you still need to match the spectra manually to ensure best 
results - don't trust the software to do it for you! Often there will be some odd minerals in the 
top few matches, so don't be fooled by them. Check peak (or trough) coincidence by running 
the cursor over the spectrum. Check for relative depth of absorption features.               
Back to contents

Using ENVI's Spectral Analyst to Determine Mineralogy  

hing is an integral part of remote sensing. PIMA spectra obtained in t
ood way to ground truth ASTER or hyperspectral imagery.

PIMA spectra must be identified with a mineral or combination of minerals, 
results for that mineral in the image. There ar

capable of identifying PIMA spectra. One of these is TSG (The Spectral 
ul program. Another method is to use ENVI's sp

Spectral Library Viewer from the Spectral menu and open your sp
(e.g. of PIMA spectra, in a .hdr file or .sli file). 

 of the spectra to display it. 
Spectral Analyst from the Spectral menu. In the dialog box select

library you want to use to compare to your spectra (e.g. th

oose which method you want to use for spectr
e are three choices - Spectral Angle Mapper, Spectral F

the first two methods are recommended. Here we will use Spectral Feature Fitting 
(which is usually the best method to begin with) so set the weighting to 1 for that 
method (therefore 0 for all others) and click OK.  

                                                                                                                                              

 

In the Spectral Apply to match your spectrum (open in the 
erence library. Spectral Analyst won't

displayed. If more than one spectrum is 
displayed th

6) You will see
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13. Resampling Library Spectra to ASTER Band Resolution 
 
You can do more spectral matching and mapping by comparing your PIMA results directly 
with ASTER results. To do this the PIMA spectra need to be resampled to ASTER band 
resolution. This also shows you which bands are likely to be the most effective at identifying 
various minerals.   
 

1) On the main menu (main toolbar), go to Spectral → Spectral Libraries → Spectral 
Library Resampling. A file chooser will appear. Select the library you want to 
resample and click OK. The Spectral Resampling Parameters window appears. 

 the button). Select ASTER from the 

 right: resampled to ASTER bandwidths (same wavelength range shown).  

 

ack to contents

2) In the Resample Wavelength To part of the window, select Pre Defined Filter 
Function. A sensor list will appear (click on
sensor list.  

3) Display the resampled spectra. You can run your mouse pointer over the spectra and 
click to find what spectral band you are looking at. Below left: original PIMA spectra. 
Below

 
B  
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14. Minimum Noise Fraction (MNF) 
 
MNF (minimum noise fraction) rotation (using principal components calculations) is used to 
show the variation between bands in an image. This is a statistical method which works out 
differences in an image based on pixel DNs in various bands. Mathematically, this uses 
eigenvectors and eigenvalues to work out the principal vectors and directions of the data 
loud (collection of data values for the image). The idea is to show the differences rather 

tha
maxim
where The 
calc
some b
each M ome feature or characteristic. Remember that these are statistics and do 
not
method
help: 

"Use the MNF Rotation transforms to determine the inherent dimensionality of image data, to 
segregate noise in the data, and to reduce the computational requirements for subsequent 
processing … The data space can be divided into two parts: one part associated with large 
eigenvalues and coherent eigenimages, and a complementary part with near-unity 
eigenvalues and noise-dominated images. By using only the coherent portions, the noise is 
separated from the data, thus improving spectral processing results." (extract from ENVI help 
manual). 

1) Start ENVI. 
2) From the main toolbar, go to the Spectral Menu → MNF Rotation → Forward MNF → 

Estimate Noise Statistics From Data. The MNF Transform Input File window appears.  
3) Go to Open File, and select a raster file you want to work on. The file information will 

appear in the window.  
4) Click OK on the window. A new window, Forward MNF Transform Parameters, 

elect subset from eigenvalues box read yes. The program will calculate 
d perform the transform.  

5) When finished, two windows appear showing you the amount of variation in each 
principal component (the most in PC1, the least in PCn) and the list of available 
bands. The MNF bands are listed on the x-axis and the amount of variation between 
bands is shown on the y-axis. As you can see, the most variation (nearly all, in fact) is 
recorded in MNF band1. A smaller amount is recorded in B2, then 3, 4 and so on until 
the line becomes just about flat. The last MNF band will look very speckled and will 
be mainly noise.  

c
n the similarities between bands. So in principal component images you are looking at the 

um differences between what the sensor is picking up in different bands rather than 
different bands are recording the same thing i.e. reducing redundancy. 

ulations also identify noise in the image. After doing this analysis you can then go and do 
and ratios, compare to your MNF or principal components image, and perhaps assign 
NF band to s

 indicate any specific mineral, merely differences between areas of the image. This 
 works best for SWIR images. For more information look in the ENVI or ERMapper 

appears. You don't have to choose output files for the statistics but you must choose 
an output file for the MNF image about to be created (bottom-most text field). Also, 
make the S
statistics an
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6) In the Available Bands List window select RGB color and then choose MNF bands 1, 
2, 3 for R, G, B respectively (or any other combination you like, although this one will 

 

7) 

blue or green or yellow. carbonate rocks and blue 
silicate rocks. Green could indicate vegetation. You won't know until you do 

 what these 
areas represent. Also, You can also classify or 
vectorise the principal 

8) You can import vector mage as a .bil to use in 
Arcmap or as olbar, File → Save As → 
select your f values to 0, so 
you may ha

Back to contents

probably be the most useful as it shows the greatest amount of variation). Click Load 
RGB to view the image.  

Three image windows appear. They are all geolinked. The main window is the Image 
window, from which you can control image enhancement etc. The Scroll window 
allows you to view the entire image and select a part of it to view in the Image window 
by moving the red box. The Zoom window allows you to zoom in on areas of the 
image.  
In the Image window, go to Enhance → [image] linear 2% to apply a simple 
transform. You can see the variation in the image through the different colouring. For 
example, areas that are red are similar to each other but different to areas that are 

So, for example, red could indicate 
 dense 

some ratios and band combinations (in ENVI or ER Mapper) to find out
try overlaying the geology maps. 

component images to overlay on other images.  
files (e.g. geology) or export the i

 an ERMapper .ers dataset. Go to the main to
ile type. (Note: unlike ER Mapper, ENVI does not set null 

ve to do this manually back in ER Mapper).  
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15.

"Use P
components, and to reduce the dimensionality of data sets. Because multispectral data 

6) 

 

 

 
 

 Principal components 

rincipal Components to produce uncorrelated output bands, to segregate noise 

bands are often highly correlated, the Principal Component (PC) Transformation is used to 
produce uncorrelated output bands. This is done by finding a new set of orthogonal axes that 
have their origin at the data mean and that are rotated so the data variance is maximized.            

PC bands are linear combinations of the original spectral bands and are uncorrelated. You 
can calculate the same number of output PC bands as input spectral bands. The first PC 
band contains the largest percentage of data variance and the second PC band contains the 
second largest data variance, and so on. The last PC bands appear noisy because they 
contain very little variance, much of which is due to noise in the original spectral data. 
Principal Component bands produce more colorful color composite images than spectral 
color composite images because the data is uncorrelated. ENVI can complete forward and 
inverse PC rotations. " (Richards, J.A., 1999. Remote Sensing Digital Image Analysis: An 
Introduction, Springer-Verlag, Berlin, Germany, p. 240., extract from ENVI help manual) 

1) Start ENVI. 
2) From the main toolbar, go to the Transform Menu → Principal Components → 

Forward PC Rotation → Compute New Statistics and Rotate. The Principal 
Components Input File window appears.  

3) Go to Open File, and select a raster file you want to work on. The file information will 
appear in the window.  

4) Click OK on the window. A new window, Forward PC Parameters, appears. You don't 
have to choose output files for the statistics but you must choose an output file for the 
PC image about to be created (bottom-most text field). Also, make the Select subset 
from eigenvalues box read yes. The program will calculate statistics and perform the 
transform. A small dialog box showing you the percentage variation in each band 
appears midway through the process - click OK and keep going. 

5) When finished, two windows appear showing you the amount of variation in each 
principal component in one (the most in PC1, the least in PCn), and the list of 
available bands in the other. The PC bands are listed on the x-axis and the amount of 
variation between bands is shown on the y-axis. As you can see, the most variation 
(nearly all, in fact) is recorded in PC band1. A smaller amount is recorded in B2, then 
3, 4 and so on until the line becomes just about flat. The last PC band will look very 
speckled and will be mainly noise. 
In the Available Bands List window select RGB color and then choose MNF bands 1, 
2, 3 for R, G, B respectively (or any other combination you like, although this one will 
probably be the most useful as it shows the greatest amount of variation). Click Load 
RGB to view the image (you can also view each band in greyscale). 

Three image windows appear. They are all geolinked. The main window is the Image 
window, from which you can control image enhancement etc. The Scroll window 
allows you to view the entire image and select a part of it to view in the Image window 
by moving the red box. The Zoom window allows you to zoom in on areas of the 
image.  
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7) In the Image window, go to Enhance → [image] linear 2% to apply a simple 
transform. You can see the variation in the image through the different colouring. For 
example, areas that are red are similar to each other but different to areas that are 
blue or green or yellow. So, for example, red could indicate carbonate rocks and blue 

 Green could indicate dense vegetation. You won't know until you do 

to overlay on other images.  

 

 
8) 

or as an ERMapper .ers dataset. Go to the main toolbar, File → Save As → 
select your file type. (Note: unlike ER Mapper, ENVI does not set null values to 0, so 
you may have to do this manually back in ER Mapper).  

 
Back to Contents

silicate rocks.
some ratios and band combinations (in ENVI or ER Mapper) to find out what these 
areas represent. Also, try overlaying the geology maps. You can also classify or 
vectorise the principal component images 

 
 
 
 

 
 

You can import vector files (e.g. geology) or export the image as a .bil to use in 
Arcmap 
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16. Decorrelation Stretch
 
Decorellation stretch is useful when viewing 
bands that are highly cor R or SWIR bands). For example, 
the TIR bands 10, 12, a dull RGB image. This 
sort of image is difficult ul. Applying decorrelation stretch 
essentially stretched each band such nimum correlation between bands is shown 
and therefore the decorrelation, i. the bands are not 
correlated, are highlighte ancy in the image.  
 
"Use Decorrelation Stretch y found in multispectral 
datasets and to produ ighly correlated data 
sets often produce quit  requires three bands 
for input. Th  from an open color 
disp
Princip
ENVI h
 
Decorr
ERMap
necess
 

1) Start ENVI.  
use in this process (TI

best), by going to the File → Open Image File 
Bands List dialog opens. 

3) Go to the Transform menu and choose 
the Decorrelation Stretch Input Input Bands dialo

4) Select three bands, e.g. 
5) In the Decorrelation Stretch Parameters dialog b

select a file to save to. Press OK to begin the pro
6) When finished, the three decorrelated bands appear at the t

List dialog box. Assign the three bands to the same RGB la
probably already done this for you) and click 
colour and contrast in the resulting image (bel
10 image (below left).  

 
 
 
 
 
 
 
 
 

 
 
 

Back to Contents

 

another way to enhance images. It is especially 
related (e.g. combinations of the TI

nd 13 are highly correlated and produce a fairly 
to interpret and not particularly usef

 that the mi
e. areas of the spectrum where 

d. It is another way to reduce redund

 to remove the high correlation commonl
ce a more colorful color composite image. The h
e bland color images. Decorrelation stretching

ese bands should be stretched byte data or may be selected
lay. Similar results to decorrelation can be obtained by using a sequence of forward 

al Components (PC), contrast stretching, and inverse PC transforms." (extract from 
elp) 

elation stretch can be done in ENVI or in ER Mapper, although if using the function in 
per it is necessary to have C++ compiler installed. Without the compiler it is 
ary to perform the function in ENVI, as described below. 

2) Open the image file you want to R datasets are usually the 
→ select your TIR file. The Available 

Decorrelation Stretch. Another band chooser, 
g box appears.  

B13 for red, B12 for green and B10 for blue. Click OK.  
ox, choose Output Result to File and 
cessing.  

op of the Available Bands 
yers as before (ENVI has 

OK to display the image. Compare the 
ow right) with the original RGB 13-12-
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17. Writing Scripts in ER Mapper 

ll of the ER Mapper scripts are stored with the program, in the Batch subfolder of the main 

unning a script from ER Mapper

 
One of the benefits of using ER Mapper is the ability to write your own batch scripts 
(including wizards) to automate some of your processing tasks, particularly tasks that you do 
regularly and are mechanical or repetetive. Batch scripts in ER Mapper are relatively easy to 
write and most of the time you can copy bits of code from other scripts that do part of what 
you want. You can also easily add your own buttons to the toolbars to run your scripts more 
quickly. 
 
A
ER Mapper 6.4 folder on your C: drive. Some are stored in further subfolders (for example 
Aster, library, etc.). You can open the batch files (.erb) with Wordpad (this is best but other 
notepad-type text programs should also work). There is a reasonable help section 
associated with scripting in the ER Mapper reference manual although you will probably 
learn more by studying existing scripts. You can run scripts from ER Mapper or from the 
command prompt. 
 
R  

ntrol from the drop-down list. 
An empty dialog box with the same name will open.  

box, click on the Run Script button. An ER Mapper file chooser will 

4) 
 E

 
 
 
 
 
 
 
 
 

dialog boxes pop up. Otherwise you may not see anything until t
Some processes require you to have  open first. You can run just about all of the 
processes that appear in the toolbar from the dialog above. You can also easily design and 
add buttons to the toolbars to run your scripts fro .  
 
Writing Scripts

 
1) Start ER Mapper. 
2) Go to the View menu and select Batch Engine Script Co

3) In the dialog 
appear, automatically connected to the C:/ERMapper64/batch directory.  
Choose a script from the list and click OK. The name of the script will appear in the 
blank window of the Batch ngine Script Control dialog box and the status will be 
Running.  

 
 
 
In the case of wizards or functions that require prompts (e.g. inputs or outputs), you will see 

he process is finished. 
 your image

m

 
 
Template scripts for simple functions as well as for wizards can be found in the Template 
subdirectory of the Batch directory. A list o  commands you can use in your code is in the 
back of the user manual or tutorial manual, or in the online help. More complicated functions 
must be written using these predefined simple functions. One particularly important thing to 
remember when writing scripts is to include comments, so that you or someone else will be 

hat your script does, how it does it and why you wrote it a certain way. 

f

able to understand w
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Unfortunately many of the standard ER Mapper scripts are not commented very well and so 
ou have to discover the functionality of some scripts through trial and error.  

ivalence test is represented by the double equals sign '=='). 
• Strings must be in double "quotes"  

y
 
A few simple rules: 
 

• Variables are denoted by a dollar sign in front of the variable name e.g. $filename 
• Variables are assigned values using the = sign e.g. $number_of_files = 6 (note, the 

equ

• Comments are preceded by a # hash 
• If [condition] then [goto…] else [goto…] is a useful construct 

 
Sample script 
 
# Summary:  Takes vnir bands from an input hdf file and produces a                    
# pseudocolour alg

 
orithm with those bands only 

his script contains all the necessary startup info 

 These are all variable definitions - look for how they are used in the script  
$start = "Processing your HDF file... please wait..." 
$fi
$er
aga
$sa
$exten
 
if 
# if a
 
ake_algorithm
   println $start  # prints a line with the contents of the variable on it 
   copy algorithm from window  # gets the dataset from the image window 
   $hdfname = get layer dataset  # assign the dataset to a variable 
   new algorithm    # create a new algorithm for the VNIR bands 
   set algorithm mode to pseudo  # set mode  
   set layer dataset to $hdfname 
   set layer description to "Band1" # first layer will be called band1 
   set layer input 1 to band 1 # assing band 1 of dataset to layer 1 of algorithm 
   duplicate layer    # copy the layer 
   set layer description to "Band2" # assign band 2 to layer 2 and name the 
   set layer input 1 to band 2  # layer 
   duplicate layer    #repeat the process 
   set layer description to "Band3" 
   set layer input 1 to band 3 
   println $finish   # printing lines is a useful debugging technique 

epath[1] + $extension # hdf ending, and assign the .alg ending  
 $hdfalg     

rintln $saved 

 

 
include "lib/BE_Startup.erb" # t
 
#

nish = "Processing finished. Loading algorithm into new window..." 
ror = "Error: no input image. Please open a HDF file in a new window, then try 

" in.
ved = "Your algorithm has been saved." 

sion = "_VNIR.alg" 

current window then goto make_algorithm else goto try_again 
 window exists with an image then continue else print an error message  

m :    # name of the routine  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
    go algorithm    # run the algorithm 
    new window    # create a new window 
    copy algorithm to window  
    go window     # display the algorithm created 
 
$string = $hdfname 
filepath = split $string at "."   # get the name of the hdf file without the  $
$hdfalg = $fil
save algorithm
p
 
exit 1 
 
try_again:  # error message telling person to open an image in a window 
    println $error 
exit 1 
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Adding Buttons 
 
You can design your own button to put onto one of the standard toolbars. The button is a .tif 

in any drawing package and save as a new button. Once that is done, 
ou must insert a line into the script for the toolbar of your choice that will both install the 

but
 
The i apper 6.4 folder. You 
can tton, then modify in your drawing program. 
 
The .4 folder. There are other 
les r.bar). These are text 

the information about what buttons and functions need to be on that toolbar. 
e toolbar file for the ASTER toolbar: 

ds only" BATCH "aleks_swir" 
BATCH "aleks_tir" 

"Produce RGB 321 algorithm" BATCH "aleks_rgb321_wizard" 

the ic
ll 

ve yo

in the ry since this is the default for all 

which you can alter 
y

ton on that toolbar, and run your script from that button.  

cons (buttons) are all stored in the Icons subfolder of the ER M
 take any of these, save as another bu

 toolbar files are in the Config subfolder of the ER Mapper 6
in this folder so look for those that have the ending .bar (e.g. astefi

files that store 
ere is an example of thH

 
 
# 
# FILE:    $ERMAPPER/config/aster.bar 
CREATED: 13 Feb 2002 # 

# AUTHOR:  Abdullah Mah 
# PURPOSE: ER Mapper ASTER config file. 
######################################################## 
"aster_icons/aster_bar_icon" "ASTER Processing Wizard" BATCH "aster/aster_main" 
"aster_icons/aleks_vnir" "HDF to VNIR bands only" BATCH "aleks_vnir" 
"aster_icons/aleks_swir" "HDF to SWIR ban

"HDF to TIR bands only" "aster_icons/aleks_tir" 
ster_icons/aleks_rgb" "a

 
 
 

Helpful tip Name of .tif 
Name o
batch sc

f 
ript 

The first file in the list is on (without the .tif ending). All the icons in this case are stored 
fold iin the aster_icons subfolder of the icons er. The second column is the helpful text that w

appear next to the b to o ur cursor over it. The final column holds the 
ated. Note that no file path is 

ut n when you m
associated batch scripts that will run when the icon is activ

  Batch directonecessary when the scripts are stored
scripts. A file path is only necessary if you put your icons or batch scripts into subfolders.    
 
 
Back to Contents 
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