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Intego Personal Backup User Manual

Welcome to the User Manual for Intego Personal Backup, Intego's program for backing up and synchronizing data, and
for creating bootable backups of a Mac OS X startup volume. Use the Table of Contents below to go to the different
sections of the manual. You can come back to this main Table of Contents at any time by clicking the Go to Main
Table of Contents link at the top of each page.

For information about installing Personal Backup and updating the program with Intego NetUpdate, see the Intego
Getting Started Manual.
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About Intego Personal Backup

Intego Personal Backup is a comprehensive backup solution for Mac OS X, protecting you from data loss by making
copies of your documents, applications, and system files onto external media.

Intego Personal Backup can back up your files to most media, including:

Partitions or volumes on your hard drive
External hard drives
Removable media (such as USB key drives)
Optical media (such as recordable CDs or DVDs)
Network volumes
AirPort disks (hard disks connected to Apple's AirPort Extreme or Time Capsule base station)
An iDisk (available with Apple's MobileMe service)
An iPod (if it offers hard disk mode)
Disk images

Intego Personal Backup can also synchronize data between two computers (such as a desktop Mac and a MacBook or
MacBook Pro), or create a bootable backup of your entire Mac OS X volume. And, of course, it restores files to your
computer as easily as it backs them up.

At its simplest, backing up files with Personal Backup requires dragging and dropping a couple of folders and clicking
the Backup button. For more complex tasks, Personal Backup's advanced mode lets you create backup scripts that
perform multiple actions, and that can run on predetermined schedules.

Installation
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System Requirements

Any officially-supported Mac OS X compatible computer running a PowerPC or Intel processor.
Mac OS X 10.5 or higher; Personal Backup is fully compatible with Mac OS X 10.6 Snow Leopard and Mac OS X
10.5 Leopard. Personal Backup is not supported for use on Mac OS X Server.
20 MB free hard disk space.

Installing Intego Personal Backup

For information on installing and serializing Personal Backup, see the Intego Getting Started Manual.

About Backups

Personal Backup performs the following operations:

A backup copies specific files and folders, or the contents of entire volumes or hard drives, from one location to
another. The location that contains files at the beginning of the process is called the source; the one receiving the
copied files is the destination. To keep the backup files safe, the destination files should be stored and never
modified, and should be on a different storage device from the source. For example, you might back up files from
your MacBook onto an external hard disk that you keep at home: then, if the MacBook gets lost or stolen, you still
have copies of your files on the hard disk.

One common backup strategy is to make a copy of all your files when you first run Personal Backup. Then on each
subsequent run, you direct the program to copy only those files that have changed since the last backup. This is called
an "incremental" backup. (Don't worry - Personal Backup makes these easy.)

Restoring is the opposite of backing up, and is usually performed when source files have disappeared or become
damaged (or when you've accidentally deleted some). You copy files from the destination disk back to the original
source. (In our example above, these files would go from the external hard drive to your MacBook.) Of course, these
files will only be current as of the last time you performed a backup: if you've modified those files since then, that
subsequent work will be lost - hence the need to make regular backups.

Synchronization twins a source's contents so both the source and destination are identical. The first time you run a
synchronization, Personal Backup may copy many files to ensure that both the source and destination contain the
same elements. But after that, only those files that are changed on one side are copied to the other side, and, by
default, items removed from one side are deleted from the other. Since you may update some files on, say, your
desktop Mac and others on your laptop, a synchronization can keep both of these Macs up to date with the latest
versions of each file. Changing file A on your desktop Mac and file B on your laptop means that, when synchronizing
the two Macs, file A will be copied to the laptop and file B to the desktop Mac. The result is that the source and
destination are always maintained as exact duplicates of each other.

A bootable backup copies a volume with Mac OS X on it to a second hard disk so the new location can act as a
startup disk. The bootable backup process creates an exact duplicate of the source, so the destination can function
exactly as the source. If you have a system problem on your Mac, you can connect the backup disk, restart your Mac
while holding down the Option key, select the backup disk and start up your Mac. You can copy all the user files on
your Mac to a safe location, then "restore" the bootable backup to your Mac by performing a bootable backup in the
opposite direction. You'll then be up and running without having to reinstall Mac OS X, its system updates, and your
own applications.

Backup Decisions

http://www.intego.com/manuals/en/gs/x6/intego-getting-started-manual-x6.html
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Before you implement your backup plan, determine four things:

Source: Which files will I back up?
Destination: Where will these backup files be stored?
Schedule: When and how often will I perform these backups?
Archives: How long will I keep backup files?

If you can't make up your mind right away, don't worry: you can have several backup strategies running concurrently.
For example, you might decide to make daily backups of important business files to DVDs that are then delivered to an
offsite location (such as a safe-deposit box) once a week. On the other hand, perhaps you consider photos and videos
of office renovations much less important, so you back them up only once a month to a server in the office.

Two criteria help you make decisions regarding which source files to backup: the files' importance, and the amount of
space available for backup. If, for example, you have a 250 GB hard drive in your MacBook, and a 1 TB external hard
drive available for backups, your decision is easy: back up everything, since there's no reason to save a few gigabytes
when you have so many to spare.

If you're short on space, your decisions are more complicated. Which files will cause the most inconvenience if lost?
Which are irreplaceable? For most people, personal and business documents come first; think of all your family photos
and videos, and any music you've bought by download, as well as any tax records, accounting software files, receipts
in electronic format, and your e-mail. Then, if there's additional space, applications and system files are important. On
Mac OS X, most of your personal documents are stored in the Documents folder of your home folder. But if you have
room, don't forget the Pictures, Movies, and Music folders! These are also in your home folder, next to your
Documents folder.

The destination for your backups could be on the same device as the source, although we recommend you use an
external device for all backups except the most casual (and insecure). The problem with the source and destination
existing on the same device is that a problem with that device (such as a hard drive crash) could easily destroy both
your originals and your backups, leaving you with nothing.

Instead, we recommend you make backups to another device, such as a CD, DVD, or external hard drive. (Note that
high-capacity external hard drives are relatively inexpensive.) If you have a MobileMe subscription, you can use
Personal Backup to back up selected folders to your iDisk. To save space (and copying time over a network), Personal
Backup can make incremental backups that replace only those files that have changed or been created since the last
backup.

We recommend you take the total size of your source files and budget at least twice as much space on your
destination disk. This ensures that there is enough room for the many files that change from one backup to the next.
If you are merely making a clone of your hard disk, however, you can use an external hard disk that is the same size
as your internal disk.

When you use removable media (such as CDs or DVDs), Personal Backup will let your backups span multiple discs,
asking you to insert a new disc as each one fills up. In this way you have a (theoretically) infinitely big destination: all
you need is more discs! However, such media can become inconvenient for very large backups, such as those of your
entire Mac, as you'd have to attend to the backup and switch out disks every few minutes.

Your backup schedule depends on how often you change the original files. Ask yourself this: how long will it take to
recreate changes made to lost files? For example, let's say you start working intensively on a file at 9 am. If you lose it
due to a crash or power outage at noon, you'll probably need three hours to restore the file - if that's even possible.

To ensure that you don't lose such data, you should regularly back up your files. For critical data, a backup of working
files to external media (or a network location) every few hours is wise, and for professional documents, you may want
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to run hourly backups. Then, complete daily or weekly backups provide additional protection to cover all files, whether
you have worked on them or not.

Again, scheduling decisions will depend on the amount of space available on your destination device. If you have
plenty of space compared to the total size of your source files, and are able to perform backups conveniently, there's
no reason not to do them every day. Consider how long you'll want to keep archives of your backups. A financial-
services company might be required by law to retain computer data for several years: such a company would want to
ensure that it always has a definitive copy of each file stored away in case auditors come around. However, it probably
won't need to access those old files frequently, or at all: therefore, it would probably store them in a compressed
format (to save space), at an offsite location.

On the other hand, home users might want to make backups only to ensure that they can recover the most recent
versions of their files, not caring about older versions. For them, the best solution might be to back up their Macs to
external drives, automatically discarding old versions as they go.

Finally, it's a good idea to create a bootable backup of your Mac OS X startup volume on an external hard drive in case
you suffer major disk problems or cannot start up your Mac for other reasons. Then, if problems occur, you can restart
your Mac from this disk and get to work immediately.

In any case, you should develop a backup strategy that corresponds to the way you work-and perform regular
backups.

Using Scripts to Automate Backups

Regardless of whether you create a backup, synchronization, or bootable backup, the specific details of your session
are called a "script". (You don't need a script to restore files, however.)

There are three advantages to using scripts. First, they ensure that you back up the same files, in the same way, every
time; second, scripts can trigger actions from other programs and Mac OS X; third, Personal Backup lets you schedule
scripts to run periodically without requiring your attention.

For example, you might create a script that does the following every day at 5 pm:

1. Selects all spreadsheet documents that are under 20 MB;
2. Scans them with Intego VirusBarrier X6;
3. Backs them up, keeping only the two latest versions, then;
4. Shuts down your Mac.

You'll learn all about scripts in Backing Up and Restoring Files.

Your First Backup

Making your first backup is simple. First, launch Intego Personal Backup; there are three ways to do this:

Navigate to your Applications folder in the Finder, then, double-click the Personal Backup icon.

Or, from the Intego menu, choose Personal Backup > Open Personal Backup….
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Or, click the Personal Backup icon in your Dock.

If you haven't created any scripts already in a previous version of Personal Backup, the first time you launch the
program it displays a window with three default scripts, a backup, bootable backup, and a synchronization script,
none of which have source, destination or options defined.

To create a first backup, click the "untitled backup script" to select it. Next, add your source. To do this, drag its
folder - that is, the one containing files you want to back up - from the Finder to the area labeled Click to choose
Source. (You can also click in that area and navigate to the source folder through Mac OS X's file selection window.)

Do the same for the backup's destination.

The window will now show which folder you intend to back up, and where they're going.

Then click the Play button, which looks like a right-pointing triangle labeled Back Up.
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Preparing to Back Up Your Files ››

Personal Backup will back up all the files from the source folder to the destination folder or volume, except for those
you don't have permission to copy.

That's it! You now have a spare copy of all files in the source, ready in case any of the original files disappear.

But Personal Backup does much more than the simple backup described here; the next chapter details all the options
that give it the power to satisfy everyone's backup needs, from the single-Mac home user to the corporate
administrator of thousands of computers.

© 2010 Intego. All Rights Reserved.
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Using Personal Backup Scripts

Regardless of whether you use Personal Backup for backups, synchronizations or bootable backups, you can tell the
program what you want it to do by creating a script that you can then execute whenever you want. A script consists of
two parts:

Indication of the source of files to copy and their destination.
Options that control such matters as when a backup will run, what happens before and after it runs, what to do
with duplicate files, and so forth.

If you haven't created any scripts already in a previous version of Personal Backup, the first time you launch the
program it displays a window with three default scripts, a backup, bootable backup, and a synchronization script,
none of which have source, destination or options defined.

You can use one of these scripts, or you can delete them and create your own new scripts. To create a script, either
choose File > New Script, or press Command-N.
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Or, click the + button.

You'll see a window that offers a selection of a Backup, Bootable Backup, or Syncronization. (A description of each
of these is in the About Backups section of this manual.)

We've chosen Backup, which results in a new script named "untitled backup script."
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If you do the same thing again, you'll notice a second script underneath the first one, titled "untitled backup script
2".

Depending on your Mac's screen settings, you might not see the script's full name. But you can fix that if necessary.
First, hover the cursor over the vertical dividing line between the list of scripts and the rest of the window, or over the
tiny vertical lines next to the word Scripts at the top of the script list. You'll know it's in the right place when it turns
into a thick vertical line with two small arrows on either side. Then, drag it to the right until you can see all your
scripts' full names.

Let's say you want to delete that second script. The first way is to click it once and then click the - button; the second
is to press the Control key while clicking the script's name until a menu appears, then choosing Remove. (Such
"contextual menus" occur throughout Personal Backup.)
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In either case, a dialog box will ask you to confirm your choice.

Now you have just one script called "untitled backup script." To change this name, highlight it where it appears at the
top of the window and type in its new name.

Or, double-click its name in the left column, then type in its new name. Once you hit the tab, enter, or return key, the
two locations will reflect the new name.

You can also change the icon that represents a script by clicking the current one at the top of the main window and
selecting a new icon.

You set up synchronization and bootable backup scripts in exactly the same way as backup scripts, although with
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different default icons to help you differentiate them at a glance.

Once you've created a script, you might want to make another one almost exactly like it, with just a few small
changes. To do this, press the Control key, click the script that you wish to copy, then select Duplicate.

A new script appears with the same name as the one you just duplicated, but with the word "copy" at the end. You can
then change its name to whatever you like in the manner described above.

Sources and Destinations for Scripts

So now you have one or more scripts set up and named: the next step is to determine which files will be copied, and
where they'll go. The process is similar for backups, bootable backups, and synchronizations; however, there are
enough differences among them that we'll look at each separately.

As used here, a "source" is the location of files to be backed up, put into a bootable backup, or synchronized. A
"destination" is where copies of the files will go.

Backups are the most flexible in terms of sources and destinations. You can define multiple backup sources, for
example to duplicate the contents of several folders, or even several network volumes, to one destination. Backup
sources don't have to be on computers running Mac OS X: in fact, they don't have to run any operating system at all.
That means you can back up from an external disk, network volume, memory stick, iPod, or any other Mac OS X-
readable medium in addition to computer drives. Further, you can back up to any Mac OS X-writable medium.

You can synchronize from any folder or volume to any folder or volume. But unlike with a backup, you can't
synchronize individual files, or synchronize from multiple sources.

A bootable backup is the most specific type of action, as its source must be an entire disk or volume that contains a
bootable copy of Mac OS X, and its destination must be a medium that can be booted. (Personal Backup does not
create bootable backups on DVDs.)

Creating Sources and Destinations

Regardless of whether you're making a backup, bootable backup, or synchronization, you define sources and
destinations through the top section of Personal Backup's window.
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There are five ways of indicating sources and destinations:

1. Dragging and dropping items from the Finder to their locations in Personal Backup.

2. Clicking in the source or destination area of the window, finding an item you want to use, and clicking Select.

3. Selecting menu options under the Script menu, Choose Source… or Choose Destination….
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4. Using command keys: press Option-Command-S to select a source, and Option-Command-D to select a
destination (as is shown in the above menu).

5. Using popup menus that appear the source and destination areas of Personal Backup's main window. These only
appear when creating bootable backups.

In addition to using folders and volumes as sources and destinations, Personal Backup offers other options. If you click
on the Source or Destination areas, you'll see a window where you can choose a source or destination. By default, the
Kind menu shows Local File or Folder. Click that menu, and you'll see the other options available. The sources
available are the following:

And you can choose from the following destinations:
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Network Drives

You can use a network drive as a source or destination; to do so, select it in the Kind menu. A dialog displays where
you can enter information for your network drive:

First, enter an address. This can be a local address (such as iMac.local), which you can find in the Sharing pane of
System Preferences on the Mac you want to mount; a Windows share (such as smb://servername); an FTP or SFTP
server, identified by its address (ftp://example.com, or sftp://example.com); or a network volume on a remote
computer, identified by its IP address. In each of these cases, you must enter a full address, including any volume
and/or folder name. You can add any type of network volume that you can mount in the Finder: in fact, in most cases,
the easiest way is to mount the volume in the Finder, then drag its icon onto the Address field in the above dialog.

If you check Connect automatically as, and enter a name and password, Personal Backup will not prompt you for this
information when running its script. And if you check Wake computer if needed, Personal Backup will attempt to
wake the computer containing the network volume. (Note: this does not work with all computers.)

You can click Test Settings to check to make sure your settings are correct.

Spotlight Searches

You can use a search from Spotlight, Mac OS X's search technology, as a source for your scripts. To do this, select
Spotlight Search from the Kind menu: you'll see a sheet where you can set up a Spotlight search.
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To create a search, first choose a location from the Search in menu. This can be Computer (your Mac), Home Folder
(your home folder) or Other…. If you choose Other…, you can select any folder or volume you would like to search.

Next, choose criteria for your search. For example, you could choose Content Modified from the first menu, then
After from the second menu, and enter a date in the text field. Or you could choose a specific type of file (Other >
Kind > Contains > Word to find all Microsoft Word documents). For more on using Spotlight to create searches, see
Mac OS X's help documentation.

Note that you can also drag a smart folder, which is a way of saving a Spotlight Search, from the Finder onto the
Source section of the Personal Backup window to add that search as a source. If the smart folder is in the Finder
sidebar, click the folder, then drag its "proxy" icon - the icon in the title bar of the window - onto the Source section
of the Personal Backup window.

iDisks

If you have an Apple MobileMe account, Personal Backup allows you to choose an iDisk as either a source or
destination. Using it as a source allows you to back up its contents on a local Mac; if you choose it as a destination,
you can back up some of your files to your iDisk to have off-site backups easily. Note that iDisk storage space is
limited, so you might not be able to back up all your files without purchasing additional space from Apple.

If you select iDisk from the Kind menu, Personal Backup mounts your iDisk (if it is not currently available in the
Finder), and displays a sheet where you can select a subfolder for your source or destination:
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If you wish to back up a folder, or use a folder as destination, click it and click Select. To choose your entire iDisk as a
source, hold down the Command key and click on the selected folder to deselect it, then click Select.

Optical Discs

You can use an optical disc - a CD or DVD - as either a source or destination. To use an optical disk as a source,
insert it into your Mac's drive, wait a moment for it to mount, then select it in the Choose a Source dialog. Alternately,
drag it on the Source area of the Personal Backup window. To use one as a destination, select Optical Disc from the
Kind menu of the Choose a Destination dialog. You'll see the following:

If your Mac has more than one optical drive, select it from the Preferred drive menu. If you want Personal Backup to
verify the disc after running your backup script, leave the Verify disc after backup option checked. It's a good idea to
do this; it only takes a few minutes, and ensures that your disc is readable. If you uncheck this option, you'll save
time, but you may not have a working backup.

When you use an optical disc as a destination, you will have different Backup Options from other destinations. (See the
Personal Backup Script Options section to learn more about such options.) The Mode menu of the Backup Options
offers two choices:
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You can only choose between Copy only changed files or Copy everything each time you run your backup. If you
copy everything each time you run the backup, each backup disc (or set of discs) will contain all your files. If you need
to restore any files, you can do so from any of your backup discs (or sets of discs).

If you choose to copy only changed files, you can make incremental backups, each new disc (or set of discs) containing
only those files that have changed since the previous backup. In this case, Personal Backup will ask you to insert the
last disc of your previous backup before copying files to new discs. (For example, if your backup spanned three DVDs,
you will need to insert the third of these discs into your Mac.) This is done so Personal Backup can read information
regarding the files that have already been backed up, so the program will know which files to copy.

Note: Personal Backup can create multi-session backups on CDs, but not on DVDs; this is because the Mac OS X
framework for writing optical discs cannot write multiple sessions on DVDs. This allows you to use empty space on
CDs for incremental backups. If you back up to CDs, and have only used half the capacity of a CD, Personal Backup
will be able to use the remaining space for your next backup.

Disk Images

You can use a disk image as either a source or destination. To use a disk image as a source, mount it in the Finder
and select it in the Choose a Source dialog, or drag the mounted disk image (not the .dmg file) on the Source area of
the Personal Backup window. To use one as a destination, select Disk Image from the Kind menu of the Choose a
Destination dialog. You'll see the following:

In this sheet, choose a name for your disk image, and select a location by clicking Change… or by dragging a folder
or volume into the Location field. If you wish your disk image to be compressed, choose a form of compression, and if
you want to encrypt your backup, choose from two levels of encryption.



Preparing to Back Up Your Files

http://www.intego.com/manuals/en/pb/2-Preparing-to-Back-Up.html[3/14/12 7:07:37 PM]

When you run the script the first time, Personal Backup creates the disk image. Each subsequent time, Personal
Backup mounts the existing disk image if it is in the same location. If you move it, though, Personal Backup will create
a new disk image with the same name, so you should make sure to leave the .dmg file in the appropriate location.

Personal Backup doesn't ask you to choose a size for the disk image; Personal Backup determines the appropriate
size. If you run a subsequent backup, Personal Backup enlarges the size of the disk image if necessary. You therefore
don't need to worry about how big it is.

Changing Sources and Destinations

Once you've chosen a source or destination, you can change it by clicking it and selecting an option from the large
popup menu that appears. Options vary depending on whether you're working on a backup, bootable backup, or
synchronization.

A backup source can be pretty much anything. You can create a script that backs up a single file, a folder, a volume,
or entire drive, or combinations of any of these, spread among multiple devices.

Type of script Options

Backup source Edit the current choice by clicking the pencil icon, then selecting
a new choice.

Remove the current choice by clicking the - icon.

Add an additional source by choosing Add Source… and
selecting the desired source.

Backup destination

A single location - a folder, volume, or drive - on
any Mac OS X-writable medium.

Same as backup source, except that Change Destination…
replaces Add Source…. This is the same as clicking the pencil
icon. (You can only select one backup destination.)

Synchronization source Same choices as backup source, above, except that Add
Source… has become Change Source…; selecting it is the same
as clicking the pencil icon. (You can only select one
synchronization source.)
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A single folder, volume, or drive, on any Mac OS
X-writable medium.

Synchronization destination

A single folder, volume, or drive, on any sort of
Mac OS X-writable medium.

Same choices as synchronization source, except that Change
Source… has become Change Destination….

Bootable backup source Shows all volumes that contain a bootable copy of Mac OS X.

Bootable backup destination Shows all currently mounted volumes that are capable of
containing Mac OS X, plus the option ASR Disk Image, which
creates a single file that contains the full contents of the
bootable backup's source. This file is portable, and can be used
to produce multiple copies of the source disk, for example to
standardize the contents of all Macs on a network.

Obviously, a bootable backup's destination can't be the same as
its source. If you attempt to make them the same, Personal
Backup intelligently changes the previously chosen one so
they're not the same.

Locking, Exporting, and Importing Scripts
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So far, we've considered Personal Backup from the point of view of lone Mac users who don't need to share or protect
their backup scripts. But if you share your computer, you might want to protect your scripts from the itchy fingers of
others. And if you know others who also have Personal Backup, you might want to share copies of your scripts with
them so they can see what you did.

Personal Backup includes a very simple system that prevents accidental changes to your scripts. Since the scripts
themselves aren't valuable information, the "lock" is more of a deterrent than a security measure: for example, no
password is needed to unlock scripts. But it's an effective tool to prevent scripts' accidental deletion or changing.

To lock a script, either:

Hold down the Control key while clicking the script in the script list, then select Lock Settings from the
contextual menu that appears;

Choose Script > Lock Settings;

Or press Command-L.

To unlock the script, either select Unlock Settings in the contextual menu, choose Script > Unlock Settings, or press
Command-L again.

To export a script, click it in the script list, then either choose File > Export Script… or press Command-Shift-S. To
import a script that's been exported, whether from your copy of Personal Backup or someone else's, either choose
File > Import Script…, press Command-O, or double-click the script's icon in the Finder.

Exported scripts are plain-text XML files that store all the script's options, including the locations of sources and
destinations. If you move the script to a Mac that doesn't have the source or destination in the same location, the
script will open but not run.

Personal Backup Script Options
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At this point you know how to set up Personal Backup scripts to create backups, bootable backups, and
synchronizations; how to show which files should be backed up; how to protect those scripts; and how to transfer
them among Macs where Personal Backup is installed. You can run any of these scripts by clicking the one you want in
the left column and pressing the Play button in the lower-right corner (that is, the right-pointing triangle).

But Personal Backup gives you much, much more control over operations than you've seen so far, through Script
Options.

Virtually all of Personal Backup's custom options - such as when a script runs, what happens before and after it runs,
what it does when it encounters duplicate files, and so forth - are set in the script's options, which appear as a row of
five buttons at the bottom of Personal Backup's window. They are:

Schedule. You can make a script run periodically, wake up your Mac (if it's asleep), or run even if you're not
logged in. Schedules can have several parts, so for example you could direct Personal Backup to run a backup
every Monday and Wednesday at 5pm, then again on the first of every month.
Preparation. You can set Personal Backup to run another program before starting its script. Most commonly, the
program will be Intego VirusBarrier X6, to identify dangerous files before copying them (and possibly infecting
other files or computers). However, you can also direct Personal Backup to run any program, including a custom
AppleScript that, in turn, runs several other programs.
Exceptions. Personal Backup has selectors that give you wide-ranging control over which files are copied. You
can choose to back up (or not back up) files based on their visibility, name, kind, path, size, date created, date
modified, label, or any combination of these criteria.
Options. Each of the three script types - backup, bootable backup, and synchronization - offers a set of choices
specific to that script. These involve the number of backups to keep; whether to copy aliases or the files to
which they point; what to do when a file has been changed on both the source and the destination disk; and so
forth.
Finishing. Like the Preparation option, Finishing lets you direct Personal Backup to run a program (or
AppleScript) after the script is finished. It also lets you choose whether to unmount the destination disk, quit the
program, run another Personal Backup script, put Mac OS X to sleep, or shut down your Mac entirely.

You can view each of these five sets of options in any of three ways: by clicking its button, by choosing its menu item,
or by pressing its command-key combination. Each set of options shows up in its own section of the Options part of
Personal Backup's main window. But you don't need to specify any of these options: if you don't, the script will simply
run using Personal Backup's default options.

There are three ways to remove a set of options from the Options section of the window, and therefore use the
default options:

Click the small X in the upper-right corner of that section of the Options window;

Press the same command-key combination that causes the option to appear; or
Select the same menu item that causes the option to appear.

In any case, a dialog box will ask you to confirm your choice.
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Schedules

You can run a Personal Backup script at any time by pressing the Play button in the main window's bottom-right
corner. But much of the convenience of backup and synchronization operations is in setting them to run periodically,
without your intervention or attention. For example, you might want a backup script to run automatically whenever you
plug in an external hard drive, or synchronize two computers whenever they're on the same network together.
Schedules make this possible.

To access Personal Backup's Schedule options, either:

Choose Script > Options > Schedule
Press Command-1
Click the Schedule button at the bottom of Personal Backup's main window.

The Schedule options display.

The Run script section lets you direct Personal Backup to run the selected script periodically. To do so, click the
checkbox labeled Run script. Then, select how often you want the script to run by selecting a period from the popup
menu. The choices are:

Every Day: Select the time of day.
Every Week: Select the day of the week, and the time on that day.
Every Month: Select the day of the month, and the time on that day.
Every ____: Select the number of periods and the length of the period (minutes, hours, days, weeks, months).
For example, you could make the script run every 20 minutes, or every three months.
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You can set up complex schedules by clicking the + button to add more lines to the Run script section. For example,
here we've set a script to run every week on Monday and Friday at 11pm, then on the first day of every month at 1am.

To remove any criterion, click the - button to its right; to disable all schedules in this script (without deleting them),
uncheck the Run script checkbox

The other three controls in this section are:

Wake up computer if necessary allows you to put your Mac in its power-saving "sleep" mode, yet still be
confident that Personal Backup will perform its scheduled script. Once the script is completed, the computer will
remain on, unless you also turn on an option in the Finishing section to put the computer back to sleep when
done. (To learn how to do this, see Finishing: Postprocessing Files, below.) Note that this option will not turn
on your computer if it's fully turned off, rather than merely asleep.
Run this script even if you're not logged in allows the script to execute even if no-one, or another person, is
logged on at the time it's set to run.
Run script when volume ____ is ready automatically starts the script when the specified volume is visible to
your Mac - for example, whenever you connect to a network, or turn on or plug in an external hard drive.
Except for your Mac's startup drive, all volumes that are given as sources or destinations for this script are
available in the popup menu; if both the sources and destination are on your Mac's startup drive, this option will
not be available.

Preparation: Preprocessing Files

To access Personal Backup's Preparation options, either:

Choose Script > Options > Preparation,
Press Command-2, or,
Click the Preparation button at the bottom of Personal Backup's main window.

This option lets you run a program before Personal Backup makes its copies. Because a virus checker is what Mac
users most often want to run before backing up or synchronizing, the first checkbox is dedicated to Intego
VirusBarrier. Personal Backup will work with either VirusBarrier X5 or VirusBarrier X6 to scan your files.

The second checkbox lets you direct the script to run any application first. That program could be a Mac application
with a graphical interface, an AppleScript, a shell script, an Automator workflow, or even a sound file that you want to
play when the script begins. When you check this box, you'll see a dialogue box asking you to select the program to
be run; to change it later, click the Choose… button.
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Exceptions

To access Personal Backup's Exceptions options, either:

Choose Script > Options > Exceptions,
Press Command-3, or,
Click the Exceptions button at the bottom of Personal Backup's main window.

 

The first two popup menus let you specify whether you want to copy - or not copy - items matching any of the
conditions you give, or all of them. For example, changing this selection could make the difference between copying
only files with "cache" in their names, none of them, or those files together with others.

The next section lets you specify the type of information that you want the filter to find. The choices are: Visibility,
Name, Kind, Path, Size, Created (i.e., the date the file was "born"), Last Modified, and Label. After choosing one of
these, you'll have the opportunity to specify filter details.

As in the Schedule section, clicking the + button at the right of the window adds an additional condition, while
clicking the - button next to a condition removes it from the list. You can also modify filter conditions by simply
changing their popup menu options or typing new data into the data fields.

In the example below, files will only be copied if they:

Are Microsoft Office files (such as Word documents), or
Are in a certain folder named "Documents to back up", or
Have the name "Finances".
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Options Overview

Regardless of whether you're running a backup, bootable backup, or synchronization, you access the script's options in
the same ways. (Available selections change depending on which type of script you've clicked in the script list in the
left column.)

Script type Ways to access the script's options

Backup Choose Script > Options > Backup Options,

Press Command-4,

Click the Backup Options button at the bottom of Personal Backup's main window.

Bootable backup Choose Script > Options > Bootable Backup Options,

Press Command-5,

Click the Bootable Backup Options button at the bottom of Personal Backup's main
window.

Synchronization Choose Script > Options > Synchronization Options,

Press Command-6,

Click the Synchronization Options button at the bottom of Personal Backup's main
window.

We'll look at each of these individually.

Backup Options
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Mode: This section defines how many versions of copied files you wish to keep. (The Backup Decisions section of this
manual will help you decide the best strategy for you.) By default, Personal Backup saves all old versions of your files
until your backup disk is full, after which it deletes the oldest backups in order to have enough space for new ones.
However, you can choose to save only a specific number of old versions.

The other option in the Mode popup menu is Keep the latest version of each file only. Selecting that reveals three
different options.

Remove files deleted from source ensures that your backup doesn't contain copies of any files that you have
removed from the source location. In this case, your backup precisely reflects the current contents of your
source.
Overwrite destination files, even if they are more recent than in source makes the backup truly one-way: it
assumes the source contains the definitive versions of files that you want to keep, no matter what. This could be
useful if (for example) you use files at the backup location for testing purposes while those at the source
location are used for "real" business.
Back up to root level of destination when only one source is defined produces a "mirror" of the source that
could be less complicated than other backup schemes.

The Permissions section asks whether you want Personal Backup to copy only those files that you have permission to
read, or whether it should use administrator authority to copy all files. If you choose the latter, you're given the choice
of either entering an administrator's password just before the script runs (Ask for authentication before running
script) or ahead of time (Do not ask for authentication).

To copy all files, you must enter a user name and password belonging to someone with administrator-level
permissions. To determine who that is on your Mac, choose System Preferences… from the Apple menu, and open
the Accounts preference pane by clicking its icon: users with such power will have "Admin" under their names.

The Advanced options section contains a single checkbox, Resolve aliases. If you leave this unchecked, each alias
file will be copied to the destination location without any changes; check it, and the file to which the alias points will
be copied instead.
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Bootable Backup Options

Bootable backups have four options.

Do not ask for an administrator password makes Personal Backup ask for the administrator password when
you define the script, saving you from having to enter it later. If you leave it unchecked, you'll have to enter the
password just before the script runs.
Never remove anything in destination: if you leave this unchecked, Personal Backup will make a perfect clone
of the source volume, erasing everything on the destination in the process. By checking it, you're saying that
you want a perfect clone of the source to be created on the destination volume in addition to content that's
already there. Note that checking this box could cause trouble with your bootable backup. If you simply want to
keep a folder from being deleted, you can add it as an exception.
Repair permissions on _______ examines the permissions on system files. Personal Backup will attempt to fix
any errors it finds.
Repair _______ examines the destination volume after running the bootable backup to make sure that it's in
good shape. Personal Backup will attempt to fix problems it finds, such as directory errors.

Note: when running a bootable backup, you don't need to back up your startup volume to a hard disk the same size as
the original. For example, you may have a Mac with a 250 GB hard disk, but only 80 GB of its space is used. In this
case, you could create a bootable backup on, say, a 120 GB hard disk, and still have room for that backup to grow.
You do need to have several GB of free space on the destination, however, or you may not be able to use the backup
to start up your Mac in case of problems. (Your Mac uses invisible virtual memory files that can take up several GB of
space.)

Synchronization Options

A synchronization coordinates the files contained in two folders or volumes so they both have the same versions of all
files. The question arises when the same file has been changed on both the source and destination volumes: which
one should be copied? The first popup in the synchronization options window lets you decide.

The first option, Ask, displays a window whenever it encounters a file that's been changed in both places.



Preparing to Back Up Your Files

http://www.intego.com/manuals/en/pb/2-Preparing-to-Back-Up.html[3/14/12 7:07:37 PM]

On the left you see details about the document in its source location; on the right, the same document in its
destination. In the bottom right of each section is a small magnifying glass icon: clicking it shows the file in Quick
Look. You can show the file in the Finder by pressing the Option key when you click the magnifying glass.

You have two options for this file: either make the version on the source location the "official" one that gets copied, or
copy the version that was changed most recently, then click the Continue button. Or, you could choose to ignore all
such conflicts by checking Resolve other conflicts then choosing one of the elements in the popup menu. If you want
to resolve the conflicts later, click the Resolve All Later button. If you make no choice within 60 seconds, Personal
Backup will act as though you clicked the Resolve All Later button.

The popup menu labeled When files have changed on both sides since last sync also has selections to make
Personal Backup act consistently whenever it runs into such synchronization conflicts. Besides Ask, its other four
options are Copy from Source, Copy from Destination, Copy newest, and Copy oldest.

Whatever you choose, Personal Backup will erase previous versions so that only one version will remain on both the
source and destination volumes. However, you can override this behavior and save all previous versions by checking
the Never delete anything checkbox.

The Permissions section asks whether you want Personal Backup to copy only those files that you have permission to
read, or whether it should use administrator authority to copy all files. If you choose the latter, you're given the choice
of either entering an administrator's password just before the script runs (Ask for authentication before running
script) or ahead of time (Do not ask for authentication).

To copy all files, you must enter a user name and password belonging to someone with administrator-level
permissions. To determine who that is on your Mac, choose System Preferences… from the Apple menu, and open
the Accounts preference pane by clicking its icon: users with such power will have "Admin" under their names.

Finishing: Postprocessing Files

To access Personal Backup's Finishing options, either:

Choose Script > Options > Finishing
Press Command-7
Click the Finishing button at the bottom of Personal Backup's main window.
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The first Finishing option is similar to one you read about in the Preparation section: it lets you run another program
once the script has finished. As before, this program can be any application, AppleScript, shell script, Automator
workflow, or sound file that you want to play when the script completes. When you check this box, you'll see a
dialogue box asking you to select the program to be run; to change it later, click the Choose… button.

The next option, which is checked by default, directs Personal Backup to unmount the destination volume when the
script is complete. Here a popup menu gives you two options: either unmount the volume only if it was mounted by
Personal Backup (a network volume, for example), or always.

The last option allows you to tell Personal Backup to quit, put your Mac to sleep, shut your Mac down, or run another
script. If you select Run script, you'll see another popup menu, listing all available scripts. In this way you could have
Personal Backup perform a series of scripts, one after the other, and finally shut down.

What Happens When You Click "Play"

At this point everything's set: you've chosen which files to copy, what Personal Backup will do with those files, how it
will handle exceptions, and what it will do before and after the script is complete. Now it's time for action!

To run a script, click it in the left column, then click the right-pointing triangle in the lower-right corner (called the
Play button, as it resembles that button on a DVD player.) The label on this button will vary, depending on whether
you're performing a backup, bootable backup, or synchronization.

For the most part, Personal Backup will run without your intervention: once a script's scheduled time arrives, or you
press the Play button, the program does exactly what you directed, every time. However, there is one notable
exception: if you're making a backup to removable media such as DVDs, you may have to watch the process and insert
new media as needed.

Personal Backup provides ways to inspect a backup or synchronization before, during, and after it has run. The
Preview button shows you exactly which files will be copied; you can see how the process is humming along in three
different ways by clicking the Summary, Chart, and Details buttons; and the Log keeps a record of past scripts, both
successful and failed.

A backup is useless without a way to recover lost files. Personal Backup's Restore function lets you choose not only
which files to return to their original places, but which versions of those files to keep. (See Backing Up and Restoring
Files for more on restoring files.) Of course, since it stores files in their native format, you can also just drag them
from one folder to another in Mac OS X.

Preview
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So now you've set up your backup or synchronization script. But what, exactly, will happen? How many files will be
copied? In which direction? What if you want to make a temporary exception? With its Preview function, Personal
Backup answers all these questions.

Click your script in the script list, then click the Preview button at the bottom right of Personal Backup's main
window.

Alternately, you can enter Preview mode by choosing Script > Preview, or pressing Command-Option-Return.

The bottom part of the window will look something like this:

The left column shows the name of the file or folder to be copied; the center column shows what will happen to it; and
the third column shows where the item will end up in the destination location. Note that even invisible files appear in
this list, so you'll see some (such as .localized in the above example) that don't appear in the Finder.

Want to see more information? Clicking the gear icon in the window's bottom-left corner lets you display two
additional columns of information for each item in the list: its modification date, and creation date. Further, selecting
Complete Path shows not only the name of the source file, but where it is on the source volume. A checkmark
appears next to those that are showing: to hide them, simply select them from the gear menu again.
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Here's the same window, with all information visible.

Depending on which options you selected, your Mac's screen might be too small to see everything. You can change the
width of columns to better see those that are most important to you. To do so, hover your cursor over the line to the
right of the column head you want to expand or contract until it turns into a "double-arrow" cursor. Here, we're about
to expand the Source column:

Here it is, fully expanded so you can see each file's complete path.
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‹‹ Welcome to Personal Backup Backing Up and Restoring ››

Double-clicking any portion of the file path reveals the file in the Finder.

What if you see an item that you don't want copied? Of course you could create a rule in the Exceptions (see
Exceptions in the Personal Backup Script Options) section), but Personal Backup gives you a much faster way to make
individual exceptions: simply click the action for that item in the Change To column: you'll see a popup menu, from
which you can choose to disable that item from being copied.

Once you've confirmed that the backup or synchronization script will go as you like, you can run it by pressing the Play
button, or go back to the main window by clicking the Edit Mode button in the window's lower-right corner.

 

© 2010 Intego. All Rights Reserved.
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Backing Up and Restoring

Running Backups, Bootable Backups, and Synchronizations
Restoring: Recovering Lost Files

Go to Main Table of Contents

Running Backups, Bootable Backups, and Synchronizations

A backup or synchronization script starts when:

Its scheduled time arrives,
You click the Play button,
You choose Script > Run, or
You press Command-Return.

In any case, you might see that Personal Backup is "Preparing to copy" your files, while it analyzes them to determine
whether they do, in fact, need to be copied. (If your script involves a small number of files, you probably won't notice
anything because the program checks them so quickly.)

A small icon also appears next to the script's name.

Once preparation is complete, this icon changes to show that the script is copying files.

The main section of Personal Backup's window also changes to look something like this:
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This is Summary view. At the top is a progress bar, showing how much has been copied, how much in total is to be
copied, and an estimate of how much time the script will take to complete. The center section shows an animation of
two hard drives at work.

Clicking the Chart button changes the view to one that shows a timeline of how quickly the files have been copied so
far. In this case, our copy speed peaked at about 15MB/s, or fifteen megabytes per second. Moving the slider at the
bottom lets you see a longer or shorter time period.



Backing Up and Restoring Files

http://www.intego.com/manuals/en/pb/3-Backing-Up-and-Restoring.html[3/14/12 7:08:15 PM]

The Details view gives specifics about which file is being copied right now, in addition to some other useful
information, such as the script's average speed. This view also gives you the opportunity to skip certain files by
pressing the Skip button when they appear next to the text Current Action at the top. Generally, only large files can
be skipped, because small ones would already be copied by the time you click the button.
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Finally, you can stop a script at any time by pressing the Stop button in the lower-right corner. However, it will
continue until you respond to a dialog box confirming your choice. (If you want the script to stop immediately in the
future when you press the Stop button, check the box labeled Do not show this message again for this script.)

After a few moments, the main window will confirm that the script was successfully halted.
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To temporarily stop a script, press the Pause button. It will turn into a button labeled Resume, which you can click to
continue the script where it left off.

If you let a script run to its conclusion, you'll see a message in the main window to that effect.

If Personal Backup encountered any problems, such as a file that couldn't be copied for some reason, information
about the issue will appear in this concluding message. The icon next to the script's name will also change to an alert
symbol, which will remain until the next successful run.

Two additional buttons appear at the bottom of the window, replacing the Play and Pause buttons. The first, Show
Logs, lets you review what just happened (and the success or failure of past scripts). The Reveal Destination button
is a handy way to look at the newly copied files in the Finder.

Click the Edit Mode button to continue working with Personal Backup scripts.

Logs: Reviewing What Happened

There are four ways to examine past backups and synchronizations you've run.

Click the Log button at the bottom-right of the main window. (It resembles a magnifying glass held over a
page.)

Choose Window > Logs.
Press Command-Option-L.
Click the small alert icon, if any, next to the script's name.

A window appears, listing every script you've run.
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The first column shows when the script started; the second, which script was run; the third, its result. By default the
list is sorted with the most recently run script at the top; to re-sort them in reverse order, click the Date & Time
column header (shown with blue highlighting in this example). You can also sort the list by script name and status by
clicking the headers of each of those columns, respectively.

Clicking any line in the log displays some details on that script.
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You may want to save this information to a file. To do so:

Select the log entry you want to save. To select multiple entries that are next to one another, click the first one, hold
down the Shift key, and click the last one. To select multiple entries that aren't next to each other, press the
Command key and click each entry you want to save. You can also select all entries by clicking once in the window,
then either choosing Edit > Select All, or pressing Command-A.

Click the Export… button.

Choose a format to which the details should be saved: your choices are Plain text (to examine in a text editor such as
TextEdit or in any word processor); HTML (to view in a Web browser); or a Personal Backup archive (which adds the
log entry to the log window, which could be useful in team situations where your colleagues are also running Personal
Backup).

To remove entries from the log window, first click them, then either click the - button, or press the Delete key. In
either case a dialog box will ask you to confirm your choice.

Restoring: Recovering Lost Files

Let's say a disaster happens: you look for a file or folder on your Mac, and it's gone. No problem! Since you've been
diligently running backups, you have a copy. (We'll discuss how to recover files from synchronizations below.)
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For backup scripts, there are several ways to replace the missing items. The most obvious is to simply copy them in
the Finder: unlike some backup programs, Personal Backup stores files in their Mac OS X-native file format. However,
this plan only works if you know which files are missing or out of date, and where they are. Often if one file is missing,
several are, and it's very easy to miss important files when you copy them one by one from various locations in the
Finder.

A faster and more-thorough method is to use Personal Backup's Restore function, which you access by first clicking
the script that created the files you wish to restore, then by either choosing Script > Restore or clicking the Restore
button at the bottom-right corner of Personal Backup's main window.

You'll see a window that shows a list of past scripts in the left column, and the files affected in the main section. The
most-recent run is at the top, and is selected by default. However, you can choose any of the script's past runs by
clicking it: the main section's contents will change to reflect files affected during that run.

At first you'll only see the script's top level, in this case the folder labeled My backup script: click the disclosure
triangle at its left to reveal all the sources that are part of this script; click again to display its contents.
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If you're looking for a specific file, you can keep browsing in this manner, or you can type part of the file's name in the
box labeled Search Files at the bottom of the window: only files whose names contain that text will remain in the
window above. To return to the full list of files, click the X button in the search box.

To restore items from a previous backup, simply click the desired item and either click the Restore to… button in the
window's lower-right corner, or hold Control while clicking the folder and select Restore to…. (The other option in the
contextual menu, Reveal in Finder, will display that item on the script's destination volume-that is, the volume from
which you'll retrieve the backup copy.) In the example below, we're restoring the contents of the entire backup.

After indicating where you want Personal Backup to put the restored files, you'll see a progress bar that shows how
long the process will take.

If you choose the top-level folder (i.e., the name of the script), your files will be placed at the location you chose in a
folder labeled with the date and time of the backup from which you restored, in the format Year/Month/Day Hour-
Minute-Second. For example, "09/10/29 12-41-50" means that Personal Backup restored files from a backup made
on the 29th of October, 2009, at 12:41:50.

To restore files from backups made to optical discs, you may need one or all of the discs you used for your backup. If
you chose to copy all files each time you ran your backups, as you learned how to do in the "Optical Discs" section of
Sources and Destinations for Scripts, each disc or set of discs will contain all of your files. However, if you chose to
copy only changed files, you may need all your backup discs to restore files. You will need to insert the last disc when
running a restoration, at which point Personal Backup will examine the information contained on this disc, regarding
which files were backed up and where, then ask you to insert the disc or discs needed to perform the restoration.

Note: if you have deleted a script, you can still restore items from its backup folder. To do this, choose File > Restore
from Backup, then select the top-level folder containing the backup you wish to restore. Since Personal Backup writes
an invisible file containing backup information at this location, you will then see a restoration interface, such as that
shown earlier. You can proceed with the restoration as explained above.

To leave Restore mode, click the Edit Mode button at the bottom-right corner of Personal Backup's main window.



Backing Up and Restoring Files

http://www.intego.com/manuals/en/pb/3-Backing-Up-and-Restoring.html[3/14/12 7:08:15 PM]

‹‹ Preparing to Back Up Personal Backup Preferences ››

The Restore function isn't available for synchronization scripts; if you need to recover files that were deleted on your
source but exist still on your destination, you should do so manually, by copying them from the destination back to
the source.

Bootable backup scripts don't offer the Restore function, as their purpose is to create a precise copy ("clone") of a
computer volume. To restore a bootable backup, run a new bootable backup in the other direction: choose your
destination as the source, and the source as destination.

© 2010 Intego. All Rights Reserved.
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Personal Backup Preferences

Personal Backup Preferences
Using the Personal Backup Widget

Go to Main Table of Contents

Personal Backup Preferences

Log Preferences

Personal Backup offers several options for customizing how you view logs and schedule scripts. To access the
program's preferences, either choose Personal Backup > Preferences…, or press Command-comma. A window will
appear, showing the preferences.

In the Logs preferences, the Recording section lets you show more - or less - information in the log window. The first
option, Record exceptions, keeps track of the selection criteria you made in the Exception options when you set up
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the script. (See the Exceptions section under Personal Backup Script Options.) The second option, Record successful
deletions, keeps track of files that a script deleted from either the source or destination. The third option, Record all
successful operations, augments the second option by tracking not only deletions, but everything a script does, such
as copying a file or creating a folder.

If any of these first three checkboxes is selected, a new Show Details button appears in the log window. Clicking it
displays as many details as you specified in the preferences; clicking it again hides these details.

The last option, Only keep the last ___ logs of each script, allows you to keep the log window more manageable by
not saving irrelevantly old information. (By default, Personal Backup retains only the last five logs of each script.)

You can also have Personal Backup send copies of the log to recipients of your choosing after a script completes. To
do so, check the Send logs by e-mail box, then click the Configure… button. In the window that appears, fill in
details of the message's origination and destinations, plus details needed by your mail server to send the message.
(For specifics, contact your e-mail administrator.) You can test your e-mail setting to ensure that mail will actually be
sent using the configuration you gave by clicking the Test Settings button. You may have to wait as much as a minute
for the results, which will appear in a dialog box.
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To add recipients, click the + button below the Recipients box. You can add as many recipients as you like. To
remove a recipient, click it, then click the - button.

Schedule Preferences
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Clicking the Schedule button at the top of the preferences window brings up options in four categories.

Activation: the Disable Scheduled Scripts… button stops all schedules from running. Until they're re-enabled
again (by clicking the button again, now labeled Enable Scheduled Scripts…), the only way to run backups and
synchronizations is to open Personal Backup, select a script, then click the Play button, or choose a script from
the Intego menu. A schedule that fails to run, or that runs unexpectedly, could cause security issues: therefore,
you must enter your password to change this setting. In any case, all schedules will be re-enabled when you
restart your Mac.
Edited scripts: the Always skip execution when a scheduled script is being edited checkbox ensures that a
script doesn't suddenly spring into action while it's selected in the Edit mode. If you check this checkbox, it's
wise to quit Personal Backup whenever you're not editing a script. Otherwise, you might accidentally leave a
schedule-enabled script selected, and the script will not run as expected.
Display: the first option, Warn me when no backup has been made for ___ day(s), displays a warning dialog if
the specified number of days has passed without a backup. The second option, Display scheduled scripts in
____ has two options: Personal Backup, and Task Manager. If you check the first option, Personal Backup
opens when scheduled scripts run; you can follow their progress in the Personal Backup window. If you check
the second option, only the small Task Manager window displays.
Intego Calendar: the first option, Synchronize all scripts creates a calendar, and clicking Subscribe in iCal
button opens the Mac OS X iCal program and creates an Intego calendar showing all the dates and times of
your scheduled script. You can use this to keep an eye on what scripts you have planned, and organize your
backups.

Using the Personal Backup Widget
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Personal Backup installs several Dashboard widgets that display information about your scripts and let you control
them from Dashboard. (This is in addition to the two general widgets, the Intego Status widget and the NetUpdate
widget. These widgets are covered in the Intego Getting Started Manual.) The Personal Backup widget looks like this:

This widget shows all the scripts you have set up in Personal Backup, and their last execution (if you have run them
previously), as well as the next scheduled execution for scheduled scripts.

You can launch any of your scripts from the Personal Backup widget by moving your cursor over one of them to
display a play button, then clicking that button.

The script launches, and the widget changes to show its progress:

If you need to, you can pause or stop the script by clicking the appropriate buttons. When the script has finished, the
widget will show that it has completed, and whether there were any errors:

The Personal Backup widget also shows if any of your scripts had errors. If this occurs, there will be a red dot to the
right of the script name; you'll need to open Personal Backup and check the script's logs to find out what the errors
were.

http://www.intego.com/manuals/en/gs/x6/intego-getting-started-manual-x6.html
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‹‹ Backing Up and Restoring

Finally, the popup menu at the top of the widget lets you choose what to display: the previous script run, the next
script to run, or a list of all scripts:
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