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INTRODUCTION 
Thank you for your purchase of LINEEYE analyzer. To use it correctly, you are advised 
to read and understand this instruction manual thoroughly. Keep this together with the 
warranty. If you encounter any problems, you will find helpful information in this manual. 
INTRODUCTION 

NOTICE 
a) It is prohibited to reprint or duplicate any part or the whole of this instruction manual 

without prior permission from LINEEYE. 
b) The contents of this instruction manual and specifications of the product is subject to 

change without any notice. 
c) This instruction manual has been designed and edited with great care to give you all 

necessary information. If you have any questions, feel free to direct your inquiries to 
LINEEYE CO., LTD. 

d) LINEEYE shall not be liable for any damages resulting from the use of this product. 
Furthermore, LINEEYE makes no guarantee if data disappears, or the recorded data 
corrupts while using this product. 

 

USE LIMITATION 
This product has been developed for the purpose of using as an analyzer only, and has 
not been developed for the use that needs exclusively high reliability and safety; 
aerospace apparatus, trunk communication apparatus, nuclear control apparatus, 
medical apparatus related with life maintenance etc. Also, this product does not 
warrant the use for those purposes. If you use for those purposes, please consider the 
safety measures in terms of fail-safe etc. 
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Safety Information 
 
Read this first ! ! 
This Safety Information includes the important information in order to not only learn the 
right way to use the analyzer, but also prevent you from causing damage to other 
people and property. Before using, please read the following WARNING and CAUTION.  
 
WARNING: Improper handling poses a risk of causing death or serious injury. 
 
CAUTION:  Improper handling poses a risk of causing injury*1 or damage to the 

product and property*2. 
 

*1: “Injury” indicates injury, burn, an electric shock, or the like which does not require 
hospitalization or hospital visit for over a long period. 
 
*2: “Damage to the product and property” indicates damage expansion related to a 
house, a building, furniture, apparatus, livestock or a pet. 

 
WARNING 

Do not disassemble or modify. 
This may result in fire, an electric shock and/or unit malfunction. 

 
Stop using the analyzer immediately when smells emanate from itself. 

Continuous use may result in an electric shock, a burn and/or fire. 
 
Keep the product away from water. 

Failure to do so may result in the heat generation, an electric shock and/or unit 
malfunction. 

 
Do not use deteriorated cables (damage etc.). 

This may result in the heat generation and fire. 
 
Do not use in the place which generates inflammable gas etc. 

This may result fire. 
 

CAUTION 
Do not use and keep this product in the following places: 

a)The places exposed to the direct rays of the sun. 
b)The places with the humidity and temperature exceeding the tolerance level, and 

with a rapid temperature change. 
c)The places with much dust and moisture. 
d)The places near the objects which generate heat (the heater etc.). 

 
Using in these places may result unit malfunction and /or injury. 
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Software License Agreement 
LINEEYE CO., LTD (LINEEYE) grants you to use the software program and 
accompanying documents under terms of this license. And you are consenting to be 
bound by and are becoming a party to this agreement. To use the software, you need 
to agree to this license agreement. 
 
1. Copyright 

LINEEYE holds the copyright on this software. 
 
2. Grant of License 

LINEEYE grants you to use this software on only one computer by getting the 
software and agreeing this license agreement. Therefore, you shall not rent, lease 
and loan to a third party. 

 
3. Copy, Analysis, and Modification 

This software shall not be reproduced, analyzed or modified in any form unless 
prescribed in the manual. 

 
4. Upgrade 

This software may be upgraded without advance notice because of technical 
progress of hardware or software. LINEEYE provides software upgraded by payment 
specially. For upgrade, only licensed user can have upgrades. 

 
5. Limitation of Liability 

In no event shall LINEEYE or its licensors be liable for any direct, indirect, incidental 
or consequential damages arising from products of this software or the related 
software. 
Besides LINEEYE shall not be liable for any damages arising from the product or the 
medium. 

 
6. General 

If any provision of the agreement is held invalid, such provision shall be removed 
from this license agreement. 

 
7. Support 

LINEEYE supports functions, operation and only the problem on this software. 
 
8. Notice 

Any matter not specified in this agreement will be governed by and constructed in 
accordance with copy right law and related laws. 

 
 
 
 
 
 
 
 
 
 

LINEEYE CO., LTD. 
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Before Using the product 
LE-580FX is a compact network tool which has TAP mode and PG mode. With TAP 
mode, you can capture/monitor full-duplex data on 10/100 Base-TX Network via USB 
port. With Packet Generator (PG) mode, you can generate traffic of max. at 100Mbps 
line-speed. 
 
Composition 
When you unpack the product, please make sure of the following: 
Analyzer : 1 
Utility CD : 1 
Mini-USB  Cable : 1 
USB 2Way Cable : 1  
User’s Manual : 1 (This book) 
Warranty : 1 
 
a) Please contact LINEEYE or its distributors or us if you find any damage to the 

product caused by transportation or any insufficient part. 
b) Please keep the box carefully and use it when sending the product back to us for 

repair etc. 
 
Utility CD 
This product contains the analysis software, the driver, and the latest manuals. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 



 

 -5- 
E-Mail: info@lineeye.co.jp

http://www.lineeye.com
LINEEYE CO.,LTD 

LE-580FX USER'S MANUAL

CONTENTS 
Notice..............................................................................................................................1 
Use Limitation .................................................................................................................1 
Safety Information...........................................................................................................2 
Software License Agreement..........................................................................................3 
Before Using the Product................................................................................................4 
 

1.Installation and uninstallation .................................................................................. 6 

1.1 Driver Installation .................................................................................................. 6 

1.2 Install the application software .............................................................................. 8 

1.3 Uninstall the application software.......................................................................... 8 

2. LED Description........................................................................................................ 8 

3. Specification and Environment ............................................................................... 9 

3.1 Specification.......................................................................................................... 9 

3.2. Environment ....................................................................................................... 10 

4. Test Connection Setup........................................................................................... 10 

4.1 TAP Mode (monitor and capture)........................................................................ 10 

4.2 Packet Generation Mode .................................................................................... 11 

4.3 USB 2way cable.................................................................................................. 11 

5. Application Software .............................................................................................. 12 

5.1 LE-580FX window............................................................................................... 12 
5.1.1 Function Tree ............................................................................................ 12 

5.2 LE-580FX QoS.................................................................................................... 13 
5.2.1 Function Tree ............................................................................................ 13 

6 Use of LE-580FX Window........................................................................................ 14 

6.1 Packet Generator (PG Mode) ............................................................................. 14 

6.2 Network Monitor (TAP Mode).............................................................................. 17 

6.3 Capture Function (TAP Mode) ............................................................................ 19 

7. LE-580FX with 3rd Party Sniff Software ................................................................ 20 

8. Warranty and Repair............................................................................................... 21 

 
 
 



 

 -6- 
E-Mail: info@lineeye.co.jp

http://www.lineeye.com
LINEEYE CO.,LTD 

LE-580FX USER'S MANUAL

1.Installation and uninstallation  

1.1 Driver Installation 
When you connect LE-580FX to USB port of host PC at the first time, you will be asked 

to install the driver. 

Please follow the instruction. 

    
Click Next to continue. 

 

  
Choose Install the software automatically… (Recommended) and click Next to 

continue. 
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Click Browse to choose the proper driver location to locate LE-580FX device driver. 

 

    
Click Finish to complete installation and exit Wizard. 

 

   
The Local Area Connection Properties window shows the LE-580FX Ethernet Adapter 

has been successfully installed. 
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1.2 Install the application software 
Install the LE-580FX Window(basic software).  Installation will start when you invoke 

“LE-580FX window Setup. exe”. At the same time WinPcap (packet driver for Windows) 

will be installed. 

*1) If the system is installed the firewall/anti-virus software, traffic from LE-580FX to 

host PC may be blocked. Please close that software if blockage occurs.  

*2) Software for LE-580FX works at WinPcap Ver4.0.2. When you install the  

LE-580FX Window, WinPcap Ver4.0.2 will also be installed. If you have different 

version of WinPcap, please uninstall it. Then install the software for LE-580FX. 

 

 

1.3 Uninstall the application software 
Open the “Add or Remove Programs” in the Control Panel for WindowsXP and 

Windows2000. Choose “LE-580FX Window” and then click “Change/Remove” for 

WindowsXP, or “Remove” for Windows2000 to uninstall. 

 

 

2. LED Description 

 

 

 

Mini-USB port  : to connect with PC by Mini-USB cable. 
Port A  : RJ-45 connector to connect with test object. 
Port B  : RJ-45 connector to connect with test object. 

 

Port A Port BLED

Mini-USB Port 

Front 

Back 
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LED Discription: 

Item Color Description 

Power Green Power on 
Green TAP mode *1 
Amber PG mode 

 
TAP/PG *2 

Blinking Green NWay fails (TAP mode) 
Green Link under 100Full/Half duplex 
Amber Link under 10Full/Half duplex 
Blinking Green Transmit traffic at 100Full/Half duplex 

Lk/Tx 

Blinking Amber Transmit traffic at 10Full/Half duplex 
Green *3 Full duplex 
Amber *3 Half duplex 
Blinking Green Receive traffic 

Rx/Err 

Blinking Amber Receive traffic with CRC error 
 

*1 :TAP mode is set as default.  

*2 :When either one of Port A or B is linked, the LED of TAP/PG will be Green (TAP 

mode) or Amber (PG mode). 

*3 :In the TAP mode, when NWay fails, the LED of TAP/PG will be blinking, the speed 

status will be shown through the LED of Lk/Tx, and the duplex status will be shown 

through the LED of Rx/Err. 

 

 

3. Specification and Environment 

3.1 Specification 
Measurement port 10Base-T/100Base-TX Ethernet 2 port (RJ-45) 
PC connection port Mini-USB port (USB2.0  High speed) 

LED Display for power on/off, TAP/PG, Link/Tx of Port A, 
Rx/Err of Port A, Link/Tx of Port B, Rx/Err of Port B 

Power  USB bus power (max. 3W) 
Temperature 0 to 40 (operation), -10 to 50 (storage) 
Humidity below 85%RH(no condensation) 
Dimension and Weight 95mm x 75mm x 20mm, 180g 
Accessories Utility CD, Mini-USB cable, USB 2way cable *1, warranty, 

manual 
*1: Use for extension or for power supply. 
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3.2. Environment 
 

PC/AT compatible (DOS/V)  with USB2.0 port 
RAM : 256MB or more (recommended). 
CPU : Pentium4, 1.6GHz or more (recommended) 
HDD : 10 GB or more (recommended) 
OS    : Windows2000 / XP 

 
 
 

4. Test Connection Setup 

4.1 TAP Mode (monitor and capture) 
For TAP mode, choose the target link to monitor and insert LE-580FX into it. LE-580FX 

has Ethernet counters to collect associated traffic information and send to host PC via 

USB. Bi-directional capture function is also supported. Please note, in this mode, data 

is captured in two directions: PortA to PortB or PortB to PortA. 

 

 
 
 
*When either A or B port of LE-580FX is connected to LAN cable,  LE-580FX is in NIC 
mode. And when both A and B port of LE-580FX are connected to LAN cables,  LE-
580FX is in TAP mode. 
 
 
 
 
 



 

 -11- 
E-Mail: info@lineeye.co.jp

http://www.lineeye.com
LINEEYE CO.,LTD 

LE-580FX USER'S MANUAL

4.2 Packet Generation Mode 
For Packet Generation (PG) mode, choose the target DUT (Device under Test) or NUT 

(Network under Test) and connect one or two ports of LE-580FX to it. Functions of 

packet generation and packet analysis can be configured individually in each port. 

Please note, in this mode, data is delivered to two separate ports. 

Note: TAP mode is set as default if LE-580FX is not working as PG mode or QoS. 

Please make sure that LE-580FX is not in loop connection (It will block the network). 
  

 
 

4.3 USB 2way cable 
If LE-580FX is not working stable, it may be because of the lack of bus power. Please 
use the USB 2way cable for power steadiness. 
 
<Steps> 
1. Insert 2way cable (male) into 2 USB ports of PC. 
2. Insert 2way cable (female) into USB port of LE-580FX. 
 
 
 
 
 
 
 
 
 



 

 -12- 
E-Mail: info@lineeye.co.jp

http://www.lineeye.com
LINEEYE CO.,LTD 

LE-580FX USER'S MANUAL

5. Application Software 
There are two application software, LE-580FX Window and LE-580FX QoS in the LE-
580FX. LE-580FX Window is for controlling LE-580FX. And LE-580FX QoS is for 
testing QoS for layer 2. 
 
5.1 LE-580FX window 
In the LE-580FX Window, you can switch LE-580FX into TAP or PG mode. With PG mode, you 
can generate traffic at line-speed. With TAP mode, you can analysis various networks. 
 
5.1.1 Function Tree 

=> Load Default 
Workspace 

 : Opens default workspace configuration 
information. 

=> Load Monitor Log  : Loads monitored log(statistic information). 

File 

=> Exit  : Exits LE-580FX Window. 
=> Cut  : Cuts  text. 
=> Copy  : Copies text. 

Edit 

=> Paste  : Pastes text cut or copied. 
=> Alarm Info  : Reveals alarm information based on threshold View 
=> Control Window  : Invokes main control window. 
=> Capture Setup => Port A/B : Sets up capture condition. 
=> Capture Window => Port A/B(PG) : Provides start/stop/view capture data 

Capture 

=> Capture Option  : Selects Ethereal or Wireshark to open the 
captured file (“ .enc“ file). 

Media Type => Set Media Type => Port A/B : Changes speed/duplex mode on port A/B. 
=> Dashboard : Provides real time traffic information update. => Meter 
=> Threshold : Provides traffic threshold configuration. 

Statistics 

=> Counter window  : Provides packet related counter statistics. 

=> Matrix setup => Port A/B : Sets up TX packet information. 
=> X-trailer => Port A/B : Sets up X-trailer for Port A/B. 
=> Flow Control => Port A/B : Switches flow control on/off. 

PG 

=> Rx BERT => Port A/B : Sets up BERT of Rx for Port A/B(on/off). 
=> IFG converter  : Provides Inter frame gap calculator for TX IFG. 
=> Device Info  : Reveals LE-580FX device information. 

Tools 

=> FPGA Download  : Makes version up for FPGA 
Help => About  : Provides information on the current version of 

LE-580FX. 

*Please read the PDF document in the utility CD for more information about LE-580FX 

Window.  
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5.2 LE-580FX QoS 
LE-580FX QoS turns LE-580FX into an easy-use tester for Layer 2. 

(QoS: Quality of Servise) 

 
 

5.2.1 Function Tree 
=> Load  : Display saved log file File 
=> Exit  : Exit LE-580FX QoS 
=> Set Test 

Configuration 
 : Display the window for test configuration Configuration 

=> Set Chart Color  : Display the window for chart color 
=> Test Panel  : Display the result in table or chart Test 
=> Detailed Counter  : Display the detailed statistic information for 2 ports 
=> Help  : for future upgrade Help 
=> About  : display the version of LE-580FX (software/hardware) 

*Please read the PDF document in the utility CD for more information about LE-580FX 

QoS. 
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6 Use of LE-580FX Window 

6.1 Packet Generator (PG Mode) 
Packet Generator mode is useful for Network test because it generates packet streams and 
error frames. 
 
<Example of setting> 
Set LE-580FX to generate 10% utilization rate and 64bytes ARP packet traffic at port A. 
Receive the traffic at port B. 
 
Step 1: Select PG mode from the Control Window. 
 
Step 2: Select PG => Matrix Setup => Port A to bring out Matrix Setup window for port A.  
Click Pattern (Byte) for the Frame No.1, and then frame editor button will appear. Invoke frame 
editor to configure the packet content. Click “OK”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click to 
select  
PG mode. 

Click to invoke frame editor. 

Set TX mode.

Set all frame types.

Click to select No.1 frame for TX. 

Adjust frame gap.

Inter Frame Gap
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Step 3: Select ARP in frame type. Enter required information, such as destination MAC, source 
MAC, etc. 
*Please refer to the protocol specification for more detail about the protocols. 

 
 
Step 4: Set Inter Frame Gap (IFG). Set utilization rate to be 10%. Frame gap, “6144” bit times in 
100M mode, will be shown in the Matrix Setup window.  

 
 
Step 5: All frame configuration setup is completed. Select “Tx mode” to be “Continuous” and 
click Apply Matrix Settings button, click start button (green arrow) to start transmitting the target 
traffic. 
 
Step 6: Select Statistic => Meter => Dashboard. Select Statistic => Counter window to show 
performance information of port A (TX side) and port B (RX side). 
 
Step 7: Click the Stop button (red square) in the Matrix Setup Window to stop the traffic. (if you 
set the number of transmitting packets in the Tx mode, it automatically stops after finishing the 
transmission) 
 
*Warning: Improper test traffic may cause the network blockage. 
 
<Hint> 
Matrix setup: User may generate up to 128 packet streams per one port. User may configure 
packet length, content, and IPG (inter packet gap), and attach various errors. Transmit 
performance will be shown on the Dashboard or Counter window. 
 
Frame editor: User may edit packet content through frame editor embedded in Matrix Setup 
window that provides predefined packet type: IPv4, TCP, UDP, ICMP, IGMP, IPX, and ARP with 
optional VLAN Tag/MPLS.  
 
Tx rate pre-calclate: Inter packet gap between packets are adjusted in term of bit time. Tx rate 
pre-calclate is useful to calculate the utilization rate of transmission.   
 
 
 
 

Select 
editor’s 
frame type. 

Input raw data. 

Input selected frame
header Information. 
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Counter

Dashboard
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Dashboard

Traffic 
Direction

Traffic 
Counter 
Report & 
Warning 
Indication 

Traffic Type 
selection 

6.2 Network Monitor (TAP Mode) 
 
When connecting LE-580FX in TAP mode, LE-580FX hardware will be act as a “TAP” device to 
forward the link traffic into the host PC. You can invoke LE-580FX Window to see the 
performance of the link, or capture certain traffic by LE-580FX capture function. 
 
<Important> 
Please be aware that LE-580FX does not have the fail-safe function. 
Network will be blocked by the power shortage. 
 
<Example of setting> 
To monitor a FTP link between two stations 
 
Step 1: Insert LE-580FX between the target monitor link. If LE-580FX is in default mode(TAP), 
no mode change needed, otherwise switch to TAP mode 
 
Step 2: Real-Time Report Chart. Select Statistic => Meter => Dashboard to show the 
performance information of both port A(TX side) and port B(RX side) in real time. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Real Time 
Traffic 
Drawing 
Chart 
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Counter Window

Step 3: Select Statistic => Counter window to show the counter information of port A (TX side) 
and port B (RX side). 

 
 
 
 
 
<Hint: Counter information provided by LE-580FX.> 
 
Rate Counter: TX Packet Rate/Bytes Rate/Utilization. RX Packet Rate/Bytes Rate/Utilization. 
Filter 1 Packet Rate/Byte Rate. Filter 2 Packet Rate/Byte Rate. 
 
Amount Counter: TX/RX Packets/Bytes. Broadcast/Multicast/Unicast Packets/Bytes. 
Pause Packet. Packet with VLAN Tag. Sequential/TCP Checksum/ IP 
Checksum/CRC/Alignment/Dribble Error. RUNT. Oversize. Fragment. Jabber. 
Lower/Upper Bound Counter. Size Distribution Counter. ARP Request/Reply. ICMP 
Request/Reply. 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Control bar to
clear/start/stop 
counter and  
adjust counter 
alignment/size. 
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6.3 Capture Function (TAP Mode) 
 
With the TAP mode, you may select capturing in the “Capture setup.” 
 
<Example of setting> 
Step 1: Select TAP mode.  
 
Step 2: Capture Setup. Select Capture => Capture Setup => Port A (Port A => Port B). Choose 
capture type and apply. The folder for saving files can be selected in “Buffer” TAB. 
 

 
 
 
 
 
Step 3: Select Capture => Capture Window to pop up the Capture window. Click Start 
button(green arrow) to start capturing. Packets meet the capture type will be forwarded to host 
PC. LE-580FX is a hardware based filter, so packets do not meet the filter condition will not be 
forwarded to host. After stopping capture, click the Stop button to show the captured packet 
information in the Capture window. You may export the captured file to a 3rd party sniff software, 
such as Ethereal and Wireshark, for deeper protocol analysis. 

 
 

Captured 
Packet Number

Packet Analyzer Window 

Packet Raw Data 

Use control bar to  
view packet page. 
Start/Stop capture. 

Capture Windows

Capture Setup Windows 
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7. LE-580FX with 3rd Party Sniff Software 
When connecting LE-580FX in TAP mode, it will be act as a “TAP” device to forward the link 
traffic to host PC. The following procedure shows how to control a 3rd party sniff software 
“Ethereal” using LE-580FX to capture traffic. 
*In the time of which the ability of capturing of the packet is important, because Ethereal and 
Wireshark are more excellent in the capturing ability than LE-580FX, Ethereal and Wireshark 
are recommended. 
*LE-580FX TAP Mode Utility is available at LINEEYE website  (http://www.lineeye.com/).  
This software introduces the procedure to setup LE-580FX for Ethernet TAP between 2 target 
devices with Wireshark. Other third party software can also work in the same way. 
Use LE-580FX TAP Mode Utility if one or two of target devices only support Media Type in 
forced mode (ex: only support forced 100M Full duplex or forced 10M Full duplex). 
 
<Important> 
1. LINEEYE has tested that LE-580FX works at WinPcap Ver4.0.2. LINEEYE does not 
guarantee to use LE-580FX at other version of WinPcap. Please notice this when you install 
Ethereal or Wireshark. 
 
<Use  Ethereal> 
Step 1: Invoke Ethereal. Select Capture => Interfaces. You will find the LE-580FX device in the 
“Ethereal Capture Interfaces” window. 
Step 2: Click “Capture” button to start capturing traffic. 
Step 3: Stop capturing traffic to see detailed packet analysis. 
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8. Warranty and Repair 
 
Warranty 
Within a period of 12 months from the date of shipment, LINEEYE warrants that your 
purchased products (excepting consumable parts such as the batteries and software) 
are free of charge from any defects in material and workmanship, only when the 
products are operated in accordance with procedures described in the documents 
supplied by LINEEYE. If the defects exist during the Warranty period, please send back 
the products to LINEEYE distributors or LINEEYE office. LINEEYE will repair or 
exchange them at no charge. In this case, the shipping charge will be at your own 
expense. 
The foregoing warranties are the sole warranties given by LINEEYE. Above warranties 
shall not be applied to the products that have been modified, repaired or altered 
(excepting by LINEEYE employees) or that have been subjected to unusual physical or 
electrical stress, misuses, abuse, negligence or accidents. 
LINEEYE disclaims all other warranties including the warranties of merchantability 
fitness for some particular purposes and noninfringement of third party right. LINEEYE 
cannot promise that the software is error-free or will operate without any interruption. 
When you have some errors while operating the software, please refer to the contents 
and modified programs shown on our web page (http://www.lineeye.com).  
 
Repair 
LINEEYE will repair the products at your own expense. 
For malfunction, please contact the LINEEYE distributors where you purchased at. Or, 
contact us directly. 
If your product needs to be repaired, please read details about a repair on our web 
page and ask LINEEYE for a repair. 
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