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Safety Precautions 

Before using the wireless data card, read the safety precautions carefully and 
also let your children know these, so that you can use your wireless data card 
correctly and safely. For details, refer to "Warnings and Precautions." 

 

Do not switch on your wireless data card when it is prohibited to use wireless 
device or when the wireless data card may cause interference or danger. 

 

Do not use your wireless data card while driving. 

 

Follow any rules or regulations in hospitals and health care facilities. Switch 
off your wireless data card near medical apparatus. 

 

Switch off your wireless data card in aircraft. The wireless data card may 
cause interference to control signals of the aircraft. 

 

Switch off your wireless data card near high-precision electronic devices. The 
wireless data card may affect the performance of these devices. 

 

Do not attempt to disassemble your wireless data card or its accessories. Only 
the qualified personnel is allowed to service or repair the wireless data card. 

 

Do not place your wireless data card and its accessories in containers with 
strong electromagnetic field. 

 

Do not place magnetic storage media near your wireless data card. Radiation 
from the wireless data card may erase the information stored on them. 

 

Do not put your wireless data card in a high-temperature place or use it in a 
place with flammable gas such as a gas station. 

 

Keep your wireless data card and its accessories away from children. Do not 
allow children to use your wireless data card without guidance. 

 

Observe any laws or regulations on the use of wireless data cards. Respect 
others’ privacy and legal rights when using your wireless data card. 
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1  Overview 

Thank you for choosing Huawei EC321 Data Card (hereinafter referred to as the EC321). 
With the EC321, you can easily: 

 Access the Internet. 
 Make and answer calls. 
 Send and receive messages. 
 Use the contacts. 
 Use the call logs service. 
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2  What Is in Your Packing Box 

Your EC321 packing box includes: 

 An EC321 data card. 
 An earphone. 
 A CD which contains a PDF document of user manual and a setup program. 
 A quick start guide. 
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3  Getting to Know Your EC321 

The following is an illustration of your EC321. 

Indicator
Earphone jack

Antenna
 

Note: 
This is a sketch of the EC321. Your EC321 may be different. It is subject to your 
actual one. 

 

Antenna 

The EC321 adopts a built-in antenna that can be pulled out and adjusted in any directions. 
When using the EC321, you can adjust the angle of the antenna according to the actual 
signal reception situation so as to reach a most favorable signal reception quality. 
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Warning: 
After pulling out the data card antenna, do not bend it at will. Otherwise, the 
antenna might be damaged and cannot receive network signals. 

Earphone Jack 

Insert your earphone into the jack on the EC321 when you use the call service. 

Indicator 

The LED indicates the status of your EC321. Normally, the indicator is green. 

Indicator status Meaning 
The indicator is off. The EC321 is disabled. 

The indicator is on all the time. The EC321 is starting. 

Single-flash: 
The indicator is flashing every two 
seconds. 

 The EC321 is searching the network. 
 The EC321 cannot find the network and needs 

to authenticate by the PIN or unlock by the 
PUK. 

Double-flash: 
The indicator is flashing two times 
every two seconds. 

The EC321 is in the standby or conversation 
mode. 

Quick flash: 
The indicator is flashing quickly 
with an interval of 0.1 second. 

There is an incoming call and the tone is ringing; 
or the EC321 is transferring data by the data 
service. 
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4  Getting Started 

Computer Configuration Requirements 
To use the EC321, the following requirements are recommended for your computer: 

 CPU: Pentium 4, 1 GHz or above 
 Memory: 256 MB RAM or above 
 Hard Disk: 50 MB free disk space 
 OS: Windows XP, Windows 2000 or Windows Vista operating system 
 Data Card Interface: A type II PCMCIA Card slot, supporting CARDBUS 
 Display Resolution: 800 by 600 pixels or above (1024 by 768 pixels is recommended.) 

 

Note: 
If the configuration of your computer is inferior to the recommended 
configuration, the running performance of the data card software may be 
affected. 

 

Preparing the EC321 
Note: 

Whether a UIM card needs to be installed in your EC321, consult your network 
operator. 

 

1. Take out the EC321 from the protective cover. 
2. Take out the UIM card slot from the EC321 and place the UIM card into the slot, as 

shown in the following figure. Make sure that the UIM card is fully in place. 
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3. As shown in the following figure, place the slot into the EC321. 

 
4. Insert the EC321 with the UIM card into the PCMCIA slot of your computer. 
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5  Installation Guide 

The installation process is subject to different operating systems, such as Windows XP, 
Windows 2000 and Windows Vista. During the actual installation, if any step differs from 
what is described here, follow the specific installation instructions. The following 
sections take Windows XP as an example. 

 

Note: 
Make sure that the EC321 Manager has been installed before the EC321 card is 
inserted into the computer. 

 

Installing the EC321 Manager 
1. Put the EC321 CD into the CD-ROM drive. 
2. The setup program starts automatically, and the EC321 installation interface is 

displayed later. 
 

Note: 
If the auto-run program does not start, double-click the Setup.exe file in the 
drive path and then the program is running. 

 

3. The Choose Language dialog box appears. Select an installation language and click 
OK. 

4. Follow the instructions of the program. 
5. Once the installation completes, the shortcut icon  for the EC321 Manager 

appears on the desktop. 
6. When the system prompts you that the installation is finished, click Finish to finish 

the installation of the EC321 driver. 
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Removing the EC321 
If you want to remove the EC321 from the computer, do it after having stopped it through 
the hardware removing feature provided by Windows. 

When removing the EC321 from your computer, follow the procedure below: 

1. Double-click  on the lower right corner of your interface. 
A dialog box of "Safely Remove Hardware" will pop up. 

2. Select NEC PCI to USB Open Host Controller, and then execute the operation of 
stopping the use of the EC321. 

3. When the system prompts you that it is safe to remove the device, pull out the 
EC321. 

Uninstalling the EC321 Manager 
Uninstall the EC321 Manager through the Add/Remove function of Windows. 
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6  The EC321 Manager GUI 
Description 

Accessing the EC321 Manager GUI 
1. To start the program, double-click the shortcut icon  of the EC321 Manager on 

the desktop. 
2. If you are prompted to enter the Personal Identification Number (PIN) code, enter the 

correct one and click OK. 
You can try three times to enter your PIN code. If you failed to do that after three 
times, your UIM card would be locked. If this happens, use the PIN Unblocking Key 
(PUK) code to unlock it. 
You can try 10 times to enter your PUK code. If you failed to do that after 10 times, 
your UIM card cannot be used. If this happens, contact your network operator. 

3. When you failed to enter the PIN code or the PUK code, you can click Cancel to 
skip over the authentication of the PIN code. Then, the functions related to the UIM 
card such as connecting to the Internet, making and answering calls, sending and 
receiving text messages, and reading the messages recorded in the UIM card are not 
available for you. However, you can still make emergency calls. 
The PIN code and the PUK code are provided by your operator. For information 
about how to modify and enable/disable your PIN code, refer to "PIN Code 
Management." 

Exiting the EC321 Manager 
Select File > Exit and you can perform the following operations: 

 Select Quit application to exit the EC321 Manager. 
 Select Shut down device to exit the EC321 Manager and stop the data card. If you 

want to re-access the network service, plug and insert the device again. 
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Introduction to the Main Interface 

Main Interface Overview 

The initial interface after the EC321 manager starts is as follows. 

 
When you maximize the interface, it is displayed as follows. 

 

Shortcut Icons and Keys 

The following table describes the shortcut icons and keys provided by the EC321 
Manager. 
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Shortcut icon/key Description 
F1 Access the online help. 

/ /F2 
Connect to/Disconnect from the network. 

/F3 
Start the default Internet browser in your operating system. 

/F4 
Access the Call interface. 

/F5 Access the SMS interface. 

/F6 
Access the Contacts interface. 

/F7 
Access the Call Log interface. 

 

Status Information on the Interface 

The status information displayed on the interface depends on the service that is going on. 
All the status and the descriptions are listed as follows. 

The following table lists the status information when the interface is being initialized and 
in minimized status. 

Status information Description 
Signal strength Displays the current network type and signal strength. The 

larger the number of the bars is, the stronger the signal is. 

Network Information about the network status. 

Duration of this 
connection 

Displays the duration of the current data connection. 

Volume of this 
connection 

Displays the volume of the current data connection. 

 

The following table lists the status information when the interface is maximized. 

Status information Description 
Signal strength Indicates the current network type and signal strength. 

Network The information about the network status. 
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Status information Description 
Connection  The duration of the current connection. 

 The data volume of the current connection. 
 The volume, rate and the top rate of the current sending and 

received data. 

Note: 
When a prompt for hibernate appears here, it 
indicates the data service is in hibernate status, and 
you can answer and make calls. 

Missed calls Displays the number of missed calls that have not been 
viewed in real-time. If there are any missed calls, the number 
blinks. 

New messages Displays the number of new messages in real-time. If there are 
any new messages, the number blinks. 

New SMS reports Displays the number of new SMS reports in real-time. If there 
are any new SMS reports, the number blinks. 

Voice mail waiting Displays the number of voice mail waiting in real-time. 
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7  Menu 

1  File 

    1.1 Connect/Disconnect 

    1.2 Import Contacts from File 

    1.3 Export Contacts to File 

    1.4 Contacts Storage Manager 

    1.5 SMS Storage Manager 

    1.6 Exit 

2  Tools 

    2.1 Open Browser 

    2.2 Call 

    2.3 SMS 

    2.4 Contacts 

    2.5 Call Log 

    2.6 Volume Statistic 

    2.7 Diagnostics 

3  Settings 

   3.1 Modify PIN Code 

   3.2 PIN Code Protection 

        3.2.1 Validate 

        3.2.2 Enable 

        3.2.3 Disable 

    3.3 Options 
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    3.4 SMS Settings 

    3.5 Network Connection Settings 

4  Help 

    4.1 Help Topics 

    4.2 HUAWEI Online Support 

    4.3 About 
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8  Internet Service 

Network Connection Settings 

Creating a Profile 

Select Settings > Network Connection Settings on the menu bar. 

Step Action 
1 Click New. 

2 Enter a new profile name in the Profile name field. 

3 Enter required relevant information for the settings. 

4 Click Save to finish. 

 

Note: 
 If you use the High-speed Packet Data Service to access the internet, enter 

#777 into the phone number. For more information, consult the network 
operator. 

 If you use the Low-speed Data Service Access to access the internet, consult 
the network operator for all the information to be entered. 

 

Deleting a Profile 

Select Settings > Network Connection Settings on the menu bar. 

Step Action 
1 In the Choose Profile Name field, select a profile to delete. 

2 Click Remove. 
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Modifying a Profile 

Select Settings > Network Connection Settings on the menu bar. 

Step Action 
1 In the Choose Profile Name field, select a profile to modify. 

2 Click Modify. 

3 Modify the profile. 

4 Click Save. 

 

Accessing the Internet 

Step Action 
1 Select Settings > Network Connection Settings. Choose a profile and click 

OK. 

2 Click  to set up a connection. 

3 When the connection is set up, click  or start the browser on your 
computer, and then you can access the Internet. 

4 Click  to disconnect from the network. 

 

Once the connection is established, the following detailed information about the network 
connection is displayed on the main interface: 

 The duration of the current connection 
 The data volume of the current connection 
 The volume, rate and the top rate of the current sending and received data 

Volume Statistic 
You can view the content of the volume statistic. 

Select Tools > Volume Statistic on the menu bar: 

 Last Volume Statistic: The volume of the last connection with the Internet, including 
sent and received volume statistic values and the duration of the connection. 
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 Total Volume Statistic: The total volume of all connections since the last reset, 
including sent and received volume statistic values and the duration of the connections. 

 Last Reset Time: Recording the time of your reset. 
 Reset: You can click it to clear the last volume statistic information and the total 

volume statistic information. 
 

Note: 
The above data of volume statistic is for your reference only. 
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9  Call Service 

When you use the call service, you need to insert the earphone to the earphone jack on 
the EC321. 

 

Note: 
 You can use the control key on the earphone to answer or reject an incoming 

call conveniently. 
 When there is an incoming call, you can press the control key to answer it. 
 When there is an incoming call, you can press and hold the control key to 

reject it. 
 During a call, you can press and hold the control key to end the call. 

 

Making a Call 
The EC321 provides many easy and quick ways to make calls. 

Entering a Telephone Number Directly 

You can make a call by entering a telephone number directly. 

Step Action 
1 Click  or select Tools > Call to display the Call interface. 

2 Enter a telephone number by one of the following ways: 
 Type the number directly on the keyboard of your computer. 
 Click the telephone keypad on the Call interface. 

3 Click  to make a call. 

4 Click  to hang up. 
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Note: 

You can press  to delete the number on the call interface digit by digit. 
You can press and hold  to clear the whole number. You can also press 
the backspace key to do this. 

 

Selecting a Telephone Number in the Contact List 

You can make a call by selecting a telephone number in the contact list. 

Step Action 
1 Click  or select Tools > Call to display the Call interface. 

2 Click , and the Contacts interface is displayed. Double-click a 
contact or select a contact and then click Call. 
 If only one number in the selected contact, the number is displayed on the 

Call interface and dialed out. 
 If two or more number(s) in the contact, double-click the selected number in 

the pop-up Select Phone Number interface or click Call after selecting the 
number. The selected number is displayed on the Call interface and dialed 
out. 

3 Click  to hang up. 

 

Selecting a Recently Dialed Number 

You may make a call by selecting a number from the recently dialed numbers. 

Step Action 
1 Click  or select Tools > Call to display the Call interface. 

2 Click  to display a list of 10 recently dialed numbers. Double-click the 
selected number or click Call after selecting the number. Then the number is 
dialed out. 

3 Click  to hang up. 
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Answering a Call 
The default alert mode of the EC321 for incoming calls is by sound. You can select 
Settings > Options to set the mode. You can select the sound alert or display alert. For 
details, refer to "System Settings." 

When you have any missed calls, the amount of missed calls is displayed in real-time 
under the status information on the main interface. 

With the Setting of Sound Alert 

When there is an incoming call, you can hear the sound alert. 

Step Action 
1 Click  or select Tools > Call to display the Call interface. 

2 Click  to answer a call. 

3 Click  to hang up. 

 

With the Setting of Display Alert 

An alert window is displayed when there is an incoming call. You can choose to the 
options in the following table. 

Option Description 
Click Answer Answer the call. 

Click Reject Reject the call. 

 

Supplementary Services 
The EC321 data card supports the following supplementary services: 

 Call forwarding (Busy) 
 Call forwarding (Default) 
 Call forwarding (No Answer) 
 Call forwarding (Unconditional) 
 Call waiting 
 Three-way calling 
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 Caller ID display 
 Conference Call 

To use the supplementary services, you need the operator to enable them. For details of 
the operation, consult the network operator. 

Volume Adjustment and Mute 

Click  or select Tools > Call. Then the Call interface is displayed. You can adjust the 
volume at any time. You can also mute your voice so that the person you are talking to 
cannot hear you even though the line is still active. 

 To increase the volume, press . 
 To decrease the volume, press . 
 To mute your voice, press . 

 To resume normal talk, press . 

Shortcut Keys for Call Service 
The following table lists the shortcut keys and their functions. 

Shortcut 
keys 

Description 

Enter  After entering a call number, press Enter to make the call. 

 Press Enter to answer an incoming call. 

Ctrl + B The shortcut key for . 

Ctrl + D The shortcut key for . 

Ctrl + H The shortcut key for . 

Ctrl + +/- The shortcut key for volume adjustment. 
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10  SMS 

Sending and Receiving a Message 

Writing a New Message 

Click  or select Tools > SMS, Then the SMS interface is displayed. 

Step Action 
1 Click Write and the Write interface is displayed. 

2 Enter the telephone number(s). 
You can enter one or more number(s) by one of the following ways: 
 To enter one or more numbers directly: In the Contacts textbox, enter the 

numbers separated by semicolons ";". 
 To select a number from the contacts: Click Contacts. Select one or more 

contact(s) and click OK. Select the number to send a message in the pop-up 
dialog box and click OK. 

Note: 
 You can directly enter the numbers or select the numbers in the 

contacts. 
 When you select more than one contact, you can press Shift to 

select a sequence of contacts, or press Ctrl to select the contacts one 
by one. 

 If you select several receivers, click the Apply to all items check 
box to simplify the following operations. 

3 Input the message, the character number is displayed in real-time on the upper 
right of the Contacts text box. The maximum length of each message is 1000 
characters. 
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Step Action 
4  Click Send to send the message.  

After the message is sent successfully, it is automatically saved to the 
Outbox. If the message is sent unsuccessfully, you are prompted whether to 
send it again. If you cancel the sending, the message is saved to the Outbox. 

 Click Save to save the message to the Draft. 
 Click Clear to clear the contacts and the message content. 

 

Note: 
 The EC321 supports to send a message to a group of up to 20 numbers. 
 When your message contains no more than 160 characters, it is sent as one 

message. If this limit is exceeded, the message is divided into several 
messages and sent one by one. 

 When you use the SMS service, you can always operate in this way to display 
the Write interface or select contacts. 

 

Inbox 

The Inbox stores the messages you have received. It supports up to 1000 messages. 

When the Inbox is full and a new message is coming, the earliest message in the Inbox is 
removed automatically to the Trash. 

The number of unread messages is displayed under the status information on the main 
interface in real-time, if any such message exists. 

In the SMS interface, click Inbox and the Inbox is displayed. 

Viewing a Message in the Inbox 
1. You can view a message in the Inbox directly. 
You can do as follows to browser and view the message in the Inbox. 

Step Action 
1 Click  or select Tools > SMS to display the SMS interface. 

2 Click Inbox to open and browse the Inbox. Double-click a message to view the 
detailed content. 

 

There are two types of icons in the Inbox: 

 : Indicating an unread message. 
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 : Indicating a read message. 

Note: 

If a message is locked,  is displayed in front of the message. 

 

2. You can view a message when there is a new message. 
Select Settings > Options to set the alert mode. You can be alerted to a new message in 
different ways. You can select Sound alert or Display alert. For details, refer to "System 
Settings." 

 If the sound alert is enabled: 
When there is a new message, you can hear the sound alert. 

Step Action 
1 Click  or select Tools > SMS to display the SMS interface. 

2 Click Inbox to view the Inbox and check the new message. Double-click the 
message to view the detailed content. 

 

 If the display alert is enabled: 
When there is a new message, you can see the alert window. 

Option Description 
Click View on the 
alert window 

The content of the message is displayed. 

Click Close on the 
alert window 

The content of the message is not displayed. 

 

Replying a Message 
You can reply to a message directly in the Inbox. 
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Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Reply. 

2 The telephone number of the original sender appears automatically in the blank 
field behind Contacts and you can change it. 

3 Input the content for the message to reply. 

4 Click Send. 

 

Forwarding a Message 
You can forward a received message in the Inbox. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Forward. 

2 Input the telephone number to forward to, or click Contacts to select the 
number. 

3 The content of the message to forward displays automatically in the text box. 
You can edit it. 

4 Click Send to forward the message. 

 

Making a Call 
You can call back the number of a message sender. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Call. 

2 The Call interface is displayed. The number of the sender is displayed and 
dialed out automatically at the same time. 

 

Deleting a Message 
You can delete a received message. 
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Step Action 
1  Select one or more message(s) and click Delete. 

 Double-click a message to display the interface with the detailed contents 
and click Delete. 

2 The message(s) can be removed to the Trash. 

 

Locking/Unlocking a Message 
You can lock or unlock a received message to prevent the message from being deleted 
accidentally. 

Step Action 
1 Select one or more message(s) and right-click. 

2  Select Lock to lock the messages; 
 Select Unlock to unlock the messages. 

 

Saving a Number 
You can save the number of a message sender to your contacts. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Get Number. 

2 The New interface is displayed, and the number of the message sender displays 
automatically in the blank field behind Mobile Number. 

3 Input the required information of this number. 

4 Click Save. 

 

Outbox 

The messages you have sent out are saved in the Outbox. Up to 1000 messages can be 
stored in this box. When the Outbox is full and an additional message is coming, the 
earliest message in the Outbox is removed to the Trash automatically. 

In the SMS interface, click Outbox and the Outbox is displayed. 

Viewing a Message in the Outbox 
You can display the Outbox to check and view messages. 
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Step Action 
1 You can browse all the messages in the Outbox. 

2 Double-click a message to view the detailed contents. 

 

Sending a Message 
In the Outbox, you can send a new message to the receiver you have already sent a 
message to. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Send. 

2 The telephone numbers of the receivers whom the message has been sent to are 
displayed automatically in the blank field behind Contacts. You can change 
these numbers. 

3 Input the content for the new message. 

4 Click Send to send the new message. 

 

Forwarding a Message 
In the Outbox, you can forward a message that has already been sent out. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Forward. 

2 Enter the telephone number to forward to in the blank field behind the 
Contacts, or click Contacts to select the number. 

3 The content of the message to forward displays automatically in the text box. 
You can edit it. 

4 Click Send to forward the message. 

 

Making a Call 
In the Outbox, you can dial a number of a receiver whom a message has been sent to. 
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Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Call. 

2 The Call interface is displayed. The number of the receiver whom the message 
has been sent to appears on the interface and the number is dialed 
automatically at the same time. 

 

Deleting a Message 
You can delete a message in the Outbox. 

Step Action 
1  Select one or more message(s) and click Delete; 

 Double-click a message to display the interface with the detailed contents 
then click Delete. 

2 The message(s) can be removed to the Trash. 

 

Locking/Unlocking a Message 
You can lock or unlock a received message to prevent the message from being deleted 
accidentally. 

Step Action 
1 Select one or more message(s) and right-click. 

2  Select Lock to lock the message; 
 Select Unlock to unlock the message. 

 

Saving a Number 
You can save the receiver number of a message in the Outbox to your contacts. 

Step Action 
1 Select a message or double-click it to display the interface with the detailed 

contents and click Get Number. 

2 The New interface is displayed, and the number of the message receiver 
appears automatically in the Mobile column. 

3 Input the required information of the number. 

4 Click Save. 
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Draft 

The message that you write on the Write window, if having been saved, can be stored in 
the Draft. Up to 1000 messages can be stored in the Draft. 

When you save a message, only the message content can be saved in the Draft. The 
designated number cannot be saved. 

In the SMS interface, click Draft and the Draft is displayed. 

Editing a Message 
You can edit a message in the Draft. 

Step Action 
1  Select a message and click Edit; 

 Double-click a message. 
2 When the Write interface is displayed, change the information and select 

Send, Save, or Clear. 

 

Deleting a Message 
You can delete a message in the Draft. 

Step Action 
1 Select one or more message(s) and click Delete. 

2 The message(s) can be removed to the Trash. 

 

Trash 

The message you deleted from the Inbox, Outbox and Draft are all removed to the Trash. 
Up to 1000 messages can be stored in the Trash. 

When the Trash is full and another message is removed to it, the earliest message in the 
Trash is removed automatically. 

In the SMS interface, click Trash and the Trash is displayed. 

Restoring a Message 
You can restore a message in the Trash to the original box. 
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Step Action 
1 Select one or more message(s) and click Restore. 

2 The message(s) can be restored to the original box before it is removed. 

 

Deleting a Message 
If you delete a message in the Trash, it is permanently removed. 

Step Action 
1 Select one or more message(s) and click Delete. 

2 If you are sure to do this, click OK and the message(s) can be removed 
permanently. 

 

Reports 

The Reports saves the received message reports. Up to 1000 message reports can be 
stored in the Reports. When the box is full and another report is coming in, the earliest 
report in this box is removed automatically. 

In the SMS interface, click Reports and the Reports is displayed. 

Step Action 
1 Select one or more message(s) and click Delete. 

2 If you are sure, click OK and the return notification message is removed. 

 

Message Storage Management 
Select File > SMS Storage Manager and then you can import the messages saved in the 
computer, UIM card and EC321 memory from one to another. 

Note: 
 With the message storage management, you can copy/move messages 

between different memories in mailboxes of the same type. Messages cannot 
be copied or moved to the mailboxes of different types. You cannot 
copy/move messages in the Reports or Draft. 

 The messages saved in the EC321 memory can be lost because of the changes 
of the UIM card and PC. 
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 WMI Box: Waiting voice message indicator box. 
 

Step Action 
1 In the SMS Storage Manager interface, select the source position and the aim 

position of importing. 

2 Select an operation mode: 
 Copy: The message at the source position is kept. 
 Move: The message at the source position is deleted. 

3 Select the message at the source position. 

 Click  to import the message from the left of the arrow to the 
right. 

 Click  to import the message from the right of the arrow to the 
left. 

 

You can export the messages saved in the computer, UIM card and HUAWEI Mobile 
Connect memory to a file. 

Step Action 
1 Select one or more message(s), and then right-click. 

2 Select export to file. In the Save as… dialog box, enter a file name with .txt as 
its extension. 

3 Click Save, and the messages are exported to the file. 

 

SMS Settings 
Select Settings > SMS Settings to display the SMS settings interface. 

Option Description 
Reports You can enable or disable this function. If the function is 

enabled, after you send a message, the network can send a 
message to inform you that the receiver has got the message 
you have sent. 

Priority Select the priority level for sending a message. 
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Note: 
If no storage space is available in your UIM card for the reports, the Request 
status report option is invalid. For details, contact your UIM card provider. 
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11  Managing Your Contacts 

The EC321 can store up to 1000 contacts. 

You can create, modify and delete the contacts. You can also send messages, make calls 
to the contacts. The EC321 also supports the import/export of the contacts for your 
convenience to manage the contacts. 

Managing the Items in the Contacts 

Click  or select Tools > Contacts to display the Contacts interface. 

Creating a Contact 

The following table lists the procedure for creating a contact. 

Step Action 
1 Click New. 

2 Fill in the Name, Mobile Number, Family Phone Number, Office Phone 
number, E-mail addresses, and/or the Comments. 

3 Click Save to save a new contact to the Contacts. 

 

Modifying a Contact 

The following table lists the procedure for modifying a contact. 

Step Action 
1 Select a contact to modify in the Contacts. Double-click the contact or click 

Edit. 

2 Modify the contact. 

3 Click Save. 
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Deleting a Contact 

The following table lists the procedure for deleting a contact. 

Step Action 
1 Select one or more contact(s) to delete from the Contacts and click Delete. 

2 Click OK to confirm. 

 

Sending a Message 

The EC321 allows you to select a number from the contact and send a message. The 
following table lists the procedure. 

Step Action 
1 Select one or more contact(s) from the Contacts. 

2 Click Send. The EC321 picks up the number in the selected contact, and the 
Write SMS interface is displayed. 

3 The retrieved numbers appear in the blank field behind the Contacts. Input the 
content for the message and click Send. 

 

Making a Call 

You can dial out the number you have selected from the contacts. The following table 
lists the procedure. 

Step Action 
1 Select a contact that contains the number to dial from the contacts, and click 

Call. 

2  If the selected contact contains only one telephone number, the Call 
interface is displayed automatically. 

 If two or more telephone numbers are contained in the selected contact, the 
Select Phone Number window is displayed and you are prompted to select 
one number. After doing that, click Call and the Call interface is displayed. 

3 The selected number appears on the Call interface automatically and dialed out 
automatically at the same time. 
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Searching a Contact 

The EC321 provides the function of searching a contact in the Contacts. 

Step Action 
1 Click Search. 

2  Select a field item such as Name, Mobile, Family, Office or E-mail from the 
pull down list in the Condition area. 

 Enter relevant searching terms in the Value text box. 
 Choose Match Whole Word Only and/or Match Case for Matching Type.

3 Click Search Now to begin to search. 

4 Click Stop Search to stop searching. 

 

Importing/Exporting a Contact 

Importing a Contact 

The EC321 allows you to import the contacts from a file in a specified format to the 
EC321 Contacts. 

The EC321 supports for importing of the *.txt and *.csv files. 

Step Action 
1 Select File > Import Contacts From File. 

2 In the Open window, select a file to import. 

3 Click Open, and the contacts in the file are imported to the EC321 Contacts 
automatically. 

 

Exporting a Contact 

The EC321 allows you to export the contacts from the EC321 Contacts to a file. The 
following table lists the procedure. 

Step Action 
1 Select File > Export Contacts To File. 

2 In the Save as window, input a file name with .csv as its extension. 
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Step Action 
3 Click Save, and the contacts in the EC321 Contacts are exported to the 

specified file. 

Note: 
An error can occur to the re-imported files if the exported files have been 
modified. 

 

Contacts Storage Management 

Select File > Contacts Storage Manager, and then you can import the contacts saved in 
the computer, UIM card and EC321 Memory from one to another. 

 

Note: 
The contacts information saved in the EC321 Memory can be lost because of the 
changes of the UIM card and PC. 

 

Step Action 
1 In the Contacts Manager window, you can select the source position and the 

aim position for importing. 

2 Select an operation mode: 
 Copy: The contact information at the source position is kept 
 Move: The contact information at the source position is deleted 

3 Select the contact information at the source position.  

 Click  to import the contact information from the left of the arrow 
to the right. 

 Click  to import the contacts information from the right of the 
arrow to the left. 
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12  Call Logs 

The call log contains information about dialed, received and missed calls. Each kind of 
call log supports up to 1000 items. 

Click  or select Tools > Call Log to display the Call Log interface. 

Missed Calls 
Click Missed calls, and the Missed Calls interface is displayed. 

Sending a Message 

You can send a message to the numbers of missed calls. 

Step Action 
1 Select one or more item(s). 

2 Click Send, and then the EC321 automatically retrieves the numbers in the 
selected items, and the Write SMS interface is displayed. 

3 The retrieved numbers are automatically displayed in the blank field behind the 
Contacts. Input the content for the message and click Send. 

 

Making a Call 

You can dial the number of a missed call. 

Step Action 
1 Select an item. 

2 Click Call. 

3 The Call interface is displayed The selected number appears on the interface 
and dialed out automatically at the same time. 
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Saving a Number 

You can save the number of a missed call. 

Step Action 
1 Select an item. 

2 Click Get Number. 

3 The New interface is displayed. By default, the EC321 saves the number of the 
selected item to the Mobile column in the Contacts. You can change the 
number if the number is not corresponding to the Mobile column. 

4 Click Save. 

 

Deleting a Missed Call 

You can delete an item from the missed calls. 

Step Action 
1 Select one or more item(s). 

2 Click Delete. Click OK to confirm. 

 

Received Calls 
Click Received calls, and the Received calls interface is displayed. 

Sending a Message 

You can send a message to the numbers of received calls. 

Step Action 
1 Select one or more item(s). 

2 Click Send, and the EC321 automatically retrieves the numbers in the items 
you select, and the Write SMS interface is displayed. 

3 The numbers retrieved automatically are displayed in the blank field behind the 
Contacts. Input the content for the message and click Send. 
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Making a Call 

You can dial the number of a received call. 

Step Action 
1 Select an item. 

2 Click Call. 

3 The Call interface is displayed, and the selected number you appears 
automatically on the interface, and, dialed out automatically at the same time. 

 

Saving a Number 

You can save the number of a received call. 

Step Action 
1 Select an item. 

2 Click Get Number. 

3 The New contacts interface is displayed. By default, the EC321 saves the 
number to the Mobile column in the Contacts. You can change the number if 
the number is not corresponding to the Mobile column. 

4 Click Save. 

 

Deleting a Received Call 

You can delete an item from the received calls. 

Step Action 
1 Select one or more item(s). 

2 Click Delete. Click OK to confirm. 

 

Dialed Calls 
Click Dialed calls, and the Dialed calls interface is displayed. 
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Sending a Message 

You can send a message to the numbers of the dialed calls. 

Step Action 
1 Select one or more item(s). 

2 Click Send. The EC321 automatically retrieves the selected numbers, and the 
Write SMS interface is displayed. 

3 The retrieved numbers automatically are displayed in the blank field behind the 
Contacts. Input the content for the message and click Send. 

 

Making a Call 

You can dial the number of a dialed call. 

Step Action 
1 Select an item. 

2 Click Call. 

3 The Call interface is displayed, and the selected number appears automatically 
on the interface, and dialed out automatically at the same time. 

 

Saving a Number 

You can save the number of a dialed call. 

Step Action 
1 Select an item. 

2 Click Get Number. 

3 The New contacts interface is displayed. By default, the EC321 saves the 
number to the Mobile column in the contacts. You can change the number if 
the number is not corresponding to the Mobile column. 

4 Click Save. 
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Deleting a Dialed Call 

You can delete items from the dialed calls. 

Step Action 
1 Select one or more item(s). 

2 Click Delete. Click OK to confirm. 
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13  PC Fax 

The EC321 supports the service of PC fax. You can select PC fax software freely. 

Step Action 
1 Be sure that you have installed the management program for data card 

completely and the data card is inserted into the computer. 

2 Install the fax software on the computer. 

3 Select "HUAWEI Mobile Connect-3G Modem" as the modem for the PC fax 
software. 

4 Follow the relevant descriptions of the PC fax software to operate the fax. 

 

Note: 
This function needs to be supported by the network. For more information, 
consult the local network operator. 
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14  Settings and Information 
Query 

PIN Code Management 
The PIN code is used to prevent your UIM card from the invalid use. The PIN code is 
provided along with your UIM card. You can change your PIN code, and you can also 
enable/disable the PIN feature. If you enable the feature, you need to enter the PIN code 
when the EC321 starts up. 

PIN Code Modification 

You can change your PIN code. 

Step Action 
1 Select Settings > Modify PIN Code. 

2 Enter the current PIN code and the new PIN code. Enter the new code again to 
confirm it. 

3 Click OK to modify it. 

 

PIN Code Validation 

After accessing the EC321 management program, you can still use the function of PIN 
code validation. 

Step Action 
1 Select Settings > PIN Code Protection. 

2 Select Validate, and you can access the PIN code validation flow which is the 
same as that when the EC manager starts. For more information, refer to the 
descriptions on page 11. 
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PIN Code Protection 

You can enable/disable the PIN feature. If the feature is enabled, you need to enter a PIN 
code when the EC321 is started. Otherwise, you need not to do this. 

Step Action 
1 Select Settings > PIN Code Protection. 

2 Select Enable/Disable. After that, you need to enter the PIN code according to 
the prompt. 
 Enable: You need to enter the PIN code when the EC321 is started. 
 Disable: You need not to enter the PIN code when the EC321 is started. 

 

System Settings 
The system settings include the startup mode of the EC321 manager, the alert mode for 
incoming calls, the alert mode for messages, and so on. 

Select Settings > Options. 

Startup 

Click the Startup tab, and you can set the EC321 manager to start along with the 
Windows, or to be displayed in the minimized mode when it starts. 

Option Description 
Launch this 
application when 
Windows starts up 

The EC321 manager starts along with the Windows. 

Minimize main 
window after startup 

The program is displayed in the minimized mode when it 
starts. 

Check unread 
message(s) while 
starting 

When the program starts, it checks the unread messages in the 
UIM card and the data card. 
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Call Alerts Settings 

Click the Call Alerts tab. By default, the EC321 sounds whenever a call comes. 
Meanwhile, an alert window can also be displayed if you select the option. 

Option Description 
Alert window Check the check box, and an alert window is displayed 

whenever a call comes. 
 Click Answer to answer the call. 
 Click Reject to reject the call. 

Sound file  Click Browse to select a sound file. 
 Click Play to hear the sound. 

If a sound file is selected, it plays on the sound card of 
computer whenever a call comes. 

Earphone alert tone Check the check box. The ring sounds on the earphone of data 
card when a call comes. 

 

Note: 
An alert file can be *.wav and *.mid files. 

 

SMS Alerts Settings 

Click the SMS Alerts tab. You can select the sound alert and display alert. 

Option Description 
Alert window Check the box, and an alert window is displayed whenever a 

new message comes. 
 Click View to see the new message. 
 Click Close to leave the message unseen. 

Alert tone  Click Browse to select a sound file. 
 Click Play to hear the sound. 

If a sound file is selected, it plays on the earphone of data card 
whenever a new message comes. 

 

Note: 
An alert file can be *.wav and *.mid files. 
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Standby/Hibernate Settings 

Click the Standby/Hibernate tab, and you have the following options. 

Option Description 
Prevent 
Standby/Hibernate 

To prevent the computer from standby or hibernate mode.

Allow 
Standby/Hibernate 

To allow the computer to start the standby or hibernate 
mode. 

 

Note: 
 Even though Prevent Standby/Hibernate is selected, you can transfer the PC 

into Standby/Hibernate status manually under the Windows Vista operating 
system. 

 Select Settings > Options, and then you can set the default values on each tab. 
To recover the current default configuration, click Default. 

Diagnostics 
The EC321 allows you to query information about the EC321 and the UIM card. 

Select Tools > Diagnostics. 

 Messages in Wireless Device: This information is displayed in the format of 
"XX/YY". "XX" indicates the amount of the existing messages, and "YY" indicates 
the capacity of the data card. 

 Contacts in Wireless Device: This information is displayed in the format of "XX/YY". 
"XX" indicates the amount of the existing contacts, and "YY" indicates the capacity of 
the data card. 

 Messages in UIM: This information is displayed in the format of "XX/YY". "XX" 
indicates the amount of the existing messages, and "YY" indicates the capacity of the 
UIM card. 

 Contacts in UIM: This information is displayed in the format of "XX/YY". "XX" 
indicates the amount of the existing contacts, and "YY" indicates the capacity of the 
UIM card. 

 ESN Number: The ESN number of the hardware(EC321 or UIM card). 
 API Version: The version of the API. 
 Firmware Version: The board software version of the EC321. 
 Hardware Version: The hardware version of the EC321. 
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15  Technical Parameters 

Item Description 
PC card type Type II, 68 Pin, CARDBUS 

Radio system CDMA2000 1x: 
 EC301: 450 MHz 
 EC321: 800 MHz 
 EC351: 1900 MHz 

Radio frequency band  EC301: 
450 MHz Band Block A: 
Reverse Link: 452.5–457.5 MHz 
Forward Link: 462.5–467.5 MHz 
450 MHz Band Block C: 
Reverse Link: 450.0–454.8 MHz 
Forward Link: 460.0–464.8 MHz 
 EC321: 

Reverse Link: 824–849 MHz 
Forward Link: 869–894 MHz 
 EC351: 

Reverse Link: 1850–1910 MHz 
Forward Link: 1930–1990 MHz 

Radio power output > 200 mW 

Services  Voice Service: 8K EVRC 
 High Speed Packet Data Service: Maximum Data 

Rate 153.6 kbps/Reverse Link, 153.6 kbps/Forward 
Link 

 Asynchronous Data Service: Maximum Data Rate 
14.4 kbps 

 PC Fax: Maximum Data Rate 14.4 kbps 
 Short Message Service 

Dimensions (D % W % H) 88.4 mm % 54 mm % 5 mm 

Weight Approx. 50 g 
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Item Description 
Battery Powered by the PC card slot, uses laptop battery 

Operating temperature –10oC to +55oC 

Storage temperature –20oC to +65oC 
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16  FAQs on the EC321 Data Card 

How to Judge Whether the EC321 Data Card Has Been Installed 
Correctly? 
After installing the EC321 Data Card, two devices are displayed in the device manager, 
namely, the "HUAWEI Mobile Connect-3G Modem" and the "HUAWEI Mobile 
Conncet-3G Application Interface". 

Check whether these two devices are installed correctly at first. If a yellow exclamatory 
mark or other signs appear in front of the devices, it means that the data card has not been 
installed correctly, and you need to retry. 

After Installing the EC321 Management Software, the System 
Always Prompts "Data Card does not Exist". Why? 
Probably you have inserted the data card before the completion of installing the EC321 
management software. Pull out the data card and insert it after the installation of EC321 
management software is completed. Then, install the EC321 hardware driver by 
following the guide for the hardware installation. 

After Installing the EC321 Management Software, the System 
Always Prompts "Unidentified USB device". Why? 
If the prompt "Unidentified USB device" displays on the task bar, your data card still can 
be used. 

What Shall I Do If I Cannot Access the Internet? 
1. Check whether you have activated the wireless online service at first. Ask the local 

network operator for how to activate it. 
2. If you are sure that the wireless online service has been activated, refer to "Internet 

Service" to implement relevant settings. 

Only Part of the Message Is Displayed After I Use the "Paste" 
Function to Edit It. Why? 
While editing the message, at most 1000 characters are supported in the text. If the 
quantity of the pasted information exceeds the limitation, the exceeded part will be 
deleted automatically. 

When a Message Is Received, No Prompt Displays. Why? 
Because you have not set the SMS Alerts function. 
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Select Settings > Options, and then check Message alerts settings on the SMS Alerts 
tab. 

How to Dial the Telephone Numbers with "+" Sign? 
Double-click the */+ key on the telephone service interface, or input it through the PC 
keyboard. 

Why I Cannot Paste the Telephone Numbers? 
Telephone numbers that only contains "0123456789#*+" are legal. Confirm no other 
character is contained in the cut or pasted texts. 
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17  Warnings and Precautions 

Electronic Device 
 Switch off your wireless data card near high-precision electronic devices. The wireless 

data card may affect the performance of these devices. 
 Such devices include hearing aids, pacemakers, fire alarm systems, automatic gates, 

and other automatic-control devices. If you are using an electronic medical device, 
consult the device manufacturer and confirm whether the radio wave affects the 
operation of this electronic device. 

Hospital 
Pay attention to the following points in hospitals or health care facilities: 

 Do not take your wireless data card into the operating room (OR), intensive care unit 
(ICU), or coronary care unit (CCU). 

 Do not use your wireless data card at places for medical treatment where it is 
prohibited to use wireless devices. 

Area with Flammables and Explosives 
In the area with inflammables and explosives, disconnect your wireless data card from 
your PC and turn off the PC to avoid explosion and fire. The area with inflammables and 
explosives include: 

 Gas station 
 Area for storing fuels (such as the bunk under the deck of a ship) 
 Device/Vehicle for transporting and storing fuels or chemical products 
 Area with chemical substances and particles (such as: granule, dust, metal powder) in 

the air 
 Area with the sign of Explosives 
 Area with the sign of Turn off bi-direction wireless equipment. 
 Area where it is generally suggested to stop the engine or a vehicle 
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Traffic Safety 
 Observe the relevant regulation of the area or country where you are. Do not use your 

wireless data card while driving to avoid traffic accident. 
 Secure the wireless data card on its holder. Do not place the wireless data card on the 

seat or other places where it can get loose in a sudden stop or collision. Use the 
wireless data card after the vehicle stops at a safety place. 

 Do not place the wireless data card over the air bag or in the air bag outspread area. 
Otherwise, the wireless data card may hurt you owing to the strong force when the air 
bag inflates. 

 Observe the rules and regulations of airline companies. On or nearby a plane, 
disconnect the wireless data card from your PC and turn off the PC. In areas where it is 
prohibited to use wireless device, do not use the wireless data card. Otherwise, the 
wireless signal of the wireless data card can disturb the plane control signals. 
Disconnect the wireless data card from your PC and turn off the PC before boarding an 
aircraft. 

Storage Environment 
 Do not place magnetic storage media such as magnetic cards and floppy disks near the 

wireless data card. Radiation from the wireless data card may erase the information 
stored on them. 

 Do not put your wireless data card in containers with strong magnetic field, such as an 
induction cooker and a microwave oven. Otherwise, circuit failure, fire, or explosion 
can be caused. 

 Do not leave your wireless data card in a very hot or cold place. Otherwise, 
malfunction of the products, fire, or explosion can be caused. 

 If your PC is equipped with earphones, do not place sharp metal objects such as pins 
near the earphones. The earphones may attract these objects and hurt you when you are 
using the wireless data card. 

 Do not put your wireless data card in the pocket on the back side of trousers or a skirt 
to avoid wireless data card damage while seating. 

Children Safety 
 Put your wireless data card in places beyond the reach of children. Do not allow 

children to use the wireless data card without guidance. 
 Do not allow children to touch the small fittings. Otherwise, suffocation or gullet jam 

can be caused if children swallow the small fittings. 
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Operating Environment 
 The wireless data card is not water-resistant. Keep it dry. Protect the wireless data card 

from water or vapor. Do not touch the wireless data card with a wet hand. Otherwise, 
short-circuit and malfunction of the product or electric shock can be caused. 

 Do not use the wireless data card in dusty, damp and dirty places or places with 
magnetic field. Otherwise, malfunction of the circuit can be caused. 

 Do not connect or disconnect the wireless data card when it is near your ears to avoid 
negative impact on your health. 

 When you carry or use the wireless data card, keep it at least one inch (2.5 cm) away 
from your body, to avoid negative impact on your health caused by radio frequency 
leakage. 

 On a thunder stormy day, do not use your wireless data card outdoors. 
 Do not touch the wireless data card when it is running. This may affect call quality and 

cause the wireless data card to operate with more power. 
 The wireless data card may interfere nearby TV sets and radios. 
 In accordance with the international standards for radio frequency and radiation, use 

wireless data card accessories approved by Huawei only. 

Cleaning and Maintenance 
 Before you clean or maintain the wireless data card, disconnect your wireless data card 

from your PC and turn off the PC. Otherwise, electric shock or short-circuit may be 
caused. 

 Do not use any chemical detergent, powder, or other chemical agent (such as alcohol 
and benzene) to clean the wireless data card. Otherwise, part damage or a fire can be 
caused. You can clean the wireless data card with a piece of soft antistatic cloth that is 
a little wet. 

 Do not scratch the shell of the wireless data card. Otherwise, the shed coating may 
cause skin allergy. Once it happens, stop using the wireless data card at once and go to 
see a doctor. 

 If the wireless data card or any of its fittings does not work, turn to the local authorize 
service center for help. 

Environmental Care 
Observe the local regulations regarding the disposal of your packaging materials, old 
wireless data card and promote their recycling. Do not dispose of an old wireless data 
card in a dustbin or fire. Otherwise, explosion can be caused 
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Emergency Call 
You can use your wireless data card for emergency calls. However, connections in all 
conditions cannot be guaranteed. You should never rely solely on the wireless data card 
for essential communications. 

Exposure to Electromagnetic Energy 
This product is designed not to exceed the limits for exposure to electromagnetic energy 
set by International Commission on Non-ionizing Radiation Protection (ICNIRP). The 
limits include a margin designed to assure the safety of all persons, regardless of age and 
health. The rules for exposure to electromagnetic energy adopt SAR value as the basis of 
judgment. The SAR value is measured in a standard mode. That is, this wireless product 
transmits with maximum transmit power in the bands it use during the measuring. The 
SAR value limit suggested by ICNIRP is 2 W/kg (10 g Average). By measuring, the 
maximum SAR value of this wireless product is 0.169 W/kg (10 g Average). 
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18  Abbreviations and 
Acronyms 

C  

CDMA Code Division Multiple Access 

  

E  
ESN Electronic Serial Number 

EVRC Enhanced Variable Rate Coder 

  

G  

GUI General User Interface 

  

P  

PIN Personal Identification Number 

PUK PIN Unblocking Key 

  

S  

SMS Short Message Service 

  

U  

UIM User Identity Module 
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