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Image Re-Sizing 

When you insert an image on to your SharpSchool site, you are given the option to re-size 

the display. This process, however, does not re-size the image itself; only the appearance of 

the image is changed. As such if you have a high quality 3000 pixel by 3000 pixel image that 

you want to display on the site at 200 pixels by 200 pixels, anyone visiting the site will still be 

downloading a 3000 pixel by 3000 pixel file. As you might imagine if you have a lot of these 

larger images on your site it can make the site take longer to load, particularly for users on a 

slow internet connection.  

 

To save users from unnecessarily downloading more data than they need, the best option is 

to re-size the files so that the 200 by 200 pixel image the user is looking at is coming from a 

200 by 200 pixel file. In many cases, a 200 by 200 pixel file will be less than 1/100th the size 

of a 3000 by 3000 pixel version of the file even though the two files will look identical to the 

user.  

 

There are a vast number of programs and methods for re-sizing an image. This guide will 

focus on four: Thumbnail Creator found within the RadEditor, Adobe Photoshop, GIMP 

and Microsoft Office Picture Manager. 
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SharpSchool’s Thumbnail Creator 

If you would like to be able to re-size your image so that the dimensions on-screen are the 

same as the file itself, the Thumbnail Creator that is part of the SharpSchool solution is a 

good option. One advantage of this option is that it is the easiest way to re-size images that 

have already been uploaded to the Image Manager. Another advantage is that it requires no 

additional software from the user; any user who can edit a page can use the Thumbnail 

Creator.  

 

The easiest way to access the Thumbnail Creator is to go to the Image Manager (by clicking 

this icon  inside of the editor). Find the file you want to re-size, left-click on it and then 

click on the Create Thumbnail  icon.  
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Once you click the Create Thumbnail icon, you will have a range of options to configure: 

 

New Image Name: By default, the word “thumbnail” will be added to the end of the file 

name (for instance, 2004_mrm_16_05.jpg becomes 2004_mrm_16_05thumbnail.jpg). If you 

are not happy with the default name, you may choose another.  

 

Width and Height: These two fields allow you to set the specific width and height you 

would like for an image. For maximum efficiency you should enter the exact dimensions you 

intend to use on the page. 

 

Dimension Unit: This allows you to choose between setting the Width and Height by 

pixel or percent. The pixel setting means the image will be that many pixels in height/width 

and the percent setting means that the image will be re-sized by that amount relative to the 

original. For instance, if you enter 50 for the height and width, the new image will be half the 

height and half the width of the original.  

 

Constrain Proportions: If this is checked, any change you make to the Width will 

automatically change the Height to keep the image ratio the same (and vice versa). For 

example, if you have an image that is 1000 pixels in height and 600 pixels in width, changing 

the height to 100 pixels will automatically change the width to 60 pixels.  

 

Note: If you uncheck constrain proportions you should still try to keep the image ratio as 

close to the original ratio as possible or your image may appear distorted.  

 

Overwrite if file with such name exists: If this is checked, creating a new thumbnail will 

overwrite an existing file with the same filename. This can be useful if you are not happy 

with a previous thumbnail and decide to replace it.  
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Click the Create button when you have configured your thumbnail settings. You will then 

have a thumbnail that you can insert on to a page just like any other image. In the case of 

our example file, we have gone from a 4.21 MB file to a file less than 10 kb in size.  
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Adobe Photoshop 

The advantage of using an image editing program like Adobe Photoshop is that you have 

complete control over the image. You can change the dimensions of the image, alter the 

resolution and choose the file quality. 

 

Tip: Photoshop can also be used for cropping images, adjusting brightness/contrast, 

tweaking colors, etc. For more information on those features, consult the in-program help or 

one of any number of tutorials available online.  

 

To start editing an image in Photoshop, launch Photoshop and click File -> Open. Choose 

the image you wish to edit and click Open.  

 
Now click Image -> Image Size.  
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You will be presented with a range of Image Size configuration options. Unless you have a 

lot of experience working with Photoshop, most of these should be left as is. The ones you 

will want to change are: 

 

Width and Height: These allow you to choose the width and height of the image. You may 

configure them by pixels or by percent by clicking the dropdown menu and selecting your 

preferred choice. The pixel setting means the image will be that many pixels in height/width 

and the percent setting means that the image will be re-sized by that amount relative to the 

original. For instance, if you enter 50 for the height and width, the new image will be half the 

height and half the width of the original.  

 

Resolution: This setting determines how many pixels go into each inch of the image. The 

number needed here is dependent on if the image is going to printed or displayed on a 

screen. As this is a guide for re-sizing your images online, presumably the image is meant to 

be displayed on a computer monitor. Most monitors display at either 72 pixels or 96 pixels, 

anything higher than that will not look any different on a computer monitor; a higher 

number will, however, result in a larger file so for our purposes you will probably want to 

use a resolution of 96, 72, or lower.  

 

Constrain Proportions: If this is checked, any change you make to the Width will 

automatically change the Height to keep the image ratio the same (and vice versa). For 

example, if you have an image that is 1000 pixels in height and 600 pixels in width, changing 

the height to 100 pixels will automatically change the width to 60 pixels.  

 

Note: If you uncheck constrain proportions you should still try to keep the image ratio as 

close to the original ratio as possible or your image may appear distorted.  
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Once you have finished configuring the image size press OK to re-size the image. 

To save the newly re-sized file, click File -> Save As. Select the File name you would 

prefer and ensure that Format is set to JPEG.  Click Save.  

 

You will now be prompted to choose the quality of your file on a scale of 1 to 12. The 

higher the number, the higher the quality (and also the larger the file) you will be saving. As 

you have already drastically reduced the file size by resizing the image, you will probably 

want to keep the quality level somewhere in the 10 to 12 range, but feel free to experiment 

with lower numbers.   

 

Even when saving at the highest quality, the 4.21 MB file is now only 73 KB. If displayed at 

308 pixels by 200 pixels the smaller file will actually look better than the 4.21 MB version as 

the browser will not need to re-size the image.  
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GIMP 

The advantage of using an image editing program like GIMP is that you have complete 

control over the image. You can change the dimensions of the image, alter the resolution 

and choose the file quality. GIMP is also a free program, making it a cost-efficient alternative 

to other image editing programs.  

 

Tip: GIMP can also be used for cropping images, adjusting brightness/contrast, tweaking 

colors, etc. For more information on those features, consult the in-program help or one of 

any number of tutorials available online.  

 

To start editing an image in GIMP, launch GIMP and click File -> Open. Choose the image 

you wish to edit and click Open.  
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Click on Image -> Scale Image to change the size of the image.  

 
You will be presented with a range of Scale Image configuration options. Unless you have a 

lot of experience working with GIMP, most of these should be left as is. The ones you will 

want to change are: 

 

Width and Height: These allow you to choose the width and height of the image. You may 

configure them by pixels or by percent by clicking the dropdown menu and selecting your 

preferred choice. The pixel setting means the image will be that many pixels in height/width 

and the percent setting means that the image will be re-sized by that amount relative to the 

original. For instance, if you enter 50 for the height and width, the new image will be half the 

height and half the width of the original.  

 

Constrain Proportions: To toggle between constraining and not constraining proportions, 

click on the picture of the link chain to the right of Width and Height. If this is checked, 

any change you make to the Width will automatically change the Height to keep the image 

ratio the same (and vice versa). For example, if you have an image that is 1000 pixels in 

height and 600 pixels in width, changing the height to 100 pixels will automatically change 

the width to 60 pixels. 
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X Resolution and Y Resolution: This setting determines how many pixels go into each 

inch of the image. The number needed here is dependent on if the image is going to printed 

or displayed on a screen. As this is a guide for re-sizing your images online, presumably the 

image is meant to be displayed on a computer monitor. Most monitors display at either 72 

pixels or 96 pixels, anything higher than that will not look any different on a computer 

monitor; a higher number will, however, result in a larger file so for our purposes you will 

probably want to use a resolution of 96, 72, or lower.  

 

Note: You should make sure the X Resolution and the Y Resolution match.  

 

Once you are ready to re-size the image click the Scale button.  

 

To save your re-sized image, click File -> Save As. Choose your preferred name and folder 

and click Save.  

 

You will see a Save as JPEG window where you can choose the Quality of the file you are 

saving — The higher the number, the higher quality (and larger the file size). As we have 

already drastically reduced the file size by re-sizing the image, you will probably want to keep 

the quality setting somewhere between 80 and 100. Click Save to save the re-sized image.   
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Microsoft Office Picture Manager 

Microsoft Office Picture Manager allows you to quickly and easily resize a large number of 

images at one time. The downside is that the pre-set export size results in images that are a 

bit larger than necessary. Even so, the images created through Microsoft Office Picture 

Manager will be far smaller than the original images, with most files being between 40 and 

100 kb.  

  

Any version of Microsoft Office from 2003 onwards will come with Microsoft Office 

Picture Manager. To access the software, go to Microsoft Office Tools and select Microsoft 

Office Picture Manager.  

 

Once you have loaded the program, if you do not see the folder with your images on the 

left-hand side, you can add it. To do so, click on the Add Picture Shortcut button in the 

top left corner of the window, navigate to the folder you want, and click Add.  
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Now click on the folder with your images in it. Select the images you wish to make more 
web-friendly and click File and choose Export.  

An Export dialog box will open on the right side of the screen, presenting you with a range 
of exporting options. 
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Under the Export selected file to field, click Browse to choose a destination folder for 
your re-sized files. If you do not already have a destination in mind, you may need to create a 
new folder through the browse interface.  
 
As long as you are not exporting the files into the original location, you can leave the original 
file names box checked. If you want to keep your new files in the same directory as the 
original files (and not over-write those originals) then uncheck Original file names.  
 
For Export with this file format, you can choose whichever format you would prefer, but 
JPEG File Interchange Format is recommended.  
 
For Export using this size, click on the dropdown menu and choose Web – Small.  

 
Once you have finished configuring your Export settings, click on the OK button to create 
your re-sized images.  
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