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HRPay File Generator 

Disclaimer 

By using the HRPay File Generator, you expressively agree to the following Terms and Conditions details 

below. HRPay File Generator is a product of Enterprise Banking Solution, Malayan Banking Berhad. 

1. Under no circumstances including, but not limited to, negligence, shall bank be liable for any direct, 

indirect, incidental, special of consequential damages arising out of the use of or inability to use 

HRPay File Generator. 

2. The transaction generated via the HRPay File Generator will not be deemed as an official payment 

instruction to the bank. It will be the user responsibility to verify, confirm and authorize the 

payment instruction after the uploading of the generated file.  

3. Payment instruction uploaded and authorized via Maybank2e.net will be deemed as an official 

payment instruction to the bank. Any dispute on the transaction will be based on the authorized 

transaction uploaded into Maybank2e.net. 

4. Bank will not be responsible for the inability to use the HRPay File Generator if there are any 

amendment to the layout and the coding. 

5. You should only use the value given by bank for these field below: 

a. Client Code 

6. File generated from the HRPay File Generator will be processed in batch mode only. 
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User Manual 

 

Settings 
You must set the Macro security setting to low before you start using HRPay File Generator. This is a one 

time exercise. 

 

For Microsoft Office XP :- 

1. Open the Microsoft Excel application. 

2. On the Tools menu, point to Macro, and click Security. The Security dialog box will appear. 

3. Click on the Security tab. 

4. Click on the Low and click OK. 

5. Save the File Generator excel file. 

6. Close the Microsoft Excel application and reopen the saved version. 

For Microsoft Office 2003 : - 

1. Open the Microsoft Excel application. 

2. On the Tools menu, point to Macro, and click Security. The Security dialog box will appear. 

3. Click on the Security tab. 

4. Click on the Low and click OK. 

5. Save the File Generator excel file. 

6. Close the Microsoft Excel application and reopen the saved version. 

For Microsoft Office 2007 : - 

1. Open the Microsoft Excel application. 

2. Please ensure that you will be able to see Developer menu. Otherwise, please turn on the 

developer menu by doing the below step: 

a. Click on the Office icon button on the top left. 

b. Click on Excel Option button at the bottom of the dialog box. 

c. Tick on the box for “Show developer tab in the Ribbon”. 

d. Click OK. 

3. On the Developer menu, click Macro Security. The Trust Center dialog box will appear. 

4. Click on the Macro Setting from the left menu. 

5. Select/Mark “Enable all macros” and click OK. 

6. Save the File Generator excel file. 

7. Close the Microsoft Excel application and reopen the saved version. 
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Security Feature 

You may set a security password to the HRPay File Generator. However, you must store the password 

safely as there is NO WAY to unlock the file. 

 

TO PASSWORD PROTECT THE HRPAY FILE GENERATOR 

For Microsoft Office XP and Microsoft Office 2003 :- 

1. On the File menu, click Save As. 

2. On the Tools menu, click General Options. 

3. Do either or both of the following 

a. If you want users to enter a password before they can view the workbook, type a 

password in the Password to open box, and then click OK. 

b. If you want users to enter a password before they can save changes to the workbook, 

type a password in the Password to modify box, and then click OK. 

4. When prompted, retype the new password again and click OK. 

5. Click Save.  

6. If prompted, click YES to replace the existing workbook. 

 

For Microsoft Office 2007 : - 

1. Click on the Microsoft Office button , point to Prepare, and click Encrypt Document. 

2. In the Password box, type a password and click OK. 

3. In the Reenter Password box, type the same password again and click OK. 

4. Save the file. 

 

 

 

 

 

 

 

 



   

© COPYRIGHT 2009 Enterprise Banking Solution, Maybank Page 4 of 16 

 

TO REMOVE OR CHANGE THE PASSWORD 

For Microsoft Office XP and Microsoft Office 2003 :- 

1. On the File menu, click Save As. 

2. On the Tools menu, click General Options. 

3. In the Password to open or Password to modify box, clear the password. 

4. Click OK and then click Save.  

5. Click YES to replace the existing workbook. 

 

For Microsoft Office 2007 : - 

1. Click on the Microsoft Office button , point to Prepare, and click Encrypt Document. 

2. In the Password box, double click the asterisk (*)  and then clear the password. 

3. Click OK and save the file 
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How to generate a SALARY File 

A.  FILE DETAILS  

1. Client Code  

• Value will be given by the bank. 

• Maximum length allowed is 10 characters inclusive of space. 

2. PIR Reference No.  

• Mandatory field 

• File reference determined by you. E.g : SALARY 31122009. 

• Maximum length allowed is 20 characters inclusive of space 

3. Debit Account Number 

• Mandatory field 

• the company account number to pay from 

4. Mode of Processing 

• Optional 

• Batch  = it will be processed by the batch processing windows 

• Realtime = only allow maximum 10 salary payments to be made in 1 file. 

• No value  = same as Batch 

5. Debit Reference 

• Optional 

• Transaction Reference determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 14 characters inclusive of space. 

6. Debit Description 

• Optional 

• Transaction Description determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 40 characters inclusive of space. 

7. Payment Date 

• Mandatory field 

• Format = YYYYMMDD. Example 20081231 

• You can indicate future payment date here. The transaction will be processed on the 

mentioned date. 

8. Testing File 

• Optional field 

• Yes  = file is for testing purpose 

• No   = file is an actual salary file. 

9. Confidential 

• Yes  =  detail in the file is not viewable by anyone except those who has confidential 

rights. 
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• No = detail in the file is viewable by anyone who has access to SALARY 

• No value = same as N 

 

B.  EMPLOYEE SALARY DETAILS 

1. Staff Name 

• Mandatory field 

• Name of the account holder that you want to pay to 

• Maximum length allowed is 40 characters inclusive of space. 

2. Staff Bank 

• Mandatory field 

• The bank which you want to pay to 

• Please use the “Bank Code” listed on Bank Code List sheet 

2. Staff Account No. 

• Mandatory field 

• The bank account number of the person/company that you want to pay to 

3. Company Staff No. 

• Optional field 

• Your staff’s company number. 

4. Staff New IC/Old IC/Passport No 

• Mandatory field (at least 1 of the above must have a value) 

• New IC format = 801231018888 (without dash) 

5. Salary Amount 

• Mandatory field. 

• Format = 00.00 

• Salary amount to be paid to the staff 

 

 

After completing filling up the file details and Employee salary details, follow the step below: 

1. Click Generate SALARY File. 

2. Please select the folder/location to save the generated file in the new window. You may rename 

the file name. The file name cannot be duplicated. 

3. Click OK. 
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How to generate an EPF File 

A.  FILE DETAILS  

1. Client Code  

• Value will be given by the bank. 

• Maximum length allowed is 10 characters inclusive of space. 

2. PIR Reference No.  

• Mandatory field 

• File reference determined by you. E.g : SALARY 31122009. 

• Maximum length allowed is 20 characters inclusive of space 

3. Debit Account Number 

• Mandatory field 

• the company account number to pay from 

4. Mode of Processing 

• Optional 

• Batch  = it will be processed by the batch processing windows 

• Realtime = only allow maximum 10 salary payments to be made in 1 file. 

• No value  = same as Batch 

5. Debit Reference 

• Optional 

• Transaction Reference determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 14 characters inclusive of space. 

6. Debit Description 

• Optional 

• Transaction Description determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 40 characters inclusive of space. 

7. Payment Date 

• Mandatory field 

• Format = YYYYMMDD. Example 20081231 

• You can indicate future payment date here. The transaction will be processed on the 

mentioned date. 

8. Testing File 

• Always select “NO” 

• No testing is allowed for Statutory Body payments. 

9. Confidential 

• Yes  =  detail in the file is not viewable by anyone except those who has confidential 

rights. 

• No = detail in the file is viewable by anyone who has access to SALARY 
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• No value = same as N 

10. EPF Registration File 

• Yes = file is for EPF registration purposes. 

• No  = file is for EPF contribution payment. 

B. EMPLOYER DETAILS 

1. Contribution Month and Year 

• Mandatory 

• Format MMYYYY (e.g. 052009 for contribution May 2009) 

2. Company Contact Person 

• Mandatory 

• Contact Person for EPF to contact for any inquiries 

• Maximum length allowed is 25 characters inclusive of space. 

3. Company Contact Number 

• Mandatory 

• Phone Number of Contact Person for EPF to contact for any inquiries 

• Maximum length allowed is 15 characters inclusive of space. 

4. EPF Employer Reference No 

• Mandatory 

• The registered EPF Employer Reference No 

• Maximum length allowed is 9 characters without space. 

5. EPF Employer Name 

• Mandatory 

• Company name which is registered with EPF for the mentioned EPF Employer Reference 

No. 

• Maximum length allowed is 40 characters inclusive of space. 

6. Company State Code 

• Mandatory 

• The state which the company resides in. 

 

C. EMPLOYEE DETAILS 

1. Staff Name 

• Mandatory 

• Maximum length allowed is 40 characters inclusive of space. 

2. Staff New IC/Old IC/Passport Number 

• Mandatory (at least 1 of the above must have a value) 

• New IC format = 801231018888 (without dash) 
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3. EPF Employee Reference No 

• Mandatory  

• Maximum length allowed is 8 characters inclusive of space. 

4. Employee’s Initial 

• Optional (3 characters) 

• This value is passed to EPF if there is any discrepancies 

5. Employee Identifying Key 

• Optional (11 characters) 

• This will be the reference passed to EPF if there is any discrepancies 

6. Employee Amount 

• Mandatory  

• Format = 00.00 

7. Employer Amount 

• Mandatory 

• Format = 00.00 

8. Member’s Wages 

• Mandatory 

• Format = 00.00 

• The employee’s salary/wages 

 

 

After completing filling up the file details, employer details and employee details, follow the step below: 

1. Click Generate EPF File. 

2. Please select the folder/location to save the generated file in the new window. You may rename 

the file name. The file name cannot be duplicated. 

Click OK. 
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How to generate an SOCSO File 

A.  FILE DETAILS  

1. Client Code  

• Value will be given by the bank. 

• Maximum length allowed is 10 characters inclusive of space. 

2. PIR Reference No.  

• Mandatory field 

• File reference determined by you. E.g : SALARY 31122009. 

• Maximum length allowed is 20 characters inclusive of space 

3. Debit Account Number 

• Mandatory field 

• the company account number to pay from 

4. Mode of Processing 

• Optional 

• Batch  = it will be processed by the batch processing windows 

• Realtime = only allow maximum 10 salary payments to be made in 1 file. 

• No value  = same as Batch 

5. Debit Reference 

• Optional 

• Transaction Reference determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 14 characters inclusive of space. 

6. Debit Description 

• Optional 

• Transaction Description determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 40 characters inclusive of space. 

7. Payment Date 

• Mandatory field 

• Format = YYYYMMDD. Example 20081231 

• You can indicate future payment date here. The transaction will be processed on the 

mentioned date. 

8. Testing File 

• Always select “NO” 

• No testing is allowed for Statutory Body payments. 

 

 

 

 



   

© COPYRIGHT 2009 Enterprise Banking Solution, Maybank Page 11 of 16 

 

9. Confidential 

• Yes  =  detail in the file is not viewable by anyone except those who has confidential 

rights. 

• No = detail in the file is viewable by anyone who has access to SALARY 

• No value = same as N 

 

B. EMPLOYER DETAILS 

1. Contribution Month and Year 

• Mandatory 

• Format MMYYYY (e.g. 052009 for contribution May 2009) 

2. SOCSO Employer Reference No 

• Mandatory 

• Maximum length allowed is 9 characters inclusive of space. 

 

 

 

C. EMPLOYEE DETAILS 

1. Staff Name 

• Mandatory 

• Maximum length allowed is 40 characters inclusive of space. 

2. Staff New IC/Old IC/Passport Number 

• Mandatory (at least 1 of the above must have a value) 

• New IC format = 801231018888 (without dash) 

3. SOCSO Employee Reference No 

• Optional 

4. Employee Amount 

• Mandatory  

• Format = 00.00 

5. Employer Amount 

• Mandatory 

• Format = 00.00 

 

After completing filling up the file details, employer details and employee details, follow the step below: 

1. Click Generate SOCSO File. 

2. Please select the folder/location to save the generated file in the new window. You may rename 

the file name. The file name cannot be duplicated. 

Click OK. 
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How to generate an IRB File 

A.  FILE DETAILS  

1. Client Code  

• Value will be given by the bank. 

• Maximum length allowed is 10 characters inclusive of space. 

2. PIR Reference No.  

• Mandatory field 

• File reference determined by you. E.g : SALARY 31122009. 

• Maximum length allowed is 20 characters inclusive of space 

3. Debit Account Number 

• Mandatory field 

• the company account number to pay from 

4. Mode of Processing 

• Optional 

• Batch  = it will be processed by the batch processing windows 

• Realtime = only allow maximum 10 salary payments to be made in 1 file. 

• No value  = same as Batch 

5. Debit Reference 

• Optional 

• Transaction Reference determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 14 characters inclusive of space. 

6. Debit Description 

• Optional 

• Transaction Description determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 40 characters inclusive of space. 

7. Payment Date 

• Mandatory field 

• Format = YYYYMMDD. Example 20081231 

• You can indicate future payment date here. The transaction will be processed on the 

mentioned date. 

8. Testing File 

• Always select “NO” 

• No testing is allowed for Statutory Body payments. 
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9. Confidential 

• Yes  =  detail in the file is not viewable by anyone except those who has confidential 

rights. 

• No = detail in the file is viewable by anyone who has access to SALARY 

• No value = same as N 

 

B. EMPLOYER DETAILS 

1. Contribution Month and Year 

• Mandatory 

• Format MMYYYY (e.g. 052009 for contribution May 2009) 

2. IRB Payment Region 

• Mandatory 

• The region which the company resides in 
3. IRB Employer IT Group 

• Optional 

• Employer IT Group are the alphabets portion in the Employer Tax Ref No.  

• E.g.    E 12345678-09(0) , “E” is the Employer IT Group 
4. IRB Employer Ref No 

• Mandatory 

• Ignore the alphabets and dash (-) 

• E.g : E 12345678-09(0), “1234567809” is the Employer Tax Ref No 
 

C. EMPLOYEE DETAILS 

1. Staff Name 

• Mandatory 

• Maximum length allowed is 40characters inclusive of space. 

2. Staff New IC/Old IC/Passport Number 

• Mandatory (at least 1 of the above must have a value) 

• New IC format = 801231018888 (without dash) 

3. SOCSO Employee Reference No 

• Optional 

4. Employee IT Group 

• Optional 

• Employee IT Group are the alphabets portion in the Employee Tax Ref No.  

• E.g.    SG1234567809, “SG” is the Employee IT Group 
5. Employee Tax Reference No 

• Mandatory 

• Ignore the alphabet and dash (-) 
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• E.g : E 1234567809,  “1234567809” is the Employee Tax Ref No 
6. Wife Code 

• Optional 

• As given by LHDN 
7. PCB Amount 

• Mandatory 

• PCB is the same as CP39. Format = 00.00 

• If no amount, please key in “0” 

8. CP38 Amount 

• Mandatory 

• CP38 is the amount instructed by LHDN to employer to perform tax deduction for 

employee. Format = 00.00 

• If no amount, please key in “0” 

 

 

After completing filling up the file details, employer details and employee details, follow the step below: 

1. Click Generate IRB File. 

2. Please select the folder/location to save the generated file in the new window. You may rename 

the file name. The file name cannot be duplicated. 

Click OK. 
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How to generate an ZAKAT File 

A.  FILE DETAILS  

1. Client Code  

• Value will be given by the bank. 

• Maximum length allowed is 10 characters inclusive of space. 

2. PIR Reference No.  

• Mandatory field 

• File reference determined by you. E.g : SALARY 31122009. 

• Maximum length allowed is 20 characters inclusive of space 

3. Debit Account Number 

• Mandatory field 

• the company account number to pay from 

4. Mode of Processing 

• Optional 

• Batch  = it will be processed by the batch processing windows 

• Realtime = only allow maximum 10 salary payments to be made in 1 file. 

• No value  = same as Batch 

5. Debit Reference 

• Optional 

• Transaction Reference determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 14 characters inclusive of space. 

6. Debit Description 

• Optional 

• Transaction Description determined by you. This value will be shown in your company’s 

Account Statement.  

• Maximum length allowed is 40 characters inclusive of space. 

7. Payment Date 

• Mandatory field 

• Format = YYYYMMDD. Example 20081231 

• You can indicate future payment date here. The transaction will be processed on the 

mentioned date. 

8. Testing File 

• Always select “NO” 

• No testing is allowed for Statutory Body payments. 
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B. EMPLOYER DETAILS 

1. Contribution Month and Year 

• Mandatory 

• Format MMYYYY (e.g. 052009 for contribution May 2009) 

2. Zakat Employer Reference Number 

• Mandatory 

• Maximum length allowed is 10 characters inclusive of space. 

3. Zakat Payment Region 

• Mandatory 

• The region of which the employer resides in 

4. Zakat Employer Name 

• Mandatory 

• Employer name registered with Zakat 

• Maximum length allowed is 100 characters inclusive of space 

 

C. EMPLOYEE DETAILS 

1. Staff Name 

• Mandatory 

• Maximum length allowed is 40 characters inclusive of space 

2. Staff New IC/Old IC/Passport Number 

• Mandatory (at least 1 of the above must have a value) 

• New IC format = 801231018888 (without dash) 

3. Employee Amount 

• Mandatory  

• Format = 00.00 

4. Zakat Classification 

• Mandatory 

• Choose the zakat classification “HARTA” or “PENDAPATAN” 

 

 

After completing filling up the file details, employer details and employee details, follow the step below: 

1. Click Generate Zakat File. 

2. Please select the folder/location to save the generated file in the new window. You may rename 

the file name. The file name cannot be duplicated. 

Click OK. 

 


