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Editing a Project 

This chapter is divided into two sections. The first deals with options included within the 
master. In this section you learn how to: 

• open a section, 

• navigate in a section, 

• select and exclude text, 

• use the Choices function, 

• change views and preview your documents, and 

• use the Notes window. 

The second section of this chapter deals with user-added material. In this section you learn 
how to: 

• edit a paragraph, 

• switch from edited back to master text, 

• add and delete paragraphs, 

• add tables, 

• add, edit, and delete choice groups, 

• copy and paste paragraphs, 

• import from the clipboard, and  

• demote and promote paragraphs. 
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Overview 
Because the master database in SpecLink is very extensive and is expanded and updated 
quarterly, you must select what you need and edit it for individual projects. Unlike word-
processing specification strategies, with SpecLink you edit by selecting paragraphs for 
inclusion in the project rather than by deleting text. This inclusive process means that 
master text is always available, even when old projects are copied as the basis for a new 
one. Making copies of existing projects for subsequent modification is therefore a much 
safer and more productive way of producing documents than using documents generated 
by conventional word processing, where master text is deleted. 

In addition to selecting paragraphs, you edit in SpecLink by selecting from among choices 
embedded in many paragraphs. You can also modify the master text by simply clicking in a 
paragraph and editing as you would on a word processor. You can also add paragraphs, 
articles, or whole sections using tools such as Copy/Paste and Import from Clipboard. 

Finally, you can add a note to any paragraph, including paragraphs you have added. This 
chapter explains the editing functions of SpecLink in detail. 

Viewing a Section 
To view a section, click on its title in the Tree panel. The section appears in the adjacent 
Document panel. 

NOTE: If you cannot see the Document panel, from the View menu, choose Document 
Panel. 

Depending on the resolution of your computer screen, you may want to close the Tree 
panel while you are editing a specific section. To do so, from the View menu, choose Tree 
Panel. 

NOTE: The section opens to the level indicated by the depressed “Show Level” button. 
For maximum opening speed, especially if you are looking at the initial notes in 
each section, first click on the Show Level 1 button on the Project Window 
toolbar to collapse the text. 

For fastest editing speed, use the document check-out feature described in Chapter 9. 



C h a p t e r  5  :  E d i t i n g  a  P r o j e c t  

 S p e c L i n k  U s e r  M a n u a l  127 

Opening Multiple Sections 
Opening multiple sections is particularly helpful when you are working with Links. You can 
have more than one section open at a time, and even open the same section more than 
once to look at the beginning and the end at the same time. To open a new section in the 
current project, from the Window menu choose New Window, then view the section you 
want. 

As in all Windows-based applications, windows can be moved, resized, minimized, and 
maximized. This applies to each section window that is opened. Sections can be cascaded, 
moved, pulled up one at a time, pushed mostly off the screen, and minimized. To make a 
minimized section current, from the bottom of the Window menu, choose the name of the 
window you want. 

In addition to cascading, two special types of "tiling" are available: Tile Horizontally and Tile 
Vertically. When it is necessary to review two or more sections simultaneously, tiling is very 
useful. When you choose a Tile command, all the open sections are tiled, so minimize any 
sections you don’t wish to tile, then select the method of tiling desired. You also will 
probably want to close the Tree Panel to maximize the amount of text visible in the 
Document Panel of each section. 

Keep the following hints about multiple windows in mind:  

• If you use the Restore button  to reduce the size of the main window, you can 
see several windows on the screen at the same time. Alternatively, you can use the 
Window menu to switch between open windows. 

• If your current window is less than full screen size, a new window automatically 
"cascades" (lays over the previous window so some of the previous window is 
visible). Instead of cascading windows, you can use the Window menu to tile them 
either horizontally or vertically.  

• Tiled and cascaded windows can be moved, viewed one at a time, or hidden. The 
title of each opened window appears on the Windows menu; if you have hidden a 
window, select the hidden window from the list on the Windows menu. 

• You can use the mouse to resize a window by dragging an edge. You can also use 
the Windows size control buttons to minimize, maximize, restore, and close 
windows. 

The Document Panel 
When you click on a section title in the Tree panel, the section content appears in the 
Document panel. In addition to the section content area, the Document panel includes a 
toolbar, a horizontal ruler for formatting, status columns, and horizontal and vertical scroll 
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bars for moving within the section. These areas of the Document panel are described in 
detail in Chapter 3. 

NOTE: For faster editing, on the Document menu, point to Check Out | Check In, and 
then choose Check Out Document. A copy of the section will be copied to a 
temporary location on your local drive and links to other sections will be 
suspended, speeding up the editing process. When you are finished editing, you 
check the section back in. See Chapter 9 for details. 

The section content portion of the Document panel is where the specification text appears. 
Each paragraph is one field in a database record, sequentially numbered as shown in the 
sequence number status column (#) to the left of the text. 

 

Document panel  

The text is organized in hierarchical, or “outline” form, with the hierarchy for each paragraph 
displayed on the die icon in the paragraph level status column (LVL). Relative hierarchy is 
also indicated by the amount of indentation from the left margin. As you select text, the 
default style for that level is applied automatically. This includes the appropriate paragraph 
numbering, provided that Auto Numbering is toggled on (View menu…Display Layout, or 
View toolbar). 

The status of each paragraph is displayed, indicating whether it prints in the final document 
or not. Selected, active text is indicated by a change in the color of the text and in the 
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background color of the status columns. At inactive paragraphs, the text is light gray and 
the status column background color is also light gray. At active paragraphs (selected text 
that will be included in the printed document), the text is black (except for embedded 
choices) and the background of the status columns is dark gray. In addition, the status box 
for each active paragraph shows a checkmark, a green background, or both. See the 
"Status Boxes" section of Chapter 3 for details. If there is any doubt about whether text is 
active or inactive, click on the Compact View button on the View Toolbar. Only selected, 
active text that will print appears in this view. Return to Master View to continue editing. 

Embedded choices are shown in color. Blue text indicates a multiple choice option, red 
indicates a fill-in, and green indicates a global choice that is established in the Summary 
Info dialog box. Unused optional multiple choices are indicated by the following 
combination of symbols, which do not print: [<>]. Fill-ins are enclosed by square 
brackets [  ] that do not print. To open any embedded choice, click once anywhere within 
the blue-colored choice area. To insert text in a fill-in, click once anywhere between the 
brackets to block the underlined area, then enter your text or use Ctrl+V to paste in text 
from the clipboard. 

Navigating in a Section 
When editing, the following methods can be used to navigate the section.  

Scrolling 
You can use the vertical scroll bar to navigate through the section. If you want to scroll a 
paragraph at a time, click on the up or down buttons on the scroll bar. Click on the bar in the 
direction you want to go, to move one "page" at a time. To scroll in leaps and bounds, drag 
the scroll thumb on the scroll bar. 

NOTE: If you have a scroll button on your mouse you can also use the scroll button to 
scroll through the tree and document panels. 

Keyboard Options 
You can use the arrow keys on the keyboard to scroll line by line through the section. Using 
Page Up and Page Down will move you faster through the Document Panel. 
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Move To Buttons 
The Move To Buttons are a more exact way to navigate than scrolling. For example, if your 

cursor is in Part 1 General you can click the Next Paragraph at Current Level button  to 
move directly to Part 2 Products or the next level 1 folder. You can also move to the 
previous paragraph at current level, to the first paragraph, or to the last paragraph in the 
section. 

 

Move To buttons 

Use Collapse/Expand to Speed Navigation 
In addition to using the Move To buttons to jump from one level to the next, you can also 
use the Show Level buttons to aid in navigation. The Show Level buttons allow you to 
change the number of visible levels quickly. Click on the lowest level you want to have 
visible. 

 

Show Level buttons 

For example, suppose you are in PART 3 reviewing the field testing provisions and wish to 
skip to PART 1 to see what is said about testing under Quality Assurance.  “Collapse” the 
section to level 1, move the cursor to PART 1, “expand” to level 2, move the cursor to 
Quality Assurance, and then “show all levels”.   Now you can scroll through the Quality 
Assurance provisions. 

Bookmarks - Mark This Place 
Bookmarks are useful for jumping back quickly to a specific location within any section. 
Click on the paragraph you want to mark, and then choose Mark Place from the Document 
menu, or use the button on the Edit toolbar. At any later time, choose the Return to Mark 
command to return to your marked paragraph. 

NOTE: The existing bookmark is replaced when you bookmark a different paragraph, or 
move to a different section; only one bookmark can exist in a section at one time. 

This variety of navigational tools should help make you more productive and efficient as 
you produce your specifications. 
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Selecting and Excluding Text 
Now that you understand the Document Panel and are armed with several navigational 
tools, this section describes selection concepts. In addition, this section includes step-by-
step instructions for selecting and excluding text. 

Remember that with SpecLink, you select the text you want to include in your specification 
documents. Because the master provides you with many options, you have to specifically 
select the text you want. On occasion, you may want to specifically exclude system-
selected paragraphs. 

Selecting Text 
1. Navigate through the section using the tools most comfortable to you 

2. When you find a paragraph you want in your specification, if the status box is green 
the text is already selected and you do not need to click in the status box. 

 If the status box is gray, a yellow triangle, or a red stop sign, select the paragraph by 
clicking once in the status box to the left of the text cell, which puts a checkmark in the 
box. 

 When the text in the cell changes to black and the background of the status columns 
turns dark gray, the text is active and is included in the document you print. If the text 
remains gray and the status columns remain light gray, check the parentage of the 
selected paragraph. 

3. Continue selecting the text you want for your project. 

When you are selecting text, the notes displayed in the Notes panels can provide 
information to help you make better decisions. See the "Using the Notes Function" in this 
chapter for details. 

Excluding Text 
One of the productivity features of SpecLink is the system’s automatic selection of 
additional paragraphs based on those you choose. The system either "highlights" (yellow 
triangle) or "includes" (green square) paragraphs relevant to those you select.  

Text in a highlighted paragraph remains gray and does not print, giving you the opportunity 
to make a decision about that paragraph. An included paragraph changes to black text if 
the parentage is intact. You can override a system-included paragraph, but you should be 
cautious about doing so. 
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To exclude a system-included (green square) paragraph: 

 Click in the status box to the left of the text cell until an X appears. The status box 
now indicates that the paragraph is excluded, and the text becomes gray. 

 

User Excluded Text 

Note: It is not necessary to exclude text to keep it from printing. Black text is the only 
text included in the printed documents. If the text is gray, it will not print and does not 
need to be excluded. 

Parent/Child 
The hierarchical arrangements of specifications lend themselves to the concept of 
parentage. A parent at text Level 1 may have several children at Level 2, a Level 2 parent 
may have several Level 3 children, and so on.  

SpecLink requires this parentage to be maintained in order to include lower level text. 
Therefore, if you select a Level 3 paragraph and the text remains gray, it is because the text 
is “orphaned.” You must select the parent text to make certain the selected Level 3 text is 
included in the printed document.  

The Color Scheme Is More Than Just Aesthetics 
The colors of the various parts of the windows and the status indicators are designed for 
quick recognition - learn what they mean and you can work faster. 

Gray and Black 
When you start a section, paragraph text is gray. When a paragraph has been selected 
and becomes active, the active text changes to black. The background color of the status 
columns changes from light gray to dark gray when the text is selected and active. 

User 
Excluded
Text 
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NOTE: Only black text and associated embedded choices print, regardless of the status 
box indicators. 

Use the gray and black text and the color of the status columns to speed evaluation. The 
software links automatically include text based on previous decisions. Your first priority is to 
make sure the automatic inclusions are appropriate for the project, so scan all black text 
with green status boxes first and make whatever changes are necessary. 

Gray text is optional, to be included only if required for the project. However, a selected 
paragraph may continue to be inactive (gray text) because its "parent" paragraph has not 
been selected. 

NOTE: If the background of the document panel is gray, this means the section is in use 
by another user, and you will be unable to edit that section. To identify the other 
user, see the parentheses in the Tree panel. 

Paragraphs that have been selected by links may sometimes be found in articles that are 
optional. So, scan the gray text for paragraphs with a green square status box  
(indicating a strong need), then for those with a yellow triangle status box  (indicating a 
possible need). Then select the "parent" text to include both it and the linked paragraphs 
below it, if appropriate. See the "Parent/Child" section in this chapter for details. 

Software links can also exclude paragraphs. In most cases, these are truly mutually 
exclusive options. In some cases, however, more than one of the options may be 
appropriate, provided the specification is edited to indicate where each option is applicable. 
Scan the red stop sign status boxes  to be sure that exclusions are appropriate for your 
project. You can override any software exclusion (red stop signs) by clicking on the status 
box to select a paragraph. 

Blue 
Blue is used in the Document Panel text to identify embedded multiple choices. Blue icons 
are used in the Notes (N) and Origin (O) status columns to indicate user-added and user-

modified text and notes. In the Notes column a blue notebook icon on the right  
indicates a user added note. In the Origin column, there are two different blue icons as 
follows: 

 a white sheet of paper with blue text indicates a user-added paragraph 

 
a blue rectangle across the bottom half of the column indicates a user-
modified master paragraph 
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SpecLink also changes the background of the Status (S) column of the current paragraph 
to a dark blue, indicating cursor location in the Document Panel. 

Non-proprietary (BSD) sections are blue in the project Tree Panel. 

Green 
Green text in the Document Panel indicates an embedded global option that can be 
changed globally at the Summary Info dialog box (which is accessed from the File menu), 
or individually by typing over them in the paragraph. Global options include replaceable 
terms such as MasterFormat version, Design-Builder and units of measure. Green is also 
used to indicate “Yes” links (selecting text) in both the paragraph status box and in the Links 
window. 

User added or copied master sections appear in a green font in the project Tree Panel. 

Red 
Red is used in the Document Panel to denote a user fill-in. Red is also used to indicate 
“No“ links (excluding text) in both the paragraph status and in the Links window. 

Yellow 
In the Notes (N) column a yellow notebook on the left indicates the presence of a master 

note ( ). In the Origin (O) column a yellow rectangle across the top ( ) indicates that 
the master version of a user-modified master paragraph is currently displaying. Yellow is 
also used to indicate “Maybe” links (potentially relevant text) in both the paragraph status 
box and in the Links window. 

Magenta 
When a project is opened using the option to not update, sections that have been updated 
in the new master display magenta titles in the Tree panel, so that you can see the changes 
that would be made if you were to accept the updates. 

Rust 
When a project is opened using the option to not update, paragraphs that have been 
updated in the new master are marked by a rust color in the background of the Status (S) 
column in the Document panel, so that you can see the changes that would be made if you 
were to accept the updates. The updated paragraphs can be viewed by opening the Tools 
menu and clicking on View Updated Master Paragraph. 
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Choices Function 
Many paragraphs in the master database include embedded choices, which are identified 
by red, green, or blue text. Fill-ins, usually in red, also have brackets that do not print. 

Blue embedded choices are multiple choices. The options for the multiple choice may be a 
single number, word, phrase, a fill-in, or an option to print nothing where the choice is 
located. One of the options is the default value – the one currently being displayed – and it 
may or may not be appropriate for your project. Therefore, it is important to look at the other 
options available in any selected paragraph that includes an embedded choice. 

To view the choice options for an embedded multiple choice (marked by blue text), click 
once anywhere within the embedded choice to "pop up" the choice options. The types of 
choices are described below. 

NOTE: To open the choice list on a single character choice (such as a number 7), drag 
across the single character to highlight it. Do not include the space before or after 
the character. When you release the mouse button, the choice list will open. 
 

If a fill-in has blue brackets instead of red, it is part of a multiple choice. To view 
the other choices, double-click between the blue brackets. 

Exclusive Multiple Choice 
Exclusive multiple choices include two or more options, one of which must be selected, but 
only one. They sometimes include a "None - N/A" option, which effectively allows all 
choices to be omitted. When a "None - N/A" option is selected, it appears in the paragraph 
as [<>] but does not print. 

 
Exclusive Multiple Choice Group 
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Inclusive Multiple Choice 
Inclusive multiple choices include two or more options, one or more of which must be 
selected. These options are automatically punctuated and joined with the word "and" or "or" 
as appropriate. They sometimes include a "None - N/A" option, which effectively allows all 
choices to be omitted.  

 
Inclusive Multiple Choice Group 

Fill in the Blank 
For blanks, the user must enter a word, phrase, or number to make the text complete. 
These are shown in the text as [______]. Fill-ins can stand alone, as the only option, or 
they can occur as one of the options in multiple choice groups. Stand-alone fill-ins appear 
with red brackets. Those that are an option in a multiple-choice group appear with blue 
brackets. 

 
Fill in the Blank as option in Exclusive Multiple Choice list, and as fill-in in text 

To enter text in a fill in the blank, click anywhere within the brackets to block the underline, 
then type or paste text from the clipboard. The brackets continue to show, to denote the 
presence of the fill-in, but they do not print. For a fill-in that is part of a multiple choice list, 
you must first select the choice, then click on text outside of the choice list, and then click 
within the brackets to block the underline. 
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If you do not want to use the fill-in, type None - N/A in the fill-in. When you print the section, 
the fill-in will not print and the spaces around it will be closed properly. For example, if the 
fill-in is between two words and you type None - N/A in the fill-in, when it prints there will 
only be one space between the two words. If you deleted the underline instead, two spaces 
would print between the words. None - N/A is case-sensitive, so be sure you capitalize the 
correct letters, and also be sure to put a space on either side of the hyphen. 

NOTE: Once you choose a fill-in as your choice and you subsequently need to view the 
other choice options, double click within the fill-in to pop up the list of choices. 

Global Choices (in green) 
Global choices appear in green. They reflect choices made in the Summary Info dialog box.  
They include Master Format Version, Unit of Measure display, printing of Edition dates and 
Specific Terms.  See Chapter 4 for more information on Global Choices. Note that the 
Section Title in the Related Sections is sort of a hybrid global choice.  The Section Title 
display changes based on your MasterFormat hierarchy selection, but it is blue to allow you 
the option of inserting your own Section Title. 

 

Global Choice Examples 

Making Choices 
To view available choice options in a paragraph: 

1. Click once anywhere within the blue text to open the choice box that displays the list of 
options available. The default is initially selected. 

 After the list of options is displayed, the current option can be changed. Each option 
has a selection box or circle to the left:  for exclusive options,  for inclusive 
options. 

2. Click on the selection box/circle for the desired option(s). 

3. To execute the change, click the Close button or click anywhere else in the Document 
Panel. 
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4. To enter text in a fill in the blank, click once between the brackets to block the 
underscore, then type (or use Ctrl+V to paste from the clipboard) to replace the 
underscore with your entry. The square brackets remain visible to mark the location of 
a fill-in, but they do not print in the final document. 

NOTE: Clicking once between the brackets automatically blocks the entire fill-in, so that 
what you type replaces the underline.  

Changing Views and Previewing 
As you select and exclude text, it is sometimes helpful to change your view of the project. 
The View options provide three different ways to "look at" your project in the Document 
Panel. 

Master View 
In the Document panel, Master View shows all text regardless of status. This is the default 
view, which is generally the most useful. 

Expert View 
In the Document panel, Expert View hides all paragraphs that have been excluded by the 
user or by links and shows all other text. Expert View is useful when you want to 
concentrate on possibilities and eliminate distractions. Because all excluded information is 
hidden, you work only with information that has potential for your project.  

Compact View 
In the Document panel, Compact View hides all paragraphs that are not active. It shows 
only the text that prints in the final document. Compact View is useful to get a "snapshot" of 
exactly what is included in your final documents before previewing or printing sections. 

Using the View Options 
Choose the desired view option from the View menu or click the appropriate button on the 
View toolbar. 
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View commands on View menu 

The following three views are of the same section in the Document panel. Notice the 
differences in the material presented based in each view. 

 

Master View in Document Panel: All paragraphs—selected, excluded, and available—appear. 
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Expert View in Document Panel: Excluded paragraphs (and their children) are hidden. 
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Compact View in Document Panel: Only active, selected paragraphs appear. 

You must be in Master View, showing all levels of text in order to perform most paragraph 
editing. If you are in Compact View, Expert View, and/or showing only 1, 2, or 3 levels of 
text when you try to perform one of the kinds of edits that are not permitted, you will get the 
following message: 

 

You must be in Master View message 

Click Yes. SpecLink will turn on Master View and All Levels and present the following 
message: 
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View Changed message 

Click OK, and then attempt the edit again. 

Using Preview 
To see what the final specification will look like when it prints, use the Preview function. 
From the File menu choose Print Preview. You can also choose the Print Preview button 
from the Standard Toolbar. The section appears on your screen as it would if printed. 

 

Print Preview 

If the text is not readable at your screen resolution, you can “zoom” into the document by 
clicking anywhere within it. See Chapter 8 for more details about Print Preview. 
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Preview Window in “Zoom” Mode 

NOTE: You can insert manual Page Breaks. Close the Preview Window using the 
button that says Close. Then click to place your cursor in the paragraph that you 
want to have at the top of the page, and from the Document menu choose Insert 
Page Break. A dark line will appear above the paragraph, representing the page 
break. For the page break to work, the paragraph must be active and not have 
NP or NS tags. To remove the page break, click in the paragraph that has the 
dark line above it, and from the Document menu choose Remove Page Break. 

Using the Notes Panels 
Notes can help you make decisions about what to include in your project. By default, the 
Project and Master Notes panels display below the Tree panel. 
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Notes Panels displaying notes on the current paragraph (Gypsum Board Assemblies title) 

The panels can be resized by dragging the gray dividers with your mouse. They can also 
be toggled on and off by choosing them from the View menu, or by clicking the following 
buttons on the toolbar: 

 
Toggle display of Master Notes 

 
Toggle display of Project Notes 

When a section is open, Notes attached to particular paragraphs appear in the Notes 
panels when the relevant paragraph has focus and the Notes panels are open. Paragraphs 
that have Notes are marked with the following icons in the "N" (Notes) status column:  

 A yellow notepad on the left indicates that the paragraph has a Master note. 

 A blue icon on the right indicates that the paragraph has a Project note. 

 Both icons indicate that the paragraph has both a Master and a Project 
note. 

Project 
Notes Panel 

Master 
Notes Panel 
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You cannot modify master notes, but you can add your own project notes to any paragraph. 
Click in the Project notes panel, then type or paste from the Windows clipboard.  

NOTE: For paragraphs that do not already have a master note, you can display graphics 
in the Master Notes panel. See Adding Pictures to Notes in Chapter 10 for more 
information. 

The Value of Notes 
Project notes are a valuable way to communicate the decision-making process throughout 
the creation of a project. For example, if one person is editing the specifications and 
another is reviewing them, the editor can enter notes to indicate what the underlying 
assumptions were. This way the reviewer can more quickly determine whether the section 
was edited properly for the project.  

Using Notes To Decide Which Sections To Include 
Click on a section title in the Tree Panel and a note will display in the Master Notes panel. 
(If the Master Notes panel is not open, click the Master Notes button on the View Toolbar.) 
The Master Note describes the section content. To read the note better, you can resize the 
Master Notes panel, and/or turn off the Project Notes and Document panels. To see the 
content description for another section, click on the title of that section in the Tree Panel. 

Hyperlinks within Master Notes 
Hyperlinks to Manufacturers: Hyperlinks are provided to the websites of the 
manufacturers listed in SpecLink’s master database. The hyperlinks are located in the 
master note for each manufacturer paragraph. When a spec is complete, the Manufacturer 
Listing requirements report can be printed. This report lists by section and by product every 
acceptable manufacturer listed in the specs. In addition, some manufacturer listings include 
a paid “infomercial,” or advertisement, in the notes window, with additional information 
about that manufacturer’s products and multiple hyperlinks to various locations with 
relevant information.  

Reference Standards on Demand: BSD has entered into an agreement with another 
organization – IHS, Inc. – which is in the business of gathering information from disparate 
sources and making it available to various industries, including the construction industry. 
Under our agreement with IHS, we have provided links to all documents that are available 
through their IHS Standards Store. To access the hyperlink for a particular standard, find the 
citation in Part 1 of the section or any place where the standard is referenced, open the 
master notes panel, and then click on the hyperlink. In a few cases, the document itself is 
available online at no cost. In most cases, however, at least a synopsis of the standard is 
available, and the document itself can be purchased online. Once purchased, most 
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documents can be viewed or downloaded immediately. A minority of the reference  
standards will have to be shipped. 

Using Notes Within a Section 
You can add project notes to any paragraph. However, you cannot delete a note from the 
master database. You can edit a master note by first blocking it and copying to the 
Windows clipboard, then pasting it in the Project Notes panel for the same paragraph. You 
can also highlight and then drag and drop a note from the Master Note Panel into the 
Project Note Panel. 

• To add a note to a paragraph, click in the paragraph and then click in the Project 
Notes panel. Type your text, or paste from the clipboard. 

• To modify an existing project note, place your cursor in the note in the Project Notes 
panel where you want to modify it, then add or delete text as desired. 

NOTE: You can use Ctrl+C and Ctrl+V to copy and paste to the Project Notes panel. 

When you move the cursor to a different paragraph, all your modifications are automatically 
saved. If you have added a new project note, the Notes (N) column will indicate the 
change. 

Editing Paragraphs 
SpecLink provides several tools for editing paragraphs that are very similar to word 
processing. You can add, modify, or delete text in any paragraph. You can promote and 
demote paragraphs, you can copy and paste paragraphs, and you can import text from the 
Windows Clipboard. Each of these editing tools is described in its own section in this 
chapter. 

NOTE: For faster editing, use the Section Check Out feature described in Chapter 9. 

Editing a Paragraph 
When you first view a master section, the Paragraph Origin "O" column is blank indicating 
that the paragraphs are master paragraphs and have not been edited. When you edit a 
paragraph, you are not modifying the BSD master. Instead, your edits are saved in a copy 
of the paragraph that is in your project overlay. Your edits will print instead of the BSD 
master. When a master paragraph has been edited in this fashion, a blue rectangle will 
appear across the bottom of the "O" column. 
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To edit a master paragraph: 

1. In the Document Panel, position the cursor on the paragraph you want to modify by 
clicking at the point you want to edit. 

2. Type and/or delete text as desired, or paste text from the clipboard. 

3. When you have finished editing your text, click outside the paragraph to save the 
edits. 

 A blue rectangle appears across the bottom of the "O" (Origin) column  to indicate 
that the text has been edited. 

NOTE: To undo your edits, you must choose Undo before you click outside the 
paragraph. If you have already clicked outside the paragraph, use the steps 
below to restore the master version. 

Switching Between Master Text and Paragraph Text 
Because the master text is never edited, you can switch back to the master text at any time 
after you have edited a paragraph.  

1. In the Document Panel, position the cursor on the edited paragraph you want to 
restore to the master text (it will have a blue rectangle across the bottom of the "O" 
column). 

2. From the Document menu, choose Restore Paragraph from Master. 

 The original master text is restored, and a yellow rectangle appears across the top of 

the "O" column , indicating this is master text for which a user-edited version is 
available. 

3. To return to the paragraph you edited, from the Document menu, choose Restore 
Paragraph From Project. 

 Your edited project text reappears along with the blue rectangle across the bottom of 
the "O" (Origin) column, indicating this is an edited version of the master text. 

Deleting Edits 
If you accidentally edit a paragraph, or no longer need the project version of a paragraph, 
rather than restoring from the master (as described above) and leaving the yellow rectangle 
in the O column, use the following steps to remove user modifications from a paragraph: 

1. In the Document panel, position the cursor on the edited paragraph (it will have a blue 
or yellow rectangle in the "O" (Origin) column). 

2. From the Document menu, choose Remove Paragraph. 
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 The Confirm Delete message opens. 

 

Confirm Delete message 

3. If you are certain that you want to delete your modifications, choose Yes. Otherwise, 
choose No since you will not be able to Undo this deletion. 

 If you choose Yes, the master version of the paragraph will be displayed and the "O" 
column will return to a blank state. 

Adding and Deleting Paragraphs 
To further customize your specification project, you can add and delete paragraphs. 

NOTE: You can delete user-added paragraphs only. 

Adding a New Paragraph 
There are a few ways to make a new paragraph: 

• To add a new paragraph after the current paragraph, click at the end of the 
paragraph and press Enter. 

• To add a new paragraph above the current paragraph, click at the beginning of the 
paragraph and press Enter. 

• Also to add a new paragraph above the current paragraph, click anywhere within 
the paragraph, and using your right mouse button menu click on Add Paragraph or 
from the Document menu choose Add Paragraph or click the Add Paragraph 
button on the toolbar. 

After using any of these methods, a blank paragraph will appear. The new paragraph will 
be the same level as the paragraph you clicked on prior to creating it. It will have its own 

status box and a white and blue square in the Origin column , indicating that it is a user-
added paragraph. 
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Click in the blank paragraph and type in your text, or use the Paste function to paste text 
from the clipboard. To save the new paragraph, click in a different paragraph. 

NOTE: If the format of the paragraph is not correct, see the next section on changing the 
level of paragraphs. 

By default, new paragraphs are selected automatically, which is indicated by a checkmark 
in the status column. If the new paragraph should not be selected, deselect it. If you would 
prefer that new paragraphs not be selected automatically, you can turn this feature off in the 
Tools menu. 

Changing the Level Of Paragraphs 
Changing the level of a paragraph changes how the paragraph will be formatted. With the 
default formatting, level 1 paragraphs print in bold type, all caps, and are not numbered. 
Level 2 paragraphs print in bold type, all caps, and are numbered 1.01, 1.02, 1.03, and so 
on. If the format of the paragraph is not correct, you may need to promote or demote it.  

NOTE:  Details on the default formatting and how to change it are covered in Chapter 8 
"Printing." 

You can also change the level of a paragraph to create a branch of user-added 
paragraphs. In a branch, the parent paragraph acts as a title to the subparagraphs so that if 
you deselect the parent, none of the children will print even if you leave their status boxes 
selected. Creating branches in appropriate places makes editing faster and more logical. 

You can change the level of any paragraph, master or user-added, provided the change 
does not cause a 'break in levels.’ An example of a break in levels would be a level 2 
paragraph directly followed by a level 4 paragraph. There must be a level 3 paragraph 
before the level 4. If a level change would cause a break in levels, the following message 
will appear when you attempt the change:  

 

Break in Level Hierarchy message box 
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To change the level of a paragraph, click in the paragraph you want to change and then 
choose the appropriate command from the Document menu, or use the appropriate button 
on the toolbar. 

There are four commands for changing paragraph levels: 

 Demote 
Demote causes the current paragraph (the paragraph with the dark blue background in its 
status columns) to become one level lower. For example, demoting a level 3 paragraph 
would make it level 4. 

If the level 3 paragraph had any subparagraphs, those paragraphs would remain at their 
original levels, and would no longer be subparagraphs to the demoted paragraph. 

NOTE: Demoting a parent paragraph is useful when trying to delete or copy just the 
parent paragraph. If a paragraph has any subparagraphs, those paragraphs are 
copied or deleted when the parent is copied or deleted. 

 Demote Branch 
Demote Branch causes the current paragraph to become one level lower just like the 
Demote command. However, if the current paragraph has any subparagraphs, those 
paragraphs will also be demoted one level. 

For example, if a level 3 paragraph has a level 4 subparagraph, the level 3 paragraph will 
become level 4, and the level 4 paragraph will become level 5. If the original level 4 
paragraph had a level 5 subparagraph, the level 5 paragraph would become level 6. 

 Promote 
Promote causes the current paragraph to become one level higher. For example, 
promoting a level 3 paragraph would make it level 2. 

If the level 3 paragraph is directly followed by another level 3 paragraph, the newly 
promoted level 2 paragraph will become the parent of the level 3 paragraph. 

If the level 3 paragraph is directly followed by a level 4 paragraph, you will not be able to 
promote the level 3 paragraph since it would cause a break in levels. Use Promote Branch 
instead. 
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 Promote Branch 
Promote Branch causes the current paragraph to become one level higher just like the 
Promote command. However, if the current paragraph has any subparagraphs, those 
paragraphs will also be promoted one level. 

For example, if a level 3 paragraph is directly followed by a level 4 paragraph, the level 3 
paragraph will become a level 2 paragraph and the level 4 paragraph will become a level 3 
paragraph. If the original level 4 paragraph had a level 5 subparagraph, the level 5 
subparagraph would become a level 4 paragraph. 

Also, if there are any level 3 paragraphs between the newly promoted level 2 paragraph 
and the next level 2 paragraph, those paragraphs are now part of the new level 2 
paragraph's branch. 

Deleting a Paragraph 
NOTE: You can delete user-added paragraphs only. Master paragraphs cannot be 

deleted, only excluded. 

To delete a user-added paragraph: 

1. In the Document Panel, position the cursor on the user-added (new or copied) 
paragraph you want to delete (there will be a white and blue square in the "O" 
column). 

NOTE: Make sure the cursor is blinking in the paragraph. If any text is blocked (selected) 
the next step will only delete the blocked text and not the entire paragraph. 

2. Using your right mouse button, selection Delete or from the Edit menu choose Delete,  

or click the Delete paragraphs or selected text button on the toolbar , or select 
Remove Paragraph from the Document menu. 

NOTE: The Delete key on your keyboard cannot be used for this step - it will only delete 
the character to the right of the cursor. 

3. You are prompted to confirm the deletion. 

If the paragraph has no master subparagraphs or if it has user-added subparagraphs, 
the following message will appear: 
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Confirm Delete message 

Before clicking Yes, make sure you do want to delete the paragraph along with any user-
added subparagraphs it may have. If you choose Yes, there is no way to get the 
paragraph(s) back without recreating them or copying them from another project. 

If you are certain that you want to delete the paragraph and any user-added 
subparagraphs, click Yes. The paragraph will be deleted. If the paragraph had any user-
added subparagraphs, they will also be deleted. 

If you are in any way unsure that you want to delete the paragraph or any user-added 
subparagraphs, click No. The paragraph(s) will not be deleted. If you want to delete the 
parent paragraph, but not the subparagraphs, either promote the first subparagraph, or 
demote the parent paragraph. 

NOTE: If the paragraph has subparagraphs that are master paragraphs, the following 
message will appear: 

 
Unable to Delete message 

 In order to delete the parent paragraph, demote it so that it is no longer the 
parent of any master paragraphs. 

Copying and Pasting 
Anyone who has used a word processor knows the value of Copy and Paste. SpecLink 
takes copy and paste further, taking advantage of the hierarchical nature of the standard 
specification format and the built-in links.  
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When you copy a paragraph and paste it into a different location, either in the same section 
or in a different section, in addition to the paragraph text, you get: 

• all subparagraphs, down to the end of the hierarchical "branch" 

• all the choice options 

• all links to targets (outside links to targets in the copied branch are not copied to the 
pasted copy) 

If you only want to copy the text in a paragraph and not the items listed above, drag across 
the text to highlight it before Copying. If you want to copy the text and all the items listed 
above, click in the paragraph so your cursor is blinking before Copying. 

If you want to copy the parent of a branch including choices and target links, but not its 
subparagraphs, first demote the parent so that it no longer has subparagraphs, then click in 
the paragraph so your cursor is blinking, and then Copy. 

Using Copy and Paste 
You can copy a paragraph by positioning the cursor on the paragraph you want to copy, 
then performing the following steps: 

1. Using the right mouse button click on Copy. Or from the Edit menu, choose Copy. You 
can also choose the Copy button from the Standard Toolbar, use the key combination 
Ctrl+C, or use the right mouse button menu. 

2. Position the cursor in the paragraph that is below where you want to paste the copied 
paragraph. 

3. Using the right mouse button click on Paste or from the Edit menu, choose Paste. You 
can also click on the Paste button from the Standard Toolbar, use the key combination 
Ctrl+V, or use the right mouse button menu. 

 Notice the white and blue square in the Origin column indicating this is a user-added 
paragraph. 

You can copy any branch within a section. Position the cursor on the paragraph at the top 
of the branch and choose Copy. Then click on the paragraph that is below where you want 
to paste the copied text and choose Paste. 

The pasted branch pushes down the original paragraph at the pasted location. The 
paragraph at the top of the pasted branch is given the level of the paragraph at which it was 
pasted. If this inherited level is incorrect, you can adjust it. See the "Demoting and 
Promoting Paragraphs" section in this chapter for details. 
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Copy and Paste between Sections 
You can copy paragraphs and branches from one section to another. Here’s how: 

1. From the Window menu, choose New Window. 

 A second window of the project opens, covering the first window. 

2. In the new window, display the second section you want to work in. 

3. From the Window menu choose one of the Tile or Cascade options to arrange the 
windows on your screen. 

NOTE: To better see the text you are working with you may want to close the Tree panel. 
When you choose the option to turn off the Tree panel, it will close in the window 
that has the more brightly colored title bar. To close the Tree panel in the other 
window, first click in the window so that its title bar indicates that it is the current 
window. 

4. Click in the paragraph or the parent of the branch that you want to copy.  

5. Using the right mouse button click on Copy or from the Edit menu, choose Copy. You 
can also choose the Copy button from the Standard Toolbar, use the key combination 
Ctrl+C, or use the right mouse button menu. 

6. Click in the other section to place your cursor anywhere in the paragraph that is below 
where you want to paste the copied paragraph(s). 

7. Using the right mouse button click on Paste or from the Edit menu, choose Paste. You 
can also choose the Paste button from the Standard Toolbar, use the key combination 
Ctrl+V, or use the right mouse button menu. The pasted text "pushes down" the 
paragraph originally at that location. 

NOTE: To copy an entire section from one project to another, see Import From Project in 
Chapter 4 "Starting a New Project." 

Importing from a Word Processor 
You can take previous work from a word processor and import it into SpecLink. Use Paste 
or Import From Clipboard to copy and paste any number of paragraphs from a word 
processor to SpecLink. To import an entire section, save the word processing document in 
RTF format, and use Add New Section From RTF File (available on the Document menu 
under Sections).  For more information on Add New Section from RTF File, see the Adding 
New Sections part of Chapter 4. 
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Importing or pasting from the Windows Clipboard treats new paragraphs according to two 
settings in the Tools menu: 

Auto-Select New 
Paragraphs 

This command is a toggle. When checked (default setting), new 
paragraphs will automatically be selected by a checkmark. 

Look for Choice 
Fields in Import 

This command is a toggle. If toggled on, when using Import From 
Clipboard or Add New Section From RTF File, brackets and greater 
than and less than signs will be used to create new choices in the 
imported text.  For a list of choice formats, see the Adding New 
Sections part of Chapter 4. 

The following topics should also be considered when importing: 

Paragraphs 
Each paragraph in the original text is pasted consecutively into a separate new paragraph 
cell. Hard returns (WordPerfect), paragraph marks (Word), hard line breaks (Word Perfect), 
and manual line breaks (Word) are used to determine the end of a paragraph. If you are 
uncertain about where paragraphs end, turn on whatever function is used in your word 
processor to display the paragraph marks or codes and view them. 

If you are using line breaks in the word processing document in order to keep paragraphs 
from being numbered, after you import the text, use No AutoNumber from the Document 
menu to keep those paragraphs from being numbered in SpecLink. 

Blank paragraphs in specification text are discarded; blank lines within notes are 
maintained. 

Notes 
Lines beginning with 10 or more asterisks will be recognized as the boundary beginning or 
ending text that should be treated as a Note to the following paragraph. To import a note on 
a paragraph, it should be formatted like this: 

**********  

This is the project note for Paragraph One 

**********  

Paragraph One 

Paragraph Numbering 
Paragraph numbering is removed in the import process so that the new section will be 
numbered consistently with all the other sections in your project. See Customize Styles for 
how to change the numbering styles. 
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SpecLink identifies a number as up to five characters at the beginning of a paragraph, 
followed by a tab. Numbers followed by spaces will import. Numbers (and words) of five 
characters or less at the beginning of a paragraph, followed by a tab, will not import. 

NOTE: If you have a word of five characters or less at the beginning of a paragraph 
followed by a tab, the word will not import. This may happen if you are importing 
tables or definitions. 

Levels 
Paragraphs beginning with the word “Part” and one of the words “General,” “Products,” or 
“Execution” will import at Level 1. The test is not case-sensitive. 

Other paragraph levels are determined by the amount of space between the left margin 
and the first printable character on the line (not including numbering), whether tabs, left 
indents, or multiple spaces, create the space. If the amount of space indicates that a 
paragraph is indented two or more levels below its parent, the paragraph will import at one 
level below its parent. 

Other Characters 
Imported text from the Clipboard is ASCII text. Besides letters and numbers, and tabs and 
carriage returns, the only characters that are imported are those in the standard ASCII 
character set, which correspond to a standard keyboard.  

Using Import from Clipboard 
To import text into an existing section, use the following steps:  

1.  In your word processor, look over the text you are importing paying special attention to 
tables, special characters, and choices as described above. 

2.  Copy the text you want to import. You can do this by dragging across the text with 
your mouse to highlight (or select, or block) the text, and then use the word 
processor’s Copy function to copy the text to the Clipboard. 

NOTE: You can use the key combination Ctrl+C to copy text to the Clipboard. 

3.  In SpecLink, open the project and section into which you want to import the text. 

4.  Put the cursor anywhere in the paragraph that is below where you want to paste the 
text. 

5.  Using your right mouse button click on Paste or from the Tools menu, choose Import 
from Clipboard. (Or choose any Paste command.) 
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 The text from the Clipboard is imported as described above, with white and blue 
square icons in the Source status column indicating that these are user added 
paragraphs. 

Adding Tables 
To further customize your specification project, you can add tables in SpecLink, either by 
copying from Word, or by typing directly into SpecLink. 

Copying a Table from Word to SpecLink 
Tables can not be imported into SpecLink as SpecLink tables.  They can be imported as 
tabbed text, which will appear as a table, if none of the text needs to wrap to another line.  
To copy a table from a Word document into SpecLink, do the following:  (If you need 
columns with text that wrap, or you need printed borders, see the topic below Inserting a 
Table in SpecLink Directly.)  

NOTE: Be certain the margin settings in SpecLink are the same or wider than the 
document in Word. Otherwise, the table will not fit properly and line breaks will 
occur at inappropriate locations. 

1. In the SpecLink Tools menu, verify that Auto-Select New Paragraphs and Look For 
Choice Fields in Import are turned off or on as you want them. See the descriptions of 
these options earlier in this chapter for more information. 

2. Select the table in Word. 

3. From the Table menu, choose Convert, and then choose Table to Text. 

4. Use the option to separate with tabs. 

5. Once complete, select all the text in the table, and Copy (from the Edit menu, or the 
toolbar, or use Ctrl+C). 

6. Open the appropriate section in SpecLink and place the cursor in the paragraph that is 
below where you want the table, then from the Tools menu, choose Paste or Import 
from Clipboard. 

 The paragraphs are added above the paragraph you clicked on. 

7. Add tabs where needed in the ruler above the Document Panel.  

If the text does not line up in columns, click to place your cursor where more space is 
needed and press tab on your keyboard. Continue doing this until all the columns line 
up. It is best to line up the columns from left to right. 

8. Tab stops can be changed by highlighting all of the paragraphs and then clicking on 
View and then Tabs.  (See below for more information on the Tabs Dialog box.) 
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9. If you do not want the rows of the table to be numbered, drag across all the text in the 
table to highlight it, and then from the Document menu choose No AutoNumber. 

10. To add a page break before the table, click in the paragraph that you want to have at 
the top of the page, and from the Document menu choose Insert Page Break. 

 A dark line will appear above the paragraph, representing the page break. The 
paragraph mush be active and not be tagged NS or NP in order for the page break to 
work. 

NOTE: To remove a page break, click in the paragraph that has the dark line above it 
and from the Document menu choose Remove Page Break. 

Eliminating Paragraph Numbers for a Table 
To suspend SpecLink’s automatic paragraph numbering for imported tables, block the 
paragraphs in the table, and from the Document menu or right mouse button menu, choose 
No AutoNumber. 

Inserting a Table in SpecLink Directly 
Inserting a table directly into SpecLink will allow you to incorporate text that wraps within a 
cell.  Borders on inserted tables can also be printed, if desired.  If you want to create a table 
in SpecLink itself, do the following: 

1. Click on the paragraph that will be below the new table. 
2. Click on the Table menu and choose Insert Table. 
The Insert Table dialog box opens. 

 

3. Input the number of columns and rows desired for this table and then click 
on OK. 
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Note that you may want to create one or more extra columns in the table since it 
is possible to delete columns but it is not possible to add them once a table has 
been created. 

NOTE: The maximum number of rows in a table is 29.  The maximum number of 
columns is 14.  Do not set a column width of less than ½”.  

The table is inserted into the section at the same level as and above the 
paragraph you originally highlighted.  The left edge of the table will be at the left 
indent of the assigned level.  To further indent the text of a table allow an extra 
column; to reduce the indent of the text put the table at a higher level or promote 
it after creating it.  The initial width of columns will be the width between the left 
indent and the right indent divided by the number of columns.  A table will never 
be wider than the margin created by the right indent. 
4. To make adjustments, use the other commands on the Table menu: 

• Insert Row Below - Use this command to insert an additional row into the table 
below the current row.  

• Configure Column- Use this command to change the width and column 
alignment of the current column. Note that you can also use the alignment 
buttons on the text panel toolbar to change the alignment of a single table cell. 

• Set Border… - Use this command to add or remove a border for the table.  
(Note that for a border to print, you must also select Print Table Borders in the 
Report Setup Dialog Box.) 

• Delete Current Row - Use this command to delete the current row.  

• Delete Current Column - Use this command to delete the current column.  

Deleting a Table 
A table is treated as a single paragraph by the software.  To delete a table, simply click 
anywhere within the table and then click on the X in the Toolbar, use your Right Mouse 
Button and select Delete or choose Remove Paragraph from the Document menu. 

NOTE: Beware that you don’t remove an entire table when you are intending to only 
remove a row or a column. 

Applying Tabs to Paragraphs 
On the View menu is a selection called Tabs.  The Tabs dialog box allows you to use tabs 
within a selected area of your section.  This feature can be used when you want columns to 
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be aligned but do not need to create a table. This feature is not available when you are in a 
table. 

NOTE: Tabs may not be applied to Level 0 or Level 1 paragraphs. 

Using the Tabs Dialog Box 
Use the Tabs Dialog box to align text in a columnar format. The dialog box allows you to set 
and clear tabs as left, centered or right justified.  The tabs set or cleared in the Tab Dialog 
box are applied to all paragraphs that are selected at the time that the Tabs Dialog box is 
opened.  Tab stops for the currently highlighted paragraph are indicated in the ruler bar 
above the text panel using angle marks. 

1. Within your document, select the paragraph or group of paragraphs that are to have 
the tabs applied.  To select one paragraph, simply click anywhere on that paragraph.  
To select a group, click on the first one and then drag your mouse over the remaining 
paragraphs. When selected, they will have a black background in the document 
panel. 

2. While the paragraphs are selected, click on the View menu and select Tabs. 
 

 
3. To set a tab, click on the Tab stop position field and input the width of the first tab stop in 

inches.  Note that the first tab stop will be measured from the left margin of the 
document. 

4. If the alignment is to be Left, leave the Left alignment set.  Click on Center or Right to 
change the alignment from Left. 

5. Click on the Set button. 
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6. To add additional tab stops, click on the Tab stop position and enter another number. 

7. If you need to change the position for an existing tab, click on it and then click the Clear 
button.  Re-add the Tab stop position as desired.  Use the Clear All command to clear 
all tabs settings. 

8. When finished, click on OK to implement the tabs within the selected paragraphs. 

NOTE: Note that the Tables capability is sometimes a more effective way to arrange 
multiple data columns. 

User-Added Choices 
In user-added and copied paragraphs, you can add embedded choice options like those in 
master paragraphs. Building choice options is a bit more time-consuming than simply 
adding the text that is needed for a particular project, so this feature is principally useful for 
adding options within an office master project. 

NOTE: Choices can be added only to user-added or copied paragraphs. 

Adding Choices To a Paragraph 

You can add choices to any user-added or copied paragraph. It is usually easier to add the 
choice after you have entered all the text and punctuation in the paragraph that will not be 
part of the choice. To add choices to a paragraph: 

1. Copy an existing master paragraph or add a new paragraph. 

2. In the new paragraph, type any (additional) text that should always be in the 
paragraph, regardless of the selected choice. 

3. Add any punctuation that should precede or follow the choice. If the choice will be 
between two existing words, put two spaces between the existing words. If the choice 
will be the end of the paragraph, add the punctuation for the end of the paragraph. 

NOTE: If the punctuation should change according to what is selected in the choice, 
then do not type that punctuation in the paragraph. In the paragraph type 
anything that would follow the punctuation. You will include the punctuation in the 
choice options below. 

4. Click to place your cursor where the choice should be located. 

5. On the Document menu, point to Choices, and then choose Add Choice. 
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 The Add Choice dialog box opens. 

 

Add Choice dialog box 

6. Click the pull-down arrow at the end of the Choice Group Type field. The pull-down list 
shows the same types as those that appear in master paragraphs, plus the special 
"global" types for replaceable terms (Architect, Owner, Contractor, etc.) and units of 
measure. 

NOTE: Optional types automatically insert the choice "None - N/A" into the option list. 
Choice types also can be combined. For example, an entire choice group can be 
exclusive multiple choice, but individual choice options can be fill-in-the blank or 
unit of measure. 

7. Select the desired choice type, and click Insert. 

 The choice type selected appears in the Choice Group Type box and the cursor 
appears in the Current Option box. If you selected an optional choice type, the words 
None - N/A" appear in the Choice Options box. 
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Add Choice Dialog Box with Optional Choice Type 

8. Enter the text of the first choice option in the Current Option box, then click Add. 

 The choice option just entered appears in the Choice Options box. 

9. To add another choice option, enter text in the current option field and click Add. 
Continue in this manner until all your desired choice options have been entered. 

10. Change the order of the choice options by clicking on a choice option and then 
clicking the Up or Down button. 

11. Edit a choice option by clicking on the choice option and then editing the text in the 
Current Option field. Click the Add button when you are done editing. 

12. When the choice group is complete, click OK. 

 The new choice group appears in the paragraph at the location selected, with the first 
option as the default. If you click once within the colored choice text, the choice list 
pops up just as it does in master paragraphs. You can change the default option by 
clicking on the appropriate choice, then pressing Close. 

Hints About Adding Choices 
You can combine types of choices. 

To include a fill-in as a choice option in any of the multiple choice group types, click in the 
Current Option field and type [____]. Be sure you use opening and closing brackets at the 
beginning and end (You do not use the Shift key to type the brackets.) Between the 
brackets type as many underlines as you wish. When it is later filled in with text it will grow 
or shrink as necessary. 

To add None - N/A as a choice option, click in the Current Option field and type None - N/A. 
It is case-sensitive so be sure to capitalize the correct letters. Also be sure to type spaces 
before and after the hyphen. 



 C h a p t e r  5  :  E d i t i n g  a  P r o j e c t  

164 S p e c L i n k  U s e r  M a n u a l  

To include a unit of measure as a choice option value, click the UOM box. Three fields 
appear. Enter the English and Metric versions of the unit of measurement text in the first 
two boxes, then click Add. The English (Metric) options fills in automatically. The unit of 
measure that will display in the specification will correspond to the selected Unit Of 
Measure choice in the Summary Information dialog box. 

 

Add Choice Dialog Box with UOM Option in Optional Multiple Choice Group 

To create a section number as a MasterFormat Version Choice, choose MasterFormat 
Version Format as the Choice Group Type. Three fields appear. Enter the MF04 and MF95 
versions of the section number in the first two boxes, then click Add. The MF04 (MF95) 
option fills in automatically. The section number that will display in the specification will 
correspond to the selected MasterFormat Version choice in the Summary Information 
dialog box.  

NOTE: When adding a MF04 Choice, always use the 00 0000 format, rather than 00 00 
00 or 000000.  That way, you can change the MF04 section display in the 
Summary Info Dialog Box to whichever MF04 section format you choose. 

Clicking the MFV checkbox on the bottom right allows you to include both MF versions 
within another Choice Group Type. 
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Add Choice Dialog Box with MasterFormat Version Format Choice Group 

 

Edit Choice Dialog Box with MasterFormat Version as a Choice Option in an Exclusive Multiple 
Choice  

Using the MFV option with an Exclusive Multiple Choice allows the option of a fill-in the 
blank so the specifier can input an alternate section name. 

Replaceable terms such as Architect or Owner cannot be combined with other choice 
types. You must insert them directly into the paragraph as a Choice Group. 

Editing an Existing Set of Choices 
You may edit choice groups in user-added or copied paragraphs only. This means that if 
you wish to modify the choices available in a master paragraph, you must first copy the 
paragraph and paste it into the project. 
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NOTE: If there are links to the original paragraph, you may wish to manually exclude the 
original paragraph and create new links to your replacement paragraph. 

1. Position the cursor on the colored text denoting an embedded choice group. 

2. On the Document menu, point to Choices, and then choose Edit Choice, or click the 
Edit Choice button on the Edit toolbar. 

 

Edit Choice Dialog Box 

3. Click on the choice option you want to edit and make the desired changes in the 
Current Option text box, then click Add. 

4. Click on any other choice option you want to edit and proceed as above. If you want to 
add a new choice option, click in the Current Option field, enter the new text, then click 
Add. To delete a choice option, click on the option and click Remove. 

5. To change the order of the choice options (choices are often listed with the most 
common choice first or in alphanumerical order), click on a choice option and click the 
Up or Down buttons. 

6. When your changes have been completed, click OK. 

NOTE: You cannot change the choice group type. If that is necessary, delete the choice 
group and build a new one in the same location. 

Removing a Choice Group 
You may remove choice groups in user-added or copied paragraphs only. This means that 
if you wish to remove a set of choices available in a master paragraph, you must first copy 
the paragraph and paste it into the project. 
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NOTE: If there are links to the original paragraph, you may wish to manually exclude the 
original paragraph and create new links to your replacement paragraph. 

1. Position the cursor on the colored text denoting an embedded choice group. 

2. From the Document Menu, select Choices and then Remove Choice, or press the 
Remove Choice icon on the Edit Toolbar. 

3. You are prompted to verify that you wish to remove the choice group. When you click 
OK, the choice group is removed. 

NOTE: Be certain you want to delete the choice group before clicking OK, because it is 
not possible to UNDO this process. 
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