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Summary of Changes

The following is the history and summary of changes for this publication: 

EC Date Edition Description

123024 February 2000 First Initial release. 

123103 June 2000 Second Refer to this edition for a description of the changes. 

123138 August 2000 Third Updated to support Version 1.1.1 installation 
instructions, new screen shots, and LUNWorks Ready 
HBAs. Added a procedure to un-install LUNWorks.
Version 1.1.1 has HBA drivers that support both the 
QLA2100 and QLA2200.
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Preface 

The LUNWorks Installation and User’s Manual contains instructions for using 
StorageTek’s LUNWorks application to configure, manage, and maintain Fibre 
Channel disk storage on a storage area network (SAN).

This manual is intended for administrators who perform network management 
tasks such as installation, configuration, and storage allocation. Because 
LUNWorks is transparent to non-administrative users on the network, client User 
Guide’s are not required. 

■ Organization of Information 

This guide has the following organization: 

■ Trademarks 

StorageTek, the signature, Information Made Powerful, and LUNWorks are 
trademarks of Storage Technology Corporation. Other product names, features, 
and terms used in this publication are for informational purposes only and 
might be trademarks of Storage Technology Corporation or of other companies.

Chapter 1 Introduction contains an overview about LUNWorks features 
and storage area networks. 

Chapter 2 Installation and Configuration guides you through the 
LUNWorks installation and configuration process.

Chapter 3 LUNWorks Basics explains the basic operation and screens.

Chapter 4 Administration contains information about the administration 
of the LUNWorks application and software.

Chapter 5 Storage Management contains helpful information about 
storage management.

Chapter 6 Advanced Administration provides information about share 
groups with Microsoft cluster servers. 

Appendix A Troubleshooting contains helpful information about isolating 
hardware (or network) and software problems.

Glossary Defines new or special terms and abbreviations in this guide.

Index Assists in locating information in this publication.
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■ Assumptions 

This guide assumes that you have a working knowledge of the Windows NT 
Operating System and its conventions. Refer to your Windows NT 
documentation for more information about Windows NT. 

This guide also assumes you are familiar with networking issues and 
components as they relate to the customer’s environment.

■ Conventions 

This guide uses the following conventions: 

Note: Provides additional information that might be of special interest. A note 
can point out exceptions to rules or procedures. 

When referring to menus and submenus, Edit > Select All means to choose the 
Select All option from the Edit menu. 

Filenames appear in Courier font, such as trsmadmin.exe. 

■ Related Publications 

Refer to the following publications for additional information about LUNWorks: 

• LUNWorks Read Me First file 
• LUNWorks for Solaris Installation Manual Part Number 313429201 
• Requesting Help From Software Support Part Number 112124004 

■ Contacting Us 

We welcome input from our customers. 

If you have any comments or suggestions for improving our products, go to 
the Customer Support website and follow the contact links:

http://www.stortek.com/StorageTek/css/

If you would like to know more about StorageTek, our products, and 
services, visit StorageTek’s StoreFront website: 

http://www.storagetek.com/

If you would like to send feedback about the documentation, please fill out 
and return the Reader’s Comment Form at the back of this publication. We 
encourage and appreciate your feedback. 

Tip: Provides helpful information and suggestions for LUNWorks. 

http://www.stortek.com/StorageTek/css/
http://www.storagetek.com/
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1Introduction

Welcome to LUNWorks. 

LUNWorks is a software product that allows you to manage Fibre Channel 
storage in a highly efficient manner as an administrative cluster. LUNWorks 
allows homogeneous systems to use a common pool of storage devices on a 
storage area network (SAN). Administrators can assign devices when and where 
they are needed through a simple drag-and-drop interface. 

Using LUNWorks, storage can be added to the network or assigned to nodes 
without rebooting network nodes or storage systems. Storage is available for 
immediate use because it is mounted automatically when assigned. These 
features eliminate the costly downtime normally associated with adding and 
moving storage.

LUNWorks shared nothing architecture provides network security by enforcing 
exclusive access rights to storage. 

This chapter contains an overview about storage area networks (SAN) and the 
LUNWorks features.

Note: Check the Read Me First file for the availability of supported products, 
services, and components including host bus adapters (HBAs) and 
applications such as CLARiiON’s Application Transparent Failover. 

■ Overview

LUNWorks is a storage area network software product for Enterprise networks 
(also known as SANware). LUNWorks controls Fibre Channel storage at the 
device or logical unit number (LUN) level, and includes the following features:

• Storage asset pool creation 

• Reduced administration costs 

• Business critical environments 

• Data security 

• Industry compatible 
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Storage Asset Pool Creation 

LUNWorks creates a highly scalable storage asset pool that allows devices to be 
assigned exclusively and securely to designated nodes on the network. Up to 
16,000 devices and a maximum of 200 nodes can be configured on a single SAN 
for superior system scalability.

Reduced Administration Costs

LUNWorks reduces the Total Cost of Ownership by simplifying storage 
administration. All nodes and storage on the network are presented to the 
administrator as a single image. This single, unified view provides control over 
all network storage assets, allowing storage to be added or moved without 
physically reconfiguring the network. Storage can be assigned when and where 
it is needed in a matter of seconds.

Simple drag-and-drop procedures, automatic discovery of new nodes and 
storage, mounting assigned storage automatically when it comes online, filtered 
views and other timesaving features significantly reduce administration time.

Business Critical Environments

With LUNWorks, storage and node changes can occur without requiring nodes 
or storage arrays to reboot, providing 100% availability during SAN 
administration procedures. When devices containing file systems are moved, 
LUNWorks automatically mounts the associated file systems so they will be 
available for immediate use.

There are no single software points of failure in the LUNWorks architecture, 
making it suitable for enterprise environments which demand that systems be 
operational 24 hours a day, 7 days a week (7 by 24).

Data Security

LUNWorks only allows nodes to mount and access storage that is exclusively 
assigned to them. In conjunction with underlying network operating system 
security, this restricted access mechanism provides solid security for all storage 
network assets.

Industry Compatible 

Redundant array of independent disks (RAID) or just a bunch of disk (JBOD) 
storage from industry leaders, clustered servers, file system and storage 
management utilities, and backup and restore products can be integrated under 
one administration umbrella using LUNWorks. 
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LUNWorks Architecture

Network topology independence and compatibility with a wide range of Fibre 
Channel components allows LUNWorks to bring it all together.

■ LUNWorks Architecture 

A typical LUNWorks network is shown below: 

LUNWorks nodes connected to the LAN access Fibre Channel storage directly 
through the SAN. In the illustration above, there are three disk arrays with 21 
devices (LUNs). Nodes A, B, and C can only access their assigned storage. 

For example, Node A can access Tower 1 device 1, Node B can access Tower 2 
device 0, and Node C can access Tower 2 device 4 and Tower 3 device 2. All other 
devices are hidden until they are assigned through the LUNWorks application.

LAN

Fabric

Node ANode A Node BNode B Node CNode C

Device 6

Device 5
Device 4

Device 3

Device 2

Device 1

Device 0

Device 6

Device 5

Device 4

Device 3

Device 2
Device 1

Device 0

Device 6

Device 5
Device 4

Device 3

Device 2

Device 1

Device 0

Tower 1 Tower 2 Tower 3

FC SAN
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2Installation and Configuration

This chapter guides you through the installation and configuration process. 

■ System Requirements 

All LUNWorks nodes must meet the following minimum system requirements: 

• Windows NT Server, Workstation, or Enterprise Version 4.0 with Service 
Pack 4, or higher 

• PCI bus-equipped computer, with one free bus mastering slot 

• 200 MHz Pentium or faster 

• 64MB RAM 

• Available disk space: 4 MB 

• Network interface card (NIC) 

• Network protocol stacks: NetBIOS, TCP/IP 

Note: See the LUNWorks for Solaris Installation Manual for information about 
the minimum system requirements and installation for Solaris nodes. 

■ Components 

The main components for LUNWorks include: 

Table 2-1. LUNWorks Components 

File Name Description
Control 
Panel

trsmadmin.exe LUNWorks Application none

trsanmanservice.exe LUNWorks Service Services

trdisk.sys LUNWorks Disk Driver Devices

trlds.sys LUNWorks Logical Device System Driver Devices

trlls.sys LUNWorks Low-Level SCSI Driver Devices

trspfltr.sys LUNWorks Ready Filter Driver Devices

trqladrv.sys LUNWorks Driver for QLogic HBAs Devices
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■ Setting Up the Hardware 

For detailed hardware setup procedures, see the product manuals included with 
your Fibre Channel hardware. In general, follow the steps outlined below: 

Installing a Fibre Channel Host Bus Adapter 

Install a Fibre Channel host bus adapter (HBA) into each computer: 

1. Verify that the computer functions properly before installing the HBA.

2. Power-off the computer.

3. Install the Fibre Channel HBA. 

For detailed instructions, see your Fibre Channel HBA installation guide.

Connecting the Hardware 

Note: Refer to the appropriate documentation for instructions about how to 
install the hardware. 

To install the hardware: 

1. Cable the Fibre Channel storage enclosures to the hubs or switches using 
the appropriate cable types (optical or copper).

2. Plug in the power cords of all Fibre Channel network components.

3. Cable each computer to the hub or switch.

4. Power-on the network-attached storage.

5. Power-on the Fibre Channel network hardware.

6. Power-on the network-attached computers.

Note: Unless you choose a custom location, the application and service are 
installed into the following folder: C:\Program Files\LUNWorks.
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Installation Instructions

■ Installation Instructions 

LUNWorks comes with drivers that support both JNI and QLogic HBAs. The 
steps to install LUNWorks depends on which HBA and driver will be used. 

If using a JNI HBA and driver refer to the following instructions: 

• “Installing LUNWorks” on page 2-4 
• “Installing the JNI Host Bus Adapter Driver” on page 2-7. 
• “Configuring LUNWorks” on page 2-10 

Note: It does not matter when you install the JNI driver, you can install it before 
or after LUNWorks is installed. 

If using a QLogic HBA and driver refer to the following instructions: 

• “Installing LUNWorks” on page 2-4 
• “Configuring LUNWorks” on page 2-10 

Important: 
The installation of the QLogic HBA driver is integrated into the LUNWorks 
installation procedure. Make sure to select it if using the QLogic HBA or deselect 
it if using the JNI HBA. 

Before Installation 

Before installing LUNWorks, check the following items: 

• Does the computer meet the system requirements? 
• Are the hardware installation procedures complete? 
• Is the LAN up and running? 
• Is the Fibre Channel network hardware powered-on? 

During the configuration procedure, the application prompts you to choose one 
or more administration groups from a list of Windows NT groups. Members of 
designated administration groups can access the application and administer the 
network from any node. You can use existing Windows NT groups, or you may 
create a new group that includes all users that need administration privileges. 

Have the following items available: 

• LUNWorks installation CD 
• LUNWorks Installation and User’s Manual (included on the CD)
• Read Me First file (included on the CD) 
• LUNWorks installation keys 
• LUNWorks for Solaris Installation Manual (if necessary) 

Note: You may want to print the documentation to have available during the 
installation and configuration of LUNWorks. 
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■ Installing LUNWorks 

To install LUNWorks: 

1. Log on to the computer with administrator level privileges.

2. Run the installer by doing one of the following: 

• Insert the CD in the CD drive. If autorun is enabled, inserting the CD 
starts the installer automatically. 

• If autorun is disabled or you are installing it across a network, locate the 
CD directory and double-click on Selector.exe. 

The Selector screen appears. 

3. Click the Install LUNWorks button, and follow the on-screen instructions. 

From the Selector screen, you can also View the Read Me First file, View the 
Installation Manual, Browse the CD, or Exit. 

Note: Adobe Acrobat Reader installed on the CD. You need this program 
to open, view, and print both the Installation and User’s Manual and 
Read Me First file. 
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Installing LUNWorks

4. Check the following when the LUNWorks installer screen appears: 

• If a previous installation of LUNWorks exists. Un-install it before you 
continue with this installation procedure. 

• If other Windows programs are running. We recommend that you close 
all running Windows programs and start the installation procedure 
again, click Cancel then click the Exit Setup button. 

5. Read the software license screen and then click Next to agree. 

6. Accept the default location and click Next or click Browse and choose a 
custom destination, specify the desired location, then click Next. 

7. When asked what components of LUNWorks you would like to install: 

• Select LUNWorks administration application. 

Deselect this box if you are installing LUNWorks on a client. You 
only need to install the LUNWorks administration application on the 
Master computer and any backup computers.

• Select LUNWorks ready QLogic HBA driver only if using QLogic 
adapters for the network connection. 

Deselect this option if using JNI. 

• Select Update Windows NT registry for optimal SAN support. 
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8. Click Next to continue. The LUNWorks Ready HBA driver dialog box 
appears. 

9. Do one of the following:

• If a LUNWorks ready HBA is installed, select Yes and click Next.
• If you are not using a LUNWorks ready HBA, select No and click Next. 

Note: A LUNWorks ready HBA card or driver is a third-party HBA card or 
driver (such as JNI) that has been qualified for use with LUNWorks. 

10. Verify the installer indicates the correct list of settings you specified. 

If these settings are correct, click the Next button. Otherwise, click the Back 
button and specify the correct settings. The installer copies the necessary 
files to the system and notifies you when the installation is complete. 

11. Observe for the following messages: 

• Everything was installed correctly, and 

• You do not need to restart your system and you can start to use 
LUNWorks immediately, or 

• You indicated that you plan on installing LUNWorks Ready HBA drivers. 
After you exit this installer, proceed with the installing the HBA drivers 
then restart your system.

12. Press Finish to exit this installer. 
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Installing the JNI Host Bus Adapter

■ Installing the JNI Host Bus Adapter Driver 

To install the JNI HBA driver: 

1. Log on to the computer with administrator level privileges. 

2. Insert the installation CD in the disk drive. 

3. Start Windows Explorer or open My Computer. 

4. Double click on the disk drive to see the contents of the CD. 

5. Double click on Setup.exe. 

The JNI Setup screen appears: 

6. Click Next. 

7. Click OK at the following message: 
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8. Select the Drivers tab. 

9. Click the Add... button. 

A message appears saying creating driver list. 

10. Click the Have Disk... button at the Install Driver screen. 

11. Enter the pathname for the location of the install CD and driver filename or 
click browse and navigate to oemsetup.inf. 

Such as D:\JNI116x\WINNT40\oemsetup.inf 

12. Click OK. 
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Installing the JNI Host Bus Adapter

13. Click OK at the Install Driver prompt. 

14. Click No at the Systems Settings Change prompt.

15. Select the JNI adapter and click OK at the SCSI Adapters prompt: 
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The Setup Complete screen appears: 

16. Click Finish to complete the setup. 

This completes the installation of the JNI host bus adapter driver.

You must restart your computer before the new settings will take effect. 

17. Restart your computer. 

■ Configuring LUNWorks

The configuration process includes the following steps:

1. Creating the database. 

2. Choosing administration groups. 

3. Entering installation keys. 

4. Installing operational keys. 

5. Registering the SAN. 

Tip: To streamline the configuration process, StorageTek recommends 
installing the software on all nodes before configuring LUNWorks.
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Creating the Database

■ Creating the Database

The database stores important information such as administration groups, 
device assignments, and customized device information. 

To ensure reliability, the database design takes advantage of disk mirroring. By 
using a mirrored database, it writes database information to multiple devices 
simultaneously, but reads from just one. If the active database device goes 
offline, another device from the mirror set takes over. With a three-device 
mirror set, you can experience two disk failures and the SAN will continue to 
run uninterrupted.

The database must be created on a mirror set composed of up to three SAN-
disk devices that are partitioned with the Universal Partition Map (UPM) format. 
Devices with any other type of partition map cannot be used for the database.

Note: Refer to the following for more information about creating the database: 

• For more information about the UPM partitioning format, see 
“Partitioning Disks” on page 5-2.

• Before you can create a database and begin using the SAN, you must 
prepare up to three database devices by partitioning them and creating 
a mirror set.

• You must be a domain administrator to set up LUNWorks during the 
initial configuration procedure. If your network does not have a 
Windows NT domain, log on to the network as a member of the 
computer’s local administrators group. 

To create the database: 

1. On any node, log on to the network as a member of the domain 
administrators group.

2. From the Start menu, choose Programs > LUNWorks.

LUNWorks prompts you to create a database mirror set. 

3. Click Yes.

The New Database dialog box opens.

The Devices pane lists all network-attached devices. 
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Devices with database partitions are listed in the Database Devices pane. 

Note: The default naming convention is as follows: 

- Vendor, World Wide Name (last 6 digits, unique to each device) 

- LUN number 

For example: 

- DGC FE-08-B9 000 is manufactured by Data General Clariion 

- Last six digits of its World Wide Name are FE-08-B9 

- Device is logical unit number 0 
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Creating the Database

Partitioning a Database Device 

There are two methods available for partitioning database devices. 

• Automatically with the database partitioning shortcut menu 

• Manually for greater flexibility

Automatically 

The automatic partitioning method creates one 400-megabyte database partition 
and one file system partition composed of the remaining disk space.

Note: This shortcut is not available when there is an existing SAN database. 

To automatically create a database: 

1. Right-click a device in the New Database or Database Mirror Set dialog box. 

2. Choose Partition for Database. 

3. Click Yes when warned that partitioning will destroy data on the device. 
The device appears in the Database Devices pane with a database icon.
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Manually 

For greater flexibility, you can partition database devices manually. 

To manually create a database: 

1. Double-click a device in the New Database dialog box.

The Device Information dialog box appears. 

:

2. Click the Edit Partitions button.

The Device Partitions dialog box appears. 

3. Type 400 in the Partition Size text box. 

Note: The recommended database partition size is 400 megabytes.
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Creating the Database

4. Click the Add Partition button. 

5. Do one of the following to change the partition’s type to database:

• Select the partition created earlier and choose Database Partition in the 
Partition Type drop-down menu. 

• Right-click the partition and choose Database Partition in the shortcut 
menu: 

The partition’s icon changes into a database icon. 

6. Create file system partitions to use the remaining disk space: 

a. Select the Free Space icon.

b. Type the size for the new partition in the Partition Size text box. 

c. Click Add Partition.

The new partition appears in the Partitions pane with a file system icon.

d. Do one of the following to resize and select a partition: 

• To decrease a partition’s size, type the new partition size into the 
Partition Size text box, and click Resize Partition.
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• To increase a partition’s size, ensure that there is free space listed 
immediately after the selected partition in the Partitions list. If there 
is free space available, type the new partition size in the Partition 
Size text box, and click Resize Partition.

e. Repeat the above steps until the desired partitions are created. 

Note: The partitioning utility supports up to 256 partitions per device. 
However, because Windows NT only has 26 available drive letters, 
LUNWorks Windows NT nodes can only access the same number of 
partitions as their number of available drive letters.

7. Click OK.

A warning appears stating this will destroy any data on new or deleted 
partitions. 

8. Click Yes.

When partitioning is done, the Device Partitions dialog box closes, and the 
created partitions are listed in the Device Information dialog box.

9. Click OK to return to the New Database dialog box.

10. Repeat these steps to create additional database partitions.

Note: The maximum number of partitions in a LUNWorks mirror set is three. 
Each database partition must be created on a separate storage device.
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Creating the Database

Creating a Database Mirror Set 

StorageTek recommends a three-device mirror set for the LUNWorks database, 
but if you do not have three database devices available, you can create a mirror 
set of just one or two devices, and add additional devices later. 

The Database Devices pane lists the database partitions. 

To create a database mirror set:

1. Confirm that the correct devices are listed in the Database Devices pane.

• To add a device, create a database partition as described on page 2-11.

• To remove a device, select it and click on Remove Database Partition.

Tip: Ideally, devices chosen for the mirrored set should reside on different 
physical storage arrays to provide redundancy and to prevent a 
single point of failure. 
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2. Click the Create Database Mirror Set button.

Note: If you only partitioned one device for database use, you still need to 
create a database mirror set. Although disk mirroring does not take place 
when only one disk is available, this allows you to create a functioning 
mirror later by simply adding devices. 

See “Adding a Partition to the Mirror Set” on page 4-12 for instructions 
on adding devices to an existing mirror set.

When you create a database mirror set, the icons in the Database Devices pane 
change into mirror set icons. 

Creating the Database 

To create the data base:

1. Confirm that the desired mirror set has been created. 

If not, reconfigure the mirror set as described in “Reconfiguring the Existing 
Mirror Set” on page 4-11.

2. Click the Create Database button.

LUNWorks asks if you want to load a saved database.

3. Do one of the following:

• Click No for a new installation. 

• Click Yes if you want to reinstall or restore a saved database file. When 
prompted, locate the database backup file and click Open. 

Note: If you created a new database, continue with the Choosing 
Administration Groups procedure below. If you loaded a saved 
database, the SAN configuration procedure is complete.
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Choosing Administration Groups

■ Choosing Administration Groups 

After a new database is created, LUNWorks prompts you to choose the network 
administration groups. Only members of these groups can run the application 
and perform administrative procedures. If your Windows NT network has a 
domain, the Administration Groups dialog box lists global Windows NT groups. 
If the network does not have a domain, groups from the local computer are 
listed. 

1. To add a SAN administration group, double-click the group to move it into 
the SAN Administration Groups pane.

2. To remove a SAN administration group, double-click the group to move it 
into the Windows NT Groups pane.

3. Click OK to close the Administration Groups dialog box. 

Tip: You can also move groups between the SAN Administration Groups 
and Windows NT Groups panes by selecting them and clicking the 
right and left arrow buttons.
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■ Licensing

After defining administration groups, LUNWorks prompts you to install license 
keys and register your SAN.

About License Keys

There are two types of license keys, Installation and Operational. 

If you received your license keys (installation and operational) in electronic 
format, you can enter them into the New License Key text box by using 
Windows NTs copy and paste command

The application ships with a set of installation keys that expire after a 
predefined interval. When you register your SAN, you will receive permanent 
license keys, which are called operational keys. 

Note: You must register your SAN to obtain the operational keys. 

License keys enable designated amounts of SAN storage, and control the 
number of licensed nodes and the operating system types that can use the 
network. In the future, when you add new operating systems, nodes, or storage 
to your SAN, you may need to purchase additional license keys.

LUNWorks prompts you to enter your installation keys by opening the Licenses 
dialog box. 
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Licensing

Installation Keys 

To install the installation keys: 

1. Enter an installation key in the New License Key text box. 

2. Click the Enter License button.

3. Repeat these steps for additional installation keys. 

4. Click OK. 

Note: Until you register your SAN, the License Expiration Warning dialog 
box will appear each time you run the application.

5. Do one of the following:

• To register now, click the Registration…button and follow the 
registration procedure, below.

• If you do not want to register now, click OK. 

If you do not have enough licenses for all of the attached nodes, the 
License Nodes dialog box opens and allows you to license specific 
nodes (see “Licensing a Node” on page 4-10 for instructions). 

To register later, follow the registration procedure in “Registration” on 
page 2-23

Operational Keys 

Important: 
You must register your SAN to obtain your permanent operational keys 
for LUNWorks.

See “Registration” on page 2-23 for information about registering your storage 
area network. 

To install the operational keys: 

1. Click the Show Licenses button, or choose View > Licenses….

The installed license keys are listed in the Licenses dialog box. 

2. Enter an operational key in the New License Key text box. 
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3. Click the Enter License button.

The expiration date of the corresponding installation key changes to Never 
and the lock symbol is removed from the license key icon.

4. Repeat these steps for additional operational keys, then click OK. 

Note: The SAN is now licensed with permanent operational keys.
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■ Registration 

When you enter registration information into LUNWorks, the application 
generates a unique SAN ID number. To obtain permanent operational keys, you 
must register your SAN ID number and installation keys. 

Note: StorageTek recommends registering your SAN during the initial 
configuration procedure. However, you may register the SAN at any time 
before your installation keys expire. 

If you do not register your SAN, your installation keys will expire, 
leaving the SAN non-operational. 

Registering 

Tip: Save the Registration.txt file, and your installation and 
operational keys. These items can be used to set up a new database 
in case of a database failure. 
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To register your SAN: 

1. Start the application if the Registration dialog box is not open. 

2. Choose View > Registration… 

3. Enter your registration information.

Note: Make sure you fill out the Registration dialog box completely and 
accurately. This information is needed to generate operational keys for 
your SAN ID.

Submitting Your Registration Now 

To submit your registration now: 

1. Do one of the following: 

• Click the Fax/E-mail Registration button to submit your registration 
information via fax or e-mail. Follow the on-screen instructions. 

• Click the Web Registration button to submit your registration 
information via the Internet. Follow the on-screen instructions. 

2. Click OK to save your registration information. 

3. Close the Registration dialog box. 

Note: When you click OK in the Registration dialog box, it saves a copy of 
your registration information into a file called Registration.txt. 
This file is stored in the program directory.

Submitting Your Registration Later 

To submit your registration later: 

1. Click OK to save your registration information. 

2. Start the application when you are ready to submit your registration 
information. 

3. Choose View > Registration.

4. Click the Fax/E-mail Registration or Web Registration button in the 
Registration dialog box and follow the on-screen instructions. 

5. Click OK to close the Registration dialog box.

Once your registration information is processed, you will receive operational 
license keys for your SAN ID. If you register using e-mail or the Internet, your 
operational keys will be sent to the e-mail address included in your registration 
information. If you fax your registration information, be sure to provide a return 
fax number. 
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Non-LUNWorks Servers

■ Non-LUNWorks Servers 

Caution: 
Servers that are connected to the SAN that do not have LUNWorks installed 
(also known as rogue servers) will be able to access all disk storage. For this 
reason systems administrators are urged to take steps to ensure that all servers 
have LUNWorks and  the associated HBA and driver installed before attaching 
them to the SAN. 

If you are running your LUNWorks SAN through a switch, StorageTek 
recommends disabling the ports that are not in use by the SAN to prevent the 
inadvertent introduction of a non LUNWorks server to the SAN. As part of the 
installation of an additional server the port can be re-enabled. 

■ Un-installing LUNWorks 

If you ever need to un-install LUNWorks: 

1. Log on to the computer. 

2. Choose Start > Settings > Control Panel. 

3. Double-click on the Add/Remove Programs item. 

4. Select the Install/Uninstall tab, scroll to and select LUNWorks, then click the 
Add/Remove button.

Windows NT prompts you to confirm the file deletion.

5. Click Yes to continue the uninstall procedure.

LUNWorks notifies you it is stopping services.
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6. Click OK. 

The following dialog box notifies you that LUNWorks has been removed.

When the un-installer is finished removing the LUNWorks files, the 
following message appears:

7. Restart the computer. 
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3LUNWorks Basics 

This chapter explains the basic operation and screens for LUNWorks. 

CAUTION:
Do not attempt to run LUNWorks on more than one node at a time.

The screens in this chapter include: 

• Help screen 

• Main Window 

- Main window icons 
- Drag and drop icons 

• Nodes Pane 

• Storage Pane 

• Share Groups Pane 

• Toolbar 

• Database drop-down menu 

• View drop-down menu 

• Shortcut menus 

■ Accessing LUNWorks 

To access LUNWorks: 

1. Log on to the network as a member of a designated storage area network 
(SAN) administration group.

2. Choose Programs > LUNWorks from the Start menu. 
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■ Getting Help 

LUNWorks online help system contains information from this Installation and 
User’s Manual, plus context-sensitive What’s This? help topics. These topics 
provide details about the dialog boxes. 

To view the online help: 

1. Press F1.

2. Click the Help button in the Toolbar.

3. Choose Help > Contents and Index.

To use What’s This? help: 

Note: Dialog boxes that contain What’s This? help have a What’s This? button 
in the title bar of the dialog box:. 

1. Click the What’s This? button.

The pointer displays a question mark. 

2. Click the dialog box item that you want information about. 

The help topic displays in a pop-up window. 

3. Click anywhere on the screen to close the pop-up window. 

Figure 3-1. Help Screen 
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Main Window

■ Main Window

When you start LUNWorks, the main window appears and displays the 
following panes: 

• Nodes 

• Storage 

• Share groups (an optional display) 

Most SAN Administration tasks are performed in the main window. 
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Main Window Preferences 

LUNWorks allows you to customize the way information is displayed in the 
main window.

Main Window Icons 

LUNWorks uses icons to indicate the status of nodes and devices. Icons are 
dynamically added to node and device icons when their status changes.

Missing Node and Device Icons 

When nodes or devices are missing or offline, their icons are displayed in gray. 
For instructions on removing missing nodes and devices, see Chapter 4.

Note: LUNWorks detects nodes that are powered-on and connected to the 
network whether or not a user is logged on. Nodes that are powered-off 
or disconnected from the network are classified as missing. 

To show/hide the toolbar: Choose View > Toolbar.

To show/hide share groups: Click the Show/Hide Share Groups button, 
or choose View > Share Groups.

To show/hide device groups: Device groups can be used to organize devices in the Storage 
pane.To show/hide device groups, click the Show/Hide 
Device Groups button, 
or choose View > Device Groups.

To show/hide the status bar: Choose View > Status Bar.

Icon Displayed on… Meaning

Devices and nodes This item is assigned to a share group.

Devices This device is partitioned.

Devices This device is assigned to a node.

Icons Click the toggle large/small icon button.

Devices This device is unlicensed. On unlicensed devices, only the 
lock icon badge is shown. All other icon badges are hidden 
until the device is licensed.
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Drag-and-Drop Icons 

When performing drag-and-drop operations, the following icons may appear: 

Nodes Pane 

The Nodes Pane displays nodes and their device assignments. Node names are 
obtained from the NetBIOS settings on each computer, and cannot be changed.

A typical Nodes pane includes the following elements: 

• Nodes pane view menu 
• Node with assigned devices
• Share group node with assigned non-share group devices 
• Share group node
• Missing node
• Active node 
• Unlicensed node 

Nodes Pane View Menu allows you to choose the type of nodes displayed in 
the Nodes pane: 

• Show All: Displays all nodes.
• Missing: Displays missing nodes.
• Grouped: Displays nodes that are in one or more share groups.
• w/o Storage: Displays nodes that do not have assigned storage.

Icon Meaning

When the pointer shows a plus sign, a valid drag-and-drop operation is possible at the 
current pointer location.

When the pointer changes into this symbol, a valid drag-and-drop operation is not 
possible at the current pointer location.



Main Window

3-6 Third Edition 313410503
  

Storage Pane

The Storage Pane lists all of the devices that are accessible. To organize devices 
within this pane, use the device groups feature. 

A device group is a set of physical disks that are grouped together as a logical 
set, for example, a just a bunch of disk (JBOD), a department, or a computer 
room. See “Using Device Groups” on page 4-1 for more information. 

A typical Storage pane includes the following elements: 

• Storage pane pull down menu
• Default device group
• Assigned, unpartitioned device
• Unlicensed device
• Device with a database partition

The storage pane drop down menu allows you to choose the type of devices 
displayed in the Storage pane: 

• Show All: Displays all devices.
• Missing: Shows missing devices
• Raw: Displays unpartitioned devices.
• Unassigned: Displays unassigned devices.
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Renaming Items

Share Groups Pane

The Share Groups pane is hidden by default. 

To view the Share Groups pane: 

• Click the Show/Hide Share Groups button  

• Choose View > Share Groups 

The share groups feature allows multiple nodes within a share group to access 
the same devices. Nodes outside the share group cannot “see” share group 
devices. 

A Share Groups pane includes members of a share group. 

■ Renaming Items 

Devices, device groups, and share groups can be renamed at any time. When 
renaming items, consider the following:

• Device group, device, and share group names can be up to 32 
alphanumeric characters. 

• If you rename the default device group, the word [Default] is 
automatically added to the name. When device groups are deleted, their 
devices are returned to the default device group.

• The default naming convention for devices is as follows:

- Vendor, World Wide Name (last 6 digits, unique to each device) 
- Logical unit number (LUN) 

For example, the disk DGC FE-08-B9 000 is manufactured by Data General 
Clariion, the last six digits of its World Wide Name are FE-08-B9, and the 
device is logical unit number 0. 
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Renaming Devices, Groups, and Share Groups 

To rename devices, groups, and share groups: 

1. Select the item to be renamed and press F2, or right-click the item and 
choose the Rename option in the shortcut menu.

2. Type the new name when the item name is selected and press Enter.

Renaming Devices 

To rename devices only: 

The following is an alternate way to rename devices: 

1. Double-click a device, or right-click a device icon and choose Device Info 
in the shortcut menu.

The Device Information window appears (see page 5-8 for more 
information).

2. Type the new device name in the Device Name text box.

3. Click OK or press Enter to apply the name change and close the Device 
Information window.

Using the Name Devices As Command 

The Name Devices As command allows you to assign sequential device names 
that correspond to a device group or share group name. 

To use this command: 

1. Right-click a device group or share group. 

2. Choose Name Devices As in the shortcut menu.

Resetting Device Names 

To set the names of all members of a device group to their default names: 

1. Hold down the Shift key, right-click the device group. 

2. Choose Name Devices As in the shortcut menu.
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Toolbar

■ Toolbar 

The following toolbar buttons are available:

Database buttons: 

1. Restore database from file

2. Backup database to file 

3. Scan for nodes 

4. Scan for devices 

5. Remove all missing nodes

6. Remove all missing devices

View buttons: 

7. Toggle icon size 

8. Show/hide share groups

9. Show/hide device groups

10. Show licensing information

11. Show SAN Administration groups

12. View the online help system.

1 2 3 4 5 6 7 8 9 10 11 12
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Toolbar Positions 

By default, the toolbar is attached or “docked” in the toolbar area of the main 
window. You can also dock the toolbar along any main window edge, or drag it out 
of the main window as a floating toolbar. 

To change a docked toolbar into a floating toolbar: 

1. Click in the toolbar’s margin and hold down the mouse button.

2. Drag the toolbar out of the main window.

When the toolbar is dragged out of the main window, a floating toolbar 
outline appears: 

3. Release the mouse button when the toolbar outline appears in the desired 
location. 

To change the layout of a floating toolbar: 

1. Position the pointer on the edge of the toolbar. 

2. Click and drag to rearrange the toolbar when the cursor changes into an 
arrow. 

To dock a floating toolbar: 

1. Click in the floating toolbar’s margin, and hold down the mouse button.

2. Drag the toolbar into the main window.

When the toolbar is dragged onto a docking area of the main window, a 
toolbar outline appears:

3. Release the mouse button when the toolbar outline appears over the 
desired location. 

Tip: If you want to position the floating toolbar on top of the main window, 
press the Control key to prevent the toolbar from docking when you 
release the mouse button. 
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■ Menus

This is a reference to the menus. See Chapters 2, 4, and 5 for more information. 

File 

The file menu allows you to exit the application:

Database 

The database menu contains commands for backing up, restoring, verifying, 
and modifying the database:

Item Function

Backup Database to File Creates a backup of the current database. 

Restore Database from File Restores the database from a backup copy. 

Create New Database Deletes the existing database and prompts you to create a new 
one. During this procedure, you can either create a new database, 
or restore a saved database file.

Database Mirror Set Allows you to view and/or edit the database mirror set.

Scan for Nodes Scans the SAN for new nodes and nodes with status changes.

Scan for Devices Scans the SAN for new devices and devices with status changes.

Add Node Use the Add Node command to add a node when there is a networking 
problem that prevents the node from being auto detected. 

Remove missing nodes Removes all missing nodes from the database.

Remove missing devices Removes all missing devices from the database.
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View

The View menu contains commands for opening the dialog boxes and 
changing the r main window view preferences: 

 

Help

The Help menu allows you to run the Online Help file or view information about 
this version of the software. 

See “Getting Help” on page 3-2 for more information. 

Item Function

Licenses… Opens the Licenses dialog box, which shows all installed license 
keys. From this dialog box, you can install license keys, or open the 
License Nodes and Registration dialog boxes.

Registration… Choose this option to register the SAN or to view the current 
registration information.

Administration Groups… Opens the Administration Groups dialog box where you can add 
and remove SAN administration groups.

Toolbar Shows or hides the toolbar.

Share Groups Shows or hides the Share Groups pane.

Device Groups Shows or hides device groups. When device groups are hidden, their 
storage devices are still visible in the Storage pane.

Status Bar Shows or hides the status bar.
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■ Shortcut Menus 

The application includes shortcut menus for ease-of-use. 

Shortcut menus are displayed by right-clicking when pointing to an object in 
main window. Some typical shortcut menus are described below:

Device Groups

When you right-click a device group, the following menu appears:

Use this menu to:

• Create a new device group.

• Assign sequential device names that correspond to the device group name. 
For more information, see page 3-8.

• Identify all of the devices in the group by blinking their disk lights.

• Remove the selected device group. 

When you use this command, all of the devices assigned to this device 
group are returned to the Default Device Group.

• Rename the device group.
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Devices 

Right-clicking a device in any of the three panes produces the following 
shortcut menu: 

This menu allows you to choose from the following options:

• Identify one or more devices by blinking their disk lights.
• Unassign one or more devices from a node or share group.
• View and/or edit the device information for the selected device.
• Rename the device.

Note: When right-clicking a missing device, choose from the following 
options:

• Unassign the missing device.
• Remove the missing device from the SAN database.
• View and/or edit the device information for the selected device.

Nodes

Right-clicking a node in the Nodes pane displays the following options: 



313410503 Third Edition 3-15

  

Shortcut Menus

• Ping the node. If a node’s status is unclear, choose this command to check the 
status. If the status is different from the displayed status in the main window, it 
refreshes and displays the correct status.

• Identify all devices assigned to the node by blinking their disk lights.

• Unassign all devices that are assigned to this node.

Notes: 

- Right-click a node in the Share Groups pane to remove the node from 
the share group.

- Right-click on a missing node to remove the node from the SAN 
database or to Ping the node.

Share Groups

The share groups shortcut menu includes the following choices: 

• Create a new share group.

• Assign sequential device names that correspond to the share group name 
see page 3-8.

• Identify all of the devices in the share group by blinking their disk lights.

• Remove the share group from the SAN database.

• Rename the share group.

Note: You must remove all nodes and devices from a share group before you can 
remove it from the SAN database.
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4Administration 

The LUNWorks application provides a single system image of the storage area 
network (SAN) from any node on the network. This image allows members of 
administration groups to manage all nodes and storage from a single computer. 

■ Administration Groups 

Administration groups for the network are assigned during the initial install and 
configuration procedure. 

To modify administration group settings:

1. Click the Administration Groups button, or choose 
View > Administration Groups. 

2. To add and remove administration groups, do one of the following:

• To add an administration group, double-click the group to move it into 
the SAN Administration Groups pane.

• To remove an administration group, double-click the group to move it 
into the Windows NT Groups pane.

• To move selected groups, click the left and right arrows between the 
network administration groups and Windows NT Groups panes.

3. Click OK to close the Administration Groups dialog box. 

■ Using Device Groups

Device groups are a set of devices that are grouped into a logical set, for 
example, just a bunch of disk (JBOD), a department, or a computer room. With 
device groups, you can assign a set of devices to a node or share group, or 
identify all devices in the group. 

Note: Devices are stored in the default device group until you move them into 
a custom device group. 
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Show/Hide Device Groups 

Click the Show/Hide Device Groups button in the toolbar, or choose 
View > Device Groups. 

When device groups are hidden, their devices are still listed in the Storage 
pane.

Creating a Device Group 

To create a device group:

1. Right-click in the Storage pane 

2. Choose New Device Group in the shortcut menu.

The new device group appears in the Storage pane with its name selected.

3. Type a device group name, and press Enter. 

Device group names can be up to 32 alphanumeric characters.

4. Add devices to the group by selecting them and dragging them onto the 
device group’s icon.

5. Right-click the new device group if desired.

6. Choose Name Devices As (see “Using the Name Devices As Command” on 
page 3-8).

Note: For recommendations on device group, device, and partition naming, 
see “Naming Conventions” on page 5-7.

Adding Devices to a Group 

To add devices to a group:

1. Select one or more devices. 

2. Drag them onto the destination device group’s icon.

Removing a Device From a Group 

To remove a device from a group, do one of the following: 

• Drag the device into another group.

• Remove the device group from the network database.
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Removing a Device Group

To remove a device group, do one of the following: 

1. Right-click the device group icon and choose Remove Device Group in the 
shortcut menu.

2. Select the device group and press the Delete key.

LUNWorks removes the device group and moves all of its devices into the 
Default Device Group. When you remove a device group, current storage 
assignments are preserved.

■ Assigning Devices 

LUNWorks lets you assign devices to nodes or share groups without rebooting 
the network nodes or storage systems. 

To assign devices, do one of the following:

1. For nodes and share groups:

• Drag a device or device group onto the destination node or share group 
icon.

• Drag multiple selected devices and/or device groups onto the 
destination node or share group icon.

2. For nodes only: 

• Drag a device from the current node onto the destination node’s icon. 

Note: You cannot reassign devices that are in use. If a device reassignment fails, 
close all files and applications on the current node, then try again.

Tip: Storage assignments are effective immediately, but some 
applications such as Windows Explorer may need to be refreshed 
before the new storage is available. If assigned storage is not visible 
to an open application, tell the user to press F5 to refresh the display. 
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■ Unassigning Devices 

You cannot unassign devices that are in use. Some examples include devices 
that contain open files or folders, or filter drivers. For more information about 
filter drivers, see Chapter 6, “Advanced Administration”.

To unassign devices, use one of the following methods:

1. For nodes and share groups:

• Right-click a device, and choose Unassign Device.

• With multiple devices selected, right-click a selected device and choose 
Unassign Device.

2. For nodes only:

• Right-click a node and choose Unassign Devices.

• Drag one or more devices from the current node onto the another 
node’s icon.

■ Using Share Groups 

Share groups allow multiple nodes to access the same devices. Nodes outside a 
share group cannot access share group devices. For general information on 
using share groups, follow the instructions below. 

See Chapter 6, “Advanced Administration” for directions on using share groups 
with Microsoft Cluster Servers. 

The following restrictions apply to share groups:

• Nodes can be in one or more share groups.
• Devices can be in only one share group at a time.
• Share group nodes can have non-share group storage assigned for exclusive 

access.

Note: When using share groups, you must use an application that preserves data 
integrity on shared storage (such as Microsoft Cluster Server). Without 
this type of application, data corruption may occur. 

Show/Hide Share Groups 

The Share Groups pane is hidden by default. 

To toggle between showing/hiding the Share Groups pane, click the 
Show/Hide Share Groups button, or choose View > Share Groups.
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Using Share Groups

Creating a Share Group 

To create a share group:

1. Right-click in the Share Groups pane. 

2. Choose New Share Group.

The new share group appears in the Share Groups pane with its name 
selected.

3. Type a name for the share group, and press Enter. 

Share group names can be up to 32 alphanumeric characters.

4. Assign share group devices, see page 4-3. 

5. Right-click the share group icon and choose Name Devices As if desired 
(see “Using the Name Devices As Command” on page 3-8).

Note: For tips on device group, device, and partition naming, see “Naming 
Conventions” on page 5-7.

6. Add nodes to the share group by dragging a single node or multiple 
selected nodes onto the icon of the destination share group. 

Assigning and Unassigning Share Groups 

See page 4-3 for instructions on assigning and unassigning share group devices.

Adding Nodes to Share Groups 

Drag a single node or multiple selected nodes onto the destination share 
group’s icon. 

Removing Nodes From Share Groups 

To remove nodes from a share group, do one of the following:

• Right-click a single node and choose Remove Node from Share Group in 
the shortcut menu.

• Right-click a selected node with multiple nodes selected and choose 
Remove Node from Share Group in the shortcut menu.

Tip: Because nodes can be in multiple share groups, you can add nodes 
to a share group by dragging them from the Nodes or Share Groups 
panes onto the icon of the destination share group. 
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Deleting a Share Group 

1. Unassign all share group devices. For instructions, see page 4-4.

2. Remove all nodes from the share group. For instructions, see To remove 
nodes from a share group, above.

3. Do one of the following:

• Select the share group and press the Delete key.
• Right-click the share group and choose Remove Share Group in the 

shortcut menu.

■ Adding and Removing Nodes

Nodes can be added to or removed from the network database without 
rebooting other network nodes or storage.

Adding a Node 

1. Follow the instructions in Chapter 2, “Installation and Configuration” to add 
a node. 

2. Start LUNWorks to scan the network and add the new node to the database 
on any node. 

3. Do one of the following: 

• Click the Scan for Nodes button.
• Choose Database > Scan for Nodes.

Manually Adding a Node 

To manually add a node:

1. Choose Database > Add Node…. The Add Node dialog box appears:

2. Select either Node Name or IP Address.

3. Enter the hostname or IP Address, and click the Add Node button.
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Adding and Removing Devices

Removing a Node 

To remove a node from the database:

1. Unassign all storage from the node.

2. If the node is assigned to one or more share groups, remove it by right-
clicking the node icon in the Share Groups pane, and choosing Remove 
Node from Share Group.

3. Physically detach the node from the SAN.

4. Un-install LUNWorks from the node that you detached in the above step.

Note: Do not un-install LUNWorks from a node that will remain attached to 
the network. If LUNWorks and its drivers are not installed on all 
attached nodes, the exclusive storage assignments could be 
compromised.

5. In the main window, right-click the icon of the node to be removed, and 
choose Ping Node.

Because the node is no longer attached to the network, the node icon changes 
into a missing node icon. 

6. Do one of the following to remove the node from the database: 

• Right-click the missing node icon, and choose Remove Node. 

• To remove all missing nodes, click the Remove Missing Nodes button, 
or choose Database > Remove Missing Nodes.

Note: Be careful when removing all missing nodes from the database, because 
you may inadvertently remove nodes that are missing or offline 
temporarily.

■ Adding and Removing Devices 

Devices can be added to and removed from the database without rebooting 
network nodes or devices.

Adding Storage to the Network 

To add storage to the network: 

1. Connect the storage to the network.

2. Install and register a new license key to enable the added storage if 
necessary. See page 4-8 for instructions. 

3. Click the Scan for Devices button, or choose Database > Scan for Devices 
to add the new devices to the database.

4. Partition and format the new devices if desired. 
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Note: To set up devices with standard partitioning/formatting utilities, they 
must be assigned to the node performing the partitioning/formatting. 
To set up devices they must be unassigned. See “Partitioning Disks” 
on page 5-2 for more information.

The new devices are ready to be assigned to nodes or share groups.

Remove a Device from the Network 

To remove a device from the network: 

1. Unassign the device if it is assigned to a node or share group.

2. Physically detach the device from the SAN.

3. Click the Scan for Devices button, or choose Database > Scan for Devices.

4. Do one of the following to remove a device: 

• Right-click the missing device icon, and choose Remove Device.
• Click the Remove Missing Devices button, or choose 

Database > Remove Missing Devices to remove all missing devices 
from the database.

Note: Be careful when removing all missing devices from the database, 
because you may inadvertently remove devices that are missing or 
offline temporarily.

■ Licensing

For details about licensing and registration during the initial configuration, see 
“Licensing” on page 2-20. When you add new operating systems, nodes, or 
storage to your network, you may need to install and register additional license 
keys.

Entering an Installation Key 

To enter and installation key:

1. Click the Show Licenses button, or choose View > Licenses. 

2. Enter an installation key in the New License Key text box. 

3. Click the Enter License button.



313410503 Third Edition 4-9

  

Licensing

Registering an Installation Key 

We recommend that you register the new installation key immediately, but if 
desired, you can register later.

To register now: 

1. Click the Registration… button.

2. Do one of the following:

• Click the Fax/E-mail Registration button to submit your registration 
information via fax or e-mail. Follow the on-screen instructions.

• Click the Web Registration button to submit your registration 
information via the Internet. Follow the on-screen instructions.

3. Click OK to save your registration information and close the Registration 
dialog box. 

4. Click OK to close the Licenses dialog box.

5. Click OK to continue when the License Expiration Warning dialog box 
appears.

Once your registration request is processed, you will receive an operational key for 
each registered installation key. 

To register later: 

If you do not want to register at this time, click OK. When you are ready to 
register, choose View > Registration and follow the steps above.

Installing an Operational Key 

To install an operational key:

1. Click the Show Licenses button, or choose View > Licenses….

All of your installed license keys are listed in the Licenses dialog box.

2. Enter an operational key in the New License Key text box. 

3. Click the Enter License button.

The expiration date of the corresponding installation key changes to Never and the 
clock symbol is removed from the license key icon.
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Licensing a Node 

If you do not have enough licenses for all of the SAN-attached nodes, you can 
choose the nodes to license. 

1. Click the Show Licenses button, or choose View > Licenses….

2. Click the License Nodes… button in the Licenses dialog box.

The License Nodes dialog box appears. 

3. Do one of the following:

• To un-license a node, double-click it in the Licensed Nodes pane. 

• To license a node, double-click it in the Unlicensed Nodes pane.

• Use the arrow buttons to license and un-license selected nodes.

4. Click OK.

■ Managing the Database 

Backing Up the Database to a File 

To back-up the database to a file:

1. Click the Backup Database button, or choose 
Database > Backup Database to File.

2. Enter a file name in the Save As dialog box. 

3. Choose a destination for the file. 

If you do not customize the file name and destination, the file will be saved 
to the program directory with the file name DatabaseBackup.san.

4. Click Save. 

Restoring the Database from a File 

1. Click the Restore Database button, or choose 
Database > Restore Database from File.

2. Navigate to the saved database file. 

Tip: The database stores important information such as administration 
groups, device assignments, and customized device information. To 
preserve this data, StorageTek recommends backing up the 
database regularly, and backing up the saved database file with a 
standard backup utility. 
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3. Click Open.

Note: You can also load a saved database file during the Create New Database 
procedure. For instructions, see page 4-12.

Reconfiguring the Existing Mirror Set 

You can add or delete devices from the database mirror set at any time.

To view or edit the database mirror, choose 
Database > Database Mirror Set….

The Database Mirror Set dialog box appears: 
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Removing a Partition from the Mirror Set 

To remove a partition from the mirror set:

1. In the Database Devices pane, select the partition.

2. Click the Remove Partition from Set button.

Note: When you remove a partition from the database mirror set, the partition 
type changes from Database to Free Space. If you have a single-partition 
mirror set, you cannot remove the database partition.

Adding a Partition to the Mirror Set 

To add a partition to the mirror set:

1. Create a database partition. For instructions, see “Partitioning a Database 
Device” on page 2-13.

Note: If you already have an existing mirror set of three devices, you must 
remove a device before you can add one to the mirror set.

2. Select the new partition in the Database Devices pane. 

3. Click the Add Partition to Mirror Set button.

Creating a New Database 

During the Create New Database procedure, you can create a new database, or 
restore the database from a saved file. 

Creating a new database deletes the existing database which contains storage 
assignments, administration groups, and other important information. 

If you create a new database, be prepared to re-enter this information. 

1. Choose Database > Create New Database….

LUNWorks prompts you to confirm that you want to delete the existing 
database. 

2. Click Yes.

The New Database dialog box appears with the existing mirror set. 
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3. Do one of the following if you do not want to use the existing mirror set:

• Reconfigure the mirror set as described in the section “Reconfiguring the 
Existing Mirror Set” on page 4-11. 

• Create a new mirror set by clicking the Dissolve Database Mirror Set 
button, and create a new mirror set according to the instructions on 
“Creating a Database Mirror Set” on page 2-17.

4. Click the Create Database button.

LUNWorks asks if you want to restore the database from a saved file. 

5. Click Yes to restore the database, or No to create a new database.

• If you clicked Yes, locate the saved database file when prompted, then 
click Open.

• If you clicked No, continue.

6. LUNWorks prompts you to specify administration groups. For instructions, 
see page 4-1.
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Checking the Database Mirror 

Choose Database > Database Mirror Set to check the database mirror.

The Database Mirror Set dialog box, database partitions use these icons:

Check the following:

• If a database partition is not working properly, it is labeled with either a 
problem database icon or a missing database icon.

• If a problem is reported with a database device, select it and click the 
Remove Partition from Set button. 

• If a database device is missing, click the Remove Missing Mirrors button.

• If desired, add the damaged/missing device back into the mirror set, or 
replace it with a new device.

Tip: To check for mirror set problems when the Database Mirror Set 
dialog box is already open, click the Verify Mirror Set button. 

Icon Meaning

Default database icon: This database partition is working correctly.

Problem database icon: Errors were encountered when writing to this partition.

Missing database icon: This database partition is missing.
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Adding Damaged or Missing Device Back 

Note: When you remove a damaged device from the mirror set, the database 
partition’s type is reset to Free Space. If you remove a missing database 
device and it comes back online, when you choose Database > 
Database Mirror Set…, the database partition changes to Free Space. 

To add damaged or missing devices back to the mirror set: 

1. Verify that the device is operating properly.

2. Change the database partition’s type to database if the damaged or missing 
device’s partitions are intact. See “Changing a Partition Type” on page 5-5 
for more information.

3. Add the device to the mirror set as described on page 4-12.

Adding a Replacement Device 

To add a replacement device: 

1. Prepare the device for database use as described on “Partitioning a 
Database Device” on page 2-13.

2. Add the device to the mirror set as described on page 4-12.
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5Storage Management

Because LUNWorks manages storage at the device or logical unit number (LUN) 
level, the application supports any partitioning format. You can partition and 
format devices before or after adding them to the storage area network (SAN).

When partitioning devices for use, consider the following:

• To partition and format devices with standard partitioning utilities, first 
assign them to the node you will use for partitioning and formatting.

• To partition devices with LUNWorks partitioning utility, the devices must be 
unassigned.

• Database devices must be partitioned with LUNWorks partitioning utility.

• You cannot edit partitions on a device that has an active database mirror 
partition. To edit partitions on a database device, first remove the database 
partition from the mirror set. 

See “Removing a Partition from the Mirror Set” on page 4-12 for more 
information.

• To prevent wasted disk space on a database device, LUNWorks allows you 
to partition and use the leftover disk space. Database devices are presented 
as devices that can be assigned to nodes. When a database device is 
assigned to a node, the database partition is hidden, but all file system 
partitions are available.
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■ About the Universal Partition Map 

LUNWorks Universal Partition Map (UPM) is an Operating System-independent 
partitioning format. 

UPM Partition Types 

The partitioning utility allows you to create the following UPM partition types: 

■ Partitioning Disks 

Observe the following when partitioning disks:

• When you partition a disk, its partition map type is changed to the Universal 
Partition Map format. Changing a partition map type destroys all data on a 
disk.

• Modifying partitions destroys data only on the partitions that are being 
modified.

Partitioning a Device 

To partition a device:

1. Double-click an unassigned device in the main window. 

2. Click the Edit Partitions button in the Device Information dialog box.

The Device Partitions dialog box appears. 

Existing UPM partitions are listed in the Partitions pane. If there are no UPM 
partitions, the available disk space is listed as free space.

Icon Partition Type

Database partition: 
Used in the database mirror set. 
Note: The recommended database partition size is 400 MB.

Free space: 
If you do not want to use all of the space on a UPM disk, you can leave the 
unused space as free space, which can be partitioned later.

File system partition: 
This UPM partition is designated for use as a file system partition.
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3. Type the desired partition size in megabytes in the Partition Size text box.

4. Press Enter or click Add Partition. 

The new partition appears in the Partitions pane with a file system icon. 
Each time you create a new partition, the value in the Partition Size text box 
changes to reflect the remaining available disk space.

5. Repeat Step 3 until all of the desired partitions are created.

Note: The partitioning utility supports up to 256 partitions per device. 
However, because Windows NT only has 26 available drive letters, 
Windows NT nodes can only access the same number of partitions as 
their number of available drive letters.

6. When you create UPM partitions, they default to the file system partition 
type. To change a partition’s type, do one of the following:
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• Select the partition and choose a type in the Partition Type drop-down 
menu.

• Right-click the partition and choose a partition type in the shortcut 
menu. 

For more information about the available partition types, see page 5-2.

7. Click OK to partition the disk and close the Device Partitions dialog box.

The following warning appears:

8. Click Yes.

The Device Information dialog box appears. 

9. Enter custom device information, and click OK. 

If you do not want to customize the device information, click OK to close 
the dialog box.

■ Modifying UPM Partitions 

After partitioning a device, you may want to resize or change partition types. 

Increasing a Partition’s Size 

If there is free space listed after a partition in the Device Partitions dialog box, 
the partition size can be increased by adding some, or all of the free space to it. 

1. Double-click a UPM partitioned device in the main window.

2. Click Edit Partitions in the Device Information dialog box.

3. Select the partition to be enlarged.

4. Type the new partition size in the Partition Size text box. 

5. Click Resize Partition.

6. Click Apply or OK to commit the change. 

Note: Use the Apply button if you want to edit more partitions.

Use the OK button if you want to close the Device Partitions dialog box 
after editing this partition.

A warning appears stating this will destroy any data. 
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7. Click Yes to resize the partition.

8. Do one of the following:

• If you clicked OK, click OK again to close the Device Information 
dialog box.

• If you clicked Apply, continue editing devices, then click OK to close 
the Device Partitions dialog box. When finished, click OK to close the 
Device Information dialog box.

Decreasing a Partition’s Size 

To decrease a partitions size:

1. Double-click a UPM partitioned device in the main window.

2. Click Edit Partitions in the Device Information dialog box.

3. Select the partition to be reduced.

4. Type the new partition size in the Partition Size text box. 

5. Click Resize Partition.

6. Click Apply or OK to commit the change. 

Note: Use the Apply button if you want to edit more partitions.

Use the OK button if you want to close the Device Partitions dialog 
box after editing this partition.

A warning appears stating this will destroy any data. 

7. Click Yes to resize the partition.

8. Do one of the following:

• If you clicked OK, click OK again to close the Device Information 
dialog box.

• If you clicked Apply, continue editing devices, then click OK to close 
the Device Partitions dialog box. When finished, click OK to close the 
Device Information dialog box.

Changing a Partition Type 

Partition types can be changed during the initial disk partitioning or at any time 
afterwards. 

Note: When you change the type of a partition, all data on the partition will be 
erased.

1. Double-click a UPM partitioned device in the main window.

2. In the Device Information dialog box, click Edit Partitions.
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3. Do one of the following:

• Select the partition to be changed, and choose a partition type in the 
Partition Type drop-down menu. 

• Right-click the partition to be changed and choose a partition type in 
the shortcut menu. 

4. Click Apply or OK to commit the change.

Note: Use the Apply button if you want to edit more partitions.

Use the OK button if you want to close the Device Partitions dialog box 
after editing this partition. 

A warning appears stating this will destroy any data. 

5. Click Yes.

6. Do one of the following:

• If you clicked OK, click OK again to close the Device Information 
dialog box.

• If you clicked Apply, continue editing devices, then click OK to close 
the Device Partitions dialog box. When finished, click OK to close the 
Device Information dialog box.

■ Formatting UPM Partitions 

When you assign a UPM partitioned device to a node, all UPM file system 
partitions are listed as drive letters in Windows Explorer and My Computer. 

Note: When you assign a database device to a node, the database partition is 
hidden. 

If you double-click the drive listing of an unformatted UPM partition in 
Windows Explorer, Windows NT informs you with a warning that the disk does 
not contain a recognized file system. This warning appears because the disk has 
not been formatted, so it contains no file system.

Do one of the following to format a UPM partition: 

• Right-click the UPM partition’s drive listing in Windows Explorer or My 
Computer, and Quick Format the partition.

• Use the Command Prompt to format the partition. For more information on 
formatting disks, see your Windows NT documentation.

Note: You cannot partition or format UPM disks in Disk Administrator. UPM 
partitions are displayed in Disk Administrator as foreign (UNIX) disks.
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■ Erasing a UPM Partition Map 

To re-partition a UPM disk with a standard partitioning utility, first you need to 
erase the UPM partition map. 

To erase a partition map:

1. Double-click an unassigned device to open the Device Information dialog 
box, or right-click a device and choose Device Info in the shortcut menu.

2. Click the Edit Partitions button.

3. Click the Erase UPM Partition Map button in the Device Partitions dialog 
box. 

A warning appears informing you any data will be destroyed. 

4. Click Yes.

Note: The Device Partitions dialog box closes because there are no longer 
any partitions, and returns to the Device Information dialog box.

5. Click OK to close the Device Information dialog box.

■ Naming Conventions 

Assigned storage appears as local storage to the nodes.When you assign a 
device to a node or share group, one or more separate partitions are listed by 
drive letter and volume label (if available) in Windows Explorer/My Computer 
on the nodes that have access. 

We suggest the following naming convention for the partitions:

Device Group name_Device name_Partition name.

For example: 

Tip: Because the device group and device names do not automatically 
correspond with the drive letters and volume labels of partitions, you 
may want to use a naming convention that ties together the device 
group, device, and volume names. 
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In this example, the first partition “Group1” is a partition of the FE-04-B4 
device, located in the System_1 device group. 

This naming convention allows the administrator to quickly see the connection 
between the device groups and devices, and the drives listed in Windows 
Explorer/My Computer.

■ Device Information 

Double-clicking a device opens the Device Information dialog box. 

On the left side of the Device Information dialog box, the text boxes with white 
backgrounds are customizable. The text boxes with gray backgrounds contain 
information that is automatically entered. 

The following details are automatically entered:

• Device Name: The name of the device. 

The device name can be modified here, or in the main window.
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• Manufacturer: The device manufacturer and model number.

• Firmware Revision: The version of the installed drive firmware.

• World Wide Name: The WWN of this device.

• LUN: The logical unit number of this device.

• Size: The size of the disk in megabytes.

• Device Group: The device group that contains this device.

• Assigned to: The current device assignment.

• Partition Map: The type of partition map on the device, for example, 
Microsoft, UPM, SUN or Unknown.

Customizable device information: 

The customizable text boxes in the Device Information dialog box have the 
following character limits:

• Device Name: 32 alphanumeric characters

• Serial Number: 32 alphanumeric characters

• Features: 255 alphanumeric characters

• Location: 64 alphanumeric characters

• Price: 10 alphanumeric characters

• Description: 255 alphanumeric characters

Note: When you create a new database, the customized device information is 
deleted. 
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6Advanced Administration 

This chapter provides information about advanced administrations tasks and 
registry values for customizing the LUNWorks application. 

Note: Check the Read Me First file for availability and additional information.

■ Share Groups with Microsoft Cluster Server 

The following information may be helpful when running LUNWorks with 
Microsoft Cluster Server (MSCS): 

• If the quorum disk is not an active resource on a cluster node, Cluster Disk 
(the MSCS disk filter) prevents that node from seeing the disk in the Disk 
Administrator. 

• If one node is running and establishes a cluster, it begins reserving the 
quorum disk, which prevents the other node from mounting the disk. 

To work around this problem, stop the Cluster Server service on the active 
node before attempting to mount the disk on the other node by either 
starting up the node or adding it to the share group.

• Cluster Server may not be able to use a disk that is added dynamically to a 
running node. In some cases, the node must be rebooted for Cluster Server 
to begin using the disk. 

For example, if the quorum disk is unassigned from a node, then assigned 
to the node again, Cluster Server will not begin using it until the node has 
been rebooted.

• Do not attempt to unassign a quorum disk device from a running cluster’s 
share group. The device may be successfully unassigned from the node on 
which it is not active, but even if the device is reassigned to that node, the 
Cluster Disk driver on that node will not attach to the disk. 

This means that failover from the active node will not work. At this point, 
the cluster is degraded until the device is assigned to both nodes, and both 
nodes are rebooted.
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Setting Up a MSCS Share Group 

To setup a MSCS share group: 

1. Install Windows NT Server Enterprise Edition on two or more servers.

2. Install Microsoft Service Packs or software updates. Consult Technical 
Support for compatibility issues.

3. Install the Fibre Channel hardware (see“Setting Up the Hardware” on 
page 2-2).

4. Install the LUNWorks software (see “Before Installation” on page 2-3).

5. Create a share group (see “Creating a Share Group” on page 4-5).

6. Select the devices that will be used by the cluster, and assign them to the 
share group (see “Assigning Devices” on page 4-3).

7. Assign one of the cluster nodes to the share group (see “Assigning and 
Unassigning Share Groups” on page 4-5).

8. Partition and format the cluster storage according to Microsoft Cluster 
Server’s requirements from the cluster node in the share group. See your 
Microsoft documentation for instructions.

9. Assign the remaining cluster nodes to the share group.

10. Install Microsoft Cluster Server onto all of the share group nodes.

11. Configure MSCS according to the instructions in your documentation.

■ Navisphere Software 

Navisphere software provides a graphical user interface that lets you configure 
and manage CLARiiON disk-array storage subsystems connected on a storage 
area network (SAN). 

Discover LUNs on Both Storage Processors 

To discover logical unit numbers (LUNs) on both storage processors: 

1. Install CLARiiON’s Navisphere software on the host you will use to 
configure the disk array. 

2. Scan for devices to discover the active LUNs on the array’s SPs. 

3. Confirm that all of the LUNs on the RAID are licensed and listed in the 
LUNWorks main window. 

All of the active LUNs on both service processors should be listed. 
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Note: Each device name lists the World Wide Name (WWN) of its SP plus 
the LUN. If all LUNs were initially assigned to a single controller, a 
missing LUN 00000 that corresponds to the SP that had no assigned 
LUNs will be listed.

4. Assign all of the LUNs to a node that has Navisphere installed.

Note: You cannot run Navisphere until you assign at least one LUN from 
each SP to the node that is running Navisphere.

5. Close the LUNWorks application. 

6. Change the default SP assignment of each LUN using Navisphere. For 
example, change all LUNs on SP A to SP B, and change all LUNs on SP B to 
SP A.

7. Cycle the power on the RAID to activate the change in SPs (if necessary). 

8. Start LUNWorks and scan for devices.

The LUNWorks main window should now display the active LUNs and their 
missing peers. A LUNs peer is a logical unit on the other SP that has the 
same logical unit number. 

9. Use Navisphere to redistribute the LUNs between the two SPs for normal 
operation if desired. 

Assign Failover Pairs 

A failover pair consists of a LUN and its missing peer.

1. Assign a LUN and its missing peer to a node that will be running ATF. 

2. Make sure that the LUN and its missing peer are correctly assigned. If you 
assign the wrong missing peer LUN, ATF will not function correctly under 
LUNWorks. 

3. After the LUNs and missing peers are assigned, restart the nodes to which 
they are assigned. 

Tip: To keep your devices organized in the LUNWorks main window, 
StorageTek recommends creating a separate device group for all of 
the devices attached to each SP. 

Tip: Use the Event Viewer Log or bring up the ATF Console for any ATF 
program messages. 
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■ CLARiiON’s Application Transparent Failover 

CLARiiON’s Application Transparent Failover (ATF) is a software product that 
works with disk-array storage subsystems. This software product allows 
applications to continue running after a failure of a storage processor (SP), host 
bus adapter (HBA), or subsystem cable without human intervention. At the 
detection of a failure, ATF routes the I/O of an application through a secondary 
path to the disk arrays. 

To set up CLARiiON’s ATF: 

1. Install LUNWorks on all of the nodes requiring this application. 

2. Set up the LUNWorks database. 

3. Save the database to a file for backup purposes. 

4. Enter the registry settings from Table 6-1 on page 6-5 for each node that 
accesses the disk subsystem. 

5. Restart the node to activate the registry changes. 

6. Scan for devices the discover the LUNs on the array’s storage processors.

7. Assign failover pairs. 

Note: If you selected the Update Windows NT Registry for Optimal Support option 
when you installed LUNWorks, some of the registry keys listed below 
were installed during the installation. 

If a registry path or value does not exist, create it. See your Microsoft 
documentation for instructions about how to do this. 
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Table 6-1. ATF Registry Table 

Path:

Value Name:
Value Type:
Value for ATF: 

HKEY_LOCAL_MACHINE\SYSTEM\DISK 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk 
ScanDisconnectedDevices 
REG_DWORD 
1 
Note: You must enter this registry setting under both paths listed above. 

Path: 

Value Name:
Value Type:
Value for ATF:

HKEY_LOCAL_MACHINE\SYSTEM\DISK
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk
LunRescan
REG_STRING 
’’ ’’ (empty string) 
Note: You must enter this registry setting under both paths listed above. 

Path:

Value Name:
Value Type:
Value for ATF:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<HBA driver 
name>\Parameters\Device[N]
LargeLuns
REG_DWORD
1
Note: The <HBA driver name> corresponds to the installed HBA driver. For 

example, for users with the LUNWorks ready QLogic driver, the 
registry path would be: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ 
trqladrv\Parameters\Device[N] 

The number N appended to the path name is optional. It identifies 
the ScsiPort device instance (adapter) that the setting applies to. 
Omitting the number applies the setting to all adapters controlled by 
the HBA driver. 

Path:
Value Name:
Value Type:
Value for ATF: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\trlls
ScsiFilterCompatibility
REG_DWORD
1 

Path:
Value Name:
Value Type:
Value for ATF:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\trfcs
AllowDiskClaims
REG_DWORD
1

Path:

Value Name:
Value Type:
Value for ATF:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\trqladrv\Par
ameters
DeviceMissingDelay
REG_DWORD
1
Note: This registry setting is only applicable if you are using LUNWorks 

Ready QLogic HBA driver.

Delete the DeviceMissingDelay value if you un-install ATF. 
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■ Diskperf and Performance Monitor 

Diskperf (a filter driver) layers over disk drivers such as LUNWorks Disk Driver 
(trdisk). All disk I/O originating in higher-level drivers and applications passes 
through Diskperf, which collects performance statistics and reports them to the 
Performance Monitor application.

Potential Problems 

Potential problems include: 

• The filter driver is not loaded until it is enabled (diskperf -y) and the 
computer is restarted.

• The filter has to attach to the disk before the file system mounts the disk. If 
the file system mounts first, the filter cannot insert itself between file system 
and disk, so none of the file system activity is noted. For this reason, starting 
the Diskperf driver in the Devices control panel will not allow you to collect 
performance information, because the file system drivers have already 
mounted the disk.

• The filter driver only looks for and attaches to disks when it is loaded, such 
as at startup. If devices are assigned to the machine afterwards, the filter 
driver will not filter them, so no performance information can be collected. 

• LUNWorks allows you to unassign devices from a node with Diskperf 
loaded, but remember, if you assign the device to the node again, Diskperf 
will not filter it until the node is rebooted. 

■ Ftdisk 

Ftdisk (fault tolerant disk driver) is a Microsoft striping, mirroring, and volume-
set driver or a disk filter driver. 

Once a disk is enabled on a machine running Ftdisk, the device cannot be 
disabled until Ftdisk is stopped or the machine is shut down. This is because 
Ftdisk does not release its reference to the disk.

Disabling a disk when there are active references to it could cause a computer 
to crash, so LUNWorks does not allow it. 

To determine if Ftdisk is running, check its status in the Devices Control Panel.
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■ Disk Administrator

Disk Administrator is the utility provided with Windows NT for managing disk 
partitions. This utility discovers the disks and partitions attached to the node on 
which it is running only at the time the program starts running. 

Disk Administrator does not hold disks open, and the View > Refresh menu 
item does not detect the addition or removal of storage since the time Disk 
Administrator started. For this reason, although it is possible to change the 
device assignments, it is not recommended. 

For example, if a device is unassigned from a node, and the partitions for that 
device are changed in Disk Administrator, the program may encounter 
unexpected errors or exit abruptly without committing changes.

■ Storage Management Software 

Software for configuring and/or managing storage devices such as redundant 
arrays of independent disks (RAIDs) and tape libraries from Windows NT 
typically requires the capability of issuing small computer system interface 
(SCSI) commands to devices representing the hardware in question. 

When LUNWorks is installed on a storage area network, these commands 
cannot be sent to a device unless the device is assigned to the node on which 
the software is run. The same logical unit number (LUN) often represents a unit 
of storage as well as a management command target, so it may be necessary to 
assign a storage LUN to the management node (perhaps temporarily) even 
though the storage is not needed on that node. 

Clariion’s Navisphere is an example of such management software. As an 
alternative to assigning a LUN from every Clariion RAID to the Navisphere 
Manager node, you may assign the LUNs wherever the storage is actually 
needed and run the Navisphere Agent on the same nodes. The Navisphere 
Manager can manage the RAIDs using these agents.
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■ Replacing a Windows NT Domain 

If one Windows NT domain is replaced with another, either intentionally or due 
to a failure of all domain controllers, and a previous LUNWorks database is 
found at startup, LUNWorks will not run until a new database is created. This is 
because the database contains only administration groups from the old domain 
and these groups no longer exist. 

If possible, complete steps 1 and 2 before replacing the domain: 

1. In the case of a domain controller failure, locate a backup database file, if 
available. If you are intentionally replacing a domain follow the database 
backup and deletion procedure below: 

a. Click the Backup Database button or choose Database > Backup 
Database to File. Save the backup file as described in the on-screen 
instructions.

b. Choose Database > Create New Database.

c. When asked if you want to delete the existing database, click Yes.

d. In the New Database dialog box, click the Cancel button.

2. Identify the database devices, if possible if you were unable to delete the 
database due to a domain controller failure. 

This information is needed in Step 4.

3. Replace the domain.

4. Disconnect the database mirror set devices from the SAN if the database 
could not be deleted due to a domain controller failure, 

5. Create a new database. 

If you successfully destroyed the previous database from Step 1, you can 
create the new database on the same storage; otherwise, create the new 
database on a different set of devices. You can restore a database backup 
during the new database creation or afterwards. 

To create the new database, follow one of these procedures: 

Creating and Restoring a Backup Database File 

a. Start LUNWorks. When prompted to create a database, click Yes and 
follow the instructions.

b. Partition the devices that will be used for the new database and create a 
database mirror set. 

c. Click the Create Database button.

d. Click Yes and select the old database file when asked if you want to 
load a saved database file. 
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After the database restoration process, the Administration Groups dialog 
box opens and prompts you to select administration groups from the 
new domain. 

e. Remove the old groups and add groups from the new domain. See 
Chapter 4, “Administration” for instructions on adding and removing 
Administration Groups. 

Note: If you click Cancel before updating the administration groups, 
you will be locked out of LUNWorks and must start this 
procedure again. 

f. If you were able to remove the storage devices in Step 4 above, 
continue with Step 6 below. Otherwise your database setup is complete. 

Creating and Restoring a Backup Database File Later

a. Start LUNWorks. When prompted to create a database, click Yes and 
follow the instructions. 

b. Partition the devices used for the new database and create a database 
mirror set. 

c. Click the Create Database button.

d. LUNWorks asks if you want to load a saved database file. 

Click No and continue with the new database creation by defining SAN 
Administration groups from the list of new domain groups.

Note: If you restore from a database backup that contains old domain 
groups, do not click Cancel in the Administration Groups dialog box 
before removing the old domain groups and adding new ones. If 
you do so, you will be locked out of the LUNWorks application and 
will need to start over with step 1 of this procedure.

e. Continue with Step 6 if you removed storage devices in Step 4. 

6. Open the Device Information dialog box for the current database devices, 
and write down the last three numbers in the World Wide Name of each, so 
they can be recognized in Step 9.

7. Re-attach the disconnected mirror set devices to the SAN. 

8. Exit the LUNWorks application and re-launch the application.

9. Select the old mirror set in the Multiple Database Mirrors dialog box and 
click the Remove Database Mirror Set button. 
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■ Moving a Node from One Network to Another 

1. Unassign all storage and remove the node from any share groups.

2. Stop LUNWorks on the node or shut the node down.

3. Make the cabling change to attach the node to a different network.

4. Restart LUNWorks or power up the node.

5. To add the node to the database on the new network, run the LUNWorks 
application from any Windows NT node and click the Scan for Nodes 
button.

6. Delete the node from the original SAN database. See Chapter 4, 
“Administration” for instructions. 

Note: Nodes that are re-cabled without restarting may fail to correctly identify 
storage on the network. Additionally, when a node cannot see storage, 
LUNWorks may be unable to identify that node as a device on the 
network. Rebooting the node may be necessary to allow LUNWorks to 
find the node.

■ Customizing the Installer 

Some LUNWorks preferences are written into the registry by the installer. When 
you run the installer, it parses the file ModifiedInstall.txt and makes 
registry entries based on the contents of the file. You can create a custom 
installer simply by editing the ModifiedInstall.txt file. This method can 
be used to install entire sites with consistent, custom configurations. 

To customize the installer: 

1. Copy the LUNWorks installation files from the CD to any read-write disk.

2. Edit the ModifiedInstall.txt file in this new location. 

3. Make the custom installer accessible to all nodes by placing the installer 
files, including the ModifiedInstall.txt file, on a LAN file-server 
share; or create your own installer CD or copy the files onto other 
removable media.

Note: See the ModifiedInstall.txt file for descriptions of the 
customizable entries.
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■ Registry Values 

Refer to the following values to customize your version of LUNWorks. 

Values Description 

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\Software\Hewlett-Packard\LUNWorks
“PortRangeBase”
REG_DWORD
6120
Tells the application and service which IP ports to use for their 
communications.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\Software\Hewlett-Packard\LUNWorks
“PromptDBBackupOnExit”
REG_DWORD
1
Determines if the application will prompt the user to back up the SAN 
database each time the application is exited.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trlls
“ScsiFilterCompatibility”
REG_DWORD
0
If true, directs the LLS driver to perform I/O in a manner that is 
compatible with SCSI filter drivers. 

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trfcs
“AllowDiskClaims”
REG_DWORD
0
Defines whether the SCSIPORT filter portion of the HBA driver allows 
filter and class drivers other than LUNWorks drivers to claim a disk LUN.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trqladrv\Parameters
“DelaySwitchUpdate”
REG_DWORD
0
If true, the QLogic HBA driver will not query the fabric nameserver 
immediately when it receives notification of a change. Instead, it waits 
until directed by a higher driver to do the update.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trqladrv\Parameters
“DeviceMissingDelay”
REG_DWORD
30 (seconds)
Time in seconds to wait for a missing device to return. IO for the device 
will be held until this timer expires or the device returns. 
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Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trqladrv\Parameters
“ExecutionThrottle”
REG_DWORD
No limit. (0xFFFF or 65535)
Maximum number of I/O allowed outstanding, at once, to a particular 
LUN. A value of 0xFFFF hex disables the firmware limit. If devices 
become saturated with IO, reduce this value.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trqladrv\Parameters
“FrameSize”
REG_DWORD
1024 (bytes)
Maximum Fibre Channel payload size to use. Acceptable values: 512, 
1024, 2048, and 2112. For best performance in high I/O environments use 
smaller frame sizes (512, 1024). For best performance in high data rate 
environments use larger frame sizes (2048 or 2112).

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKLM\System\CurrentControlSet\Services\trdisk\letters\<disk signature>
“<offset>:<length>”
REG_SZ
N/A
Single character string indicates the persistent drive letter to be assigned 
to the partition identified by the offset and length, on the disk identified 
by the signature. The signature is an 8-digit hexadecimal number, while 
the offset and length are each 16-digit hex numbers.

Path: 
Value Name: 
Value Type:
Implicit Default:
Purpose:

HKCU\Software\Hewlett-Packard\LUNWorks
…
<keys>
N/A
GUI settings: Such as size and position of the window and toolbar; icons 
and the share groups pane.

Values Description 
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This appendix provides troubleshooting tips for LUNWorks and information for 
contacting Technical Support if additional help is needed. 

■ Errors 

The following are errors you might see when using LUNWorks: 

LUNWorks Will Not Start 

Disk is Not Accessible 

Cause Solution 

When starting LUNWorks, a message appears 
stating you are not a LUNWorks 
Administrator. Exiting now. 

You are not a member of a designated 
LUNWorks administration group.

Log on to the network as a LUNWorks 
Administrator, or ask an Administrator to 
make any required changes.

Cause Solution 

When attempting to access LUNWorks disk in 
Windows Explorer, a message appears stating 
the disk is not accessible. 

The volume does not contain a recognized file 
system. Please make sure all required file 
system drivers are loaded and the volume is not 
corrupt. 

The disk has not been formatted.

Format the disk. 

See “Formatting UPM Partitions” on page 5-6 
for instructions on formatting UPM partitions. 

See your Windows NT documentation to 
format partitions in Disk Administrator.
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Cannot Unassign Device 

No Windows NT Groups in Administration 

Cause: Solution: 

There may be open files or shares on the device Close all open files, and try again. 

You may need to close applications and stop 
background processes. 

Ftdisk (fault tolerant disk driver) may be 
running. 

Microsoft’s striping, mirroring and volume-set 
driver (Ftdisk) is a disk filter driver. Once a 
device is enabled on a machine running Ftdisk, 
the device cannot be disabled because Ftdisk 
contains an open reference to the device, and 
devices with open references cannot be 
unassigned.

Try the following solutions: 

• Stop the Ftdisk
• Shut down the node before unassigning 

storage, then restart the node.
• Use the Devices control panel to disable 

Ftdisk and then reboot the node. Note that 
stripe- and volume-sets will not be 
accessible with Ftdisk disabled. 

A disk filter may be running. Try the following solutions:

• Shut down the node before unassigning 
storage, then restart the node. 

• Determine which disk filters are running 
and deactivate them if they are not being 
used. Restart the node after deactivating 
any disk filters. 

A software crash or operating system resource 
leak may leave open handles to a device. 

Restart the node.

Clariion Navisphere agent is still running.

Navisphere agent communicates to the disk 
array down the SCSI channel.

Go into services and stop Navisphere.

Cause: Solution: 

No groups are listed in the Windows NT 
Groups pane of the Administration Groups 
dialog box.

The account you used to log on is not included 
in any groups. 

Logon with an account that is included in at 
least one global group. 
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No Devices SCSI Adapter Control Panel 

Cause: Solution: 

There is a Fibre Channel network or storage 
device problem. 

There are several possible solutions. 

See items 1–3 below.

1. Check the following:

• All Fibre Channel cable connections. If 
copper cables are used, check the length 
and possible earth plane differential 
potentials. 

• The hub and switch status.
• The LUN status if a RAID is connected 

and ensure that there are LUNs created 
on the RAID. 

2. If you are using JBODs on a switch, and 
devices repeatedly go missing, update the 
firmware to the latest Public Loop capable 
version. JBOD drives have exhibited poor 
recovery behavior after hot-plugging on a 
switched network.

3. If a switch is connected, check the port 
type, and link status.

• Most RAIDs and HBAs use F_port on 
fabric switches. 

• JBOD drives and QLogic HBAs use 
FL_port on fabric switches. 

No devices are assigned to the node. Assign the desired devices to the node

The system SCSI port driver has not updated 
its list of devices.

Run Disk Administrator to trigger a refresh, 
then run the SCSI Adapters control panel.

There is a LUNWorks installation or 
configuration problem.

Ensure that the LUNWorks Service and 
drivers are installed and running. 
Refer to the Installation and User’s Manual for 
a list of components. 

LUNWorks drivers refused to enable any 
devices because multiple SAN databases were 
detected

Run the LUNWorks application from the node 
in question. If LUNWorks detects multiple 
databases, remedy the situation as described in 
the section “Multiple Databases” on page A-6 
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No Windows Domain for LUNWorks 

User Group is Missing 

No Nodes Found When Scanning 

Cause: Solution: 

No domain is set up on the LAN; no Domain 
Controller is present

Use a workgroup instead of a domain

Note: When using LUNWorks in a workgroup environment, the LUNWorks application can 
only be run from the node that set up the database, because only groups local to that 
machine can be selected as administration groups. 

Cause: Solution: 

The Administration Groups dialog box does 
not refresh automatically

After creating a new group, close the 
Administration Groups dialog box, then open 
it again. 

The group was not created at the right scope. 
If LUNWorks is running on a node that is 
logged into a Windows NT domain, the 
Administration Groups dialog will list only 
global groups. If you are running LUNWorks 
on a node that is not in a domain, only local 
groups appear in the Administration Groups 
dialog box. 

Make sure the new group is a global (domain) 
group, or a local group, as appropriate 

Cause: Solution: 

The node’s connection to the Microsoft 
network is not configured correctly. Verify this 
cause by checking other applications that use 
the network, such as Network Neighborhood 
and File Sharing. 

Reconfigure the network connection and 
parameters, such that you can see nodes in 
Network Neighborhood and browse into their 
file shares. 

Other LUNWorks nodes are not in the same 
LAN domain or workgroup. Verify this cause 
by using Network Neighborhood to determine 
if other nodes are on the network, and which 
domain or workgroup they appear in.

Move nodes into the same domain or 
workgroup
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Intermittent Mouse 

Fibre Channel Device Errors 

Nodes are inaccessible via TCP/IP due to 
incorrect configuration. Verify this cause by 
using the command-line ping utility to 
determine if nodes are accessible.

Four possible solutions are listed below: 

• Ensure that TCP/IP is installed. If not, 
install it from your Windows NT CD-
ROM.

• Check the IP subnet numbers and masks 
on local and remote nodes, and make sure 
they match.

• Check the routing tables on local and 
remote nodes.

• Check the hardware components such as 
LAN cables, hubs, and switches. 

Cause: Solution: 

A Fibre Channel communication problem is 
causing a high rate of adapter resets in the HBA 
driver.

Check all Fibre Channel connections and 
storage. If you are using a switch, check the 
port logs for possible errors.

The host bus adapter may be malfunctioning. Replace the host bus adapter. 

Excessive activity on the system or network. Wait for over-activity to slow down. 

Cause: Solution: 

The Fibre Channel card and/or drivers are not 
installed.

Install the Fibre Channel card and/or drivers.

Network attached storage or other network 
hardware is powered off.

Power on the drives or the network hardware.

Network cables are not connected properly. Verify all cable connections.

There is a failure within the Fibre Channel 
loop.

Power-off the Fibre Channel hardware. 

Then power-on the hardware to reset the Fibre 
Channel loop.

The Fibre Channel Card has become unseated 
in the computer.

Power-off the computer, remove and reseat the 
card.

Cause: Solution: 
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■ Multiple Databases 

Do not run LUNWorks on a node that has access to multiple LUNWorks 
databases. This situation may occur when UPM-partitioned devices with database 
mirror set partitions are added to a SAN that already has a database, or when a node 
is connected to more than one SAN. 

When a multiple database situation occurs, the following dialog box appears when 
the LUNWorks application is started: 

Do one of the following: 

• Determine which database mirror set contains the current database. 

Select all other database mirror sets and click the Remove Database Mirror Set 
button. 

When prompted to confirm the deletion, click Yes. When you remove a 
database mirror set, its database partitions are automatically changed to 
LUNWorks Free Space partition type.

• Click Quit and resolve and remove the excess database storage.

• Quit the application and reconfigure the SAN topology. 

Tip: If LUNWorks drivers detect multiple databases when a node is 
started, LUNWorks will not enable any devices for use on the node. 
Correct the multiple-databases situation and reboot the node. 
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■ Multiple Writers 

When restoring the SAN database from a file, LUNWorks may display a message 
indicating that a multiple-writer situation exists. 

This occurs in rare cases under the following conditions:

1. A device is assigned to a node before a database file is restored.

2. The restored database file indicates that the same device is assigned to a different 
node.

3. LUNWorks assigns the device to the node in the restored database file, but 
the node in step 1 will not release the device.

Resolving a Multiple Writer Situation 

During the database restoration, the following dialog box appears for each device 
that has a multiple-writer situation. 

1. Note the device name and the node from which it cannot be disabled, then click 
OK.

2. Take any steps necessary to get the listed node to release the device. This may 
include closing files, applications or windows; or shutting down the node.

3. Click the Scan for Nodes button. 

Note: During the Scan for Nodes process, LUNWorks resolves device 
assignments by unassigning devices from nodes that should not have 
them. If the listed node still cannot release the device, the warning 
dialog shown above appears again. Repeat steps 1–3 above.
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■ LUNWorks Error Codes 

Error Code Description 

21001000 Command packet over- or under-sized.

21001001 Command starts with invalid tag.

21001002 Command packet version is unknown.

21001003 Command could not be authenticated.

21001004 Command is for an unknown application.

21001005 Payload size and command length do not match.

21001006 Command packet not identified as request or response.

21001007 Enable-LUN command failed.

21001008 Disable-LUN command failed–check for open references to the storage.

21001009 Payload is at maximum size limit.

2100100A Unexpected command response.

2100100B Command addressed to different node.

21001016 Command timed-out waiting for a response.

21001017 Unknown command.

20000001 Application error in object database.

20000002 Application error, the database object was not initialized before use.

20000003 Low on virtual memory.

20000005 Error opening the backup file.

20000006 The object already exists in the database.

20000007 A database already exists.

20000008 No database was found.

20000009 Low-level SCSI I/O failure.

2000000A The database is locked by another user.

2000000B The database could not be locked.

2000000C The database lock was hijacked by another process.

2000000D Database header not found.

2000000E No database partitions.

2000000F The database format does not match the expected version.

20000010 The database is corrupted.
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20000011 The raw node list is full.

20000012 Illegal device or object ID.

20000013 Buffer is too small to hold command results.

20000014 Database licenses list is full.

20000015 A cryptographic call failed.

20000016 Security identifier is not valid.

20000017 An attempt was made to invalidate cached data that had not yet been written.

20000019 No ping response from semaphore owner.

20000100 Database I/O failed because the device is too busy; try again later.

20000101 Database I/O failed because the device was reserved.

20000102 Database I/O failed because a device error occurred.

20000103 Database I/O failed because the SCSI subsystem failed to issue a command.

20000104 Database I/O failed because insufficient resources available for the operation.

20000105 Database I/O failed due to an invalid parameter.

20000106 Database I/O failed because an unknown storage device was specified.

Error Code Description 
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■ Contacting Technical Support 

For information on your Technical Support options, see the Requesting Help From 
Software Support manual included with your LUNWorks package.

■ Before Contacting Technical Support 

1. Consult the information in this Installation and User’s Manual.

2. Try to determine the nature of the problem. 

By eliminating variables, the problem can be narrowed down. 

3. Try to replicate the problem and write down the circumstances in which it 
occurs. If possible, save screen captures of all encountered error messages.

4. Have the workstation that has a problem up and running on the network, if 
possible, and be at the place in the software where you are experiencing 
difficulties.

5. Have the latest Operating System installer on hand.

Note: Access to your computer when calling Technical Support is mandatory. 

■ Required Information

Be prepared to give our Technical Support staff a description of the problem, and 
the following information:

1. LUNWorks version number

2. LUNWorks License Keys

3. Devices connected to the Fibre Channel network

4. If possible, create a Microsoft Diagnostics Report for the computer that is 
having a problem.

Tip: To create a Microsoft Diagnostics Report, open a command prompt 
window, and from the C drive type: winmsd /a /f and press Return. 
The diagnostic report will be saved in the top level (root) of the C:\ 
drive with the filename computername.txt. 
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Glossary

This glossary defines new or special terms 
and abbreviations found in this publication. 
For definitions of other StorageTek terms 
and abbreviations refer to the appropriate 
publication. 

A

Administrative cluster: A collection of 
resources that can be managed as a group, 
from any node in the group. An 
administrative cluster does not provide for 
distributed applications. 

American National Standards Institute 
(ANSI): The principle group in the United 
States for defining standards.

Application Transparent Failover (ATF): 
A software product that allows applications 
to continue running after a failure of a 
storage processor, host bus adapter, or 
subsystem cable without human 
intervention. 

Availability: A measure of the amount of 
time that a computer system is operational. 

C

Cluster: A type of parallel or distributed 
system consisting of a collection of 
interconnected whole computers. A cluster 
is used as a single, unified computing 
resource. 

D

Device groups: User-configured storage 
device groups that help manage the SAN. A 
device group is a set of devices that are 
grouped into a logical set, for example, a 
JBOD, a department, or a computer room.

Disk mirroring: A technique in which the 
same data is written to multiple disks 

simultaneously. If a disk fails, the system 
can continue to operate without data loss 
or network interruption. 

Domain administrator: The person in 
charge of setting up and managing domain 
controllers. 

F

Fibre Channel: Fibre Channel is an ANSI 
standard serial I/O and networking 
protocol. Fibre Channel has very low 
overhead, low latency with very high 
bandwidth, and uses large block sizes to 
transfer data with delivery guarantee at the 
hardware level. Fibre Channel allows easy 
connectivity between mass storage and 
“multiple initiators” — multiple hosts 
accessing the storage directly.

File system: A set of data files and 
associated metadata contained on storage 
devices that are accessible by computer 
operating systems. 

G

Global group: A defined set of users from 
within a single domain. A global group may 
be granted rights and permissions for use 
within its own domain, member servers 
and workstations of the domain, and other 
trusting domains. 

Graphical user interface (GUI): A visual 
method of displaying information and 
interacting with software.

H 

Heterogeneous: Used to describe an 
environment which includes multiple 
computers with dissimilar operating 
systems.
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Host bus adapter (HBA): The hardware 
providing the Fibre Channel connection 
capability to a computer; the Fibre Channel 
network interface card.

L

Local group: A defined set of users local 
to a machine. Such a group is not intended 
for use outside the machine on which it is 
defined. 

Logical unit: A physical or virtual device 
addressable through another device. The 
disk drive is a target, but also a logical unit.

Logical unit number (LUN): Identifies a 
logical unit. Most disk drives are considered 
logical unit number zero. RAID devices can 
often be divided into multiple LUNs which 
may have LUN numbers other than zero. 

M

Mirror set: A set of partitions used for disk 
mirroring.

N

Nodes: The network attached computer 
systems that reside on the SAN, and use the 
SAN storage. They may be servers, clients 
or just attached systems using the storage.

P

Partition: A portion of a physical disk that 
is treated as a logical drive.

Partition Map: Information that maps the 
layout of partitions on a device.

Physical disk: A physical device that is 
associated with a logical unit number. A 
physical disk represents a raw storage 
component prior to building logical 
partitions out of it.

R

Redundant array of independent disk 
(RAID): A method of organizing small 
format disk devices to drastically increase 
the I/O bandwidth and improve overall 
data availability. 

S

SANware: Storage area network (SAN) 
software used to create and manage 
administrative or shared data SANs.

Scalability: The ability to increase the 
number of LUNs and nodes on the SAN.

Share Group: A share group is a group of 
nodes that shares designated storage. For 
example, clustered servers could share 
devices within a share group.

Single System Image: Ability of a 
collection of individual resources, such as 
nodes or storage, to appear to users as a 
unified computing resource.

Small computer system interface 
(SCSI): An ANSI standard for controlling 
peripheral devices by one or more hosts.

Storage Area Network (SAN): A topology 
independent network designed for, among 
other things, high-speed movement of data 
between storage devices and computer 
systems.

Storage Pool: A storage pool is the total 
available storage resources on the network. 

V

Volume: The logical storage component 
that represents the location where the data 
for a file system resides. 

W

World Wide Name (WWN): A WWN 
uniquely identifies a device on local and 
global networks.
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to share groups, 4-3

assumptions, xii
ATF, 6-4

B
before installation, 2-3

C
cannot unassign device, A-2
caution

rogue servers, 2-25
Cautions

updating administration groups during do-
main replacement, 6-9

CLARiiON’s
Application Transparent Failover, 6-4
Navisphere software, 6-2
Navisphere troubleshooting, A-2

codes, error, A-8
components, 2-1
configuration

choosing administration groups, 2-19
creating the database, 2-18
domain administrator, requirement, 2-11
partitioning database devices, 2-13

contacting technical support, A-10
contacting us, xii
conventions, xii
customizing LUNWorks, 6-11

D
database

adding a replacement device, 4-15

backing up, 4-10
creating, 2-18
partitioning database devices, 2-13
recommended partition size, 2-14
reconfiguring the mirror set, 4-11

device errors, A-5
device groups

about, 4-1
adding devices, 4-2
deleting, 4-3
name devices as, command, 4-2
to show/hide device groups, 3-4
See Also naming conventions

device information
customizing, 5-9
window, 5-8

devices
assigning

to nodes, 4-3
to share groups, 4-3

default naming convention, 3-7
partitioning, 5-1
partitioning database devices, 2-13
partitioning in LUNWorks, 5-2
reassigning, 4-3
remove missing devices command, 

warning, 4-8
unassigning

from nodes, 4-4
from share groups, 4-4

Disk Administrator
using with LUNWorks, 6-7

disk is not accessible, A-1
Diskperf, using with LUNWorks, 6-6
docked toolbar, 3-10
driver installation, HBA, 2-7

E
error codes, A-8
errors, troubleshooting, A-1

F
failover, application transparent, 6-4
Fibre Channel card (HBA)
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installation, 2-2
fibre channel device errors, A-5
floating toolbar, 3-10
Ftdisk

using with LUNWorks, 6-6

G
guide

related documents, xii

H
hardware installation, 2-2

connecting the SAN hardware, 2-2
Fibre Channel card (HBA), 2-2

HBA installation, 2-7
HBAs

LUNWorks-ready, 2-6
help

contacting technical support, A-10
error codes, A-8
LUNWorks online help, 3-2
troubleshooting, A-1
What’s This style help, 3-2

Host Bus Adapter (HBA)
see also Fibre Channel card (HBA)

host bus adapter installation, 2-7

I
icons

drag-and-drop, 3-5
icon badges, main window, 3-4
missing nodes and storage, 3-4
show/hide, 3-4
to toggle large/small icon size, 3-4

installation
customizing the LUNWorks installer, 6-10
default install location, 2-2
hardware, 2-2
installed components, 2-4
messages, 2-6
registration, 2-23
system requirements, 2-1

installation keys
defined, 2-20

installation, JNI driver, 2-7
installing HBAs, 2-3
installing LUNWorks, 2-4
intermittent mouse, A-5

J
JNI

installation, 2-7
JNI HBAs, 2-3
JNI Setup screen, 2-7

L
license keys

installation keys, 2-20
operational keys, 2-20
registering, 2-23

licensing
about license keys, 2-20
licensing a node, 4-10

location of LUNWorks, 2-5
LUNWorks

architecture, 1-3
components, 2-1, 2-5
configuration, 2-7
customizing, 6-11
error codes, A-8
installation, 2-4
installed components, 2-4
location, 2-5
ready HBAs, 2-6
selector screen, 2-4
system requirements, 2-1
uninstall, 2-25

M
main window

drag-and-drop icons, 3-5
icon badges, 3-4
missing node and device icons, 3-4
nodes pane, 3-5
nodes pane view menu, 3-5
share groups pane, 3-7
show/hide, 3-4
storage pane, 3-6
storage pane view menu, 3-6

menus
database, 3-11
file, 3-11
help, 3-12
view, 3-12
See Also shortcut menus

messages
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installation complete, 2-6
uninstallation complete, 2-26

Microsoft Cluster Server
using with share groups, 6-1

Microsoft diagnostic reports, A-10
mirror set

adding a replacement device, 4-15
icons, 2-18
maximum partitions per set, 2-16
reconfiguring, 4-11
single partition mirror, note, 2-18

mirrors, multiple databases, A-6
mouse, intermittent, A-5
multiple database errors, A-6
multiple database mirrors, A-6
multiple writers, A-7

N
naming conventions

device groups, 5-7
devices, 5-7
partitions, 5-7

Navisphere software, 6-2
no devices in control panel, A-3
no nodes found, A-4
no windows domain for LUNWorks, A-4
no Windows NT groups, A-2
nodes

licensing individual nodes, 4-10
removing from the database, 4-7

nodes pane
elements, 3-5
view menu, 3-5

non-LUNWorks servers, 2-25
notes, xii

O
operational keys

defined, 2-20
overview

business critical environments, 1-2
data security, 1-2
heterogeneous system support, 1-2
industry compatible, 1-2
reduced administration costs, 1-2
storage asset pool creation, 1-2

P
partitioning

database devices, 2-13
modifying UPM partitions, 5-4
with LUNWorks, 5-2

Performance Monitor
using with LUNWorks, 6-6

Q
QLogic HBAs, 2-3

R
ready HBAs, 2-6
registration

registering the SAN, 2-23
Registration.txt file, 2-24

registry values, 6-11
related documents, xii
remove programs, 2-26
requirements, system, 2-1
resolving multiple writer situations, A-7
rogue servers, 2-25

S
scanning errors, A-4
SCSI adapters, 2-8
selector screen, 2-4
servers

rogue, 2-25
share groups

additional software, warning, 4-4
data integrity, warning, 4-4
defined, 4-4
devices

assigning, 4-3
unassigning, 4-4

name devices as, command, 4-5
restrictions, 4-4
to show/hide share groups, 3-4, 4-4
using with MSCS, 6-1
See Also naming conventions

share groups pane, 3-7
showing/hiding share groups, 3-7

shortcut menus
device groups, 3-13
devices, 3-14
nodes, 3-14
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share groups, 3-15
software

ATF, 6-4
JNI driver, 2-7
LUNWorks, 2-4
Microsoft Cluster Server, 6-1
Navisphere, 6-2

status bar
show/hide, 3-4

storage
assigning, 4-3
pane, 3-6
reassigning, 4-3
unassigning, 4-4
See Also device groups
See Also devices

Storage Management Software
using with LUNWorks, 6-7

storage pane, 3-6
system requirements, 2-1

T
Technical Support, A-10
Tips, description of, xii
toggle large/small icons, 3-4
toolbar

buttons, 3-9
database buttons, 3-9
docking, 3-10
floating, 3-10
layout, 3-10
positioning, 3-10
show/hide, 3-4
view buttons, 3-9

trademarks used in this guide, xi
transparent failover, 6-4
troubleshooting

appendix, A-1
cannot unassign device, A-2
disk is not accessible, A-1

fibre channel device errors, A-5
Ftdisk, A-2
intermittent mouse, A-5
LUNWorks will not start, A-1
mouse, A-5
multiple database errors, A-6
multiple writers, A-7
Navisphere, A-2
no devices in control panel, A-3
no nodes found, A-4
no Windows domain, A-4
no Windows NT groups, A-2
user group missing, A-4

U
unassigning devices

devices that are in use, 4-4
from nodes, 4-4
from share groups, 4-4

uninstalling LUNWorks, 2-25
Universal Partition Map (UPM)

about, 5-2
Disk Administrator, note, 5-6
erasing, 5-7
formatting UPM partitions, 5-6
partition types, 5-2

unlicensed device marker, 3-4
UPM partitions

erasing the UPM partition map, 5-7
formatting, 5-6

user group missing, A-4

V
values, registry, 6-11

W
will not start, A-1
writers, multiple, A-7
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