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About this Document

1 Overview

This User Service Manual (USM) provides the following information for Lucent
Technologies AnyMedia™ Access System Element Manager for Narrowband
(AEM-NB), Release 1.5:

■ A product overview and a functional product description

■ System turn-up procedures and system modifications

■ User Management

■ Configuration management

■ Fault Management, Maintenance.

The purpose of the USM is to provide the provisioning personnel with all informa-
tion necessary to provision an AnyMedia Access System R1.5 via the AEM-NB.

The USM is a network oriented manual and will be shipped to all sites where an
AEM-NB is available. It provides the provisioning operator(s) with necessary infor-
mation to configure or re-configure network elements after local installation.

The philosophy behind the provisioning of network elements within a network is
that the network is already installed, configured and service has been provided to
the network after first installation and that re-configuration of the NE is necessary.
Provisioning takes place from the AEM-NB, located in one or more central offices.

Purpose



X Issue 2 (09.99) 363-211-402

AEM-NB R1.5

About this Document Intended Audience

2 Intended Audience

The USM is intended for personnel who take care of deploying NEs by carrying
out all provisioning activities of the NEs using the AEM-NB.

Tasks to be performed by the Provisioning personnel are:

■ Collect information of provisioning data (e.g. check shelf layout, units list)

■ Put ports in-service and out-service

■ Assign timeslots (Cross Connections)

■ Download and upload the provisioning data to and from the NEs

■ Testing of assigned ports.

■ Recognize, interpret, analyze or correct failures, caused by provisioning
data that is configured incorrectly.

The personnel should at least have the following education level:

■ Computer knowledge (e.g. windows applications and/or SUN applications)

■ Telecommunication Network knowledge.
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How to use this document

3 How to use this document

The guide is divided into a number of sections (subjects), clearly separated by
numbered tabs. The front pages of the guide also describe this division, and list
the titles of the subjects together with the corresponding tab numbers. Through
this readers can quickly select the subject of their interests and needs.

■ How are we doing
A comment form so readers can give feedback to improve the next revision
of the document.

■ Table of contents, list of figures, list of tables

■ Overview
Defines the purpose of the document and the intended audience. Also in-
cluded are topics about the conventions used in the document, related doc-
umentation, how to order documents, and how to comment on this docu-
ment.

■ Chapter 1, Functional Description
Contains a short overview over the system, its features and capabilities.

■ Chapter 2, Software Installation
Describes the standard procedure to install the AEM-NB R1.0 server pack-
age (server applications) and client package (client applications).

■ Chapter 3, System Management
Provides the system administrator with all information necessary to admin-
ister the AEM-NB so that it can be used as a centralized management sys-
tem.

■ Chapter 4, User Management
Describes all actions necessary to create/modify/delete users, user groups
and domains and the handling of controlled objects.

■ Chapter 5, Configuration Management, Provisioning
Describes the database and software management, the default system
configuration parameters and the provisioning and service activation, the
inventory management, clock synchronization management and protection
switching.

■ Chapter 6, Fault Management/Maintenance
Describes alarms and events, how to use the Alarm Viewer, how to perform
tests and trouble clearing procedures.

■ Appendix
Describes the Data Communications Network (DCN) configurations.

■ Abbreviations and Acronyms
Lists all abbreviations and acronyms used in this manual.

■ Glossary
Defines special terms used in this manual.

■ Index
Alphabetical index to quickly search for paragraphs in the manual which
provide more information on a certain keyword.
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4 Conventions Used

The following are terms used in this USM that may have a different meaning than
the general or common use of the term.

■ In the AEM-NB, the term access means that the system provides the pri-
mary service interface for the customer to enter the network.

■ The term plug-in is generally used for circuit pack units (COMDAC, CIU,
IO-DS1, CTU and application packs (APs)) which have pre-designated
slots with the capability to plug-in the circuit pack.

Each fascicle can be identified by its number and contains a chapter which is
numbered accordingly (e.g. Chapter 2 is contained in Fascicle 2).

The page, figure and table numbering begins with “1” in every chapter. To be able
to identify them easily, these numbers are prefixed with the fascicle number. For
example, Figure 2-3 designates the third figure in Fascicle 2.

Cross-reference conventions are identical with those used for numbering, i.e. the
first number in cross-references refers to the corresponding fascicle.

To facilitate the location of specific text passages, the guide contains so-called
keyword blocks. These are placed to the left of the main text and contain either a
keyword or a word which indicates the contents of a paragraph or group of para-
graphs.

Each abbreviation used in this guide is listed in Fascicle AB (“Abbreviations”) of
the hardcopy version unless it can be assumed that the reader is familiar with this
abbreviation.

Commands and messages are displayed in constant-width font (e.g., tar xf
/cdrom/cdrom_name/AnyMediaEMSR10.tar ).

The trademarks used in this document are identified after the title page. Trade-
marks of Lucent Technologies and other companies are in italics and the trade-
marks modify a noun (e.g., the system name contains a trademark, AnyMedia®

Access System). A trademark is not treated as an acronym (it is not spelled out or
expanded).

Lucent Technologies trademarks are identified with the registered mark (®) or
trademark (™) symbol the first time the trademarks are used in a chapter.

The trademarks of other companies are identified with a footnote reference the
first time the trademarks are used in a chapter.

Numbering

Cross-References

Keyword Blocks

Abbreviations

Commands

Trademarks

Lucent Technolo-
gies Trademarks

Trademarks of
Other Companies
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The following table gives examples of the typographical conventions used in this
chapter.

6 General Safety Information

This section lists the safety information needed for the AnyMedia Access System
for system turn-up after installation has been completed, operating, provisioning
and maintaining the system.

6.1 General Notes on Safety

This system has been developed in line with the present state-of-the-art and fulfils
the current national and international safety requirements. It is provided with a
high degree of operational safety resulting from many years of development expe-
rience and continuous stringent quality checks in our company.

The system is safe in normal operation. There are, however, some potential
sources of danger that cannot be completely eliminated. In particular, these arise
during the

■ Opening of housings or equipment covers

■ Manipulation of any kind within the equipment, even if it has been discon-
nected from the power supply

■ Disconnection of optical or electrical connections

through possible contact with

■ Live parts

■ Laser light

■ Hot surfaces

■ Sharp edges, or

■ Devices sensitive to electrostatic discharge.

Table 0-5 Typographical Conventions

Object Example Meaning

Keyboard Return  or A Return  or A key on the keyboard

Shift-Ctrl-B Shift , Ctrl and B key pressed simultaneously

Esc A B Esc , A and B key pressed one after the other

Pushbutton Apply Apply  pushbutton in a window

Menu File -> Exit Menu option Exit  in File  menu

Objects in
windows

Date Designates the object Date in a window (e.g.
text field, check box, spin box etc.)

Typographical Con-
ventions
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6.2 General Safety Requirements

In order to keep the technically unavoidable residual risk to a minimum, it is imper-
ative to observe the following rules:

■ Installation, configuration and disassembly must be carried out only
by expert personnel and with reference to the respective documenta-
tion.
Due to the complexity of the unit/system, the personnel requires special
training.

■ The unit/system must be operated by expert and authorized users
only.
The user must operate the unit/system only after having read and under-
stood the chapter on safety and the parts of the documentation relevant to
operation. For complex systems, additional training is recommended. Any
obligatory training for operating and service personnel must be carried out
and documented.

■ Any conversions or changes to the system or parts of the system (in-
cluding the software) must be carried out by qualified Lucent Tech-
nologies personnel or by expert personnel authorized by Lucent
Technologies.
All changes carried out by other persons lead to a complete exemption
from liability.
No components/spare parts must be used other than those recommended
by the manufacturer and those listed in the procurement documents.

■ The unit/system must not be operated unless it is in perfect working
order.
Any faults and errors that might affect safety must be reported immediately
by the user to a person in responsibility.

■ The equipment must be supplied with Safety Extra-Low Voltage
(SELV) of -48 V and the positive terminal of this source must be cor-
rectly connected to the protective earth.
Never connect to –60 V.

■ The unit/system must be operated only with the connections and un-
der the environmental conditions as described in the documentation.

■ The removal or disabling of safety facilities, the clearing of faults and
errors, and the maintenance of the equipment must be carried out by
specially qualified personnel only .
The respective parts of the documentation must be strictly observed.
The documentation must also be consulted during the selection of measur-
ing and test equipment.

■ Transport, storage and operation of the unit/system must be under
the permissible conditions only.
See accompanying documentation and information on the unit/system.

■ Calibrations, special tests after repairs and regular safety checks
must be carried out, documented and archived .

■ Only use tested and virus-free diskettes.
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■ Do not place the shelves on an unstable cart, stand, or table.
The product may fall causing serious damage to the equipment.

■ Never push objects of any kind into this product through cabinet
slots as they may touch dangerous voltage points or short out parts
that could result in a risk of fire or electrical shock. Never spill liquid
of any kind on the product.

6.2.1 Safety Symbols and Labels

All safety instructions have a uniform appearance. They include a signal word that
classifies the danger and a text block that contains descriptions of the type and
cause of the danger, the consequences of ignoring the safety instruction and the
measures that can be taken to minimize the danger. In some safety instructions, a
warning symbol is placed underneath the signal word.

There are five classes of safety instructions: “Danger”, “Warning”, “Caution”, “Im-
portant” and “Notice”. The classification is shown in the following table.

7 Related Documentation

The following is related documentation for the AEM-NB and for additional compo-
nents:

DANGER Serious injury is definite or likely.

WARNING Serious injury is possible.

CAUTION Minor injury is definite, likely or possible, or material damage
to the product or in the product environment is definite or
likely.

IMPORTANT Material damage to the product or in the product environment
is possible.

NOTICE A fault, i.e. considerable impairment to operation, will be
caused or may be caused.

Table 1 List of Documents

Component Manual Type Comcode
CIC Ordering
Number

AEM-NB R1.5 Functional Description 108588740 363-211-401a

a For the ordering address see Chapter 8, How to Order This Document.

AnyMedia Access System Applications, Planning, and
Ordering Guide (APOG)

363-211-101a

AnyMedia Access System Installation Manual (IM) 363-211-102a

AnyMedia Access System Commands and Procedures 363-211-100

Classification

Document List
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7.1 Print Copy (Hard Copy)

All listed documents are available in print.

7.2 CD-ROM

The User Service Manual and the Functional Description are available in PDF for-
mat on CD-ROM and an Adobe Acrobat Reader 1 is provided to view them.

8 How to Order This Document

The ordering number for the AEM-NB User Service Manual is 363-211-402.

To order additional hard copies of this document and/or to request placement on
the standing order list, send or call in an order as follows:

Table 2 Customer Documentation on CD-ROM

Component CD-ROM Ordering Number

AEM-NB R 1.5 Customer Documentation on CD-ROM includes:

− User Service Manual (USM)

− Functional Description.

363-211-400 a

a For the ordering address see Chapter 8, How to Order This Document.

1 Acrobat Reader is a registered trademark of Adobe Systems Incorporated.

Mail Ordera

a For ordering, a purchase order number, or charge card number is required with all orders. Make
checks payable to Lucent Technologies.

Telephone Order
(Monday through
Friday)

Lucent Technologies

Customer Information Center

Attention: Priscilla Stanley,
email: pfstanley@lucent.com

2855 N. Franklin Road P.O. Box 19901
USA-Indianapolis, IN 46219

Within USA:1-888-LUCENT8
7:30 a.m. to 6:30 p.m. EST
FAX from USA:
+1-800-566-9568
FAX Worldwide:
+1-317-322-6699

Document
Packaging and
Format

Ordering Number

Order Procedure
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One-time orders include the contents for the current document issue in effect at
the time of order.

You may request an update on the standing order list for all later reissues of any
document. The standing order list for each document provides automatic distribu-
tion for all reissues of the document.

9 How to Comment on This
Document

The first sheet in this manual (after the title page) is the feedback form How Are
We Doing?

Please use this form to fax your comments and suggestions concerning the USM,
363-211-402 to:

Lucent Technologies Network Systems GmbH
Fax no.: +49 911 526-3545.

One-time Orders

Standing Orders

Document Com-
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1Functional Description 1

1.1 About this Subject

This chapter describes the Release 1.5 of the AnyMedia®-Element Manager for
narrowband services (AEM-NB).

This chapter provides an overview of the AEM-NB and tries to give an insight into
the functioning of the AEM-NB by providing detailed information on the AEM-NB
features mentioned.

The following AEM-NB subjects are described:

■ Basic functionality

■ Management features

■ System and software architecture

■ Hardware and software platform

■ Interfaces

■ Applications.

Scope

Purpose

Contents
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1.2 Introduction

The AEM-NB is part of a Telecommunication Management Network (TMN). It rep-
resents the element management layer and fulfills the tasks of the ISO (Interna-
tional Standardisations Organisation) functional areas (see Chapter 1.2.2,
page 1-3).

This provides some benefits for the operator:

■ Better control over revenue generating services by local and centralized
management

■ Reduced time and effort for provisioning tasks

■ Fast and efficient fault detection and isolation

■ Prevention of unauthorized access by appropriate security mechanisms

■ Reduction of operator mistakes by easy-to-use Graphical User Interface
(GUI)

■ Integration with higher management levels for network, service and busi-
ness purposes.

1.2.1 Main Functions

The AEM-NB provides the following main characteristics/functions:

■ Support of all AnyMedia Access Systems features

■ Equipment Overview

■ Common alarm handling for all network elements (NEs)

■ Report, Log, Backup & Restore functions

■ TL1 NE access via TCP/IP based on DCN

■ User security handling (user profiles, NE domains)

■ Online Help

■ Multi User access

■ Northbound interfaces (TL1).

General

Benefits
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1.2.2 ISO Functional Areas

1.2.2.1 Configuration Management

The Configuration Management supports the complete range of graphical func-
tions to provision and maintain the R1.2 NEs. Network topologies, shelf views and
self-explaining menus are navigating the operator to configure POTS, ISDN-BRA
and Leased Line Services. The following main functionalities are offered (for more
detail see Chapter 1.3.1.1, page 1-8):

■ Inventory management

■ Equipment provisioning and maintenance

■ Service provisioning

■ Clock synchronization

■ System/Equipment/Service status

■ Software download

■ NE database backup and restore

■ System date/time synchronization.

1.2.2.2 Fault Management

The Fault Management supports the operator in detecting, displaying, localizing
and logging any faults occurring in the managed network. The following main
functionalities are offered (for more detail see Chapter 1.3.1.1, page 1-8):

■ Handling of alarm severities (critical, major, minor)

■ Receiving of autonomous alarm messages

■ Retrieving of alarms per system, plug-in unit, application pack

■ Retrieving of alarm and event logs from NE

■ Initiation/Evaluation of tests for fault analysis purposes.
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1.2.2.3 Performance Management

The Performance Management provides facilities for retrieving, storing and print-
ing of the NE performance and data to ensure the quality of service.

1.2.2.4 Security Management

The Security Management functions which are based on UNIX® control the ac-
cess to the AEM-NB and to the managed NEs. The following main functionalities
are offered (for more detail see Chapter 1.3.1.1, page 1-8):

■ AEM-NB user administration

■ AEM-NB user security profile

■ No additional NE login for current AEM-NB user

■ AEM-NB access via login name and password1

■ Inactivity user session time-out1.

1.2.3 Applications

The AEM-NB provides 6 applications which give access to the management func-
tionality as described in Chapter 1.2.2, page 1-3. The following applications are
available:

■ System Administration

■ User Administration and Profiling

■ Log Viewer

■ Alarm Viewer

■ Configuration Manager

■ BroadBand EM.

Each application is composed by one or more tasks. The default user group as-
signment to the individual applications/tasks is described in Chapter 1.4.4,
page 1-26.

1 provided by the OS System (SUN Solaris)
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1.2.4 System Working Modes

The AEM-NB can work in the following two modes:

■ Stand-alone Mode

■ Integrated Management Mode.

These modes are not mutually exclusive, i.e. the AEM-NB is always able to per-
form the element management tasks even while it is connected to any OS.

In the stand-alone mode the AEM-NB performs the whole management of the
NEs on its own. The user is able to perform all management tasks via the GUI.

Figure 1-1 shows the system architecture in the stand-alone mode.

Figure 1-1 Stand-Alone Mode

In the integrated management mode the AEM-NB works as an integral part of the
customer’s management network, providing higher management systems (OSs)
with services to manage NEs in their domains.

The AEM-NB allows other OSs to pass provisioning, testing or fault information to
and from the NEs, e.g. a fault management surveillance system can collect fault
data using the pass-through interface.

Stand-Alone Mode

NE

TL1

NE

AEM-NB

Integrated
Management Mode
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Figure 1-2 shows the system architecture of the integrated management mode.

Figure 1-2 Integrated Management Mode

The complete system and software architecture of the AEM-NB is described in
Chapter 1.3, page 1-7.

OS

NE

TL1

NE

TL1

AEM-NB
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1.3 System and Software
Architecture

1.3.1 Functional Groups

The AEM-NB software architecture is built with a number of components that can
be grouped in the following distinct functional groups:

1. NE Management
(Equipment Management, Service Management, Alarm Management,
Test Management, Performance Management)

2. General Components
(Components for Operation, Administration and Maintenance (OAM);
Common Servers)

3. Software Platform
(Software bus, Repository, third party libraries)

4. Graphical User Interface (GUI)

5. Northbound Interface

6. Southbound Interface .

Figure 1-3 shows the six functional groups. The shadowed blocks are part of the
AEM-NB.

Figure 1-3 AEM-NB Functional Groups

Hardware Platform

Software Platform
(Software bus, Repository, third party libraries)

NE Management
(Equipment, Service, Alarm, Test, Performance)

GUI

User

OS

Southbound
Interface

Northbound
Interface

General
Components

3

25 1

4

6

NE

Common S.,
OAM comp.)

(SUN/Solaris)
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1.3.1.1 NE Management

The NE Management functionality is distributed in 5 areas. These are: Equipment
Management, Service Management, Alarm Management, Performance Manage-
ment and Test Management.

The Equipment Management provides the following functionality/features:

■ Scrolling List of NEs

The NEs are displayed in a list covered in a single window called Network
Browser, where the NEs and their components can be handled like files in
a file browser.

■ NE Provisioning

The operator can create a new NE manageable for the AEM-NB view. The
operator must enter the specific configuration data for the new NE such as
IP address, NE Name, NE user-id and password.

■ Software Download to a single NE

Provides a storage medium for maintaining a copy of the software and a
mechanism for downloading that software to a NE.

■ Software Download to multiple NEs

Download of new software to multiple NEs on an individual connection ba-
sis.

■ NE Non-Volatile Data Storage Restoration

Restores NE non-volatile data storage upon user request. Provides a stor-
age medium for maintaining a copy of the NVDS for backup and restore
purposes on a periodic basis.

■ Maintain a local Copy of NE Inventory

The AEM-NB maintains a local copy of specific hardware identifiers and
software version identifiers. This local copy accepts automatic inventory
notifications. This information can be used for display and report functions
in case of loss of communication with the supported NE. The hardware
identifiers include all plug in units.

■ Maintain a local Copy of NE Provisioning Configuration Data

The AEM-NB maintains a local copy of all cross-connection and parameter
settings for each NE. This information can be used for display and report
functions in case of loss of communication with the supported NE.

■ Maintain NE Software Copies

The system keeps a copy of the versions of the NE software running in the
NEs managed by the AEM-NB (FAST 24-channel, FAST 30-channel,
SDH). Generally, only one version of NE software per NE type is used by
all the NEs in a network but the AEM-NB must have the capacity to man-
age two software versions during the upgrade period.

Equipment
Management
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■ NE Reset (INIT-SYS)

Allows the user to delete the NE and restore the factory settings for the
whole NVDS except for the IP address, so that the AEM-NB can still com-
municate with the NE after the command execution has been completed.

■ AEM-NB Database Synchronization

Automatic update of the AEM-NB database records based on NE database
changes.

■ Protection Control

The management system provides a facility to allow the user to switch op-
eration of one unit in a NE to a standby unit, if that unit exists.

■ Equipment Protection

The AEM-NB allows the user to provision the equipment information for the
protection scheme. Also the user can force protection switching.

— NE R1.2 COMDAC - simplex/duplex and IO-DS1

■ NE Timing Synchronization

The AEM-NB supports the user to configure the NE synchronization clock
sources.

■ NE Date and Time

The AEM-NB allows the user to set and retrieve the date and time of the
NE.

■ NE Disaster Recovery from the AEM-NB

The AEM-NB is able to reconstruct its NE database by polling the NEs for
information and from internally maintained backup copies of data.

The Service Management provides the following functionality/features:

■ NE Service Status

Provides the aliveness status of the individual NEs providing a customer's
service across all NEs under the EM’s control.

■ Logical DS1 List

Logical DS1 ids can be listed based on a selection criteria.

■ Change Voice Frequency Data Enhancement (VFDE) for TR-303 VRTs

Enabling/Disabling of the Voice Frequency Data Enhancement (VFDE) of a
TR-303 Virtual Remote Terminal (VRT).

■ Datalink Protection Switching

Provides datalink protection switching of a TR-303 Virtual Remote Terminal
(VRT) for both TR-303 datalinks, Embedded Operations Channel (EOC)
and Timeslot Management Channel (TMC).

■ Edition of the Network Interface

■ Creation of a VRT/VB Logical Feeder (T1 Cross-Connection)

Service
Management
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■ Edition of a VRT/VB Logical Feeder (T1) of a VRT/VB

■ Deletion of a VRT/VB Logical Feeder (T1) from a VRT/VB

■ Addition/Deletion of a Logical Line (Subscriber, T0) to/from a VRT/VB

■ Edition of a Logical Line (Subscriber, T0) of a VRT/VB.

The Alarm Management provides the following functionality/features:

■ Integrated display of all the alarms

The AEM-NB provides a common window (alarm viewer) to show all
alarms reported by the managed NEs or generated by the management
system itself. The display shows all the information pertaining to the alarm,
including alarm type, severity, service affecting indication, date/time of oc-
currence and clearing.

■ Alarm Display Filters

It is possible to filter the items shown in the alarm viewer, for instance, to
see only the critical alarms.

■ Alarm Notification to User

The user is informed by visual and audible alerts when a new alarm has
been reported to the AEM-NB.

■ Clearing of Alarms

Alarms in the management system will automatically be cleared when the
faults are removed at the source (such as in the NEs or in the platform).
The alarm information will contain the date and time of alarm clearance.

■ Acknowledged Alarms

The operator can acknowledge a raised alarm - alarm still active but being
investigated. The AEM-NB registers the time at which an alarm changes its
status from raised to acknowledged and, separately, from acknowledged to
cleared. It is also possible for an alarm to go directly from the raised to the
cleared state.

■ Alarm Colors

The management system provides a color scheme based on alarm severi-
ties.

■ Enable/Disable of autonomous Alarms on an NE Basis

■ Fault Localization

Provides fault localization across all NEs under the AEM-NB control. The
COMDAC LEDs show the highest severity alarm for the system. The indi-
vidual plug-in unit LEDs show the highest severity alarm for the plug-in unit.
Fault localization is performed at AP level.

■ NE Alarm Log Handling

The AEM-NB is able to retrieve the NE alarm log via the cut-through inter-
face.

Alarm
Management
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The Performance Management provides the following functionality/features:

■ Handling of Performance Records

Records can be displayed, printed and stored in a user-defined file.

The Test Management provides the following functionality/features:

■ Port Test (via cut-through)

It is possible to request a test for a particular port on a specific application
pack.

■ Application Pack Card Test

It is possible to start a series of self-diagnostic routines for all port circuits
on a specified Application Pack plus its common circuitry.

■ Standby Card Test Scheduling (via cut-through)

It is possible to schedule a test to perform a COMDAC side switch or off-
line diagnostic for the standby COMDAC or the protection.

■ Built-in Self-Test

Each NE performs a built-in self-test of plug-in circuit packs periodically.

■ Loopback Test at the Feeder Side

It is possible to set or clear a loopback on particular feeders.

1.3.1.2 General Components

The components of this group do not have or require any knowledge of the NEs
the AEM-NB is managing. They provide a platform on which the other AEM-NB
components can operate and isolate them from the underlying customer platform.

The OAM components provide operation, administration, maintenance and secu-
rity functionality. This is based on third party-tools (i.e. orbix) and a set of specific
applications.

The OAM components provide the following functionality/features:

1. Operation/Administration/Maintenance

■ Standard Reports

The system allows the user to generate a set of predefined reports from
the information kept by the AEM-NB. The reports cover the following areas:

— Alarms

— Equipment configuration

— Service provisioning

— NE inventory

— Performance.

The reports are available for displaying, printing and saving in a postscript
file.

Performance
Management

Test
Management

OAM Components
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■ Backup and Restore of system relevant data

Relevant data includes all information necessary to restore the situation in
case of an AEM-NB crash.

■ AEM-NB Software Upgrades

Provides an established release cycle for AEM-NB software upgrades in a
way that minimizes incompatibility with NE software releases, and allows
for upgrades to provide for OS compatibility. This upgrade does not affect
the services provided by NEs.

■ Log Administration

The logs are capable of being printed and visualized. The system limits the
size of the system logs. It is possible to make backups of the logs and to re-
move them from the system. There are logs for:

— Actions

Contains all the information on actions performed by users or the
AEM-NB and which imply changes in the AEM-NB configuration,
equipment (NE) configuration, service and subscriber configuration,
access to the AEM-NB, print reports and backup & restore, i.e. all
operations triggered by the user or the AEM-NB and all subsequent
actions. The results of operations are also logged in the actions log.

— System Internal Events

Contains all internal events or actions which report unusual changes
in the configuration and state of the AEM-NB or indicate errors that
occurred in the AEM-NB.

— Autonomous Reports

Contains all information useful for the equipment supplier about
alarms (NE and platform), the performance and all TL1 messages
sent from all managed NEs and which imply changes in the data-
base.

■ Possibility to sort logs

2. Security

■ Possibility of creating/deleting/modifying AEM-NB Users

The AEM-NB uses the security mechanisms provided by the SOLARIS Op-
erating System.

■ AEM-NB Security Privilege Levels

Allows at least three privilege levels within the managed domain. This is
mapped to the NE privilege levels accordingly.

— Administrator: has all the permissions.

— Maintenance: has configuration and monitoring permissions.

— Monitoring: has alarm monitoring and testing permissions.
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■ NE User Security Privilege Levels

It is possible to administer the NE users and the privilege levels via the cut-
through interface.

■ User Access is authenticated through User Name and Password

■ Single Login to Access the Domain

Enables an authorized user to access multiple NEs simultaneously (e.g.
multiple windows) using a single login and password.

■ Domain Partitioning

Enables the NEs managed by the AEM-NB to be partitioned into separate
security domains and permits users access to the domains based on their
areas of responsibility and profile.

■ User Inactivity Timer1

The user terminal will be locked with a screen saver once a configurable in-
activity timer has expired. To unlock the terminal, the user has to type
his/her password. The timer has to be configured by the administrator.

■ Lock Screen1

The user is able to lock the screen whenever he wants. To unlock the termi-
nal the user has to enter his/her password.

Common Servers offer general purpose services. A common server

■ manages the AEM-NB history and security logs

■ logs the history and security data of other processes upon request

■ provides log information upon request

■ provides a facility to generate and print client reports in the AEM-NB
printers

■ provides event distribution services based on a supplier/consumer model.

1.3.1.3 Software Platform

1.3.1.3.1 Software Bus

The communication between the AEM-NB processes is based on the Common
Object Request Broker Architecture (CORBA) standard. The heart of the CORBA
architecture is the Object Request Broker (ORB). The ORB is a software bus to
which different applications can connect to offer their services and/or to use other
applications’ services (from which they are clients).

The ORB provides a transport mechanism that makes connected servers’ loca-
tion, platform and implementation transparent to their clients, making applications
easier to distribute and scale.

1 provided by the OS System (SUN Solaris)

Common Servers

CORBA
Architecture
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The protocol used by the ORB is the Internet Interoperability Protocol (IIOP).

1.3.1.3.2 Repository

The Repository contains all the AEM-NB information that must be persistent. It is
supported by an Object Oriented Database (ObjectStore) and the underlying op-
erating file system. All components of the system have direct access to the repos-
itory to store/retrieve their own data.

Information in the repository includes:

■ NE inventory
(for each NE: the hardware identifiers and the software versions)

■ Equipment and Service provisioning data

■ History and security logs

■ External system communication parameters

■ AEM-NB configuration data

■ Alarms cache.

1.3.1.4 Graphical User Interface (GUI)

The Java based GUI is responsible for putting up forms, collecting user input
(commands and data) and routing it on to the correct component. It also receives
data from the relevant process which it uses to update its display. The GUI has di-
rect access to the services provided by the AEM-NB through the ORB.

The GUI provides the following functionality/features:

■ Multi-National Language Support

Provides all user interface capabilities in English.

■ Support TL1 messages

Supports all TL1 messages for all NE products for dumb terminal access.
Allows direct input of TL1 messages. In some markets, direct input of TL1
messages may not be allowed and can be suppressed via the appropriate
security permissions.

■ Online Help

Provides access to online help which contains at least information on the
operation of the AEM-NB, meaning of the buttons, etc.

■ Multiple windowing

Provides multiple windowing for access to multiple NE information on a sin-
gle screen.

■ Multiple user access

Provides for multiple users access to the AEM-NB at the same time. Multi-
ple users may include multiple OSs or NMSs as well as multiple GUI ac-
cess.

Protocol

Introduction

Contained
Information

Introduction

Functionality,
Features
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■ Time and Date format

Enables the user to use local/preferred time and date format. For example,
the local calendar must be supported or optional use of 24 hour clock ver-
sus a 12 hour clock.

■ User friendly GUIs

Provides a user-friendly interface and hides the complexities of the infor-
mation models.

■ Manageable Objects organized in a Hierarchy

The configuration is implemented within a GUI hierarchy:

— NE group level, containing a number of NEs

— NE level, starting with shelf-view.

1.3.1.5 Northbound Interface

The Northbound Interface performs all the tasks needed to communicate to other
OSs. It allows external OSs access to the NEs managed by the AEM-NB directly
through TL1 commands via a pass-through interface. This access is controlled by
the Northbound Interface until the OS is disconnected.

The TL1 Pass-Through Interface allows an external OS access to the NEs man-
aged by the AEM-NB directly through TL1 commands for provisioning, testing and
alarm purposes.

1.3.1.6 Southbound Interface

The Southbound Interface performs all the tasks needed to communicate to the
NEs managed by the AEM-NB. It provides distributed CORBA access which in-
cludes implementation and translation of TL1 commands, response and autono-
mous messages into equivalent CORBA requests and events.

The TL1 Southbound Adaptors isolate the main AEM-NB functionality from the
specific protocols used by the NEs. They are responsible for translating actions
and state changes conveyed through CORBA messages from/into the NE specific
message formats.

The Southbound Interface provides the following functionality/features:

■ Southbound TCP/IP TL1 Client Application

Support for the TL1 client application on the southbound TCP/IP interfaces.
TL1 is used for most of the OAM&P functions (see Chapter 1.3.1.2,
page 1-11).

■ Southbound TCP/IP FTP Client Applications

Support for the FTP client application on the southbound TCP/IP inter-
faces. FTP is required for software download and NE data backup/restore.

Tasks

TL1 Pass-Through
Interface

Tasks

TL1 Southbound
Adaptors

Functionality,
Features



1-16 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Functional Description System and Software Architecture

■ Southbound TCP/IP Telnet Client Applications (Cut-Through)

Support for the Telnet application on the southbound TCP/IP interfaces.
Telnet is used to provide a direct command line into the NE (i.e. an equiva-
lent ASCII terminal interface).

1.3.2 Hardware Platform

1.3.2.1 Architecture

A number of AEM-NB Clients (UNIX Workstations) can be added to the AEM-NB
Server to support concurrent users or remote access to the server’s applications.
These clients can be connected through a TCP/IP infrastructure or a Wide Area
Network (WAN). Examples are shown in Figure 1-9 to Figure 1-12.

The tasks of the components are:

■ AEM-NB Server:
Manages all the AEM-NB applications and provides access to the NEs, the
database and the external OS.

■ AEM-NB Client :
Formats the display of the application screens and manages the users ses-
sions with the application, e.g. database access.

Figure 1-4 is a conceptual representation of the various generic components.

Figure 1-4 Hardware Components

Components

Tasks of the
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 Two examples of an AEM-NB system are shown in Figure 1-5.

Figure 1-5 Examples of AEM-NBs

1.3.2.2 Requirements

A SUN SOLARIS workstation can be used as AEM-NB Server as well as AEM-NB
Client.

The AEM-NB system may use a number of peripherals with the following tasks:

■ CD-ROM:
Used for installing the system software.

■ Tape drive or another removable device (optional):
Used for backup and restore functions.

■ Printer:
Used for obtaining hard copies, e.g. configuration/alarm reports or perfor-
mance monitoring measurement information.

Examples of
AEM-NBs

Client

Hub

Client Client

AEM-NB System 1: AEM-NB System 2:

AEM-NB Server

AEM-NB Server

Server/Clients
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1.4 Working with AEM-NB

This chapter will outline the management activities and processes in the AEM-NB.
The main emphasis is on presenting everyday operation processes. The chapter
is structured with respect to the various network life cycle phases (see further be-
low).

There are 3 default user profiles: the administrator, maintenance and monitoring
profile. The rights belonging to these profiles are described in Chapter 1.4.4,
page 1-26.

The individual life cycle of a telecommunication network has the following phases:
planning, installation, provisioning, operation & surveillance, modification and fi-
nally decommissioning. Modification of a network may take the form of fine adjust-
ment, expansion or restructuring of the network, and addition of new functionality.

Figure 1-6 shows the life cycle of a network.

Figure 1-6 Life Cycle of a Network

The AEM-NB is mainly used in three life cycle phases: during network provision-
ing, network modification and network operation & surveillance. The installation
phase is supported by the Graphical System Interface (GSI).
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1.4.1 Network Planning and
Physical Installation

In the network planning phase, all specifications and requirements of the future
network operation are translated into a concrete network structure. That means,
the network planning phase, during which a decision on the network topology,
equipment and components is made, has to take place before the operation with
the AEM-NB starts.

The installation of the network follows the planning phase. The installation in-
cludes the following steps:

■ Physical NE installation.
This includes the installation of racks, plug-in units and cabling of the NEs

■ Creation of a DCN plan

Communication between the AEM-NB and the NEs is carried out via the
Data Communication Network (DCN). A DCN plan should be drawn up be-
fore provisioning the network to ensure that the AEM-NB can reach all NEs
and that the administration of the DCN does not lead to an undue increase
in performance requirements.

■ NE connection to the AEM-NB server

■ OS connection to the AEM-NB Server (optional)

■ Installation of the third-party, application and AEM-NB software on the
AEM-NB Server.

After completion of these steps, the network operator has at his disposal a net-
work which is connected physically with AEM-NB and which is, in principle, ready
for operation.
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1.4.2 Configuration Management

The Configuration Management in accordance with the specific operating condi-
tions of the network operator is performed by special provisioning actions. It is as-
sumed that the NEs and AEM-NB have already been physically connected.

Figure 1-7 provides an overview of the provisioning actions and the text which fol-
lows gives a detailed description.

Figure 1-7 Network Provisioning

Prior to equipment configuration and service provisioning, the NEs must be known
in the AEM-NB. To achieve this, the following 4 steps are necessary:

1. Creation of domains

2. Creation of NEs

3. Assignment of NEs to any domain(s)

4. Logical connection of NEs.

All steps are described in detail in Chapter 5.

NEs can be configured if they are known in the AEM-NB. The following measures
should be performed:

■ Selection of the timing synchronization source

■ Selection of the COMDAC (simplex/duplex) and IO-DS1 protection scheme

■ Selection of those slots for which an absence of the circuit pack will be
alarmed

■ Provisioning of the protection switching.
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All steps are described in detail in Chapter 5.

If the NEs are configured and integrated in the network, cross connections can be
defined. The following actions are necessary:

■ Creation of VRT/VB logical feeders

■ Changing of Voice Frequency Data Enhancement (VFDE) for TR-303
VRTs

■ Datalink Protection Switching for TR-303 VRTs

■ Creation of VRT/VB logical lines (Subscriber)

■ Cross-connection logical line to logical feeder.

All steps are described in detail in Chapter 5.

After the provisioning phase the NEs can now be controlled and monitored by the
AEM-NB and start operation & surveillance.

1.4.3 Network Operation & Surveillance

During network operation & surveillance, the administration, control and supervi-
sion of the network mainly include

■ Fault Management

■ Network Modification

■ Performance Monitoring.

The administrator rights are sufficient to perform all required operations. The vi-
sual check of parameters and displays on the GUI requires monitoring rights only.

1.4.3.1 Fault Management

There are two alarm types: alarms generated by the NEs and alarms generated
by AEM-NB itself, e.g. an alarm indicating that log files without archiving is being
removed (LOG_DEL_FULL). All alarms are displayed in the alarm viewer. It al-
lows the network operator to detect the alarm and to locate its source.

Figure 1-8, page 1-22 shows the general fault handling. In the following the indi-
vidual phases are described in more detail.

Service
Provisioning

Network Status
after Provisioning

Actions

Required
Rights

Alarm Types

General Fault
Handling



1-22 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Functional Description Working with AEM-NB

Figure 1-8 General Fault Handling

1.4.3.1.1 Fault Identification

AEM-NB gathers information about faults occurring in the network and forwards
this information to the network operator. This procedure includes two tasks: on the
one hand, the fault must be identified, and on the other hand, the fault information
must be processed as alarm notifications to be displayed on the user interface.

If a NE fault is detected, the NE notifies the AEM-NB. The notification comprises
the type of fault and the address of the originating NE. The AEM-NB detects and
processes such a notification automatically.
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If the unit of a NE fails that is responsible for the communication with the AEM-NB,
the fault is identified differently. No alarm notification will be sent to the AEM-NB.
The AEM-NB detects the fault by testing at regular intervals whether the associa-
tion to the particular NE is dropped. In this case the AEM-NB itself raises an
alarm.

A complete alarm overview and a detailed alarm description is provided by the
alarm viewer. All relevant alarm data (e.g. alarm severity) are shown.

The AEM-NB keeps alarm logs to store the alarm notifications. Alarm logs are
used among other things for long-term observations, e.g. of the fault behaviour in
the network. Alarm logs exist for pending alarms, for the alarm history and for
clock events in the network.

1.4.3.1.2 Fault Localisation and Diagnosis

When a fault has been detected, it is necessary to localise its source and diag-
nose its cause in order to initiate appropriate repair procedures. To locate the
cause of fault, the AEM-NB provides information gathered from alarm notifications
and general network data.

Each alarm notification contains the name of the network component from which it
originates. This network component, however, need not always be the real fault
source.

1.4.3.1.3 Fault Clearance

The AEM-NB detects faults automatically and clears various software errors by it-
self (fault recovery). The transmission characteristics of the network will not be im-
paired by this.

System Recovery protects the AEM-NB and associated users from unnecessary
problems and avoids or reduces manual work.

Recovery processes vary depending on the type of failure that occurred, the struc-
tures affected, and the type of recovery. If no files are lost or damaged, recovery
may amount to no more than restarting an instance. If data has been lost, recov-
ery requires additional steps, such as database restore using a previous backup.

AEM-NB recovery mechanisms are initiated mainly by the following situations:

■ NE software crash

■ AEM-NB crash

■ Communication between AEM-NB and a NE is interrupted.

In the case of a NE crash, the AEM-NB configures NEs in accordance with the in-
ternal state of the AEM-NB database. In the event of a AEM-NB crash or an inter-
ruption in communication, the AEM-NB downloads the current NE configuration
from the NE to its database.
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Faults (software or hardware), the cause of which the AEM-NB cannot eliminate it-
self by means of a recovery mechanism, must then be handled by the user. The
AEM-NB supports this. The AEM-NB first displays the fault on the user interface.
The user then initiates appropriate measures to clear the fault and/or to maintain
network operation. This includes access to faulty network units and the redirection
of the network traffic. The AEM-NB supports both.

Sometimes, additional maintenance actions are necessary to clear a fault. For ex-
ample, some network disturbances can also originate in hardware faults. Such
hardware faults often require the faulty component to be replaced, and this can
only be done by maintenance personnel.

NOTE:
More detailed information about maintenance actions is provided in Chap-
ter 6.

Once the fault has been cleared, the alarm is reset automatically.

1.4.3.2 Network Modification

Usually, network operation & surveillance requires structural modifications in the
network. The AEM-NB supports this. There are two types of network modifica-
tions:

■ Installation or removal of NEs

■ Modification of NEs.

1.4.3.2.1 Installation and Removal of a NE

For installing a new NE in an existing network the following steps must be carried
out:

1. Check whether the new NE can be incorporated in the existing DCN plan
drawn up in the network planning phase (if not, the DCN plan must first be
revised)

2. Creation of the NE

3. Assignment of the NE to a domain

4. Logical connection of the NE

5. Selection of the timing synchronization source

6. Selection of the COMDAC protection scheme (simplex/duplex)

7. Selection of those slots for which an absence of the circuit pack will be
alarmed.

All steps are described in detail in Chapter 5.
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If an NE is no longer be managed by the AEM-NB, the administrator deletes it
from the AEM-NB database.

NOTE:
When an NE is deleted from the AEM-NB database, it is still fully functional.
The TL1 and TCP/IP links between the AEM-NB and the NE will be closed
and the management access via the AEM-NB is not possible until the NE is
created and connected again.

1.4.3.2.2 Modification of NEs

NEs can be modified by adding or removing plug-in units. The AEM-NB recogn-
ises automatically which plug-in unit has been plugged and where. As only default
settings are set on the new plug-in unit, the system administrator must adapt the
configuration.

When deleting a plug-in unit, it must be ensured that there are no connections
running via this unit. Then the plug-in unit may be removed.

1.4.3.3 Performance Monitoring

Performance management guarantees that the transmission quality does not fall
below a minimum performance threshold. Another task is the recording of data for
analysis at a later date.

Removal of a NE
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Plug-in Unit

Tasks of
Performance
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1.4.4 System Security and User Groups

The AEM-NB provides mechanisms which protect the system from unauthorised
access. The user groups play a very important role in this context as they define
different levels of access rights for the individual users.

By default there are 3 user groups: the administrator, maintenance and monitoring
user group. Further groups can be added.

Table 1-1 provides an overview of the access permissions the user groups should
have.

Table 1-1 Assignment of User Groups to Applications/Tasks

Application Task User Group

System
Administration

Start-up / Shutdown Administrator

Monitoring Administrator

User Administration
and Profiling

Access Policy
Management

Administrator

Domain Management Administrator

Log Viewer Actions Administrator, Maintenance

System Internal Events Administrator, Maintenance

Autonomous Report Administrator, Maintenance,
Monitoring

Alarm Viewer Acknowledge Administrator, Maintenance

View Administrator, Maintenance,
Monitoring

Clear Administrator, Maintenance

Configuration
Manager

NE Creation Administrator, Maintenance

Equipment and
Service Provisioning

Administrator, Maintenance

View Administrator, Maintenance,
Monitoring

Test Administrator, Maintenance,
Monitoring

Cut-through Administrator

BroadBand EM BroadBand EM Administrator, Maintenance,
Monitoring

Protection from
Unauthorised
Access

User Groups

Access Rights
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1.5 Network Configuration

The network configuration depends on the user applications. The most probable
configurations are described below and illustrated in Figure 1-9 to Figure 1-12.

NOTE:
If there are various configuration options of the DCN, these are shown in
the figures by means of dashed lines. The hubs are optional depending on
the number of client platforms and NEs.

1.5.1 AEM-NB Server without Clients and
external OS (LAN)

AEM-NB server connected to the NEs using a Local Area Network (LAN).

Figure 1-9 AEM-NB Server without Clients and external OS (LAN)
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1.5.2 AEM-NB Server with Clients and
without external OS (LAN)

AEM-NB server and one or more clients connected to the NEs using a LAN.

Figure 1-10 AEM-NB Server with Clients and without external OS (LAN)
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1.5.3 AEM-NB Server without Clients and
with external OS (WAN)

AEM-NB server connected to the NEs using a LAN and connected to one or more
external OSs using a WAN link.

Figure 1-11 AEM-NB Server without Clients and with external OS (WAN)
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1.5.4 AEM-NB Server with Clients and ex-
ternal OS (WAN)

AEM-NB server and one or more clients connected to the NEs using a WAN link
and connected to one ore more external OSs using a LAN connection.

Figure 1-12 AEM-NB Server with Clients and external OS (WAN)
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2.1 General

The AEM-NB R1.5 (AnyMedia® Access System Element Manager for Narrow-
band Services, Release 1.5) runs on SUN SPARC Solaris 2 computers running
Solaris 2.5.1 plus security and Y2000 patches and patch 106255-01 recom-
mended by SUN.

In order to successfully install the AEM-NB R1.5 for the SUN Solaris installation
the following has to be taken into account:

■ Disk partitioning :
HDD partitioning should include, in addition to the standard UNIX entries
(e.g. /, /usr, /var, etc.), two entries for the AEM-NB software and the trans-
action.log (cf. Chapter 2.1.1, page 2-2 for size requirements).

■ Swap space :
In addition to the SUN recommendation (at least double the size of the
RAM memory should be used for swap), 100MB per platform should be
configured for OODBMS requirements.

■ NIS:
If more than one AEM-NB platform is to be used, NIS should be configured
in the server, so all the AEM-NB clients will share the logins and password
which are configured in the server tables. All the users require a NOT null
password in order to manage AEM-NB.

■ NFS:
Network File Sharing is not required even when using a LAN, but if NIS is
used, NFS allows operators to log-in in any client platform having access to
their home directories.

■ SUN patches :
All the Solaris patches described in the shopping list must be installed be-
fore AEM-NB installation
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■ LAN & WAN configuration :
E.g. default router to NEs, etc. must be available.

How to install SUN Solaris is described in SUN support/SUN Solaris Installation
Guide.

For the following description it is assumed that

■ The hardware required to install the AEM-NB R1.5 (AnyMedia® Element
Manager for Narrowband Services, R1.5) is prepared

■ The AEM-NB R1.5 consists of a number of server and client applications.
The software install may imply the installation of all these applications or
only some of them.

■ The AEM-NB R1.5 includes as part of its environment the Java Runtime
Environment (JRE) Release 1.1.7. JRE is included here free of charge for
the final user.

2.1.1 Introduction

This document is intended as a guide for the person(s) who will be responsible for
the installation and configuration of the hardware and software required for the
AEM-NB R1.5 installation.

The AEM-NB R1.5 runs on Sun SPARC Solaris 2 computers running Solaris 2.5.1
plus security and Y2000 patches and 106255-01 patch recommended by SUN.

The AnyMedia distribution can be divided into two parts, Server side installation
and Client side installation. Both include the specific Third-party applications
needed to run the AnyMedia successfully.

To store the AEM-NB R1.5 files, your system must have the following amount of
free disk space:

■ AEM-NB client: 60 MB

■ AEM-NB server: The space will depend upon the number of NEs managed
by the system because of the data size. The recommended size for n NEs
is obtained from adding the following (numbers in kbyte):

software=450000

logs=15000

databases=1400+600*n

transactions=2*(800+350*n)+n+25%

The size calculated is based on maximum configurations and includes the
overhead necessary for the temporary data used in operation.

It is recommended to create a separate partition to locate the transaction log file
needed by ObjectStore. This partition would be used for this purpose only. It must
not be deleted or managed because this file is only created and managed by Ob-

Assumptions

JRE

System Require-
ments

Disk Space
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jectStore. Note that without this file ObjectStore is not able to work and also if a
new partition or location is chosen, it needs write permissions for the AnyMedia
user (login). If you choose a directory under AnyMedia location the correct owner
and permits will be automatically provided in the installation process of AnyMedia.

The following table shows the recommended size of the partitions for a maximum
of 10, 40 and 100 NEs:

where /part1 contains all the AEM-NB server software and data bases and the
/part2 is dedicated to the transaction log.

The AEM-NB R 1.5 distribution media is on CD-ROM and the defaults installation
directories are /opt/lucent/Application_name (refer to Table 2-1, page 2-4 for more
information about application names).

The AEM-NB R1.5 distribution is divided into eleven packages, as follows:

■ AnyMedia Servers

■ AnyMedia Client <GUI>

■ AnyMedia Help

■ OrbixMT2.3c patch 02

■ OrbixTalk1.2c patch 02

■ OrbixNames1.1c

■ OrbixWeb 3.0

■ ObjectStore5.0

■ jre1.1.7+symantec+ReportPro

■ LUMOS build 5

■ RogueWave 1.5.7 & 1.1.2

which were built using the Application Packaging tools offered by Solaris (refer to
your SUN documentation for more information).

NEs /part 1 /part 2

10  475 MB 11 MB

40 500 MB 37 MB

100  530 MB 100 MB

Distribution Media
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A package contains a collection of files and directories required for the application
and scripts to control how, where and if the package is installed.

NOTE:
RT describes a Run Time application version.

In order to successfully install the AEM-NB R1.5 Client side, the application
Netscape 4.5 shall  be already installed on the target system.

TCP ports:
The following ports must  be available in order to successfully run the AEM-NB
R1.5:

■ 1570: Orbix daemon uses the TCP port 1570 in order to wait for incoming
connections that use the Orbix protocol.

■ 1591 to 1641: As Corba servers are activated by the Orbix daemon, they
are assigned a port so that clients can communicate with it.

■ OrbixTalk uses two ports for communications. These ports have as default
values "5000" and the next one. The first can be modified at installation
time to a value between 1024 and 65534. It is essential that these ports are
not used by any process on the SAME SUBNET DOMAIN.

IP multicast addresses:
Using OrbixTalk, all communications takes place using multicast addresses. The
range of IP multicast addresses used by OrbixTalk is 31 with 255.0.0.0 as the first
IP address (it is configurable at installation time in the range 255.0.0.0 to
239.255.255.255).

Table 2-1 AEM-NB R1.5 distribution description

Package Name Application Name

LuANY16S AnyMedia Servers

LuANY16C AnyMedia Clients

LuANY16en AnyMedia Help

LuLUMRT Lumos build 5 RT

LuOXNSRT OrbixNames 1.1c RT

LuOX23RT OrbixMT 2.3c pacth02 RT

LuOSRT ObjectStore 5.0 RT

LuOXTKRT OrbixTalk 1.2c patch02 RT

LuOXWRT OrbixWeb 3.0 RT

LuRWRT RogueWave 1.5.7 & 1.1.2 RT

LuJRERT jre 1.1.7 + symantec + ReportPro

Pre-requisites
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The time zone must  be the same for the AnyMedia Client <GUI>, LUMOS, Net-
work Element and OS. This parameter is needed for installing the AnyMedia Cli-
ent.

The install_AMEMR15 script runs on K-shell <ksh> environment.

At least the system environment variable PATH must  include the paths "/usr/bin"
"/usr/sbin" and "/usr/ucb"
(for instance, "export PATH = $PATH:/usr/bin/:/usr/sbin:/usr/ucb")

2.2 Installation Procedure

The AEM-NB R1.5 distribution includes an installation script called
Install_AMEMR15  which shall be used in a full installation - it includes all pack-
ages stored on the distribution media -. Also, you can make individual package in-
stallations using the pkgadd  command. In this case, you must be very careful
with the packages dependencies showed in “Packages dependencies” on
page 37.

This guide shows the flow of the installation - according to the interaction with the
administrator - using the installation script provided in the distribution and using
the pkgadd  command for individual installations.

Common actions must be make in both cases, as follows:

■ You need to be logged on as root .

■ Get ready your distribution medium:

Insert and mount the CD. If the machine is running the vold, it will recogn-
ise that the CD is in place and mount it on /cdrom/AnyMediaNBEMR15
(depending on your system configuration, /cdrom/AnyMediaNBEMR15
might have to be replaced with a different device name). Depending on the
configuration of vold  you may have to append a trailing dot (“.”) to refer-
ences to filenames on the CD. This is due to hsfs imposing a suffix on the
filenames. If the machine is not running the vold , type:

# mount -F hsfs -o ro,notraildot
/dev/dsk/c0t6d0s2/cdrom

The device identifier c0t6d0s2 is configuration dependent, and as such will
vary from machine to machine.
This will mount the CD on /cdrom  (depending on your system configura-
tion, /cdrom  might have to be replaced with a different mount point. For
more information about on how to mount a CD-ROM drive refer to your
SUN documentation.

■ A new user shall be created on the target system, who will be the user
owner of the AEM-NB R1.5 files.

General

Common Tasks

Insert and Mount
the CDROM
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2.2.1 Full Installation

This type of installation uses the Install_AMEMR15 script in order to install all
packages contained in the distribution.

For the following description it is assumed that:

■ The hardware and software requirements to install the AEM-NB R1.5 are
prepared

■ AEM-NB R1.5 software have not been installed previously.

■ Common actions showed above have been made

Complete the following procedure to install the AEM-NB R1.5 application

NOTE:
Lines with indentation and quoted are the system responses. They are in-
cluded here to guide the installation procedure.

2.2.1.1 Server side installation

Complete the following procedure to install the AnyMedia server side.

Step Procedure

1. Go to the directory where the installation script is placed (cdrom or disk)

2. Type "./Install_AMEMR15"  and press Return .

AnyMedia NB EM R1.5 installation
CopyRight (c) 1999 Lucent Technologies, Inc.
All Rights Reserved

**Pre-requisites**

1.- Before attempting to install the applica
tion, please,read the readme.txt file.

2.- AnyMedia NB EM R1.5 runs on SUN SPARC So
laris 2 computers running Solaris 2.5.1 plus se
curity and Y2000 patches recommended by SUN and
106255-01 patch.

3.- TCP ports:
The following ports MUST be available in order
to succesfully run the AnyMedia EM:
* 1570: Orbix daemon uses the TCP port 1570 in
order to wait for incoming connections that use
the Orbix protocol.

Procedure
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* 1591 to 1641: As Corba servers are activated
by the Orbix daemon, they are assigned a port so
that clients can communicate with it.
* OrbixTalk uses two ports for communications.
These ports have as default values "5000" and
the next one. The first can be modified
at installation time to a value between 1024 and

65534.It is essential that these ports are not
used by any process on the SAME SUBNET DOMAIN.

4.- IP multicast adresses:
Using OrbixTalk, all communications takes place
using multicast addresses. The range of IP mul
ticast addresses used by OrbixTalk is 31 with
255.0.0.0 as the first IP address (it is config
urable at installation time in the range
255.0.0.0 to 239.255.255.255)

5.- The Install_AMEMR15 script runs on K-shell
<ksh> environment.

6.- At least the system environment variable
PATH MUST include the paths "/usr/bin",
"/usr/sbin" and "/usr/ucb" (for instance,
"export PATH=$PATH: /usr/bin/ :/usr/sbin: /usr/
ucb").

7.- The time zone MUST be the same for the Any
Media Client <GUI>, LUMOS and Network Element.
This parameter is needed for installing the Any
Media Client.

******************

Do you like to continue [y,n,?,q]

3. Type "y" and press Return  to continue or type "n" or "q" and press Re-
turn  to exit.

"AnyMedia NB EM R1.5 installation"

"CopyRight (c) 1999 Lucent Technologies, Inc."

"All Rights Reserved."

"Please, choose the installation mode"

"  1  Client     <Client side installation>"

"  2  Server     <Server side installation>"

"Enter selection [?,??,q]:"
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NOTE:
Type ? to get help, type ?? to repeat the prompt and type q to exit from the
installation.

4. Type "2"  and press Return .

"Transferring <LuLUMRT> package instance"

"Transferring <LuRWRT> package instance"

"Transferring <LuOX23RT> package instance"

"Transferring <LuOXNS> package instance"

"Transferring <LuOXTKRT> package instance"

"Transferring <LuOSRT> package instance"

"Processing package instance <LuLUMRT> from
</tmp/lucent_pkg/1>"

"Lumos Runtime for AnyMedia NB-EM R1.5"

"(sparc-solaris) Build 5 run-time"

"OK, No previous package LuLUMRT have been
found."

"Enter install directory [/opt/lucent/LUMOS]
[?,q] "

5. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Checking your DNS domain name... "

"done."

"What is your DNS domain name  [default: es.lu
cent.com]  [?,q]"

6. Type your DNS domain name and press Return (press Return  to se-
lect default).

LUMOS Build 5 In-
stallation
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NOTE:
A list of DNS user:group items of the target system is displayed (for in-
stance, anymedia:lucent). This provides information to select an user owner
and a group owner for packages files.

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

7. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuLUMRT> [y,n,?]"
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8. Type "y"  and press Return .

"Installing Lumos Runtime for AnyMedia NB-EM
R1.5 as <LuLUMRT>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <none> ]"

"## Executing postinstall script."

"You have the installation logfile in
/tmp/EM_Install_LuLUMRT.log"

"Installation of <LuLUMRT> was successful."

"Processing package instance <LuRWRT> from
</tmp/lucent_pkg/2>"

"RogueWave Tools & Threads Runtimes for AnyMedi
aNBEM R1.5"

"(sparc) 7.0.7 & 1.1.2"

"OK, No previous package LuRWRT have been
found."

"Enter install directory [/opt/lucent/rw] [?,q]"

9. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

10. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

RogueWave 1.5.7 &
1.1.2 Installation
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"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuRWRT> [y,n,?]"

11. Type "y"  and press Return .

"Installing RogueWave Tools & Threads Runtimes
for AnyMediaNBEM R1.5 as <LuRWRT>"

"## Installing part 1 of 1. "

"<files list>"

“[ verifying class <none> ]"

"## Executing postinstall script."

"You have the installation logfile in
/tmp/EM_Install_LuRWRT.log"

"Installation of <LuRWRT> was successful."

"Processing package instance <LuOX23RT> from
</tmp/lucent_pkg/3>"

"Orbix 2.3c02 Runtime for AnyMedia NB-EM R1.5"

"(sparc-solaris) Version 2.3c02MT Run-Time"

"OK, No previous package LuOX23RT have been
found."

NOTE:
A list of partitions and free space is displayed

"Here is a list of your partitions and the free
space in each of them:"

"Filesystem kbytes used avail capacity Mounted
on"

"<information about your partitions and free
space>"

"Where should Orbix be installed? [/opt/lu
cent/OrbixMT_2.3c2] [?,q] "

12. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

OrbixMT 2.3c patch
02 Installation
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"If you intend to use Orbix to communicate with
anything outside"

"your own subnet, you will need to supply your
subnet’s domain name."

"If your machines all have fully-qualified host
names, reply with the value "null"."

"What is your domain name? [es.lucent.com] "

13. Type your domain name and press Return  or reply null if all machines
have fully-qualified host names (press Return  to accept default).

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

14. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuOX23RT> [y,n,?]"

15. Type "y"  and press Return .

"Installing Orbix 2.3c02 Runtime for AnyMedia
NB-EM R1.5 as <LuOX23RT>"

"## Installing part 1 of 1. "

"<files list>"
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"[ verifying class <bin> ]"

"<files list>"

"[ verifying class <cfg> ]"

"<files list>"

"[ verifying class <lib> ]"

"## Executing postinstall script."

"You have the installation logfile in
/tmp/EM_Install_LuOX23RT.log"

"Installation of <LuOX23RT> was successful."

"Processing package instance <LuOXNS> from
</tmp/lucent_pkg/4>"

"OrbixNames 1.1c Runtime for AnyMedia NB-EM
R1.5"

"(sparc-solaris) Version 1.1c Run-Time"

"OK, No previous package LuOXNS have been
found."

"Package <LuOX23RT> OrbixMT Version 2.3c02MT
Run-Time have been found in <OrbixMT path>"

"Where should OrbixNames be installed? [/opt/lu
cent/OrbixNames1.1c][?,q] "

16. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Multi-threaded Orbix installation detected, is
this correct? [y] [y,n,?] "

17. Type "y"  and press Return .

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

18. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

OrbixNames 1.1c
Installation
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"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuOXNS> [y,n,?]"

19. Type "y"  and press Return .

"Installing OrbixNames 1.1c Runtime for AnyMedia

NB-EM R1.5 as <LuOXNS>"

"## Installing part 1 of 1."

"[ verifying class <names> ]"

"<files list>"

"[ verifying class <bin> ]"

"<files list>"

"[ verifying class <lib> ]"

"## Executing postinstall script."

"---------------------------------------------"
"Okay, OrbixNames is now installed."

"You have the installation logfile in
/tmp/EM_Install_LuOXNS.log"

"Installation of <LuOXNS> was successful."

"Processing package instance <LuOXTKRT> from
</tmp/lucent_pkg/5>"

"OrbixTalk 1.2c02 Runtime for AnyMedia NB-EM
R1.5"

"(sparc-solaris) 1.2c02"

"OrbixTalk Installation details:"

"Version:   1.2c02"

"Platform:  Solaris 2.x"

OrbixTalk 1.2 c
patch02 Installation
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"Compiler:  WorkShop Compilers 4.2 30 Oct 1996
C++ 4.2"

"To install OrbixTalk1.2c you must already
have Orbix2.3c installed. "

"If this is not the case please exit now."

"If you already have OrbixTalk on your system,
this installation may overwrite some of the
files. Make sure you have a backup of your old
OrbixTalk, or install this new version in a new
set of directories. If you want to make a backup
copy of the old version, you should exit now."

"It is recommended that you read the installa
tion guide before you continue."

"Do you want to continue? [y]:"

20. Type "y"  and press Return .

"OK, No previous package LuOXTKRT have been
found."

"Package <LuOX23RT> OrbixMT Version 2.3c02MT
Run-Time have been found in <OrbixMT path>"

NOTE:
A list of partitions and free space is displayed.

"Here is a list of your partitions and the free
space in each of them:"

"Filesystem kbytes used avail capacity Mounted
on"

"<information about your partitions and free
space>"

"Where should the main OrbixTalk software dis
tribution be installed?[/opt/lu
cent/OrbixTalk1.2c02] "

21. Type a valid path where the package files must be placed and press Re-
turn (press Return  to select default).

"Which UDP/IP port should the OrbixTalk Direc
tory Enquiries daemon use?"
"OrbixTalk requires that you reserve a range of
AT LEAST 2 ports starting at this port? [5000]"
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22. Type a valid UDP/IP port and press Return  (press Return  to select de-
fault).

"The OrbixTalk Directory Enquiries daemon as
signs individual Topics an IP Multicast address
starting with the next address above the base IP
address. What base IP Multicast address ( within
the range 225.0.0.0 to 239.255.255.255 ) should
the OrbixTalk Directory Enquiries daemon
use?[225.0.0.0]"

23. Type a valid IP multicast address and press Return  (press Return  to
select default).

"What directory should the OrbixTalk data files
be stored? [/opt/lucent/OrbixTalk1.2c02/dat]"

24. Type a valid path (for instance <OrbixTalk path>/dat  where the
package files must be placed and press Return (press Return to select
default).

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

25. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuOXTKRT> [y,n,?]"
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26. Type "y"  and press Return .

"Installing OrbixTalk 1.2c02 Runtime for AnyMe
dia NB-EM R1.5 as <LuOXTKRT>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <bin> ]"

"<files list>"

"[ verifying class <lib> ]"

"<files list>"

"[ verifying class <raw> ]"

"## Executing postinstall script."

"* Making backing copy of the orbix configura
tion file <OrbixMT path>/cfg/Orbix.cfg" to "<Or
bixMT path>/cfg/Orbix.cfg.old""

"* Licence registration was accepted for otd."

"* Licence registration was accepted for otmsd."

"* Licence registration was accepted for otdsm."

"*******************************************"

"*  INSTALLATION WARNINGS:"

"*"

"* For Orbix and OrbixTalk to be able to find Or
bix.cfg, you must set the environment variable
IT_CONFIG_PATH to its location,ie. "<OrbixMT
path>/cfg/Orbix.cfg"."

"* If the OrbixTalk binaries fail with the mes
sage "password" invalid""

"The licence install utility will need to be run
manually. Enter the following command: "

" <OrbixMT path>/bin/install_licence <OrbixTalk
path>/bin/otd <code>"

"* OrbixTalk 1.2c02 is now successfully in
stalled."

"You have the installation logfile in
/tmp/EM_Install_LuOXTKRT.log"

"Installation of <LuOXTKRT> was successful."
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"Processing package instance <LuOSRT> from
</tmp/lucent_pkg/6>"

"ObjectStore 5.0_SP3 Runtime for AnyMedia NB-EM
R1.5"

"(sparc-solaris) 5.0_SP3 Run-Time"

"Enter install directory [/opt/lucent/OS50_SP3]
[?,q]"

27. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default)

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"The following files are being installed with
setuid and/or setgid permissions: <ObjectStore
path>/sunpro/lib/oscminit <setuid root>"

"Do you want to install these as setuid/setgid
files [y,n,?,q]"

28. Type "y"  and press Return .

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuOSRT> [y,n,?]"

29. Type "y"  and press Return .

"Installing ObjectStore 5.0_SP3 Runtime for Any
Media NB-EM R1.5 as <LuOSRT>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <none> ]"

"## Executing postinstall script."

"********************************************"

ObjectStore 5.0 In-
stallation
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" * Remember execute "osconfig" to set the envi
ronment *"
"******************************************"

" You have the installation logfile in
/tmp/EM_Install_LuOSRT.log"

"Installation of <LuOSRT> was successful."

"Object Store configuration"

"The default copy of ObjectStore to configure is
in <ObjectStore path>/sunpro."

"Is this the copy that you want to configure?
[yes]"

30. Press Return .

"ObjectStore includes shared libraries. For Ob
jectStore applications and utilities to work,
the dynamic linker must be able to find them."

"The recommended arrangement is to have symbolic
links in /usr/lib to the shared libraries."

"If you choose not to make these links, then you
will have to instruct all ObjectStore users to
add <ObjectStore path>/sunpro/lib to their
LD_LIBRARY_PATH environment variable."

"Do you want to create links to ObjectStore li
braries in /usr/lib? [yes]"

31. Press Return .

"Since you have requested a File-database con
figuration,you must give a pathname for the
transaction log file. Where do you want to put
the transaction log?"

32. Type a valid path (for instance <ObjectStore path>/transac-
tion.log ) where the package files must be placed and press Return
(press Return  to select default)

"You have configured this machine to run an Ob
jectStore server. The server’s transaction log
is in <Transaction log path>."

"Do you want to proceed? [yes]"

33. Press Return .

ObjectStore Config-
uration
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"Writing configuration files and initializing
the server, please"

"wait..."

"990423 111330 ObjectStore Release 5.0 Service
Pack 3 Database Server"

"ObjectStore includes a server daemon which must
be running for any application to access an Ob
jectStore database."

"It is recommended that you auto-start the dae
mon via commands in your operating system star
tup scripts. If you do not configure automatic
startup, you will have to start the server dae
mon by hand,or re-run this utility to configure
auto-start."

"Would you like to configure automatic server
startup and shutdown? [yes]"

34. Press Return .

"Successfully created /etc/rc2.d/S80ostore4."

"Successfully created link from
/etc/rc2.d/K80ostore4 to /etc/rc2.d/S80ostore4."

"Note that you must manually remove or edit ex
isting ObjectStore R3 scripts in /etc/rc2.d in
some situations:"

"To run only R4 clients or R3 file database cli
ents, remove all R3 scripts in /etc/rc2.d."

"To run all R4 clients and R3 clients, including
R3 rawfs clients, edit existing R3 scripts in
/etc/rc2.d to run only the R3 Directory Manager,
but not the R3 Server."

"To run both R3 and R4 clients with separate R3
and R4 Servers, see the documentation on editing
your OS_ROOTDIR/etc/ports file."

"This script will now verify the installation:"

"The ObjectStore Server daemon process is acces
sible. Schema databases are accessible."

"The cache manager launcher for release 4 (<Ob
jectStore path>/sunpro/lib/oscminit) has correct
modes and ownership."

"ObjectStore configuration completed."

"Transferring <LuANY16S> package instance"

AnyMedia Servers
Installation
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"Processing package instance <LuANY16S> from
</tmp/lucent_pkg/1>"

"AnyMedia NB Element Manager Release 1.5
(server)"

"(sparc) LuANY16S_X.Xc"

"**************************************"

"*AnyMedia Element Manager *"

"*(c) 1999-Lucent Technologies *"
"***************************************

"OK, No previous package LuANY16S have been
found."

"***Select an installation path for AnyMediaEM
R1.5 server applications***"

"Enter install directory for the AnyMediaEM
R1.5 [/opt/lucent/AnyMediaNBEM_R1.5] [?,q] "

35. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"The installation path selected for AnyMedia EM
R1.5 is <Server path>"

"Package <LuOX23RT> OrbixMT Version 2.3c02MT
Run-Time have been found in <OrbixMT path>"

"Package <LuOXTKRT> OrbixTalk 1.2c02 have been
found in <OrbixTalk path>"

"Package <LuOXTKRT> OTGateway 1.2c02 have been
found in <OrbixTalk path>"

"Package <LuOXNS> OrbixNames Version 1.1c Run-
Time have been found in <OrbixNames path>"

"Package <LuOSRT> ObjectStore 5.0_SP3 Run-Time
have been found in <ObjectStore path>"

"Package <LuLUMRT> Lumos Build 5 run-time have
been found in <Lumos path>"

"Package <LuRWRT> RogueWave Tools and Threads
7.0.7 & 1.1.2 have been found in <RogueWave
path>"

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "
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"  ....    "

"Enter selection [?,??,q]:"

36. Type a user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"***Boot processes***"

"Do you like install the SystemAdmin process on
the system boot [y,n,?,q]"

37. Type "y"  to confirm and press Return  or type "n"  to do nothing on the
system.

NOTE:
If you select "y"  the following request is displayed.

"Start-up MODE"

" 1 ALL to start-up all AnyMedia applications"

"  2  CORE to start-up only core AnyMedia appli
cations"

"Enter selection [?,??,q]:"

38. Type the desired Start-up more < 1 or 2 >

"****cron processes****"

"RemoveAlm cron process will be executed every
day at 3.00 AM. Do you like change it [y,n,?,q]"

39. Type "y" to confirm and press Return or type "n" and press Return to
do nothing on the system.

NOTE:
If you select "y" the following requests are displayed.

"Enter minute (0-59,*):  [?,q]"

40. Type a valid entry.

"Enter hour   (0-23,*):  [?,q]"

41. Type a valid entry

"Enter day of the month (1-31,*):  [?,q]"
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42. Type a valid entry.

"Enter month of the year (1-12,*):  [?,q]"

43. Type a valid entry.

"Enter day of the week (0-6 with 0=Sunday,*):
[?,q]"

44. Type a valid entry.

"Do you like install the Backup process as a
cron [y,n,?,q]"

45. Type "y" to confirm and press Return or type "n" and press Return to
do nothing on the system.

NOTE:
If you select "y"  refer to steps 38 - 41.

"Do you like install the Archive process as a
cron [y,n,?,q]"

46. Type "y" to confirm and press Return or type "n" and press Return to
do nothing on the system.

NOTE:
If you select "y"  refer to steps 38 - 41.

"Clean-up tasks for the AnyMediaNB-EM system
will be executed every"

"day at 4.00 AM. Do you like change it
[y,n,?,q]"

47. Type "y" to confirm and press Return or type "n" and press Return to
do nothing on the system.

NOTE:
If you select "y"  refer to steps 38 - 41.

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."
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"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuANY16S> [y,n,?]"

48. Type "y"  and press Return .

"Installing AnyMedia NB Element Manager Release
1.5 (server) as <LuANY16S>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <common> ]"

"<files list>"

"[ verifying class <channels_24> ]"

"## Executing postinstall script."

"Starting orbixd daemon in the system"

"Starting ns daemon in the system"

"[ s1224: OrbixNames (Release 1.1) ]"

"[ s1369: OrbixOTM package (Release 1.5) ]"

"Checking AnyMedia EM R1.5 naming contexts"

"Starting CreateNEM_db process..."

"Getting the AnyMedia installation path..."

"OK"

"Getting NEM data base path"

"OK"

"Creating NEM Data Base"

"OK"

"exit OK"

"Starting CreateCMR12_db process..."

"Getting the AnyMedia installation path..."

"OK"

"Getting CM R1.2 data base path"

"OK"

"Creating CM R1.2 Data Base"
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"OK"

"exit OK"

"Starting AMDbPopulate process..."

"Getting the AnyMedia installation path..."

"OK"

"Getting Alarm data base path"

"OK"

"Creating Alarm Data Base..."

"Creating os_Collection<HostElement*>..."

"Creating ListOfAlarmsPerHost ..."

"Creating segment and ElementManager Host
(0)..."

"OK"

"exit OK"

"Getting the AnyMedia installation path..."

"Getting OAM Security data base path"

"OK"

"Creating Database"

"Registering Servers in the Orbix Implementation
Repository"

""

"[20948: New Connection"

"(<hostname>. <domain_name>, IT_daemon,*,root,
pid=<pid>,optimised) ]"

"[20949: New Connection"

"(<host name>.<domain_name>,IT_daemon, *,root
,pid=<pid>,optimised) ]"

"[20950: New Connection"

...

"<pid> Killed"

"orbixd daemon pid=<pid> have been killed. Was
mine."

"20846 Killed"

"ns daemon pid=20846 have been killed. Was
mine."

"*****************************************"
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"* Execute ". AnyMediaNBEM.sh" to set the envi
ronment *"

"*****************************************"

"You have the installation logfile in <Server
path>/tmp/EM_Install.log"

"Installation of <LuANY16S> was successful."

"Installation of AnyMedia EM R1.5 was successful
<Server side installation>"

2.2.1.2 Client side installation

Complete the following procedure to install the AnyMedia client side.

Step Procedure

49. Go to the directory where the installation script is placed (cdrom or disk).

50. Type "./Install_AMEMR15"  and press Return .

AnyMedia NB EM R1.5 installation
CopyRight (c) 1999 Lucent Technologies, Inc.
All Rights Reserved

**Pre-requisites**

1.- Before attempting to install the applica
tion, please,read the readme.txt file.

2.- AnyMedia NB EM R1.5 runs on SUN SPARC So
laris 2 computers running Solaris 2.5.1 plus se
curity and Y2000 patches recommended by SUN and
106255-01 patch.

3.- TCP ports:
The following ports MUST be available in order
to succesfully run the AnyMedia EM:
* 1570: Orbix daemon uses the TCP port 1570 in
order to wait for incoming connections that use
the Orbix protocol.
* 1591 to 1641: As Corba servers are activated
by the Orbix daemon, they are assigned a port so
that clients can communicate with it.
* OrbixTalk uses two ports for communications.
These ports have as default values "5000" and
the next one. The first can be modified
at installation time to a value between 1024 and
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65534.It is essential that these ports are not
used by any process on the SAME SUBNET DOMAIN.

4.- IP multicast adresses:
Using OrbixTalk, all communications takes place
using multicast addresses. The range of IP mul
ticast addresses used by OrbixTalk is 31 with
255.0.0.0 as the first IP address (it is config
urable at installation time in the range
255.0.0.0 to 239.255.255.255)

5.- The Install_AMEMR15 script runs on K-shell
<ksh> environment.

6.- At least the system environment variable
PATH MUST include the paths "/usr/bin",
"/usr/sbin" and "/usr/ucb" (for instance,
"export PATH=$PATH: /usr/bin/ :/usr/sbin: /usr/
ucb").

7.- The time zone MUST be the same for the Any
Media Client <GUI>, LUMOS and Network Element.
This parameter is needed for installing the Any
Media Client.

******************

Do you like to continue [y,n,?,q]

51. Type "y" and press Return  to continue or type "n" or "q" and press Re-
turn  to exit.

"AnyMedia NB EM R1.5 installation"

"CopyRight (c) 1999 Lucent Technologies, Inc."

"All Rights Reserved."

"Please, choose the installation mode"

"  1  Client     <Client side installation>"

"  2  Server     <Server side installation>"

"Enter selection [?,??,q]:"

52. Type "1"  and press Return .

"Transferring <LuJRERT> package instance"

"Transferring <LuOXWRT> package instance"

"Transferring <LuANY16en> package instance"
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"Transferring <LuANY16C> package instance"

"Processing package instance <LuJRERT> from
</tmp/lucent_pkg/1>"

"JRE 1.1.7 for AnyMediaNBEM R1.5"

"(sparc-solaris) 1.1.7"

"OK, No previous package LuJRERT have been
found."

"Applications to install:"

"1 --> jre version 1.1.7"

"2 --> symantec classes"

"3 --> report pro classes"

"4 --> all"

"5 --> exit"

"Selection:"

53. Type "4"  and press Return .

"Enter install directory [/opt/lucent/jre1.1.7]
[?,q] "

54. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

55. Type an user:group number and press Return .

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

jre 1.1.7 + symantec
classes + reportPro
class installation
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"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuJRERT> [y,n,?]"

56. Type "y"  and press Return .

"Installing JRE 1.1.7 for AnyMediaNBEM R1.5 as
<LuJRERT>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <jre> ]"

"<files list>"

"[ verifying class <symantec> ]"

"<files list>"

"[ verifying class <report> ]"

"## Executing postinstall script."

"You have the installation logfile in"

"/tmp/EM_Install_LuJRERT.log"

"Installation of <LuJRERT> was successful."

"Processing package instance <LuOXWRT> from
</tmp/lucent_pkg/2>"

"OrbixWeb 3.0 Runtime for AnyMedia NB-EM R1.5"

"(sparc-solaris) Version 3.0 Run-Time"

"Installing Version 3.0 Run-Time."

"OK, No previous package LuOXWRT have been
found."

"Enter install directory [/opt/lu
cent/OrbixWeb3.0] [?,q]"

57. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Package <LuJRERT> jre 1.1.7 have been found in
<jre Path>"

OrbixWeb 3.0 In-
stallation



2-30 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Software Installation and Commissioning Installation Procedure

"(If you don’t plan to use fully-qualified host
names with OrbixWeb, enter "null" here.)"

"Checking your DNS domain name... done."

"What is your DNS domain name? [default: es.lu
cent.com]"

58. Type your domain name and press Return  or reply null if all machines
have fully-qualified host names (press Return  to accept default).

"Enter the NS hostname: "

59. Type the NS host name and press Return .

"Enter the NS IP address:"

60. Type the NS IP adress and press Return .

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

61. Type an user:group number.

"User: <users> and Group: <group>, have been se
lected"

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuOXWRT> [y,n,?]"

62. Type "y"  and press Return .
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"Installing OrbixWeb 3.0 Runtime for AnyMedia
NB-EM R1.5 as <LuOXWRT>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <none> ]"

"## Executing postinstall script."

" You have the installation logfile in
/tmp/EM_Install_LuOXWRT.log"

"Installation of <LuOXWRT> was successful."

"Processing package instance <LuANY16en> from
</tmp/lucent_pkg/4>"

"AnyMedia NB Element Manager Release 1.5 (Help)"

"(sparc) LuANY16en_US_X.X"

" *******************************************"

" *         AnyMedia Element Manager*"

" *         (c) 1999-Lucent Technologies*"

" ******************************************"

"OK, No previous package LuANY16en have been
found."

"Where should AnyMediaNBEM Help be installed?
[/opt/lucent/AnyMediaNBEM_R1.5/Help] [?,q]"

63. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Select owner and group for package files."

"Enter a valid owner:"

64. Type a valid user and press Return .

"Enter a valid group:"

65. Type a valid group and press Return .

"Using </> as the package base directory."

"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

AnyMedia Help In-
stallation
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"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuANY16en> [y,n,?]"

66. Type "y"  and press Return .

"Installing AnyMedia NB Element Manager Release
1.5 (Help) as <LuANY16en>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <common> ]"

"## Executing postinstall script."

"You have the installation logfile in"

"/tmp/EM_Install_LuANY16en.log"

"Installation of <LuANY16en> was successful."

"Processing package instance <LuANY16C> from
</tmp/lucent_pkg/5>"

"AnyMedia NB Element Manager Release 1.5 (Cli
ent)"

"(sparc) <LuANY16C_X.Yc>"

" *************************************"

" *         AnyMedia Element Manager*"

" * (c) 1999-Lucent Technologies*"

" **************************************"

"OK, No previous package LuANY16C have been
found."

"Where should AnyMediaNBEM GUI be installed?
[/opt/lucent/AnyMediaNBEM_R1.5/GUI] [?,q] "

67. Type a valid path where the package files must be placed and press Re-
turn  (press Return  to select default).

"Package <LuOXWRT> OrbixWeb Version 3.0 Run-Time
have been found in <OrbixWeb path>"

AnyMedia Client
Installation
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"Package <LuJRERT> jre 1.1.7 have been found in
<jre path>"
"Package <LuANY16en> Help have been found in
<Help path>"

WARNING: Netscape release 4.5 is necessary to
run the AnyMedia NB EM R1.5 Help and the AnyMe
dia Broad Band application. If it is already in
stalled on the system,please, answer 'y' to next
question, otherwise answer 'q' to exit or 'n' to
continue the AnyMedia NB EM R1.5 Client instal
lation. In this case, when the Netscape release
4.5 will be installed, the following variables
must be modified according the Netscape instal
lation settings in the AnyMediaNBEM_GUI.sh file:
.- PATH to add the Netscape path.
.- MOZILLA_HOME to store the Netscape path.
For instance, if Netscape release 4.5 is in
stalled on /opt/appl/Netscape4.5 the variables
shall be modified as follows:"
.- PATH=/opt/appl/Netscape4.5:other_paths
.- MOZILLA_HOME=/opt/appl/Netscape4.5"

"Is Netscape release 4.5 already installed on
the system [y,n,?]"

68. Type "y" if Netscape is already installed on the system and press Return
otherwise type "n" and press Return .

NOTE:
The following question only appears if above answer was "y".

"What is the base path of Netscape?[[?,q]"

69. Type the path where the Netscape release 4.5 is installed on the system
and press Return .

"Netscape version is correct"

"Select owner and group for package files."

"NBR  USER:GROUP"

"  1  anymedia:lucent     "

"  ....    "

"Enter selection [?,??,q]:"

70. Type an user:group number.
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"User: <users> and Group: <group>, have been se
lected"

"What is the AnyMediaNBEM Server Host? [<de
fault>] [?,q] "

71. Type the host name where the AnyMedia AEM-NB servers were installed
and press Return  (press Return  to select default).

"Wait...."

"What is the URL for Broad Band Manager?
[http://www.lucent.com][?,q]"

72. Type a valid URL where the broad band manager is placed and press Re-
turn  (press Return  to select default).

"Login for CutThrough functionallity?  [?,q]"

73. Type a valid login and press Return .

"Password for CutThrough functionallity? [?,q]"

74. Type a valid password and press Return .

"Code for the representation of names of lan
guages"

"Refer to ISO 639:1988 (E/F) for more informa
tion"

"  1  da     Danish"

"  2  de     German"

"  3  fr     French"

"  4  it     Italian"

"  5  zh     Chinese"

"  6  es     Spanish"

"  7  en     English"

"Enter selection [?,??,q]:"

75. Type your language code and press Return .

"Code for the representation of names of coun
tries"

"Refer to ISO 3166 for more information"
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"  1  DK     DENMARK"

"  2  DE     GERMANY"

"  3  FR     FRANCE"

"  4  IT     ITALY"

"  5  CN     CHINA"

"  6  ES     SPAIN"

"  7  GB     UNITED KINGDOM"

"  8  US     UNITED STATES"

"Enter selection [?,??,q]:"

76. Type your country code and press Return .

"Code for the representation of names of Time
Zones"

"  1  GMT     (0)    Greenwich Mean Time"

"  2  ECT     (1)    European Central Time"

"  3  EET     (2)    Eastern European Time"

"  4  ART     (2)    (Arabic) Egypt Standard
Time"

"  5  EAT     (3)    Eastern African Time"

"  6  MET     (3.5)  Middle East Time"

"  7  NET     (4)    Near East Time"

"  8  PLT     (5)    Pakistan Lahore Time"

"  9  IST     (5.5)  India Standard Time"

" 10  BST     (6)    Bangladesh Standard Time"

"... 21 more menu choices to follow;"

"<RETURN> for more choices, <CTRL-D> to stop
display:"

"Enter selection [?,??,q]:"

77. Type the desired time zone and press Return .

NOTE:
The time zone must  be the same for the AnyMedia Client (GUI), LUMOS,
Network Element and OS.

"Using </> as the package base directory."
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"## Processing package information."

"## Processing system information."

"## Verifying disk space requirements."

"## Checking for conflicts with packages already
installed."

"## Checking for setuid/setgid programs."

"This package contains scripts which will be ex
ecuted with super-user permission during the
process of installing this package."

"Do you want to continue with the installation
of <LuANY16C> [y,n,?]"

78. Type "y"  and press Return .

"Installing AnyMedia NB Element Manager Release
1.5 (Client) as <LuANY16C>"

"## Installing part 1 of 1. "

"<files list>"

"[ verifying class <common> ]"

"## Executing postinstall script."

"****************************************"

"* Execute ". AnyMediaNBEM_GUI.sh" to set the
environment *"

"*****************************************"

" You have the installation logfile in <Client
path>/EM_Install.log"

"Installation of <LuANY16C> was successful."

"Installation of AnyMedia EM R1.5 was successful
<Client side installation>"

2.2.2 Individuals Package Installations

Also, it is possible to install each package individually using the command pk-
gadd -d package_name.pkg  (refer to Table 2-1, page 2-4 to obtain the pack-
ages names).
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NOTE:
If the package is already installed on the target system, the following ac-
tions must be make:

■ the package must be un-installed previously (refer to “Remove Any-
Media package Installations” on page 40 for more information about
packages un-installation)

■ in order to does not affect the rest of the installed packages, the
package must be re-installed in the same directory as the previous
one.

NOTE:
the pkgadd -d  command makes a temporal uncompressing on the
/var/spool/pkg directory. Therefore, you must sure enough free disk space
in this location. If you like uncompress in other location, the command
pkgtrans package_name.pkg new_location package_name shall
be executed previously (for instance, pkgtrans LuOX23RT.pkg /tmp
LuOX23RT).

In this type of installation is necessary to comply with the packaged dependencies
showed in the following table.

Traces and inputs in this type of installation and in a full installation are similar.
Only the following differences could be found:

Table 2-2 Packages dependencies

To install the following package must be installed previously

OrbixNames OrbixMT

OrbixTalk OrbixMT

OrbixWeb jre

AnyMedia Serv-
ers

OrbixMT

OrbixTalk

OrbixNames

LUMOS

ObjectStore

RogueWave

AnyMedia Client OrbixWeb

jre + symantec + reportPro

Netscape -not included into the AnyMedia distribution-

Help none
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■ When an installation starts, the package checks if a previous installation
will make with the same package version. If no previous package is found
the following message will appear:

“OK, No previous package <Package_Name> have
been found.”

NOTE:
Refer to “Type "2" and press Return.” on page 8 to see this trace.

In other cases, the following messages will appear:

■ When the same package was installed previously

“Previous completely installed package
<Package_Name> version: <Package_Version> have
been found. And it is the same to the new one you
want to install:<Package_Version>.”

■ When a package with the same architecture and version and different
name was installed previously

“Previous completely installed package
<Package_Name> version: <Package_Version> have
been found.Please, use pkgrm <Package_Version>
to delete previous version.”

■ When a package with the same architecture and name and different ver-
sion was installed previously

“Previous completely installed package
<Package_Name> version: <Package_Version> have
been found.but with different version
(Package_Version) than the new you want to in
stall.”

■ When the same package was installed partially previously

“Previous partially installed package
<Package_Name> version: <Package_Version> have
been found. And it is the same to the new one you
want to install:<Package_Version>.”

■ When a package with the same architecture and version and different
name was installed partially previously

“Previous partially installed package
<Package_Name> version: <Package_Version> have
been found.Please, use pkgrm <Package_Version>
to delete previous version.”

■ When a package with the same architecture and name and different ver-
sion was installed partially previously
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“Previous partially installed package
<Package_Name> version: <Package_Version> have
been found.but with different version
(Package_Version) than the new you want to in
stall.”

NOTE:
In cases 1, 2, 4 and 5, the installation will finish without changes on the sys-
tem.

■ After this step, the installation looks for its packages dependencies. If a
needed package is found the following message will appear:

“Package <Package_Name> <Application_Name>
<Application_Verison> have been found in
<Application_Path>”

NOTE:
Refer to “Type "y" and press Return.” on page 12 to see this trace.

If the package is not found, the installation will prompt about its installation path in
order to check this path and the correct application version:

"<Package_Name> needs <Application_Name>
<Application_Version> to be installed previ
ously. Answer ’q’ to next question and install
the package <Package_Name> otherwise provide the
paths required.
What is the base path of <Required_Package_Name>
<Package_verision> [?,q]?"

When an input is provided the installation checks the path and the version of the
application. If the path is invalid the following message will appear:

“ERROR: Pathname does not exist.”

And if the version is invalid:

“Package <Required_Package_Name> have been found
but INSTALL_PATH is not defined"

“Package <Required_Package_Name> have been found
but with version: <Package_Version> not valid
for <Package_Name>"

In both cases, the installation will prompt again for the required package.

■ Also, the path where the Orbix.cfg file is located is request in the Orbix-
Names, OrbixTalk and AnyMedia Servers packages installation, after the
request for the installation path of the OrbixMT -the file will modified by both
installations- :
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“Where is Orbix.cfg file located
[Orbix_path/cfg] [?, ??, q]?”

■ Finally, after the ObjectStore installation the user must execute the oscon-
fig server command, in order to configure the ObjectStore daemon
(refer to steps 28 to 32).

2.2.3 Cancel Installation

There are two ways to cancel the installation, as follows:

■ internal cancellation: when the Install_AMEMR15 or pkgadd  com-
mand detect through information files or installation scripts that something
is invalid.

■ external cancellation: if the administrator kill the process (kill -9 or Ctrl+C).

In both cases, the system informs about if files has been installed on the system.
In this case, the administrator must use the pkgrm command to remove the instal-
lation.

2.2.4 Remove AnyMedia package Installa-
tions

In order to remove any AnyMedia package installations, the administrator must ex-
ecute the command pkgrm <Package_Name> .

NOTE:
Refer to Table 2-1, page 2-4 to obtain the AnyMedia packages names.

When a package is removed, all files installed by it or created during the AnyMe-
dia operation, such as data bases and temporal data files, are erased in the target
system.

2.2.4.1 Remove AnyMedia Servers package

Complete the following procedure to remove the AnyMedia Servers package.

Step Procedure

1. Log in as root .

2. Type pkgrm LuANY16S  and press Return .

The following package is currently installed:

LuANY16S AnyMedia NB Element Manager Release
1.5 (server)(sparc) LuANY16S_X.Xc

Do you want to remove this package?
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3. Type "y"  and press Return .

## Removing installed package instance
<LuANY16S>

This package contains scripts which will be
executed with super-user permission during the
process of removing this package.

Do you want to continue with the removal of this
package [y,n,?,q]

4. Type "y"  and press Return .

## Verifying package dependencies.

## Processing package information.

## Executing preremove script.

Removing data bases

TRACE: Removing NEM data base

TRACE: Removing CM data base

TRACE: Removing ALM data base

TRACE: Removing SEC data base

## Removing pathnames in class <channels_24>

## Removing pathnames in class <common>

<files list>

## Executing postremove script.

## Updating system information.

Removal of <LuANY16S> was successful.

You have now removed the AnyMedia Servers package.

2.2.4.2 Remove AnyMedia Client package

Complete the following procedure to remove the AnyMedia Client package.

Step Procedure

1. Log in as root .

2. Type pkgrm LuANY16S  and press Return .

The following package is currently installed:

LuANY16C AnyMedia NB Element Manager Release
1.5 (Client) (sparc) LuANY16C_X.Xc
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Do you want to remove this package?

3. Type "y"  and press Return .

## Removing installed package instance
<LuANY16C>

This package contains scripts which will be
executed with super-user permission during the
process of removing this package.

Do you want to continue with the removal of this
package [y,n,?,q]

4. Type "y"  and press Return .

## Verifying package dependencies.

## Processing package information.

## Executing preremove script.

## Removing pathnames in class <channels_24>

## Removing pathnames in class <common>

<files list>

## Executing postremove script.

## Updating system information.

Removal of <LuANY16C> was successful

You have now removed the AnyMedia Client package.
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2.2.4.3 Remove Third-Party packages

The following procedure is the same for all parts of the Third-Party software. For
example the procedure below describes the removal of the RogueWave package.

Complete the following procedure to remove the RogueWave package:

Step Procedure

1. Log in as root .

2. Type pkgrm LuRWRT and press Return .

The following package is currently installed:

LuRWRT RogueWave Tools & Threads Runtimes for
AnyMediaNBEM R1.5 (sparc) 7.0.7 & 1.1.2)

Do you want to remove this package?

3. Type "y"  and press Return .

## Removing installed package instance <LuRWRT>

## Verifying package dependencies.

## Processing package information.

## Removing pathnames in class <none>

<file list>

## Updating system information.

Removal of <LuRWRT> was successful.

You have now removed the RogueWave package.
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2.3 Configuration Parameters

2.3.1 Introduction

This chapter provides information about all the configuration parameters that are
used with AEM-NB R1.5, as follows:

■ An alphabetical list of all configuration parameters that are used with AEM-
NB R1.5.

■ Detailed information about each parameter.

These configuration parameters are distributed in three configuration files, as fol-
lows:

■ AnyMediaNBEMR1.5.cfg  for variables used by the AnyMedia servers.

■ AnyMedia.ini  and SystemPreferences.ini  for variables used by the GUI.

Only the configuration parameters the AnyMedia administrator can modify are ex-
plained in this chapter -modify these configuration variables with caution as they
may adversely affect the correct operation of the application-. To modify the other
configuration parameters stored in the configuration files, please contact with Lu-
cent Technologies TCL.

2.3.2 AnyMedia Server Configuration Pa-
rameters

The following table provide an alphabetical list of the configuration parameters for
AnyMedia servers.
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Table 2-3 AnyMediaNBEM.cfg file

configuration parameter

 name  description

CM.directoryNVDS NVDS files location. This files store informa-
tion in such a way as to survive indefinite peri-
ods of total power failure. The current values
for all provisionable parameters are store in
the NVDS directory and hence are the param-
eter values that will be used on subsequent
NE power-up.

Default value: CM/nefiles/NVDS.

NOTE:
All paths showed as default value are relative to the AnyMedia installation
path.

CM.directoryNVPS NVPS files location. It keeps software program
data. It resides in the NE <COMDAC>

Default value: CM/nefiles/NVPS.

OAM.backup.archiveDirectory default path or device -like a Tape unit- where
the AnyMedia archives will be placed.

Default value: archives.

OAM.backup.backupDirectory default path or device -like a Tape unit- where
the AnyMedia backups will be placed.

Default value: backups.

OAM.backup.backupLogDirec-
tory

default path where the backup’s logs will be
placed.

Default value: tmp.

OAM.backup.numberOfLog-
Files

maximum number of backup’s log files.

Range of values: 1 to 10

Default value: 10.

OAM.log.directoryCurrentLogs default path where the AnyMedia logs will be
placed.

Default value: log.

OAM.log.directoryRestored-
Logs

default path where the AnyMedia restored
logs will be placed.

Default value: restored.

OAM.log.maximumTotal-
LogSize

maximum size in kilobytes for all AnyMedia log
files.

Range of values: 10000 to 20000.

Default value: 15000.

Configuration Man-
agement Settings

OAM Settings



2-46 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Software Installation and Commissioning Configuration Parameters

2.3.3 AnyMedia client <GUI> configuration
variables

The following table provides an alphabetical list of the configuration parameters
for AnyMedia GUI.

OAM.log.minimumDaysKept log’s latency period in days.

Range of values: 5 to 10.

Default value: 7.

configuration parameter

 name  description
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Table 2-4 SystemPreferences.ini configuration file

configuration parameter

 name  description

SITE the city or the location where the Element
Manager is working. This value is used for
printing purposes.

LOC_TIME_ZONE code for the representation of names of
time zones.

Range of values: GMT (Greenwich Mean
Time), ECT (European Central Time), ...

Default value: defined at installation time.

USERVIEW default view in User Administration window.

Range of values: users, usergroups, do-
mains or objects.

Default value: users.

ALM_VIEW default view.

Range of values: view1, view2, view3 or
view4.

Default value: view1.

ALM_FILTER default alarm filter.

Range of values: Last24h, CritRaised,
Raised, Host, CritNotCleared, OwnedAck,
Clear, AllAck or All.

Default value: Last24h.

NOTE:
The following parameters are used for alarms notification purposes. The
notification can be either a visual effect -in the AnyMedia GUI main win-
dow the flag icon changes to up state and the count of notified alarms is
increased- or/and audio effect -a beep sound is generated-.

VISUAL_CRITICAL_ALARM_SEV enable-disable visual notification of critical
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

VISUAL_MAJOR_ALARM_SEV enable-disable visual notification of major
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

Site Settings

User View Settings

Alarm Viewer Set-
tings
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VISUAL_MINOR_ALARM_SEV enable-disable visual notification of minor
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

VISUAL_INFO_ALARM_SEV enable-disable visual notification of infor-
mation severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

AUDI_CRITICAL_ALARM_SEV enable-disable audio notification of critical
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

AUDI_MAJOR_ALARM_SEV enable-disable audio notification of major
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

AUDI_MINOR_ALARM_SEV enable-disable audio notification of minor
severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

AUDI_INFO_ALARM_SEV enable-disable audio notification of infor-
mation severity alarms.

Range of values: true -to enable- or false -
to disable-.

Default value: true.

BROAD_BAND_URL the URL where the Broad Band application
is located.

Default value: defined at installation time.

LOGTELNET login to connect to AnyMedia NB server for
CutThrough purposes.

Default value: defined at installation time.

configuration parameter

 name  description

Broad-Band Appli-
cation Settings

Cutthrough Set-
tings
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Table 2-5 AnyMedia.ini configuration file

PASSTELNET password to connect to AnyMedia NB
server for CutThrough purposes.

Default value: defined at installation time.

SERVER server host where the AnyMedia NB appli-
cation is running.

Default value: defined at installation time.

HELP_URL the URL where the help files are located.

configuration parameter

 name  description

LV_READLINES line number of server log messages read in
Log Viewer.

Range of values: 1 to 50.

Default value: 50.

configuration parameter

 name  description

Help Settings
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3.1 Overview

This chapter provides you with information about:

■ Accessing the AnyMedia® management system (AEM-NB)

■ General handling of the workspace and AEM-NB windows

■ Starting up and shutting down applications

■ Printing out reports from AEM-NB windows

■ Backup and restore tasks

■ Basics on log management and how to use the Log Viewer.
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3.2 System Access

To access the AnyMedia Element Manager (AEM-NB) application, you need to
have an account in the underlying operating system, and this account has to be
accepted as a user account of AEM-NB. AEM-NB user accounts are managed by
the administrator (cf. Chapter 4).

3.2.1 Login to Operation System

This chapter describes how to log into the system.

Complete the following procedure to log in:

Step Procedure

1. The system asks for your user name. Enter your user name and press
Return  or click OK.

2. The system asks for your password. Enter your password and press
Return  or click OK.

If the login was correct, the workspace is displayed.

If the login was incorrect, a warning message appears ("Login incorrect;
please try again ."). Confirm the message by pressing Return  or clicking
OK and repeat the login procedure.

If the core applications were not yet started an administrator has to do this
(cf. Chapter 3.4.4, page 3-20) before the AEM-NB Access Bar can be started.

To start the AEM-NB Access Bar (cf. Figure 3-1) after a correct login, type in a ter-
minal window, which you can start via the workspace manager (cf. Chapter 3.3.8,
page 3-12):

GUI_Main

The AEM-NB Access Bar is shown.

System Login

Login Correct

Login Incorrect

Start Core Applica-
tions

Start AEM-NB Ac-
cess Bar
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Figure 3-1 Workspace with AEM-NB Access Bar

3.2.2 Logout from Operation System

This chapter describes how to log out from the system. You can log out manually
or be logged out automatically after a certain time of mouse and keyboard inactiv-
ity.

Complete the following procedure to log out manually:

Step Procedure

1. Close the AEM-NB Access Bar window.

2. Click on the Exit symbol in the workspace manager or select Log out... in
the workspace menu.

3. A message box pops up. Press Return or click OK to confirm the logout.
Press Cancel  not to log out.

After a logout the login screen is displayed again.

NOTE:
During the client installation (cf. 2.2.1.2, page 2-27) a cron process is in-
stalled. This cron automatically kills the GUI processes every night due se-
curity reason. The execution time of the cron can be changed by the admin-
istrator only.

System Logout
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3.2.3 AEM-NB Access Bar

The AEM-NB Access Bar allows access to all AEM-NB applications and offers an
alarm indication as well as a help feature.

Figure 3-2 AEM-NB Access Bar

To start the Access Bar click on the access bar icon in the workspace manager
(cf. Chapter 3.3.8).

The Access Bar provides access to the following applications:

■ Equipment Configuration (cf. Chapter 5)

■ Log Management (cf. Chapter 3.7, page 3-32)

■ Users & Groups (cf. Chapter 4)

■ System Administration (cf. Chapter 3.4, page 3-17)

■ Alarm Monitoring (cf. Chapter 6)

■ Alarm Notification (cf. Chapter 3.2.3.1, page 3-4)

■ Broad Band Element Management

■ Help.

To start an application click on the respective icon.

If an icon of the Access Bar is grayed, you are not allowed to access this applica-
tion or the application is not running. Whether access is granted or denied de-
pends on your user group membership. The Alarm Notification and Help icons are
always accessible.

3.2.3.1 Alarm Notification Icon

The Alarm Notification icon displays a flag and a counter. The flag is raised if new
alarms are received. The counter is increased every time an alarm is received. By
default, only critical alarms affect the Alarm Notification icon. The counting starts
with "0" every time the Access Bar is started. The behavior of the Alarm Notifica-
tion icon can be changed so that it displays alarms with other severities.

System

Users &

Log

Alarm

Alarm

Equipment

Help
Administration

Configuration Monitoring

Notification

Groups

Management

Broad Band
Element Mgmt.

Start Access Bar

Functions

Start applications

Access Control

Description
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If you click on the Alarm Notification icon, the flag is lowered and the counter re-
set.

The behavior of the Alarm Notification Icon can be customized. It reports only
alarms for which the corresponding variable (see Table 3-1) in the system prefer-
ences file ($ANYMEDIAPATH/GUI/cfg/SystemPreferences.ini ) is set to
true . If the variable is set to false  it reports no alarms of this alarm severity.

If an alarm of a certain alarm severity (default: critical) is received an audible sig-
nal is issued. The audible signal is generated only for alarms with an alarm sever-
ity for which the corresponding variable (see Table 3-2) in the system preferences
file is set to true . If it is set to false no audible signal is generated for alarms of
this alarm severity. Alarms are audible on the server only.

Changes in the system preferences file take effect only after the next start-up of
the AEM-NB GUI clients.

3.2.3.2 Help Icon

The Help icon provides access to the AEM-NB online help. If you click on the Help
icon the help index is displayed.

3.2.4 Capacity

The AEM-NB allows for a maximum of

■ 5 simultaneous users

■ 100 NEs to be managed.

Table 3-1 Variables for Customizing Visual Alarm Notifications

Alarm Severity Variable Name

Critical VISUAL_CRITICAL_ALARM_SEV

Major VISUAL_MAJOR_ALARM_SEV

Minor VISUAL_MINOR_ALARM_SEV

Info VISUAL_INFO_ALARM_SEV

Table 3-2 Variables for Customizing Audible Alarm Notifications

Alarm Severity Variable Name

Critical AUDI_CRITICAL_ALARM_SEV

Major AUDI_MAJOR_ALARM_SEV

Minor AUDI_MINOR_ALARM_SEV

Info AUDI_INFO_ALARM_SEV

Reset Counter

Customize Alarm
Notification

Audible Alarm No-
tification

Make Changes
Take Effect

Description
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3.3 General Information on Key-
board and Windows

3.3.1 Keyboard

The keyboard offers special keys which are pressed individually or in combination
with others to perform specific actions.

The most important special keys are:

■ Return , to confirm an entry or to start a new line when a text consisting of
several lines is entered

■ Esc  = "Escape" to initiate an escape sequence, i.e. the keys pressed after
pressing Esc are interpreted as an instruction and not as entered text

■ Ctrl  = "Control" to initiate a control sequence. Ctrl  is always used in
combination with one or several other keys and represents an instruction

■ Alt  = "Alternate" is pressed in combination with one or more other keys
thereby assigning these keys another meaning

■ Backspace  or Del  (= "Delete") to delete all characters to the left of the
cursor.

The keys on the keyboard are represented in the text in the following way: Ctrl ,
Backspace , A, B,...

Two or more of these keys connected by a hyphen ("-") indicate that they must be
pressed simultaneously. Shift-Ctrl-A , for example, means that the "A" key
must be typed while holding down Shift  and Ctrl .

Keys that are separated by blanks only must be pressed one after the other.
Esc A B , for example, means that Esc  must be pressed first followed by A and
then B.

3.3.2 Mouse

When using the mouse, you will frequently find the following terms:

■ Click  or Select : Position the cursor on an object and press the left mouse
button.

■ Double click : Click the left mouse button twice in rapid succession.

■ Drag : Move the mouse keeping the left mouse button pressed.

Special Keys

Conventions

Conventions
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3.3.3 Different Aspects of the Cursor

The aspect of the cursor will vary to indicate the actions you may currently under-
take using the mouse.

The following symbols show examples for possible cursor aspects:

The arrow up pointing to the left is used to select objects and to press buttons.

The "I" beam is used within a text field to indicate the position where text is to be
inserted.

The "clock" cursor indicates that in the window where the cursor is positioned a
process requiring a lot of processing time is running and no mouse or keyboard
inputs are possible.

3.3.4 Basics on Windows

The window which contains the input focus evaluates all keyboard and mouse in-
puts. The window containing the input focus is easy to distinguish from other win-
dows opened on the screen by the different colour of its window frame.

Use the mouse to direct the input focus to a defined window. Click on a position
within the window or place the cursor on the window.

The window shown in Figure 3-3 labels the different window controls which allow
the user to change the aspect of the window on the screen and the process repre-
sented by the window.
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Figure 3-3 Specimen Window and Window Controls

The individual window controls shown in Figure 3-3 are:

Figure 3-4 Controls in a Window

Window Part Function

Window frame
with resize cor-
ners

The frame delimits the window on the screen and its colour indicates whether this
window contains the input focus. Drag the frame to shift and resize the window. By
dragging the window corners, the window size may be modified to both limiting sides
at the same time.

Title bar The title bar informs you about the function of the window. Drag the title bar to shift
the window on the screen.

Minimize button If you click on the minimize button, the window will be displayed in its minimum size,
i.e. it will appear as an icon on the screen, though the process represented by the
window will continue running.

Title bar Minimize button Maximize buttonWindow menu button

Menu bar

Window frame with
resize corners

Vertical scroll barHorizontal scroll bar

Slider

Slider

AnyMedia
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Horizontal scroll
bar

Use the horizontal scroll bar and the slider to shift the visible window section to the
left or right.

■ Small step to the left or right:
Click on the left or right scroll bar arrow.

■ Page left or right:
Click on the scroll bar to the left or right of the slider.

■ Shift window section:
Use the mouse and drag the slider horizontally until the desired window section
becomes visible.

Vertical scroll bar Use the vertical scroll bar to shift the currently visible window section up or down:

■ Small step up or down:
Click on the top or bottom scroll bar arrow.

■ Page up or down:
Click on the scroll bar section above or below the slider.

■ Shift window section:
Use the mouse and drag the slider up or down until the desired window section
becomes visible.

Maximize button Activate the maximize button by clicking on it to show the window at its maximum
size, i.e. the window will occupy the whole screen. If you click again on the maximize
button thus activated, the window will be restored to its original size.

Menu bar The menu bar contains the menu names, each of them containing options related to
the topic. These options may be selected to control the process running in this win-
dow (cf. Chapter 3.3.6)

Window menu
button

Click this button to open the window menu (cf. Figure 3-5). Double click to exit the ap-
plication.

Figure 3-4 Controls in a Window

Window Part Function
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3.3.5 Window Menu

A window can be provided with a window menu. The window menu allows to alter
the appearance of the window or to exit the application represented by the win-
dow.

Figure 3-5 Window Menu

To open the window menu shown in Figure 3-5, click on the window menu button
or click with the right mouse button on the window frame.

The menu options in the window menu are listed in the following table.

Table 3-3 Window Menu Items and their Function

Menu Item Function

Restore A window currently being represented as an icon or in its maxi-
mum size is restored to its original size.

Move Allows you to move the window interactively on the screen. The
window frame will follow the mouse movements until you press the
left mouse button.

Size Allows interactive resizing of the window. Move the cursor appear-
ing in the window to the window edge you wish to move. The edge
will follow the mouse movements until you press the left mouse
button.

Minimize The window is shown as an icon.

Maximize The window is shown in its maximum possible screen size.

Lower If there are several overlapping windows, the currently active win-
dow is shifted to the bottom of the pile.

Close This function will close the window and remove it from the user in-
terface, exiting the application linked to the window.

Restore Alt+F5
Move Alt+F7
Size Alt+F8
Minimize Alt+F9
Maximize Alt+F10
Lower Alt+F3
Close Alt+F4



System Management

363-211-402 Issue 2 (09.99) 3-11

AEM-NB R1.5

General Information on Keyboard and Windows

3.3.6 Menu Bar

The menu bar of a window contains the menu names. Once you click on a menu it
opens and a series of related menu options will be displayed under the menu
name.

Each option represents a function, which can be used to control the application
running in the window. To call this function, click on the required option. A menu
option is referred to in the text as: "Menu name -> Menu option " (e.g. in the menu
below: Network View -> Maps ).

A grayed menu name or option cannot be selected.

Submenus are menus opening under a certain menu option and containing a
number of related menu options. Some menu options are provided with a small ar-
row pointing to the right (>). These menu options have a submenu that will open
as soon as you click on the menu option. A submenu option is referred to in the
text as "Menu name -> Menu option -> Submenu option " (e.g. "Network View
-> Submaps -> Open/List... "). A submenu option again may offer a submenu,
then an appropriate number of "->" is added.

3.3.7 Cursor Menu

Some objects in windows have a menu associated with them. This menu will pop
up at the cursor position when the right mouse button is pressed. The cursor must
not, however, be positioned on a menu bar or a window frame. The cursor menu is
not available in all windows. The functions which can be executed using this cur-
sor menu depend on the application of the respective window.

Proceed as follows to select a menu option from the cursor menu:

Step Procedure

1. Press the right mouse button.

2. Move the cursor onto the desired menu option.

3. Click the left or right mouse button to execute the menu option, or if you
do not wish to execute a menu option, move the cursor away from the
menu and click somewhere outside the menu.

Menu Options

Conventions

Submenu Conven-
tions

Menu at the Cursor
Position

Select Menu
Option
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3.3.8 Workspace Manager

After logging in to the operation system (SUN Solaris), the workspace manager
window is situated at the bottom of the screen offering a range of functions and in-
formation. A function is initiated by clicking the respective area of the workspace
manager. In Figure 3-6 only an example of the workspace manager is given, as
the entries are configurable.

Figure 3-6 Workspace Manager

For a detailed description of the offered functions, please refer to your Solaris
User’s Guide and Solaris Common Desktop Environment User’s Guide.

3.3.9 Workspace Menu

The workspace menu opens when you click with the right mouse button on the
background of the workspace.

Figure 3-7 Workspace Menu

General

Clock

Calendar

File Manager

Editor

Mailtool

Other Workspaces

Lock Screen Log Out

Printer

Solaris Help

Trash CanTools

Workspace
Configuration

Personal Applications
(e.g. Terminal)

Functions

General
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The workspace menu provides the functions listed in the following table:

3.3.10 Controls in AEM-NB Windows

The windows of the AEM-NB display certain controls (buttons, text fields, etc.).
These controls are the same in all AEM-NB windows and explained in this chap-
ter.

All controls within a window can be activated by clicking on them only if they are
not grayed.

Table 3-4 Menu Items of the Workspace Menu

Menu Item Function

Programs A submenu offering several programs.

Shuffle Up If several windows on the screen are layered on top of one
another, "Shuffle Up" brings the window from the very bot-
tom to the top of the pile.

Shuffle Down If several windows on the screen are layered on top of one
another, "Shuffle Down" moves the window from the top of
the pile to the very bottom.

Refresh The contents of the windows on the screen and the screen
backdrop are refreshed.

Minimize/Re-
store Front Panel

The workspace manager window is reduced to an icon or, if
already iconized, restored to a window.

Restart Work-
space Manager...

The workspace manager is restarted. Some of the changes
to the user interface become valid only after the restart of the
workspace manager. The restart must be acknowledged in a
window.

Log out... A logout from the system can be initiated.

Workspace Menu
Functions

Introduction

Grayed Controls
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Figure 3-8 Example of an AEM-NB Window

The following font is used when a button is mentioned, e.g. Close .

The following elements are used within windows:

■ Pushbutton

Each pushbutton is provided with a designation describing its function. If
you click on the pushbutton, the function will be executed. If you click on a
pushbutton, the designation of which is followed by three dots (e.g.:
Help... ), a window will open where you may set further parameters. Push-
buttons which alter their designation depending on context are also called
Label buttons .

■ Check Box

Check boxes have the same function as an on/off switch. Each time you
click on a check box, you will change its toggle status. A (pressed) check
box containing a check mark means that the option at this position is se-
lected.

Radio Button

Tab

Menu Button

Push Button

Text Box

Convention
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■ Radio Button

Radio buttons have the same function as check boxes, with the difference
that of various radio buttons of the same group, only one can be pressed at
a time. As with a radio set, a set button will pop out when you press the
next one in.

■ Text Box

Text boxes are used to input text via the keyboard.

■ List Box

A list box contains read-only data in list form. To scroll through a list you
have to use the scroll bar at the right of the list box.

■ Drop-Down List Box

A drop-down list box allows you to enter data by selecting an entry from a
list that drops down after clicking on the triangle on the right of the box.

■ Spin Box

A spin box only allows a limited set of discrete ordered input values. You
have to use the up and down arrows to increment or decrement the value.

■ Tab

A window can contain a register of several tabs. Clicking on a tab displays
the corresponding contents in the window.

■ Option Menu

The option menu is used to set a certain option. Its designation will indicate
the option currently set. Handling of the option menu is the same as for a
menu.

The table below provides an overview of buttons which have the same function in
every AEM-NB window:

Table 3-5 Function of Frequently Used Buttons

Button Function

OK Applies changes; window is closed

Apply Applies changes; window stays open for further edits

Cancel Discards changes; running operation is cancelled; window is closed

Close Discards changes; window is closed

Edit Opens an edit window for the displayed parameters

Frequently Used
Buttons
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The table below provides an overview of menus which have the same function in
every AEM-NB window:

Table 3-6 Function of Frequently Used Menus

Menu Function

File -> Print -> Print Table Prints the contents of text lists in the window
(cf. Chapter 3.5, page 3-21).

File -> Print -> Print Preview Prints a screenshot of the lists in the window
(cf. Chapter 3.5, page 3-21).

File -> Exit Closes all windows of this application.

Help -> On Window Displays online help for this window.

Help -> Index Displays online help index.

Frequently Used
Menus
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3.4 Application Start-Up and
Shutdown

3.4.1 General on Applications

The following tables gives definitions of terms used in this chapter.

There are three ways to start the server applications:

■ at boot time

Root can configure the system at the installation so that Level 1 applica-
tions only or Level 1 and all Level 2 applications start at boot time.

■ via command line

The administrator can start Level 1 applications or Level 1 and all Level 2
applications via command line.

■ via GUI

The administrator can start any desired Level 2 application from the GUI
once Level 1 is already running.

Table 3-7 Definitions for Applications

Term Meaning

Server application Set of server processes that perform a certain functional-
ity. Server applications provide services for client applica-
tions.

Client application Set of processes that use the services provided by the
server applications (e.g. GUI and Northbound users)

Level 1 or core
applications

The minimum set of server applications that have to run
together to provide the minimum functionality of the AEM-
NB. These applications must run to allow the Level 2 Ap-
plication to be started up. These applications are shown
as only one running application. If this group is shut down
the AEM-NB is shut down.

Level 2 applications The server applications that can be started-up and shut-
down individually without affecting the functioning of other
applications. However, there are interdependences be-
tween Level 2 applications so that the shut-down of one
may affect the services of others.

Definitions
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3.4.2 AEM-NB Server Applications

The AEM-NB consists of four server applications. The following list gives their
names and uses:

■ System core

Provides basic functionalities and is needed by all applications. If this
server application is shut-down, all other applications are shut down and all
client applications are notified of the shutdown

■ Configuration management

needed by the configuration management application (cf. Chapter 5). If this
server application is shut down, the configuration management application
will no longer run.

■ Alarm management

needed by the fault/alarm management application (cf. Chapter 6). If this
server application is shut down, the fault/alarm management application
will no longer run.

■ Network element management

Needed for operations which affect NEs. If this server application is shut
down, operations with NEs can no longer be carried out. All client applica-
tions continue working, except for those parts involving NEs.

If a server application crashes, the AEM-NB tries to start-up this server application
one time automatically. If the server application start-up mechanism fails, and it is
a level 2 application, it remains stopped. If it is a level 1 application, the whole sys-
tem is shutted-down and restarted (all running applications at that moment are
shutted-down and restarted).

3.4.3 Start-Up/Shutdown of Server Applica-
tions via GUI

The System Administration function of the Access Bar allows to start up or shut
down server applications manually and to monitor the state of each application.
Only the administrator has access to this function. The "System Administration"
window is shown below.

Restart of Server
Applications

Introduction
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Figure 3-9 System Administration

The "System Administration" window displays two lists: Stopped  and Running .
The Stopped list contains all applications which are not running. The Running list
contains all running applications. You can stop running or start stopped applica-
tions.

The following table provides an overview of the possible actions in the "System
Administration" window.

You may start or shut-down more than one application at the same time. To do so,
click on all desired applications once. Clicking on a selected application again, de-
selects it.

Table 3-8 System Administration Actions

If you want to... then...

start one or more applications select the applications which shall be started under
Stopped  and press Add .

shut-down one or more applications select the applications to be shut down under Running and
press Remove .

close the window press Close  or select File -> Exit .

Stopped/Running
Lists

Start/Shut-down
more applications
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3.4.4 Start-Up/Shutdown of Server Applica-
tions via Command Line

The system can be configured at installation time to start-up the server applica-
tions automatically on every reboot. An administrator can start-up or shut-down
server applications via a command line interface.

The following table shows which commands have to be entered in a terminal win-
dow to start-up or shut-down server applications.

3.4.5 Deinstall AEM-NB from Your System

The AEM-NB software can be deinstalled from your system. The deinstallation re-
moves all AEM-NB related items (databases, 3rd party software, etc.), which have
been installed at the time when AEM-NB was installed, from your system.

The following table shows which commands have to be entered in a terminal win-
dow to deinstall AEM-NB from your system. Log in as root to execute these com-
mands:

For details about the above commands, please refer to Chapter 2.2.4.1 Remove
AnyMedia Servers package, Chapter 2.2.4.2 Remove AnyMedia Client package
and Chapter 2.2.4.3 Remove Third-Party packages.

Table 3-9 Commands for Start-up and Shut-down

If you want to... Type in a terminal window...

start-up all AEM-NB applications systemAdmin ALL

start-up the core AEM-NB applications systemAdmin CORE

shut-down all AEM-NB applications systemAdmin CLEAN

Table 3-10 Commands for Deinstallation

If you want to... Type in a terminal window...

remove the server package pkgrm LuANY10S

remove the client package pkgrm LuANY10C

remove third-party software pkgrm LuRWRT

Commands for
Start-Up and Shut-
Down

Deinstallation

Commands for
Deinstallation
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3.5 Print out Reports

The "Print Dialog" is used from any application within AEM-NB to generate an out-
put of data. It pops up when you press Print  in a window.

If the Unix command "lp " does not exist or is not configured on your system the
AEM-NB software will not be able to print. This is because the print-out is first con-
verted to PostScript format and then piped to the Unix command
"lp -d printer_name " where printer_name  is replaced by the value en-
tered in the Printer  field of the "Print Dialog".

Figure 3-10 shows an example of the "Print Dialog".

Figure 3-10 Print Dialog

The following table provides an overview of the possible actions in the "Print Dia-
log".

Table 3-11 Print Dialog Actions

If you want to... then...

print multiple copies enter the number of copies in Copies .

print to a printer enter the name of the printer in Printer .

print to a file enter the name of the file in File .

have a title over the printed pages enter the title in Banner Page Title .

General

System Details for
Printing

Actions in Print
Dialog
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After you confirmed your settings with Print , the "Print Preview" window is
opened, cf. Figure 3-11.

Figure 3-11 Print Preview Window

apply UNIX print options enter the options in Print Command Options .

select the paper size click one of the radio buttons below Paper Size .

select the orientation of the print out click one of the radio buttons below Orientation .

start printing and close the window click on Print .

close the print window without printing click on Cancel .

Table 3-11 Print Dialog Actions

If you want to... then...
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The following table provides an overview of the possible actions in the "Print Pre-
view".

3.6 Backup and Restore

The backup functions of the AEM-NB allow you to copy AEM-NB related file sys-
tems to removable media (such as tape) to safeguard against loss, damage, or
corruption. The AEM-NB system files and database backup allows to back up and
restore system files and databases belonging to the installed applications (e.g.
configuration files). Archiving is possible for AEM-NB log files

The restore functions allow you to restore file systems by copying reasonably cur-
rent backup files from removable media to a working directory.

3.6.1 Basics on Backups and AEM-NB Data-
bases

The following table gives definitions of terms used in this chapter.

Table 3-12 Print Dialog Actions

If you want to... then...

print out click on the printer icon

cancel the print out click on Close

view a single page preview click on the single page icon

view a multi page preview click on the multi page icon

change the magnification of the preview select another magnification with the % option menu

maximize/restore the preview window click on the monitor icon

Table 3-13 Definitions

Term Meaning

Backup process of copying file systems to removable media (such as
tape) to safeguard against loss, damage, or corruption.

Archive process of copying file systems to removable media (such as
tape) and deleting the original files once they have been backed
up.

Restore process of copying backup files from removable media to a work-
ing directory, replacing the original files which could have been
damaged.

Full Backup copies a complete file system or directory

Actions in Print
Preview

Definitions
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The AEM-NB database can be subdivided into four different databases:

■ Alarm DB

To maintain alarm information

■ OAM DB

To maintain user administration, domain information, etc.

■ NE DB

Used to keep all the NE specific data, considered to be a copy from the real
NE. There will be an NE DB per network element version managed.

■ NE EM DB

used to keep private NE data (name, status) not retrieved from the real NE.

There are three different backup types. The following list shows their differences
and advantages:

■ Full backup

A full backup copies a complete file system or directory, e.g. all AEM-NB
data. This method requires large numbers of backup tapes that take a long
time to write and takes also some time to retrieve individual files because
the backup drive has to move sequentially to the point on the tape where
the file is located. On the other hand, using full backup makes it easier to
retrieve small changes in file systems.

■ Incremental backup

An incremental backup only includes copies of new files and files that have
changed since a previous backup. It is available for database files only. Re-
quires less resources, but searching for a certain file on the incremental
tapes can take time.

Incremental
Backup

copies new files and files that have changed since a previous
backup. The incremental backups are usually given a dump level
which determines which files are backed up. A certain level incre-
mental backup will save all the new or changed files since the last
backup with a lower level.

On-line
Backup

backups performed on user demand

Off-line
Backup

backups performed automatically via any scheduling mecha-
nisms, e.g. cron file

Table 3-13 Definitions

Term Meaning

AEM-NB Data-
bases

Backup Types
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3.6.2 Commands for Backup, Archive and
Restore

If a backup is done, the four AEM-NB databases, the NVDS and the log files are
copied to the backup medium. If an archive is made the log files are moved to the
backup medium. The files from which a backup or archive is done are shown in
the table below. The location of the files is relative to the main installation direc-
tory. (For changing default locations refer to Chapter 3.8, page 3-38.)

When a backup is restored, all files are restored to their original location. When
archives are restored they are copied into the directory restored (relative to the
main installation directory).

When more than one backup is placed on a tape and a particular one shall be re-
stored, the name of this backup must be known. The name can be determined by
using the tar  command. For example: tar tvf /dev/rmt/0mn .

In the following description of the commands, square brackets, e.g. [-c] , indicate
optional parameters. The pipe symbol "|" indicates alternative options from which
one has to be chosen, e.g. INC|FULL . All parameters not enclosed in brackets are
mandatory. Each command is entered without enclosing parameters in brackets.

Table 3-14 Default File Names for Backup and Archive

Database/File
File Name
(Directory/File)

Backup Fails if
File doesn’t exist

Alarm database AM/db yes

Configuration management database CM/db yes

NE management database NEM/db yes

Security database Security/db yes

Non-volatile Data Storage (NVDS) CM/nefiles/NVDS no

Log Files log (directory) no

Default Locations
of Data for Backups
or Archives

Default Locations
for Restored Data

Restore One of Sev-
eral Backups from
Tape

Command Syntax
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Use the following command to make a backup of a database or directory. If you
enter none of the optional parameters, a backup of all data necessary to restore
the AEM-NB will be done:

AEMNB_backup [-c] [-p path] [-f file] [-t INC|FULL] [-l level]

Parameter description:

-c Aborts a running backup operation.

-p path path  is the directory or device to back up.

-f file Location of the backup file. file  can be a local file or a locally
mounted file (in case a local tape device is used file specifies
a "soft label"). (Default file names:
EM_SYSBCK_yyyymmdd.fullbck for full backup
EM_SYSBCK_yyyymmdd.incbck for incremental backup,
with yyyy = year, mm = month, dd = day of the backup.)

-t INC|FULL Type of backup: incremental (INC) or full (FULL ). (Default:
FULL). This parameter is ignored if "-l 0" is used.

-l level Specifies the backup level. Files modified since last backup
at a lower level are copied, level = 0...9. This parameter is ig-
nored if "-t FULL " is used.

Use the following command to restore a database or directory:

AEMNB_restore [-c] [-p path] -f file

Parameter description:

-c Aborts a running restore operation.

-p path path  is the directory or device to which the restored data
should be written. If no value is specified, the original loca-
tions will be used.

-f file Location of the backup file. file  can be a local file, a locally
mounted file or a local tape device.

Use the following command to archive log files. This function is primarily intended
to archive the AEM-NB log files. If you enter none of the optional parameters, the
AEM-NB log files will be archived.

AEMNB_archive [-c] [-p path] [-f file]

Parameter description:

-c Aborts a running archive operation.

-p path path is the directory or device to archive. (Default: path to log
files.)

-f file Location of the backup file. file  can be a local file or a locally
mounted file (in case of a local tape device is used file speci-
fies a "soft label"). (Default file name:
EM_SYSARCH_yyyymmdd.arc, with yyyy = year, mm =
month, dd = day of the archive.)

Backup Files

Restore Files

Archive Files
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3.6.3 Backup, Archive and Restore Proce-
dures

This section gives an overview of the steps necessary for a backup, archive or re-
store operation.

The backup, archive or restore commands require that some path system vari-
ables are properly set. This is done by the command AnyMediaNBEM.sh  during
the installation of AEM-NB. If this command was not executed the backup, archive
or restore commands will not work.

When different users perform backup, archive or restore operations the system
will display a message asking whether temporary data which remained from the
previous user should be deleted. If such a message is displayed you must confirm
the deletion of these data.

3.6.3.1 Backup Procedure

The backup operation needs no user interaction after the backup command was
executed.

3.6.3.2 Archive Procedure

The archive operation needs no user interaction after the archive command was
executed.

3.6.3.3 Restore Procedure

3.6.3.3.1 General

When a backup is restored, all files are restored to their original location. When
archives are restored they are copied into the directory restored (relative to the
main installation directory).

When more than one backup is placed on a tape and a particular one shall be re-
stored, the name of this backup must be known and the tape must be positioned
at the beginning of this backup. The name can be determined by using the tar
command. For example: tar tvf /dev/rmt/0mn . The positioning is done as
described below.

If you know the order of the backups on tape, you can position the tape at the be-
ginning of the desired backup as follows: Rewind the tape (e.g with
mt -f /dev/rmt/0m rewind ) and issue a tar  command (see example
above) until the backup which comes before the one which shall be restored is
displayed. If you do not know the order of the backups on the tape, it can be deter-
mined as follows: Rewind the tape and then repeatedly issue a tar  command
(see example above) until the backup to be restored is displayed while you note
the order of the backups on tape. Then you can position the tape as shown above.

Prerequisite for
Backup, Restore
and Archive

Different Users

Default Locations
for Restored Data

Restore One of Sev-
eral Backups from
Tape

Position Tape
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3.6.3.3.2 Full Restoration Procedure

When the restore command is executed the user must decide which image type
should be restored. The restore script displays the following message:

Please enter the type of the image to be restored [backup/archive]

Type backup  or archive  and press Enter .

Copies of the original databases are saved to allow for a cancellation of the oper-
ation. If such a copy could not be made the appropriate image can nevertheless
be restored, but a warning is issued. For each database for which no copy could
be made the following message is displayed:

Actual <DATABASE TYPE> is not present or ObjectStore copy operation failed.
The AnyMedia NB-EM system state cannot be recovered if a cancellation is requested.
Do you want to continue? [y/n]

Type y  and press Enter  to continue with the restore procedure. If you type n the
restore command stops with an error message, no data are restored and the sys-
tem will not work unless a correct restore is performed. When the original data-
bases are present, the message above is not displayed.

While the different databases are restored certain information is displayed on the
screen. Then the restoration tool asks whether additional databases should be re-
stored:

Do you wish to restore from any additional incremental backups? (yes/no):

Type no  and press Enter .

After that the execution of the restore tool finishes and the restoration is complete.

3.6.3.3.3 Incremental Restoration Procedure

Before a certain incremental backup can be restored the previous full backups
and possibly some previous incremental backups must be restored.

The procedure to restore an incremental backup is the same as the above de-
scribed procedure for a full backup except for the last ("Additional Incremental
Backups") step. In that step the restore tool asks for a confirmation that all needed
full backups which are a prerequisite for the incremental backup are present. An-
swer this question affirmatively. After that the execution of the restore tool finishes
and the restoration is complete.

3.6.4 Examples for Backup Schedules

This section gives you some examples for typical backup schedules and explains
the backup level.

Crucial for the understanding of the backup schedules is understanding the
backup level. The backup level is a number which is assigned by you to every
backup you make. Each time you make a new backup only those files are put on

Copy of Originals

Additional Incre-
mental Backups

Introduction

Backup Level
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the back-up media which were altered since the last backup with a lower backup
level. A backup level "0" means a full backup.

3.6.4.1 Daily Cumulative, Weekly Cumulative
Backups

This is the most commonly used backup schedule. It is recommended for most sit-
uations.

This schedule has the following characteristics:

■ Each weekday backup accumulates all files changed since the end of the
previous week (or the initial level 0 backup).

■ Each Friday's backup contains all files changed since the first level 0
backup. For the level 9 backups, the previous level 0 or level 5 is the closest
backup at a lower level.

■ Each Friday's backup contains all files changed during the month to that
point.

The following table shows the backup levels for each days backup. Once a month,
a backup with backup level 0 must be performed.

The following table shows how files accumulate in the backup for each weekday.

Table 3-15 Backup Levels of Each Backup

variable Mon Tue Wed Thu Fri

1st of month 0

1st week 9 9 9 9 5

2nd week 9 9 9 9 5

3rd week 9 9 9 9 5

4th week 9 9 9 9 5

Table 3-16 Example for Files in Backup for Two Weeks

Mon Tue Wed Thu Fri

1st week ab abc abcd abcde abcdef

2nd week g gh ghi ghij abcdefghijk

Schedule Charac-
teristics

Example
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3.6.4.2 Daily Cumulative, Weekly Incremen-
tal Backups

The following table shows the backup levels for each days backup. Once a month,
a backup with backup level 0 must be performed

The following table shows how files accumulate in the backup for each weekday.

3.6.4.3 Daily Incremental, Weekly Cumula-
tive Backups

The following table shows the backup levels for each days backup. Once a month
a backup with backup level 0 must be done.

Table 3-17 Backup Levels of Each Backup

variable Mon Tue Wed Thu Fri

1st of month 0

1st week 9 9 9 9 3

2nd week 9 9 9 9 4

3rd week 9 9 9 9 5

4th week 9 9 9 9 6

Table 3-18 Example for Files in Backup for Two Weeks

Mon Tue Wed Thu Fri

1st week ab abc abcd abcde abcdef

2nd week g gh ghi ghij ghijk

Table 3-19 Backup Levels of Each Backup

variable Mon Tue Wed Thu Fri

1st of month 0

1st week 3 4 5 6 2

2nd week 3 4 5 6 2

3rd week 3 4 5 6 2

4th week 3 4 5 6 2

Example

Example
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The following table shows how files accumulate in the backup for each weekday.

Table 3-20 Examples for Files in Backup for Two Weeks

Mon Tue Wed Thu Fri

1st week ab cd ef h abcdefghi

2nd week jk lmn o p jklmnopqr
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3.7 Log Management

The log management records information on events in the AEM-NB. The logged
events can be viewed with the Log Viewer.

3.7.1 Different Log Types

There are three log types within the Log Viewer:

■ Actions

It contains all the information on actions performed by users or the AEM-
NB and which imply changes in the AEM-NB configuration, equipment
(NE) configuration, service and subscriber configuration, access to the
AEM-NB, print reports and backup& restore. That means all operations
triggered by the user or the AEM-NB and all subsequent actions. Also the
results of operations are logged in the actions log.

■ System Internal Events

It contains all internal events or actions which report unusual changes in
the configuration and state of the AEM-NB or indicate errors which oc-
curred in the AEM-NB.

■ Autonomous Reports

It contains all information valuable for the equipment supplier about alarms
(NE and platform), the performance and all TL1 messages sent from the
NE which imply changes in the AEM-NB database.

3.7.2 Configuration of Logs

The following values can be configured (conf. Chapter 3.8, page 3-38) for the log
system by the administrator:

■ Minimum number of days (incl. current day) in the log (default: 7 days)

■ Maximum size of all logged data (default: 15 Mbyte)

The logs are stored as separate files, one file holds one day of one log type. If the
size of the logged data has reached the size limit and a new event to be logged
occurs, some of the already logged data has to be deleted. The oldest recorded

Log size

Log Grows Too Big
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day of one of the logs holding the largest number of days is always deleted. The
log system determines which log shall be shortened as follows:

The log system issues an alarm if

■ one of the logs is shortened to a number of days below the minimum num-
ber of days. (I.e. also, if a log is shortened that already holds fewer than the
minimum number of days.) Alarm name: LOG_DEL_PART.

■ the current day of a log is deleted. Alarm name: LOG_DEL_FULL.

When log files are restored (cf. Chapter 3.6), the log of the current day is not over-
written.

3.7.3 Log Viewer Window

The logs can be viewed by means of the Log Viewer application. The logged en-
tries in the Log Viewer cannot be edited.

The Log Viewer is started-up by clicking on the log viewer icon in the Access Bar.
After start-up the default log type is displayed, this value can be configured (de-
fault: "Actions").

The log types which are visible to you depend on your user group. The following
table shows the log types which the different user groups are allowed to see.

Table 3-21 How the Log be Shortened is Determined

If... then the log system will...

only one log holds more days than the
others

delete oldest recorded day of this log.

the longest logs hold the same number
of days and the log for which an event
shall be logged is among these logs

delete oldest recorded day of the log
for which an event shall be logged.

the longest logs hold the same number
of days and the log for which an event
shall be logged is not among these logs

select one of the longest logs in the
following order: Autonomous Report,
Actions, System Internal Events and
delete oldest recorded day of this log.

Table 3-22 Visibility of a Log Type for a Certain User Group

Log type Visible for user group

Actions Administrator, Maintenance

System Internal Events Administrator, Maintenance

Autonomous Reports Administrator, Maintenance, Monitoring

Alarms

Restore Log Files

Start Log Viewer

Access Permission
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Figure 3-12 Log Viewer

The following table explains the meaning of the columns in the Log Viewer table.

Table 3-23  Information Displayed in the Log Viewer Table

Column Meaning

Date&Time Date and time when the event was registered in the log
file. Format: "year-month-date hour:minute:second"

Login The user name of the user performing an action or "EM"

Conditions The condition of a performed action, to indicate whether it
is the request or the response. (E.g. START,
END_SUCCESS, END_ERROR)

Object Unique identification of the object (NE_Id or EM) which
has sent a TL1 message or has received an action.

Meaning of
Columns
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Depending on the chosen log type the table in the Log Viewer displays different in-
formation (more or less columns). The following table shows which information is
displayed for which log type.

The following table provides an overview of the menus of the Log Viewer and their
functions.

Method A string explaining the performed action.

Parameters ■ For Actions and System Internal Events

Shows all parameters involved in the action.

■ For Autonomous Reports

Shows all TL1 message parameters in the order they
were received (for TL1 messages sent from NE) and
all alarm fields (except Description) for platform
alarms.

Event Type The event which happened in the AEM-NB.

Table 3-24 Log Types

Log Type Contents

Actions Date&Time, Login, Conditions, Object, Method, Pa-
rameters

System Internal Events Date&Time, Object, Event Type, Parameters

Autonomous Report Date&Time, Parameters, NE_Id

Table 3-25 Menus and Functions

Menu Item Function

File -> New Start up a new Log Viewer

File -> Reload Update the displayed Log Viewer table with
newly logged items.

File -> Print -> Print Table Print out all logged items displayed in the table
of the Log Viewer.

File -> Print -> Print Preview Print a screenshot of the list of log messages.

File -> Close The selected Log Viewer window is closed.
Other open Log Viewer windows stay open.

File -> Exit Close all Log Viewer windows.

Table 3-23  Information Displayed in the Log Viewer Table

Column Meaning

Log Types and Dis-
played Information

Menus and Func-
tions
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The following table lists all actions you can perform in the Log Viewer window.

Options -> Default Type Set a new default type, which will be displayed,
when the next Log Viewer window is opened.

Help -> On Window Display help for Log Viewer

Help -> Index Display help index.

Table 3-26 Actions in the Log Viewer Window

If you want to... then... Result

display a certain log
type of a specific
date

select the desired log type with the pull
down control Type  and the date of inter-
est with the pull down control Date and
press Apply .

The log of the selected type and date is
displayed in the Log Viewer table.

view different log
types or dates si-
multaneously

start another Log Viewer with File ->
New and set the desired Type  or Date.

A new Log Viewer window displays the
selected log type and date.

change the log type
displayed at start-up

select Options -> Default Type . In the
window which opens (cf. Figure 3-13),
click on the new default log type and
press Apply  or, to set no new default
type, press Cancel .

The selected log type is displayed by
default whenever a new Log Viewer win-
dow is opened.

print displayed log select File -> Print Table  or File -> Pre-
view

The Log Viewer table or a screenshot of
the window is printed out.

display updated log select File -> Reload Newly logged entries are displayed.

sort the log click on one of the column headers to
sort the log according to the column en-
tries alphabetically or by date and time.
Click again to reverse the sort order.

The Log Viewer table is displayed sorted
alphabetically or by date and time.

close one Log
Viewer window

select File -> Close  or press Close The selected Log Viewer window is
closed.

close all Log Viewer
windows

select File -> Exit All Log Viewer windows are closed.

Table 3-25 Menus and Functions

Menu Item Function

Actions
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The following window pops up if you have chosen to set a new default log type via
Options -> Default Type to be displayed at every start-up of the Log Viewer. You
can select a log type and press Ok or close the window without any actions with
Cancel .

Figure 3-13 Set Default Type

Select Default View
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3.8 System Variables

The values of some system variables are specified in the file
AnyMediaNBEM.cfg which is located in the directory $ANYMEDIAPATH/cfg/ .
The system variables can be changed by editing their values in this file with a text
editor. The changes take effect after the system is restarted.

The following table shows selected variable names, their meaning and default val-
ues. The locations of the directories are relative to the main installation directory
of the AEM-NB.

Table 3-27 System Variables and their Default Values

System Property Variable Name Default Value

Location of alarm database AM.databaseLocation AM/db

Location of configuration management data-
base

CM.databaseLocation CM/db

Location of NE management database NEM.databaseLocation NEM/db

Location of security database OAM.security.databaseLocation Security/db

Location of Non-volatile Data Storage
(NVDS)

CM.directoryNVDS CM/nefiles/NVDS

Location of log files OAM.log.directoryCurrentLogs log

Minimum number of days (incl. current day)
in the log

OAM.log.minimumDaysKept 7

Maximum size of all logged data OAM.log.maximumTotalLogSize 15

Stop OrbixMT (3rd party software) when the
AEM-NB goes down

Gen.3rdParty.mgmtOrbixMT true

Stop OrbixNames (3rd party software) when
the AEM-NB goes down

Gen.3rdParty.mgmtOrbixNames true

Stop OrbixTalk (3rd party software) when
the AEM-NB goes down

Gen.3rdParty.mgmtOrbixTalk true

Stop ObjectStore (3rd party software) when
the AEM-NB goes down

Gen.3rdParty.mgmtObjectStore true
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4.1 Introduction

This chapter describes the "User Administration and Profiling" application. It al-
lows to

■ create/modify/delete users

■ assign/unassign users to/from user groups

■ create/modify/delete user groups

■ assign/unassign user groups access to/from applications, tasks and do-
mains

■ create/modify/delete domains

■ assign/unassign controlled objects to/from domains.

NOTE:
All actions can only be done by the AEM-NB administrator!
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4.2 User

4.2.1 Create User

This chapter describes the process to add a new user to the system. Before add-
ing a new user to the system, please pay attention to the following remarks:

■ The AEM-NB administrator must have a system login.

■ The user must be created via OS.

■ The AEM-NB administrator should know the login ID of the user to be cre-
ated and the group the user shall belong to.

Complete the following procedure to add a new user:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-1 Access Bar

2. Select the third  icon.
The User Administration window pops up showing the Users Table.

Introduction

Procedure
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Figure 4-2 "Users Table"

3. Click New.
The User Profile window pops up.

Figure 4-3 Window "User Profile"
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4. Enter a new login name in the Login Name  field (this is mandatory - 3 to
12 characters) and extra information like last name, first name, email, etc.
in the User Name Description field (this is optional - 0 to 60 characters).
Any characters are allowed.

5. Select one or more user groups the user shall belong to in the User
Groups Not Assigned  field and Click Add .

NOTE:
To create user groups see Chapter 4.4.1, page 4-17.

6. Click OK or Apply  to save the settings (the system ensures that the new
user does not yet exist in the system). After clicking OK the window will be
closed.
If you want to reject the settings, click Close before OK or Apply .

The other fields are described in Chapter 4.2.2, page 4-4.

4.2.2 Modify User

This chapter describes the process to modify the information or profile of a user.
Before modifying the information or profile of a user, please pay attention to the
following remarks:

■ To modify the information or profile of a user the AEM-NB administrator
must have a system login.

■ The AEM-NB administrator is not able to change the system login informa-
tion of a user, i.e. system login and password.

Complete the following procedure to modify the information or profile of a user:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-4 Access Bar

2. Select the third  icon.
The User Administration window pops up showing the Users Table.

Introduction

Procedure
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Figure 4-5 "Users Table"

3. Select one user of the Login Name  field and click Open .
The User Profile window pops up with the current information about the
selected user.

Figure 4-6 Window "User Profile"
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To change the user name description like last name, first name, email, etc., enter
the new information in the User Name Description field (0 to 60 characters). Any
characters are allowed.

To assign the selected user to further user groups, select one or more user groups
in the User Groups Not Assigned  field and click Add .

NOTE:
To create user groups see Chapter 4.4.1, page 4-17.

To remove the selected user from user groups, select one or more user groups in
the User Groups Assigned  field and click Remove .

Click OK or Apply  to save the changes. After clicking OK the window will be
closed.
If you want to reject the changes, click Close before OK or Apply .

The following fields are read-only fields to display user data:

Login Name:
Displays the label which identifies the user.

User Status:
Displays if the system login associated to this user is created (enabled) or deleted
(disabled).

Number of sessions opened:
Displays the number of sessions opened into the AEM-NB by the user.

4.2.3 Delete User

This chapter describes the process to remove a user from the AEM-NB. Before re-
moving a user, please pay attention to the following remarks:

■ To remove a user from the AEM-NB the administrator must have a system
login.

■ When a user is deleted, all related information and profiles are removed
from the system. This does not include the system login and any other sys-
tem resources such as home directories or system files which are not man-
aged by the AEM-NB. Furthermore, the user is automatically deleted from
the user groups it was included in.

■ Before deleting any user assigned to the administrator user group, the
AEM-NB checks that this is not the last user assigned to the administrator
user group. If this is the last one assigned, the deletion is rejected.

Change User Name
Description

Adding to
User Groups

Removing from
User Groups

Other Fields
(read-only)

Introduction
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Complete the following procedure to remove a user from the AEM-NB:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-7 Access Bar

2. Select the third  icon.
The User Administration window pops up showing the Users Table.

Figure 4-8 "Users Table"

3. Select the user which shall be deleted in the Login Name  field and click
Delete .

4. Confirm your selection. The window will be closed.

Procedure
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4.3 Domains

4.3.1 Create Domains

This chapter describes the process to create a new domain. Before creating a
new domain, please pay attention to the following remarks:

■ The AEM-NB administrator must have a system login.

■ The controlled objects are defined as sets of managed NEs.

■ Only "EM" and "NE" controlled object types are supported.

NOTE:
An "EM" object is generated by default with "Type: EM" and "Value: AnyMe-
dia" which cannot be deleted.

Complete the following procedure to create a new domain:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-9 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-10 Window "User Administration"

Introduction

Procedure
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3. Select View -> Domains .
The Domains Table appears.

Figure 4-11 "Domains Table"
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4. Click New.
The Domain Profile window pops up.

Figure 4-12 Window "Domain Profile"

5. Enter a new domain name in the Domain Name  field (this is mandatory -
3 to 30 characters) and extra information in the Description  field (this is
optional - 0 to 60 characters). Any characters are allowed.

6. Select one or more controlled objects that shall belong to the new domain
in the Controlled Objects Not Assigned field and click Add .

NOTE:
Each controlled object consists of two fields: Type and Value.

7. Select one or more user groups that shall have access to the new domain
in the User Groups Not Assigned field and click Add .
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NOTE:
To create user groups see Chapter 4.4.1, page 4-17.

8. Click OK or Apply  to save the settings (the system ensures that the new
domain does not yet exist in the system). After clicking OK the window will
be closed.
If you want to reject the settings, click Close before OK or Apply .

The other fields are described in Chapter 4.3.2, page 4-11.

4.3.2 Modify Domains

This chapter describes the process to modify the information of a domain, e.g.
which devices it includes, etc. Before modifying the information of a domain, the
AEM-NB administrator must have a system login.

Complete the following procedure to modify the information of a domain:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-13 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-14 Window "User Administration"

Introduction

Procedure



4-12 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

User Management Domains

3. Select View -> Domains .
The Domains Table appears.

Figure 4-15 "Domains Table"
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4. Select one domain in the Domain Name  field and click Open .
The Domain Profile window pops up with the current information about
the selected domain.

Figure 4-16 Window "Domain Profile"

To change the domain name, enter the new name in the Domain Name field (3 to
30 characters). Any characters are allowed.

To change the domain description, enter the new information in the Description
field (0 to 60 characters). Any characters are allowed.

To assign further controlled objects to the selected domain, select one or more
controlled objects in the Controlled Objects Not Assigned  field and click Add .

NOTE:
Each controlled object consists of two fields: Type and Value.

Change
Domain Name

Change Domain
Description

Adding
Controlled Objects
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To remove assigned controlled objects from the selected domain, select one or
more controlled objects in the Controlled Objects Assigned  field and click
Remove .

NOTE:
Each controlled object consists of two fields: Type and Value.

To give further user groups access to the selected domain, select one or more
user groups in the User Groups Not Assigned  field and click Add .

NOTE:
To create user groups see Chapter 4.4.1, page 4-17.

To remove assigned user groups from the selected domain, select one or more
user groups in the User Groups Assigned  field and click Remove .

Click OK or Apply  to save the changes. After clicking OK the window will be
closed.
If you want to reject the changes, click Close before OK or Apply .

4.3.3 Delete Domains

This chapter describes the process to remove a domain from the AEM-NB. Before
removing a domain, please pay attention to the following remarks:

■ The AEM-NB administrator must have a system login.

■ Before deleting a domain, the AEM-NB ensures that there are no controlled
objects assigned to this domain. If this is the case, the deletion request will
be rejected.

■ After a domain deletion, all related information will be removed from the
AEM-NB. This does not include the devices (NEs or any other type) which
are grouped in that domain or their information. Furthermore, the access
permission will be automatically unassigned from the user groups that had
access to this domain.

Removing
Controlled Objects

Adding
User Groups

Removing
User Groups
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Complete the following procedure to remove a domain:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-17 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-18 Window "User Administration"

Procedure
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3. Select View -> Domains .
The Domains Table appears.

Figure 4-19 "Domains Table"

4. Select the domain which shall be deleted in the Domain Name  field and
click Delete .

5. Confirm your selection. The window will be closed.
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4.4 User Groups

4.4.1 Create User Groups

This chapter describes the process to create a new user group. Before creating a
new user group, please pay attention to the following remarks:

■ By default the AEM-NB provides three user groups: Administrator, Mainte-
nance and Monitoring.

■ The administrator user group shall be assigned access permissions to all
domains, applications and tasks.

■ Before a user group can be created, modified or deleted the AEM-NB ad-
ministrator must have a system login.

■ Applications are divided into tasks. A user can be assigned a whole appli-
cation or only a subset of its tasks.

Complete the following procedure to create a new user group:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-20 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-21 Window "User Administration"

Introduction

Procedure
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3. Select View -> User Groups .
The User Groups Table appears.

Figure 4-22 "User Groups Table"
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4. Click New.
The User Group Profile window pops up.

Figure 4-23 Window "User Group Profile"

5. Enter a new user group name in the User Group Name field (this is man-
datory - 3 to 30 characters) and extra information in the Description field
(this is optional - 0 to 60 characters). Any characters are allowed.

6. Click Users .

7. Select one or more users that shall belong to the new user group in the
Users Not Assigned  field and click Add .

NOTE:
To create user see Chapter 4.2.1, page 4-2.

8. Click Domains .

9. Select one or more domains the user group shall has access to in the Do-
mains Not Assigned  field and click Add .
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NOTE:
If access permission to a domain is granted to a user group, that permis-
sion will be automatically granted for each controlled object within that do-
main.

NOTE:
To create domains see Chapter 4.3.1, page 4-8.

For carrying out the next three steps (10, 11 and 12) please pay attention to
Table 4-1. It provides an overview about the access permissions the user groups
shall have.

Table 4-1 Assignment of User Groups to Applications/Tasks

Application Task User Group

System
Administration

Start-up / Shutdown Administrator

Monitoring Administrator

User Administration
and Profiling

Access Policy
Management

Administrator

Domain Management Administrator

Log Viewer Actions Administrator, Maintenance

System Internal Events Administrator, Maintenance

Autonomous Report Administrator, Maintenance,
Monitoring

Alarm Viewer Acknowledge Administrator, Maintenance

Viewa

a If the VIEW task is unassigned but other tasks are still assigned, these tasks are left as assigned
to this user group. But the user is not able to perform any kind of operation over these tasks until
the VIEW task is assigned again.

Administrator, Maintenance,
Monitoring

Clear Administrator, Maintenance

Configuration
Manager

NE Creation Administrator, Maintenance

Equipment and
Service Provisioning

Administrator, Maintenance

Viewa Administrator, Maintenance,
Monitoring

Test Administrator, Maintenance,
Monitoring

Cut-through Administrator

BroadBand EM BroadBand EM Administrator, Maintenance,
Monitoring
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The most of the task names are self described, but other tasks needs a deeper
description:

Access Policy Management  provides the functionality to:

■ create/modify/delete AEM-NB users

■ create/modify/delete AEM-NB user groups

■ create/modify/delete AEM-NB domains

■ create/modify/delete assignments between AEM-NB users and AEM-NB
user groups

■ create/modify/delete access assignments between AEM-NB user groups
and applications/tasks

■ create/modify/delete access assignments between AEM-NB user groups
and domains

■ modify assignments between domains and controlled objects.

Domain Management  provides the functionality to:

■ modify assignments between domains and controlled objects.

NE Creation  provides the functionality to:

■ create/modify/delete controlled objects with Type NE.

10. Click Applications & Tasks .

11. Select one or more applications the user group shall has access to in the
Applications Not Assigned  field and click Add .
The corresponding tasks are displayed for selection.

12. Select one or more tasks the user group shall has access to in the Tasks
Not Assigned  field and click Add .

13. Click OK or Apply  to save the settings (the system ensures that the new
user does not yet exist in the system). After clicking OK the window will be
closed.
If you want to reject the settings, click Close before OK or Apply .

The other fields are described in Chapter 4.4.2, page 4-22.
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4.4.2 Modify User Groups

This chapter describes the process to modify the properties of a user group. Be-
fore modifying the properties of a user group, please pay attention to the following
remarks:

■ The AEM-NB administrator must have a system login.

■ The administrator user group shall be assigned access permissions to all
applications and tasks and these access permissions shall not be modified.

Complete the following procedure to create a new user group:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-24 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-25 Window "User Administration"
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3. Select View -> User Groups .
The User Groups Table appears.

Figure 4-26 "User Groups Table"



4-24 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

User Management User Groups

4. Select one user group of the User Group Name  field and click Open .
The User Group Profile window pops up with the current information
about the selected user group.

Figure 4-27 Window "User Group Profile"

To change the user group name, enter the new name in the User Group Name
field (3 to 30 characters). Any characters are allowed.

To change the user group description, enter the new information in the Descrip-
tion field (0 to 60 characters). Any characters are allowed.

To assign further users to the selected user group, click Users , select one or more
users in the Users Not Assigned  field and click Add .

NOTE:
To create user see Chapter 4.2.1, page 4-2.

To remove assigned users from the selected user group, click Users , select one
or more users in the Users Assigned  field and click Remove .

NOTE:
The last user of user group administrator is protected against deletions.

Change
User Group Name

Change User Group
Description

Adding
Users

Removing
Users
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To give the selected user group access to further domains, click Domains , select
one or more domains in the Domains Not Assigned  field and click Add .

NOTE:
If access permission to a domain is granted to a user group, that permis-
sion will be automatically granted for each controlled object within that do-
main.

NOTE:
To create domains see Chapter 4.3.1, page 4-8.

To disable the access to one or more domains, click Domains , select one or more
domains in the Domains Assigned  field and click Remove .

NOTE:
The administrator user group shall be assigned access permissions to all
domains and this access permissions shall not be modified.

To give the selected user group access to further applications, click Applications
& Tasks , select one or more applications in the Applications Not Assigned field
and click Add .

NOTE:
For this action please pay attention to Table 4-1, page 4-20.

To disable the access to one or more applications, click Applications & Tasks,
select one or more applications in the Applications Assigned  field and click Re-
move . For this action please pay attention to Table 4-1, page 4-20.

NOTE:
The administrator user group shall be assigned access permissions to all
applications and this access permissions shall not be modified.

NOTE:
If the user select an application in the Applications Assigned field, all tasks
that are under it will be expanded in the Tasks Assigned and Tasks Not As-
signed fields.

To give the selected user group access to further tasks, select one or more tasks
in the Tasks Not Assigned  field and click Add .

NOTE:
For this action please pay attention to Table 4-1, page 4-20.

Adding to
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To disable the access to one or more tasks, select one or more tasks in the Tasks
Assigned  field and click Remove . For this action please pay attention to
Table 4-1, page 4-20.

NOTE:
If the task "View" is removed, also the tasks "Acknowledge" and "Clear" are
not possible (but not removed).

NOTE:
The administrator user group shall be assigned access permissions to all
tasks and this access permissions shall not be modified.

Click OK or Apply  to save the changes. After clicking OK the window will be
closed. If you want to reject the changes, click Close before OK or Apply .

4.4.3 Delete User Groups

This chapter describes the process to remove a user group from the AEM-NB. Be-
fore removing a user group, please pay attention to the following remarks:

■ The AEM-NB administrator must have a system login.

■ The administrator user group is protected against deletions.

■ After a user group deletion, all related information is removed from the
AEM-NB. This does not include the contained users or their information,
but these users will lose the ability to invoke the applications, tasks, devices
and maps for which the user group had permission.

Complete the following procedure to remove a user group:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-28 Access Bar
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2. Select the third  icon.
The User Administration window pops up.

Figure 4-29 Window "User Administration"

3. Select View -> User Groups .
The User Groups Table appears.

Figure 4-30 "User Groups Table"

4. Select the user group which shall be deleted in the User Group Name
field and click Delete .

NOTE:
The administrator user group is protected against deletion.

5. Confirm your selection. The window will be closed.
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4.5 Controlled Objects

4.5.1 Modify Controlled Objects

This chapter describes the process to modify the information about existing con-
trolled objects. The controlled object creation and deletion are not covered by this
document. For NE creation and deletion refer to Chapter 5.3.1 and Chapter 5.3.3.

Before modifying the information about any controlled object the AEM-NB admin-
istrator must have a system login.

Complete the following procedure to modify the information about existing con-
trolled objects:

Step Procedure

1. Login as AEM-NB administrator.
After the login process is complete the Access Bar pops up.

Figure 4-31 Access Bar

2. Select the third  icon.
The User Administration window pops up.

Figure 4-32 Window "User Administration"

Introduction

Procedure
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3. Select View -> Controlled Objects .
The Controlled Objects Table appears.

Figure 4-33 "Controlled Objects Table"
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4. Select one controlled object type in the Controlled Object Type field and
click Open .
The Controlled Object Profile window pops up with the current information
about the selected controlled object.

Figure 4-34 Window "Controlled Object Profile"

To assign the selected controlled object to further domains, select one or more
domains in the Domains Not Assigned  field and click Add .

NOTE:
To create domains see Chapter 4.3.1, page 4-8.

To remove the selected controlled object from domains, select one or more do-
mains in the Domains Assigned  field and click Remove .

NOTE:
The "EM" object generated by default is protected against deletion.

Click OK or Apply  to save the changes. After clicking OK the window will be
closed.
If you want to reject the changes, click Close before OK or Apply .

Adding to
Domains

Removing from
Domains
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The following fields are read-only fields to display data of the selected controlled
object:

Controlled Object Type:
Displays the controlled object type. Possible values are EM and NE.

Value:
Displays the characteristics of the selected controlled object (e.g. NE name).

Other Fields
(read-only)
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5.1 Overview

This chapter describes the Configuration Manager application of the AnyMedia®

Access System Element Manager for Narrowband Services (AEM-NB). It ad-
dresses the following topics:

■ Overview of the controlled AnyMedia Access System.

■ Explanation of Menu bar and Network Browser.

■ Screen navigation.

■ Equipment Configuration and Service Provisioning.

5.1.1 Overview of AnyMedia Access System
R1.5

The architecture of the AnyMedia Access System R1.5 is a single shelf with the
following main components as shown in Figure 5-1, page 5-2:

■ Up to 6 IO_DS1 packs

■ Up to two Common Data and Control (COMDAC) packs

■ One Craft Test Unit (CTU) pack

■ Up to 16 Application Packs (APs)

— 32-line 2WCF Programmable: PROG2W a.k.a. POTS 32/512 a.k.a.
PROG32.

— 32-line 2WCF POTS only: a.k.a. POTS32.

— 32-line 2W Programmable Special/Coin:
PRCOIN a.k.a. PROG1_CF.

— 16-line ANSI ISDN: ISDN AP a.k.a. ISDN16_u.
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— AFM_DS33: The Access Feeder Multiplexer card provides a DS3
ATM interface for ADSL traffic (one or more AFMs the in right-most
AP slot(s)).1

— ADSL4: The Quad ADSI packs provide four ADSL subscriber line
terminations each.

— Metallic Distribution Server Units (MDSUs):
The AnyMedia Access System supports the MDS2 and MDS2B
shelves (Chapter 5.1.1.1, page 5-3) for installation of SLC carrier
channel units. Only narrowband transmission is planned for this
shelf. MDS2/MDS2B shelves are connected via an electrical inter-
face through one or two Metallic Distribution Server Units APs that,
in effect, extend the PCM Highway from the AnyMedia Access Sys-
tem backplane to the MDS2/MDS2B. An MDSU can be located in
any AP slot; however, the MDSUs will normally be located in AP
slots 14 and 15 to simplify shelf cabling. One MDSU extends 1.5
PCM Highways to a controller (MSC) in the MDS2/MDS2B Shelf. In
order to extend 3 PCM Highways to both sections of the
MDS2/MDS2B Shelf, two MDSUs must be installed (MSU100 -
SAPQADMBAA).

Figure 5-1 AnyMedia Shelf Layout (Release 1.2)

1 Even when the AnyMedia Access System AEM-NB directly manages only the narrowband
plug-ins of the AnyMedia Access System, the broadband packs will also be displayed to
provide the required integration level between both managers.

01 02 03 04 05 06

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

A
pp

lic
at

io
n 

P
ac

k

C
O

M
D

A
C

07 08 0910 11 12 13

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

A
pp

lic
at

io
n 

P
ac

k
A

pp
lic

at
io

n 
P

ac
k

C
O

M
D

A
C

1 2 141

A
pp

lic
at

io
n 

P
ac

k

 C
T

U

A
pp

lic
at

io
n 

P
ac

k

A
pp

lic
at

io
n 

P
ac

k

15 16IO
_D

S
1p

IO
_D

S
1

IO
_D

S
1

IO
_D

S
1

IO
_D

S
1

IO
_D

S
1

Fusing



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-3

AEM-NB R1.5

Overview

5.1.1.1 MDS2/MDS2B Shelf Layout

The use of the MDS2 or MDS2B Shelf is optional. If it is used, one or two AnyMe-
dia Access System AP slots are equipped with the MDSUs server units, each of
which connects to an MSC (Metallic Shelf Controller) pack in the MDS2 Shelf. The
MDS2/MDS2B Shelf, based on the SLC-2000 Metallic Distribution Shelf (MDS),
has the capacity to hold 24 SLC (SPQ or AUA) channel units and to serve up to 96
DS0-rate services.

The MDS2/MDS2B Shelf is used to provide specials via SPQ/AUA Channel Units.
A maximum of one MDS2/MDS2B Shelf is supported per AnyMedia Access Sys-
tem. The shelf can serve up to 96 DS0s in 24 slots; each MDSU pack on the Any-
Media Access System shelf can serve up to 48 DS0s and up to 12 channel units
(CU). The MDSU APs primarily serve as pass-through for the PCM transmission
and the UART messages. All control messages to and from the MDS2/MDS2B
Shelf are routed through the MDSU packs; the MDSU-1 pack serves the first 12
slots (slots 1 through 12) on the MDS2, the MDSU-2 pack serves the remaining
12 (slots 13 through 24).

The MDS2/MDS2B Shelf may be equipped so that only half of the shelf is opera-
tional (12 channel units). For this case, only one MDSU is needed in the AnyMe-
dia Shelf. A partially-equipped (half) MDS2 Shelf requires one PTU (Power Test
Unit) and one MSC.

The MDSUs utilize the same timing signals as the narrowband APs. A single
8-MHz clock and 8-kHz sync are supplied by an MDSU to an MCS in the MDS2/
MSD2B for timing the MDS2/MSD2B link. Side selection of the clock and sync
from the COMDACs is performed by the MDSU.

The MDS2 shelf shown in Figure 5-2 is arranged to accommodate 12 CU circuit
packs, a PTU and an MSC pack per section. The first, or left, section is a mirror
image of the second, or right, section.

Figure 5-2 MDS2 Shelf Layout

The MDS2B shelf shown in Figure 5-3, page 5-4 is arranged to accomodate 12
CU circuit packs, a PTU and MSC pack pre section. The fist, or top, section is a
mirror image of the second, or down, section.
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Figure 5-3 MDS2B Shelf Layout

The MSC provides the required shelf interface and central control for half of the
shelf. Each MSC is two slots wide but has only one backplane connector. An
8-MHz MDS2 link is provided to interface with the AnyMedia Access System shelf.
On the distribution side the MSC supports 3 4.096-Mbps PCM links for connecting
12 channel units. The MSC performs the following functions:

■ Translates between 1.5 AnyMedia Access System PCM Highways and 3
SLC carrier format PCM buses

■ Performs rate conversion from incoming 8-MHz link and distributes timing
and synchronization to CUs

■ Translates between one AnyMedia Access System UART link and the SLC
carrier Bank Controller Link (BCL) and PTU control interfaces

■ Control and monitoring for CUs and PTUs

■ Composite clock input and DDS (Digital Data System) timing distribution to
CUs

■ Supports signaling bit translation and signaling state transition detection for
DID (Direct Inward Dialing) services on TR-303.

■ The MSC is a simplex pack. The MSC hardware can support software
download. (AEM-NB R1.5 does not support this feature).

The PTU has power converters to distribute +5V and -5V power to the CUs and
5V power to the MSC. Each PTU powers 12 CUs and one MSC. Positive and neg-
ative ringing inputs are looped through each PTU so that each PTU distributes
ringing to the 12 CUs it provides power to. The PTU can detect the loss of its ring-
ing inputs. The PTU has relays and protectors for test access. It also has termina-
tions and detectors for channel testing. Each PTU also supports one TAP (Test
Access Path). The PTU2 TAP (TAP-A) is required for special services testing and
local test access, the PTU1 TAP (TAP-B) is required for POTS testing.

SLC carrier (SPQ and AUA type) channel units will be used. All intelligence about
the CUs, their register formats and locations, the PTU message sets, etc., reside
on the COMDAC. The set of SLC channel units supported is shown below:
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■ AUA293 BRITE III

■ SPQ429 Quad P-phone CF

■ SPQ442 Quad E SPOTS CS

■ AUA41B 4W CF, inventory ready

■ AUA45B Ringing repeater (manual ringdown)

■ AUA75 PLAR

■ SPQ452 Dual Dataport OCU

■ AUA200 SW 56 2W CU (Adtran)

■ AUA232 RS-232(Adtran)

■ SPQ444 Single 4W CS w/TDM

■ SPQ454 Single 4W E&M Types I & II

■ MCU-5205 DC alarm CU (Tollgrade)

■ MCU-5405 DC bypass CU (Tollgrade).

5.1.1.2 Virtual Remote Terminals

The AnyMedia Access System can be configured to be logically divided into a
number of separate virtual terminals that provide three types of voice frequency
service node interfaces: TR303, TR08 and INA.

5.1.1.3 OAM&P Interfaces

There are three operations, administration, maintenance and provisioning
(OAM&P) interfaces to the AnyMedia Access System shelf for telephony applica-
tions:

■ Local EIA-232D serial port on the CTU DTP100 in the AnyMedia Access
System shelf to which a TL1 system interface (TL1SI or CIT) or a GSI can
be connected. This interface is typically used during initial installation.

■ A local LAN interface on the AnyMedia Access System shelf provides ac-
cess to an IEEE 802.3-compliant LAN through a 10BaseT connection. All
communications through this interface will be over Transaction Control Pro-
tocol/Internet Protocol (TCP/IP), and is the way to the AEM-NB.

■ Remote Operations Channel: a remote LAN interface, which uses TCP/IP
to communicate with the AEM-NB. The OAM&P functionality is provided
via a nailed-up DS0 link that is part of the DS1 (payload) connectivity to the
AnyMedia Access System shelf. The DS0 link originates from a data com-
munication network (DCN) that supports TCP/IP over an Ethernet LAN
connection on the AEM-NB side and does a translation to a wide area net-
work (WAN) via multiple DS0s on the other.
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5.1.1.4 External Interfaces for Circuit Testing

The AnyMedia Access System provides three external interfaces for circuit test-
ing:

■ Local access for manual testing via jacks on the CTU DPT 100

■ Connection to the Test Access Path (TAP) - B

■ Remote Test Unit (RTU-2) via the tip/ring leads from two APs VF port cir-
cuits.

5.1.1.5 Synchronization Interfaces

The AnyMedia Access System supports four timing modes which can be provi-
sioned by the AEM-NB:

■ External DS1

■ External Composite Office Clock

■ Free Running Mode

■ Loop Timed Mode.

The provisioning options are described in Chapter 5.3.2.4, page 5-52.

5.1.1.6 Plug & Play Capabilities

The circuit packs associated with the AnyMedia Access System have the capabil-
ity to self-identify themselves with inventory data. This capability is very useful
during the execution of provisioning and maintenance procedures.

For example, upon insertion of the new circuit pack in the AnyMedia Access Sys-
tem Shelf, the inventory data of the new pack, as well as its serial number, slot
and pack entity, will be reported to the AEM-NB and/or GSI interface. The removal
of any plug-in unit will be announced also.

5.1.1.7 NE Equipment Configuration-Related
Tasks

The NE equipment configuration facilities provided by the AEM-NB cover the op-
erations that control and provision the NE, including the following:

■ Configuration Specific Equipment Data - which involves tasks for:

■ NE Creation & Deletion

■ Circuit Pack Management

— COMDAC Management

— IO_DS1s Management - Physical Feeder Management

— CTU Management

— AP Management

■ Protection Management
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■ Slot Alarming Configuration

■ Date & Time Management

■ NE Security Configuration

■ Timing Synchronization Provisioning

■ Maintaining a local copy of the NE Provisioning Data - which includes tasks
for:

■ Initializing the local copy when an NE is add to the AEM-NB

■ Maintaining the local copy concerning equipment changes

■ Synchronizing the local copy with the equipment data maintained by
the NE, and reporting differences.

■ Inventory Management  - system activity of collecting, updating and re-
porting data on AnyMedia Access System equipage and system status, in-
cluding providing users with access to the entire equipment information,
whether locally maintained or not.

■ NE Memory Administration  - this means the management of the Nonvol-
atile Data Storage (NVDS) of the AnyMedia Access System: Backup & Re-
store

■ NE Software Administration - this involves tasks to manage the Nonvola-
tile Program Storage (NVPS) of the AnyMedia Access System: software
download, copying the NVPS between controller CARDS, etc.

■ MDS2/MDS2B management  - which, in this release, involves:

■ MDS2/MDS2B shelf Slots Alarming Configuration.

■ Retrieve & Maintain MDS2/MDS2B Inventory information.

For more information refer to the AMAS R1.5 network elements documentation.
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5.2 Configuration Manager Win-
dow

This major application provides the operator with the facilities needed to fully con-
figure AnyMedia network elements (both equipment and services).

Figure 5-4 Configuration Manager

The initial window consists of two frames:

■ At the top, a menu bar  provides access to all possible operations on the
network elements (cf. Chapter 5.2.2, page 5-9).

■ On the left-hand side, the screen displays a tree-like structure (known as
the Network Browser ) with the list of NEs created and manageable by the
AEM-NB (see below).

Depending on previous actions the following frames are additionally available:

■ On the right-hand side, a common area is used for the display of the infor-
mation requested through the menu bar, cursor menu or tool bar (if
present).
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■ A status bar is incorporated at the bottom of every single screen except of
Network Browser and menu bar (cf. Chapter 5.2.3, page 5-11).

■ The cursor menu  will pop up at the cursor position when the right mouse
button is pressed (cf. Chapter 5.2.4, page 5-12).

5.2.1 Network Browser

The Network Browser  displays the list of all NEs available to the operator in a
tree-like structure. You can select the object you want to configure, view, modify or
delete. The action to be taken is selected from the Menu bar or the object’s pop up
menu (cursor menu). By default the first time this window is opened, level two is
displayed (i.e. all NEs).

By selecting an NE it is possible to gradually explode this level to display the
shelf(s), slots and ports (if any), as well as network interfaces, and user ports.

The Network Browser displays (at the NE level) an icon that identifies the connec-
tion state of each NE (not connected, not connected (trying), not connected (can-
celling), connected (synchronizing) and connected.

5.2.2 Menu Bar

The Menu bar entries are enabled/disabled depending on the object selected in
the Network Browser. The following table describes the Menu bar’s main entries
and subsequent submenus. The right column (Available at level) identifies the
Network Browser item that needs to be selected to have this menu option avail-
able to the user.

Menu entries Available at level

File -> New -> NE All

File -> Open NE, Shelf, Slot, User Port
(physical and logical), Phys-
ical DS1 (physical and logi-
cal), Logical DS1 List, Logi-
cal TO List, VRT/VB List,
VRT/VB id

File -> Delete NE

File -> Print -> Window

File -> Print -> Table

File -> Print -> Preview

File -> Exit Any

Edit -> Cut Text editing field

Edit -> Copy Text editing field

Edit -> Paste Text editing field

NE Connection
State
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Edit -> Clear Text editing field

View -> Expand Branch (+ sign on the left) Any

View -> Collapse Branch (- sign on the left) Any

View -> Reload Window

Equipment -> Provisioning -> Create -> NE All

Equipment -> Provisioning -> Edit/View NE, Shelf, Slot, DS1 Feeder,
Port (User Port/Physical
DS1)

Equipment -> Provisioning -> Delete NE

Equipment -> Provisioning -> Time Source
Control

NE

Equipment -> Provisioning -> Date & Time NE

Equipment -> NE Inventory Data NE

Equipment -> EM-NE Synchronization NE

Equipment -> NE Reset (INIT-SYS) NE

Equipment -> NE SW Download All

Equipment -> NE NVDS Backup NE

Equipment -> NE NVDS Restore NE

Equipment -> Shelf View Shelf, MDS2 Shelf
MDS2Shelf

Equipment -> Protection Shelf

Equipment -> Program Copy Shelf

Equipment -> Loopback Physical DS1

Service -> Provisioning -> Add -> Logical DS1 VRT/VB id

Service -> Provisioning -> Add -> Logical T0 VRT/VB id, User Port

Service -> Provisioning -> Edit/View Network Interfaces List,
Logical DS1 List, Logical T0
List

Service -> VRT/VBs List NE

Service -> Logical DS1 List NE

Service -> Logical T0 List NE

Alarms -> Alarm Viewer
(cf. Chapter 6.3, page 6-10)

NE

Menu entries Available at level
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5.2.3 Status Bar

Feedback from the NE is displayed on screen, as is progress information related
to the commands issued by the AEM-NB. This feedback is provided by the status
bar incorporated at the bottom of every single screen except Network Browser
and Menu bar.

Figure 5-5 Status Bar (Example)

The status bar is composed of three sub-areas:

■ Message area : Used to display feedback. It indicates what is being done.
The last feedback message sent by the NE is displayed until a new com-
mand is sent or the window is closed.

■ Progress area : Informs the user there are jobs running

Test Manager -> Physical Port Test  (cf.
Chapter 6.4.1, page 6-24)

Port

Test Manager -> AP Test  (cf. Chapter 6.4.2,
page 6-26)

AP

TL1 -> Cut-through NE

Window -> Cascade Any

Window -> Window 1 Any

Window -> Window 2 Any

Help -> Index Any (displays the help index
for navigation through the
EM help information)

Help -> On Window Any (case sensitive online
help).

Menu entries Available at level

Obtaining operational state for ds1-1-1-2

Message area (feedback) Progress area

Stop/Cancel button

Progress bar
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■ Stop / Cancel button : for commands: allows cancellation of commands.
Note that Cancel does not imply undo.

If you try to close the window and the last command executed has not finished yet,
you will be informed (Warning window) that there are still jobs running:

You have running jobs. Do you want to continue?

You have to decide whether to continue or wait until the job is finished.

5.2.4 Cursor Menu

Some objects in windows have a menu associated with them. This menu will pop
up at the cursor position when the right mouse button is pressed. The cursor must
not, however, be positioned on a Menu bar or a window frame. The cursor menu is
not available in all dialogue boxes. The functions which can be executed using this
cursor menu depend on the application of the respective dialogue box.

Proceed as follows to select a menu option from the cursor menu:

Step Procedure

1. Press and hold down the right mouse button.

2. Drag the cursor onto the desired menu option.

Release the right mouse button to execute the menu option, or if you do not wish
to execute a menu option, move the cursor away from the menu and release the
right mouse button.

5.2.4.1 Structure and Cursor Menus

In the following table, the last column contains the cursor menus. It also shows (in
parenthesis) the name of the window launched if the name of the cursor menu en-
try and the name of the window are not the same.

Browser entries
Cursor menu entries and asso-
ciated windows

All Create NE (NE Information)

All -> NE NE Information
Cut Through
Delete NE

All -> NE -> Shelf Shelf View
Protection
Program Copy

All -> NE -> Shelf -> IO-DS1 Edit (IO-DS1)

Menu at the cursor
position

Select menu
option
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All -> NE -> Shelf -> IO-DS1 -> Physical DS1 Add/Edit (Physical DS1-Logi-
cal DS1)
Loopback (Physical DS1-Logi-
cal DS1)

All -> NE -> Shelf -> COMDAC Edit (COMDAC)

All -> NE -> Shelf -> CTU Edit (CTU)

All -> NE -> Shelf -> AP Edit (AP)
AP Test

All -> NE -> Shelf -> AP -> User Port (Logi-
cal T0)

Add/Edit Logical T0 (Logical
T0)
Physical Port Test

All -> NE -> Shelf -> MDS2-1 MDS2 Shelf View

All -> NE -> Shelf -> MDS2B-1 MDS2B Shelf View

All -> NE -> Shelf -> MDS2-1 -> MSC Edit (MSC)

All -> NE -> Shelf -> MDS2B-1 -> MSC Edit (MSC)

All -> NE -> Shelf -> MDS2-1 -> PTU Edit (PTU)

All -> NE -> Shelf -> MDS2B-1 -> PTU Edit (PTU)

All -> NE -> MDS2-1 -> CU Edit (CU)

All -> NE -> MDS2B-1 -> CU Edit (CU)

All -> NE -> VRT/VBs List Edit (VRT/VB List)

All -> NE -> VRT/VBs List -> VRT/VB Type
(TR-303, TR-08, INA)

Edit (VRT/VB List)

All -> NE -> VRT/VBs List -> VRT/VB Type
(TR-303, TR-08, INA) -> VRT/VB id

Edit (VRT/VB)
Edit Logical DS1 List (Logical
DS1 List)
Edit Logical T0 List (Logical T0
List)
Add Logical DS1 (Physical
DS1-Logical DS1)
Add Logical T0 (Logical T0)

All -> NE -> Logical DS1 List Edit (Logical DS1 List)

All -> NE -> Logical T0 List Edit (Logical T0 List)

Browser entries
Cursor menu entries and asso-
ciated windows
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5.3 Equipment Configuration

Configuration of Specific Equipment Data is the process of preparing the AEM-NB
for control of the AnyMedia Access System by configuring and setting any re-
quired option.

Prior to network interface configuration and service configuration, the AEM-NB
must know some data of the equipment; this is done during the NE creation pro-
cess, which is usually followed by circuit pack configuration.

Then, during NE management, some other tasks regarding equipment configura-
tion can be performed by the AEM-NB, e.g. Date & Time Management, Timing
Synchronization Management, Protection Management, etc.

Finally, if the NE is not managed by the AEM-NB any longer, it shall be deleted
from the AEM-NB database.

The description of equipment configuration is divided in three main sections:

■ Add NE (cf. Chapter 5.3.1, page 5-16)

■ Edit/view configuration data (cf. Chapter 5.3.2, page 5-21)

■ Delete NE (cf. Chapter 5.3.3, page 5-67).

Figure 5-5, page 5-15 shows an overview of the screen navigation for equipment
configuration. In this figure is assumed that the NE is already connected (cf.
Chapter 5.3.1, page 5-16).

The boxes with a gray background show the Network Browser selection the other
boxes show the possible menus that can be reached by using the Menu bar or the
cursor menu.

The arrows represent the order in which the windows can be opened.

To open the COMDAC Shelf Protection window proceed as follows:

■ Select All -> NE -> Shelf -> COMDAC  via the Network Browser and
select Equipment -> Protection  via the Menu bar or

■ Select All -> NE -> Shelf -> via the Network Browser and
select Protection via the cursor menu.

Overview

Examples
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Figure 5-5 Screen Navigation for Equipment Configuration

NE

NE Name Information

NE NVDS
Backup

NE NVDS

NE Details

NE View

NE Inventory
Data

Timing Source
Control

Date &Time

SynchronizationShelf Slot Details

IO-DS1

DS1

CTU

COMDAC

AP

Shelf Protection

COMDAC

IO-DS1

Shelf

Cut-Through

SW Download

Program CopyIn Progress

to Physical DS1-Logical DS1
window (Service Provisioning -
cf. Chapter 5.4, page 5-68)

to Logical T0 window (Service
Provisioning -
cf. Chapter 5.4, page 5-68)

All

Restore

MSD2/B

MDS2 Slot Details

PTU

MSC

CU

User Port

User Port

Shelf MSD2/B

Object

Window (can contain tabs)

Set of related windows
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5.3.1 Add an NE

The following steps are necessary to add an NE:

■ Create NE

■ Assign Domain

■ Connect NE.

To add an NE the following assumptions must be fulfilled:

■ The PC-based GSI (Graphical System Interface) is used to set the NE in a
state where NVDS (Non-Volatile Data Storage) is populated with the mini-
mum values (i.e. target id, IP-address, user id).

■ All those parameters are assumed to be known by the Operator.

■ The DCN link with the NEs is available (cf. Appendix A).

■ Domains are already created (cf. Chapter 4.3.1).

Assumptions



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-17

AEM-NB R1.5

Equipment Configuration

Complete the following procedure to add an NE.

Step Procedure

1. Select ALL  in the Network Browser and Create NE  via the cursor menu
or select File -> New -> NE  or

Equipment -> Provisioning -> Create -> NE
via the Menu bar.
The NE Name Information window pops up:

Figure 5-6 "NE Name Information" Window

While creating a new NE the tab NE Details  is active by default.

2. Enter an appropriate NE name  in the corresponding field. All characters
are allowed, the maximum length is 30 characters. (At this stage the fields
Communications Info , Authentication  and Connection  are not avail-
able.)

The field NE id  shows a unique identifier internally used by the AEM-NB.

3. Press Apply to confirm. The Domain Selection window pops up.

Add NE Procedure
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Figure 5-7 "Domain Selection" Window

At creation time, the NE must be included in one or several domains (for domain
creation see chapter 4). The Domain Section window consists of two lists: Avail-
able Domains  and Selected Domains . This window provides the user with the
facilities needed to select the domains from which the NE will be accessible.

4. Use the Add >>  button to move the selected NE from the Available Do-
mains list box to the Selected Domains one. Use << Remove to remove
domains from the Selected Domains  list.
(The Add >>  button and the << Remove  button are available only after
having selected a domain name from the corresponding list.)

5. Press Apply to confirm.
In the NE Name Information window the fields Communications Info ,
Authentication  and Connection are now displayed. The Connection
State  is set to Not Connected  (see step 7).

NOTE:
If you decide to close this window (via Close  or window controls), a Warn-
ing window pops up informing you of the possible rejection of the NE cre-
ation:

At least 1 domain must be selected. Otherwise the NE
creation operation will be rejected. Do you want to go
back to Domain Selection?

Assign Domain
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If you select No, the creation of the NE is rejected. Otherwise, the Domain
Selection window is activated. The window remains on the screen until
you make a decision.

NOTE:
To establish the connection to the created NE first you have to enter the ap-
propriate data in the fields Communications Info and Authentication  in
the NE Name Information window. After that it is possible to establish the
connection by pressing Connection . Depending on the Connection State
this Label button provides different functions: Connect, Disconnect, Can-
cel .

6. Enter the IP Address and TID (Target ID, the name of the NE to which the
connection is addressed) of the new NE in the field Communications
Info . IP Address format: xxx.xxx.xxx.xxx; where x is a numeric [0, 9]; the
TID has a range from 1 to 20 characters.

NOTE:
Once the connection is established, these fields can not be edited unless
the connection is broken.

7. Press Apply to confirm.

8. Enter the Login  and Password  in the Authentication  pane.

NOTE:
Once the connection is established, these fields can not be edited unless
the connection is broken.

9. Press Apply to confirm.

NOTE:
Now the connection can be established. The label button in the field Con-
nection  displays Connect.

10. Press Connect  to establish the connection.
If all entries were correct the connection will be established and the new
NE can be displayed on the Network Browser.
Wrong entries (incorrect login or password) will result in an error mes-
sage.

NOTE:
The field Connection State  reflects the current connection state with the
NE (Not Connected, Not Connected (Trying), Not Connected (Cancelling),
Connected (Synchronizing) and Connected).
The label button on the right hand side can be used to change the connec-
tion state (Connect , if the connection state is Not Connected; Disconnect ,

Connect NE
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if the connection state is Connected or Connected (Synchronizing); Cancel,
if the connection state is Not Connected (Trying).

Edit and provisioning actions are only possible once the connection is established.
Only in this case the NE can be displayed on the Network Browser.

Adding an NE is normally followed by setting timing source (cf. Chapter 5.3.2.4,
page 5-52) and configuring simplex COMDAC protection (cf. Chapter 5.3.2.6,
page 5-58).
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5.3.2 Edit/View of Configuration Data

All edit/view actions of configuration data can be started via NE Name Information
window.

Figure 5-8 "NE Name Information" Window

This window includes of 6 tabs:

■ NE Details (cf. Chapter 5.3.1, page 5-16)

■ NE View (cf. Chapter 5.3.2.1, page 5-21)

■ NE Synchronization (cf. Chapter 5.3.2.2, page 5-46)

■ NE Inventory Data (cf. Chapter 5.3.2.3, page 5-49)

■ Timing Source Control (cf. Chapter 5.3.2.4, page 5-52)

■ Date & Time (cf. Chapter 5.3.2.5, page 5-55).

5.3.2.1 NE View

The purpose of this tab of the NE Name Information window is to provide a simple
graphical representation of the NE shelves (in case of multiple shelves).

NE Name Informa-
tion
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Complete the following procedure to display the shelf view:

Step Procedure

1. Select All -> NE  in the Network Browser and NE Information  via the cur-
sor menu
or select File -> Open  or Equipment -> Provisioning -> Edit
via the Menu bar.
The NE Name Information window pops up.

2. Click on tab New View

Figure 5-9 "NE Name Information" Window (Tab NE View)

It is possible to navigate to the different shelves with a single click on the
appropriate box
(Shelf 1-> Shelf View window - cf. Chapter 5.3.2.1.1, page 5-23;
MDS2/MDS2B-> MDS2/MS2B Shelf View window - cf. Chapter 5.3.2.1.2,
page 5-25).
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Figure 5-10 Menu Tree

5.3.2.1.1 Shelf View Window

This window provides general inventory, provisioning and alarm information
(through the circuit pack LEDs). Each slot will show the card type inserted and its
alarms (when applicable). If the slot is empty, no card will be shown.

Figure 5-11 "Shelf View" Window

Single clicking on any slot will launch the card-specific window even when the
card is not inserted (cf. Chapter 5.3.2.1.3, page 5-27 for IO-DS1,
Chapter 5.3.2.1.4, page 5-30 for COMDAC, Chapter 5.3.2.1.5, page 5-32 for CTU,
Chapter 5.3.2.1.6, page 5-34 for Application Pack).

NE View

MDS2/B Shelf View

CTUShelf View

IO-DS1

COMDAC

Application Pack

MSC

PTU

CU

Shelf Protection

Shelf Protection
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The Shelf View window displays different colors for different types of LEDs. The
following table describes the colors which will be used for each LED type inside
every card type. The table describes the color used when the LED is ON or is
blinking. If the LED is OFF the color black is used.

Circuit Pack LED Color Meanings

IO-DS1 FLT red ■ Lit during circuit pack failure

■ Flashes when the circuit pack executes off-
line self-test.

ACT green Lit when the circuit pack is service-active.

CLF1 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 1.

CLF2 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 2.

CLF3 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 3.

CLF4 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 4.

COMDAC FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and
turnup.

ACT green Indicates that this COMDAC is active.

CR red Lit when the highest severity alarm is critical.

MJ red Lit when the highest severity alarm is major.

MN yellow Lit when the highest severity alarm is minor.

NE yellow Lit when the source of the fault or abnormal condi-
tion is near end.

FE yellow Lit when the source of the fault or abnormal condi-
tion is far end.

CTU FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes on turnup.

ACT green Lit when a test is in progress.

MISC yellow Lit when one of the eight miscellaneous alarm in-
puts is active.

ACO green For future use

All Application
Packs

FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and turn-
up.
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See Chapter 6.2, page 6-1 for more details about alarm handling.

5.3.2.1.2 MDS2/MDS2B Shelf View Window

This window provides general inventory, provisioning and alarm information
(through the circuit pack LEDs). Each slot will show the card type inserted and its
alarms (when applicable). If the slot is empty, no card will be shown.

Figure 5-12 "MDS2 Shelf View" Window

Figure 5-13 "MDS2B Shelf View" Window

AP (MDSU) FLT red Lit when a fault is detected on the circuit pack.

LNK yellow ■ Lit when loss of clock/sync signal is detected

■ Flashes when incorrect
MDSU/MDS2/MDS2B side association is de-
tected.

Circuit Pack LED Color Meanings
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Single clicking on any slot will launch the card-specific window (cf.
Chapter 5.3.2.1.7, page 5-38 for MSC, Chapter 5.3.2.1.8, page 5-40 for PTU,
Chapter 5.3.2.1.9, page 5-42 for CU).

Circuit Pack LED Color Meanings

CU FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and
turnup.

MSC FLT red Lit when a fault is detected on the circuit pack.

LNK yellow ■ Lit when loss of clock/sync signal is detected

■ Flashes when incorrect
MDSU/MDS2/MDS2B side association is de-
tected.

PTU FLT red Lit when a fault is detected on the circuit pack.

TST Lit when a channel served by the PTU is under
test.
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5.3.2.1.3 Configure IO-DS1

The IO-DS1 circuit pack provides four physical DS1 interfaces to accommodate
telephony via standard TR-08, TR-303 and INA network interfaces.

This window can be displayed even when the circuit pack is not plugged in.

Complete the following procedure to view/edit the IO-DS1 data:

Step Procedure

1. Select All -> NE -> Shelf -> IO-DS1 in the Network Browser and Edit via
the cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack IO-DS1 in Shelf View window.
The IO-DS1 window pops up:

Figure 5-14 "IO-DS1" Window

Procedure
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The following table shows the view/edit options of the IO-DS1 window:

Parameters/
Buttons Description

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot format:
iods1-1-shelf-slot (e.g. iods1-1-2-4 for working IO-DS1s and
iods1p-shelf (e.g. iodsp1-1) for the protection IO-DS1.

Possible values:
iods1-{1}-{1, 5} for working IO-DS1
iods1p-{1} for protection IO-DS1.

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible value: IODS1.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible values are: FAC 100.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

Slot Required  displays the required state of the shelf slot.
This state can be changed by the operator as long as the cir-
cuit pack is not  inserted. Default state for iods1: Not Re-
quired  (with the exception of iods1p whose default is Re-
quired )

The Apply  button is available only if the IO-DS1 is not in-
serted and the required state of the IO-DS1 has been modi-
fied by the operator.

The read-only text field Protection State shows whether the
selected IO-DS1 is working or not. Possible values: Working
(providing service) or Standby (not in service).

The Protection...  button provides access to the Shelf Pro-
tection window.
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2. Use the check box Slot Required in the pane Operation & Protection to
define the required slot state.

3. Click on Apply  to confirm the change of the state of the shelf slot (the
window remains on screen for further use).

Go to step 4 to modify protection; go to step 5 to edit the logical DS1.

4. Use the IO-DS1 Protection... button to open the Shelf Protection window
(IO-DS1 tab - cf. Chapter 5.3.2.7, page 5-59) to modify the current protec-
tion scheme or to perform protection switches.

5. Select a row in the Physical DS1 Information  list.

6. Click on Edit Logical DS1...  to open the corresponding Physical DS1-
Logical DS1 window (Chapter 5.4.3, Figure 5-36, page 5-84). The same
result will be obtained by double clicking on any row.

Physical DS1
Information

The information in this field is displayed in a table (4 rows,
one per physical DS1):

■ Physical DS1 : Physical address of the DS1 feeders.
Feeders are DS1 circuits used to provide the Virtual
Remote Terminal (VRT) or INA Virtual Bank (VB)
feeder facilities.
Format: ds1-slot-port (e.g. ds1-1-4).

■ Logical DS1 id : This is the id used to identify logical
feeders.
Possible values: v3fdr-1-{1, 28} for TR-303

v8fdr-{1, 20}-{a, b, c, d} for TR-08
ina-{1,20} for INA

Once a row in the table is selected, the Add/Edit Logi-
cal DS1...  button becomes available.

Parameters/
Buttons Description
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5.3.2.1.4 Configure COMDAC

The COMDAC (Common Data and Control) circuit pack performs the main band-
width management and control functions for the system.

This corresponding window contains all the information related to the COMDAC. It
can be displayed even when the circuit pack is not plugged-in.

Complete the following procedure to view/edit the COMDAC data:

Step Procedure

1. Select All -> NE -> Shelf -> COMDAC in the Network Browser and Edit
via the cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack COMDAC in Shelf View window.
The COMDAC window pops up:

Figure 5-15 "COMDAC" Window

Procedure
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The following table shows the view/edit options of the COMDAC window:

Parameters/
Buttons Description

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot number where the COMDAC is plugged in.
Slot format: comdac-1-{1,2}

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible value: COMDAC.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible value: COM100.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

SW Version : Obtained from the NE at connection time. In-
ternally, the AEM-NB will have to verify whether the men-
tioned SW Version is manageable by the system.

Program Code : Code of the SW currently stored in the plug-
in.

Operation &
Protection

This field is described in Chapter 5.3.2.6, page 5-58.

Ongoing Tasks Copy Mem in Progress,
Sw Download in Progress

These check boxes indicate operations in progress which
can take a long time and must be known by the opera-
tor.They will be refreshed when the window is launched or
when refreshing the whole window.
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5.3.2.1.5 Configure CTU

The CTU (Craft Test Unit) circuit pack provides both channel testing support and a
termination for local operations, administration, maintenance and provisioning.

This corresponding window contains all information related to the CTU. It can be
displayed even when the circuit pack is not plugged in.

Complete the following procedure to view/edit the CTU data:

Step Procedure

1. Select All -> NE -> Shelf -> CTU in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack CTU in Shelf View window.
The CTU window pops up:

Figure 5-16 "CTU" Window

Procedure
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The following table shows the view/edit options of the CTU window:

2. Use the check box Slot Required  to define the slot state.

3. Press Apply  to confirm (the window remains on screen for further use).

Parameters/
Buttons Description

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot number where the CTU is plugged in.

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible value: CTU.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible value: DTP100.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

The check box Slot Required  displays the required state of
the shelf slot. This state can be changed in the case of CTU,
regardless of the slot status.
Default state for CTU: Not Required (empty check box).

The Apply  button is available only if the required state of
CTU has been modified by the operator.
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5.3.2.1.6 Configure Application Pack

The APs (Application Packs) provide the line side interface functionality that pro-
vide service to end-users.

The corresponding window contain all information related to the AP. It can be dis-
played even when the circuit pack is not plugged in.

Complete the following procedure to view/edit the Application Pack data:

Step Procedure

1. Select All -> NE -> Shelf -> AP in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack AP in Shelf View window.
The Application Pack window pops up:

Figure 5-17 "Application Pack" Window

Procedure
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The following table shows the view/edit options of the Application Pack window:

Parameters/
Buttons Description

NE Name NE Name of the selected NE (max. 30 characters).

Slot Slot number where the AP is plugged in.
Format: ap-{1,16}

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible values: cf. Table 5-1,
page 5-37.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in.
Possible values: cf. Table 5-1, page 5-37.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

The check box Slot Required  displays the required state of
the shelf slot. This state can be changed only if the card is
not inserted.

The Apply button is available only if the required state of the
AP has been modified from Required  to Not Required.
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2. Use the check box Slot Required  to define the slot state.

Port Informa-
tion

This pane contains a table displaying port information. This
information is presented in a 4-column table.
The table is sorted by Physical Port id . A scroll bar allows
navigation through the table. Rows in the table can be se-
lected to edit (single row selection) or delete (single or multi-
ple row selection) the corresponding Logical T0(s) through
the use of the Edit Logical T0... or Delete Logical T0... but-
tons (see below).

■ Physical Port id : Identifies the port within the applica-
tion pack.
Format: drop-shelf-slot-port
Possible values: drop-1-{1,16}-{1,32}

The following entries are available only if a port is already
cross-connected (not yet implemented for R1.5).

■ VRT/VB id : shows the VRT/VB id on which the service
is provided - only available if the physical port is cross-
connected.
VRT/VB id format: v303-1 for TR-303,

v08-{1, 20} for TR-08
ina-{1, 20} for INA

■ Logical T0 id : Indicates the Logical T0 id within the
VRT/VB id shown in the row (only available if the physi-
cal port is cross-connected).
Possible values: v3dp-{1}-{2048} for TR-303

v8dp-{1, 20}-{1, 96} for TR-08
inads0-{1, 20}-{1, 24} for INA

■ GSFN: Generic Signalling Function that identifies the
service type provided. The following values are possi-
ble: DFLT (default), 2LS, 2GS, Coin, 2FXLS, 2FX,
2RV0, 2NOS, ISDN and 4DO (only for ROC), Un-
known.

The Add Logical T0... button provides access to the Logical
T0 window. In this case, the Physical Port id will be trans-
ferred. This button is enabled only if a physical port is se-
lected with no cross-connection to a logical T0 id.

The Edit Logical T0... button provides access to the Logical
T0 window where you will be able to edit the logical T0 pa-
rameters (whenever this is possible) or even remove the ex-
isting cross-connection (delete Logical T0) of the selected
User Port from the list. This button is enabled only if a physi-
cal port cross-connected to a logical T0 is selected.

The Delete Logical T0... button removes the cross-connec-
tion selected in the list (see above).

Parameters/
Buttons Description



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-37

AEM-NB R1.5

Equipment Configuration

3. Press Apply  to confirm (the window remains on screen for further use).

Logical T0 will be deleted. Ok to proceed?

NOTE:
If the logical T0 is red-lined the following warning message pops up:
Redlined logical T0 will be deleted. Ok to proceed?

4. If you decide to continue, the remove operation will be started. The infor-
mation displayed will be updated once the remove operation is finished to
show the current list.

Table 5-1 AP Cards - Possible Values

If ... then ...

you want to add a Logical T0 select a row in the Port Information
list and press Add Logical T0... . The
Logical T0 List window pops up (cf.
Chapter 5.4.7, page 5-90).

you want to edit a Logical T0 select a row in the Port Information
list and press Edit Logical T0... . The
Logical T0 window pops up (cf.
Chapter 5.4.8, page 5-112).

you want to delete a cross-connection select the desired Logical T0 id  in the
Port Information list and press Delete
Logical T0... . A Warning window pops
up displaying the following message:

Card Type Apparatus Code CLEI

PROG2W LPA380 E5ISFB0AAA

POTS32 LPA300 SLCUVR0BAA

PRCOIN LPA350 E5ISFA0AAA

ISDN16_U LPU116 E5PQAXUAAA

AFM_DS33 LPA900 SLCUZN0BAA

ADSL4 LPA400 E5ICNJ0AAA

MDSU MSU100 SAPQADMBAA
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5.3.2.1.7 Configure MSC

The MSC (Metallic Shelf Controller) circuit pack provides the required shelf inter-
face and central control for half of the MDS2 Shelf or MDS2B Shelf.

The corresponding window contains all information related to MSC. It can be dis-
played even when the circuit pack is not plugged in.

Complete the following procedure to view/edit the MSC (Metallic Shelf Controller)
data:

Step Procedure

1. Select All -> NE -> Shelf -> MSC in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack MSC in MDS2/MDS2B Shelf View win-
dow.
The MSC window pops up:

Figure 5-18 "MSC" Window

Procedure
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The following table shows the view/edit options of the "MSC" window:

2. Use the check box Slot Required  to define the slot state.

3. Press Apply  to confirm (the window remains on screen for further use).

Parameters/
Buttons Description

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot number where the MSC is plugged in.
Possible values: msc-1-{1,2}

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible values: MSC.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible value: MSC100.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

The check box Slot Required  displays the required state of
the shelf slot. This state can be changed by the operator only
if the card is not inserted.

The Apply  button is available only if the required state of
MSC has been modified by the operator.
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5.3.2.1.8 Configure PTU

The PTU (Power Test Units) circuit pack provides power converters to distribute
+5V and -5V power to the CUs and 5V power to the MSC.

The corresponding window contains all information related to PTU pack. It can be
displayed even when the circuit pack is not plugged in.

Complete the following procedure to view/edit the PTU (Power Test Unit) data:

Step Procedure

1. Select All -> NE -> Shelf -> PTU in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack PTU in MDS2/MDS2B Shelf View win-
dow.
The PTU window pops up:

Figure 5-19 "PTU" Window

Procedure
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The following table shows the view/edit options of the "PTU" window:

2. Use the check box Slot Required  to define the slot state.

3. Press Apply  to confirm (the window remains on screen for further use).

Parameters/
Buttons Description/Action

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot number where the PTU is plugged in.
Possible values: ptu-1-{1,2}.

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible values: PTU.

Serial Number : 12-character alphanumeric code that in-
cludes date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible value: BDJ200.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

The check box Slot Required  displays the required state of
the shelf slot. This state can be changed by the operator only
if the card is not inserted.

The Apply  button is available only if the required state of
MSC has been modified by the operator.
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5.3.2.1.9 Configure CU

The CU (Channel Unit) circuit packs provides the line side interface functionality
that provide service to end-users.

The corresponding window contains all information related to CU packs. It can be
displayed even when the pack is not plugged in.

Complete the following procedure to view/edit the CU (Channel Unit) data:

Step Procedure

1. Select All -> NE -> Shelf -> CU in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar
or single click on the circuit pack CU in MDS2/MDS2B Shelf View window.
The Channel Unit window pops up:

Figure 5-20 "Channel Unit" Window

Procedure
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The following table shows the view/edit options of the CU window:

Parameters/
Buttons Description/Action

NE Name NE name of the selected NE (max. 30 characters).

Slot Slot number where the CU is plugged in.
Possible values: cu-1-{1, 24}.

Inventory Infor-
mation

The read-only text fields provide the following information:

Card Type : 11-character mnemonic used to identify the gen-
eral type of function provided. Possible values: cf. Table 5-2,
page 5-45.

Serial Number : 12-character alphanumeric code that in-
cludes the date and place of manufacture.

Apparatus Code : Specifies the function of the plug-in. Pos-
sible values: cf. Table 5-2, page 5-45.

ICC (InterChangeability Code) : Indicates the interchange-
ability among plug-ins to specify forward/backward compati-
bility. Format of the ICC is Sm:n  where m is the Issue num-
ber and n the Series Number.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

Operation &
Protection

The check box Slot Required  displays the required state of
the shelf slot. This state can be changed by the operator only
if the card is not inserted.

The Apply button is available only if the required state of CU
has been modified by the operator.
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Port Informa-
tion

This pane contains a table displaying port information. This
information is presented in a 4-column table. The table is
sorted by Physical Port id . A scroll bar allows navigation
through the table. Rows in the table can be selected to edit
(single row selection) or delete (single or multiple row selec-
tion) the corresponding Logical T0(s) through the use of the
Edit Logical T0...  or Delete Logical T0...  buttons (see be-
low).

■ Physical Port id : Identifies the port within the applica-
tion pack.
Format: m2drop-shelf-slot-port
Possible values: m2drop-1-{1,24}-{1,4}.

The following entries are available only if a port is already
cross-connected (not yet implemented for R1.5).

■ VRT/VB id : shows the VRT/VB id on which the service
is provided - only available if the physical port is cross-
connected
VRT/VB id format: v303-1  for TR-303

v08-{1, 20}  for TR-08
ina-{1, 20}  for INA.

■ Logical T0 id : Indicates the Logical T0 id within the
VRT/VB id shown in the row - only available if the phys-
ical port is cross-connected.
Possible values: v3dp-{1}-{2048} for TR-303

v8dp-{1}-{1, 96} for TR-08
inads0-{1, 20}-{1, 24} for INA.

■ GSFN: Generic Signalling Function that identifies the
service type provided.
The following values are possible: AC, BRI, DATA, DPT,
DX4[N, R], EBS, ETO4, FXO, FX[S,T][1,2,3,5], LR,
NO[1,2], OCU[1,2,3], PLR[1,2], SW56, TD[O,
S][A,B,C,D], TO, TO4, EM4[C, H], FX[O,P][1,2,3,5],
EM4[C, H], Unknown.

The Add Logical T0... button provides access to the Logical
T0 window. In this case, the Physical Port id will be trans-
ferred.This button is enabled only if a physical port is se-
lected with no cross-connection to a logical T0 id.

The Edit Logical T0... button provides access to the Logical
T0 window where you will be able to edit the Logical T0 pa-
rameters (whenever this is possible) or even remove the ex-
isting cross-connection (delete Logical T0) of the selected
User Port from the list. This button is enabled only if a physi-
cal port cross-connected to a logical T0 is selected.

The Delete Logical T0... button removes the cross-connec-
tion selected in the list (see above).

Parameters/
Buttons Description/Action
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2. Use the check box Slot Required  to define the slot state.

3. Press Apply  to confirm (the window remains on screen for further use).

Logical T0 will be deleted. Ok to proceed?

NOTE:
If the logical T0 is red-lined the following warning message pops up:
Redlined logical T0 will be deleted. Ok to proceed?

4. If you decide to continue, the remove operation will be started. The infor-
mation displayed will be updated once the remove operation is finished to
show the current list

Table 5-2 CU Cards - Possible Values

If ... then ...

you want to add a Logical T0 select a row in the Port Information
list and press Add Logical T0... . The
Logical T0 List window pops up (cf.
Chapter 5.4.7, page 5-90).

you want to edit a Logical T0 select a row in the Port Information
list and press Edit Logical T0... . The
Logical T0 window pops up (cf.
Chapter 5.4.8, page 5-112).

you want to delete a cross-connection select the desired Logical T0 id  in the
Port Information  list and press Re-
move Logical T0... . A Warning window
pops up displaying the following mes-
sage.

Card Type Apparatus Code CLEI

AUA293 AUA293 5SC4PT0CAA

SPQ429 SPQ429 SAC1AK0AAA

SPQ442 SPQ442 SAC1AH0AAA

AUA41B AUA41B 5SC3HJEAAA

AUA45B AUA45B 5SCUUJ5AAB

AUA75 AUA75 5SC1FF2AXX

SPQ452 SPQ452 5SCTFFGAAB

AUA200 AUA200 5SCTB0DAAA

SPQ444 SPQ444 SAC1BF0AAB

SPQ454 SPQ454 SAC1BG0AAB

MCU-5205 MCU-5205 t. b. d.

MCU-5405 MCU-5405 t. b. d.
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5.3.2.2 NE Synchronization

5.3.2.2.1 Configuration Information Synchronization

The possibility exists for the AEM-NB database to become inconsistent with the
information stored locally in the NE (Non-Volatile Data Storage). A database re-
synchronization capability provides a mechanism for the AEM-NB database to be
made consistent (synchronized) with the locally stored NE information.

Two NE configuration data synchronization states can be identified:

■ Sync : The AEM-NB database is consistent with the locally stored NE infor-
mation and all the autonomous messages concerning configuration
changes are enabled (DB changes, switch reports and some events of type
protection switches, lockout and loop back).

■ Async : The AEM-NB database and the NE configuration data are out of
synchronization and/or configuration reports are inhibited and/or AEM-NB
configuration message buffer is overflowing.

(For more information refer to the AMAS R1.5 network elements documentation.)

5.3.2.2.2 Alarm Information Synchronization

In general alarms can be considered independently of each other (any alarm re-
port can be processed by the AEM-NB independent of other alarm reports). The
AEM-NB distinguishes two possible states for alarm handling: alarms from NEs
are enabled or they are inhibited.

Two NE synchronization states can be considered:

■ Sycn : The AEM-NB alarm database is consistent with the current NE
alarms. If alarm and/or environment alarm reports are inhibited, the AEM-
NB database is only a snapshot of NE alarm information at a certain mo-
ment in time.

■ Async : The AEM-NB alarm database and the current NE alarms are out of
synchronization due to alarm buffer overflow. The AEM-NB alarm database
is only a snapshot of NE alarm information at a certain moment in time.

(For more information refer to the AMAS R1.5 network elements documentation.)

Overview

Overview
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Complete the following procedure to modify the synchronization states for configu-
ration and alarms and to define the autonomous output states:

Step Procedure

1. Select All -> NE in the Network Browser and NE Information  via the cur-
sor menu
or select File -> Open  or Equipment -> Provisioning -> Edit or Equip-
ment -> EM-NE Synchronization via the Menu bar.
The NE Name Information window pops up.

2. Click on tab Synchronization .
(this step is not necessary if the NE Name Information window has been
opened via Equipment -> EM-NE Synchronization ).

Figure 5-21 "NE Name Information" Window (Tab Synchronization)

Parameter Setting
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3. Use the Label  button in the pane Configuration  to change the Sync
State .
If the Sync State  is Sync , the label says Resync . If the Sync State  is
Async , the label says Sync .

4. Use the Resync button in the pane Alarms  to re-synchronize the alarm
synchronization state.

5. Use the Label  buttons (Enable/Disable ) to modify the alarms and envi-
ronmental alarms.
Possible values for these labels are Enable  (if the alarms or platform
alarms say Disable ) or Disable  (if the alarms or platform alarms say En-
able ).

6. Use the Get button to update the display of the autonomous output states.

Parameters/
Buttons Description

Configuration The Sync State  represents the configuration synchroniza-
tion state between the AEM-NB and NE. This information is
obtained from the NE and it will be automatically updated.
Possible values are: Sync  and Async .

Alarms The Sync State  represents the alarm processing state be-
tween the AEM-NB and NE. This information is obtained
from the NE and it will be automatically updated. Possible
values are: Sync and Async .

Autonomous
Outputs States

Check boxes indicate autonomous output states.

The Get button can be used to show the current autono-
mous output states of the NE.
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5.3.2.3 NE Inventory Data

This window provides NE inventory data.

Complete the following procedure to get the inventory data:

Step Procedure

1. Select All -> NE in the Network Browser and NE Information  via the cur-
sor menu
or select File -> Open  or Equipment -> Provisioning -> Edit or Equip-
ment -> NE Inventory Data via the Menu bar.
The NE Name Information window pops up.

2. Click on tab NE Inventory Data .
(this step is not necessary if the NE Name Information window has been
opened via Equipment -> NE Inventory Data ).

Figure 5-22 "NE Name Information" Window (Tab NE Inventory Data)

Procedure
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Two non-editable tables display NE inventory information. The first table contains
per slot data, while the second one provides summarized information per card
type.

Table 5-3 Card Information - Possible Values

Parameters/
Buttons Description

NE Inventory
data

Shelf/Slot : Numeric field that identifies the position of each
plug-in unit.

Circuit Pack Type : Mnemonic that identifies the circuit pack
type. Possible values: cf. Table 5-3, page 5-50

Apparatus Code : Identifies the specific function provided by
the plug-in unit. Possible values: cf. Table 5-3, page 5-50

Serial Number : A 12-character alphanumeric code that
identifies each plug-in. It includes the date and place of man-
ufacture.

ECI: Code that corresponds to the bar-coded label on the
faceplate of the plug-in. There is a one-to-one correspon-
dence between CLEI and ECI codes.

CLEI: Code assigned by Bellcore that provides information
about the functionality of the plug-in.

ICC: Indicates the interchangeability among plug-ins to
specify forward/backward compatibility. Format of the ICC is
Sm:n  where m is the issue number and n the Series Num-
ber.

SW Version : Obtained from the NE at connection time. In-
ternally, the AEM-NB will have to verify whether the men-
tioned SW Version is manageable by the system. Only appli-
cable to the COMDACs or the shelves, where the shelf-back-
plane version will be displayed.

Program Equipment Code : Code of the SW currently
stored in the plug-in. Only applicable to the COMDAC.

Summary Circuit Pack Type : Displays a mnemonic that identifies the
circuit pack type. Possible values are: cf. Table 5-3,
page 5-50

Number of Units : Displays two numbers: the number of
plug-in units and the number of unplugged units.

Card Type Apparatus Code CLEI

FAST (Shelf number) --

COMDAC COM100 SLC1CG0CAA

IO_DS1 FAC 100 SLC1EJ0CAA



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-51

AEM-NB R1.5

Equipment Configuration

CTU DTP100 SLC1DH0CAA

PROG2W LPA380 E5ISFB0AAA

POTS32 LPA300 SLCUVR0BAA

PRCOIN LPA350 E5ISFA0AAA

ISDN16_U LPU116 E5PQAXUAAA

AFM_DS33 LPA900 SLCUZN0BAA

ADSL4 LPA400 E5ICNJ0AAA

MDSU MSU100 SAPQADMBAA

MSC MSC100 SACPHM0BAA

PTU BDJ200 SAPQAAV

t. b. d. AUA293 5SC4PT0CAA

t. b. d. SPQ429 SAC1AK0AAA

t. b. d. SPQ442 SAC1AH0AAA

t. b. d. AUA41B 5SC3HJEAAA

t. b. d. AUA45B 5SCUUJ5AAB

t. b. d. AUA75 5SC1FF2AXX

t. b. d. SPQ452 5SCTFFGAAB

t. b. d. AUA200 5SCTB0DAAA

t. b. d. AUA232 5SCTCB0AAA

t. b. d. SPQ444 SAC1BF0AAB

t. b. d. SPQ454 SAC1BG0AAB

t. b. d. MCU-5205 5SC26TV2AA

t. b. d. MCU-5405 5SC26T02AA

Card Type Apparatus Code CLEI
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5.3.2.4 Configuration of Timing Source

The AnyMedia Access System supports four timing modes:

■ External DS1 : The Line Code and Framing format for the external DS1
synchronization input must be provided

■ External Composite Office Clock

■ Free Running Mode:  For free-running operation, the NE derives timing
from an internal crystal oscillator (XO) with an accuracy not worse than
±32 parts-per-million (ppm) over full power supply, temperature, and life-
time. The free-running mode is intended only for turn-up and failure condi-
tions.

■ Loop Timed Mode : In this mode, a selected feeder DS1 signal synchro-
nizes an internal phase-locked loop. The NE can loop time to any feeder
DS1 input as required by TR303. However, the system will only use two
timing inputs (selected via provisioning) for protection reasons.

The two timing inputs are identified as Primary  (Reference Source) and Second-
ary (Protection Source). The first DS1 feeder of the first IO_DS1 plug-in is the de-
fault primary input, and the first feeder of the second IO_DS1 plug-in is the default
secondary input. The network provider can tailor the set of valid timing inputs and
their priorities via provisioning. The Primary and Secondary reference signals can
be selected from any physical feeder inputs on any two IO_DS1 plug-ins, or from
two feeder inputs on the same plug-in. The NE can continue to derive timing from
the reference inputs if one or both of the physical inputs are switched to the pro-
tection IO_DS1 plug-in.

For more information refer to the AMAS R1.5 network elements documentation.

Upon initialization, the NE selects the primary input as the active reference, and
the secondary input as its alternate source. If the primary reference fails, the NE
hardware switches to the alternate source, providing synchronization reference
source protection is available (cf. Chapter 5.3.2.7, page 5-59).

Complete the following procedure to configure the timing source:

Step Procedure

1. Select the All -> NE in the Network Browser and NE Information  via the
cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit or Equip-
ment -> Provisioning -> Timing Source Control via the Menu bar.
The NE Name Information window pops up.

2. Click on tab Timing Source Control .
(this step is not necessary if the NE Name Information window has been
opened via Equipment -> Provisioning -> Timing Source Control ).

Overview

Timing Inputs

Configuration Pro-
cedure
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Figure 5-23 "Timing Source Control" Window

This window provides the operator with the facilities needed to configure the NE
timing source. Three menu buttons are available: Synchronization Mode , Refer-
ence Source  and Protection Source .

Parameters/
Buttons Description

Synchroniza-
tion Mode

This option menu displays the current Synchronization
Mode .

Possible values: Free Running , Loop Timed , External
Clock , External DS1 . This option menu can also be used to
change the Synchronization Mode .

Only after changing the mode the next two fields (Primary
Source  and Secondary Source ) are available.

Primary Source This option menu is available only if the Synchronization
Mode  is Loop Timed . The Primary Source (working) and
(optionally) the Secondary Source (standby) can be se-
lected.

Possible values: any of the available feeders (ds1-1-{1, 5}-{1,
4}).

Once the source(s) of synchronization has been selected,
click on the Apply  button to accept the change.
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Secondary
Source

This option menu is available only if the Synchronization
Mode is Loop Timed . The Secondary Source (standby) can
be selected.

Possible values: any of the available feeders (ds1-1-{1, 5}-{1,
4}).

Once the source(s) of synchronization has been selected,
click on the Apply  button to accept the change.

NOTE:
The secondary source must be different from the pri-
mary source. Otherwise there is no protection avail-
able.

Line Code This option menu is available only if the Synchronization
Mode  is External DS1 .

Possible values: B8ZS, ZCS, Not Applicable (can not be se-
lected).

Once the Line Code  has been changed, click on the Apply
button to accept the change.

Framing Format This option menu is available only if the Synchronization
Mode  is External DS1 .

Possible values: ESF, SF, Not Applicable (can not be se-
lected).

Once the Line Code  has been changed, click on the Apply
button to accept the change.

Apply This button is available only when:

■ Synchronization Mode  has been changed.

■ Synchronization Mode  is Loop Timed  and at least
one source has been modified.

■ Synchronization Mode is External DS1 and either the
Line Code  or Framing Format  have been modified.

NOTE:
During the apply operation, the Get and Switch  but-
tons are disabled. The whole subpane will be updated
as result of the operation.

Parameters/
Buttons Description
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3. Use the menu buttons to select appropriate values for Synchronization
Mode , Primary Source and Secondary Source.

4. Press Switch  to switch between the working and standby sources of syn-
chronization.

5. Press Apply  to confirm.

5.3.2.5 Set Date and Time

A function required by the AEM-NB is provisioning the date and time of the man-
aged NEs, i.e. the operator is able to set the NE Date & Time. Also it is possible
for the AEM-NB to retrieve the date and time of any NE.

Active Timing
Sync Source

This field shows the current timing synchronization source
obtained from the NE by using the Get button.

Possible values: Free Running, Loop Timed / PRI, Loop
Timed / SEC, External DS1 / Ext1, External DS1 / Ext 2, Ex-
ternal Clock / Ext1, External Clock / Ext 2.

If the Get button has not been pressed this field will be
empty.

Get This button can be used to retrieve the Active Timing Syn-
chronization Source  from the NE.

NOTE:
During the get operation, the Apply  and Switch  but-
tons are disabled. The timing reference subpane will
also be updated as result of this operation.

Switch This button is enabled only if the Active Timing Synchroni-
zation Source  is not Free Running .

It can be used to switch between the working and standby
sources of synchronization.

In other words, the standby source becomes the working
source and the working source becomes the standby source.

NOTE:
During the switch operation, the Apply  and Get but-
tons are disabled. The Active Timing Synchroniza-
tion Source field will also be updated as result of this
operation.

Parameters/
Buttons Description

Overview
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Complete the following procedure to set the date and time:

Step Procedure

1. Select All -> NE in the Network Browser and NE Information  via the cur-
sor menu
or select File -> Open  or Equipment -> Provisioning -> Edit or Equip-
ment -> Provisioning -> Date & Time via the Menu bar.
The NE Name Information window pops up.

2. Click on tab Date & Time .
(this step is not necessary if the NE Name Information window has been
opened via Equipment -> Provisioning -> Date & Time ).

Figure 5-24 "Date & Time" Window

This tab provides you with the facilities needed to obtain the current date
and time used in the NE as well as to change them. Two panes are
shown: Current  and New.

— Current

The current date and time used in the NE is displayed.

Use the Get button to retrieve the data from the NE.

Procedure
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— New

Enter the Date and Time  in order to change the NE date and time
(possible range for the date is 1 Jan. 1970 to 31 Dec. 2037).

Press Apply  to confirm.

The Apply  button is active only if a new date and/or new time have
been entered.
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5.3.2.6 Configure Simplex COMDAC Protec-
tion Scheme

The NE automatically sets the COMDAC protection mode (or duplex mode) when
both COMDACs are plugged in. Then the alarming state of both COMDACs slots
is set to Required  and the AEM-NB is not able to change it until one of the COM-
DACs is removed. When a COMDAC is removed, the AEM-NB is then able to set
that slot to Not-Required , so the COMDAC protection mode will be disabled (sim-
plex).

Complete the following procedure to set the COMDAC protection to simplex:

Step Procedure

1. Select All -> NE -> Shelf -> COMDAC  in the Network Browser and Edit
via the cursor menu
or select File -> Open  or Equipment -> Provisioning -> Edit via the
Menu bar.
The COMDAC window pops up:

Figure 5-25 "COMDAC" Window

This window includes hardware and software data (inventory) as well as
the operational and protection state.

Overview

Procedure
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The Inventory Information  pane contains read-only fields (cf.
Chapter 5.3.2.1.4, page 5-30).

For configuring the protection scheme the pane Operation & Protection
is used.

2. Deselect the check box Slot Required .

3. Press Apply  to confirm (the window remains on screen for further use).

5.3.2.7 Protection Switching

Protection switching provides an automatic recovery mechanism in the AnyMedia
Access System when a fault is detected. NE entities that are involved in carrying
service to a large number of end users are generally required to be protected with
a redundant unit. However, the NE provides customer options to have none or
some entities protected with redundant units. These entities can be either 1:1 or
1:N protected. For 1:1 protected entities, one of them serves as the active or pri-
mary unit and the other serves as a “protection” or standby unit. For 1:N protected
entities, one entity serves as the “protection” or standby unit for all N active units.
If an active unit fails, the failure is detected and service is automatically “protection
switched” to the protection unit. The protection switching can also be requested
on demand.

Protection switching can be revertive or non-revertive. Revertive protection switch-
ing implies that the active and standby units will return to their original configura-
tion once the failure causing the protection switch has been repaired. Non-rever-
tive switching does not return the entities to their original configuration. With non-
revertive switching, the repaired unit becomes the new standby unit.

Parameters/
Buttons Description

Slot This non-editable field shows which one of the two
slots is being used (comdac-1-{1,2}).

Slot Required Slot required displays the required state of the shelf
slot. This state can be changed by the operator as
long as the circuit pack is not inserted. However, it is
not  possible to set both COMDACs to not  required.

The Apply button is available only if both COMDACs
are present and the user modifies the required state
of one of them from Required  to Not -Required .

Protection State This non-editable field shows whether the selected
COMDAC is working or not: Working (providing ser-
vice) or Standby  (not in service).

Protection... This button provides access to the Shelf Protection
window (COMDAC tab) to allow you to modify the
current protection scheme or perform protection
switching (cf. Chapter 5.3.2.7.1, page 5-60).

General

Revertive/non-re-
vertive
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The AnyMedia Access System supports the following protection features:

■ COMDAC pack - 1:1 protection; non-revertive switch (cf. following section).

■ IO_DS1 packs - 1:N protection (1 ≤ N ≤ 5); revertive switch (cf.
Chapter 5.3.2.7.2, page 5-63).

■ Synchronization reference source - 1:1 protection; non-revertive switch (cf.
Chapter 5.3.2.4, page 5-52).

■ EOC/TMC data links - 1:1 protection; non-revertive switch (cf.
Chapter 5.4.1, page 5-73).

The different kinds of switching (COMDACs and IO_DS1 circuit packs) are de-
fined as follows:

■ Side Switching:  refers to the operation of deactivating the active core en-
tity and activating the standby core entity.

■ Manual (normal) Switch:  refers to an AEM-NB-initiated switch command
that instructs the NE to perform a switch only if the protection unit is in ser-
vice and there are no known faults.

■ Forced Switch:  refers to an AEM-NB-initiated switch command that in-
structs the NE to perform a switch no matter what the conditions of the pro-
tection unit.

■ Inhibit Switch:  refers to an AEM-NB-initiated switch command that in-
structs the NE to inhibit a side switch no matter what the conditions of the
active unit are.

5.3.2.7.1 COMDAC Protection Switching

The COMDAC is the core circuit pack of the AnyMedia Access System. The NE
supports both duplex and simplex operations, i.e., the COMDAC can be protected
or unprotected. In duplex operation, the COMDAC will run in an active and
standby mode.

The NE automatically sets the COMDAC protection mode when both COMDACs
are plugged in. Then the alarming state of both COMDACs slots is set to Re-
quired  and the AEM-NB is not able to change it until one of the COMDACs is re-
moved. When a COMDAC is removed, the AEM-NB is then able to set that slot to
Not-Required , so the COMDAC protection mode will be disabled (simplex).

Definitions

Overview
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Complete the following procedure to define protection switching for the COMDAC.

Step Procedure

1. Select All -> NE - > Shelf  in the Network Browser and Protection  via the
cursor menu
or select Equipment -> Protection via the Menu bar.
The Shelf Protection window pops up (tab COMDAC):

Figure 5-26 "Shelf Protection" Window (Tab COMDAC)

(for IO-DS1 description see Chapter 5.3.2.7.2, page 5-63)

Procedure
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This window provides COMDAC protection information. It also provides the mech-
anisms needed to perform changes in the protection scheme as well as protection
switches.

2. Use the Radio buttons in field Protection Switch to switch the protection:
Clear or Forced Switch to Protection  or Inhibit

3. Press Apply to confirm. A Warning window pops up:

Protection switching may be service affecting. Do you
want to continue?

If you decide to continue, the switch operation will be started. The infor-
mation displayed will be updated once the switch is finished to show the
current state.

The following events set off error messages:

■ The NE is not equipped for the requested protection switching (i.e. the pro-
tecting slot is empty).

■ The NE detects an error in the switch request (i.e. the request cannot be
executed due to another activity in the AEM-NB).

Parameters/
Buttons Description

Protection
Scheme

Represents the protection scheme used in the NE. If only
one COMDAC is present in the shelf, the protection scheme
is Simplex . If both COMDACs are present, Duplex  is the
value shown. Only in this case (Duplex configuration) is the
Protection Switch pane available (see below).

COMDAC Infor-
mation

COMDAC 1 (2): This non-editable fields display the current
COMDAC working state. The following values are possible:
Working , Standby  and Not Equipped  (if there is no COM-
DAC inserted in the corresponding slot).

SW Version: Shows the SW Version for the respective
COMDAC.

Protection
Switch

Radio buttons allow protection switching to be specified.
Only the working COMDAC is inhibited.
With the Forced Switch  request the working COMDAC be-
comes standby and vice versa.
Inhibited Switch request is disabled if the current protection
status is Forced .
Forced Switch  request is disabled if the current protection
status is Inhibit .
Therefore before you can switch from Forced Switch to
Protection  to Inhibit  or vice versa you have to Clear the
current protection.

Protection
Mode

This field displays the current protection mode which will be
updated as a result of a protection switch.
Possible values: Clear  or Freeze.
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■ The NE cannot execute the request as the NE software installation is in
progress.

5.3.2.7.2 IO-DS1 Protection Switching

The NE supports both protected and unprotected DS1 feeder interface opera-
tions, i.e., the IO-DS1 can be 1:N protected (1≤N≤5) or without a protection
IO_DS1 pack. IO-DS1 pack protection is controlled by the active COMDAC via the
Protection Control Bus.

The AEM-NB cannot provision DS1 pack-level protection. It is automatically in-
voked when an FAC100 pack is plugged into the IO-DS1 protection slot.

Complete the following procedure to define protection switching for IO-DS1.

Step Procedure

1. Select All -> NE -> Shelf  in the Network Browser and Protection  via the
cursor menu
or select Equipment -> Protection via the Menu bar.
The Shelf Protection window pops up:

2. Click on tab IO-DS1.

Overview

Procedure
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Figure 5-27 "Shelf Protection" Window (Tab IO-DS1)

This window provides IO-DS1 protection information. It also provides the
mechanisms needed to perform changes in the protection scheme as well
as protection switches.
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3. Use the following table to define the IO-DS1 Protection Switch:

Parameters/
Buttons Description

Protection
Scheme

Displays the protection scheme used in the NE for IO-DS1.
Possible values: Enable  (IO-DS1-p present) or Disable  (no
IO-DS1-p). Only in the case of protection scheme Enable
the Protection Switch  pane is available.

Protection
Switching

The IO-DS1 option menu shows all IO-DS1s (present or ab-
sent) in the NE. Selecting one of these IO-DS1 will provoke
population of the Active Switch Request  and Protection
State  read-only fields (see below).

The possible values for Active Switch Request are:

■ Clear : No active switch in effect. Any protection switch
is allowed for the specified IO-DS1.

■ Lockout : If this is selected for the protection IO-DS1,
access to the protection pack for the group is not al-
lowed. When applied to a service IO-DS1, access to
the protection pack is prevented. No protection
switches will be done on the specified service slot until
the switch is reset. Only Clear Protection Switch will be
allowed.

■ Forced Switch to Protection : Applicable to IO-DS1
only. No automatic or manual switches will be done un-
til the forced switch is reset.

■ Automatic Switch to Protection : A switch provoked
by a failed (or missing) IO-DS1 to the protection unit.

■ Manual Switch to Protection : The specified service
IO-DS1 has been manually switched to protection IO-
DS1.

The Protection State  displays the current protection state
which will be updated as a result of a Protection Switch
(see below). Possible values are: Not Equipped , Working
and Standby.
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4. Use the menu button IO-DS1 to select an appropriate IO-DS1.

5. Use the radio buttons in the field Protection Switch to select the desired
protection: Clear  or Inhibit  or Forced Switch to Protection  or Manual
Switch to Protection.

6. Press Apply to confirm. The Warning window pops up:

Protection switching may be service affecting. Do you
want to continue?

If you decide to continue, the switch operation will be started. The infor-
mation displayed will be updated once the switch is finished to show the
current state.

The following events set off error messages:

■ The NE is not equipped for the requested protection switching (i.e. the pro-
tecting slot is empty).

■ The NE detects an error in the switch request (i.e. the request cannot be
executed due to another activity in the AEM-NB).

Protection
Switch

Radio buttons allow protection switching: Clear  or Inhibit  or
Forced Switch to Protection  or Manual Switch to Protec-
tion .

Clear : Clears any active switch request and returns traffic on
the protection pack to its original service pack (provided this
pack is functional). Clear  does not affect the Automatic
Switch .

Inhibit : If applied on the protection pack, service shall return
to the protected pack and Protection Scheme  changed to
Disable . If applied on the protected pack, protection for this
pack is disabled. If this pack was providing service through
the protection pack, a protection-to-service switch will occur.
This protection switch remains in effect till a protection mode
is cleared.

Forced Switch to Protection : Switches service from the
service pack to the protection pack (no matter what). Not ap-
plicable to protection pack. The switch remains in this state
until a Lockout  or Clear  is requested.

Manual Switch to Protection : Switches service from ser-
vice pack to the protection pack if the protection pack is
present, functional and not carrying traffic. Not applicable to
the protection pack.
This protection switch remains in effect till a protection
switching Lockout , Forced , or Clear  is entered or an Auto-
matic Protection Switch  occurs.

Parameters/
Buttons Description
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■ The NE cannot execute the request as the NE software installation is in
progress.

■ The forced switch is denied as the protecting slot is locked out.

■ The manual switch is denied either because there is a higher protection
switch active (Inhibit, Forced) or because an automatic switch is already
protecting that protected slot.

5.3.2.8 Alarm Configuration

Configuring of the alarm severities is only possible via the cut-through inter-
face.The corresponding TL1 commands are available on-line using the GSI help
on AnyMedia Access System.

5.3.3 Delete NE

If the NE should not be managed by the AEM-NB any longer, it shall be deleted
from the AEM-NB database.

Complete the following procedure to delete an NE.

Step Procedure

1. Select the All -> NE in the Network Browser and Delete NE via the cursor
menu
or select File -> Delete  or Equipment -> Provisioning -> Delete via the
Menu bar. A Warning window pops up:

You are about to delete <NE Name>. Do you want to
continue?

If you select No, the deletion of the NE is rejected. Otherwise, the NE will
be deleted.

NOTE:
When an NE is deleted from the AEM-NB database, it is still fully functional.
The TL1 and TCP/IP links between the AEM-NB and the NE will be closed
and the management access via the AEM-NB is finished until the NE is cre-
ated and connected again.

Procedure



5-68 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Configuration Management/Provisioning Service Provisioning

5.4 Service Provisioning

Service provisioning (deactivation) consists of the setting of those parameters
needed to provide service to (or disconnect service from) an individual end-cus-
tomer. For Distribution Ports, such parameters include those that specify a T0
cross-connection between a Logical T0 on a VRT/VB (Virtual Remote Terminal /
Virtual Bank) and an end-customer’s physical port, and the setable parameters
within the port. Service provisioning is typically initiated by a service order, al-
though reprovisioning is sometimes also needed for maintenance purposes or for
reconfiguration of an existing network, e.g., load balancing.

Figure 5-28, page 5-69 shows a conceptual diagram of the cross-connections be-
tween the physical (DS1 and subscriber) ports of the AnyMedia Access System
and the VRTs/VBs. The AnyMedia Access System supports

■ up to one TR-303 VRT

■ up to 20 TR-08 VRTs

■ and up to 20 INA VBs

in any combination not exceeding 20 feeder DS1s (4 DS1 feeders for each IO-
DS1).

T1 cross-connections provide feeder bandwidth to VRTs and VBs. A maximum of
20 T1 cross-connections can be created; they are limited by the maximum num-
ber of DS1 feeder ports in the system.

Overview
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Figure 5-28 Cross-Connection Diagram

T0 cross-connections bind a Distribution Port (a tip/ring pair) to a VRT or VB. A
maximum of 609 T0 cross-connections can be created in the AnyMedia Access
System; they are limited by the maximum number of Distribution Ports in the sys-
tem.

Each Logical T0 may contain provisioning data for its associated physical sub-
scriber line. In addition, the T0 data for locally switched services and ISDN lines
on the TR-303 VRT can be administered by the LDS through its EOC. When a
physical subscriber line is T0 cross-connected to a VRT or VB, it takes on the
characteristics defined by the T0 data for the corresponding logical port (e.g., if a
line from a PROG2W LPA380 AP is cross-connected to a logical port that is provi-
sioned for POTS service, it provides a loop-start interface; if the line is then cross-
connected to a logical port that is provisioned for Foreign Exchange (FX) service,
it provides a ground-start interface).
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The NE logical configuration supports a combined maximum of 672 T0 records
among all VRTs and VBs. This number exceeds the total number of physical sub-
scriber lines that the system supports.

The physical ports of the AnyMedia Access System provide feeder DS1 connec-
tions and subscriber tip/ring pairs. The physical ports are associated with IO-DS1
FAC100 circuit packs and APs respectively.

Service provisioning for VF (Voice Frequency) services requires that feeder and
distribution ports be associated with a VRT/VB through T1 and T0 cross-connec-
tions, respectively, and that T0 provisioning data be entered for the desired ser-
vice. Finally, the required physical circuit packs must be equipped. Figure 5-29
represents the composite provisioning data required to bring a single subscriber
line into service on a TR-08 VRT.

Figure 5-29 Provisioning Data for a TR-08 POTS Subscriber Line

As mentioned before the AnyMedia Access System may contain 1 TR-303 VRT
and/or up to 20 TR-08 VRTs and INA VBs in any combination, subject to the limit
imposed by the 20 available DS1 network interfaces. A physical distribution port
may be assigned to only 1 logical line on 1 VRT or INA VB; similarly, a logical line
can be assigned to only 1 physical distribution port.

The single TR-303 VRT can support any number of physical lines up to the full
608-line maximum capacity of the AnyMedia Access System. The logical lines of
the TR-303 VRT are identified by Call Reference Values (CRVs), which may be
any of 672 integer values from 1 to 2048. A physical distribution port in the system
can be assigned to any CRV of the TR-303 VRT.

The TR-303 VRT includes full access concentration between its logical line DS0s
and available time slots on the feeder DS1s (24 time slots) associated with the
VRT (full access means that if there is an available feeder time slot it is possible to
assign a logical line DS0 to that time slot). For time slot management the TR303
VRT supports the following process:
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Dynamic time slot assignment : a time slot assignment made over the Timeslot
Management Channel (TMC) for locally-switched application. This time slot as-
signment/deassignment is done on a per call basis under control of the LDS.

Semi-permanent time slot assignment : a time slot assignment made over the
Embedded Operation Channel (EOC) for providing a dedicated voice/data path.
This time slot assignment/deassignment is done on a per service order basis. The
LDS will manage the semi-permanent cross-connections in the TR-303 VRT.

A TR-08 VRT supports up to 96 physical lines. The logical lines are identified by
logical line numbers (LLNs), which are integer values ranging from 1 to 96. A
physical distribution port may be assigned to any LLN within any TR-08 VRT.
There is a fixed mapping between TR-08 LLN number and the TR-08 feeder DS0
used for the circuit. This allows the FAST to make the cross-connection between
the TR-08 physical port and the feeder DS0 without explicitly provisioning the
feeder DS0 to be used.

An INA VB supports a maximum of 24 physical lines. The logical lines are num-
bered from 1 to 24. A physical distribution port may be assigned to any logical line
within any INA VB.

There is a fixed mapping between INA LLN number and the INA feeder DS0 used
for the circuit. This allows the AnyMedia Access System to make the cross-con-
nection between the INA physical port and the feeder DS0 without explicitly provi-
sioning the feeder DS0 to be used. The AID (Access Identifier) of an INA logical
line and its INA feeder DS0 are the same.

For more information refer to the AMAS R1.5 network elements documentation.

Figure 5-30, page 5-72 shows an overview of the screen navigation for service
provisioning.

The arrows represent the order in which the windows can be opened.

To edit the Physical DS1-Logical DS1 window

■ select All -> NE -> Shelf -> IO-DS1 -> Physical DS1 in the Network
Browser and
select Edit  via the cursor menu.

TR-08 VRT

INA VB

Screen Navigation

Example
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Figure 5-30 Screen Navigation for Service Provisioning

NE

Physical DS1-Logical DS1

from IO-DS1 window (Equip-
ment Configuration -
cf. Chapter 5.3, page 5-14)

from AP or CU window
(Equipment Configuration - cf.
Chapter 5.3, page 5-14)

Logical T0

VRT/VB List

VRTs/VBs

Logical DS1 List Logical T0 List
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5.4.1 Edit Network Interface

Complete the following procedure to configure a VRT/VB.

Step Procedure

1. Select All -> NE -> VRT/VB List in the Network Browser and Edit via the
cursor menu
or select File -> Open  or Service -> Provisioning -> View/Edit via the
Menu bar. The VRT/VB List window pops up.

Figure 5-31 "VRT/VB List" Window

This window displays the VRT/VB ids list based on a selection criterion. It pro-
vides access to the VRT/VB window for addition or deletion of Logical DS1s

Procedure
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and/or Logical T0s and for modifying VRT/VB specific parameters (when applica-
ble).

2. Use the radio buttons to choose a desired VRT/VB.

3. Select an appropriate entry in the list click on Edit VRT/VB...  or double
click on the entry. The VRT/VB window pops up.

NOTE:
Figure 5-32, page 5-75 shows the VRT/VB window for TR-303. Only for this
interface type the panes VFDE and Datalink & Protection  are available.
For TR-08 and INA are only the panes Actions and Operational State are
available. Only these two panes are shown in the corresponding windows.

Parameters/
Buttons Description

Selection Crite-
ria

Radio buttons are used to define the list that will be dis-
played in the pane VRT/VB List .

VRT/VB List Selected criterion is All VRT/VB :
The list will display all VRT/VB ids.

Selected criterion is TR-303 or TR-08 or INA:
In these cases, only the VRT/VB ids of the selected type will
be displayed.

The VRT/VB table provides a scroll bar to allow access to all
VRT/VB ids.
VRT/VB id format:
v303-1  for TR-303
v08-{1, 20}  for TR-08
ina-{1, 20}  for INA

Upon selection of any entry, the Edit VRT/VB...  button be-
comes available.
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Figure 5-32 "VRT/VB" Window

This window provides access to the lists of Logical DS1s and Logical T0s, as well
as allowing addition of Logical DS1s and Logical T0s to the selected VRT/VB. It
also displays (on demand) the VRT/VB operational state. In the case of TR-303,
this window will show the VFDE state (enable or disable) and datalink protection
information.
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Parameters/
Buttons Description

Actions Four buttons provide access to other windows:

Edit Logical DS1 List... : Provides access to the Logical
DS1 List window for the selected VRT/VB (cf. Chapter 5.4.5,
page 5-88).

Edit Logical T0 List... : Provides access to the Logical T0
List window for the selected VRT/VB (cf. Chapter 5.4.8,
page 5-112).

Add Logical DS1... : Provides access to the Physical DS1-
Logical DS1 window (tab Cross-connection - cf.
Chapter 5.4.3, page 5-81). The VRT/VB id will be populated
using the selected VRT/VB id.

Add Logical T0... : Provides access to the Logical T0 win-
dow for the selected VRT/VB (cf. Chapter 5.4.7, page 5-90).

Operational
State

The Service State  shows the VRT/VB service state ob-
tained from the NE through the use of the Get button.
Possible values: In Service (IS) and Out of Service (OOS).

The Get button retrieves the VRT/VB service states.

The following panes are only applicable to TR-303 (cf.
Chapter 5.4.4, page 5-88).

VFDE Two radio buttons (Enable / Disable ) are used to modify the
VFDE status by clicking on Apply .

The Apply  button is available only if the VFDE status has
been modified.
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Datalinks & Pro-
tection (not yet
available for
R1.5)

Primary Link, Secondary Link : Displays the Logical DS1 id
of the Primary (logical feeder DS1-1) and Secondary Link
(logical feeder DS1-2). Only available if Logical DS1 id is
present. Possible values are: v3fdr-{1}-{1, 28}.

The Edit Logical DS1... button provides access to the DS1-
Logical DS1 window (Physical DS1 Data tab - cf.
Figure 5-37, page 5-86) to change the timing reference.

EOC Datalink:

■ Working / Standby EOC : Displays the Logical DS1 id
used by the working/standby EOC (Embedded Opera-
tions Channel).
Possible values are:  v3fdr-{1}-{1, 28}.

■ Manual Switch button: Performs a manual switch be-
tween working and standby EOCs. Only available if
both working and standby EOCs are present and the
standby path is not out of service.

■ Forced Switch  button: Performs a forced switch be-
tween working and standby EOCs. Only available if
both working and standby EOCs are present and re-
gardless of the service condition of the standby path.

TMC Datalink:

■ Working / Standby TMC : Displays the Logical DS1 id
used by the working/standby TMC (Timeslot Manage-
ment Channel).
Possible values:  v3fdr-{1}-{1, 28}.

■ Manual Switch  button: Performs a manual switch be-
tween working and standby TMCs. Only available if
both working and standby TMCs are present and the
standby path is not out of service.

■ Forced Switch  button: Performs a forced switch be-
tween working and standby TMCs. Only available if
both working and standby TMCs are present and re-
gardless of the service condition of the standby path.

Parameters/
Buttons Description
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5.4.2 Logical DS1 List

Complete the following procedure to edit the Logical DS1 List.

Step Procedure

1. Select All -> NE -> VRT/VBs List -> VRT/VB Type (TR-303, TR-08, INA)
-> VRT/VB id in the Network Browser and Edit Logical DS1 List via the
cursor menu
or select File -> Open  or Service -> Logical DS1 List via the Menu bar.
The Logical DS1 List window pops up.

Figure 5-33 "Logical DS1 List" Window

Procedure
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This window displays Logical DS1 id list based on a selection criteria. It provides
access to Physical DS1-Logical DS1 window for Physical DS1-Logical DS1 pa-
rameter modification.

Parameters/
Buttons Description

Selection Crite-
ria

Radio buttons are used to define the list that will be dis-
played in the pane Logical DS1 List .

■ All VRTs/VBs : The list displays all Logical DS1s cur-
rently present in the NE for all VRT/VBs.

■ TR-303, TR-08, INA: In all these cases except TR-303,
a non-editable option list will be available showing the
possible options. Selection of one of these VRT/VB ids
automatically sets the corresponding radio button. If no
VRT/VB id is selected, the radio button is not editable
(i.e. the user will not be able to set it).
Possible values: v08-{1, 20} for TR-08

ina-{1, 20} for INA.

Add Logical
DS1...

This button is only available if a specific VRT/VB id has been
selected and the maximum number of Logical DS1s has not
yet been created:

max. 4 for TR-08
max. 20 for TR-303
max. 1 for INA.

This button provides access to the Physical DS1-Logical
DS1 window to add a new Logical DS1.

Logical DS1
List

The information in this field is displayed in a table:

■ VRT/VB id : Displays a logical part of the NE that sup-
ports a single type of interface.
Format: v303-1 for TR-303

v08-{1, 20} for TR-08
ina-{1, 20} for INA.

■ Logical DS1 id : Indicates the Logical DS1 id within the
VRT/VB id.
Possible values: v3fdr-1-{1, 28} for TR-303

v8fdr-{1, 20}-{a, b, c, d} for TR-08
ina-{1, 20} for INA.

■ Physical DS1 Id : Displays the Physical DS1 id cross-
connected to the Logical DS1 id.
Possible values: ds1-1-{1, 5}-{1, 4}.

Edit Logical
DS1...

This button provides access to the Physical DS1-Logical
DS1 window to edit the Logical DS1 parameters (whenever
this is possible) and the Physical DS1 parameters.

Delete Logical
DS1...

Deletes the Physical DS!-Logical DS1 cross-connection se-
lected in the list.
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2. Use the radio buttons to choose a desired VRT/VB.

If you want ... then ...

to add a Logical DS1 press Add Logical DS1... . The Physi-
cal DS1-Logical DS1 window pops up
(cf. Chapter 5.4.3, page 5-81).

to edit a Logical DS1 select a row in the Logical DS1 List
and press Edit Logical DS1... . The
Physical DS1-Logical DS1 window
pops up (cf. Chapter 5.4.5, page 5-88).

to delete a Logical DS1 refer to Chapter 5.4.6, page 5-89.



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-81

AEM-NB R1.5

Service Provisioning

5.4.3 Creation of VRT/VB Logical Feeder
(T1 Cross-Connection)

For the following description it is assumed that the NE is connected, a logical
feeder is not yet created and the physical feeder (DS1) is not in use by any other
logical feeder.

The following figure shows a block diagram of T1 cross-connections.

Figure 5-34 T1 Cross-Connections

Complete the following procedure to add a logical feeder (T1) to a VRT/VB.

Further information is contained in Chapter 5.4.5, page 5-88 for editing the
VRT/VB logical feeder; cf. Chapter 5.4.6, page 5-89 for deleting the VRT/VB logi-
cal feeder.

Step Procedure

1. Select All -> NE -> VRT/VB List -> VRT Type -> VRT/VB id in the Net-
work Browser and Add Logical DS1  via the cursor menu
or select Service -> Provisioning -> Add -> Logical DS1 via the Menu
bar. The Physical DS1-Logical DS1 window pops up.

NOTE:
There are different ways to open this window (cf. Figure 5-30, page 5-72).
Depending of the previous actions the options in the window are different.

Assumptions

I/O DS1
1

I/O DS1
5

INA VB

T1 Cross -
Connections

LOG FDR DS1 #28

LOG FDR DS1 #1

TR-303
VRT

LOG FDR DS1 #4

LOG FDR DS1 #1

TR-08
VRT

LOG FDR = Logical Feeder

Physical Feeder

Procedure
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Figure 5-35 "Physical DS1-Logical DS1" Window (Tab Cross-Connection)

The tab "Cross-connection" identifies the NE and VRT/VB related to the cross-
connection and provides the facilities for selecting the appropriate Physical DS1
and Logical DS1 id (from the lists of available ones) in the case of cross-connect-
ing Physical DS1-Logical DS1. As far as editing is concerned, both fields will be
non-editable and the only possible action will be delete the cross-connection.

Parameters/
Buttons Description

VRT/VB id Depend on the previous action this field displays the already
selected VRT/VB id or provides an option menu (if the DS1
is not yet cross-connected) to select an appropriate VRT/VB
id.

Cross-connec-
tion Information

The field Physical DS1  is used to enter an appropriate
Physical DS1 to be cross-connected.

(When coming from a window in which the Physical DS1 is
already defined the corresponding value is displayed and
this field is not editable.)

Format: ds1-shelf-slot-feeder
Possible values: ds1-1-{1, 5}-{1, 4}
(five possible IO-DS1s per shelf, four possible feeders
per IO-DS1).
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2. Enter the appropriate Physical DS1  (up to 9 characters) to be cross-con-
nected in field Physical DS1.

3. Enter the appropriate Logical DS1 id  (up to 10 characters) to be cross-
connected.

4. Click on label button Add Logical DS1 .

5. Switch to tab Logical DS1 Data.

The field Logical DS1  is used to enter an appropriate Logi-
cal DS1 id to be cross-connected.

(When coming from a window in which the Logical DS1 is al-
ready defined the corresponding value is displayed and this
field is not editable.)

Possible values: v3fdr-{1}-{1, 28} for TR-303
v8fdr-{1, 20}-{a, b, c, d} for TR-08
ina-{1,20} for INA.

Label For the label  button two values are possible: Add Logical
DS1 or Delete Logical DS1 .

Add Logical DS1  will be available when the Logical DS1
does not yet exist.

Delete Logical DS1 will be available when the Logical DS1
does already exist.

Parameters/
Buttons Description
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Figure 5-36 "Physical DS1-Logical DS1" Window (Tab Logical DS1 Data)

Logical DS1 information will be provided only if there is a Physical DS1-Logical
DS1 cross-connection in place.

Parameters/
Buttons Description

Logical DS1 id This field shows the corresponding value: any number be-
tween 1 and 28.

Possible values: v3fdr-{1}-{1, 28} for TR-303
v8fdr -{1, 20}-{a, b, c, d} for TR-08
ina-{1, 20} for INA.

NOTE:
Only 20 logical DS1s can be cross-connected inside
an NE.
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6. Select the appropriate frame format in the option menu Frame Format .

7. Select the appropriate line coding value in the option menu Line Code .

Frame Format This option menu shows the possible frame formats:

Three possible values: ESF (Extended SuperFrame), FS
(SuperFrame with Datalink) or SF (SuperFrame).
Default values are:

■ ESF for TR-303 not reprovisionable

■ FS for TR-08 (DS1-a) not reprovisionable

■ SF for TR-08 (DS1-{b,d} not reprovisionable

■ ESF for INA ESF or SF.

NOTE:
Values are only changeable for INA VB.

Line Code This option menu shows the line coding values:

Possible values are:

ZCS (Zero Code Suppression) or
B8ZS (Bipolar with 8 Zero Suppression).

The default is B8ZS for TR-303, TR-08 and INA VRT/VBs.

NOTE:
Values only changeable for TR-08 and INA. ZCS is
blocked for TR-303 VRTs.

Get Via this button the Logical DS1 Service State  and the Logi-
cal DS1 Secondary Service State  can be displayed.

Possible values for Service State: IS (In Service) or OOS
(Out of Service).

Possible values for Secondary Service State: AUTO (Auto-
matic Non Alarmed), LPBK  (Loop back), MON (Degraded
Signal) or YEL (Yellow Alarm).

Apply This command button will only be available in the following
cases:

1. There is a Physical DS1-Logical DS1 cross-connection
present.

2. VRT/VB Type is TR-08 and Line Code has been modi-
fied.

3. VRT/VB type is INA and any of the Frame Formats has
been modified.

Parameters/
Buttons Description
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8. Click on Apply  to confirm.

9. Switch to tab Physical DS1 Data.

Figure 5-37 "Physical DS1-Logical DS1" Window (Tab Physical DS1 Data)

This window provides physical DS1 information.

Parameters/
Buttons Description

Physical DS1 This field displays the selected physical DS1 id (already pop-
ulated).

Format: ds1-shelf-slot-feeder
Possible values: ds1-1-{1, 5}-{1, 4}

(Five possible IO-DS1s per shelf, four possible feeders per
IO-DS1).

Equalization This field is used to define the cable length to the DSX-1.
This field is mandatory. Possible values are: 0 to 655 ft.
Default value is 0 ft.

Degrade
Threshold

Physical DS1 Signal Degrade Threshold.
Possible values are: 10E-7, 10E-6, 10E-5, 10E-4.
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10. Enter the appropriate cable length to the DSX-1 in the Equalization  field.

11. Select the Degrade Threshold  for Physical Feeder.

12. Click on Apply  to confirm.

Loopback This field displays the current loopback state (clear  or set ).
Use the Label button on the right-hand side to change the
loopback state (for loopback details see Chapter 6.4.5,
page 6-29).

Label Use this button to set or clear the physical DS1 loopback.
Depending on the loopback state reflected, this command
button displays the possible operation (Clear, if the loopback
is set; Set, if the loopback is cleared).

Timing Refer-
ence

Displays whether or not the selected physical DS1 is the tim-
ing source reference (Yes or No). The reference can be
changed via the Edit...  button on the right-hand side. This
button provides access to the NE Information window (tab
Timing Source Control  - cf. Chapter 5.3.2.4, page 5-52) to
allow the modification of the current NE timing source refer-
ence.

Get Via this button the physical DS1 Service State and the DS1
Secondary Service State  can be displayed.

Possible values for Service State: IS (In Service) or OOS
(Out of Service).

Possible values for Secondary Service State: AUTO (Auto-
matic Non Alarmed), LPBK  (Loop back), MON (Degraded
Signal) or YEL (Yellow Alarm).

Apply This button will only be available if the Equalization and/or
Degrade Threshold have been modified.

Parameters/
Buttons Description
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5.4.4 Change Voice Frequency Data En-
hancement (VFDE) for TR-303 VRTs

For the following description it is assumed that the NE is connected and the VFDE
state is well-known.

Complete the following procedure to change VFDE for TR-303 VRTs.

Step Procedure

1. Select All -> NE -> VRT/VB List -> VRT Type TR-303 in the Network
Browser and Edit  via the cursor menu
or select File -> Open  or Service -> Provisioning -> Edit via the Menu
bar. The VRT/VB window pops up (cf. Figure 5-32, page 5-75).

2. Choose the VFDE state (Enable/Disable ) by using the radio buttons in
the field VFDE.

3. Click on Apply  to confirm. A Warning window pops up in case of chang-
ing the VFDE state to Disable :

The operation may be service affecting. Continue
anyway?

4. If you decide to continue, the AEM-NB will send an allow-VFDE message
(in case of enable) or an inhibit-VFDE message (in case of disable) to the
NE. The following In Progress message will be shown in the status bar:

Disable/Enable VFDE launched.

5.4.5 Edit VRT/VB Logical Feeder

For the following description it is assumed that the NE is connected, the Logical
Feeder is created and the Service State of the Logical Feeder is well known.

Complete the following procedure to change a Logical Feeder (T1) of a VRT/VB.

Step Procedure

1. Select All -> NE -> VRT/VBs List -> VRT/VB Type -> VRT/VB id  in the
Network Browser and Edit Logical DS1 List  via the cursor menu
or select Service -> Logical DS1 List via the Menu bar.The Logical DS1
List window pops up.

2. Select the appropriate VRT/VB id in the table Logical DS1 List.

3. Click on Edit Logical DS1... . The Physical DS1-Logical DS1 window
pops up (cf. Chapter 5.4.3, page 5-81).

Assumption

Procedure

Assumptions

Procedure
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Use the tabs Physical DS1 Data  and Logical DS1 Data  to edit the Logi-
cal Feeder Data.

NOTE:
Physical Feeder:
If the new DS1 is not in use, both a delete-cross-connection and a new en-
ter-cross-connection message are sent to the NE.
If the new DS1 is in use, both existing cross-connections are released (old
and new DS1), via two delete-cross-connection messages, and two new
cross-connections are created via two enter-cross-connection messages.

5.4.6 Delete VRT/VB Logical Feeder

For the following description it is assumed that the NE is connected, the Logical
Feeder is created and the Service State of the Logical Feeder is well known.

Complete the following procedure to remove a Logical Feeder (T1) from a
VRT/VB.

Step Procedure

1. Select All -> NE -> VRT/VBs List -> VRT/VB Type -> VRT/VB id  in the
Network Browser and Edit Logical DS1 List  via the cursor menu
or select Service -> Logical DS1 List via the Menu bar.The Logical DS1
List window pops up.

2. Select the appropriate VRT/VB id in the table Logical DS1 List.

3. Click on Delete Logical DS1... . A Warning window pops up:

Deleting Logical DS1 id may be service affecting and
may remove existing semi-permanent cross-connections
(DS0 end points), OK to proceed?

If you decide to continue, the AEM-NB will send a delete-cross-connec-
tion message to the NE.

Assumptions

Procedure
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5.4.7 Add VRT/VB Logical T0 (Subscriber)

For the following description it is assumed that the NE is connected, the Logical
T0 is not yet created and the Physical Line (drop or roc) is not in use by any other
Logical T0.

The following figure shows a block diagram of T0 cross-connections.

Figure 5-38 T0 Cross-Connections

Complete the following procedure to add a Logical T0 of a VRT/VB:

Step Procedure

1. Select All -> NE -> VRT/VBs List -> VRT/VB Type -> VRT/VB id  in the
Network Browser and Edit Logical To List  via the cursor menu
or select Service -> Logical T0 List via the Menu bar.
The Logical T0 List window pops up.

This window can also be reached with All -> NE -> Logical T0 List via
the cursor menu.

Assumptions

INA VB

TR-303
VRT

TR-08
VRT

PLN #1

1

24

 LLN (CRV) #1

 LLN (CRV) #2048

PLN #2

Physical Distribution Port
Circuits in APs and CUs

PLN #512

PLN #513

PLN #608

T0 Cross-
Connection

 LLN #1

 LLN #96

AP
#1

AP
#16

CU
#24

CU
#1

Procedure
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Figure 5-39 "Logical T0 List" Window

This window displays the Logical T0 id  list based on a selection criterion.

Parameters/
Buttons Description

Selection Crite-
ria

Radio buttons are used to define the list that will be dis-
played in the pane Logical T0 List (see below).

■ All Network Interfaces : The list displays all Logical
T0s currently present in the NE for all VRT/VBs.

■ TR-303, TR-08, INA: In all these cases except TR-303,
a non-editable option list will be available showing the
possible options. Selection of one of these VRT/VB ids
automatically sets the corresponding radio button. If no
VRT/VB id is selected, the radio button is not editable
(i.e. the user will not be able to set it).
Possible values: v08-{1, 20} for TR-08

ina-{1, 20} for INA.
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2. Use the radio buttons to choose a desired Logical T0 .

3. Click on Add Logical T0... .The new VRT/VB id will be inserted into the
Logical T0 list.

4. Select an appropriate entry in the Logical T0 list and click on Edit
VRT/VB... or double click on the entry. The Logical T0 window pops up:

Add Logical
T0...

This button is only available if a specific VRT/VB id has been
selected and the maximum number of Logical T0s has not
yet been created:

max. 96 for TR-08
max. 2048 for TR-303
max. 24 for INA.

Logical T0 List The information in this field is displayed in a table:

■ VRT/VB id : Displays a logical part of the NE that sup-
ports a single type of interface.
Format: v303-1 for TR-303

v08-{1, 20} for TR-08
ina-{1, 20} for INA.

■ Logical T0 id : Indicates the Logical T0 id within the
VRT/VB id.
Possible values: v3dp-1-{1, 2048} for TR-303

v8dp-{1, 20}-{1, 96} for TR-08
inads0-{1,20}-{1, 24} for INA.

■ Physical Port Id : Displays the Physical Port id cross-
connected to the Logical T0.
Possible values: drop-{1}-{1,16}-{1,32} for APs

m2drop-{1}-{1,24}-{1,4} for CUs.

■ GSFN: Generic Signalling Function. The following val-
ues are possible: DFLT (default), 2LS, 2GS, Coin , AC,
EBS, LR, DPT, 2FXLS, 2FX, 2RVO, 2NOS, TO,
DX4[N,R], FX[O,P,S,T] [1,2,3,5] EM4[C,H], PLR[1,2],
ETO4, FXO, TD[O,S] [A,B,C,D], TO4, ISDN, 4DO,
DATA , NO1, NO2, OCU1, OCU2, OCU3, SW56, BRI.
Unknown.

Edit Logical
T0...

This button provides access to the Logical To window to edit
the Logical T0 parameters (whenever this is possible).

NOTE:
This button is disable if GSFN = Unknown.

Delete Logical
T0...

Deletes the cross-connection selected in the list (cf.
Chapter 5.4.9, page 5-112).

Parameters/
Buttons Description
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Figure 5-40 "Logical T0" Window (Tab General)

This window is composed of two tabs: General and Service Details . It is used to
add Logical T0, remove Logical T0 or modify Logical T0. The parameters shown
in this window will be enabled or disabled depending on the action selected and
where this action has been selected from. This window allows cross-connection of
User Port-Logical T0 (T0 Cross-connections), as well as service configuration and
modification.

Parameters/
Buttons Description

VRT/VB id This field displays the selected VRT/VB id.
v303-1 for TR-303
v08-{1, 20} for TR-08
ina-{1, 20} for INA.

NOTE:
When coming from the Application Pack window (Add
Logical T0... - cf. Chapter 5.3.2.1.6, page 5-34) or the
Physical Port id cursor menu (Network Browser), this
field is empty and non-editable. An option menu with
all VRT/VB ids is offered for selection.
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GSFN Available GSFNs:

Group 1: DFLT, 2LS, 2GS, Coin , AC, EBS, LR, DPT
Group 2: 2FXLS, 2FX, 2RVO, 2NOS, TO, DX4[N,R],
FX[O,P,S,T] [1,2,3,5] EM4[C,H], PLR[1,2], ETO4, FXO,
TD[O,S] [A,B,C,D], TO4
Group 3: ISDN
Group 4: DATA , NO1, NO2, OCU1, OCU2, OCU3,
SW56, BRI.

The GSFNs are described in Chapter 5.4.7.1,
page 5-98 to Chapter 5.4.7.15, page 5-110.

NOTE:
When coming from the Application Pack window (Add
Logical T0... - cf. Chapter 5.3.2.1.6, page 5-34) or the
VRT/VB window (Add Logical T0...  - cf.
Chapter 5.4.1, page 5-73), this field is empty and edit-
able.

NOTE:
GSFN type is NOT modifiable in R1.5. A change in the
GSFN of a Logical T0 implies deletion and new cre-
ation of a Logical T0. Depending on the GSFN se-
lected, the list of parameters needed for configuring a
subscriber will differ - see the next sections.

Logical T0 id(s) These fields show the Logical T0 id(s):

v8dp-{1, 20}{1, 96} for TR-08
v3dp-{1}-{1, 2048} for TR-303
inads0-{1, 20}-{1, 24} for INA.

There are three fields available:
The second field will be available only when the GSFN field
is populated with BRI, NO1, NO2 or OCU1, OCU2, OCU3 for
a second entry in bundle Logical T0.
The third field will be available only when the GSFN field is
populated with BRI for a third entry in bundle Logical T0.

NOTE:
These fields are populated and non-editable only
when coming from Edit Logical T0... . Otherwise they
are empty and editable.

NOTE:
For NO1, NO2, OCU1, OCU2 and OCU3 a second
entry is possible but not allowed because this is not
yet supported by the NE.

Parameters/
Buttons Description
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5. Use the option menu GSFN to select an appropriate GSFN.

6. Enter the desired Logical T0 id(s) .

7. Use the option menu Expected Pack Type  to select a desired AP (this
step is optional).

8. Use the check box Red Line to define whether the subscriber shall be red
lined.

9. Click on Apply  to confirm.

Physical Port id This field displays the physical Port id cross-connected to the
Logical T0.

Possible values:
drop-{1}-{1,16}-{1, 32} for APs
m2drop-{1}-{1, 24}-{1, 4} for CUs.

NOTE:
When coming from the Application Pack window (Add
Logical T0... - cf. Chapter 5.3.2.1.6, page 5-34) or the
Physical Port id cursor menu (Network Browser), this
field is populated and editable.

Expected Pack
Type

In order to provide service, the subscriber has to be as-
signed to the proper Application Pack. To ensure that the
service requested will work, the user should enter the CLEI
code of the circuit pack that is supposed to provide that type
of service. Since CLEI codes are completely meaningless,
the GUI offers an option menu of the circuit pack types sup-
ported (cf. Table 5-1, page 5-37 and Table 5-2, page 5-45).
Therefore the user is able to select one of these types that
internally is to be mapped to its corresponding CLEI code.

Red Line This check box is used to identify red-lined subscribers.

NOTE:
A special warning message appears when red-lined
Logical T0s are to be edited (cf. Chapter 5.4.9,
page 5-112).

Label The function of this label button depends on the situation.
Possible values are: Apply  or Delete .
Apply  will be displayed whenever Add Logical T0...  has
been selected or Edit Logical T0... has been chosen and at
least one parameter has been modified.
Delete  will be active when coming from Edit Logical T0...
selection and both Logical T0 id and Physical Port id are
present.

Parameters/
Buttons Description
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Switch to tab Service Detail  to get/edit service-specific details of the selected
GSFN.

The following parameters are available for all Logical T0 types:

GSFN Cross-References

DFLT cf. Chapter 5.4.7.1, page 5-98

2LS, 2GS, 2FXLS, 2FX cf. Chapter 5.4.7.2, page 5-98

2RVO cf. Chapter 5.4.7.3, page 5-100

2NOS cf. Chapter 5.4.7.4, page 5-101

BRI cf. Chapter 5.4.7.5, page 5-102

T0 cf. Chapter 5.4.7.6, page 5-102

DX4N, DX4R, FX cf. Chapter 5.4.7.7, page 5-103

EM4C, EM4H, PLR1, PLR2 cf. Chapter 5.4.7.8, page 5-104

ETO4 cf. Chapter 5.4.7.9, page 5-105

DPT cf. Chapter 5.4.7.10, page 5-106

FXO cf. Chapter 5.4.7.11, page 5-107

OCU 1, 2, 3 cf. Chapter 5.4.7.12, page 5-108

SW56 cf. Chapter 5.4.7.13, page 5-109

TD cf. Chapter 5.4.7.14, page 5-109

T04 cf. Chapter 5.4.7.15, page 5-110

Parameters/
Buttons Description

NE Name Displays the NE name of the selected NE.

VRT/VB id Displays the selected VRT/VB id.

GSFN Displays the selected GSFN for the Logical T0.
The GSFN parameters are dependent on the GSFN type,
and they are shown in each GSFN group table. There are
some services which do not have special details: COIN,
ISDN, AC, DATA, EBS, LR and NO[1,2].

Service State Shows the Logical T0 service state obtained from the NE
through the use of the Get button.

Possible values: In Service (IS), Out of Service (OOS).
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The following descriptions of service details are introduced by a short explanation
(overview). For more information refer to the AMAS R1.5 network elements docu-
mentation.

Secondary Ser-
vice State

Shows the secondary service state information obtained
from the NE. It provides supplementary information about
the line state.
This field (capable of displaying two lines of text) has a verti-
cal scroll bar to allow display of multiple lines.

Possible values:

Abnormal (ANR)
Facility Failure (FAF)
Family of Equipment Failure (FEF)
Fault (FLT)
Mismatch of Equipment and Attributes (MEA)
Red Lined (RDLD)
Supported Entity Exists (SDEE)
Supported Entity Outage (SGE)
Switch (SWTCH)
Test (TS)
Unassigned (UAS)
Unequipped (UEQ).

Get This button retrieves the Logical T0 service states.

Apply This button is used to accept the different changes.

Parameters/
Buttons Description
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5.4.7.1 Service Details, GSFN = DFLT

The DFLT (Default POTS/SPOTS) service is primarily applicable to TR-08 appli-
cations.

5.4.7.2 Service Details, GSFN = 2LS, 2GS,
2FXLS, 2FX

The 2LS (2-wire loop-start service with enhanced transmission and signaling pro-
visioning options) is applicable to the POTS32 LPA300, PRCOIN LPA350 and
PROG2W LPA380 APs.

The 2GS (2-wire ground-start service with enhanced transmission and signaling
provisioning options) is applicable to the PRCOIN LPA350 and PROG2W LPA380
APs.

The 2FXLS (2-wire FX, loop-start) is applicable to the PRCOIN LPA350 and
PROG2W LPA380 APs.

Service Details
(Parameters) Description

Enable Full
Time Transmis-
sion

When a check mark is set in the check box the transmission
circuits in the AP or CU remain active when the subscriber is
on-hook.

Possible values: Set, Not set . Default: Set.

Loss Mode Use this option menu to specify whether the Application
Pack will automatically adjust its transmit/receive loss to con-
trol the overall loop loss to approximately 2 or 5 dB, or use
prescription-set values.

Possible values: 2, 5, Auto . Default: Auto.

Overview

Overview
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The 2FX (2-wire FX, ground-start) is applicable to the PRCOIN LPA350 and
PROG2W LPA380 APs.

Service Details
(Parameters) Description

Enable Full
Time Transmis-
sion

When a check mark is set in the check box the transmission
circuits in the AP or CU remain active when the subscriber is
on-hook.

Possible values: Set, Not set . Default: Set.

Balance1 Mode
(BAL1)

This option menu can be used to define whether the AP or
CU uses an adaptive hybrid to control the 4-wire-to-2-wire
balance or a prescription set value.

Possible values: Auto , Fixed . Default: Auto.

Balance2 Mode This slider can be used to establish the prescription balance
setting, in case BAL1 is Fixed . If BAL1 has value Auto , this
control will be disabled (grayed out).

Possible values: 0 ... 31, step 1. Default: 0.

Loss Mode
(LOSS)

This option menu can be used to specify whether the AP or
CU will automatically adjust its transmit/receive loss to con-
trol the overall loop loss to approximately 2 or 5 dB, or use
prescription-set values.

Possible values: 2, 5, Fixed . Default: 2.

RTLP (Receive
Transmission
Level Point)

This slider is used to reset a fixed receive gain or loss in dB.
Negative values define loss; positive values define gain.

Only valid if LOSS is Fixed . If LOSS is not fixed, this control
will be disabled.

Possible values: -8 ... 1.5, step 0.25. Default: -8.

TTLP (Transmit
Transmission
Level Point)

This slider can be used to set a fixed transmission gain or
loss in dB. Negative values define loss; positive values de-
fine gain.

Only valid if LOSS is Fixed . If LOSS is not fixed, this control
will be disabled.

Possible values: -6.75 ... 4.5, step 0.25. Default: 4.5.

Z This option menu can be used to define the termination im-
pedance of the tip/ring interface.

Possible values: 600, 900. Default: 900.

Equalization This slider can be used to set the slope equalization for the
AP or CU.

Possible values: 0 ... 7, step 1. Default: 0 (7 for 2FXLS).

Trunk Condition This option menu can be used to determine whether the AP or
CU sets the signaling state toward the CO (Central Office) to
the Idle  state, Busy  or the DS0 Remote Alarm Indication(Rai)
code during a fault condition. Default: Idle (Busy for 2FX).



5-100 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Configuration Management/Provisioning Service Provisioning

5.4.7.3 Service Details, GSFN = 2RVO

The 2RVO (2-wire loop reverse battery, originate) is applicable to the PRCOIN
LPA350 and PROG2W LPA380 APs.

Service Details
(Parameters) Description

RTLP (Receive
Transmission
Level Point)

This slider can be used to reset a fixed receive gain or loss in
dB. Negative values define loss; positive values define gain.

Possible values: -8 ... 1.5, step 0.25. Default: -8.

TTLP (Transmit
Transmission
Level Point)

This slider can be used to set a fixed transmission gain or
loss in dB. Negative values define loss; positive values de-
fine gain.

Possible values: -6.75 ... 4.5, step 0.25. Default: 4.5.

Z This option menu can be used to define the termination im-
pedance of the tip/ring interface.

Possible values: 600, 900. Default: 900.

Balance1 Mode
(BAL1)

This option menu can be used to define whether the AP or
CU uses an adaptive hybrid to control the 4-wire-to-2-wire
balance or a prescription set value.

Possible values: Auto , Fixed . Default: Fixed.

Balance2 Mode This slider can be used to establish the prescription balance
setting, in case BAL1 is Fixed . If BAL1 has value Auto , this
control will be disabled (grayed out).

Possible values: 0 ... 31, step 1. Default: 0.

Equalization This slider can be used to set the slope equalization for the
AP or CU.

Possible values: 0 ... 7, step 1. Default: 0.

Trunk Condition This option menu can be used to determine whether the AP
or CU sets the signaling state toward the CO to the Idle
state, Busy  or the DS0 Remote Alarm Indication (Rai) code
during a fault condition. Default: Idle.

Overview
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5.4.7.4 Service Details, GSFN = 2NOS

The 2NOS (2-wire transmission only, with sealing current) is applicable to the
PRCOIN LPA350 and PROG2W LPA380 APs.

Service Details
(Parameters) Description

Z This option menu can be used to define the termination im-
pedance of the tip/ring interface.

Possible values: 600, 900. Default: 900.

Equalization This slider can be used to set the slope equalization for the
AP or CU.

Possible values: 0 ... 7, step 1. Default: 0.

Balance1 Mode
(BAL1)

This option menu can be used to define whether the AP or
CU uses an adaptive hybrid to control the 4-wire-to-2-wire
balance or a prescription set value.

Possible values: Auto , Fixed . Default: Fixed.

Balance2 Mode This slider can be used to establish the prescription balance
setting, in case BAL1 is Fixed . If BAL1 has value Auto , this
control will be disabled (grayed out).

Possible values: 0 ... 31, step 1. Default: 0.

RTLP (Receive
Transmission
Level Point)

This slider can be used to reset a fixed receive gain or loss in
dB. Negative values define loss; positive values define gain.

Possible values: -8 ... 1.5, step 0.25. Default: -8.

TTLP (Transmit
Transmission
Level Point)

This slider can be used to set a fixed transmission gain or
loss in dB. Negative values define loss; positive values de-
fine gain.

Possible values: -6.75 ... 4.5, step 0.25. Default: 4.5.

Overview
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5.4.7.5 Service Details, GSFN = BRI

The BRI (basic rate interface transmission extension (3 DS0 ISDN BRITE)) is ap-
plicable to the AUA293 ISDN BRITE channel unit which uses the U-Interface
2B1Q signal comprising two B channels and one D channel, plus overhead.

5.4.7.6 Service Details, GSFN = T0

The TO (transmission only, no sealing current) is used for a private line application
with no DC signal. It is applicable to the SPQ442 channel unit which provides four
channels of service which can be used for 2-wire non-switched private lines.

Service Details
(Parameters) Description

Switched VC Switched Virtual Connection for ISDN. This option menu can
be used to select the combination of bearer (B) channels
provided to the subscriber.

Possible values: 2B+D, B1+D, B2+D, D. Default: 2B+D.

Service Details
(Parameters) Description

Impedance The transmit and receive impedance parameter selects the
termination impedance of the channel unit.

Possible values: 600, 900. Default: 600.

Slope This slider can be used to adjust the frequency response of
the equalizer.

Possible values: 0 ... 7, step 1. Default: 0.

Balance This slider can be used to specify the precision network for
the 4-wire-to-2-wire hybrid balance function.

Possible values: 0 ... 15, step 1. Default: 3.

RCVGN This slider can be used to define the receive gain parameter.

Possible values: -8 ... 1.5, step 0.25. Default: -8.

XMTGN This slider can be used to define the transmit gain parame-
ter.

Possible values: -1 ... 6.75, step 0.25. Default: -1.

Overview

Overview
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5.4.7.7 Service Details, GSFN = DX4N, DX4R,
FX

The DX4[N, R] (4-wire duplex signaling, normal simplex and reverse simplex) is
applicable to the AUA41B channel unit which provides one channel of service to
be used in the MDS2/MDS2B.

The FX[O, P][1,2,3,5] (4-wire foreign Xoffice, no toll diversion/with toll diversion
(LSNS, LSRS, GSNS, LSNS)) is applicable to the SPQ444 channel unit which is
intended for use in non locally switched loop- and ground-start special services
(Loop start normal simplex, Loop start reverse simplex, Ground start normal sim-
plex, Ground start reverse simplex).

The FX[S, T][1,2,3,5] (4-wire foreign exchange, no toll diversion/with toll diversion
(LSNS, LSRS, GSNS, LSNS)) is applicable to the AUA41B channel unit which
provides one channel of service to be used in the MDS2/MDS2B (Loop start nor-
mal simplex, Loop start reverse simplex, Ground start normal simplex, Ground
start reverse simplex).

Service Details
(Parameters) Description

TRMT This slider can be used to define the transmit attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

RCV This slider can be used to define the receive attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

Load/Non Load This option menu can be used to select whether the transmit
equalizer mast be loaded or non-loaded distribution cable.

Possible values: N, L. Default: N.

Bandwidth This slider can be used to control the frequency response
characteristic of the transmit equalizer.

Possible values: 0 ... 15, step 1. Default: 0.

Slope This slider can be used to adjust the frequency response of
the equalizer.

Possible values: 0 ... 15, step 1. Default: 7.

Impedance The transmit and receive impedance parameter selects the
termination impedance of the channel unit.

Possible values: 150, 600, 1200. Default: 600.

Height This slider can be used to control the amplitude of the trans-
mit equalizer’s transfer function.

Possible values: 0 ... 15, step 1. Default: 0.

Trunk Condition This option menu can be used to determine whether the AP
or CU sets the signaling state toward the CO to the Idle
state, Busy  or the DS0 Remote alarm indication (Rai) code
during a fault condition. Default: Idle.

Overview
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5.4.7.8 Service Details, GSFN = EM4C, EM4H,
PLR1, PLR2

EM4[C, H]: 4-wire E&M, Type I and Type II. The E&M function is used in PBX tie
trunks to provide the E&M signaling interface. It is applicable to the SPQ454 chan-
nel unit which is intended for used in PBX tie trunks and it can interface with a
PBX or other transmission equipment.

PLR[1,2]: 4-wire pulse link repeater, Type I and Type II. The primary application of
the PLR function is also in PBX tie trunks providing the E&M signaling interface
with inverted polarity. It is also applicable to the SPQ454 channel unit.

Menu Description

Service Details
(Parameters) Description

TTMT This slider can be used to define the transmit attenuator pa-
rameter.

Possible values: 0 ... 25.5, step 0.1. Default: 25.5.

RCV This slider can be used to define the receive attenuator pa-
rameter.

Possible values: 0 ... 25.5, step 0.1. Default: 25.5.

Trunk Condition This option menu can be used to determine whether the AP
sets the signaling state toward the CO to the Idle  state,
Busy or the DS0 Remote alarm indication (Rai) code during
a fault condition. Default: Idle.

Overview



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-105

AEM-NB R1.5

Service Provisioning

5.4.7.9 Service Details, GSFN = ETO4

The ETO4 (4-wire equalized transmission only) function is used in private lines
(voice or data) when equalization of cable transmission characteristics is required.
It is applicable to the AUA41B channel unit.

Service Details
(Parameters) Description

TRMT This slider can be used to define the transmit attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

RCV This slider can be used to define the receive attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

-7 dB (J3)
(DBJ3)

When the Black  option is selected, the channel unit sup-
ports an input TLP range of -15.0 to 1 dB. When the White
option is selected, the channel unit supports an input TLP
range of -8.0 to 8.5 dB.

Possible values: Black , White . Default: Black.

Load/Non Load This option menu can be used to select whether the transmit
equalizer mast be loaded or non-loaded distribution cable.

Possible values: N, L. Default: N.

Bandwidth This slider can be used to control the frequency response
characteristic of the transmit equalizer.

Possible values: 0 ... 15, step 1. Default: 0.

Slope This slider can be used to adjust the frequency response of
the equalizer.

Possible values: 0 ... 15, step 1. Default: 0.

Impedance The transmit and receive impedance parameter selects the
termination impedance of the channel unit.

Possible values: 150, 600, 1200. Default: 600.

Height This slider can be used to control the amplitude of the trans-
mit equalizer’s transfer function.

Possible values: 0 ... 15, step 1. Default: 0.

Sealing Current When a check mark is set, the channel unit applies a current
from tip to ring (or across the transmission lead simplex) of
the subscriber interface.

Possible values: Set, Not set . Default: Set.

Overview
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5.4.7.10 Service Details, GSFN = DPT

The DPT (dial-pulse terminating) function is used for a DID (Direct Inward Dial)
with either dial pulse or multi-frequency addressing. It is applicable to the SPQ442
channel unit which provides four channels of service which can be used for DID
trunks.

Service Details
(Parameters) Description

Impedance The transmit and receive impedance parameter selects the
termination impedance of the channel unit.

Possible values: 600, 900. Default: 600.

Balance This slider can be used to specify the precision network for
the 4-wire-to-2-wire hybrid balance function.

Possible values: 0 ... 15, step 1. Default: 15.

Receive Gain This slider can be used to define the receive gain parameter.

Possible values: -8 ... 1.5, step 0.25. Default: -1.

Transmit Gain This slider can be used to define the transmit gain parame-
ter.

Possible values: -1 ... 6.75, step 0.25. Default: -1.

Slope  (SL) This slider can be used to adjust the frequency response of
the equalizer.

Possible values: 0 ... 7, step 1. Default: 0.

Trunk Condition This option menu can be used to determine whether the AP
or CU sets the signalling state toward the CO to the Idle
state, Busy  or the DS0 Remote alarm indication (Rai) code
during a fault condition. Default: Idle.

Overview



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-107

AEM-NB R1.5

Service Provisioning

5.4.7.11 Service Details, GSFN = FXO

The FXO (foreign exchange office) function is used for a non locally or locally
switched loop- or ground-start application. It is applicable to the SPQ442 channel
unit.

Service Details
(Parameters) Description

Impedance The transmit and receive impedance parameter selects the
termination impedance of the channel unit.

Possible values: 600, 900. Default: 600.

Balance This slider can be used to specify the precision network for
the 4-wire to 2-wire hybrid balance function.

Possible values: 0 ... 15, step 1. Default: 0.

Receive Gain This slider can be used to define the receive gain parameter.

Possible values: -8 ... 1.5, step 0.25. Default: -8.

Transmit Gain This slider can be used to define the transmit gain parame-
ter.

Possible values: -1 ... 6.75, step 0.25. Default: -1.

Slope This slider can be used to adjust the frequency response of
the equalizer.

Possible values: 0 ... 7, step 1. Default: 0.

Toll Diversion When no check mark is set, the channel unit will not transmit
the reverse loop current feed signaling state toward the digi-
tal facility.

Possible values: Set, Not set . Default: Not set.

Trunk Condition This option menu can be used to determine whether the AP
or CU sets the signaling state toward the CO to the Idle
state, Busy  or the DS0 Remote alarm indication (Rai) code
during a fault condition. Default: Idle.

On-Hook Trans-
mission

When a check mark is set, the channel unit is configured for
full-time on-hook transmission.

Possible values: Set, Not set . Default: Not set.

LS/GS This option menu can be used to define whether Loop Start
or Ground Start is used.

Possible values: LS, GS. Default: GS.

Overview
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5.4.7.12 Service Details, GSFN = OCU 1, 2, 3

The OCU[1,2,3] (office channel unit dataport (1, 2 or 4 data rates)) is applicable to
the SPQ452 dual OCU data port which is primarily used in an end-link of a DDS
private line data service.

Service Details
(Parameters) Description

Rate This option menu can be used to specify the subscriber data
rate, in kbps, for the subscriber interface.

Possible values:
OCU1: 24, 48, 96, 192;
OCU2: 384, 560;
OCU3: 640.
Default: 19.2 for OCU1, 56.0 for OCU2, 64.0 for OCU3.

Error Correc-
tion

This option menu can be used to select the error correction
technique for the DS0 path. The MVEC option is applicable
only for subscriber data rates of 19.2 kbps and less. SCEC
requires two DS0 time slots.

Possible values:
OCU1: {NONE, MVEC}. Default: NONE
OCU2, OCU3:{NONE, SCEC}. Default: NONE.

All-Zero Code All-Zero Code allowed: when a check mark is set, the chan-
nel unit will not allow a word containing 8 zeros to be sent to-
ward the digital facility.

Possible values:
OCU1, OCU2: {Set, Not set }. Default: Not set
OCU3: {Set}.

SCC Secondary channel used: when a check mark is set, the
channel unit supports a low-speed telemetry channel in the
subscriber’s data bits.

Possible values:
OCU1, OCU2: {Set, Not set }. Default: Not set
OCU3: {Set}.

QM When a check mark is set, the channel unit will send Abnor-
mal Station Code to the Network upon detecting an exces-
sive number of bipolar violations from the loop.

Possible values:
OCU1, OCU2: {Set, Not set }. Default: Not set
OCU3: {Not set }.

Overview
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5.4.7.13 Service Details, GSFN = SW56

The SW56 (Switched 56 kbps DDS service) is also applicable to the SPQ452 dual
OCU dataport including enhanced service options to the DDS.

5.4.7.14 Service Details, GSFN = TD

TD[O, S][A, B, C, D]: 4-wire tandem office and 4-wire tandem subscriber, 4-state
(Type II, Type I) and 2-state (Type II, Type I). The tandem function is used for pro-
viding a back-to-back carrier interface for loop- or ground-start circuits. It is appli-
cable to the SPQ444 channel unit.

Service Details
(Parameters) Description

Enhanced
Switch

When the Enhanced Switched 56-kbps check mark is set,
the channel unit supports the transmission of call progress
tones to the CPE (Customer Premises Equipment).

Possible values: Set, Not set. Default: Not set.

AB Signaling The AB Signaling parameter check mark is normally not set,
which causes the channel unit to operate in the software sig-
naling mode.

Possible values: Set, Not set. Default: Not set.

Quality Monitor-
ing

When the Quality Monitoring parameter check mark is set,
the channel unit will send Abnormal Station Code to the Net-
work upon detecting an excessive number of bipolar viola-
tions from the loop.

Possible values: Set, Not set. Default: Not set.

Service Details
(Parameters) Description

TRMT This slider can be used to define the transmit attenuator pa-
rameter.

Possible values: 0 ... 11.6, step 0.1. Default: 11.6.

Trunk Condition This option menu can be used to determine whether the AP
or CU sets the signaling state toward the CO to the Idle
state, Busy  or the DS0 Remote alarm indication (Rai) code
during a fault condition. Default: Idle.

Overview

Overview
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5.4.7.15 Service Details, GSFN = T04

The T04 (4-wire transmission only) function is used in voice or data private lines. It
is applicable to the AUA41B channel unit which may be used in the
MDS2/MDS2B, interfacing with a switch, other transmission equipment, data
equipment, or cable.

Menu Description

5.4.7.16 Overview of Application Packs and
GSFNs

The following table provides an overview of the general service functions and the
compatible Applications Packs/channel units.

Service Details
(Parameters) Description

TRMT This slider can be used to define the transmit attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

-7 dB Transmit This option menu can be used to control a 7 dB pad in the
transmit path. When the Black  option is selected, the chan-
nel unit supports an input TLP range of -9.0 to 7.5 dB. When
the White option is selected, the channel unit supports an in-
put TLP range of -16.0 to 0.5 dB.

Possible values: Black , White . Default: Black.

-7 dB Receive
(DBR)

This option menu can be used to control a 7 dB pad in the
receive path. When the Black option is selected, the channel
unit supports an input TLP range of -16 to 0 dB. When the
White  option is selected, the channel unit supports an input
TLP range of -9.5 to 7 dB.

Possible values: Black , White . Default: Black.

RCV This slider can be used to define the receive attenuator pa-
rameter.

Possible values: 0 ... 16.5, step 0.1. Default: 16.5.

Sealing Current When a check mark is set, the channel unit applies a current
from tip to ring (or across the transmission lead simplex) of
the subscriber interface.

Possible values: Set, Not set . Default: Set.

GSFN Compatible AP/CU

DFLT LPA300, LPA350, LPA380

2LS LPA300, LPA350, LPA380

2GS LPA350, LPA380

2FX LPA350, LPA380

Overview

Overview
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2FXLS LPA350, LPA380

2RVO LPA350, LPA380

2NOS LPA350, LPA380

ISDN LPU116

COIN LPA350, (lines 1-16 only)

4DO (ROC)

DATA AUA200, AUA232

EBS SPQ429

AC, LR AUA45B, AUA75

NO1, NO2 MCU5205, MCU5405

BRI AUA293

TO SPQ442

DPT SPQ442

DX4[N,R] AUA41B

FX[O,P][1,2,3,5] SPQ444

FX[S,T][1,2,3,5] AUA41B

EM4[C,H] SPQ454

PLR[1,2] SPQ454

ETO4 AUA41B

FXO SPQ442

OCU[1,2,3] SPQ452

SW56 SPQ452

TD[O,S][A,B,C,D] SPQ444

TO4 AUA41B

GSFN Compatible AP/CU
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5.4.8 Edit VRT/VB Logical T0 (Subscriber)

There are several ways to start the edit procedure. The following figure shows the
possibilities for opening the corresponding windows.
Access via the Network Browser (All -> NE -> Shelf -> AP -> User Port (Logical
T0)) and cursor menu (Edit ) is also possible.

Figure 5-41 Edit Logical T0

The edit options are described in Chapter 5.4.7, page 5-90.

5.4.9 Delete VRT/VB Logical T0 (Sub-
scriber)

There are several ways to initiate the deletion of Logical T0s. The corresponding
button Delete Logical T0... exists in the CU, AP and Logical T0 List windows (this
button is disabled in CU and AP windows for R1.5).

Complete the following procedure to remove a Logical T0:

1. Select the Logical T0 in the corresponding list

2. Click on Delete Logical T0...  button. A Warning window pops up:

Logical T0 will be deleted, OK to proceed?

NOTE:
If the chosen Logical T0 has been configured as red lined (cf. Figure 5-40,
page 5-93) the following Warning message will pop up:

Redlined Logical T0 will be deleted, OK to proceed?

If you decide to continue, the AEM-NB will send a delete message to the
NE.

Logical T0 window

AP window

Edit Logical T0...

CU window

Edit Logical T0... Logical T0 List window

Edit Logical T0...

VRT/VB window

Edit Logical T0 List...

Procedure
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5.5 NE Software Upgrade

This function is subdivided into two parts: NE software download and program
copy.

5.5.1 NE Software Download

There are two software versions, the one in the active COMDAC and the new one
to be downloaded. It is assumed that the user has a copy of the software currently
running in the active COMDAC.

The software download procedure is as follows:

■ Start download

■ Load software into the standby COMDAC.

For the following description it is assumed that the NE is already connected and
the NE hardware platform is prepared to receive and work with the new program
version.

Complete the following procedure to start software download:

Step Procedure

1. Select All in the Network Browser.

2. Select Equipment -> NE SW Download via the Menu bar. The NE SW
Download window pops up:

Overview

Assumptions

Procedure
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Figure 5-42 "NE SW Download" Window

This window is subdivided into two fields: Target  and Download Information .

3. Select one or more NEs in the Target list.

4. Set the check box Standby Comdac Automatic Copy if you want to copy
automatically the software from the working COMDAC to the standby
COMDAC after the software download is completed successfully.

5. Select a desired file in the Download Information list. The corresponding
file will be displayed in the Filename  field.

6. Click on OK. A Warning window pops up (the Software Download window
remains on the screen after the download is finished):

SW Download is service affecting. Do you want to continue?

If you decide to continue the AEM-NB starts the download procedure. An
In Progress window pops up showing the following message:

SW Download to <NE Name> in progress.

NOTE:
The In Progress window is a dialog window with progress indicator and
cancel option that will be displayed any time there is a long duration task
being performed, such as SW Download. The following figure shows an ex-
ample:
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Figure 5-43 Example of an "In Progress" Window

The progress bar shows the operation status. A percentage display exists for SW
Download and NE Reset. The display continues to show 90% until the end of the
process. The Cancel  button will be disabled if either the SW Download or the
NVDS Restore commands are being executed (i.e. an FTP process is still run-
ning).

7. Wait until this process is finished.

After the download process has correctly finished the connection to the
NE breaks off. To re-establish the connection proceed with Step 6 .

The following errors will stop the download process:

■ NE does not match login and password. The AEM-NB returns oper-
ation failed to the AEM-NB.

■ NE detects that the side switch to the standby COMDAC is not pos-
sible (e.g. 2nd COMDAC not present, as the NE R1.5 does not sup-
port SW Download in simplex mode) and refuses the SW Download
operation.

■ If the download of the data fails an alarm is issued and manual inter-
vention will be required to:

— restart the download procedure from the beginning, or

— write from the active COMDAC to the standby COMDAC to
back out the partial load (duplex configuration) - see
Chapter 5.5.2, page 5-116.

■ If the software program is not installed successfully on the standby
COMDAC:

In duplex configuration, an alarm will be sent to the AEM-NB and
manual intervention will be required to:

— restart the download procedure from the beginning, or
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— write from the active COMDAC to the standby COMDAC to
remove the downloaded copy - see Chapter 5.5.2,
page 5-116.

5.5.2 Program Copy

This function is used to copy a new loaded software from the currently active
COMDAC to the standby COMDAC. During normal operation both COMDACS
should have the same software version. So the software copy should always be
the next step after software download.

For the following description it is assumed that the NE is configured in duplex con-
figuration.

Complete the following procedure to copy the new software from the active COM-
DAC to the standby COMDAC:

Step Procedure

1. Select All -> NE -> Shelf  in the Network Browser an Program Copy  via
cursor menu
or select Equipment -> Program Copy via the Menu bar. The Program
Copy window pops up:

Figure 5-44 "Program Copy" Window

This is a dialog window requesting information from the operator to con-
tinue. There are two panes (titled Working COMDAC and Standby COM-
DAC) showing the corresponding slot number and SW versions used in
each of the COMDACs.

Overview

Duplex Configura-
tion

Procedure
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— Slot

Identifies which COMDAC is where (e.g. Working COMDAC in slot 1
and Standby in slot 2).

— SW Version

Obtained from the NE. The SW version of the working COMDAC will
be taken as the NE SW version.

2. Press OK to start the software copy. An In Progress window pops up:

Program Copy from COMDAC 1 to COMDAC 2 in Progress

3. Wait until this process is finished.

5.6 Nonvolatile Data Storage
(NVDS)

This section describes the backup and restore procedures. The backup procedure
uploads the data from the NE’s COMDAC to the AEM-NB. The restore function
deals with the downloading of a previous backup NVDS from the AEM-NB to the
NE. Both functions apply to both simplex and duplex NE configurations.

For database backup and restoration the AEM-NB is able to create/maintain a
copy of provisioning data from the active COMDAC (NVDS). When a loss of data
occurs in the NE (due to factors such as human error, power failure or hardware
and software failures), the restoration features enable the AEM-NB to restore a
previous backup to one NE.

The AEM-NB is able to store the backup copy in diverse storage media that can
include Hard Disk Drive (HDD), tapes, removable disk cartridges and any other
available mass-storage medium.

For database backup and restoration operations the AEM-NB uses a File Transfer
Protocol (FTP) connection within the NE. FTP allows the AEM-NB to overwrite or
copy information residing on the NE.

The AEM-NB can open only one FTP session per NE at a time where the AEM-
NB will support the client role of the FTP session, and the AnyMedia Access Sys-
tem will play the server part.

Overview

Backup/restore
Data

Backup Media

FTP
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5.6.1 Data Backup

Complete the following procedure to initiate data backup:

Step Procedure

1. Select All -> NE  in the Network Browser

2. Select Equipment -> NE NVDS Backup via Menu bar. The NVDS
Backup window pops up:

Figure 5-45 "NVDS Backup" Window

The Filename  list displays all file names available for a backup.

3. Select the file in the list of which you wish to make a backup. The corre-
sponding file will be displayed in the Filename  field and can be edited.

4. Click on OK (this command button is available only after having selected
the file name). The status bar shows the progress of the operation.



Configuration Management/Provisioning

363-211-402 Issue 2 (09.99) 5-119

AEM-NB R1.5

Nonvolatile Data Storage (NVDS)

5.6.2 Data Restore

Complete the following procedure to initiate data Restoration:

Step Procedure

1. Select All -> NE  in the Network Browser

2. Select Equipment -> NE NVDS Restore via Menu bar. A Warning win-
dow pops up:

NE NVDS Restore may be service affecting. Do you want to
continue?

3. Press Yes to confirm this message. The NVDS Restore window pops up:

Figure 5-46 "NVDS Restore" Window

The Filename  list displays all backup file names.

4. Select a desired file in the list. The corresponding file will be displayed in
the Filename  field and can be edited.

5. Click on OK (this command button is available only after having selected
the file name). An In Progress window pops up:

NVDS restore on <NE Name> in progress

After the restoration is finished the following message is displayed:

NVDS restore on <NE Name> in completed
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5.7 NE Reset

This menu is used to reset the NE’s NVDS to the factory default except for the IP
address, so that the AEM-NB can still communicate with the NE after command
execution is complete.

Complete the following procedure to get the inventory data:

Step Procedure

1. Select All -> NE in the Network Browser.

2. Select Equipment -> NE Reset (INIT-SYS) via the Menu bar. A Warning
window pops up:

NE Reset is service affecting. The data stored in the
NE Name will be destroyed and set to the default
manufacturing values. Do you want to continue?

If you decide to continue, the AEM-NB will send an INIT-SYS to the NE to
reset the NVDS to its default values. An In Progress window pops up.

Reset <NE Name> in progress

NOTE:
After the reset process has correctly finished the connection to the NE
breaks off. To re-establish the connection proceed with Step 3 .

3. Select Equipment -> Provisioning -> Edit via the Menu bar. The NE
Name Information window pops up.

4. Press Connect  in the Connection  pane to establish the connection.

Procedure
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5.8 TL1 Cut-Through

The AEM-NB provides the operator with a command line to a TL1 (transaction
language 1) session with any NE. Using this command line, the user can type any
TL1 command, send these commands to a selected NE and get the responses to
the requests as well as all the autonomous outputs sent by the NE.

TL1 used for the provisioning, maintenance and administration of the AnyMedia
Access System is an ASCII-based command language.

This cut-through interface is used by remote AEM-NB craft personal when the
GUI does not support certain TL1 commands. The AEM-NB will provide the inde-
pendence between the cut-through interface and the GUI interface.

To open a cut-through interface with an NE the operator must provide the connec-
tion information (Login and Password) defined in the NE Name Information win-
dow (cf. Chapter 5.3.1, page 5-16).

When the AEM-NB receives the request to open a cut-through session, it opens
the TCP/IP connection with the selected NE using a new virtual connection, to
avoid conflicts with the current AEM-NB GUI session. Then the operator will man-
age the cut-through session through the use of TL1 commands.

The AEM-NB GUI behavior (but not necessarily the performance) is not affected
by any simultaneous cut-through connection running on the platform.

The operator using the AEM-NB GUI need not have to know about any cut-
through session running on the AEM-NB platform. The performance of the system
could be affected by the load of the hardware, but the behavior of the GUI is the
same in both cases.

Complete the following procedure to start a TL1 session:

1. Select All -> NE in Network Browser.

2. Select TL1 -> Cut-through  via the Menu bar to start a TL1 session. The
Cut through window pops up.

Overview

Cut-through / GUI
independence

Procedure

How to start a TL1
session
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Figure 5-47 "Cut Through" Window

3. Enter the Login  and Password  as defined in the NE Name Information
window (cf. Chapter 5.3.1, page 5-16).

Now you are able to enter the appropriate TL1 commands.

5.9 Fiber Reach

The AEM-NB provides an interface to a ITM-SNC (Integrated Transport Manage-
ment - Sub NetworkController) session with any DDM-2000 Fiber Reach compo-
nent on the transport network that interacts with the AnyMedia Access System.
Using this software package, the user can retrieve alarms and configuration re-
lated to the transport sub-network.

The Fiber Reach interface is used by remote login when the operator wants to lo-
cate a failure or defect that is shown on the access system that have been origi-
nated in the transport network. The GUI interface and the ITM-SNC are totally in-
dependent from each other because they are operating on different NEs.

To open a remote session with an ITM-SNC the operator must provide the con-
nection information (Login and Password) as for the login into an ITM-SNC ses-
sion (for more information, cf. ITM-SNC User Manual).

The AEM-NB GUI behavior (but not necessarily the performance) is not affected
by any simultaneous Fiber Reach connection running on the platform.

The operator using the AEM-NB GUI does not need to know about any Fiber
Reach sessions running on the AEM-NB platform. The performance of the system

Overview

FiberReach / GUI
independence
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could be affected by the load of the hardware, but the behavior of the GUI is the
same in both cases.

5.9.1 Start a Fiber Reach Session

Complete the following procedure to start a Fiber Reach session:

1. Type fr in a terminal window, which you can start via the workspace
manager (cf. Chapter 3.3.8, page 3-12) and press Return . The following
message is shown:

List of available hosts:
1.-mahp1
2.-mascusa14

a) Add Host     d) Del Host     q) Quit
Enter Selection:

2. Enter the host number where the ITM-SNC is installed from the list of
available hosts or enter a for include a new one (cf. Chapter 5.9.2,
page 5-123).

3. Enter the Login  and Password  defined on the ITM-SNC documentation.

Now you are able to use the ITM-SNC application.

5.9.2 Add a Host

Complete the following procedure to add a host for Fiber Reach:

1. Type fr in a terminal window, which you can start via the workspace
manager (cf. Chapter 3.3.8, page 3-12) and press Return . The following
message is shown:

List of available hosts:

a) Add Host     d) Del Host     q) Quit
Enter Selection:

2. Enter a that identifies the option Add Host and press Return . The next
message pops up:

Host to be added:

NOTE:
The host is reachable by Fiber Reach if the user name and the IP address
of the AEM-NB user is contained in the rlogin file.

3. Enter the name of the host where the ITM-SNC is installed.

4. Enter q and press Return to exit.
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5.9.3 Delete a Host

Complete the following procedure to delete a host for Fiber Reach:

1. Type fr in a terminal window, which you can start via the workspace
manager (cf. Chapter 3.3.8, page 3-12) and press Return . The following
message is shown:

List of available hosts:
1.-mahp1
2.-mascusa14

a) Add Host     d) Del Host     q) Quit
Enter Selection:

2. Enter d that identifies the option Del Host and press Return . The next
message pops up:

Host to be removed:

3. Enter the number that identifies the host on the list.

4. Select q and press Return to exit.
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6.1 Overview

This chapter provides you with informations about

■ Basics on the alarm management

■ Basics on alarms

■ Maintenance actions if certain alarms are pending

■ Using the Alarm Viewer

■ Performing test actions with the test management

■ Basics on information management (e.g. connection states).

6.2 Alarm Management

6.2.1 Overview

The main function of the alarm management is to manage the AnyMedia® Access
System Element Manager for Narrowband Services (AEM-NB) and Network Ele-
ment (NE) related alarms that are registered in the Element Manager System
(EMS). For the list of the NE alarms refer to Chapter 6.6.3, page 6-37. For the list
of the alarms generated by the management system refer to Chapter 6.6.4,
page 6-37.

Once the communication connection between the AEM-NB and an NE is estab-
lished, the AEM-NB clears the "not-connected" NE alarm indication (if they exist)
and starts an alarms and environment alarms synchronization process between
the AEM-NB alarm database and active NE alarms. Finally the AEM-NB will try to
update its view of NE configuration data and will start a synchronization process
between the AEM-NB data set and the NE configuration information (NE NVDS).
The NE database is always the master.
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The database does not maintain the alarm history, it only stores the current
alarms status. An alarm can be in one of the following three states:

■ Raised

■ Acknowledged

■ Cleared.

The main responsibilities of the Alarm Management Subsystem (AMS) are the fol-
lowing:

■ Maintain up-to-date alarm information.

■ Notify alarm changes to alarm clients.

■ Provide access to the current alarm data.

■ Manage alarms raising.

■ Manage cleared alarms.

■ Manage acknowledgment of alarms.

■ Synchronization of the alarm data per NE.

■ AEM-NB Alarm log handling.

■ Periodical deletion of cleared alarms.

6.2.2 Maintain Up-To-Date Alarm Information

During the alarm life time, the AEM-NB updates the following information:

■ The date and time of the last status change.

■ The last alarm status change.

■ The last user (id) which acknowledged an alarm.

■ The number of times the alarm has occurred between the first occurrence
and now.

If an acknowledged alarm is raised again the status for this alarm is changed from
acknowledged to raised. Additionally the acknowledge data (user Id), if available,
is removed from the alarm information.
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Figure 6-1 Life Cycle of an Alarm

6.2.3 Alarm Notification to the User

Any time incorrect data (out-of-range values, inappropriate value types, etc.) is
entered at the Graphical User Interface (GUI), a new alarm occurs or the status of
any alarm changes to raised again, an alarm message is reported to the AEM-NB.
The alarms are indicated, if defined, visually and acoustically.

The occurrence of a new alarm of a defined severity (default value: critical) is visu-
ally indicated in different ways:

■ Notification icon displayed in the AEM-NB access bar.

This icon consists of a flag and a counter. The flag is raised only the first
time a new alarm of the defined severity is reported to the AEM-NB. Addi-
tionally the counter is increased.

Every time the user clicks on the icon, the flag is lowered and the counter is
reset before the AEM-NB requires confirmation.

The alarm severity affecting the notification icon is configurable via the sys-
tem variables in the file $ANYMEDIAPATH/GUI/cfg/SystemPreferences.ini.

ACKNOWLEDGED

Acknowledge

Acknowledge

CLEARED

Clear

RaiseRaise

Clear

RAISED

Overview

Visual Alarm Indi-
cation
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For alarm notification see aslo Chapter 3.2.3.1.

■ Shelf View Window

This window (cf. Chapter 5.3.2.1.1, page 5-23) provides general inventory,
provisioning and alarm information (through the circuit packs LEDs). Each
slot shows the card type inserted and its alarms (via a red FLT LED, if avail-
able). If the slot is empty, no card will be shown.

See table below for the list of LEDs provided in each pack. The table de-
scribes the color used when the LED is ON or blinking. If the LED is OFF
the color black is used.

Table 6-1 Configure Notification Icon

System Variable Severity Possible States

VISUAL_CRITICAL_ALARM_SEV Critical On/Off, default = ON

VISUAL_MAJOR_ALARM_SEV Major On/Off, default = OFF

VISUAL_MINOR_ALARM_SEV Minor On/Off, default = OFF

VISUAL_INFO_ALARM_SEV Information On/Off, default = OFF

Table 6-2 LED Meanings

Circuit Pack LED Color Meanings

IO-DS1 FLT red ■ Lit during circuit pack failure

■ Flashes when the circuit pack executes off-
line self-test

ACT green Lit when the circuit pack is service-active.

CLF1 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 1

CLF2 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 2

CLF3 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 3

CLF4 yellow Lit when a fault or facility alarm occurs on the in
service received DS1 port 4
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COMDAC FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and
turnup

ACT green Indicates that this COMDAC is active.

CR red Lit when the highest severity alarm is critical

MJ red Lit when the highest severity alarm is major

MN yellow Lit when the highest severity alarm is minor

NE yellow Lit when the source of the fault or abnormal condi-
tion is near end

FE yellow Lit when the source of the fault or abnormal condi-
tion is far end

CTU FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes on turnup

ACT green Lit when a test is in progress

MISC yellow Lit when one of the eight miscellaneous alarm in-
puts is active

ACO green For future use

All Applica-
tion Packs

FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and turn-
up

AP (MDSU) FLT red Lit when a fault is detected on the circuit pack.

LNK yellow ■ Lit when loss of clock/sync signal is detected

■ Flashes when incorrect
MDSU/MDS2/MDS2B side association is de-
tected.

Table 6-2 LED Meanings

Circuit Pack LED Color Meanings
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Figure 6-2 Shelf View

■ MDS2/MDS2B Shelf View Window.

The user is warned by an audible indication if a new alarm of a defined severity
(default value: critical) is reported to the AEM-NB. Only alarms from NEs within
the user domain will be indicated.

Circuit Pack LED Color Meanings

CU FLT red ■ Lit when a fault is detected on the circuit pack

■ Flashes during software download and
turnup.

MSC FLT red Lit when a fault is detected on the circuit pack.

LNK yellow ■ Lit when loss of clock/sync signal is detected

■ Flashes when incorrect
MDSU/MDS2/MDS2B side association is de-
tected.

PTU FLT red Lit when a fault is detected on the circuit pack.

TST Lit when a channel served by the PTU is under
test.

Audible Indication
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The alarm severity which causes audible alarm notification is configurable via the
system variables in the file $ANYMEDIAPATH/GUI/cfg/SystemPreferences.ini.

For alarm notification see aslo Chapter 3.2.3.1.

By default, the AEM-NB causes an audible alarm indication every time a new crit-
ical alarm is reported to the AEM-NB.

For more information on the reported alarm open the Alarm Viewer (cf.
Chapter 6.3, page 6-10).

Acknowledging alarms is described in Chapter 6.3.5, page 6-21.

Clearing alarms is described in Chapter 6.3.5, page 6-21.

6.2.4 Provide Access to the Current Alarm
Data

The user can select lists of alarms filtered by several fields. Therefore the user
specifies a selection criterion (cf. Chapter 6.3.4.3, page 6-19) that is taken by the
AMS to make the appropriate filters. For instance, an user can request all the crit-
ical alarms of an NE, or all platform alarms, or all alarms which are service affect-
ing and are raised at the same time.

The number of alarms stored in the alarm database can be retrieved, too. The to-
tal number of alarms can be retrieved as well as the number of alarms per severity
(number of critical alarms, major, minor and information).

The user domain is the list of NEs and/or the AEM-NB the user can manage. The
user domains are applicable in the AMS to the alarm retrieval operations and to
the alarm notification.

Each user can only request alarms and the number of alarms that are in the user’s
domain. The client and server security filters fill in this information. When the
alarm retrieval operation arrives at the alarm server, in addition to the normal input
data it also contains the user domain information added by the user interface.

Table 6-3 Configure Audible Notification

System Variable Severity Possible States

AUDI_CRITICAL_ALARM_SEV Critical On/Off, default = ON

AUDI_MAJOR_ALARM_SEV Major On/Off, default = OFF

AUDI_MINOR_ALARM_SEV Minor On/Off, default = OFF

AUDI_INFO_ALARM_SEV Information On/Off, default = OFF

Alarm Information

Alarm
Acknowledgment

Alarm Clearance

Alarm Retrieval

User Domains
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6.2.5 Managing the Raising of Alarms

An alarm is raised by the NE or by any object of the AEM-NB. When an alarm is raised
its state and the relevant transmitted data (cf. Chapter 6.6.2, page 6-35) are updated.
Special care has to be taken if the alarm is raised repeatedly (see “Repetitive and Fluc-
tuating Alarms”). In this case the already existing alarm is put into the raised state. The
user acknowledge identification, if available, is removed from the alarm. This way a
raised condition of an existing alarm is considered as a new raising (not a new alarm).
The number of occurrences is increased every time the same alarm is raised.

A repetitive alarm is an alarm that is raised several times before it is cleared. A fluctuating
alarm is an alarm that is raised and cleared alternatively several times in a short period (at
least less than the AEM-NB constant for the cleared alarms, see Chapter 6.2.10, page 6-9).

To handle these alarms three fields are defined and maintained for each alarm:

■ First Raised Time

■ Last Changed Time

■ Number of Occurrences.

The alarm viewer can obtain the following information:

■ The "Number of Occurrences" is the number of times the alarm has been raised
between when it was first raised and the current time (only the raised alarms are
counted). In this period the alarm has been raised all the time or it may have
been raised/cleared several times (it is not relevant to distinguish both cases).

6.2.6 Manage Alarm Acknowledgment

Alarms can only be acknowledged by a user at the user interface. It is possible to ac-
knowledge all alarms types. If an alarm is acknowledged its state is updated accordingly
and the user identification and the last changed time are registered. Acknowledging an
alarm causes a change to the alarm database. Therefore the alarm was logged before
in the action log. It is possible to acknowledge an alarm that has already been acknowl-
edged. The user identification and the new acknowledge time are registered as well,
overwriting the previous acknowledge data.

6.2.7 Managing the Clearing of Alarms

The NE alarms are cleared by the NE-AMS. Platform alarms are cleared automat-
ically (e.g. NE-AEM-NB association alarms) or by a user at the user interface (e.g.
log alarms). Users can only clear specific platform alarms. Users cannot clear the
association alarms for the NE alarms. When an alarm is cleared its state is up-
dated and the time is registered, too. Clearing an alarm causes a change to the
alarm database. Therefore the alarm was logged before in the autonomous report
log (if the user clears an alarm this will be logged in the action log; if an alarm is
cleared by the NE it will be logged in the autonomous report log).

If the raise is newer, then it is a repetitive raise; the alarm state is set to the raised
state. If the raise is older, then this message is ignored; the alarm state stays in
the cleared state and the relevant data is updated.

General

Repetitive and
Fluctuating Alarms

General
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If network and platform alarms are cleared at their source the AEM-NB clears them
after a variable period of time in the AEM-NB database. This period of time is set by
default to 3 days and can be configured by the user via the system variable "AM.mini-
mumClearPeriod" in the file $ANYMEDIAPATH/cfg/AnyMediaNBEM.cfg.

6.2.8 Alarm Data Synchronization

The AMS is responsible for the performance of NE alarm synchronization. To ac-
complish this, the AMS requests all the current alarms (normal and environment)
of the NE that is being synchronized. Once the AMS has received these alarms it
compares them with the alarms stored in the AEM-NB alarm database. At the end
of the synchronization the alarms stored in the alarm database must be the same
as the alarms retrieved from the NE-AMS. Only one synchronization per NE can
be performed at the same time. The AMS rejects any synchronization request for
the same NE if the first one has still not finished.

6.2.9 AEM-NB Alarm Log Handling

If the user wants to know the different states throughout the alarm life the user will
have to see the Log System (cf. Chapter 3.7, page 3-32) in which all alarm
changes are stored.

Three types of logs are used. The AMS logs the following situations:

■ Actions log:

Periodical database deletion of cleared alarm’s start and end.

Alarm’s synchronization start and end.

Periodical deletion of cleared alarms.

Manual clear, manual acknowledge. The user identification that performs
these actions is also logged.

■ System-internal events log:

Exception conditions of the AMS.

■ Autonomous report log:

Raise, automatic clear, update of every alarm.

6.2.10 Periodical Deletion of Cleared Alarms

By default, alarms with cleared status are maintained for at least three days (including
the current day) in the database. This value and can be configured by the user via the
system variable "AM.minimumClearPeriod" in the file
$ANYMEDIAPATH/cfg/AnyMediaNBEM.cfg and is an integer multiple in days. The
default value is 3 days.

The AEM-NB performs a periodical deletion of the alarms with cleared status that
exceed the specified time. This is done during the night period in low-load hours.

Automatic alarm
clearance
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6.3 Alarm Monitoring

6.3.1 General

The AEM-NB provides a process to monitor and display all alarms stored in the
database. Using this system, the Alarm Viewer, the user is able to see many dif-
ferent alarm attributes such as Alarm Type, Severity, Status, Summary and the
date and time when the alarm was raised. Via this tool the user can perform ac-
tions (e.g. acknowledge, clear) for some of these alarms.

In this chapter you will find the following information:

■ Instructions for starting and terminating the alarm viewer
(Chapter 6.3.2, page 6-10)

■ Instructions for handling the alarm viewer (Chapter 6.3.3, page 6-11)

■ Structure of the alarm viewer window (Chapter 6.3.3.3, page 6-14 and
Chapter 6.3.3.4, page 6-15)

■ System management (Chapter 6.3.4, page 6-18)

■ Alarm viewer functions (Chapter 6.3.5, page 6-21).

6.3.2 Starting and Terminating the Alarm
Viewer

6.3.2.1 Starting the Alarm Viewer

The Alarm Viewer can be started in different ways:

■ Clicking on the icon Alarm Viewer  in the Access Bar (cf. Chapter 3.2.3,
page 3-4).

■ Clicking on Alarms in the menu bar of the other Element Manager applica-
tions (cf. Chapter 3.3.6, page 3-11). In this case only alarms of the NE
which is selected in the Network Browser are shown.

The displayed window has the title "Alarm Viewer" and maintains similarities with
the other AEM-NB’s windows.

The Alarm Viewer window consists of the sections:

■ Menu bar (File, Views, Filters, Actions, Help).

■ Toolbar (buttons for Acknowledge, Clear and Reload).

■ General Information section.

■ Alarm table.

Overview

What you will find
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Figure 6-3 Alarm Viewer Window

6.3.2.2 Terminating the Alarm Viewer

The Alarm Viewer can be terminated as follows:

■ By selecting File -> Exit  in the Alarm Viewer menu to close all Alarm
Viewers launched by the user.

■ By clicking on Close  button to close only the Alarm Viewer being in use.

Before quitting the Alarm Viewer the user is prompted for confirmation.

6.3.3 Performing Alarm Viewer Functions

The Alarm Viewer provides different possibilities to perform internal functions and
alarm management functions.

These functions can be initiated via:

■ Menu

■ Toolbar

In most cases the choice depends on the user’s personal preference.
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6.3.3.1 Menu Bar

The menu is used to activate alarm viewer functions.

NOTE:
The executable functions depend on your user privileges.

Figure 6-4 Menu Bar of the Alarm Viewer

Selection is achieved

■ By opening the menu by pressing the left mouse button and dragging the
cursor to the desired option in the menu or

■ By opening the menu via the keyboard by entering Alt plus the underlined
letter of the relevant menu to open the menu option and then entering the
letter underlined in the desired menu option.

Table 6-4 File Menu

Menu display Menu option Meaning Information in

New Launch a new instance of the Alarm Viewer. Chapter 6.3.4.1,
page 6-18

Reload Display a fresh copy of the current informa-
tion shown in the window. Only alarms which
match the filter criteria will be included.

Chapter 6.3.5,
page 6-21

Print Print all alarm items displayed in the cur-
rently displayed table or save the items into
an ASCII file.

Chapter 6.3.4.1,
page 6-18

Close Dismiss this window, but without closing
other instances of the Alarm Viewer.

Chapter 6.3.4.1,
page 6-18

Exit Close all Alarm Viewers opened by the user. Chapter 6.3.4.1,
page 6-18

Table 6-5 Views Menu

Menu display Menu option Meaning Information in

View1 Select a view from the predefined views. Chapter 6.3.4.2,
page 6-18View2

View3

View4

New
Reload
Print
Close
Exit

View1
View2
View3
View 4
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Table 6-6 Filters Menu

Menu display Menu option Meaning Information in

Alarms for the last 24 hours Selection of filter criteria for
displaying alarm information.

Chapter 6.3.4.3,
page 6-19Critical Raised Alarms

Raised Alarms

Alarms from a Host/s

Critical Alarms not cleared

Owned Acknowledge Alarms

Clear Alarms

All Acknowledge Alarms

None Filter / All Alarms

Table 6-7 Actions Menu

Menu display Menu option Meaning Information in

Acknowledge Acknowledge all selected alarms, their status
will change to acknowledged.

Chapter 6.3.5,
page 6-21

Clear Clear all selected alarms, their status will
change to cleared.

Chapter 6.3.5,
page 6-21

Table 6-8 Help Menu

Menu display Menu option Meaning Information in

Index Display the index help, allowing the user to
navigate through the AEM-NB help informa-
tion.

Chapter 6.3.4.4,
page 6-21

On window Display the help information of the window
where the user is currently working.

Alarms for the last 24 hours
Critical Raised Alarms
Raised Alarms
Alarms from a Host/s
Critical Alarms not cleared
Owned Acknowledge Alarms
Clear Alarms
All Acknowledge Alarms
None Filter / All Alarms

Acknowledge
Clear
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6.3.3.2 Toolbar

The toolbar contains often used functions and consists of four buttons:

6.3.3.3 General Information Section

The first section is a frame titled General Information, this frame includes controls
showing information about the number of alarms of each alarm severity (in the do-
main where the user is working):

■ Critical

Displays the number of critical (CR) alarms.

■ Major

Displays the number of major (MJ) alarms.

■ Minor

Displays the number of minor (MN) alarms.

■ Information

Displays the number of information (IN) alarms.

■ Total

Displays the total number of alarms (all severities).

Additionally the frame contains two option menus, which show the filter (cf.
Chapter 6.3.4.3, page 6-19) and view (cf. Chapter 6.3.4.2, page 6-18) currently
being used. In this two option menus the user can select filters and views.

Table 6-9 Toolbar

Function Icon Meaning

Acknowledge Acknowledge all selected alarms. Their status im-
mediately changes to acknowledged. The
User_Ack is set to the login of the user who has
acknowledged the alarm

Clear Clear all selected alarms. Their status immedi-
ately changes to cleared.

Reload Reload the actual alarms states into the table.
Only alarms which match the filter criteria are in-
cluded.

Print Open a window for printing out all alarm items
displayed in the currently displayed table (cf.
Chapter 3.5, page 3-21).



Fault Management and Maintenance

363-211-402 Issue 2 (09.99) 6-15

AEM-NB R1.5

Alarm Monitoring

Figure 6-5 Frame General Information

6.3.3.4 Alarm Table

The last section in the Alarm Viewer window is a table that contains zero or more
alarms belonging to a domain. This table allows the user to sort the alarms (cf.
Chapter 6.3.3.4.2, page 6-17) by clicking on a specific table header. The user also
can select them for acknowledgment or clearance. The mechanism to acknowl-
edge or clear is the same, the user has to select one or more alarms. After select-
ing the alarms click on Acknowledge  or Clear in the tool bar
or select Actions -> Acknowledge  or Actions -> Clear  via the menu bar.

Figure 6-6 Alarm List Section

6.3.3.4.1 Alarm Parameters

For each alarm the following alarm fields (depending on the selected view) can be
displayed:

■ Index

Sequence number for each different alarm reported to the AEM-NB (the
maximum sequence number is 100 000).

■ Alarm_Type

Unique identification of each alarm type.

■ Summary

Contains text briefly describing the alarm. The summary text is unique in
the Element Manager.

■ Severity

Contains the default severity of the alarm.
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— Critical (CR)

— Major (MJ)

— Minor (MN)

— Information (IN)

■ Service Affecting

Specifies whether the alarm is subscriber service affecting or not.

Possible values: Yes, No.

■ Description

Contains a full description of the alarm.

■ Host

Unique text label in the AEM-NB scope. For NE alarms, it is the "NE-Name"
that identifies the NE through all the AEM-NB applications the alarm be-
longs to. For platform alarms, it is the string "EM".

■ Object_Id

Object identifier referring to the alarm. Examples of objects are network el-
ements, "ASSOC", etc.

■ Status

Working status of the alarms.

— Raised

Alarm with alarm condition raised, and has not been yet processed.

— Acknowledged

The alarm is still active and being investigated.

— Cleared

Alarm condition has been cleared, or the user has requested the
clearing of this alarm.

■ Date&Time First Raise

Date and Time of the first Raised status in the life cycle of one alarm.

■ Date&Time Last Change

Date and Time of the last status change in the life cycle of one alarm.

■ Occurrences

Number of times the alarm has been raised between the first raised time
and the current time.

■ User Ack

The last user which has acknowledged an alarm.
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6.3.3.4.2 Sorting Alarms

The user can sort alarms by the different fields by clicking on the respective
header. The sort can be ascending or descending order. The sort order is re-
versed by clicking on the respective header.

All alarm fields are sorted by alphanumeric order except dates, severity and status
fields.

■ In the severity field, alarms are sorted in the logical order: Critical, Major,
Minor and Information.

■ In the status field, alarms are sorted in the logical order: Raised, Acknowl-
edge and Clear.

The alarms are re-arranged according to the selected criteria.

Proceed as follows to sort the alarm display:

Step Procedure

1. Click on the header according to which the alarms are to be sorted.

Response: The alarms are sorted according to the selected alarm
field in ascending or descending order.

2. Check if the list was sorted as desired.

Yes: O.K.

No: Continue with step 3.

3. Click again on the header to sort the list in the reverse order.

The sort can be in ascending or descending order, each time the user
clicks on the same header again the list is sorted the other way.

Summary

Effects

Sorting Alarms
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6.3.4 System Management Functions

The general system management functions comprise the functions for file man-
agement, for defining view options and for getting help. These functions are con-
tained in the following menus:

■ File

■ Views

■ Filters

■ Help.

6.3.4.1 File

In the file menu you can start the following actions:

■ New

Launch a new instance of the Alarm Viewer.

■ Reload

Display a fresh copy of the current information shown in the window.

■ Print

(cf. Chapter 3.5, page 3-21)

■ Close

Close the active window, but without closing other instances of the Alarm
Viewer. Same functionality as the Close button.

■ Exit

Close all Alarm Viewers opened by the user.

6.3.4.2 Views

For displaying alarm lists you can select from four pre-defined views.

■ View1:
Index, Alarm Type, Host, Object Id, Severity, Status,
Date&Time Last Change

■ View2:
Index, Alarm Type, Host, Object Id, Status, Date&Time First_Raise,
Date&Time Last_Change, User Ack, Occurrences

■ View3:
Index, Summary, Host, Object ID, Severity, Status,
Date&Time Last_Change

■ View4:
All alarm fields.

The alarms are rearranged according to the selected criteria.

Summary

Effects
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Proceed as follows to select the desired view option:

Step Procedure

1. Select Views -> ViewX (X = 1 to 4) in the menu bar.

The same view options can be selected

— via the option menu Views  in the General Information section (cf.
Chapter 6.3.3.3, page 6-14)

Response: The alarms are displayed according to the selected view.

6.3.4.3 Filters

For displaying the alarm lists you can select pre-defined filters. Only those alarms
corresponding to the pre-defined criteria are displayed. The alarm set is displayed
without modifying the current view.

The filters are:

■ Alarms for the last 24 hours (all alarms which have been changed in the
last 24 hours)

■ Critical Raised Alarms

■ Raised Alarms

■ Alarms from a Host/s

■ Critical Alarms not cleared

■ Owned Acknowledge Alarms

■ Clear Alarms

■ All Acknowledge Alarms

■ None Filter / All Alarms.

The alarms are rearranged according to the selected filter criteria.

Selecting Views

Summary

Effects
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Proceed as follows to select the desired filter option:

Step Procedure

1. Select the desired filter options:

The same filter option can be selected

— via the option menu Filters  in the general information section (cf.
Chapter 6.3.3.3, page 6-14)

2. Select the NE or the AEM-NB for which the alarms are to be displayed.

A window (Figure 6-7, page 6-21) is displayed for selecting one or more
NEs and/or the AEM-NB.

3. Either click on OK or Cancel .

If you want to view ... then select Filters -> ... Result/Notes

all alarms which have
been changed in the
last 24 hours

Alarms for the last 24 hours The alarms are dis-
played according to the
selected filter.

all critical raised
alarms

Critical Raised Alarms The alarms are dis-
played according to the
selected filter.

all raised alarms Raised Alarms The alarms are dis-
played according to the
selected filter.

all alarms from a host Alarms from a Host/s Continue with step 2.

all not cleared critical
alarms

Critical Alarms not cleared The alarms are dis-
played according to the
selected filter.

all owned acknowl-
edge alarms

Owned Acknowledge Alarms The alarms are dis-
played according to the
selected filter.

all cleared alarms Clear Alarms The alarms are dis-
played according to the
selected filter.

all acknowledge
alarms

All Acknowledge Alarms The alarms are dis-
played according to the
selected filter.

all alarms. None Filter / All Alarms The alarms are dis-
played according to the
selected filter.

Selecting Filter
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OK Updates the Alarm Viewer showing only the
alarm information of the pre-selected NE, NEs
or AEM-NB.

Cancel Closes this window and cancels the operation.

Figure 6-7 NE Selection Window

6.3.4.4 Help

Help is provided for every window. The help text describes the purpose of the win-
dow, how to use it and a description of each field of the window is given.

In the Menu Bar of each AEM-NB application there are two help options:

■ Index:
Displays the help index, allowing the user to navigate through the AEM-NB
help information.

■ On window:
Displays the help information of the window where the user is currently
working.

6.3.5 Alarm Viewer Functions

The Alarm Viewer provides the user with different functions for managing alarm
information:

■ Reload alarms

■ Acknowledge alarms

The user can acknowledge one, more or all reported alarms. The AEM-NB
allows different users to acknowledge the same alarm. The name of the
last user who has acknowledged the alarm is stored.

Summary
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■ Clear alarms

The user can clear one, more or all platform alarms. If not all selected
alarms could be cleared, you are informed about the alarms for which this
action failed.

■ Print alarm lists (cf. Chapter 6.3.4.1, page 6-18).

Before performing alarm acknowledgment and alarm clearance select the alarms
you want to acknowledge or clear.

Select the desired alarm viewer action:

If you want to ... then select ... Result/Notes

retrieve alarms Actions -> Reload Reloads alarms in the table. Only alarms which
match the filter criteria are included.

Same functionality as Reload  in the tool bar.

To customize the displayed alarm list perform the ac-
tions described in Chapter 6.3.4.3, page 6-19 and
Chapter 6.3.4.2, page 6-18.

acknowledge alarms Actions -> Acknowledge All selected alarm items are acknowledged. Their sta-
tus immediately changes to acknowledge.

Same functionality as Acknowledge  in the tool bar.

For better readability the displayed alarms can be
sorted (cf. Chapter 6.3.3.4.2, page 6-17).

clear alarms Actions -> Clear All selected alarm items are cleared. Their status im-
mediately changes to cleared.

Same functionality as Clear  in the tool bar.

For better readability the displayed alarms can be
sorted (cf. Chapter 6.3.3.4.2, page 6-17).

Prerequisites

Starting Actions
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6.4 Test Management

The test management provides all the general purpose test functionality. The
main functions are:

■ Providing the user with different test options (see below),

■ Starting the test execution by means of the AEM-NB,

■ Displaying the test results on the AEM-NB user interface, and

■ Setting and clearing of loopbacks.

The following test options are available:

■ Port test (cf. Chapter 6.4.1, page 6-24)

■ Application Pack (AP) card test (cf. Chapter 6.4.2, page 6-26)

■ Standby card test scheduling (cf. Chapter 6.4.3, page 6-28)

■ Built-in self-test (cf. Chapter 6.4.4, page 6-29)

■ Loopback test at the feeder side (cf. Chapter 6.4.5, page 6-29).

The test routines are available via the "Configuration Manager" application. To
start it, click Config. Manager in the Access Bar. The Configuration Manager win-
dow and the Network Browser pop up (cf. Figure 6-8).

Figure 6-8 Window "Configuration Manager"

Main Functions

Test Options

Access to the
Testroutines
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6.4.1 Port Test

By means of a port test you are able to run a series of self-diagnostic routines for
a particular port on a specified AP.

Proceed as follows to start a port test and view the test result:

Step Procedure

1. Start the port test.

You have the following options to do this:

a. Via the Network Browser and the Main Menu:

— Select the port you intend the test to run for in the Network
Browser (All -> NE -> Shelf -> AP -> User Port ).

— Start the test by selecting Test Manager -> Physical Port
Test  from the menu bar.

b. Via the Network Browser and the Cursor Menu:

— Select the port you intend the test to run for in the Network
Browser (All -> NE -> Shelf -> AP -> User Port ).

— Start the test by selecting Physical Port Test from the cursor
menu.

c. Via the TL1 Command Line Interface:

Enter the following TL1 command by using the TL1 command line
interface (cf. Chapter 5.8, page 5-121):

Please refer to the AMAS R1.2 network elements documentation for
a detailed description of TL1 commands (including an explanation of
the input format, restrictions, error conditions etc.).

Comment: "Port Test execution in progress on NE Name, Slot, Card
Type, Physical Port id " is displayed during the test execu-
tion.

2. Wait until the Port Test Result window (cf. Figure 6-9, page 6-25) appears
and view the test result.

Purpose

Procedure

TST-ANALG:[tid]:AID:[ctag]

Command code
Staging parameter

blocks
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The Port Test Result window shows the test results of a series of self-diagnostic
routines on a specific port circuit.

Figure 6-9 The "Port Test Result" Window

The text fields are display-only, they have the following meaning:

Click Close  to dismiss the “Port Test Result” window.

Table 6-10 Meaning of the Text Fields in the "Port Test Result" Window

Text Fields Meaning Possible Values

NE Name The unique identifier of the
selected NE as specified at NE
creation time.

Any string consisting of up to
30 characters

Slot The slot number of the AP be-
ing used.

AP-1 ... AP-16

Card Type Mnemonic used to identify the
general type of function pro-
vided (AP card type).

PROG2W, PRCOIN and
POTS32

Physical
Port id

The port within the AP. Port 1 ... Port 32

Result The result of the test routines. PASS or FAIL

Test Result
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6.4.2 AP Card Test

By means of an AP card test you are able to start a series of self-diagnostic rou-
tines for all port circuits on a specified AP plus its common circuitry.

Proceed as follows to start an AP card test and view the test result:

Step Procedure

1. Start the AP card test.

You have the following options to do this:

a. Via the Network Browser and the Main Menu:

— Select the AP you intend the test to run for in the Network
Browser (All -> NE -> Shelf -> AP ).

— Start the test by selecting Test Manager -> AP Test from the
menu bar.

b. Via the Network Browser and the Cursor Menu:

— Select the AP you intend the test to run for in the Network
Browser (All -> NE -> Shelf -> AP ).

— Start the test by selecting AP Test  from the cursor menu.

c. Via the TL1 Command Line Interface:

Enter the following TL1 command by using the TL1 command line
interface (cf. Chapter 5.8, page 5-121):

Please refer to the AMAS R1.2 network elements documentation for
a detailed description of TL1 commands (including an explanation of
the input format, restrictions, error conditions etc.).

Comment: "AP Card Test execution in progress on NE Name, Slot,
Card Type" is displayed during the test execution.

2. Wait until the AP Card Test Result window (cf. Figure 6-10, page 6-27)
appears and view the test result.

Purpose

Procedure

TST-ANALG:[tid]:AID:[ctag]

Command code
Staging parameter

blocks

Note:
Use the value "all" for the Access
Identifier (AID).
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The AP Card Test Result window shows the test results of a series of self-diag-
nostic routines for all port circuits on a specified AP plus its common circuitry.

Figure 6-10 The "AP Card Test Result" Window

The text fields are display-only, they have the following meaning:

Click Close  to dismiss the AP Card Test Result window.

Table 6-11 Meaning of the Text Fields in the "AP Card Test Result" Window

Text Fields Meaning Possible Values

NE Name The unique identifier of the
selected network element as
specified at NE creation time.

Any string consisting of up to
30 characters

Slot The slot number of the AP be-
ing used.

AP-1 ... AP-16

Card Type Mnemonic used to identify the
general type of function pro-
vided (AP card type).

PROG2W, PRCOIN and
POTS32

Result List:
Physical
Port id

The port within the AP. Port 1 ... Port 32

Result List:
Result

The result of the test routines. PASS or FAIL

Test Result
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6.4.3 Standby Card Test Scheduling

During the execution of a standby card test scheduling a COMDAC side switch
and off-line diagnostics for the standby COMDAC or off-line diagnostics for the
protection feeder IO-DS1 pack are performed.

The AEM-NB provides the opportunity to the user to set-up the periodicity and the
time of the day (cf. Table 6-12, page 6-28) to perform a standby card test over:

■ the standby COMDAC pack or

■ the protection IO-DS1 pack.

To schedule a standby card test enter the following TL1 command by using the
TL1 command line interface (cf. Chapter 5.8, page 5-121):

NOTE:
It is not possible to start the standby card test via the Network Browser
(is planned for the future)!

The parameters in the common block have the following meaning:

Please refer to the AMAS R1.2 network elements documentation for a detailed
description of TL1 commands (including an explanation of the input format, re-
strictions, error conditions etc.).

Depending on the standby card test result the following behaviour can be ob-
served:

■ If the test is successful the side switch will be performed.

■ If the test fails then no side switch will be performed. Additionally an alarm
will be raised in this case.

Table 6-12 Common Block Parameters for SCHED-EX

Parameter Meaning Format Possible Values

INVL
(Interval)

Periodicity: The number
of days between two
standby card tests.

x-DAY x=0 ... 365
(0 means that the test
schedule execution is reset).

STM
(Start Time)

The time of the day
when standby card tests
shall be performed.

hh-mm hh=0 ... 23 (hour-of-day)
mm=0 ... 59 (minute-of-hour).

Side Switch and
Off-line
Diagnostics

Possible User
Settings

Procedure

SCHED-EX:[tid]:AID:[ctag]::INVL,STM

Command code
Staging parameter

blocks Common block

Parameters in the
Common Block

Result
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6.4.4 Built-in Self-Test

Each NE performs a built-in self-test of plug-in circuit packs periodically.

NOTE:
The built-in self-test is not requested from the AEM-NB, it will be always
started from the NE!

If a failure occurs, the NE will raise an alarm (REPT-ALM) which contains the AID
of the failed pack plug-in. The alarm is then visible in the “Alarm Viewer” of the
AEM-NB. For more information about possible alarms see Chapter 6.6.4,
page 6-37 (describes AEM-NB alarms) or refer to the AMAS R1.2 network ele-
ments documentation (describes NE alarms).

6.4.5 Loopback Test at the Feeder Side

It is possible to set or clear a loopback on particular feeders. Proceed as follows to
set/clear DS1 loopbacks:

Step Procedure

You have the following options to set/clear a loopback:

a. Via the Network Browser and the Menu Bar:

1. Select the DS1 you intend to set/clear a loopback in the Network
Browser (All -> NE -> Shelf -> IO-DS1 -> Physical DS1 ).

2. Select Equipment -> Loopback  from the menu bar
or
Loopback from the cursor menu.

The Physical DS1-Logical DS1 window pops up. Check that the dis-
plays in the NE Name and DS1 fields are correct.

3. Click Physical DS1 Data .
The Loopback  field displays the current loopback state (Clear  or
Set).

4. Click Label to change the loopback state.

Depending on the loopback state reflected, this command button
displays the possible operation (Clear, if the loopback is set; Set, if
the loopback is cleared).

Test Request

Procedure

Procedure
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b. Via the TL1 Command Line Interface:

To set a loopback enter the following TL1 command by using the
TL1 command line interface (cf. Chapter 5.8, page 5-121):

To clear a loopback enter the following TL1 command by using the
TL1 command line interface (cf. Chapter 5.8, page 5-121):

Please refer to the AMAS R1.2 network elements documentation for
a detailed description of TL1 commands (including an explanation of
the input format, restrictions, error conditions etc.).

OPR-LPBK:[tid]:AID:[ctag]

Command code
Staging parameter

blocks

RLS-LPBK:[tid]:AID:[ctag]

Command code
Staging parameter

blocks
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6.5 Information Management and
Maintenance

6.5.1 NE-AEM-NB Connection States

There are five NE-AEM-NB connection states. They depend on the availability of a
TCP/IP connection and TL1 communication session between the AEM-NB and
NE and also on the AEM-NB’s attempt to open a TL1 communication session with
the NE:

■ NOT_CONNECTED

Initial NE state when there is no connection between AEM-NB and NE and
the AEM-NB is in a "passive" state avoiding any possibility of connection
establishment with the NE.

■ NOT_CONNECTED (TRYING)

Initial NE connection establishment state when the TL1 communication
session between the AEM-NB and NE is not available (AEM-NB login to
NE via ACT-USER command) but the AEM-NB is in an "active" state trying
to open a connection (TCP/IP connection and TL1 communication session)
with the NE.

■ NOT_CONNECTED (CANCELLING)

The communication session between the AEM-NB and NE is available but
the AEM-NB is trying to close connection (TCP/IP connection and commu-
nication session) with NE. The user is unavailable to execute any action.

■ CONNECTED (SYNCHRONIZING)

The communication session between the AEM-NB and NE is available but
the AEM-NB is trying to synchronize AEM-NB and NE information. The
user is unavailable to execute any action until the synchronizing process is
finished. After that the state changes to CONNECTED.

■ CONNECTED

TL1 communication session between the AEM-NB and NE is available
(TCP/IP connection is alive) and the software version currently stored in
the NE is supported by the AEM-NB. When the association process be-
tween the AEM-NB and NE is completed, the NE state changes to CON-
NECTED and remains like this until the TL1 communication session is
closed on user request or the TCP/IP connection is lost/closed.

6.5.2 Changing Connection States

The connection state changes can be initiated by the user via the GUI (cf.
Chapter 5.3.1, page 5-16, section „Connect NE“) or they are initiated by the AEM-
NB.

Connection States
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The user can initiate the connection establishment process with an NE in connec-
tion state NOT_CONNECTED. After initiating this process the NE state changes
to NOT_CONNECTED (TRYING).

When the NE state is NOT_CONNECTED (TRYING), the AEM-NB tries to estab-
lish a TCP/IP connection with the NE. The AEM-NB attempts to connect to one of
the TCP ports of the NE. After the successful connection to a TCP port, the AEM-
NB checks if it supports the software version of the NE. If the software version is
supported the NE state becomes CONNECTED (SYNCHRONIZING), if not it re-
mains NOT_CONNECTED (TRYING) and the AEM-NB continues its attempts to
establish a connection. The user can cancel these attempts via the GUI, which will
change the NE state to NOT_CONNECTED (CANCELLING).

The user can request to close a connection with an NE via the GUI. When the TL1
communication session is closed by the AEM-NB, the NE state is changed to
NOT_CONNECTED. When the NE state is CONNECTED and the TCP/IP con-
nection is lost or closed, the NE state becomes NOT_CONNECTED (TRYING).
When a TL1 communication session loss is detected and the TCP/IP connection
is still established, the AEM-NB closes the TCP/IP connection and the NE state
also becomes NOT_CONNECTED (TRYING).

6.5.3 Configuration Data Synchronization
after Association

If an NE is connected to the AEM-NB the databases of NE and AEM-NB have to
be synchronized. To change synchronization settings see Chapter 5.3.2.2,
page 5-46.

There are various types of autonomous reports that are used to keep consistency
between configuration changes in the NE and AEM-NB database (e.g. LED status
reports, switch reports). For an NE the user can disable the sending of autono-
mous reports (reports can be inhibited/enabled separately or collectively). But to
maintain consistency between the NE configuration data and the AEM-NB data-
base, these configuration reports have to be enabled.

The following figure illustrates the NE state model depending on the synchroniza-
tion state between the data kept in the NE and the AEM-NB database.

Not Connected

Not Connected
(Trying)

Connected

General

Autonomous Re-
ports

Synchronization
States Diagram
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Figure 6-11 NE Configuration Data Synchronization States

There are the following two NE configuration data synchronization states:

■ SYNC

The AEM-NB database is consistent with the locally stored NE information,
and all the autonomous messages concerning configuration changes are
enabled (configuration reports: database changes, LED status reports,
switch reports and some events of the type protection switching and inhibit
messages).

■ ASYNC

The AEM-NB database and the NE configuration data are out of synchroni-
zation and/or configuration reports are inhibited and/or the AEM-NB config-
uration messages buffer is overflown.

6.5.4 Alarm Data Synchronization after As-
sociation

The AEM-NB maintains alarm data for each NE. These data are updated with all
NE alarms and environment alarms from the NEs database. To change synchroni-
zation settings see Chapter 5.3.2.2, page 5-46.

The following figure illustrates the NE state model depending on the synchroniza-
tion state between the alarm data kept in the NE and the AEM-NB alarm data-
base.

ASYNC

Out-of-sync Detection

Sync. Process Success &

Sync. Process Fail

Conf. Reports Inhibition Detection
Message Buffer Overflow Detection Sync. Process Success &

Conf. Reports Enabled

Conf. Reports Disabled

SYNC

Sync. Process Fail

Sync. Process Success &
Conf. Reports Enabled

SYNC/ASYNC

Alarm Data

Synchronization
States Diagram
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Figure 6-12 NE Alarm Data Synchronization States

There are two NE alarm synchronization states:

■ SYNC

The AEM-NB alarm database is consistent with the current NE alarms. If
alarm and/or environment alarm reports are inhibited, the AEM-NB data-
base is only a snapshot of NE alarm information at a certain moment in
time.

■ ASYNC

The AEM-NB alarm database and the current NE alarms are out of syn-
chronization due to an alarm buffer overflow. The AEM-NB alarm database
is only a snapshot of NE alarm information at a certain moment in time.

The AEM-NB configuration data which are maintained for each NE are updated
with the NEs configuration data. The data from the NE non-volatile data storage
(NVDS) are used.

6.5.5 Association Maintenance

An association between the AEM-NB and an NE is established if the TCP/IP con-
nection and the TL1 communication session are opened. The NE state changes
into CONNECTED.

The AEM-NB monitors the association state of the NE by periodically sending
messages (RTRV-HDR) to the NE. If the AEM-NB does not receive a response to
a certain number of messages within a certain time, it assumes that the TL1 con-
nection to the NE is lost and closes the TCP/IP connection to the NE.

By default these messages are sent by the AEM-NB every five minutes. The re-
sponse to a message must be received within four minutes and not more than two
responses may be lost, otherwise the TCP/IP connection is closed by the AEM-
NB.

These values can be configured by the user via the system variables "NEM.asso-
ciation.heartBeatNumber" and "NEM.association.heartBeatTime" in the file
$ANYMEDIAPATH/cfg/AnyMediaNBEM.cfg.

SYNC ASYNC

Alarm Sync. Process

Alarm Buffer Overflow Detection

SYNC/ASYNC

Configuration Data

Association

NE Monitoring

Default Values for
Monitoring
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6.6 Alarms

6.6.1 Overview

An alarm is reported for any condition that needs user attention, since it may im-
pact the normal operations of any system under user responsibility (e.g. AEM-NB,
NE).

6.6.2 Alarm Types

Detected alarms are classified as one of the following:

■ Platform Alarm

Alarm related to the AnyMedia™ Element Manager application or its hard-
ware/software platform. Generated (raised) by any object of the AEM-NB
when it detects an abnormal condition to be reported to the user.

Information provided:

— AEM-NB Object Identifier

— Alarm Type Identifier

— Severity

— Service Affecting

— Occurrence Time.

■ NE-AM Alarms

Generated (raised) by the NE-AM. Refer to Chapter 6.2.5, page 6-8 to see
how the information comes from the NE-AM to the AEM-NB The NE-AM
alarms are classified in two groups:

— Normal Alarms

Data provided:
Access Identifier, Condition Type, Notification Code, Service Affect-
ing, Access Identifier Type, Occurrence Date, Occurrence Time

— Environment Alarms

Data provided:
Access Identifier, Alarm Type, Notification Code, Occurrence Date,
Occurrence Time

For all alarm types several alarm data fields are conceptually the same (although
they convey different values). For instance, both Condition Type and Alarm Type
refer to the type of alarm being raised/cleared (Battery on discharge, Loss of
frame, ...).

Alarm Classifica-
tion
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The following table maps all the equivalent fields to general names that uniquely
identify a concept independently of the alarm type.

For each alarm one of the following alarm severities is defined:

■ Critical (CR)

■ Major (MJ)

■ Minor (MN)

■ Information (IN), only applicable for platform alarms.

The multiple key that uniquely identifies an alarm is:

■ Host Identifier

Identifies where the alarm comes from. If it comes from an NE, then this
identifier is the NE name. If the alarm is reported by the AEM-NB the host
identifier is "EM". For association alarms the host identifier is "NE_name".

■ System Object Identifier

Identifies the alarm-affected object within the host, which is identified by
the host identifier. For association alarms the system object identifier is
"ASSOC".

■ General Alarm Identifier.

Unique identifier within each type of alarm.

In order to ease possible communication between different users, an index num-
ber is provided as a temporal alarm identification. It is temporal because the index
number will be used as a circular sequence (the maximum sequence number is
100 000). It is provided only for user convenience. It will not be used to identify an
alarm within the AMS. For this purpose the multiple key defined above has to be
used.

Table 6-13 General Alarm Fields

General Name Platform Alarm NE Alarm NE Environment Alarm

Object_Id. EM Object Identifier Access Identifier Access Identifier

Alarm_Type Alarm Type Identifier Condition Type Alarm Type

Severity Severity Notification Code Notification Code

Serv_Affec. Service Affecting Service Effect -

Date_First_Time/
Date_Last_Timea

a Time and date (YYYY-MM-DD HH-MM-SS)

Occurrence Time
and Datea

Occurrence Timeb

b Only time (HH-MM-SS)

Occurrence Timeb

Occurrence Datec

c Only date (MM-DD)

Occurrence Datec

Alarm Severities

Alarm Identifica-
tion
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6.6.3 Network Element Alarms

Please refer to the AMAS R1.2 network element documentation for detailed alarm
descriptions of network element alarms.

6.6.4 Element Manager Platform Alarms

This chapter provides alarm descriptions of the AEM-NB platform alarms includ-
ing proposals for corrective maintenance actions.

In the following the AEM-NB platform alarms are listed alphabetically.

6.6.4.1 LOG_DEL_FULL

All old logs have been deleted. Because more available space was necessary the
log type of the current day has been deleted, too. The Object_Id shows which log
type has been deleted.

Abbreviation: LOG_DEL_FULL

Severity: Major

Service affecting: No

There are no old logs available, and not all logs of the current day are available to
be viewed or stored.

There may be a problem or abnormal situation in the AEM-NB, or the selection of
the configurable size limits of the log system was too small.

Proceed as follows to clear the alarm:

Step Procedure

1. Check the AEM-NB for problems or abnormal situations.

Have there any problems or abnormal situations occurred?

Yes: Try to resolve these problems or abnormal situations.
If this is not possible, continue with step 2.

No: Continue with step 2.

2. Check the size limits of the log system.

Are the size limits set correctly (cf. Chapter 3.7.2, page 3-32)?

Yes: Call Lucent Technologies Technical Support.

No: Set the size limits correctly, i.e. increase the size limits.

Alarm Descriptions

Alphabetical Order

Meaning

Effects

Possible Cause(s)

Corrective Actions
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6.6.4.2 LOG_DEL_PART

A log type not yet archived has been deleted due to lack of available space.

Abbreviation: LOG_DEL_PART

Severity: Minor

Service affecting: No

The respective log type can neither be viewed nor archived.

There may be a problem or an abnormal situation in the AEM-NB, or the config-
urable size limits of the log system have not been chosen correctly.

Proceed as follows to clear the alarm:

Step Procedure

1. Archive the remaining logs to prevent them from being deleted.

2. Check the AEM-NB for problems or abnormal situations.

Have there any problems or abnormal situations occurred?

Yes: Try to resolve these problems or abnormal situations.
If this is not possible, continue with step 3.

No: Continue with step 3.

3. Check the size limits of the log system.

Are the size limits set correctly (cf. Chapter 3.7.2, page 3-32)?

Yes: Call Lucent Technologies Technical Support.

No: Set the size limits correctly, i.e. increase the size limits.

6.6.4.3 NEASSOC_LOST

The AEM-NB lost the management association with the network element (NE).

Abbreviation: NEASSOC_LOST

Severity: Critical

Service affecting: No

The alarm will be cleared when the TCP/IP connection and TL1 communication
session are available, and the software version currently stored in the NE is sup-
ported by the AEM-NB, i.e. when the association process between the AEM-NB
and the NE is completed (NE state is CONNECTED, cf. Chapter 6.5.1,
page 6-31).

Meaning

Effects

Possible Cause(s)

Corrective Actions

Meaning
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It is not possible to manage the NE. The TL1 communication session and the
TCP/IP connection are lost.

A loss of the TCP/IP connection has been detected, or the TCP/IP connection has
been closed as a consequence of a loss of the TL1 communication session.

Proceed as follows to clear the alarm:

Step Procedure

1. Check the NE state after a waiting period of 1 minute.

Comment: When NE state is CONNECTED and the TCP/IP connec-
tion is lost or closed, the NE state is moved to TRYING
and the loop process to re-establish the connection with
the NE is started by the AEM-NB.

Is the state CONNECTED?

Yes: O.K.

No: Continue with step 2.

2. Check for Data Communication Network (DCN) being in service

Is the DCN in service?

Yes: Call Lucent Technologies Technical Support.

No: Put the DCN into service.

6.6.4.4 PASS_VIOLATION

Pass-through security violation. More than three consecutive log-in attempts on
the pass-through interface have been encountered.

Abbreviation: PASS_VIOLATION

Severity: Information

Service affecting: No

None.

An external Operations System (OS) is trying to open a pass-through link without
being authorized.

Proceed as follows to clear the alarm:

Step Procedure

1. Ask your system administrator for more details on access control.

Effects

Possible Cause(s)

Corrective Actions

Meaning

Effects

Possible Cause(s)

Corrective Actions
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6.6.4.5 SWVR_ILLEGAL

The Software Version currently stored in the NE is not supported by the AEM-NB.

Abbreviation: SWVR_ILLEGAL

Severity: Critical

Service affecting: No

It is not possible to manage the NE.

The Software Version currently stored in the NE is not supported by the AEM-NB.

Proceed as follows to clear the alarm:

Step Procedure

1. Check that the correct version of software is installed on the NE’s System
Controller Card (COMDAC).

6.6.4.6 TCP/IP_CON_REFUSED

The TCP/IP connection establishment could not be completed successfully for
port numbers 11001, 11003, 11005 and 11007.

Abbreviation: TCP/IP_CON_REFUSED

Severity: Critical

Service affecting: No

It is not possible to manage the NE.

Some TCP/IP protocol errors stopped the connection establishment process be-
tween AEM-NB and NE.

Proceed as follows to clear the alarm:

Step Procedure

1. Check the TCP/IP communication addresses.

Are the TCP/IP communication addresses correct?

Yes: Continue with step 2.

No: Correct the addresses. Continue with step 4.

2. Check the gateway NE identification.

Meaning

Effects

Possible Cause(s)

Corrective Actions

Meaning

Effects

Possible Cause(s)

Corrective Actions
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Is the gateway NE identification correct?

Yes: Continue with step 3.

No: Correct the identification. Continue with step 4.

3. Check the Data Communication Network (DCN).

Is the DCN in service?

Yes: Continue with step 4.

No: Bring the DCN into service.

4. Is the alarm now cleared?

Yes: O.K.

No: Call Lucent Technologies Technical Support.

6.6.4.7 TL1_COMM_DENIED

User login for a TL1 communication session was denied by the NE for all TCP/IP
connections opened.

Abbreviation: TL1_COMM_DENIED

Severity: Critical

Service affecting: No

The alarm will be cleared when a TL1 communication session between the AEM-
NB and the NE has been successfully opened.

It is not possible to manage the NE because there is no TL1 communication ses-
sion available.

A user login error is stopping the TL1 communication session establishment pro-
cess between the AEM-NB and the NE.

Proceed as follows to clear the alarm:

Step Procedure

1. Check for correct User Identification (user login), Password and NE target
identifier (TID).

Meaning

Effects

Possible Cause(s)

Corrective Actions
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AData Communications Network
(DCN) Configuration A

A.1 Overview

This appendix provides you with information about

■ DCN introduction,

■ General definitions of terms,

■ Network Element management communications,

■ AnyMedia Element Manager management communications,

■ Sample DCN configurations.

A.2 DCN Introduction

The AnyMedia® Access System is designed to provide a full range of narrowband
access services like POTS, ISDN and Leased Lines.

The AnyMedia Element Manager for Narrowband Services (AEM-NB) will provide
the standard management configuration, equipment configuration, fault and test-
ing, performance and security functions capabilities to do service management,
monitoring, generate reports and printouts, do backup and restore functions for
example to improve the customer’s day to day business.

The AEM-NB will communicate with the network elements by using TL1 com-
mands over TCP/IP (TL1 over raw TCP can also be used) and FTP over TCP/IP. A
communication with TL1 commands over Telnet is only possible via cut-through.
The AnyMedia AEM-NB is also prepared in the first release to communicate with
other legacy OSs by means of TL1 northbound pass-through interfaces. TL1 will
be used for request/response and autonomous reports commands and FTP will
be used for software and database upload/download operations.

The Data Communications Network (DCN) is the communications infrastructure
(routers, WAN links, etc.) needed for communication of the AEM-NB with the NEs

AEM-NB Features

Communication of
AEM-NB and NE

DCN
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it manages. This manual refers to AEM-NB Release 1.5 and AnyMedia NE Re-
lease 1.5. For this releases many DCN configurations and protocol profiles can be
used according to the network operators needs and scenarios. Two sample DCN
scenarios are given at the end of this chapter.

A.3 Terms Used in this Chapter

The Data Communications Network (DCN) consists of the communication media
and the interconnected devices which are used to exchange management infor-
mation between the AEM-NB, the NEs and other management systems.

A Semi Permanent Leased Line (SPLL) is a service in which resources are used
permanently for the transmission of data between two points. The switch is the re-
sponsible for the set-up of this service.

The Remote Operations Channel (ROC) is a bearer channel that conveys man-
agement information for a remote system (AnyMedia NE). The ROC is expected
to be used when the system is installed at locations where no Ethernet Local Area
Network (LAN) and no separate network (e.g. X.25) exists.

A router is a network layer device that forwards packets from one network to an-
other based on network layer information (OSI layer 3). Data packets are only
transferred through the router, if the participant is on another port of the router.
The router can keep data traffic certain parts of a LAN. A router is more powerful
than a bridge, it reduces the traffic on a LAN more than a bridge, because the IP
address is evaluated for traffic control.

A bridge is a network layer device that passes packets between two or more net-
work segments that use the same data link communications protocol (OSI
layer 2). The network segments appear as one segment to protocol levels higher
than the data link layer. The bridge recognizes with the help of the MAC address
which LAN component is on which port of the bridge. Data packets are only trans-
ferred over the bridge if the participant is on another port of the bridge. With a
bridge data traffic can be kept from certain parts of a LAN.

A.4 NE Communication Capabili-
ties

In this section the management communication capabilities an AnyMedia NE are
described. The AnyMedia Access System provides the following management in-
terfaces for operation, administration, maintenance, and provisioning (OAM&P):

■ Craft interface terminal (CIT).

The CIT port is a local EIA-232D (former RS-232C) interface. It is located
on the faceplate of the CTU card in the AnyMedia Access System for 24
channel market. Either a TL1 ASCII terminal or a PC-based Graphical Sys-
tem Interface (GSI-NB) can be connected to the CIT port locally. This inter-
face is typically used during initial installation and other maintenance re-
lated activities. This interface can also be used to remotely manage the NE

Data Communica-
tions Network

Semi Permanent
Leased Line

Remote Operations
Channel

Router

Bridge
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using the AEM-NB/GSI-NB (a DCN is also needed), PPP is being imple-
mented on top of the CIT port as to allow this remote management. The
protocol profile in the NE for this scenario is shown in Figure A-1.

Figure A-1 AnyMedia Remote Access to CIT Port Protocol Profiles

■ External system LAN interface.

LAN interface is available via a backplane connector on the AnyMedia Ac-
cess System shelf. It provides access to an IEEE 802.3 compliant LAN
through a 10BaseT connection. All communications through this interface
occur over the transmission control protocol/internet protocol (TCP/IP) to
the GSI-NB or element manager (AEM-NB). The protocol profile in the NE
for this scenario is shown in Figure A-2. For AnyMedia NE release 1.7 it will
be an IAO LAN (also supporting an OSI protocol stack).

Figure A-2 AnyMedia External LAN Interface Profiles
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TCP at layer 4

File Transfer Protocol

10BaseT at layer 1

MAC & LLC-1
at layer 2

IP at layer 3

TCP at layer 4

TL1 over Telnet session
(TL1 over raw TCP also
supported)



A-4 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Data Communications Network (DCN) Configuration NE Communication Capabilities

■ Remote Operations Channel (ROC)

The remote operations channel (ROC) is a 64 kbps timeslot within the pay-
load of a DS1 link bound to a feeder of the AnyMedia NE. The AnyMedia
Access System provides access for a remotely located OS if it communi-
cates via TCP. The protocol profile in the NE for this scenario is shown in
Figure A-1. This alternative can be used if no local Ethernet LAN is avail-
able or the outside plant (OSP) environment is too severe for a router. It
does not need a separate DCN, then it can be a cheaper solution. The pro-
tocol profile in the NE for this scenario is shown in Figure A-3.

Figure A-3 AnyMedia Remote Operations Channel (ROC) Protocol Profiles

For establishing communication between the AEM-NB and the NE, the NE must
be minimally configured with its LAN, ROC or CIT parameters as applicable. This
option is the only available, as the AnyMedia Access System does not support re-
mote boot and remote TCP/IP configuration. The GSI-NB can be used to provide
this initial configuration of the NE using the CIT port.

IP at layer 3

TCP at layer 4
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A.5 AEM-NB Communication
Capabilities

The AEM-NB uses for communicating management data an external system LAN
interface. The protocol profile in the AEM for this scenario is shown in Figure A-4.

Figure A-4 AEM-NB Protocol Profiles

A.6 Sample DCN Configurations

Having in mind the management communications capabilities of the AnyMedia NE
and EM two DCN scenarios have been selected as sample configurations.

A.6.1 Remote Operations Channel Over
Semi Permanent Leased Lines DCN

The assumptions for this configuration are:

■ The LAN-based element manager is located in the central office collocated
with the Local Digital Switch (LDS).

■ The NEs are located at remote locations.

■ The OAM&P information (mapped in the 64 kbit/s ROCs) is transported
from the AEM-NB in the central office to the remote locations via a semi
permanent leased line (SPLL) using either TR-08 or TR-303 access tech-
nologies.

■ A router/bridge is used for interfacing the channelized T1 I/F to the LAN in
the central office. The router/bridge performs the translation from LAN to
HDLC/DS0 access via channelized T1 interfaces.

10BaseT at layer 1

MAC & LLC-1
at layer 2

IP at layer 3

TCP at layer 4

File Transfer Protocol

10BaseT at layer 1

MAC & LLC-1
at layer 2

IP at layer 3

TCP at layer 4
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■ For layer 2 the HDLC Protocol is used between 24 channel NEs and the
router.

■ One remote operation channel is used for communicating with each NE (64
kbit/s ROC carried on a SPLL). For managing up to 24 NEs connected to
the LDS, a single T1 interface for the router/bridge is sufficient.

A.6.1.1 Router Configuration

The minimal requirements for the router/bridge for supporting this scenario are:

■ Minimal WAN Interface Requirements:

The router/bridge must have one or more channelized 1.544 Mbit/s T1 in-
terfaces (ITU G.703/G.704). An IP address may be assigned to each time-
slot or channel group.

■ Minimal LAN Interface Requirements

The router must have one or two (for cascading purposes) Ethernet (IEEE
802.3) 10BaseT ports. In case of two LAN ports, LAN-to-LAN routing is
supported.

For the router/bridge the following has to be provisioned:

■ T1 interface functionality (line code, framing type etc.)

■ Time-slot mapping (each needed serial interface will be a channel group
mapped on a time slot of the channelized T1)

■ Protocols and encapsulations

■ IP-addresses for IP routing (routing tables)

■ Ethernet media

The initial provisioning of a router/bridge is typically performed by a VT100/ANSI
terminal, connected to a RS-232C port. When the IP-address of the router is pro-
visioned, the router may be configured via LAN (TELNET, SNMP) depending on
the router/bridge used.

A.6.1.2 AnyMedia Network Element Configu-
ration

The ROC (over SPLL) is the management interface used to access the NE. The
initial provisioning has to be done via pre-provisioning (factory settings) or a local
GSI-NB (LAN or RS-232C) because the SPLL service, carrying the remote opera-
tions channel, must be in-service to get remote access to the NE via remote oper-
ations channel.

The following actions have to be made to provision the ROC over SPLL manage-
ment interface:

■ Provision the Local Digital Switch (LDS) that is connected to the NE shelf
to associate the DS0 channel to a SPLL service.

■ Provision the NE using the ENT-T0 TL1 command to indicate that the re-
ceived DS0 is a 64 Kbps clear channel (gsfn=4do).

Configuration

Provisioning the
ROC via GSI
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■ Provision the NE using the ENT-CRS-T0 command to indicate that the re-
ceived DS0 should be cross connected to the logical ROC port. Note that
the remote operations port T0 cross-connection created for a TR-08 VRT
will cause system bandwidth to be allocated, while for TR-303 this com-
mand is more an association function than a cross-connection. No actual
cross-connection is made in TR-303 until a request to connect the logical
line specified in this command is received from the LDS over the EOC data
link (for semi-permanent connections).

■ Provision the NE using the SET-IP command to an unique IP address.

TL1 commands can be used to configure the NE. Note that the default router ad-
dress of the NE must be set to 224.0.0.2 (universal router’s multicast address) so
that the NE points to the router on the other side of the ROC interface.

The following TL1 commands are an example of ROC over SPLL configuration
(for TR-303) in the NE.

ent-t0::v3dp-1-49::::gsfn=4do;
ent-crs-t0::v3dp-1-49,roc-1;
ent-crs-t1::ds1-1-1-1,v3fdr-1-3;
set-ip::::::shelf=135.5.78.2,defrouter=224.0.0.2,
submask=255.255.255.0

The “nail-up” of the DS0 channel must also be provisioned in the LDS after that
the ROC over SPLL is provisioned. Once communications with the element man-
ager is established via the ROC over SPLL, remote operations on the NE can be
executed as over a connection via LAN. Also either the GSI-NB or a standard win-
dows FTP/TELNET can be used.

A.6.1.3 Element Manager Server Configura-
tion

The server on which the AEM-NB application resides must have its IP parameters
configured:

■ IP address (e.g. 135.88.20.234)

■ subnet mask (e.g. 255.255.240.0)

■ default router (e.g. 135.88.17.1)

In the AEM-NB the following parameters have to be configured to be able to com-
municate with the NEs.

■ TCP/IP configuration related to NEs

— For every NE the AEM-NB wants to communicate with, its IP ad-
dress (e.g. 135.88.4.2) must be introduced in the AEM-NB (provi-
sionable via AEM-NB GUI).

— The ports to be used in the NE needs to be stored in the AEM-NB
(e.g., for TL1 over TELNET communication the ports to be used are
in the order: 11001, 11003, 11005 and 11007; for FTP communica-
tion the port number 20 for FTP data transmissions and the port
number 21 for FTP control communication).

Provisioning the
ROC via TL1 using
GSI

Server IP Parame-
ters

Configuration
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■ Association configuration related to NEs

— For every NE with which the AEM-NB has to communicate, the NEs
Target Identifier (TID) must be known by the AEM-NB (provisionable
via AEM-NB GUI).

— For every NE with which the AEM-NB wants to communicate, the
LOGIN information related to that NE must be introduced in the
AEM-NB (provisionable via AEM-NB GUI).

— For every NE the AEM-NB wants to communicate with, the PASS-
WORD information related to that NE must be known by the AEM-
NB (provisionable via AEM-NB GUI).

A.6.1.4 Element Manager Client Configuration

The workstation with the AEM-NB client has the following IP parameters config-
ured. Note that if the client is located at the same machine as the server these pa-
rameters are already configured.

■ IP address (e.g. 135.88.20.230)

■ subnet mask (e.g. 255.255.240.0)

■ default router (e.g. 135.88.17.1)

In the preferences file of the AEM-NB client the following information must be
stored to be able to access the AEM-NB server (this file has to be created before
starting the AEM-NB client GUI):

■ The AEM-NB server IP address (e.g. 135.88.20.234)

■ The LOGIN for accessing the AEM-NB server (encrypted)

■ The PASSWORD for accessing the AEM-NB server (encrypted)

A.6.1.5 Local Digital Switch Configuration

Management operations have to be performed on the LDS to create the SPLL ser-
vice and associate this service to the DS0 channel which will be cross connected
with the ROC. The provisioning of this DS0 channel will be static with TR-08 and
dynamic with TR-303.

A separate SPLL needs to be established with every NE which shall be managed.

Client IP Parame-
ters

AEM-NB Prefer-
ences File
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Figure A-5 ROC over Semi Permanent Leased Line for AEM-NB

A.6.2 X.25 DCN

The assumptions for this configuration are:

■ The LAN-based element manager is located in the central office.

■ The NEs are located at remote locations (a remote LAN may exist at the re-
mote location).

■ The OAM&P information is transported from the AEM-NB in the central of-
fice to the NEs in the remote locations via a public/private X.25 network.

■ An X.25 router (maybe a PC with X.25 and Ethernet cards) is needed at
both sides (AEM-NB and NE sides) for interfacing X.25 network (playing
the role of the X.25 DTE) and the LANs. The router performs the mapping
from IP to X.25 and is responsible for call set-up, data transfer and call
clearing in the X.25 network. The local LAN OA&M NE interface will be
used for the communication between the router and the AEM-NB/NEs.

■ X.25 Permanent Virtual Circuits (PVCs) or Switched Virtual Circuits (SVCs)
are established for interchanging information.
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A.6.2.1 Router Configuration

The minimal requirements for the router/bridge for supporting this scenario are:

■ Minimal WAN Interface Requirements:

The router/bridge must have one or more X.25 DTE interfaces. An IP ad-
dress has to be assigned to every X.25 DTE interface.

■ Minimal LAN Interface Requirements

The router must have one or two (for cascading purpose) Ethernet (IEEE
802.3) 10BaseT ports. In case of two LAN ports, LAN-to-LAN routing
should be supported.

Provisioning needs for the router are the following:

■ X.25 interface functionality (encapsulation, window size, etc.)

■ Protocols and encapsulations

■ PVC and SVC characteristics (If SVCs are used the router is responsible
for establishing and releasing the SVC.).

■ IP-addresses for IP routing (routing tables)

■ Ethernet media

The initial provisioning of a router/bridge is typically performed by a VT100/ANSI
terminal, connected to a RS-232C port.

A.6.2.2 Configuration of AnyMedia Network
Element

On the AnyMedia NE the local LAN port must be configured. The initial provision-
ing has to be done via pre-provisioning (factory settings) or a local GSI-NB (LAN
or RS-232C). The NE IP address, the default router address and the subnet mask
of the NE local LAN port must be configured. How to use TL1 commands to con-
figure the NE is shown in the next example. The default router address will be the
IP address of the X.25 router on NE side.

set-ip::::::shelf=135.88.4.2,defrouter=135.88.17.1,
submask=255.255.240.0

Once the communication with the element manager is established via X.25, the
remote operations on the NE can be executed as if a connection via LAN were
present.

A.6.2.3 Element Manager Server Configura-
tion

The element manager server configuration is the same as described in
Chapter A.6.1.3, page A-7. The default router will be the X.25 router on AEM-NB
side.

Router/Bridge Re-
quirements

Router/Bridge Pro-
visioning
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A.6.2.4 Element Manager Client Configuration

The element manager client configuration is the same as described in
Chapter A.6.1.4, page A-8.

A.6.2.5 Transport Elements Configuration

If the transport is achieved by means of an X.25 Public Data Network (PDN) then
X.25 permanent virtual circuits or switched virtual circuits must be provisioned be-
tween routers on both sides before the AEM-NB and NEs are able to exchange
management information.

If PVCs are used they may be established by the PDN operator. If SVCs are used
the routers on AEM-NB and NE sides are responsible for establishing (e.g. for
routing IP packets) and releasing the connections (e.g. by timeouts). It is neces-
sary to assign the address of the router before X.25 WAN can be used.

Figure A-6 X.25 Communication with Remote NEs
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A

ACO
Alarm Cut-off

ADSL
Asymmetrical Digital Subscriber Line

AEM
AnyMedia™ Access System Element Manager

AFM
Access Feeder Multiplexer

AID
Access Identifier

AMAS
AnyMedia Access System

ANR
Abnormal

ANSI
American National Standards Institute

AO
Autonomous Output Message

AP
Application Pack

APOG
Applications, Planning, and Ordering Guide

ASCII
American Standard Code for Information Interchange

ATM
Asynchronous Transfer Mode

AUTO
Automatic

B

BAL
Balance

BB
Backus-Naur Form

Abbreviations AB
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BCL
Bank Controller Link

BITS
Building Integrated Timing Supply

BRA
Basic Rate Access

C

CD
Compact Disk

CDE
Common Desktop Environment

CFL
Customer Feature List

CIT
Craft Interface Terminal

CIU
Communication Interface Unit

CLEI
Code assigned by Bellcore

CMIP
Common Management Information Protoco

CO
Central Office

CPE
Customer Premises Equipment

CR
Critical (alarm severity)

CRV
Call Reference Value

CTAG
Correlation Tag

CTRL
Control

CTU
Craft Test Unit

CU
Channel Unit
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D

DB
Database

DC
Direct Current

DCN
Data Communication Network

DDS
Digital Data System

DFL
Default

DID
Direct Inward Dial

DPT
Dial Pulse Termination

E

ECI
(Code that corresponds to the bar-coded label on the faceplate of the plug-in)

EIA
Electronic Industries Association

EM
Element Manager

EM-AM
Element Manager-AnyMedia

ENT
Enter

EOC
Embedded Operations Channel

EQPT
Equipment

ESF
Extended Super Frame

ETO
Equalized Transmission Only

EVT
Event
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F

FAF
Facility Failure

FEF
Family of Equipment Failure

FLT
Fault

FS
SuperFrame with Datalink

FTP
File Transfer Protocol

FXO
Foreign Exchange Office

G

GS
Ground Start

GSF
General Service Function

GSFN
Generic Signalling Function

GSI
Graphical System Interface

GUI
Graphical User Interface

H

HBER
High Bit Error Ratio

HDD
Hard Disk Drive

HDLC
High Level Data Link Control

HP
Hewlett Packard

HW
Hardware
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I

ICC
InterChangeability Code

ICMS
Integrated Configuration Management System

ID
Identifier

IEEE
Institute of Electrical and Electronics Engineers

IIOP
Internet Interoperability Protocol

IN
Information (alarm severity)

INA
Integrated Network Access

IP
Internet Protocol

IS
In Service

ISDN
Integrated Services Digital Network

ITM-SNC
Integrated Transport Management - Sub NetworkController

ITU
International Telecommunication Union

L

LAN
Local Area Network

LBER
Low Bit Error Ratio

LDS

LED
Light Emitting Diode

LIC
License

LLN
Logical Line Number
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LPBK
Loop Back

LS
Loop Start

M

MDS
Metallic Distribution Server

MDSU
Metallic Distribution Server Unit

MEA
Mismatch of Equipment and Attributes

MHz
Megahertz

MJ
Major (alarm severity)

MLT
Mechanized Loop Testing

MM
Module Manager

MN
Minor (alarm severity)

MON
Degraded Signal

MR
Modification Request

MSC
Metallic Shelf Controller

N

NB
Narrow Band

NE
Network Element

NEM
Network Element Management / AnyMedia EM subsystem

NM
Network Management
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NMA
Network Monitoring and Analysis

NMS
Network Management System

NVDS
Nonvolatile Data Storage

NVPS
Nonvolatile Program Storage

O

OAM
Operations, Administration and Maintenance

OCU
Office Channel Unit

OMG
Object Management Group

OODB
Object Oriented Database

OOS
Out Of Service

OPS
Operations System

ORB
Object Request Broker

OS
Operation System

P

PBX
Private Branch Exchange

PC
Personal Computer

PCM
Pulse Code Modulation

PID
Password Identifier

PLN
Physical Line Number
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PLR
Pulse Link Repeater

POTS
Plain Old Telephone Service

PPP
Point to Point Protocol

PSTN
Public Switched Telephone Network

PT
Power Test

PTU
Power Test Unit

R

RAM
Random Access Memory

RCV
Receive

RDLD
Red Lined

REPT
Report

ROC
Remote Operations Channel

ROM
Read Only Memory

RTLP
Receive Transmission Level Point

RTU
Remote Test Unit

2RVO
2-Wire Loop Reverse Battery, Originate

S

SCC
Secondary Channel

SCEC
Secondary Channel Error Correction
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SDEE
Supported Entity Exists

SDH
Synchronous Digital Hierarchy

SGE
Supported Entity Outage

SL
Slope

SLC
Subscriber Loop Carrier

SNMP
Simple Network Management Protocol

SPLL
Semi Permanent Leased Line

SW
Software

T

TA
Terminal Adapter
Test Area

TAP
Test Access Path

TCA
Threshold Crossing Alert

TCP
Transmission Control Protocol

TID
Target Id

TL1
Transaction Language 1

TLP
Transmission Level Point

TM
Timeslot Management

TMC
Timeslot Management Channel

TMN
Telecommunication Management Network

TNM
Total Network Management
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TO
Transmission Only

TRMT
Transmit Attenuator Parameter

TS
Test

TS
Timeslot

TTLP
Transmit Transmission Level Point

TTMT
Tandem Transmit Attenuator Parameter

U

UART
Universal Asynchronous Receiver/Transmitter

UAS
Unassigned

UEQ
Unequipped

UI
User Interface

UID
User Id

UPS
Uninterruptable Power Supply

UX
Unix

V

VB
Virtual Bank

VC
Virtual Connection

VF
Voice Frequency

VFDE
Voice Frequency Data Enhancement
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VRT
Virtual Remote Terminal

W

WAN
Wide Area Network

X

XO
Crystal Oscillator

Y

YEL
Yellow Alarm

Z

ZCS
Zero Code Suppression

ZS
Zero Suppression
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10Base T
This is a physical interface used for high speed Ethernet connection. It uses twisted pair cables.

A

a-wire
One of the wires of the subscriber line. Sometimes it is called the tip wire.

AEM-NB
AnyMedia Access System Element Manager for Narrowband Services. It may be also named simply AEM-NB in
some parts of the document.

Alarm
Any condition that needs operator attention, since it may impact the normal operations of any system under opera-
tor responsibility (e.g. Element Manager, Network Element).

AMS
Alarm Management Subsystem.

AnyMedia Access System
This is also referred to as the Network Element or just the NE.

AnyMedia NE
AnyMedia Network Element for Narrow Band Services. It is the Network Element to which the DCN defined in this
document is related. Also known as FAST or AMAS.

AO
Autonomous output; reports generated by the NEs.

Application
Group of one or more modules that offer related functionality.

Applicatios Pack (AP)
This is a circuit pack which provides the line-side interface functionality for POTS, SPOTS, ISDN or special service
circuits. Each AP handles 24 or 32 lines (POTS, SPOTS, COIN and special services) or 16 lines (ISDN). There can
be up to 16 APs in an AnyMedia Access System shelf.

Archive
Process of copying file systems to removable media (such as tape) and deleting the original files once they have
been backed up.

AUDIT Trail
A subset of all log messages. A record showing who has accessed an Anymedia EM and what operation was per-
formed during a given period of time.

Glossary GL
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B

b-wire
One of the wires of the subscriber line. Sometimes it is called the ring wire.

Backup
Process of copying file systems to removable media (such as tape) to safeguard against loss, damage, or corrup-
tion.

BB
Broad Band.

Blinking Alarm
An alarm which is continuously changing its status: raised, clear, raised, clear ...

Bridge
A network layer device that passes packets between two or more network segments that use the same data link
communications protocol (OSI layer 2). The network segments appear as one segment to protocol levels higher
than the data link layer. The bridge recognizes with the help of the MAC address which LAN component is con-
nected at which port of the bridge. Data packets are only transferred over the bridge if the participant is at another
port of the bridge. With a bridge, data traffic can be kept from a certain part of a LAN.

Built-in Self Test (BIST)
This is a procedure executed by each plug-in circuit pack either after power-up or on demand. The task is to check
the functions of the hardware.

Burst Load
Load that can occur in certain well-known circumstances, where response times are no longer guaranteed, but
queues handle excess traffic. After removing the causes of the burst load, and a certain settling time, normal oper-
ation is resumed. During burst load there is a graceful degradation, no loss of information, only a queueing occurs
to defer the load to a later moment.

Busy Hour Load
Maximum load that is expected to occur in real life that must be handled with normal response times.

C

Call Reference Value (CRV)
This is a numeric value used to identify a logical line on a TR-303 Virtual Remote Terminal (VRT) in messages ex-
changed between the HDT and the TR-303 switch when setting up and tearing down individual calls. For TR-303
VRTs, the CRV is identical to the last field in the AID for a logical line, e.g.,104 is the CRV for the logical line having
AID v3dp-1-104. CRVs are numbered between 1 and 2048. A maximum of 672 provisioned logical lines are sup-
ported by the AnyMedia Access System R1.2. A CRV can be uniquely associated with a single Distribution Port by
setting up a T0 cross-connection between that port and the logical line specified by the CRV.
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Cross Connection
Several types of cross connections are present in the AnyMedia Access System:

■ T1 cross-connections provide links between physical DS1 feeder ports and the logical feeder ports of the
VRTs and INA Virtual Banks (VB). They are created and deleted using the TL1 commands ENT-CRS-T1 and
DLT-CRS-T1. The creation of a T1 cross-connection acts as a trigger within the NE to instantiate the associ-
ated VRT or VB.

■ T0 cross-connections provide links between the logical ports of a VRT or an INA VB and the physical distri-
bution ports of the NE. They are created and deleted by the TL1 commands ENT-CRS-T0 and DLT-CRS-T0.

■ Finally, the undifferentiated term cross connection  describes an actual bandwidth assignment within the
system’s TSI fabric. Such bandwidth assignments are administered dynamically by the TR-303 TMC, they are
administered semi-permanently by the TR-303 EOC, and they are created automatically by the NE in re-
sponse to provisioning activities on TR-08 VRTs and INA VBs.

Circuit
This refers to the devices and functions built on or provided by an AP for one port. In some documents this is also
called facility. The subscriber line is not included.

Client
An entity that initiates requests to a server. For the AnyMedia Access System a client could be a PC with a GUI in-
terface, a telnet session or an OS (like the AEM-NB).

Client Application
A group of one or more user modules that offer related functionality.

Client Host
A machine where one or more user modules are installed.

Common Data and Control Pack (COMDAC)
This performs the main bandwidth management and control functions of the system.

Configuration Management
This consists of a set of functions for controlling the network elements, including initialization, parameter setting,
starting and stopping and collecting information about the NE configuration.

Controlled Objects
An entity defined via type and value. Where type is defined as NE for AEM-NB R1.0, but later when unbundled it
requires the ability to configure type as VRT for the 24-channel product. Value will identify one specific managed
NE or VRT Interface.

CIT: Craft Interface Terminal
A local RS232 connection on the AnyMedia access system to which a PC GUI can be connected.

D

Date
This refers to the day, month, and year and represents a calendar function that needs to include a calculation for
leap years and a capability of determining the day of the week from the date, and must be Y2K compliant.

DCN
Data Communications Network; the communication media and interconnected devices used to exchange manage-
ment information between the AEM-NB, the NEs and other OSs.

Defaults
These are the parameter values built into the NE when it is shipped from the factory. (Default values are restored
upon execution of an INIT SYS command.)
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Device Driver
A program that controls a specific device, such as a cartridge tape (DAT).

Distribution Port
The circuitry that provides narrowband access (i.e., up to the 1.544 Mbps DS1 rate) to a single network interface
over one (2- or 4-wire) metallic facility and converts between the format seen by this network interface (e.g., analog
voice-frequency, ISDN U-interface, etc.) and the internal format (i.e., 4-Mbps timeslots). Distribution Ports are con-
tained in Application Packs / Channel Units for the AnyMedia Access System. A maximum of 32 Distribution Ports
are supported on POTS/COIN Application Packs (APs) and a maximum of 16 Distribution Ports are supported on
ISDN APs.

Download
The process of moving information from a server to a client at the request of a client according to client/server par-
adigm. Expected applications of this capability are database retrievals.

Drop
This comprises the wire to the customer and customer premises equipment (CPE). In some documents this is also
called equipment.

DS1 ports
DS1 circuits are used to provide the AnyMedia Access System shelf virtual remote terminal (VRT) or INA Virtual
Bank feeder facilities and are physically located on the IO_DS1 circuit packs in the NE shelf.

DU
Development Unit.

E

EAS Element Access Server
This is a CORBA server developed by Lumos Technologies which provides an interface between TL1 messages
and CORBA methods.

EM Application
A group of one or more modules that offers related functionality.

EM Domain
An assigned collection of Controlled Objects.

EM Task
This represents a subset of the management functions supported by EM applications.

EM User
An entity defined via login name that can be assigned at least to an EM user group.

EM User Group
A logical group of EM users enabled to access one or more “domains”. Permissions to access domains, applica-
tions and tasks are administered on an EM user group basis.

Embedded Operations Channel (EOC)
A duplicated DS0 data link dedicated for exchange operations messages between the LDS and RDT.
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F

Fault Case
For some faults (e.g. DCN failure), normal working conditions need to be re-established within certain time limits.
These are fault cases that are taken into account.

Fault Management
For detecting, displaying, storing, filtering and routing fault/alarm data.

Feeder DS1 Ports
These are the DS1 circuits that are used to provide virtual remote terminals or INA virtual bank feeder facilities and
are provided by IO_DS1 circuit packs in the AnyMedia Access System. The DS1 port numbers are included as part
of the AIDs for these feeder DS1 ports.

Forced Switch
This refers to an Element Manager-initiated switch command that instructs the NE to perform a switch no matter
what the conditions of the protection unit (COMDAC and IO_DS1 circuit packs only) are.

Full Backup
This copies a complete file system or directory.

G

Generic Signaling Function (GSFN)
This defines the signaling interface for a provisioned distribution port. It is part of the T0 object data associated with
each port. Typical values for the GSFN are 2LS (2-wire loop start) and 2RV0 (2-wire loop reverse battery, originat-
ing side).

Global Program
This defines the information presentation to the user according to the user's preferred language and customs. A
global program is one that has been internationalized and can be localized.

GSI
This is an intelligent terminal which may be a laptop PC that supports Graphical User Interface (GUI) software and
the TL1 protocol interface to the AnyMedia Access System.

GSI-NB
The Graphical System Interface for narrowband services. This is a Windows 95-based PC which uses TL1 com-
mands for the management of AnyMedia Network Elements.

GUI
The Graphical User Interface of the AnyMedia Element Manager System.

H

Host
A machine where one or more modules are installed.

Hub or Multiport Repeaters
This have 8, 12, 16 or more ports. With their help multiple devices with 10BASE-T interface can be connected to a
single LAN. They have at least one additional port for connecting an additional segment of a LAN.
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I

Incremental Backup
This copies new files and files that have changed since a previous backup. The incremental backups are usually
given a dump level which determines which files are backed up. A certain level incremental backup will save all the
new or changed files since the last backup with a lower level.

Inhibit Switch
This refers to an Element Manager-initiated switch command that instructs the NE to inhibit a side switch irrespec-
tive of the conditions of the active unit (COMDAC and IO_DS1 circuit packs only).

Internationalization
This is the process of isolating the language- and customs-dependent code in a computer program from the lan-
guage-independent code. The term internationalization is often abbreviated as i18n.

IO/DS1 Pack (IO_DS1)
This provides four DS1 interfaces to accommodate telephony via standard TR-08 mode, TR-303 and INA network
interfaces.

IO_DS1 Circuit Packs
Each circuit pack contains four feeder DS1 port circuits together with the circuitry needed to interface with DS1 sig-
nals (metallic feeder).

IP Addresses
These are distributed according to the worldwide or local configuration. The IP address is used in ISO layer 3. A
LAN contains tables for making an assignment between MAC address and IP address.

L

Level 1 Applications
The minimum set of server applications that have to run together to provide the minimum functionality of the Any-
Media NB EM. These applications must exist before the Level 2 Application can be started. If this group is shut
down the AEM-NB is shut down.

Level 2 Applications
Server applications that can be started up and shut down individually without affecting the functioning of other ap-
plications.

Line Test
Also called drop test. This checks for open circuits, short circuits, leakages to ground, foreign voltages, or other
faults on the subscriber line that connects an AP port circuit to the CPE. The results are used to detect broken or
bad quality wires even before the customer realizes a lack of quality.

LL/PLL Permanent Leased Lines
A service in which resources are used permanently for the transmission of data between two points. The switch is
not responsible for setting up this service.

Locale
This is a geographic or political region that shares the same language and customs. In this document, a locale is
also used to refer to the definition of the subset of a user's information technology environment that depends on
language and cultural conventions.

Local Digital Switch (LDS)
This is a switching machine that terminates a TR-303 VRT. An example of an LDS is the Lucent 5ESS switch.



Glossary

363-211-402 Issue 2 (09.99) GL-7

AEM-NB R1.5

Localization
This is the process of adapting a program for use in a specific locale.

LOG File
This is the file used for listing all actions that have occurred in a system. This information is generated and re-
corded concurrently and sequentially as transactions and events are processed in the system.

Logical DS0
The descriptor used in this document to refer to parameters affecting a DS0 (64-kbps) service or facility (TR-303
logical line DS0).

Logical DS1
The descriptor used in this document to refer to parameters affecting a DS1 (1.544-Mbps) service or facility (TR-
303 logical feeder DS1).

Logical Feeder DS1 Numbers
These are the identifiers (1 to 28, for the TR-303 VRT) of the VRT feeder DS1s that are used by the real-time call
processing software of the TR-303 Local Digital Switch (LDS) and in communicating with the VRT (over the TMC
and/or EOC) about these feeder DS1s. The AnyMedia Access System provides only 20 physical feeder DS1 ports,
so only a subset of the logical feeder DS1s can be in service.

Logical Line
This is a logical customer termination provided by the NE on either a TR-303/TR-08 VRT or an INA VB.

Logical Line Number (LLN)
This is the Access IDentifier (AID) used externally by the Element Manager to identify uniquely a VRT or INA Vir-
tual Bank distribution-side logical drop.

M

MAC Address
This is a 6-byte hardware address, which identifies a unique participant worldwide in an Ethernet LAN. A MAC ad-
dress is used in OSI layer 2.

Manual (normal) Switch
This refers to an Element Manager-initiated switch command that instructs the NE to perform a switch only if the
protection unit (COMDAC and IO_DS1 circuit packs only) is in service and not faulty.

Migration
This refers to converting an NE from one software release to another by installing a different software release.

Module
An executable installed on a Host.

N

NE
AnyMedia Access System Network Element.

NEM
Network Element Management Subsystem.
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Non-Volatile Data Storage (NVDS)
This refers to a capability of the AnyMedia Access System to store information in such a way as to survive indefi-
nite periods of total power failure. The current values for all provisionable parameters are stored in the NVDS and
hence are the parameter values that will be used on subsequent NE power-up.

Non-Volatile Program Storage (NVPS)
This keeps software program data. It resides in the COMDAC.

Normal Hour Load
The average load expected during the lifetime of the system.

O

Off-line Backups
These are backups performed automatically via any scheduling mechanisms, e.g. cron file.

On-line Backups
These are backups performed on user demand.

Operator
This refers to the AnyMedia Element Manager users.

Operator Mode
Testing initiated by staff from the EM using the NE-integrated capabilities. These tests can last some time, e.g.,
some measurements can be executed several times during a test session. The results in this mode usually are val-
ues (e.g. resistance, voltage, ...) and pass/fail decisions.

Overload
The load that causes the system to take drastic measures to ensure its integrity. During overload normal system
function is disrupted and certain inputs (the ones causing the overload) are ignored. After clearing the overload sit-
uation, the system is left in asynchronous state for those inputs that generated the overload. Re-synchronization of
this input retrieves synchronization.

OS
This is any operations system or Element Manager connected to the AnyMedia Access System Element Manager
by some means of communication. For the AnyMedia Element Manager R1.0 the communication method is
TCP/IP.

P

Password (PID)
This is always associated with a login UID. PID is a case-sensitive string containing 6 to 10 alphabetic, numeric
and symbolic characters, where at least two characters are non-alphabetic and one is symbolic.

PCM Highway
The COMDAC pack is connected to each AP by the PCM highway, which consists of two 4.096-Mbps serial links, a
4.096-MHz clock and an 8-kHz sync signal. The AnyMedia Access System uses two PCM highways between the
COMDAC, the IO_DS1s and each of the 16 AP slots.

Performance Management
For receiving, detecting, time stamping, analyzing, displaying and storing performance data.

Plain Old Telephone Service (POTS)
The conversional 2-wire analog subscriber service.
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Platform
The hardware on which any AnyMedia EM module, server or client, is running.

Platform Alarm
This is an alarm related to the AnyMedia Element Manager application or its hardware/software platform. It usually
refers to an Element Manager function or hardware/software platform object.

Port
This is circuitry built on an AP to provide an interface for subscribers. Note that more than one port can be housed
on an AP, e.g. the LPZ100 provides 32 Z-ports.

Port Test
Also called circuit test. Verifies the ability of an AP port to provide proper transmission and signaling. It is the test-
ing of the port hardware. The functions of the port test rather depend on the hardware function of the circuit (e.g.
POTS, pulse metering, ISDN, ...). These tests are performed on each AP using part of their self-test capabilities.

R

RDT
This refers to the physical Remote Digital Terminal. A Remote Digital Terminal is a physical section of the NE that
interfaces to the LDS at DS1 rate.

Response Time
The real elapsed time between detectable start of an action and its completion.

Restore
The process of copying backup files from removable media to a working directory, replacing the original files which
could have been damaged.

ROC (Remote Operations Channel)
The bearer channel that conveys management information for a remote system (AnyMedia NE). The ROC is in-
tended to be used when the system is installed at locations where no local Ethernet LAN and no separate network
(e.g., X.25) exists.

Router
A network layer device that forwards packets from one network to another based on network layer information (OSI
layer 3). Data packets are only transferred through the router if the participant is connected to another port of the
router. With a router, data traffic can be kept from certain parts of a LAN. A router is more powerful than a bridge, it
reduces the traffic on a LAN more than a bridge, because the IP address is evaluated for traffic control.

S

Security Management
This restricts access based upon the establishment of log-in procedures and an associated set of passwords.
Screen locks are used as well.

User access is based upon domain partitioning. Controls the access to the data and capabilities inherent within a
fixed partition of the network, including unbundling.

Server
A network element that waits for requests from clients to perform specific tasks. This is the function performed by
the AnyMedia Access System.

Server Application
This is a set of server processes that perform a certain function.



GL-10 Issue 2 (09.99) 363-211-402

AEM-NB R1.5

Glossary

Server Host
This is the machine where the system server modules are installed.

Server Module
This is the module that provides a subset of the system services.

Service
This is a piece of functionality provided by a server module.

ServiceState (of an object or entity)
This represents the current availability status of an associated resource or service in the NE from the management
point of view (e.g., memory administration, maintenance).

Session
This is the active communication link between a client (in the context of this document the client will be the AEM-
NB) and a server (in the context of this document the server will be the AnyMedia Access System for Narrow
Band).

Side Switching
This refers to the operation of deactivating the active core entity and activating the standby core entity (COMDAC
and IO_DS1 circuit packs).

Software Download
The transport of the information required to upgrade/update a given NE’s generic program.

SPLL Semi Permanent Leased Lines
A service in which resources are used permanently for the transmission of data between two points. The switch is
responsible for setting up this service.

System
AnyMedia-EM software. It provides a set of services allowing an operator to manage the AnyMedia NE.

System Failure
Any problem that prevents the EM system from continuing to work.

T

T0
This is the descriptor used for the TL1 interface to refer to parameters concerning a DS0 (64 kbps) service or facil-
ity.

T1
This is the descriptor used for the TL1 interface to refer to parameters concerning a DS1 (1.544 Mbps) service or
facility.

TAS (Terminal Access Server)
This adapts local area networks (LAN) to wide area networks (WAN). TASs have the ability to integrate remote net-
work elements in a local network. TASs support different LAN protocols (e.g. Ethernet) and WAN protocols (e.g.
PPP).

TCA (Threshold Crossing Alert)
A crossing of a parameter threshold that is generally considered to be a transient condition.

TELNET
This ia a remote terminal interface protocol which allows remote login capability into a system on a network from
any other node on that network that is also running TELNET. TELNET is a TCP/IP application.
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Test Access Path (TAP)
There are up to two TAPs, one consisting of two pairs (TAP-B) and the other of six pairs (TAP-A), both providing in-
ternal and external metallic test access to the circuits.

Test Session
This is the procedure including all necessary functions to test a subscriber. This includes the setup of the test path
as well as the release of the test equipment. The test session runs in the NE.

Time
This represents a 24-hour clock function.

Timeslot Management Channel (TMC)
This is a duplicated DS0 data link that a TR-303 VRT and Local Digital Switch (LDS) use to exchange connection
control information with each other as they set up and tear down DS0 paths through the system on a per-call basis.

TL1 (Transaction Language 1)
This is a bellcore standard message language. It is the primary means of operating and maintaining the V5DLC
system. A TL1 message session supports bi-directional message transmission and when a TL1 link is established,
the system can initiate autonomous messages to monitor alarms and changes in system status.

TR303 VRT (TR303 Virtual Remote Terminal)
This refers to the logical portion of the NE that supports a single TR303 interface acting as a TR303 RDT. Only one
TR303 VRT can be supported in NE R1.2.

U

Upgrade
Is a type of migration where the software release is changed from an earlier release to a later release.

Upload
The process of moving information from a client to a server at the request of a client according to client/server par-
adigm. Intended applications of this capability are software updates and restoring databases.

User
The operator who will use the EM to provision, maintain and monitor the AnyMedia Access System.

User Identifier (UID)
This is a unique user login identifier. This string is required and cannot be null. Grouping of UID string values for
this command is not allowed. The valid UID value is a 3 to 10 case-sensitive alphanumeric character string.

User Module
A module that provides an interface to the users or to other external systems to the AnyMedia EM functionality.

V

VB
Virtual Bank. This is the entity that groups a feeder and various drops for permanent leased line services in a simi-
lar way to the VRTs for switched traffic.
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W

Workload or Load
A mix of actions and their frequencies from all possible input points that need processing in some way in the sys-
tem.

Z

Z-port
A Z-port is circuitry built on a POTS AP to provide a Z interface for analog subscribers. Note that more than one Z-
port is housed on an AnyMedia POTS AP, e.g. the LPZ100 provides 32 Z-ports.

Z-port (for transmission only)
This is a Z-interface normally used for services other than telephony (e.g. data transmission). This type of Z-inter-
face does not support DC feeding and does not support out-band signaling. This interface can support Analog
Leased Line (ALL) service.
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DCN introduction A-1
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Delete
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Delete key 3-6
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Comment procedure XVII
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Delete ~ 4-14
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Double click (mouse) 3-6
Drag (mouse) 3-6
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E

Edit (button) 3-15
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External LAN AEM system interface A-5
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F

Fault
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H
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Log type
Actions 1-12, 3-32
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System Internal Events 1-12, 3-32

Log Viewer application 3-33
LOG_DEL_FULL 6-37
LOG_DEL_PART 6-38
Login 3-2, 5-19
Logout

~ manually from System 3-3
Loopback

Clear 6-30
Set 6-30
Test 6-29

M

MDS2 shelf 5-3
MDS2B Shelf 5-3, 5-4
MDS2B Shelf View 5-25
Menu

Actions 6-13
File 6-12, 6-18
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Help 6-13
Views 6-12

Menu bar 3-11
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File -> Exit 3-16
File -> Print 3-16
Help -> Index 3-16
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Metallic Distribution Shelf 5-3
Metallic Shelf Controller 2-2, 5-4
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network 1-24
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Mouse 3-6
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N

NE Date & Time 5-55
NE Details 5-17
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physical installation 1-19

Network Browser 5-9
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Network element management 3-18
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NVDS

Data Backup 5-118
Data Restore 5-119

O
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OK (button) 3-15
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OPR-LPBK 6-30
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Ordering

Document XVI

P

PASS_VIOLATION 6-39
Password 5-19
Performance

~ monitoring 1-25
Periodical Alarm Deletion 6-9
Platform Alarm 6-35
Plug-in unit

adding 1-25
removing 1-25

Port Information
Application Pack 5-36
Channel Unit 5-44

Port test 6-24
Port test result 6-25
Power Test Units 5-4
Print reports 3-21
Product safety

Classification XV
Programs (workspace menu) 3-13
protection

forced switching 5-60
inhibit switching 5-60
manual switching 5-60
side switching 5-605-60

5-60
5-60
5-60

6-38
6-35 3-13

5-17 XV
5-17

5-55 3-21
5-4

6-25
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5-44
5-36
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3-16
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XVI6-13
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5-119
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6-30
6-30 6-35

1-19
3-3 3-18
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Protection Switching
COMDAC 5-62
IO-DS1 5-65
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network 1-20

Pushbutton 3-14

Q

Quitting the Alarm Viewer 6-11

R

Radio button 3-15
Reaction

to fault identification 1-23
Recovery 1-23
Refresh (workspace menu) 3-13
Remote Operations Channel (definition) A-2
Remote Operations Channel protocol profiles A-4
Remote Operations Channel, protocol A-4
Repetitive Alarm 6-8
Restart Workspace Manager (workspace menu) 3-13
Restore (database) 3-23
Restore command 3-26
Return key 3-6
RLS-LPBK 6-30
ROC over Semi Permanent Leased Lines (DCN) A-5
Router (definition) A-2

S

Safety
Classification XV

SCHED-EX 6-28
screen navigation

equipment configuration 5-14
Semi Permanent Leased Line (definition) A-2
Server application

Definition 3-17
restart 3-18
shut-down 3-19
start options 3-17
start-up 3-19

Server applications
Alarm management 3-18
Configuration management 3-18
Network element management 3-18
System core 3-18

Server applications of AEM 3-18

Server applications start-up via a command line 3-20
Shelf protection

COMDAC 5-60
IO-DS1 5-63

Shelf view 5-23
Shuffle Up/Down (workspace menu) 3-13
Software

~ installation 1-19
copy 5-116
download 5-113
upgrade 5-113

Sorting Alarms 6-17
Spin box 3-15
sreen navigation

service provisioning 5-71
Standby card test scheduling 6-28
Status Bar 5-9, 5-11
Sub NetworkController 5-122
SWVR_ILLEGAL 6-40
Synchronization

alarm data 6-33
configuration data 6-32

System
~ security 1-26

System Administration application 3-18
System core 3-18
System Internal Events 1-12, 3-32
System management functions 6-18

T

Tab 3-15
Target ID 5-19
TCP/IP_CON_REFUSED 6-40
Terminating the Alarm Viewer 6-11
Testroutines

Access to the ~ 6-23
AP card test 6-26
AP card test result 6-27
Built-in self-test 6-29
Loopback test 6-29
Port test 6-24
Port test result 6-25
Result of standby card test scheduling 6-28
Standby card test scheduling 6-28

Text box 3-15
timing source 5-52
timing source control

primary source 5-53
secondary source 5-54
synchronization mode 5-53

TL1_COMM_DENIED 6-41
Trademarks XII
TST-ANALG 6-24, 6-263-18 6-24 6-26

3-18 XII
3-18 6-41

3-18 5-53
3-18 5-54

5-53
3-19

3-17 5-52
3-19 3-15

3-18 6-28
3-17 6-28

6-25
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5-14 6-29
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3-6
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A-4 3-18
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1-23
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5-9 5-11
6-28
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3-15
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5-113
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U

Unassign
~ controlled objects from domains 4-14
~ user groups access from applications 4-25
~ user groups access from domains 4-25
~ user groups access from tasks 4-26
~ users from user groups 4-6

User
Create ~ 4-2
Delete ~ 4-6
Modify ~ 4-4

User administration 4-1
User group

Create ~ 4-17
Delete ~ 4-26
Modify ~ 4-22

W

Window controls 3-7, 3-8
maximize button 3-9
menu bar 3-9
minimize button 3-8
scroll bar 3-9
title bar 3-8
window frame 3-8
window menu 3-9

Window controls, AEM-NB windows 3-13
Window menu 3-10

Close 3-10
Lower 3-10
Maximize 3-10
Minimize 3-10
Move 3-10
Restore 3-10
Size 3-10

Windows, basics 3-7
Workspace manager 3-12
Workspace menu 3-12

Log out 3-13
Minimize/Restore Front Panel 3-13
Programs 3-13
Refresh 3-13
Restart Workspace Manager 3-13
Shuffle Up/Down 3-13

X

X.25 DCN A-9

3-13
3-13

3-13
3-13

3-13
3-13

3-12
3-12

3-7
3-10

3-10
3-10

3-10
3-10

3-10
3-10

3-10
3-13

3-9
3-8

3-8
3-9

3-8
3-9

3-9
3-7 3-8

4-22
4-26
4-17

4-1
4-4
4-6
4-2

4-6
4-26

4-25
4-25

4-14

A-9

X

XIII
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