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1. Glossary 
The following list provides definitions of terms and abbreviations used in this user manual: 

ARK CLS   Geoscience software development company. 

CmAct  Security method by WIBU Systems, software (file-)based. 

CmContainer CodeMeter Container. A locally connected CmDongle or a CmAct file 

on your computer. 

CmDongle   Security method by WIBU Systems, USB Dongle. 

CodeMeter Control Center Graphical User Interface (GUI) of the CodeMeter Runtime. 

CodeMeter Runtime Software package by WIBU Systems, the interface between one or 

more licenses (CmAct or CmDongle), the user and the protected 

software.  

Daemon A program or process that sits idly in the background until it is 

invoked to perform its task. 

INPEFA INtegrated Prediction Error Filter Analysis. Method patented by 

ENRES International for making stratigraphic correlations using well 

data. 

INPEFA curve   Curve visualizing INPEFA results. 

Licensor   Program by ENRES International to obtain license(s). 

MD    Measured Depth. 

Petrel A Schlumberger owned software application intended to aggregate 

and interpret geoscience data from multiple sources. 

Plug-in A plug-in is a software component that adds a specific feature to an 

existing software application, in this case Petrel. 

Ticket number   Alphanumerical string of characters needed to obtain licenses. 

WIBU Systems   Supplier of security and licensing products. 

  

http://en.wikipedia.org/wiki/Software_component
http://en.wikipedia.org/wiki/Software_application


 

2.  Introduction 
Geophysical well log data contain highly detailed information on rocks and reservoirs in the 

subsurface. Correlation of these data is a widely adopted tool for improving subsurface models. 

However, robust well correlation frameworks are still hard to obtain, especially in the absence of 

additional constraints, such as bio- and chemostratigraphic data.  

INtegrated linear Prediction Error Filter Analysis (INPEFA) provides a different approach to 

geophysical well log correlation, it focusses on the discontinuities within these data.  

INPEFA visualizes discontinuities in a curve, the INPEFA curve.  Discontinuities in well log data can 

geologically be interpreted as hiatuses, unconformities, abrupt changes in sedimentation rate and 

/or abrupt changes in lithology. Since these are basin wide occurring events, they provide ideal levels 

for well correlation. INPEFA curves are very helpful in generating robust exploration to reservoir scale 

well correlations in a timely manner. In addition, they reduce the need for additional constraints. 

This INPEFA Plug-in for Petrel allows Petrel users to perform INPEFA on geophysical well log data. 

Following is a description of how to install the plug-in and a description of its features. 

 

  



 

3. Installation and license activation 
There are two different scenarios for installation of the INPEFA plug-in. One scenario is stand-alone 

installation with or without a connected USB-dongle, the other is network installation. Installation 

requirements for both scenarios are summarized in the table below.   

Table 3.1. Requirements for INPEFA Plug-in installation  

Requirement Description/notes 

Petrel software Installation See release notes for supported versions 

Codemeter runtime  v5.00 or higher is required 

ENRES International ticket 
number 

A ticket number consists of 25 alphanumerical characters  

Suitable license type Either CmAct or CmDongle. For network installation an USB 
dongle is required. 

Internet connection  

No previously installed 
versions of the INPEFA Plug-In 
for Petrel 

Uninstall previously installed versions of the INPEFA Plug-in 
for Petrel 

INPEFAPluginLicensor bundle 
(archive) from ENRES 
International 
 

Only for network deployment 

Microsoft Windows on the 
license server(s). 

Only for network deployment. See 7. Troubleshooting if 
license servers run on a different operating system. 
 

 

3.1 Stand-alone installation 
Installation and license activation for stand-alone users consists of the following steps: 

1) Check if the requirements of the table above are met. 

2) Make sure that the edition of the installer for the Plug-in (msi installer file that was provided by 

ENRES International) matches the licensing option that was selected at time of purchase. There 

are two different editions of the installer, a software based licensing installer (CmAct) or a USB-

dongle based licensing installer (CmDongle) 

3) Run the msi installer and follow the instructions. 
4) Start Petrel and view the INPEFA  plug-in by: 

a. (Petrel 2013 and earlier): going to the Processes pane (View->Panes->Processes), 
opening the ENRES folder (see figure 3.1), and double clicking the INPEFA Log Transform 
process.  

b. (Petrel 2014 and later): going to the Stratigraphy ribbon bar tab and clicking the INPEFA 
button in the ENRES group (see figure 3.2). 



 
Figure 3.1. Petrel Processes Pane. 

 
 

 
Figure 3.2. Petrel ribbon bar. INPEFA is located on the right in the ENRES group. 

 
 

5) In the plug-in dialog, go to the ‘About’ tab (figure 3.3) 

 

 
Figure 3.3. About tab of the INPEFA plug-in. 

 

6) Click on the ‘License activation button’ to start the ‘INPEFA Plug-in Licensor’ (figure 3.4). 

  



 

 
 

Figure 3.4. Start-up window Licensor. 

 

(The following steps also apply for license server deployment) 

 

7) Click on the ‘Next’ button in the starting window of the INPEFA plug-in licensor (figure 3.4).  

 

 

Figure 3.5 Window for entering an ENRES International ticket number. 

 



 

8) Enter a valid ENRES International ticket number and click on the ‘Next’ button (figure 3.5). 

9) Only if a proxy address is configured on the client machine, which needs user credentials, the 

following pop-up menu appears (figure 3.6): 

 

 
 

Figure 3.6 Pop-up message when a proxy server is installed. 

Enter the credentials and continue with the step 10, or continue with step 10 directly if no proxy 

address is configured on the client machine. 

 

10) Review the list of available licenses (figure 3.7). Choose the license(s) you wish to activate. 

Usually only one license is available for retrieval. Choose a suitable CmContainer from the 

dropdown menu, or have one created automatically. If you have received a CmDongle from 

ENRES International, please connect it to your machine. Click on the ‘Refresh’ button to get the 

suitable CmContainer. 

 

 
Figure 3.7. INPEFA Plug-in licensor displaying a list of available licenses. 

 

 



11) Click on the ‘Finish’ button. The licensor will collect the selected license(s) and show a dialog of 

the status. The process could take up to a minute depending on network speed. Successful 

activation of the license is indicated by ‘Activation process successfully finished’ in the Activation 

Results of the dialog and a pop-up message (figure 3.8). 

 

 

Figure 3.8. INPEFA Plug-in licensor displaying activation results. 

12) Close the INPEFA Plug-in licensor by clicking on ‘Close’ (figure 3.8). License activation is now 

completed. 

 

3.2 Network Installation 
Installation of the INPEFA plug-in in a network environment consists of: 

1) License server deployment 

2) Client installation and configuration 

3.2.1 License server deployment 
1) Check if the requirements of  table 3.1 are met. 

2) Extract the INPEFAPluginLicensor bundle (archive) holding ‘INPEFAPluginLicensor.exe’ and 

associated files. 

3) Start the executable  ‘INPEFAPluginLicensor.exe’ 

4) Follow installation steps 7 to 12 as described in: 3.1 Stand-alone installation. 

5) Check the license list via the CodeMeter Control Center or via the webadmin using a web 

browser (usually at http://localhost:22350). Go to ‘Content’ -> ‘Licenses’ to view all 

CmContainers and the licenses they contain. 

6) Enable server functionality by going to Configuration’ -> ‘Server’ and check the box ‘Run Network 

Server’ (see figure 3.9). This starts the CodeMeter daemon on the LAN on port 22350 (the IANA 

officially registered port for CodeMeter communication). 

 

http://localhost:22350/


 
Figure 3.9. Codemeter Server tab within Codemeter Configuration, showing network license server 

configuration. 

3.2.2 Client installation and configuration 
Installation requirements for Clients are identical to those for stand-alone installation (See:  3.1 

Stand-alone installation) except that Clients do not have a ticket number since they do not need a 

license locally. CodeMeter Runtime installed on the client will automatically search the network for 

an available license. See 6. Troubleshooting if this is not the case. 

Installation of the INPEFA plug-in for Clients consists of the following steps: 

Steps 1 to 4 as outlined in 3.1 Stand-alone installation. 



4. Uninstallation 
Before uninstalling, close all running Petrel software applications. The INPEFA plug-in can be 
uninstalled by using the standard operating system ‘Programs and Features’ utility. Alternatively, run 
the msi installer that was provided by ENRES International for installation and select the ‘Remove’ 
option. 
 

 

5. Functionality of the INPEFA Plug-in 
After installation of the plug-in (See:  3.  Installation and license activation), Petrel can be started and 

the INPEFA plug-in can be viewed (see figures 3.1 and 3.2): 

In Petrel 2013 and earlier: 

o Go to the Processes pane (View->Panes->Processes) 

o Open the ENRES folder 

o Double-click the INPEFA Log Transform process to start the plug-in. 

 

In Petrel 2014 and later: 

o On the Home tab of the ribbon bar, select the Seismic to Simulation perspective 

o Select the Stratigraphy ribbon bar tab 

o Click the INPEFA button on the ribbon bar 

 

The INPEFA log transform dialog contains three tabs, the Input tab, the Settings tab and the About 

tab. 

5.1 Input tab 
The input tab is subdivided into three sections: the Input log section, Output log section and the 

Input wells section (see figure 5.1). 



 

Figure 5.1. Input tab of the INPEFA plug-in. 

 

5.1.1 Input log section 
Here, the global well log which serves as input for INPEFA log transformation can be selected. 

Selection is done by either drag & drop of the input log from the workspace, or by selecting the log in 

the workspace and clicking the  arrow. Only a continuous log can be used as input, and logs with 

regular sampling are recommended. 

5.1.2 Output log section 
The output log section serves to define the name of the INPEFA curve that is generated. Its 

dropdown menu contains three menu items: Auto, Existing and Name: 

‘Auto’. Selecting ‘Auto’ from the dropdown menu will provide the generated INPEFA curve with the 

name of the input log (see 5.1.1) extended with ‘INPEFA’.  For example, an INPEFA curve generated 

from an input log named ‘GR’ will be named ‘GR INPEFA’ when the ‘Auto’ menu item is selected. 

‘Existing’. Selecting ‘Existing’ from the dropdown menu will provide the generated INPEFA curve with 

the name of an existing global well log. For example, if a global well log named ‘GR INPEFA’ exists, it 

can be selected by selecting the log in the workspace and clicking the  arrow. Any existing global 

log (e.g. GR INPEFA) that occurs within the well selection and whose name matches that of the 

output global well log name will be overwritten by the newly generated INPEFA curve. 

‘Name’. Selecting ‘Name’ from the dropdown menu will provide the generated INPEFA curve with 

the name that can be specified in the textbox below the dropdown menu. Any existing global log that 

occurs within the well selection and whose name matches that of the name specified in the textbox 

log will be overwritten by the newly generated INPEFA curve. 



5.1.3 Input wells section 

This section displays logs from the wells selected in the tree (empty in figure 5.1). 

 

5.2 Settings tab 
The settings tab is subdivided into four sections: Top limit, Base limit, Settings and Options (figure 

5.2). 

 

Figure 5.2. Settings tab of the INPEFA plug-in. 

 

5.2.1 Top limit section 
The Top limit sections allows the user to specify the top boundaries of stratigraphic intervals, used 

for the generation of INPEFA curves.  It consists of a dropdown menu, ‘Well top or surface’ input 

field, a ‘Depth (MD)’ input field and an ‘Interval above top limit’ input field. 

5.2.1.1 Dropdown menu 

The dropdown menu of the Top limit section allows specification of one of the following types of 

limit: ‘Log top’, ‘Well top’ or ‘Depth’: 

‘Log top’. Selecting this item from the dropdown menu will set the top limit that is used for INPEFA 

calculation at the shallowest data point contained within the selected well log.  

‘Well top’. Selecting this item from the dropdown menu will set the type of top limit that is used for 

INPEFA calculation as a predefined level, i.e. a ‘Well top’ or ‘surface’. The exact well top or surface 

can be selected further down in the ‘Well top or surface’ input field that is enabled upon selection of 

the ‘Well top’ menu item.  

‘Depth’. Selecting this item from the dropdown menu will set the type of top limit that is used for 

INPEFA calculation as a depth. The exact depth can be specified further down in the ‘Depth (MD)’ 

input field that is enabled upon selection of the ‘Depth’ menu item.  



5.2.1.2 ‘Well top or surface’ input field 
This input field is enabled upon selection of the ‘Well top’ menu item in the dropdown menu (see 

above). It allows selection of a predefined level. i.e. a ‘Well top’ or ‘surface’. An example of a well top 

could be ‘Top_Cretaceous’.  Well tops or surfaces can be selected in the workspace and clicking the

 arrow 

5.2.1.3 ‘Depth (MD)’ input field 
This input field is enabled upon selection of the ‘Depth’ menu item in the dropdown menu (see 

above). It allows specification of the exact depth where INPEFA generation will start. 

5.2.1.4 ‘Interval above top limit’ input field 
The ‘Interval above top limit’ input field is enabled upon selection of the ‘Well top’ menu item in the 

dropdown menu (see above). It allows specification of an optional interval (in MD) that needs to be 

added above the well top or surface that is selected for INPEFA generation.  

 

5.2.2 Base limit section 
The Base limit section allows the user to specify the bottom boundaries of stratigraphic intervals, 

used for the generation of INPEFA curves.  Its constituent parts are analogous to those of the Top 

limit section and need no further explanation here. 

Note: Undefined log values (e.g. NULL values) at the top or base of the defined range will not be used 

for INPEFA generation. Undefined log values within the data will be interpolated. 

5.2.3 Settings section 
The Settings section consists of the input field for ‘processing window length’. The INPEFA log 

transform makes use of a moving window, whose size can be specified here. The processing window 

length needs to be specified in log measured units, i.e. m or ft. Values below 3m or 10ft are not 

recommended for INPEFA generation. 

5.2.4 Options section 
The options section consists of an ‘Overwrite without prompting’ checkbox. A log can be overwritten, 

depending on the name provided to the output log (see 5.1.2 ‘Output log section’). Therefore, a 

warning prompts each time before a log is overwritten. By checking the box, this warning is 

bypassed.  

 

5.3 About tab 
The ‘About’ tab is subdivided into two sections: the About section and the Licensing section (figure 

5.3). The about section is self-explanatory, the Licensing section will be discussed below. 



 

Figure 5.3. About tab of the INPEFA plug-in. 

 

5.3.1 License status 

The licensing status can be either ‘allocated’ or ‘unallocated’. The former means that a license for the 

plug-in has been made available for use as long as Petrel remains open. In the latter case, a license 

for the plug-in may not be available because it has not yet been used during this session, the 

available number of licenses is already in use, the license has expired or no license has been 

purchased.  

 

5.3.2 License type 

The type of the license required by the plug-in is set at installation time. This may be one of two 

types: 

1) CmDongle: The license is tied to a dongle that must be present on the local machine or on the 

network in order to enable the license. 

2) CmAct: The license is tied to the local machine and no dongle is required in order to enable the 

license. 

 

5.3.3 License activation 
This button can be used to activate or update the plug-in license, or to enter a license ticket number 

issued by ENRES International. See for how to activate a license 3. Installation and license activation. 

5.3.4 ‘Get license’ button 
 The license will not normally be allocated until the plug-in is used to make calculations. If required, 

use this button to check and allocate the license in advance. 



6. Troubleshooting 
How do I obtain a version of CodeMeter 5.00 or higher? 
If you have not previously installed CodeMeter 5.00 or higher, you can download and install it for 
free at http://www.wibu.com/downloads-user-software.html . Alternatively, you can obtain the 
installer through ENRES International (See:  8. Contact) 
 

How do I uninstall a version of CodeMeter older then version 5.00? 

To uninstall a version of CodeMeter older then version 5.00, the following steps need to be taken: 

1. Close all running instances of Petrel. 
2. Open the CodeMeter Control Center using the start menu: Start->All Programs-

>CodeMeter->CodeMeter Control Center 
3. Check which version of CodeMeter Runtime you have, using the menu option Help-

>About. 
4. Stop the CodeMeter service with menu option Process->Stop CodeMeter Service 
5. Close the CodeMeter Control Center with File->Quit 
6. Uninstall the old version of CodeMeter using Windows control panel Programs and 

Features to remove “CodeMeter Runtime Kit”. 
 

I do not have a valid Petrel license available. How can I obtain a license for the INPEFA plug-in? 
You can run the ‘INPEFA plug-in Licensor’ program manually and follow installation steps 1 to 12. The 

licensor program is located in your Petrel installation directory at  

C:\Program Files\Schlumberger\Petrel 201X\Extensions\ENRES INPEFA Log 

Transform_201X.X.XXXX.X\INPEFAPluginLicensor.exe   

(Replace X’s with appropriate version of Petrel and plug-in versions). 

I do not have Microsoft Windows running on my license server(s). How do I install the INPEFA plug-
in license(s)? 
Please contact ENRES International (see 8. Contact) to discuss a customized server installation (e.g. 
MAC OS, Linux or Solaris). 
 
CodeMeter runtime installed on the client cannot find the network license server automatically. 
How can I direct the Client to the correct server? 
In some cases, especially when firewall restrictions do not permit client-machines (workstations) to 
search the network, or when network latencies cause the search to timeout before the correct 
license server is found. You can manually specify a ‘Server Search List’ on each client, directing the 
client to the correct server by either IP address or Server name. This is done via ‘Configuration’ -> 
‘Network’ from the Webadmin on the client machine (figure 6.1). 
 

http://www.wibu.com/downloads-user-software.html


 

Figure 6.1. Network tab within CodeMeter Configuration. 

The application is not behaving as expected 
Check the Message log pane in Petrel for possible error messages (View->Panes->Message log). 
These provide you information on how to solve the problem and are usually self-explaining. Most 
commonly, you’ve selected processing for a certain log family, if some wells don’t have this log 
available this will be displayed in the ‘Message log’. When selecting well-tops, these need to be 
present in each of the wells too. If you’re not able to resolve the problem, please contact ENRES 
International (See: 8. Contact). 
 
The tool items are missing from the Stratigraphy ribbon bar or Processes pane 
The plug-in is shown as disabled in the Ocean Plug-in Manager dialog (if present), but attempts to 

enable it as described in 5. Functionality of the INPEFA Plug-in fail: the Petrel security settings may be 

preventing the plug-in from being loaded. Try changing the plug-in security settings: open the Ocean 

Plug-in Manager dialog (File->Options->Plug-in manager (Petrel 2014 and later) or Help->Ocean 

Plug-in Manager (Petrel 2013 and earlier), see figure 6.2), click on the Security tab. If you’re running 

the Ocean Plug-in Manager on the High security setting, you’ll need to add ARK CLS as a trusted 

publisher. Click ‘Add trusted publisher’ to do so. Alternatively, you can select a lower security level 

like Medium or Low. You’ll have to restart Petrel for any security changes to take effect. If the Ocean 

plug-in manager does not have a security tab, then consult your system administrator or the Petrel 

installation guide. 

 
 



 

Figure 6.2. Security settings in the Ocean Plug-in Manager. 

Error ‘Firmware version not supported’ 
When using a USB dongle (CmDongle) to hold your INPEFA Log Transform plug-in license, you get an 
error ‘Firmware version not supported’ and are not allowed to run the plug-in (or allocate the 
license). This is usually the case when you’ve used a different CmDongle than provided by ENRES, 
running with outdated firmware. You can upgrade your CmDongle firmware (for free) by running the 
program cmu32.exe, usually located in C:\Program Files (x86)\CodeMeter\Runtime\bin. Use the 
parameter /d to upgrade the CmDongle firmware: cmu32.exe /d 
Only connect the CmDongle holding the INPEFA Log Transform plug-in license, since it will try to 

upgrade all connected CmDongles. 

 
 

  



7. Release notes 
Version 2014.1.5462, 15 December 2014 

 Released for Petrel 2014.x and 2013.x 

 In Petrel 2014, the plug-in is now opened from the Stratigraphy ribbon bar 

 INPEFA is no longer available in the workflow editor 
 

Version 2012.2.5144, 31 January 2014 

 Improved licensing installation and management 

 Revised documentation version 27 January 2014 

 Released for Petrel 2012.x and 2011.x 

 Second release candidate 
 

Version 2012.1.4869, 1 May 2013 

 Second alpha release 

 Improved help, but work still to do. 

 Bugs 1-4 resolved 

 Features requests 1-3, 5-11 added 

 Licensing still incomplete 

 Released for Petrel 2012.x and 2011.x  
 

Version 2012.1.4850, 12 April 2013 

 First alpha release 

 All calculation functionality now in place, but help and licensing still need plenty of work. 

 Released for Petrel 2012.x and 2011.x  
 

 

8. Contact 
 
It is very important for ENRES International to answer your questions and constantly making our 
software and documentation better using your suggestions.  
  
Our normal office hours are CET, from 9am to 5pm, Monday to Friday. 
  
Contact our support team at: support@enresinternational.com, or call: +31 (0) 30 227 0137 
  



9. Copyright notices and disclaimers 
Trademark Information 

INPEFA and ENRES International are registered trademarks of ENRES International.  

Petrel is a trademark of Schlumberger.  

ENRES Energy Resources International BV acknowledges the trademarks of third parties used within 

this document. 

10. Patent Information 
The accompanying product is protected by patents held by ENRES International. 

Copyright © 2014 ENRES International BV. All rights reserved 
 
ENRES International BV 
Euclideslaan 201 
3584 BS Utrecht 
The Netherlands 
 
No part of this document may be reproduced or transmitted in any form or by any means, electronic 
or mechanical, for any purpose, without the express written permission of ENRES International. 
Under the law, reproducing includes translating into another language or format. As between the 
parties, ENRES International retains title to, and ownership of, all proprietary rights with respect to 
the software contained within its products. The software is protected by copyright laws. Therefore, 
you must treat the software like any other copyrighted material (e.g. a book or sound recording). 
Every effort has been made to ensure that the information in this user guide is accurate. ENRES 
International is not responsible for printing or clerical errors. Information in this document is subject 
to change without notice. 
 


