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Important Information
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National Instruments believes that the information in this document is accurate. The document has been carefully reviewed

for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to

make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult
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Copyright
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The following conventions are used in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.
This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.
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System Requirements
and Installation

This chapter lists system requirements and installation instructions and
introduces the IMAQ Vision Builder environment.

System Requirements

To run IMAQ Vision Builder, you must have the following minimum
system requirements:

Personal computer using at least a 133 MHz Pentium or higher
microprocessor (233 MHz Pentium MMX or higher microprocessor
recommended)

Microsoft Windows 2000/N'T/Me/9x. If you are using
Windows NT 4.0, you must have Service Pack 3 or higher installed on
your computer to run IMAQ Vision Builder.

800 x 600 resolution (or higher) video adapter, 65,536 colors (16-bit)
or higher

National Instruments image acquisition (IMAQ) hardware and
NI-IMAQ 2.5 or higher for Windows 2000/NT/Me/9x (if you are
acquiring images)

Minimum of 32 MB RAM (64 MB recommended)

Minimum of 40 MB of free hard disk space

@ Note You need Microsoft Excel 97 or higher installed on your computer to complete a few
steps in the second tutorial.

© MNational Instruments Corporation
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Chapter 1 System Requirements and Installation

Installing IMAQ Vision Builder

@ Note To install IMAQ Vision Builder on a Windows NT or Windows 2000 system, you
must be logged in with Administrator privileges.

1. Insert the IMAQ Vision Builder CD into your CD-ROM drive.

If the CD startup screen does not appear, use Windows Explorer to run
the SETUP . EXE program in the \ Setup directory on the CD.

2. Follow the setup instructions you see on your screen.

By default, the IMAQ Vision Builder installation program creates a new
folder, \Program Files\National Instruments\IMAQ Vision
Builder 6, that contains the following items:

* programfolder—IMAQ Vision Builder.exe, the online help file,
function libraries, and other related program files

* readme.txt—Late-breaking information about IMAQ Vision
Builder

* examples folder—Images and scripts that you need to complete the
example tutorials in this manual

¢ manuals folder—Portable Document Format (PDF) versions of the
IMAQ Vision Concepts Manual, IMAQ Vision Builder Release Notes,
and this manual. You must have Adobe Acrobat Reader installed to
access these documents.

* solutions folder—Example images and scripts

Launching and Exiting IMAQ Vision Builder

To launch IMAQ Vision Builder in Windows, point to
Start»Programs»National Instruments IMAQ Vision Builder 6.
To quit IMAQ Vision Builder, follow these steps:

1. Close any open parameter windows.

2. Save your script and images if you want to keep them.
3. Select File»Exit.

IMAQ Vision Builder Tutorial 1-2 ni.com



Chapter 1 System Requirements and Installation

IMAQ Vision Builder Environment

IMAQ Vision Builder is a tool for prototyping and testing image
processing applications. To prototype your image processing application,
you build custom algorithms with the IMAQ Vision Builder scripting
feature. The scripting feature records every step of your processing
algorithm. After completing the algorithm, you can test it on other images
to make sure it works.

The algorithm is recorded in a Builder file. Builder files are ASCII text files
that list the processing functions and relevant parameters for an algorithm
that you prototype in IMAQ Vision Builder. Using the LabVIEW VI
creation wizard, you can create a LabVIEW VI that performs the prototype
that you created in IMAQ Vision Builder.

@ Note You must have LabVIEW 6.0 or higher and IMAQ Vision 6 for LabVIEW or higher
installed on your machine to use this feature.

Features

For more information on LabVIEW VI creation, see Creating a LabVIEW
VI in Chapter 3, Using Blob Analysis to Analyze the Structure of a Metal.

You can also implement the algorithm defined by the Builder file into any
development environment, such as LabWindows/CVI or Visual Basic,
using the IMAQ Vision machine vision and image processing libraries.

IMAQ Vision Builder offers the following features:

*  Script window—Records a series of image processing steps and the
settings you use for each of those steps. You can run scripts on single
images or image collections (batch processing). You can modify and
save scripts. See Figure 2-4, Thresholded Image, to view a script in the
Script window.

e Image Browser—Contains all of the images currently loaded in
IMAQ Vision Builder. Through the Image Browser, you can select an
image to process by double-clicking on it. See Figure 2-1, Image
Browser, to view images loaded into the Image Browser.

*  Acquisition window—Displays the Interfaces window (IMAQ image
acquisition boards and channels available) and the property pages for
the IMAQ image acquisition board. See Figure 2-5, Acquiring Images
in IMAQ Vision Builder, to view all the elements of the Acquisition
window.

© MNational Instruments Corporation 1-3 IMAQ Vision Builder Tutorial



Chapter 1 System Requirements and Installation

Processing window—Updates the image as you change parameters.
Because this view immediately reflects the changes you have made in
the parameters window, you can continue modifying parameters until
you get the desired result. See Figure 2-2, Processing an Image, to
view an image loaded into the Processing window.

Parameter window—Displays parameters that you can set for an image
processing function. Each IMAQ Vision function available through the
menus has a parameter window in which you set the parameters for
that function. See Figure 2-3, Thresholding an Image, to view an
example of the threshold Parameter window.

Reference window—Displays the original version of the image
(image source) as you manipulate it in the processing window. See
Figure 2-2, Processing an Image, to view an image in the Reference
window.

Tools palette—Displays a collection of tools for selecting regions of
interest (ROIs), zooming in and out, and changing the Image palette.
See Figure 2-4, Thresholded Image, to view the Tools palette.

Solution Wizard—Displays a list of industries and corresponding
quality-assurance tasks that those industries perform. Based on the
task the user selects, the wizard loads an IMAQ Vision-based solution
to the task.

Performance Meter—Estimates how long your script will take to
complete in IMAQ Vision on a given image.

LabVIEW VI Creation—Creates the LabVIEW and IMAQ Vision VI
corresponding to the algorithm you prototype in IMAQ Vision Builder.
Based on the options you select, the LabVIEW VI creation wizard
creates a new VI that implements the image processing steps of the
current script or of a saved script file.

Image Analysis Functions

IMAQ Vision Builder offers several image analysis functions, including
the following:

IMAQ Vision Builder Tutorial

Histogram—Counts the total number of pixels in each grayscale value
and graphs the result

Line Profile—Returns the grayscale values of the pixels along a line
that you draw with the Line Tool from the Tools palette and graphs the
result

3D View—Displays an image using an isometric view. Each pixel
from the image source is represented as a column of pixels in the
3D view. The pixel value corresponds to the altitude.

1-4 ni.com



Chapter 1 System Requirements and Installation

Color Image Processing Functions

IMAQ Vision Builder includes a comprehensive set of functions for
processing and analyzing color images, including the following:

*  Color Operators—Applies an arithmetic operation between
two images or between an image and a constant

*  Color Plane Extraction—Extracts the Red, Green, or Blue plane or the
Hue, Saturation, or Luminance plane of a color image

*  Color Threshold—Applies a threshold to the three planes of an RGB
or HSL image

*  Color Location—Locates colors in an image

*  Color Matching—Compares the color content of one or multiple
regions in an image to a reference color set

*  Color Pattern Matching—Searches for a color template in an image

Grayscale Image Processing and Analysis Functions

IMAQ Vision Builder also includes functions for grayscale image
processing and analysis:

*  Filtering—Functions for smoothing, edge detection, and convolution

*  Lookup Tables—Applies predefined lookup table transformations to
the image to modify the dynamic intensity of regions in the image with
poor contrast

*  Operators—Performs basic arithmetic and logical operations on
images

*  Grayscale Morphology—Modifies the shape of objects in grayscale
images using erosion, dilation, opening, and closing functions

e Threshold—Isolates pixels that interest you and sets the remaining
pixels as background pixels

*  Quantify—Measures the intensity statistics of one or multiple regions
in an image

*  Centroid—Computes the energy center of a grayscale image or area of
interest

© MNational Instruments Corporation 1-5 IMAQ Vision Builder Tutorial



Chapter 1 System Requirements and Installation

Binary Processing and Analysis Functions

IMAQ Vision Builder contains functions for binary processing and
analysis:

Binary Morphology—Performs morphology transformations that
modify the shape of objects in binary images

Invert Binary Image—Reverses the dynamic of an image that contains
two different grayscale populations

Particle Filtering—Filters objects based on shape measurements

Particle Analysis—Computes more than 40 measurements on objects
in an image, including the area and perimeter of the objects

Circle Detection—Separates overlapping circular objects and
classifies them according to their radii

Machine Vision Functions

IMAQ Vision Builder features several machine vision functions, such as
the following:

IMAQ Vision Builder Tutorial

Edge Detection—Finds edges along a line that you draw with the
Line Tool from the Tools palette

Find Straight Edge—Finds points within the edge of an object and then
finds a line describing the edge

Find Circular Edge—Locates the intersection points between a set of
search lines within a circular area (annulus), and then finds the best fit
circle

Clamp—Finds edges within a rectangular ROI drawn in the image and
measures the distance between the first and last edge

Pattern Matching—Locates regions of a grayscale image that match a
predetermined template. Pattern Matching can find template matches
regardless of poor lighting, blur, noise, shifting of the template, and
rotation of the template

Caliper—Computes measurements—such as distances, areas, and
angles—based on results returned from other machine vision and
image processing functions

1-6 ni.com
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Calibration Functions

IMAQ Vision Builder features several calibration functions, including the
following:

*  Simple Calibration—Sets a simple calibration for an image. This
function sets the horizontal and vertical scaling factor, as well as the
origin and orientation of the coordinate system for the image.

*  Grid Calibration—Learns a calibration based on the image of a grid
template acquired with the imaging setup you are calibrating

e Calibration from Image—Applies the calibration information saved in
an image file to the current image

* Image Correction—Transforms a distorted image acquired in a
calibrated setup into an image where perspective errors and lens
distortion are corrected

Getting Help

As you work with IMAQ Vision Builder, you may need to consult other
sources if you have questions. The following sources can provide you with
more specific information about IMAQ Vision, IMAQ hardware, and
imaging.

IMAQ Vision Builder Online Help

IMAQ Vision Builder offers tooltips and online help that you can access in
the following ways:

*  Access the IMAQ Vision Builder online help by selecting Online Help
from the Help menu. There you can find information not available in
this manual, such as function descriptions and directions for
performing image processing functions.

*  Move the cursor over a button to see tooltips on buttons in the
Processing toolbar, Tools palette, Script window, Reference window,
Acquisition window, or Image Browser.

*  Click the Help button in any function parameter window to get
information about that function and its parameters.

© MNational Instruments Corporation 1-7 IMAQ Vision Builder Tutorial
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IMAQ Vision Documentation

If you have purchased IMAQ Vision software from National Instruments,
you also have one of the following sets of documentation, depending on the
development environment you use.

¢ IMAQ Vision for LabVIEW

— IMAQ Vision for LabVIEW User Manual—Contains information
about how to build a Vision application using IMAQ Vision for
LabVIEW.

— IMAQ Vision for LabVIEW online help (from inside the
LabVIEW environment: Help»IMAQ Vision)—Contains
reference information about IMAQ Vision VIs.

¢ IMAQ Vision for Measurement Studio

—  IMAQ Vision for Measurement Studio User Manual:
LabWindows/CVI—Contains information about how to build a
vision application using IMAQ Vision for LabWindows/CVI.

— IMAQ Vision for LabWindows/CVI online help—Contains
reference information about IMAQ Vision for LabWindows/CVI.

—  IMAQ Vision for Measurement Studio User Manual:
Visual Basic—Contains information about how to build a Vision
application using the tools for Visual Basic that come with
IMAQ Vision for Measurement Studio.

— IMAQ Vision for Visual Basic online help—Contains reference
information about the tools for Visual Basic that come with IMAQ
Vision for Measurement Studio.

For detailed information about the concepts and algorithms used by
IMAQ Vision Builder, launch the IMAQ Vision Concepts Manual from the
Start menu (Start»Programs»National Instruments»IMAQ Vision
Builder 6>IMAQ Vision Concepts Manual).

National Instruments Web Site

IMAQ Vision Builder Tutorial

The National Instruments Web site provides information about IMAQ
hardware and software. Visit the site at ni.com/imaq.

From the IMAQ site, you can locate information about new IMAQ Vision
features, machine vision problems and solutions, using MMX technology
on machine vision applications, and selecting the appropriate IMAQ
hardware, cameras, lenses, and lighting equipment for your application.
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The NI Developer Zone at ni . com/zone is the essential resource for
building measurement and automation systems. At the NI Developer Zone,
you can easily access the latest example programs, system configurators,
tutorials, technical news, as well as a community of developers ready to
share their own techniques.

IMAQ Vision Builder Scripts

You installed several example scripts when you installed IMAQ Vision
Builder. You can run these scripts to learn more about IMAQ Vision
Builder scripting capabilities. You also can customize these scripts for
your own applications. By default, the scripts are installed at \ Program
Files\National Instruments\IMAQ Vision Builder
6\Examples and at \Program Files\National
Instruments\IMAQ Vision Builder 6\Solutions.

© MNational Instruments Corporation 1-9 IMAQ Vision Builder Tutorial



Introduction to Image
Processing with
IMAQ Vision Builder

This chapter describes how you can use IMAQ Vision Builder to create and
test your own image processing algorithms. It explains how to get started
in IMAQ Vision Builder. For detailed information about digital images, see
Chapter 1, Digital Images, in the IMAQ Vision Concepts Manual.

Getting Started in IMAQ Vision Builder

This section describes the software-specific terminology that you need

to complete the tutorials in this manual and understand the online help.

The best way to understand how IMAQ Vision Builder works and what
you can accomplish with IMAQ Vision Builder is by using it.

In this short example, you load images into IMAQ Vision Builder and
perform one image processing function—a threshold. Thresholding
isolates objects so that you can keep those that interest you and remove
those that do not. Thresholding also converts the image from a grayscale
image, with pixel values ranging from 0 to 255, to a binary image, with
pixel values of O or 1.

Follow these steps to get started in IMAQ Vision Builder:

1. Launch IMAQ Vision Builder from the Start menu
(Start»Programs»National Instruments IMAQ Vision Builder 6).

2. To load images, select the Open Image button from the Welcome
Screen.

3. Navigate to Program Files\National Instruments\IMAQ
Vision Builder 6\Examples\Metal and check the Select All
Files option. IMAQ Vision Builder previews the images in the Preview
Image window and displays information about the file type and image
depth.

4. Click OK.

© MNational Instruments Corporation 2-1 IMAQ Vision Builder Tutorial



Chapter 2

Introduction to Image Processing with IMAQ Vision Builder

IMAQ Vision Builder loads those image files into the Image Browser,
as shown in Figure 2-1. The Image Browser provides information
about the selected image, such as image size, location, and type.

Builder
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Figure 2-1. Image Browser

You can view new images in either thumbnail view, as shown in
Figure 2-1, or in full-size view, which shows a single full-size view of
the selected image.

5. Click the Thumbnail/Full-Size View Toggle button to view the first
image in full size.
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Chapter 2 Introduction to Image Processing with IMAQ Vision Builder

6. To enter processing mode, double-click the image Metall.jpg.
IMAQ Vision Builder loads the image into the processing window,
as shown in Figure 2-2.
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Figure 2-2. Processing an Image
@ Tip The Reference window displays the original version of the image as you manipulate

it in the Processing window.
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Chapter 2 Introduction to Image Processing with IMAQ Vision Builder

7. Select Grayscale»Threshold. The Threshold parameter window
appears in the lower right corner of the IMAQ Vision Builder window,
as shown in Figure 2-3.
T
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Figure 2-3. Thresholding an Image

The Threshold parameter window displays a histogram. A histogram
counts the total number of pixels at each grayscale value and graphs it.
From the graph, you can tell whether the image contains distinct
regions of a certain grayscale value, and you can select pixel regions of
the image. For example, if the background of an image is black and you
want to remove it, you can select a range with values close to 255
(white).
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The Processing window displays a preview of the threshold operation
using the current set of parameters. The pixels depicted in red have
intensities that fall inside the threshold range. The threshold operator
sets their values to 1. The pixels depicted in gray have values outside
the threshold range. The threshold operator sets their values to 0.

From the Threshold parameter window, specify settings that work best
for your application. To threshold this image, set the Min value to 130
and Max value to 255 to select all of the objects.

Tip You may need to manipulate the parameters several times to find the values that work

best. Rather than entering numbers in the Min and Max fields, you can select the range
using the pointers on the histogram. Adjust the pointers until all of the objects you want to
select are red. The black pointer marks the minimum value, and the white pointer marks
the maximum value.

© MNational Instruments Corporation

Click OK to apply the manual threshold to the image. The image is
converted to a binary image where all of the selected pixels in the
threshold range are set to 1 (red) and all other pixels are set

to 0 (black).
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Refer to Figure 2-4 to see what the image looks like after applying the

threshold.
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Figure 2-4. Thresholded Image

The thresholding step is recorded in the Script window. The script
records the processing operation and all of its parameters. If you need

to run the same operation on other images, you can save the script and
use it again.
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10. Select Script»Save Script and name the script threshold. scr.

If you find another image that you need to threshold similarly, run this
script on the image using the following steps:

a. Load the image.
b. Select Script»Open Script to open threshold.scr.
1 c. Click the Run Script button in the script window.

Try experimenting with different options and images. For example,
you can perform a particle analysis to find the area that each object in
this image occupies. If you need help with any specific image
processing operation, click the Help button in the parameter window.

11. Select File»Exit to close IMAQ Vision Builder.

Acquiring Images in IMAQ Vision Builder

IMAQ Vision Builder offers three types of image acquisitions: snap, grab,
and sequence. A snap acquires and displays a single image. A grab
acquires and displays a continuous sequence, which is useful, for example,
when you need to focus your camera. A sequence acquires images
according to settings that you specify and sends the images to the Image
Browser.

If you have National Instruments IMAQ image acquisition boards and
NI-IMAQ 2.5 or later installed on your computer, you can acquire live
images in IMAQ Vision Builder. For more information on setting up your
boards and channels in Measurement & Automation Explorer (MAX),
see the MAX online help.

If you do not have IMAQ image acquisition boards and NI-IMAQ 2.5 or
later installed on your computer, IMAQ Vision Builder automatically
simulates the acquisition process by displaying a sequence of images. You
can stop the sequence at any frame, capture the image, and send the image
to the Image Browser for processing.

© MNational Instruments Corporation 2-7 IMAQ Vision Builder Tutorial
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Opening the Acquisition Window

If IMAQ Vision Builder is not loaded, launch the application from the
Start menu (Start»Programs»National Instruments

IMAQ Vision Builder 6). Click the Acquire Image button from the
Welcome Screen to view the Acquisition window, as shown in Figure 2-5.

If you already have IMAQ Vision Builder running, click the
Acquire Image button in the toolbar. IMAQ Vision Builder displays the
Acquisition window, as shown in Figure 2-5.

The acquisition plug-in list shows the different modules that you can use to
acquire images:

e Simulation module

e Image acquisition board

The Interfaces window displays all IMAQ image acquisition boards and
channels available for your computer. Figure 2-5 shows that two IMAQ
hardware boards are available—the IMAQ PCI-1408 and the

IMAQ PCI-1424.

@ Note The hardware boards listed in your Interfaces window will vary according to the
boards plugged into your computer.

IMAQ Vision Builder Tutorial
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Figure 2-5. Acquiring Images in IMAQ Vision Builder

The property pages above the Interfaces window list properties available
for the selected board. In Figure 2-5, the IMAQ PCI-1408 is selected.
Because the PCI-1408 can acquire a sequence of images, you can set the
following properties for a Sequence acquisition. For information about the
properties of other IMAQ boards, see your hardware manual and the MAX
online help.

© MNational Instruments Corporation

Number of Frames—Number of frames you want to acquire

Skip Count—Number of frames you want to skip between

acquisitions

Line—Physical trigger line

2-9
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*  Action—Triggering action
— Disabled—Disables triggering
—  Trigger start of acquisition
—  Trigger each image

¢ Timeout—Time, in milliseconds, within which the trigger must occur

@ Note A trigger is any signal that causes or starts some form of data capture.
@ To set any other property of your image acquisition board or your camera,
select the board or channel in the list, then click the MAX button to display

the corresponding MAX property window.

See the MAX online help for more information on the MAX property
windows.

@ Note Your computer must have a National Instruments IMAQ image acquisition board
and NI-IMAQ 2.5 or higher installed before you can acquire live images in
IMAQ Vision Builder.

Snapping an Image (Single Acquisition)

1. Make sure the Acquisition window is open.

2. Click the Acquire Single Image button to acquire a single image with

sl the IMAQ board and display it. This operation is also known as a snap.

@ Note If your computer does not have an IMAQ board, IMAQ Vision Builder simulates the
live acquisition process. You can interact with the simulation module as you would with a
live acquisition.

c_.l 3. Click the Store Acquired Image in Browser button to send the image
& to the Image Browser.

Click Return to return to the Image Browser.

Process the image as you would any other image in IMAQ

Vision Builder. See Chapter 3, Using Blob Analysis to Analyze the
Structure of a Metal, and Chapter 4, Using Gauging

Sfor Part Inspection for examples of processing images in IMAQ
Vision Builder.

Grabbing an Image (Continuous Acquisition)

1. Make sure the Acquisition window is open.
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Click the Acquire Continuous Images button to acquire and display
images in continuous mode at the maximum rate. This operation is also
known as a grab.

Click the Acquire Continuous Images button again to stop the
acquisition and display the last acquired image.

Tip You can acquire a region of interest within the full-sized image. Draw a region of

interest in your image while grabbing it, and the image reduces to that area. You can refine
the acquired area again by selecting another region of interest or return to the full-sized
image by clicking on the image.

4.

Click the Store Acquired Image in Browser button to send the image
to the Image Browser.

Click Return to return to the Image Browser.

Process the image as you would any other image in IMAQ Vision
Builder. See Chapter 3, Using Blob Analysis to Analyze the Structure
of a Metal, and Chapter 4, Using Gauging for Part Inspection, for
examples of processing images in IMAQ Vision Builder.

Acquiring a Sequence of Images

1.
2.

Make sure the Acquisition window is open.
Set the properties for the Sequence property page.

Click the Sequence Acquisition button to acquire a sequence of live
images. A panel describing the status of the Sequence acquisition
appears.

If you set the triggering action property to Disabled, click the
Start Acquisition button to begin acquiring a sequence of images.

Images acquired are automatically sent to the Image Browser.

@ Note If your computer does not have an IMAQ board, IMAQ Vision Builder simulates the
live acquisition process. You can interact with the simulation module as you would with a

live acquisition.

4,

© MNational Instruments Corporation

Click Return to return to the Image Browser.

Process the image as you would any other image in IMAQ Vision
Builder. See Chapter 3, Using Blob Analysis to Analyze the Structure
of a Metal, and Chapter 4, Using Gauging for Part Inspection, for
examples of processing images in IMAQ Vision Builder.
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Using Blob Analysis to Analyze
the Structure of a Metal

This chapter describes blob analysis and provides step-by-step directions
for prototyping a blob analysis application in IMAQ Vision Builder.

What Is Blob Analysis?

Blob analysis consists of a series of processing operations and analysis
functions to produce some information about the blobs in an image. A blob
(binary large object) is defined as a connected region or grouping of pixels
in an image in which all pixels have the same intensity level. In a binary
image, the background pixels are zero, and every non-zero pixel is part of
a binary object.

You perform a blob analysis to find statistical information—such as the size
of the blobs or the number, location, and presence of blob regions. With this
information, you can detect flaws on silicon wafers, detect soldering
defects on electronic boards, or locate objects in motion control
applications when there is significant variance in part shape or orientation.

Tutorial

In this tutorial, you find the area of circular particles in a metal. As you
perform this analysis, IMAQ Vision Builder records all of the processing
operations and parameters in a script. You will run that script on other
images to test your blob analysis algorithm.

To find the total area of circular particles, you will perform the following
image processing steps:

*  Filter the image to sharpen edges and ease the separation of the
particles from the background.

*  Threshold the image to isolate pixels that interest you (the particles).

*  Fill holes that appear in the particles after thresholding.
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Remove all objects touching the border so that you remove partial
particles.

Use a particle filter to find all circular blobs and remove non-circular
blobs.

Perform a particle analysis to find the total area occupied by circular
blobs.

Loading Images into IMAQ Vision Builder

1.

If IMAQ Vision Builder is not loaded, launch the application from
the Start menu (Start»Programs»National Instruments

IMAQ Vision Builder 6). Click the Open Image button from the
Welcome Screen.

If you already have IMAQ Vision Builder running, press the
Open Image button in the toolbar.

Navigate to Program Files\National Instruments\IMAQ
Vision Builder 6\Examples\Metal and check the Select All
Files option. IMAQ Vision Builder previews the images in the
Preview Image window and displays information about the file
format, size, and pixel depth.

@ Tip The Preview Image window displays all selected images in a sequence. To view the
images at a different rate, adjust the slide to the right of the Preview Image window.

Click OK.

IMAQ Vision Builder loads the image files, which represent
microscopic views of pieces of metal, into the Image Browser.
From this collection of images in the Image Browser, you can select
the image that you want to process.

Double-click the first image, Metall.jpg. The image is loaded into
the processing window.

Preparing an Image for Blob Analysis

Before you can separate circular particles from non-circular particles,
you need to prepare the image. To isolate particles of interest, verify that
individual particles are distinct from other particles (that is, there is a gap
between particles) and that the borders of those particles are distinct.

IMAQ Vision Builder Tutorial
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Examining the Image

Examine the image in the processing window. The image is slightly
blurred. Also, the edges of particles are not distinct. Although you can see
these problems from just looking at this image, you may need to use a line
profile in other cases. A line profile returns the grayscale values along a line
that you draw with the Line Tool from the Tools palette. Follow these steps
to examine edges using a line profile:

1. Select Image»Line Profile. The parameter window appears and the
Line Tool from the Tools palette is automatically selected and active.

2. Draw a short segment across a particle, as shown in Figure 3-1.
@ Tip ROIs are context-sensitive, and you can easily adjust their location in the image or the

position of their center points. You can also adjust the position of the ROI in the image by
using the arrow keys.
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Figure 3-1. Using a Line Profile to Examine Edges

In Figure 3-1, the areas labeled 1 represent the edges of the particles.
Notice that the edges of both particles have a slope. The more shallow
the slope, the greater variation you will have in detecting the exact
location of the edge. As you change the threshold level in images with
shallow-sloped particle edges, you could inadvertently change the
shape or size of the particle. In the Filtering the Image section, you use
the Convolution-Highlight Details filter under Grayscale»Filters to
define the edges of the particles and increase the slope.
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The area labeled 2 is a fluctuation in pixel values, which may be caused
by brighter and darker pixels in the center of the particles or it could be
edges of a hole in the particle. Later, you threshold the image to make
all of the pixels in the particles the same pixel value and perform a
morphological operation on the image to fill any holes left in the
particles.

3. Click Close.

Filtering the Image

Filters can smooth, sharpen, transform, and remove noise from an image so
that you can extract the information you need. To sharpen edges, including
the edges of any holes inside a particle, and create contrast between the
particles and the background, follow these steps:

1. Select Grayscale»Filters.

2. Select Convolution-Highlight Details from the Filters list. This
function looks for sharp transitions and highlights edge pixels
according to a kernel to make gaps more prominent. A kernel is a
structure that represents a pixel and its relationship to its neighbors.
For more information about kernels, see Chapter 5, Image Processing,
in the IMAQ Vision Concepts Manual.

Click Apply to add this step to the script.
4. Click Close.

Examining the Results of the Filtering

To confirm that the filter sharpened edges and separated particles, perform
another line profile using the following steps:

1. Select Image»Line Profile.

2. Click and drag to draw a short segment across a particle to examine the
line profile of a particle and its border, as shown in Figure 3-2. The line
profile indicates more defined edges.

3. Click Close.
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Figure 3-2. Using a Line Profile to Examine Particle Edges

Separating Particles from the Background with Thresholding

Thresholding isolates pixels that interest you and sets the remaining pixels
as background pixels. Thresholding also converts the image from grayscale
to binary.

The Threshold parameter window displays a histogram. A histogram
counts the total number of pixels in each grayscale value and graphs it.
From the graph, you can tell whether the image contains distinct regions of
a certain grayscale value, and you can select pixel regions of the image.

Follow these steps to select a range of brighter pixels to analyze:
1. Select Grayscale»Threshold.
2. Select Manual Threshold from the Threshold list.
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3. Select arange of 130 to 255.

Notice that the particles of interest (circular and non-circular) are
highlighted in red. When you apply the threshold, everything
highlighted is set to 1, and all other pixels are set to 0.

@ Tip You can adjust the pointers until all of the particles of interest are red. The black
pointer marks the minimum value, and the white pointer marks the maximum value.

4. Click OK to apply the threshold and add this step to the script.
Figure 3-3 shows the thresholded image. The pixels that you selected
for processing appear red. Unselected pixels appear black.

The image is now a binary image, which is an image composed of
pixels with values of 0 and 1. This image is displayed using a binary
palette, which displays the pixel intensities of an image with unique
colors. All pixels with a value of 0 appear black and pixels set to 1
appear red. The red pixels are now referred to as blobs or particles.
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Modifying Blobs with Morphological Functions

Morphological functions affect the shape of blobs. Each blob or region

in the binary image is affected on an individual basis. Morphological
operations prepare blobs in the image for quantitative analysis such as
finding the area, perimeter, or orientation. Use the following steps to apply
two morphological functions to the image. The first function fills holes in
the particles and the second removes objects that touch the border of the

image.

1. Select Binary»Adv. Morphology.

2. Select Fill holes from the Morphology-Advanced function list.

3. Click Apply to add this step to the script.

4. Select Remove border objects to remove any objects that touch the
border of the image, as shown in Figure 3-4.

5. Click Apply and Close to add this step to the script and close the

Advanced Morphology window.
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Figure 3-4. Modifying Blobs with Morphological Functions
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Isolating Circular Blobs

Use the following steps to define a particle filter that isolates and keeps the
circular blobs and removes the non-circular blobs from the image.

1. Select Binary»Particle Filter.

2. Select Heywood circularity factor from the list of particle filters.
This function calculates the ratio of the perimeter of the blob to the
perimeter of the circle with the same area. The more circular the blob,
the closer the ratio to 1.

3. To find more circular and less oblong blobs, enter a minimum value
of 0 and a maximum value of 1.06 for the parameter range.

4. Select the Keep Objects option to keep circular blobs (and remove
blobs that do not fit in this range).

5. Click OK to add this step to the script. The image now contains only
circular blobs, as shown in Figure 3-5.
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Figure 3-5. Isolating Circular Blobs
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Analyzing Circular Blobs

Now that you have isolated circular blobs, follow these steps to find the
area occupied by them:

1.

Select Binary»Particle Analysis. A results table is displayed with all
of the measurement results.

IMAQ Vision Builder assign numerical labels to each blob. The
first row of the results table lists the numerical label associated with
each blob.

Click the Show/Hide Labels button to view the labels.

@ Tip When you click on a blob, the measurement results for that blob are highlighted in
blue. When you click on the results for a blob, the blob is highlighted in green in the
processing view.

® N ok

To show only the area measurement, click the Choose Measurements
button.

Click None to deselect all of the measurements.

Click Area (unit).

Click OK.

Click Apply to record the particle analysis in the script.
Click Close.

You now have all of the information you need to analyze the structure of
the metal. Remember to include the analysis as part of your LabVIEW,
LabWindows/CVI, or Visual Basic solution. You also can use Microsoft
Excel to analyze the data generated by IMAQ Vision Builder.

@ Tip To send the data to Microsoft Excel, click the Send Data to Excel button in the
Particle Analysis results window.

Testing the Blob Analysis Script

IMAQ Vision Builder Tutorial

1.

The script that you created as you processed this image is a custom
algorithm. To test this algorithm, run it on another image in the collection
using the following steps:

Click the Image Browser button in the Standard toolbar.

2. Double-click the third image, Metal3. jpg.
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Tip Rather than returning to the Image Browser, you can navigate through the images in
the Image Browser from the Reference window. Click the Next Image and Previous
Image buttons until you see the image you want to process and then click the Make Image
b 3 Active button to move that image into the Processing window.

3]

1 3. Click the Run Script button.
Figure 3-6a shows the original image, Metal3 . jpg. Figure 3-6b
shows the image after the blob analysis processing. Notice that two
circular blobs are removed from the image during processing because
they are touching each other. Adjust the thresholding step to separate

particles from each other.

1 Overlapping Circular Blobs

Figure 3-6. Comparing the Original Image to the Processed Image

Click Done to close the Particle Analysis window.

Double-click the Threshold step in the script window to open the
threshold parameters. Figure 3-7 shows Metal3.jpg at the
thresholding step of the script.
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Figure 3-7. Testing the Blob Analysis Script

Adjust the minimum threshold value until the blobs are clearly
separated. A minimum value of 150 works well.

Click Replace.

Click the Run Script button to rerun the script. Notice that only the
circular blobs now appear in the final processed image.

Click Done to close the Particle Analysis window.
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Saving the Blob Analysis Script

Now that you have written a blob analysis algorithm and tested it on
another image, you can save the script to use on similar images. You also
can perform batch processing with this script. See the Analyzing a
Collection of Images with Batch Processing section in Chapter 4, Using
Gauging for Part Inspection, for an example of batch processing in
IMAQ Vision Builder.

1. Select Script»Save Script.

2. Save the script as blob analysis.scr.

Estimating Processing Time

IMAQ Vision Builder can estimate the time, in milliseconds, that

IMAQ Vision will take to process the active image with the open script.
The Performance Meter gives both an estimate of the total time IMAQ
Vision will take to process the image and an estimate of the time each
function within the script will require. Follow these steps to estimate how
many milliseconds IMAQ Vision will use to process Metal3.jpg with
blob analysis.scr:

1. Select Script»Performance Meter. The Performance Meter gives an
estimate of the total time IMAQ Vision will take to run the script.

2. Click Details to view an itemized list of the time IMAQ Vision will
take to perform each function in the script.

3. Click OK to close the Performance Meter.
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Creating a LabVIEW VI

IMAQ Vision Builder features a wizard that creates the LabVIEW and
IMAQ Vision VI for implementing the different steps of your script.
Figure 3-8 shows the VI creation wizard.
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Figure 3-8. LabVIEW VI Creation Wizard

Follow these steps to create your LabVIEW VI:
1. Select Script»Create LabVIEW VI.

@ Note If several versions of LabVIEW and IMAQ Vision are installed on your computer,
the wizard searches your machine and displays a list of the available LabVIEW and
IMAQ Vision versions you can use to create the VI. Select the target version of LabVIEW

in the list, and click Next.

2. Select Current Script to create a VI that performs the algorithm you
prototyped.

Select the Image Source and the Acquisition Type, then click Next.

Select Image File as the Image Source to create a VI to open an image
from your hard disk.
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5. Check the parameters that you want to appear as controls (inputs) and
indicators (outputs) on the front panel of the created VI. Any
unchecked parameters are hard-coded as constants in the diagram.

6. Click Finish to create the VL.

@ Note You must have LabVIEW 6 or higher and IMAQ Vision 6 for LabVIEW or higher
to use the LabVIEW VI creation features of IMAQ Vision Builder.

© National Instruments Corporation 3-15 IMAQ Vision Builder Tutorial



Using Gauging
for Part Inspection

This chapter describes gauging and provides step-by-step directions for
prototyping a part inspection application in IMAQ Vision Builder.

What Is Gauging?

Tutorial

Components such as connectors, switches, and relays are small and
manufactured in high quantity. Human inspection of these components is
tedious and time consuming. Vision systems can quickly and consistently
measure certain features on a component and generate a report with the
results. From the results, you can determine whether a part meets its
specifications.

Gauging consists of making critical distance measurements—such as
lengths, diameters, angles, and counts—to determine if the product is
manufactured correctly. If the gauged distance or count does not fall within
tolerance limits, the component or part does not meet specifications and
should be rejected. Gauging inspection is used often in mechanical
assembly verification, electronic packaging inspection, container
inspection, glass vile inspection, and electronic connector inspection.

In this tutorial, you analyze images of pipe brackets to see if the brackets
meet their physical specifications. A pipe bracket is a metal piece of
hardware used to bolt down long, slender parts, such as a tube of bundled
wires.

Your goal is to measure angles and distances between features on the
brackets and determine if those measurements fall within a tolerance range.
Figure 4-1 illustrates the measurements and the acceptable values for those
measurements.
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178 to 181 degrees Edge 2

Side View

Bracket Distance
362 to 368 pixels

Edge 1
"

Bracket Angl
racket Angie Width Center

Top View

Figure 4-1. Bracket Specifications

Width Center is the center of the bracket’s width. Width Center becomes
the vertex of Bracket Angle. Bracket Angle measures the angle of the arms
of the bracket and determines if the bracket’s arms are aligned properly.
Bracket Distance measures the length in pixels between two manufactured
holes in the bracket. Bracket Distance also determines whether the
bracket’s arch is the appropriate height and curvature.

As you perform this analysis, IMAQ Vision Builder records all of the
processing operations and parameters in a script. You will run that script on
other bracket images to determine which are good and which are defective.
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Chapter 4 Using Gauging for Part Inspection

Loading Images into IMAQ Vision Builder

Perform the following steps to load an image:

1. Launch IMAQ Vision Builder from the Start menu
(Start»Programs»National Instruments IMAQ Vision Builder 6).

2. Select File»Open Image to load images.

Navigate to Program Files\National Instruments\IMAQ
Vision Builder 6\Examples\Bracket and check the

Select All Files option. IMAQ Vision Builder previews the images in
the Preview Image window and displays information about the file
format, size, and type.

@ Tip The Preview Image window displays all selected images in a sequence. To view
the images at a different rate, adjust the slide to the right of the Preview Image window.

4. Click OK to load the image files into IMAQ Vision Builder. From this
collection of images in the Image Browser, you can select the image
that you want to process.

5. Double click the first image, Bracketl.jpg, to load it into the
processing window.

Finding Measurement Points Using Pattern Matching

Before you can compute the measurements, you need to locate features on
which you can base the measurements. In this example, you use pattern
matching to find manufactured holes in a bracket. These holes serve as
measurement points from which you can determine whether the bracket’s
arch is the appropriate height and curvature.

1. Select Machine Vision»Pattern Matching. Make sure the Learn
Template tab is selected.

I:l 2. With the Rectangle Tool, click and drag a box around the left hole in
the image, as shown in Figure 4-2. The selected area, or region of
interest (ROI), will become the template pattern.
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Figure 4-2. Selecting a Template Pattern

3. Click Create from ROI to learn the selected area as the template
pattern. Learning the template takes a few seconds. After
IMAQ Vision Builder learns the template, a save dialog box appears.

4. Navigate to Program Files\National Instruments)\
IMAQ Vision Builder 6\Examples\Bracket.

5. Save the template as template . png. The Pattern Matching parameter
window displays the template image and its path.

Select the Search Template tab.

Set Search Mode to Shift Invariant. Use shift-invariant matching when
you do not expect the matches you locate to be rotated in their images.
If you expect your matches to be rotated, use rotation-invariant
matching.

Check the Sub-Pixel Accuracy checkbox.

9. Set the Minimum Score to 600. A minimum score of 600 ensures that
IMAQ Vision Builder will find matches similar, but not identical, to the
template.

10. Set Number of Matches to 1.

11. With the Rectangle Tool, draw an ROI around the left side of the
bracket, as shown in Figure 4-3. Be sure that the region you draw is
larger than the template image and big enough to encompass all
possible locations of the template in the other images you will analyze.

Drawing a region of interest in which you expect to locate a template
match is a significant step in pattern matching. It reduces the risk of
finding a mismatch. It also allows you to specify the order in which you
want to locate multiple instances of a template in an image.
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12.
13.

14.
15.
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Figure 4-3. Selecting the First Search Area

Once you draw the region of interest, IMAQ Vision Builder
automatically locates the template in the region and displays the score
and location of the match. Notice that the score for the match is 1000.
The score for this match is perfect because you made the template from
the same region of the image.

Click Apply to add this step to the script.

With the Rectangle Tool, draw a region of interest around the right
side of the bracket, as shown in Figure 4-4. IMAQ Vision Builder
automatically locates the template in the region bound by the rectangle
and displays the score and location of the match.

Figure 4-4. Selecting the Second Search Area

The score of the second match is not a perfect 1000, but it is high
enough for you to consider it a match to the template.

Click Apply to add this step to the script.
Click Close.
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Finding Edges in the Image

Before you can compute measurements to determine whether a bracket
meets specifications, you need to detect edges on which you can base the
measurements. The Edge Detector function finds edges along a line that
you draw with the Line Tool from the Tools palette.

1. Select Machine Vision»Edge Detector.

2. Select the Advanced Edge Tool. The Advanced Edge Tool is effective
on images with poor contrast between the background and objects.

3. Select First & Last Edge so that IMAQ Vision Builder finds and
labels only the first and last edges along the line you draw.

4. Set the Contrast to 40. The detection process only returns the first and
last edge whose contrast is greater than 40.

5. Click and drag to draw a vertical line across the middle of the bracket
to find the edges that you can use to calculate Width Center, as shown
in Figure 4-5. IMAQ Vision Builder labels the edges 1 and 2.

@ Tip To draw a straight line, press and hold the <shift> key as you draw the line.

Figure 4-5. Finding the Edges for Bracket Distance

Look at the line profile. The sharp transitions in the line profile indicate
edges. Notice that the number of edges found is displayed under the
line profile.

Click Apply to add this edge detection step to the script.
Click Close to close the Edge Detector window.
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Taking the Measurements

Now that you have found the bracket’s holes and the necessary edges, you
can calculate the center of the bracket’s width, distance between the
bracket’s holes, and angle of the bracket’s arms with the caliper function.
The caliper function is a tool that uses points on the image to calculate
measurements—such as distances, angles, the center of a segment, or the
area—depending on the number of points you have selected on the image.
These points are results of earlier processing steps, such as edge detections
and pattern matching.

Follow these steps to make the measurements:
1. Select Machine Vision»Caliper.

2. In the image, click on points 3 and 4 to obtain the first
measurement—Width Center—which specifies the center of the
bracket’s width.

@ Tip If you have trouble finding the points, click the Zoom In tool in the Tools palette to
magnify the image. Magnification factors are displayed in the lower, left corner of the
processing window. 1/1 specifies 100% magnification (default). 2/1 specifies a slightly
magnified view, and 1/2 specifies a slightly demagnified view.

Tip Instead of clicking on the points in the image, you can double click on the points in
the Points list box to select them. When you select a point, IMAQ Vision Builder places a
check mark next to it.

)

3. Select Center from the Type of Measure list.
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4. Click the Measure button to compute the center of the bracket’s width
and add the Width Center measurement to the results table, as shown
in Figure 4-6.
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Figure 4-6. Using the Caliper Function to Find Width Center

Click Apply to add this step to the script.

Select Machine Vision»Caliper again. The center of the bracket’s
width appears as point 5.

7. Click on points 1 and 2 in the image to find the second
measurement—Bracket Distance—which measures the length
between the manufactured holes in the bracket and determines whether
the bracket’s arch is the appropriate height.

Select Distance from the Type of Measure list.

9. Click the Measure button to compute the distance between the
bracket’s holes and add the measurement to the results table.
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10. Click on points 1, 5, and 2 (in that order) to find the third
measurement—Bracket Angle—which measures the angle of the
bracket’s arms with respect to a vertex at point 5, as shown in
Figure 4-7.

11. Select Angle from the Type of Measure list.

12. Click the Measure button to compute the angle of the bracket’s arms
and add the measurement to the results table.

Figure 4-7 shows the image with Bracket Distance and Bracket Angle
selected on the image and displayed in the results table.
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Figure 4-7. Using the Caliper Tool to Collect Measurements

13. Click Apply to add these caliper measurements to the script and close
the caliper window.

14. Select Script»Save Script and save the script as bracket . scr.
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Analyzing a Collection of Images with Batch Processing

Perform the following steps to run the script as a batch process on
the bracket images and generate a text file containing all of the
measurement data:

1.
2.

Select Script»Batch Processing.

Select Browser from Image Source to process the images stored in the
Image Browser.

The listbox contains all of the steps in the script. You can select any
step in the script and choose options, such as saving that step’s results
to file, displaying results, or opening the parameter window to adjust
the settings on each iteration. For this example, open the caliper
parameter window and save the caliper results to a file.

Select the last caliper entry in the list box.
Check Open Results Panel and Save Results under Analysis Mode.
Click the Setup button and set the following options:

Select One file for all results.

b. Press the Browse button, navigate to the directory where you want
the file saved, and click Select Cur Dir.

c. In the File Name Prefix box, type bracket . txt to give the
results files a consistent name.

Click OK to close the Setup options.
Click Run! to start the batch process.

As batch processing runs, a progress window appears on the left side
of the IMAQ Vision Builder window. The progress window displays
the current process (acquiring an image or processing an image), the
number of times the process has been completed, the starting time, and
an estimation of the time remaining. If you ever need to stop a batch
process, click the Cancel button.

@ Note Because you checked Open Results Panel when setting up the batch processing
parameters, you must click the Done button after the script runs on each image.

8.

When the batch processing completes, click OK.

9. Click Return to exit the Batch Processing window.

The bracket images have been processed and the caliper results stored in a
text file.

IMAQ Vision Builder Tutorial
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Analyzing the Results

Chapter 4 Using Gauging for Part Inspection

As you implement this algorithm in your development environment using
the LabVIEW VI creation feature or the Builder file, remember to include
your analysis. For this example, you can use Microsoft Excel to quickly

analyze the results.

@ Note To complete this part of the tutorial, you must have Microsoft Excel 97 or higher
installed on your computer.

1.
2.

Launch Microsoft Excel.

Open bracket . txt from within Excel to view the results.

The results are labeled and listed in the order in which they appear in the
Image Browser. In this case, images are listed from Bracket1l.jpg to
Bracket6.jpg.

Table 4-1 lists the acceptable ranges for the bracket measurements and the
actual values you might see for the bracket images. Notice that Bracket1,
Bracket2, and Bracket3 are the only ones that meet the specifications.

The bold values for the other brackets indicate which measurements caused
them to fail.

@ Note The results you see in Excel may not match the values in Table 4-1 exactly. However,
the results you obtain should be close enough to the values in Table 4-1 so that Bracket1,
Bracket2, and Bracket3 pass inspection, and Bracket4, Bracket5, and Bracket6

do not pass.
Table 4-1. Bracket Measurement Results

Bracket Bracket Distance Bracket Angle
Number (acceptable range: 362-368 pixels) (acceptable range: 178°-181°)
Bracket 1 363.00 179.8

Bracket 2 364.00 180.3

Bracket 3 363.00 179.7

Bracket 4 349.00 178.5

Bracket 5 339.01 178.4

Bracket 6 359.03 174.8

© National Instruments Corporation
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Technical Support Resources

Web Support

National Instruments Web support is your first stop for help in solving
installation, configuration, and application problems and questions. Online
problem-solving and diagnostic resources include frequently asked
questions, knowledge bases, product-specific troubleshooting wizards,
manuals, drivers, software updates, and more. Web support is available
through the Technical Support section of ni . com

NI Developer Zone

The NI Developer Zone at ni . com/zone is the essential resource for
building measurement and automation systems. At the NI Developer Zone,
you can easily access the latest example programs, system configurators,
tutorials, technical news, as well as a community of developers ready to
share their own techniques.

Customer Education

National Instruments provides a number of alternatives to satisfy your
training needs, from self-paced tutorials, videos, and interactive CDs to
instructor-led hands-on courses at locations around the world. Visit the
Customer Education section of ni . com for online course schedules,
syllabi, training centers, and class registration.

System Integration

If you have time constraints, limited in-house technical resources, or other
dilemmas, you may prefer to employ consulting or system integration
services. You can rely on the expertise available through our worldwide
network of Alliance Program members. To find out more about our
Alliance system integration solutions, visit the System Integration section
of ni.com
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Appendix A

Worldwide Support

National Instruments has offices located around the world to help address
your support needs. You can access our branch office Web sites from the
Worldwide Offices section of ni . com. Branch office Web sites provide
up-to-date contact information, support phone numbers, e-mail addresses,
and current events.

If you have searched the technical support resources on our Web site and
still cannot find the answers you need, contact your local office or National
Instruments corporate. Phone numbers for our worldwide offices are listed
at the front of this manual.
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Glossary

Prefix Meaning Value

p- pico- 10-12
n- nano- 10-°
y- micro- 10-¢
m- milli- 10-3
k- kilo- 103
M- mega- 106
G- giga- 10°
t- tera- 1012

Numbers/Symbols

3D Three-dimensional.

3D view Displays the light intensity of an image in a three-dimensional coordinate

arca

area threshold

arithmetic operators

system, where the spatial coordinates of the image form two dimensions
and the light intensity forms the third dimension.

A rectangular portion of an acquisition window or frame that is controlled
and defined by software.

Detects objects based on their size, which can fall within a user-specified

range.

The image operations multiply, divide, add, subtract, and remainder.

© MNational Instruments Corporation
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Glossary

binary image

binary morphology

binary threshold

bit depth

blob

blob analysis

blurring

BMP

border function

brightness

IMAQ Vision Builder Tutorial

Bit. One binary digit, either 0 or 1.

Byte. Eight related bits of data, an eight-bit binary number. Also denotes
the amount of memory required to store one byte of data.

An image in which the objects usually have a pixel intensity of 1 (or 255)
and the background has a pixel intensity of 0.

Functions that perform morphological operations on a binary image.

Separation of an image into objects of interest (assigned a pixel value of 1)
and background (assigned pixel values of 0) based on the intensities of the
image pixels.

The number of bits (n) used to encode the value of a pixel. For a given n, a
pixel can take 2" different values. For example, if n equals 8-bits, a pixel
can take 256 different values ranging from 0 to 255. If n equals 16 bits, a
pixel can take 65,536 different values ranging from 0 to 65,535 or -32,768
to 32,767.

Binary large object. A connected region or grouping of pixels in an image
in which all pixels have the same intensity level.

A series of processing operations and analysis functions that produce some
information about the blobs in an image.

Reduces the amount of detail in an image. Blurring commonly occurs
because the camera is out of focus. You can blur an image intentionally by
applying a lowpass frequency filter.

Bitmap. Image file format commonly used for 8-bit and color images
(extension BMP).

Removes objects (or particles) in a binary image that touch the image
border.

(1) A constant added to the red, green, and blue components of a color pixel
during the color decoding process. (2) The perception by which white
objects are distinguished from gray and light objects from dark objects.
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C

caliper

chroma
chrominance
circle function

closing

color images

contrast

convolution kernel

D

default setting

definition

digital image

dilation

driver

Glossary

(1) A function in IMAQ Vision Builder that calculates distances, angles,
circular fits, and the center of mass based on positions given by edge
detection, particle analysis, centroid, and search functions. (2) A
measurement function that finds edge pairs along a specified path in the
image. This function performs an edge extraction and then finds edge pairs
based on specified criteria such as the distance between the leading and
trailing edges, edge contrasts, and so forth.

The color information in a video signal.
See chroma.
Detects circular objects in a binary image.

A dilation followed by an erosion. A closing fills small holes in objects and
smooths the boundaries of objects.

Images containing color information, usually encoded in the RGB form.

A constant multiplication factor applied to the luma and chroma
components of a color pixel in the color decoding process.

2D matrices (or templates) used to represent the filter in the filtering
process. The contents of these kernels are a discrete two-dimensional
representation of the impulse response of the filter that they represent.

A default parameter value recorded in the driver. In many cases, the default
input of a control is a certain value (often 0).

The number of values a pixel can take on, which is the number of colors or
shades that you can see in the image.

An image f (x, y) that has been converted into a discrete number of pixels.
Both spatial coordinates and brightness are specified.

Increases the size of an object along its boundary and removes tiny holes in
the object.

Software that controls a specific hardware device, such as an IMAQ or
DAQ device.
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Glossary

E

edge

edge contrast

edge detection

edge steepness

erosion

F

fiducial

function

G

gauging
grayscale image

grayscale morphology

H

histogram

hole filling function

HSI

IMAQ Vision Builder Tutorial

Defined by a sharp change (transition) in the pixel intensities in an image
or along an array of pixels.

The difference between the average pixel intensity before and the average
pixel intensity after the edge.

Any of several techniques to identify the edges of objects in an image.

The number of pixels that corresponds to the slope or transition area of an
edge.

Reduces the size of an object along its boundary and eliminates isolated
points in the image.

A reference pattern on a part that helps a machine vision application find
the part's location and orientation in an image.

A set of software instructions executed by a single line of code that may
have input and/or output parameters and returns a value when executed.

Measurement of an object or distances between objects.
An image with monochrome information.

Functions that perform morphological operations on a grayscale image.

Indicates the quantitative distribution of the pixels of an image per
gray-level value.

Fills all holes in objects that are present in a binary image.

Color encoding scheme in Hue, Saturation, and Intensity.
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HSL

HSV

hue

I/0

image

image border

Image Browser

image definition

image enhancement

image file

image format

image palette

image processing

Glossary

Color encoding scheme using Hue, Saturation, and Luminance information
where each image in the pixel is encoded using 32 bits: 8 bits for hue, 8 bits
for saturation, 8 bits for luminance, and 8 unused bits.

Color encoding scheme in Hue, Saturation, and Value.

Represents the dominant color of a pixel. The hue function is a continuous
function that covers all the possible colors generated using the R, G, and B
primaries. See also RGB.

Input/output. The transfer of data to/from a computer system involving
communications channels, operator interface devices, and/or data
acquisition and control interfaces.

A two-dimensional light intensity function f (x, y) where x and y denote
spatial coordinates and the value f at any point (X, y) is proportional to the
brightness at that point.

A user-defined region of pixels surrounding an image. Functions that
process pixels based on the value of the pixel neighbors require image
borders.

An image that contains thumbnails of images to analyze or process in a
vision application.

See pixel depth.

The process of improving the quality of an image that you acquire from a
sensor in terms of signal-to-noise ratio, image contrast, edge definition, and
SO on.

A file containing pixel data and additional information about the image.

Defines how an image is stored in a file. Usually composed of a header
followed by the pixel data.

The gradation of colors used to display an image on screen, usually defined
by a color lookup table.

Encompasses various processes and analysis functions that you can apply
to an image.
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Glossary

image source
image visualization
imaging

IMAQ

inspection

inspection function

instrument driver

intensity

intensity profile
intensity range

intensity threshold

JPEG

K

kernel

IMAQ Vision Builder Tutorial

Original input image.

The presentation (display) of an image (image data) to the user.

Any process of acquiring and displaying images and analyzing image data.
Image Acquisition.

The process by which parts are tested for simple defects such as missing
parts or cracks on part surfaces.

Analyzes groups of pixels within an image and returns information about
the size, shape, position, and pixel connectivity. Typical applications
include quality of parts, analyzing defects, locating objects, and sorting
objects.

A set of high-level software functions, such as NI-IMAQ, that control
specific plug-in computer boards. Instrument drivers are available in
several forms, ranging from a function callable from a programming
language to a virtual instrument (VI) in LabVIEW.

The sum of the Red, Green, and Blue primary colors divided by three.
(Red+Green+Blue)/3

The gray-level distribution of the pixels along an ROI in an image.
Defines the range of gray-level values in an object of an image.

Characterizes an object based on the range of gray-level values in the
object. If the intensity range of the object falls within the user-specified
range, it is considered an object. Otherwise it is considered part of the
background.

Joint Photographic Experts Group. Image file format for storing 8-bit and
color images with lossy compression (extension JPG).

Structure that represents a pixel and its relationship to its neighbors.
The relationship is specified by weighted coefficients of each neighbor.
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L

labeling

LabVIEW

line profile

logic operators

luma

luminance

machine vision

match score

MB

MMX
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The process by which each object in a binary image is assigned a unique
value. This process is useful for identifying the number of objects in the
image and giving each object a unique identity.

Laboratory Virtual Instrument Engineering Workbench. Program
development environment application based on the programming language
G used commonly for test and measurement applications.

Represents the gray-level distribution along a line of pixels in an image.

The image operations AND, NAND, OR, XOR, NOR, XNOR, difference,
mask, mean, max, and min.

The brightness information in the video picture. The luma signal amplitude
varies in proportion to the brightness of the video signal and corresponds
exactly to the monochrome picture.

See luma.

(1) Mega, the standard metric prefix for 1 million or 10°, when used with
units of measure such as volts and hertz (2) Mega, the prefix for 1,048,576,
or 229, when used with B to quantify data or computer memory.

An automated application that performs a set of visual inspection tasks.

A number ranging from 0 to 1000 that indicates how closely an acquired
image matches the template image. A match score of 1000 indicates a
perfect match. A match score of 0 indicates no match.

Megabyte of memory.

Multimedia Extensions. Intel chip-based technology that allows parallel
operations on integers, which results in accelerated processing of 8-bit
images.
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Glossary

morphological
transformations

neighbor

neighborhood
operations

NI-IMAQ

0

opening

operators

P

palette

pattern matching

picture element

pixel

IMAQ Vision Builder Tutorial

Extract and alter the structure of objects in an image. You can use these
transformations for expanding (dilating) or reducing (eroding) objects,
filling holes, closing inclusions, or smoothing borders. They are used
primarily to delineate objects and prepare them for quantitative inspection
analysis.

A pixel whose value affects the value of a nearby pixel when an image is
processed. The neighbors of a pixel are usually defined by a kernel or a
structuring element.

Operations on a point in an image that take into consideration the values of
the pixels neighboring that point.

Driver software for National Instruments IMAQ hardware.

An erosion followed by a dilation. An opening removes small objects and
smooths boundaries of objects in the image.

Allow masking, combination, and comparison of images. You can use
arithmetic and logic operators in IMAQ Vision.

The gradation of colors used to display an image on screen, usually defined
by a color lookup table.

The technique used to locate quickly a grayscale template within a
grayscale image

An element of a digital image. Also called pixel.

Picture element. The smallest division that makes up the video scan line.
For display on a computer monitor, a pixel's optimum dimension is square
(aspect ratio of 1:1, or the width equal to the height).
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pixel aspect ratio

pixel depth

PNG
proper-closing
proper-opening

pts

Q

quantitative analysis

R

resolution

RGB

ROI

ROI tools

rotation-invariant
matching
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The ratio between the physical horizontal size and the vertical size of the

region covered by the pixel. An acquired pixel should optimally be square,
thus the optimal value is 1.0, but typically it falls between 0.95 and 1.05,

depending on camera quality.

The number of bits used to represent the gray level of a pixel.

Portable Network Graphic. Image file format for storing 8-bit, 16-bit, and
color images with lossless compression (extension PNG).

A finite combination of successive closing and opening operations that you
can use to fill small holes and smooth the boundaries of objects.

A finite combination of successive opening and closing operations that you
can use to remove small particles and smooth the boundaries of objects.

Points.

Obtaining various measurements of objects in an image.

The number of rows and columns of pixels. An image composed of m rows
and n columns has a resolution of mxn.

Color encoding scheme using red, green, and blue (RGB) color information
where each pixel in the color image is encoded using 32 bits: 8 bits for red,
8 bits for green, 8 bits for blue, and 8 bits for the alpha value (unused).

Region of interest. (1) An area of the image that is graphically selected
from a window displaying the image. This area can be used focus further
processing. (2) A hardware-programmable rectangular portion of the
acquisition window.

Collection of tools from the Lab VIEW Tools palette that enable you to
select a region of interest from an image. These tools let you select a point
or line; polygon, rectangle, and oval regions; and freehand lines and areas.

A pattern matching technique in which the reference pattern can be located
at any orientation in the test image as well as rotated at any degree.
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S

saturation

scale-invariant
matching

shift-invariant
matching

smoothing filter

sub-pixel analysis

T

template

threshold

threshold interval

TIFF

Tools palette

IMAQ Vision Builder Tutorial

The amount of white added to a pure color. Saturation relates to the richness
of a color. A saturation of zero corresponds to a pure color with no white
added. Pink is a red with low saturation.

A pattern matching technique in which the reference pattern can be any size
in the test image.

A pattern matching technique in which the reference pattern can be located
anywhere in the test image but cannot be rotated or scaled.

Blurs an image by attenuating variations of light intensity in the
neighborhood of a pixel.

Finds the location of the edge coordinates in terms of fractions of a pixel.

Color, shape, or pattern that you are trying to match in an image using the
color matching, shape matching, or pattern matching functions. A template
can be a region selected from an image or it can be an entire image.

Separates objects from the background by assigning all pixels with
intensities within a specified range to the object and the rest of the pixels to
the background. In the resulting binary image, objects are represented with
a pixel intensity of 255 and the background is set to 0.

Two parameters, the lower threshold gray-level value and the upper
threshold gray-level value.

Tagged Image File Format. Image format commonly used for encoding
8-bit, 16-bit, and color images (extension TIF).

Collection of tools that enable you to select regions of interest, zoom in and
out, and change the image palette.
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value The grayscale intensity of a color pixel computed as the average of the
maximum and minimum red, green, and blue values of that pixel.

VI Virtual Instrument. (1) A combination of hardware and/or software
elements, typically used with a PC, that has the functionality of a classic
stand-alone instrument (2) A LabVIEW software module (VI), which
consists of a front panel user interface and a block diagram program.
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Numerics
3D view, 1-4

A
acquiring images
grab (continuous image), 2-11
opening the Interface window, 2-8, 3-2
region of interest, 2-11
sequence, 2-11
snap (single image), 2-10
acquisition types
grab, 2-7
sequence, 2-7
snap, 2-7
Acquisition window, 1-3
opening, 2-8
acquisiton modules, 2-8
advanced edge tool, 4-6
analyzing blobs, 3-10

batch processing, 1-3, 4-10

binary morphology, 1-6

binary processing and analysis functions, 1-6
circle detection, 1-6
invert binary image, 1-6
particle analysis, 1-6

blob, 3-1

blob analysis
analyzing circular blobs, 3-10
definition, 3-1
estimating processing time, 3-13
examining image, 3-3
filtering, 3-5
introduction, 3-1
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isolating circular blobs, 3-9
modifying blobs with morphological
functions, 3-8
morphology, 3-8
opening images, 3-2
overview, 3-1
particle analysis, 3-10
particle filter, 3-9
preparing images for processing, 3-2 to 3-5
saving the script, 3-13
separating particles from background, 3-6
testing the script, 3-10
thresholding, 3-6
Browser. See Image Browser
Builder file, 4-11

C

calibration from image, 1-7
calibration functions, 1-7
calibration from image, 1-7
grid calibration, 1-7
image correction, 1-7
simple calibration, 1-7
caliper, 1-6, 4-7 to 4-9
centroid, 1-5
Choose Measurements button, 3-10
circle detection, 1-6
circular blobs
analyzing, 3-10
isolating, 3-9
clamp, 1-6
closing IMAQ Vision Builder, 1-2
color image processing functions, 1-5
color location, 1-5
color matching, 1-5
color operators, 1-5
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color pattern matching, 1-5
color plane extraction, 1-5
color threshold, 1-5
color location, 1-5
color matching, 1-5
color operators, 1-5
color pattern matching, 1-5
color plane extraction, 1-5
color threshold, 1-5
continuous acquisition (grabbing
images), 2-11
conventions used in manual, iv
creating a LabVIEW VI, 3-14
customer education, A-1

D

documentation
conventions used in manual, iv
IMAQ Vision manuals, 1-8

E

edge detection, 1-6

edge detector, 4-6

edges, finding in image, 4-6
exiting IMAQ Vision Builder, 1-2

F

features of IMAQ Vision Builder, 1-3
fill holes, 3-8

filtering, 1-5

filtering images, 3-5

find circular edge, 1-6

find straight edge, 1-6

finding edges, 4-6

full-size view (Image Browser), 2-2
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functions
binary processing and analysis
functions, 1-6
calibration functions, 1-7
color image processing functions, 1-5
grayscale image processing functions, 1-5
image analysis functions, 1-4
machine vision functions, 1-6
morphological functions, 3-8

G

gauging
analyzing results, 4-11
batch processing, 4-10
bracket specifications (figure), 4-2
definition, 4-1
finding edges, 4-6
finding measurement points using pattern
matching, 4-3
introduction, 4-1
loading images, 4-3
making measurements, 4-7 to 4-9
overview, 4-1
getting help, 1-7
getting started in IMAQ Vision Builder,
2-1to 2-7
grab, 2-7
grabbing images (continuous
acquisition), 2-11
grayscale image processing and analysis
functions, 1-5
centroid, 1-5
quantify, 1-5
grayscale morphology, 1-5
grid calibration, 1-7
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H

help
IMAQ Vision Builder scripts, 1-9
IMAQ Vision documentation, 1-8
National Instruments Web site, 1-8
online help, 1-7
Heywood Circularity Factor particle filter, 3-9
histogram, 1-4, 2-4, 3-6
in Threshold parameter window, 2-4

I
image acquisition, 2-7
image acquisition. See acquiring images
image analysis functions, 1-4
3D view, 1-4
histogram, 1-4
line profile, 1-4
Image Browser
accessing from the toolbar, 3-11
definition, 1-3
full-size view, 2-2
important elements (figure), 2-2
thumbnail view, 2-2
image correction, 1-7
image processing
entering processing mode, 2-3
getting started in IMAQ Vision Builder,
2-1to 2-7
thresholding images, 2-5
images
loading
for blob analysis, 2-3
for gauging, 4-3
for image processing, 2-3
opening in IMAQ Vision Builder, 2-1
IMAQ hardware, 1-1, 2-7
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Index

IMAQ Vision Builder
acquiring images, 2-7 to 2-12
binary processing and analysis
functions, 1-6
calibration functions, 1-7
color image processing functions, 1-5
environment, 1-3
exiting, 1-2
features, 1-3
getting help, 1-7
getting started, 2-1 to 2-7
grayscale image processing and analysis
functions, 1-5
image analysis functions, 1-4
installing, 1-2
using with LabVIEW, 3-10
using with LabWindows/CVI, 3-10
launching, 1-2
machine vision functions, 1-6
online help, 1-7
sending data to Microsoft Excel, 4-11
system requirements, 1-1
using with Microsoft Excel, 3-10
using with Visual Basic, 3-10
IMAQ Vision documentation, 1-8
installing IMAQ Vision Builder, 1-2
Interface window (acquisition), 1-3
Interfaces window, 2-8
invert binary image, 1-6
isolating circuar blobs, 3-9

L

LabVIEW, 3-10

LabVIEW VI creation, 1-4, 4-11
LabVIEW VI creation wizard, 3-14
LabWindows/CVI, 3-10

launching IMAQ Vision Builder, 1-2
line profile, 1-4, 3-3, 4-6

line tool, 3-3
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loading images
blob analysis, 3-2
gauging, 4-3
image processing, 2-3
lookup tables, 1-5

machine vision functions, 1-6
caliper, 1-6
clamp, 1-6
edge detection, 1-6
find circular edge, 1-6
find straight edge, 1-6
pattern matching, 1-6
magnifying an image, 4-7
manuals for IMAQ Vision, 1-8
Measurement & Automation Explorer
(MAX), 2-7
measurements for gauging. See gauging
Microsoft Excel, using with IMAQ Vision
Builder, 3-10, 4-11
morphology, 3-8

National Instruments Web site, 1-8
National Instruments Web support, A-1
NI Developer Zone, A-1

NI-IMAQ, 1-1, 2-7

0

online help, 1-7
opening images, 2-1, 3-2, 4-3
operators, 1-5

P

Parameter window, 1-4
part inspection, 4-1
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particle analysis, 1-6, 3-10

particle filter, 3-9

particle filtering, 1-6

particles, separating from background with
thresholding, 3-6

pattern matching, 1-6

pattern matching for finding measurement
points, 4-3

Performance Meter, 1-4, 3-13

Preview Image window, 3-2, 4-3

processing mode, 2-3

Processing window, 1-4, 2-3

Q

quantify, 1-5

R

Reference window

definition, 1-4

purpose, 2-3

using to browse images, 3-11
remove border objects, 3-8
Run Script button, 2-7, 3-11, 3-12

S

scripting
batch processing, 4-10
description, 1-3
using example scripts, 1-9
modifying scripts, 3-12
opening scripts, 2-7
Run Script button, 2-7, 3-11, 3-12
saving scripts, 2-7, 3-13
Script window, 1-3, 2-6
testing scripts, 3-10
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scripts
blob analysis script
recording, 3-1
saving, 3-13
testing, 3-10
gauging script
analyzing collection of images, 4-10
saving, 4-9
sample scripts, 1-9
thresholding script, 2-7
Select All Files option, 3-2, 4-3
Send Data to Excel button, 3-10
separating particles from background, 3-6
sequence, 2-7
sequence acquisition, 2-11
Show Labels option, 3-10
simple calibration, 1-7
simulation module, 2-10, 2-11
snap, 2-7
snapping one image (single acquisition), 2-10
Solution Wizard, 1-4
starting IMAQ Vision Builder, 1-2
system integration, by National
Instruments, A-1
system requirements, 1-1

T

taking measurements, 4-7
technical support resources, A-1
testing scripts, 3-10
threshold, 1-5
Threshold parameter window, 2-4
thresholding
manual threshold, 2-4, 3-6
modifying threshold parameters, 3-11
procedure, 2-4
separating particles from background, 3-6
thumbnail view (Image Browser), 2-2
Tools Palette, 1-4
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trigger, 2-10

tutorials
blob analysis, 3-1
gauging, 4-1

U

using the caliper function, 4-7

v

Visual Basic, 3-10

W

Web support from National Instruments, A-1
getting help for IMAQ Vision, 1-8
windows
Acquisition, 1-3
Parameter, 1-4
Processing, 1-4, 2-3
Reference, 1-4, 2-3, 3-11
Script, 1-3, 2-6
worldwide technical support, A-2

z

Zoom In tool, 4-7
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