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LabVIEW  Real-Time Module 
Release Notes
Version 7.1

These release notes provide installation information, references to related 
documentation, descriptions of the new features, and known issues with 
version 7.1 of the LabVIEW Real-Time Module.
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Installation
This section includes information about installing the LabVIEW 
Real-Time Module for ETS Targets and the LabVIEW Real-Time Module 
for RTX Targets.
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LabVIEW Real-Time Module for ETS Targets
(Mac OS) Refer to the LabVIEW Real-Time Module for Mac OS X User 
Manual Addendum for installation instructions.

(Windows 2000/NT/XP) Complete the following steps to install the LabVIEW 
Real-Time Module for ETS Targets on the host computer.

1. Log in to the host computer as an administrator or as a user with 
administrator privileges.

2. Insert the LabVIEW Real-Time Module CD into the CD-ROM drive. 
The LabVIEW Real-Time Module installation program runs 
automatically.

3. Follow the instructions that appear on the screen.

LabVIEW Real-Time Module for RTX Targets
(Windows 2000/XP) Complete the following steps to install the LabVIEW 
Real-Time Module for RTX Targets on the host computer.

1. Log in to the host computer as an administrator or as a user with 
administrator privileges.

2. Install the Venturcom RTX 5.5 Runtime. You might be required to 
update the Hardware Abstraction Layer (HAL) for the host computer 
before installing the RTX 5.5 Runtime. Refer to the Venturcom 
RTX 5.5 documentation for information about updating the HAL and 
for information about installing and configuring the RTX 5.5 Runtime 
on the host computer.

Note The LabVIEW Real-Time Module for RTX Targets supports the Venturcom 
RTX 5.5 Runtime on Windows 2000 or XP.

3. Restart the computer and verify that the host computer performs 
correctly.

4. Insert the LabVIEW Real-Time Module CD into the CD-ROM drive. 
The LabVIEW Real-Time Module installation program runs 
automatically.

5. Follow the instructions that appear on the screen.

Note The National Instruments Device Driver CD does not install components of the 
Real-Time and Embedded category if the LabVIEW Real-Time Module is not currently 
installed. First install the LabVIEW Real-Time Module and then install the Real-Time and 
Embedded drivers from the National Instruments Device Driver CD.
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Hardware Configuration (ETS Only)
National Instruments Measurement & Automation Explorer (MAX) allows 
you to configure RT targets and install software on the targets. Refer to the 
MAX Help for information about configuring and installing software on 
remote systems.

(Mac OS) The Remote System Explorer allows you to configure NI RT 
Series PXI controllers and install software on the controllers. Refer to the 
LabVIEW Real-Time Module for Mac OS X User Manual Addendum for 
information about using the Remote System Explorer to configure and 
install software on RT Series PXI controllers.

After rebooting an RT target with a monitor, the target displays the 
following message to indicate that it successfully loaded the real-time 
operating system:

Welcome to LabVIEW Real-Time 7.1

Related Documentation
The following documents contain information you might find helpful as 
you work with the LabVIEW Real-Time Module:

• Getting Started with the LabVIEW Real-Time Module

• LabVIEW Real-Time Module User Manual

• (Mac OS) LabVIEW Real-Time Module for Mac OS X User Manual 
Addendum

• LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help

• RT Series hardware documentation

• Getting Started with LabVIEW

• LabVIEW User Manual

• LabVIEW Application Builder User Guide

You can search the LabVIEW and LabVIEW Real-Time Module 
documentation from the LabVIEW Real-Time Module Bookshelf, available 
by selecting Help»Search the Real-Time Module Bookshelf in 
LabVIEW.

(Mac OS) PDF links do not work with the Apple Preview viewer. You must 
use Adobe Reader 6.x to view and use the LabVIEW Real-Time Module 
Bookshelf. Refer to the Adobe Systems Incorporated Web site at 
www.adobe.com to download Acrobat Reader.

http://www.adobe.com
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New Features
The LabVIEW Real-Time Module includes the following new features.

Hardware Support and Configuration
• (ETS) NI-DAQmx 7.2 support—NI-DAQmx allows you to 

communicate with and control NI-DAQmx-supported NI data 
acquisition devices.

• (ETS) RT target Ethernet configuration in MAX—Use the Advanced 
Ethernet Settings dialog box in MAX to configure advanced Ethernet 
settings for an RT target. Refer to the MAX Help for information about 
the Advanced Ethernet Settings dialog box.

• (ETS) 1394 external hard drive support—You can use a 1394 external 
hard drive as a second drive.

• (ETS) Desktop PCs as RT targets—Prototype and run real-time 
applications on desktop PCs. Refer to the ETSonPCs_readme.html 
file on the LabVIEW Real-Time Module CD for informaiton about 
using desktop PCs as RT targets.

• NI PXI-818x controller support—The NI PXI-818x controller 
provides a flexible, rugged platform for deterministic, real-time 
embedded measurement and control applications.

New VIs and Changes to Existing VIs
• (ETS) Real-Time Timing VIs—The Real-Time Timing VIs manipulate 

the speed at which an operation executes allowing you to time control 
loops in VIs running on the RT target. The Real-Time Timing VIs offer 
a finer timing resolution than the LabVIEW Time functions. Refer to 
the LabVIEW Help for reference information about the Real-Time 
Timing VIs.

• (ETS) LabVIEW Timed Loop—A Timed Loop executes each iteration 
of the loop at the period you specify. The Timed Loop uses the 
Real-Time Scheduler to schedule each iteration of the loop by setting 
a periodic alarm. Use the Timed Loop to develop applications that 
require multiple timed activities, to coordinate the timing of those 
activities, and to acquire feedback about when the subdiagram within 
the Timed Loop executed. Refer to the Using the Timed Loop to Write 
Multirate Applications in LabVIEW Application Note for information 
about the Timed Loop.

• Waveform type support in Real-Time FIFO VIs—The Real-Time 
FIFO VIs now support passing double waveforms, 16-bit signed 
integer waveforms, arrays of double waveforms, and arrays of 16-bit 
signed integer waveforms.
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Performance Tools
• Waveform type support in the RT Communication Wizard—To 

accommodate the newly supported RT FIFO data types, the RT 
Communication Wizard now can handle passing double waveforms, 
16-bit signed integer waveforms, arrays of double waveforms, and 
arrays of 16-bit signed integer waveforms from the time-critical VI 
to the normal priority communication VI.

• (ETS) Real-Time System Manager—The Real-Time System Manager 
displays details about VIs running on an RT target and provides a 
dynamic display of the performance of the target. You can stop VIs and 
start idle VIs on the RT target using the Real-Time System Manager. 
Refer to the LabVIEW Help for information about the Real-Time 
System Manager.

• (ETS) LabVIEW Execution Trace Toolkit support—The LabVIEW 
Execution Trace Toolkit is a real-time event and execution tracing 
tool that allows you to capture and display the timing and event data 
of VI and thread events for LabVIEW Real-Time Module applications. 
Refer to the NI Web site at ni.com/info and enter the info code 
lvtrace for information about the LabVIEW Execution Trace 
Toolkit.

Examples
Refer to the VIs in the examples\Real-Time directory for examples of 
deterministic programming and control applications.

(ETS) Refer to the examples\Real-Time\ETS directory for examples 
specific to the LabVIEW Real-Time Module for ETS Targets.

Known Issues
The following are known issues with the LabVIEW Real-Time 
Module 7.1. Refer to readme.rtf on the LabVIEW Real-Time 
Module CD for information about the latest known issues.

All Platforms
• The Software tab for installing software on RT targets is no longer 

displayed in MAX when you select the target. To install software on 
the RT target, you must launch the LabVIEW Real-Time Install 
Software Wizard from MAX. Complete the following steps to launch 
the LabVIEW Real-Time Install Software Wizard.

1. Expand the Remote Systems category in the Configuration 
section.

http://ni.com/info
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2. Expand the RT target and select the Software category under the 
target. 

3. Click the Install Software button in the toolbar.

• MAX and the Remote System Explorer install software only on RT 
targets that run on FAT32 file systems. If you format the drive of an RT 
target to upgrade the software or to reinstall the real-time operating 
system, you must format the drive to use a FAT32 file system.

• You must enable the W2 hardware jumper to upgrade the RT Engine 
of an NI PXI-8140RT controller to version 7.1. Refer to the 
PXI-8140RT Series User Manual for information about the settings 
and options for the onboard jumpers and switches.

• TCP access to the VI Server is disabled on RT targets by default. Refer 
to the LabVIEW Help for information about configuring VI Server 
options for RT targets.

• When using the LabVIEW Real-Time Module 7.1, National 
Instruments does not recommend opening a front panel connection 
to a start-up application running on an RT target.

• Avoid using LabVIEW Express VIs in time-critical or 
processor-intensive applications running on RT targets. Refer to 
Chapter 1, Introduction to the LabVIEW Real-Time Module, of the 
LabVIEW Real-Time Module User Manual for information about 
using LabVIEW Express VIs in real-time applications.

• In LabVIEW, you can set the execution properties of a VI to clear 
indicator values and set them to default values when you run a VI on 
the host computer. If you run a VI on an RT target with an open front 
panel connection, avoid using the Clear indicators when called 
option because LabVIEW does not properly update the indicators. 
Select File»VI Properties and then select Execution from the 
Category pull-down list to set the execution properties of a VI.

• If you run a subVI on an RT target and then attempt to run the top-level 
VI of the subVI, LabVIEW returns the Error list dialog box indicating 
that the subVI is already running. If you stop the subVI and then 
attempt to run the top-level VI, LabVIEW returns the Error list dialog 
box with no errors. You must ensure that subVIs are not running before 
attempting to open a top-level VI.

• RT targets can accept a maximum of ten remote panel connections.

Note The LabVIEW Full Development System and the LabVIEW Application Builder 
include a remote panel license that allows one client to view and control a front panel 
remotely. The LabVIEW Professional Development System includes a remote panel 
license that allows five clients to view and control a front panel remotely. You must upgrade 
the remote panel license to support more clients. Refer to the Products & Services section 
of ni.com for information about purchasing additional licenses.

http://www.ni.com
http://www.ni.com
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Attempting to connect more than ten connections might return an error. 
You must ensure that you do not exceed the remote panel connection 
limit to an RT target.

• Using VI Server, a VI running on the host computer cannot invoke 
subVIs stored in directories on the RT target that are not in the 
LabVIEW search path. You can save the subVIs to a directory in the 
LabVIEW search path, such as ni-rt\startup, on the RT target.

ETS

Windows
• Some RT targets have two media storage devices designated as the 

c: drive and the d: drive. From MAX, you can access the file system 
of an RT target using the MAX FTP client by right-clicking the RT 
target in the Remote Systems category and selecting File Transfer 
from the shortcut menu. The MAX FTP client shows the file system of 
the c: drive by default. To switch to the d: drive, enter the following 
into the Current Remote Directory text box:

/d:

To switch back to the c: drive on the RT target, you must enter the 
following in the Current Remote Directory text box:

/c:

Mac OS X
• Some RT targets have two media storage devices designated as the 

c: drive and the d: drive. From the Remote System Explorer, you can 
access the file system of an RT target using the Remote System 
Explorer FTP client by clicking the Launch File Transfer Utility 
button. The Remote System Explorer FTP client shows the file system 
of the c: drive by default. To switch to the d: drive, enter the following 
into the Current Remote Directory text box:

/d:

To switch back to the c: drive on the RT target, you must enter the 
following in the Current Remote Directory text box:

/c:

• When building a start-up application that uses shared libraries (DLLs) 
with the LabVIEW Application Builder, LabVIEW opens the DLLs 
Used by Application dialog box and lists the DLLs used by the 
application. Some DLLs might report the following error:

Target OS fails to load this DLL
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Ignore the warning and click the OK button if you already transferred 
the DLL to the RT target. If you have not transferred the DLLs to the 
target, use an FTP client to transfer the DLLs to the /ni-rt/system 
directory of the RT target.

RTX
• VIs that monopolize processor resources prevent Windows processes 

from executing, and Windows returns an RTX Starvation Timeout 
error. You can reboot the host computer to recover from the error. You 
then can update the VIs running on the RT target to include sleep time 
and allow Windows processes enough processor resources to run. 
Refer to the NI Web site at ni.com/info and enter the info code 
RTX001 for information about RTX Starvation Timeout errors that 
might occur when using the LabVIEW Real-Time Module for RTX 
Targets.

• You must install NI-VISA 3.1 from the National Instruments Device 
Driver CD and NI-RIO 1.1 for R Series devices from the NI-RIO for R 
Series Devices CD if you want to use the NI PCI-7831 plug-in device 
for instrument I/O.

• The LabVIEW Real-Time Module for RTX Targets does not support 
the Real-Time System Manager, Real-Time Timing VIs, or the 
LabVIEW Timed Loop.

• The LabVIEW Real-Time Module for RTX Targets does not support 
the -reset command line argument when launching VIs or 
stand-alone applications on the host computer that connect to the 
RT target running in the real-time subsystem.

http://ni.com/info
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