Screen and Menus

Double clicking the COMPEND ICON on the Windows Program Manager opens the
COMPEND Window. This Window contains a series of boxes whose configurations are
defined in Setup Files (*.CFG) with calibrations are stored in Calibration Files (*.CAL).
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A single screen or Page contains up to 40 boxes and there are 6 Pages of display (giving a
total of 240 boxes). The current Page Number is shown in the top right hand corner. The
page Number may be increased with a right click of the mouse or by pressing Page Up on
the keyboard. The Page Number may be reduced by a left click of the mouse or by
pressing Page Down on the keyboard. Home will return to Page 1 and End will move to
Page 6.

Right clicking on the box title will switch the text to show the current I/O connection for
that box. A left click of the mouse will restore the box title.

File Menu

Clicking on the File menu enables different configurations to be loaded (Load Setup).
These will be machine mode specific for standard Phoenix Tribology products, but by
pressing New a new un-configured file can be loaded.

After editing a set-up, Save Setup over-writes the existing file and Save Setup As allows
the edited file to be saved under a different name. File can have any name allowed by
Windows and do not use file extensions as these are automatically added by the system.

Saving a set-up also saves the current calibration values to the Calibration File linked to
that set-up. Use Show Setup to view the current connections and open Files.

Use Edit Setup to enter the edit mode. This allows configuration and calibration of each
box.



Use Set Box Fonts either to adjust the size of the Title or Data Fonts (using the arrow
buttons) or to change the Font Type for the Title (the Data Font Type is not adjustable).

Use Exit to close COMPEND.

Calibration Menu

The calibrations relevant to the current Setup File are stored in a separate file (the current
connection is viewed under the File Menu: Show Setup).

These calibrations can be saved to a new file name using Save This Calibration As. This
can, for instance, be used as part of an annual calibration routine where the "old" figures
are archived and the new figures used for the next year’s operation.

Load Existing Calibration allows the current Setup File to be linked to a set of
calibrations already stored (for example a previous year's calibration, or the default
calibrations delivered with the machine).

Test Sequence Menu

Test programs are called Test Sequence Files (TSF). This menu is used to open a
previously created Test Sequence File (Open).

To create a new program starting with a blank file Create 10 Step Blank TSF and
Create 20 Step Blank TSF are used. Note that the number of steps in a Test Sequence
File is not fixed and that extra steps can be added as required.

Selecting either of these options opens the Test Control Panel Window and Test File
View Window. These have a default tiling arrangement, which can always be reached,
even after re-sizing of the Windows by the user, by selecting Arrange on the COMPEND
Window menu bar.
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Data File Menu

View Data File in Excel provides a hot-link to Excel and offers a pick-list of available
Data Files. The default directory is C:\compendx\data and the data is stored as *.tsv
format (TAB separated variables). This is recognised by Excel as a "native" file format
and does not require the Import Wizard. It is also possible to store data as *.csv format
(comma separated variables).

To change the data separator from TAB to comma select the Tools Menu. select System
File and then INI File. This will open a window containing the COMPENDX.INI file.
The COMPENDX.INI file consists of different section named between []. The
EXTENSIONS section have the following format:

[EXTENSIONS]
CFG_EXT=.CFG
TSF_EXT=.TSF
CAL_EXT=.CAL
DAT EXT=TSV
DAT SEP=9

DAT SEP is the mnemonic for data separator and 9 is the ASCII code of TAB. By
replacing DAT SEP=9 by DAT SEP=44 (44 is the ASCII code for the comma) the data
mode change from TSV to CSV.

Any change to the INI file must be saved and COMPEND must then be closed and
restarted for the changes to take effect, as the INI file is only read at start up.

The EXCEL path is also defined in the INI file. If the hyperlink to Excel is not
functioning the path should be changed. The Excel path is defined in the PATHS section:

[PATHS]

APP_PATH="C:\COMPENDX\"

CFG_DIR=CONFIGS\

TSF_DIR=TESTS\

DAT DIR=DATA\

DAT PATH=c:\COMPENDX\DATA\

CAL DIR=CALIBS\

EXCEL PATH=C:\PROGRAM FILES\MICROSOFT OFFICE\OFFICE\EXCEL.EXE
MANDAT DIR=IMMEDIATE\

Test File Header

In addition to the test data, a Data File may be linked to a Header, which contains
information specific to that test or machine configuration. The Header template may be
edited by selecting Edit Header. The left hand boxes are then made available to the user
for customising.
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If a Data File is opened before the start of a test (see Test Control Panel window), when
the test is started, the Header template is opened. This retains the right hand side
information from the previously run test. The user may fill in or edit the information on
the right hand side.

Manual Data Recording

Manual collection and recording of data is available as an alternative to Test Sequence
File programmed data acquisition. Data may be collected at user-defined rates and under
the user’s manual control in a Data File.

The data is saved in a sub directory <C:\COMPENDX\DATA\IMMEDIATE\>. If this
directory does not exist it will be created automatically. The name of this directory is
controlled by the following entry in <COMPENDX.INI> e.g.

[PATHS]
MANDAT DIR=IMMEDIATE\

If the above entry does not exist it will be created automatically with the default name
<IMMEDIATE\>.

The user may edit this entry to create a new user directory.

Open Immediate Data File

Selecting Open Immediate Data File will display a window where the user may either
enter a new name for a Data File or select an existing Data File name. If the selected file
exists, choose to overwrite the existing file or to append the data to the existing file:



Do you want to APPEND data to this file ?

Cihcompend\DAT AN mmediata\test TSV is ah existing file.
Click YES to APPEND your new test data to the end of this file.

Click NO to OVERMWRITE the file with yout newtast data

A popup menu allow the user to select the data collection method:

Manual Trigger
Every 1 second
Every 10 seconds
Every 1 minute

Every 0.1 second

The COMPEND window will then display three boxes:
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Clicking on the green START button will begin the data collection at the chosen rate. The
buttons then change to the following:

ILine5= 10 -l 1s

The user may click STOP to suspend the data collection and subsequently restart
collection by clicking START again.

The data rate can be modified without having to stop the data collection by right clicking
once on the right hand yellow data rate button. This will display the popup data rate
menu.

When Manual Trigger is selected the buttons are as follows:

ILine5=31Ei -I manual

Each time the user clicks on the cyan Line button a new data set is recorded.




When the data collection process has been completed, the user closes the file by clicking
the Data File menu and selecting Close Immediate Data File. The Immediate Data File
can then be displayed in Excel by using View Immediate Data File in Excel.

Automatically Forward File Data

The last feature of this Data File Menu is Setup Auto-Email. This feature can be used
when running unattended tests provided that a network connection with e-mail service is
available. At the end of the test a message can be sent to an e-mail address indicating that
the test has ended and giving the reasons for termination.
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Mail Recipient is the e-mail address where the message is to be sent. Select Attach Data
File(s) is used to attach the data collected during the test to the e-mail. Enable Automatic
E-Mail activates this feature.

Graph Menu

Create Graph sets up a new Graph Window. This is automatically tiled to the bottom of
the COMPEND window. This default arrangement can always be reached, even after re-
sizing of the windows, by selecting Arrange on the COMPEND window menu bar.

The created Graph has the configuration defined under Edit Graph Connections and
Setup Graph.

Edit Graph Connections is used to populate the graph by defining which parameters are
to be displayed (by connecting the required parameter to a line number), the display
scaling and whether auto-scaled on the y-axis.



o M= & ]
[&] coMPEND 2000 ver 1.0 Plint & Partners Ltd. [TE67HIGH LOAD] & Test Control ... [H[] [EY

File Calibration TestSeguence DataFile Graph Tools  Arrange DataFile Alarms  Font

[‘com 1 [Fage

Speed SP———— (| [Load SP o[ [Temperature SP - urrert Time R
0 rpm ON 0°Cc Flapsed Test Time
w w w

urrent Step
Speed Load Specimen Temp—— | ||/ SteTine
0 rpm ONM 0°C Elapsed Step Time 0%
Resicdusl Step Time
fTest Status ETORPED
Displacement Wear Wear Offset Moot Fis EATEST
0 ym 0 um 0 pm Dtz Fils
Data Points in Step
Radips———————— Friction Forcem———— | [Contact Potential———— |[=&!DstaLines
25 mm ON 00 mV START || PausE
N STOP | NEXT
Sliding Velocty | (Frietion Coeff | [CounterReset
L 0.00 mis L 1.71 COUNT — Eile ¥iew Alarms  Edit
-
— NEWTEST
Distance Motor Enable—— Heater Enable—— Step  (Mext \Loop 52l
— — MNo.  |Step  |Count T_I
Om DISABLED DISABLED —
hd I ¥ [0 2 0 11
z 3 0 11
. Real Time Graph [_[O] x] 3 g g }'
File  Edit  Histanliode 5 3 i T
100 R[O- 2] Friction Coeff G 7 il 11
B0 [0-100] Specimen Temp = g 0 T
S [0-50] Contact Potential
e R[-100 - 100] Wear 5 9 0 Il
i g 10 0 11
2 W0
0T v e e e e o T i
00:00:00 00:00:12 00:00:24 00:00:36 00:00:48 00:01:00 = = = —
Elapsed Time HH:MM: 55 4 | | '|
—_— |
A Start| ) COMPEND 2000 .. | B Microsoftword | 3, Test Control Panel | 53 TestFileView [ Real Time Gra... 1636

There are 16 possible lines on the graph. Click on the line to be connected, click on the
parameter to be connected to that line (the parameters are all those defined in the Setup
File currently in use) and then click Connect.
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Fill in the MIN and MAX boxes to define the display scaling for that graph line. Check
the Auto Re-Scale box for the y-axis to re-scale if the MIN or MAX value is exceeded.
The MIN and MAX values will be used as the starting scales for that line on the graph.



To disconnect a parameter from a line, simply click on the line number and click on
Disconnect.

Press Cancel to abort changes and Apply to accept changes.

Note that the Graph Connections may also be edited while running on the current graph
using the Edit menu.

Setup Graph is used to define the x-axis (time axis) of the graph. Two graph types are
available: a History Graph with a defined width and an Auto-Scaling Graph.
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A number of History Graph time “widths” are available. Select one by clicking on the
time parameter. The grey box under the pick-list will display the total time size of the
History Graph buffer. For instance if the width is 1 minute, the total History Graph scroll
will be 2 hours, 46 minutes and 40 seconds. If the test runs for longer than this period,
data will be lost from the History buffer.

Check the Auto-Scale X-Axis to run a graph with the whole test automatically
compressed into the field of view at all times.

Note that in addition to this graph, when the High Speed Data Acquisition Card is
installed, a similar utility is provided for displaying snapshots of high speed data. Both
graph types may be displayed simultaneously.

Tools Menu

The Tools Menu is used for initial system configuration purposes, offering editing of the
various system files in a text editor. Most of the Menu items are locked to prevent user
access.

The Show Channel Usage menu option shows a list of all the I/O channels with their
current box connections. Multiple connections are shown and clicking on the left hand
column of the list will show the screen labels and positions for all the connections to the
selected channel.



The System Files menu allows the user to open the different system files used by
COMPEND in Windows Notepad. Changes in COMPEND system files should only be
undertaken with advice from Phoenix Tribology.

The Save Screen item captures the computer screen in the clipboard of the computer so
that it can be pasted as a picture into a different application. This can be used in reports or
for sending screen data for diagnostic purposes to Phoenix Tribology.

Arrange Menu

Arrange will re-size the open windows to a single default layout, similar to a Windows
"tile" command.

Help Menu

About COMPEND provides information about the version of the software, the system
configurations and contact numbers for support.

The Help system is accessed via a searchable Help Index. This is not context specific,
but is arranged in Window/Menu/Tab sequence. The Help Index may also be searched for
key words.

Revision and Application Notes provides a history of all the software upgrades since
COMPEND Ver 1.00. In addition, two application notes are provided, one detailing the
High Speed Data Acquisition capabilities the second explaining how to create a Manual
Offset Channel.



