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This file contains notes on the Wilcom EmbroideryStudio e3.0K software update. This update is intended for 
installation with any released version (already installed) of Wilcom EmbroideryStudio e3.0. It contains all 
improvements and fixes contained in other interim updates, including e3.0H. 
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New & improved features in ES e3.0H 

The main theme of the e3.0H software update was to enhance support for third-party machine connection. 
Specifically, Happy, ZSK and Brother machines. Other aims of this release include: 

• Resolve issues associated with multi-language release. 

• Improve machine connectivity by providing the ability to add named machines and define a network 
location for design retrieval. 

• Fix other outstanding software issues unresolved at the time of last release. 

Updated Connection Manager 
EmbroideryStudio Connection Manager has been updated to provide a more flexible method of connection to 
different machines that appear as removable media or use a third-party application to connect to the machine 
and require files to be placed in a specific network location. Each machine, once set up, will only require a 
single click in order to send a design to the predefined folder on a network or PC. 

Basic workflow 
The basic workflow is as follows: 

1. Set up a machine connection. 

• Each machine has a unique name and ‘Quick Access’ button. 

• Each machine can have a unique folder to which designs can be sent so they can be accessed from 

the machine control panel or third-party machine connection software. 

2. Create a design. 

3. Click the Quick Access button for the specific machine. 

4. The design is sent to the specified folder. 

5. Using the machine controller or third-party connection software, access the design from the network or PC 

folder. 

6. Load or send the design. 

7. Stitch the design on the machine. 

Sending a design for the first time 
1. Click the Connection Manager icon on the Standard toolbar. 

 

Alternatively, select Setup > Connection Manager Setup. 

If no connections currently exist, the message appears: 

 

2. Click Yes to start setting up your connections. 
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The Connection Settings dialog opens. 

 

3. Select the connection type. Choose from: 

• Machine folder – e.g. Barudan DFS, HappyLink/LAN, Brother PR series and so on 

• Janome MB-4 

• CAMS (rhinestone placement machine) 

4. Enter a unique machine name. This name identifies the Quick Access button. 

5. Select the file type required by the machine. 

6. Enter or browse to a file location on the network or the PC 

 

7. Click OK when complete. 

The new machine will appear as a Quick Access button on the Standard toolbar 

 

8. Click Send to send the currently open design to the specified machine folder. 
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A confirmation message is displayed. 

 

Setting up additional connections 
1. Click the Connection Manager icon on the Standard toolbar. 

 

Alternatively, select Setup > Connection Manager Setup. 

If a connection already exists, the Send to Connection Manager dialog opens. 

 

2. Select Setup Connections. 

The Connection Manager Setup dialog opens. 

 

3. Click Create. 

The Connection Settings dialog opens. 
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4. Repeat steps outlined above to set up another machine connection. 

As more machines are created, more quick access buttons are added with unique colors for each. 

 

A single click on a machine quick access button will send the current design to the predefined location for 

the selected machine. 

Other improvements 
The e3.0H also includes the following fixes and improvements. 

Multi-language issues 

Problem Resolution 

Multi-language GUI 
problems 

A number of problems were reported with regards to truncations and faulty 
message strings in languages other than English. These have been resolved. 

‘My Product’ for multi-
languages 

Previously, clicking an element on left hand pane of the ‘My Product’ dialog, when 
switched to languages other than English, did not load the corresponding page. 
This issue has been resolved. 

‘Capture Design 
Bitmap’ in French 

If running ES in French language, the ‘Capture Design Bitmap’ dialog crashed the 
system. This issue has been resolved. 

German translation of 
Application Fabric 
dialog 

The Application Fabric dialog title has now been correctly translated as 
‘Applikations-Stoff’. 

‘New from Template’ 
fabric selection 

Some fabrics could not be selected in the ‘New from Template’ dialog when 
switched to languages other than English. This issue has been resolved. 

Fabric selection in 
non-English languages 

Fabrics displayed to the user in non-English language did not match the translated 
fabric selected. This issue has been resolved. 

Lettering issues 

Problem Resolution 
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Complex Fill TTF 
conversions 

When converting letters with holes, such as the registered trademark character ®, 
strokes inside the outer ring were not always properly generated. This issue has 
been resolved. 

Unwanted Wingdings 
in text field 

Characters entered into the text field sometimes appeared as Wingding symbols, 
even when a Wilcom alphabet was selected. This happened after digitizing lettering 
with Webding and Wingding alphabets. This issue has been resolved. 

Layout names Teamname layout names did not always appear in the Teamname Layouts dialog. 
Sometimes the name fields appeared blank. This issue has been resolved. 

Team Names options 
when sending via 
Connection Manager 

Problems were reported when selecting Team Names options when sending 
designs via Connection Manager. This issue has been resolved. 

Auto-digitizing issues 

Problem Resolution 

Converting embroidery 
to graphics 

Previously, ‘Convert Embroidery to Graphics’ did not always convert selected 
embroidery to vectors. When it did convert, a ‘ghost image’ of the embroidery could 
still be seen after conversion to graphics. These issues have been resolved. 

Appliqué covering 
stitches when 
converting vectors 

When creating an appliqué object from a combined vector object, covering stitches 
for the hole were positioned on the wrong side for appliqué and had to be manually 
fixed by swapping ‘Inside’ and ‘Outside’ values. This issue has been resolved. 

 

Thread-related issues 

Problem Resolution 

Assigning threads to 
colorways 

The Color Palette Editor dialog was slow to respond during thread assignments 
involving a large number of colorways – e.g. > 50. This issue has been resolved. 

Only used colors 
displayed in colorways 

Colorways available from the Color Palette popup menu showed all colors in the 
palette, whether used or not. Now only colors used in the design (underlined in 
blue) are displayed. If no color is currently being used, no colors appear in the 
combo – only the name and background. 

Improved colorway 
popup display 

The number of colors visible in the colorways popup menu has been increased as 
follows: 
• Maximum number of (used) colors shown has been increased from 8 to 16. 
• The number of colorways shown at any one time has increased from 4 to 6. The 

list can be scrolled to reveal more colorways if available. 

System-related issues 

Problem Resolution 

Access denied when 
starting software 

Previously, the very first time ES was started, an ‘Error - Access Denied’ message 
was displayed. This issue has been resolved. 

Software crashes with 
Flatten tool 

Software crashes were reported when using the Flatten shaping tool with 
embroidery objects. This issue has been resolved. 
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Miscellaneous 

Problem Resolution 

Rotating objects with 
slanted satin 

When a Satin or Raised Satin outline object with Calligraphy applied is rotated and 
entry and exit points are changed, the stitch angle of the object does not reflect the 
original orientation of the object. This issue has been resolved. 

Compound Chenille 
needle height 

The Needle Height controls in the Compound Chenille Effect dialog were not 
working properly. This issue has been resolved. 

Background preview in 
‘New from Template’ 

When selecting a fabric in the New from Template dialog, the background preview 
panel continues to display some background color behind the fabric. This issue has 
been resolved. 

Object scaling width 
and height values 

When resizing an object via selection handles, the Width and Height values 
appearing in the resize tooltip were out of sync with those of the Property Bar. This 
issue has been resolved. 

Happy machine hoop 
display 

Happy machine hoops appear in the software to be smaller than actual size. This 
issue has been resolved. 
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New & improved features in ES e3.0K 

The main purpose of the e3.0K software update is to provide runtime estimates for stitching designs on 
specified machines. 

Runtime analyst feature 
The Runtime Analyst calculates the estimated running time for a specific embroidery file on an embroidery 
machine using specified RPM values and other runtime parameters. These are used on a design-by-design 
basis to determine scheduling, running costs, and calculate payments for production staff. Output can be used 
by any third-party software such as ERP and accounting systems. 

Typical usage 
Information can be made available to various stakeholders for payroll, estimations, and scheduling. For 
instance: 

• The designer creates a new design and saves as EMB and/or stitch file such as U11. 

• EmbroideryStudio automatically calculates running time. 

• The designer saves or the system automatically saves calculated results to a CSV file in a designated file 
location. 

• The Payroll Department accesses the CSV file and calculates pay rates for the design. For example: 

o A Payroll Clerk may need to find out what the runtime will be for a given job in order to pay the 
machine operator. 

o A Manager may need to provide an accurate runtime estimate for any given design so the payroll 
department is able to process machine operator payments. 

• The ERP system accesses the CSV file for estimation and scheduling purposes. 

• Runtime information may need to be communicated to the Machine Operator who needs to know the 
runtime estimate for specific jobs. 

Machine setup 
Users can set up multiple named machines with specific parameters such as ‘fast speed’, ‘slow speed’, ‘trim 
time’, ‘color change time’, etc. Access the Machine Runtime Setup dialog via the Setup menu … 
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This dialog is similar to Connection Manager Setup. It lists all machines currently defined in the software for 
the purposes of runtime analysis. 

Note: Machine types set up here are independent of machines defined in Connection Manager Setup or 
Embroidery Machine Connection dialogs. 

Machine runtime settings 
Click Create to access the Machine Runtime Settings dialog … 

 

Parameters set here are based on metrics gathered both from machine specs, controller and/or empirical 
observation. 

Parameter Description 
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Name May pertain to a particular machine or a class of machines. The class may be based 
on machine model. However different machines of the same model may be set up for 
different purposes – e.g. to run at different speeds. If so, you’ll need to set up 
different classes to suit. 

Normal (high) speed Defines the speed at which the machine normally sews. Normally available from 
machine specs. 

Slow speed Defines the slowest speed at which the machine runs. Normally available from 
machine specs. 

Slow above Defines the length of stitch above which the machine slows down. This value is 
automatically adjusted according to speed settings, in particular slow speed. It should 
be available from the machine specs. 

Trim time The time the machine takes to perform a trim. May be available from machine specs 
or empirical observation. 

Color change time Same as for Trim time. 
Stop time Defines time spend stopping in order to place fabric, foam, etc. This is normally 

determined through empirical observation. The number of heads on the machine will 
be a determining factor – e.g. 16 heads x 6 secs each. 

Design start time Defines how long the machine takes to go from stop to normal speed – e.g. it may 
stitch a number of slow stitches to start off. May be available from machine specs or 
empirical observation. 

Design end time Defines stopping time – the machine may slow down and then travel to the centre of 
the hoop before actually stopping. 

 

All machines or machine classes you define are listed in the Machine Runtime Setup dialog. From here they 
can be updated or deleted from the system. 

 

Design information 
Once your machines or machine classes have been defined, estimated running time for a specific embroidery 
file is displayed in the Design Properties dialog under a new Runtime tab. 
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This tab lists available machines and estimated runtimes for the current design. A new Area field on the 
Information tab shows total design area. It is calculated by multiplying design width and height, not actual 
stitched area. This figure is used to estimate the cost of fabric or 3D foam that can be used in the design. 

 

Outputting design information 
Design information, including runtime estimate and relevant parameters, can be output to CSV file for later use 
by third-party applications. New data is appended to any existing CSV file.  

Predefining export options 
Design information can be written whenever the design is: 
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• recorded into DW database 

• saved 

A new Options > Export tab allows you to preset these options. 

 

Manually exporting design properties 
The new File > Export Design Properties command allows you to manually save current design propeties. 

 

Wilcom EmbroideryStudio e3.0K Software Update 25/11/2013 12 



CSV output 
The CSV output file includes the following fields. The first group derive from the Design Properties > 
Information tab. The next group derives from parameters entered in the Machine Runtime Settings dialog. 

Field Description 

Design properties Data derived from design properties 

Date Date and time of exporting properties. 
File name Name design saved under. 
Machine format Machine format of design. 
Stitches Total number of stitches in design. 
Colors Total number of thread colors in design. 
Color changes Total color changes – may or may not coincide with number of colors. 
Stops Number of machine stops in design. 
Trims Number of trims in design. 
Sequins Number of sequins in design. 
Blings Number of individual rhinestones in design. 
Thread length (m) Total length of thread used in design. 
Height (mm) Height of sewing area – derived from design extents. 
Width (mm) Width of sewing area – derived from design extents. 
Area (mm²) Area covered by design – calculated according to design extents. 

Runtime data Data derived from machine runtime settings 

Below 
Above 

Number of stitches stitched at slow and hight speed according to ‘slow 
above’ parameter. Combined numbers should equate to ‘Stitches’ value. 

Machine Machine as shown on Machine Runtime Setup dialog. If there are multiple 
machines defined, a separate line entry appears for each. 

Normal (high) speed (RPM) Runtime setting as shown on Machine Runtime Settings dialog. 
Slow speed (RPM) Ditto 
Slow above (mm) Ditto 
Trim time (sec) Ditto 
Color change time (sec) Ditto 
Stop time (sec) Ditto 
Design start time (sec) Ditto 
Design end time (sec) Ditto 
Runtime (min:sec) Calculated runtime of this design according to particular machine as 

shown on Design Properties > Runtime tab. If there are multiple machines 
defined, a separate line entry appears for each. 

Printing of runtime estimates & design area 
The Production Worksheet prints the new runtime information. Three new fields to control the new information 
appear under the Blocks tab: ‘Area’, ‘Total thread’ and ‘Machine runtime’.  
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The Machine runtime checkbox is only availble if the feature is available in the software. If there are no 
machines set up, checking ‘Machine runtime’ has no effect as there is nothing to print. 

Total thread prints the information of the same name in the Design Properties dialog. This information is 
included in both Production Worksheet and Production Summary. 
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Interface & usability improvements 
ES e3.0K includes the following interface & usability improvements. 

Ruler display 
Inch rulers are now displayed in 1/16, 1/8, ¼, ½, and 1" divisions not 1/10s. The grid size can be set in decimal 
inches now. This is usable as is. 

 

Transformation & measure tooltips 
Unit of measure displayed in the Resize tooltip can now be chosen by the user. Similarly distance moved – e.g. 
moving letters – is now displayed in appropriate units. Similarly, ‘Length’ and ‘Angle’ labels have been added to 
the Measure tooltip, together with the appropriate length unit. 
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Travel tool keyboard shortcuts 

 

All Travel tools now have keyboard shortcuts. New shortcuts include: 

• Travel by 1000 stitches: Shift + Num- / Shift + Num+ 

• Travel by Function: Ctrl + Page Up / Ctrl + Page Down 

• Travel by Trim: Ctrl + Left Arrow / Ctrl + Right Arrow 

Ctrl+M shortcut for Auto Trace 
The Ctrl+M shorcut is not correctly activating Auto Trace. This issue has been resolved. 

Appearance tab in Carving Stamp docker 
The software crashes on closing all open windows when the Appearance tab is selected in Carving Stamp 
docker. This issue has been resolved. 

 

Other Objects option in Save to Template dialog 
The Other Objects option is missing in the Save to Template dialog in languages other than English. This 
issue has been resolved. 

 

Machine Manager in Japanese 
Machine Manager is not working in e3 Japanese. This issue has been resolved. 
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Schiffli toolbar Borer Depth display 
The Schiffli toolbar does not show correct Borer Depth when traveling through stitches in ES e3. This issue 
has been resolved. 

 

Garbage characters in Japanese menus 
Garbage characters are appearing in menus in e3 Japanese when using WinXP. This issue has been 
resolved. 

Photo Flash and Auto Digitize Bitmaps 
If the Auto Digitize Bitmaps Element is disabled, the Auto-Digitizing Tools flyout is not available on the 
Toolbox toolbar. This means the Photo Flash icon is not available even when the Element is enabled. The 
Photo Flash tool is now correctly displayed when enabled. 

 

Thread & fabric improvements 
ES e3.0K includes the following thread and fabric improvements. 

Access to Manage Thread Charts dialog 
The Manage Thread Charts dialog is now directly accessed via the Setup menu along with other asset 
management functions. Previously it could only be accessed indirectly via the Thread Charts dialog. 
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Madeira color palettes 
Madeira color palettes have been updated and now include all the latest threads. The new PolyNeon palette is 
also included. 

 

Pull compensation fabric settings 
There is a rounding issue with pull compensation settings: values that should be .40 appear as .39. Also the 
pull compensation unit is missing in all tabs, except Stablizer, in the Auto Fabric Settings dialog. These 
issues have now been resolved. 
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New from Template dialog 
Currently, the last chosen template is not remembered in the New from Template dialog. It always appears 
with the Normal template selected. This issue has been resolved. 

 

Lettering improvements 
ES e3.0K includes the following lettering improvements. 

Offset outlines with Kanji lettering 
DS now provides the ability to apply offset outlines to Kanji characters as part of a lettering object. 
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Preview of fonts in lettering properties 
Previewing fonts in lettering properties can cause ES to unexpectedly shut down. This generally happens if 
there are a very large number of TrueType fonts installed in Windows. This issue has been resolved. 

 

Available stitch types for lettering and branched objects 
There are inconsistencies between stitch types available for lettering and branched objects on the toolbars and 
those displayed in the Object Properties dialog. This issue has been resolved. 
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Stitching & color improvements 
ES e3.0K includes the following stitching and color improvements. 

Sequin fixing stitch previews 
Sequin fixing stitch preview were incorrect for A01-4, A02-8, A03-4, and A04-6. These have now been fixed. 
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Slant angle of zigzag underlay 
The slant angle of zigzag underlay defaults to 30º when opening an V2006 or earlier EMB files in e3. This can 
cause the underlay to extend outside the boundary. With e1.5 and e2.0, the slant angle correctly defaults to 
90º. This issue has now been resolved for V2006 and earlier. 

Color assignment with Fill Holes 
After applying Fill Holes to an object with holes, changing color of the source object incorrectly changes the 
color of the fill object. Also vice versa. This issue has been resolved. 
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File handling improvements 
ES e3.0K includes the following file handling improvements. 

Using ZSK TC format in Export Multi-Decoration Files 
Clicking Options when using ZSK TC format in the Export Multi-Decoration Files dialog crashes the 
software. This issue has been resolved. 

 

Design Explorer and DesignWorkflow file display 
Currently, DE and DW do not display Barudan U?? files at all. This issue has been resolved. 

Saving single sequins 
When saving a single sequin created by Sequin Run Manual or Sequin Run Auto to any file format results in 
the sequin being lost upon reopening the design. This issue has been resolved. 
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Missing formats in ES 
TrueSizer can open and save some formats that are not available in ES. This has now been corrected so that 
all products open and save the same formats. Also, three additional formats have been added to both 
TrueSizer and ES: 

• Elna (*.EMD) 

• Janome/Elna/Kenmore (*.JEF+) 

• Pfaff (*.PCM) 

Solving problems 

If you encounter a problem with the EmbroideryStudio e3.0K software update, refer to the following sources for 
help: 
 
• Wilcom EmbroideryStudio e3.0 User Manual – select Help > User Manual. 
• Wilcom EmbroideryStudio e3.0 Onscreen Help – select Help > OnScreen Help 
• Windows help – select Start > Help and Support 
• Windows manual – documentation supplied with your hardware. 

If you are unable to solve a problem, you should contact your Wilcom dealer. Before seeking help, check that 
your PC meets the system requirements, and check the Troubleshooting chapter of the Onscreen Manual. 

Copyright 

Copyright © 1990-2013 Wilcom Pty Ltd. All rights reserved. 

No parts of this publication or the accompanying software may be copied or distributed, transmitted, 
transcribed, stored in a retrieval system or translated into any human or computer language, in any form or by 
any means, electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the 
express written permission of: 

Wilcom Pty Ltd. (A.B.N. 43 001 971 919) 
146-156 Wyndham Street, Alexandria (Sydney) 
New South Wales, 2015, Australia 
PO Box 581, Alexandria, 1435 
Phone: +61 2 9578 5100 
Fax: +61 2 9578 5108 
Email: wilcom@wilcom.com 
Web: http://www.wilcom.com 

TrueView™ and Point & Stitch™ are trademarks of Wilcom Pty Ltd. Portions of the imaging technology of this 
Product are copyrighted by AccuSoft Corporation. The EPS File Import/Export Converter used in this Product 
is copyrighted by Access Softek, Inc. All rights reserved. 

Contact 

If you have any questions, please contact your local Wilcom dealer or distributor in your country. 
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